您好!

您是否了解以用户身份登录后可以查看更多内容?

Support articles

如何修改默认零件前缀?

Q:如何修改默认零件前缀?我想修改混凝土默认前缀A:你可以在user.ini文件中用下面两个高级选项设置前缀和开始编号:XS_CONCRETE_PART_NUMBERING_PREFIX=XS_CONCRETE_PART_NUMBERING_START_NUMBER=
by Tekla China
0
  • part prefix

编号容许误差

问:编号容许误差是如何工作的?答:编号容许误差是对比零件的最长顶点距离,而不是实际的零件长度。拥有最小ID号的零件(通常是最先建模的部分)被作为比较的基础。其他同样材料的零件都和这些零件做比较。在编号设置中,容许误差是根据材料来分类的,这和材料对话框是一样的:钢、混凝土、钢筋。其他材料(木材、组合材料)用其他的容许误差设定。对于螺栓来说,容许误差比对是使用钢的容许误差设置的,它是比较零件边缘和螺栓的距离的,而不是螺栓的间距。请看下图:
by Tekla China
4
  • numbering tolerance

图纸列表编号显示如 2 of 10

问题: 如何利用图纸页码将图纸表达如 2 of 10这样的格式?答案: 在模板编辑器中,你可以使用如下公式获取到页码列表:mid(GetValue("CURRENT_DRAWING.NAME_BASE"),(1+(find(GetValue("CURRENT_DRAWING.NAME_BASE"),"-"))),2)然而,最后的页码数不会自动出现,你可以将它放置到UDA用户定义属性里,或者其他的一些不用的属性框里,例如标题3区域,但是这需要在增加图纸数量的时候手动修改。mid(GetValue("CURRENT_DRAWING.NAME_BASE"),(1+(find(GetValue("CURRENT_DRAWING.NAME_BASE"),"-"))),2)+GetValue("TITLE3")
by quangang yu
0

检查可用的TCP/IP端口

问题:在配置授权服务器时,需要为授权服务器添加TCP/IP端口,如何检测哪些端口是可用的呢?答案:授权服务器默认使用TCP/IP协议的27007端口。 根据我们的经验,其它常用工程软件一般不会占用27007端口,Tekla用户中也没有发现其它使用其它软件占用27007端口的情况,因此默认的27007端口对客户来说是一般是不会被占用的。 如要要查看计算机上已使用的端口情况,可以使用dos命令netstat来查看:
by quangang yu
0

Tekla Structures软件安装后无法启动

问题:Tekla Structures软件安装完成后,无法正常启动,并且收到如下提示:“应用程序初始化失败(0xc0000XXXX)。”答案:经过测试和分析,我们发现如下三种软件在64位计算机上可能导致这类问题:Adobe 3D Capture  (X64),这是Adobe Acrobat 9 Pro的一部分(acaptuser64.dll);Mozzilla 3虚拟键盘,Kaspersky Internet Security 2009-2011(卡巴斯基互联网安全软件2009-2011)的一部分EMBASSY Trust Suite(ETS)Wave(wxvault.dll)以上三个应用程序会在其它应用程序启动时注入,Microsoft 微软公司不建议使用这类注入方式对软件进行外挂加载http://support.microsoft.com/kb/197571  这种机制会导致Tekla Structures在启动时导致错误。如果您要检测是哪种软件导致您的Tekla Structures软件启动错误,您可以下载Autoruns软件进行检测: http://technet.microsoft.com/fi-fi/sysinternals/bb963902启动Autoruns,进入AppInit标签页,将页面截图并发送到您当地的Tekla Structures技术支持:a. 
by quangang yu
0

NC文件中原始零件和镜像零件的不同

问题:我有一个板块边缘准备焊接。当我镜子,镜像图像不相同的NC文件,即使它是完全一样的部分。为什么会出现这种情况,和数控得到完整的信息,我能做些什么?我有一块板做焊接准备,当我对它做镜像时,镜像过后的物体得到的是不同的NC文件,即使他们是完全相同的物体。为什么会出现这种情况,如何处理?答案:在Tekla Structures,当您复制/镜像的一部分,几何形状是镜像的,但物体的位置朝向不会改变。例如,如果在原有的部分,前半部分是指向西(见下面的图片 - “V”向)时,镜像后,朝向将保持不变,它保持着同样的的方向,即使形状部分已镜像。由于AK块信息的NC文件是基于前/后/顶部/底部的朝向镜像的部分,有一定的朝向(例如,“V”朝向),是指不同的几何形状,如下图所示。在下面的例子中,“V”朝向对镜像的一部分,包含焊接准备的信息,而这不是在原有的部分。该解决方案将是为了NC文件显示的正面和背面,因此,不会丢失信息。有一个高级选项,使您能够做到这一点:XS_DSTV_WRITE_BEHIND_FACE_FOR_PLATE。选项​​设置为TRUE。
by quangang yu
0

当使用展开时,如何保持一样标记?

问题:使用表面展开 (21)组件区域展开一个在矩形到圆(17)中创建的板来给不同构件标记(编号)。如何才能保持展开板的标记相同?答案:用户能通过不选择矩形到圆(17)组件对话框中的型材选框来保持构件编号。
by quangang yu
0

输出型材信息到IFC文件

问题:如何从Tekla Structures输出一些型材信息到IFC文件?答案:用户可以在位于C:\TeklaStructures\<version>\environments\common\inp 下的IFC_properties_sets.inp文件进行修改。用户能增加想要的型材属性,例如,通过增加线Tekla_General Section_modulus_x PROFILE.SECTION_MODULUS_X FLOAT以下是最简单的方法来得到确切的属性名称1.   在模板编辑器中创建一个新的文本模板。2.   插入一个新的零件行。3.   插入一个新的值域。4.   点击属性,向下滚动然后寻找型材,然后展开视图去查看所有型材类型属性。5.   选择属性然后点击确认去显示公式域中的确切名字。Tekla Structures 能应用的版本: 17.0 SR3, 17.0.3 和 更早期的版本。在之后的Tekla Structures 版本中,相同的信息是在IfcPropertySetConfigurations.xml 文件中处理。
by quangang yu
0

三角函数

问题:我尝试在Rebar Shape Manager中使用三角函数,但是我在报告中什么也看不到。答案:当尝试要映射角度和三角函数时,用户需要使用小写字母写函数(sin, cos, tan),如括号内所示。如果使用大写字母,将不被认可。而且在报告中将出现一片空白。另一个要注意的是当使用rebar_schedule_config.inp时,不再需要将角度转换为弧度。例如,用户现在能只需写sin(A1)来代替sin(A1*PI/180)。
by quangang yu
0

过滤没有零件编号或构件编号的零件

问:我能使用选择过滤去过滤没有零件编号或构件编号的零件吗?答:过滤选择模板种类和SERIAL_NUMBER属性,值为0,就能过滤出。所有未编号零件的值为0。
by quangang yu
0

多用户问题

问:多用户模型中,零件在被删除后又出现。如何修复?如何避免此类问题再次发生?答:模型转储是一个解决方法。记住要在单用户中进行模型转储和导入。为了避免这个问题,所有的多用户需要经常和主模型同步(保存-编号-保存)。– 可以避免在保存后“零件的移动”– 可以避免在保存后“控柄的移动”– 避免碰撞从16.0后你可以规律的运行修复编号。
by Tekla China
0
  • multi-user mode

让用户定义属性影响混凝土编号

问:我试图去修改objects.inp中的混凝土钢筋项,这样用户定义属性就可以影响编号。在objects.inp中,我在需要的区域将 'no'改为 'yes'来影响编号,但是貌似不能工作。答:影响USER_FIELD_4的如下图所示:你还需要在part行钟修改同样的属性,而不只在rebar行:如果你不在part行修改是没用的。
by Tekla China
0
  • UDA

在对象浏览器中显示用户定义属性

问:在对象浏览器中显示用户定义属性?答:打开模板编辑器.创建文本模板 创建一个行,类型自定-如你需要得到零件的UDA,你可以定义为零件行 创建数值域. 点选“属性” 选择你需要的属性. 复制这个属性的名称 在对象浏览器中,打开设置对话框,创建一个自定义属性。名字就用步骤一中复制的名称. 现在你可以在对象浏览器中看到新的属性列了
by Tekla China
0
  • Object Browser
  • UDA

网页模型打开问题

有时候当你想打开一个Tekla网页模型,而且你是这台电脑的管理员,仍然会出现下图的问题。这个问题通常出现在你点击了“允许阻止信息”后。我们可以手动注册需要的文件来解决这个问题。第一,建个新文件夹在C盘上。这个文件夹建好后就不能动了,因为windows会记住这个文件夹的位置。在这个新文件夹里,将下列文件复制到其中:复制msvcr71.dll从…Tekla Structures\<version>\nt\bin 文件夹中 复制regsvr32.exe从C:\Windows\system32 文件夹中 复制zkitlib.dll文件从网页模型文件夹“dll” 文件夹中 现在打开命令提示符,在运行中输入“cmd”输入 cd \文件夹名称 ,到你新建的那个文件夹的盘符下 输入regsvr32 zkitlib.dll并回车 如果你成功注册,你会得到一个下图的信息重新打开Tekla网页模型即可。注意:如果你想禁止load the Active-X component这个提示,到控制面板的Internet选项或在IE浏览器, 在高级标签下检查“Allow active content to run in files on My Computer”这一项.请注意这个选项有可能由你的系统管理员管理,可能被禁止修改。
by Tekla China
0
  • webviewer
  • permission
  • active-x

Tekla-Revit BIM工作流程示例

Tekla-Revit BIM工作流程示例 下面是一个在Tekla和Revit(Architectural/Structural/MEP)之间BIM工作流程案例.   例子 1. 使用Export to Tekla 工具将Revit里的结构输出,并插入到Tekla中去。.您同样可以可以从Revit中输出IFC格式,然后以参考模型的形式(文件>输入参考模型)插入到Tekla中。注意:使用Export to Tekla 工具能更快,更精确。是Tekla与Revit集成的理想选择。     2. 关闭除结构图层外的所有IFC模型图层。3. 使用 IFC Object Converter 工具(工具>转换IFC对象)来将Revit 的IFC模型转换程Tekla实体对象。使用IFC对象转换设置对话框来控制IFC转化对象方法。3.1 通过使用截面名称(Profile name)或尺寸(Dimension)来设置截面衍射,同时还能定义必要的误差值。3.2 使用校核(check)键来校核:是否有截面或材质没有自动转换的。这些丢失的截面或材质能通过手动来衍射。3.3 当转换IFC模型对象时,还可以复制其它IFC对象信息并放置在Tekla UDAs(用户定义属性)中,用于追踪和过滤。如果想要复制其它信息,按下面操作:点击增加(Add)键来在复制属性到用户定义属性(Copy
by Tekla China
0
  • Tekla interoperability with Autodesk Revit products
  • Revit
  • BIM workflow

模型管理器的属性设置文件位置

问:模型管理器的属性设置值储存在哪里?答:设置属性和模型管理器类别关联。如果用户自定义了一个类别,一个新的文件会生成在储存位置。在Tekla Structures version 17.0以后版本,当打开模型管理器,默认属性设置会自动创建。  在18.1以前版本保存在模型文件夹里. 在19.0放在 ..\TeklaStructuresModels\model folder\ModelOrganizer文件夹. 在Tekla Structures 19.0中,打你打开一个早期版本创建模型,打开模型管理器,属性设置自动会移动到..\TeklaStructuresModels\model folder\ModelOrganizer文件夹.即使你不保存,这些文件也会保留在新位置. 如果你想在以前版本中用回自定义的属性设置,你需要将设置从 ..\TeklaStructuresModels\model\ModelOrganizer文件夹移动到模型文件夹中。如果你不打开模型管理器,那就属性设置就不会移动到新位置。你可以继续在原来的版本中使用。
by Tekla China
4
  • Model Organizer

分析模型的空白警告/错误报告

问: 我创建了一个分析模型,出现了一个警告/错误信息对话框,但当我打开这个信息报告,里面没有任何信息。我在 TeklaStructuresModels文件夹中也找不到错误报告。答:在teklastructures.ini检查并修正XS_RUNPATH属性. 
by Tekla China
0
  • analysis model

得到零件的表面处理

问:我如何得到零件的表面处理?答:建个Part行,用这个公式:if NextValue("CONTENTTYPE") == "SURFACING" thenOutput()elseStepOver()endif然后再下面添加个子行,类型是SURFACING。
by Tekla China
0
  • surface treatment
  • report

模板空白行

问:有时我在做模板的时候,当应用到图纸后发现行与行之间还有些空白行,见下图,如何处理?答:这是由于在模板中您所使用的行高大于行中内容的高度,这样会导致模板在图纸中应用时出现行与行之间的空白。解决方法其实很简单,在模板中,点击出现空白的行外边蓝框,右键点击,选择对齐模板右侧和对齐组件高度即可。如果整个模板在输出是周围都有空白,可以在文件>模板>页中,设置页边距离都为0。
by quangang yu
0

图纸页码

问:如何利用图纸页码将图纸表达如 2 of 10这样的格式?答:在模板编辑器中,你可以使用如下公式获取到页码列表:mid(GetValue("CURRENT_DRAWING.NAME_BASE"),(1+(find(GetValue("CURRENT_DRAWING.NAME_BASE"),"-"))),2)然而,最后的页码数不会自动出现,你可以将它放置到UDA用户定义属性里,或者其他的一些不用的属性框里,例如标题3区域,但是这需要在增加图纸数量的时候手动修改。mid(GetValue("CURRENT_DRAWING.NAME_BASE"),(1+(find(GetValue("CURRENT_DRAWING.NAME_BASE"),"-"))),2)+GetValue("TITLE3")
by quangang yu
0

页面