您好!

您是否了解以用户身份登录后可以查看更多内容?

创建模型视图

已添加 April 3, 2019 by Tekla User Assistance tekla.documentation@trimble.com

软件版本: 
2019

创建模型视图

创建模型视图

您可以在 Tekla Structures 中以多种方式创建模型视图。

例如,您可以创建以下视图

每个视图都有定义其外观的属性。您可以在创建视图后更改其外观。要 查看和修改每个视图的属性 ,请双击模型背景中的任意位置以打开 视图属性 对话框。

如果创建沿着轴线的视图,则可以使用 沿着轴线生成视图 对话框 查看和修改相应属性

创建模型基本视图

可以沿两个坐标轴创建基本视图。使用此视图作为模型的整体视图。

  1. 视图 选项卡上,单击 新视图 > 基本视图
  2. 平面 列表中选择一个视图平面。

    视图平面通过两条轴定义。

  3. 坐标 框中,输入视图级别。

    此值定义与视图平面垂直的视图平面到全局原点的距离。

  4. 单击 创建

使用两点创建视图

您可以使用选取的两个点创建视图:原点和 x 轴方向上的点。

  1. 视图 选项卡上,单击 新视图 > 使用两点
  2. 选取一点以表示视图平面的原点。
  3. 选取第二个点以指示 x 轴的方向。

    y 轴垂直于所选第一个点所在的视图平面。

使用三点创建视图

您可以使用选取的三个点创建视图:原点、x 轴方向上的点和 y 轴方向上的第三个点。

  1. 视图 选项卡上,单击 新视图 > 使用三点
  2. 选取一点以表示视图平面的原点。
  3. 选取第二个点以指示 x 轴的方向。
  4. 选取第三个点以表示 y 轴的方向。

创建工作平面视图

可以使用当前视图属性创建工作平面视图。

视图 选项卡上,单击 新视图 > 在工作平面上

生成网格视图

您可以沿所选轴线创建视图。

开始之前,请创建一个包含轴线的视图并检查轴线属性。请注意,对于半径轴线,您只能在直轴线上(而不能在弯曲轴线上)创建轴线视图。

如果轴线属性在某种程度上不正确, Tekla Structures 可能会以错误的标高切割视图或错误地命名视图。若在以后更改轴线标签、标高或轴线,视图将不会自动重命名。

  1. 选择网格。
  2. 视图 选项卡上,单击 新视图 > 沿轴线
  3. 根据需要修改轴线视图属性。
    1. 视图数量 列表中,选择要创建多少视图。
    2. 视图名称前缀 框中,输入前缀。
    3. 视图属性 列表中,定义要使用的视图属性(已应用或已保存)。
  4. 单击 创建

    将会打开 视图 对话框。

  5. 单击箭头按钮可以将视图从 命名的视图 列表移动到 可见视图 列表。

    只有在您将视图移动到 可见视图 列表之后,它们才可见。

示例

本示例说明如何创建下面模型中轴线 1–7 的垂直视图:

沿着轴线生成视图 对话框中,对视图平面 XZ 选择 全部 并对视图平面 XY 和 ZY 选择 。对视图名称前缀和视图属性使用默认设置。

创建轴线视图后,将名为 轴线 2 的视图移动移到 可见视图 列表中:

此网格视图在新窗口中显示为平面视图:

旋转视图以 3D 方式查看:

创建平面视图

您可以在现有零件的工作平面或几乎任何平面上创建视图。

  1. 视图 选项卡上,单击 新视图 > 在平面上

    在您将鼠标指针悬停在模型对象上时, Tekla Structures 将以淡蓝色突出显示可用平面。

  2. 选择所需平面。
Tip:

或者,要创建零件的前视图、顶视图、后视图或底视图,您还可以使用 视图 选项卡中提供的下列命令:

  • 在零件前平面上

  • 在零件上平面上

  • 在零件后平面上

  • 在零件底平面上

要使用这些命令,请首先选择命令,然后再选择零件。

创建零件的 3D 视图

当需要仔细查看特定零件时,可创建零件的 3D 视图。这会将零件置于视图中心。

  1. 视图 选项卡上,单击 新视图 > 零件的 3D 视图
  2. 选择零件。

    Tekla Structures 使用在 part_basic_view 属性文件中定义的属性来创建视图。此视图平面的 y 轴是模型的全局 z 轴。x 轴是零件的局部 x 轴在全局 xy 平面上的投影。

    Tekla Structures 适合工作区以包括所选零件。

    如果您希望 Tekla Structures 每当您创建新 3D 视图时旋转视图一次,请在 文件 菜单中选择 基本视图自动旋转 设置。

创建默认零件视图

可以创建一个零件的四个视图:前视图、顶视图、端部视图和 3D 视图。 Tekla Structures 使用同一个命令一次创建这些视图。默认情况下前视图、顶视图和端部视图是平面视图。

  1. 视图 选项卡上,单击 新视图 > 默认零件视图
  2. 选择零件。

    Tekla Structures 使用在 part_front_viewpart_top_viewpart_end_viewpart_persp_view 属性文件中定义的属性来一次性创建四个默认视图。

创建零件的无变形视图

可以创建一个以无变形方式显示变形零件的视图。这仅适用于梁和柱。

  1. 视图 选项卡上,单击 新视图 > 未变形的零件视图
  2. 选择零件。

    例如,选择一个翘曲的梁。 Tekla Structures 会在单独的视图中以无变形方式显示该梁。

创建组件的 3D 视图

当需要仔细查看特定组件时,可创建组件的 3D 视图。这会将组件置于视图中心。

  1. 视图 选项卡上,单击 新视图 > 组件的 3D 视图
  2. 选择组件。

    Tekla Structures 使用在 component_basic_view 属性文件中定义的属性来创建视图。此视图平面的 y 轴是模型的全局 z 轴。x 轴是第一个次零件的局部 x 轴在全局 xy 平面上的投影。工作区深度在所有方向上均为 1 m。

    您选择的组件将自动定义工作区。

    如果您希望 Tekla Structures 每当您创建新 3D 视图时旋转视图一次,请在 文件 菜单中选择 基本视图自动旋转 设置。

创建默认组件视图

可以创建一个组件的四个视图:前视图、顶视图、端部视图和 3D 视图。 Tekla Structures 使用同一个命令一次创建这些视图。默认情况下前视图、顶视图和端部视图是平面视图。

  1. 视图 选项卡上,单击 新视图 > 组件默认视图
  2. 选择组件。

    Tekla Structures 使用在 component_front_viewcomponent_top_viewcomponent_end_viewcomponent_persp_view 属性文件中定义的属性来一次性创建四个默认视图。

创建表面视图

使用 Create surface view 宏可创建自动对齐的表面视图。在复杂几何形状上为螺栓组、加劲肋板和穿孔建模时,这非常有用。

为了能够选择零件的表面,请确保使用显示零件面的模型视图。在 视图 选项卡上,单击 渲染 ,然后选择 零件灰度已渲染零件 选项。

  1. 单击侧窗格中的 应用程序和组件 按钮 打开 应用程序和组件 目录。
  2. 单击 应用 旁边的箭头打开应用列表。
  3. 双击 Create surface view 以启动宏。
  4. 选择零件的表面。

    Tekla Structures 会创建一个新的临时视图,并且通常会将工作平面沿该零件表面的最长边缘移动。您可以在该表面视图中建模,同时在原始 3D 视图中查看建模工作的进行过程。

  5. Esc 停止该宏。
  6. 使工作平面返回到原点:
    1. 重复步骤 1-2 以打开 应用程序 列表。
    2. 双击 Work plane global 宏。

      工作平面会返回到原点,并与模型中的全局 x、y 和 z 平面对齐。

沿所选边缘创建表面视图

使用 Create surface view wEdge 宏可创建表面视图并沿所选边缘对齐该工作平面。在复杂几何形状上为螺栓组、加劲肋板和穿孔建模时,这非常有用。

为了能够选择零件的表面,请确保使用显示零件面的模型视图。在 视图 选项卡上,单击 渲染 ,然后选择 零件灰度已渲染零件 选项。

  1. 确保已激活捕捉到几何线/点 贴靠开关

    这使您可以沿着一个边缘进行选取以定义方向。

  2. 单击侧窗格中的 应用程序和组件 按钮 打开 应用程序和组件 目录。
  3. 单击 应用 旁边的箭头打开应用列表。
  4. 双击 Create surface view wEdge 以启动宏。
  5. 选择零件的表面。

    将鼠标指针悬停在零件边缘上时,会显示一个黄色箭头符号,指示可以将视图对齐到的边缘。箭头的头部表示 x 轴正向。视图将在此方向旋转以形成视图的水平边缘。视图的原点和工作平面将位于箭头捕捉线的起点。

  6. 选取所需边缘。

    Tekla Structures 会创建一个新的临时视图,选定的边缘成为视图的 x 轴。您可以在该表面视图中建模,同时在原始 3D 视图中查看建模工作的进行过程。

  7. Esc 停止该宏。
  8. 使工作平面返回到原点:
    1. 重复步骤 2-3 以打开 应用程序 列表。
    2. 双击 Work plane global 宏。

      工作平面会返回到原点,并与模型中的全局 x、y 和 z 平面对齐。

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
内容评级: 
没有投票