您好!

您是否了解以用户身份登录后可以查看更多内容?

自定义功能区

已添加 April 3, 2019 by Tekla User Assistance tekla.documentation@trimble.com

软件版本: 
2019

自定义功能区

自定义功能区

您可以根据需要使用 功能区编辑器 自定义功能区。例如,您可以更改任何按钮的大小和形状。您可以创建用户定义的命令,然后将您常用的组件和扩展添加到功能区中以便轻松访问。

要打开 功能区编辑器 ,请单击 文件菜单 > 设置 > 自定义 > 功能区

借助 功能区编辑器 ,您可以

  • 将新按钮添加到功能区
  • 移动功能区中现有的按钮
  • 调整功能区按钮的大小
  • 更改按钮的图标和文本
  • 删除不需要的按钮
  • 创建新命令并为其添加按钮
  • 将水平分隔条添加到功能区
  • 添加新选项卡
Note:

如果要自定义建模功能区,请在建模模式下打开 功能区编辑器

如果要自定义图纸功能区,请在图纸模式下打开 功能区编辑器

您只能自定义配置中可用的功能区。

自定义功能区保存在 ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons 文件夹中。如果找不到该文件夹,请确保您可以查看计算机上的 隐藏文件和文件夹

公司管理员可以 将自定义功能区或选项卡分发 到整个组织中,其方法与用于自定义属性窗体布置的方法相同。

将按钮添加到功能区

您只需选择按钮类型及其外观,然后将命令拖动到功能区或 快速访问工具栏 即可添加命令按钮。

目的 操作步骤
为单个命令添加按钮
  1. 添加功能区项 列表中,选择 简单按钮
  2. 命令 列表中,选择要添加到功能区的命令。

    您还可以添加组件、宏和扩展。通过浏览列表或使用 搜索 框以过滤内容。例如,输入 网格 以查找 创建钢筋网 命令和其他与钢筋网相关的组件:

  3. 外观 列表中:
    • 选择按钮是否有图标。选择图标大小,或者是要使用可缩放图标,还是浏览图标图片。
    • 选择按钮是否包含任何文本。

  4. 预览 显示按钮的外观。如果需要,请修改按钮外观。
  5. 将按钮拖动到功能区。

    蓝色指示命令按钮将插入的位置。

添加可开启/关闭特定命令的切换按钮

例如,使用此选项可添加从 文件菜单 > 设置 > 开关 切换到功能区的任意开关。您也可以添加单个捕捉开关,然后选择切换到功能区的开关。

  1. 添加功能区项 列表中,选择 检查按钮
  2. 命令 列表中,选择可以打开或关闭的命令。

    可以打开或关闭的命令旁边有一个复选框。

  3. 外观 列表中:
    • 选择按钮是否有图标。选择图标大小,或者是要使用可缩放图标,还是浏览图标图片。
    • 选择按钮是否包含任何文本。
  4. 预览 显示按钮的外观。如果需要,请修改按钮外观。
  5. 将按钮拖动到功能区。

    蓝色指示命令按钮将插入的位置。

添加其下包含一组命令的下拉列表按钮
  1. 添加功能区项 列表中,选择 下拉列表按钮
  2. 外观 列表中:
    • 选择按钮是否有图标。浏览图标图片。
    • 选择按钮是否包含任何文本。
  3. 预览 显示按钮的外观。如果需要,请修改按钮外观。
  4. 将按钮拖动到功能区。

    按钮现在是单个命令的空占位符。需要为下拉列表按钮添加命令才能使其正常工作。

    1. 添加功能区项 列表中,选择 简单按钮
    2. 命令 列表中,选择要添加到下拉列表中的命令。
    3. 外观 列表中,设置按钮的外观。
    4. 将按钮拖动到下拉列表。

      蓝色指示命令按钮将插入的位置。如果将鼠标指针悬停在向下箭头上,将打开一个列表,并且您可以向该列表拖动命令。该列表将保持打开状态,直到您再次单击向下箭头。

    5. 根据需要将任意数量的命令添加到下拉列表按钮。
为单个命令添加一个按钮以及其下包含一组命令的下拉列表按钮
  1. 添加功能区项 列表中,选择 拆分按钮
  2. 命令 列表中,选择要添加到功能区的命令,该命令作为整个拆分按钮的主按钮。
  3. 外观 列表中:
    • 选择按钮是否有图标。选择图标大小,或者是要使用可缩放图标,还是浏览图标图片。
    • 选择按钮是否包含任何文本。
  4. 预览 显示按钮的外观。如果需要,请修改按钮外观。
  5. 将按钮拖动到功能区。

    按钮现在有单个命令。需要将命令添加到下拉列表中。

    1. 添加功能区项 列表中,选择 简单按钮
    2. 命令 列表中,选择要添加到下拉列表中的命令。
    3. 外观 列表中,设置按钮的外观。
    4. 将按钮拖动到下拉列表。

      蓝色指示命令按钮将插入的位置。如果将鼠标指针悬停在向下箭头上,将打开一个列表,并且您可以向该列表拖动命令。该列表将保持打开状态,直到您再次单击向下箭头。

    5. 根据需要将任意数量的命令添加到下拉列表按钮。

您还可以将命令拖动到位于功能区上方的 快速访问工具栏 中,或拖动到功能区左侧的固定容器中:

移动按钮

您可以重新排列功能区上的按钮。请注意,您无法将下拉列表中的某个按钮移到另一个按钮的下方。

  1. 选择要移动的按钮。

    将高亮显示该按钮:

  2. 将按钮拖动到新的位置。

    蓝色指示命令按钮将插入的位置。例如:

调整按钮的大小

您可以更改现有按钮的大小。

  1. 选择要调整大小的按钮:

  2. 将鼠标指针移动到按钮的任一侧或任一角将显示一个白色箭头符号:

  3. 拖动箭头以定义新大小:

    按钮的大小会相应改变。如果需要,其他按钮会在功能区上自动前移。

  4. 双击按钮将其展开。

    按钮现在完全占满其四周的空白:

更改按钮的外观

您可以更改任意按钮的外观。

  1. 选择要修改的按钮。
    • 如果要添加新按钮:从 命令 列表中选择该命令。

      外观 列表中将显示该按钮的当前属性。

    • 如果按钮在该功能区中已存在:右键单击功能区中所选的按钮。

  2. 要更改图标,请选择其中一个选项:
    1. :未对该按钮使用任何图标
    2. 命令: 大图标 :已使用默认的大图标 (32x32)
    3. 命令: 小图标 :已使用默认的小图标 (16x16)
    4. 命令: 可缩放图标 :使用可缩放矢量图标
    5. 库(位图) :从 Tekla Structures 图标库中选择一个大的或小的位图图标
    6. 库(可扩展) :从 Tekla Structures 图标库中选择一个可缩放图标
    7. 自定义 :通过选择合适的图片文件来定义自定义图标。大按钮的建议大小为 32x32 像素,小按钮的建议大小为 16x16 像素。如果您的自定义图片无法显示为正确尺寸,请检查图片文件的 DPI 设置。推荐 DPI 为 96。
  3. 要更改名称,请选择其中一个选项:
    • :未对该按钮使用任何名称
    • 命令: 全文本 :已使用名称的默认完整版本
    • 命令: 短文本 :已使用名称的默认简短版本
    • 自定义 :为按钮输入自定义名称

使用命令编辑器创建用户定义的命令

您可以创建用户定义的命令并将它们链接到任何文件或 URL。使用 命令编辑器 创建用户定义的命令。

  1. 单击 文件菜单 > 设置 > 自定义 > 用户定义的命令 以打开 命令编辑器
  2. 单击 新建
  3. 输入命令的唯一 ID,然后单击 确认

    例如,创建 Tekla Discussion Forum 的链接。输入 OpenTeklaDiscussionForum 作为命令 ID。

    将显示一个包含更多属性的新列。

  4. 全称短名称 框中,为命令输入名称。

    该名称将显示在 Tekla Structures 用户界面中。您可以定义两个替代名称:完整名称和简短版本。例如,输入 Tekla Discussion Forum 作为该命令的全称,并输入 Forum 作为短名称。

  5. 大图标小图标可缩放图标 设置中,为命令选择一个图标。

    您可以定义三种替代图标:大图标、小图标或可缩放矢量图标。

    您可以使用自己的图标或从 Tekla Structures 图标库中选择合适的图标。

  6. 工具提示 框中,为命令输入工具提示。

    例如,输入 转至 Tekla discussion forum

  7. 操作 框中定义文件或 URL。

    例如,输入 https://forum.tekla.com.

  8. 可用性 中,选择模式(命令在该模式下可用)。
  9. 单击 保存 以保存新命令。
  10. 转到 功能区编辑器
  11. 选择按钮类型。
  12. 命令 列表中,搜索您创建的新命令。
  13. 如果需要,请在 外观 列表中修改按钮外观。
  14. 将新按钮拖动到功能区。

  15. 要修改用户定义的命令,请右键单击功能区中的命令并编辑命令属性,就像修改任何其他命令一样。

添加分隔条

您可以将竖直和水平分隔条添加到功能区中以将按钮划分为较小的组。

  1. 添加功能区项 列表中,选择 分隔符
  2. 外观 列表中,选择添加水平条还是竖直条以及条的厚度。

    预览 显示分隔条的外观。

  3. 将预览项拖动到功能区。
  4. 要修改条的方向或线宽,请右键单击选项卡上的条并选择 方向厚度
  5. 要删除条,请选择功能区中的条并按键盘的 Delete

    或者,请右键单击功能区中的条,并选择 删除

删除按钮

  1. 选择功能区中的按钮。
  2. 按键盘上的 Delete

    或者,右键单击功能区中的按钮,并选择 删除

添加、隐藏和编辑选项卡

您可以添加、移动和重命名功能区选项卡,选择其对齐方式,并在当前工程中不需要某些选项卡时将其隐藏。例如,如果您仅对钢结构零件进行建模,则可以临时隐藏 混凝土 选项卡。

目的 操作步骤
添加新选项卡
  1. 添加功能区项 列表中,选择 选项卡
  2. 文本 框中,输入选项卡的名称。
  3. 单击 添加选项卡 以将其添加到功能区中。
更改功能区中选项卡的顺序 拖放选项卡标题。
选择选项卡的对齐方式 在功能区区域中右键单击并选择其中一个 导航模式 选项:
  • 滚动可见 :当您在选项卡之间切换时,功能区的移动最小
  • 左侧对齐 :图标从功能区的左侧开始
  • 选项卡对齐 :图标从当前选项卡的左侧开始
隐藏当前工程中不需要的选项卡
  1. 将鼠标指针停放在选项卡标题上。

    选项卡标题旁会显示一个小的眼睛符号:

  2. 单击眼睛符号

    眼睛符号会更改,选项卡标题会变灰:

现在 视图 选项卡在功能区中处于隐藏状态。如果您滑动功能区,则隐藏的选项卡显示为:

要重新显示隐藏的选项卡,请再次单击眼睛符号。

重命名选项卡 右键单击选项卡并选择 重命名 。输入选项卡的新名称。
删除选项卡

选择选项卡并按 Delete

或者,右键单击选项卡并选择 删除

保存功能区

当您对更改满意时,可保存自定义的功能区。

  1. 功能区编辑器 中,单击 保存 按钮。
  2. 当您返回到 Tekla Structures 并且程序询问您是否要加载新功能区时,请单击 功能区将随您所做更改进行更新。

查看更改

可以将原始功能区与您更改后的功能区进行比较。 您可以查看已添加和删除的内容,以及已移动到不同选项卡的内容。

  1. 如果您尚未保存自定义功能区,请执行此操作。
  2. 单击 比较 按钮。
  3. 比较功能区 对话框中,查看您所做的更改。

    例如:

    • 不存在 :已删除这些命令
    • 已移动 :已将这些命令移动到新位置
    • 自定义添加 :已添加这些命令
    Note:

    原始功能区 是指安装 Tekla Structures 时随附的适用于您当前配置的功能区文件。

  4. 如果您已删除要恢复的命令,请将其从 比较功能区 对话框拖动到功能区。
  5. 完成操作后,单击 关闭

备份和恢复功能区

您可以随时恢复默认的 Tekla Structures 功能区。 在恢复默认设置之前,请确保保存自定义功能区的备份副本,因为将会永久删除自定义项。 您可以使用备份文件重新使用您的自定义功能区,将功能区设置复制到另一台计算机,或与您的同事共享自定义功能区。

  1. 保存自定义功能区的备份副本:
    1. 功能区编辑器 中,单击 保存 按钮。
    2. 转到 ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons 文件夹。
    3. 创建所需功能区文件的副本并将其保存在另一个文件夹中。

      可根据 Tekla Structures 配置命名功能区。例如,在 全部 配置中, 建模 功能区文件的名称为 albl_up_Full--main_menu.xml

  2. 单击 恢复 按钮以恢复默认 Tekla Structures 建模或图纸功能区。
  3. 重新使用自定义功能区:
    1. 将备份文件复制回 ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons 文件夹。
    2. 当您返回到 Tekla Structures 并且程序询问您是否要加载新功能区时,请单击 功能区将随您所做更改进行更新。

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
内容评级: 
没有投票