您好!

您是否了解以用户身份登录后可以查看更多内容?

复制对象

已添加 April 3, 2019 by Tekla User Assistance tekla.documentation@trimble.com

软件版本: 
2019

复制对象

复制对象

有多种不同的方式可以复制对象。当复制一个对象时, Tekla Structures 会复制与该对象相连接的所有对象,包括组件。

通过选取两个点复制

在模型或图纸中复制对象的基本方式是定义原点和一个或多个目标点。

  1. 选择要复制的对象。
  2. 运行 复制 命令:
    • 在模型中的 编辑 选项卡中,单击复制

    • 在图纸中的 图纸 选项卡上,单击 复制 > 复制

  3. 选取复制原点。

  4. 选取一个或多个目标点。

    将立即复制对象。 复制 命令仍处于活动状态。

  5. 如果要撤消最近一次的复制操作,请单击 Tekla Structures 主窗口左上角的撤消 按钮。

    复制 命令仍处于活动状态。

  6. 要停止复制,请按 Esc

线性复制

在模型中,您可以在同一线性方向上创建一个对象的多个副本。

  1. 选择要复制的对象。
  2. 编辑 选项卡上,单击 选择性复制 > 线性

    将会打开 复制 - 线性 对话框。

  3. 选取两个点,或在 dXdYdZ 框中输入坐标。

    您也可以使用公式来计算 x、y 和 z 位移。例如:

  4. 输入复制份数。
  5. 单击 复制
  6. 要停止复制,请按 Esc 。 
    Tip:

    如果对话框已打开,但命令不再处于活动状态,请单击 点取... 按钮以重新激活命令。

通过指定到原点的距离复制

通过指定与原点的距离,可以在模型或图纸中将对象复制到新位置。可以使用 输入数字位置 对话框指定此距离。

  1. 选择要复制的对象。
  2. 运行 复制 命令:
    • 在模型中的 编辑 选项卡中,单击复制

    • 在图纸中的 图纸 选项卡上,单击 复制 > 复制

  3. 选取复制原点。
  4. 沿着对象复制的目标点方向移动光标,但不要选取点。
  5. 输入距离。

    在您开始输入时, Tekla Structures 将自动显示 输入数字位置 对话框。

  6. 单击 确认

使用拖放复制

您可以通过拖放来复制对象。

  1. 文件 菜单中,单击 设置 并选中 拖放 复选框以激活命令。
  2. 选择要复制的对象。

  3. 按住 Ctrl 键并将对象拖到新位置。

    拖动的起点(中心、角点或中点)会影响对象在新位置中的排列。

    Tekla Structures 复制对象:

Note:

要在图纸中复制轴线标签,请先选择轴线标签,然后激活选择轴线 选择开关 或选择轴线标签控柄。

复制对象到另一个对象

在模型中,您可以将对象从一个对象复制到另一个相似对象。此功能很有用(例如在细化先前建模的零件时)。您可在其间复制对象的这两个对象可以有不同的尺寸、长度和旋转。

  1. 选择要复制的对象。
  2. 编辑 选项卡上,单击 选择性复制 > 到另一个对象
  3. 选择要复制的对象(源对象)。
  4. 选择要复制到的对象(目标对象)。

将所有内容复制到另一个对象

在模型中,可以将对象从构件或浇筑体复制到其它类似构件或浇筑体,无需单独选择每个对象进行复制。例如,当您详细了解构件的各个细部,并且希望将所有细部复制另一个类似的构件时,此功能就会非常有用。

  1. 确保已激活选择构件 选择开关
  2. 选择待复制的构件或浇筑体(源对象)。
  3. 编辑 选项卡上,单击 选择性复制 > 所有内容到另一个对象
  4. 选择要复制到的构件或浇筑体(目标对象)。

这样, Tekla Structures 会复制以下对象:

  • 次零件
  • 钢筋、螺栓和焊缝
  • 切割、接合和边缘折角
  • 子构件
  • 组件
Note:

Tekla Structures 不复制浇筑中断点,或者一个已创建构件主零件的组件所创建的次零件。如果要复制的某些对象已存在于要复制到的目标构件或浇筑体, Tekla Structures 可能会创建重复的对象。 Tekla Structures 会提示您存在重复的次零件、钢筋和子构件,但不会提示您存在重复的螺栓、焊缝、切割或组件。

复制到另一个平面

在模型中,您可以将对象从指定的第一个平面复制到指定的第二个(和第三个等)平面。复制的对象相对于第二个(和第三个等)平面的位置保持与源对象相对于第一个平面的位置相同。

  1. 选择要复制的对象。
  2. 编辑 选项卡上,单击 选择性复制 > 到另一个平面
  3. 选取第一个平面的原点。
  4. 在第一个平面中沿 x 轴正向选取一点。
  5. 在第一个平面中沿 y 轴正向选取一点。
  6. 对所有目标平面重复步骤 3-5。

从另一个模型中复制

您可以根据状态编号从另一个模型复制对象。请注意,仅当次零件与其主零件属于同一状态时, Tekla Structures 才从模型复制这些次零件。这也适用于组件对象。

  1. 编辑 选项卡上,单击 选择性复制 > 从另一个模型

    将会打开 从模型中复制 对话框。

  2. 模型目录 列表中,选择要从中复制的模型。

    这是源模型。请注意,必须已使用与源模型相同或更新版本的 Tekla Structures 创建目标模型。您无法从新版本复制到旧版本。

  3. 状态编号 框中,输入从中复制对象的状态的编号(使用空格分隔)。

    例如 2 7

  4. 单击 复制
  5. 关闭对话框。
Note:

如果您从另一个模型中复制浇筑中断点,则所复制的浇筑中断点会自动适应目标模式。始终检查所复制的浇筑中断点是否已正确适应。

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
内容评级: 
没有投票