您好!

您是否了解以用户身份登录后可以查看更多内容?

评注工具

最后更新 May 16, 2018 by Tekla User Assistance tekla.documentation@trimble.com

软件版本: 
19.1
环境: 
Not environment-specific

评注工具

内容

  1. 用途和描述
  2. 系统要求
  3. 安装与启动
  4. 基本用法
  5. 共享评注
  6. 在多用户模式下创建评注
  7. 在 Tekla BIMsight 和 Tekla Structures 之间共享评注
  8. 在两个 Tekla Structures 模型(一个本机,一个 IFC 参考)中创建评注
  9. 示例工作流摘要
  10. 附加信息

1.        用途和描述

使用评注工具,用户可以通过 Tekla Structures 模型沟通项目问题、更改、疑问甚至工作分配情况。评注可以包括模型截屏、相机视图位置、文档、网站以及与它们链接的 Tekla Structures 本机或 IFC 参考模型对象。

评注自动存储在模型文件夹中。可以从评注工具中与他人共享评注,方法是指定一个供评注工具读写共享评注的文件夹。例如,此文件夹可以是

  • 公司服务器上一个多用户模型的模型文件夹
  • 公司服务器上一个单独的评注文件夹
  • 通过 Dropbox 等文件共享应用程序 ( http://www.dropbox.com ) 在计算机和公司间自动同步的一个本地文件夹。

此外,还可以通过电子邮件或 FTP 站点发送和接收评注。

这样,用户就可以选择是在一个组织内实时添加/共享评注,在不共享服务器的多个组织间添加/共享评注,还是只是对自己的项目进行评注和注释。

评注工具创建和读取的文件使用 BIM 协作格式 (BCF),这是由国际 buildingSMART 组织定义的。这意味着可以使用 Tekla BIMsight 或其它支持 BCF 的 BIM 软件和项目管理工具轻松交换评注(包括链接的模型文件和视图位置)。

 

2.        系统要求

Tekla Structures 配置:         任意(包括浏览器)

环境:                                    任意

3.        安装与启动

要安装并启动此扩展,请执行以下操作:

  1. 下载并安装相应的 32 位或 64 位 (x64) 评注工具版本。安装程序会自动检测您的环境并将工具栏和文件安装到相应的文件夹中。
  2. 重新启动 Tekla Structures。新工具栏以及图标就会出现在用户界面中。

    注意:工具栏是用户(即 Windows 用户帐户)特定的,这意味着安装此扩展的用户会在 Tekla Structures 中得到用户工具栏,而其他用户不会。

    要在 Tekla Structures 中手动添加用户工具栏扩展,请执行以下操作:

    1. 单击“工具”>“自定义”打开“自定义”对话框。
    2. 在“工具栏”选项卡上,单击“新建...”。工具栏树中会出现一个名为“用户工具栏 1”的新工具栏。您可以输入工具栏的新名称。
    3. 在左侧列表中搜索找到该扩展,单击它,然后单击向右箭头将其添加到工具栏中。
    4. 单击“关闭”。

4.        基本用法

在 Tekla Structures 中打开一个模型并按工具栏图标启动评注工具。或者,也可以转到“工具”>“宏”菜单,选择“评注工具”,然后按“运行”。就会显示评注工具界面。

4.1.  添加新评注

缩放到模型中要评注的具体位置。到达目标位置后,按评注工具左上角的“新建”按钮。评注工具就会记住当前位置和相机角度。

注意:如果您在“透视”视图中添加了评注,然后又切换到“正交”视图,将不会显示这一位置,反之亦然。因此最好商定对所有评注使用一种投影模式。

列表中会出现一条新评注。要更改“标题”、“已分配”或“状态”域,只需单击要编辑的单元格/域。就会出现一个弹出框,可以在其中输入新值。

4.2.  编写评注文本并添加信息

下一步是编写评注文本。只需单击评注列表下方的评注框并键入评注即可。

评注文本上方是您的名字标签。如果需要,可以单击标签对其进行编辑。

您可以将所选模型对象链接到评注。这意味着每次在“评注工具”列表中选中评注时,该评注不仅会缩放到创建它的相机位置,还会高亮显示/选中模型中与该评注链接的零件。在模型中选择零件,然后按“链接对象”按钮。所链接对象的数目会显示在“对象”按钮上,并且按此按钮可以高亮显示这些对象。

接下来可以将文档或 Web URL 链接到评注。直接在“链接”域中键入地址或路径,或者单击该域旁的“...”按钮浏览您计算机或服务器文件夹中的文档。文件路径就会插入并存储到评注中。单击“打开”按钮会用相应文件类型/扩展名的默认关联应用程序打开链接的文档,如果是 Web URL,则打开 Internet Explorer。

提示:如果使用点号 (.) 作为路径的第一个字符,它会引用当前模型文件夹。如果您共享了评注(请参见“共享”),然后另一用户打开了该评注,URL 就会引用该用户的 模型文件夹。这对于共享的模型和注释非常有用。如果您浏览到当前模型文件夹中的一个文件,将自动插入点号。

最后,您可以向评注添加截屏。只需单击包含相机图片的框。就会打开一个透明的相机窗口。将窗口移动到模型中要截屏的区域并调整窗口大小。单击“捕获”或在透明窗口中双击进行截屏,然后图像就会与评注关联。

   

提示:单击“编辑”可以向截屏添加红线。将会用默认打开 *.png 文件的关联应用程序打开图像。完成编辑后,保存图像并关闭编辑应用程序。评注工具中的图像就会更新。

对评注文本和信息感到满意后,可以按“保存”保存评注。

4.3.  回复评注

保存评注后,可以对其添加回复。只需在最后一条评注后显示的评注框中单击,然后开始编写回复,完成后单击“保存”。评注就会添加为当前主题的回复。

注意:不能在回复中添加截屏或链接。如果要添加新截屏,必须添加新评注。

4.4.  过滤评注

要搜索评注,请在工具栏中的过滤文本框中键入一个字符串,就会根据您键入的内容即时过滤评注。

这时,评注列表中将只显示包含该字符串文本的任意部分的评注。此工具将搜索评注标题、正文以及状态和已分配域。

要删除过滤,只需清空过滤文本框即可。

4.5.  设置

“设置”下有一些选项,可以使该对话框始终保持在其他窗口之上,打开评注时缩放到关联的对象(而不是还原到保存的相机视图),更改评注工具对话框的显示方向以及在共享文件夹中检测到新评注时即时刷新评注列表。

 

5.        共享评注

您编写的所有评注开始都会以私有方式存储在模型文件夹中(在一个名为“PrivateComments”的文件夹中)。您可以决定要与他人共享哪些评注。共享采用 bcfzip 格式,这意味着您可以像与其他评注工具用户一样轻松与 Tekla BIMsight 共享注释。

有两种方法可以与他人共享评注。

5.1.  使用共享文件夹共享

您可以将评注共享到系统或网络中的任意文件夹。如果其他评注工具用户可以访问您选择的文件夹,他们就可以将其工具设置为使用同一文件夹,这样每个人在您共享评注时都会自动接收您的评注。共享评注的一个非常简便的方法是使用文件共享/同步服务,如 Dropbox。只需将您的评注工具指向一个设置为在计算机和公司间自动同步的文件夹即可(有关如何与他人共享/同步文件夹的信息,请参见相应的共享服务文档)。

要指定共享文件夹,请打开共享下拉菜单并单击“设置共享文件夹”。就会看到当前共享文件夹显示在共享菜单底部。“打开共享文件夹”按钮可以在 Windows 资源管理器中显示文件夹内容。

现在,选择要共享的一条或多条评注,然后单击“共享所选”。就会打包所选评注并复制到共享文件夹中。

一次共享多条评注将只创建一个 bcfzip 文件。这个文件可以轻松输入 Tekla BIMsight 或附加到电子邮件中。多次共享一条评注会创建多个版本的 bcfzip 文件,每个版本都有唯一的时间戳。

注意:每次启动评注工具时都会清理共享文件夹。本文档稍后将详细说明。

编写新评注或回复评注时,可以选择单击评注框下的“保存并共享”。这会保存评注或回复,然后立即将评注或回复(与整个评注主题一起)共享到共享文件夹。

5.2.  通过电子邮件共享

要通过电子邮件共享,请先选择要共享的评注,然后转到共享菜单并单击“将所选复制到粘贴板”。在 Outlook 中新建一封电子邮件,右键单击邮件正文并选择“粘贴”。这会将评注添加到电子邮件附件中。

提示:复制的评注作为文件放在 Windows 粘贴板上,因此应该可以将评注粘贴到支持从粘贴板粘贴文件的任意电子邮件客户端或应用程序。如果您的客户端不支持这样做,可以将评注共享到共享文件夹(“共享所选”),然后从那里附加 bcfzip 文件。

5.3.  获取他人的评注

新评注从共享文件夹直接读入评注工具。因此,当几个评注工具用户协作时,他们都应该将评注共享到同一网络文件夹,或者使用一个自动与他人同步的文件夹(例如 Dropbox 文件夹)。这样,每次有人共享评注时,所有其他用户都能立刻看到。

单击共享菜单右侧的“刷新”图标时,评注工具会读入所有评注,并在共享文件夹中更新发现的结果。新评注显示为绿色,有更新或新回复的现有评注显示为蓝色。

如果有人使用其他应用程序进行评注(如 Tekla BIMsight),他们可以将评注从应用程序输出到同一共享文件夹。然后就可以通过刷新将评注读入您的评注工具。

如果通过电子邮件接收评注,只需将它们拖放到评注工具的评注列表中以打开这些评注。当然,也可以如前所述,将收到的评注复制到共享文件夹,然后单击“刷新”图标。

提示:如果在设置菜单中启用了“实时刷新”,新评注和更新的评注添加到共享文件夹中时,评注工具会自动读入它们。

5.4.  共享工作详述

有时多个用户可能分别回复同一评注,您可能从不同来源,在不同时间,甚至往往不按文件创建顺序收到这些文件。

从共享文件夹刷新时,评注工具会比较它所找到的所有评注文件的内容。如果有多个文件包含对同一原始评注的不同回复,则会合并这些回复,并显示为一条评注,其中包含按时间戳排序的回复。

每次启动评注工具时,都会按前面所述的方式比较并合并评注。此外,评注工具还会为每条评注创建一个 bcfzip 文件。原始文件会被删除,但共享文件夹仍会包含相同的信息。这是为了避免评注文件堆积在文件夹中。

所有注释也会始终在本地存储(在模型文件夹中的“PrivateComments”下)。因此,如果从共享文件夹中删除了评注,在您的评注工具中仍有本地副本。如果之后回复已删除的评注并将之共享,整个主题将重新出现在共享文件夹中。

 

6.        在多用户模式下创建评注

可以使用共享文件夹在多用户模式下共享评注。可以将共享文件夹设为服务器上主模型文件夹中的一个文件夹,这意味着使用该模型的每个人都可以即时访问所有共享评注。

可以通过按“共享”菜单上的“设置共享文件夹”按钮更改共享评注文件夹的位置。也可以通过按“打开共享文件夹”按钮在 Windows 资源管理器中浏览评注文件夹。

注意:共享前,评注将以私有方式存储在每个人的本地模型文件夹中,该文件夹名为“PrivateComments”使用模型共享时不应同步此文件夹。可以在 Tekla Structures 菜单中的“文件”>“模型共享”>“设置...”>“设置”下将它设置为排除。

共享文件夹使得多用户模式下使用项目的所有用户能够同时在同一项目中查看、添加和编辑评注。多用户模型中添加的评注不需要模型中的所有成员都保存模型才能查看评注,因为评注本身并不存储在模型数据库中,它们只是与模型链接的外部文件。这非常方便,特别是当您在两台不同计算机上(比如在不同国家/地区的两个办公室中)加载了同一模型的两份副本时,可以将评注目录设置为两个办公室都可以访问的共享网络文件夹。与模型相比,评注文件非常小,这意味着您可以通过服务器文件夹远程实时共享评注,而不必交换模型本身。

请尝试与一名同事在多用户模型中使用评注工具。如果在“设置”菜单中单击“实时刷新”,当你们两个都在自己的计算机上打开评注工具并开始添加和共享评注时,可以看到每个人的评注都会自动显示在对方的屏幕上。新评注会采用绿色颜色编码,修改的评注会采用蓝色颜色编码。

接下来尝试以下操作:一人关闭其评注工具会话,另一人继续添加评注回复。进行少量添加和更改后,重新打开评注工具。注意,重新打开评注工具时,顶部会以绿色显示一些评注,还有一些以蓝色显示。评注工具记下了上次会话的评注以及之后的更改,并能显示这些区别。评注将按时间顺序显示在列表中,最近的评注显示在最前面。

此处还要注意的一点是,对于拆分为多个模型的大型项目,您需要协调与两个模型的衔接线有关的更改或问题。您可以在两个不同的 Tekla Structures 模型中使用评注工具,从模型 A 拍照并存储相机位置,然后使它们对模型 B 中的用户可见。这样做的关键是模型 A 中钢材衔接线的终点与模型 B 中钢材衔接线的起点恰好处于同一物理位置。

 

7.        在 Tekla BIMsight 和 Tekla Structures 之间共享评注

如果安装了 Tekla BIMsight ( http://www.teklabimsight.com ),就可以在 Tekla Structures 和 Tekla BIMsight 之间轻松共享评注。

要试用此功能,请先将模型输出到 Tekla BIMsight(Tekla Structures 菜单:“文件”>“输出到 Tekla BIMsight”)。在 Tekla BIMsight 中打开模型。

接下来,在评注工具中选择一些注释并单击“共享所选”。然后转到 Tekla BIMsight 并单击“注释”>“共享”>“输入注释”。

导航到共享文件夹并选择刚刚从评注工具中共享的注释(如果不确定是哪些注释,可以参考创建时间)。这会将评注添加到注释列表中。

双击打开一条注释,可以看到评注、回复、截屏和链接的对象都显示出来。单击截屏可转到模型中最初创建注释的位置。

 

在评注工具和 Tekla BIMsight 中打开的同一评注
 

现在可以在 Tekla BIMsight 中添加评注回复并创建几条新注释。然后,选中注释列表中的所有注释,并单击“共享”>“保存到文件”。将该文件保存到评注工具共享文件夹。

然后转到评注工具并单击“刷新”。新评注即显示在评注列表中,新回复也会加载到现有评注之中。只要 Tekla Structures 中的模型与 Tekla BIMsight 处于相同的视图模式(透视/正交),单击每条新评注时就应缩放到在 Tekla BIMsight 中创建评注时指定的位置。

提示:您也可以从 Tekla BIMsight 中通过选择“作为电子邮件发送”通过电子邮件共享评注,或如“共享”部分所述从评注工具中共享。在电子邮件中收到评注时,可以直接将附加的文件拖放到 Tekla BIMsight 或评注工具的评注列表中进行查看。

 

8.        在两个 Tekla Structures 模型(一个本机,一个 IFC 参考)中创建评注

下一个测试步骤演示如何在 IFC 模型对象被拆分后对 IFC 模型对象创建评注。建议的测试工作流是输出之前使用的现有模型的 IFC 文件(“文件”>“输出”>“IFC”)。然后创建一个新的 Tekla Structures 模型,并将该 IFC 文件作为参考模型插入新的空 Tekla Structures 模型(“文件”>“插入参考模型”)。插入参考模型时,必须确保以与本机 Tekla Structures 模型相同的方向、在相同的原点插入模型。插入 IFC 模型后,确保在 Tekla Structures 中选择该模型,然后按“插入参考模型”对话框中显示的“再划”按钮。这样做以后,评注工具才能读取模型对象的 IFC GUID。

然后,重新打开评注工具,将此新模型中的共享评注文件夹位置更改为与之前的 Tekla Structures 本机模型中的评注文件夹相同。这样做之后,便可以看到其他模型的评注出现在这里。请务必确保 3D 模型视图属性设置为与添加评注时使用的模式相同(透视/正交)。单击列表中的评注,可以看到,视图缩放到原始模型中定义的同一位置,并且 IFC 模型对象高亮显示,表示在之前的模型中为同一本机对象链接了评注。

   

如果您是工程师并有一些建筑师发来的 IFC 文件,或者如果您是总承包商并有一些机械或其他 IFC 文件,也请将这些文件插入模型并再划。您也可以在评注工具中将这些对象链接到评注。只需确保在选择工具栏上选中“选择节点中的目标”,然后再选择与您的评论链接的 IFC 参考对象。

一个建议使用的工作流是,即使细部设计人员与使用可以生成 IFC 模型的不同 BIM 应用程序集的设计师工程团队一起工作,也可以在 Tekla Structures 中协调使用这些模型与其结构细部设计模型。例如,钢结构细部设计人员可以将 MEP、建筑和结构工程 IFC 模型插入其结构细部设计模型的副本或新的空 Tekla Structures 模型中,在那里还可以插入以 IFC 模型格式输出的结构模型副本。现在,所有模型都保存到一个 Tekla Structures 模型中,细部设计人员可以将此模型发送给总承包商或设计团队,他们至少可以使用查看许可证浏览连接的模型,查询属性、测量模型,最重要的是可以在连接的模型中添加/查看评注。在设计和细部设计团队之间可以轻松收发这些评注,从而在受保护的 IFC 参考模型环境中轻松沟通,降低实施难度、成本和风险。与其他 BIM 软件相比,Tekla Structures 平台的设计更适合处理大量细部和模型,因此,出于检查和沟通目的,可以由他方使用 Tekla Structures 来更有效地检查项目。

在这种环境下,你们双方经常不在有共享服务器文件夹的同一公司中,但仍希望轻松建立实时评注会话。使用 Dropbox ( www.dropbox.com ) 这样的文件共享/同步服务就可以做到这一点。Tekla 并不对 Dropbox 的使用表示支持或承担负责,但在与评注工具的测试中,使用 Dropbox 提供的基本文件文件夹同步功能确实可以轻松便捷地设置实时多公司评注系统。工作流图片如下所示。

 

9.        示例工作流摘要

下面是 5 个简单的评注工具使用示例:

1.            在实时多用户模型环境中交流校核评注、每日工作分配或疑问,甚至在保存模型之前也可以做这些工作。

2.            跟踪 RFI、更改顺序或问题区域。一般是您自己在模型中添加的工作注释。

3.            在 Tekla BIMsight 中所做的评注在输出到共享文件夹之后可以由评注工具提取;或者,也可以先输出再拖放到评注列表中。这意味着,工程师、建筑师、承包商、安装人员、项目经理、制造人员即使算机上没有 Tekla Structures,也可以使用 Tekla BIMsight 对模型进行评注,然后 Tekla Structures 用户可以直接在 Tekla Structures 中轻松缩放到相同的评注区域。

4.            Tekla Structures 细部设计人员可以输出其连接项目的 IFC 模型。Tekla Structures 工程师或制造人员可以打开一个新的 Tekla Structures 模型参考该 IFC 模型并再划。工程师或制造人员不能修改细部设计人员的几何形状,不必担心截面目录、编号设置等。他们只是在模型中添加评注,然后将评注与细部设计人员生成的 IFC 参考模型对象链接起来。然后,评注文件发回给细部设计人员。他将这些评注加载到其本地的本机 Tekla Structures 细部设计项目,生成并链接到 IFC 参考模型对象的评注现即可见,并与细部设计人员的本机 Tekla Structures 对象关联。因为评注通过 IFC GUID 记住 IFC 和生成它们的 Tekla 本机对象之间的链接,所以可以这样做。这为输出的项目协作提供了一种更安全简便的形式。

5.            安装人员在工作现场拍摄了一张现场条件或区域照片。使用 Tekla Structures 的查看许可证和评注工具,他就可以拖动拍摄的现场情况照片文件并将其链接到模型中的相应区域和零件。然后,就可以轻松压缩并通过电子邮件发回办公室供项目经理查看。

10.    附加信息

外联网上的评注工具页面 ( https://extranet.tekla.com/BC/tekla-structures-en/product/extensions/comment-tool/Pages/Default.aspx ) 有一些演示如何使用该工具的视频。请注意,这些视频是针对上一版本的评注工具制作的,因此可能不再完全准确,但基本工作流相同。

 

此页针对 Tekla Structures

的旧版本编写

由于此页不再更新,文档评论和反馈已关闭。

内容评级: 
没有投票