Tekla Structures 2016

Templates and reports
April 2016
©2016 Trimble Solutions Corporation

Contents
1

Templates....................................................................................... 3

1.1
1.2
1.3
1.4

Create a template............................................................................................. 4
Create a template in HTML format................................................................. 5
Create a template for nested assemblies...................................................... 6
Create a template for bending schedules or pull-out pictures .................10

1.5
1.6
1.7
1.8

Bending schedule attributes................................................................................................ 11

Add images in a template.............................................................................. 12
Content types.................................................................................................. 15
Template attribute files (contentattributes.lst)..........................................18
User-defined template attributes................................................................. 19

Add user-defined template attributes to Template Editor............................................... 21
Add comments to user-defined template attributes........................................................ 22
Add hierarchy to user-defined template attributes.......................................................... 23

2

Reports..........................................................................................25

2.1
2.2
2.3
2.4
2.5
2.6
2.7
2.8

Create a report................................................................................................ 26
Create a report of selected drawings............................................................27
Create a report of nested assemblies........................................................... 27
Show a report ..................................................................................................28
Define how reports are displayed................................................................. 28
Add tabs to reports......................................................................................... 29
Print a report .................................................................................................. 30
Report settings................................................................................................ 31

3

Tips for templates and reports.................................................. 33

3.1
3.2
3.3
3.4
3.5
3.6

Select objects to include in a report using GUIDs....................................... 33
Useful shortcuts in viewing logs and reports.............................................. 34
Use text type attribute in calculations.........................................................35
Change value field content to use imperial units....................................... 35
Define customized date format.....................................................................36
Assembly or cast unit drawing sheet number.............................................36

4

Disclaimer.....................................................................................38

2

1

Templates

Templates are descriptions of forms and tables that can be included in Tekla
Structures. Templates are either graphical or textual. Graphical templates can
be included in drawings as tables, text blocks, and drawing headers. Textual
templates can be used as reports. The contents of the template fields are filled
in by Tekla Structures at run time.
Tekla Structures includes a large number of standard templates you can use.
Use Template Editor to modify existing templates, or create new ones to suit
your needs. Graphical template definitions have the file name extension .tpl.
Textual template definitions have the file name extension .rpt.
Example

For more information on using templates, see the Template Editor Help or the
Template Editor User's Guide
To access Template Editor Help, open Template Editor and click Help -->
Contents .
To open the guide in .pdf format, click Template Editor User's Guide.
See also
Create a template (page 4)
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Reports (page 25)
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1.1 Create a template
To create a template:
1.

On the File menu, click Editors --> Template Editor.

2.

In Template Editor, click File > New.

3.

Select the template type and click OK. A new empty template is created.

4.

Add new rows in the template.

5.

a.

Click Insert --> Component --> Row to add a new row.

b.

Select a content type for the row and click OK.

c.

Repeat steps a–b for each new row.

Add value fields to get the required data from your Tekla Structures
database.
a.

Click Insert --> Value field .

b.

Click a point to define the location of the field within the row.
The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

6.

c.

Select an attribute and click OK.

d.

Repeat steps a–c for each value field.

Save the template.
a.

Click File --> Save as.

b.

Browse to the template folder ..\environment
\<your_environment>\template.

c.

In the File name field, enter a name for the template.

d.

Click OK.

See also
Templates (page 3)
Create a template in HTML format (page 5)
Create a template for nested assemblies (page 6)
Create a template for bending schedules or pull-out pictures (page 10)
Add images in a template (page 12)
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1.2 Create a template in HTML format
Templates in HTML format give you more possibilities for different layout,
fonts, and images. Templates that generate output in HTML format are
graphical and have the file name extension *.html.rpt.
1.

On the File menu, click Editors --> Template Editor.

2.

In Template Editor, click File > New.

3.

Select Graphical template and click OK.

4.

Add new rows in the template.

5.

a.

Click Insert --> Component --> Row to add a new row.

b.

Select a content type for the row and click OK.

c.

Repeat steps a–b for each new row.

Add value fields to get the required data from your Tekla Structures
database.
a.

Click Insert --> Value field .

b.

Click a point to define the location of the field within the row.
The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

6.

7.

c.

Select an attribute and click OK.

d.

Repeat steps a–c for each value field.

Add a header for each value field.
a.

Click Insert --> Component --> Header...

b.

Click Insert --> Text...

c.

Enter a heading for the template, and then click OK.

d.

Click a point to define the location of the heading in the header row.

e.

Repeat steps a–d to create headings for all the value fields.

Save the template:
a.

Click File --> Save as

b.

Browse to the template folder ..\environment
\<your_environment>\template.

c.

In the File name field, enter a name for the template.
Include the extension *.html.rpt in the file name. For example,
Part_list.html.rpt.

d.

Click OK.
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NOTE If you add images in your HTML template, the images should be located in ..
\Program Files\Tekla Structures\<version>\nt\TplEd\bitmaps
folder, otherwise they are not shown in the HTML output.

Example

1.

Header that contains text fields

2.

Row that contains two value fields

See also
Templates (page 3)
Add images in a template (page 12)

1.3 Create a template for nested assemblies
This example shows how to produce a template that displays the hierarchical
structure of nested assemblies. You will create a nested assembly structure in
a textual template similar to the one in the following picture:
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1.

On the File menu, click Editors --> Template Editor.

2.

In Template Editor, click File > New.

3.

Select Textual template and click OK.

4.

Add four new rows in the template.
a.

Click Insert --> Component --> Row to add a new row.

b.

Select a content type for the row, and then click OK.
For the first and third row, select the ASSEMBLY content type, and for
the second and fourth row, select the PART content type.

c.
5.

Repeat steps a–b for each new row.

Use the arrow buttons under Sorting and drawing order to create a
nested assembly structure for the template.
a.

Move the second and third row down one level.

b.

Move the fourth row down two levels.

The structure should now look like this:

6.

Add value fields to get the required data from your Tekla Structures
database.
In this example, the added value fields are assembly or part position,
number, and weight.
a.

Click Insert --> Value field .

b.

Click a point to define the location of the field within the row.
The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

c.

Select an attribute and click OK.

d.

Repeat steps a–c for each value field.
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7.

8.

Modify the layout of the template. For example:
a.

Move objects to display the nested assembly structure in the printed
report. To do this, select the object you want to move and drag it to
the desired position.

b.

Align objects. To do this, select all the objects you want to align, rightclick and select the appropriate option from the pop-up menu, for
example Align --> Right .

c.

Add a header and a footer. To do this, click Insert --> Component -->
Page header and Page footer. Add the required information to the
header and footer.

Save the template.

Example
Below is an example textual template and a report that has been created using
the template:
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NOTE You can create graphical templates for nested assemblies in the same manner
as textual templates. The difference between graphical and textual templates
is that in a graphical template you can display project and company
information and graphics, such as table outlines, pictures, or symbols.

See also
Templates (page 3)
Templates
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1.4 Create a template for bending schedules or pull-out
pictures
You can use Template Editor for creating bending schedules or pull-outs
pictures on reinforcement bars and bent meshes, and control the type of
information that is shown in the bending schedules.
1.

On the File menu, click Editors --> Template Editor.

2.

Click File --> New .

3.

Select Graphical template and click OK.

4.

Click Insert --> Component --> Row to add a new row.

5.

Select REBAR or MESH as the content type for the row.

6.

Add value fields to get the required data from your Tekla Structures
database.
a.

Click Insert --> Value field .

b.

Click a point to define the location of the field within the row.
The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

7.

c.

Select an attribute and click OK.

d.

Repeat steps a–c for each value field.

Insert a graphical field to your REBAR or MESH content type row.
a.

Click Insert --> Graphical Field...

b.

Click and drag with the mouse to draw a frame.

8.

Double-click the graphical field to open the Graphical Field Properties
dialog box.

9.

Click Free attributes and go to the User tab.

10. Add the required bending diagram attributes.
11. Save the template.
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Example

See also
Bending schedule attributes (page 11)

Bending schedule attributes

The following table lists the attributes and values that can be used for bending
schedules in templates.
Attribute

Default value

Available values

FontName

romsim

Available template fonts

FontSize

2.0

Available font sizes

FontColor

1 (black)

1 = black
2 = red
3 = bright green
4 = blue
5 = cyan
6 = yellow
7 = magenta
8 = brown
9 = green
10 = dark blue
11 = forest green
12 = orange
13 = gray

Templates
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Attribute
RotationAxis

Default value

Available values
0 = by view

2

1 = by global Z
2 = by local axis
Exaggeration

0 = no

1

1 = yes
EndMark

1 = straight

1

2 = half arrow
3 = full arrow
Dimensions

0 = no

1

1 = yes
BendingRadius

0

Shows the bending
radius in form of
diameter of the bending
roll.
0 = no
1 = yes

BendingAngle

0 = no

1

1 = yes
ImageWidth

Width of the graphical
field multiplied by 4.

Number of pixels

ImageHeight

Height of the graphical
field multiplied by 4.

Number of pixels

See also
Create a template for bending schedules or pull-out pictures (page 10)

1.5 Add images in a template
You can add images in graphical templates. For example, you might want to
include a company logo in your drawings. Tekla Structures supports the
following image formats in graphical
templates: .bmp, .jpg, .jpeg, .tif, .tiff and .png.
1.

Open an existing graphical template or create a new graphical template in
Template Editor.

2.

Add a new row in the template:
a.

Click Insert --> Component --> Row to add a new row.

Templates
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b.
3.

Select a content type for the row and click OK.

Ensure that you have the row selected, and click Insert > Picture to open
the Select Picture File dialog box.
If a local symbols folder exists, the contents of that folder are shown by
default. You can browse for the contents of the common\symbols folder
by selecting that folder. If a local symbols folder does not exist, Tekla
Structures displays the contents of the common\symbols folder.

4.

If you have images in other folders, you can display these folders in the
Select Picture File dialog box:
a.

In Template Editor, click Options --> Preferences.

b.

Go to the File Locations tab and on the Symbols, pictures row, add
a new folder separated by a semicolon (;), for example:

The folder you defined is displayed in the Directory list:

5.

Select an image from the File list and click OK and add the image.
You can adjust the size by dragging from the image handles.

Things to remember when adding images in templates
•

Do not add very large images because they update very slowly.

•

The image may look different in the image editor and in the printout or in
the exported DWG file.

•

When you export the drawing to DWG, Tekla Structures copies the images
in the same folder as the DWG file. If the image for some reason is not in
the same folder, only the name of the image is displayed together with an
empty frame instead of the image in the DWG.

•

If environments have local symbols, the local symbol folder is also included
in the search path with the common\symbols folder. If the local symbols

Templates
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folder contains files with the same name as common\symbols folder, then
the local symbol file is used.
•

When you open the drawing that contains images inserted in the template,
Tekla Structures first looks for the images in the model folder and then in
the \symbols folder in the current environment.

•

You can define a folder where Tekla Structures always looks for images
using the advanced option DXK_SYMBOLPATH. You can also define a firm
folder for your images.

Example
Below are some examples of the Select Picture File dialog box showing folder
structure in different environments.

Templates
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In the following example, a company logo has been added in a template.

See also
Templates (page 3)

1.6 Content types
When you create a new row in the template, you must select a content type for
the row. The content type determines which template attributes you can use in
that row.
The available content types are:
Content type

Description

ANTIMATERIAL
ASSEMBLY

Use to create lists of assemblies and single parts.
Includes all assemblies containing the selected
parts and bolts.

BOLT

Use to create screw and bolt lists. Includes all bolts
connected to selected parts.

CAST_UNIT

Use to create lists of cast units.

CHAMFER

Use to create lists of the length of the chamfers.

COMMENT

Use to create empty rows or rows that only have
textual data or lines anywhere on a template.

CONNECTION

Use to create lists of connections.

DRAWING

Use to create drawing lists without revision history
information. Use for reports and included
drawings.

HIERARCHIC_OBJECT

Use to create lists of various types of hierarchies.
For example, lists hierarchical objects in Organizer.
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Content type

Description
Use to retrieve history information of the model.
You can use this content type with PART, REBAR,
CONNECTION and DRAWING rows.

HISTORY

The following template attributes can be used with
this content type:
•

TYPE: the type of the historical action, for
example update or numbering.

•

USER: the user who made the change.

•

TIME: the time the change was made.

•

COMMENT: the comment which was entered
upon clicking Save.

•

REVISION_CODE: the revision code which was
entered upon clicking Save.

HOLE

Use to create lists of holes.

LOAD

Use to create lists of loads.

LOADGROUP

Use to create lists of load groups.

MESH

Use to create lists of meshes.

NUT

Use to create lists of nuts. Contains all nuts for
bolts associated with the selected parts.

PART

Use to create lists of parts.

POUR_BREAK

Use to create lists of pour breaks.

POUR_OBJECT

Use to create lists of pour objects.

REBAR

Use to create lists of reinforcing bars.

REFERENCE_MODEL

Use to list the reference models.

REFERENCE_OBJECT

Use to list the reference model objects in a
reference model.
Only reference model objects that have userdefined attributes are displayed in reports.

REFERENCE_ASSEMBLY

Use to list the reference assemblies in a reference
model.

REVISION

Use to create lists of revision marks.

SIMILAR_ASSEMBLY

Use to create lists of similar parts.

SIMILAR_CAST_UNIT

To use this content type, you need to have an
empty (hidden in output) ASSEMBLY, PART or
CAST_UNIT row in the row hierarchy above the row
with SIMILAR_* content type:

SIMILAR_PART
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Content type

Description

You cannot have any rows below SIMILAR_* row
content type in the row hierarchy.
Note: Used in drawings to collect similar object
information from the model. All the other attribute
information is collected from visible drawing
objects.
SINGLE_REBAR

Use to create lists of individual bars in reinforcing
bar groups.
For example, use it to the get the lengths of the
individual bars in tapered reinforcing bar groups.

SINGLE_STRAND

Use to create lists of individual prestressed
strands.

STRAND

Use to create lists of prestressed strands.

STUD

Use to create lists of studs.

SURFACE

Use to create lists of surfaces.

SURFACING

Use to create lists of surface treatments.

SUMMARY

Use to summarize the contents of the row(s) that
are above SUMMARY in the hierarchy.

For example, use PART - SUMMARY hierarchy to
summarize the contents of the PART rows.
TASK

Use to create lists of tasks.

WASHER

Use to create lists of washers. Contains all washers
for all bolts associated with the selected parts.

WELD

Use to create lists of welds.

See also
Template attribute files (contentattributes.lst) (page 18)
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1.7 Template attribute files (contentattributes.lst)
Template attributes represent object properties. You can use template
attributes in value fields, formulas, and row rules to get the required data from
your Tekla Structures database.
When you output the template, Tekla Structures replaces the attribute with the
actual value of the corresponding object property. For example, if you include
the attribute WEIGHT in a report template, Tekla Structures displays the weight
of the model object in the report.
Template attributes are defined in the following files:
File name

Description
This is a container file listing all the
files that contain the actual attribute
definitions. The files are added with
INCLUDE sentences. The order of the
files included in
contentattributes.lst defines
the reading order of the files.

contentattributes.lst

This file is overwritten in the
installation when you install a newer
version of Tekla Structures. Ensure
that you make a copy of this file
before updating.
Generally, there is no need to modify
contentattributes.lst. Do not
modify it if you are not an
administrator.
contentattributes_global.lst

This file contains attributes that are
hard-coded into the program. Do not
edit this file.

contentattributes_userdefined This file contains user-defined
.lst
attributes, the same as in the
objects.inp file.
This file is overwritten in the
installation when you install a newer
version of Tekla Structures. To use
your own attributes in templates and
reports, create a copy of this file and
add the necessary attributes to that
file.

Templates
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By default, these files are located in ..\Program Files\Tekla Structures
\<version>\nt\TplEd\settings, but the location may be different in your
environment.
The search order for the contentattributes.lst file is the following:
1.

Model folder

2.

Project folder defined by XS_PROJECT

3.

Firm folder defined by XS_FIRM

4.

Folder defined by XS_TPLED_INI

5.

Folder defined by XS_TEMPLATE_DIRECTORY/settings

See also
User-defined template attributes (page 19)

1.8 User-defined template attributes
User-defined template attributes are defined in the
contentattributes_userdefined.lst file. By default, this file includes
most of the user-defined attributes that are visible in the part properties
dialog boxes. To use your own attributes in templates and reports, you should
make a copy of the file, rename it appropriately, and add the necessary
attributes to that file.
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The contentattributes_userdefined.lst file is divided into two sections:
•

A list of attribute names and default settings:

•

A list of attributes assigned to content types:

1.

The content type of the row in Template Editor

2.

The attribute hierarchy in Template Editor

3.

Customizable comments, such as the tab name in the user-defined
attributes dialog box

4.

The name of the user-defined attribute, must be the same as in the
objects.inp file

See also
Add user-defined template attributes to Template Editor (page 21)
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Add comments to user-defined template attributes (page 22)
Add hierarchy to user-defined template attributes (page 23)

Add user-defined template attributes to Template Editor

This example shows how to add your own user-defined attributes to the
attribute tree in Template Editor.

Before you start, add your user-defined attribute to the objects.inp file. For
example, you might add an attribute named MY_ATTRIBUTE to the userdefined properties of drawings.

1.

Open the contentattributes_userdefined.lst file in a text editor.

2.

Save the file with an appropriate name, for example
MY_contentattributes_userdefined.lst, in the same folder.

3.

Add MY_ATTRIBUTE to the list of attribute names and, define the settings
as follows:

4.

Add MY_ATTRIBUTE to the list of attributes assigned to content types.
Select the content type according to which object the attribute is
associated to in the objects.inp file. In this example, the content type is
DRAWING. Add the attribute in the format
USERDEFINED.<ATTRIBUTE_NAME>.

5.

Save the changes.

6.

Open the contentattributes.lst file.

Templates
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7.

Add the following line in the file:
[INCLUDE MY_contentattributes_userdefined.lst]

8.

Save the changes.
The attribute is shown in the attribute tree in Template Editor, under
DRAWING > USERDEFINED:

See also
User-defined template attributes (page 19)

Add comments to user-defined template attributes

You can add your own comments to the user-defined attibutes in the Template
Editor attribute tree.
1.

Open your copy of the contentattributes_userdefined.lst file.
For example, MY_contentattributes_userdefined.lst. Do not
modify the original contentattributes_userdefined.lst file.

2.

Scroll down to the list of attributes assigned to content types.

3.

Add your comment inside quotation marks, after the attribute name.
For example:

4.

Save the changes.
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The comment you added is displayed in the attribute tree in Template
Editor:

See also
User-defined template attributes (page 19)

Add hierarchy to user-defined template attributes

You can add your own hierarchy to the Template Editor attribute tree.
1.

Open your copy of the contentattributes_userdefined.lst file.
For example, MY_contentattributes_userdefined.lst. Do not
modify the original contentattributes_userdefined.lst file.

2.

Scroll down to the list of attributes assigned to content types.

3.

Define the hierarchy in square brackets, between USERDEFINED. and the
attribute name.
For example:

NOTE Notice the periods after the brackets, and between the
hierarchies.
4.

Save the changes.
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The new hierarchy is shown in the attribute tree:

WARNING User-defined attributes are case sensitive. Ensure that you enter the
attribute name using the correct case for all characters.

See also
User-defined template attributes (page 19)
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2

Reports

You can create reports of the information included in models. These could be
lists of drawings, bolts, and parts, for example. Tekla Structures creates reports
directly from the model, so the information is always accurate. Reports can
contain information about selected parts or the entire model.
Tekla Structures includes a large number of standard report templates. Use
Template Editor to modify the existing report templates, or create new ones to
suit your needs. The report templates are located in the folder ..
\ProgramData\Tekla Structures\<version>\environments
\<environment>\system. Report templates have the file name
extension .rpt.
Example

For more information on using templates, see the Template Editor Help or the
Template Editor User's Guide

Reports
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To access Template Editor Help, open Template Editor and click Help -->
Contents .
To open the guide in .pdf format, click Template Editor User's Guide.
See also
Create a report (page 26)
Templates (page 3)

2.1 Create a report
You can include in a report information related to an entire model or only the
selected model objects. Tekla Structures automatically selects the related
assemblies and other objects.
1.

Open the model.

2.

If needed, number the model.
You can create reports without numbering the model. This is useful when
you need to produce draft reports from large multi-user models. Tekla
Structures still warns you if numbering is not up to date.

3.

On the Drawings & reports tab, click Reports .

4.

Select a report template from the list.

5.

Enter the report titles you want to use from the Titles in reports lists.

6.

Enter a new name for the report file in the Name box.

7.

Set the viewing options on the Options tab.
You can select whether to view the report in a dialog box or in a viewer,
and also whether to show the report or not.

8.

Unless you want to create a report of the entire model, select the objects
you want to include in the report using appropriate selection switches and
filters.

9.

Do one of the following:
•

To run a report on the entire model, click Create from all.

•

To run a report on the selected model objects, click Create from
selected.

Tekla Structures creates the report according the settings you defined.
See also
Reports (page 25)
Report settings (page 31)
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Create a report of selected drawings (page 27)
Create a report of nested assemblies (page 27)

2.2 Create a report of selected drawings
You can create a report of several drawings that include the desired model
objects.
1.

Create drawings of the parts you want to include in the report.

2.

Open the model.

3.

On the Drawings & reports tab, click Drawing list.

4.

In the Drawing List, select the drawings you want to include in the report.
TIP To select multiple drawings, hold down Ctrl and then click the
drawings you want to select.

5.

On the Drawings & reports tab, click Reports.

6.

Select a drawing report template from the list.
For example, select Drawing_List or Drawing_Revision_History.

7.

If needed, enter the report titles you want to use under Titles in reports.

8.

If needed, enter a new name for the report file in the Name box.

9.

If needed, set the report options on the Options tab.

10. Click Create from selected.
Tekla Structures automatically selects all the parts in the selected
drawings and includes them in the report.
See also
Report settings (page 31)

2.3 Create a report of nested assemblies
You can produce a list of assemblies, or a report of the parts included in the
assemblies. If the report template has a nested assembly structure, Tekla
Structures displays the assembly hierarchy in the report when you view or
print it.
1.

Open the model.

2.

Select the assemblies you want to include in the report.
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3.

On the Drawings & reports tab, click Drawing list.

4.

Select an assembly report template from the list.
•

Assembly_List: Creates a list of the assemblies

•

Assembly_Part_List: Creates a report of the parts included in the
assemblies

5.

If needed, enter the report titles you want to use under Titles in reports.

6.

If needed, enter a new name for the report file in the Name box.

7.

If needed, set the report options on the Options tab.

8.

Click Create from selected.

See also
Report settings (page 31)

2.4 Show a report
1.

On the Drawings & reports tab, click Drawing list.

2.

Click Browse to locate the report file you want to view.

3.

Click Show to view the report.

See also
Define how reports are displayed (page 28)

2.5 Define how reports are displayed
You can define how reports are displayed. For example, you can have Tekla
Structures open all HTML reports in a web browser. By default, all reports are
displayed in a new dialog box within the Tekla Structures window.
1.

On the Drawings & reports tab, click Reports and go to the Options tab.

2.

Select the report template.

3.

In the Show report list, select With associated viewer.

4.

Click Save in the Report dialog box.

See also
Show a report (page 28)
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2.6 Add tabs to reports
You can associate Tekla Structures to open reports of a certain type in
Microsoft Excel. When you open such reports in Microsoft Excel, the report
template rows might not be divided correctly into cells. To correct this, you can
add tabs between the cells.
1.

Open an existing report template.

2.

Add \t between the text and value fields. For example:

3.

Save the report.
The output in Microsoft Excel:

The output in a text editor:
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TIP Alternatively, you can use a comma or semicolon as a delimiter between the text
fields. However, the default delimeter may vary between users, and the output
might not be readable in all text editors.

See also
Show a report (page 28)

2.7 Print a report
You can print a report from the Reports dialog box or through the File menu.
1.

2.

Do one of the following:
•

On the Drawings & reports tab, click Reports, and then click Print

•

On the File menu, click Printing --> Print reports .

Use the Browse button to display the Select file dialog box, where you
can give the folder and file name of the report.
By default, Tekla Structures uses the Report files (*.xsr) filter to show
Tekla Structures reports only.

3.

If needed, modify the print settings:
•

To change the report font and font style, click Select.
In this dialog box, you can only change the font and font style, the font
size is fixed to 12. One way to change the font size is to open the
created report in a text editor and change the font size there. The
default font can be changed with the advanced option
XS_PRINT_REPORT_FONT.
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•
4.

To set printer-specific options such as paper size and orientation, click
Printer setup

Click Print.

2.8 Report settings
Use the Report dialog box to check or change the report settings.
Option

Description

Report: Report templates

Lists all the available report
templates.

Report:Titles in reports

Optional report titles.
You can enter up to three report
titles. All the titles are not used in
every standard report. Title1, for
example, is used to show phase
information in the Assembly_list
report.

Report: Browse

Use to change the folder where the
report will be stored. By default,
reports are stored in the current
model folder.

Show

Shows the selected report.

Print

Prints the selected report.

Create from all

Creates a report from all objects in
the model using the selected
template.

Create from selected

Creates a report from the objects you
have selected using the selected
template.

Options: Show report

Defines how Tekla Structures displays
reports.
On dialog displays the report in a
new window.
With associated viewer displays the
report in the associated program. For
example, you can have Tekla
Structures open all HTML reports in a
web browser.
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Option

Description

Options: Show created report

Defines whether or not the report is
automatically shown on the screen
after it has been created.

See also
Reports (page 25)
Create a report (page 26)
Create a template (page 4)
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Tips for templates and reports

There are some things that you might consider to be able to use templates
and create reports more efficiently.
Click the links below to find out more:
•

Select objects to include in a report using GUIDs (page 33)

•

Useful shortcuts in viewing logs and reports (page 34)

•

Use text type attribute in calculations (page 35)

•

Change value field content to use imperial units (page 35)

•

Define customized date format (page 36)

•

Assembly or cast unit drawing sheet number (page 36)

3.1 Select objects to include in a report using GUIDs
You can select objects to be included in reports by using their GUIDs (globally
unique identifiers).
1.

Create a template that is used for creating the report.
a.

On the File menu, click Editors --> Template Editor .

b.

In Template Editor, click File --> New .

c.

Select Textual template and click OK.

d.

Add a row for the GUID.
•

Click Insert --> Component --> Row .
Select a content type for the row and clicking OK.

•

Click Insert --> Text and enter the text guid:, Guid: or GUID:.
Click OK.
This enables the selecting of objects in the model.
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•

Click Insert --> Value Field . Click a point to define the location of
the field within the row. The Select Attribute dialog box appears
prompting you to select an attribute for the value field.
Select the attribute GUID and click OK.

e.

Add the required amount of other rows in the template.

f.

Click File --> Save As .
Enter a name for the template and browse the folder ..
\environment\<your_environment>\template. Use the file
name extension .rpt.

2.

Create a report based on the report template you saved.
a.

On the Drawings & reports tab, click Reports.

b.

Select the report template you created from the list.

c.

Click Create from all.
Tekla Structures displays the report.

3.

Click a row that contains an GUID number in the report.
Tekla Structures selects the corresponding object in the active model view.

See also
Create a template (page 4)
Create a report (page 26)

3.2 Useful shortcuts in viewing logs and reports
You can zoom to the objects you have selected in a report, and also fit the
work area to the selected objects.
To

Do this

Zoom to the objects selected in a
report

1.

Hold down Z.

2.

Click a row that contains an ID
number.
Tekla Structures zooms to the
corresponding objects in the
active model view.

Fit the work area to include only the
objects selected in a report
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1.

Hold down F.

Useful shortcuts in viewing logs and reports

To
2.

Do this
Click a row that contains an ID
number.
Tekla Structures zooms to the
corresponding objects in the
active model view.

See also
Show a report (page 28)

3.3 Use text type attribute in calculations
Change text to numeric format
double(GetValue("ASSEMBLY_TOP_LEVEL"))
Change into correct format for calculation (double=decimals)
format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)
Add all above into calculation formula
format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)+15000
Another example of the same for part elevation
(double(GetValue("TOP_LEVEL"))(double(GetValue("BOTTOM_LEVEL"))))*1000

3.4 Change value field content to use imperial units
Advanced option to check if imperial units are in use:
GetValue("ADVANCED_OPTION.XS_IMPERIAL")==1
Translated string call for multi lingual text:
GetValue("TranslatedText("albl_Diameter_")")
Formatting of units:
format(GetValue("DIAMETER"),"Length","inch-frac", 1/16)
format(GetValue("DIAMETER"),"Length","mm", 1)
Combine all above in a rule:
if GetValue("ADVANCED_OPTION.XS_IMPERIAL")==1 then
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GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","inch-frac", 1/16) + "
Inches"
else
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","mm", 1)+" mm"
endif

3.5 Define customized date format
Use mid function to find year, month and day:
mid("","","") string, offset, n
year:
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
month:
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
days:
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")
Combine all above in rule:
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")

3.6 Assembly or cast unit drawing sheet number
Use match function to find "-" character
match(GetValue("NAME_BASE"),"*-*")
Use of mid function to return only characters after "-"
mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
Combine all above in rule
if (match(GetValue("NAME_BASE"),"*-*"))
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then mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
else ""
endif
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Disclaimer

© 2016 Trimble Solutions Corporation and its licensors. All rights reserved.
This Software Manual has been developed for use with the referenced
Software. Use of the Software, and use of this Software Manual are governed
by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other
warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the Software.
All information set forth in this manual is provided with the warranty set forth
in the License Agreement. Please refer to the License Agreement for important
obligations and applicable limitations and restrictions on your rights. Trimble
does not guarantee that the text is free of technical inaccuracies or
typographical errors. Trimble reserves the right to make changes and
additions to this manual due to changes in the software or otherwise.
In addition, this Software Manual is protected by copyright law and by
international treaties. Unauthorized reproduction, display, modification, or
distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.
Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve,
Fastrak and Orion are either registered trademarks or trademarks of Trimble
Solutions Corporation in the European Union, the United States, and/or other
countries. More about Trimble Solutions trademarks: http://www.tekla.com/
tekla-trademarks. Trimble is a registered trademark or trademark of Trimble
Navigation Limited in the European Union, in the United States and/or other
countries. More about Trimble trademarks: http://www.trimble.com/
trademarks.aspx. Other product and company names mentioned in this
Manual are or may be trademarks of their respective owners. By referring to a
third-party product or brand, Trimble does not intend to suggest an affiliation
with or endorsement by such third party and disclaims any such affiliation or
endorsement, except where otherwise expressly stated.
Portions of this software:
D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights
reserved.
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EPM toolkit © 1995-2004 EPM Technology a.s., Oslo, Norway. All rights
reserved.
Open CASCADE Technology © 2001-2014 Open CASCADE SA. All rights
reserved.
FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.
Teigha © 2003-2014 Open Design Alliance. All rights reserved.
PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.
FlexNet Copyright © 2014 Flexera Software LLC. All Rights Reserved.
This product contains proprietary and confidential technology, information
and creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission of
such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited.
Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or
rights under any Flexera Software LLC intellectual property rights, whether by
estoppel, implication, or otherwise.
To see the third party licenses, go to Tekla Structures, click File menu --> Help
--> About Tekla Structures and then click the 3rd party licenses option.
The elements of the software described in this Manual are protected by
several patents and possibly pending patent applications in the United States
and/or other countries. For more information go to page http://
www.tekla.com/tekla-patents.
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