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Conventions used in this guide
Typographical
conventions

The following typographical conventions are used in this guide:
Font

Usage

Bold

Any text that you see in the user interface appears in bold.
This font is used, for example, for window and dialog box
titles, box and button names, and list items.

Italic bold

New terms are in italic bold when they appear in the
current context for the first time.

Monospace

Extracts of program code, HTML, or other material that you
would normally edit in a text editor, appear in monospaced
font.
This font is also used for file names and folder paths, and
for any text that you should type yourself.

Noteboxes

The following types of noteboxes are used in this guide:

A tip might introduce a shortcut, or suggest alternative ways
of doing things.

A note draws attention to details that you might easily
overlook. It can also point you to other information in this
guide that you might find useful.

You should always read very important notes and warnings,
like this one. They will help you avoid making serious
mistakes, or wasting your time.

This symbol indicates advanced or highly technical
information that is usually of interest only to advanced or
technically-oriented readers.
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About Symbol Editor

Symbol Editor is for creating, modifying and managing symbols and symbol files
in your products.
Find out more:
Main features of Symbol Editor (7)
What are primitives? (7)
What are symbols? (8)
What are symbol files? (9)

1.1 Main features of Symbol Editor
With Symbol Editor you can do the following:

•
•
•
•
•
See also

View and modify symbol and font files.
Create symbols whose line, color, fill or other properties are determined by
the product at run-time when the symbol is used at run-time.
Fine-tune the drawing order of the symbol primitives.
Import graphics from AutoCAD and MicroStation files.
Use a background image as a drawing aid to draw a symbol that is available
only in bitmap format.

Symbol files (19)
Modifying primitive attributes (39)
Modifying transparent primitives (42)
Importing AutoCAD or MicroStation files (47)
Using a bitmap file as a background image (48)

1.2 What are primitives?
Primitives are the building blocks of symbols.
A symbol is made up of primitives and their combinations such as lines,
polygons, arcs, circles, rectangles, filled areas, and text.
Primitives have properties such as line color, fill color or size. The properties of
the primitives determine the final appearance and are defined with attributes.
See also
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Symbol primitives (29)
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1.3 What are attributes?
Attributes define various properties of symbols in Symbol Editor. Attributes
determine things such as the size, color, font and output options of a primitive.
You can modify attributes through primitive-specific property dialog boxes.
The attributes can be fixed in the symbol file or they can be defined at run-time by
the product. The run-time defined attributes are called transparent attributes.
Transparency allows the product to display the symbol, for example, in different
colors for different contexts on the screen.
Here are the terms you should be familiar with.
Term

See also

Description

Current attributes

Attributes of the currently selected
primitive i.e. properties of line, fill or
font. Attribute values can be fixed or
transparent.

Default attribute value

If you select the Default value for an
attribute instead of using one of Symbol
Editor’s preset values or a productspecific value, you make the attribute
transparent, and the product determines
the value for this attribute at run-time.

Fixed attributes

A fixed attribute value is specified in
Symbol Editor. It applies to the selected
primitive and all the primitives below the
selected one in the Primitive List down to
a primitive that defines another fixed
value. Fixed values override transparent
values

Selection attributes

Attributes of the selected primitive.

Transparent attributes

A transparent attribute is specified by
the product when it uses the symbol. In
Symbol Editor transparent attributes
appear in Symbol Editor default values
and do not have an effect on the final
symbol.

Opening the attributes dialog box (39)
Setting attributes for new primitives (40)
Making an attribute transparent (40)
Modifying line color, type and width (41)
Modifying fill color and type (41)
Modifying font color, type and dimensions (42)

1.4 What are symbols?
Symbols are used for a variety of different purposes, for example to represent
parts used in a construction assembly, to denote electrical network items such as
distribution stations or utility poles; or to represent buildings, highways or parks.
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You create symbols with Symbol Editor and save them in a symbol file with the
file extension .sym.
You use symbols in your product. The output options of symbols may vary
between different products. Basically symbols can be output on the screen, to a
printer or to a file.
See also

Symbols (23)

1.5 What are symbol files?
A symbol file is a collection of individual symbols. A symbol file can contain up to
256 symbols. Individual symbols are identified with numbers from 0 to 255.

NOTE: Do not modify the standard symbol files delivered with
your product. If you need to modify any symbols, copy the
original symbol file and work on the copy and keep the
original symbol file intact.
See also

9

Symbol files (19)
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2

User interface overview

This is an overview of the Symbol Editor user interface and its basic features.
Find out more:
Interface components (11)
Setting up the drawing grid (14)
Symbol Editor windows (15)

2.1 Interface components
This is an overview of the Symbol Editor user interface components.
1. The title bar displays the Symbol Editor program name and the name and
path of the currently loaded file. If no file is open at the moment, it displays
the text *New file*. The menu bar contains program commands.
2. The toolbars are shortcuts to the most common file, drawing and modifying
operations.
3. The Library workarea.
4. The Edit workarea.
5. The Value bar.
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6. The Status bar.

Find out more:
Library workarea (12)
Edit workeara (13)
Value bar (13)
Status bar (13)
Toolbars (14)

Library workarea
The Library workarea shows the contents of the current symbol file, so you can
select a symbol to modify. There are 256 symbol slots, indexed from 0 to 255,
each containing a single symbol.
Symbols are identified by the index number of the slot. Click a symbol in the
library to see the index number in the Status bar.
See also

Creating a new symbol (24)
Selecting a symbol to modify (24)
Cutting, copying, pasting and deleting symbols (26)
Status bar (13)
Arranging symbols (25)
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Edit workeara
The Edit workarea shows the symbol that you have selected in the Library workarea
so you can create new primitives or modify the existing ones. The sizes and
distances are measured in world units.
The size of the Edit workarea is 2x2 world units. The coordinate system is a regular
Cartesian coordinate system:
the origin (x=0 and y=0) is in the center of the workarea
x is the horizontal distance from the origin in world units
y is the vertical distance from the origin in world units
values increase up and right and decrease down and left from the origin.

•
•
•
•

The world units do not determine the final size of the symbol. Instead, they define
the proportions so you can enlarge or reduce the symbol in your product with a
constant scaling rate, or set the size in pixel units.
For more details on using symbols in your product, refer to the product
documentation.
See also

Symbol primitives (29)
Modifying the text primitive size (36)

Value bar
The Value bar appears below the workareas in the Symbol Editor main window.
You can view and modify the fields that describe the location, size and some
primitive-specific properties of the primitive that you have selected in the Edit
workarea.
Field

See also

Description

X

Sets the X-coordinate of the selected primitive’s starting
point.

Y

Sets the Y-coordinate of the selected primitive’s starting
point.

X2

Sets the X-coordinate of the selected primitive’s ending
point.

Y2

Sets the Y-coordinate of the selected primitive’s ending
point.

B/R

Applies only to lines, arcs and circles. Sets the bulge
factor if a line or an arc is selected, or radius if a circle is
selected.

Angle

Applies only to text primitives. Sets the rotation angle of
the selected text primitive.

Text

Applies only to text primitives. Sets the text string of the
selected text primitive.

Modifying the text primitive string (36)

Status bar
The Status bar appears at the bottom of the main window. As you move the mouse
pointer in the main window, you see:

•
13
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•
•

the index number of the symbol that the mouse pointer is on
x- and y-coordinates of the mouse pointer in the Edit workarea.

Toolbars
You can select the most common file and modification operations from the
toolbars in the Symbol Editor main window.
To view or hide the File toolbar, click View > Toolbars > File.
To view or hide the Primitive toolbar, click View > Toolbars > Primitive.
A check mark in front of the toolbar name indicates that the toolbar is visible.

2.2 Setting up the drawing grid
This covers the options in Symbol Editor that allow you to customize drawing grid
options, such as specifying the dimensions, visibility and dynamics of the drawing
grid.
Find out more:
Activating the grid (14)
Setting grid size and pick tolerance (14)
Showing or hiding the grid (15)

Activating the grid
The drawing grid is an aid for drawing primitives in the Edit workarea. When the
grid is active, each click snaps to the nearest grid point, so you can easily draw
regular shapes.
To activate or deactivate the grid, click Options > Grid > Active.
A check mark in front of the option indicates that the grid is activated.
See also

Setting grid size and pick tolerance (14)
Showing or hiding the grid (15)
Snapping a primitive to the grid (38)

Setting grid size and pick tolerance
Set the grid size and the pick tolerance in order to facilitate the drawing of
symbols and to customize the drawing interface.
To set the size of the drawing grid and the tolerance in picking operations:
1. Click Edit > Preferences... to open the Preferences dialog box.
2. In the Pick section drag the scale pointers or type in new values for grid size
and tolerance.
Set the distance between the grid points in the Edit workarea in world units.
The distance can be 0,01-0,20 units.
Set how close to a grid point you have to click in order to snap to it. The
tolerance is given in pixel units, and it can be 1-20 screen pixels.
3. Choose one of the following to end the operation:
• Click OK to save the settings.
• Click Cancel to discard the changes.
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•

Click Apply to retain the current settings.

Grid settings are saved across sessions.
See also

Activating the grid (14)
Showing or hiding the grid (15)
Snapping a primitive to the grid (38)
Selecting multiple primitives with one click (33)

Showing or hiding the grid
Activating the grid does not automatically make it visible. On the other hand, the
grid may be visible without being active.
To show or hide the grid, click Options > Grid > Visible.
The check mark next to the option indicates that the grid is visible.
See also

Activating the grid (14)
Setting grid size and pick tolerance (14)

2.3 Symbol Editor windows
The Symbol Editor main window displays the symbols of the currently loaded file
in the Library workarea and if you select a symbol you can view and modify it in the
Edit workarea. You can open one file at a time. You can create zoom windows from
either one of the workareas in order to work with symbol details. Here you will
find out more about zoom windows and browsing in Symbol Editor windows.
Find out more:
Creating a new zoom window (15)
Panning (16)
Zooming in and out (16)
Browsing through the view history (17)
Restoring the original view (17)
Turning a zoom window into magnifier (17)

Redrawing a window
Redrawing an active Symbol Editor window is useful if you are working on a slow
computer and cannot use the automatic redraw option.
To redraw the active main window, click Misc > Redraw (Ctrl + L).
The windows are then redrawn.

Creating a new zoom window
You can create independent zoom windows for both Symbol Editor workareas.
This allows you to modify a symbol in an enlarged workarea. The zoom window
functionality is inherited from the workarea.
In the Library workarea window you can select symbols. In the Edit workarea window
you can modify symbols.
To create a new zoom window:
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1. Click the New Zoom Window button.
2. Then do one of the following:
• Drag over the area you want to view in the new window.
• Click a symbol, centering the display around the point you click.
The zoom window opens and displays the selected area or symbol.

See also

Zooming in and out (16)

Panning
Panning is the easiest way to position the view in a Symbol Editor window.
To pan in a zoom window:
1. Click the Pan button in the Zoom toolbar.
2. Drag in the zoom window to pan, or click to set the center point of the viewing
window.
See also

Restoring the original view (17)

Zooming in and out
Enlarge the current zoom window to see symbols in more detail.
To enlarge the display in the current zoom window:
1. Click the Zoom In button in the Zoom toolbar.
2. Drag over the area you want to zoom in, or click to zoom in to the next preset
percentage.
The display is centered around the point you click.
To zoom out and reduce the display in the current zoom window:
1. Click the Zoom Out button in the Zoom toolbar.
16
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2. Click to zoom out to the previous preset percentage.
The display is centered around the point you click.
See also

Restoring the original view (17)

Browsing through the view history
Browse through history of your actions when you need to review your work. You
must have a zoom window open in order to view the history.
Do the following:

•
•
See also

Click the Previous View button to go forward in the viewing history in the zoom
window.
Click the Next View button to go forward in the viewing history in the zoom
window.

Creating a new zoom window (15)

Restoring the original view
Click the Original View button in the zoom window to return to the original view in a
zoom window.
The zoom window view will be restored to what it was when you first opened that
specific zoom window.
See also

Creating a new zoom window (15)

Turning a zoom window into magnifier
You can turn a zoom window into a magnifier and magnify a part of either the
Library or the Edit workarea in the zoom window.
You can magnify only one workarea at a time, i.e. the workarea that is displayed
in this zoom window.
To turn a zoom window into a magnifier:
1. Click the Magnifier button in the Zoom toolbar.
2. Move the mouse into the workarea displayed in the zoom window. The view in
the zoom window changes as you move the mouse.
3. Click to end the command.
See also

Browsing through the view history (17)
Restoring the original view (17)

2.4 Setting the environment path for fonts
Use an environmental variable to specify the location of fonts that will be used in
Symbol Editor.
1. Click Edit > Preferences. This opens the Preferences dialog box.
2. Click ... to open a dialog box to specify the folder.

17

User interface overview

3. Choose the folder and click OK.
Symbol Editor loads the fonts immediately and you can use them in your symbol.
See also
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Setting a font list for the symbol file (19)
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3

Symbol files

This is an overview of symbol files and discusses how they are created and
modified.
Find out more:
Setting a font list for the symbol file (19)
Creating a new symbol file (20)
Opening a symbol file (21)
Saving a symbol file (21)

3.1 Setting a font folder in Symbol Editor
Symbol Editor can access only the font files in the same directory as the program
file SymEd.exe or in the directory specified with the \DXK_Fontpath environment
variable.
You can also select the by setting the preferences.
1. Click Edit > Preferences.
The Preferences dialog box opens.
2. Click ... to open the location from which you want to select the folder.
3. Select the folder and click OK.
You have to restart Symbol Editor in order for the preferences to take effect.

Symbol Editor does not support TrueType, OpenType or
PostScript font technologies.

See also

Setting a font list for the symbol file (19)

3.2 Setting a font list for the symbol file

19

Symbol files

Each symbol file must define a font list that determines the fonts to use with text
primitives. Symbol Editor accepts only the proprietary font files (*.FON). They are
delivered with your product, for example romsim.fon and fixfont.fon. You can use
up to 20 different fonts in a symbol file.
If you do not define the font list, you can use only the default font of your product.
We recommend that you set the font list before you create symbols and use
those fonts with your text primitives.
To set or modify the font list of the currently open symbol file:
1. Click Misc > Font List. This opens the Font List dialog box.
2. In the Name column, click on the line that you want to modify.
The number in the left most column is the font index.
3. Type in the name of the font, for example "romsim" or "fixfont".
The name must be exactly the same as the base name of the corresponding
font file.
4. Repeat steps 2 and 3 to define all the fonts that you want to use in symbols of
the current symbol file.
5. Click Close.
Symbol Editor loads the fonts immediately and you can use them in your symbol.
Symbol Editor can access only the font files in the same directory as the program
file SymEd.exe or in the directory specified with the \DXK_Fontpath
environment variable.

Symbol Editor does not support TrueType, OpenType or
PostScript font technologies.

When using fonts in symbols be sure that your product has the
correct settings for exporting content. Consult your product
documentation for more information.

See also

Modifying font color, type and dimensions (42)

3.3 Creating a new symbol file
It is a rare occasion that you will create a symbol file from scratch.
In case you need to, do the following:
1. Click File > New or click the New button.
This creates a new, empty symbol file. If you already have a symbol file open,
Symbol Editor asks if you want to save changes to the current file.

•
•
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Click OK to save the changes and close the current file before creating a
new file.
Click No to close the current file without saving changes and to create a
new file.

•

Click Cancel to return to work with the current symbol file and cancel the
creation of a new file.

2. Set the font list for the new file.
3. You can now begin to create a new symbol in an empty slot of the symbol file,
by clicking a primitive on the toolbar.
See also

Setting a font list for the symbol file (19)
Saving a symbol file (21)
Creating a new symbol (24)

3.4 Opening a symbol file
Open a symbol file in order to modify symbols and primitives.
To open a symbol file:
1. Click the Open button, which opens the file selection dialog box.
2. Select the file to open and click OK.
If you already have a file open, Symbol Editor asks if you want to save
changes to the current file. Choose the desired option.
Be sure you have set the font file before getting started.
3. Now you can modify and add to the symbol file.
With Symbol Editor you can also view and modify font files (*.FON).
See also

Setting a font list for the symbol file (19)
Saving a symbol file (21)
Symbols (23)
Symbol primitives (29)
Bitmaps and pictures in Symbol Editor (47)

3.5 Saving a symbol file
Save a file to keep the contents intact.
To save a symbol file:
1. Click the Save button.
To save a symbol file with a new name, location or format:, click File > Save As.

•
•

For a symbol file, add the extension .SYM after the file name.
For a font file, add the extension .FON after the file name.

2. When you save the file for the first time, the file selection dialog box opens so
you can specify the name and location for the file.
If you specify an existing file name, Symbol Editor will overwrite the existing
file without a warning. Make sure all files you want to keep intact are writeprotected (read-only).
3. Click OK.
See also

Creating a new symbol file (20)
Opening a symbol file (21)
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Symbols

Here you will find out more about creating and modifying symbols.
Find out more:
Using symbols in products (23)
Selecting items in Symbol Editor (23)
Creating a new symbol (24)
Selecting a symbol to modify (24)
Deselecting a symbol (25)
Arranging symbols (25)
Magnifying and modifying a symbol (26)
Cutting, copying, pasting and deleting symbols (26)

4.1 Using symbols in products
Use Symbol Editor files in products for creating user interface items. Some
products (Tekla Structures, for example) use symbol files directly, others (Trimble
NIS, for example) use a combination of symbol and presentation files created
with Presentation Editor (PresEd). To find out how your product uses symbol files,
refer to the product documentation.
You can adjust symbols for your own needs by modifying symbol files and
introduce your own customized symbols without making changes in the product.
NOTE: Do not modify the standard symbol files delivered with your product. If you
need to modify any symbols, copy the original symbol file and work on the copy.
Keep the original symbol file intact.

4.2 Selecting items in Symbol Editor
Here you find out more about the options in Symbol Editor that affect selecting
symbols or primitives.
Find out more:
Extending or reducing the amount of selected items (24)
Setting the options for selecting symbols (24)
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Extending or reducing the amount of selected items
In Symbol Editor you can use the common Windows shortcut keys to extend or
reduce the amount of the selected items.
To...

See also

Do this...

Extend the selection by selecting
more items

Hold down the Ctrl key while selecting.

Select several items sequentially

Hold down the Shift key and click the first
and the last item of the sequence that you
want to select. This applies when selecting
items in the Primitive List.

Deselect an item

Hold down the Ctrl key and click a selected
item. To deselect all selected items, click
outside the grid.

Selecting a primitive in the Edit workarea (34)
Selecting a primitive in the Primitive List (34)
Selecting multiple primitives with one click (33)
Selecting primitives partially inside the drag frame (33)

Setting the options for selecting symbols
In Symbol Editor you can specify how to select symbols to modify in the Library
workarea. By default you have to double-click a symbol, but you can also enable
symbol modification after a single click by clicking Options > Single Click Select.
A check mark next to the menu option indicates that it is on, and you can select a
symbol to modify by clicking it once in the Library workarea.

4.3 Creating a new symbol
Create new symbols if they do not already exist in the currently open symbol file.
Be sure you have set the font file before creating a new symbol.
To add a new symbol to the currently open symbol file:
1. Click End Command.
2. Double-click an empty symbol slot in the Library workarea.
A red outline in the slot indicates that you can modify the symbol in the Edit
workarea.
3. Draw the symbol by inserting primitives, importing AutoCAD or MicroStation
files, or to draw a copy of an image in a bitmap file, use it as a background
image in Symbol Editor.
Save the changes you made in the current file by clicking File > Save.
See also

Bitmap files Symbol Editor can display as background image (48)
Importing AutoCAD or MicroStation files (47)

4.4 Selecting a symbol to modify
Open a symbol file to start modifying symbols.
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To select a symbol to modify:
1. Click End Command.
2. Double-click the symbol you want to modify in the Library workarea.
You can also hold down the Shift key and use the arrow keys to move around
the Library workarea slot by slot.
A red outline in the slot indicates that you can modify the symbol in the Edit
workarea.
If you turn on the Single Click Select option, you will be able to select a symbol to
modify with one click.
See also

Selecting items in Symbol Editor (23)
Magnifying and modifying a symbol (26)

4.5 Deselecting a symbol
Deselect symbols to disable modifying operations.
To deselect symbols:
1. Click End Command.
2. To deselect all symbols, click outside the symbol grid in the Library workarea or
in an empty area in the Edit workarea.
To deselect one symbol, hold down the Ctrl key and click the symbol slot.
Note that if you want to change the symbol that you are modifying in the Edit
workarea, simply select a new symbol to modify.
See also

Selecting a symbol to modify (24)

4.6 Arranging symbols
Arrange symbols in the Library workarea when you want to reorder them according
to your preferences. Note that products identify each symbol by the symbol id,
which is determined by the symbol’s location in the Library workarea.
To arrange symbols do the following:
1. Click End Command.
2. Click the symbol that you want to move to a different slot. A black outline
around the selection indicates that you can proceed.
3. Drag the selected symbol to the desired slot. You must start dragging on top
of the symbol, or you will end up making an area selection.
If you select several symbols, other symbols are moved with the one that you
drag, keeping the relations between slots intact.

Arranging symbols also changes the symbol ids in Symbol
Editor and in the products that use the symbol library in
question. This will affect the output in your product,

See also
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4.7 Magnifying and modifying a symbol
Enlarge a symbol when you need to see it in more detail.
To enlarge the symbol view:
1. Select the symbol you want to modify.
2. Create a zoom window that displays the Edit workarea.
3. Resize the zoom window to suit your needs.
Take care that you can see the drawing tools of the Symbol Editor main
window.
4. Zoom in and pan the view in the zoom window to your liking.
5. Modify the symbol in the zoom window. You can select drawing tools and
menu commands from the Symbol Editor main window, and select, insert
and modify primitives in the zoom window.
See also

Symbol Editor windows (15)

4.8 Cutting, copying, pasting and deleting symbols
You can cut or copy symbols and paste them into another location. Symbol Editor
saves the most recently cut or copied symbol in the symbol cut buffer. Symbol
Editor maintains cut buffers until you exit the program. You can copy symbols
across symbol files by opening symbol files during a Symbol Editor session.
Delete a symbol from a file when you no longer need it.
To cut, copy, paste and delete symbols, do any of the following:
To...
Cut a symbol

Do this...
Select the symbol and click the Cut button.
If you want to delete a symbol without adding it
to the cut buffer, click the Delete button.

See also

Copy a symbol

Select the symbol and click the Copy button.

Paste a symbol

To paste a symbol, click the Paste button, and
select a target slot in the Library workarea or vice
versa.

Delete a symbol

To delete a symbol, select a symbol in the
Library workarea and click the Delete button.

Selecting items in Symbol Editor (23)
Selecting a symbol to modify (24)
Cut buffer (26)

Cut buffer
All cut or copied objects (whole symbols or primitives) are stored in the Symbol
Editor cut buffers. They can be retrieved in Symbol Editor with the Paste
command. The Library workarea and the Edit workarea both have their own cut
buffers that are not connected to each other. If you cut or copy a whole symbol in
the Library workarea you can only paste it into another symbol slot. If you cut or
copy individual primitives you can only paste them into the Edit workarea.
See also
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Cutting, copying, pasting and deleting primitives (35)
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Here you will find out more information about inserting and modifying primitives
and primitive attributes.
Find out more:
Symbol Editor primitives (29)
The Primitive List (30)
Inserting primitives (32)
Selecting primitives (33)
Modifying primitives (34)
Modifying primitive attributes (39)
Modifying transparent primitives (42)

5.1 Symbol Editor primitives
Individual primitives are basic geometric shapes: lines, arcs, circles, text strings
and filled areas.
Primitive groups are shapes that consist of primitives: rectangles (four lines),
polylines and polygons (groups of lines) and free forms (groups of lines and arcs).
The primitives of a symbol are listed in the Primitive List. Use this list as an aid
while drawing and modifying primitives.
If you want to draw with the help of the grid, ensure the grid is active.
Here is a list of the primitives and any exceptions that apply to them. To insert
primitives, click the related toolbar button.
Primitive

Notes

Line

Click at both ends of the line or insert by
dragging.

Polyline

Move the mouse and click to define each vertex
point, double-click to end drawing.
The lines building the polyline or polygon appear
in the Primitive List as separate line primitives. To
modify the attributes of the polyline or polygon,
select all of its lines.
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Primitive
Rectangle

Notes
Click to give two opposite corner points or draw
by dragging.
The lines building the rectangle appear in the
Primitive List as separate primitives. To modify the
rectangle, you must modify the separate lines.

Circle

Click to define the center point and click to
define the radius. You can also draw by dragging.

Arc

Click at both ends of the arc, then move the
mouse and click to define the bulge of the arc.

Filled rectangle

Insert the same way as a Rectangle. A filled
rectangle appears in the Primitive List as a "Fill
area".

Filled circle

Insert the same way as a circle. A filled circle
appears in the Primitive List as a "Fill area".

Filled area

Click to define a vertex point, and continue until
you have clicked all vertex points.
If you want to arch the line starting from the
most previously given vertex, do not click but
drag to give the next vertex point. This both
arches the line and inserts the new vertex. The
point where you start dragging becomes the next
vertex point. Click the starting point to finish
drawing.

Text

See also

Enter text into the dialog box that appears and
click OK. Double-click in a symbol slot to define
the lower left corner of the text.

Activating the grid (14)
Setting a font list for the symbol file (19)
Making a fill area from lines (35)
Modifying the text primitive string (36)
Modifying the text primitive size (36)
Making lines from a fill area (35)
Rotating primitives (38)
Modifying line color, type and width (41)
Modifying font color, type and dimensions (42)

5.2 The Primitive List
The Primitive List displays the symbol primitives that appear in the Edit workarea.
Symbol Editor adds new primitives at the end of the list as you draw them.
Transparent primitives are effective only when they appear at the top of the list.
You can use the list as an aid when selecting primitives to modify or when
arranging the transparent primitives at the top of the list after drawing them.
Symbol Editor updates the primitive list automatically when you create or delete
primitives.
Find out more:
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Displaying the Primitive List (31)
Arranging primitives in the list (31)

Displaying the Primitive List
To display the primitive list of the current symbol, click Misc > Primitive List.
For example, when you create a rectangle, Symbol Editor adds four line primitives
to the list. The following shows an example of the Primitive List dialog box
displaying three fill areas:

See also

Arranging primitives in the list (31)
Selecting a primitive in the Primitive List (34)

Arranging primitives in the list
The order of primitives in the Primitive List has a significant effect on their
appearance. Transparent primitives are effective only if they appear at the top of
the list before primitives that have fixed attributes. Symbol Editor adds new
primitives at the end of the list as you draw them so you may need to arrange
their order in the list later on.
To arrange the order of primitives in the current symbol:
1. Click Misc > Primitive List to display the list of primitives in the current symbol.
2. Select the primitive that you want to order.
The selection is highlighted both in the Primitive List and in the Edit workarea.
3. Order the selected primitive by moving it up or down in the list by clicking the
Move Up or Move Down arrow.
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If you select an existing primitive before you draw a new one, Symbol Editor adds
the new one in the Primitive List before it.
See also

Selecting primitives (33)
Opening the attributes dialog box (39)
Making an attribute transparent (40)

5.3 Inserting primitives
Find out more about inserting primitives.
Find out more:
Inserting a primitive (32)
Draw several primitives running with one tool (32)
Draw several primitives running with all tools (33)

Inserting a primitive
Insert primitives to complete the design of the symbol you are working on.
To insert primitives in the selected symbol:
1. Select the primitive you want to insert from the Primitive toolbar.
2. Drag or click to specify the size for the primitive in the Edit workarea.
The definition of starting point and ending point depends on the primitive
type.
Note that you can rotate line, arc and text primitives while dragging.
3. If you use both transparent and fixed primitives, arrange the Primitive List so
that the transparent ones are at the top of the list, and fixed primitives after
them.
See also

User interface overview (11)
Symbol Editor primitives (29)
Setting attributes for new primitives (40)
The Primitive List (30)
Cutting, copying, pasting and deleting primitives (35)

Draw several primitives running with one tool
If the continuous drawing mode is switched off, you must repeatedly click a
primitive button in order to draw new primitives.
You can make a single drawing tool of the Primitive toolbar temporarily
continuous. This way you can draw several primitives of the same type in
succession without selecting the tool again.
To turn continuous drawing on and then draw the same primitive repeatedly:
1.
2.
3.
4.
5.
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Select an empty slot in the symbol file.
Select the primitive you want to draw from the Primitive toolbar.
Click Misc > Continuous.
Draw the primitives.
Click End Command to end continuous drawing.
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If you click another primitive in the toolbar, continuous drawing is turned off.
See also

Draw several primitives running with all tools (33)

Draw several primitives running with all tools
You can draw several items in succession with any tool in the Primitive toolbar
without having to reselect it when the continuous drawing mode is on.
When continuous drawing is on, you must click the End Command button or press
Esc to end the current command before you can select symbols or primitives to
modify.
To turn continuous drawing on and then draw different types of primitives:
1. Click Options > Continuous.
The check mark next to the option indicates that the continuous drawing is
on.
2. Select an empty slot in the symbol library.
3. Select the primitive you want to draw from the Primitive toolbar.
4. Draw the primitives in the Edit workarea, using as many primitive types as you
require.
5. Click End Command to end continuous drawing.
6. Save the symbol file.
See also

Draw several primitives running with one tool (32)

5.4 Selecting primitives
Here you find out more on how to select and deselect primitives.
Find out more:
Selecting multiple primitives with one click (33)
Selecting primitives partially inside the drag frame (33)
Selecting a primitive in the Edit workarea (34)
Selecting a primitive in the Primitive List (34)

Selecting multiple primitives with one click
To pick multiple primitives with one mouse click, click Options > Pick > Multiple.
A check mark next to the menu option indicates that the multiple pick option is
on, and a single mouse click in the Edit workarea selects all primitives within the
pick tolerance, not only the nearest one.
See also

Selecting primitives partially inside the drag frame (33)
Setting grid size and pick tolerance (14)

Selecting primitives partially inside the drag frame
To select all primitives that are either completely or partially inside the drag
frame click Options > Pick > Partially.
A check mark next to the option indicates that the pick partially option is on, and
primitives that are completely or partially inside the drag frame get selected, not
just the ones that are completely inside.
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See also

Selecting multiple primitives with one click (33)

Selecting a primitive in the Edit workarea
Select primitives in the Edit workarea as a precursor to modifying them.
To select a primitive:
1. Click End Command.
2. Click the primitive that you want to select.
You can also drag to select several primitives inside a rectangular area.
All selected primitives are highlighted and you can see their resize handles.
You can also select a primitive to modify in the Primitive List. This is useful, for
example, when you modify a symbol that is made up of several overlapping
primitives.
See also

Extending or reducing the amount of selected items (24)
Selecting a primitive in the Primitive List (34)

Selecting a primitive in the Primitive List
You can select a primitive to modify in the Primitive List. This is useful when you
modify a symbol that is made up of several overlapping primitives. This also
speeds up your work if you need to arrange the drawing order of primitives.
To select a primitive in the primitive list:
1. Click Misc > Primitive List. This opens the Primitive List dialog box.
2. Click a primitive in the list.
You can also drag to select several subsequent primitives.
Selected primitives are also highlighted in the Edit workarea so you can see their
resize handles.
Click End Command to deselect a primitive.
To deselect all primitives, click outside the symbol grid in the Library workarea or in
an empty area in the Edit workarea.
To deselect one primitive, hold down the Ctrl key and click the primitive that you
want to deselect.
See also

Extending or reducing the amount of selected items (24)
Arranging primitives in the list (31)
Selecting a primitive in the Edit workarea (34)

5.5 Modifying primitives
This section covers the different ways to modify Symbol Editor primitives.
Find out more:
Cutting, copying, pasting and deleting primitives (35)
Making a fill area from lines (35)
Making lines from a fill area (35)
Modifying the text primitive string (36)
Modifying the text primitive size (36)
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Moving a primitive by dragging (37)
Snapping a primitive to the grid (38)
Resizing the primitive by dragging (37)
Moving or resizing primitives with exact coordinate values (37)
Rotating primitives (38)
Modifying the shape of a primitive (38)

Cutting, copying, pasting and deleting primitives
You can cut and copy primitives in Symbol Editor and paste them to another slot
in the same symbol file or in another symbol file. Delete primitives when you no
longer need them.
To...
Cut a primitive

Do this...
Select the primitive and click the Cut button.
If you want to delete a primitive without
adding it to the cut buffer, click the Delete
button.

See also

Copy a primitive

Select the primitive and click the Copy button.

Paste a primitive

Click the Paste button, and click in the Edit
workarea to give the exact insertion point for
the primitive.

Delete a primitive

To delete a primitive, select it in the Edit
workarea and click the Delete button.

Selecting items in Symbol Editor (23)
Cut buffer (26)

Making a fill area from lines
You can convert a sequence of line primitives into a filled area. This is useful, for
example, when you need to group primitives that are imported from AutoCAD or
MicroStation images and treat them as one object.
You can set the fill color and fill type before you select the command.
Do the following:
1. Select the line primitives you want to convert into a filled area. Note that
selected lines must form a closed shape.
2. Click Insert > Fillarea From Lines.
The lines are converted into a fill area.
See also

Setting attributes for new primitives (40)
Making lines from a fill area (35)

Making lines from a fill area
You can convert a filled area to lines.
You can set the line color, type and width of the new line primitives before you
select the command.

35

Symbol primitives

Do the following:
1. Select the fill area primitive you want to convert to line primitives.
2. Click Insert > Lines From Fillarea.
The fill area is converted into lines.
See also

Setting attributes for new primitives (40)
Making a fill area from lines (35)

Modifying the text primitive size
You can modify the size of a text primitive by setting the height or width of a
character.
Before modifying the size you must set the scaling properties of the text primitive.
It can be either scalable or have a fixed pixel size. Scalable text is scaled together
with the rest of the symbol, and pixel-sized text always appears in the given size
regardless of the scaling of the symbol.
To modify the text primitive size do the following:
1. Select the text primitive you want to modify.
2. Click Misc > Current Attributes.
This opens the Selection Attributes dialog box, where you can modify the font.
3. To set the scaling of the text, choose appropriately in the Unit field:
• World sets the text to be scalable. This means that you will use world units
to set the height and the width of text (steps 3 and 4). The characters are
scaled when the symbol is scaled in a product.
• Pixel sets the text to a fixed size. You will use pixel units to set the height
and the width of text (steps 3 and 4). The characters are not scaled in a
product, even though the rest of the symbol would appear scaled. Note
that the view in the Library workarea may appear distorted: the text might
not fit in the symbol slot because the view in there is scaled.
4. In the Height field, type in the new height to apply to the text primitive. The
capital letters inherit the given height and lowercase characters are scaled
accordingly.
5. In the Width field, type in the new width to apply to a single character. Each
character consumes the given amount of space.
See also

Modifying the text primitive string (36)
Snapping a primitive to the grid (38)
Moving or resizing primitives with exact coordinate values (37)

Modifying the text primitive string
Modify the text in a string when you need to make corrections or add or remove
information.
To modify the text string of a text primitive:
1. Select the text primitive.
2. In the value bar at the bottom of the Edit workarea, click in the Text field and
modify the contents.
3. Press Enter to the save changes and update the text.
See also
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Modifying the text primitive size (36)

Moving a primitive by dragging
You can move primitives by dragging them.
Do the following:
1. Click End Command.
2. Select the primitive that you want to move.
3. Middle-drag to move the selection around the Edit workarea.
If you drag with the left mouse button, you must start dragging on top of a
selected object, otherwise you will make a new area selection.
See also

Selecting a primitive in the Edit workarea (34)
Moving or resizing primitives with exact coordinate values (37)

Resizing the primitive by dragging
You can resize symbol primitives by dragging them, but you cannot resize text
primitives in this manner.
To resize primitives:
1. Select the primitive(s) that you want to resize.
2. Hold down the Shift key and drag to resize.
Note that if you use the left mouse button, you must place the mouse pointer
on top of a selected primitive when you start dragging.
If you use the middle mouse button in dragging, you can start resizing
anywhere.
You see a temporary resize box. Resizing starts when you cross any of its borders
and ends when you release the mouse button.
See also

Modifying the text primitive size (36)
Moving or resizing primitives with exact coordinate values (37)

Moving or resizing primitives with exact coordinate values
You can move, resize or reshape primitives by specifying exact coordinate values
in world units.
You can give an exact rotation angle in degrees for text primitives.
Do the following:
1. Click End Command.
2. Select the primitive that you want to modify.
3. Type in the new coordinates in the value bar that appears right below the
workareas of the Symbol Editor main window. Symbol Editor updates the
primitive as you change the values and move to the next field.
See also

Selecting a primitive in the Edit workarea (34)
Moving a primitive by dragging (37)
Resizing the primitive by dragging (37)
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Snapping a primitive to the grid
You can move primitives onto the closest grid point in the Edit workarea.
Do the following:
1. Set the grid size.
2. Select the primitive or primitives that you want to snap to the grid.
3. Click Edit > Snap To Grid.
The selected objects move onto the closest grid points.
Both the starting point and the ending point are placed on the closest grid points
so this may also change the size or proportions of the primitive, especially if its
dimensions are smaller than the distance between grid points. Coordinates are
rounded, the accuracy depends on the grid size.
See also

Setting grid size and pick tolerance (14)
Selecting a primitive in the Edit workarea (34)

Rotating primitives
Rotate the primitives in a symbol when you need to reposition them.
To rotate primitives:
1. Select the primitive(s) that you want to rotate.
2. Hold down the Control key and drag to rotate.
3. Save the file.
Note that if you use the left mouse button, you must place the mouse pointer on
top of a selected primitive when you start dragging. The point where you start
dragging is the anchor point while rotating.
If you use the middle mouse button for dragging, you can start rotating anywhere.
To select the anchor point, middle-click it before you start to rotate by dragging.
You can also rotate a text primitive by typing in a new angle in the value bar that
appears right below the workareas in the main window.
See also

Selecting primitives (33)

Modifying the shape of a primitive
You can modify the shape of a primitive by dragging the resize handles, that
appear when you select the primitive. Corner handles appear in starting and
ending points of the primitive, and curved lines also have a bulge point.
To modify the shape of a primitive:
1. Click a primitive to select it.
Corner handles appear as small boxes, and bulge handles as small circles
within the selected primitive.
2. Move the mouse pointer on a handle.
Drag a corner handle to move a starting, ending or vertex point.
Drag a bulge handle to change the curvature.
The following figure illustrates the handles of a single straight line:
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You can also modify primitive shapes by typing in new coordinates and bulge
values in the value bar.
See also

Selecting a primitive in the Edit workarea (34)

5.6 Modifying primitive attributes
Primitive attributes define the following properties of the primitive:

•
•
•

line width, color and type
fill color and type
font face, color, measurement unit, height, width, slant and thickness

When you modify primitive attributes, be aware that fixed attribute values
override transparent attributes across primitives. You can avoid this by ordering
transparent primitives at the top of the Primitive List.
If you create a symbol file, which contains symbols with
default attributes (read: transparent attributes) and save it as
such; when you use the symbol file in another product, the
settings for symbols in the product will override the attributes
assigned in Symbol Editor.
Find out more:
Opening the attributes dialog box (39)
Setting attributes for new primitives (40)
Making an attribute transparent (40)
Modifying line color, type and width (41)
Modifying fill color and type (41)
Defining a color with the color index (41)
Modifying font color, type and dimensions (42)

Opening the attributes dialog box
You can modify primitive attributes by opening the Selection Attributes dialog box.
Do one of the following:

•
•

Double-click the primitive you want to modify.
Select the primitive you want to modify, and select Misc > Current Attributes.

This opens the Selection Attributes dialog box.
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Modify the attribute values to your liking. Symbol Editor updates the appearance
of the primitive on the screen as you select new values.
See also

Making an attribute transparent (40)
Modifying line color, type and width (41)
Modifying fill color and type (41)
Modifying font color, type and dimensions (42)

Setting attributes for new primitives
When you draw a new primitive, Symbol Editor inserts it with the current
attributes that determine the line, fill or font properties.
To view and modify the current attributes:
1. Double-click on empty area within the Edit workarea
This opens the Current Attributes dialog box.
2. Modify the attribute values.
3. Click Close when you are done.
All new primitives are now added with the given attributes. Be aware that
transparent attributes are overridden if preceding primitives in the Primitive List
have fixed values for those attributes.
If you select the Default value for an attribute instead of using one of Symbol
Editor’s preset values or a product-specific value, you make the attribute
transparent, and the product determines the value for this attribute at run-time.
See also

Opening the attributes dialog box (39)

Making an attribute transparent
Make the attributes of a primitive transparent when you want the product to
adjust the attributes at run-time.
To make an attribute transparent:
1. Double-click the primitive you want to modify. This opens the Selection
Attributes dialog box.
2. Set the value of the attribute that needs to be adjustable to Default.
3. Click Close.
When you are working in Symbol Editor, the default value is displayed with
Symbol Editor’s transparent attribute setting.
Primitives with an outline can have transparent line color, type or width. Any of
the attributes may be transparent, while some of them may be fixed.
Filled primitives can have transparent fill color and type. Both attributes must be
transparent, if you want to use transparency with a filled primitive.
Text primitives can have transparent font color, type and dimensions. All
attributes must be transparent, if you want to use transparency with a text
primitive.
See also

Modifying line color, type and width (41)
Modifying fill color and type (41)
Modifying font color, type and dimensions (42)
Modifying transparent primitives (42)
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Defining a color with the color index
Symbol Editor has eight preset colors, indexed from 0 to 7, which you can apply to
line, fill or font. Some products use a wider selection of colors, with productspecific index numbers.
To set the color index for a primitive attribute:
1. Choose the symbol you want to work with and double-click the primitive you
want to modify.
The Selection Attributes dialog box opens.
2. Determine what you are going to modify: line, fill or font.
3. Type the color index number in the field to the right of the Color list.
4. When you are done, click Close.
5. Save the symbol file.
Note that Symbol Editor may not be able to display product-specific colors
correctly.

Modifying line color, type and width
You can modify the color, line type and line width of lines, arcs, polylines and
circles.
Do the following:
1. Double-click the primitive you want to modify.
This opens the Selection Attributes dialog box.
2. Modify the fields in the Line area of the dialog box.
• Color - Sets the line color. Select from eight (8) preset colors, or use a
product-specific color index.
• Type - Sets the line type. Select a solid line or a dotted line from four
preset dotted lines.
• Width - Sets the line width in pixels.
You can select Default in any field instead of using one of Symbol Editor’s
preset values. This makes the line transparent and thus adjustable in your
product.
The symbol is updated as you make the changes.
3. When you are done, click Close.
4. Save the symbol file.
See also

Defining a color with the color index (41)

Modifying fill color and type
You can modify the fill color and type of fill area primitives.
Do the following:
1. Double-click the primitive you want to modify.
This opens the Selection Attributes dialog box.
2. Modify the fields in the Fill area of the dialog box.
• Color - Sets the fill color as well as the outline color. You can select from
eight (8) preset colors, or use a product-specific color index.
• Type - Sets the fill type. You can select a solid fill or a fill pattern from four
preset patterns.
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You can select Default in any field instead of using one of Symbol Editor’s
preset values. This makes all fill attributes transparent, and thus adjustable
in your product.
The symbol is updated as you make the changes.
3. When you are done, click Close.
4. Save the symbol file.
See also

Defining a color with the color index (41)

Modifying font color, type and dimensions
You can modify the font color, type and dimensions of text primitives.
Do the following:
1. Double-click the text primitive you want to modify.
This opens the Selection Attributes dialog box.
2. Modify the fields in the Font area of the dialog box.
You can select Default in any of the first three fields instead of using one of
Symbol Editor’s preset values. This makes all text attributes transparent, and
thus adjustable in your product.

•
•
•
•
•
•
•

Color - Sets the font color. Select from eight (8) preset colors, or use a
product-specific color index.
Font - Sets the font type. Select from the font list of the current symbol
file.
Units - Defines the measurement unit to apply to this text primitive, world
units or pixel units.
Width - Sets the width of one character in world units or pixels, depending
on the value of the Units field.
Height - Sets the height of one character in world units or pixels,
depending on the value of the Units field.
Slant - Sets the slanting of font, allowing you use italic typeface. Negative
values (from -1 to -11) slant the text to the right.
Thickness - Sets the thickness of font in pixels, allowing you to use bold
typeface.

The symbol is updated as you make the changes.
3. When you are done, click Close.
4. Save the symbol file.
See also

Setting a font list for the symbol file (19)
Defining a color with the color index (41)

5.7 Modifying transparent primitives
When you insert new primitives into a symbol, Symbol Editor automatically uses
transparent line, fill and font. This means that the product can adjust the line, fill
or font properties of the symbol at run-time.
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If you have modified the line, fill or font of any primitive in the symbol, or are
working with an existing symbol, there may be transparency overrides so you
need to make sure that transparency works the way you want in the final symbol.
Here you find out more about transparency.
Symbol Editor settings for transparent attributes do not affect the final
appearance of symbols. products adjust and determine the final appearance,
when symbols with transparent attributes are used.
Find out more:
Setting appearance of transparent attributes (43)
Making a primitive transparent (43)
Removing transparency from a primitive (44)
Highlighting transparent primitives (44)
Troubleshooting transparency problems (45)

Setting appearance of transparent attributes
Symbols that have transparent attributes can be adjusted by your product at runtime. You can test how the symbol will appear at run-time, when you change the
way transparent attributes, (i.e.) adjustable line, fill and font, appear in Symbol
Editor.
To change the way transparent line, fill and font show in Symbol Editor:
1. Click Misc > Transparent Attributes.
This opens the Transparent Attributes dialog box.
2. Modify the attribute values. Symbol Editor updates the appearance of
primitives on the screen as you select new values.
3. Click Close when you are done.
The transparent attribute settings are Symbol Editor’s internal settings so they do
not determine the appearance of the final symbol but assist you when making
primitives transparent and testing how it works. The product sets the final
appearance of tran§ q1 sparent lines, fills and fonts at run-time.
See also

Troubleshooting transparency problems (45)
Making an attribute transparent (40)
Modifying line color, type and width (41)
Modifying fill color and type (41)
Modifying font color, type and dimensions (42)

Making a primitive transparent
You can make a primitive transparent and adjustable when the symbol is used in
your product.
Do the following:
1. Select and double-click the primitive to open the Selection Attributes dialog
box.
2. Decide which attributes should be transparent:
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•

•

•

Primitives with an outline can have transparent line color, type or width.
Any of the attributes may be transparent, while some of them may be
fixed.
Filled primitives can have transparent fill color and type. Both attributes
must be transparent, if you want to use transparency with a filled
primitive.
Text primitives can have transparent font color, type and dimensions. All
attributes must be transparent, if you want to use transparency with a
text primitive.

3. Modify the primitive attributes to make the selected attributes transparent.
4. Click Close.
5. Click Save to save the symbol file.
See also

Making an attribute transparent (40)
Troubleshooting transparency problems (45)

Removing transparency from a primitive
Modify the transparency of a primitive when you want to change how it appears
at run-time.
To remove transparency of a primitive and fix its properties in Symbol Editor:
1. Click Misc. > Transparent Attributes to open the Transparent Attributes dialog box.
2. Select the primitive whose line, fill or font you want to fix so that the product
cannot change it at run-time.
3. Modify the line, fill or font by selecting a pre-defined line, fill or font.
4. Click Close to close the Transparent Attributes dialog box.
5. Save the symbol file.
If transparency of the other primitives does not work the desired way after this
operation, you will have to troubleshoot the problem.
See also

Modifying line color, type and width (41)
Modifying fill color and type (41)
Modifying font color, type and dimensions (42)
Troubleshooting transparency problems (45)

Highlighting transparent primitives
You can use any color or style to highlight the transparent primitives of a symbol
in Symbol Editor. Highlighting does not affect the final symbol in any way but
makes it easy for you to check how transparency works.
Do the following:
1. Select the symbol you want to modify.
2. Click Misc. > Transparent Attributes to open the Transparent Attributes dialog
box.
Modify the settings for transparent line, fill and font so that they differ from
the current appearance of your symbol as much as possible.
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For example, if you want to check which primitives have transparent fill
settings in a symbol that currently appears in black, choose a bright fill color
that makes the transparent fill area primitives stand out. Now you can
concentrate on working with the fill areas that do not act the way you want
them to.
3. Examine the results and make any other modifications as needed.
4. Click Close when you are done to close the dialog box.
Note that saving the file has no effect on the symbol file. When you exit and
restart Symbol Editor the file will exist as it when you opened it in the prior
session
See also

Setting appearance of transparent attributes (43)
Troubleshooting transparency problems (45)

Troubleshooting transparency problems
If symbol transparency does not work in the way that you expected, the problem
is most likely that a fixed line, fill or font attribute is overriding the transparency.
To remove the overrides and restore the effectiveness of the transparent
primitives:
1. Highlight the transparent primitives of the symbol.
2. Make sure that all the primitives with transparent attributes are at the top of
the Primitive List.
Be aware that transparency overrides can also occur across partially transparent
primitives. A partially transparent primitive has both transparent and fixed
attributes. For example, a line primitive can have a transparent line color while its
line width is fixed. Any primitives that have transparent line width will be drawn
with this fixed width, if they appear below this line primitive in the Primitive List. To
avoid this, list primitives with solely transparent attributes topmost, and
primitives that have both transparent and fixed attributes after them. Primitives
that only have fixed attributes should appear last in the Primitive List.
See also
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6

Bitmaps and pictures in
Symbol Editor

This covers how to use graphics with other file types for symbols. You can import
AutoCAD or MicroStation files and use bitmap pictures as a drawing aid in the
background of the Edit workarea.
Find out more:
Importing AutoCAD or MicroStation files (47)
Mappings and limitations of file imports (48)
Using a bitmap file as a background image (48)

6.1 Importing AutoCAD or MicroStation files
You can use AutoCAD (DXF or DWG) files and MicroStation (DGN) files in Symbol
Editor. Symbol Editor imports the files and converts the contents into primitives
that you can modify.
To import a file:
1. Click File > Import transform to set the scaling and the initial positioning of the
file to import.
2. Enter the values for scaling the imported image and shifting the x and y
coordinates.
• Scale: Type in the scaling rate. A value of 1 means that the image is
imported in its original size. A value of 2 means that the image is
imported twice as large as the original.
• Translate x: Shifts the imported image in a horizontal direction. Negative
values shift the image to the left, and positive values to the right. Values
are in world units.
• Translate y: Shifts the imported image in a vertical direction. Negative
values shift the image down, and positive values up. Values are in world
units.
If the value of both translation fields is 0, the origin of the imported image is
placed on the origin of the Edit workarea.
3. Click OK.
4. In the Library workarea, select the symbol into which you want to import the
image.
5. Click File > Import. This opens the standard file selection dialog box.
47

Bitmaps and pictures in Symbol Editor

6. Select the file to import and click OK.
The image is converted to Symbol Editor primitives that are inserted into the
selected symbol. Scaling and positioning are set according to the settings you
specified in step 2.
You can group the primitives of the image and handle them as one object.
See also

Mappings and limitations of file imports (48)
Making a fill area from lines (35)

6.2 Mappings and limitations of file imports
This describes how AutoCAD and MicroStation files are converted into Symbol
Editor drawing primitives.
Object mappings

Fill type mappings

The following object types are imported from the original file to the symbol: ARC,
LINE, CIRCLE, CELL, CURVE, SHAPE, SOLID, TEXT, TRACE, INSERT, POLYLINE,
LWPOLYLINE, LINESTRING and HATCH.
The fill type of a filled object is converted as follows:
Fill style name in DWG/DXF/DGN file

Text limitations

Other limitations

Fill type in Symbol Editor

NONE

transparent

SOLID

solid fill

SINGLEHATCH

diagonal lineation

DOUBLEHATCH

diagonal lineation

all other fill types

transparent

The fonts used in text objects are mapped to Symbol Editor fonts. This may
slightly distort the font alignment within the text box as the original font geometry
is not available in Symbol Editor.
User-defined line styles and world unit line widths from AutoCAD files are not
imported.

6.3 Using a bitmap file as a background image
You can use a background image in Symbol Editor as a drawing aid to draw a
symbol that is available only in bitmap format. You cannot import bitmap files.
Find out more:
Bitmap files Symbol Editor can display as background image (48)
Setting a bitmap file as the background image (49)
Show or hide background image (49)

Bitmap files Symbol Editor can display as background image
Click File > Background Image to choose a background image.
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A file selection dialog box opens for selecting a bitmap file (GIF, JPEG or TIF) that
you can use as a drawing aid to draw a symbol that is available only in bitmap
format.
The bitmap image will appear as a background for all symbols in the current
symbol file in the modification phase, but it does not show in the final symbols.

Setting a bitmap file as the background image
When a background image is used it does not appear in final symbols. It is
intended as an aid for drawing symbols from bitmap files.
To set a bitmap file as the background image:
1. Click File > Background Image.
The file selection dialog box opens.
2. Select the file you want to use as a background image and click OK.
3. Proceed with drawing the symbol.
The bitmap is displayed in the background of Edit workarea, and it appears there
for all the symbols of the current symbol file.
You can control the visibility of the background image by selecting Options >
Background Image.
See also

Show or hide background image (49)

Show or hide background image
If you have selected a background for a symbol file, it appears in the Edit workarea
for all the symbols of the file.
To show or hide the background image, select Options > Background Image.
A check mark next to this menu option indicates that the background image is
visible.
Note that the background does not appear in zoom windows, regardless of this
visibility setting.
See also
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