Contents

1 Create points........................................................................................................11
  1.1 Create points on a line..................................................................................12
  1.2 Create points on a plane.................................................................................13
  1.3 Create points parallel to two points.............................................................13
  1.4 Create points along the extension line of two points.................................14
  1.5 Create projected points on a line.................................................................15
  1.6 Create points along an arc using center and arc points.............................16
  1.7 Create points along an arc using three arc points......................................16
  1.8 Create points tangent to a circle....................................................................17
  1.9 Create points at any position..........................................................................18
  1.10 Create bolt points.........................................................................................18
  1.11 Create points at the intersection of two lines.............................................19
  1.12 Create points at the intersection of a plane and a line................................19
  1.13 Create points at the intersection of a part and a line..................................19
  1.14 Create points at the intersection of a circle and a line..............................20
  1.15 Create points at the intersection of two part axes.......................................20
  1.16 Import points...............................................................................................21

2 Create construction objects.............................................................................23
  2.1 Create a construction line............................................................................23
  2.2 Create a construction plane..........................................................................24
  2.3 Create a construction circle using center point and radius..........................25
  2.4 Create a construction circle using three points............................................26
  2.5 Modify a construction object........................................................................26

3 Create parts.......................................................................................................29
  3.1 About parts.....................................................................................................29
    Part handles.......................................................................................................30
    Part labels.........................................................................................................31
  3.2 About items...................................................................................................33
    Limitations to items........................................................................................33
  3.3 Create steel parts..........................................................................................34
    Create a steel column......................................................................................34
    Create a steel beam.........................................................................................35
    Create a steel polybeam..................................................................................36
    Create a curved beam.....................................................................................37
    Create a contour plate.....................................................................................38
3.4 Create concrete parts................................................................. 51
  Create a round contour plate...................................................... 38
  Create a bent plate....................................................................... 39
  Create a bent plate by selecting parts........................................ 39
  Create a bent plate by selecting faces....................................... 41
  Modify the bend radius............................................................... 42
  Modify the shape of a bent plate............................................... 44
  Remove curved sections............................................................ 47
  Examples..................................................................................... 48
  Limitations.................................................................................. 49
  Create an orthogonal beam......................................................... 49
  Create a twin profile................................................................. 50
  Create an item........................................................................... 51

4 Modify parts............................................................................... 60
  4.1 Modify the part properties.................................................... 60
  4.2 Modify the position of a part............................................... 61
  4.3 Modify the length of a part.................................................. 62
  4.4 Change the profile of a part................................................. 63
  Use standardized values for profile dimensions......................... 64
  4.5 Change the material of a part.............................................. 65
  4.6 Change the shape of an item................................................ 65
  4.7 Modify the adaptivity of model objects................................. 66
  Define default adaptivity settings............................................. 66
  Modify the adaptivity of an individual model object.................... 66
  4.8 Split parts............................................................................. 67
  Split a straight or curved part or polybeam................................. 67
  Split a plate or slab using a polygon......................................... 67
  4.9 Combine parts...................................................................... 67
  Attach parts to each other......................................................... 68
  Detach an attached part............................................................ 69
  Explode attached parts............................................................. 70
  4.10 Attach parts to each other.................................................. 68
  4.11 Warp concrete parts.......................................................... 70
  Warp a concrete beam using deformation angles....................... 71
  Warp a concrete slab by moving chamfers................................ 71
  Warp a Floor Bay (66) slab....................................................... 72
  4.11 Warp concrete parts.......................................................... 70
  4.12 Camber a part..................................................................... 73

5 Add details to parts.................................................................. 75
  5.1 Create bolts.......................................................................... 76
Create a bolt group ................................................................. 76
Create a single bolt ............................................................... 77
Create bolts using the Auto bolt component ...................... 77
Change or add bolted parts .................................................. 81
5.2 Create studs ........................................................................ 82
5.3 Create holes ....................................................................... 82
Create round holes ............................................................... 83
Create oversized holes ......................................................... 84
Create slotted holes ............................................................. 84
5.4 Create welds ..................................................................... 86
Set the visibility and appearance of welds ......................... 86
Create a weld between parts ................................................ 87
Create a polygon weld ........................................................ 88
Create a weld to a part ........................................................ 89
Weld preparation ................................................................. 89
Prepare a part for welding with a polygon ......................... 90
Prepare a part for welding with another part ..................... 90
Change a weld to a polygon weld ....................................... 91
User-defined weld cross sections ...................................... 91
Define a user-defined cross section for a weld ................... 92
Remove a user-defined cross section from a weld ............... 93
5.5 Create fittings .................................................................. 93
5.6 Create cuts ...................................................................... 94
Cut parts with a line ............................................................ 94
Cut parts with a polygon ..................................................... 95
Cut parts with another part ............................................... 97
5.7 Create part chamfers ....................................................... 98
Chamfer part corners ......................................................... 98
Status of polybeam chamfers ............................................. 99
Chamfer part edges ........................................................... 100
5.8 Add surface treatment ..................................................... 101
Modify surface treatment properties ................................. 102
Add surface treatment to parts ......................................... 102
Add surface treatment to a selected area on a part face .... 103
Add surface treatment to an entire part face ....................... 103
Add surface treatment to all faces of a part ....................... 103
Add surface treatment to cut faces .................................... 104
Surface treatment on chamfered parts ............................... 104
Surface treatment on parts with openings and recesses .... 105
Create new surface treatment options ............................... 106
Tiled surface treatment ....................................................... 107
Create new tile patterns ..................................................... 107
Example pattern definition ................................................. 108
Tile pattern definitions ....................................................... 108
Tile pattern elements ........................................................ 111
Create an unpainted area using the No paint area component 111
5.9 Add a surface to a face .................................................... 113
6 Create assemblies ............................................................. 115
6.1 Create an assembly ........................................................ 115
Create a sub-assembly ....................................................... 116
Use bolts to create assemblies ......................................... 116
Bolt sub-assemblies to an existing assembly..........................................................117
Use welds to create assemblies........................................................................117
Weld sub-assemblies to an existing assembly.......................................................118

6.2 Add objects to assemblies.............................................................................118
   Assembly hierarchy............................................................................................119
   Add parts to an assembly..................................................................................120
   Create a nested assembly................................................................................121
   Join assemblies..................................................................................................121

6.3 Change the assembly main part.................................................................122
6.4 Change the main assembly.........................................................................122
6.5 Remove objects from an assembly.............................................................122
6.6 Check and highlight objects in an assembly.............................................123
6.7 Explode an assembly.....................................................................................123
6.8 Assembly examples.........................................................................................124

7 Create cast units..............................................................................................126
7.1 Define the cast unit type of a part..............................................................126
7.2 Create a cast unit..........................................................................................127
7.3 Add objects to a cast unit.............................................................................127
7.4 Change the cast unit main part...................................................................128
7.5 Remove objects from a cast unit.................................................................128
7.6 Check and highlight objects in a cast unit.................................................129
7.7 Explode a cast unit.......................................................................................129
7.8 Casting direction............................................................................................129
   Define the casting direction of a part..............................................................131
   Show the top-in-form face...............................................................................131

8 Manage pours..................................................................................................133
8.1 Enable the pour functionality......................................................................134
   Disable the pour functionality temporarily....................................................134
8.2 Show concrete structures as continuous..................................................135
8.3 Define the pour phase of a part...................................................................137
8.4 Pour objects....................................................................................................138
   View pour objects............................................................................................139
   Change the color and transparency of pour objects......................................140
   Modify the properties of a pour object.........................................................141
   About the pour type property........................................................................142
8.5 Pour units........................................................................................................143
   Calculate pour units.......................................................................................143
   Check and highlight objects in a pour unit..................................................144
   Inquire a pour unit.........................................................................................144
   Add objects to a pour unit............................................................................145
   Remove objects from a pour unit.................................................................145
   How Tekla Structures attaches objects to pour objects.............................145
8.6 Pour breaks.....................................................................................................146
   Pour break adaptivity......................................................................................148
   Set the visibility of pour breaks.......................................................................148
8.7 Troubleshoot pours.......................................................................................... 153
  View pour errors in a log file............................................................................... 155
  Example: Identify and fix a pour error................................................................. 156
8.8 Example: Create concrete geometry and work with pours............................ 157
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.4</td>
<td>Create a clip plane</td>
<td>188</td>
</tr>
<tr>
<td>12.5</td>
<td>Fly through the model</td>
<td>189</td>
</tr>
<tr>
<td>12.6</td>
<td>Detect clashes</td>
<td>190</td>
</tr>
<tr>
<td></td>
<td>Find clashes in a model</td>
<td>191</td>
</tr>
<tr>
<td></td>
<td>Manage clash check results</td>
<td>192</td>
</tr>
<tr>
<td></td>
<td>Symbols used in clash checking</td>
<td>192</td>
</tr>
<tr>
<td></td>
<td>About clash types</td>
<td>192</td>
</tr>
<tr>
<td></td>
<td>Manage the list of clashes</td>
<td>193</td>
</tr>
<tr>
<td></td>
<td>Search for clashes</td>
<td>196</td>
</tr>
<tr>
<td></td>
<td>Change the status of clashes</td>
<td>197</td>
</tr>
<tr>
<td></td>
<td>Change the priority of clashes</td>
<td>197</td>
</tr>
<tr>
<td></td>
<td>Group and ungroup clashes</td>
<td>198</td>
</tr>
<tr>
<td></td>
<td>View the details of a clash</td>
<td>198</td>
</tr>
<tr>
<td></td>
<td>Add comments to a clash</td>
<td>199</td>
</tr>
<tr>
<td></td>
<td>Modify a clash comment</td>
<td>199</td>
</tr>
<tr>
<td></td>
<td>Remove a clash comment</td>
<td>199</td>
</tr>
<tr>
<td></td>
<td>View the history of a clash</td>
<td>200</td>
</tr>
<tr>
<td></td>
<td>Print a list of clashes</td>
<td>200</td>
</tr>
<tr>
<td></td>
<td>Preview a list of clashes before printing</td>
<td>200</td>
</tr>
<tr>
<td></td>
<td>Set the paper size, margins and page orientation</td>
<td>201</td>
</tr>
<tr>
<td></td>
<td>Open and save clash check sessions</td>
<td>202</td>
</tr>
<tr>
<td></td>
<td>Define a clash check clearance area for bolts</td>
<td>203</td>
</tr>
<tr>
<td>12.7</td>
<td>Diagnose and repair the model</td>
<td>203</td>
</tr>
<tr>
<td>12.8</td>
<td>Find distant objects</td>
<td>205</td>
</tr>
<tr>
<td>13</td>
<td>Number the model</td>
<td>207</td>
</tr>
<tr>
<td>13.1</td>
<td>What is numbering and how to plan it</td>
<td>207</td>
</tr>
<tr>
<td></td>
<td>Numbering series</td>
<td>208</td>
</tr>
<tr>
<td></td>
<td>Plan your numbering series</td>
<td>209</td>
</tr>
<tr>
<td></td>
<td>Assign a numbering series to a part</td>
<td>210</td>
</tr>
<tr>
<td></td>
<td>Assign a numbering series to an assembly</td>
<td>210</td>
</tr>
<tr>
<td></td>
<td>Overlapping numbering series</td>
<td>211</td>
</tr>
<tr>
<td></td>
<td>Identical parts</td>
<td>212</td>
</tr>
<tr>
<td></td>
<td>Identical reinforcement</td>
<td>212</td>
</tr>
<tr>
<td></td>
<td>Define what affects numbering</td>
<td>213</td>
</tr>
<tr>
<td></td>
<td>User-defined attributes in numbering</td>
<td>214</td>
</tr>
<tr>
<td></td>
<td>Family numbers</td>
<td>214</td>
</tr>
<tr>
<td></td>
<td>Assign family numbers</td>
<td>214</td>
</tr>
<tr>
<td></td>
<td>Change the family number of an object</td>
<td>215</td>
</tr>
<tr>
<td>13.2</td>
<td>Adjust the numbering settings</td>
<td>216</td>
</tr>
<tr>
<td>13.3</td>
<td>Number parts</td>
<td>217</td>
</tr>
<tr>
<td></td>
<td>Number a series of parts</td>
<td>217</td>
</tr>
<tr>
<td></td>
<td>Number assemblies and cast units</td>
<td>218</td>
</tr>
<tr>
<td></td>
<td>Number reinforcement</td>
<td>219</td>
</tr>
<tr>
<td></td>
<td>Number welds</td>
<td>219</td>
</tr>
<tr>
<td></td>
<td>Save preliminary numbers</td>
<td>220</td>
</tr>
<tr>
<td>13.4</td>
<td>Change existing numbers</td>
<td>220</td>
</tr>
<tr>
<td>13.5</td>
<td>Clear existing numbers</td>
<td>221</td>
</tr>
<tr>
<td>13.6</td>
<td>Check the numbering</td>
<td>221</td>
</tr>
<tr>
<td>13.7</td>
<td>View the numbering history</td>
<td>224</td>
</tr>
</tbody>
</table>
13.8 Repair numbering errors ................................................................. 225
13.9 Renumber the model .................................................................. 226
13.10 Control numbers ................................................................. 226
  Assign control numbers to parts .................................................... 227
  Control number order ............................................................... 228
  Display control numbers in the model ........................................ 229
  Remove control numbers .......................................................... 230
  Lock or unlock control numbers ............................................... 231
  Example: Use control numbers to indicate the erection order ..... 231
13.11 Number parts by design group (Design Group Numbering) ...... 234
13.12 Numbering examples ............................................................ 235
  Example: Number identical beams ............................................. 236
  Example: Use family numbers .................................................... 237
  Example: Number selected part types ....................................... 238
  Example: Number parts in selected phases ............................... 239

14 Modeling settings ....................................................................... 242
14.1 General settings ...................................................................... 242
  Grid properties .......................................................................... 242
  Grid line properties .................................................................... 243
  Point properties ......................................................................... 244
  Rotation settings ...................................................................... 244
  Screenshot settings ................................................................... 245
14.2 View and representation settings ........................................... 246
  View properties ........................................................................ 246
  Grid view properties .................................................................. 247
  Display settings ........................................................................ 248
  Color settings for object groups ................................................. 250
  Transparency settings for object groups .................................... 251
14.3 Part properties .......................................................................... 251
  Steel column properties ............................................................ 252
  Steel beam properties ................................................................ 253
  Contour plate properties ........................................................... 253
  Orthogonal beam properties ....................................................... 254
  Twin profile properties .............................................................. 255
  Item properties ......................................................................... 256
  Pad footing properties ............................................................... 257
  Strip footing properties ............................................................. 258
  Concrete column properties ....................................................... 259
  Concrete beam properties .......................................................... 260
  Concrete slab properties ............................................................ 261
  Concrete panel properties ........................................................... 262
  Concrete item properties ............................................................ 263
  User-defined attributes ............................................................. 264
14.4 Part position settings .............................................................. 264
  Position on the work plane ........................................................ 265
  Rotation ..................................................................................... 266
  Position depth .......................................................................... 267
  Vertical position ......................................................................... 269
  Horizontal position .................................................................... 270
  End offsets ................................................................................ 272
14.5 **Detail properties** ................................................................. 273
   Bolt properties ........................................................................... 274
   Bolt group shape ........................................................................ 277
   Weld properties ........................................................................... 278
   List of weld types ....................................................................... 283
   Corner chamfer properties ........................................................... 284
   Corner chamfer types and dimensions ......................................... 284
   Edge chamfer properties .............................................................. 286
14.6 **Numbering settings** ............................................................ 286
   General numbering settings ....................................................... 287
   Weld numbering settings ............................................................ 288
   Control number settings ............................................................ 289
15 **Modeling tips** ..................................................................... 291
15.1 **General modeling tips** ....................................................... 291
   Create a radial grid ..................................................................... 292
   If you cannot see all objects ....................................................... 293
   Should I model in a 3D or plane view? ....................................... 294
   Hide cut lines in a model view ..................................................... 294
   Show part reference lines in a model view ................................. 294
   How to cut efficiently .................................................................. 295
   Right-hand rule .......................................................................... 296
   Find RGB values for colors ....................................................... 296
   When to use an autosaved model .............................................. 297
15.2 **Tips for creating and positioning parts** ................................. 297
   Define default part properties ................................................... 298
   Create curved parts ................................................................... 298
   Create horizontal parts .............................................................. 299
   Create beams close to each other .............................................. 300
   Create closed polybeams .......................................................... 300
   Alternative way of creating a round plate or slab ....................... 301
   Position columns, pad footings, and orthogonal beams ............. 302
   Position objects in a radial or circular pattern ............................ 302
   Optional ways of placing objects in a model ............................. 303
   How to model identical areas .................................................... 304
   Create bolts by modifying an existing bolt group ....................... 304
15.3 **Tips for numbering** ............................................................. 305
   Numbering settings during a project ......................................... 305
   Create a standard-part model .................................................... 305
15.4 **Tips for large models** .......................................................... 307
16 **Disclaimer** ........................................................................... 309
Create points

You can create points to make it easier to place model objects at positions where no lines or objects intersect.

There are many ways to create points in Tekla Structures. Which method is the most convenient at each time depends on what you have already created in the model and which locations you can easily pick.

When you create points, Tekla Structures always places them according to the work plane coordinate system. Points located on the view plane are yellow and points outside the view plane are red.

See also
Create points on a line (page 12)
Create points on a plane (page 12)
Create points parallel to two points (page 13)
Create points along the extension line of two points (page 14)
Create projected points on a line (page 15)
Create points along an arc using center and arc points (page 16)
Create points along an arc using three arc points (page 16)
Create points tangent to a circle (page 17)
1.1 Create points on a line
You can create points at equal intervals along a line that is defined by two points.

1. On the Edit tab, click Points --> On line.
   The Divided Line Points dialog box appears.
2. Define the number of points to be created.
3. Click OK.
4. Pick the start point of the line (1).
5. Pick the end point of the line (2).

See also
Create points (page 11)
1.2 Create points on a plane

You can create several equally spaced points in the desired area in the model. The points are created in relation to the picked origin position.

A point array consists of several points in a rectangular xy(z) pattern relative to the current work plane. The x, y, and z coordinates of the points define the array pattern. The x and y coordinates are relative distances between the points on the work plane. The z coordinates are absolute distances perpendicular to the work plane.

1. On the Edit tab, click Points --> On plane.
   The Point Array dialog box appears.
2. Define the array point coordinates.
   Use positive or negative values to define the direction of the array.
   Use a zero at the beginning of the row to represent a point in the array origin. Separate multiple values with spaces.
3. Pick the origin of the array in the view.
   Alternatively, you can define the origin in the Point Array dialog box.
4. Click OK.

See also
Create points (page 11)

1.3 Create points parallel to two points

You can create offset points that are parallel to a line between two points you have picked.

1. On the Edit tab, click Points --> Parallel to two points.
   The Point Input dialog box appears.
2. Define the distances at which the points are created.
   If you want to create multiple pairs of offset points, enter multiple values separated with spaces.
3. Click OK.
4. Pick the start point of the line (1).
5. Pick the end point of the line (2).
   The picking order of the start point and the end point defines the offset direction of the new points.
   When you look from the start point to the end point, Tekla Structures creates the new points to the left of the picked points. If you enter
negative values to the **Point Input** dialog box, Tekla Structures creates points to the right of the picked points.

When you pick points, Tekla Structures uses arrows to indicate the offset direction.

For example, if you enter 500 500 to the **Point Input** dialog box, the first pair of new points is created at a 500 mm distance from the picked points, and the second pair of points is created at a 500 mm distance from the first pair of points.

![Diagram showing point input with 500 mm offsets]

**See also**
Create points (page 11)

1.4 **Create points along the extension line of two points**

1. On the **Edit** tab, click **Points --> Along extension of two points**.

   The **Point Input** dialog box opens.

2. Define the distances at which the points are created.
   Separate multiple values with spaces.

3. Click **OK**.

4. Pick the start point of the line (1).

5. Pick the end point of the line (2).

For example, if you enter 500 100 100 to the **Point Input** dialog box, the first point is created at 500 mm distance from the end point of the line, and the
second and the third point are each created at 100 mm distance from the previous point.

**TIP** Enter a negative value to the **Point Input** dialog box to create a point between the start point and the end point.

**See also**
Create points (page 11)

### 1.5 Create projected points on a line
You can project a point onto a selected line or its extension.

1. On the **Edit** tab, click **Points --> Projected points on line**.
2. Pick the first point on the line (1).
3. Pick the second point on the line (2).
4. Pick the point to be projected (3).

**See also**
Create points (page 11)
1.6 Create points along an arc using center and arc points
You can create points along an arc.
1. On the Edit tab, click Points --> Along arc using center and arc points .
   The Arc Points dialog box appears.
2. Select either Angles or Distances and enter the angles or distances between the points along the arc.
   Give the angle values in degrees.
   Separate multiple angle and distance values with spaces.
3. Click OK.
4. Pick the center point.
5. Pick the start point of the arc.
   Tekla Structures creates the arc points counterclockwise from the start point.

See also
Create points (page 11)

1.7 Create points along an arc using three arc points
You can create points as an extension of an arc.
1. On the Edit tab, click Points --> Along arc using three arc points .
   The Arc Points dialog box appears.
2. Select either Angles or Distances and enter the angles or distances between the points along the arc.
   Give the angle values in degrees.
   Separate multiple angle and distance values with spaces.
3. Click **OK**.
4. Pick three points along the arc (1-3).

See also

*Create points (page 11)*

### 1.8 Create points tangent to a circle

1. On the **Edit** tab, click **Points --> Tangent to circle**.
2. Pick the center point of the circle (1).
3. Pick a point on the circle to define the radius (2).
4. Pick the end point of the tangent (3).
5. Pick a side to indicate the side on which Tekla Structures creates the tangent point (4).
See also
Create points (page 11)

### 1.9 Create points at any position

**NOTE** Snap switches determine the positions you can pick.

You can also use temporary reference points and numeric snapping to create a point, for example, to a certain distance from an existing corner or a point.

1. On the **Edit** tab, click **Points --> At Any Position**.
2. Pick the intersection of two part edges (1), or the corner of a part (2).

See also
Create points (page 11)

### 1.10 Create bolt points

You can create points on the view plane at the center points of single bolts and bolt group bolts.

1. On the **Edit** tab, click **Points --> Bolt points**.
2. Select a bolt or a bolt group.

See also
Create points (page 11)
1.11 **Create points at the intersection of two lines**

1. On the **Edit** tab, click **Points** --> **At intersection of two lines**.
2. Pick the start point of the first line (1).
3. Pick the end point of the first line (2).
4. Pick the start point of the second line (3).
5. Pick the end point of the second line (4).

See also

Create points (page 11)

---

1.12 **Create points at the intersection of a plane and a line**

1. On the **Edit** tab, click **Points** --> **At intersection of plane and line**.
2. Pick three points to define the plane.
3. Pick the first point of the line.
4. Pick the second point of the line.

See also

Create points (page 11)

---

1.13 **Create points at the intersection of a part and a line**

You can create points where a line intersects with the surface of a part.

1. On the **Edit** tab, click **Points** --> **At intersection of part and line**.
2. Select the part.
3. Pick the first point of the line.
4. Pick the second point of the line.

See also
Create points (page 11)

1.14 Create points at the intersection of a circle and a line
1. On the Edit tab, click Points --> At intersection of circle and line.
2. Pick the center point of the circle (1).
3. Pick a point on the circle to define the radius (2).
4. Pick the first point on the line (3).
5. Pick the second point on the line (4).

See also
Create points (page 11)

1.15 Create points at the intersection of two part axes
You can create points where the axes of two parts intersect, and project the points onto the axis of the part that you select first.
1. On the Edit tab, click Points --> At intersection of two part axes.
2. Select the first part (1).
3. Select the second part (2).
   Tekla Structures projects the point onto the axis of the first part.
1.16 Import points

NOTE This section is for advanced users.

You can import points to specific locations in an open Tekla Structures model using the **Point Creation Import (8)** component. You need to specify the point coordinates in a text file. In some cases this file is generated by another software package.

1. Create a point import file.
   a. Create a text file that consists of single lines for each point.
      Use commas or tabs as delimiters for the three point coordinates on a line. For example:
      
      100,500,1000
      300,700,1500
   b. Save the file.

   NOTE During the import process, Tekla Structures ignores all lines in the import file which do not consist of valid values delimited by tabs or commas.

2. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.

3. Enter point in the **Search** box.

4. Click **Point Creation Import (8)**.
5. Enter the ASCII file name.
   Include the full path and the file name extension. If you do not specify the path, Tekla Structures looks for the file in the current model folder.

6. Define the origin of the imported points by entering the coordinates.

7. Click **Create**.

**See also**

Create points (page 11)
Create construction objects

Construction planes, lines, and circles help you place other objects in the model.

For example, you can easily pick the points at intersections of construction lines and circles.

The snap priority of construction objects is the same as with the other lines.

Construction objects remain in the model when you update or redraw views and windows. They do not appear in drawings.

You can also create magnetic construction lines or planes to bind and move groups of objects. For example, rather than binding lots of handles and chamfers to faces, simply create a construction plane that goes through all the handles and chamfers. Then make this plane magnetic and bind the plane to the appropriate face. When you move the plane, the attached handles and chamfers move with it.

See also
Create a construction plane (page 24)
Create a construction line (page 23)
Create a construction circle using center point and radius (page 25)
Create a construction circle using three points (page 26)
Modify a construction object (page 26)

2.1 Create a construction line

1. On the Edit tab, click Construction object --> Line.
2. Pick the start point of the construction line.
3. Pick the end point of the construction line.
4. If needed, you can make the construction line magnetic.
a. Double-click the line in the model.
b. Select the Magnetic check box.
c. Click Modify.

See also
Create construction objects (page 23)
Modify a construction object (page 26)

2.2 Create a construction plane
1. On the Edit tab, click Construction object --> Plane.
2. Pick three points.
3. Click the middle mouse button. Tekla Structures draws the plane.
4. Double-click the plane in the model. The Construction Plane Properties dialog box appears.
5. Enter a name for the plane.
6. If you want to make the construction plane magnetic, select the Magnetic check box.
7. Click Modify.

See also
Create construction objects (page 23)
2.3 Create a construction circle using center point and radius

1. On the Edit tab, click Construction object --> Circle using center point and radius.

2. Pick a point to define the center point of the circle.

3. Pick another point to define the radius.

Tekla Structures draws the construction circle on the view plane.

See also
Create a construction circle using three points (page 26)
Create construction objects (page 23)
2.4 Create a construction circle using three points

1. On the **Edit** tab, click **Construction object** --> **Circle using three points**.
2. Pick three points along the arc of the circle. The picking order does not matter. For example:

![Construction circle using three points](image)

Tekla Structures draws the construction circle.

**See also**

- Create a construction circle using center point and radius (page 25)
- Create construction objects (page 23)
- Modify a construction object (page 26)

2.5 Modify a construction object

You can modify construction points, lines, circles, and planes using direct modification.
Before you start:

- Ensure that the **Direct modification** switch is active.
- Select the construction object.

Tekla Structures displays the handles and dimensions that you can use to modify the construction object.

When you select a handle and move the mouse pointer over 📦, Tekla Structures displays a toolbar with more modification options. The available options depend on the type of the construction object you are modifying.

To modify a construction object, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
<th>Available for</th>
</tr>
</thead>
</table>
| Set a reference point to move in one, two, or any direction | 1. Select the handle in the reference point.  
2. To define in which directions the handle can move, select an option from the list on the toolbar:  
  ![Toolbar options](image)
  You can also press **Tab** to cycle through the options.  
3. To move the handle in a certain plane only, click 🛠️ and select the plane. | Construction points, lines, circle center points, planes |
<p>| Move a point, a point on a line or circle, or a plane corner | Drag the handle in the reference point to a new location. | All construction objects |
| Move a circle | Drag the handle in the center point to a new location. | Construction circles |
| Move a line or a plane edge | Drag the line handle to a new location. | Construction lines, planes |
| Move a plane | Drag the plane to a new location. | Construction planes |
| Show or hide direct | 1. Select a handle. | Construction lines, planes |</p>
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
<th>Available for</th>
</tr>
</thead>
<tbody>
<tr>
<td>modification dimensions</td>
<td>2. On the toolbar, click ![eye icon].</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3. Click the eye button to show or hide orthogonal and total dimensions:</td>
<td></td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Dimensions toolbar" /></td>
<td></td>
</tr>
<tr>
<td>Change a dimension</td>
<td>Drag a dimension arrowhead to a new location, or:</td>
<td>Construction lines, circles, planes</td>
</tr>
<tr>
<td></td>
<td>1. Select the dimension arrowhead which you want to move.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To change the dimension at both ends, select both arrowheads.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To change the radius of a circle, select the outer arrowhead.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2. Using the keyboard, enter the value with which you want the dimension</td>
<td></td>
</tr>
<tr>
<td></td>
<td>to change.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To start with the negative sign (-), use the numeric keypad.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To enter an absolute value for the dimension, first enter $, then the</td>
<td></td>
</tr>
<tr>
<td></td>
<td>value.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3. Press <strong>Enter</strong>, or click <strong>OK</strong> in the <strong>Enter a Numeric Location</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>dialog box.</td>
<td></td>
</tr>
</tbody>
</table>

**See also**

- Create construction objects (page 23)
- Create points (page 11)
This section explains how to create parts using different materials and profiles. Click the links below to find out more:

About parts (page 29)  
About items (page 33)  
Create steel parts (page 34)  
Create concrete parts (page 51)

### 3.1 About parts

In Tekla Structures, the term *part* refers to the basic building objects that can be modeled and detailed further. These are the building blocks of the physical model.

Every part has properties that define it, such as material, profile, and location. You can use part properties in view and selection filters. For example, you can select, modify, and hide parts based on their properties. You can also include part properties (page 251) and user-defined attributes (page 264) in drawing and report templates.

**See also**

Part handles (page 29)  
Part labels (page 31)  
Create steel parts (page 34)  
Create concrete parts (page 51)  
About items (page 33)
Part handles
Tekla Structures indicates the direction of a part with handles. When you select a part, Tekla Structures highlights the handles. The handle of the first end point is yellow, the rest are magenta.

For information on how to select only the handles of a part, see Select objects. If Direct modification is on, Tekla Structures also displays direct modification handles for the reference points, corners, segments, and segment midpoints of the selected part. These handles are blue.

Swap handles
You can change the modeling direction of a part by using the Swap Handles macro. This changes the yellow start handle to magenta, and the other way around.
1. Select the part whose modeling direction you want to change.
Tekla Structures highlights the part handles.

2. Go to **Quick Launch**, start typing *swap handles*, and select the **Macro.Swap Handles** command from the list that appears.

   Tekla Structures changes the modeling direction of the part, and swaps the start and end handles.

---

**See also**

*Show part reference lines in a model view (page 294)*

**Part labels**

You can display selected part properties, user-defined attributes, and template attributes in a model view by using *part labels*. 

---

Create parts 31 About parts
Part labels are textual descriptions that are displayed next to the part they represent. You can define what information to display in the labels, such as the name, profile, and position number of the part.

To show part labels in a model view:
1. Double-click the view to open the **View Properties** dialog box.
2. Click **Display**.
3. In the **Display** dialog box, go to the **Advanced** tab.
4. Select the **Part label** check box.
5. Define which part properties to display in part labels.
   a. Select a property in the **Properties** list.
   b. Click **Add** to add the property to the **Part label** list.
6. If needed, define which user-defined attribute or template attribute to display in part labels.
   a. Select **User-defined attribute** in the **Properties** list.
   b. Click **Add**. The **Part label** dialog box appears.
   c. Enter the user-defined attribute name exactly as it appears in the objects.inp file, or the template attribute name. For example, **PRELIM_MARK**.
   d. Click **OK**.
3.2 About items

In Tekla Structures, the term *item* refers to the parts that have a 3D *shape*. Shapes are created in an external modeling software, or in Tekla Structures, and they are available in the Tekla Structures shape catalog.

Items are similar to other parts, such as beams and columns. The main difference between items and other types of parts is that a 3D shape defines the geometry of an item, whereas a part has a 2D profile that is extruded to create the length of the part.

You can use items to model objects that would be difficult to model using basic Tekla Structures parts and commands, such as cutting. You can also use items to model objects that use shapes modeled in an external software or by a manufacturer.

Every item has properties that define it, such as shape, material, and location. If you want to use item properties in view and selection filters or in drawing and report templates, you need to use the template attributes of parts and profiles. If you want to separate items from parts, use the IS_ITEM template attribute.

See also

- Limitations to items (page 33)
- Create an item (page 51)
- Create a concrete item (page 58)
- Item properties (page 256)
- Concrete item properties (page 263)

Limitations to items

- Items have a fixed geometry according to their shape, so items cannot be scaled, stretched, or fitted.
- Items cannot be mirrored.
- Items cannot be split or combined. Splitting an imported item creates a duplicate to the splitting position.
- Items can only be cut or attached to another part if they have a solid shape.
- The gross weight value of an imported item may be different from that of an identical Tekla Structures part modeled with cuts. This is because the cuts are not taken into account when calculating the gross weight of parts.
• The contextual toolbar does not work for items.

See also
About items (page 33)

3.3 Create steel parts
This section explains how to create steel parts.
Click the links below to find out more:

Create a steel column (page 34)
Create a steel beam (page 35)
Create a steel polybeam (page 36)
Create a curved beam (page 37)
Create a contour plate (page 37)
Create a bent plate (page 39)
Create an orthogonal beam (page 49)
Create a twin profile (page 50)
Create an item (page 51)

Create a steel column

1. On the Steel tab, click Column.
2. Pick a point.
Tekla Structures creates the column at the level defined in the Column Properties dialog box.

3. If you want to change the part properties:
   a. Double-click the column to open the Column Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

TIP Sometimes when you copy and mirror a column, its upper and lower levels may become incorrectly switched. Use the Orthogonal Beam Properties dialog box to correct the position of a column. Remember to change the part name to COLUMN.

See also
Steel column properties (page 252)
Position columns, pad footings, and orthogonal beams (page 302)

Create a steel beam

1. On the Steel tab, click 
2. Pick two points.
Tekla Structures creates the beam between the points you picked.

3. If you want to change the part properties:
   a. Double-click the beam to open the **Beam Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

**See also**
Steel beam properties (page 252)

**Create a steel polybeam**
A polybeam can contain straight and curved segments.

1. On the **Steel** tab, click **Beam --> Polybeam**.
2. Pick the points you want the beam to go through.
   - If you want to create a closed polybeam (page 300), start modeling from an intermediate point somewhere along a polybeam segment, not from a corner point. This way, the end faces will be created against each other, and the polybeam closes properly.
3. Click the middle mouse button.
   Tekla Structures creates the polybeam between the points you picked.

4. If you want to change the part properties:
   a. Double-click the polybeam to open the **Beam Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

5. If you want to create curved segments, chamfer the corners of the polybeam.
For example:

See also
Steel beam properties (page 252)
Chamfer part corners (page 98)

Create a curved beam
1. On the Steel tab, click Beam --> Curved beam.
2. Pick the start point (1).
3. Pick a point on the arc (2).
4. Pick the end point (3).
   Tekla Structures creates the beam between the points you picked.
5. If you want to change the part properties:
   a. Double-click the curved beam to open the Beam Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

See also
Steel beam properties (page 252)
Create curved parts (page 298)
Create a contour plate
When you create a contour plate, the profile you use defines the thickness of the plate and the picked points define the shape. The corners of the contour plate can be chamfered.

1. On the **Steel** tab, click **Plate**.
2. Pick the corner points of the contour plate.
3. Click the middle mouse button.

Tekla Structures creates the plate.

4. If you want to change the part properties:
   a. Double-click the plate to open the **Contour Plate Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

**See also**
Create a round contour plate (page 38)
Contour plate properties (page 253)

Create a round contour plate
1. Create a square contour plate with four equal sides.
2. Select the plate.
3. Select the handles of the plate.

   **TIP** To select all the handles at once, hold down the **Alt** key and drag the mouse from left to right, covering all the handles.

4. Press **Alt + Enter** to display the **Chamfer Properties** dialog box.
5. Select the round chamfer symbol from the list.
6. Enter the chamfer radius in the **x** box. The radius must be equal to half of the side of the square.
7. Click **Modify**.

See also
- Alternative way of creating a round plate or slab (page 301)
- Create a contour plate (page 37)
- Contour plate properties (page 253)
- Create part chamfers (page 97)

**Create a bent plate**

You can create bent steel plates either by selecting two parts or two part faces. The parts that you use for creating a bent plate must be contour plates, or beams whose profile is a plate (for example, PL200*20).

After creating a bent plate, the individual parts no longer exist in the model. The bent plate gets its properties from the first part that you selected when creating the bent plate.

**Create a bent plate by selecting parts**

You can create a bent plate by selecting two steel parts. The bent plate properties, such as the ID, thickness, class, and material of the plate, are determined by the first part you select.

1. On the **Steel** tab, click **Plate --> Create bent plate using parts**.
2. Select the first part.
3. Select the second part.

Tekla Structures creates the bent plate:
Create a bent plate by selecting faces
You can create a bent plate by selecting two part faces. The bent plate properties, such as the ID, thickness, class, and material of the plate, are determined by the part that the first selected face belongs to.

1. On the Steel tab, click Plate --> Create bent plate using faces.
2. Select the first part face.
3. Select the second part face.
Modify the bend radius
Tekla Structures uses a default bend radius when creating bent plates. You can change the bend radius to suit your needs.

1. Ensure that Direct modification is switched on.
2. Select the bent plate.
A blue line handle appears in the middle of the curved section.

3. Select the line handle.
   A blue dimension arrow appears:

4. Drag the arrow forward or backward along the magenta line.
The dimension "r = " changes accordingly. When you release the arrow, the radius also changes in the model.

Alternatively, you can select the arrow and type a dimension. When you start typing, Tekla Structures displays the Enter a Numeric Location dialog box. Click OK to confirm the dimension.

Modify the shape of a bent plate
When you create a bent plate, Tekla Structures adds a curved section between the parts you select. You can modify the curved section by choosing one of the predefined options or by modifying the shape manually. You can also modify the flat sections, by which we mean the original parts the bent plate was made of.

1. Ensure that Direct modification is switched on.
2. Select the bent plate.
   A blue line handle appears in the middle of the curved section.
3. Select the line handle.
   A contextual toolbar appears.
4. On the contextual toolbar, select one of the predefined options:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tapered bend</td>
<td>A gradual decrease in the width between the parts. This is the default shape.</td>
<td><img src="image" alt="Tapered Bend Example" /></td>
</tr>
<tr>
<td>Narrow bend</td>
<td>Constant width between the parts. The width is determined by the <strong>narrowest</strong> part.</td>
<td><img src="image" alt="Narrow Bend Example" /></td>
</tr>
<tr>
<td>Wide bend</td>
<td>Constant width between the parts. The width is determined by the <strong>widest</strong> part.</td>
<td><img src="image" alt="Wide Bend Example" /></td>
</tr>
</tbody>
</table>

5. To modify the curved section manually:
   a. Select the blue line handle.
Tekla Structures displays the boundary handles in blue:

b. Drag the handles to change the shape of the curved section.
For example:

6. To modify the flat sections:
   a. Select the bent plate.
      Tekla Structures displays a green selection handle in the middle of each flat section:

b. Click the selection handle of the section you want to modify.
The direct modification handles of the selected section become visible:

![Diagram showing direct modification handles]

c. Use the direct modification handles to change the shape of the flat section.

**Remove curved sections**

You can return bent plates into individual objects, and then edit and use them as any other model object. If the bent plate consists of several curved sections that are all joined to the same part, you can either remove each curved section separately or explode the entire bent plate all at once.

<table>
<thead>
<tr>
<th>To remove individual curved sections</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Ensure that Direct modification is switched on.</td>
<td></td>
</tr>
</tbody>
</table>
| 2. Select the curved section you want to remove.  
  A blue line handle appears. |
| 3. Select the line handle.  
  A contextual toolbar appears. |
| 4. On the contextual toolbar, click Remove bend.  
  Tekla Structures removes the selected curved section. For example: |
To explode the entire bent plate

1. Select one of the curved sections.
2. Right-click and select **Explode**.

Tekla Structures explodes the entire bent plate into individual objects. For example:

**Examples**
Here are some examples of bent plates that you can create:

<table>
<thead>
<tr>
<th>Starting point</th>
<th>End result</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Starting point diagram" /></td>
<td><img src="image2" alt="End result diagram" /></td>
</tr>
</tbody>
</table>
**Limitations**

- Only the side faces of the part can be used for creating a bent plate.
- Chamfered or cut faces cannot be used for creating a bent plate.
- Curved beams and deformed parts cannot be used for creating a bent plate.
- Details (such as bolts, welds, cuts, chamfers, and preparations) are not supported on the curved section of the bent plate.
- The angle between the parts cannot be changed.

**Create an orthogonal beam**

Use the **Orthogonal beam** command when you want to create a steel part that is perpendicular to the current work plane. After you have created an orthogonal beam, you can modify it as if it were beam or column.

1. On the **Steel** tab, click **Beam --> Orthogonal beam**.
2. Pick a point.
Tekla Structures creates the beam at the position you picked.

3. If you want to change the part properties:
   a. Double-click the orthogonal beam to open the properties dialog box.
   b. Modify the properties.
   c. Click **Modify**.

See also
Orthogonal beam properties (page 254)

Create a twin profile
A twin profile consists of two identical beams. You define the positions of both beams by selecting the twin profile type and setting the clearance between the beams in two directions.

1. On the **Steel** tab, click **Beam --> Twin profile**.
2. Pick two points.
   
   Tekla Structures creates the twin profile between the points you picked.

3. If you want to change the part properties:
   a. Double-click either of the beams to open the **Beam Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.
Create an item

1. On the Steel tab, click Item.
2. Pick two points.
   Tekla Structures creates the item between the points you picked starting from the first point (yellow handle) towards the direction of the second point (magenta handle).

3. If you want to change the item properties:
   a. Double-click the item to open the Item Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

See also
Item properties (page 256)
About items (page 33)

3.4 Create concrete parts
This section explains how to create concrete parts.
Click the links below to find out more:

Create a pad footing (page 52)
Create a strip footing (page 52)
Create a concrete column (page 53)
Create a concrete beam (page 54)
Create a concrete polybeam (page 55)
Create a concrete slab (page 56)
Create a concrete panel or wall (page 57)
Create a concrete item (page 58)

Create a pad footing

1. On the Concrete tab, click 🏗️.
2. Pick a point.
   
   Tekla Structures creates the footing at the position you picked.

3. If you want to change the part properties:
   a. Double-click the pad footing to open the Pad Footing Properties dialog box.
   b. Modify the properties.
      
      For example, to create a circular pad footing, select a circular section for Profile.
   c. Click Modify.

See also
Pad footing properties (page 257)

Create a strip footing

1. On the Concrete tab, click Footing → Strip footing.
2. Pick the points you want the footing to go through.
3. Click the middle mouse button.
Tekla Structures creates the footing between the points you picked.

4. If you want to change the part properties:
   a. Double-click the strip footing to open the **Strip Footing Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

5. If you want to create curved segments, chamfer the corners of the footing.

   For example:

   ![Footing examples](image)

   **See also**

   - Strip footing properties (page 258)
   - Chamfer part corners (page 98)

**Create a concrete column**

1. On the **Concrete** tab, click **Column**.
2. Pick a point.
   Tekla Structures creates the column at the level defined in the Concrete Column Properties dialog box.

3. If you want to change the part properties:
   a. Double-click the column to open the Concrete Column Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

**See also**
Concrete column properties (page 259)

**Create a concrete beam**

1. On the Concrete tab, click .
2. Pick two points.
3. If you want to change the part properties:
   a. Double-click the beam to open the Concrete Beam Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

See also
Concrete beam properties (page 260)

Create a concrete polybeam
A polybeam can contain straight and curved segments.

1. On the Concrete tab, click Beam --> Polybeam.
2. Pick the points you want the beam to go through.
   If you want to create a closed polybeam (page 300), start modeling from an intermediate point somewhere along a polybeam segment, not from a corner point. This way, the end faces will be created against each other, and the polybeam closes properly.
3. Click the middle mouse button.
   Tekla Structures creates the beam between the points you picked.

4. If you want to change the part properties:
   a. Double-click the polybeam to open the Concrete Beam Properties dialog box.
   b. Modify the properties.
   c. Click Modify.
5. If you want to create curved segments, chamfer the corners of the polybeam.
For example:

See also
Concrete beam properties (page 260)
Chamfer part corners (page 98)

Create a concrete slab
When you create a concrete slab, the profile you use defines the thickness of the slab and the picked points define the shape. The corners of the slab can be chamfered.

1. On the Concrete tab, click Slab.
2. Pick the corner points of the slab.
3. Click the middle mouse button.
Teka Structures creates the slab.

4. If you want to change the part properties:
   a. Double-click the slab to open the Concrete Slab Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

See also
Create a round slab (page 57)
Concrete slab properties (page 261)
Create a round slab

1. Create a square slab with four equal sides.
2. Select the slab.
3. Select the handles of the slab.

**TIP** To select all the handles at once, hold down the Alt key and drag the mouse from left to right, covering all the handles.

4. Press Alt + Enter to display the Chamfer Properties dialog box.
5. Select the round chamfer symbol from the list.
6. Enter the chamfer radius in the \( \text{x} \) box. The radius must be equal to half of the side of the square.
7. Click Modify.

See also

- Alternative way of creating a round plate or slab (page 301)
- Create a concrete slab (page 56)
- Concrete slab properties (page 261)
- Create part chamfers (page 97)

Create a concrete panel or wall

You can create a concrete panel or wall that passes through the points you pick.

1. On the Concrete tab, click Panel.
2. Pick the points you want the panel or wall to go through.
3. Click the middle mouse button.
Tekla Structures creates the panel or wall.

4. If you want to change the part properties:
   a. Double-click the panel or wall to open the Concrete Panel Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

5. If you want to create curved segments, chamfer the corners of the panel or wall.
   For example:

See also
Concrete panel properties (page 262)
Chamfer part corners (page 98)

Create a concrete item

1. On the Concrete tab, click Item.
2. Pick two points.
Tekla Structures creates the item between the points you picked starting from the first point (yellow handle) towards the direction of the second point (magenta handle).

3. If you want to change the item properties:
   a. Double-click the item to open the **Concrete Item Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

**See also**

- Concrete item properties (page 263)
- About items (page 33)
This section explains how to modify different part properties, such as shape, position and length of a part. It also explains how to split and combine parts, and how to use the deforming options to warp and camber parts.

Click the links below to find out more:

- Modify the part properties (page 60)
- Modify the position of a part (page 61)
- Modify the length of a part (page 62)
- Change the profile of a part (page 63)
- Change the material of a part (page 65)
- Change the shape of an item (page 65)
- Modify the adaptivity of model objects (page 66)
- Split parts (page 66)
- Combine parts (page 67)
- Attach parts to each other (page 68)
- Warp concrete parts (page 70)
- Camber a part (page 73)

### 4.1 Modify the part properties

1. Double-click a part to open the part properties dialog box.
2. To indicate which properties should be changed, select or clear the desired check boxes.
For example, if you want some steel parts to share the same name but do not want to change any of their other individual properties, ensure that only the **Name** check box is selected.

**TIP** Click to switch all check boxes on or off.

3. Modify the properties.
4. Select the parts you want to modify.
5. Click **Modify**.

**See also**

*Part properties (page 251)*

### 4.2 Modify the position of a part

To modify the position of a part, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Modify part position in the part properties dialog box | 1. Double-click a part to open the part properties dialog box.  
2. On the **Position** tab, modify the desired position settings.  
For example, you can define the part to be positioned 200 units above its handles.  
3. Click **Modify**. |
| Modify part position using the contextual toolbar | 1. Click in the contextual toolbar.  
2. Modify the settings. The object moves in the model accordingly.  
   - To change the overall position of a beam, column, panel, or footing, use the round selection dial. Click a sector in the dial to select a position.  
   - To change the rotation angle, click and drag the green rotation angle knob. |
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>•</td>
<td>To change the <strong>Angle</strong>, <strong>Plane offset</strong>, or <strong>Depth offset</strong>, enter a value in the corresponding box.</td>
</tr>
<tr>
<td>•</td>
<td>To change the position of a plate or slab, select an option and enter a value in the <strong>Depth offset</strong> box.</td>
</tr>
</tbody>
</table>

**TIP** The rotation angle knob snaps to every 5 degrees. Hold down **Shift** to override this.

See also
- Part position settings (page 264)
- Tips for creating and positioning parts (page 297)

### 4.3 Modify the length of a part

If you do not want to use direct modification, you can use the part handles to modify the length of a part.

1. Ensure that the **Direct modification** switch is **not** active.
2. Select the part. Tekla Structures highlights the handles of the part.
3. Click one of the handles to select it.
4. Move the handle like any other object in Tekla Structures. For example, right-click and select **Move**.
   - If **Drag and drop** is active, just drag the handle to a new location.
WARNING  Do not use cuts or fittings to change the length of a part, for the following reasons:

• Cuts may cause shop errors, because cuts do not always affect part length when you export information to NC files.
• Fittings may cause problems with connections and details.

See also
Part handles (page 29)

4.4 Change the profile of a part
When you create or modify a part, you can select the profile from a list that contains all the profiles available in the profile catalog.

1. Double-click a part to open the part properties dialog box.
2. Click Select next to the Profile box.
   The Select Profile dialog box appears.
   By default, only the profile types that are relevant to the material of the part are shown. For example, if you are changing the profile of a steel part, only the profile types that are associated with steel are shown.
3. If needed, define what profile information you want to see.
   • To display all the profiles of the profile catalog in the list, regardless of the material the profile types are associated with, select the Show all profiles check box.
   • To see all the properties of profiles, select the Show details check box.
4. Select a profile from the list.
5. If the profile is parametric, define its dimensions on the General tab.

<table>
<thead>
<tr>
<th>Property</th>
<th>Symbol</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Height</td>
<td>h</td>
<td>300.00</td>
<td>mm</td>
</tr>
<tr>
<td>Web thickness</td>
<td>s</td>
<td>15.00</td>
<td>mm</td>
</tr>
<tr>
<td>Flange thickness</td>
<td>t</td>
<td>20.00</td>
<td>mm</td>
</tr>
</tbody>
</table>

[1] Click the Value box and replace the existing value with a new one.
6. Click OK to close the Select Profile dialog box.
7. Click **Modify**.

**TIP** Alternatively, if you know the name of the profile, you can enter it directly in the appropriate box in the part properties dialog box or on the contextual toolbar.

See also

*Use standardized values for profile dimensions (page 64)*

**Use standardized values for profile dimensions**

You can use standardized values for the dimensions of parametric profiles.

1. Double-click a part to open the part properties dialog box.
2. Click the **Select** button to open the **Select Profile** dialog box.
3. Select a parametric profile.

   If standardized values have been defined for this profile, the **Use industry standardized values only** check box appears on the **General** tab under the profile properties:

   4. Select the **Use industry standardized values only** check box.
5. Select the profile dimensions from a list in the **Value** column.
4.5 Change the material of a part

When you create or modify a part, you can select the material and grade from a list that contains all the materials available in the material catalog.

1. Double-click a part to open the part properties dialog box.
2. Click Select next to the Material box.
   The Select Material dialog box appears.
3. If needed, define what material information you want to see.
   • To include aliases for material grades in the list, select the Show aliases check box.
   • To see all the properties of materials, select the Show details check box.
4. Select a material from the list.
5. Click OK to close the Select Material dialog box.
6. Click Modify.

TIP Alternatively, if you know the name of the material, you can enter it directly in the Material box in the part properties dialog box.

4.6 Change the shape of an item

When you create or modify an item, you can select the shape from the list that contains all the shapes available in the shape catalog.

Before you start, ensure that you have the required shape imported to the shape catalog.

1. Double-click an item to open the item properties dialog box.
2. Click Select next to the Shape box to open the Shape Catalog dialog box.
3. If needed, use the Filter box to search for a shape.
4. Select a shape from the list.
5. Click OK to close the Shape Catalog dialog box.
6. Click Modify.
4.7 Modify the adaptivity of model objects

Model objects may adapt to other model objects they are linked to. For example, reinforcement and surface treatment automatically adapt to changes in part geometry and size. You can modify the adaptivity settings either for the entire model or for each model object separately. If you modify the adaptivity of individual model objects, these modifications override the default settings that you may have defined for the entire model.

The options are:

- **Off**: adaptivity is not defined
- **Relative**: handles retain their relative distances to the nearest part faces in relation to the part's overall size
- **Fixed**: handles retain their absolute distances to the nearest part faces

**Define default adaptivity settings**

You can define default adaptivity settings that affect the entire model.

1. On the **File** menu, click **Settings --> Options**, and go to the **General** settings.
2. Under **Default adaptivity**, select one of the options.
3. Click **OK** to save the changes.

**Modify the adaptivity of an individual model object**

You can modify the adaptivity settings for each model object separately. These modifications override the default settings that you may have defined for the entire model.

1. In the model, select the reinforcement or surface treatment (page 101) whose adaptivity settings you want to change.
2. Right-click, select **Adaptivity**, and then select one of the options.
4.8 Split parts

Use splitting to split a part into two. You can use splitting with straight parts, polybeams and curved beams without offsets, and normal and tapered reinforcing bar groups. You can also split plates and slabs by using a polygon.

Split a straight or curved part or polybeam

1. On the Edit tab, click Split.
2. Select the part you want to split.
3. Pick a point for the dividing line.
4. If you split a polybeam, check that the following are correct:
   • The position and orientation settings of the split polybeams
   • The components related to the split polybeams

Split a plate or slab using a polygon

1. Ensure that the Z axis is perpendicular to the plate or slab you want to split.
2. On the Edit tab, click Split.
3. Select the part you want to split.
4. Pick positions to outline the polygon to be used for splitting.
5. Click the middle mouse button to close the polygon and to split the part.

NOTE When you pick the corner points of the polygon to be used for splitting, make sure the starting and end points are:
   • outside of the part, and
   • on the same side of the part.

NOTE If you split contour plates that have bolts, welds or surface treatments, check the result after splitting.

4.9 Combine parts

You can combine two parts into one. This can be useful when you want to model complex parts (such as folded plates) that are otherwise difficult to model, or when you want to model prefabricated parts that are delivered to the workshop already attached to profiles.

1. On the Edit tab, click Combine.
2. Select the first part.
   The properties of the first selected part will be used for the combined part.
3. Select the second part.
   The parts are combined into one.
   If the center lines of the parts are not in line with each other, Tekla Structures combines them by taking the largest distance between the start and end points from both parts. For example:

![Diagram showing combined parts]

Limitations
- Combining does not work for contour plates, polybeams or slabs.
- When you combine parts, Tekla Structures retains the attached objects and connections. Tekla Structures does not recreate connections in the part that was selected first.

See also
Attach parts to each other (page 68)

4.10 Attach parts to each other
You can attach one or more parts to another part, or detach or explode the attached parts using the Added material commands.

You can use the Attach to part command to have more than 100 corner points in a polygon plate. Each plate has a maximum number of corner points. When you attach plates, the corner points of all the plates are summed up, that is, the maximum number of points in the whole part is \( \text{number of plates} \times \text{maximum number of points} \).

When you modify the properties of attached parts, note that some of the part properties are taken from the main part. These properties are not shown in
the properties of the attached part. You can inquire the properties of the whole part and the properties of each attached part separately. The attached parts are taken into account when calculating area, volume, and weight:

- **Weight (Gross)** compares the weight with fittings and without fittings, and shows the biggest weight result without cuts and with attached parts.
- **Weight (Net)** shows the weight with cuts and attached parts based on the geometry volume of the modeled part.
- **Weight** shows the net weight.

**Limitations**

- Connections must be added to the part to which other parts have been attached. You cannot add connections to an attached part.

- All reinforcement components may not work correctly with parts that have been attached to each other using the *Added material* commands. The geometry of the parts is not always kept suitable for adding a component. For example, the reference points of the attached part may be lost and therefore the orientation information needed for adding the reinforcement is not known anymore.

To ensure that the reinforcements work correctly, add them manually or use the *Reinforcing Bar Shape Catalog* to place them.

**See also**

- Attach a part to another part (page 69)
- Detach an attached part (page 70)
- Explode attached parts (page 70)

### Attach a part to another part

1. Double-click the view to open the view properties, click the *Display* button, and ensure that the *Cuts and added material* option is selected in the display settings.

2. On the *Edit* tab, click *Added material* --> *Attach to part*.

3. Select the part to attach to.

4. Select the part you want to attach.

You can attach more than one part at a time.

5. Click the middle mouse button to attach the part.

**See also**

- Attach parts to each other (page 68)
**Detach an attached part**

1. Double-click the view to open the view properties, click the **Display** button, and ensure that the **Cuts and added material** option is selected in the display settings.

2. On the **Edit** tab, click **Added material --> Detach from part**.

3. Select the attached part you want to detach.
   - You can detach more than one part from several different parts at a time.
   - Select the parts either by clicking them or by using area selection.

4. Click the middle mouse button to detach the part.
   - The detached part keeps the color it had as an attached part.

**See also**

- Attach parts to each other (page 68)
- Explode attached parts (page 70)

**Explode attached parts**

You can explode a part that has attached parts.

1. Double-click the view to open the view properties, click the **Display** button, and ensure that the **Cuts and added material** option is selected in the display settings.

2. On the **Edit** tab, click **Added material --> Explode part**.

3. Select the part you want to explode.

4. Click the middle mouse button to explode the part.

**See also**

- Attach parts to each other (page 68)
- Detach an attached part (page 70)

### 4.11 Warp concrete parts

You can warp concrete beams and slabs. The warping functionality is available only in the Full, Precast Concrete Detailing, and Steel Detailing configurations.

Click the links below to find out more:

- **Warp a concrete beam using deformation angles** (page 71)
Warp a concrete slab by moving chamfers (page 71)
Warp a Floor Bay (66) slab (page 72)

Warp a concrete beam using deformation angles
1. Double-click a concrete beam to open the Concrete Beam Properties dialog box.
2. Go to the Deforming tab.
3. In the Start box, enter the angle of the beam at its start point, relative to the part handles.
4. In the End box, enter the angle of the beam at its end point, relative to the part handles.
   For example, to warp the beam 10 degrees at the end point, enter 0 in the Start angle box and 10 in the End angle box.
5. Click Modify to warp the beam.
6. Click OK to close the dialog box.

See also
Warp concrete parts (page 70)

Warp a concrete slab by moving chamfers
Before you start, create a concrete slab by using the Slab command on the Concrete tab.
1. Double-click a chamfer to open the Chamfer Properties dialog box.
2. Modify the chamfer properties.
   Do not modify the chamfers so that the slab faces are no longer planar.
   • To move the upper corner of the chamfer, use the dz1 box.
• To move the lower corner of the chamfer, use the dz2 box.

3. Click Modify to warp the slab.
4. Click OK to close the dialog box.

See also
Warp concrete parts (page 70)

Warp a Floor Bay (66) slab

Before you start, create a concrete slab by using the Modeling of floor bay (66) component.

1. Ensure that the Select components selection switch is on.
2. Select the chamfer you want to move.

   For example, select the corner point of a slab component to warp that end of the slab:

3. Right-click and select Move Special --> Linear.
4. In the Move - Linear dialog box, enter a value in the appropriate direction box.

   For example, enter 100 in the dZ box to lift that corner up 100 mm.
5. Click Move.
Tekla Structures moves the point in the direction you selected, which warps the slabs.

6. Right-click and select **Interrupt**.
7. Ensure that the **Select objects in components** selection switch is on.
8. To see the warping angle of a single slab, double-click a slab to open the **Beam Properties** dialog box, and go to the **Deforming** tab.
   - The **Start** box shows the warping angle at the start point of the part.
   - The **End** box shows the warping angle at the end point of the part.

**See also**

Warp concrete parts (page 70)

### 4.12 Camber a part

You can use cambering to pre-camber parts, in other words, to curve long heavy sections that will settle on site and become flat. Use cambering to show the natural camber of a prestressed part in a model. Cambering affects the position of cuts, skews, and embeds in the model.

1. Double-click a part to open the part properties dialog box.
2. Go to the **Deforming** tab.
3. In the **Cambering** box, define the degree of camber.
4. Click **Modify**.
Tekla Structures cambers the part in the local z direction.
This section explains how to create details using Tekla Structures. It also gives you some techniques for fine-tuning the part shape.

Click the links below to find out more:

- Create bolts (page 75)
- Create studs (page 81)
- Create holes (page 82)
- Create welds (page 85)
- Create fittings (page 93)
- Create cuts (page 94)
- Create part chamfers (page 97)
- Add surface treatment (page 101)
- Add a surface to a face (page 113)
5.1 Create bolts

To create bolts, you can either create a single bolt group or apply a component that automatically creates bolt groups.

Tekla Structures uses the same command for creating bolts and holes. If you want to create only holes, do not use any bolt elements (such as bolts, washers, and nuts).

You can create different marks for bolts and holes in drawings.

See also
Create a bolt group (page 76)
Create a single bolt (page 77)
Create bolts using the Auto bolt component (page 77)
Create bolts by modifying an existing bolt group (page 304)
Change or add bolted parts (page 81)
Create studs (page 81)
Create holes (page 82)

Create a bolt group

1. On the Steel tab, click Bolt.
2. Select the main part, to which the secondary parts will be bolted.
3. Select the secondary parts.
4. Click the middle mouse button to finish selecting parts.
5. Pick a point to indicate the bolt group origin.
6. Pick a second point to indicate the direction of the bolt group x axis.

**NOTE** Tekla Structures determines the location of the bolt group using the following values: the bolt group x axis and the work plane. Dimensions are relative to the bolt group origin, which is the first point picked. Tekla Structures sets the x direction of the bolt group using the second point picked. It is important that the points you pick to create the bolt group are close enough to the parts you want to connect.

**See also**
- Create bolts (page 75)
- Bolt properties (page 274)

### Create a single bolt

1. On the Steel tab, hold down Shift and click Bolt to open the Bolt Properties dialog box.
2. Under Bolt group, select Array from the Shape list.
3. In the Bolt dist X and Bolt dist Y boxes, enter 0.
4. Click Apply to save the changes.
5. Create the bolt the same way you would create a bolt group:
   a. Select the main part, to which the secondary parts will be bolted.
   b. Select the secondary parts.
   c. Click the middle mouse button to finish selecting parts.
   d. Pick a point to indicate the bolt origin.
   e. Pick a second point to indicate the direction of the x axis.

**See also**
- Create bolts (page 75)
- Bolt properties (page 274)

### Create bolts using the Auto bolt component

Use the Auto bolt component to bolt parts and nearby parts, shim plates, splice plates, or other plates. Auto bolt follows the part rotation and finds the best rotation so that you do not need to set the work plane. With Auto bolt one bolt group can span many parts, for example, manage a splice as a single group.
1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.

2. Start typing **auto bolt** in the search box.

3. Double-click **Auto bolt** in the catalog to open the **Auto bolt** dialog box.

4. Define the bolt properties.

5. If needed, use the **Show cut length as temporary lines** option to view where the bolts should be placed even if they are not created.
   - Select ![select](image) to not show the temporary lines.
   - Select ![select](image) to show the temporary lines.

   To delete the temporary lines, right-click the view and select **Redraw View**.

6. Click **Apply**.

7. Select the main part.

   **Auto bolt** uses this part to identify the best rotation. This part will be the main part of the assembly.

8. Select the secondary part.

9. Click the middle mouse button.

10. Pick the first and the second position to define the bolt group direction.

![Diagram of a bolt group direction with select icons]
The bolt group is created automatically when you pick the second position. The bolts are automatically split into separate bolt groups.

Examples
Examples of parts bolted using the **Auto bolt** component are shown below. The main parts and the selected points are highlighted.
See also
Create bolts (page 75)

Change or add bolted parts
You can change the parts a bolt group connects to.
1. On the Steel tab, click **Bolted parts**.
2. Select the bolt group.
3. Reselect the main and secondary parts.
4. Click the middle mouse button to finish selecting the parts.
   Tekla Structures automatically updates bolt length to suit the changes.

See also
Create bolts (page 75)
5.2 Create studs

You can create studs by using the same commands that you use when creating bolts, but by selecting the stud assembly standard in the Bolt Properties dialog box. You can create a group of studs or a single stud.

You can also create studs by using the Shear stud (1010) component.

1. Ensure that the needed studs are added to the bolt catalog and bolt assembly catalog.

2. On the Steel tab, hold down Shift and click Bolt to open the Bolt Properties dialog box.

3. In the Bolt standard list, select the bolt assembly standard for the studs.

4. Under Bolt group, do one of the following:
   • To create a group of studs, define Shape and the related properties as desired.
   • To create a single stud, select Array from the Shape list and type 0 in the Bolt dist X and Bolt dist Y boxes.

5. Modify the other properties as desired.

6. Click Apply to save the changes.

7. Select the main part.

8. Click the middle mouse button to finish selecting parts.

9. Pick a point to indicate the origin of the stud or stud group.

10. Pick a second point to indicate the direction of the stud group x axis.

See also

Create bolts (page 75)
Bolt properties (page 274)

5.3 Create holes

You can create the following types of holes:

• Round
• Oversized
• Slotted
• Tapped

Note that Tekla Structures uses the same command for creating bolts and holes. Before creating holes, you need to change some of the properties in the
Bolt Properties dialog box. If you want to create only holes without any bolts, clear all the Include in bolt assembly check boxes:

See also
Create round holes (page 83)
Create oversized holes (page 84)
Create slotted holes (page 84)

Create round holes
You can create a group of round holes, or a single round hole. Tekla Structures calculates the diameter of a round hole as the sum of Bolt size and Tolerance.

1. On the Steel tab, hold down Shift and click Bolt to open the Bolt Properties dialog box.
2. If you do not want to create any bolts, clear all the Include in bolt assembly check boxes.
3. If needed, modify the hole properties.
4. Click Apply to save the changes.
5. Create the holes the same way you would create a bolt group:
   a. Select the main part, to which the secondary parts will be bolted.
   b. Select the secondary parts.
   c. Click the middle mouse button to finish selecting parts.
   d. Pick a point to indicate the hole group origin.
   e. Pick a second point to indicate the direction of the hole group x axis.

See also
Create holes (page 82)
Create oversized holes
You can create a group of oversized holes.

1. On the Steel tab, hold down Shift and click Bolt to open the Bolt Properties dialog box.
2. Select the desired Parts with slotted holes check boxes to indicate which plies of the connection get oversized holes.
3. If you do not want to create any bolts, clear all the Include in bolt assembly check boxes.
4. In the Hole type list, select Oversized.
5. In the Oversize box, enter the allowance for the oversized hole.
You can also use a negative value to create smaller (tapped) holes.
6. Click Apply to save the changes.
7. Create the holes the same way you would create a bolt group:
   a. Select the main part, to which the secondary parts will be bolted.
   b. Select the secondary parts.
   c. Click the middle mouse button to finish selecting parts.
   d. Pick a point to indicate the hole group origin.
   e. Pick a second point to indicate the direction of the hole group x axis.

See also
Create holes (page 82)

Create slotted holes
You can create a group of slotted holes.

1. On the Steel tab, hold down Shift and click Bolt to open the Bolt Properties dialog box.
2. To indicate which parts should be slotted, select the desired Parts with slotted holes check boxes.

Tekla Structures counts the pieces of steel from the head of the bolt down. For example, if you select the second check box from the head of the bolt, Tekla Structures slots the second piece of steel from the head of the bolt.
3. If you do not want to create any bolts, clear all the Include in bolt assembly check boxes.
4. In the Hole type list, select Slotted.
5. Enter the allowance for the slotted hole in the x and y directions of the hole group using the **Slotted hole X** or **Slotted hole Y** boxes.

6. If you want to rotate alternate holes by 90 degrees, select **Even** or **Odd** in the **Rotate slots** list.

7. Click **Apply** to save the changes.

8. Create the holes the same way you would create a bolt group:
   a. Select the main part, to which the secondary parts will be bolted.
   b. Select the secondary parts.
   c. Click the middle mouse button to finish selecting parts.
   d. Pick a point to indicate the hole group origin.
   e. Pick a second point to indicate the direction of the hole group x axis.

**See also**

*Create holes (page 82)*
5.4 Create welds

You can either create a weld manually, or use a component that automatically creates welds.

By default, Tekla Structures places the welds above line according to the ISO standard. You can change this to below line to comply with the AISC standard with the advanced option XS_AISC_WELD_MARK.

See also

Set the visibility and appearance of welds (page 86)
Create a weld between parts (page 87)
Create a polygon weld (page 88)
Create a weld to a part (page 89)
Weld preparation (page 89)
Change a weld to a polygon weld (page 91)
User-defined weld cross sections (page 91)
Weld properties (page 278)

Set the visibility and appearance of welds

Modify the display settings to define how welds appear in the model.

1. Double-click the view to open the View Properties dialog box.
2. Click Display to open the Display dialog box.
3. Ensure that the Welds check box is selected.
4. Select a representation option for welds:
   • Fast
     Use this option to show the weld symbols only.
     ![Fast representation](image)
   • Exact
     Use this option to show welds as solid objects with weld symbols, and to display weld marks when you select welds.
• **Exact - no weld mark**

Use this option to show welds as solid objects without weld symbols. Weld marks will not be displayed when you select welds.

5. Ensure that the view is being selected.
6. Click **Modify** to apply the changes.

**NOTE** If the representation option is **Exact** and you still cannot see the weld object in the model, check that the following properties have been defined for the weld in question:

- **Size**
- **Type**
- **Angle**
- **Root opening**

**See also**

- [Weld properties](#)
- [Display settings](#)

**Create a weld between parts**

Weld two parts together using the weld position defined in the **Weld Properties** dialog box. The length of the weld depends on the length of the connection between the welded parts.

1. On the **Steel** tab, click **Weld --> Create weld between parts**.
2. Select the part to weld to.
   
   If you are creating a workshop weld, this is the main part of the assembly.
3. Select the part to be welded.
If you are creating a workshop weld, this is the secondary part of the assembly.

1. Main part
2. Secondary part

See also

- Weld properties (page 278)
- Use welds to create assemblies (page 117)

Create a polygon weld

Create polygon welds when you want to define the exact position of the weld by picking the points you want the weld to traverse.

1. On the Steel tab, click Weld --> Create polygon weld.
2. Select the part to weld to.
   - If you are creating a workshop weld, this is the main part of the assembly.
3. Select the part to be welded.
   - If you are creating a workshop weld, this is the secondary part of the assembly.
4. Pick the starting and end point, or alternatively, pick the points you want the weld to go through.
5. Click the middle mouse button to create the weld.
Create a weld to a part
You can create a weld to a single part, without connecting any other parts.

1. On the Steel tab, click Weld --> Create weld to part.
2. Select the part that you want to weld.
3. Pick the starting and end point, or alternatively, pick the points you want the weld to go through.
4. Click the middle mouse button to create the weld.

Example
Use the Create weld to part command to weld seams in tubular sections:

TIP To model tubular sections with visible seams, use the SPD profile.

Weld preparation
When parts are prepared for welding, their edges can be beveled to produce a groove for the weld. You can define the angle of bevels and grooves.

You can either prepare a part for welding manually, or apply a component that does it automatically, or you can use the Preparation options in the Weld Properties dialog box or in the component weld properties.

See also
Create welds (page 85)
Prepare a part for welding with a polygon (page 90)
Prepare a part for welding with another part (page 90)
Weld properties (page 278)

**Prepare a part for welding with a polygon**
You can manually prepare a part for welding by cutting it with a polygonal shape.

Before you start, ensure that the work plane is on the plane you are cutting on.

1. On the **Steel** tab, click **Weld --> Prepare part for welding with polygon** .
2. Select the part that you want to cut.
3. Pick positions to outline the polygon to be used for cutting.
   - Extend the polygon outside the part, so that it is clear that the part edge should be cut away.
4. Click the middle mouse button to close the polygon and to cut the part.

![Diagram](1)

1. The part to be cut
2. Cuts are displayed using dash-and-dot lines

**See also**
Weld preparation (page 89)
Prepare a part for welding with another part (page 90)

**Prepare a part for welding with another part**
You can manually prepare a part for welding by cutting it with another part. The cutting part will subsequently be deleted.

Before you start, create a cutting part and position it through the part you want to cut.

1. On the **Steel** tab, click **Weld --> Prepare part for welding with another part** .
2. Select the part that you want to cut.
3. Select the cutting part.

![Diagram showing three parts: 1. The part to be cut, 2. The cutting part, 3. Cuts are displayed using dash-and-dot lines.]

See also
Weld preparation (page 89)
Prepare a part for welding with a polygon (page 90)

Change a weld to a polygon weld
You can change existing welds to polygon welds if the existing welds have been created by using the Create weld between parts command or by a component. The new polygon welds will traverse the same points as the original welds did.

1. Select the weld you want to change.
   To select multiple welds, hold down the Ctrl or Shift key.
2. On the Steel tab, click Weld --> Convert to polygon weld.

See also
Create a weld between parts (page 87)
Create a polygon weld (page 88)

User-defined weld cross sections
You can define special cross sections for welds. This is useful when you need weld cross sections that are not predefined in Tekla Structures.
For example, you can create bevel backing welds:

To find the welds in the model that have a user-defined cross section, set **Category** to **Weld** and **Property** to **User-defined cross section** in the selection or view filter, or in the color and transparency settings.

**Limitations**

- User-defined weld cross sections are reported using only the above-line properties.
- User-defined weld cross sections do not create automatic weld preparation.

**See also**

Define a user-defined cross section for a weld (page 92)
Remove a user-defined cross section from a weld (page 93)

### Define a user-defined cross section for a weld

You can define your own cross sections for model welds.

1. Select the weld you want to modify.
2. Right-click and select **Define Cross Section**.
3. In the weld cross section editor view:
   a. Pick points to indicate the weld cross section corners.
   b. Click the middle mouse button to finish picking.

**See also**

Remove a user-defined cross section from a weld (page 93)
User-defined weld cross sections (page 91)
**Remove a user-defined cross section from a weld**

You can remove user-defined cross sections from model welds and revert to the previous standard cross sections.

1. Select a weld that has a user-defined cross section.
2. Right-click and select **Remove Cross Section**.

   Tekla Structures removes the user-defined cross section and uses the previous standard cross section and properties for the weld.

**See also**

- Define a user-defined cross section for a weld (page 92)
- User-defined weld cross sections (page 91)

---

### 5.5 Create fittings

You can fit the end of a part to a plane by creating a straight cutting line between two points you pick. You can use fittings to extend or shorten parts **inside a component**, which makes it easier to create connections, details, and so on. Do not use fittings to otherwise change the length of a part in the model.

1. On the **Edit** tab, click **Fit part end**.
2. Select the part you want to cut with a fitting.
3. Pick the first point of the cutting line.
4. Pick the second point of the cutting line.

   Tekla Structures creates a fitting between the two points you picked. The fitting adjusts the end of a beam on a plane, perpendicular to the view plane.

![Fitting symbol](image)

1 Fitting symbol

**Limitations**

- Fittings cannot be used on contour plates.
• If you apply a second fitting on the same part end, Tekla Structures will ignore the first fitting.

**See also**
Modify the length of a part (page 62)

### 5.6 Create cuts
You can use cuts to shape a part. Do not use cuts to otherwise change the length of a part in the model.

Click the links below to find out more:

- Cut parts with a line (page 94)
- Cut parts with a polygon (page 95)
- Cut parts with another part (page 96)

**Cut parts with a line**
Use line cuts to shape the end of a beam or column. A line cut cuts the end of a beam on a plane that passes through the points you pick. Tekla Structures displays the cut line using dash-and-dot lines.

1. On the **Edit** tab, click **Line cut**.
2. Select the part you want to cut.
3. Pick the first point of the cutting line.
4. Pick the second point of the cutting line.
5. Pick the side you want to remove.
6. If you want to modify the cut, use direct modification.
Example

Cuts are displayed using dash-and-dot lines
Cut lines can be hidden

See also
How to cut efficiently (page 295)

Cut parts with a polygon
A polygon cut cuts a part using a polygonal shape. Tekla Structures displays the cut using dash-and-dot lines.
1. Press Ctrl+P to switch to the plane view.
2. Ensure that the work plane is on the plane you are cutting on.
   For example, if you are creating a polygonal cut on the yz plane, you should temporarily set your work plane to the yz plane as well.
3. On the Edit tab, click Polygon cut.
4. Select the part you want to cut.
5. Pick positions to outline the polygon to be used for cutting.
   Define the polygon so that there is some tolerance between the edges. If the edge of a cutting polygon is in exactly the same position as the edge of the part to be cut, it can be unclear whether the edge should be cut away.
6. Click the middle mouse button to close the polygon and to cut the part.
7. If you want to modify the cut, use direct modification.
Example

1. Polygon-shaped cut
2. Cut lines can be hidden

NOTE  Tekla Structures uses the parametric profile BL to create polygonal cuts.
If you are unable to create polygonal cuts, ensure that the BL profile is defined in the profitab.inp file in ..\ProgramData\Tekla Structures <version>\environments\<environment>\profil as follows:
BL ! PL ! -1 ! ! 1 ! 2 ! ! !

See also
How to cut efficiently (page 295)
Cut parts with another part
You can cut a part using another part. Tekla Structures displays the cut using dash-and-dot lines. Note that you can cut parts that already have cuts. That can be useful, for example, when you want to create more sophisticated cut shapes.

1. Create a cutting part and position it through the part you want to cut.
2. On the Edit tab, click Part cut.
3. Select the part you want to cut.
4. Select the cutting part.
   Tekla Structures cuts the selected main part. The part cut does not affect other parts.
5. Delete the cutting part.
   a. Ensure that the Select cuts and added material selection switch is off.
   b. Select the cutting part and press Delete.

1 Cuts are displayed using dash-and-dot lines
2 Cut lines can be hidden

Limitations
Do not create cuts with the same planes or vertices. Otherwise, it may be unclear what should be cut away.

See also
How to cut efficiently (page 295)
5.7 Create part chamfers

Chamfers are modeling details that can be used to refine the shape of parts for aesthetic, practical, and manufacturing reasons. In Tekla Structures, you can chamfer part corners and part edges.

Limitations

- Only the following parts have corner chamfers: contour plates, concrete slabs, strip footings, steel and concrete polybeams, and concrete panels.
- The end points of a part do not have corner chamfers. The handles that you select must be at corner points or between two segments of a part.

See also

Chamfer part corners (page 98)
Status of polybeam chamfers (page 99)
Chamfer part edges (page 100)

Chamfer part corners

When Tekla Structures creates a part, by default it has a rectangular chamfer at each corner, which does not change the geometry of the part. You can modify the default chamfers.

To modify a corner chamfer:
1. Select the part.
2. Double-click the handle of any part corner.
   
   The Chamfer Properties dialog box is displayed.
3. Modify the chamfer properties.
4. Select the handles of the part corners you want to modify.
5. Click Modify.

See also
Corner chamfer properties (page 284)
Corner chamfer types and dimensions (page 284)
Status of polybeam chamfers (page 99)

Status of polybeam chamfers

Tekla Structures shows the status of polybeam chamfers using the following colors:

<table>
<thead>
<tr>
<th>Color</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Magenta</td>
<td>Correct chamfer</td>
<td><img src="image1.png" alt="Correct Chamfer" /></td>
</tr>
<tr>
<td>Yellow</td>
<td>Correct chamfer that cannot be unfolded</td>
<td><img src="image2.png" alt="Incorrect Chamfer" /></td>
</tr>
<tr>
<td>Red</td>
<td>Incorrect chamfer</td>
<td><img src="image3.png" alt="Incorrect Chamfer" /></td>
</tr>
</tbody>
</table>
**TIP** To see the chamfer lines of polybeams, set the advanced option XS_DRAW_CHAMFERS_HANDLES to CHAMFERS or to CHAMFERS_AND_HANDLES.

See also
Chamfer part corners (page 98)

**Chamfer part edges**

To chamfer the edge of a part in a model view:

1. Double-click the view to open the view properties, click the **Display** button, and ensure that the **Cuts and added material** option is **not** selected in the display settings.
2. On the **Edit** tab, click **Chamfer**.
3. Select the part you want to chamfer.
4. Pick a point where you want the chamfer to start on the part edge.
5. Pick a second point where you want the chamfer to end on the part edge.
   Tekla Structures displays the chamfer in light blue.
6. If needed, you can modify the chamfer.
   a. Double-click the chamfer to open the **Edge Chamfer Properties** dialog box.
   b. Modify the chamfer properties.
   c. Click **Modify**.
7. Right-click the view and select **Redraw View**.
   Tekla Structures removes the chamfered edge.
5.8 Add surface treatment

Use the surface treatment tools to add surface treatment to parts. Surface treatment for concrete parts include flat finishes, surface mixes, and tiles. Surface treatment for steel parts include fire-proofing and unpainted areas, for example.

When you modify the shape or size of a part, Tekla Structures automatically modifies (page 66) the surface treatment to fit the part.

When you create overlapping surface treatments, the smaller surface treatment overrides the larger one. The overlapping area is recognized in reports: only the topmost (visible) surface treatment is calculated.

See also
Modify surface treatment properties (page 102)
Add surface treatment to parts (page 102)
Create new surface treatment options (page 105)
Modify surface treatment properties

1. On the Edit tab, hold down Shift and click Surfaces --> Surface treatment to part face to open the Surface Treatment Properties dialog box.
2. In the Type list, select the type of surface treatment to use.
3. In the Surface treatment name list, select the specific surface treatment.
4. Click Select to select a material from the catalog.
5. Enter the Thickness of the surface treatment.
6. Set the Color to use to display the surface treatment in model views.
7. In the At depth list, select the location of the surface treatment. The options are Middle, Front, and Behind.
8. If needed, define the properties of a tiled surface treatment:
   a. On the Attributes tab, select Tile surface from the Type list.
   b. On the Pattern tab, select the pattern from the Pattern type list.
   c. The Definition table lists the properties of the pattern type.
9. Click Apply or OK to save the surface treatment properties.

See also
Add surface treatment (page 101)

Add surface treatment to parts
This section explains how to add surface treatment to a part.
Click the links below to find out more:

Add surface treatment to a selected area on a part face (page 103)
Add surface treatment to an entire part face (page 103)
Add surface treatment to all faces of a part (page 103)
Add surface treatment to cut faces (page 103)
Surface treatment on chamfered parts (page 104)
Surface treatment on parts with openings and recesses (page 105)
**Add surface treatment to a selected area on a part face**

1. On the **Edit** tab, click **Surfaces --> Surface treatment to selected area**.
3. Pick a point to indicate the direction of the surface treatment.
4. Select an area of the part face to apply the surface treatment to.
   a. Move the mouse pointer over a part. The part faces that you can select are highlighted.
   b. Select the part face.
   c. Pick three or more points on the part face to define a polygonal area.

**See also**

Add surface treatment to parts (page 102)
Modify surface treatment properties (page 102)

**Add surface treatment to an entire part face**

1. On the **Edit** tab, click **Surfaces --> Surface treatment to part face**.
3. Pick a point to indicate the direction of the surface treatment.
4. Select the part to apply the surface treatment to.
   a. Move the mouse cursor over a part. The faces that you can select are highlighted.
   b. Select the part face.

**See also**

Add surface treatment to parts (page 102)
Modify surface treatment properties (page 102)

**Add surface treatment to all faces of a part**

1. On the **Edit** tab, click **Surfaces --> Surface treatment to all part faces**.
2. Select the part to apply the surface treatment to.

**See also**

Add surface treatment to parts (page 102)
Modify surface treatment properties (page 102)
Add surface treatment to cut faces

1. On the Edit tab, click Surfaces and then either Surface treatment to part face or Surface treatment to selected area.
3. Pick the direction.
4. Select the cut face to apply the surface treatment to:

5. If you are using the Surface treatment to selected area command, pick the points to define the area of the surface treatment.

See also
Add surface treatment to parts (page 102)
Modify surface treatment properties (page 102)

Surface treatment on chamfered parts
Take these things into account when adding surface treatment to chamfered parts:

- Surface treatment does not work on sketched profiles with chamfers.
- Add surface treatment before chamfering the part. If surface treatment is applied to a chamfered part, the surface treatment chamfer cannot be modified later on.
- The chamfers for the main part and surface treatment are separate. Modifying the main part chamfer does not affect the surface treatment chamfer.
• The orientation of unsymmetric chamfers depends on the face where it was created (such as top, bottom, left, or right). To change the orientation of an unsymmetric chamfer, you must swap the chamfer’s x and y values.

See also
Add surface treatment to parts (page 102)

Surface treatment on parts with openings and recesses

To force Tekla Structures to consider openings and recesses in parts when adding surface treatment, select the **Cut by father part cuts** check box in the **Surface Treatment Properties** dialog box.

The green surface treatment has the **Cut by father part cuts** check box selected

The tiled surface treatment is not cut by the cut in the part: **Cut by father part cuts** is not selected.

NOTE  If you use the **Surface treatment to all part faces** command and select the **Cut by father part cuts** checkbox, Tekla Structures automatically adds surface treatment also to the cut faces.

See also
Add surface treatment to parts (page 102)
Modify surface treatment properties (page 102)
Create new surface treatment options
You can add new options to the Surface treatment name list in the Surface Treatment Properties dialog box.

NOTE This section is for advanced users.

1. Copy the product_finishes.dat file from the ..\ProgramData\Tekla Structures\<version>\environments\<environment>\system folder to your firm, project, or model folder.

2. Open the copied file using any text editor.

   The first section of the file explains the available types of surface treatment. The surface treatment types are hard-coded, so do not modify this section:

   ```
   // Product finishes
   // -----------------------
   //
   // Type : Type of surfacing
   // 1 = concrete finish
   // 2 = special mix
   // 3 = tile surface
   // 4 = steel finish
   ```

3. Go to the sections that define the options for each type of surface treatment:

   ```
   // ==============
   // *** Concrete Finish
   // ===============
   // WET FINISH
   // =
   1 MF "Magnesium Float"
   1 SMF "Smooth Magnesium Float"
   1 WT "Wet Trowel"
   ```

4. Add rows to define new options.
   a. Define the surface treatment type. For example, 1 for concrete finish.
   b. Define a code for the surface treatment option. For example, MF for Magnesium Float.
   c. Define the full name of the surface treatment option. For example, Magnesium Float. Remember to enclose the name in double quotes " ".

5. Save the file.
See also
Add surface treatment (page 101)

Tiled surface treatment
Tekla Structures includes complex tile and brick surface treatment options, such as basketweave and herringbone patterns. Tiled surface treatment options are based on repeating tile patterns that are stored in XML format.

NOTE This section is for advanced users.

Click the links below to find out more:

Create new tile patterns (page 107)
Example pattern definition (page 108)
Tile pattern definitions (page 110)
Tile pattern elements (page 111)

Create new tile patterns
1. Copy the TilePatternCatalog.xml file from the ..\ProgramData\Tekla Structures\<version>\environments\<environment>\system folder to your firm, project, or model folder.
2. Open the copied file using any text editor.
3. Add a new <TilePattern> element to the file.
   The <TilePattern> element must have <HOffset> and <VOffset> elements and at least one <Tile> element. Other elements are optional.
   
   TIP You may find it easier to copy one of the existing elements, and then modify it to suit your needs.
4. Repeat adding <TilePattern> elements for all the patterns you want to define.
5. Save the TilePatternCatalog.xml file.

See also
Tiled surface treatment (page 107)
Example pattern definition (page 108)
Tile pattern definitions (page 110)
Tile pattern elements (page 111)
Example pattern definition
This example explains how the Basketweave tile pattern is defined in the TilePatternCatalog.xml file.

The Basketweave pattern block is made up of eight tiles:

1. Tile width
2. Mortar width
3. VOffset
4. HOffset
5. Red marks indicate TileOrigin. Angle value for vertical tiles is 90
6. Tile height
7. Mortar height

The pattern is repeated in the x and y direction of the surface treatment, starting from the origin of the surface treatment. You can run the pattern in different x directions:
In the `TilePatternCatalog.xml` file, the pattern is defined as follows:

```xml
<TilePattern Name="Basketweave">
  <Parameter Name="W" DefaultValue="220">
    <Label>_Tile_Width</Label>
  </Parameter>
  <Parameter Name="H" DefaultValue="100">
    <Label>_Tile_Height</Label>
  </Parameter>
  <Parameter Name="TH" DefaultValue="100">
    <Label>_Tile_Thickness</Label>
  </Parameter>
  <Parameter Name="MH" DefaultValue="20">
    <Label>_Mortar_Height</Label>
  </Parameter>
  <Parameter Name="MW" DefaultValue="20">
    <Label>_Mortar_Width</Label>
  </Parameter>
  <HOffset>
    <Vector2D X="W-2*H-3*MW" Y="0" />
  </HOffset>
  <VOffset>
    <Vector2D X="0" Y="W-2*H-3*MH" />
  </VOffset>
  <TileOrigin>
    <Vector2D X="0" Y="0" />
  </TileOrigin>
</TilePattern>
```

1. The name of the pattern
2. The size of the pattern block in the x direction, after which the pattern repeats

Add details to parts 109 Add surface treatment
The size of the pattern block in the y direction, after which the pattern repeats.

The definition file uses the same symbols as the pattern definition table in the **Surface Treatment Properties** dialog box:

<table>
<thead>
<tr>
<th>Property</th>
<th>Symbol</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tile width</td>
<td>W</td>
<td>220.00</td>
<td>mm</td>
</tr>
<tr>
<td>Tile height</td>
<td>H</td>
<td>100.00</td>
<td>mm</td>
</tr>
<tr>
<td>Tile thickness</td>
<td>TH</td>
<td>100.00</td>
<td>mm</td>
</tr>
<tr>
<td>Mortar height</td>
<td>MH</td>
<td>20.00</td>
<td>mm</td>
</tr>
<tr>
<td>Mortar width</td>
<td>MW</td>
<td>20.00</td>
<td>mm</td>
</tr>
</tbody>
</table>

**See also**

Create new tile patterns (page 107)
Tile pattern definitions (page 110)
Tile pattern elements (page 111)

**Tile pattern definitions**

The predefined tile patterns that are available in the **Surface Treatment Properties** dialog box are stored in the following files:

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TilePatternCatalog.xml</td>
<td>• Contains the tile pattern definitions.</td>
</tr>
<tr>
<td></td>
<td>• Located in the ..\ProgramData\Tekla Structures&lt;version&gt;\environments &lt;environment&gt;\system folder.</td>
</tr>
<tr>
<td>TilePatternCatalog.dtd</td>
<td>• Document Type Declaration (DTD) file that defines the elements allowed in the TilePatternCatalog.xml file.</td>
</tr>
<tr>
<td></td>
<td>• Located in the same folder as the TilePatternCatalog.xml file.</td>
</tr>
<tr>
<td>Thumbnail images</td>
<td>• The images that appear on the <strong>Pattern</strong> tab in the <strong>Surface Treatment Properties</strong> dialog box.</td>
</tr>
<tr>
<td></td>
<td>• Located in the ..\ProgramData\Tekla Structures&lt;version&gt;\Bitmaps folder.</td>
</tr>
<tr>
<td>File</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>• Filenames identify the pattern types. For example, herringbone.bmp illustrates the herringbone pattern type.</td>
</tr>
</tbody>
</table>

**See also**
Tiled surface treatment (page 107)

**Tile pattern elements**

The TilePatternCatalog.xml file can contain the following elements:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TilePatternCatalog</td>
<td>The container for tile patterns. Required.</td>
</tr>
<tr>
<td>TilePattern</td>
<td>Tile pattern element. Required. This element can contain the following elements listed in this table.</td>
</tr>
<tr>
<td>HOffset</td>
<td>Horizontal offset of the tile pattern. Required.</td>
</tr>
<tr>
<td>VOffset</td>
<td>Vertical offset of the tile pattern. Required.</td>
</tr>
<tr>
<td>Tile</td>
<td>The individual tiles used in a tile pattern. At least one required.</td>
</tr>
<tr>
<td>Color</td>
<td>Color of the tile or mortar, defined by the RGB values (0–255). Optional.</td>
</tr>
<tr>
<td>Label</td>
<td>The label that identifies a parameter in the dialog box. Optional.</td>
</tr>
<tr>
<td>TileOrigin</td>
<td>The origin of an individual tile, defined from the origin of the pattern. Optional.</td>
</tr>
</tbody>
</table>

**See also**
Tiled surface treatment (page 107)

**Create an unpainted area using the No paint area component**

You can create an unpainted area between bolted steel parts using the No paint area component.

1. Open No paint area from the Applications & components catalog.
2. On the General tab:
a. Click the **Load bolt standards** button to display the available bolt standards, and select the relevant standards.

b. Select the clearance location from the **Create for** list.
   - Define the hole tolerance.
   ![Diagram](image1)
   - Define the contact area offset.
   ![Diagram](image2)

c. In the **Allowable gap** box, enter the maximum distance that can exist between two plates so that the surface treatment can be created.

3. On the **Surfacing attributes** tab:
   a. Select one of the following **Surfacing attributes**.
      - Standard surface treatment properties file
      - A custom surface treatment properties file
      You can create your own properties files using the **Surface Treatment Properties** dialog box. In the properties file, the **Type** has to be **Steel finish** and the **Surface treatment name** has to be **UP - Unpainted**.
      - ... 
      Define the custom attributes and the position for the surface treatment.

4. Click **OK**.

5. Select a bolt group in the model.
The unpainted area is created between the bolted parts.

See also
Modify surface treatment properties (page 102)

5.9 Add a surface to a face
You can add surfaces to the faces of parts and pour objects. You can add surfaces to any face geometry, for example curved faces. You can use surfaces for calculating surface areas, such as formwork areas.

1. On the Edit tab, hold down Shift and click Surfaces --> Add surface to face to open the Surface properties dialog box.
2. Define the surface properties.
   For example, you can define the surface type and whether you want the surface to be cut by the holes in the part or pour object.
3. Click Apply or OK to save the properties.
4. Depending on whether you want to create the surface on a part or on a pour object, use a part view or a pour view.
   To switch between part and pour views, click Pour view on the Concrete tab.

5. Select the part face or pour object face to which you want to add the surface.

See also
Add surface treatment (page 101)
6 Create assemblies

This section explains how to turn steel parts into assemblies.

Tekla Structures creates assemblies of steel parts when you use a workshop weld or bolt to join parts together. Assemblies and their main parts are automatically defined when you create single workshop welds or bolts, or when you apply automatic connections that create workshop welds or bolts.

Click the links below to find out more:

- Create an assembly (page 115)
- Add objects to assemblies (page 118)
- Change the assembly main part (page 121)
- Change the main assembly (page 122)
- Remove objects from an assembly (page 122)
- Check and highlight objects in an assembly (page 122)
- Explode an assembly (page 123)
- Assembly examples (page 123)

6.1 Create an assembly

1. Ensure that the Select assemblies selection switch is active.
2. Select the parts and/or assemblies that you want to join together.
3. Right-click and select Assembly --> Make into assembly.

See also
- Create assemblies (page 115)
- Create a sub-assembly (page 116)
Use bolts to create assemblies (page 116)
Use welds to create assemblies (page 117)

Create a sub-assembly
You can create a sub-assembly of parts that are already in an assembly.

1. Ensure that the Select objects in assemblies selection switch is active.
2. Select the parts you want to include in the sub-assembly.
3. Right-click and select Make into Sub-Assembly.

See also
Create an assembly (page 115)

Use bolts to create assemblies
You can use bolts to create and connect assemblies. You can create nested assemblies by connecting sub-assemblies to an existing assembly, or you can just connect more parts to assemblies using bolts.

To control how Tekla Structures creates assemblies, use the Connect part/assembly and Bolt type lists in the Bolt Properties dialog box. The order in which you select parts when creating the connection determines the main and secondary parts of the assembly or the assembly hierarchy.

<table>
<thead>
<tr>
<th>Connect part/assembly</th>
<th>Bolt type</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>As sub-assembly</td>
<td>Workshop or Site</td>
<td>Nested assembly with the assembly you are bolting as a sub-assembly. The first part you pick determines the assembly to which you are bolting.</td>
</tr>
<tr>
<td>As secondary part</td>
<td>Workshop</td>
<td>Basic assembly with the part you are bolting as a secondary part. The first part you pick usually becomes the main part in the assembly.</td>
</tr>
<tr>
<td>As secondary part</td>
<td>Site</td>
<td>No assembly created.</td>
</tr>
</tbody>
</table>

See also
Create assemblies (page 115)
Bolt sub-assemblies to an existing assembly (page 117)

**Bolt sub-assemblies to an existing assembly**

1. On the Steel tab, hold down Shift and click Bolt Properties to open the Bolt Properties dialog box.
2. In the Connect part/assembly list, select As sub-assembly.
3. Click Apply or OK.
4. Select a part in the assembly to bolt to.
5. Select a part in the sub-assembly to be bolted.
6. Pick the bolt group origin.
7. Pick a point to indicate the bolt group x direction.

**See also**
Use bolts to create assemblies (page 116)

**Use welds to create assemblies**

Tekla Structures forms assemblies based on where the weld should be made. You can create workshop welds and site welds.

The order in which you select parts when creating the connection determines the main and secondary parts of the assembly or the assembly hierarchy. The first part you select becomes the main part of the assembly. Tekla Structures dimensions secondary parts relative to the main part in assembly drawings. The largest main part in the weld becomes the main part of the assembly.

When you connect assemblies, the first part you select determines the assembly to which you weld sub-assemblies.

To control how Tekla Structures creates assemblies, use the Connect part/assembly and Workshop/Site lists in the Weld Properties dialog box.

<table>
<thead>
<tr>
<th>Connect part/assembly</th>
<th>Workshop/Site</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>As sub-assembly</td>
<td>Workshop or Site</td>
<td>Nested assembly with the assembly you are welding as a sub-assembly. The first part you pick determines the assembly to which you are welding.</td>
</tr>
</tbody>
</table>

Create assemblies 117 Create an assembly
### Weld sub-assemblies to an existing assembly

1. On the **Steel** tab, hold down **Shift** and click to open the **Weld Properties** dialog box.
2. In the **Connect part/assembly** list, select **As sub-assembly**.
3. Click **Apply** or **OK**.
4. Select a part in the assembly to weld to.
5. Select a part in the sub-assembly to be welded.
6. To check that the weld marks look correct, create a drawing.

**See also**
- Use welds to create assemblies (page 117)

### 6.2 Add objects to assemblies

You can add objects to assemblies in the following ways:

<table>
<thead>
<tr>
<th>To</th>
<th>Do one of the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a basic assembly</td>
<td>• Add parts to an existing assembly as secondary parts.</td>
</tr>
<tr>
<td></td>
<td>• Bolt or weld parts to an existing assembly as secondary parts.</td>
</tr>
</tbody>
</table>
To | Do one of the following
--- | ---
Create a nested assembly | • Add parts to an existing assembly as secondary parts.
| • Bolt or weld assemblies to an existing assembly as sub-assemblies.
| • Add assemblies to an existing assembly as sub-assemblies.
| • Join existing assemblies together without adding any loose parts.

**NOTE**  Sub-assemblies in a nested assembly retain their own assembly information and main part. You can also define properties separately for the sub-assemblies and the nested assembly by using the part properties dialog box.

**See also**
- Create assemblies (page 115)
- Assembly hierarchy (page 119)
- Add parts to an assembly (page 120)
- Create a nested assembly (page 121)
- Join assemblies (page 121)

**Assembly hierarchy**

You can work on any level of a nested assembly, from single parts and bolts, through the basic and sub-assemblies, up to the highest level of the nested assembly.

To work with nested assemblies, you need to know how to use the Shift key and mouse scrolling to select objects on different levels in the assembly hierarchy.
The assembly hierarchy in nested assemblies affects drawings and reports. You can create separate drawings and reports of the sub-assemblies and the nested assembly, and still produce dimensions, marks, fabrication information, etc. for all assembly levels.

**See also**

*Add objects to assemblies (page 118)*

**Add parts to an assembly**

You can add secondary parts to a basic assembly or to any level of a nested assembly.
1. Ensure that the \textit{Select objects in assemblies} selection switch is active.

2. Select the part you want to add.

3. Right-click and select \textit{Assembly} --- \textit{Add to Assembly}.

4. Select the assembly to add to.

\textbf{See also}

\textit{Add objects to assemblies (page 118)}

\section*{Create a nested assembly}

1. Ensure that the \textit{Select assemblies} selection switch is active.

2. Select the assemblies you want to add to another assembly. They will become sub-assemblies in the nested assembly.

3. Right-click and select \textit{Assembly} --- \textit{Add as sub-assembly}.

4. Select the assembly to add to.

\textbf{See also}

\textit{Add objects to assemblies (page 118)}

\section*{Join assemblies}

You can join existing assemblies without adding any loose parts.

1. Ensure that the \textit{Select assemblies} selection switch is active.

2. Select the assemblies you want to join.

3. Right-click and select \textit{Assembly} --- \textit{Make into Assembly}.

   The assembly with the largest volume becomes the main assembly.

\textbf{See also}

\textit{Change the main assembly (page 122)}

\textit{Add objects to assemblies (page 118)}
6.3 Change the assembly main part

The main part in a steel assembly has other parts welded or bolted to it. By default, the main part is not welded or bolted to any other parts. You can change the main part in an assembly.

1. If needed, check (page 122) what is currently the main part of the assembly.

2. Ensure that the **Select objects in assemblies** selection switch is active.

3. On the Steel tab, click **Assembly --> Set as main object**.

4. Select the new main part.

Tekla Structures changes the main part.

See also

Add objects to assemblies (page 118)

6.4 Change the main assembly

When you join two or more assemblies together, the assembly with the largest volume becomes the main assembly. You can change the main assembly in a nested assembly at any time.

1. Select the new main assembly.

2. Right-click and select **Assembly --> Set as New Main Sub-Assembly**.

See also

Add objects to assemblies (page 118)

6.5 Remove objects from an assembly

1. Select the part or sub-assembly you want to remove.

2. Right-click and select **Assembly > Remove from Assembly**.

See also

Create assemblies (page 115)
6.6 Check and highlight objects in an assembly

Use the Inquire tool to check which objects belong to a particular assembly.

1. On the ribbon, click the down arrow next to , and then select Assembly objects.

2. Select a part that belongs to an assembly.
Tekla Structures highlights the other parts that belong to the same assembly. The following colors are used:

<table>
<thead>
<tr>
<th>Object type</th>
<th>Highlight color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete - main part</td>
<td>magenta</td>
</tr>
<tr>
<td>Concrete - secondary part</td>
<td>cyan</td>
</tr>
<tr>
<td>Reinforcement</td>
<td>blue</td>
</tr>
<tr>
<td>Steel part - main part</td>
<td>orange</td>
</tr>
<tr>
<td>Steel part - secondary part</td>
<td>yellow</td>
</tr>
</tbody>
</table>

See also
Create assemblies (page 115)

6.7 Explode an assembly

When you explode a nested assembly, Tekla Structures breaks the assembly hierarchy level by level, always starting from the highest level. You need to use the Explode command several times to break a nested assembly back to single parts.

You can also explode sub-assemblies to single parts without breaking the entire assembly hierarchy.

1. Select the assembly or sub-assembly you want to explode.

2. Do one of the following:
   - To explode the entire assembly, right-click and select Assembly > Explode.
   - To only explode the sub-assembly, right-click and select Assembly > Explode Sub-Assembly.

See also
Create assemblies (page 115)
6.8 Assembly examples

**Column corbel**

A column corbel is fabricated in one workshop, and then attached to the column in another workshop. Model the corbel as a sub-assembly of the column. Then create an assembly drawing for each workshop: one assembly drawing showing how the corbel is welded together, another assembly drawing showing how the corbel and the other part are welded to the column.

**Complex truss**

Model the halves of a complex truss as assemblies. Create assembly drawings for the workshop to fabricate the truss halves. Then create another assembly drawing showing how the halves should be joined on site.

1. Drawing 2, Workshop 2
2. Drawing 1, Workshop 1
Built-up profile

In a frame of built-up columns and beams, each built-up profile can be a sub-assembly. You can create an assembly drawing showing the entire frame, and separate drawings showing how the columns and beams are constructed.

See also

Create assemblies (page 115)
Create cast units

This section explains how to create cast units.

By default, each concrete part is considered a separate cast unit. For construction purposes, you may need to merge several concrete parts into one cast unit. For example, a single cast unit could consist of a column with corbels.

Click the links below to find out more:

Define the cast unit type of a part (page 126)
Create a cast unit (page 127)
Add objects to a cast unit (page 127)
Change the cast unit main part (page 128)
Remove objects from a cast unit (page 128)
Check and highlight objects in a cast unit (page 128)
Explode a cast unit (page 129)
Casting direction (page 129)

7.1 Define the cast unit type of a part

You must define the cast unit type of concrete parts. Tekla Structures checks the cast unit type of the main part each time you create or modify a cast unit. Precast and cast-in-place parts cannot be mixed within a cast unit.

1. Double-click a concrete part to open the part properties dialog box.
2. Go to the Cast unit tab.
3. In the Cast unit type list, select one of the following:
   • Cast in place
     Cast units that are constructed fully in their final location.
4. Click **Modify** to save the changes.

**NOTE** It is important to use the correct cast unit type, because some functionalities, for example numbering, are based on the cast unit type.

**See also**
Create cast units (page 126)

### 7.2 Create a cast unit

You need to specify which parts form the cast unit. Cast units can include reinforcement, as well as concrete parts.

1. On the **Concrete** tab, click **Cast Unit --&gt; Create cast unit**.
2. Select the objects you want to include in the cast unit.
3. Click the middle mouse button to create the cast unit.

**See also**
Create cast units (page 126)

### 7.3 Add objects to a cast unit

You can use different methods to add objects to cast units. The available methods depend on the objects' material and on the hierarchy you want to create in the cast unit.

To add an object to a cast unit, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
<th>Available for</th>
</tr>
</thead>
</table>
| Add an object as a secondary part | 1. On the **Concrete** tab, click **Cast unit --&gt; Add to cast unit**.  
2. Select the object you want to add.  
3. Select an object in the cast unit. | Concrete, timber, miscellaneous materials |
<p>| Add an object as a sub-assembly | 1. If you are adding a custom part, ensure that the <strong>Select</strong> | Steel, concrete, timber,               |</p>
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
<th>Available for</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>components selection switch is active.</td>
<td>miscellaneous materials</td>
</tr>
<tr>
<td></td>
<td>2. On the Steel tab, click Assembly --&gt; Add as sub-assembly.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3. Select the object you want to add.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>4. Select the cast unit to which you want to add the object.</td>
<td></td>
</tr>
</tbody>
</table>

**See also**
Create cast units (page 126)

### 7.4 Change the cast unit main part

The *main part* in a concrete cast unit is the one with the largest volume of concrete. You can change the main part in a cast unit.

1. If needed, check (page 128) what is currently the main part of the cast unit.

2. Ensure that the ![Select objects in assemblies](image) selection switch is active.
3. Select the new main part.
4. Right-click and select Set as New Main Part of Assembly.

**See also**
Add objects to a cast unit (page 127)

### 7.5 Remove objects from a cast unit

1. On the Concrete tab, click Cast unit --> Remove from cast unit.
2. Select the objects you want to remove.

**See also**
Create cast units (page 126)
7.6 **Check and highlight objects in a cast unit**

Use the **Inquire** tool to check which objects belong to a particular cast unit.

1. On the ribbon, click the down arrow next to 
   Assembly objects.
2. Select a part that belongs to a cast unit.

   Tekla Structures highlights the other parts that belong to the same cast unit. The following colors are used:

<table>
<thead>
<tr>
<th>Object type</th>
<th>Highlight color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete - main part</td>
<td>magenta</td>
</tr>
<tr>
<td>Concrete - secondary part</td>
<td>cyan</td>
</tr>
<tr>
<td>Reinforcement</td>
<td>blue</td>
</tr>
<tr>
<td>Steel part - main part</td>
<td>orange</td>
</tr>
<tr>
<td>Steel part - secondary part</td>
<td>yellow</td>
</tr>
</tbody>
</table>

See also

Create cast units (page 126)

7.7 **Explode a cast unit**

1. On the **Concrete** tab, click **Cast unit --> Explode**.
2. Select an object in the cast unit you want to explode.

See also

Create cast units (page 126)

7.8 **Casting direction**

To indicate the casting direction of a concrete part, you can define which part face you want to face upwards in the casting form. The top-in-form face is displayed in the front view of a drawing.

The casting direction affects the numbering of concrete parts. If you define the casting direction for parts that differ only by their modeling direction, they get different position numbers. This is because the modeling direction affects the
top-in-form face of the parts. By default, the casting direction of the parts is undefined, which means the modeling direction does not affect numbering.

**NOTE** In drawings, use the **Fixed** coordinate system to show the top-in-form face in the front view.

**Example**

In the following example, each cast unit gets a **different** position number, because the top-in-form setting and the orientation of the panels is different. The red arrow indicates the modeling direction.

In the following example, the cast units get the **same** position number, because their top-in-form setting has not been defined. The red arrow indicates the modeling direction.
See also
Create cast units (page 126)
Define the casting direction of a part (page 131)
Number the model (page 207)

Define the casting direction of a part
You can define the casting direction for concrete parts.
1. Set the rendering of parts to **Rendered** by doing one of the following:
   • On the **View** tab, click **Rendering --> Parts rendered**.
   • Press **Ctrl + 4**.
2. Select a concrete part.
3. Right-click and select **Cast Unit --> Set Top in Form Face**.
4. Select the part face that will face upwards in the form.

See also
Casting direction (page 129)

Show the top-in-form face
You can display the top-in-form face of a concrete part in a model view.
1. On the **Concrete** tab, click **Cast unit --> Show top-in-form face**.
2. Click the concrete part whose top-in-form face you want to show.
   Tekla Structures highlights the top-in-form face in red:
TIP To hide the top-in-form face again, right-click the view and select Update Window.

See also
Casting direction (page 129)
With the pour management functionality of Tekla Structures, you can view the geometry of cast-in-place concrete structures, show them as parts or as pour objects, plan pours and pour breaks, and report pour information, such as concrete volumes and formwork areas. You can define pours, pour objects, and pour breaks for concrete parts whose cast unit type is **Cast in place**.

In Tekla Structures, a *pour object* is a building object that consists of one or more cast-in-place concrete parts. The cast-in-place concrete parts are merged into one pour object if they have the same material grade and they touch each other. They also need be in the same *pour phase* to be merged. Pour objects are visible in *pour views*.

A *pour unit* is a management unit for cast-in-place concrete that consists of a pour object and all related reinforcement, embeds, and other objects that need to be in place before concrete can be poured on the building site.

A *pour* is a group of pour objects that is poured at one go.

With a *pour break* you can split a pour object into smaller pour objects.

**NOTE** The pour management functionality is mainly targeted at contractors for quantity take-off, planning, and on-site activities. By default, the pour management functionality is enabled only in the **Contractor** role. If you are using another role, you must enable the functionality by using the advanced option XS_ENABLE_POUR_MANAGEMENT.

**See also**

- Enable the pour functionality (page 134)
- Show concrete structures as continuous (page 135)
- Define the pour phase of a part (page 137)
- Pour objects (page 137)
- Pour units (page 143)
- Pour breaks (page 146)
- View pour errors in a log file (page 155)
8.1 Enable the pour functionality

By default, the pour functionality is enabled only in the Contractor role. If you are using another role, you must enable the functionality in the Advanced Options dialog box.

When the pour functionality is enabled in a model, the commands for showing and creating pour objects and pour breaks in the model and in the drawings will be available.

1. On the File menu, click Settings --> Advanced options to open the Advanced Options dialog box.
2. Under Concrete Detailing, set XS_ENABLE_POUR_MANAGEMENT to TRUE.
3. Click OK.
4. Save and re-open the model for the change to take effect.

**WARNING** If the pours are enabled in the model, do not disable the pours using XS_ENABLE_POUR_MANAGEMENT, especially in the middle of the project. This may cause problems if you have drawings containing pours, and if you are sharing your model. The pours and pour breaks in the model and in the drawings may get invalid, and you may lose all pour-related modeling work.

See also

Disable the pour functionality temporarily (page 134)

Disable the pour functionality temporarily

You can temporarily disable the pour functionality. This may be needed if the pour functionality seems to significantly slow down your model, for example, when the pours and pour objects are very large and require splitting into smaller ones.

When the pour functionality is temporarily disabled, the existing pour objects and pour breaks are still present in the model, but any modifications to the model geometry that would normally update pour objects and pour breaks automatically will not do that. Any information related to pours will be outdated and inaccurate, for example, in reports, and the pour breaks will not
be adaptive. They will be updated automatically when you re-enable the pour functionality.

To disable or re-enable the pour functionality:

1. Go to Quick Launch, start typing pours and pour breaks, and select the Pours and Pour Breaks command from the list that appears.
2. Click Yes in the confirmation dialog box.

**NOTE** If you are working in the multi-user mode, remember to re-enable the pour functionality before you save the model. In this way, information related to pours stays up to date for all users of the model.

**TIP** If you have problems opening a large model with pour objects that contain many parts, you may need to disable the pour functionality before you open the model. You can do this by modifying the xs_user.[user name] file located in the model folder. Set PAPB to 0 to disable pours, and then save the file.

When needed, remember to re-enable the pour functionality.

---

**See also**

Enable the pour functionality (page 134)

---

### 8.2 Show concrete structures as continuous

When the pour functionality is enabled, Tekla Structures shows concrete parts as merged in the model if their cast unit type is **Cast in place**, if they have the same material grade and pour phase number, and if they touch or overlap one
another. When these criteria are met, Tekla Structures automatically removes the outlines of the individual parts within each continuous concrete structure.

You can view cast-in-place concrete structures in model views either as parts or as pour objects. You can switch between part viewing and pour viewing by using the **Pour view** command on the **Concrete** tab or the **Cast in place** part representation setting in the **Display** dialog box.

Continuous concrete structures cannot be selected or highlighted in part views. When you hold the mouse pointer over a concrete structure in a part view, Tekla Structures highlights the original parts belonging to it. You can select a part and modify it if needed:

Duplicates and overlapping parts are counted only once in the volume calculations for pour objects. Note that single part and cast-unit volumes are still calculated the same way as before, which means that the sum of single part and cast-unit volumes may be higher than the volume of pour objects that are defined from exactly the same part geometry.

When you reinforce a concrete structure, you need to reinforce the individual concrete parts within it in part views, or you can reinforce pour objects by using **Reinforcing Bar Shape Catalog** in pour views. The reinforcement geometry follows each part's geometry, not the continuous concrete geometry. Therefore, you can reinforce a part of a continuous concrete structure.
independently from the whole continuous concrete structure. All reinforcement are visible both in part views and in pour views.

See also
Enable the pour functionality (page 134)
View pour objects (page 139)

8.3 Define the pour phase of a part

Use the pour phase property to separate pour objects from one another. By defining pour phases, you can prevent cast-in-place concrete parts from merging even if they have the same material grade and they touch or overlap one another.

**NOTE** Pay attention to pour phases when you create cast-in-place concrete parts. For example, use pour phase 0 for horizontal structures, like beams and slabs, and pour phase 1 for vertical structures, like columns and walls, to separate them to different pour objects. In this way you can make sure that the number of parts included in each single pour object is reasonable, and that your models do not slow down due to too large pour objects.

To modify the pour phase of a part:
1. Double-click a concrete part to open the part properties dialog box.
2. On the **Cast unit** tab, ensure that the cast unit type is set to **Cast in place**.
3. Enter a pour phase in the **Pour phase** box.
   By default, the value is 0. If you are unable to change the value, the cast unit type that you set in step 2 is incorrect.
4. Click **Modify**.

**NOTE** When you define pour phases, make sure that parts in different pour phases do not overlap. As overlapping volumes of different pour phases are not merged, they are counted twice in calculations, and you may end up with incorrect volume, area, or weight information.

See also
Show concrete structures as continuous (page 135)
8.4 Pour objects

Each concrete part whose cast unit type is Cast in place automatically forms a pour object.

Tekla Structures automatically merges multiple cast-in-place concrete parts to a pour object if they have the same material grade and pour phase number, and if they touch or overlap one another.

By creating pour breaks you can split pour objects into smaller pour objects.

**NOTE** Make sure that the number of parts included in each single pour object is reasonable. Too large number of parts and part surfaces in a pour object slows down the model.

Pour objects are visible in pour views. All pour objects are displayed in the same color, regardless of the individual parts' color within a concrete structure. The default color is pink, but you can change it by using the advanced option XS_POUR_OBJECT_COLOR in File menu --> Settings --> Advanced options --> Concrete Detailing.

You can also use different color and transparency settings to show pour object groups, for example, by pour number.

**TIP** You can group pour objects using Organizer or Task Manager.

**Limitations**

The following commands are not available for pour objects: Copy, Move, Delete, Split, and Combine. This is because pour object geometry is defined
by parts. If you want to change the geometry of pour objects, you have to modify the parts instead of pour objects, or you can create pour breaks.

**See also**

View pour objects (page 139)
Change the color and transparency of pour objects (page 140)
Modify the properties of a pour object (page 141)
About the pour type property (page 141)

**View pour objects**

You can view pour objects in model views that are set to show cast-in-place concrete structures as pour objects instead of parts.

Before you start, ensure that the pour management functionality is enabled.

To view pour objects in a model view, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show the pour objects using the <strong>Display</strong> dialog box</td>
<td>1. Double-click the view to open the <strong>View Properties</strong> dialog box.  2. Click <strong>Display</strong> to open the <strong>Display</strong> dialog box.  3. Select <strong>Pours</strong> from the <strong>Cast in place</strong> list.  4. Click <strong>Modify</strong>.</td>
</tr>
<tr>
<td>Show the pour objects using the <strong>Pour view</strong> command</td>
<td>On the <strong>Concrete</strong> tab, click <strong>Pour view</strong>. The command changes the representation of the active view from <strong>Parts</strong> to <strong>Pours</strong>, and the other way round.</td>
</tr>
</tbody>
</table>

**TIP** You can also create two views, a pour view and a part view, and keep them both open side by side on your screen.

**See also**

Enable the pour functionality (page 134)
Pour objects (page 137)
Change the color and transparency of pour objects (page 140)
Show concrete structures as continuous (page 135)
Change the color and transparency of pour objects

By default, all pour objects are displayed in pink in pour views, regardless of the individual parts' color. You can customize the pour object color and transparency in model views by defining object groups and then selecting specific color and transparency settings for each group.

**TIP** To change the default color of pour objects, use the advanced option XS_POUR_OBJECT_COLOR in **File menu --> Settings --> Advanced options --> Concrete Detailing**.

**NOTE** Customized colors are not preserved when you export pour objects. In the exported model, all pour objects are displayed in pink.

1. On the **View** tab, click **Representation**. The **Object Representation** dialog box is displayed.
2. Create a new object group for the pour objects whose color and transparency you wish to change.
   a. In the **Object Representation** dialog box, click **Object group**.
   b. In the **Object Group - Representation** dialog box, click **Add row**.
   c. To direct the settings to pour objects instead of parts, select the following options for the row:
      • **Category** = Object
      • **Property** = Object type
      • **Condition** = Equals
      • **Value** = Pour object
   d. If needed, add any additional filtering criteria.
      For example, to filter pour objects by a certain user-defined attribute, add a row with **Pour object** as **Category**, and define the **Property**, **Condition**, and **Value** as desired.
   e. Enter a unique name in the box next to the **Save as** button.
   f. Click **Save as** to save the object group.
   g. Click **Close**.
3. Repeat step 2 if you wish to create more object groups.
4. In the **Object Representation** dialog box, select an object group from the **Object group** list.
5. In the **Color** list, choose a color for the object group.
6. In the **Transparency** list, set the transparency of the object group.
7. Click **Modify**.
   The object group's color and transparency changes in the model.

**See also**

- Define color and transparency settings (page 176)
- Define your own colors for object groups (page 174)

**Modify the properties of a pour object**

Pour objects have properties and user-defined attributes which you can view, define, and modify.

For example, you can enter a **Pour number** that groups pour objects to a pour, or a **Pour type** that you can use to describe each pour object.

![Pour Object Properties dialog box](image)

1. Ensure that you are using a pour view. If not, click **Pour view** on the **Concrete** tab to show the pour objects.
   By default, the pour objects are shown in pink.
2. Double-click the pour object whose properties you want to modify.
3. In the **Pour Object Properties** dialog box, enter or modify the pour object properties.
4. Click **Modify**.

**See also**

- About the pour type property (page 141)
- Pour objects (page 137)
About the pour type property
You can use the **Pour type** property to describe pour objects.

When you create or copy a cast-in-place concrete part, Tekla Structures automatically creates a pour object of it. By default, Tekla Structures uses the part name as the **Pour type** property of the pour object. The default pour type is enclosed in square brackets [] and it will be automatically updated if you change the part name. If you modify the pour type, the brackets are automatically removed, the modified pour type you enter replaces the default value, and the pour type no longer automatically changes by the part name.

Merging pour objects
When pour objects with default pour types in square brackets [] are merged to a larger pour object, the default pour type of the new pour object is the name of the part with the largest volume in the new pour object.

1. **Pour type** = [SLAB]
2. **Pour type** = [BEAM]
3. **Pour type** = [SLAB]

Splitting pour objects with pour breaks
When you create a pour break and split a pour object into smaller pour objects, the smaller pour objects inherit their properties from the original pour object.

When a pour object with the default pour type in square brackets [] is split, each new pour object also receives a default pour type by the part name, that is, the name of the part with the largest volume in the new pour object.

1. **Pour type** = [SLAB]
2. **Pour type** = [SLAB]
3. **Pour type = [BEAM]**

If you have modified the pour type of the original pour object and the pour type is no longer in square brackets [], the modified pour type value is used also for the new pour objects.

**See also**

Modify the properties of a pour object (page 141)

Pour objects (page 137)

---

### 8.5 Pour units

A *pour unit* is a management unit for cast-in-place concrete. The pour unit consists of a pour object and all related reinforcement, embeds, and other objects that need to be in place before concrete can be poured on the building site.

You can create pour units automatically by attaching objects to each pour object in the model. You can also modify the pour units manually.

The following model objects can be attached to pour objects to create pour units:

- Reinforcement, such as single reinforcing bars, bar groups, reinforcement meshes and strands
- Assemblies (for example, embeds)
- Sub-assemblies (for example, embeds in cast-in-place cast units)
- Bolts (for example, anchor bolts and shear studs)
- Precast cast units
- Surfaces added to the pour object

*Note that some model objects such as parts and welds cannot be directly attached to a pour object. Instead, these objects are indirectly linked to the pour object through the assemblies and cast units they belong to.*

One model object can be included in only one pour unit at a time.

---

**Calculate pour units**

You can have Tekla Structures detect which objects form pour units and automatically attach the related objects to each pour object.

1. On the **Concrete** tab, click **Calculate pour units**.

   Tekla Structures attaches objects to pour objects (page 145) and creates pour units.
You can check the created pour units in a pour view, or using the Inquire tool, Organizer, or reports.

If you want to modify the pour units, you can manually add and remove pour unit objects. The manual additions will be kept even if you use the Calculate pour units command again, but the objects you manually remove from pour units will be re-attached.

Check and highlight objects in a pour unit
You can visually check which objects are included in a pour unit.

1. Ensure that you are using a pour view. If not, on the Concrete tab, click Pour view to show the pour objects.

2. Ensure that the Select assemblies selection switch is active.

3. Select a pour object.
   
   A magenta box indicates the pour unit. The objects that are attached to the pour object are also highlighted.

Inquire a pour unit
Use the Inquire tool to check which objects belong to a particular pour unit and to get information about these objects.

1. Ensure that you are using a pour view. If not, on the Concrete tab, click Pour view to show the pour objects.

2. Select a pour object.

3. Right-click and select Inquire.
Tekla Structures highlights the objects that belong to the same pour unit as the pour object.

Tekla Structures also lists the pour unit objects and their properties in the Inquire Object dialog box.

**Add objects to a pour unit**
After using the Calculate pour units command, you can manually add objects to pour units.

1. Ensure that you are using a pour view. If not, on the Concrete tab, click Pour view to show the pour objects.
2. Select the objects that you want to add to a pour unit.
   You can select reinforcement, assemblies, cast units, and bolts.
3. Right-click and select Pour --> Add to pour unit.
4. Select the pour object to which you want to attach the objects.

Tekla Structures adds all the objects that can be added to the pour unit. The unallowed objects are not added.

**Remove objects from a pour unit**
After using the Calculate pour units command, you can manually remove objects from pour units.

1. Select the object that you want to remove from a pour unit.
2. Right-click and select Pour --> Remove from pour unit.

The removed object can then be added to another pour unit either manually with the Pour --> Add to pour unit command, or automatically with the Calculate pour units command.

**How Tekla Structures attaches objects to pour objects**
When you use the Calculate pour units command, Tekla Structures automatically attaches objects to pour objects to create pour units.

Each object that collides with a pour object, meaning that the object at least partly overlaps the pour object, can be directly or indirectly attached to the pour object and included in the same pour unit as the pour object.

If any object in an assembly or cast unit collides with a pour object, the entire assembly or cast unit is included in the pour unit.

If any reinforcing bar or strand in a group collides with a pour object, the entire group is included in the pour unit, unless the bar or strand belongs to a precast cast unit.
**Objects colliding with more than one pour object**

If an object collides with more than one pour object, the object will be attached to the pour object whose bounding box has the lowest global z coordinate.

For example, the reinforcing bars colliding with a footing pour object and a column pour object are attached to the footing pour object because its bottom face has a lower global z coordinate than the column pour object.

If the lowest global z coordinates of the pour object bounding boxes are the same or differ less than 100 mm, the object will be attached to one of the pour objects according to these rules:

1. If the object's center of gravity is within only one of the colliding pour object bounding boxes, the object will be attached to that pour object.
2. If the object's center of gravity is within more than one pour object bounding box, or completely outside any pour object bounding box, the object will be attached to the pour object whose center of gravity is closest to the object's center of gravity.

**See also**

*Pour units (page 143)*

### 8.6 Pour breaks

Use pour breaks to split pour objects into smaller pieces.
Pour breaks are visible and you can work with them both in pour views and in part views. Pour breaks are displayed as a thin plane or line, depending on the part representation setting.

WARNING  Pour breaks do not follow the part. If you move the part, the pour break remains at the original location.

If a pour break does not split a pour object completely into two, the pour break is displayed in red by default. This means that it is invalid and needs to be remodeled.

See also
Pour break adaptivity (page 147)
Set the visibility of pour breaks (page 148)
Create a pour break (page 149)
Select a pour break (page 151)
Copy a pour break (page 151)
Move a pour break (page 151)
Modify a pour break (page 152)
Remove a pour break (page 153)
Pour break adaptivity

Pour breaks are adaptive to changes in cast-in-place concrete parts and pour objects. This means that if you change the geometry or location of a cast-in-place concrete part or pour object, its pour breaks change accordingly.

If you delete a cast-in-place concrete part, its pour breaks disappear as well.

If you modify a cast-in-place concrete structure in any of the following ways, its pour breaks adapt:

- Change the profile or dimensions of a part
- Add or remove cuts or fittings
- Change chamfer shape or dimensions
- Add or remove parts of the cast-in-place concrete structure by:
  - Changing the cast unit type of a part from Precast to Cast in place or vice versa
  - Changing the pour phase of a part
  - Changing the concrete grade of a part
  - Moving, copying, or deleting parts

If you move a cast-in-place concrete part outside its pour breaks, the pour breaks disappear. If you move a part so that it still hits one or more pour breaks, the pour breaks that are inside the part stay in their original locations and adapt to the part in the new location.

If you copy or move a pour break and it hits a cast-in-place concrete part in the destination location, the pour break adapts to the part.

If a pour break is dependent on another pour break that is split or deleted, the dependent pour break is deleted as well. If a pour break is dependent on another pour break that is moved, the dependent pour break adapts inside the pour object, as long as the pour break plane can touch the moved pour break.

Set the visibility of pour breaks

You can show pour breaks in model views.

Before you start, ensure that the pour management functionality is enabled (page 134).

1. Double-click a model view to open the View Properties dialog box.
2. Click Display to open the Display dialog box.
3. Select the Pour break check box.
4. Click Modify.
See also
Pour breaks (page 146)

Create a pour break
You can add pour breaks to pour objects or concrete parts whose cast unit type is **Cast in place**.

You can create pour breaks by picking one, two, or more points in the model.

When you create a pour break that traverses more than two points, the pour break will be limited to the pour object it splits and perpendicular to the current work plane. If you need to create an inclined or horizontal pour break using multiple points, shift the work plane first.

**TIP** Use the **Snap to nearest points** snap switch to start or end pour breaks on part or pour object edges.

Use the **Snap to any position** snap switch to pick intermediate points for pour breaks.

To create a pour break, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Create a pour break, perpendicular to a part face, using one point | 1. On the **Concrete** tab, click **Pour break** --- Single point.  
  2. Pick the location for the pour break. |
| Create a pour break that splits all cast-in-place concrete parts and pour objects located between two points | 1. On the **Concrete** tab, click **Pour break** --- Two points.  
  2. Pick two points to define the location of the pour break. |
| Create a pour break using multiple points | 1. If needed, shift the work plane.  
  2. On the **Concrete** tab, click **Pour break** --- Multiple points.  
  3. Pick the points you want the pour break to go through. |
| Create a pour break defined by the opposite corners of a rectangle | 1. If needed, shift the work plane.  
  2. On the **Concrete** tab, click **Pour break** --- Multiple points. |
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Create a pour break defined by the center and one corner of a rectangle | 1. If needed, shift the work plane.  
2. On the **Concrete** tab, click **Pour break** --> **Multiple points**.  
3. Hover over 🗼, and then click 🗼 on the toolbar that appears.  
4. Pick the center point of the pour break.  
5. Pick one corner point of the pour break. |
| Create a pour break defined by three corners of a rectangle | 1. If needed, shift the work plane.  
2. On the **Concrete** tab, click **Pour break** --> **Multiple points**.  
3. Hover over 🗼, and then click 🗼 on the toolbar that appears.  
4. Pick three corner points of the pour break. |
| Create a pour break defined by one side midpoint and two corners of a rectangle | 1. If needed, shift the work plane.  
2. On the **Concrete** tab, click **Pour break** --> **Multiple points**.  
3. Hover over 🗼, and then click 🗼 on the toolbar that appears.  
4. Pick one side midpoint of the pour break.  
5. Pick two corner points of the pour break. |

**See also**  
*Select a pour break (page 151)*
Copy a pour break (page 151)
Move a pour break (page 151)
Modify a pour break (page 152)

Select a pour break

1. Ensure that the Select pour breaks selection switch is active.
2. Select the pour break.

See also
Pour breaks (page 146)

Copy a pour break

1. Ensure that the Select pour breaks selection switch is active.
2. Select the pour break.
3. Copy the pour break like any other object in Tekla Structures. For example, right-click and select Copy.

See also
Pour breaks (page 146)

Move a pour break
You can move existing pour breaks. This may be needed, for example, if you have moved the part, because the pour break does not follow the part.

1. Ensure that the Select pour breaks selection switch is active.
2. Select the pour break.
3. Move the pour break like any other object in Tekla Structures. For example, right-click and select Move.

See also
Pour breaks (page 146)
Modify a pour break (page 152)
Modify a pour break
You can modify existing pour breaks.

Before you start:

- Ensure that the Direct modification switch is active.
- Ensure that the Select pour breaks selection switch is active.
- Select the pour break.

Tekla Structures displays the handles and dimensions that you can use to modify the pour break.

To modify a pour break:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the shape or location of the pour break</td>
<td>Drag a corner point or an end point to a new location.</td>
</tr>
<tr>
<td>Change a location dimension</td>
<td>Drag a dimension arrowhead to a new location, or:</td>
</tr>
<tr>
<td></td>
<td>1. Select the dimension arrowhead which you want to move.</td>
</tr>
<tr>
<td></td>
<td>2. Using the keyboard, enter the value with which you want the dimension to change.</td>
</tr>
<tr>
<td></td>
<td>To start with the negative sign (-), use the numeric keypad.</td>
</tr>
<tr>
<td></td>
<td>To enter an absolute value for the dimension, first enter $, then the value.</td>
</tr>
<tr>
<td></td>
<td>3. Press Enter, or click OK in the Enter a Numeric Location dialog box.</td>
</tr>
<tr>
<td>Add an intermediate point to the pour break</td>
<td>Drag a midpoint handle to a new location.</td>
</tr>
<tr>
<td>To</td>
<td>Do this</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>----------------------------------------------</td>
</tr>
</tbody>
</table>
| Remove an intermediate point fr the pour break | 1. Select an intermediate corner point.  
|                                          | 2. Press Delete.                             |

**See also**

*Pour breaks (page 146)*

### Remove a pour break

1. Ensure that the *Select pour breaks* selection switch is active.
2. Select the pour break.
3. Press *Delete*.

**See also**

*Pour breaks (page 146)*

### 8.7 Troubleshoot pours

When you work with cast-in-place concrete parts, it is important that you regularly check the resulting pour objects, and try to get rid of the errors related to them, before you start detailing, or creating drawings and reports. The errors in solid pour objects may lead to inaccuracies in volume and other quantity calculations, and to incorrect representation in drawings.

While you model, use the following methods to check the model for pour-related errors:

- Check if there are *Solid error* rows in the session history log file.
- Ensure that the cast-in-place concrete parts and pour objects look continuous in model views. They should not have part outlines or shadow lines inside them, like in the following images:

Manage pours 153 Troubleshoot pours
If you notice errors or overlapping volumes or faces, try remodeling some of the parts.

You can also try out the following tips to avoid pour-related errors:

• Make sure that the number of parts included in a single pour object is reasonable.
• Sometimes modeling the parts in a different order may fix errors in pour objects.
• To control which lines are visible in drawings, use the advanced options XS_DRAW_CAST_PHASE_INTERNAL_LINES and XS_DRAW_CAST_UNIT_INTERNAL_LINES.

This may help because the cast-in-place concrete parts that have errors are treated in the same way in drawings as the precast concrete parts.

If remodeling the parts does not fix errors in solid pour objects, then overlap the parts as little as possible to ensure that the volume and quantity calculations are close to the correct values.
See also

View pour errors in a log file (page 155)
Example: Identify and fix a pour error (page 155)
Manage pours (page 133)

View pour errors in a log file
You can view pour-related errors in a log file. This may be needed, for example, if overlapping volumes and faces occur for parts and pour objects, and you need to analyze the error.

1. On the File menu, click Logs --> Session history log.
2. Look for rows that start with the phrase Solid error.
3. Click the corresponding Solid failure position row to show the solid object error.
   A diamond-shaped position locator is displayed in the model to point you to the error.

   TIP When you click a Solid error row in the log file, hold down the z key to center the view to the error location.

4. Redraw the view to hide the position locator.

See also
Troubleshoot pours (page 153)
Example: Identify and fix a pour error (page 155)
Manage pours (page 133)
Example: Identify and fix a pour error

This is how an error related to a solid pour object can be indicated in a model view and in a drawing. The pour object is not shown as continuous, and there are extra lines between the parts in the pour object:

Checking the session history log file and clicking a Solid failure position row helps you to locate the error in the model (press Ctrl+2 to see through the parts):

Try moving a beam end so that it is no longer on the same surface as the column side:

This is how the model and the drawing look like after you have fixed the model:
Also the volume of the pour object is now correct, for example, in reports. The overlapping volume of the beam and the column is only counted once.

See also

Troubleshoot pours (page 153)
View pour errors in a log file (page 155)

8.8 Example: Create concrete geometry and work with pours

The guidelines in this example help you to efficiently model cast-in-place concrete geometries, and to define, visualize, sequence, and report pours and pour breaks.

Before you start, ensure that you have the pour management functionality enabled. See Enable the pour functionality (page 134).

1. If possible, use an existing engineering or architectural model or drawing as a basis when you create concrete structures in Tekla Structures.
   Import the existing model or drawing as a reference model to your Tekla Structures model.
   See Import a reference model and Reference models.

2. If you are using an IFC model as a reference model:
   a. Convert the concrete structures you need from the IFC model to native Tekla Structures objects.
      See Convert IFC objects into native Tekla Structures objects and Example: Convert IFC objects into Tekla Structures objects in one go.
   b. Check the conversion results.
   c. If needed, modify the converted objects.
For example, you may need to change the profile, material, or cast unit type of the converted objects.

**TIP** Use Organizer for checking and selecting objects.

3. If you are using a different reference model type, or if there are structures that cannot be converted from an IFC model, model the needed concrete structures as cast-in-place concrete parts in Tekla Structures.
   
   You can model by tracing over the reference model.
   
   See Create concrete parts (page 51).

4. For each cast-in-place concrete part, define a pour phase number to divide your Tekla Structures model into pour objects.
   
   For example, use the default pour phase 0 for horizontal structures, like beams and slabs, and the default pour phase 1 for vertical structures, like columns and walls, to separate them to different pour objects.
   
   See Define the pour phase of a part (page 137).

   **TIP** Use selection filters or Organizer to efficiently select multiple parts and to modify them all at the same time.

5. View and check the pour objects in a pour view.
   
   See View pour objects (page 139) and Pour objects (page 137).

6. If needed, modify the pour phases or create pour breaks to fine-tune the pour objects.
   
   For example, create pour breaks to split large slabs into smaller pour objects.
   
   See Create a pour break (page 149) and Pour breaks (page 146).

7. Once you are ready with the concrete geometry and pour objects, you can define pour sequences by entering pour numbers for pour objects, or by using the Organizer categories.
   
   You can also define other properties for pour objects, for example, concrete mixtures, or dates or status of workflow.
   
   See Modify the properties of a pour object (page 141) and Categories in Organizer.

8. Use Organizer to categorize pours. Then you can select them by their sequence and report pour-specific information, such as pour volumes and formwork areas.
See View object properties in Organizer and Example: Organize the model into location and custom categories, and view quantities.

9. If you wish, use **Task Manager** to include pour objects in tasks and to schedule pours. You can then visualize pour status information based on planned and actual dates by using **Project Status Visualization**.
See Create a task in Task Manager, Link a task to the model in Task Manager, and Project Status Visualization.

Manage pours 160  Example: Create concrete geometry and work with pours
Show and hide model objects

This section explains how to control the visibility and appearance of parts and other model objects. Click the links below to find out more:

Set the visibility and appearance of model objects (page 161)
Change the rendering of parts and components (page 163)
Hide model objects (page 165)
Show only selected model objects (page 166)
Temporarily display assembly and component objects (page 167)
Display detailing of a part (page 168)

9.1 Set the visibility and appearance of model objects
Modify the display settings to define how parts and other model objects appear in a model view.

1. Double-click the view to open the View Properties dialog box.
2. Click Display to open the Display dialog box.
3. Select or clear check boxes to specify which objects are visible in the view.
4. Select a representation option for parts, bolts, holes, welds, construction planes and reinforcing bars.
   You have the following options:
   • Fast
   • Exact
   • Reference line (only for parts)
   • Exact slotted holes (only for holes)
• **Exact - no weld mark** (only for welds)
  For cast-in-place concrete parts, you can select whether you want to show them as **Parts** or as **Pours**.

5. Ensure that the view is selected.
6. Click **Modify** to apply the changes.

**See also**
- Display settings (page 248)
- Show parts with exact lines (page 162)
- Show parts with high accuracy (page 162)
- View pour objects (page 139)
- Change the rendering of parts and components (page 163)

**Show parts with exact lines**
Use the **Show Part with Exact Lines** command to temporarily display a part with exact lines even if you are using the **Fast** representation option for parts.

1. Select the part.
2. Go to **Quick Launch**, start typing `show part with exact lines`, and select the **Show Part with Exact Lines** command from the list that appears.
3. Click the view in which you want to display exact lines.
4. To clear the exact lines effect, on the **View** tab, click ![Icon](icon.png).

**See also**
- Show and hide model objects (page 161)

**Show parts with high accuracy**
You can temporarily display parts with the highest possible level of accuracy. This can be useful, for example, when checking a large model, because the entire model can still be displayed in the **Fast** or **Exact** representation mode but the individual part can be shown in more detail.

1. Select the parts.
2. Right-click, and then hold down the **Shift** key while selecting **Show with Exact Lines**.

   Tekla Structures displays the selected parts with the highest possible level of accuracy.
3. To clear the high accuracy effect, right-click and select *Show with Exact Lines*.

![Diagram showing normal display mode and high accuracy mode](image)

1. Normal display mode
2. High accuracy mode

**See also**
- *Show and hide model objects (page 161)*
- *Display settings (page 248)*

### 9.2 Change the rendering of parts and components

You can easily change the rendering of parts and components in model views.

1. On the **View** tab, click **Rendering**.
2. Select one of the rendering options for parts or components:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Wireframe</strong></td>
<td>Object outlines are displayed, surfaces are not. Objects are transparent.</td>
<td>In this wireframe example, component objects are displayed as rendered.</td>
</tr>
<tr>
<td><strong>Rendered</strong></td>
<td><strong>wireframe</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Object outlines are displayed. Objects are transparent, and their surfaces are rendered.</td>
<td>In this rendered wireframe example, component objects are displayed as rendered.</td>
</tr>
<tr>
<td><strong>Grayscale</strong></td>
<td>Objects are shown in grayscale.</td>
<td></td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Rendered</td>
<td>Object surfaces are displayed. Objects are not transparent.</td>
<td></td>
</tr>
<tr>
<td>Show only selected</td>
<td>Selected objects are displayed. Other objects are almost completely transparent. This option is useful, for example, when viewing clash check results in a large model.</td>
<td></td>
</tr>
</tbody>
</table>

**TIP** Alternatively, you can use the keyboard shortcuts **Ctrl+1...5** for parts and **Shift +1...5** for components to switch between the rendering options.

See also

Set the visibility and appearance of model objects (page 161)

### 9.3 Hide model objects

You can quickly hide selected parts or other objects in a model view. This can be useful, for example, when you want to temporarily hide parts to see the parts behind them.

1. Select the objects you want to hide.
2. Right-click and select **Hide**.
   The selected objects become invisible.

3. To make the objects visible again, click ⬤ on the **View** tab.

**See also**

*Show only selected model objects (page 166)*

### 9.4 Show only selected model objects

As an alternative to hiding single objects in a model view, you can define which objects you want to keep visible. All of the other, unselected objects will be hidden.

1. Select the objects that you want to keep visible.
2. Right-click and select **Show Only Selected**.
   The unselected objects become almost transparent.

   **TIP** To completely hide the unselected objects, hold down the **Shift** key when selecting the command.
   To show the unselected parts as sticks, hold down the **Ctrl** key when selecting the command.

3. To make the objects visible again, click on the **View** tab.

**See also**

*Hide model objects (page 165)*

### 9.5 Temporarily display assembly and component objects

You can temporarily show the contents of an assembly or a component even if some of the assembly or component objects are not visible in a model view.
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show the contents of an assembly</td>
<td>1. Right-click an assembly, or a part in the assembly.</td>
</tr>
<tr>
<td></td>
<td>2. Select <strong>Assembly --&gt; Show Assembly</strong>.</td>
</tr>
<tr>
<td></td>
<td>For a concrete part, select <strong>Show assembly</strong>.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures shows an orange box around the assembly, and displays all parts, bolts, welds, and other details (not cuts or fittings) belonging to the assembly, even if you had defined them as hidden in the display settings (page 248).</td>
</tr>
<tr>
<td></td>
<td>For concrete parts, Tekla Structures displays reinforcement and surface treatment (not surfaces), even if you had defined them as hidden in the display settings.</td>
</tr>
<tr>
<td>Show the contents of a component</td>
<td>1. On the <strong>View</strong> tab, click <strong>Rendering --&gt; Show component content</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Select a component.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures displays all bolts, welds, and other details belonging to the component, even if you had defined them as hidden in the display settings (page 248).</td>
</tr>
<tr>
<td>Reapply the display settings (page 248) and make assembly or component objects hidden again</td>
<td>On the <strong>View</strong> tab, click <img src="" alt="on" />.</td>
</tr>
</tbody>
</table>

**See also**

Display detailing of a part (page 168)

Set the visibility and appearance of model objects (page 161)

### 9.6 Display detailing of a part

In some cases it is useful to see in the model all the objects that are connected to a part, such as components, welds, fittings, reinforcement, and surfaces. You can then examine, for example, whether parts are welded correctly.

1. Select a part.

2. Click ![on] **Display detailing** on the contextual toolbar. Alternatively, you can press **Alt+D**, or use **Quick Launch**.
For steel parts, Tekla Structures displays all parts, bolts, welds, cuts, fittings, and other details belonging to the assembly, even if you had defined them as hidden in the display settings [page 248]. For concrete parts, Tekla Structures displays also reinforcement, surface treatment, and surfaces.

**See also**

- Temporarily display assembly and component objects [page 167]
- Set the visibility and appearance of model objects [page 161]
You can group parts and other objects based on their properties. Use object groups to control the color and transparency of parts in the model. Object groups are also needed in model view filters, selection filters, Organizer filters, and with the Project Status Visualization tool.

Click the links below to find out more:

Create an object group (page 170)
Copy an object group to another model (page 171)
Delete an object group (page 171)

10.1 Create an object group

1. On the View tab, click Representation to open the Object Representation dialog box.
2. Click Object group to open the Object Group - Representation dialog box.
3. Modify the object group settings.
   You can use the same object properties and techniques as in filtering.
   a. Click Add row.
   b. Select options from the Category, Property, and Condition lists.
   c. In the Value list, enter a value or select one from the model.
   d. Add more rows, and use the And/Or options or parentheses to create more complex rules.
4. Select the check boxes next to all object group rules that you want to enable.
   The check boxes define which rules are enabled and effective.
5. Enter a unique name in the box next to the Save as button.
6. Click Save as to save the object group.

See also
Change the color of an object group (page 174)

10.2 Copy an object group to another model

1. Select the object group you want to copy.

   The object groups you have created are located in the model's \attributes folder, and they have the file name extension *.PObjGrp.

2. Select where you want to copy the object group.

   • To make an object group available in another model, copy the file to the \attributes folder of the destination model.

   • To make an object group available in all models, copy the file to the project or firm folder, defined by the advanced option XS_PROJECT or XS_FIRM.

3. Restart Tekla Structures.

See also
Group parts together (page 170)

10.3 Delete an object group

1. Delete the object group file located in the model's attributes folder.

   Object groups have the file name extension *.PObjGrp.

2. Restart Tekla Structures.

See also
Group parts together (page 170)
You can modify the color and transparency of model objects and create customized presentations of the model. The following images show the same model with different transparency settings:

1. Standard color and transparency settings
2. Only parts whose profile name starts with IPE* or HEA* are visible
3. Parts whose user-defined attribute **Planned erection date** is set to a certain date are displayed in blue, while all other parts are 90% transparent

**See also**

Change the color of a model object (page 173)
11.1 Change the color of a model object

You can change the color of individual objects in a model by modifying their class on the contextual toolbar or in the properties dialog box. Alternatively, you can use the object representation settings to specify colors for entire object groups.

The possible class numbers range between 0 and 14, and result in different colors as follows:

- Class 0
- Class 1
- Class 2
- Class 3
- Class 4
- Class 5
- Class 6
- Class 7
- Class 8
- Class 9
- Class 10
- Class 11
- Class 12
- Class 13
- Class 14

Class numbers above 14 produce the same colors as 1...14. For example, class numbers 2, 16, 30, 44, and so on, all result in red.

You can also use class numbers to define the default color of pour objects and pour breaks.

To change the color and class of a part or reinforcement:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Change object color on the contextual toolbar | 1. Select a model object.  
2. On the contextual toolbar, select a new class. |
### 11.2 Change the color of an object group

You can customize the color of model objects by selecting a specific color for each object group. You can use an unlimited number of colors. This option gives you more freedom in visualizing the different types of objects in the model.

1. On the View tab, click **Representation** to open the **Object Representation** dialog box.
2. Select an object group from the **Object group** list.
3. In the **Color** list, select a color (page 250).
4. In the **Transparency** list, select the desired transparency (page 251) option.
5. Click **Save** to save the changes.
6. Click **Modify** to change the color of objects in the model.

**See also**
- Create an object group (page 170)
- Define your own colors for object groups (page 174)
- Change the color of a model object (page 173)

### Define your own colors for object groups

1. On the View tab, click **Representation** to open the **Object Representation** dialog box.
2. Select an object group from the **Object Group** list.
3. In the **Color** list, select **Choose color**.
4. Do one of the following:
   • Click a color in the **Basic colors** palette.
     ![Basic colors palette]
   • Click **Define Custom Colors** and create a color of your own:
     a. Click a color in the color window.
     ![Color window]
     b. Define the color depth by using the color bar on the right, or enter the exact RGB values.
     c. Click **Add to Custom Colors**.
     d. Click the color in the **Custom colors** palette to select it.

5. Click **OK**.
6. Click **Save** to save the changes.
When you open the **Object Representation** dialog box the next time, the **Color** list shows a maximum of 10 colors that you last defined. Customized colors are shown above the dashed line:

Information about the colors that you define for the object groups is stored in the `used_custom_colors.clr` file, which is located in the `\attributes` folder under the model folder. Information about the colors that you add in the **Custom colors** palette is stored in the `xs_user.xxx` file in the model folder (`xxx` is your user name).

**See also**

*Change the color of an object group (page 174)*

### 11.3 Define color and transparency settings

You can define color and transparency settings for parts and other model objects.

1. On the **View** tab, click **Representation** to open the **Object Representation** dialog box.
2. Click **Add row**.
3. Select an object group from the **Object group** list.
4. Use the **Color** list to define the color of the objects.
5. Use the **Transparency** list to define the transparency of the objects.
6. Repeat steps 3–5 for each row you add.
7. Use the **Move up** and **Move down** buttons to change the order of the rows.

   If an object belongs to several object groups, the color and transparency setting defined on the top row is applied to that object.

8. Enter a unique name in the box next to the **Save as** button.

9. Click **Save as** to save the settings.

**NOTE** If your setting does not contain the group **All**, Tekla Structures adds that row to the bottom of the list when you click **Modify**, **Apply** or **OK**.

**See also**

- Change the color and transparency of model objects (page 172)
- Color settings for object groups (page 250)
- Transparency settings for object groups (page 251)
- Define your own colors for object groups (page 174)

### 11.4 Copy color and transparency settings to another model

1. Select the settings you want to copy.

   The settings you have created are located in the model's `\attributes` folder, and they have the file name extension `.rep`.

2. Select where you want to copy the settings.

   - To make the settings available in another model, copy them to the `\attributes` folder of the destination model.
   - To make the settings available in all models, copy them to the project or firm folder, defined by the advanced option XS_PROJECT or XS_FIRM.

3. Restart Tekla Structures.

**See also**

- Change the color and transparency of model objects (page 172)

### 11.5 Delete color and transparency settings

1. Delete the `.rep` file located in the model's `\attributes` folder.

2. Restart Tekla Structures.
See also
Change the color and transparency of model objects (page 172)
This section describes a variety of tools you can use to ensure the model does not contain errors.

Click the links below to find out more:

- Inquire object properties (page 179)
- Measure objects (page 184)
- Compare parts or assemblies (page 188)
- Create a clip plane (page 188)
- Fly through the model (page 189)
- Detect clashes (page 190)
- Diagnose and repair the model (page 203)
- Find distant objects (page 205)

### 12.1 Inquire object properties

Use the Inquire commands to get information about a particular object, or a group of objects, within the model.

Do any of the following:

<table>
<thead>
<tr>
<th>To inquire</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object properties</td>
<td>1. On the ribbon, click <strong>Inquire objects</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Select an object.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures displays the object properties in a separate window.</td>
</tr>
<tr>
<td>To inquire</td>
<td>Do this</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Center of gravity</td>
<td>1. On the ribbon, click the down arrow next to <img src="image" alt="down arrow" />, and then select <strong>Center of gravity</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Select one or more parts. Tekla Structures creates a point at the center of gravity of each selected part, and displays information about the center of gravity in a separate window.</td>
</tr>
<tr>
<td>Object properties using custom reports</td>
<td>See [Custom inquiry](page 182).</td>
</tr>
<tr>
<td>Welded parts</td>
<td>1. On the ribbon, click the down arrow next to <img src="image" alt="welded part" />, and then select <strong>Welded parts</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Select a part. Tekla Structures highlights the selected part and all the parts that are welded to it.</td>
</tr>
<tr>
<td>Primary welded parts</td>
<td>1. On the ribbon, click the down arrow next to <img src="image" alt="primary welded part" />, and then select <strong>Primary welded parts</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Select a part. Tekla Structures highlights the primary part when you select a secondary part.</td>
</tr>
<tr>
<td>Assembly or cast unit objects</td>
<td>See [Check and highlight objects in an assembly](page 122) or [Check and highlight objects in a cast unit](page 128).</td>
</tr>
<tr>
<td>Component objects</td>
<td>1. On the ribbon, click the down arrow next to <img src="image" alt="component object" />, and then select <strong>Component objects</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Select a component. Tekla Structures highlights all objects belonging to the selected component.</td>
</tr>
<tr>
<td>Phases</td>
<td>On the ribbon, click the down arrow next to <img src="image" alt="phases" />, and then select <strong>Phases</strong>.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures displays information about objects in different phases in a separate window.</td>
</tr>
</tbody>
</table>
To inquire | Do this
---|---
Model size | On the ribbon, click the down arrow next to and then select **Model size**. Tekla Structures displays the quantity of all objects in the current model in a separate window.

**See also**
Object property report templates (page 181)

### Object property report templates

When you view object properties using the **Inquire object** command, Tekla Structures uses the following report templates, available in the folder `.\ProgramData\Tekla Structures\<version>\environments\common\system`:

<table>
<thead>
<tr>
<th>Object type</th>
<th>Template</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assemblies</td>
<td>TS_Report_Inquire_Assembly.rpt</td>
</tr>
<tr>
<td>Bolts</td>
<td>TS_Report_Inquire_Bolt.rpt</td>
</tr>
<tr>
<td>Cast units</td>
<td>TS_Report_Inquire_Cast_Unit.rpt</td>
</tr>
<tr>
<td>Parts</td>
<td>TS_Report_Inquire_Part.rpt</td>
</tr>
<tr>
<td>Pour breaks</td>
<td>TS_Report_Inquire_Pour_Break.rpt</td>
</tr>
<tr>
<td>Pour objects</td>
<td>TS_Report_Inquire_Pour_Object.rpt</td>
</tr>
<tr>
<td>Reinforcement meshes</td>
<td>TS_Report_Inquire_Rebar_Mesh.rpt</td>
</tr>
<tr>
<td>Reinforcement strands</td>
<td>TS_Report_Inquire_Rebar_Strand.rpt</td>
</tr>
<tr>
<td>Reference models</td>
<td>TS_Report_Inquire_Reference.rpt</td>
</tr>
<tr>
<td>Reinforcement</td>
<td>TS_Report_Inquire_Reinforcement.rpt</td>
</tr>
<tr>
<td>Surfaces</td>
<td>TS_Report_Inquire_Surface.rpt</td>
</tr>
<tr>
<td>Welds</td>
<td>TS_Report_Inquire_Welding.rpt</td>
</tr>
</tbody>
</table>

You can modify these templates according to your needs. For more information on how to use templates, see the Template Editor user documentation.

You can also create a custom template for connections and details by saving the template with the name `TS_Report_Inquire_Connection.rpt`.

**See also**
Inquire object properties (page 179)
Custom inquiry
You can use the Custom inquiry command to display information about the selected model object in the side pane. You can define what information you want to display.

Use the Custom Inquiry tool
1. Click the Custom Inquiry button in the side pane.

   Alternatively, you can click the down arrow next to on the ribbon, and then select Custom inquiry.

   The Custom Inquiry window opens in the side pane.

2. In the Report type list, select the report template you want to use for showing the object information.

3. Select a model object.

   Tekla Structures displays the object properties in the side pane.

   If you select several objects or object types, for example parts, bolts, and reinforcing bars, Tekla Structures displays the quantity of all the selected objects, regardless of the object types, or the report template used. For the object properties that differ, Tekla Structures shows Varies.

Define what information is shown by Custom Inquiry tool
You can define what information is displayed in the Custom Inquiry side pane window. You can add and modify report templates and the attributes in them.

1. Click the Custom Inquiry button in the side pane.

   Alternatively, you can click the down arrow next to on the ribbon, and then select Custom inquiry.

   The Custom Inquiry window opens in the side pane.

2. Click the button.
The Manage contents dialog box appears.

The Attributes list contains the attributes that are available by default. In the Calculated attributes area you can create your own attribute formulas. The Contents of Custom Inquiry list contains the attributes whose values will be displayed in the side pane.

3. Define which report templates and attributes are available.
   - To modify an existing report template, select it from the top left-hand list in the Manage contents dialog box.
   - To create a new report template, enter a name in the box next to the Save button, and then click Save.
   - To modify the default attributes, edit the InquiryTool.config file. See the separate instructions below.
   - To create or modify a calculated attribute, double-click a cell in the Calculated attributes area. In the first cell, type the name of the attribute. In the second cell, use attribute names and standard mathematical symbols (+, -, *, and /) to form equations.

4. Define which attributes are shown in the Custom Inquiry side pane window.
To add more attributes to the side pane, select an attribute in the Attributes list and then click the ➪ button.

To remove attributes from the side pane, select an attribute in the Contents of Custom Inquiry list and then click the ➫ button.

To change the order of the attributes, use the ▲ ▼ buttons.

To change the formula of an attribute, click the down arrow and select a different formula (Sum, Average, Max, or Min) from the list.

5. Click Save to save the changes.

*Modify the default attributes in InquiryTool.config file*

**NOTE** This section is for advanced users.

Use the InquiryTool.config file to control which attributes are shown as default attributes in the Manage contents dialog box in the Custom Inquiry tool. The file is located in the folder defined with the advanced option XS_MACRO_DIRECTORY, and under ..\modeling\InquiryToolAttributes in that folder path.

For example, if XS_MACRO_DIRECTORY is set to C:\ProgramData\Tekla Structures\<version>\environments\common\macros, the file InquiryTool.config is located in the folder C:\ProgramData\Tekla Structures\<version>\environments\common\macros\modeling \InquiryToolAttributes.

To add new attributes to the InquiryTool.config file:

1. Open the InquiryTool.config file in any standard text editor.

2. Copy the entire contents of [ATTR_CONTENT_??] to the end of the file.

3. Change the position number of the new attribute.
   
   For example, change [ATTR_CONTENT_??] to [ATTR_CONTENT_66].

4. Modify the NAME, DISPLAY_NAME, DATATYPE, UNIT, and DECIMAL values of the new attribute. Use the attribute names and definitions that are included in the contentattributes_global.lst file.

5. Change the TOTAL_ATTR_CONTENT value to reflect the total number of attributes in the file.
   
   For example, change TOTAL_ATTR_CONTENT=65 to TOTAL_ATTR_CONTENT=66.

6. Save the file.

Check the model 184 Measure objects
12.2 Measure objects

Use the Measure commands to measure angles, arcs, the distance between two points and between bolts in the model.

All measurements are temporary. The measurements appear in the model view window until you update or redraw the window.

The units depend on the settings in File menu --> Settings --> Options --> Units and decimals.

See also
Measure distances (page 185)
Measure angles (page 186)
Measure arcs (page 186)
Measure bolt spacing (page 187)

Measure distances
You can measure horizontal, vertical and user-defined distances in the model.

1. Press Ctrl+P to switch to the plane view.
2. On the Edit tab, click Measure and select one of the following commands:
   
   • **Free distance**
     This command measures the distance between any two points. Use this command to measure inclined or aligned distances. By default, the results contain the distance and the coordinates.
   
   • **Horizontal distance**
     This command measures the distance between two points in the direction of the view plane x axis.
   
   • **Vertical distance**
     This command measures the distance between two points in the direction of the view plane y axis.

3. Pick the start point.
4. Pick the end point.
5. Pick a point to indicate on which side of the dimension line you want the measurement to appear.
   
The measurement is displayed until the next window update or redraw.
See also
Measure objects (page 184)

Measure angles
You can measure angles in the model.
1. On the Edit tab, click Measure --> Angle.
2. Pick the center point.
3. Pick the start point.
4. Pick the end point.
The measurement is displayed until the next window update or redraw.

See also
Measure objects (page 184)

Measure arcs
You can measure the radius and length of an arc in the model.
1. On the Edit tab, click Measure --> Arc.
2. Pick the start point.
3. Pick the middle point.
   This can be any point along the arc between the start and end points.
4. Pick the end point.

- Start point
- Middle point
End point
Arc radius
Arc length

The measurements are displayed until the next window update or redraw.

See also
Measure objects (page 184)

Measure bolt spacing
You can measure distances between bolts in a bolt group. Tekla Structures also gives you the edge distances between the bolts and a selected part.

1. On the Edit tab, click Measure --> Bolt spacing.
2. Select a bolt group.
3. Select a part.

The measurements are displayed until the next window update or redraw.

See also
Measure objects (page 184)
12.3 Compare parts or assemblies

You can compare two selected parts or assemblies.

1. Select the objects you want to compare.
   - To compare parts, select two parts in the model.
   - To compare assemblies, select a part in each assembly.

2. On the Edit tab, click Compare, and then select either Parts or Assemblies.

Tekla Structures displays the results on the status bar.

See also

Check the model (page 179)

12.4 Create a clip plane

Clip planes enable you to focus on the required detail in the model. You can create up to six clip planes in any model view that shows the object faces.

1. When you create clip planes, ensure that you are using a model view that shows object faces.

   On the View tab, click Rendering, and use any of the following options:
   - Parts grayscale (Ctrl+3)
   - Parts rendered (Ctrl+4)
   - Components grayscale (Shift+3)
   - Components rendered (Shift+3)

2. On the View tab, click Clip plane.

3. Move the mouse pointer over the model objects.

   A green symbol indicates the object faces that you can select and align the clip plane with. The green line indicates the side that will be clipped out. For example:

4. Select an object face.
The clip plane symbol appears in the model:

5. Repeat step 4 to create as many clip planes as needed.
6. To finish creating clip planes, press Esc.
7. To move a clip plane, select the clip plane scissor symbol and drag it to a new location.
8. If you want to move the clip plane scissor symbol to a new location on a clip plane, hold down Shift and drag the symbol. This does not move the clip plane, only the scissor symbol.
9. To delete a clip plane, select the clip plane symbol and press Delete.

12.5 Fly through the model

Using the Fly command, you can travel through a model, changing direction and varying the speed as you go. You can also adjust the field of view setting, which can be useful when flying in a tight space.

1. Set view projection to Perspective.
   a. Double-click the view to open the View Properties dialog box.
   b. In the Projection list, select Perspective.
   c. Click Modify.
2. If needed, adjust the field of view setting.
   The bigger the value, the more distance there is between the parts when you fly through the model.
   a. On the File menu, click Settings --> Advanced options, and go to the Model View category.
   b. Modify the advanced option XS_RENDERED_FIELD_OF_VIEW.
   c. Click OK.
3. On the View tab, click Fly.
4. Select a view.
   The mouse pointer changes into an arrow and a cross. The arrow indicates the current flying direction.

5. Drag the mouse to move around in the model.
   • To fly forward, move the mouse forward.
   • To change the flying direction, drag the mouse in the desired direction.
     The flying speed grows exponentially when you are approaching the model from a distance.
   • To move up or down, hold down Ctrl and drag the mouse forward or backward.
   • To change the camera angle, scroll with the mouse wheel.
   • To fly in the in the direction of the camera angle, hold down Shift and scroll forward or backward.
6. To stop flying, press Esc.

12.6 Detect clashes

Use the Clash Check Manager tool to find parts, bolts, reinforcement, or reference model objects that collide. Clashes of objects that only touch one another are not included in the clash check results.
Use the clash check settings to define clearances between different model objects.

You can also use the sections and floors created in Organizer to run a controlled clash check.

If you want to use another Tekla Structures model as a reference model, you must export it in IFC format to be able to use it in clash checking. The following reference model file types are supported in clash checking:

- IFC
- DWG
- DGN

See also

Find clashes in a model (page 191)

Find clashes in a model

1. On the Manage tab, click Clash check.
2. In the model, select the objects you want to include in the clash check.
3. Click to check the objects.

   You can continue working during the clash check. When the clash check is complete, the status bar message changes from Clash checking in progress to Ready.

4. To highlight a clash in the model, select a row in the list of clashes.
   The related model objects are selected.
5. To zoom the active view so that the selected objects are shown in the center of the view, double-click a row.

6. If you want to include more objects in the clash check, select the desired model objects and re-run the clash check.
   New clashes are appended to the end of the list.

7. After removing or modifying objects, re-run clash check to see if the clash still exists.
   a. Select the desired rows in the list of clashes.
   b. Click to re-run clash check.

**NOTE** For best results, run the clash check only for appropriate sections and floors, not for the entire model. Use Organizer to select the sections and floors for which you want to run the clash check. Right-click and select Select in the Model.

**NOTE** If you cannot find the clashes in the model, change the rendering of objects to Show only selected part (Ctrl+5) for better visibility.

**See also**
Manage the list of clashes (page 196)

**Manage clash check results**
This section describes how to interpret the symbols and clash types used in clash checking and how to change the status or priority of the clashes.

Click the links below to find out more:

Symbols used in clash checking (page 192)
About clash types (page 193)
Manage the list of clashes (page 196)
Search for clashes (page 196)
Change the status of clashes (page 197)
Change the priority of clashes (page 197)

**Symbols used in clash checking**
Clash Check Manager uses the following flags to indicate the state of clashes:
<table>
<thead>
<tr>
<th>Flag</th>
<th>State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(none)</td>
<td>Active</td>
<td>The default state. The clash is not new, modified, resolved, or missing.</td>
</tr>
<tr>
<td>✉️</td>
<td>New</td>
<td>All clashes are marked as new when they are found for the first time.</td>
</tr>
<tr>
<td>⚠️</td>
<td>Modified</td>
<td>If the object has been modified (for example, if the profile has been changed), the state changes to modified when you re-run the clash check. Only certain object properties affect this flag. To see which properties have an effect, right-click one of the column headings. Both visible and hidden properties affect the flag.</td>
</tr>
<tr>
<td>✅</td>
<td>Resolved</td>
<td>If the objects no longer clash, the state changes to resolved when you re-run the clash check.</td>
</tr>
<tr>
<td>❔</td>
<td>Missing</td>
<td>If one or both of the clashing objects have been removed from the model, the state changes to missing when you re-run the clash check.</td>
</tr>
</tbody>
</table>

**See also**

*Find clashes in a model* (page 191)

**About clash types**

Tekla Structures shows the type of each clash in the **Type** column in the **Clash Check Manager** dialog box.
The following clash types can occur:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clash</td>
<td>The object partly overlaps with another object.</td>
<td><img src="image" alt="Clash Example" /></td>
</tr>
<tr>
<td>Clash</td>
<td>Two identical objects completely overlap.</td>
<td><img src="image" alt="Clash Example" /></td>
</tr>
</tbody>
</table>

Check the model 194 Detect clashes
<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clash</td>
<td>Objects intersect with each other in several locations.</td>
<td></td>
</tr>
<tr>
<td>Clash</td>
<td>The object cuts through another object.</td>
<td></td>
</tr>
<tr>
<td>Type</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>-----------</td>
<td>--------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Is inside</td>
<td>The object is inside another object.</td>
<td></td>
</tr>
</tbody>
</table>

**See also**
- Find clashes in a model (page 191)
- Manage clash check results (page 192)

**Manage the list of clashes**

To manage the list of clashes in **Clash Check Manager**:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the sort order of clash</td>
<td>Click the heading of the desired column to alternate between the ascending and descending sort order.</td>
</tr>
<tr>
<td>results</td>
<td></td>
</tr>
<tr>
<td>Select multiple rows in the list</td>
<td>Hold down <strong>Ctrl</strong> or <strong>Shift</strong> while selecting rows.</td>
</tr>
<tr>
<td>of clashes</td>
<td></td>
</tr>
<tr>
<td>Show or hide a column</td>
<td>1. Right-click one of the column headings to open a menu.</td>
</tr>
<tr>
<td></td>
<td>2. Click any of the list items to show or hide them.</td>
</tr>
<tr>
<td></td>
<td>A check mark ✗ in front of the item indicates that it is visible.</td>
</tr>
</tbody>
</table>

**See also**
- Find clashes in a model (page 191)
**Search for clashes**

Use the **Search** box to find clashes based on search terms. The more search terms you enter, the more refined your search will be. For example, if you enter `column 8112`, only the clashes that match both of these terms are displayed.

1. Open the clash check session you want to find clashes from.
2. In the **Search** box, enter the words to search for.
   - The search results are displayed as you type.
3. To narrow your search, enter more characters.
4. To display all the clashes again, click `×` next to the **Search** box.

**See also**

Find clashes in a model (page 191)

**Change the status of clashes**

1. In **Clash Check Manager**, select the clashes whose status you want to change.
2. Right-click one of the selected rows.
3. Select **Status** and then one of the status options:
   - Assign
   - Fix
   - Approve
   - Ignore
   - Reopen

**See also**

Find clashes in a model (page 191)

**Change the priority of clashes**

1. In **Clash Check Manager**, select the clashes whose priority you want to change.
2. Right-click one of the selected rows.
3. Select **Priority** and then one of the status options:
   - High
   - Medium
   - Low
See also
Find clashes in a model (page 191)

Group and ungroup clashes
You can combine several clashes into a group so that the clashes are treated as a single unit.

1. In Clash Check Manager, select the clashes you want to group.
2. Right-click and select Group --> Group.
3. If you want to add clashes to an already existing group, select the clashes and the group, and then repeat step 2.

   NOTE You cannot create nested groups of clashes.

4. If you want to ungroup clashes:
   a. Select the clash group to ungroup.
   b. Right-click and select Group --> Ungroup.

See also
Detect clashes (page 190)

View the details of a clash
Use the Clash Information dialog box to view more detailed information about a clash. For example, you can view the profile, material and class of the objects that collide. This can be useful especially when you view clash groups that contain more than two objects.

1. Select the clash or clash group whose details you want to view.
2. Right-click and select Clash Information.

   NOTE If more than one clash or clash group is being selected at the same time, the Clash Information option appears dimmed.

See also
Add comments to a clash (page 198)
View the history of a clash (page 200)
Add comments to a clash
You can add comments to clashes and clash groups. For example, you might use comments as reminders to yourself and other users.

1. Select the clash or clash group you want to comment on.
2. Right-click and select Clash Information.
3. Go to the Comments tab.
4. Click to open the Add comment dialog box.
5. Enter your comment in the Comment box.
6. Modify the author name and the date if needed.
7. Click OK.

See also
Modify a clash comment (page 199)
Remove a clash comment (page 199)

Modify a clash comment
1. Select the clash or clash group whose comment you want to modify.
2. Right-click and select Clash Information.
3. Go to the Comments tab.
4. Select the comment you want to modify.
5. Click to open the Edit comment dialog box.
6. Modify the comment.
7. Click OK.

See also
Add comments to a clash (page 198)
Remove a clash comment (page 199)

Remove a clash comment
1. Select the clash or clash group whose comment you want to remove.
2. Right-click and select Clash Information.
3. Go to the Comments tab.
4. Select the comment you want to remove.
5. Click 

**See also**
- Add comments to a clash (page 198)
- Modify a clash comment (page 199)

**View the history of a clash**
You can view the history of a particular clash. For example, you can see when and by whom the clash was detected.

1. Select a clash or a clash group.
2. Right-click and select **Clash Information**.
3. Go to the **History** tab.
   The history information of the clash is displayed.

**See also**
- View the details of a clash (page 198)

**Print a list of clashes**
You can print lists of clashes. You can control the print settings the same way as in any standard Windows application.

1. Open the clash check session you want to print.
2. Click **Print**
3. If needed, modify the print settings.
4. Click **Print**.

**See also**
- Preview a list of clashes before printing (page 200)
- Set the paper size, margins and page orientation (page 201)

**Preview a list of clashes before printing**
Use the options in the **Print preview** dialog box to see what a list of clashes will look like when it is printed.
To preview a list of clashes:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the <strong>Print preview</strong></td>
<td>In <strong>Clash Check Manager</strong>, click the down arrow next to 📊 and select <strong>Print preview</strong>.</td>
</tr>
<tr>
<td>dialog box</td>
<td></td>
</tr>
<tr>
<td>Select how many pages to view at</td>
<td>Click one of the <strong>Page Layout</strong> buttons:</td>
</tr>
<tr>
<td>a time</td>
<td>If the list of clashes is very long, it might be spread out on several pages.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom the page in or out</td>
<td>Click the down arrow next to 🕵️ and select an option from the menu.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Print the current page</td>
<td>Click 📈.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Close the <strong>Print preview</strong></td>
<td>Click <strong>Close</strong>.</td>
</tr>
<tr>
<td>dialog box</td>
<td></td>
</tr>
</tbody>
</table>

**See also**

- Print a list of clashes (page 200)
- Set the paper size, margins and page orientation (page 201)

**Set the paper size, margins and page orientation**
Before printing a list of clashes, you can set the paper size, margins, and page orientation in the **Page Setup** dialog box.

**NOTE** The options for paper size and paper source are printer-dependent. To use different paper options, select another printer in the **Print** dialog box and click **Apply**.

1. Click the arrow 🖣 next to the 📊 button and select **Page setup**.
2. In the **Size** box, select the paper size you want to use.
3. In the **Source** box, select the correct paper source.
4. Under **Orientation**, select one of the page orientation options.
   - **Portrait**: vertical page orientation
   - **Landscape**: horizontal page orientation
5. Under **Margins**, enter values for the **Left**, **Right**, **Top**, and **Bottom** margins.
6. Click **OK** to save the changes.
See also
Print a list of clashes (page 200)
Preview a list of clashes before printing (page 200)

Open and save clash check sessions
Clash check sessions are saved as XML files in the ..\TecklaStructuresModels\<model>\Clashes folder. Tekla Structures creates the folder automatically when you open Clash Check Manager for the first time.

To open or save sessions in Clash Check Manager, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Open a session                                | 1. Click .  
2. In the Open dialog box, select a session.  
3. Click OK.                                                                                                                                 |
| Start a new session                           | Click . Clash Check Manager clears the list of clashes without running clash check.                                                                                                                        |
| Save the current session                      | Click .                                                                                                                                                                                                 |
| Save the current session with a another name or in another location | 1. Click the arrow next to the button. A menu appears.  
2. Click Save as.  
3. In the Save As dialog box, browse to the folder where you want to save the session.  
4. In the File name box, enter a new name.  
5. Click Save.                                                                                                                          |
| Save only selected clashes                    | 1. In the list of clashes, select the clashes you want to save.  
2. Click the arrow next to the button. A menu appears.  
3. Click Save selected.                                                                                                                   |

See also
Detect clashes (page 190)
Define a clash check clearance area for bolts

To check if bolts collide with profiles and if there is enough space to fix the bolt, you can define a clash check clearance area for bolts.

1. On the File menu, click Settings --> Options.
2. In the Options dialog box, go to the Clash check settings.
3. Modify the bolt clearance values.
   If the boxes are empty, Tekla Structures uses the default value 1.00.

   ![Bolt clash check settings](image)

   1. \(d\) is the larger value of the bolt head or nut diameters
   2. Clash check clearance area

4. Ensure that you have selected the check box in front of each box.
   If you clear the check boxes, the clearance will be zero.
5. Click Apply or OK.

**NOTE** If Tekla Structures cannot find the bolt head or nut diameter in the bolt catalog, it uses the shank diameter instead.

See also

Detect clashes (page 190)

12.7 Diagnose and repair the model

Use the Diagnose & repair commands to check and to repair errors and inconsistencies in the structure of model objects and the library database (xslib). By diagnosing and repairing the model you can ensure, for example, that empty assemblies are removed and that unused points and attributes are
deleted. Repairing the model also corrects invalid object relations and hierarchies. We recommend you to diagnose and to repair your model regularly to maintain the consistency and integrity of your model databases.

1. On the **File** menu, click **Diagnose & repair**.
2. Select the appropriate **Diagnose** command.

The errors and inconsistencies found in the model are listed in a report. Some of them are automatically corrected, some of them are warnings that you need to correct manually.

If a profile, material grade, bolt element or assembly, or reinforcement seems to be missing from the corresponding catalog, your Tekla Structures environment or a catalog file may not be the same as the model's original one.

The following table lists the most common errors and inconsistencies found when diagnosing the model.

<table>
<thead>
<tr>
<th>Diagnosis result</th>
<th>Description</th>
<th>Action needed</th>
</tr>
</thead>
</table>
| Empty assembly       | The assembly does not contain any objects. | a. On the **File** menu, click **Diagnose & repair**.  
                      |                                                    | b. Under **Model**, click **Repair model** to delete the assembly. |
| Missing assembly     | A part is not included in any assembly. | a. On the **File** menu, click **Diagnose & repair**.  
                      |                                                    | b. Under **Model**, click **Repair model** to create an assembly and to move the part to it. |
| Illegal profile      | An unknown profile has been found.    | a. Ensure that you are using the correct Tekla Structures environment.  
                      |                                                    | b. Use the model's original profdb.bin and profitab.inp files and save them in the model folder.  
                      |                                                    | c. Reopen the model. |
| Illegal material     | An unknown material grade has been found. | a. Ensure that you are using the correct Tekla Structures environment.  
                      |                                                    | b. Use the model's original matdb.bin file and save it in the model folder.  
<pre><code>                  |                                                    | c. Reopen the model. |
</code></pre>
<table>
<thead>
<tr>
<th>Diagnosis result</th>
<th>Description</th>
<th>Action needed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Illegal bolt</td>
<td>An unknown bolt element or bolt assembly has been found.</td>
<td>a. Ensure that you are using the correct Tekla Structures environment.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>b. Use the model's original screwdb.db and assdb.db files and save them in the model folder.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>c. Reopen the model.</td>
</tr>
<tr>
<td>Illegal reinforcing bar size or</td>
<td>Reinforcement with invalid properties has been found.</td>
<td>a. Ensure that you are using the correct Tekla Structures environment.</td>
</tr>
<tr>
<td>grade</td>
<td></td>
<td>b. Use the model's original rebar_database.inp and mesh_database.inp files and save them in the model folder.</td>
</tr>
<tr>
<td>Illegal reinforcement mesh</td>
<td></td>
<td>c. Reopen the model.</td>
</tr>
<tr>
<td>Invalid rebar geometry</td>
<td>Reinforcement with undefined geometry has been found.</td>
<td>See Check the validity of reinforcement geometry.</td>
</tr>
</tbody>
</table>

If the model does not contain any errors or inconsistencies, a message is displayed on the status bar.

**See also**

Check the model (page 179)

### 12.8 Find distant objects

When the work area is huge, the model may contain some distant objects that are not easy to find. Use the **Find distant objects** command to find these objects.

1. On the **File** menu, click **Diagnose & repair**.
2. Under **Utilities**, click **Find distant objects**.
Tekla Structures displays a list of object IDs. At the end of the list, Tekla Structures displays additional six objects that have the biggest and smallest x, y, or z coordinates.

Id: 13218
Id: 13217
Id: 13109
Id: 13108
Id: 13107
Id: 13106
Id: 13105

-----------------------------
Min x: Id: 291
Max x: Id: 13226
Min y: Id: 6094
Max y: Id: 13226
Min z: Id: 796
Max z: Id: 4996

3. Select an object in the list.
4. Right-click and select a command.

You can, for example, inquire or delete the object.

See also

Check the model (page 179)
This section explains how to change numbering settings and apply numbering in Tekla Structures.

Click the links below to find out more:

- What is numbering and how to plan it (page 207)
- Adjust the numbering settings (page 216)
- Number parts (page 217)
- Change existing numbers (page 220)
- Clear existing numbers (page 221)
- Check the numbering (page 221)
- View the numbering history (page 224)
- Repair numbering errors (page 225)
- Renumber the model (page 225)
- Control numbers (page 226)
- Number parts by design group (Design Group Numbering) (page 233)
- Numbering examples (page 235)

### 13.1 What is numbering and how to plan it

Before you can create drawings or accurate reports, you need to number all parts in the model. You do not need to number the model before you create general arrangement drawings.

*Numbering* is the key to the production output, for example, drawings, reports, and NC files. Numbers are also needed when you export models. Part numbers are vital in the fabrication, shipping, and erection stages of construction. Tekla Structures assigns a mark to each part and assembly/cast unit in a model. The mark includes part or assembly prefix and position.
number, and other elements, such as profile or material grade. It is useful to identify the parts with numbers to see which parts are similar and which different. Identical parts within a numbering series have the same number, which makes the planning of the production easier.

We recommend that you plan the numbering in an early phase of the project. If other users are using the same model, it is even more important to make a numbering plan that everybody in the project follows. You should have the numbering ready before you create the first drawings and reports.

When planning the numbering, it can be useful to number the model in phases, for example first floor of the building first, then the second, and so on.

Give start numbers in wide ranges so that you do not run out of numbers within a numbering series, and that any numbering series does not overlap with another. For example, start the first floor with the start number 1000 and the second with start number 2000.

If the numbering of a part or assembly is not up to date, a question mark (?) is displayed in the part label and in the **Inquire Object** dialog box, for example:

```
<table>
<thead>
<tr>
<th>Assembly information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly Pos: C/O(?)</td>
</tr>
<tr>
<td>Main part profile: H&amp;14U</td>
</tr>
</tbody>
</table>
```

**See also**
- Numbering series (page 208)
- Identical parts (page 211)
- Identical reinforcement (page 212)
- Define what affects numbering (page 213)
- User-defined attributes in numbering (page 214)
- Family numbers (page 214)
- Inquire object properties (page 179)

**Numbering series**

Use numbering series to divide steel parts, assemblies, and cast units into groups. For example, you can allocate a separate numbering series to each phases or part type. Using separate numbering series for different parts speeds up the numbering operation.

The name of a numbering series consists of a **prefix** and a **start number**. You do not always have to define a part prefix (for example, you may want to omit the part prefix for minor parts).
When you run numbering, Tekla Structures compares parts that belong to the same series with each other. All identical parts in the same numbering series are given the same part number.

**NOTE**  Concrete parts are numbered according to the cast unit numbering settings. For example, if the cast unit prefix is C and the start number is 1, concrete parts will get the part prefix Concrete_C-1.

This applies also to concrete components whose part position prefix is Concrete and start number is 1.

**Example**

For example, if you define a numbering series with the prefix P and start number 1001, Tekla Structures numbers that series P1001, P1002, P1003, ...

**See also**

Plan your numbering series (page 209)
Assign a numbering series to a part (page 210)
Assign a numbering series to an assembly (page 210)
Overlapping numbering series (page 211)
Family numbers (page 214)

**Plan your numbering series**

Before you start modeling, it is a good idea to plan the numbering prefixes and start numbers you will use for the entire project. Careful planning prevents numbering conflicts.

To save time, include the numbering series in the default part properties for each type of part before you start modeling.

You may want to omit the part prefix for minor parts, such as plates. If you do this, ensure that you assign a **Start number** for that numbering series so that it will not overlap other parts.

**Example**

One way to plan the numbering series is to create a table:

<table>
<thead>
<tr>
<th>Part type</th>
<th>Part Prefix</th>
<th>Part Start number</th>
<th>Assembly Prefix</th>
<th>Assembly Start number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beam</td>
<td>PB</td>
<td>1</td>
<td>AB</td>
<td>1</td>
</tr>
<tr>
<td>Vertical brace</td>
<td>PVB</td>
<td>1</td>
<td>AVB</td>
<td>1</td>
</tr>
<tr>
<td>Horizontal brace</td>
<td>PHB</td>
<td>1</td>
<td>AHB</td>
<td>1</td>
</tr>
<tr>
<td>Rafter</td>
<td>PR</td>
<td>1</td>
<td>AR</td>
<td>1</td>
</tr>
<tr>
<td>Part type</td>
<td>Part Prefix</td>
<td>Part Start number</td>
<td>Assembly Prefix</td>
<td>Assembly Start number</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
<td>-------------------</td>
<td>-----------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>Purlin</td>
<td>PP</td>
<td>1</td>
<td>AP</td>
<td>1</td>
</tr>
<tr>
<td>Column</td>
<td>PC</td>
<td>1</td>
<td>AC</td>
<td>1</td>
</tr>
<tr>
<td>Plate</td>
<td>1001</td>
<td>A</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

**See also**

- Numbering series (page 208)
- Overlapping numbering series (page 211)
- Numbering prefixes in US environments

**Assign a numbering series to a part**

1. Double-click a part to open the part properties dialog box.
2. If you are modifying the properties of a concrete part, go to the **Cast unit** tab.
3. Under **Numbering series**, define a part prefix and a start number.
4. Click **Modify**.

**See also**

- Assign a numbering series to an assembly (page 210)
- Numbering series (page 208)

**Assign a numbering series to an assembly**

To assign a numbering series to an assembly:

<table>
<thead>
<tr>
<th>To assign a numbering series to an assembly according to its main part</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1.</td>
</tr>
<tr>
<td></td>
<td>a.</td>
</tr>
<tr>
<td></td>
<td>b.</td>
</tr>
<tr>
<td></td>
<td>c.</td>
</tr>
<tr>
<td>Check what is the main part of an assembly.</td>
<td>On the ribbon, click the down arrow next to <strong>?</strong>, and then select <strong>Assembly objects</strong>.</td>
</tr>
<tr>
<td>Select the assembly.</td>
<td>Tekla Structures highlights the main part in orange.</td>
</tr>
<tr>
<td>Press <strong>Esc</strong>.</td>
<td></td>
</tr>
<tr>
<td>To assign a numbering series to an assembly by using the assembly properties</td>
<td>Do this</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>1. Ensure that the <code>Select assemblies</code> selection switch is active.</td>
<td></td>
</tr>
<tr>
<td>2. Double-click an assembly to open the assembly properties dialog box.</td>
<td></td>
</tr>
<tr>
<td>3. On the <code>Assembly</code> tab, define an assembly prefix and a start number.</td>
<td></td>
</tr>
<tr>
<td>4. Click <code>Modify</code>.</td>
<td></td>
</tr>
</tbody>
</table>

**See also**

- Assign a numbering series to a part (page 210)
- Numbering series (page 208)
- Assembly prefix and start number fields are greyed out

**Overlapping numbering series**

When you plan numbering, ensure that you reserve enough numbers for each series. If a series overlaps another, Tekla Structures numbers only one of the objects that would have overlapping numbers and leaves the other object unnumbered.

Tekla Structures warns you about series overlaps. View the numbering history log to check which numbers overlap, and then adjust the numbering prefixes and start numbers so that the series will not overlap anymore.

**See also**

- Numbering series (page 208)
- View the numbering history (page 224)
**Identical parts**

Tekla Structures gives parts the same number if the parts are identical in the *fabrication or casting*. If a part is deformed after fabrication or casting (for example if the part is cambered, shortened, or warped), the final geometry on site and in the model may be different.

Tekla Structures treats parts as identical and gives them the same number if the following basic part properties are the same:

- Part geometry
- Casting direction
- Numbering series
- Profile
- Material
- Finish
- Shortening

You can set the degree of tolerance for part geometry in the **Numbering Setup** dialog box. If the geometry of parts differs within this degree of tolerance, Tekla Structures treats the parts as identical for numbering purposes.

Class and phase do not affect numbering. Tekla Structures gives the same number to identical parts that belong to different classes or phases.

If you have created NC files, pop marks and contour marking affect numbering.

**See also**

- Part properties (page 251)
- Casting direction (page 129)
- Define what affects numbering (page 213)
- User-defined attributes in numbering (page 214)

**Identical reinforcement**

Tekla Structures treats reinforcing bars as identical, and gives them the same number, if the following properties are the same:

- Bar geometry
- Numbering series
- Size
- Grade
• Bending radius

Tekla Structures uses the values of the rebar_config.inp file located in the ..\ProgramData\Tekla Structures\<version>\environments\<environment>\system\ folder to round bar dimensions up or down. For example, if you set the rounding accuracy for bar dimensions to 5 and the rounding direction to up, Tekla Structures rounds all bar dimensions up to the nearest 5 mm. In that case, two bars with dimensions of 131 mm and 133 mm would both round up to 135 mm. This gives them identical bar geometry.

Class does not affect numbering. Tekla Structures gives the same number to identical reinforcing bars that belong to different classes.

**Define what affects numbering**

To define which properties affect numbering in your model, modify the settings in the **Numbering Setup** dialog box.

You can have Tekla Structures compare the following properties:

• Holes (if created with the **Bolt** command)
• Part name
• Beam orientation
• Column orientation
• Reinforcement
• Embedded objects (affect only cast units)
• Surface treatment (affects only assemblies)
• Welds (affect only assemblies)

If these properties differ, Tekla Structures treats objects as different, and therefore numbers them differently.

For example, if two otherwise identical parts have different names and you select the **Part name** check box, Tekla Structures gives the parts different numbers.

By default, a part retains its number, as long as only one part has that particular number, regardless of the settings in the **Numbering Setup** dialog box.

**See also**

Adjust the numbering settings (page 216)
What is numbering and how to plan it (page 207)
Identical parts (page 211)
Identical reinforcement (page 212)
User-defined attributes in numbering (page 214)
General numbering settings (page 287)

User-defined attributes in numbering
You can set in the objects.inp file whether a user-defined attribute affects numbering or not. Tekla Structures treats parts and reinforcing bars as different, and therefore numbers them differently, if the values of the user-defined attribute differ.

**NOTE** Only user-defined attributes of parts and reinforcement can affect numbering. User-defined attributes of other objects, such as phases, projects and drawings do not affect numbering.

If you want Tekla Structures to consider a user-defined attribute when numbering, set the special_flag option of the attribute to yes in the Part attributes section of objects.inp. For reinforcement, you need to set special_flag to yes also in the Reinforcing bar attributes section. Tekla Structures assigns different numbers to parts or reinforcement that are otherwise identical but have different values for this user-defined attribute.

If you want Tekla Structures to ignore a user-defined attribute when numbering, set the special_flag option to no in objects.inp.

**See also**
User-defined attributes (page 264)
Define what affects numbering (page 213)

Family numbers
With family numbering you can group objects within the same numbering series into different “families”. This can be used, for example, to find similar cast units that can be cast in the same bed.

When you use family numbering, the cast unit position numbers consist of a family number and a qualifier. For example:

```
TT/102-3

1  TT/102  3  2
```

1 Family number
Assemblies and cast units that match the comparison criteria you define in the **Numbering Setup** dialog box get the same family number. However, if they have the same family number but different part geometry or materials, they get unique qualifier numbers.

**See also**
- Numbering series (page 208)
- Assign family numbers (page 215)
- Change the family number of an object (page 216)
- Example: Use family numbers (page 236)

**Assign family numbers**

1. On the **Drawings & reports** tab, click **Numbering settings** --> **Numbering settings** to open the **Numbering Setup** dialog box.
2. Go to the **Family numbering** tab.
3. Define which numbering series to assign family numbers to.
   a. Click **Add series** to open the **Add series** dialog box.
      - Tekla Structures displays all the assembly and cast unit numbering series in the model.
   b. Select a numbering series from the list, and then click **Add**.
      - The numbering series appears in the family numbering list.
4. Under **Compare**, select the properties that need to be identical for the members of the same family.
   - Define comparison criteria for each numbering series separately.
   - Select at least one check box, but not all of them. If you select all the check boxes, the family number will be the same as the normal assembly position, and the qualifier number will be 1 for all. If you do not select any check boxes, only one family number per series is assigned.
5. Click **Apply**.
   - Tekla Structures stores the settings in the numbering database file (<model_name>.db2) in the current model folder the next time you save the model.
6. If you are assigning family numbers to parts that have already been numbered, clear the existing numbers.
7. Update numbering in the model.
   Tekla Structures assigns a family number to all objects in the numbering series.

**See also**

Family numbers (page 214)
Clear existing numbers (page 221)

**Change the family number of an object**
You can change the family number and/or family qualifier of an object.

1. Select the objects whose family numbers you want to change.
2. On the Drawings & reports tab, click Change number --&gt; Change family number.
3. In the Assign Family Number dialog box, enter the desired values in the Family number and Family qualifier boxes.
4. Click Assign.

**See also**

Family numbers (page 214)

### 13.2 Adjust the numbering settings

You can adjust the numbering settings to better suit your needs. This should be done early in the project, before creating any drawings or reports. Do not change your numbering conventions in the middle of a project.

1. On the Drawings & reports tab, click Numbering settings --&gt; Numbering settings to open the Numbering Setup dialog box.
2. Modify the settings if necessary.
   
   For example, you can define which part properties affect numbering in your model. Using the default settings is effective in most cases.
3. Click Apply or OK.

**NOTE**
Always check and repair numbering after you have changed the numbering settings.

**See also**

Define what affects numbering (page 213)
Numbering settings during a project (page 305)
13.3 Number parts

Use the **Number modified objects** command to number all parts that have been created or modified since the last numbering. If this is the first time you run numbering for this model, all parts in the model are new and will therefore be numbered.

To number new and modified parts:

- On the **Drawings & reports** tab, click **Perform numbering --> Number modified objects**.
  
  Tekla Structures numbers the parts.

**See also**

- Number a series of parts (page 217)
- Number assemblies and cast units (page 218)
- Number reinforcement (page 219)
- Number welds (page 219)
- Save preliminary numbers (page 220)
- Number parts by design group (Design Group Numbering) (page 233)

**Number a series of parts**

Use the **Number series of selected objects** command to only number parts that have a certain prefix and start number. This enables you to limit the numbering to certain series of objects only, which can be useful in large models.

Before you start, we recommend that you plan the numbering series carefully, and split the model into smaller numbering series, for example by area or phase.

1. Select the parts that have the desired prefix and start number.
   
   Only parts that have the same prefix and start number as the selected part will be numbered.

2. On the **Drawings & reports** tab, click **Perform numbering --> Number series of selected objects**.
   
   Tekla Structures numbers all parts in the specified numbering series.
See also
Example: Number selected part types (page 238)
Example: Number parts in selected phases (page 239)

Number assemblies and cast units
To number assemblies and cast units, use the same numbering commands as for numbering parts. Before numbering, you can modify the sort order, which defines how assemblies and cast units are given their position numbers. Sorting does not affect part position.

1. If needed, modify the sort order of assemblies and cast units.
   a. On the Drawings & reports tab, click Numbering settings --> Numbering settings to open the Numbering Setup dialog box.
   b. Modify the sort order by selecting options from the Sort by and Then by lists.

   The default sort order is XYZ. You have the following options:
   • The x, y or z coordinates of the main part of the assembly or cast unit
     The sorting is based on the center of gravity (COG) location of the assembly or cast unit. Tekla Structures finds the center of gravity for each assembly and cast unit and compares them in the order you defined.
   • The user-defined attribute of an assembly or the main part
     If your sorting is based on user-defined attributes, Tekla Structures displays a list that includes all the available user-defined attributes.

   c. Click Apply or OK to save the changes.

2. If needed, modify the other numbering settings.

3. On the Drawings & reports tab, click Perform numbering --> Number modified objects to number the model.

Number the model 218 Number parts
NOTE If you add new parts in the model, parts that have already been numbered are not renumbered to suit the sorting order. In this case you should check and repair the numbering of those parts.

See also
Repair numbering errors (page 225)

Number reinforcement
To number reinforcement, use the same numbering commands as for numbering parts.

Note that reinforcement may affect the numbering of parts and cast units. To force Tekla Structures to give otherwise identical concrete parts and cast units different numbers if they have different reinforcement, select the Reinforcing bars check box in the Numbering Setup dialog box.

Part numbering and cast unit numbering do not affect the numbering of reinforcement.

See also
Number parts (page 217)
Identical reinforcement (page 212)
Define what affects numbering (page 213)
User-defined attributes in numbering (page 214)

Number welds
Use the Number welds command to assign numbers to welds. Weld numbers are displayed in drawings and reports.

1. On the Drawings & reports tab, click Perform numbering --> Number welds to open the Weld Numbering dialog box.
2. If needed, modify the weld numbering settings (page 288).
   For example, you can define whether to assign numbers for All welds or Selected welds.
3. If you selected to assign numbers to certain welds only, select the welds.
4. Click Assign numbers to start numbering welds.

See also
Number parts (page 217)
Save preliminary numbers
A preliminary mark is a user-defined attribute that defines the part position number. You can save the current part position numbers as preliminary marks for selected parts. The previous preliminary numbers are overridden.

1. Select the parts.
2. On the Drawings & reports tab, click Numbering settings --> Save preliminary numbers.

See also
Number parts (page 217)

13.4 Change existing numbers
Use the Change number commands to change the existing part, assembly, multi-position, or family numbers into something you have defined yourself. These commands do not change the numbering series of parts. To prevent drawing, modeling, and fabrication errors, Tekla Structures does not allow you to use identical numbers for two different assemblies or parts.

1. On the Drawings & reports tab, click Change number and select one of the following commands:
   • Change part number
   • Change assembly number
   • Change part multinumber
   • Change assembly multinumber
   • Change family number
   The corresponding dialog box appears.
2. Select a part in the model.
3. Click Get to view the current numbering properties of the part.
4. Enter the numbering properties you want to use for this part.
   Note that the position numbers you enter here are not absolute numbers. For example, if the start number of the series is 100, the position numbers refer to numbers in that series. Therefore, position number 1 is actually 100, position number 2 is 101, position number 3 is 102, and so on.
5. If you are changing the assembly number of selected parts, ensure that the Assign to: Selected objects only option is selected.
   Otherwise, all parts with the same original number will be renumbered.
6. Click **Assign** to change the number.
   
   If the number you specified is already in use, Tekla Structures displays a warning and keeps the original number.
   
   Tekla Structures also displays a warning if the position number is higher than the highest current number. This is for information only and the number is still changed.

**See also**

Number parts (page 217)

### 13.5 Clear existing numbers

Use the **Clear numbers** commands to permanently remove the current position numbers of parts. Next time you run numbering, Tekla Structures assigns new numbers to these parts, irrespective of what their previous numbers were.

1. Select the parts whose numbers you want to clear.
2. On the **Drawings & reports** tab, click **Change number** and select one of the following commands:
   
   • **Clear part and assembly numbers**
   • **Clear part numbers**
   • **Clear assembly numbers**
   • **Clear reinforcing bar numbers**

Tekla Structures removes the position numbers of the selected parts.

**See also**

Number parts (page 217)

### 13.6 Check the numbering

You can check the position numbers in many places:

• In the model, double-click the background to modify the view properties. Click **Display** to open the **Display** dialog box, then go to the **Advanced** tab
and add **Part position** to the **Part label**. The part labels contain the position numbers.

- You can check the part number in the **Drawing List**.

  - **[AP1]** STANDARD
  - **[AR1]** STANDARD
  - **[AV1]** STANDARD

- The drawing label shows the position number and the amount of identical parts.

<table>
<thead>
<tr>
<th>MARK</th>
<th>PROFILE</th>
<th>MATERIAL</th>
<th>NO.</th>
<th>LENGTH</th>
<th>AREA</th>
<th>WEIGHT</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC/5</td>
<td>HEA800</td>
<td>S355JR</td>
<td>1</td>
<td>15200</td>
<td>49.1</td>
<td>4088.1</td>
</tr>
</tbody>
</table>

**GENERAL NOTES**: ALL HOLES ARE 0.0 mm UNLESS NOTED, ALL WELDS ARE 0.0 mm F.W UNLESS NOTED

Number the model 222 Check the numbering
- You can use the **Inquire** commands.

![Inquire Object window]

<table>
<thead>
<tr>
<th>Name</th>
<th>Profile</th>
<th>Grids</th>
<th>Part</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly</td>
<td>Top</td>
<td>Bottom</td>
<td>position</td>
</tr>
<tr>
<td>position</td>
<td>level</td>
<td>level</td>
<td></td>
</tr>
</tbody>
</table>

- **COLUMN**  
  - HEB800  
  - F/7  
  - PC/3

- **AC/3**  
  - 13.200  
  - 7.175

---

Total 4 Parts: 9.90 T, 44.10 m

**Part**

- **Start point (8202) [mm]**:  
  - $x = 6000.00$  
  - $y = 7175.00$

- **End point (8203) [mm]**:  
  - $x = 6000.00$  
  - $y = 18200.00$

- **Center of gravity [mm]**:  
  - $x = 6100.00$  
  - $y = 7175.00$
• You can create reports that list your assembly and part positions.

See also
Repair numbering errors (page 225)

13.7 View the numbering history

To view the numbering history:
• On the File menu, click Logs --> Numbering history log.
  Tekla Structures displays the numbering log file.
13.8 Repair numbering errors

We recommend that you check and repair numbering in the model every now and then, especially before producing drawings or reports.

**NOTE** If you work in the multi-user mode, it is very important that you repair numbering regularly.

1. On the **Drawings & reports** tab, click **Numbering settings** to open the **Numbering Setup** dialog box.
2. Ensure that the option **Compare to old** is selected for **New** parts.
3. Ensure that one of the following options is selected for **Modified** parts:
   - **Compare to old**
   - **Keep number if possible**
4. Click **OK** to save the changes.
5. Unless you want to repair the entire model, select the objects whose numbering you want to repair.
6. On the **File** menu, click **Diagnose & repair** and select one of the following commands under **Numbering**:
   - **Diagnose and repair numbering: All**
     - This command numbers all parts and assemblies, even the unmodified ones.
   - **Diagnose and repair numbering: Series of selected objects**
     - This command numbers all parts and assemblies that have the same prefix and start number as the selected part.

     Note that Tekla Structures assigns the position number of the oldest part or assembly to all identical parts, even if a newer part or assembly has a smaller position number.

**TIP** To manually assign a certain position number on a part or assembly, use the **Change number** command after repairing numbering in the model.

**See also**

*Change existing numbers (page 220)*
13.9 Renumber the model
Use the Renumber all option when the numbering needs to be started over. This option permanently removes the existing position numbers and resets them with new ones. Any existing drawings will also be removed.

1. On the Drawings & reports tab, click Numbering settings --> Numbering settings to open the Numbering Setup dialog box.
2. Select the Renumber all check box.
3. Click Apply or OK.
4. On the Drawings & reports tab, click Perform numbering --> Number modified objects.
5. When you are asked to confirm the renumbering of the model, click Yes. Tekla Structures renumbers the entire model.

See also
- Change existing numbers (page 220)
- Clear existing numbers (page 221)

13.10 Control numbers
Control numbers are additional numbers that can be used to identify parts in a model. Use control numbers if you need to give additional, unique numbers to assemblies or cast units, regardless of their position numbers.

Control numbers can be useful, for example, when delivering a large number of similar wall elements to the site. To successfully pack and unpack the load, you need to plan the order of the wall elements already when the order is shipped. Although all of the wall elements may have the same cast unit position number, you can assign a unique control number to each individual wall element.

See also
- Assign control numbers to parts (page 226)
- Control number order (page 227)
- Display control numbers in the model (page 229)
- Remove control numbers (page 230)
- Lock or unlock control numbers (page 231)
- Example: Use control numbers to indicate the erection order (page 231)
Assign control numbers to parts

1. On the Drawings & reports tab, click Numbering settings -> Assign control numbers to open the Create control numbers dialog box.

2. Indicate which parts to assign control numbers to.
   - To number the entire model, do not select any parts.
   - To only number specific parts, select the parts you want to number.

3. If you want to assign control numbers only to parts in a specific numbering series:
   a. In the Numbering list, select By numbering serie.
   b. Enter the prefix and start number in the corresponding boxes.

4. Define the control numbers to be used.
   a. In the Start number of control numbers box, enter the first control number to be used.
   b. In the Step value box, define the control number interval.
      For example, to assign the control numbers 2, 5, 8, 11, and so on, enter 2 in the Start number of control numbers box and 3 in the Step value box.

5. Use the Renumber list to specify how to treat parts that already have control numbers.
   - Select No to keep the existing control numbers.
   - Select Yes to replace the existing control numbers with new ones.

6. Use the First direction, Second direction, and Third direction lists to define the order of control numbers.

7. In the Write UDA to list, select where to save the control numbers. The control number will appear on the Parameters tab in the user-defined attributes dialog box either for:
   - Assembly
   - Main part

8. Click Apply to save the changes.

9. Click Create to number the parts.

See also
Control number order (page 227)
Control number settings (page 289)
Control number order

When you assign control numbers, you must define in what order to assign them. The order is based on the location of each part on the global coordinate system.

The options are:

- **None**
- **X**
- **Y**
- **Z**
- **-X**
- **-Y**
- **-Z**

With positive directions (X, Y, and Z), the parts with the lowest coordinate value are numbered first. With negative directions (-X, -Y, and -Z), the parts with the highest coordinate value are numbered first.

For example, if the first direction is X, the second direction is Y, and the third direction is Z, numbering starts from the parts that have the lowest x coordinate value. If multiple parts have the same x coordinate, also their y coordinates are compared. If multiple parts have the same x and y coordinates, also their z coordinates are compared.

**Example**

In the following example, the first direction is X and the second direction is Y. The numbers 1–8 indicate the control numbers.
Display control numbers in the model
If the control numbers are not displayed in the model, you can set them visible using the display settings.

1. Double-click the view to open the View Properties dialog box.
2. Click Display and go to the Advanced tab.
3. Select the Part label check box.
4. In the Properties list, select User-defined attributes, and then click Add.
   The Part label dialog box is displayed.
5. Enter ACN and click OK.
   The property is moved to the Part label list.
6. Click Modify.
   The control numbers are displayed in the model, right after the part position numbers.

Example
In the following example, the numbers 1–8 indicate the control numbers.
Remove control numbers

If needed, you can remove existing control numbers from all or some of the parts. Do not remove control numbers unless you are absolutely sure that they are no longer needed.

**NOTE** Removing of control numbers is different than reassigning of control numbers. If you only want to reassign new control numbers to parts that already have control numbers, use the Renumber option in the Create control numbers dialog box.

1. Double-click the part to open the part properties dialog box.
2. Click **User-defined attributes**
   
   The current control number of the part is displayed on the **Parameters** tab, next to the **Control Number** box. For example:

   ```
   Control Number 2
   ```
   
   3. Remove the existing control number from the box.
   4. Click **Modify** to apply the change.

   **Number the model** 230 **Control numbers**
See also
Control numbers (page 226)

**Lock or unlock control numbers**
To prevent other users from changing the control numbers of some or all of the parts in the model, use the **Lock/unlock control numbers** command. Later on, if the control numbers need to be changed, you can use the same command for unlocking the numbers.

1. On the **Drawings & reports** tab, click **Numbering settings --> Lock/unlock control numbers** to open the **Lock/Unlock control numbers** dialog box.
2. Define which parts’ control numbers to lock or unlock.
   - To lock or unlock the control numbers of all parts, do not select any parts in the model.
   - To lock or unlock the control numbers of specific parts only, select the parts in the model.
3. In the **Status** list, select **Lock** or **Unlock**.
4. Click **Apply** to save the changes.
5. Click **Create** to lock or unlock the numbers.

See also
Control numbers (page 226)

**Example: Use control numbers to indicate the erection order**
This example shows how to assign control numbers to six concrete walls. As four of these walls have the same cast unit position, you cannot make a clear distinction between the cast units based on their position number. That is why each wall will get a unique identifier that indicates their erection order at the site. The erection order also affects the order of shipping. For example, the wall number 1 needs to be shipped on top of the delivery, because it will be erected first on the site; the wall number 2 should be the second on the bundle, because it will be erected next; and so on.
To assign control numbers to the concrete walls:

1. On the **Drawings & reports** tab, click **Numbering settings** --> **Assign control numbers** to open the **Create control numbers** dialog box.
2. Select the six concrete walls.
3. Define that you want to assign control numbers only to parts in the numbering series S with the start number 1.
   a. In the **Numbering** list, select **By numbering serie**.
   b. In the **Prefix** box, enter **S**.
   c. In the **Start number** box, enter **1**.
4. Define that you want to use the numbers 1–6 as the control numbers for these concrete walls.
   
   a. In the **Start number of control numbers** box, enter 1.
   
   b. In the **Step value** box, enter 1.

5. Define that you want to first number the walls with identical z coordinates in the order they appear in the positive x axis.
   
   a. In the **First direction** list, select **Z**.
   
   b. In the **Second direction** list, select **X**.

6. Click **Apply** to save the changes.

7. Click **Create** to number the concrete walls.

Each concrete wall gets a unique control number, as shown in the following image.

_TIP_ If you cannot see the control numbers in the model, modify the display settings. For more information on the required settings, see Display control numbers in the model (page 229).
13.11 **Number parts by design group (Design Group Numbering)**

You can number parts by design groups so that you can differentiate the parts from each other in drawings and reports. The design group numbers can be used in engineering documents or as preliminary numbers.

Use the **Design Group Numbering** application to assign prefixes and numbers to parts on the basis of design groups. The **Design Group Numbering** application groups parts that match a selection filter into a design group, numbers them, and optionally compares the part lengths. The application also compares the user-defined attributes of parts that are set to affect numbering.

Before you start:

- Create the needed selection filters that define the design groups.
- In multi-user or Tekla Model Sharing models, make sure that only one of the users runs the **Design Group Numbering** application.

To number parts by their design group:

1. In the model, Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.
2. Click the arrow next to **Applications** to open the applications list.
3. Double-click **Design Group Numbering** to start the application.
4. In the **Design group numbering** dialog box:
   a. Click **Add group** to create design group numbering settings for parts matching a selection filter.
      - Select the filter in the **Group filter** column.
      - The selection filters are read from specific folders in the standard folder search order.
      - Enter the design group prefix and start number you want to use for the parts in this group.
      - In the **Compare length** column, define whether the part lengths are compared or not.
   b. Repeat step 4a for all part groups that you want to number by design group.
   c. If needed, change the order of the groups by using the **Move up** and **Move down** buttons.
      - If a part belongs to several groups, the last group filter in the list overrides the previous ones.
   d. If you want to compare part lengths, define the length tolerance.
For example, if you enter 0, parts must be exactly the same length to receive the same design group number. If you enter 2, part lengths can differ 2 mm from each other.

The default tolerance is 0.05 mm.

e. Enter a number separator that is used to separate the design group prefix and number in drawing marks and in reports. For example, enter - .

We recommend that you do not change the separator during the project.

f. In Renumber all, select whether to renumber all parts or not.

g. To reuse old, unneeded numbers, select the Reuse old numbers check box.

h. To number the parts by design group, click Perform numbering.

A design group number is saved as the user-defined attribute DESIGN_GROUP_MARK of each part.

By default, the user-defined attribute DESIGN_GROUP_MARK is available in the objects.inp file in the Engineering configuration in the default and US environments.

i. To create a report to show the numbering results, select whether to create a report of all or the selected parts, and then click Create report.

Tekla Structures shows the report in the List dialog box and also saves the report as dgnReport.txt in the \Reports folder under the current model folder.

When you select a row in the List dialog box, Tekla Structures highlights and selects the corresponding part in the model.

If the numbering of a part is not up to date, meaning that the part has been modified after numbering, a question mark (?) is added after the design group number.

5. To show the design group numbers in drawing marks or in reports, use the user-defined attribute DESIGN_GROUP_MARK.

13.12 Numbering examples

This section gives some examples of numbering the model.

Click the links below to find out more:

Example: Number identical beams (page 236)
Example: Number identical beams
This example explains how different numbering settings result in different part numbers when you modify a part.

To number identical beams:
1. Create three identical beams with the numbering series prefix P and start number 1.
2. Number the model. All the beams have the part position number P1.
3. Modify one of the beams.
4. Number the model. You should now have two beams P1 and one P2.
5. Change beam P2 to be identical to the others.
6. Number the model.

Depending on the numbering settings in the Numbering Setup dialog box, Tekla Structures assigns one of the following part position numbers to the modified part:

- **Compare to old**: P1
- **Keep number if possible**: P2
- **Take new number**: P3

See also
Number parts (page 217)
Example: Use family numbers

In this example, the following four beams have the numbering series prefix B and the start number 1. The parts have the same main profile, and each pair has the same length, but the holes are different.

- Assembly position: B/1
- Assembly position: B/2
- Assembly position: B/3
- Assembly position: B/4

We use the following family numbering settings:

- Numbering series: B/1
- Compare: Main part profile and Overall length

With the given family numbering criteria, Tekla Structures divides the beams into two families. All beams have the same profile, but each pair has a different length. Within both families the beams get different qualifiers because they have different holes.

- The first beam gets the assembly position number B/1-1
- The second beam gets the assembly position number B/1-2
- The third beam gets the assembly position number B/2-1
- The fourth beam gets the assembly position number B/2-2
**Example: Number selected part types**

This example shows how different numbering settings can be used for different part types. We will use one set of numbering settings for steel anchor rods, and another one for steel columns. Note that the **Number series of selected objects** command numbers all parts that have the same assembly prefix.

To number anchor rods and columns:

1. Create steel columns.

2. Create anchor rods with the numbering series prefix AR and start number 1.

   Ensure that this numbering series is different to any other parts or assemblies in the model.

3. On the **Drawings & reports** tab, click **Numbering settings** --> **Numbering settings** to open the **Numbering Setup** dialog box.

4. Ensure that the **Column orientation** check box is not selected, and then click **Apply**.

5. Select one of the anchor rods in the model.

6. On the **Drawings & reports** tab, click **Perform numbering** --> **Number series of selected objects**.

   All parts with the AR prefix and start number at 1 are numbered.
7. After the anchor rod numbering is complete, on the Drawings & reports tab, click Numbering settings --> Numbering settings to open the Numbering Setup dialog box.

8. Select the Column orientation check box, and then click Apply.

9. Select one of the steel columns in the model.

10. On the Drawings & reports tab, click Perform numbering --> Number series of selected objects.

   All columns belonging to the same numbering series as the selected column are numbered.

See also

Number a series of parts (page 217)

Example: Number parts in selected phases

This example shows how to number a model that consists of multiple phases, each phase having a different detailing and submittal schedule. This enables you to release drawings for a particular phase at any time.

Before you start, divide the model into phases.

To number parts in selected phases:

1. Apply a specific numbering series prefix and start number for parts in each phase.

   For example:
   - The beams in phase 1 get the numbering series prefix B and start number 1000.
   - The beams in phase 2 get the numbering series prefix B and start number 2000.
Phase 1: green

Phase 2: magenta

2. Ensure that the numbering series are not overlapping.
   For example, to avoid numbering overlaps with the beams in phase 2, phase 1 should not contain more than 1000 position numbers.

3. Select the parts you want to number.

   **TIP** Use selection filters to easily select parts belonging to a certain phase or parts with a specific start number series. You can also use selection filters to ignore specific phases that are already completed or phases that are not ready for numbering.

4. On the **Drawings & reports** tab, click **Numbering settings** --> **Numbering settings** to open the **Numbering Setup** dialog box.

5. Modify the numbering settings, and then click **Apply**.

6. Select one of the parts you want to number.

7. On the **Drawings & reports** tab, click **Perform numbering** --> **Number series of selected objects**.
   All parts belonging to the same numbering series as the selected part are numbered.
See also

Number a series of parts (page 217)
Numbering settings during a project (page 305)
This section provides more information about the various settings you can modify in Tekla Structures.

Click the links below to find out more:

- General settings (page 242)
- View and representation settings (page 246)
- Part properties (page 251)
- Part position settings (page 264)
- Detail properties (page 273)
- Numbering settings (page 286)

### 14.1 General settings

This section provides more information about some general modeling settings.

Click the links below to find out more:

- Grid properties (page 242)
- Grid line properties (page 243)
- Point properties (page 244)
- Rotation settings (page 244)
- Screenshot settings (page 245)

### Grid properties

Use the Grid dialog box to view and modify the grid properties. The units depend on the settings in File menu -> Settings -> Options -> Units and decimals.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinates</td>
<td>The coordinates of the grid in the x, y, and z directions. X: grid lines vertical to the work plane. Y: grid lines horizontal to the work plane. Z: elevations in the structure. You can enter a maximum of 1024 characters. Use a zero at the start to represent a grid on the 0,0 coordinate and spaces as separators for coordinates. The x and y coordinates are relative, which means that the entries for x and y are always relative to the previous entry. The z coordinates are absolute, which means that entries for z are absolute distances from the work plane origin.</td>
</tr>
<tr>
<td>Labels</td>
<td>The names of the grid lines shown in views. The names in the X box are associated with the grid lines parallel to the y axis and vice versa. The Z box is for the names of levels parallel to the work plane. If you wish, you can leave the label boxes empty.</td>
</tr>
<tr>
<td>Line extensions</td>
<td>Define how far the grid lines extend in the directions Left/Below and Right/Above.</td>
</tr>
<tr>
<td>Origin</td>
<td>The coordinates of the grid origin in the x, y, and z directions. These values offset the grid from the work plane origin, not from the global model origin.</td>
</tr>
<tr>
<td>Magnetic grid plane</td>
<td>Select to bind objects to grid lines.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>Click to access the user-defined properties of the grid.</td>
</tr>
</tbody>
</table>

**Grid line properties**

Use the Grid Line Properties dialog box to view and modify the properties of a single grid line. The units depend on the settings in File menu --> Settings --> Options --> Units and decimals.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>The name of the grid line.</td>
</tr>
<tr>
<td>Depth in view plane</td>
<td>The height of the grid plane perpendicular to the view plane.</td>
</tr>
<tr>
<td>Extension Left/Below</td>
<td>Define how far the grid lines extend in the directions Left/Below and Right/Above.</td>
</tr>
<tr>
<td>Extension Right/Above</td>
<td></td>
</tr>
</tbody>
</table>
### Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Magnetic grid plane</td>
<td>Select to bind objects to the grid line.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>Click to access the user-defined properties of the grid line.</td>
</tr>
<tr>
<td>Visible in drawings</td>
<td>Select to make the grid line visible in drawings.</td>
</tr>
<tr>
<td>Grid line automatic dimensioning</td>
<td>Select to use single grid lines in grid dimensioning.</td>
</tr>
</tbody>
</table>

### Point properties

Use the **Point Information** dialog box to view the properties of a point.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase</td>
<td>The phase number. You can filter objects by their phase numbers.</td>
</tr>
<tr>
<td>Id</td>
<td>The ID number, which is used in log files. You can filter objects by their ID numbers.</td>
</tr>
<tr>
<td>Coordinates</td>
<td>The local (work plane) and global x, y, and z coordinates of a point. Indicates the correct location of the point. The units depend on the settings in File menu --&gt; Settings --&gt; Options --&gt; Units and decimals.</td>
</tr>
</tbody>
</table>

See also

*Create points (page 11)*

### Rotation settings

Use the **Copy - Rotate** and **Move - Rotate** dialog boxes to view and modify the settings that are used when you rotate objects in Tekla Structures. The units depend on the settings in File menu --> Settings --> Options --> Units and decimals.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>The x and y coordinates of the start point of the rotation axis.</td>
</tr>
<tr>
<td>Y0</td>
<td></td>
</tr>
<tr>
<td>Origin angle</td>
<td>The angle of the rotation axis when rotating around a line on the work plane.</td>
</tr>
<tr>
<td>Number of copies</td>
<td>Defines the number of copies created.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>dZ</td>
<td>The difference in position between the original and copied object in the z direction.</td>
</tr>
<tr>
<td>Rotation angle</td>
<td>The rotation angle between the original and new position.</td>
</tr>
<tr>
<td>Around</td>
<td>Defines whether the rotation axis is a line on the work plane or in the z direction.</td>
</tr>
</tbody>
</table>

**Screenshot settings**

Use the **Screenshot** dialog box to view and modify the screenshot settings.

The following options are available in model views and in drawings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View name</td>
<td>Shows the selected view name.</td>
</tr>
<tr>
<td>View</td>
<td>Includes the view content and window borders in the screenshot. Not available in model views.</td>
</tr>
<tr>
<td>View without borders</td>
<td>Includes only the view content in the screenshot. Not available in model views.</td>
</tr>
<tr>
<td>Rendered view</td>
<td>For high resolution screenshots from model views. The <strong>Options</strong> button displays the <strong>Screenshot Options</strong> dialog box. Not available in drawings.</td>
</tr>
<tr>
<td>Place on clipboard</td>
<td>Places the screenshot on the clipboard. Not available in drawings.</td>
</tr>
<tr>
<td>Print to file</td>
<td>Saves the screenshot to a file.</td>
</tr>
</tbody>
</table>

The following screenshot options are only available in model views:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Final width</td>
<td>The width of the screenshot. The units depend on the settings in File menu --&gt; Settings --&gt; Options --&gt; Units and decimals.</td>
</tr>
<tr>
<td>Final height</td>
<td>The height of the screenshot. The units depend on the settings in File menu --&gt; Settings --&gt; Options --&gt; Units and decimals.</td>
</tr>
</tbody>
</table>
Option | Description
---|---
DPI | The pixel density (DPI) of the screenshot. There are limitations to pixel density. You can change the DPI using a graphics editor.
White background | Uses white background.
Smooth lines | Uses smooth lines to decrease jagged edges.
Line width | Sets the line width.

### 14.2 View and representation settings

This section provides more information about specific view and representation settings.

Click the links below to find out more:

- View properties (page 246)
- Grid view properties (page 247)
- Display settings (page 248)
- Color settings for object groups (page 250)
- Transparency settings for object groups (page 251)

#### View properties

Use the **View Properties** dialog box to view and modify the model view properties.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the view.</td>
</tr>
<tr>
<td>Angle</td>
<td>Whether the view angle is <strong>Plane</strong> or <strong>3D</strong>.</td>
</tr>
<tr>
<td>Projection</td>
<td>The projection type of views. <strong>Orthogonal:</strong> All objects are of equal size (no perspective). When you zoom, text and point size remains the same. In addition, the zoom remains on object faces. <strong>Perspective:</strong> Distant objects appear smaller than close ones, as do text and points. You can zoom, rotate, or fly through the model.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Rotation</strong></td>
<td>How the view is rotated around the z and x axes. Rotation is view-specific. The units depend on the settings in File menu --&gt; Settings --&gt; Options --&gt; Units and decimals.</td>
</tr>
<tr>
<td><strong>Color and transparency in all views</strong></td>
<td>The color and transparency setting that is used in all views (according to the status of the objects in the model).</td>
</tr>
<tr>
<td><strong>Representation</strong></td>
<td>Opens the Object Representation dialog box for defining color and transparency settings.</td>
</tr>
<tr>
<td><strong>View depth</strong></td>
<td>The thickness of the displayed slice of model. You can define the depth separately upwards and downwards from the view plane. Only objects positioned within the view depth are visible in the model. The units depend on the settings in File menu --&gt; Settings --&gt; Options --&gt; Units and decimals.</td>
</tr>
<tr>
<td><strong>Display</strong></td>
<td>Opens the Display dialog box for defining which objects are displayed (page 248) in the view and how.</td>
</tr>
<tr>
<td><strong>Visible object group</strong></td>
<td>Which object group is displayed in the view.</td>
</tr>
<tr>
<td><strong>Object group</strong></td>
<td>Opens the Object Group - View Filter dialog box for creating and modifying object groups.</td>
</tr>
</tbody>
</table>

**Grid view properties**

Use the Creation of Views Along Grid Lines dialog box to view and modify the properties of grid views.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View plane</strong></td>
<td>The plane of the view defined by two axes similarly to the default view.</td>
</tr>
<tr>
<td><strong>Number of views</strong></td>
<td>Defines which grid lines the views will be created of. None does not create any views. One (First) only creates the view closest to the grid origin. One (Last) only creates the view furthest from the grid origin. All creates all views in grid planes in the relevant direction.</td>
</tr>
</tbody>
</table>
### View name prefix
The prefix to be used with the grid label in the view name. This name overrides the name in the view properties.

View names consist of a prefix and a grid label, e.g. PLAN +3000. If the **View name prefix** box is left empty, no prefix is used. Tekla Structures adds a dash and a running number to the view name if view names are otherwise identical.

### View properties
Defines which view properties (applied or saved) will be used.

Each view plane has its own view properties. You can load the properties from the current view properties with the option `<applied values>` or from saved view properties. The **Show** button displays the current view properties.

### Display settings
Use the **Display** dialog box to define which object types Tekla Structures displays and how they appear in the model. Some of these settings may affect system performance.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parts</td>
<td>Defines how parts are displayed. <strong>Fast</strong> uses a rapid drawing technique that displays internal hidden edges, but skips cuts. The setting does not automatically affect already modeled parts. When you switch this setting on, the fast representation mode will be applied only to newly created parts and to parts that are displayed with the <strong>Show with Exact Lines</strong> command. <strong>Exact</strong> displays the cuts, but hides the internal hidden lines of parts. <strong>Reference line</strong> shows parts as sticks. This option increases display speed significantly, when viewing the entire model, or large parts of it.</td>
</tr>
<tr>
<td>Bolts</td>
<td>Defines how bolts are displayed. <strong>Fast</strong> displays the axis and a cross to represent the bolt head. This is the recommended representation mode for bolts, because it increases display speed significantly and consumes less system memory. <strong>Exact</strong> shows bolts, washers, and nuts as solid objects.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Holes</td>
<td>Defines how holes are displayed.</td>
</tr>
<tr>
<td><strong>Fast</strong></td>
<td>only displays the circle in the first plane. When using this option, Tekla Structures always displays fast holes on the first part (counting from the head of the bolt). If there are slotted holes in any of the parts, a slotted hole is displayed on the first part, even if the hole in that part is not slotted. The new slotted hole has the same size and rotation as the first slotted hole (counting from the head of the bolt).</td>
</tr>
<tr>
<td><strong>Exact</strong></td>
<td>shows holes as solid objects.</td>
</tr>
<tr>
<td><strong>Exact slotted holes</strong></td>
<td>only displays slotted holes in exact mode and ordinary holes in fast mode.</td>
</tr>
<tr>
<td>Holes that are outside a part are always displayed as fast holes.</td>
<td></td>
</tr>
<tr>
<td>Welds</td>
<td>Defines how welds are displayed.</td>
</tr>
<tr>
<td><strong>Fast</strong></td>
<td>displays a symbol for welds.</td>
</tr>
<tr>
<td><strong>Exact</strong></td>
<td>shows welds as solid objects and displays the weld symbols. When you select welds, the weld marks are displayed.</td>
</tr>
<tr>
<td><strong>Exact - no weld mark</strong></td>
<td>shows welds as solid objects but does not display the weld symbols, nor the weld marks when you select welds.</td>
</tr>
<tr>
<td>Construction planes</td>
<td>Defines how construction planes are displayed.</td>
</tr>
<tr>
<td>Reinforcing bars</td>
<td>Defines how reinforcement objects are displayed.</td>
</tr>
<tr>
<td><strong>Fast</strong></td>
<td>displays the shape of reinforcement meshes using an outline polygon and a diagonal line. Single reinforcing bars and bar groups are displayed as solid objects.</td>
</tr>
<tr>
<td><strong>Exact</strong></td>
<td>shows reinforcing bars, bar groups, and reinforcement meshes as solid objects.</td>
</tr>
<tr>
<td>Part label</td>
<td>See Part labels (page 31).</td>
</tr>
<tr>
<td>Point size</td>
<td>Defines the size of points in views. Also affects the size of the handles, together with XS_HANDLE_SCALE.</td>
</tr>
<tr>
<td><strong>In model</strong></td>
<td>increases the point size on the screen when you zoom in.</td>
</tr>
<tr>
<td><strong>In view</strong></td>
<td>does not increase the point size.</td>
</tr>
</tbody>
</table>

**See also**

- Set the visibility and appearance of model objects (page 161)
- View pour objects (page 139)
Change the rendering of parts and components (page 163)
Set the visibility and appearance of welds (page 86)
Set the visibility of pour breaks (page 148)

Color settings for object groups
Use the Object Representation dialog box to define the color of object groups.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>As is</td>
<td>The current color is used.</td>
</tr>
<tr>
<td></td>
<td>If the object belongs to one of the object groups defined in the following</td>
</tr>
<tr>
<td></td>
<td>rows, its color is defined by the settings that the object group in</td>
</tr>
<tr>
<td></td>
<td>question has on that row.</td>
</tr>
<tr>
<td>Colors</td>
<td>Select color from the list.</td>
</tr>
<tr>
<td>Color by class</td>
<td>All parts are colored according to their Class property. See</td>
</tr>
<tr>
<td></td>
<td>Change the color of a model object (page 173).</td>
</tr>
<tr>
<td>Color by lot</td>
<td>Parts belonging to different lots or phases get different colors</td>
</tr>
<tr>
<td></td>
<td>according to the lot or phase number:</td>
</tr>
<tr>
<td>Color by phase</td>
<td>Displays parts according to the member analysis class.</td>
</tr>
<tr>
<td>Color by analysis type</td>
<td>Displays parts according to the utilization ratio in analysis.</td>
</tr>
<tr>
<td>Color by analysis utility check</td>
<td>Displays parts in different colors according to the values of a user-defined attribute.</td>
</tr>
</tbody>
</table>

See also
Change the color and transparency of model objects (page 172)
Transparency settings for object groups
Use the Object Representation dialog box to define the transparency of object groups.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>As is</td>
<td>The current visibility. If the object belongs to any object group whose</td>
</tr>
<tr>
<td></td>
<td>visibility and color settings have been defined, the settings will be read</td>
</tr>
<tr>
<td></td>
<td>from that object group.</td>
</tr>
<tr>
<td>Visible</td>
<td>Object is shown in the views.</td>
</tr>
<tr>
<td>50% transparent</td>
<td>Object is transparent in the views.</td>
</tr>
<tr>
<td>70% transparent</td>
<td>Object is transparent in the views.</td>
</tr>
<tr>
<td>90% transparent</td>
<td>Object is transparent in the views.</td>
</tr>
<tr>
<td>Hidden</td>
<td>Object is not shown in the views.</td>
</tr>
</tbody>
</table>

See also
Change the color and transparency of model objects (page 172)

14.3 Part properties
This section provides more information about the properties of specific steel and concrete parts.
Click the links below to find out more:
• Steel column properties (page 252)
• Steel beam properties (page 252)
• Contour plate properties (page 253)
• Orthogonal beam properties (page 254)
• Twin profile properties (page 255)
• Item properties (page 256)
• Pad footing properties (page 257)
• Strip footing properties (page 258)
• Concrete column properties (page 259)
• Concrete beam properties (page 260)
• Concrete slab properties (page 261)
• Concrete panel properties (page 262)
Steel column properties

Use the **Column Properties** dialog box to view and modify the properties of a steel column. The file name extension of a column properties file is *.*.clm.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part prefix and start number</td>
<td>The part mark series of the column.</td>
</tr>
<tr>
<td>Assembly prefix and start number</td>
<td>The assembly mark series of the column.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of the column. Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the column.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the column.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group columns. For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>Vertical</td>
<td>See Vertical position (page 268).</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation (page 266).</td>
</tr>
<tr>
<td>Horizontal</td>
<td>See Horizontal position (page 270).</td>
</tr>
<tr>
<td>Top</td>
<td>The position of the second end of the column in the global z direction.</td>
</tr>
<tr>
<td>Bottom</td>
<td>The position of the first end of the column in the global z direction.</td>
</tr>
<tr>
<td>Deforming tab</td>
<td>Warping, cambering, and shortening of the column.</td>
</tr>
</tbody>
</table>

**See also**

Create a steel column (page 34)
Steel beam properties

Use the **Beam Properties** dialog box to view and modify the properties of a steel beam, steel polybeam, or curved beam. The file name extension of a beam properties file is *.*.prt.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part prefix and start number</td>
<td>The part mark series of a beam.</td>
</tr>
<tr>
<td>Assembly prefix and start number</td>
<td>The assembly mark series of the beam.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of a beam.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of a beam.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of a beam.</td>
</tr>
<tr>
<td>Finish</td>
<td>The finish type.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group beams.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See <strong>User-defined attributes</strong> (page 264).</td>
</tr>
<tr>
<td>On plane</td>
<td>See <strong>Position on the work plane</strong> (page 265).</td>
</tr>
<tr>
<td>Rotation</td>
<td>See <strong>Rotation</strong> (page 266).</td>
</tr>
<tr>
<td>At depth</td>
<td>See <strong>Position depth</strong> (page 267).</td>
</tr>
<tr>
<td>End offset</td>
<td>See <strong>End offsets</strong> (page 272).</td>
</tr>
<tr>
<td>Radius</td>
<td>The plane of curvature and radius of a curved beam.</td>
</tr>
<tr>
<td>Number of segments</td>
<td>The number of segments Tekla Structures uses when drawing a curved beam.</td>
</tr>
<tr>
<td>Deforming tab</td>
<td>Warping, cambering, and shortening of the beam.</td>
</tr>
</tbody>
</table>

See also

**Create a steel beam** (page 35)

Contour plate properties

Use the **Contour Plate Properties** dialog box to view and modify the properties of a contour plate. The file name extension of a contour plate properties file is *.*.cpl.
### Option Description

<table>
<thead>
<tr>
<th>Part prefix and start number</th>
<th>The part mark series of the contour plate.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly prefix and start number</td>
<td>The assembly mark series of the contour plate.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of the contour plate. Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the contour plate. The format is PL+ thickness, for example PL20.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the contour plate.</td>
</tr>
<tr>
<td>Finish</td>
<td>The finish type. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group contour plates. For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth (page 267).</td>
</tr>
</tbody>
</table>

**See also**

Create a contour plate (page 37)

### Orthogonal beam properties

Use the Orthogonal Beam Properties dialog box to view and modify the properties of an orthogonal steel beam. The file name extension of an orthogonal beam properties file is *.crs.*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part prefix and start number</td>
<td>The part mark series of the beam.</td>
</tr>
<tr>
<td>Assembly prefix and start number</td>
<td>The assembly mark series of the beam.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of the beam. Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the beam.</td>
</tr>
</tbody>
</table>

---

Modeling settings 254 Part properties
### Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Material</strong></td>
<td>The material of the beam.</td>
</tr>
<tr>
<td><strong>Finish</strong></td>
<td>The finish type.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been treated, e.g., with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td><strong>Class</strong></td>
<td>Used to group beams.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td><strong>User-defined attributes</strong></td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td><strong>Vertical</strong></td>
<td>See Vertical position (page 268).</td>
</tr>
<tr>
<td><strong>Rotation</strong></td>
<td>See Rotation (page 266).</td>
</tr>
<tr>
<td><strong>Horizontal</strong></td>
<td>See Horizontal position (page 270).</td>
</tr>
<tr>
<td><strong>Top</strong></td>
<td>The position of the second end of the beam in the z direction of the work plane.</td>
</tr>
<tr>
<td><strong>Bottom</strong></td>
<td>The position of the first end of the beam in the z direction of the work plane.</td>
</tr>
</tbody>
</table>

**See also**

Create an orthogonal beam (page 49)

---

### Twin profile properties

Use the **Twin Profile Properties** dialog box to view and modify the properties of a twin steel profile. The file name extension of a twin profile properties file is *.dia.*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Part prefix and start number</strong></td>
<td>The part mark series of the twin profile.</td>
</tr>
<tr>
<td><strong>Assembly prefix and start number</strong></td>
<td>The assembly mark series of the twin profile.</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>The user-definable name of the twin profile.</td>
</tr>
<tr>
<td><strong>Profile</strong></td>
<td>The profile of both the beams in the twin profile.</td>
</tr>
<tr>
<td><strong>Material</strong></td>
<td>The material of the beams.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Finish</strong></td>
<td>The type of finish. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot</td>
</tr>
<tr>
<td></td>
<td>galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td><strong>Class</strong></td>
<td>Used to group twin profiles. For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td><strong>User-defined</strong></td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td><strong>attributes</strong></td>
<td></td>
</tr>
<tr>
<td><strong>On plane</strong></td>
<td>See Position on the work plane (page 265).</td>
</tr>
<tr>
<td><strong>Rotation</strong></td>
<td>See Rotation (page 266).</td>
</tr>
<tr>
<td><strong>At depth</strong></td>
<td>See Position depth (page 267).</td>
</tr>
<tr>
<td><strong>End offset</strong></td>
<td>See End offsets (page 272).</td>
</tr>
<tr>
<td><strong>Twin profile type</strong></td>
<td>Defines how the profiles are combined.</td>
</tr>
<tr>
<td><strong>Horizontal</strong></td>
<td>The horizontal clearance between the profiles.</td>
</tr>
<tr>
<td><strong>Vertical</strong></td>
<td>The vertical clearance between the profiles.</td>
</tr>
</tbody>
</table>

See also
Create a twin profile (page 50)

**Item properties**
Use the **Item Properties** dialog box to define, view, and modify the properties of an item. The file name extension of an item properties file is `.ips`.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Part prefix</strong></td>
<td>The part mark series of the item.</td>
</tr>
<tr>
<td><strong>Part start number</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Assembly prefix</strong></td>
<td>The assembly mark series of the item.</td>
</tr>
<tr>
<td><strong>Assembly start number</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>The user-definable name of the item. Tekla Structures uses item names in reports and drawing tables, and to identify items of the same type.</td>
</tr>
<tr>
<td><strong>Shape</strong></td>
<td>The shape of the item. To select a shape from the shape catalog, click <strong>Select</strong>. To show the item shape in reports and drawing tables, use the <strong>PROFILE</strong> template attribute.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the item.</td>
</tr>
<tr>
<td>Finish</td>
<td>The finish type. Finish is user-definable. It describes how the item surface has been treated.</td>
</tr>
<tr>
<td>Class</td>
<td>Used for grouping items. For example, you can display items of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>attributes</td>
<td></td>
</tr>
<tr>
<td>On plane</td>
<td>See Position on the work plane (page 265).</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation (page 266).</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth (page 267).</td>
</tr>
<tr>
<td>End offset</td>
<td>See End offsets (page 272).</td>
</tr>
</tbody>
</table>

See also
Create an item (page 51)

Pad footing properties
Use the Pad Footing Properties dialog box to view and modify the properties of a pad footing. The file name extension of a pad footing properties file is *.cpf.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the pad footing. Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the pad footing.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the pad footing.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group pad footings. For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>attributes</td>
<td></td>
</tr>
<tr>
<td>Vertical</td>
<td>See Vertical position (page 268).</td>
</tr>
</tbody>
</table>
## Strip footing properties

Use the **Strip Footing Properties** dialog box to view and modify the properties of a strip footing. The file name extension of a strip footing properties file is *.csf.*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the strip footing. Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the strip footing.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the strip footing.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group strip footings. For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>On plane</td>
<td>See Position on the work plane (page 265).</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation (page 266).</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth (page 267).</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>End offset</td>
<td>See End offsets (page 272).</td>
</tr>
<tr>
<td>Cast unit prefix and start number</td>
<td>Define the cast unit series of the strip footing.</td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the footing is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place parts. Used to separate pour objects from one another.</td>
</tr>
<tr>
<td>Radius</td>
<td>The plane of curvature and radius of the curved strip footing.</td>
</tr>
<tr>
<td>Number of segments</td>
<td>The number of segments required to draw a curved strip footing.</td>
</tr>
</tbody>
</table>

See also
Create a strip footing (page 52)

**Concrete column properties**

Use the **Concrete Column Properties** dialog box to view and modify the properties of a concrete column. The file name extension of a concrete column properties file is *.ccl.*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the column.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the column.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the column.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group columns.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>Vertical</td>
<td>See Vertical position (page 268).</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation (page 266).</td>
</tr>
<tr>
<td>Horizontal</td>
<td>See Horizontal position (page 270).</td>
</tr>
</tbody>
</table>
### Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>The position of the second end of the column in the global z direction.</td>
</tr>
<tr>
<td>Bottom</td>
<td>The position of the first end of the column in the global z direction.</td>
</tr>
<tr>
<td>Cast unit prefix and start number</td>
<td>Define the cast unit series of the column.</td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the column is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place parts. Used to separate pour objects from one another.</td>
</tr>
<tr>
<td>Deforming tab</td>
<td>Warping, cambering and shortening of the column.</td>
</tr>
</tbody>
</table>

See also

*Create a concrete column (page 53)*

---

### Concrete beam properties

Use the **Concrete Beam Properties** dialog box to view and modify the properties of a concrete beam or polybeam. The file name extension of a concrete beam properties file is * .cbm.*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the beam.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the beam.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the beam.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group beams.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>On plane</td>
<td>See Position on the work plane (page 265).</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation (page 266).</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth (page 267).</td>
</tr>
<tr>
<td>End offset</td>
<td>See End offsets (page 272).</td>
</tr>
</tbody>
</table>
## Concrete slab properties

Use the **Concrete Slab Properties** dialog box to view and modify the properties of a concrete slab. The file name extension of a concrete slab properties file is *.csl.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The user-definable name of the slab.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td><strong>Thickness</strong></td>
<td>The thickness of the slab.</td>
</tr>
<tr>
<td><strong>Material</strong></td>
<td>The material of the slab.</td>
</tr>
<tr>
<td><strong>Finish</strong></td>
<td>The type of finish.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td><strong>Class</strong></td>
<td>Used to group slabs.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td><strong>User-defined attributes</strong></td>
<td>See <strong>User-defined attributes</strong> (page 264).</td>
</tr>
<tr>
<td><strong>At depth</strong></td>
<td>See <strong>Position depth</strong> (page 267).</td>
</tr>
<tr>
<td><strong>Cast unit prefix and start number</strong></td>
<td>Define the cast unit series of the slab.</td>
</tr>
<tr>
<td><strong>Cast unit type</strong></td>
<td>Indicates whether the slab is precast or cast in place.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place parts. Used to separate pour objects from one another.</td>
</tr>
</tbody>
</table>

See also

Create a concrete slab (page 56)

Concrete panel properties

Use the **Concrete Panel Properties** dialog box to view and modify the properties of a concrete panel. The file name extension of a concrete panel properties file is *.cpn.*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the panel.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the panel (thickness × height of the wall).</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the panel.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group panels.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>On plane</td>
<td>See Position on the work plane (page 265).</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation (page 266).</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth (page 267).</td>
</tr>
<tr>
<td>End offset</td>
<td>See End offsets (page 272).</td>
</tr>
<tr>
<td>Cast unit prefix and</td>
<td>Define the cast unit series of the panel.</td>
</tr>
<tr>
<td>start number</td>
<td></td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the panel is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place parts. Used to separate pour objects from one another.</td>
</tr>
<tr>
<td>Radius</td>
<td>The plane of curvature and radius of the curved panel.</td>
</tr>
<tr>
<td>Number of segments</td>
<td>The number of segments required to draw a curved panel.</td>
</tr>
</tbody>
</table>
Concrete item properties

Use the Concrete Item Properties dialog box to define, view, and modify the properties of a concrete item. The file name extension of a concrete item properties file is .ipc.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the concrete item. Tekla Structures uses item names in reports and drawing tables, and to identify items of the same type.</td>
</tr>
<tr>
<td>Shape</td>
<td>The shape of the concrete item. To select a shape from the shape catalog, click Select. To show the item shape in reports and drawing tables, use the PROFILE template attribute.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the concrete item.</td>
</tr>
<tr>
<td>Finish</td>
<td>The finish type. Finish is user-definable. It describes how the item surface has been treated.</td>
</tr>
<tr>
<td>Class</td>
<td>Used for grouping items. For example, you can display items of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>On plane</td>
<td>See Position on the work plane (page 265).</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation (page 266).</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth (page 267).</td>
</tr>
<tr>
<td>End offset</td>
<td>See End offsets (page 272).</td>
</tr>
<tr>
<td>Cast unit prefix</td>
<td>The cast unit series of the concrete item.</td>
</tr>
<tr>
<td>Cast unit start number</td>
<td></td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the concrete item is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place items. Used for separating pour objects from one another.</td>
</tr>
</tbody>
</table>

See also
Create a concrete item (page 58)
User-defined attributes

User-defined attributes provide extra information about a part. Attributes can consist of numbers, text, or lists. The following table gives some examples of what you can use attributes for:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Can be used...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>In part and weld marks in Tekla Structures drawings, or in projects.</td>
</tr>
<tr>
<td>Shorten</td>
<td>When drawings of the parts are created, Tekla Structures decreases the true length of the part by this value. This is useful when creating assembly drawings of bracing bars that should always be under tension.</td>
</tr>
<tr>
<td>Camber</td>
<td>In part marks in Tekla Structures drawings.</td>
</tr>
<tr>
<td>Preliminary mark</td>
<td>To obtain preliminary marks for parts in reports.</td>
</tr>
<tr>
<td>Locked</td>
<td>To protect objects from being accidentally changed.</td>
</tr>
<tr>
<td>Shear, Tension, and Moment</td>
<td>To save reaction forces for AutoDefaults. You can enter forces separately for each end of a part.</td>
</tr>
<tr>
<td>User field 1…4</td>
<td>User-defined fields. You can change the names of these fields and add new user-defined fields.</td>
</tr>
<tr>
<td>Connection code</td>
<td>When importing information on connection types into Tekla Structures. You can then use the connection codes as rules in AutoConnection and AutoDefaults. Each end of a part can have a different connection code.</td>
</tr>
<tr>
<td>Moment connection</td>
<td>For selecting whether to show moment connection symbols in drawings or not.</td>
</tr>
</tbody>
</table>

See also

Part properties (page 251)

14.4 Part position settings

This section provides more information about specific part position settings. These settings can be modified on the Position tab in the part properties dialog box, or by using the contextual toolbar.

Click the links below to find out more:

Position on the work plane (page 265)
Rotation (page 266)
Position depth (page 267)
Position on the work plane

Use the On plane option in the part properties dialog box to view and change the part’s position on the work plane. The position is always relative to the part’s handles.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle</td>
<td>The handles are in the middle of the part.</td>
<td>![Diagram of Middle Position]</td>
</tr>
<tr>
<td>Right</td>
<td>The part is positioned underneath its handles.</td>
<td>![Diagram of Right Position]</td>
</tr>
<tr>
<td>Left</td>
<td>The part is positioned above its handles.</td>
<td>![Diagram of Left Position]</td>
</tr>
</tbody>
</table>

Examples

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle 300</td>
<td>![Diagram of Middle Position with 300]</td>
</tr>
</tbody>
</table>
Position Example

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right 300</td>
<td><img src="image1" alt="Right 300 Example" /></td>
</tr>
<tr>
<td>Left 300</td>
<td><img src="image2" alt="Left 300 Example" /></td>
</tr>
</tbody>
</table>

See also
Modify the position of a part (page 61)

**Rotation**
Use the Rotation option in the part properties dialog box to view and change the rotation of a part around its axis on the work plane.

You can also define the angle of rotation. Tekla Structures measures positive values clockwise around the local x axis.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Front</td>
<td>The work plane is parallel to the front plane of the part.</td>
<td><img src="image3" alt="Front Example" /></td>
</tr>
<tr>
<td>Top</td>
<td>The work plane is parallel to the top plane of the part.</td>
<td><img src="image4" alt="Top Example" /></td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
<td>---------</td>
</tr>
<tr>
<td>Back</td>
<td>The work plane is parallel to the back plane of the part.</td>
<td>![Example Image]</td>
</tr>
<tr>
<td>Below</td>
<td>The work plane is parallel to the bottom plane of the part.</td>
<td>![Example Image]</td>
</tr>
</tbody>
</table>

See also
Modify the position of a part (page 61)

### Position depth
Use the **At depth** option in the part properties dialog box to view and change the position depth of the part. The position is always perpendicular to the work plane.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle</td>
<td>The part is positioned in the middle of the work plane.</td>
<td>![Example Image]</td>
</tr>
<tr>
<td>Front</td>
<td>The part is positioned above the work plane.</td>
<td>![Example Image]</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
<td>---------</td>
</tr>
<tr>
<td>Behind</td>
<td>The part is positioned underneath the work plane.</td>
<td>![Diagram of part behind work plane]</td>
</tr>
</tbody>
</table>

### Examples

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Middle</strong> 400</td>
<td>![Diagram of part at middle position]</td>
</tr>
<tr>
<td><strong>Front</strong> 400</td>
<td>![Diagram of part at front position]</td>
</tr>
<tr>
<td><strong>Behind</strong> 400</td>
<td>![Diagram of part behind position]</td>
</tr>
</tbody>
</table>

**See also**

Modify the position of a part (page 61)
**Vertical position**

Use the **Vertical** option in the part properties dialog box to view and change the vertical position of the part. The position is always relative to the part’s handles.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Middle</strong></td>
<td>The handle is in the middle of the part.</td>
<td><img src="image1" alt="Middle Example" /></td>
</tr>
<tr>
<td><strong>Down</strong></td>
<td>The part is positioned underneath its handle.</td>
<td><img src="image2" alt="Down Example" /></td>
</tr>
<tr>
<td><strong>Up</strong></td>
<td>The part is positioned above its handle.</td>
<td><img src="image3" alt="Up Example" /></td>
</tr>
</tbody>
</table>
Examples

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle 200</td>
<td><img src="image1" alt="Example" /></td>
</tr>
<tr>
<td>Down 200</td>
<td><img src="image2" alt="Example" /></td>
</tr>
<tr>
<td>Up 200</td>
<td><img src="image3" alt="Example" /></td>
</tr>
</tbody>
</table>

See also

Modify the position of a part (page 61)

**Horizontal position**

Use the **Horizontal** option in the part properties dialog box to view and change the horizontal position of the part. The position is always relative to the part’s handle.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle</td>
<td>The handle is in the middle of the part.</td>
<td><img src="image1" alt="Diagram" /></td>
</tr>
<tr>
<td>Left</td>
<td>The part is positioned on the left side of its handle.</td>
<td><img src="image2" alt="Diagram" /></td>
</tr>
<tr>
<td>Right</td>
<td>The part is positioned on the right side of its handle.</td>
<td><img src="image3" alt="Diagram" /></td>
</tr>
</tbody>
</table>

**Examples**

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle 150</td>
<td><img src="image4" alt="Diagram" /></td>
</tr>
</tbody>
</table>
End offsets

Use the \textbf{Dx}, \textbf{Dy} and \textbf{Dz} options in the part properties dialog box to move the ends of a part, relative to its handles. You can enter positive and negative values.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>\textbf{Dx}</td>
<td>Changes the length of the part by moving the part end point along the line formed by the part handles.</td>
</tr>
<tr>
<td>\textbf{Dy}</td>
<td>Moves the part end perpendicular to the part handles.</td>
</tr>
<tr>
<td>\textbf{Dz}</td>
<td>Moves the part end in the z direction of the work plane.</td>
</tr>
</tbody>
</table>

Examples

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>\textbf{Dx}</td>
<td>\textbf{End point: 200}</td>
</tr>
</tbody>
</table>
| \begin{figure}[h]
\centering
\includegraphics[width=0.5\textwidth]{example.png}
\end{figure} | \begin{figure}[h]
\centering
\includegraphics[width=0.5\textwidth]{example.png}
\end{figure} |
<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dx</td>
<td><img src="image1.png" alt="Image" /></td>
</tr>
<tr>
<td>End point: -200</td>
<td></td>
</tr>
<tr>
<td>Dy</td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
<tr>
<td>End point: 300</td>
<td></td>
</tr>
<tr>
<td>Dy</td>
<td><img src="image3.png" alt="Image" /></td>
</tr>
<tr>
<td>End point: -300</td>
<td></td>
</tr>
<tr>
<td>Dz</td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
<tr>
<td>End point: 400</td>
<td></td>
</tr>
<tr>
<td>Dz</td>
<td><img src="image5.png" alt="Image" /></td>
</tr>
<tr>
<td>End point: -400</td>
<td></td>
</tr>
</tbody>
</table>

See also
Modify the position of a part (page 61)

14.5 Detail properties
This section provides more information about the properties of specific modeling details.
Click the links below to find out more:
- Bolt properties (page 274)
- Weld properties (page 278)
- List of weld types (page 282)
- Corner chamfer properties (page 284)
**Bolt properties**

Use the **Bolt Properties** dialog box to view or modify the properties of a bolt group. The units depend on the settings in **File menu --> Settings --> Options --> Units and decimals**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bolt size</strong></td>
<td>Bolt diameter.</td>
</tr>
<tr>
<td><strong>Bolt standard</strong></td>
<td>Bolt assembly standard/grade.</td>
</tr>
<tr>
<td><strong>Bolt type</strong></td>
<td>Defines whether the bolts are assembled on-site or in the shop.</td>
</tr>
<tr>
<td><strong>Connect part/assembly</strong></td>
<td>Indicates whether you are bolting a secondary part or a sub-assembly.</td>
</tr>
<tr>
<td><strong>Thread in material</strong></td>
<td>Indicates if the thread of the bolt can be inside the bolted parts.</td>
</tr>
<tr>
<td><strong>Cut length</strong></td>
<td>Indicates which parts the bolt connects. The value defines the area Tekla Structures should search for parts that belong to the bolt group. Using cut length you can determine whether the bolt will go through one flange or two. Tekla Structures searches for parts using half the cut length value, in both directions from the bolt group plane. In the illustration below, A is the cut length and B is the bolt origin. Tekla Structures calculates the search area as A/2 in both directions from point B.</td>
</tr>
</tbody>
</table>

![Diagram](image_url)
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Tekla Structures warns you if the cut length is too small (i.e. the bolt group contains no parts) and makes the bolt length 100 mm.</td>
<td>If there are large gaps between the connected parts, the gap is added to the length of the bolt. Tekla Structures calculates bolt length using the total distance between the first and last surfaces. <strong>NOTE:</strong> If you want to force a bolt to be a certain length, enter a negative value for cut length (e.g. -150).</td>
</tr>
<tr>
<td><strong>Extra length</strong></td>
<td>Additional bolt length.</td>
</tr>
<tr>
<td></td>
<td>Increases the material thickness that Tekla Structures uses when calculating bolt length. For example, you might need extra bolt length to allow for painting. You can also build additional lengths into bolt assemblies.</td>
</tr>
<tr>
<td><strong>Shape</strong></td>
<td>Bolt group shape. You have the following options:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Array</strong> for rectangular</td>
</tr>
<tr>
<td></td>
<td>• <strong>Circle</strong> for circular</td>
</tr>
<tr>
<td></td>
<td>• <strong>xy list</strong> for any shape</td>
</tr>
<tr>
<td><strong>Bolt dist X</strong></td>
<td>See Bolt group shape (page 276).</td>
</tr>
<tr>
<td><strong>Bolt dist Y</strong></td>
<td>See Bolt group shape (page 276).</td>
</tr>
<tr>
<td><strong>Tolerance</strong></td>
<td>Tolerance = Hole diameter - Bolt diameter</td>
</tr>
<tr>
<td><strong>Hole type</strong></td>
<td>Oversized or slotted. This option becomes active when you select the <strong>Parts with slotted holes</strong> check boxes.</td>
</tr>
<tr>
<td><strong>Slotted hole X</strong></td>
<td>x allowance of a slotted hole. Zero for a round hole.</td>
</tr>
<tr>
<td><strong>Slotted hole Y</strong></td>
<td>y allowance of a slotted hole. Zero for a round hole.</td>
</tr>
<tr>
<td><strong>Rotate Slots</strong></td>
<td>If the bolt connects several parts, you may want to rotate alternate holes by 90 degrees. This allows the bolt to move in different directions.</td>
</tr>
<tr>
<td><strong>Show cut length as temporary lines</strong></td>
<td>This option is available in the <strong>Auto bolt</strong> component. Shows were the bolts should be placed even if they are not created.</td>
</tr>
<tr>
<td></td>
<td>• Select ✗ to not show the temporary lines.</td>
</tr>
<tr>
<td></td>
<td>• Select ✗ to show the temporary lines.</td>
</tr>
<tr>
<td><strong>On plane</strong></td>
<td>Moves the bolt group perpendicular to the bolt group x axis.</td>
</tr>
</tbody>
</table>

Modeling settings 275 Detail properties
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Rotation</strong></td>
<td>Defines how far the bolt group is rotated around the x axis, relative to the current work plane. For example, you can use this box to indicate on which side of the connected parts you want the bolt head to be.</td>
</tr>
<tr>
<td><strong>At depth</strong></td>
<td>Moves the bolt group perpendicular to the current work plane.</td>
</tr>
<tr>
<td><strong>Dx, Dy, Dz</strong></td>
<td>Offsets that move the bolt group by moving the bolt group x axis. Use to change the position of the bolt group. The start point values ( \text{Dx} ), ( \text{Dy} ) and ( \text{Dz} ) move the first end of the bolt group, relative to the bolt group x axis. The end point values move the second end of the bolt group.</td>
</tr>
<tr>
<td></td>
<td>• A positive ( \text{Dx} ) value moves the start point towards the end point.</td>
</tr>
<tr>
<td></td>
<td>• ( \text{Dy} ) moves the end point perpendicular to the bolt group x axis on the current work plane.</td>
</tr>
<tr>
<td></td>
<td>• ( \text{Dz} ) moves the end point perpendicular to the current work plane.</td>
</tr>
<tr>
<td></td>
<td>An example bolt group with the ( \text{Dx} ) start point set to 75:</td>
</tr>
</tbody>
</table>

**See also**
- Create bolts (page 75)
- User-defined attributes (page 264)
**Bolt group shape**

Tekla Structures uses the values of the **Bolt dist X** and **Bolt dist Y** boxes to determine how many bolts the bolt group contains, as shown in the table below:

<table>
<thead>
<tr>
<th>Shape</th>
<th>Bolt dist X</th>
<th>Bolt dist Y</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Array</strong></td>
<td>Spacing between bolts, in the x direction of the bolt group.</td>
<td>Spacing between bolts, in the y direction of the bolt group.</td>
</tr>
<tr>
<td><strong>Circle</strong></td>
<td>Number of bolts.</td>
<td>Diameter of the bolt group.</td>
</tr>
<tr>
<td><strong>xy list</strong></td>
<td>x coordinate of each bolt, from the bolt group point of origin.</td>
<td>y coordinate of each bolt, from the bolt group point of origin.</td>
</tr>
</tbody>
</table>

**Examples**

<table>
<thead>
<tr>
<th>Bolt group shape</th>
<th>Dimensions</th>
<th>Result</th>
</tr>
</thead>
</table>
| **Array**        | **Bolt dist X: 150**  
|                  | **Bolt dist Y: 100**  |
| **Circle**       | **Number of bolts: 6**  
|                  | **Diameter: 100**  |
| **xy list**      | **Bolt dist X: 75 175 250**  
|                  | **Bolt dist Y: 75 -50 0**  |
Weld properties

Use the **Weld Properties** dialog box to view or modify the properties of a weld. The units depend on the settings in **File menu --> Settings --> Options --> Units and decimals.**

**NOTE** Some of the properties are only displayed in reports, not in drawings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prefix</td>
<td>The weld size prefix. Shown in drawings, but only if the weld size is also defined. The standard ISO 2553 prefixes are:</td>
</tr>
<tr>
<td></td>
<td>• a - Design throat thickness</td>
</tr>
<tr>
<td></td>
<td>• s - Penetration throat thickness</td>
</tr>
<tr>
<td></td>
<td>• z - Leg length</td>
</tr>
<tr>
<td></td>
<td>Note that if the last character of the prefix is s, Tekla Structures creates the solid weld object according to the right-hand image so that a equals weld size.</td>
</tr>
<tr>
<td>Size</td>
<td>The size of the weld. If you enter a zero or negative weld size, Tekla Structures creates the weld, but does not display it in drawings.</td>
</tr>
<tr>
<td>Type</td>
<td>See <strong>List of weld types (page 282).</strong></td>
</tr>
<tr>
<td>Angle</td>
<td>The angle of weld preparation, bevels, or groove. Enter a positive value for bevel and groove welds. Tekla Structures displays the angle between the weld type symbol and the fill type contour symbol.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Contour</td>
<td>The fill type contour of a weld can be:</td>
</tr>
<tr>
<td></td>
<td>• None</td>
</tr>
<tr>
<td></td>
<td>• Flush</td>
</tr>
<tr>
<td></td>
<td>• Convex</td>
</tr>
<tr>
<td></td>
<td>• Concave</td>
</tr>
<tr>
<td></td>
<td>This setting does not affect solid weld objects.</td>
</tr>
<tr>
<td>Finish</td>
<td>Tekla Structures displays the finish symbol above the weld type symbol in drawings. The options are:</td>
</tr>
<tr>
<td></td>
<td>• G (Grind)</td>
</tr>
<tr>
<td></td>
<td>• M (Machine)</td>
</tr>
<tr>
<td></td>
<td>• C (Chip)</td>
</tr>
<tr>
<td></td>
<td>• ☐ (Flush finished weld)</td>
</tr>
<tr>
<td></td>
<td>• ⬤ (Smooth blended weld face)</td>
</tr>
<tr>
<td></td>
<td>This setting does not affect solid weld objects.</td>
</tr>
<tr>
<td>Root face</td>
<td>Root face thickness is the height of the narrowest part inside the root opening.</td>
</tr>
<tr>
<td></td>
<td>Root face values do not appear in drawings, but you can use the WELD_ROOT_FACE_THICKNESS template attribute in reports to show the root face dimension in the weld list.</td>
</tr>
<tr>
<td>Effective throat</td>
<td>The weld size used in weld strength calculation.</td>
</tr>
<tr>
<td>Root opening</td>
<td>The space between the welded parts.</td>
</tr>
<tr>
<td></td>
<td>Enter a positive value for square-groove welds.</td>
</tr>
<tr>
<td>Edge/Around</td>
<td>Indicates whether only one edge or the entire perimeter of a face should be welded.</td>
</tr>
<tr>
<td></td>
<td><strong>Edge:</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Around:</strong></td>
</tr>
<tr>
<td>Workshop/Site</td>
<td>Indicates where the weld should be made. This setting affects assemblies and drawings.</td>
</tr>
<tr>
<td></td>
<td><strong>Workshop:</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Site:</strong></td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Position</strong></td>
<td>Defines the position of a weld relative to the work plane. The type and position of the parts to be welded affect the position of the weld.</td>
</tr>
<tr>
<td></td>
<td>The options for weld position are:</td>
</tr>
<tr>
<td></td>
<td>- + x</td>
</tr>
<tr>
<td></td>
<td>- - x</td>
</tr>
<tr>
<td></td>
<td>- + y</td>
</tr>
<tr>
<td></td>
<td>- - y</td>
</tr>
<tr>
<td></td>
<td>- + z</td>
</tr>
<tr>
<td></td>
<td>- - z</td>
</tr>
<tr>
<td></td>
<td>In most cases, Tekla Structures creates the weld on the face or side of the part that faces in the selected direction (x, y, or z). Also the following factors may affect the position of the weld:</td>
</tr>
<tr>
<td></td>
<td>- perpendicularity of the part edge towards the selected direction (x, y or z)</td>
</tr>
<tr>
<td></td>
<td>- length of the part edge</td>
</tr>
<tr>
<td></td>
<td>- distance of the part edge in the selected direction (x, y or z)</td>
</tr>
<tr>
<td></td>
<td>The following image shows welds in different positions:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Connect part/assembly</th>
<th>See Use welds to create assemblies (page 117).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Placement</td>
<td>Defines how the weld is placed in relation to the assembly parts.</td>
</tr>
<tr>
<td></td>
<td>The options are:</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>• Auto</td>
<td>The weld placement adapts to the typical situation of the weld type. Square-, V-, and U-groove welds are located in the middle of the main and secondary parts. Single-bevel and J-groove welds are located on the secondary part side. This is the default option.</td>
</tr>
<tr>
<td>• Main part</td>
<td>The weld is located fully on the main part side. Does not affect V- or U-groove welds.</td>
</tr>
<tr>
<td>• Secondary part</td>
<td>The weld is located fully on the secondary part side. Does not affect V- or U-groove welds.</td>
</tr>
<tr>
<td>Preparation</td>
<td>Defines which assembly parts, if any, are automatically prepared for welding. The options are:</td>
</tr>
<tr>
<td>• None</td>
<td>Parts are not prepared for welding. This is the default option.</td>
</tr>
<tr>
<td>• Auto</td>
<td>Parts are prepared for welding according to the weld type.</td>
</tr>
<tr>
<td>• Main part</td>
<td>The main part is prepared for welding.</td>
</tr>
<tr>
<td>• Secondary part</td>
<td>The secondary part is prepared for welding.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes (page 264).</td>
</tr>
<tr>
<td>Shape</td>
<td>The shape of the weld can be:</td>
</tr>
<tr>
<td>• [Regular, continuous weld]</td>
<td></td>
</tr>
<tr>
<td>• [Intermittent weld]</td>
<td></td>
</tr>
<tr>
<td>• [Staggered, intermittent weld]</td>
<td></td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong># of incr.</strong></td>
<td>The amount of increments in an intermittent weld. Only use with the ISO standard.</td>
</tr>
<tr>
<td><strong>Length</strong></td>
<td>Defines the length value that is shown in the weld mark. For intermittent welds, defines the length of an increment. Does not affect continuous solid weld objects.</td>
</tr>
<tr>
<td><strong>Pitch</strong></td>
<td>If the advanced option XS_AISC_WELD_MARK is set to TRUE, the center-to-center spacing of weld increments in an intermittent weld. If the advanced option XS_AISC_WELD_MARK is set to FALSE, the space between the weld increments in an intermittent weld. Tekla Structures uses the – character by default to separate weld length and pitch, for example 50–100. To change the separator to @, for example, set the advanced option XS_WELD_LENGTH_CC_SEPARATOR_CHAR to @.</td>
</tr>
<tr>
<td><strong>NDT inspection level</strong></td>
<td>Defines the non-destructive testing and inspection level.</td>
</tr>
<tr>
<td><strong>Electrode classification</strong></td>
<td>Defines the weld electrode classification.</td>
</tr>
<tr>
<td><strong>Electrode strength</strong></td>
<td>Defines the electrode strength.</td>
</tr>
<tr>
<td><strong>Electrode coefficient</strong></td>
<td>Defines the electrode strength coefficient.</td>
</tr>
<tr>
<td><strong>Welding process type</strong></td>
<td>Defines the process type.</td>
</tr>
<tr>
<td><strong>Reference text</strong></td>
<td>Additional information to appear in the weld symbol. For example, information about the weld specification or process.</td>
</tr>
</tbody>
</table>

**See also**

Create welds (page 85)
**List of weld types**

Use the **Weld Properties** dialog box to define the weld type. Some weld types also automatically prepare the parts to be welded. The following table shows the available weld types:

<table>
<thead>
<tr>
<th>Number</th>
<th>Type</th>
<th>Name</th>
<th>Optional automatic weld preparation</th>
<th>Solid weld object</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>🆕</td>
<td>None</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>10</td>
<td>📚</td>
<td>Fillet weld</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>3</td>
<td>♂</td>
<td>Bevel-groove (single-V butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>4</td>
<td>♂</td>
<td>Bevel-groove (single-bevel butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>2</td>
<td>♂</td>
<td>Square-groove (square butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>5</td>
<td>♂</td>
<td>Single-V butt weld with broad root face</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>6</td>
<td>♂</td>
<td>Single-bevel butt weld with broad root face</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>7</td>
<td>♂</td>
<td>U-groove weld (single-U butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>8</td>
<td>♂</td>
<td>J-groove weld (single-J butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>16</td>
<td>♂</td>
<td>Flare V-groove weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>15</td>
<td>♂</td>
<td>Flare-bevel-groove weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>1</td>
<td>♂</td>
<td>Edge-flange weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>17</td>
<td>♂</td>
<td>Corner-flange weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>11</td>
<td>♂</td>
<td>Plug weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>9</td>
<td>♂</td>
<td>Bevel backing weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>12</td>
<td>♂</td>
<td>Spot weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>13</td>
<td>♂</td>
<td>Seam weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>14</td>
<td>♂</td>
<td>Slot weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>18</td>
<td>♂ + ♂</td>
<td>Partial penetration weld (single-bevel butt + fillet)</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>19</td>
<td>♂ + ♂</td>
<td>Partial penetration weld (square groove + fillet)</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>20</td>
<td>♂</td>
<td>Melt-through weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Number</td>
<td>Type</td>
<td>Name</td>
<td>Optional automatic weld preparation</td>
<td>Solid weld object</td>
</tr>
<tr>
<td>--------</td>
<td>------</td>
<td>-------------------------------------</td>
<td>-------------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>21</td>
<td>|</td>
<td>Steep-flanked single-V butt weld</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>22</td>
<td>|</td>
<td>Steep-flanked single-bevel butt weld</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>23</td>
<td>^</td>
<td>Edge weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24</td>
<td>~</td>
<td>Surfacing weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>25</td>
<td>@</td>
<td>Fold joint</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>26</td>
<td>/</td>
<td>Inclined joint</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

**Corner chamfer properties**

Use the Chamfer Properties dialog box to view and modify the properties of a corner chamfer. The units depend on the settings in File menu → Settings → Options → Units and decimals.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>The shape of the chamfer.</td>
</tr>
<tr>
<td>x</td>
<td>The dimensions of the chamfer. The dimension depends on the chamfer type.</td>
</tr>
<tr>
<td>y</td>
<td></td>
</tr>
<tr>
<td>dz1</td>
<td>Only used for contour plates and concrete slabs.</td>
</tr>
<tr>
<td>dz2</td>
<td>Moves the top or bottom surface of the part corner in the part’s local z direction.</td>
</tr>
<tr>
<td></td>
<td>Use these options, for example, to give plates varying thicknesses.</td>
</tr>
</tbody>
</table>

**See also**

Chamfer part corners (page 98)

**Corner chamfer types and dimensions**

The table below describes the available corner chamfer types and dimensions. The chamfer type numbers can be used in sketches and custom components.
Straight chamfers can have different dimensions in two directions. Curved chamfers only use one dimension.

<table>
<thead>
<tr>
<th>Number</th>
<th>Type</th>
<th>Symbol</th>
<th>Dimensions</th>
</tr>
</thead>
</table>
| 0      | None          |        | x: not used
          |               |        | y: not used                                                                |
| 1      | Line          |        | x: the distance in the x coordinate direction from the corner
          |               |        | y: the distance in the y coordinate direction from the corner               |
| 2      | Rounding      |        | x: the radius                                                               |
          |               |        | y: not used                                                                 |
| 3      | Arc           |        | x: the radius                                                               |
          |               |        | y: not used                                                                 |
| 4      | Arc point     |        | x: not used                                                                 |
          |               |        | y: not used                                                                 |
| 5      | Square        |        | The chamfer is perpendicular to the edges.
          |               |        | x: the distance in the x coordinate direction from the corner
          |               |        | y: the distance in the y coordinate direction from the corner               |
| 6      | Square parallel|       | The chamfer is parallel to the opposite edge.
          |               |        | x: the distance in the x coordinate direction from the corner
          |               |        | y: the distance in the y coordinate direction from the corner               |
| 7      | Line and arc  |        | x (if smaller than y): the arc radius
          |               |        | x (if bigger than y): the distance in the x coordinate direction from the corner
          |               |        | y (if smaller than x): the arc radius
          |               |        | y (if bigger than x): the distance in the y coordinate direction from the corner |

See also

Chamfer part corners (page 98)
**Edge chamfer properties**

Use the **Edge Chamfer Properties** dialog box to view and modify the properties of an edge chamfer. The units depend on the settings in **File menu --> Settings --> Options --> Units and decimals**.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>More information</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>The shape of the chamfer.</td>
<td></td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>The name of the chamfer.</td>
<td></td>
</tr>
<tr>
<td><strong>Cutting distance in X direction</strong></td>
<td>Defines how far away from the chamfered edge the chamfer will end in the x direction.</td>
<td></td>
</tr>
<tr>
<td><strong>Cutting distance in Y direction</strong></td>
<td>Defines how far away from the chamfered edge the chamfer will end in the y direction.</td>
<td></td>
</tr>
<tr>
<td><strong>First end type</strong></td>
<td>The shape and position of the first end point.</td>
<td>The options are:</td>
</tr>
<tr>
<td><strong>Second end type</strong></td>
<td>The shape and position of the second end point.</td>
<td>• <strong>Full</strong>: The end point is positioned at the end of the part (moving along the nearest edge), and the shape is straight.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Straight</strong>: The end point is positioned at the point you pick, and the shape is straight.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Bevelled</strong>: The end point is positioned at the point you pick, and the shape is angled.</td>
</tr>
<tr>
<td><strong>Dimension</strong></td>
<td>The distance between the (picked) end point and the bevelled points.</td>
<td></td>
</tr>
</tbody>
</table>

**See also**

Chamfer part edges (page 100)

---

**14.6 Numbering settings**

This section provides more information about specific numbering settings.
Click the links below to find out more:

- **General numbering settings (page 287)**
- **Weld numbering settings (page 288)**
- **Control number settings (page 289)**

**General numbering settings**
Use the **Numbering Setup** dialog box to view and modify some general numbering settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Renumber all</td>
<td>All parts get a new number. All information on previous numbers is lost.</td>
</tr>
<tr>
<td>Re-use old numbers</td>
<td>Tekla Structures reuses the numbers of parts that have been deleted. These numbers may be used to number new or modified parts.</td>
</tr>
<tr>
<td>Check for standard parts</td>
<td>If a separate standard-part model has been set up, Tekla Structures compares the parts in the current model to those in the standard-part model. If the part to be numbered is identical to a part in the standard-part model, Tekla Structures uses the same part number as in the standard-part model.</td>
</tr>
<tr>
<td>Compare to old</td>
<td>The part gets the same number as a previously numbered similar part.</td>
</tr>
<tr>
<td>Take new number</td>
<td>The part gets a new number even if a similar numbered part already exists.</td>
</tr>
<tr>
<td>Keep number if possible</td>
<td>Modified parts maintain their previous numbers if possible. Even if a part or assembly becomes identical with another part or assembly, the original position number is maintained. For example, you might have two different assemblies, B/1 and B/2, in the model. Later on you modify B/2 so that it becomes identical with B/1. If the <strong>Keep number if possible</strong> option is used, B/2 will maintain its original position number when you renumber the model.</td>
</tr>
<tr>
<td>Synchronize with master model</td>
<td>Use this setting when working in multi-user mode. Tekla Structures locks the master model and performs a save, numbering, and save sequence, so that all other users can continue working during the operation.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Automatic cloning</td>
<td>If the main part of a drawing is modified and therefore gets a new assembly position, the existing drawing is automatically assigned to another part of the position. If the modified part moves to an assembly position that does not have a drawing, the original drawing is automatically cloned to reflect the changes in the modified part.</td>
</tr>
<tr>
<td>Holes</td>
<td>The location, size, and number of holes affects numbering.</td>
</tr>
<tr>
<td>Part name</td>
<td>The part name affects numbering.</td>
</tr>
<tr>
<td>Beam orientation</td>
<td>The orientation of beams affects numbering of assemblies.</td>
</tr>
<tr>
<td>Column orientation</td>
<td>The orientation of columns affects numbering of assemblies.</td>
</tr>
<tr>
<td>Reinforcing bars</td>
<td>Reinforcing bars affect numbering.</td>
</tr>
<tr>
<td>Embedded objects</td>
<td>Sub-assemblies affect the numbering of cast units.</td>
</tr>
<tr>
<td>Surface treatment</td>
<td>Surface treatments affect the numbering of assemblies.</td>
</tr>
<tr>
<td>Welds</td>
<td>Welds affect the numbering of assemblies.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>Parts get the same number if their dimensions differ less than the value entered in this box.</td>
</tr>
<tr>
<td>Assembly position sort order</td>
<td>See Number assemblies and cast units (page 218).</td>
</tr>
</tbody>
</table>

See also
- Adjust the numbering settings (page 216)
- Create a standard-part model (page 305)
- Numbering examples (page 235)

**Weld numbering settings**

Use the **Weld Numbering** dialog box to view and modify the weld numbering settings. The weld number is displayed in drawings and weld reports.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start number</td>
<td>The number from which the numbering starts. Tekla Structures automatically suggests the following free number as the start number.</td>
</tr>
</tbody>
</table>
### Option Description

**Apply for**

Defines which objects are affected by the change.

- **All welds** changes the number of all welds in the model.
- **Selected welds** changes the number of the selected welds without affecting others.

**Renumber also welds that have a number**

Tekla Structures replaces existing weld numbers.

**Re-use numbers of deleted welds**

If some welds have been removed, Tekla Structures uses their numbers when numbering other welds.

**See also**  
Number welds (page 219)

### Control number settings

Use the **Create control numbers (S9)** dialog box to view and modify the control number settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Numbering</strong></td>
<td>Defines which parts get control numbers.</td>
</tr>
<tr>
<td></td>
<td><strong>All</strong> creates consecutive numbers for all parts.</td>
</tr>
<tr>
<td></td>
<td><strong>By numbering series</strong> creates control numbers for parts in a specific</td>
</tr>
<tr>
<td></td>
<td>numbering series.</td>
</tr>
<tr>
<td><strong>Assembly/Cast unit numbering series</strong></td>
<td>Defines the prefix and start number of the numbering series for which to</td>
</tr>
<tr>
<td></td>
<td>create control numbers.</td>
</tr>
<tr>
<td></td>
<td>Needed only with the <strong>By numbering series</strong> option.</td>
</tr>
<tr>
<td><strong>Start number of control numbers</strong></td>
<td>The number from which the numbering starts.</td>
</tr>
<tr>
<td><strong>Step value</strong></td>
<td>Defines the interval between two control numbers.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Renumber</strong></td>
<td>Defines how to treat parts that already have control numbers.</td>
</tr>
<tr>
<td><strong>Yes</strong></td>
<td>Replaces the existing control numbers.</td>
</tr>
<tr>
<td><strong>No</strong></td>
<td>Keeps the existing control numbers.</td>
</tr>
<tr>
<td><strong>First direction</strong></td>
<td>Defines in what order to assign control numbers.</td>
</tr>
<tr>
<td><strong>Second direction</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Third direction</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Write UDA to</strong></td>
<td>Defines where to save the control numbers.</td>
</tr>
<tr>
<td><strong>Assembly</strong></td>
<td>Saves the control numbers to the user-defined attributes of assemblies or cast units.</td>
</tr>
<tr>
<td><strong>Main part</strong></td>
<td>Saves the control numbers to the user-defined attributes of assembly or cast unit main parts.</td>
</tr>
<tr>
<td></td>
<td>The control number appears on the <strong>Parameters</strong> tab.</td>
</tr>
</tbody>
</table>

**See also**

Control numbers (page 226)
Modeling tips

This section provides useful hints and tips that help you to model structures more quickly and accurately, and avoid potential problems with templates and drawings.

Click the links below to find out more:

- General modeling tips (page 291)
- Tips for creating and positioning parts (page 297)
- Tips for numbering (page 304)
- Tips for large models (page 307)

15.1 General modeling tips

These tips will help you to use some basic modeling functionalities more efficiently.

Click the links below to find out more:

- Create a radial grid (page 291)
- If you cannot see all objects (page 293)
- Should I model in a 3D or plane view? (page 294)
- Hide cut lines in a model view (page 294)
- Show part reference lines in a model view (page 294)
- How to cut efficiently (page 295)
- Right-hand rule (page 296)
- Find RGB values for colors (page 296)
- When to use an autosaved model (page 297)
Create a radial grid
You can create a radial grid using a component called Radial Grid. You can preview the grid before creating it.

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. Start typing radial grid in the search box.
3. Double-click Radial Grid to open the properties dialog box.
4. Modify the grid properties.

**TIP** In the coordinate properties
- **X** defines the location of the arched grid lines and the distance between the grid lines.
  The first value is the radius of the innermost arc.
- **Y (degrees)** defines the location of the straight grid lines and the distance between the grid lines in degrees.
  The first value defines how the grid is rotated. The grid is rotated counter-clockwise from the x axis in the current work plane.

5. Click **OK**.
6. Pick a point to indicate the origin of the grid.
The grid is created automatically.

Limitations
You cannot modify the radial grid using the general grid properties dialog box.

See also
Grid properties (page 242)

If you cannot see all objects
The visibility of objects in a view depends on a number of different settings. If you cannot see all the desired objects in a model view, check the following settings:
- work area
- view depth
- view filter
- view and representation settings
• color and transparency settings

Note that work area and view depth are like two virtual boxes. Objects that have their handles partially or totally inside both boxes are visible. Newly created objects are also visible outside the view depth but never outside the work area. When you redraw a view, only the objects inside the view depth are displayed.

See also
Show and hide model objects (page 161)
View properties (page 246)

Should I model in a 3D or plane view?
3D, plane, and elevation views provide different types of information, which is useful for different tasks.

One common technique is to open several views:
• A 3D view to see a real-life version of the model
• A plane view, where you can add and connect parts
• An elevation view to check the level

If you are working with two screens, maximize your work area by putting the elevation and 3D views on one screen and the plane view on the other.

Hide cut lines in a model view
1. Double-click the view to open the View Properties dialog box.
2. Click Display to open the Display dialog box.
3. Clear the Cuts and added material check box.
4. Click Modify.

See also
Create cuts (page 94)

Show part reference lines in a model view
The part reference line is formed between the part handles. By default, the part reference line is invisible in the model. It may be useful to display it when snapping to the middle points of parts, for example.

1. Double-click the view to open the View Properties dialog box.
2. Click **Display** to open the **Display** dialog box.
3. On the **Advanced** tab, select the **Part reference line** check box.
4. Click **Modify**.
   The part reference lines are displayed.

![Part Reference Lines](image)

**See also**
*Part handles (page 29)*

**How to cut efficiently**
Follow these guidelines when cutting objects in the model:

- **Avoid part faces**
  Avoid creating cuts that are exactly on the part planes or go through vertices. Try to position the cut at least 0.3 mm outside of the part planes.

- **Use polygon cuts**
  Whenever possible, use polygon cuts. The **Polygon cut** command automatically extends the cut slightly outside of the part face. Note that after creating the polygon, you may have to adjust the position of the handles manually.

- **Use edge chamfers**
  Whenever possible, use edge chamfers instead of small cuts, especially in components.

- **Tips for flange cuts**
  When cutting a flange, if the cutting part cuts very slightly the web as well (at least 0.3 mm), the cut is more likely to succeed. For example, if you are cutting a beam that has roundings, it may be useful to cut even further onto the web than just the flange thickness.
• **Tips for round tube cuts**

  Use the **Round tube (23)** component for round tube cuts. The component automatically rotates the cutting part until a successful cut position is found. If the component fails, rotate the cutting part slightly until you find a successful cut position.

  **NOTE** If a cut fails, Tekla Structures displays the cutting part using dash-and-dot lines. An error notification is printed in the session history log stating which part and which cut caused the failure.

  To locate the failure in the model, click a row that contains an ID number in the session history log. Tekla Structures selects the corresponding part and cut in the model.

**See also**

*Create cuts (page 94)*

**Right-hand rule**

Right-hand rule indicates the direction of the coordinate axes. When you hold the thumb, index finger, and middle finger of your right hand so that they form three right angles, then the thumb symbolizes the x axis, the index finger the y axis, and the middle finger the z axis.

![Right-hand rule diagram]

**Find RGB values for colors**

Use the **Tekla Structures Background Color Selector** tool to find a suitable background color for your model.

1. Go to *Selecting background color for model editor*.
2. Download and install the application.

**TIP** Alternatively, you can use the **Color picker** tool available at *Color picker for Tekla Structures*. 
When to use an autosaved model

You can select to use an autosaved model if there are errors when trying to open a model.

When you open a model, Tekla Structures automatically checks if the previous session ended normally. If it did not, Tekla Structures asks whether you want to continue by using the autosaved model or the original model.

If Tekla Structures displays the warning **Fatal: Model memory corrupted by read**, it means that hardware problems have damaged the model database. Your hard disk may be damaged. Use autosave or system backup files to restore the model.

15.2 Tips for creating and positioning parts

These tips will help you to efficiently create and position parts in a model view. Click the links below to find out more:

- Define default part properties (page 297)
- Create curved parts (page 298)
- Create horizontal parts (page 299)
- Create beams close to each other (page 300)
- Alternative way of creating a round plate or slab (page 301)
- Position columns, pad footings, and orthogonal beams (page 302)
- Position objects in a radial or circular pattern (page 303)
- Optional ways of placing objects in a model (page 303)
- How to model identical areas (page 303)
- Create bolts by modifying an existing bolt group (page 304)
Define default part properties
Save time by saving a default set of properties for each part you plan to create before you start modeling.

To define default sets of part properties for a project:
1. Double-click a part to open the part properties dialog box.
2. Enter the part properties you want to use as defaults.
3. In the box next to the Save as button, enter a name for the set of properties. For example, enter BEAM.
4. Click Save as to save the set of properties.
5. Click OK to close the part properties dialog box.
6. Continue to save sets of properties for each type of part you intend to create.
7. To make the sets of part properties you have defined the default sets for this project, go to Quick Launch, start typing save defaults, and select the Save Defaults command from the list that appears.

TIP To use a default set of part properties, open the part properties dialog box and select an option from the list next to the Load button. Click Load to load the properties.

Create curved parts
You can create curved parts by defining a radius and the number of segments for a part. The number of segments determines how realistic the curved part looks: the more segments, the less angular the part appears.

1. Create a part that can be bent: a beam, panel, or strip footing.
2. Double-click the part to open the part properties dialog box.
3. Go to the Curved beam settings area.
   These settings can be found either on the Position tab or on the Bending tab, depending on the part type.
4. In the Radius box, enter the radius.
5. In the Number of segments box, enter the number of segments you want to use.
6. If needed, define the plane of curvature, which is relative to the current work plane.
7. Click Modify to bend the part.
Examples

<table>
<thead>
<tr>
<th>Number of segments: 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="number_of_segments_2.png" alt="Image" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Number of segments: 5</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="number_of_segments_5.png" alt="Image" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Number of segments: 15</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="number_of_segments_15.png" alt="Image" /></td>
</tr>
</tbody>
</table>

See also

Modify the position of a part (page 61)

Create horizontal parts

When creating horizontal parts, such as beams, always pick points in the same direction. For example, pick positions from left to right, and from bottom to top (in positive x, y directions). This ensures that Tekla Structures places and dimensions the parts in the same way in drawings, and that part marks automatically appear at the same part end.

To ensure that beam rotation is correct in drawings, set part Rotation to Top in the part properties dialog box.
Create beams close to each other

When you create beams so that they are located very close to each other, Tekla Structures may consider them as a twin profile. To prevent this from happening, use the user attribute MAX_TWIN_SEARCH_DIST in the profile catalog.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
2. Select the desired profile in the profile tree.
3. Go to the User attributes tab and set the property Twin profile detection distance to a larger value than 0, for example to 0.1.
4. Click OK.
5. Create the beams using the profile.

See also

Create a steel beam (page 35)
Create a twin profile (page 50)

Create closed polybeams

If you want to create a closed polybeam, concrete panel, or strip footing, start modeling from an intermediate point somewhere along a polybeam segment, not from a corner point. This way, the end faces will be created against and parallel to each other, and the polybeam closes properly.

In case you started modeling from a corner point, a portion would be missing from the polybeam corner, and another portion would overlap. If you did this, Tekla Structures could not create a solid object of the polybeam.
Also if you model so that a polybeam end face is against a side of the same polybeam, Tekla Structures does not create a continuous structure, but displays an edge in the model and in drawings.

See also
Create a steel polybeam (page 36)
Create a concrete polybeam (page 55)
Create a concrete panel or wall (page 57)
Create a strip footing (page 52)

Alternative way of creating a round plate or slab
This example shows an alternative method for creating round plates and slabs.

To create a round plate or slab:
1. Create a diamond-shaped plate or slab with four equal sides.
2. To round the corners, use the arc point chamfer type 🔄.
See also
Create a round contour plate (page 38)
Create a round slab (page 57)

Position columns, pad footings, and orthogonal beams
For parts that you create by picking only one point (such as columns), you can define the top and bottom level of the part in the global z direction. The part is created at the defined level, not at the level you picked in the model. This can be useful when creating multi-story structures, as you can define exact levels for each part you create.

To define the top and bottom levels of a part:
1. Create a part that requires you to pick only one point.
   For example, a column.
2. Double-click the part to open the part properties dialog box.
3. Go to the Position tab.
4. Modify the top and bottom levels of the part.
   • Top: Use to define the top level of the part.
   • Bottom: Use to define the bottom level of the part.
5. Click Modify.

Example
In this example, the concrete columns form a two-story structure. To position the upper columns correctly, you must modify their bottom level position.
Top level = 1000, Bottom level = 0
Top level = 1700, Bottom level = 1200
Slab thickness = 200

See also
Modify the position of a part (page 61)

Position objects in a radial or circular pattern

To position objects in a radial or circular pattern, do one of the following:
• Create a grid line and use the **Copy Special --> Rotate** command to copy it.
• Use construction lines and circles to position the objects.

See also
Create construction objects (page 23)

Optional ways of placing objects in a model

When you want to place an object to a position where no lines or objects intersect, you have the following options:
• Use the snapping commands.
• Use construction planes, lines and circles (page 23).
• Create points (page 11).
How to model identical areas

Most structures contain identical areas, from simple frames to entire floors. Save time by modeling these areas once, then copying them throughout the model. For example, create a column with a base plate and cap plate, then copy the column to all the locations where it occurs in the model.

You can use this technique to create and reproduce any identical area. Depending on the project, you may even be able to add connections before copying the area of the building.

**TIP** For a project that has several identical floors, try modeling an entire floor, then copying it to several levels.

Create bolts by modifying an existing bolt group

An alternative way to create bolts is to apply a component that includes bolt groups.

1. Apply a component that includes bolt groups.
   
   For example, connect two beams, or a beam to a column, using a bolted end plate. For more information, see Steel component example: Add an end plate using the End plate (144) connection.

2. Explode the component.
   
   a. Go to Quick Launch, start typing `explode component`, and select the **Explode component** command from the list that appears.
   
   b. Select the component to explode.
      
      Tekla Structures separates the objects in the component.

3. Modify the bolt group.
   
   a. Select the bolt group and double-click it to open the properties dialog box.
   
   b. Modify the properties.
   
   c. Click **Modify**.

**See also**

Create a bolt group (page 76)
15.3 Tips for numbering

- It is a good idea to have some kind of a routine in numbering. For example, number the model when you start your working day or when you finish for the day.

- To save time, include the numbering series in the default part properties for each type of part before you start modeling.

- Numbering is not just another way of classifying parts. To classify, use Organizer, user-defined attributes, or colors.

- If you have overlapping position numbers, Tekla Structures will warn you about it.

  You can have a closer look at the overlapping position numbers in the numbering history log. To display the log, click File menu --> Logs --> Numbering history log.

See also

Numbering settings during a project (page 305)
Numbering examples (page 235)
Create a standard-part model (page 305)

Numbering settings during a project
You can use different numbering settings at different times in a project.
For example:

- Before releasing a phase of the project for fabrication, you might use the Re-use old numbers option for numbering the entire model.

- If a phase has already been released for fabrication in a project, you might use the Take new number option for new and modified parts.

- If you are numbering other phases of the project at earlier stages of detailing, you might use the Compare to old option and try to combine as many position numbers as possible.

See also

Example: Number parts in selected phases (page 239)
General numbering settings (page 287)

Create a standard-part model
A standard-part model contains only standard parts with specific part prefixes. You can use these prefixes when numbering parts in another model. The
prefixes that you define will be used as actual part position numbers in the other model.

The standard-part model is only used for comparing parts when you number parts in a project model. It cannot be used for creating parts in the project model.

**NOTE** This functionality only applies to steel parts. Assemblies are not affected.

1. Create a new model and give it a descriptive name.
   For example, **StandardParts**.
2. Create the objects you want to use as standard parts.
3. Explode all components.
   You can explode the components if you plan to delete the unnecessary parts such as duplicate angles and main parts.
4. Delete all unnecessary items.
5. Give the objects part prefixes that are not used elsewhere (for example, STD1, STD2, and so on).
   Ensure that the standard-part model does not contain duplicate part prefixes. You do not need to define the assembly prefix and the start numbers.
6. Save the standard-part model.
7. Open a project model that you wish to number.
8. On the **File** menu, click **Settings --&gt; Advanced options --&gt; Numbering**.
9. Check that the advanced option XS_STD_PART_MODEL points to the correct standard-part model.
   For example:
   ```
   XS_STD_PART_MODEL=C:\TeklaStructuresModels\StandardParts\ 
   ```
10. On the **Drawings & reports** tab, click **Numbering settings --&gt; Numbering settings** to display the **Numbering Setup** dialog box.
11. If you have selected the **Part name** check box, ensure that the project model has the same part names as the standard-part model.
12. Select the **Check for standard parts** check box.
13. Click **Apply** to save the changes.
14. On the **Drawings & reports** tab, click **Perform numbering --&gt; Number modified objects** to number the project model.
   As the parts are being numbered, Tekla Structures compares all parts in the project model to the standard-part model. Any part position numbers
found in the standard-part model are applied to all identical parts found in the project model.

See also
Number parts (page 217)

15.4 Tips for large models
Consider the following modeling tips when you handle large models:

<table>
<thead>
<tr>
<th>Modeling item</th>
<th>Tips</th>
</tr>
</thead>
</table>
| Coordinate system           | • Do not place the model far away from the origin. The further away from the origin you model, the less precise all the computations become.  
                            | • Mark global coordinates as labels instead of actually using them during modeling.  
                            | • If you need to use building site coordinates, drop the first digits if they are always the same. For example, instead of coordinate 758 375 6800, use 375 6800. |
| Work area and visibility    | • Keep the work area as small as possible.  
                            | • Show only the required parts in views.  
                            | • Use view filters to control the visibility of parts. |
| Views                       | • Close unnecessary views.  
<pre><code>                        | • Close all views when you save large models. |
</code></pre>
<p>| Selection switches          | • Switch on the Select reference models selection switch only when necessary. The speed of zooming and rotating may be affected by this switch especially in large and complicated models that contain reference models. |</p>
<table>
<thead>
<tr>
<th>Modeling item</th>
<th>Tips</th>
</tr>
</thead>
</table>
| Round objects                 | • Create holes with the **Create bolts** command instead of using part cuts with round beams.  
                                | • Use studs to model small straight round objects instead of small round beams.  
                                | • Model lifting hooks and other embeds with reinforcement bars instead of round polybeams. |
| Hollow core profiles          | • Use simple fixed (non-parametric) profiles.                        |
|                               | • Use chamfers for curved corners.                                  |
| Custom components             | • Do not create overly complex custom components. When used in great numbers they consume a lot of memory. |
| Numbering (page 207)          | • Do not number the whole model in one go. Numbering all objects in large models may take a considerable amount of time. |
| Model database                | • If your model file is getting large, repairing the model database can help to reduce the file size considerably and therefore help with memory problems. |
| Firm and Project folders      | • Save **Firm and Project folders** locally on the hard drive of your computer instead of a network drive. This saves time if network speed is slow.  
                                | When working in the multi-user mode, ensure that the folders are synchronized on all users' hard drives so that important data is not lost or changed. |
Disclaimer

© 2017 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced Software. Use of the Software, and use of this Software Manual are governed by a License Agreement. Among other provisions, the License Agreement sets certain warranties for the Software and this Manual, disclaims other warranties, limits recoverable damages, defines permitted uses of the Software, and determines whether you are an authorized user of the Software. All information set forth in this manual is provided with the warranty set forth in the License Agreement. Please refer to the License Agreement for important obligations and applicable limitations and restrictions on your rights. Trimble does not guarantee that the text is free of technical inaccuracies or typographical errors. Trimble reserves the right to make changes and additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by international treaties. Unauthorized reproduction, display, modification, or distribution of this Manual, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve, Fastrak and Orion are either registered trademarks or trademarks of Trimble Solutions Corporation in the European Union, the United States, and/or other countries. More about Trimble Solutions trademarks: http://www.tekla.com/tekla-trademarks. Trimble is a registered trademark or trademark of Trimble Inc. in the European Union, in the United States and/or other countries. More about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product and company names mentioned in this Manual are or may be trademarks of their respective owners. By referring to a third-party product or brand, Trimble does not intend to suggest an affiliation with or endorsement by such third party and disclaims any such affiliation or endorsement, except where otherwise expressly stated.

Portions of this software:

D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved.
This product contains proprietary and confidential technology, information and creative works owned by Flexera Software LLC and its licensors, if any. Any use, copying, publication, distribution, display, modification, or transmission of such technology in whole or in part in any form or by any means without the prior express written permission of Flexera Software LLC is strictly prohibited. Except where expressly provided by Flexera Software LLC in writing, possession of this technology shall not be construed to confer any license or rights under any Flexera Software LLC intellectual property rights, whether by estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures, click File menu --> Help --> About Tekla Structures and then click the 3rd party licenses option.

The elements of the software described in this Manual are protected by several patents and possibly pending patent applications in the United States and/or other countries. For more information go to page http://www.tekla.com/tekla-patents.
Index

A
accuracy, see high accuracy.........................162
accuracy
in modeling..............................................162
of parts.................................................162
adaptivity...................................................66
default settings.........................................66
of individual model objects....................66
angles.........................................................186
arcs
measuring...............................................186
assemblies.................................................115
adding objects.........................................118,120
changing the main assembly..................122
changing the main part..........................121
comparing..................................................188
creating.....................................................115
examples....................................................123
exploding......................................................123
highlighting.................................................122
joining.........................................................121
nested assemblies..............................119,121
numbering..................................................210,218
removing objects......................................122
showing invisible objects.......................167
sub-assemblies..........................................116
using bolts to create assemblies..........116
using welds to create assemblies...........117
attaching parts..........................................68,69
auto bolt
creating bolts..........................................77
autosave
error.....................................................297
opening model.........................................297

B
beams
cambering..................................................73
closed polybeams......................................300
cement beams............................................54,260
cement polybeams........................................55
curved beams.............................................37
orthogonal beams......................................49
steel beams...............................................35,252
steel polybeams..........................................36
warping.......................................................71
bending......................................................298
bent plates...............................................39
bolt points...................................................18
bolted parts.................................................81
bolts.........................................................75,116,274
bolt group shape......................................276
bolt spacing..............................................187
bolting sub-assemblies..........................117
clash checking..........................................203
creating......................................................76,77,304
modifying.....................................................81

C
cambering parts.........................................73
cast units...................................................126
adding objects..........................................127
cast unit type..............................................126
casting direction............................129,131,137
changing the main part........................128
creating......................................................127
exploding.....................................................129
highlighting...............................................128
numbering..................................................218
removing objects.......................................128
top-in-form face.......................................131
cast-in-place.................................................126
continuous concrete structures............135
pour breaks............................................146,148,149,151,152,153
pour objects...............................................137
pours.........................................................133,134,137,139,140,155
chamfering...............................................97
corner chamfer dimensions..................284
corner chamfer types.............................284
nested assemblies............................119,121
no paint area...............................................111
numbering............................................207,217
about numbering..................................207
assemblies.............................................218
cast units................................................218
checking and repairing.........................225
clearing...................................................221
control numbers.....226,227,229,230,231
examples................................................235,236,238,239
family numbers........214,215,216,236
history.....................................................224
identical parts........................................211
manually.................................................220
modifying...............................................220
numbering series..................................210
parts................................................217,225
preliminary numbers.........................220
reinforcement........................................212,219
renumbering..........................................225
series................................................208,209,211
settings................................................216,287,288,289,305
standard-part model............................305
user-defined attributes........................214
welds.......................................................
what affects...........................................213
numbering
design group numbering.....................233
numbering settings............................286

measuring.............................................184
numbering............................................217
placing objects in model......................303
positioning............................................303
showing and hiding................................293
offsets.................................................272
opening a model
avtosave.................................................297
error.............................................297
orthogonal beams...............................254
positioning............................................302
overlapping
numbering series..................................211
oversized holes.......................................84

pad footings........................................52,257
positioning............................................302
page margins.........................................201
page orientation.....................................201
panels.................................................57
paper size.............................................201
part add, see attaching parts..................69
part labels
showing and hiding...............................31
part properties.......................................251
part reference lines...............................294
parts
adding to assembly...............................120
assemblies............................................115
attaching..............................................68
bending.................................................298
cambering.............................................73
changing the color................................173
changing the material............................65
changing the profile..............................63
combining.............................................67
comparing.............................................188
concrete parts.......................................51
curved parts.........................................298
cutting with another part......................96
default properties..................................297
handles....................................................29
hiding....................................................165
horizontal parts..................................299
identical parts.......................................211
items.....................................................33
<table>
<thead>
<tr>
<th>standardized values</th>
<th>64</th>
</tr>
</thead>
<tbody>
<tr>
<td>twin profiles</td>
<td>50</td>
</tr>
<tr>
<td>properties</td>
<td></td>
</tr>
<tr>
<td>default</td>
<td>297</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>R</td>
<td></td>
</tr>
<tr>
<td>Radial Grid</td>
<td>291</td>
</tr>
<tr>
<td>radius</td>
<td>298</td>
</tr>
<tr>
<td>reference lines</td>
<td>294</td>
</tr>
<tr>
<td>reference models</td>
<td></td>
</tr>
<tr>
<td>clash checking</td>
<td>190</td>
</tr>
<tr>
<td>reinforcement</td>
<td></td>
</tr>
<tr>
<td>identical</td>
<td>212</td>
</tr>
<tr>
<td>numbering</td>
<td>212,219</td>
</tr>
<tr>
<td>removing</td>
<td></td>
</tr>
<tr>
<td>pour breaks</td>
<td>153</td>
</tr>
<tr>
<td>weld cross sections</td>
<td>93</td>
</tr>
<tr>
<td>rendering</td>
<td></td>
</tr>
<tr>
<td>of parts and components</td>
<td>163</td>
</tr>
<tr>
<td>renumbering</td>
<td>225</td>
</tr>
<tr>
<td>repairing model</td>
<td>203</td>
</tr>
<tr>
<td>repairing</td>
<td></td>
</tr>
<tr>
<td>numbering errors</td>
<td>225</td>
</tr>
<tr>
<td>report templates</td>
<td></td>
</tr>
<tr>
<td>for inquiring object properties</td>
<td>181</td>
</tr>
<tr>
<td>representation</td>
<td></td>
</tr>
<tr>
<td>of parts and components</td>
<td>163</td>
</tr>
<tr>
<td>RGB values</td>
<td>296</td>
</tr>
<tr>
<td>right-hand rule</td>
<td>296</td>
</tr>
<tr>
<td>rotating</td>
<td></td>
</tr>
<tr>
<td>parts</td>
<td>266</td>
</tr>
<tr>
<td>rotation settings</td>
<td>244</td>
</tr>
<tr>
<td>rotation angle knob</td>
<td>61</td>
</tr>
<tr>
<td>round</td>
<td></td>
</tr>
<tr>
<td>holes</td>
<td>83</td>
</tr>
<tr>
<td>plates</td>
<td>38,301</td>
</tr>
<tr>
<td>slabs</td>
<td>57,301</td>
</tr>
<tr>
<td>S</td>
<td></td>
</tr>
<tr>
<td>saving</td>
<td></td>
</tr>
<tr>
<td>clashes</td>
<td>202</td>
</tr>
<tr>
<td>screenshots</td>
<td>245</td>
</tr>
<tr>
<td>searching</td>
<td></td>
</tr>
<tr>
<td>clashes</td>
<td>196</td>
</tr>
<tr>
<td>selecting</td>
<td></td>
</tr>
<tr>
<td>pour breaks</td>
<td>151</td>
</tr>
<tr>
<td>selection dial</td>
<td>61</td>
</tr>
<tr>
<td>settings</td>
<td></td>
</tr>
<tr>
<td>adaptivity</td>
<td>66</td>
</tr>
<tr>
<td>bolt properties</td>
<td>274</td>
</tr>
<tr>
<td>color settings</td>
<td>176,177,250</td>
</tr>
<tr>
<td>concrete beam properties</td>
<td>260</td>
</tr>
<tr>
<td>concrete column properties</td>
<td>259</td>
</tr>
<tr>
<td>concrete item properties</td>
<td>263</td>
</tr>
<tr>
<td>concrete panel properties</td>
<td>262</td>
</tr>
<tr>
<td>concrete slab properties</td>
<td>261</td>
</tr>
<tr>
<td>contour plate properties</td>
<td>253</td>
</tr>
<tr>
<td>corner chamfer properties</td>
<td>284</td>
</tr>
<tr>
<td>detail properties</td>
<td>273</td>
</tr>
<tr>
<td>display settings</td>
<td>248</td>
</tr>
<tr>
<td>edge chamfer properties</td>
<td>286</td>
</tr>
<tr>
<td>general modeling settings</td>
<td>242</td>
</tr>
<tr>
<td>grid line properties</td>
<td>243</td>
</tr>
<tr>
<td>grid properties</td>
<td>242</td>
</tr>
<tr>
<td>grid view properties</td>
<td>247</td>
</tr>
<tr>
<td>numbering</td>
<td>305</td>
</tr>
<tr>
<td>numbering settings</td>
<td>216,286,287,288,289</td>
</tr>
<tr>
<td>orthogonal beam properties</td>
<td>254</td>
</tr>
<tr>
<td>pad footing properties</td>
<td>257</td>
</tr>
<tr>
<td>part position settings</td>
<td>264</td>
</tr>
<tr>
<td>part properties</td>
<td>251</td>
</tr>
<tr>
<td>point properties</td>
<td>244</td>
</tr>
<tr>
<td>rotation settings</td>
<td>244</td>
</tr>
<tr>
<td>screenshot settings</td>
<td>245</td>
</tr>
<tr>
<td>steel beam properties</td>
<td>252</td>
</tr>
<tr>
<td>steel column properties</td>
<td>252</td>
</tr>
<tr>
<td>steel item properties</td>
<td>256</td>
</tr>
<tr>
<td>strip footing properties</td>
<td>258</td>
</tr>
<tr>
<td>transparency settings</td>
<td>176,177,251</td>
</tr>
<tr>
<td>twin profile properties</td>
<td>255</td>
</tr>
<tr>
<td>view properties</td>
<td>246</td>
</tr>
<tr>
<td>view settings</td>
<td>278</td>
</tr>
<tr>
<td>shapes</td>
<td></td>
</tr>
<tr>
<td>of items</td>
<td>65</td>
</tr>
<tr>
<td>showing and hiding</td>
<td></td>
</tr>
<tr>
<td>model objects</td>
<td>161</td>
</tr>
<tr>
<td>parts</td>
<td>161</td>
</tr>
<tr>
<td>showing</td>
<td></td>
</tr>
<tr>
<td>cut lines</td>
<td>294</td>
</tr>
<tr>
<td>invisible assembly objects</td>
<td>167</td>
</tr>
<tr>
<td>invisible component objects</td>
<td>167</td>
</tr>
</tbody>
</table>
part labels................................................ 31
parts with exact lines............................162
parts with high accuracy...................... 162
reference lines.......................................294
top-in-form face.................................... 131
welds.........................................................86
single bolts...................................................77
single-part welds....................................... 89
slabs...........................................................56,57
warping............................................... 71,72
slotted holes................................................ 84
snapping to middle points....................... 294
splitting parts.............................................66
standard-part models............................. 305
standardized values for parametric profiles .............................................64
status in clash checking.......................... 197
steel items.............................................. 33,51,256
steel parts....................................................34
assemblies.............................................. 115
beams.....................................................35,252
bent plates................................................ 39
columns...................................................34,252
contour plates........................................... 37
curved beams........................................... 37
items..........................................................51,256
orthogonal beams.................................... 49,254
polybeams...................................................36
twin profiles.............................................50,255
stories creating multi-story structures........302
strip footings............................................ 52,258
studs...........................................................81
sub-assemblies......................................... 116
bolting to existing assembly.................... 117
welding to existing assembly................... 118
surface treatment..................................... 101
adding.................................................... 102
creating new surface treatments.............. 105
modifying..................................................102
on all faces of part.................................... 103
on chamfered parts.................................. 104
on cut faces............................................. 103
on part face............................................. 103
on parts with openings and recesses 105
on selected areas..................................... 103
tiled surface treatment......................... 102,107
surfaces..................................................... 113
Swap Handles............................................ 29
switching on/off
pour management................................. 134

tail information....................................... 278
tiled surface treatment............................ 107
creating new tile patterns...................... 107
pattern definition example....................... 108
pattern definitions................................. 110
pattern elements..................................... 111
tips creating beams close to each other...300
creating bolts.......................................... 304
creating curved parts............................. 298
creating horizontal parts....................... 299
creating round plates and slabs............... 301
cutting efficiently.................................... 295
defining default part properties................ 297
finding RGB values for colors................. 296
hiding cut lines........................................ 294
modeling identical areas........................ 303
modeling large models........................... 307
numbering settings............................... 305
placing objects in model....................... 303
positioning columns, pad footings and
orthogonal beams.................................... 302
positioning objects in radial or circular
pattern...................................................... 303
right-hand rule........................................ 296
showing part reference lines................... 294
top-in-form face....................................... 131
transparency settings............................. 251
transparency of pour objects.................. 140
settings.................................................. 176,177
twin profiles.............................................50,255

ungrouping
clashes................................................ 198
user-defined attributes......................... 264
in numbering......................................... 214
user-defined weld cross sections..... 91,92,93

V
vertical position........................................268
view depth..............................................293
view settings..........................................246
viewing
  models...............................................188
  numbering history..............................224
  pour objects.....................................139
views
  properties.........................................246
visibility of objects............................161,293
visibility
  of parts..........................................161
  of pour breaks.................................148

W
walls.....................................................57
warping
  beams...............................................71
  concrete parts...................................70
  concrete slabs.................................71,72
weld cross sections
  defining...........................................92
  removing..........................................93
weld preparation.................................89,90
welds................................................85,278
  between parts...................................87
  creating.........................................87,88,89
  defining cross sections........................92
  numbering..........................................219,288
  polygon welds....................................88
  removing cross sections........................93
  showing...........................................86
  single-part welds...............................89
  user-defined cross sections..................91
  visibility in model..............................86
weld preparation.................................89,90
weld types..........................................282
welding sub-assemblies.........................118
work area............................................293