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Components

Components are tools that you can use to connect parts in the model.
Components automate tasks and group objects so that Tekla Structures treats
them as a single unit. You can save the properties of a component and use
them in other projects.
Components adapt to changes in the model, which means that Tekla
Structures automatically modifies a component if you modify the parts it
connects. When you copy or move objects, Tekla Structures automatically
copies or moves all the associated components with the objects.
All components are stored in the Applications & components catalog. Click
the Applications & components button
Applications & components catalog.

in the side pane to open the

System components
Tekla Structures contains a wide range of predefined system components by
default. There are three types of system components:
•

Connection components connect two or more parts, and create all the
required objects such as cuts, fittings, parts, bolts, and welds.
For example, end plates, clip angles, and bolted gussets are connections.
In the Applications & components catalog, the connection symbol is

•

.

Detail components add a detail or a reinforcement to the main part. A
detail is only connected to one part.
For example, stiffeners, base plates, and lifting hooks are steel details, and
beam reinforcement and pad footing reinforcement are concrete details.
In the Applications & components catalog, the detail symbol is

•

.

Detailing components automatically create and assemble the parts to
build a structure, but do not connect the structure to existing parts.
For example, stairs, frames, and towers are detailing components.
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In the Applications & components catalog, the detailing symbol is

.

You can also create your own components, custom components if you do not
find a system component that suits your needs. You can use custom
components in the same way as system components.
See also
Component properties (page 6)
Add a component to a model (page 8)
Working with the Applications & components catalog (page 11)

1.1 Component properties
Each component has a dialog box where you can define the properties of the
component. You can open the dialog box by double-clicking the component in
the Applications & components catalog.
The image below shows a typical example of a steel connection, the Two sided
clip angle (143) connection. Concrete and reinforcement component dialog
boxes may have different options.
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Component properties

Description
1

In the upper part of the dialog box, you can save and load predefined
settings. Some components have buttons for accessing bolts, welds
and DSTV properties.
When modifying connections and details, you can select whether Tekla
Structures ignores other types of connections and details, or modifies
all selected connections and details irrespective of their type. With the
modify option, the type of the selected components is changed to
match the type of the component you are modifying.
For more information, see Save and load dialog box properties.

2

On the tabs, you can define the properties of the parts and bolts that
the component creates. You can enter values manually, use system
default values, AutoDefaults values, automatic values, or for some steel
connections, the values in the joints.def file.
Manually entered values, AutoDefaults, automatic values and the
properties defined in the joints.def file all override the system
defaults. System default values are used if you do not manually enter a
value or select any other type of property value. You cannot change the
system default values.
For more information on joints.def, see Joints.def file.

3

If you select an AutoDefaults
option, Tekla Structures uses the
property defined in the AutoDefaults rules.
The image in the AutoDefaults option is an example and does not
necessarily match the outcome in the model.
For more information on AutoDefaults, see AutoDefaults (page 38).

4

If you select an automatic
option, Tekla Structures automatically
determines which option to use for a property.
For example, when you use the automatic option for the stiffener in
End plate (144), the connection automatically adds the stiffener to a
beam-to-column connection, but does not add it to a beam-to-beam
connection.
For more information on AutoConnection, see AutoConnection
(page 32).

5

The parts that are yellow in the component dialog box are created by
the component.

6

The parts that are blue in the component dialog box should already
exist in the model before you create the component.

7

Up direction indicates how the connection is rotated around the
secondary part, relative to the current work plane. The
symbol on
the Picture tab of the component dialog box indicates the correct up
direction.
Components
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Component properties

Description
If there are no secondary parts, Tekla Structures rotates the connection
around the main part. The options are: +x, -x, +y, -y, +z, -z.
You can change the default up direction on the General tab of the
component dialog box. Try changing the positive directions first.
See also
Add a component to a model (page 8)

1.2 Add a component to a model
When you add a component to a model, you either attach the component to
existing parts in the model, or pick positions to indicate the location or length
of the component.
Connections and details have a main part that you select first. Connections
also have one or more secondary parts that you select after you have selected
the main part. Detailing components do not always have a main part and
secondary parts. Instead, they automatically create and assemble the parts to
build a structure when you pick a position in the model.
If you use a component you are unfamiliar with, use the default properties of
the component. Then check what needs to be modified, and modify only few
properties at a time to see how the modifications affect the component. This is
quicker than trying to set all the component properties before seeing what the
component actually creates.
Tekla Structures opens a command prompt when you add a component. Do
not close the prompt window, because it displays information on adding the
component. This information can be useful in problem situations.
1.

Click the Applications & components button
open the Applications & components catalog.

in the side pane to

You can also press Ctrl + F.
2.

Select a component and do one of the following:
To

Do this

Add a
1. Select the main part.
connection
2. Select the secondary part or parts.
•

If there is one secondary part, the connection is
automatically created when you select the secondary part.

•

If there are several secondary parts, click the middle mouse
button to finish selecting the parts and to create the
connection.
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Add a component to a model

To

Add a
detail

Do this
In the example image below, the numbers from 1 to 4 show the
selection order of parts. The blue parts should already exist in
the model before you create the component.

1. Select the main part.
2. Pick a position in the main part to determine the location of
the detail.

Pick one to three positions to determine the location of the
Add a
objects that the detailing component creates.
detailing
component

Component status
When you have added the component, Tekla Structures shows the component
status using the symbols shown in the table below. Double-click the symbol to
open the component properties.
Color

Status
The green symbol shows that the component was created
successfully.
The detailing component symbol in the model is
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Add a component to a model

.

Color

Status
The yellow symbol shows that the component was created,
but has problems.
This often occurs when bolts or holes have an edge distance
that is less than the default value.
The red symbol shows that the component was not created.
Common reasons are that the properties are incorrect or that
the up direction is not appropriate.

See also
Component properties (page 6)
View a component in a model (page 10)

1.3 View a component in a model
You can create several views of a component to view it from different
viewpoints.
1.

Click the component symbol in the model to select the component.

2.

Right-click and select Create View --> Default Views of Component .
Tekla Structures creates four views: front, end, top, and perspective.
The example image shows the default views of the End plate (144)
connection.
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View a component in a model

NOTE You can check the dimensions, such as bolt locations and edge distances,
using the Measure tool in the Component front view.

1.4 Working with the Applications & components catalog
Components are stored in the Applications & components catalog and
organized into two different types of groups.
The groups are shown against different background colors in the catalog.
•

Default groups are automatically available:
•

Recent contains the 12 components and applications that have most
recently been used in the model.

•

Ungrouped items contains the components and applications that are
not in any predefined groups.
Ungrouped items can be, for example, imported components that have
not been moved to any other group yet.

•

Applications contains applications, macros and drawing plugins.
If you create your own macros, you can add them to this group.

•

Connections contains connections and seams.

Components
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Working with the Applications & components
catalog

•

•

Detailing contains detailing components.

•

Details contains details.

•

Parts contains custom parts.

•

Legacy catalog shows the folder structure of the Component Catalog
used in previous Tekla Structures versions if Component Catalog
catalog definition files are found in the standard folder search paths.

Depending on your environment, the catalog may also contain predefined
groups for specific usage, such as Steel > Beam to beam connections.
You can create your own groups according to your needs, for example,
your own favorite connections.

Model-specific components are shown only in the model view and drawingspecific components are shown only in the drawing view.
How to use the Applications & components catalog
Click the Applications & components button
in the side pane to open
the Applications & components catalog. You can also press Ctrl + F.
To

Do this

Search
Enter the search term or terms in the search box. The search is
for a
case-insensitive.
compone
The search uses the following rules:
nt
• Non-numeric search terms find partial matches, for example,
bolt shows both bolt and bolted in the search result.
If you enter more than one term, for example, bolt plate,
the terms are automatically combined so that the search result
shows the components that contain both bolt AND plate in their
name, description, or tags.
•

Numeric (integer) search terms find the exact match, for
example, 121 shows component number 121 in the search
result.
You can use the *, ? and [ ] wildcards to search for partial
numeric matches. For example, 10* finds components number
10, 110, 104, 1040, and so on.

•

You can restrict the search to specific tags, groups and types of
components by using the keywords tag, group, or type. For
example, 10 tag:advanced finds the number 10 components
that have advanced in the tag, and type:custom finds all
custom components.

Components

12

Working with the Applications & components
catalog

To

Do this

Use a
Select a component in the catalog to activate it and follow the
compone instructions on the status bar to add the component to the model.
nt
Double-click a component in the catalog to open the component
properties dialog box.
Change
the view

•
•
•

Click

to show the thumbnail view.

Click

to show the list view.

Click
to change the view between the normal view and
the compact view.
The compact view shows the thumbnail images of the group
that you select from the list above the search box. You can use
the compact view to have more space on the screen.

Show
Click Show selected to show a Selected components group that
selected contains the components that are selected in the model or in the
compone drawing.
nts
Click Show selected again to hide the Selected components
group.
The Show selected button is not available when you are using the
search in the catalog.
View and
modify
compone
nt
informati
on in the
catalog

Each component has an information box that shows the type of
the component and the groups the component belongs to. You
can add a description for the component and tags that can be
used in the search.
1.

Select a component and click the small arrow on the right to
open the component information box.

2.

Type a description in the Description box.

3.
4.

Click

to add a tag and enter a tag in the box.

If needed, click

again to add more tags.

You can also remove tags.
5.

Click outside the information box to close it.

The descriptions and tags you add are by default saved in the
ComponentCatalog.xml file in the model folder.
Add a
Components have a default thumbnail image that shows a typical
thumbna situation where the component can be used. You can add several
il
thumbnails for a component and select which thumbnail is shown
in the catalog thumbnail view.
1.

Select a component.
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Working with the Applications & components
catalog

To
2.

Do this
Right-click and select Thumbnails.

3.

Click Add thumbnail.

4.

Select an image and click Open.
You can use any standard image format, for
example, .png, .jpeg, .gif, .tiff, and .bmp.

5.

Select the check boxes of the thumbnails that you want to
show in the component information box.
You can also remove thumbnails, except for the default
thumbnail.

6.

Click Close.

The thumbnail information you add is by default saved in the
ComponentCatalog.xml file in the model folder.
Create
and
modify
groups

You can create groups and subgroups, and drag the groups to
different locations in the predefined groups section. You can add
and remove components from the groups, rename the groups,
and add descriptions for the groups.
•

To create a group, right-click on the groups in the catalog and
select New group. Drag the group to the desired location.
To create a subgroup, first right-click a group and then select
New group.

•

To name a group, right-click the group, select Rename and
type the name.

•

To add components to a group:
•

Select components in the catalog and drag them to another
group.

•

Select components in the catalog, right-click and select Add
to group. Then select the group to which the components
are added.

•

Right-click a group, select Add all to group and select the
group to which all the components of the selected group
are added.
Note that the components are copied to the other groups.

•

To remove a group you have created, right-click the group and
select Remove from group.

The groups you create are by default saved in the
ComponentCatalog.xml file in the model folder.
NOTE You cannot add or remove groups from the default groups
and you cannot modify the content of the default groups.
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Working with the Applications & components
catalog

To

Do this
However, you can hide the default groups and individual
items in the groups.

Hide
1.
groups
2.
and
compone
3.
nts

Select a group or a component.
Right-click and select Hide / Unhide to hide the group or the
component.
To view the hidden group or component again, select the
Show hidden items check box at the bottom of the catalog.
The hidden group or component is shown as dimmed.

4.
Undo/
Redo
catalog
changes

To show the hidden group or component normally, right-click
it and select Hide / Unhide.

Right-click on the catalog and select Undo catalog changes or
Redo catalog changes.

Show the Click the Display message log button in the lower right corner in
message the catalog. The button is shown only if there are errors or
log
warnings, for example, in the catalog definition files.
Errors and warnings are also written to the
ComponentCatalog_<user>.log file in the \logs folder under
the model folder.
> Catalog management
The commands in Access advanced features
are used for modifying catalog definitions. Generally, there is no need to
modify catalog definitions. Do not modify the definition files if you are not an
administrator. For more information, see
XS_COMPONENT_CATALOG_ALLOW_SYSTEM_EDIT.
See also
Component properties (page 6)
Add a component to a model (page 8)
Applications (page 23)

1.5 Steel component example: Add an end plate using the
End plate (144) connection
In this example, you will connect a beam to a column using an end plate
connection. End plate (144) connects two beams, or a beam to a column,
using a bolted end plate.
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Steel component example: Add an end plate
using the End plate (144) connection

1.

Click the Applications & components button
open the Applications & components catalog.

in the side pane to

2.

Type 144 in the search box.

3.

Double-click End plate (144) to open the component properties.

4.

Click Apply to add the component using the default properties.

5.

Select the main part (column).

6.

Select the secondary part (beam).
Tekla Structures automatically adds the connection when you select the
beam.

See also
Add a component to a model (page 8)

1.6 Steel component example: Add a base plate and
anchor rods using the Base plate (1004) detail
In this example, you will add a base plate detail and anchor rods to a column.
1.

Click the Applications & components button
open the Applications & components catalog.

2.

Enter base plate in the search box.

in the side pane to

To view the thumbnail images of the components in the search results
click

.

3.

Select Base plate (1004).

4.

Select the column.
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Steel component example: Add a base plate and
anchor rods using the Base plate (1004) detail

5.

Pick a position at the base of the column.
Tekla Structures automatically adds the base plate when you pick the
position.

6.

Next, modify the anchor rod dimensions.
a.

Switch on the Select components switch
components.

b.

Double-click the component symbol in the model to open the Base
plate (1004) component dialog box.

c.

Go to the Anchor rods tab.

d.

Change the dimensions of the anchor rods.

e.

To change only this base plate, select ignore other types from the list
in the top part of the dialog box.

f.

Click Modify.

to more easily select

See also
Add a component to a model (page 8)

1.7 Steel component example: Add a beam-to-column
connection using the Column with stiffeners (186)
connection
In this example, you will connect a beam to a column using a beam-to-column
connection.
1.

Click the Applications & components button
open the Applications & components catalog.
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in the side pane to

Steel component example: Add a beam-tocolumn connection using the Column with
stiffeners (186) connection

2.

Enter 186 in the search box.

3.

Select Column with stiffeners (186).

4.

Select the main part (column).

5.

Select the secondary part (beam).
Tekla Structures automatically adds the connection when you select the
beam.

See also
Add a component to a model (page 8)

1.8 Concrete component example: Add a corbel
connection using the Corbel connection (14)
connection
In this example, you will add a corbel connection between a column and a
beam.
1.

Click the Applications & components button
open the Applications & components catalog.

2.

Enter corbel in the search box.

3.

Select Corbel connection (14).

4.

Select the main part (column).
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in the side pane to

Concrete component example: Add a corbel
connection using the Corbel connection (14)
connection

5.

Select the secondary part (beam).
Tekla Structures automatically adds the corbel connection between the
column and the beam when you select the beam.

See also
Add a component to a model (page 8)

1.9 Reinforcement component example: Add a pad
footing reinforcement using the Pad footing
reinforcement (77) detailing system component
In this example, you will reinforce a concrete pad footing.
1.

Create a pad footing.

2.

Click the Applications & components button
open the Applications & components catalog.

3.

Enter pad footing in the search box.

4.

Select Pad footing reinforcement (77).

5.

Select the pad footing.
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in the side pane to

Reinforcement component example: Add a pad
footing reinforcement using the Pad footing
reinforcement (77) detailing system component

Tekla Structures inserts the lacer bar and bottom reinforcement in the pad
footing.

See also
Add a component to a model (page 8)

1.10 Component tips
Default properties
If you use a component you are unfamiliar with, use the default properties of
the component. Then check what needs to be modified, and modify only few
properties at a time to see how the modifications affect the component. This is
quicker than trying to set all the component properties before seeing what the
component actually creates.
Valid profiles
Some components work with certain profiles only. If a component is not
created successfully, try entering a valid profile.
Select components switch
You can switch on the Select components switch
object that belongs to the component.
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Component tips

to be able to select any

Component is not added to the model
If the component is not added to the model, check the status bar. For
example, you may need to click the middle mouse button to stop selecting
parts before Tekla Structures creates the component.
Using thickness to create needed parts
If a component does not by default create the parts that you need, look for
options to create them. If there are no options, try entering a thickness value
for the parts.
If a component creates parts that you do not need, look for options to remove
them. If there are no options, enter a zero (0) as the thickness of the parts.
Many secondary parts are found
If you are using a connection that only allows one secondary part, you may see
the message Many parts found on the status bar. This means that Tekla
Structures cannot determine which parts to connect. You may have several
parts in the same location, or the view may be set too deep.

1.11 Converting a conceptual or a detailed component
Depending on the Tekla Structures configuration you are using, you can create
either detailed or conceptual components.
•

Detailed components include all the information needed for fabrication,
such as assemblies, cast units, and reinforcing bars.

Detailed components have a round symbol in the model:
•

or

.

Conceptual components look similar to detailed components but do not
include the option to change part numbering or assembly numbering
settings. Conceptual components are meant to be used as reference
information for further fabrication detailing.

Conceptual components have a rectangular symbol in the model:

or

.
You can create conceptual components in the Engineering, Rebar Detailing,
and Construction Modeling configurations.
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Converting a conceptual or a detailed component

You can edit conceptual components and convert them to detailed
components in the Full, Primary, Steel Detailing, or Precast Concrete Detailing
configurations.
Modifying part properties, such as the size of the component main part, does
not automatically convert a detailed component to a conceptual component,
or vice versa. For example, if you use the Engineering configuration and
modify the model, detailed components are not converted to conceptual
components. However, when you modify a detailed component in the Rebar
Detailing configuration, the component changes to a conceptual component.
You can convert components in the Applications & components catalog. Click
the Applications & components button
Applications & components catalog.

in the side pane to open the

Do one of the following:
To

Do this

Convert a
1.
conceptual
component
to a detailed 2.
component
Convert a
detailed
component
to a
conceptual
component

1.
2.

Configuration

Click
> Convert to
detailing component.

Full, Primary, Steel Detailing,
Precast Concrete Detailing

Select the component
symbol.
Click
>Convert to
conceptual component.

Engineering, Construction
Modeling, Rebar Detailing

Select the component
symbol.
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Converting a conceptual or a detailed component

2

Applications

All available applications, macros, and drawing plugins are located in the
section Applications of the Applications & components catalog. You can also
record macros of your own and show them on the list.
Macros
Macro types of applications (page 25) are saved as .cs files in the
\drawings or \modeling folder under the folder that has been defined with
the advanced option XS_MACRO_DIRECTORY. By default, this advanced option
is set to ..\ProgramData\Tekla Structures\<version>\environments
\common\macros.
In addition to this global folder, you can create a local folder and save your
own macros there. To use the local macros, you need to specify the local
macro folder for the advanced option XS_MACRO_DIRECTORY in addition to
the global folder.
Available macros in the modeling mode
Macro

Description

AutomaticSplicingTool

Use to split long reinforcing bars and
bar groups that exceed the stock
length, and create splices in split
locations.

ContinuousBeamReinforcement

Use to reinforce a continuous beam.
The macro creates main top and
bottom bars, stirrups, fittings, and
additional top and bottom bars using
system components.

Convert_DSTV2DXF

Use to create NC files in DXF format
by converting DSTV files to DXF files.

CreateSurfaceView

Use to create an automatically aligned
surface view.

Applications
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Converting a conceptual or a detailed component

Macro

Description

CreateSurfaceView_wEdge

Use to create a surface view and align
the work plane along the edge you
select.

DesignGroupNumbering

Use to number parts by design
groups so that you can differentiate
the parts from each other in drawings
and reports.

DirectoryBrowser

Use to to find and modify the location
of the various Tekla Structures files
and folders, and customize user
settings.

RebarClassificator

Use to classify the reinforcing bars
and reinforcement meshes by their
order of depth in concrete slabs and
panels.

RebarSeqNumbering

Use to assign cast unit specific
running numbers (1, 2, 3...) to the
reinforcement in the model.

RebarSplitAndCoupler

Use to split a reinforcing bar group
and add couplers in relation to the
direction of the picked points.

UpdateRebarAttributes

Use to manage the user-defined
attributes (UDAs) of the couplers and
the end anchor parts created by
Rebar Coupler and Anchor Tools.

Available macros in the drawing mode
Macro

Description

AddSurfaceSymbols

Use to add surface treatment symbols
in cast unit drawings.

Copy with offfsets (Drawing tools)

Use to copy lines, circles, polylines,
polygons and rectangles with offsets.

Create fillets (Drawing tools)

Use to connect two intersecting lines
by extending the two selected lines to
their intersection point.

Create chamfers (Drawing tools)

Use to create chamfers between two
lines using the distance that you
specify.

Manage cut lines (Drawing tools)

Use to create lines that are displayed
with a zigzag or a dash-and-dot in
different colors to show that the line
is partially outside the view border.
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Converting a conceptual or a detailed component

Macro

Description

Create moment connection symbols
(Drawing tools)

Use to create moment connection
symbols to show the beams that are
connected to columns with rigid
connections.

ExaggerateSelectedDimensions

Use to exaggerate narrow dimensions
to make them easier to read.

RebarLayeringMarker

Use to mark reinforcing bar layers
with different marking styles and line
types in a drawing.

RebarMeshViewCreator

Use to create drawing views each
containing one reinforcement mesh.

RemoveChangeClouds

Use to remove dimension change
symbols, mark change symbols and
associative note change symbols in
one go from an open drawing.

Extensions (.tsep)
You can download Tekla Structures extensions that have the .tsep file
extension from Tekla Warehouse and import (page 29) these extensions to
the Applications & components catalog. When you restart Tekla Structures,
the imported extensions are installed and added to the Ungrouped items
group in the catalog. You can move them to a suitable group.
Publish groups in the Applications & components catalog
You can collect content to a group that you create in the Applications &
components catalog. You can then publish the group (page 30) as a catalog
definition file to make it available for other Tekla Structures users.

2.1 Working with applications
You can run, add, edit, rename, save as and delete applications, macros and
plugins in the Applications section of Applications and Components catalog.
You can also record and edit macros.
To

Do this

Record a macro

1.

Click the Applications &
components button
in the
side pane to open the
Applications & components
catalog.

Applications
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Working with applications

To
2.

Do this
Click the Access advanced
features button
and then
click Record macro > Global or
Local depending on whether you
want to save the macro in the
global or local macros folder.
The Local command is only
available if you have defined a
location for the local macros
using the advanced option
XS_MACRO_DIRECTORY.

3.

Enter a name for the macro in
the Macro name box.

4.

Click OK and perform the actions
you want to record.

5.

Click Stop recoding to stop
recording.
The recorded macro is saved
under global or local macros in
the macros\drawings or
macros\modeling folder
depending on the mode (drawing
or modeling) you were using
while you were recording the
macro.

Create a macro file and add contents
later

1.

Click the Applications &
components button
in the
side pane to open the
Applications & components
catalog.

2.

Click the Access advanced
and then
features button
click New macro > Global or
Local depending on whether you
want to save the macro in the
global or local macros folder.
The Local command is only
available if you have defined a
location for the local macros
using the advanced option
XS_MACRO_DIRECTORY.

Applications
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Working with applications

To
3.

Do this
Enter a name for the macro in
the Macro name box.

4.

Click OK.
This creates an empty macro file
that is displayed in the
Applications list.

View or edit a macro

5.

Right-click the empty macro file
and select Edit.

6.

Add the macro content, for
example, by copying commands
from other macro files and save
the file.

1.

Click the Applications &
components button
in the
side pane to open the
Applications & components
catalog.

2.

Click the arrow next to
Applications to open the
applications list.

3.

Right-click the macro you want to
edit and click Edit.
The macro can be opened in any
text editor.

Run an application

4.

If needed, edit the macro and
save the macro file.

1.

Click the Applications &
components button
in the
side pane to open the
Applications & components
catalog.

Save an application with another
name
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2.

Click the arrow next to
Applications to open the
applications list.

3.

Double-click the application you
want to run.

1.

Click the Applications &
components button
side pane to open the

Working with applications

in the

To

Do this
Applications & components
catalog.
2.

Click the arrow next to
Applications to open the
applications list.

3.

Right-click the application that
you want to save with another
name and click Save as.

4.

Enter a new name for the
application and click OK.
The application will be added in
the list.

Rename an application

1.

Click the Applications &
components button
in the
side pane to open the
Applications & components
catalog.

2.

Click the arrow next to
Applications to open the
applications list.

3.

Right-click the application you
want to rename and click
Rename.

4.

Enter a new name for the
application and click OK.
The name of the application
changes.

Delete an application

1.

Click the Applications &
components button
in the
side pane to open the
Applications & components
catalog.

2.

Click the arrow next to
Applications to open the
applications list.

3.

Right-click the application you
want to delete and click Delete.
The application is removed from
the list.
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See also
Applications (page 23)

2.2 Import an extension to the Applications &
components catalog
You can import Tekla Structures extensions that have the .tsep file extension
(Tekla Structures extension package) to the Applications & components
catalog. First download the extension from Tekla Warehouse and then import
it to the Applications & components catalog.
System administrators can copy multiple .tsep extension files to a Tekla
Structures user's computer to the \Tekla Structures\<version>
\Extensions\To be installed folder. The extensions are installed the
next time the user restarts Tekla Structures.
1.

Click the Applications & components button
open the Applications & components catalog.

2.

Click

3.

Click the Tekla Warehouse link and log in to Tekla Warehouse with your
Tekla account.

4.

Search for the extension and click Download.

5.

In Extension manager, click Import.

6.

Double-click the .tsep file to be imported.

in the side pane to

> Extension manager.

The extension is shown in Extension manager.
You can still remove the extension from Extension manager before
installing it. Select the extension and click Cancel.
7.

If needed, repeat steps 4 - 6 to import more Tekla Structures extensions.

8.

Restart Tekla Structures to install the imported extensions.

9.

Open the Applications & components catalog.
The extension is shown in the Ungrouped items group in the catalog. You
can move the extension to a more suitable group, or create a new group.

You can remove an installed extension in the Extension manager. Select the
extension and click Remove. The extension is removed when you restart Tekla
Structures.
Installing and uninstalling an extension creates a log file in \Tekla
Structures\<version>\Extensions\TSEP Logs.
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NOTE Some Tekla Structures extensions have an .msi installation file. You have to
install these extensions separately. Download the .msi installation file from
Tekla Warehouse and double-click the file to run the installation.

See also
Working with the Applications & components catalog (page 11)

2.3 Publish a group in the Applications & components
catalog
You can collect content, such as macros, extensions, and system and custom
components to a group that you create in the Applications & components
catalog. You can then publish the group as a catalog definition file to make it
available for other Tekla Structures users. For the published content to work
correctly in another Tekla Structures installation the content must also exist in
that installation.
1.

Click the Applications & components button
open the Applications & components catalog.

2.

Create a new group:

in the side pane to

a.

Right-click in the catalog and select New group.

b.

Enter a name for the group.

c.

Select the group and click the small arrow on the right to add a
description to the group.

d.

Add content (page 11) to the group.

e.

If needed, add the needed information to the group, such as a
description, tags, and thumbnails to the items that are in the group.
Use a thumbnail image from the \ProgramData\Tekla
Structures\<version>\Bitmaps folder to ensure that the image
is available for other Tekla Structures users.

3.

Right-click the group and select Publish group to create a catalog
definition file.
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The file includes the selected group and its subgroups, the group
information you defined, and the references to the content you have
added to the group.
If you have the Show hidden items option selected, the hidden content is
published as visible content in the file.
If you have included both model components and drawing plugins in the
group, both of these are published. Model components are visible when a
model is open and drawing plugins are visible when a drawing is open.
4.

Add a unique prefix to the filename.
The filename format must be <prefix>_ComponentCatalog.ac.xml.

5.

Click Save.

6.

Make the group available for other Tekla Structures users by placing the
<prefix>_ComponentCatalog.ac.xml file to an appropriate folder:

7.

•

Project, firm or system folder defined in XS_PROJECT, XS_FIRM, or
XS_SYSTEM.

•

Extensions folder in \Program data\<version>\environments
\common\extensions, or to any of the folders defined in
XS_EXTENSION_DIRECTORY. The Applications & components catalog
also searches the subfolders of these folders. We recommend that you
use the extension folders if you have created your own extensions and
have included them in the group.

Check that the catalog definition file works correctly:
a.

Delete the published group from your Applications & components
catalog.

b.

Click

> Reload catalog to load and view the published group.

If the group works correctly, other users can start using it:
•

If the group content is already included in other users' Tekla Structures
installation, they can use the group immediately after reloading the catalog
by clicking

•

> Reload catalog.

If the group content, for example extensions, is not included in other users'
Tekla Structures installation, they have to download the missing extensions
fromTekla Warehouse first, and then re-open the model where they are
going to use the group.
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3

AutoConnection

Use the AutoConnection tool to automatically select and apply connections
with predefined properties to selected parts in a model. With AutoConnection,
Tekla Structures automatically creates similar connections for similar framing
conditions.
You can use AutoConnection to quickly add connections individually, in
phases, or project-wide. This is useful when you are working on a large project
using many connections, modifying a model, or importing modified profiles.
NOTE Before using AutoConnection in a working model, we recommend that you
create a test model, and create all the connection conditions in it that you
need for a particular project. You can then use the test model to check the
rules and properties of various connection types. The model also acts as a
quick reference for connection information.

See also
AutoConnection settings (page 32)
Create a connection using AutoConnection (page 36)
AutoConnection and AutoDefaults rules (page 45)

3.1 AutoConnection settings
With AutoConnection you can define groups of rules which Tekla Structures
automatically applies when creating connections in a model. By using a rule
group to select connections and connection properties you do not have to
select each connection and define its properties separately. For example, you
can create separate rules for different standards, projects, manufacturers, and
even individual models.
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To open the AutoConnection Setup dialog box, click File menu --> Catalogs -> AutoConnection settings.

Icon

Setup level

Description

Rule group

You can use rule groups to organize
connections and connection properties
according to different standards,
projects, manufacturers, and models.
You can create, modify and delete rule
groups.

Framing condition

Framing conditions are predefined
connection types that you cannot
change. Tekla Structures creates the
framing conditions automatically:
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•

Beam to beam web

•

Beam to beam flange

•

Beam to column web

•

Beam to column flange

•

Beam splice

•

Column splice

AutoConnection settings

Icon

Setup level

Description

Rule set

You can use rule sets to define which
connection to use in a certain situation.
You can create additional rule sets.

Connection

The connection to apply if the rule set
criteria are met.
To apply a particular connection, the
conditions in the model have to match
all the rules in the branch that contains
the connection.

Rules.zxt file
When you use AutoConnection, Tekla Structures saves the AutoConnection
information in a zipped rules.zxt file in the \attributes folder under the
current model folder.
You can copy the rules.zxt file to the project or firm folder to make it
available in other models. Each time you modify the AutoConnection setup
you need to recopy this file to the firm and project folders. To use the modified
setup in other models, restart Tekla Structures.
See also
Create a rule group for AutoConnection (page 34)
Create a rule set for AutoConnection (page 35)
Change a connection in an AutoConnection rule set (page 35)

Create a rule group for AutoConnection

You can define rule groups for AutoConnection to organize connections and
connection properties according to different standards, projects,
manufacturers, and models.
1.

On the File menu, click Catalogs --> AutoConnection settings.

2.

Right-click an existing rule group and select New Rule Group.

3.

Click the New group and enter a name.
Give the rule group a name that reflects the group of connections that you
want to create. For example, use the fabricator's name, the project name,
or any name that clearly identifies the connection rules that you want to
use for a specific model.

When you create a new rule group, Tekla Structures automatically adds the
existing framing conditions in the group.
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See also
Create a rule set for AutoConnection (page 35)
Create a connection using AutoConnection (page 36)

Create a rule set for AutoConnection

You can create AutoConnection rule sets under framing conditions to specify
which connection properties to use when specific conditions in the model are
met.
You only need to create AutoConnection rule sets if you plan to use different
connections to connect similar framing conditions. For example, in the model,
some beam-to-beam connections require clip angles, others need shear tabs.
You need to define rule sets to determine where each connection type should
be used.
1.

On the File menu, click Catalogs --> AutoConnection settings.

2.

Click the plus icon in front of the rule group

3.

Right-click the relevant framing condition
Additional Rule Sets.

4.

Right-click the new rule set and select Edit Rule Set.

5.

Enter a name for the rule set.

6.

Select a rule from the Available rules list.

7.

Click the right arrow button to move the selected rule into the list of Rules
in the rule set.

8.

Enter the values used in the rule: either an exact value, or minimum and
maximum values.

9.

Click OK.

to open the tree structure.
and select Create

NOTE The order of the rules in the tree structure is important. Tekla Structures uses
the first rule that matches the conditions in the model so you should place the
most limiting rule highest in the tree, and the most generic rule lowest.
You can change the priority of a rule set by right-clicking the rule set and
selecting Move Up or Move Down.

See also
Change a connection in an AutoConnection rule set (page 35)
Create a connection using AutoConnection (page 36)
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Change a connection in an AutoConnection rule set

You can change the connection in a rule set by selecting a connection in the
Applications & components catalog.
1.

On the File menu, click Catalogs --> AutoConnection settings.

2.

Click the plus icon in front of the relevant framing condition
set

and rule

to find the connection that you want to change.

3.

Right-click the connection and select Select Connection Type.

4.

Double-click a connection in the Select component dialog box.

5.

Click OK in the AutoConnection Setup dialog box.

See also
Create a connection using AutoConnection (page 36)

3.2 Create a connection using AutoConnection
Use AutoConnection to have Tekla Structures automatically create connections
using the properties of predefined rules. When you use AutoConnection, Tekla
Structures ignores the properties in the connection dialog boxes. Tekla
Structures does not modify the existing connections.
1.

In the model, select the parts to connect.

2.

On the Edit tab, click Components --> Create AutoConnections.

3.

Select the rule groups from the lists on the Rule groups tab.

1

Rule group for AutoConnection

2

Rule group for AutoDefaults

4.

If needed, go to the Advanced tab to change the rules used in framing
conditions:
a.

Select the connection in the Connection selection option:
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b.

5.

•

AutoConnection applies the connection defined in the rule group
that you have selected in the first list on the Rule groups tab.

•

None does not create a connection.

•

Click Select to select a connection from the Applications &
components catalog. Tekla Structures creates the connection
using the default properties.

Select the connection properties in the Parameters selection option:
•

AutoDefaults applies the properties of the rule group that you
have selected in the first list on the Rule groups tab.

•

No autodefaults applies the default connection properties.

Click Create connections.

See also
AutoConnection settings (page 32)
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4

AutoDefaults

Use AutoDefaults to set up properties for existing connections. AutoDefaults
allows you to modify the default connection properties and save them for use
in specific circumstances. When you use AutoDefaults, Tekla Structures
automatically creates the connections with the predefined AutoDefaults
properties. You can also use AutoDefaults for a single connection.
For example, you can use AutoDefaults to automatically adjust the thickness of
each base plate you create, according to the main part profile. If the main part
profile changes, Tekla Structures automatically adjusts the thickness of the
base plate.
NOTE Before using AutoDefaults in a working model, we recommend that you
create a test model, and create all the connection conditions in it that you
need for a particular project. You can then use this test model to check the
rules and properties of various connection types. It also acts as a quick
reference for connection information.

See also
AutoDefaults settings (page 38)
Modify a connection using AutoDefaults (page 43)
AutoConnection and AutoDefaults rules (page 45)

4.1 AutoDefaults settings
Use AutoDefaults to set up properties for existing connections. With
AutoDefaults you can create rules that define the situations where the
predefined properties are used.
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To open the AutoDefaults Setup dialog box, click File menu --> Catalogs -->
AutoDefaults settings.

Icon

Setup level

Description

Rule group

You can use rule groups to organize settings
according to different standards, projects,
manufacturers, and models. You can create,
modify and delete rule groups.

Components

The component tree structure shows the
connections that are available on component
toolbars in Tekla Structures.

Rule set

Rule sets control which properties to use in
certain situations. You can create additional rule
sets.
Tekla Structures processes AutoDefaults rule sets
in the order in which they are in the tree, so you
can control the selection of properties.

Properties file

AutoDefaults

The properties files are under the rule sets. By
default, each connection has a standard
properties file that defines the standard
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Icon

Setup level

Description
properties, for example, standard.j144 or
standard.j1042.
You can create additional properties files for the
properties that you want to use again and give
the files distinctive names.

Defaults.zxt file
When you use AutoDefaults, Tekla Structures saves the AutoDefaults rules in a
zipped defaults.zxt text file in the \attributes folder under the current
model folder.
You can copy the defaults.zxt file to the project or firm folder to make it
available in other models. Each time you modify the AutoDefaults setup, you
need to recopy this file to the firm or project folder. To use the modified setup
in other models, restart Tekla Structures.
NOTE We do not recommend that you edit the defaults.zxt file using a
text editor, but if you do, ensure that you are using the right syntax.
The easiest way to unzip the .zxt file is to change the file
extension .zxt to txt.gz and unzip the file. Change the extension
back to .zxt when you have finished. You do not need to zip the file
after editing it, Tekla Structures can also read the unzipped file.
See also
Create a rule group for AutoDefaults (page 40)
Create a rule set for AutoDefaults (page 41)
Modify connection properties for AutoDefaults (page 42)

Create a rule group for AutoDefaults

You can define rule groups for AutoDefaults to group the rules according to
different standards, projects, or manufacturers, for example.
1.

On the File menu, click Catalogs --> AutoDefaults settings.

2.

Right-click an existing rule group and select New Rule Group.

3.

Click the New group to rename it.
Give the rule group a name that reflects the contents of the group. For
example, use the fabricator's name, the project name, or any name that
clearly identifies the rules that you want to use for a specific model.

When you create a new rule group, Tekla Structures automatically adds the
existing components to the group.
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See also
Create a rule set for AutoDefaults (page 41)
Modify a connection using AutoDefaults (page 43)

Create a rule set for AutoDefaults

You can create rule sets to define which connection properties are used when
specific conditions in the model are met.
1.

On the File menu, click Catalogs --> AutoDefaults settings.

2.

Click the plus icon in front of the rule group

3.

Click the plus icon in front of the relevant group of components
connection

to open the tree structure.
and

.

4.

Right-click an existing rule set and select New Rule Set.

5.

Right-click the new rule set and select Edit Rule Set.

6.

Enter a name for the rule set.

7.

Select a rule from the Available rules list.

8.

Click the right arrow button to move the selected rule into the list of Rules
in the rule set.

9.

Enter the values used in the rule: either an exact value, or minimum and
maximum values.

10. Select from the Parameter file(s) selection in the rule set list how the
properties are selected in the rule set.
Option

Description

Use
Tekla Structures uses the properties files it finds in the first
combination of matching sub-rule set and does not check other rule sets.
first
parameters
Iterate until
connection
symbol is
green

Tekla Structures checks sub-rule sets until it finds matching
properties.

Iterate until
connection
symbol is
yellow

Tekla Structures checks sub-rule sets until it finds matching
properties.
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Option

Description

Use
Tekla Structures checks all rule sets and uses the properties
combination of files in all matching rule sets. The order of the properties
all parameters files is important.
When Tekla Structures combines the properties files, the
most recent files (the lowest in the tree) override previous
ones. If you do not enter any values for the properties,
Tekla Structures does not override the previous property
values.
11. Click OK.
NOTE The order of the rules in the tree structure is important. Tekla Structures uses
the first rule that matches the conditions within the model so you should
place the most limiting rule highest in the tree, and the most generic rule
lowest.
You can change the priority of a rule set by right-clicking the rule set and
selecting Move Up or Move Down.

See also
AutoDefaults settings (page 38)
Modify connection properties for AutoDefaults (page 42)
Combining and iterating properties for AutoDefaults (page 47)

Modify connection properties for AutoDefaults

Each connection has a default standard property file that defines the
properties for the connection. You can modify the properties that the standard
file uses. Save the connection properties that you want to use and set the
standard file to use these properties in the AutoDefaults settings.
1.

On the File menu, click Catalogs --> AutoDefaults settings.

2.

Click the plus icon in front of the rule group

3.

Click the plus icon in front of the relevant group of components
connection

to open the tree structure.
and

.

4.

Right-click the standard.j connection file that you want to modify, for
example, standard.j144 and select Edit connection parameters.

5.

In the connection dialog box, set the properties that you want to save.
Such properties could be, for example, bolt properties, profiles, and
materials.
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6.

Enter a descriptive name for the properties in the box next to the Save as
button.

7.

Copy this name in the Connection code option on the General tab.
Using the same name allows you to check which properties Tekla
Structures used in specific situations. Tekla Structures does not
automatically show the AutoDefaults values in the connection dialog box.

8.

Click Save as.
Tekla Structures saves the properties file in the \attributes folder
under the current model folder. The filename consists of the name you
entered in Save as and the file extension .jXXX, where XXX is the
connection number, for example, sec_0-190.j144.

9.

Click Cancel to close the connection dialog box and return to the
AutoDefaults Setup dialog box.
If you click OK to close the connection dialog box, you need to load the
default properties the next time you use the connection. Using the default
properties ensures that AutoDefaults can modify the properties.

10. Right-click the standard.j file again and select Select connection
parameters.
The Attribute File List dialog box that opens contains the properties that
have been set and saved in the connection dialog box.
11. Select a file in the Attribute File List dialog box.
12. Click OK.
See also
Modify a connection using AutoDefaults (page 43)

4.2 Modify a connection using AutoDefaults
When you use a connection that you are unfamiliar with, first use the default
properties. Then use AutoDefaults to modify the properties.
1.

Double-click a connection symbol in the model to open the connection
dialog box.

2.

On the General tab, select a rule group from the AutoDefaults rule
group list.

3.

On all tabs, select the AutoDefaults options marked with the arrow symbol
for the properties in which you want to use AutoDefaults.

4.

Click Apply.
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If you manually modify the properties after using AutoDefaults, Tekla
Structures uses the manually modified properties.
For example, you have manually set the base plate thickness of a connection
to 20 mm. AutoDefaults is active and sets the plate thickness according to the
main part profile. If you modify the main part profile, Tekla Structures does not
update the base plate thickness. It remains at 20 mm.
NOTE You can view which AutoDefault rules and properties are used:
•

To view AutoDefaults rules, select the connection symbol in the model,
right-click and select Inquire.
Tekla Structures shows the rule group, rule sets and properties files used.

•

To view the AutoDefaults properties, double-click the connection symbol in
the model, select <AutoDefaults> in the list box next to the Load button
and click Load.

See also
AutoDefaults settings (page 38)
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5

AutoConnection and
AutoDefaults rules

You can create your own AutoConnection and AutoDefaults rules for project
and company defaults. By defining rules you can accurately select connections
and connection properties when using AutoConnection and AutoDefaults.
General rules
•

Profile name is the name in the profile catalog.

•

Profile type
Profile type

Number

I

1

L

2

Z

3

U

4

Plate

5

Round bar

6

Pipe

7

Square pipe

8

C

9

T

10

ZZ

15

CC

16

CW

17

Polygon plate
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•

Number of secondary parts

•

Number of main parts

•

Material name
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Orientation rules
Depending on the relative angle of a beam, the connections can be classified
as sloped, skewed, or cant. The angle value can be between - 90 and 90
degrees.
•

Sloped angle (relative to main part cross section)
The longitudinal axis of the secondary part follows the slope of the
longitudinal axis of the main part.

•

Skewed angle (relative to main part longitudinal axis)
The longitudinal axis of the secondary part is skewed according to the main
part cross section. The angle is the smaller of the angles between the
longitudinal axis of the secondary part and the main part Z or Y axis.

•

Cant angle
For rotated secondary parts

Dimension rules
•

Profile depth

•

Web depth
For profiles with an upper and lower flange, the web depth is: h-t1t2-2*r1
Or, if t2 is zero: h-2*t-2*r1
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For profiles with one flange, the web depth is h-t-r1-r2.

•

Web thickness

•

Flange thickness

Forces and strengths
•

Shear force

•

Axial force

•

Bending moment

See also
Combining and iterating properties for AutoDefaults (page 47)
AutoDefaults example: Using iteration with connection check (page 49)
Using reaction forces and UDLs in AutoDefaults and AutoConnection
(page 51)

5.1 Combining and iterating properties for AutoDefaults
Combining properties
You can save properties files that cover different groups of properties and use
these files to define many rules. For example, you can have one file for bolt
properties and another for profile properties. AutoDefaults combines the
separate files into one file. This means that you can define fewer files because
you can use one file for several rules. If the files contain different values for
the same property, Tekla Structures uses the last property it finds, see the
example image below.
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Iterating properties
Tekla Structures tests the properties until the connection symbol is yellow or
green. Iteration changes the properties automatically if the connection is not
created successfully, even if the rules match. If connection check is active, the
iteration results in properties that have passed the check.
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Limitations
•

Tekla Structures cannot iterate property files directly. Use a single iteration
rule set with sub-rule sets.

•

You cannot have many parallel iteration rule sets. Use a single iteration rule
set and place it just before the default rule set.

•

Place the combination rule sets above the iteration rule set in the
AutoDefaults tree structure.

•

Combination rule sets can only be one level deep.

•

Tekla Structures disregards empty rule sets, so include at least one rule in
each rule set.

See also
Create a rule set for AutoDefaults (page 41)

5.2 AutoDefaults example: Using iteration with
connection check
You can use the connection check result when using AutoDefaults with
iteration. If an iteration rule matches, but the connection does not pass the
connection check and the connection symbol remains red, AutoDefaults
continues testing other rules and properties until the connection symbol is
green.
In this example, you will create iteration rules to set the number of bolts
according to the result of the connection check. After this, you will use the
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rules group and connection check together for a connection. The example
image below shows the rules in the AutoDefaults Setup dialog box.

To create iteration rules for use with connection check:
1.

On the File menu, click Catalogs --> AutoDefaults settings.

2.

Right-click the tree and select New Rule Group.

3.

Click the new rule group and rename it to Iteration example.

4.

Browse the Iteration example tree to find End plate (144), right-click
it, and select Create Additional Rule Sets.

5.

Right-click the New rule set and select Edit Rule Set.

6.

Change the rule set name to ITERATION.

7.

Set the Parameter file(s) selection in rule set option to Iterate until
connection symbol is green.

8.

Click OK.

9.

Right-click the ITERATION rule set and select Create Additional Rule
Sets.

10. Right-click the New rule set and select Edit Rule Set.
11. Change the rule set name to 2 bolts.
12. Select the rule Secondary 1 depth and set the minimum and maximum
depth values for two bolts.
13. Set the Parameter file(s) selection in rule set option to Use
combination of first parameters.
14. Click OK.
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15. Right-click the connection properties file standard.j144 under 2 bolts
and select Select Connection Parameters.
16. Select a properties file for two bolts in the Attribute File List and click
OK.
TIP If there is no suitable properties file, you can create a new file. Rightclick the standard.j144 file and select Edit Connection
Parameters. Save the needed properties and click Cancel to close
the dialog box. The saved properties are now available in the
Attribute File List.
17. Click Apply to have the changes available in the connection dialog box.
18. Repeat steps 9 to 16 for other rule sets.
19. Open the End plate (144) dialog box.
20. Select <Defaults> from the list next to the Load button and click Load.
21. On the General tab, set the AutoDefaults rule group option to the
Iteration example you created.
22. On the Design type tab, set the Check connection option to Yes.
23. Enter the load from secondary members in the Shear, Tension, and
Moment options.
24. Click OK.
See also
AutoDefaults settings (page 38)
Combining and iterating properties for AutoDefaults (page 47)

5.3 Using reaction forces and UDLs in AutoDefaults and
AutoConnection
You can set reaction forces for AutoConnection and AutoDefaults in the userdefined attributes of a part, and for AutoDefaults also on the Design tab in the
connection dialog box.
Reaction forces
When you use reaction forces in a rule and AutoDefaults is activated, Tekla
Structures first searches for reaction forces in the corresponding connection’s
properties. If the properties do not contain reaction forces, Tekla Structures
searches the user-defined attributes of the secondary part of the connection.
If Tekla Structures does not find forces there, you cannot use reaction force
rules.
Shear force calculation
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If you have not given any reaction force values, shear force is calculated using
the UDL (uniformly distributed load) shear force routine. The UDL calculation
is mainly intended for use with imperial units. It uses the yield stress value,
profile dimensions, and UDL percentage to calculate the maximum shear force
allowed.
•

Yield stress is defined in the material catalog.

•

Profile dimensions come from the profile catalog.

•

UDL percentage is taken either from the connection dialog box or from an
advanced option.

Tekla Structures compares the result with the shear force rule in AutoDefaults.
To use UDLs for AutoConnection and AutoDefaults:
To

Do this

Use UDL for
1.
AutoConnectio
n
2.

On the Design tab in the connection dialog box, set the
UDL option to Yes.
Enter the UDL percentage in the UDL% box.
If you do not enter any value, Tekla Structures uses a
default percentage set with the
XS_AUTODEFAULT_UDL_PERCENT advanced option.

Use UDL for
AutoDefaults

1.

On the Design tab in the connection dialog box, set the
Use UDL option to Yes.

2.

Enter the UDL percentage in the UDL % box.
If you do not enter any value, Tekla Structures uses a
default percentage set using the
XS_AUTODEFAULT_UDL_PERCENT advanced option.
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Disclaimer

© 2016 Trimble Solutions Corporation and its licensors. All rights reserved.
This Software Manual has been developed for use with the referenced
Software. Use of the Software, and use of this Software Manual are governed
by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other
warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the Software.
All information set forth in this manual is provided with the warranty set forth
in the License Agreement. Please refer to the License Agreement for important
obligations and applicable limitations and restrictions on your rights. Trimble
does not guarantee that the text is free of technical inaccuracies or
typographical errors. Trimble reserves the right to make changes and
additions to this manual due to changes in the software or otherwise.
In addition, this Software Manual is protected by copyright law and by
international treaties. Unauthorized reproduction, display, modification, or
distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.
Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve,
Fastrak and Orion are either registered trademarks or trademarks of Trimble
Solutions Corporation in the European Union, the United States, and/or other
countries. More about Trimble Solutions trademarks: http://www.tekla.com/
tekla-trademarks. Trimble is a registered trademark or trademark of Trimble
Navigation Limited in the European Union, in the United States and/or other
countries. More about Trimble trademarks: http://www.trimble.com/
trademarks.aspx. Other product and company names mentioned in this
Manual are or may be trademarks of their respective owners. By referring to a
third-party product or brand, Trimble does not intend to suggest an affiliation
with or endorsement by such third party and disclaims any such affiliation or
endorsement, except where otherwise expressly stated.
Portions of this software:
D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights
reserved.
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EPM toolkit © 1995-2004 EPM Technology a.s., Oslo, Norway. All rights
reserved.
Open CASCADE Technology © 2001-2014 Open CASCADE SA. All rights
reserved.
FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.
Teigha © 2003-2014 Open Design Alliance. All rights reserved.
PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.
FlexNet Copyright © 2014 Flexera Software LLC. All Rights Reserved.
This product contains proprietary and confidential technology, information
and creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission of
such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited.
Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or
rights under any Flexera Software LLC intellectual property rights, whether by
estoppel, implication, or otherwise.
To see the third party licenses, go to Tekla Structures, click File menu --> Help
--> About Tekla Structures and then click the 3rd party licenses option.
The elements of the software described in this Manual are protected by
several patents and possibly pending patent applications in the United States
and/or other countries. For more information go to page http://
www.tekla.com/tekla-patents.
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