Contents

1 Components........................................................................................................... 5
   1.1 Component properties................................................................................... 6
   1.2 Add a component to a model..................................................................... 8
   1.3 View a component in a model.................................................................. 10
   1.4 How to use the Applications & components catalog............................ 11
      Groups in the catalog................................................................................... 12
      Search for a component in the catalog......................................................... 12
      Change the view in the catalog.................................................................... 13
      Show selected components in the catalog................................................... 13
      View and modify component information in the catalog............................. 14
      Add a thumbnail image for a component in the catalog............................. 14
      Create and modify groups in the catalog...................................................... 14
      Change the order of groups in the catalog................................................... 15
      Hide groups and components in the catalog.............................................. 17
      Show the catalog message log..................................................................... 17
      Catalog definitions....................................................................................... 17
   1.5 Steel component example: Add an end plate using the End plate (144) connection.......................... 17
   1.6 Steel component example: Add a base plate and anchor rods using the Base plate (1004) detail................................. 18
   1.7 Steel component example: Add a beam-to-column connection using the Column with stiffeners (186) connection ........................................... 19
   1.8 Concrete component example: Add a corbel connection using the Corbel connection (14) connection............................... 20
   1.9 Reinforcement component example: Add a pad footing reinforcement using the Pad footing reinforcement (77) detailing system component........................................... 21
   1.10 Component tips......................................................................................... 22
   1.11 Converting a conceptual or a detailed component............................... 23

2 Applications....................................................................................................... 25
   2.1 Working with applications........................................................................ 27
   2.2 Import a .tsep extension to the Applications & components catalog...... 31
   2.3 Publish a group in the Applications & components catalog.................. 32

3 AutoConnection................................................................................................ 35
   3.1 AutoConnection settings......................................................................... 35
      Create a rule group for AutoConnection......................................................... 37
      Create a rule set for AutoConnection............................................................ 38
      Change a connection in an AutoConnection rule set................................. 39
Components

Components are tools that you can use to connect parts in the model. Components automate tasks and group objects so that Tekla Structures treats them as a single unit. You can save the properties of a component and use them in other projects.

Components adapt to changes in the model, which means that Tekla Structures automatically modifies a component if you modify the parts it connects. When you copy or move objects, Tekla Structures automatically copies or moves all the associated components with the objects.

All components are stored in the Applications & components catalog. Click the Applications & components button in the side pane to open the Applications & components catalog.

System components

Tekla Structures contains a wide range of predefined system components by default. There are three types of system components:

- **Connection** components connect two or more parts, and create all the required objects such as cuts, fittings, parts, bolts, and welds.
  
  For example, end plates, clip angles, and bolted gussets are connections.

  In the Applications & components catalog, the connection symbol is 🔄.

- **Detail** components add a detail or a reinforcement to the main part. A detail is only connected to one part.
  
  For example, stiffeners, base plates, and lifting hooks are steel details, and beam reinforcement and pad footing reinforcement are concrete details.

  In the Applications & components catalog, the detail symbol is 🏷.

- **Detailing** components automatically create and assemble the parts to build a structure, but do not connect the structure to existing parts.
  
  For example, stairs, frames, and towers are detailing components.
In the **Applications & components** catalog, the detailing symbol is ![symbol]. You can also create your own components, custom components if you do not find a system component that suits your needs. You can use custom components in the same way as system components.

**See also**

- Component properties (page 6)
- Add a component to a model (page 8)
- How to use the Applications & components catalog (page 11)

### 1.1 Component properties

Each component has a dialog box where you can define the properties of the component. You can open the dialog box by double-clicking the component in the **Applications & components** catalog.

The image below shows a typical example of a steel connection, the **Two sided clip angle (143)** connection. Concrete and reinforcement component dialog boxes may have different options.
In the upper part of the dialog box, you can save and load predefined settings. Some components have buttons for accessing bolts, welds and DSTV properties.

When modifying connections and details, you can select whether Tekla Structures ignores other types of connections and details, or modifies all selected connections and details irrespective of their type. With the modify option, the type of the selected components is changed to match the type of the component you are modifying.

For more information, see Save and load dialog box properties.

On the tabs, you can define the properties of the parts and bolts that the component creates. You can enter values manually, use system default values, AutoDefaults values, automatic values, or for some steel connections, the values in the joints.def file.

Manually entered values, AutoDefaults, automatic values and the properties defined in the joints.def file all override the system defaults. System default values are used if you do not manually enter a value or select any other type of property value. You cannot change the system default values.

For more information on joints.def, see Joints.def file.

If you select an AutoDefaults option, Tekla Structures uses the property defined in the AutoDefaults rules.

The image in the AutoDefaults option is an example and does not necessarily match the outcome in the model.

For more information on AutoDefaults, see AutoDefaults (page 41).

If you select an automatic option, Tekla Structures automatically determines which option to use for a property.

For example, when you use the automatic option for the stiffener in End plate (144), the connection automatically adds the stiffener to a beam-to-column connection, but does not add it to a beam-to-beam connection.

For more information on AutoConnection, see AutoConnection (page 35).

The parts that are yellow in the component dialog box are created by the component.

The parts that are blue in the component dialog box should already exist in the model before you create the component.

Up direction indicates how the connection is rotated around the secondary part, relative to the current work plane. The symbol on the Picture tab of the component dialog box indicates the correct up direction.
If there are no secondary parts, Tekla Structures rotates the connection around the main part. The options are: \( +x, -x, +y, -y, +z, -z \).

You can change the default up direction on the General tab of the component dialog box. Try changing the positive directions first.

**See also**

Add a component to a model (page 8)

1.2 Add a component to a model

When you add a component to a model, you either attach the component to existing parts in the model, or pick positions to indicate the location or length of the component.

Connections and details have a main part that you select first. Connections also have one or more secondary parts that you select after you have selected the main part. Detailing components do not always have a main part and secondary parts. Instead, they automatically create and assemble the parts to build a structure when you pick a position in the model.

If you use a component you are unfamiliar with, use the default properties of the component. Then check what needs to be modified, and modify only few properties at a time to see how the modifications affect the component. This is quicker than trying to set all the component properties before seeing what the component actually creates.

Tekla Structures opens a command prompt when you add a component. Do not close the prompt window, because it displays information on adding the component. This information can be useful in problem situations.

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
   You can also press Ctrl + F.
2. Select a component and do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Add a connection | 1. Select the main part.  
2. Select the secondary part or parts.  
   • If there is one secondary part, the connection is automatically created when you select the secondary part.  
   • If there are several secondary parts, click the middle mouse button to finish selecting the parts and to create the connection. |
To

Do this

In the example image below, the numbers from 1 to 4 show the selection order of parts. The blue parts should already exist in the model before you create the component.

Add a detail

1. Select the main part.
2. Pick a position in the main part to determine the location of the detail.

Add a detailing component

Pick one to three positions to determine the location of the objects that the detailing component creates.

Component status

When you have added the component, Tekla Structures shows the component status using the symbols shown in the table below. Double-click the symbol to open the component properties.

<table>
<thead>
<tr>
<th>Color</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Green Symbol" /></td>
<td>The green symbol shows that the component was created successfully.</td>
</tr>
<tr>
<td><img src="image" alt="Detailing Component Symbol" /></td>
<td>The detailing component symbol in the model is 🔄.</td>
</tr>
</tbody>
</table>

Components 9 Add a component to a model
<table>
<thead>
<tr>
<th>Color</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Yellow Symbol]</td>
<td>The yellow symbol shows that the component was created, but has problems. This often occurs when bolts or holes have an edge distance that is less than the default value.</td>
</tr>
<tr>
<td>![Red Symbol]</td>
<td>The red symbol shows that the component was not created. Common reasons are that the properties are incorrect or that the up direction is not appropriate.</td>
</tr>
</tbody>
</table>

**See also**

- Component properties (page 6)
- View a component in a model (page 10)

### 1.3 View a component in a model

You can create several views of a component to view it from different viewpoints.

1. Click the component symbol in the model to select the component.
2. Right-click and select **Create View --> Default Views of Component**.

   Tekla Structures creates four views: front, end, top, and perspective. The example image shows the default views of the **End plate (144)** connection.
NOTE You can check the dimensions, such as bolt locations and edge distances, using the Measure tool in the Component front view.

1.4 How to use the Applications & components catalog
Components are stored in the Applications & components catalog and organized into two different types of groups: default groups are automatically available and predefined groups depend on your environment.

Click the Applications & components button in the side pane to open the Applications & components catalog. You can also press Ctrl + F.

To use a component (page 8), select it in the catalog and follow the instructions on the status bar to add the component to the model. Double-click the component in the catalog to open the component properties (page 6) dialog box.
Groups in the catalog
Default groups and predefined groups are shown against different background color in the catalog.

Default groups are automatically available:

- **Recent** contains the 12 components and applications that have most recently been used in the model.
- **Ungrouped items** contains the components and applications that are not in any predefined group.
  Ungrouped items can be, for example, imported components that have not been moved to any other group yet.
- **Applications** contains applications (page 25), macros and drawing plugins.
  If you create your own macros, you can add them to this group.
- **Connections** contains connections and seams.
- **Detailing** contains detailing components.
- **Details** contains details.
- **Parts** contains custom parts.
- **Legacy catalog** shows the folder structure of the Component Catalog used in previous Tekla Structures versions if the catalog definition files are found in the standard folder search paths.

Depending on your environment, the catalog may also contain predefined groups for specific usage, such as **Steel > Beam to beam connections**. You can create your own groups according to your needs, for example, for your own favorite connections. This way you can find these connections fast and easily. You can also hide the groups that you are not using so that only the groups you use are visible in the catalog.

Model-specific components are shown in the modeling mode and drawing-specific components are shown in the drawing mode.

Search for a component in the catalog
To search for a component in the catalog, enter the search term in the search box. The search is case-insensitive.

Note that the search does not find catalog content that has been hidden. Select the **Show hidden items** check box to show the hidden content.

The search uses the following rules:
• Non-numeric search terms find partial matches, for example, bolt shows both bolt and bolted in the search result.

If you have more than one word in the search term, for example bolt plate, the words are automatically combined so that the search result shows the components that contain both bolt and plate in their name, description, or tags.

• Numeric (integer) search terms find the exact match, for example, 121 shows component number 121 in the search result.

You can use the *, ?, and [ ] wildcards to search for partial numeric matches. For example, 10* finds components number 10, 110, 104, 1040, and so on.

• You can restrict the search to specific tags, groups and types of components by using the keywords tag, group, or type. For example, 10 tag:advanced finds the number 10 components that have advanced in the tag, and type:custom finds all custom components.

Change the view in the catalog

• Click to show the thumbnail view.

• Click to show the list view.

• Click to show the compact view.

  The compact view shows the thumbnail images of the group that you select from the list above the search box. You can use the compact view to have more space on the screen.

• Click to show the normal view.

Show selected components in the catalog

Click Show selected to show a Selected components group that contains the components that are selected in the model or in the drawing.

Click Show selected again to hide the Selected components group.

The Show selected button is not available when you are using the search in the catalog.
**View and modify component information in the catalog**

Each component has an information box that shows the type of the component and the groups the component belongs to. You can add a description for the component and tags that can be used in the search.

1. Select a component and click the small arrow on the right to open the component information box.
2. Type a description in the **Description** box.
3. Click + to add a tag and enter a tag in the box.
4. If needed, click + again to add more tags. You can also remove tags.
5. Click outside the information box to close it.

The descriptions and tags that you add are by default saved in the `ComponentCatalog.xml` file in the model folder.

**Add a thumbnail image for a component in the catalog**

Components have a default thumbnail image that shows a typical situation where the component can be used. You can add several thumbnails for a component and select which thumbnail is shown in the thumbnail view in the Applications & components catalog.

1. Select a component in the catalog.
2. Right-click and select **Thumbnails**.
3. Click **Add thumbnail**.
4. Select an image and click **Open**. You can use any standard image format, for example, `.png`, `.jpeg`, `.gif`, `.tiff`, and `.bmp`.
5. Select the check boxes of the thumbnails that you want to show in the component information box. You can also remove thumbnails, except for the default thumbnail.
6. Click **Close**.

The thumbnail information that you add is by default saved in the `ComponentCatalog.xml` file in the model folder.

**Create and modify groups in the catalog**

You can create groups and subgroups, and move groups to different locations in the predefined groups section in the catalog. You can add and remove components from the groups, rename the groups, and add descriptions for the groups.
To | Do this
---|---
Create a group | Right-click in the catalog and select **New group**. Drag the group to the desired location.
Create a subgroup | Right-click a group in the catalog and select **New group**.
Name a group | Right-click a group, select **Rename** and type the name.
Add components to the group | - Select components in the catalog and drag them to another group.
- Select components in the catalog, right-click and select **Add to group**. Then select the group to which the components are added.
- Right-click a group, select **Add all to group** and select the group to which all the components in the group are added.
   Note that the components are copied, not moved, to the other groups.
Remove a group | Right-click a group and select **Remove from group**.

The groups that you create are by default saved in the **ComponentCatalog.xml** file in the model folder.

**NOTE**  You cannot add or remove groups in the default groups, and you cannot modify the content of the default groups. However, you can hide the default groups and the individual items in the groups.

**Change the order of groups in the catalog**
You can change the order of the predefined groups in the **Applications & component** catalog. Predefined groups depend on your environment, for example, **Steel** and **Concrete** can be such groups. Note that you cannot change the order of the default groups, for example, **Applications**, **Connections**, and **Detailing**.
You can control the order with a sort index. The **Sort index** option is available in the group information of each predefined group in the **Applications & components** catalog. Sort indexes are saved in the catalog definition files.

You can change the sort index by entering either a negative or a positive integer number, or 0, in the **Sort index** option box. A negative sort index moves a group towards the top and a positive sort index moves a group towards the bottom in the predefined groups section. Enter 0 or clear the value to revert to the default order. By default, the groups are in alphabetical order.

The sort index changes you make are model specific and they are saved in the `ComponentCatalog.xml` file in the `\model` folder. Administrators can define the order of groups for an environment or a project using the catalog definition files in the environment, firm and project folders. Do not edit these files if you are not an administrator.

Note that even if administrators have defined the order, you can still make model-specific changes to the order of the groups by entering a different sort index value for a group. If you need to revert to the default order, enter 0 as the sort index.

To change the order:

1. Select a predefined group.
2. Click the small arrow on the right to open the group information box.
3. Enter a number in the **Sort index** box.
   
   The group is immediately moved.
4. Save the model to keep the order.
Hide groups and components in the catalog
1. Select a group or a component in the catalog.
2. Right-click and select **Hide / Unhide** to hide the group or the component.
3. To view the hidden group or component again, select the **Show hidden items** check box at the bottom of the catalog. The hidden group or component is shown as dimmed.
4. To show the hidden group or component normally, right-click it and select **Hide / Unhide**.

Show the catalog message log
If there are errors or warnings, for example, in the catalog definition files, the **Display message log** button is shown in the lower right corner in the catalog. The button is not shown if there are no errors or warnings.

To view the error log, click the **Display message log** button.

Errors and warnings are also written to the ComponentCatalog_<user>.log file in the \logs folder under the model folder.

Catalog definitions
The commands in **Access advanced features > Catalog management** are used for modifying catalog definitions. Generally, there is no need to modify catalog definitions. Do not modify the definition files if you are not an administrator. For more information on administrator tasks, see **Applications & components catalog for administrators**.

1.5 Steel component example: Add an end plate using the End plate (144) connection
In this example, you will connect a beam to a column using an end plate connection. **End plate (144)** connects two beams, or a beam to a column, using a bolted end plate.

1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.
2. Type 144 in the search box.
3. Double-click **End plate (144)** to open the component properties.
4. Click **Apply** to add the component using the default properties.
5. Select the main part (column).
6. Select the secondary part (beam).
   Tekla Structures automatically adds the connection when you select the beam.

See also
Add a component to a model (page 8)

1.6 Steel component example: Add a base plate and anchor rods using the Base plate (1004) detail
In this example, you will add a base plate detail and anchor rods to a column.

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. Enter base plate in the search box.
   To view the thumbnail images of the components in the search results click .
3. Select Base plate (1004).
4. Select the column.
5. Pick a position at the base of the column.
   Tekla Structures automatically adds the base plate when you pick the position.
6. Next, modify the anchor rod dimensions.
   a. Switch on the Select components switch to more easily select components.
b. Double-click the component symbol in the model to open the **Base plate (1004)** component dialog box.

c. Go to the **Anchor rods** tab.

d. Change the dimensions of the anchor rods.

e. To change only this base plate, select **ignore other types** from the list in the top part of the dialog box.

![Anchor rods dialog box](image)

f. Click **Modify**.

---

**See also**

*Add a component to a model (page 8)*

---

### 1.7 Steel component example: Add a beam-to-column connection using the Column with stiffeners (186) connection

In this example, you will connect a beam to a column using a beam-to-column connection.

1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.
2. Enter **186** in the search box.
3. Select **Column with stiffeners (186)**.
4. Select the main part (column).
5. Select the secondary part (beam).
Tekla Structures automatically adds the connection when you select the beam.

See also
Add a component to a model (page 8)

1.8 Concrete component example: Add a corbel connection using the Corbel connection (14) connection

In this example, you will add a corbel connection between a column and a beam.

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. Enter corbel in the search box.
3. Select Corbel connection (14).
4. Select the main part (column).
5. Select the secondary part (beam).
Tekla Structures automatically adds the corbel connection between the column and the beam when you select the beam.

See also
Add a component to a model (page 8)

1.9 Reinforcement component example: Add a pad footing reinforcement using the Pad footing reinforcement (77) detailing system component

In this example, you will reinforce a concrete pad footing.

1. Create a pad footing.

2. Click the Applications & components button in the side pane to open the Applications & components catalog.

3. Enter pad footing in the search box.

4. Select Pad footing reinforcement (77).

5. Select the pad footing.
Tekla Structures inserts the lacer bar and bottom reinforcement in the pad footing.

See also
Add a component to a model (page 8)

1.10 Component tips

Default properties
If you use a component you are unfamiliar with, use the default properties of the component. Then check what needs to be modified, and modify only few properties at a time to see how the modifications affect the component. This is quicker than trying to set all the component properties before seeing what the component actually creates.

Valid profiles
Some components work with certain profiles only. If a component is not created successfully, try entering a valid profile.

Select components switch
You can switch on the Select components switch to be able to select any object that belongs to the component.
Component is not added to the model

If the component is not added to the model, check the status bar. For example, you may need to click the middle mouse button to stop selecting parts before Tekla Structures creates the component.

Using thickness to create needed parts

If a component does not by default create the parts that you need, look for options to create them. If there are no options, try entering a thickness value for the parts.

If a component creates parts that you do not need, look for options to remove them. If there are no options, enter a zero (0) as the thickness of the parts.

Many secondary parts are found

If you are using a connection that only allows one secondary part, you may see the message Many parts found on the status bar. This means that Tekla Structures cannot determine which parts to connect. You may have several parts in the same location, or the view may be set too deep.

1.11 Converting a conceptual or a detailed component

Depending on the Tekla Structures configuration you are using, you can create either detailed or conceptual components.

• Detailed components include all the information needed for fabrication, such as assemblies, cast units, and reinforcing bars.

  Detailed components have a round symbol in the model: 🌳 or 🎨.

• Conceptual components look similar to detailed components but do not include the option to change part numbering or assembly numbering settings. Conceptual components are meant to be used as reference information for further fabrication detailing.

  Conceptual components have a rectangular symbol in the model: 🌲 or 🎨.

You can create conceptual components in the Engineering, Rebar Detailing, and Construction Modeling configurations.
You can edit conceptual components and convert them to detailed components in the Full, Primary, Steel Detailing, or Precast Concrete Detailing configurations.

Modifying part properties, such as the size of the component main part, does not automatically convert a detailed component to a conceptual component, or vice versa. For example, if you use the Engineering configuration and modify the model, detailed components are not converted to conceptual components. However, when you modify a detailed component in the Rebar Detailing configuration, the component changes to a conceptual component.

You can convert components in the Applications & components catalog. Click

the Applications & components button in the side pane to open the Applications & components catalog.

Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
<th>Configuration</th>
</tr>
</thead>
</table>
| Convert a conceptual component to a detailed component | 1. Click > Convert to detailing component.  
2. Select the component symbol. | Full, Primary, Steel Detailing, Precast Concrete Detailing |
| Convert a detailed component to a conceptual component | 1. Click >Convert to conceptual component.  
2. Select the component symbol. | Engineering, Construction Modeling, Rebar Detailing |
All available applications, macros, and drawing plugins are located in the section **Applications** of the **Applications & components** catalog. You can also record macros of your own and show them on the list.

**Macros**

*Macro types of applications (page 27)* are saved as .cs files in the \drawings or \modeling folder under the folder that has been defined with the advanced option XS_MACRO_DIRECTORY. By default, this advanced option is set to ..\ProgramData\Tekla Structures\<version>\environments \common\macros.

In addition to this global folder, you can create a local folder and save your own macros there. To use the local macros, you need to specify the local macro folder for the advanced option XS_MACRO_DIRECTORY in addition to the global folder.

**Available macros in the modeling mode**

<table>
<thead>
<tr>
<th>Macro</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AutoConnectSelectedParts (page 39)</td>
<td>Use to automatically create connections without opening the <strong>AutoConnection</strong> dialog box.</td>
</tr>
<tr>
<td>AutomaticSplicingTool</td>
<td>Use to split long reinforcing bars and bar groups that exceed the stock length, and create splices in split locations.</td>
</tr>
<tr>
<td>ContinuousBeamReinforcement</td>
<td>Use to reinforce a continuous beam. The macro creates main top and bottom bars, stirrups, fittings, and additional top and bottom bars using system components.</td>
</tr>
<tr>
<td>Convert_DSTV2DXF</td>
<td>Use to create NC files in DXF format by converting DSTV files to DXF files.</td>
</tr>
<tr>
<td>Macro</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>CreateSurfaceView</td>
<td>Use to create an automatically aligned surface view.</td>
</tr>
<tr>
<td>CreateSurfaceView_wEdge</td>
<td>Use to create a surface view and align the work plane along the edge you</td>
</tr>
<tr>
<td></td>
<td>select.</td>
</tr>
<tr>
<td>DesignGroupNumbering</td>
<td>Use to number parts by design groups so that you can differentiate the</td>
</tr>
<tr>
<td></td>
<td>parts from each other in drawings and reports.</td>
</tr>
<tr>
<td>DirectoryBrowser</td>
<td>Use to find and modify the location of the various Tekla Structures files</td>
</tr>
<tr>
<td></td>
<td>and folders, and customize user settings.</td>
</tr>
<tr>
<td>RebarClassificator</td>
<td>Use to classify the reinforcing bars and reinforcement meshes by their</td>
</tr>
<tr>
<td></td>
<td>order of depth in concrete slabs and panels.</td>
</tr>
<tr>
<td>RebarSeqNumbering</td>
<td>Use to assign cast unit specific running numbers (1, 2, 3...) to the</td>
</tr>
<tr>
<td></td>
<td>reinforcement in the model.</td>
</tr>
<tr>
<td>RebarSplitAndCoupler</td>
<td>Use to split a reinforcing bar group and add couplers in relation to the</td>
</tr>
<tr>
<td></td>
<td>direction of the picked points.</td>
</tr>
<tr>
<td>UpdateRebarAttributes</td>
<td>Use to manage the user-defined attributes (UDAs) of the couplers and the</td>
</tr>
<tr>
<td></td>
<td>end anchor parts created by Rebar Coupler and Anchor Tools.</td>
</tr>
</tbody>
</table>

**Available macros in the drawing mode**

<table>
<thead>
<tr>
<th>Macro</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AddSurfaceSymbols</td>
<td>Use to add surface treatment symbols in cast unit drawings.</td>
</tr>
<tr>
<td>Copy with offsets (Drawing tools)</td>
<td>Use to copy lines, circles, polylines, polygons and rectangles with offsets.</td>
</tr>
<tr>
<td>Create fillets (Drawing tools)</td>
<td>Use to connect two intersecting lines by extending the two selected lines to</td>
</tr>
<tr>
<td></td>
<td>their intersection point.</td>
</tr>
<tr>
<td>Create chamfers (Drawing tools)</td>
<td>Use to create chamfers between two lines using the distance that you specify.</td>
</tr>
<tr>
<td>Manage cut lines (Drawing tools)</td>
<td>Use to create lines that are displayed with a zigzag or a dash-and-dot in</td>
</tr>
<tr>
<td>Macro</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>different colors to show that the line</td>
<td>different colors to show that the line is partially outside the view border.</td>
</tr>
<tr>
<td>is partially outside the view border.</td>
<td></td>
</tr>
<tr>
<td>Create moment connection symbols</td>
<td>Use to create moment connection symbols to show the beams that are</td>
</tr>
<tr>
<td>(Drawing tools)</td>
<td>connected to columns with rigid connections.</td>
</tr>
<tr>
<td>ExaggerateSelectedDimensions</td>
<td>Use to exaggerate narrow dimensions to make them easier to read.</td>
</tr>
<tr>
<td>RebarLayeringMarker</td>
<td>Use to mark reinforcing bar layers with different marking styles and line</td>
</tr>
<tr>
<td>RebarLayeringMarker</td>
<td>types in a drawing.</td>
</tr>
<tr>
<td>RebarMeshViewCreator</td>
<td>Use to create drawing views each containing one reinforcement mesh.</td>
</tr>
<tr>
<td>RemoveChangeClouds</td>
<td>Use to remove dimension change symbols, mark change symbols and</td>
</tr>
<tr>
<td></td>
<td>associative note change symbols in one go from an open drawing.</td>
</tr>
</tbody>
</table>

**Extensions (.tsep)**

You can download Tekla Structures extensions that have the `.tsep` file extension from Tekla Warehouse and import (page 31) these extensions to the Applications & components catalog. When you restart Tekla Structures, the imported extensions are installed and added to the Ungrouped items group in the catalog. You can move them to a suitable group.

**Publish groups in the Applications & components catalog**

You can collect content to a group that you create in the Applications & components catalog. You can then publish the group (page 32) as a catalog definition file to make it available for other Tekla Structures users.

### 2.1 Working with applications

You can run, add, edit, rename, save as and delete applications, macros and plugins in the Applications section of Applications and Components catalog. You can also record and edit macros.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record a macro</td>
<td>1. Click the Applications &amp; components button in the side pane to open</td>
</tr>
<tr>
<td></td>
<td>the Applications &amp; components catalog.</td>
</tr>
<tr>
<td>To</td>
<td>Do this</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>1. Click the Applications &amp; components button in the side pane to open the Applications &amp; components catalog.</td>
<td><strong>Create a macro file and add contents later</strong></td>
</tr>
<tr>
<td>2. Click the Access advanced features button and then click New macro &gt; Global or Local depending on whether you want to save the macro in the global or local macros folder.</td>
<td>The Local command is only available if you have defined a location for the local macros using the advanced option XS_MACRO_DIRECTORY.</td>
</tr>
<tr>
<td>The recorded macro is saved under global or local macros in the macros\drawings or macros\modeling folder depending on the mode (drawing or modeling) you were using while you were recording the macro.</td>
<td></td>
</tr>
<tr>
<td>3. Enter a name for the macro in the Macro name box.</td>
<td></td>
</tr>
<tr>
<td>4. Click OK and perform the actions you want to record.</td>
<td></td>
</tr>
<tr>
<td>5. Click Stop recoding to stop recording.</td>
<td></td>
</tr>
<tr>
<td>To</td>
<td>Do this</td>
</tr>
<tr>
<td>----</td>
<td>---------</td>
</tr>
<tr>
<td>3.</td>
<td>Enter a name for the macro in the <strong>Macro name</strong> box.</td>
</tr>
<tr>
<td>4.</td>
<td>Click <strong>OK</strong>. This creates an empty macro file that is displayed in the <strong>Applications</strong> list.</td>
</tr>
<tr>
<td>5.</td>
<td>Right-click the empty macro file and select <strong>Edit</strong>.</td>
</tr>
<tr>
<td>6.</td>
<td>Add the macro content, for example, by copying commands from other macro files and save the file.</td>
</tr>
<tr>
<td>View or edit a macro</td>
<td>1. Click the <strong>Applications &amp; components</strong> button in the side pane to open the <strong>Applications &amp; components</strong> catalog.</td>
</tr>
<tr>
<td></td>
<td>2. Click the arrow next to <strong>Applications</strong> to open the applications list.</td>
</tr>
<tr>
<td></td>
<td>3. Right-click the macro you want to edit and click <strong>Edit</strong>. The macro can be opened in any text editor.</td>
</tr>
<tr>
<td></td>
<td>4. If needed, edit the macro and save the macro file.</td>
</tr>
<tr>
<td>Run an application</td>
<td>1. Click the <strong>Applications &amp; components</strong> button in the side pane to open the <strong>Applications &amp; components</strong> catalog.</td>
</tr>
<tr>
<td></td>
<td>2. Click the arrow next to <strong>Applications</strong> to open the applications list.</td>
</tr>
<tr>
<td></td>
<td>3. Double-click the application you want to run.</td>
</tr>
<tr>
<td>Save an application with another name</td>
<td>1. Click the <strong>Applications &amp; components</strong> button in the side pane to open the <strong>Applications &amp; components</strong> catalog.</td>
</tr>
<tr>
<td>To</td>
<td>Do this</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
</tbody>
</table>
| **To Do this** | **Applications & components** catalog.  
2. Click the arrow next to **Applications** to open the applications list.  
3. Right-click the application that you want to save with another name and click **Save as**.  
4. Enter a new name for the application and click **OK**.  
The application will be added in the list. |
| **Rename an application** | 1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.  
2. Click the arrow next to **Applications** to open the applications list.  
3. Right-click the application you want to rename and click **Rename**.  
4. Enter a new name for the application and click **OK**.  
The name of the application changes. |
| **Delete an application** | 1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.  
2. Click the arrow next to **Applications** to open the applications list.  
3. Right-click the application you want to delete and click **Delete**.  
The application is removed from the list. |
2.2 Import a .tsep extension to the Applications & components catalog

You can import Tekla Structures .tsep extensions (Tekla Structures extension package) to the Applications & components catalog. First download the extension from Tekla Warehouse, and then import it to the catalog.

**NOTE** Some Tekla Structures extensions have an .msi installation file. You have to install these extensions separately. Download the .msi installation file from Tekla Warehouse and double-click the file to run the installation.

1. Click the **Applications & components** button in the side pane to open the Applications & components catalog.

2. Click **Manage extensions > Extension manager**.
   Alternatively, you can open Extension manager from **File menu --> Extend --> Extension manager**.

3. Click the Tekla Warehouse link and log in to Tekla Warehouse with your Trimble Identity.

4. Search for the .tsep extension and click **Download**.

5. Click the downloaded extension in your browser.
   Tekla Structures opens a dialog box that lists the installed Tekla Structures versions that are compatible with the extension.

6. Select the Tekla Structures versions to which you want to import the extension.

7. Click **Import**.
   The extension is shown in **Extension manager** in all the Tekla Structures versions that you selected.
   Alternatively, if you want to import the extension to the current Tekla Structures version only, you can do the import in **Extension manager** after downloading the extension. In **Extension manager**, click **Import** and then double-click the .tsep file.
   You can still remove the extension from **Extension manager** before installing it. Select the extension and click **Cancel**.

8. If needed, repeat steps 4 - 7 to import more Tekla Structures extensions.
9. Restart Tekla Structures to install the imported extension.

10. Open the **Applications & components** catalog.

    The extension is shown in the **Ungrouped items** group in the catalog. You can move the extension to a more suitable group, or create a new group.

You can uninstall an installed extension in **Extension manager**. Select the extension and click **Remove**. The extension is removed when you restart Tekla Structures. Installing and uninstalling an extension creates a log file to `\Tekla Structures\<version>\Extensions\TSEP Logs`.

System administrators can copy multiple `.tsep` extension files to a Tekla Structures user's computer to the `\Tekla Structures\<version>\Extensions\To be installed` folder. The extensions are installed the next time the user restarts Tekla Structures.

**Copy .tsep extensions to a new Tekla Structures version**

When starting to use a new Tekla Structures version, you can use the Migration Wizard tool to copy the installed `.tsep` extensions to the new version. You can open Migration Wizard either from the **Applications & components** catalog, click ➔ **Manage extensions** ➔ **Migrate extensions**, or from **File menu** ➔ **Extend** ➔ **Migrate extensions**. Once copied, the extensions are listed in **Extension manager** in the new Tekla Structures version. Restart Tekla Structures to install the copied extensions.

**See also**

*How to use the Applications & components catalog (page 11)*

### 2.3 Publish a group in the Applications & components catalog

You can collect content, such as macros, extensions, and system and custom components to a group that you create in the **Applications & components** catalog. You can then publish the group as a catalog definition file to make it available for other Tekla Structures users. For the published content to work correctly in another Tekla Structures installation, the content must also exist in that installation.

1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.

2. Create a new group:
   a. Right-click in the catalog and select **New group**.
   b. Enter a name for the group.
c. Select the group and click the small arrow on the right to add a description to the group.

d. **Add content (page 11)** to the group.
   - Some content in the **Applications & components** catalog may be hidden. To publish the hidden content, select the **Show hidden items** check box at the bottom of the catalog.
   - Note that the model-specific items you add to the group are visible in the modeling mode and the drawing-specific items in the drawing mode.

e. **Add the needed information to the items (page 11)** in the group: description, tags, and additional thumbnail images.
   - Use a thumbnail image from the \Tekla Structures\<version>\Bitmaps folder to ensure that the image is available for other Tekla Structures users.

3. Right-click the group and select **Publish group** to create a catalog definition file.
   - The file contains the following information:
     - Name and description of the published group
     - Names and descriptions of the subgroups
     - References to the items that you have added to the group
       - The file does not contain the actual items. When other users use the group, they must ensure that the referenced items exist in their Tekla Structures installation and model.
     - Descriptions, tags and thumbnail references of the items in the group
       - The file does not contain the actual thumbnail image files.

4. Add a unique prefix to the filename in the **Publish group** dialog box.
   - The filename format must be `<prefix>_ComponentCatalog.ac.xml`.

5. Click **Save**.
   - The file is by default saved to the model folder.

6. Make the group available for other Tekla Structures users by placing the `<prefix>_ComponentCatalog.ac.xml` catalog definition file to an appropriate folder:
   - **Project, firm or system folder** defined in XS_PROJECT, XS_FIRM, or XS_SYSTEM.
   - \attributes folder under the current model folder
- **Extensions folder** in `\Tekla Structures\<version>\environments\common\extensions`, or to any of the folders defined in `XS_EXTENSION_DIRECTORY`.

  The **Applications & components** catalog also searches the subfolders of these folders. We recommend that you use the extension folders if you have created your own extensions and have included them in the group.

7. Check that the catalog definition file works correctly:
   a. Delete the published group from your **Applications & components** catalog.
   b. Click > **Catalog management** > **Reload catalog** to load and view the published group.

When you have checked the group, other users can start using it:

- If the group content is already included in other users' Tekla Structures installation, they can use the group immediately after reloading the catalog by clicking > **Catalog management** > **Reload catalog**.
- If the group content, for example extensions, is not included in other users' Tekla Structures installation, they have to download the missing extensions from Tekla Warehouse first, and then re-open the model where they are going to use the group.
Use the AutoConnection tool to automatically select and apply connections with predefined properties to selected parts in a model. With AutoConnection, Tekla Structures automatically creates similar connections for similar framing conditions.

You can use AutoConnection to quickly add connections individually, in phases, or project-wide. This is useful when you are working on a large project using many connections, modifying a model, or importing modified profiles.

**NOTE** Before using AutoConnection in a working model, we recommend that you create a test model, and create all the connection conditions in it that you need for a particular project. You can then use the test model to check the rules and properties of various connection types. The model also acts as a quick reference for connection information.

**See also**

- [AutoConnection settings (page 35)](#)
- [Create a connection using AutoConnection (page 39)](#)
- [AutoConnection and AutoDefaults rules (page 48)](#)

### 3.1 AutoConnection settings

With AutoConnection you can define groups of rules which Tekla Structures automatically applies when creating connections in a model. By using a rule group to select connections and connection properties you do not have to select each connection and define its properties separately. For example, you can create separate rules for different standards, projects, manufacturers, and even individual models.
To open the **AutoConnection Setup** dialog box, click **File menu** --> **Catalogs** --> **AutoConnection settings**.

### Setup level

<table>
<thead>
<tr>
<th>Icon</th>
<th>Setup level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✅</td>
<td>Rule group</td>
<td>You can use rule groups to organize connections and connection properties according to different standards, projects, manufacturers, and models. You can create, modify and delete rule groups.</td>
</tr>
</tbody>
</table>
| 🌱  | Framing condition | Framing conditions are predefined connection types that you cannot change. Tekla Structures creates the framing conditions automatically:  
  - Beam to beam web  
  - Beam to beam flange  
  - Beam to column web  
  - Beam to column flange  
  - Beam splice  
  - Column splice |
<table>
<thead>
<tr>
<th>Icon</th>
<th>Setup level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔄 ‍ ‍外形</td>
<td>Rule set</td>
<td>You can use rule sets to define which connection to use in a certain situation. You can create additional rule sets.</td>
</tr>
<tr>
<td>🔄</td>
<td>Connection</td>
<td>The connection to apply if the rule set criteria are met. To apply a particular connection, the conditions in the model have to match all the rules in the branch that contains the connection.</td>
</tr>
</tbody>
</table>

### Rules.zxt file

When you use AutoConnection, Tekla Structures saves the AutoConnection information in a zipped `rules.zxt` file in the `\attributes` folder under the current model folder.

You can copy the `rules.zxt` file to the project or firm folder to make it available in other models. Each time you modify the AutoConnection setup you need to recopy this file to the firm and project folders. To use the modified setup in other models, restart Tekla Structures.

### See also

- Create a rule group for AutoConnection (page 37)
- Create a rule set for AutoConnection (page 38)
- Change a connection in an AutoConnection rule set (page 38)

### Create a rule group for AutoConnection

You can define rule groups for AutoConnection to organize connections and connection properties according to different standards, projects, manufacturers, and models.

1. On the **File** menu, click **Catalogs --> AutoConnection settings**.
2. Right-click an existing rule group and select **New Rule Group**.
3. Click the **New** group and enter a name.

   Give the rule group a name that reflects the group of connections that you want to create. For example, use the fabricator's name, the project name, or any name that clearly identifies the connection rules that you want to use for a specific model.

When you create a new rule group, Tekla Structures automatically adds the existing framing conditions in the group.
Create a rule set for AutoConnection

You can create AutoConnection rule sets under framing conditions to specify which connection properties to use when specific conditions in the model are met.

You only need to create AutoConnection rule sets if you plan to use different connections to connect similar framing conditions. For example, in the model, some beam-to-beam connections require clip angles, others need shear tabs. You need to define rule sets to determine where each connection type should be used.

1. On the **File** menu, click **Catalogs --> AutoConnection settings**.
2. Click the plus icon in front of the rule group ✓ to open the tree structure.
3. Right-click the relevant framing condition 🛠️ and select **Create Additional Rule Sets**.
4. Right-click the new rule set and select **Edit Rule Set**.
5. Enter a name for the rule set.
6. Select a rule from the **Available rules** list.
7. Click the right arrow button to move the selected rule into the list of **Rules in the rule set**.
8. Enter the values used in the rule: either an exact value, or minimum and maximum values.
9. Click **OK**.

**NOTE** The order of the rules in the tree structure is important. Tekla Structures uses the first rule that matches the conditions in the model so you should place the most limiting rule highest in the tree, and the most generic rule lowest.

You can change the priority of a rule set by right-clicking the rule set and selecting **Move Up** or **Move Down**.

See also

- Change a connection in an AutoConnection rule set (page 38)
- Create a connection using AutoConnection (page 39)
Change a connection in an AutoConnection rule set
You can change the connection in a rule set by selecting a connection in the Applications & components catalog.
1. On the File menu, click Catalogs --> AutoConnection settings.
2. Click the plus icon in front of the relevant framing condition and rule set to find the connection that you want to change.
3. Right-click the connection and select Select Connection Type.
4. Double-click a connection in the Select component dialog box.
5. Click OK in the AutoConnection Setup dialog box.

See also
Create a connection using AutoConnection (page 39)

3.2 Create a connection using AutoConnection
Use AutoConnection to have Tekla Structures automatically create connections using the properties of predefined rules. When you use AutoConnection, Tekla Structures ignores the properties in the connection dialog boxes. Tekla Structures does not modify the existing connections.
1. In the model, select the parts to connect.
2. On the Edit tab, click Components --> Create AutoConnections.
3. Select the rule groups from the lists on the Rule groups tab.

![AutoConnection dialog box]

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Rule group for AutoConnection</td>
</tr>
<tr>
<td>2</td>
<td>Rule group for AutoDefaults</td>
</tr>
</tbody>
</table>

4. If needed, go to the Advanced tab to change the rules used in the framing conditions:
   a. Select the connection in the Connection selection option:
• **AutoConnection** applies the connection defined in the rule group that you have selected in the first list on the **Rule groups** tab.

• **None** does not create a connection.

• Click **Select** to select a connection from the **Applications & components** catalog. Tekla Structures creates the connection using the default properties.

b. Select the connection properties in the **Parameters selection** option:

• **AutoDefaults** applies the properties of the rule group that you have selected in the first list on the **Rule groups** tab.

• **No autodefaults** applies the default connection properties.

5. Click **Create connections**.

**TIP** You can also use the **AutoConnectSelectedParts** macro to automatically create connections using the current properties without opening the **AutoConnection** dialog box.

Macros are located in the **Applications** group in the **Applications & components** catalog.

**See also**

*AutoConnection settings (page 35)*
Use AutoDefaults to set up properties for existing connections. AutoDefaults allows you to modify the default connection properties and save them for use in specific circumstances. When you use AutoDefaults, Tekla Structures automatically creates the connections with the predefined AutoDefaults properties. You can also use AutoDefaults for a single connection.

For example, you can use AutoDefaults to automatically adjust the thickness of each base plate you create, according to the main part profile. If the main part profile changes, Tekla Structures automatically adjusts the thickness of the base plate.

**NOTE** Before using AutoDefaults in a working model, we recommend that you create a test model, and create all the connection conditions in it that you need for a particular project. You can then use this test model to check the rules and properties of various connection types. It also acts as a quick reference for connection information.

See also

- AutoDefaults settings (page 41)
- Modify a connection using AutoDefaults (page 46)
- AutoConnection and AutoDefaults rules (page 48)

### 4.1 AutoDefaults settings

Use AutoDefaults to set up properties for existing connections. With AutoDefaults you can create rules that define the situations where the predefined properties are used.
To open the AutoDefaults Setup dialog box, click File menu --> Catalogs --> AutoDefaults settings.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Setup level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Rule group" /></td>
<td>Rule group</td>
<td>You can use rule groups to organize settings according to different standards, projects, manufacturers, and models. You can create, modify and delete rule groups.</td>
</tr>
<tr>
<td><img src="image" alt="Components" /></td>
<td>Components</td>
<td>The component tree structure shows the connections that are available on component toolbars in Tekla Structures.</td>
</tr>
<tr>
<td><img src="image" alt="Rule set" /></td>
<td>Rule set</td>
<td>Rule sets control which properties to use in certain situations. You can create additional rule sets. Tekla Structures processes AutoDefaults rule sets in the order in which they are in the tree, so you can control the selection of properties.</td>
</tr>
<tr>
<td><img src="image" alt="Properties file" /></td>
<td>Properties file</td>
<td>The properties files are under the rule sets. By default, each connection has a standard properties file that defines the standard</td>
</tr>
</tbody>
</table>
# Setup level

<table>
<thead>
<tr>
<th>Icon</th>
<th>Setup level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>properties, for example, <code>standard.j144</code> or <code>standard.j1042</code>. You can create additional properties files for the properties that you want to use again and give the files distinctive names.</td>
</tr>
</tbody>
</table>

## Defaults.zxt file

When you use AutoDefaults, Tekla Structures saves the AutoDefaults rules in a zipped `defaults.zxt` text file in the `\attributes` folder under the current model folder.

You can copy the `defaults.zxt` file to the project or firm folder to make it available in other models. Each time you modify the AutoDefaults setup, you need to recopy this file to the firm or project folder. To use the modified setup in other models, restart Tekla Structures.

**NOTE** We do not recommend that you edit the `defaults.zxt` file using a text editor, but if you do, ensure that you are using the right syntax. The easiest way to unzip the `.zxt` file is to change the file extension `.zxt` to `.txt.gz` and unzip the file. Change the extension back to `.zxt` when you have finished. You do not need to zip the file after editing it; Tekla Structures can also read the unzipped file.

## See also

- Create a rule group for AutoDefaults (page 43)
- Create a rule set for AutoDefaults (page 44)
- Modify connection properties for AutoDefaults (page 45)

## Create a rule group for AutoDefaults

You can define rule groups for AutoDefaults to group the rules according to different standards, projects, or manufacturers, for example.

1. On the **File** menu, click **Catalogs --> AutoDefaults settings**.
2. Right-click an existing rule group and select **New Rule Group**.
3. Click the **New** group to rename it.

   Give the rule group a name that reflects the contents of the group. For example, use the fabricator’s name, the project name, or any name that clearly identifies the rules that you want to use for a specific model.

When you create a new rule group, Tekla Structures automatically adds the existing components to the group.
Create a rule set for AutoDefaults

You can create rule sets to define which connection properties are used when specific conditions in the model are met.

1. On the **File** menu, click **Catalogs --> AutoDefaults settings**.
2. Click the plus icon in front of the rule group to open the tree structure.
3. Click the plus icon in front of the relevant group of components and connection.
4. Right-click an existing rule set and select **New Rule Set**.
5. Right-click the new rule set and select **Edit Rule Set**.
6. Enter a name for the rule set.
7. Select a rule from the **Available rules** list.
8. Click the right arrow button to move the selected rule into the list of **Rules in the rule set**.
9. Enter the values used in the rule: either an exact value, or minimum and maximum values.
10. Select from the **Parameter file(s) selection in the rule set** list how the properties are selected in the rule set.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use combination of first parameters</strong></td>
<td>Tekla Structures uses the properties files it finds in the first matching sub-rule set and does not check other rule sets.</td>
</tr>
<tr>
<td><strong>Iterate until connection symbol is green</strong></td>
<td>Tekla Structures checks sub-rule sets until it finds matching properties.</td>
</tr>
<tr>
<td><strong>Iterate until connection symbol is yellow</strong></td>
<td>Tekla Structures checks sub-rule sets until it finds matching properties.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Use combination of all parameters</td>
<td>Tekla Structures checks all rule sets and uses the properties files in all matching rule sets. The order of the properties files is important.</td>
</tr>
<tr>
<td></td>
<td>When Tekla Structures combines the properties files, the most recent files (the lowest in the tree) override previous ones. If you do not enter any values for the properties, Tekla Structures does not override the previous property values.</td>
</tr>
</tbody>
</table>

11. Click **OK**.

**NOTE**  The order of the rules in the tree structure is important. Tekla Structures uses the first rule that matches the conditions within the model so you should place the most limiting rule highest in the tree, and the most generic rule lowest.

  You can change the priority of a rule set by right-clicking the rule set and selecting **Move Up** or **Move Down**.

**See also**

- AutoDefaults settings (page 41)
- Modify connection properties for AutoDefaults (page 45)
- Combining and iterating properties for AutoDefaults (page 50)

**Modify connection properties for AutoDefaults**

Each connection has a default standard property file that defines the properties for the connection. You can modify the properties that the standard file uses. Save the connection properties that you want to use and set the standard file to use these properties in the AutoDefaults settings.

1. On the **File** menu, click **Catalogs --> AutoDefaults settings**.
2. Click the plus icon in front of the rule group ✓ to open the tree structure.
3. Click the plus icon in front of the relevant group of components 🔲 and connection 🔷.
4. Right-click the `standard.j` connection file that you want to modify, for example, `standard.j144` and select **Edit connection parameters**.
5. In the connection dialog box, set the properties that you want to save.
   Such properties could be, for example, bolt properties, profiles, and materials.
6. Enter a descriptive name for the properties in the box next to the **Save as** button.

7. Copy this name in the **Connection code** option on the **General** tab. Using the same name allows you to check which properties Tekla Structures used in specific situations. Tekla Structures does not automatically show the AutoDefaults values in the connection dialog box.

8. Click **Save as**.

Tekla Structures saves the properties file in the \attributes folder under the current model folder. The filename consists of the name you entered in **Save as** and the file extension .jXXX, where XXX is the connection number, for example, *sec_0-190.j144*.

9. Click **Cancel** to close the connection dialog box and return to the **AutoDefaults Setup** dialog box.

   If you click **OK** to close the connection dialog box, you need to load the default properties the next time you use the connection. Using the default properties ensures that AutoDefaults can modify the properties.

10. Right-click the **standard.j** file again and select **Select connection parameters**.

    The **Attribute File List** dialog box that opens contains the properties that have been set and saved in the connection dialog box.

11. Select a file in the **Attribute File List** dialog box.

12. Click **OK**.

**See also**

*Modify a connection using AutoDefaults (page 46)*

### 4.2 Modify a connection using AutoDefaults

When you use a connection that you are unfamiliar with, first use the default properties. Then use AutoDefaults to modify the properties.

1. Double-click a connection symbol in the model to open the connection dialog box.

2. On the **General** tab, select a rule group from the **AutoDefaults rule group** list.

3. On all tabs, select the AutoDefaults options marked with the arrow symbol for the properties in which you want to use AutoDefaults.

4. Click **Apply**.
If you manually modify the properties after using AutoDefaults, Tekla Structures uses the manually modified properties.

For example, you have manually set the base plate thickness of a connection to 20 mm. AutoDefaults is active and sets the plate thickness according to the main part profile. If you modify the main part profile, Tekla Structures does not update the base plate thickness. It remains at 20 mm.

NOTE You can view which AutoDefault rules and properties are used:

- To view AutoDefaults rules, select the connection symbol in the model, right-click and select Inquire. Tekla Structures shows the rule group, rule sets and properties files used.
- To view the AutoDefaults properties, double-click the connection symbol in the model, select <AutoDefaults> in the list box next to the Load button and click Load.

See also

AutoDefaults settings (page 41)
You can create your own AutoConnection and AutoDefaults rules for project and company defaults. By defining rules you can accurately select connections and connection properties when using AutoConnection and AutoDefaults.

### General rules

- **Profile name** is the name in the profile catalog.
- **Profile type**

<table>
<thead>
<tr>
<th>Profile type</th>
<th>Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>1</td>
</tr>
<tr>
<td>L</td>
<td>2</td>
</tr>
<tr>
<td>Z</td>
<td>3</td>
</tr>
<tr>
<td>U</td>
<td>4</td>
</tr>
<tr>
<td>Plate</td>
<td>5</td>
</tr>
<tr>
<td>Round bar</td>
<td>6</td>
</tr>
<tr>
<td>Pipe</td>
<td>7</td>
</tr>
<tr>
<td>Square pipe</td>
<td>8</td>
</tr>
<tr>
<td>C</td>
<td>9</td>
</tr>
<tr>
<td>T</td>
<td>10</td>
</tr>
<tr>
<td>ZZ</td>
<td>15</td>
</tr>
<tr>
<td>CC</td>
<td>16</td>
</tr>
<tr>
<td>CW</td>
<td>17</td>
</tr>
<tr>
<td>Polygon plate</td>
<td>51</td>
</tr>
</tbody>
</table>

- Number of secondary parts
- Number of main parts
- Material name
Orientation rules
Depending on the relative angle of a beam, the connections can be classified as sloped, skewed, or cant. The angle value can be between -90 and 90 degrees.

• **Sloped** angle (relative to main part cross section)
  The longitudinal axis of the secondary part follows the slope of the longitudinal axis of the main part.

• **Skewed** angle (relative to main part longitudinal axis)
  The longitudinal axis of the secondary part is skewed according to the main part cross section. The angle is the smaller of the angles between the longitudinal axis of the secondary part and the main part Z or Y axis.

• **Cant** angle
  For rotated secondary parts

Dimension rules
• **Profile depth**
• **Web depth**
  For profiles with an upper and lower flange, the web depth is: \( h - t_1 - t_2 - 2 \times r_1 \)
  Or, if \( t_2 \) is zero: \( h - 2 \times t - 2 \times r_1 \)
For profiles with one flange, the web depth is \( h - t - r_1 - r_2 \).

- **Web thickness**
- **Flange thickness**

**Forces and strengths**
- Shear force
- Axial force
- Bending moment

**See also**
- Combining and iterating properties for AutoDefaults (page 50)
- AutoDefaults example: Using iteration with connection check (page 52)
- Using reaction forces and UDLs in AutoDefaults and AutoConnection (page 54)

### 5.1 Combining and iterating properties for AutoDefaults

**Combining properties**

You can save properties files that cover different groups of properties and use these files to define many rules. For example, you can have one file for bolt properties and another for profile properties. AutoDefaults combines the separate files into one file. This means that you can define fewer files because you can use one file for several rules. If the files contain different values for the same property, Tekla Structures uses the last property it finds, see the example image below.
Iterating properties

Tekla Structures tests the properties until the connection symbol is yellow or green. Iteration changes the properties automatically if the connection is not created successfully, even if the rules match. If connection check is active, the iteration results in properties that have passed the check.
Limitations

- Tekla Structures cannot iterate property files directly. Use a single iteration rule set with sub-rule sets.
- You cannot have many parallel iteration rule sets. Use a single iteration rule set and place it just before the default rule set.
- Place the combination rule sets above the iteration rule set in the AutoDefaults tree structure.
- Combination rule sets can only be one level deep.
- Tekla Structures disregards empty rule sets, so include at least one rule in each rule set.

See also

Create a rule set for AutoDefaults (page 44)

5.2 AutoDefaults example: Using iteration with connection check

You can use the connection check result when using AutoDefaults with iteration. If an iteration rule matches, but the connection does not pass the connection check and the connection symbol remains red, AutoDefaults continues testing other rules and properties until the connection symbol is green.

In this example, you will create iteration rules to set the number of bolts according to the result of the connection check. After this, you will use the
To create iteration rules for use with connection check:

1. On the **File** menu, click **Catalogs --> AutoDefaults settings**.
2. Right-click the tree and select **New Rule Group**.
3. Click the new rule group and rename it to **Iteration example**.
4. Browse the **Iteration example** tree to find **End plate (144)**, right-click it, and select **Create Additional Rule Sets**.
5. Right-click the **New** rule set and select **Edit Rule Set**.
6. Change the rule set name to **ITERATION**.
7. Set the **Parameter file(s) selection in rule set** option to **Iterate until connection symbol is green**.
8. Click **OK**.
9. Right-click the **ITERATION** rule set and select **Create Additional Rule Sets**.
10. Right-click the **New** rule set and select **Edit Rule Set**.
11. Change the rule set name to **2 bolts**.
12. Select the rule **Secondary 1 depth** and set the minimum and maximum depth values for two bolts.
13. Set the **Parameter file(s) selection in rule set** option to **Use combination of first parameters**.
14. Click **OK**.
15. Right-click the connection properties file `standard.j144` under 2 bolts and select `Select Connection Parameters`.

16. Select a properties file for two bolts in the `Attribute File List` and click `OK`.

**TIP** If there is no suitable properties file, you can create a new file. Right-click the `standard.j144` file and select `Edit Connection Parameters`. Save the needed properties and click `Cancel` to close the dialog box. The saved properties are now available in the `Attribute File List`.

17. Click `Apply` to have the changes available in the connection dialog box.

18. Repeat steps 9 to 16 for other rule sets.

19. Open the `End plate (144)` dialog box.

20. Select `<Defaults>` from the list next to the `Load` button and click `Load`.

21. On the `General` tab, set the `AutoDefaults rule group` option to the `Iteration example` you created.

22. On the `Design type` tab, set the `Check connection` option to `Yes`.

23. Enter the load from secondary members in the `Shear`, `Tension`, and `Moment` options.

24. Click `OK`.

**See also**

- `AutoDefaults settings (page 41)`
- `Combining and iterating properties for AutoDefaults (page 50)`

### 5.3 Using reaction forces and UDLs in AutoDefaults and AutoConnection

You can set reaction forces for AutoConnection and AutoDefaults in the user-defined attributes of a part, and for AutoDefaults also on the `Design` tab in the connection dialog box.

**Reaction forces**

When you use reaction forces in a rule and AutoDefaults is activated, Tekla Structures first searches for reaction forces in the corresponding connection's properties. If the properties do not contain reaction forces, Tekla Structures searches the user-defined attributes of the secondary part of the connection. If Tekla Structures does not find forces there, you cannot use reaction force rules.

**Shear force calculation**
If you have not given any reaction force values, shear force is calculated using the UDL (uniformly distributed load) shear force routine. The UDL calculation is mainly intended for use with imperial units. It uses the yield stress value, profile dimensions, and UDL percentage to calculate the maximum shear force allowed.

- Yield stress is defined in the material catalog.
- Profile dimensions come from the profile catalog.
- UDL percentage is taken either from the connection dialog box or from an advanced option.

Tekla Structures compares the result with the shear force rule in AutoDefaults.

To use UDLs for AutoConnection and AutoDefaults:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Use UDL for AutoConnection| 1. On the Design tab in the connection dialog box, set the UDL option to Yes.  
  2. Enter the UDL percentage in the UDL% box. If you do not enter any value, Tekla Structures uses a default percentage set with the XS_AUTODEFAULT_UDL_PERCENT advanced option. |
| Use UDL for AutoDefaults   | 1. On the Design tab in the connection dialog box, set the Use UDL option to Yes.  
  2. Enter the UDL percentage in the UDL % box. If you do not enter any value, Tekla Structures uses a default percentage set using the XS_AUTODEFAULT_UDL_PERCENT advanced option. |
© 2017 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced Software. Use of the Software, and use of this Software Manual are governed by a License Agreement. Among other provisions, the License Agreement sets certain warranties for the Software and this Manual, disclaims other warranties, limits recoverable damages, defines permitted uses of the Software, and determines whether you are an authorized user of the Software. All information set forth in this manual is provided with the warranty set forth in the License Agreement. Please refer to the License Agreement for important obligations and applicable limitations and restrictions on your rights. Trimble does not guarantee that the text is free of technical inaccuracies or typographical errors. Trimble reserves the right to make changes and additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by international treaties. Unauthorized reproduction, display, modification, or distribution of this Manual, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve, Fastrak and Orion are either registered trademarks or trademarks of Trimble Solutions Corporation in the European Union, the United States, and/or other countries. More about Trimble Solutions trademarks: http://www.tekla.com/tekla-trademarks. Trimble is a registered trademark or trademark of Trimble Inc. in the European Union, in the United States and/or other countries. More about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product and company names mentioned in this Manual are or may be trademarks of their respective owners. By referring to a third-party product or brand, Trimble does not intend to suggest an affiliation with or endorsement by such third party and disclaims any such affiliation or endorsement, except where otherwise expressly stated.

Portions of this software:
D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved.
Using reaction forces and UDLs in AutoDefaults and AutoConnection
Index

A
applications in Applications and Components catalog ....................................25
autoconnection............................................. 35
defining rules......................................37,38
modifying rules........................................38
rules..................................................... 35,48
settings..................................................... 35
using......................................................... 39
autodefaults...................................................41
combining properties............................. 50
connection check.................................... 52
defining rules......................................43,44
iterating properties................................. 50
modifying properties............................................ 45
rules..................................................... 41,48
settings..................................................... 41
using......................................................... 46
using reaction forces...............................54
using UDLs............................................... 54

C
component catalog..............................................11
cmpONENTS catalog..............................................11
components
  conceptual.............................................23
  converting.............................................23
components in Applications & components
  catalog......................................................11
  components
    adding..............................................8
    adding a base plate...............................18
    adding a corbel connection....................20
    adding a pad footing reinforcement..........21
    adding an end plate...............................17
    catalog...............................................11

connecting beams to columns.............. 19
connections............................................. 5
creating component views....................10
detailing............................................... 5
details..................................................... 5
tips......................................................... 22
viewing..................................................10

E
extensions in Applications and components catalog...........................................25
extensions
  importing............................................ 31

M
macros
  adding.............................................. 27
  editing.............................................. 27
  global................................................. 25,27
  local.................................................. 25,27
  macro folder........................................ 25
  recording............................................ 27
  running............................................... 27

P
publishing groups in Applications &
  components catalog....................................32

R
recording
  macros............................................... 27
  running............................................... 27