1 Customize Tekla Structures .......................................................... 7

2 General ............................................................................................ 8

2.1 Customize the ribbon ........................................................................ 8
Add a command button ........................................................................... 9
Remove a command button ..................................................................... 11
Move a command button ........................................................................ 11
Resize a command button ...................................................................... 11
Change the appearance of a command button ........................................ 12
Create a user-defined command ............................................................ 13
Add a custom button and assign a command to it .................................. 15
Add a separator bar ................................................................................ 17
Add, hide, and edit tabs ......................................................................... 17
Save the ribbon ...................................................................................... 18
Check the changes ................................................................................ 18
Back up and restore ribbons ................................................................... 19
Distribute custom ribbons using a firm or environment folder ............... 20
  Add ribbons to the firm or environment folder ..................................... 21
  Loading order of custom ribbons .......................................................... 21
  Naming convention for ribbon files ....................................................... 21
Distribute custom tabs using a firm or environment folder ..................... 22

2.2 Customize the contextual toolbar .................................................... 24
Customize contextual toolbar ................................................................ 24
Create user profiles for contextual toolbars .......................................... 25
Back up and share contextual toolbars .................................................. 26

2.3 Customize the keyboard shortcuts .................................................... 26
Define new keyboard shortcuts ................................................................ 26
Clear and reset shortcuts ....................................................................... 28
Export keyboard shortcuts ..................................................................... 28
Import keyboard shortcuts ..................................................................... 29

3 Modeling ............................................................................................. 30

3.1 Modify the default attributes of Custom Inquiry tool ......................... 30

3.2 Define custom phase properties ....................................................... 31

3.3 Create user-defined cross sections for welds .................................... 31
Define a user-defined cross section for a weld ....................................... 31
Remove a user-defined cross section from a weld ................................ 32
Limitations ............................................................................................ 32

4 Drawings .............................................................................................. 33

4.1 Customize printing ........................................................................... 33
Customize print output file names .......................................................... 33

4.2 Customize symbols .......................................................................... 35
Customize weld symbols ........................................................................................................... 35
Customize bolt symbols ........................................................................................................... 37
Customize leader line arrow symbols ....................................................................................... 38

4.3 Customize line types ........................................................................................................... 40
Define customized line types in TeklaStructures.lin .............................................................. 40

4.4 Custom presentations in drawings ..................................................................................... 42

5 Catalogs ........................................................................................................................................ 45

5.1 Customize the profile catalog .............................................................................................. 45
Important buttons in the profile catalog .................................................................................. 46
Group profiles together ......................................................................................................... 46
   Add a rule to the profile catalog ........................................................................................ 47
   Modify a rule in the profile catalog .................................................................................... 47
Add user attributes to profiles ................................................................................................. 48
   Example: Add a user attribute to a profile and use it in a rule ........................................ 49
Associate profile types with a certain material ........................................................................ 51
Delete a profile from the profile catalog .............................................................................. 52
Import and export profiles ......................................................................................................... 53
   Import profile catalog items .............................................................................................. 54
   Export an entire profile catalog ......................................................................................... 55
   Export a part of the profile catalog .................................................................................... 55
   Example of profile export file ............................................................................................ 56
Units used in import and export ................................................................................................. 57
Import and export sketched profiles .......................................................................................... 59
Create your own profiles ........................................................................................................... 60
   Create user-defined cross sections ..................................................................................... 60
   Create fixed profiles ........................................................................................................... 66
   Create parametric profiles by sketching ............................................................................ 70
   Create parametric profiles with variable cross sections .................................................. 93
Define standardized values for parametric profiles .................................................................. 97
Create an image of a profile ....................................................................................................... 98

5.2 Customize the shape catalog ............................................................................................... 99
Import a shape ......................................................................................................................... 99
Export a shape ......................................................................................................................... 100
Delete a shape ....................................................................................................................... 101
Example: Import a shape from SketchUp Pro ........................................................................ 101

5.3 Customize the material catalog ........................................................................................... 103
Important buttons in the material catalog .......................................................................... 103
Add a material grade ............................................................................................................. 104
Copy a material grade ........................................................................................................... 104
Modify a material grade ....................................................................................................... 105
Delete a material grade ........................................................................................................ 106
Add user attributes to material grades .................................................................................. 106
Create user-defined material definitions .............................................................................. 107
Import and export material grades ........................................................................................ 108
   Import a material catalog ................................................................................................. 109
   Export an entire material catalog .................................................................................... 110
   Export a part of the material catalog .............................................................................. 110

5.4 Customize the bolt catalog .................................................................................................. 111
How the bolt catalog and bolt assembly catalogs work together ......................................... 112
Manage bolts and bolt assemblies ......................................................................................... 113
Add a bolt to the catalog .......................................................................................................... 113
Add a stud bolt to the catalog .................................................................................................. 114
Modify bolt information in the catalog........................................................................115
Delete a bolt from the catalog.................................................................................. 116
Add a bolt assembly to the catalog........................................................................... 116
Modify bolt assembly information in the catalog.................................................... 117
Delete a bolt assembly from the catalog.................................................................117
Import and export bolts and bolt assemblies.........................................................117
Import bolts to the catalog......................................................................................118
Export bolts from the catalog..................................................................................119
Import bolt assemblies to the catalog......................................................................119
Export bolt assemblies from the catalog.................................................................120
Import a bolt catalog................................................................................................120
Import a part of the bolt catalog...............................................................................121
Export an entire bolt catalog.................................................................................. 122
Bolt length calculation..............................................................................................122
Bolt catalog properties.............................................................................................126
Bolt assembly catalog properties.............................................................................127

6 Organizer..................................................................................................................130
6.1 Customize a default setup for Organizer ............................................................130

7 System....................................................................................................................133
7.1 Create project and firm folders............................................................................133
Create a project or firm folder..................................................................................133
7.2 Customize message files.....................................................................................134
7.3 Create startup shortcuts with customized initializations.......................................135
Create a startup shortcut with customized initialization.........................................135
Available parameters in shortcuts...........................................................................136
Example of an initialization file................................................................................137
7.4 Define and update user-defined attributes (UDAs)...........................................138
Update definitions of user-defined attributes (UDAs) in a model............................139
Environment database file.......................................................................................139
Example: Create and update a user-defined attribute (UDA)..................................140
7.5 Customize using Tekla Open API.........................................................................144

8 Custom components...............................................................................................146
8.1 What is a custom component..............................................................................146
Custom parts.............................................................................................................148
Custom connections.................................................................................................150
Custom details...........................................................................................................152
Custom seams..........................................................................................................154
8.2 Create a custom component................................................................................157
Explode a component..............................................................................................160
Create a nested custom component..........................................................................160
Create a thumbnail image of a custom component................................................162
Example: Create a custom end plate component.....................................................163
Example: Create a nested connection with stiffeners..............................................166
8.3 Modify a custom component..............................................................................170
Protect a custom component with a password.......................................................171
8.4 Add variables to a custom component ..............................................................172
Bind component objects to a plane..........................................................................173
Bind objects automatically......................................................................................173
8.5 Save a custom component........................................................................... 225
8.6 Modify the dialog box of a custom component........................................... 226
  Custom component input files........................................................................ 229
  Modify custom component input files manually............................................. 230
    Add new tabs............................................................................................... 230
    Add text boxes............................................................................................. 231
    Add images.................................................................................................... 231
    Change the order of boxes............................................................................ 232
    Change the location of boxes....................................................................... 233
  Lock or unlock the custom component input file............................................. 233
  Example: Create a toggle group..................................................................... 234
  Example: Modify the dialog box of a stiffener detail...................................... 238
    Example: Create a custom stiffener detail with variables............................. 238
    Example: Add a list with images.................................................................... 249
    Example: Arrange text boxes and labels...................................................... 254
    Example: Dim unavailable options.............................................................. 256
  Dialog editor settings...................................................................................... 259

8.7 Add a custom component to a model....................................................... 261

8.8 Add or move a custom part in the model.................................................. 262

8.9 Import and export custom components.................................................... 264
  Export custom components............................................................................ 264
  Import custom components............................................................................ 265

8.10 Custom component settings...................................................................... 265
  Custom component properties........................................................................ 266
    Type/Notes tab properties............................................................................ 266
    Position tab properties................................................................................ 267
    Advanced tab properties.............................................................................. 268
  Default properties of a custom component.................................................. 269
Default properties of custom parts ................................................................. 269
Default properties of custom connections, details, and seams .................. 272
Plane types ....................................................................................................... 274
Examples of component planes ...................................................................... 275
Variable properties ......................................................................................... 277

8.11 Hints and tips for using custom components ........................................ 282
Tips for creating custom components .............................................................. 282
Tips for sharing custom components ............................................................... 283
Tips for updating custom components to a new version ............................... 284

9 Disclaimer .................................................................................................... 285
You can customize most features of Tekla Structures. You can maintain most of the customization work centrally and share your work with other users.

This section includes common customization tasks that most users should find useful. This includes more basic customization, such as setting up the user interface and setting up various catalogs. This section also covers the more advanced task of creating your own custom components. This section does not include customization tasks and options that are closely linked to working in a specific feature: those are explained as part of each feature's documentation.

There are many additional customization options particularly for Tekla Structures administrators. If you are an administrator starting to set up customized configurations for your organization, see Tekla Structures setup guidelines for administrators.
2 General

2.1 Customize the ribbon

You can customize the ribbon according to your needs. You can change the size and shape of any command button, for example. You can add custom buttons and assign commands to them. You can also bring your favorite components and extensions to the ribbon for an easy access.

To open the customization tool, click **File menu --> Settings --> Customize --> Ribbon**.

The tool includes two editing modes:

- **Simple mode**: Add, move, and resize command buttons; add, hide, and edit tabs; remove command buttons and tabs from the ribbon.

- **Design mode**: Choose which name and icon is used for each command button; add new buttons and assign commands to them; add vertical and horizontal separator bars.
Add a command button
You can add command buttons simply by dragging commands to the ribbon or to the Quick Access Toolbar.

1. Ensure that Simple mode is switched on.
2. In the Select ribbon list, select which ribbon you want to customize.
   For example:

   ![Select ribbon screenshot]

   You can only customize ribbons that are available in your configuration.

3. Search for the command you want to add.
   You can also add components, macros, and extensions. Browse through the lists or use the Search box to filter content. For example, type mesh to
find the **Create reinforcement mesh** command and other mesh related components:

- **User-defined**: commands that you have created on the **User-defined commands** tab
- **Tekla Structures**: all the Tekla Structures commands available in this configuration and mode
- **Applications & components**: components, macros, plugins, and extensions

4. Drag and drop the command to the ribbon.
   The blue color indicates the place where the command button will be inserted. For example:

![Drag and drop commands to the ribbon](image)

**NOTE** If you hover over a down arrow, a list will open and you can drag commands to the list. The list will remain open until you click the down arrow again.

You can also drag commands to the **Quick Access Toolbar**, which is located above the ribbon, or to the fixed container on the left side of the ribbon:
Remove a command button
1. Select the command button.
2. Press **Delete** on your keyboard.

Move a command button
You can rearrange command buttons on the ribbon. Note that you cannot move drop-down buttons underneath each other.
1. Select the command button you want to move.
   - The command button becomes highlighted:

   ![Highlighted button]

2. Drag and drop the command button to a new location.
   - The blue color indicates the place where the command button will be inserted. For example:

   ![Drag-and-drop example]

Resize a command button
You can change the size of existing command buttons.
1. Select the command button you want to resize:
2. Move the mouse pointer over any side or corner of the command button to display a white arrow symbol:

3. Drag with the arrow to define a new size:

The size of the command button changes accordingly. The other command buttons are automatically moved forward on the ribbon, if needed.

4. Double-click the command button to expand it.
   The command button now fully occupies the empty space around it:

---

**Change the appearance of a command button**

You can change the appearance of any command button in the **Design mode**.

1. Ensure that **Design mode** is switched on.
2. Select the command button you want to modify.
The current properties of the command button are displayed.

3. To change the name, select one of the options:
   - **None**: no name is used for the command button
   - **Short name**: the default short version of the name is used
   - **Full name**: the default full version of the name is used
   - **Custom**: enter a custom name for the command button

4. To change the icon, select one of the options:
   a. **None**: no icon is used for the command button
   b. **Large icon**: the default large icon (32x32) is used
   c. **Small icon**: the default small icon (16x16) is used
   d. **Gallery**: select an icon from the Tekla Structures icon gallery
   e. **Custom**: define a custom icon by selecting a suitable image file. The recommended size is 32x32 pixels for large buttons and 16x16 pixels for small buttons. If you have problems with your custom image not appearing the right size, check the DPI setting of the image file. A DPI of 96 is recommended.

   **TIP** When you modify a command button which is on a drop-down list, the options may become hidden behind the drop-down list. Slide the ribbon right or left to make the options visible.

---

**Create a user-defined command**

You can create user-defined commands and link them to any file or URL.

1. Go to the **User-defined commands** tab.
2. Click **Add**.
3. Enter a unique ID for the command, and then click **Create**.
For example, let’s assume you are creating a link to the Tekla Discussion Forum. Enter OpenTeklaDiscussionForum as the ID of the command. A new page with more properties appears.

4. Click Action and define a file or URL. For example, enter https://forum.tekla.com.

5. Click name and enter a name for the command. This name will be visible in the Tekla Structures user interface. You can define two alternative names: a full name and a short version. For example, enter Tekla Discussion Forum as the full name of the command, and Forum as the short version.

6. Click Icon and select a suitable icon from the Tekla Structures icon gallery. You can define two alternative icons: a large one and a small one.

7. Click Tooltip and enter a tooltip for the command. For example, enter Go to the Tekla discussion forum.

8. Click Apply to save the new command.

9. Go to the Edit ribbons tab.
   The command you created is available in the User-defined list, on the left-hand side of the dialog box:

10. Drag and drop the command to the ribbon:
11. To modify a user-defined command, switch to the **Design mode** and edit the command properties just like for any other command.

### Add a custom button and assign a command to it

You can add new buttons, split buttons, toggle buttons, and drop-down buttons to the ribbon. These are all empty placeholders for commands. After creating a new button, you can assign a command to it.

1. Ensure that **Design mode** is switched on.
2. On the **Edit ribbons** tab, click the desired button type to select it:

   - **Basic**: Add a button for a single command.
   - **Toggle**: Add a toggle button that switches a particular command on or off. Use this to add any switch from the **File menu --> Settings --> Switches** to the ribbon, for example.
   - **Drop-down**: Add a drop-down button with a group of commands underneath it. You can define a name and a custom tooltip for the button.
   - **Split**: Add a button for a single command, plus a drop-down button with a group of commands underneath it.

3. Using the mouse, draw a rectangular area for the new button.

4. To assign a command to the button:
   a. Ensure that the new button is selected.
b. On the **Command** tab, search for the command you want to add. Browse through the lists or use the **Search** box to filter content. For example:

![Command tab search example](image)

c. Click **Assign this command**. The command is now assigned to the button.

d. On the **Appearance** tab, modify the command's name and icon, if needed.

5. To add commands to a drop-down button:
   a. Return to the **Simple mode**.
   b. Search for commands.
   c. Drag and drop commands to the drop-down button.

   If you hover over a down arrow, a list will open and you can drag commands to the list. The list will remain open until you click the down arrow again.

![Drop-down button example](image)
Add a separator bar
You can add vertical and horizontal separator bars to divide command buttons into smaller groups on the ribbon.
1. Ensure that Design mode is switched on.
2. Click Separator to select it.
3. Using the mouse, draw a rectangular area in the vertical direction.

A vertical bar appears in the location you defined.
4. Ensure that the bar is selected.
5. Modify the orientation and line thickness of the bar, if needed.

Add, hide, and edit tabs
You can add, move and rename ribbon tabs, choose how they are aligned, and hide some tabs if you do not need them in your current project. For example, if you are only modeling steel parts, you can temporarily hide the Concrete tab.
1. Ensure that Simple mode is switched on.
2. To add a new tab, click the plus sign at the end of the tab row.
3. To rename a tab:
   a. Right-click a tab title and select Rename....
   b. Type a new name.
   c. Press Enter to save the new name.
4. To change the order of tabs on the ribbon, drag and drop the tab titles.
5. To change how the tabs are aligned, click and then select one of the options:
   • Scroll visible: the ribbon movement is minimal when you switch between the tabs
• **Align to left:** the icons start from the left side of the ribbon
• **Align to tab:** the icons start from the left side of the current tab

6. To hide the tabs that you do not need in your current project:
   a. Rest the mouse pointer on a tab title.
      A small eye symbol appears next to the tab title:
      ![Eye symbol](image)
   b. Click the eye symbol.
      The eye symbol changes and the tab title becomes gray:
      ![Eye symbol](image)
      The **View** tab is now hidden from the ribbon. If you slide the ribbon, hidden tabs appear as:
      ![Hidden tab](image)
   c. To re-display the hidden tab, click the eye symbol again.

7. To remove a tab, select it and press **Delete**.

**Save the ribbon**
When you are happy with the changes, save the customized ribbon.

1. On the **Edit ribbons** tab, click the **Save** button.

2. When you return to Tekla Structures and the program asks if you wish to load the new ribbon, click **Yes**. The ribbon becomes updated with the changes you made.

**Check the changes**
You can compare the original ribbon with the changes you have made. You can check what has been added and removed, and what has been moved to different tabs.

1. Save the customized ribbon, if you have not already done so.
2. Click **Compare**.

3. In the **Compare ribbons** dialog box, check the changes you have made. For example:

   - **First list**: these commands have been removed
   - **Second list**: these commands have been moved to a new place
   - **Third list**: these commands have been added

   **NOTE**  **Original ribbon** refers to the ribbon file that came with the Tekla Structures installation for your current configuration.

4. If you have removed a command that you would like to get back, drag it from the **Compare ribbons** dialog box to the ribbon.

5. When you are finished, click **Close**.

**Back up and restore ribbons**

You can restore the default Tekla Structures ribbons at any time. Before restoring the default settings, make sure to save a backup copy of your customized ribbon, because the customizations will be permanently deleted. You can use the backup file to take your customized ribbon back into use, to copy the ribbon settings to another computer, or to share the customized ribbon with your co-workers.

1. To save a backup copy of the customized ribbon:
   a. On the **Edit ribbons** tab, click the **Save** button 📐.
b. Go to the `.\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\UI\Ribbons` folder.

c. Make a copy of the desired ribbon file and save it in another folder.

The ribbons are named according to the Tekla Structures configurations. For example, in the **full** configuration, the name of the **Modeling** ribbon file is `albl_up_Full--main_menu.xml`.

2. To restore the default Tekla Structures ribbons:

a. In the **Select ribbon** list, select which ribbon you want to restore.

   For example:

   ![Select ribbon](image)

   **Select ribbon:**

   - Full: Modelling

   b. Click **Reset to defaults**. The default Tekla Structures ribbons are now in use.

3. To take the customized ribbon back into use:

a. Copy the backup file back to the `.\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\UI\Ribbons` folder.

b. When you return to Tekla Structures and the program asks if you wish to load the new ribbon, click **Yes**. The ribbon becomes updated with the changes you made.

### Distribute custom ribbons using a firm or environment folder

You can distribute customized ribbon files to other users in the company by placing the ribbon files in a firm or environment folder (not in the project folder). For example, the administrator can create company ribbons and save them in the firm folder. These ribbons will be displayed in the Tekla Structures user interface for all users who use the same firm folder.
Add ribbons to the firm or environment folder

1. In the ribbon customization tool (page 8), create the modeling and drawing ribbons that you want to share. The ribbons are saved in the ..\Users\<user>\AppData\Local \Trimble\TeklaStructures\<version>\UI\Ribbons folder.

2. Copy the entire \Ribbons folder either to your company's firm folder or to the \system folder, which is located under the environment folder: ..\ProgramData\Tekla Structures\<version>\Environments \<environment>\system.

3. If the ribbon contains user-defined commands, create a subfolder named \Commands on the same level as the \Ribbons folder, and copy the UserDefined.xml file from the ..\Users\<user>\AppData\Local \Trimble\TeklaStructures\<version>\UI\Commands folder to the \Commands folder you just created.

4. Restart Tekla Structures.

Loading order of custom ribbons

Tekla Structures loads the ribbons in the following order:

1. Tekla Structures default ribbon
2. Company ribbons in the environment folders
3. Company ribbons in the firm folder
4. User-defined ribbons under %localappdata%

Note that the ribbons which are loaded later will override previously loaded ribbons that have the same configuration + editing mode combination. For example, a ribbon defined in the firm folder will take precedence over the ribbons in the environment folders.

If you have a customized ribbon in the ..\Users\<user>\AppData\Local \Trimble\TeklaStructures\<version>\UI\Ribbons folder, it will take precedence over company ribbons. To override this, open the ribbon customization tool (page 8) and click Reset to defaults. The ribbon in the environment or firm folder will now be used. Alternatively, you can remove or rename your own customized ribbons.

Naming convention for ribbon files

The customization tool saves the custom ribbons as .xml files. The naming convention for these files is:

<Tekla-Structures-configuration_identifier>--<Tekla-Structures-editing-mode>.xml

The name consists of an internal configuration name, a separator of two dash characters (--), an internal editing mode name, and the file name.
extension .xml. For example, the Full license modeling ribbon is called albl_up_Full--main_menu.xml.

<table>
<thead>
<tr>
<th>Configuration identifier</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>albl_up_Construction_Modeling</td>
<td>Construction Modeling</td>
</tr>
<tr>
<td>albl_up_Developer</td>
<td>Developer</td>
</tr>
<tr>
<td>albl_up_Drafter</td>
<td>Drafter</td>
</tr>
<tr>
<td>albl_up_Educational</td>
<td>Educational</td>
</tr>
<tr>
<td>albl_up_Engineering</td>
<td>Engineering</td>
</tr>
<tr>
<td>albl_up_Full</td>
<td>Full</td>
</tr>
<tr>
<td>albl_up_PC_Detailing</td>
<td>Precast Concrete Detailing</td>
</tr>
<tr>
<td>albl_up_Rebar_Detailing</td>
<td>Rebar Detailing</td>
</tr>
<tr>
<td>albl_up_Steel_Detailing</td>
<td>Steel Detailing</td>
</tr>
<tr>
<td>albl_up_Tekla_Structures_Primary</td>
<td>Primary</td>
</tr>
<tr>
<td>albl_up_VIEWer</td>
<td>Project Viewer</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Editing mode</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>main_menu</td>
<td>Modeling ribbon</td>
</tr>
<tr>
<td>edit_draw_menu</td>
<td>Drawing ribbon</td>
</tr>
<tr>
<td>plan_main_menu</td>
<td>Importing ribbon</td>
</tr>
</tbody>
</table>

**Distribute custom tabs using a firm or environment folder**

As an alternative to customized ribbon files, which override the existing ribbon, you can import external custom tabs to the ribbon. The custom tabs are automatically appended to the end of the ribbon for all users who use the same firm or environment folder. This means that an administrator can distribute customizations to all users in the company while still allowing individual users to customize their ribbons as well.

Note that these custom tabs do not appear in the customization tool, so the users are not able to edit them. If the administrator has updated the contents of a custom tab, the users will receive an update when they restart Tekla Structures. Tabs are not configuration specific, so they are imported regardless of the user's Tekla Structures license. If the tab contains commands that are not available in the user's configuration, they will appear dimmed on the ribbon.

1. Create the following folder structure in your company's firm folder or in the \system folder, which is located under your environment folder: ..\ProgramData\Tekla Structures\<version>\Environments \<environment>\system.
2. In the ribbon customization tool (page 8), create a custom tab and add some commands to it.

3. Save the ribbon.

4. Go to the ..\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\UI\Ribbons folder.

5. In a text editor, open the ribbon file which contains the tab you wish to share with other users.

6. Remove all the other content from the ribbon file except the first row and the description of the tab you wish to share.

For example:

```
<Tab Header="My Tab" IsCollapsed="false" IsUserDefined="true">
  <SimpleButton X="0" Y="0" Width="3" Height="4"
  Command="Common.Interrupt" Text="command:ShortText"
  Icon="command:BigIcon" ShowText="true" ShowIcon="true" />
</Tab>
```

7. Save the file with a new name in the ..\CustomTabs\Modeling or ..\CustomTabs\Drawing folder.

Tab files have the file name extension *.xml. We recommend that you use the same name as for the tab. For example, MyTab.xml. The file name is not case sensitive.

The tab will be added to either the modeling or drawing mode ribbons, depending on the folder it is located in. Note that there can be several custom tab files in the same folder. They are added to the ribbon one after the other. Note that if the same tab file exists in both the environment and firm folders, the firm version overrides the environment version.

**NOTE** To avoid file name conflicts, we recommend that administrators prefix all custom tab files with the company name, and that extension developers prefix all custom tab files with the name of the extension (for example, MyExtension_TabName.xml).

8. If the tab contains user-defined commands, copy the UserDefined.xml file from the ..\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\UI\Commands folder to the \Commands folder created in step 1.
The custom tab now appears at the end of the ribbon.

2.2 Customize the contextual toolbar
You can customize the contextual toolbar by selecting which toolbar elements are visible. You can also adjust the width of the elements, and add icons and additional titles to the elements.

Customize contextual toolbar
1. On the contextual toolbar, click \[\text{...}\].
2. By selecting and clearing check boxes, define which toolbar elements you wish to show or hide.  
The \text{Preview} area shows what the toolbar will look like. For example:

![Preview example](image)

3. To modify the toolbar elements:
   a. Click the toolbar element.  
      If the element can be modified, the following box appears:

      ![Modification box](image)

   b. Use the slider to adjust the width of the toolbar element.
   c. To add an additional title, click the text box and enter a title.
   d. To add an icon, click \[\text{...}\] and select an icon from the list.
To remove the icon or title, click ☐.

4. To add macros and user-defined attributes:
   a. Select the desired macro or user-defined attribute from the list.
   b. Click Add.
      Tekla Structures adds the macro or user-defined attribute to the list of toolbar elements and to the Preview image. For example:

   ![Preview Image]

   c. To hide the macro or user-defined attribute, clear the corresponding check box as described in step 2.

5. Click OK to save the changes.

Create user profiles for contextual toolbars
You can create multiple profiles for contextual toolbars. Each profile contains the same contextual toolbars, but with different settings.

1. On the contextual toolbar, click ☐.
2. Click Set profiles.
3. Select New profile from the list.
4. Enter a name for the profile.
5. Click Save.
6. Customize the contextual toolbar. (page 24)
   For example, remove some elements from the contextual toolbar.
7. Click OK to save the changes.
   The user profile is now active with the settings you defined.
8. To switch to another profile:
   a. Click Set profiles.
   b. Select another profile from the list.
   c. Modify the settings.
   d. Click OK.
      This user profile is now active.
Back up and share contextual toolbars

We advice you to save a backup copy of your customized contextual toolbars. You can use the backup file to copy settings to another computer or to share the customizations with your co-workers.

1. Save the contextual toolbar under a user profile, with a name that you can easily recognize. For example, MyContextualToolbar.

2. Go to the ..\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\ContextualToolbar\Profiles folder.

3. Make a copy of your customized contextual toolbar and save it in the corresponding folder on another computer.

4. To open a customized contextual toolbar on another computer:
   a. On the contextual toolbar, click ⚙.
   b. Click Set profiles.
   c. Select the correct profile from the list. For example, MyContextualToolbar, if that is the name you used in step 1.
   d. Click OK. The customizations are now active.

NOTE Alternatively, you can place the entire ContextualToolbar folder to your company's firm folder or in the system folder, which is located under your environment folder: ..\ProgramData\Tekla Structures\<version>\Environments\<environment>\system.

2.3 Customize the keyboard shortcuts

In the Keyboard shortcuts dialog box, you can view a list of all shortcuts available in Tekla Structures. You can define new keyboard shortcuts and remove existing ones. After customization, you can export the keyboard shortcuts and share them with your co-workers.

Define new keyboard shortcuts

You can assign keyboard shortcuts to any command, macro, or component. You can even change the default keyboard shortcuts, if needed.

1. On the File menu, click Settings --> Keyboard shortcuts.
The **Keyboard shortcuts** dialog box opens.

2. In the **Group** list, select the shortcut group you want to modify. A list of commands and shortcuts appears.

3. If you want to search for a particular command or keyboard shortcut, enter some text in the **Filter** box.

   For example:
   - Type `grid` to only see the commands whose name contains the word "grid".
   - Type "+" to get a list of shortcuts that consist of two parts (such as `Ctrl + S`).

General 27 Customize the keyboard shortcuts
• Type ", " to get a list of shortcuts that consist of two consecutive keys (such as \texttt{M, N}).

4. Select a command from the list.
5. Click \texttt{Enter shortcut}.
6. On the keyboard, enter the combination of keys you would like to use as the shortcut.
7. Check the \texttt{Conflicts} box to see if the keyboard shortcut is already assigned to another command.
   
   If the shortcut is already in use, enter a different combination of keys.

\textbf{NOTE} \ If you reassign a keyboard shortcut that is already used, it will no longer be associated with the command it was originally assigned to.

8. Click \texttt{Assign} to save the keyboard shortcut.

\textbf{Clear and reset shortcuts}

You can remove any existing shortcut. You can also reset all shortcuts back to the defaults.

1. On the \texttt{File} menu, click \texttt{Settings} \texttt{--> Keyboard shortcuts}.
2. To remove a keyboard shortcut, select the command from the list and click \texttt{Clear}.
3. To reset all the keyboard shortcuts to the defaults, click the \texttt{Restore} button.

\textbf{Export keyboard shortcuts}

You can export your customized keyboard shortcuts and share them with your co-workers.

1. On the \texttt{File} menu, click \texttt{Settings} \texttt{--> Keyboard shortcuts}.
2. Click \texttt{Export}.
3. Enter a file name and location.
4. Click \texttt{Save} to export the keyboard shortcuts.
5. To share your keyboard shortcuts with other users, send them the exported file.
Import keyboard shortcuts
You can import keyboard shortcuts from a file. Use this method to import keyboard shortcuts from Tekla Structures 2016 or newer.

1. On the File menu, click Settings --> Keyboard shortcuts.
2. Click Import.
3. Browse for the shortcuts file you want to import. For example, ..\Users <user>\AppData\Local\Trimble\TeklaStructures 2016\Settings\KeyboardShortcuts_4.xml.
4. Click Open to import the keyboard shortcuts.
3.1 Modify the default attributes of Custom Inquiry tool

Use the InquiryTool.config file to control which attributes are shown as default attributes in the Manage contents dialog box in the Custom Inquiry tool.

Tekla Structures searches for the InquiryTool.config file in the following folders in the following order:

1. \attributes folder in the model folder
2. \CustomInquiry subfolder in the folder defined by XS_PROJECT
3. \CustomInquiry subfolder in the folder defined by XS_FIRM
4. \CustomInquiry subfolder in the folder defined by XS_SYSTEM

If you specify several folders that have \CustomInquiry as a subfolder, Tekla Structures uses the first folder it finds.

To add new attributes to the InquiryTool.config file:

1. Open the InquiryTool.config file in any standard text editor.
2. Copy the entire contents of [ATTR_CONTENT_??] to the end of the file.
3. Change the position number of the new attribute.
   For example, change [ATTR_CONTENT_??] to [ATTR_CONTENT_66].
4. Modify the NAME, DISPLAY_NAME, DATATYPE, UNIT, and DECIMAL values of the new attribute. Use the attribute names and definitions that are included in the contentattributes_global.lst or contentattributes_userdefined.lst file.
5. Change the TOTAL_ATTR_CONTENT value to reflect the total number of attributes in the file.
   For example, change TOTAL_ATTR_CONTENT=65 to TOTAL_ATTR_CONTENT=66.
6. Save the file.
3.2 Define custom phase properties
You can add custom phase properties, which will appear as extra columns in the Phase Manager dialog box.

Define the names of phase properties in the objects.inp file. To use phase properties in reports and templates, use the syntax `PHASE.ATTRIBUTE_NAME` in the phase property field name.

3.3 Create user-defined cross sections for welds
You can define special cross sections for model welds. This is useful when you need weld cross sections that are not predefined in Tekla Structures.

For example, you can create bevel backing welds:

To find the welds in the model that have a user-defined cross section, set Category to Weld and Property to User-defined cross section in the selection or view filter, or in the color and transparency settings.

Define a user-defined cross section for a weld
1. Select the weld you want to modify.
2. Right-click and select Define Cross Section.
3. In the weld cross section editor view:
   a. Pick points to indicate the weld cross section corners.
   b. Click the middle mouse button to finish picking.
**Remove a user-defined cross section from a weld**
You can remove user-defined cross sections from model welds and revert to the previous standard cross sections.

1. Select a weld that has a user-defined cross section.
2. Right-click and select **Remove Cross Section**.

   Tekla Structures removes the user-defined cross section and uses the previous standard cross section and properties for the weld.

**Limitations**

- User-defined weld cross sections are reported using only the above-line properties.
- User-defined weld cross sections do not create automatic weld preparation.
4 Drawings

4.1 Customize printing

Customize print output file names
You can affect the way Tekla Structures automatically names the .pdf files and plot files by using certain drawing-type-specific advanced options.

1. On the File menu, click Settings --> Advanced options and go to the Printing category.
2. Enter values for any or all of the advanced options
   XS_DRAWING_PLOT_FILE_NAME_A, XS_DRAWING_PLOT_FILE_NAME_W, XS_DRAWING_PLOT_FILE_NAME_G, XS_DRAWING_PLOT_FILE_NAME_M, or XS_DRAWING_PLOT_FILE_NAME_C.
   The letter at the end indicates the drawing type. You can also combine several values. The values are not case sensitive.
3. Click OK.

Example:
Use single % around the values. The example below results in the following assembly drawing .pdf name: E_P1_PLATE_Revision=2.pdf:

   XS_DRAWING_PLOT_FILE_NAME_A=E_%NAME.%_%TITLE%REV?_Revision=%REV%.pdf

Possible values

<table>
<thead>
<tr>
<th>Value</th>
<th>Example of the result</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>%NAME%</td>
<td>P_1</td>
<td>Part, assembly, or cast unit position, using the file name format prefix_number.</td>
</tr>
<tr>
<td>Value</td>
<td>Example of the result</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-----------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>%NAME.-%</td>
<td>P-1</td>
<td>Part, assembly, or cast unit position, using the file name format prefix-number.</td>
</tr>
<tr>
<td>%DRAWING_NAME.-%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%NAME.%</td>
<td>P1</td>
<td>Part, assembly, or cast unit position, using the file name format prefixnumber.</td>
</tr>
<tr>
<td>%DRAWING_NAME.%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%REV%</td>
<td>2</td>
<td>Drawing revision number.</td>
</tr>
<tr>
<td>%REVISION%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%DRAWING_REVISION%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%REV_MARK%</td>
<td>B</td>
<td>Drawing revision mark.</td>
</tr>
<tr>
<td>%REVISION_MARK%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%DRAWING_REVISION_MARK%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%TITLE%</td>
<td>PLATE</td>
<td>Drawing name from the drawing properties dialog box.</td>
</tr>
<tr>
<td>%DRAWING_TITLE%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%UDA:&lt;drawing user-defined attribute&gt;%</td>
<td>Painted</td>
<td>Value of a user-defined drawing attribute. The user-defined drawing attributes are defined in objects.inp. The actual values for the user-defined attributes are entered in the drawing-specific user-defined attributes dialog box.</td>
</tr>
<tr>
<td>%REV? - &lt;text&gt;%</td>
<td>2 - Rev</td>
<td>Adds conditional prefixes. In this example, if REV exists, Tekla Structures adds the text between ? and % to the filename.</td>
</tr>
<tr>
<td>%TPL:&lt;template attribute&gt;%</td>
<td>Base plate</td>
<td>You can use template attributes that can be found in Template Editor. The actual values for these attributes are entered in the drawing properties dialog box. Examples:</td>
</tr>
<tr>
<td>%TPL:TITLE1%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%TPL:TITLE2%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%TPL:TITLE3%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%TPL:DR_DEFAULT_HOLE_SIZE %</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%TPL:DATE%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>%TPL:TIME%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td>Example of the result</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-----------------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>%TPL:DR_DEFAULT_WELD_SIZE %</td>
<td>•</td>
</tr>
</tbody>
</table>

**NOTE**  The print output file name switches %DRAWING_NAME% and %NAME% that should produce an underscore in the print file name (P_1) do not work if XS.Assembly.Position.Number.Format.String does not use a separator between the values (for example, %ASSEMBLY_PREFIX% %ASSEMBLY_POS%), or if XS.Use.Assembly.Number.For is set.

To make the switches work, do the following:

- If you want to use XS.Assembly.Position.Number.Format.String, use a dot (.) slash (/) or hyphen (-) between the values, for example, %ASSEMBLY_PREFIX%.%ASSEMBLY_POS%, or similar.
- Leave XS.Use.Assembly.Number.For empty.

### 4.2 Customize symbols

Most of the weld type symbols are hard coded, but you can edit some of them in Symbol Editor.

**Customize weld symbols**

The bottom seven symbols in the **Type** list in model Weld Properties and drawing Weld Mark Properties (see image below) are taken from the TS_Welds.sym file. You can edit any of these seven symbols in Symbol Editor to create a custom weld symbol. The rest of the weld symbols are hard coded.
Note that the symbol in the **Type** list in the dialog box does not change when you update the symbol.

1. Open Symbol Editor as administrator.
2. Click **File --> Open** and browse to the folder were you have the `TS_Welds.sym` file.
3. Select the file and click **OK**.
4. Modify the desired symbol.
When doing this, you need to keep the symbol in the same scale as the other symbols. If your symbol is too large to fit in the box, you can let it extend beyond the borders:

5. Save the symbol by selecting File --> Save.

For details about welds in drawings, see Welds in drawings.

**Customize bolt symbols**

You can create your own bolt symbols in Symbol Editor and use them in drawings. You only need to create bolt symbols if you need different bolt symbols than the ones that you can find in Tekla Structures.

1. Save the symbol file `ud_bolts.sym` in the symbol folder (usually the folder `..\Tekla Structures\<version>\environments\common \symbols\`).
2. Open Microsoft Notepad, or any text editor.
3. Create a text file consisting of lines in three columns:
   • The first column contains the bolt assembly standard.
   • The second contains the bolt diameter.
   • The third column contains the name of the symbol file and the symbol number, separated with the @ character.

   **Example of file contents:**

   7990 24 ud_bolts@1
Tekla Structures uses the user-defined symbol for bolts in drawings that have the standard and diameter you define in this text file.

4. Save the file with the name bolt_symbol_table.txt.

5. Set the name of the file as a value for the advanced option XS_USER_DEFINED_BOLT_SYMBOL_TABLE in File menu --> Settings --> Advanced options --> Marking: Bolts as follows:

   XS_USER_DEFINED_BOLT_SYMBOL_TABLE=bolt_symbol_table.txt

   You can also enter a full path to the bolt definition file. Without the path Tekla Structures searches for the file in the model, firm, project, and system directories.

6. To use your own bolt symbol, click Bolt --> Content --> Solid/Symbol --> User-defined symbol in the drawing view properties dialog box.

   For details about automatic bolt settings, see Automatic drawing bolts

   **Customize leader line arrow symbols**

   If you do not find a suitable leader line arrow in the Arrow list in the Mark Properties dialog box, you can add an arrow of your own.

   First you will create the arrow symbol in the Symbol Editor, and save the created symbol in the arrow.sym file. Then you need to add the position of the new symbol in the arrow.sym to the configuration file arrow.txt file, which tells which arrows are available for use in your environment.

   1. On the File menu, click Editors --> Symbol Editor to open the Symbol Editor.

   2. Open the arrow.sym file located in common environment or in your environment under symbols folder.

   3. Click an empty symbol slot and sketch your symbol with drawing tools.

   You can also import AutoCAD or MicroStation files through File --> Import.

   4. When the symbol is completed, point the symbol slot to check the number of the new symbol at the bottom of the window.
5. Save the arrow.sym file by clicking **File --> Save**.

6. Click **File --> Exit** to close the Symbol Editor.

7. Open the arrow.txt file located in the same symbols folder as the arrow.sym file.

   The file contains a list of symbol numbers.

8. Add the number of your symbol preceded by zero (0) in the correct position and separate it with a comma:

   016,017,018,019,020,021,022,023,024,032,048,049,101,102,110,200

9. Click **File --> Save** to save your change.

10. Add a bitmap of the created arrow in the `..\ProgramData\Tekla Structures\<version>\Bitmaps` folder on your computer.

    Use the following format in the file name:
    `dr_dialog_arrow_type_022.bmp`.

11. Double-click a mark in a drawing to open the **Mark Properties** dialog box.

12. Open the **Arrow** list, and you should see that the new arrow symbol is now available for use.
**NOTE** We recommend you define a firm folder for symbols, because the default folders are overwritten when you upgrade to a newer version of Tekla Structures. Add the firm folder to the advanced option DXK_SYMBOLPATH.

For details about leader lines, see Leader line types, Adjust text, frames and leader lines of automatic marks, and Adjust part mark leader lines with advanced options.

### 4.3 Customize line types

**Define customized line types in TeklaStructures.lin**

You can define your own line types, and use them wherever line type settings are available. The customized line types are handled the same way as other line types. The customized line types are defined in the `TeklaStructures.lin` file in `..\ProgramData\Tekla Structures\<version>\environments\common\inp`. By default, the most widely used line types are available in the file.

2. Start every line with the letter A to indicate the beginning of the line type pattern.
   You can use three different objects: dashes, dots and spaces to form a line.

3. Define the length of a dash (\-) using positive numbers.

4. Define the length of a space (\ ) using negative numbers.

5. Define dots (\.) using the number zero (0).
   The patterns must begin with a dash. They typically end with a space, although the space in the end is not required.

6. After you have defined the line type pattern, press Enter.

The TeklaStructures.lin.id file contains the names of the line types visible in the user interface and the unique IDs assigned for each line type. The value of the ID must be greater than 10, for example:

CENTER, 1000
BORDER, 1002
DASHDOT, 1003

You can use TeklaStructures.lin also in mapping the exported line types.

---

**NOTE** If you add new customized line types, you need to add corresponding bitmaps to the ..\ProgramData\Tekla Structures\<version>\bitmaps folder, and name them dr_line_type_.bmp, for example dr_line_type_CENTER.bmp.

---

**Example 1**

Line type definition for DASHDOT is A, 12.7, -6.35, 0, -6.35.

This string means that the pattern starts with a dash with the length of 12.7 units, followed by a space with the length of 6.35 units, then a dot, and then again a space with the length of 6.35 units. Then the first dash is drawn again.
Example 2

Below is an example containing definitions for dotted lines:

*DOT, Dot .................................................................
A, 0, -1.5875

*DOT2, Dot (.5x) .......................................................  
A, 0, -0.79375

*DOTTX2, Dot (2x) ....................................................
A, 0, -3.175

4.4 Custom presentations in drawings

You can modify the appearance of many of the objects in drawings using custom presentations. Custom presentations are delivered in Tekla Warehouse as extensions. The presentations can be controlled on the view level and object level.

When you have downloaded a custom presentation for an object type, the Custom presentation tab will become available in the drawing property dialog for that object. The list will only show custom presentations that are available for that specific object type – part, weld, mark, etc.
The following object types support custom presentations:

- welds and weld marks
- parts and part marks
- neighbor parts and part marks
- grid lines
- texts
- associative notes

**Examples**

In the example below, the **Weld solid** custom presentation is used for drawing the weld solids.

In the following example, **Corners Only** custom presentation is used for laser layout projection. Drawing all the lines of a part slows down the laser and makes it too dim to see on the layout table.

**Custom presentations in Tekla Warehouse**

- Center of gravity
- GA schedules
Custom presentations in drawings
5  Catalogs

5.1  Customize the profile catalog

The profile catalog contains information on profiles, their rules and types, and the analysis and design properties of the profiles. Profiles are displayed in a hierarchical tree grouped according to rules.

By default, the profile catalog contains standard, environment-specific profiles and generic parametric profiles. You can add, modify, import, export, and delete profiles.

You can define your own user-defined profiles, which can be either fixed or parametric. Use the profile catalog to create new fixed profiles, either from scratch or by copying an existing one. Use the sketch editor or .clb files to create new parametric profiles.

Tekla Structures stores the profile catalog information in the profdb.bin file.

See also

- Important buttons in the profile catalog (page 45)
- Group profiles together (page 46)
- Add user attributes to profiles (page 48)
- Associate profile types with a certain material (page 51)
- Delete a profile from the profile catalog (page 52)
- Import and export profiles (page 53)
- Create your own profiles (page 60)
- Define standardized values for parametric profiles (page 97)
- Create an image of a profile (page 97)
- Customize the shape catalog (page 98)
**Important buttons in the profile catalog**

When you work with the profiles, note the usage of the following buttons in the **Modify Profile Catalog** dialog box:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Update" /></td>
<td>Saves the changes of a single edited profile to the computer's memory until you click <strong>OK</strong>.</td>
</tr>
<tr>
<td><img src="image" alt="OK" /></td>
<td>Saves the changes in the model folder. Tekla Structures saves the modified catalog on the hard disk when you click <strong>OK</strong> to close the dialog box and then click <strong>OK</strong> in the <strong>Save confirmation</strong> dialog box.</td>
</tr>
<tr>
<td><img src="image" alt="Cancel" /></td>
<td>Closes the <strong>Modify Profile Catalog</strong> dialog box without saving the changes. Note that all changes made to the catalog will be lost even if you have clicked <strong>Update</strong>, because the changes have not been saved on the hard disk. The changes made to the catalog are visible during one session, because the catalog is using the computer's memory. When you start Tekla Structures the next time, the previous data is restored from the hard disk.</td>
</tr>
</tbody>
</table>

Tekla Structures stores the information of fixed profiles in the **profdb.bin** file. When you first open a model, Tekla Structures reads the data from the hard disk and stores it in the computer's memory.

When you select a profile, Tekla Structures reads the data from the computer's memory and displays it in the **Modify Profile Catalog** dialog box. This is faster than accessing the data from the hard disk.

**See also**

*Customize the profile catalog* (page 45)

**Group profiles together**

In the profile catalog, the profiles are displayed in a hierarchical tree and they are grouped according to rules ![image](image), such as the profile type (for example, **I profiles**) and the profile subtype (for example, **HEA**). To change how the profiles are grouped in the profile tree, you need to modify the rules.

The order in which you create the rules does not matter, only the location of the rules in the profile tree.

Tekla Structures reads the rules from top to bottom in the profile tree. Profiles are in the highest group where they meet the criteria defined in the rule. For example, a rule that collects **All profiles** overrides all rules that are below it in the profile tree.
See also
Add a rule to the profile catalog (page 47)
Modify a rule in the profile catalog (page 47)

**Add a rule to the profile catalog**

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.
2. Right-click any existing rule and select **Add Rule**.
   The **Profile manager rules** dialog box appears.
3. Define the rule properties.
   a. Enter a rule name in the **Rule name** box.
   b. Select the **Profile type** to which the rule is applied.
   c. Enter the **Name filter string** that defines the new rule.
      By default, the wildcard symbol (*) is entered, meaning “all entries”.
      For example, to group all catalog entries with names beginning with A, enter A* in the **Name filter string** box, or to group all catalog entries with names containing 100, enter *100*. Tekla Structures groups the catalog entries that meet your criteria under the new rule.
4. Click **OK** to close the **Profile manager rules** dialog box.
5. Click **OK** to close the **Modify Profile Catalog** dialog box.
6. Click **OK** in the **Save confirmation** dialog box to save the changes.

**TIP**  You can add a next level rule that creates a subgroup under an existing rule. Use the **Add Next Level Rule** command to add the next level rule.

See also
Modify a rule in the profile catalog (page 47)

**Modify a rule in the profile catalog**

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.
2. Right-click any existing rule and select **Edit Rule**.
   The **Profile manager rules** dialog box appears.
3. Modify the rule properties.
4. Click **OK** to close the **Profile manager rules** dialog box.
5. Click **OK** to close the *Modify Profile Catalog* dialog box.

6. Click **OK** in the *Save confirmation* dialog box to save the changes.

Profiles in the profile tree are listed in an alphabetical order, and rules are listed in the order you specify. To change the order in which the rules appear, use the *Move up* and *Move down* commands.

**TIP** If you want to delete a rule, right-click an existing rule and select **Delete Rule**.

**See also**

*Add a rule to the profile catalog (page 47)*

---

**Add user attributes to profiles**

You can add your own attributes to profiles. For example, you can specify paint layer thickness, define the maximum grain size of concrete, sort out different profile types by material, or create profile aliases for converting imperial profiles to metric and vice versa.

1. On the *File* menu, click *Catalogs --> Profile catalog* to open the *Modify Profile Catalog* dialog box.

2. On the *User attributes* tab, click *Definitions*.

   The *Modify Profile Properties* dialog box appears.

3. Click *Add* to add a new row.

4. To define a user attribute, click each item on a row.

   a. In the *Profile type* list, select a profile type to which the user attribute is applied.

   b. In the *Quantity type* list, select the type of information that the user attribute contains, for example, weight, area, ratio, or string.

   c. In the *Order* list, define the order in which the user attributes are shown in the dialog box. Larger values are shown first.

   d. In the *Property name* list, define a name for the property.

      The name is saved in the catalog and can be used in reports and templates. When *Property name* is used in a template, `PROFILE.PROPERTY_NAME` indicates where the property name appears. For example, `PAINT_LAYER_THICKNESS`.

   e. In the *Symbol* column, define an abbreviation that can be used for the property, such as `Ix` or `ct`.

   f. In the *Label* column, define a label for the attribute.

5. Click **Update**.
6. Click **OK** to close the **Modify Profile Properties** dialog box.

**See also**

Example: Add a user attribute to a profile and use it in a rule (page 49)

---

**Example: Add a user attribute to a profile and use it in a rule**

You can add your own attributes and their values to profiles. The user attributes can then be used, for example, in profile filtering.

In this example, you will add a user attribute for I profiles' rule.

1. On the **File** menu, click **Catalogs --&gt; Profile catalog** to open the **Modify Profile Catalog** dialog box.
2. On the **User attributes** tab, click **Definitions**.
   
   The **Modify Profile Properties** dialog box appears.
3. Click **Add** to add a new row.
4. Select the row that was created and modify the properties as follows:
   - Set **Profile type** to **I profiles**.
   - Set **Quantity type** to **String**.
   - Set **Property name** to **HISTORICAL_PROFILE**.
   - Set **Symbol** to **Hist**.
   - Set **Label** to **Historical profile**.
5. Click **Update** and **OK**.
6. In the profile tree, select **I profiles** and then **HEA**.
7. Right-click and select **Add Next Level Rule**.
8. In the **Profile manager rules** dialog box, set the rule properties as follows:
   - Set **Rule name** to **Historical profiles**.
   - In **Profile type**, clear the **All profiles** check box and select the **I profiles** check box.
• Enter HEA* in the Name filter string box.

• Set User attribute to HISTORICAL_PROFILE and Equals, and enter Yes in the box next to the two other boxes.

9. Click OK.

Historical profiles appears in the profile tree.

10. Select the required historical profile, for example HEA120, in the profile tree.

11. Go to the User attributes tab and set Value of Historical profile to Yes.

12. Click Update.
13. Repeat the steps 10 and 11 for any other required profiles.
14. Click OK to close the Modify Profile Catalog dialog box.
15. Click OK in the Save confirmation dialog box to save the changes.
Next time you open the profile catalog, the profiles appear under Historical profiles in the profile tree.

See also
Add user attributes to profiles (page 48)
Add a rule to the profile catalog (page 47)

Associate profile types with a certain material
You can define which profiles are available for steel parts, concrete parts, or both. This affects which profile types are shown in the Select Profile dialog box when you change the material of a part.

To define the material of a profile type:
1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
2. Select a profile type, for example, L profiles.
3. To associate the profiles with steel, right-click and select Material --> Steel.
A check mark next to **Steel** indicates that the profiles are available for steel parts.

4. To make the selected profiles available also for concrete parts, right-click and select **Material --> Concrete**.

   If needed, you can remove the check mark by clicking the material again.

5. Click **OK** to close the **Modify Profile Catalog** dialog box.

6. Click **OK** in the **Save confirmation** dialog box to save the changes.

**Delete a profile from the profile catalog**

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.

2. Select the profile that you want to delete.

3. Right-click and select **Delete Profile**.

4. Click **OK** to close the **Modify Profile Catalog** dialog box.

5. Click **OK** in the **Save confirmation** dialog box to save the changes.

Tekla Structures will continue showing parts in model views using the deleted profiles until you modify the parts or reopen the model. After that, the parts
having profiles that are not available in the profile catalog, are shown as sticks without a profile.

See also
Customize the profile catalog (page 45)

Import and export profiles
Use importing and exporting for merging profiles across profile catalogs. Profile catalogs are imported and exported as .lis files, sketched profiles as .uei files, and user-defined parametric profiles as .clb files.

When you export an entire profile catalog, Tekla Structures creates three separate files: profiles.clb, profiles.lis and rules.lis. The .clb file contains parametric profile definitions, if they are used in the profiles in the catalog, otherwise it is empty. The profiles.lis file includes the actual profile definitions and the rules.lis file the branch rules. When you export a branch of a profile catalog, the branch name is attached as prefix to the file names.

Importing and exporting is useful when you:
• upgrade to a newer version of Tekla Structures and want to use a customized profile catalog from a previous version
• want to combine profile catalogs that are stored in different locations
• want to share profile catalog information with other users
• want to combine profile catalogs across different environments.

Limitations
• You cannot import or export hard-coded profiles such as PROFILE_ZZ, PROFILE_CC, and PROFILE_CW.
• You cannot import profiles that do not have a defined cross section.
• If you have used a sketched profile or a user-defined parametric profile as the cross section for a fixed profile, you also need to import the sketched profile or the user-defined parametric profile to the new model.

TIP  You can also download or share profiles using Tekla Warehouse.

See also
Export an entire profile catalog (page 55)
Export a part of the profile catalog (page 55)
Import profile catalog items (page 54)
Import and export sketched profiles (page 59)
**Import profile catalog items**

Tekla Structures has five types of profile catalog items: fixed profiles, hard-coded parametric profiles, sketched profiles, user-defined parametric profiles, and rule sets. Profiles and rule sets are imported to Tekla Structures models as .lis files, sketched profiles as .uel files, and user-defined parametric profiles as .clb files.

If you are importing an entire profile catalog or a branch, we recommend that you save the related files in a separate folder. This makes the import process faster.

1. Open the model to which you want to import profile catalog items.
2. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.
3. Click **Import** to import a single file, or **Import Directory** to import the contents of a file folder.
4. Select the import file or the import folder.
5. Click **OK**.

If a profile item with the same name as the profile item being imported already exists, the **Review import items** dialog box appears, and you have four options:

- **Leave**: The existing profile item is not replaced and the profile definitions in the import file are ignored.
- **Merge**: Profile properties that are different in the import file are added to the existing profile. All the other properties remain unchanged. Use this option to import only certain elements of the profile catalog, such as user attributes.
- **Replace**: The existing profile item is replaced with the imported profile item.
- **Continue**: The dialog box closes and the actions you selected take place. If an import item has **Unknown** as the action, it is not imported.

You can select more than one profile item at a time by using the **Shift** and **Ctrl** keys.

**NOTE** Each cross section definition has a unique name and ID number. If, during an import, a cross section with the same name but different properties is found in the existing profile catalog, the cross section being imported is renamed by adding an incremental number at the end of the existing name.

6. Click **OK** to close the **Modify Profile Catalog** dialog box.
7. Click **OK** in the **Save confirmation** dialog box to save the changes.
See also
Import and export profiles (page 53)
Export an entire profile catalog (page 55)
Export a part of the profile catalog (page 55)
Import sketched profiles (page 59)
Units used in import and export (page 57)

Export an entire profile catalog
Profile catalogs are exported from Tekla Structures models as .lis, .uel, and .clb files.
1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
2. Click Export.
3. Browse for the folder where you want to save the export files.
   By default, the files are saved to the current model folder. For faster profile catalog import, we recommend that you create a separate subfolder for the catalog files.
4. Click OK to close the Modify Profile Catalog dialog box.

See also
Import and export profiles (page 53)
Export a part of the profile catalog (page 55)
Example of profile export file (page 56)
Import profile catalog items (page 54)
Units used in import and export (page 57)

Export a part of the profile catalog
If you do not want to export an entire profile catalog, you can export a branch of the profile tree, meaning all the profiles grouped under one rule, or a single profile. Profiles and rule sets are exported from Tekla Structures models as .lis files, sketched profiles as .uel files, and user-defined parametric profiles as .clb files.
1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
2. Select profiles to be exported.
   • To export a branch of the profile tree, right-click the branch and select Export Profiles.

Catalogs 55 Customize the profile catalog
• To export a single profile, right-click the profile and select Export Profile.

3. Browse for the folder where you want to save the export files. By default, the files are saved to the current model folder. If you are exporting a single profile, enter a name for the file.

4. Click OK.

5. Click OK to close the Modify Profile Catalog dialog box.

See also
Export an entire profile catalog (page 55)
Example of profile export file (page 56)
Import profile catalog items (page 54)
Units used in import and export (page 57)

Example of profile export file

The export .lis file is divided into specific sections.
The first row in the file is PROFILE CATALOG EXPORT VERSION = n, where n is the version number.

**WARNING** Do not delete this row. If the row does not appear in the file, the import is canceled.

The next section defines the hierarchical tree structure that is used to display the contents of the catalog.
The next section contains the profiles.

Fixed profiles

```plaintext
PROFILE_NAME = "HEA120";
{
  TYPE = 1; SUB_TYPE = 1001; COORDINATE = 0.000;
  
  "FLANGE_SLOPE_RATIO" 0.0000000000E+000
  "ROUNDBING_RADIUS_2" 0.0000000000E+000
  "ROUNDBING_RADIUS_1" 1.2000000000E+001
  "FLANGE_THICKNESS" 8.0000000000E+000
  "WEB_THICKNESS" 5.0000000000E+000
  "WIDTH" 1.2000000000E+002
  "HEIGHT" 1.1400000000E+002
```

Fixed user-defined profiles

Fixed user-defined profiles can have more than one cross section. The profile type for fixed user-defined profiles is 998. SUB_TYPE refers to the name of the
cross section definition. When importing fixed user-defined profiles, the relevant cross section definitions must be in the same import file as the profile.

```plaintext
PROFILE_NAME = "TAN_HK_TEST_2_CS";
{
  TYPE = 998; SUB_TYPE = 253; COORDINATE = 0.000;
  {
    "EQUIVALENT_TYPE" = 11;
    "FLANGE_SLOPE_RATIO" = 0.0000000000E+000;
    "ECCENTRICITY_Y" = 0.0000000000E+000;
    "ECCENTRICITY_X" = 0.0000000000E+000;
    "ROUNDING_RADIUS_2" = 0.0000000000E+000;
    "FLANGE_THICKNESS_2" = 0.0000000000E+000;
    "WEB_THICKNESS_2" = 0.0000000000E+000;
  }
}
```

**Cross section definitions**

```plaintext
CROSS_SECTION_NAME = "MY_OWN_PROFILE"
POINT_NUMBER = 1;
POINT_X = 200.00;
POINT_Y = -200.00;
CHAMFER_TYPE = 0;
CHAMFER_X = 0.00;
CHAMFER_Y = 0.00;
POINT_NUMBER = 2;
POINT_X = 200.00;
POINT_Y = 200.00;
CHAMFER_TYPE = 0;
CHAMFER_X = 0.00;
CHAMFER_Y = 0.00;
```

See also

- Export an entire profile catalog (page 55)
- Export a part of the profile catalog (page 55)

**Units used in import and export**

The table below lists the units Tekla Structures uses when importing and exporting profile catalogs and material catalogs.

<table>
<thead>
<tr>
<th>Type</th>
<th>Unit (if blank, no unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boolean</td>
<td></td>
</tr>
<tr>
<td>Integer</td>
<td></td>
</tr>
<tr>
<td>String</td>
<td></td>
</tr>
<tr>
<td>Ratio</td>
<td></td>
</tr>
<tr>
<td>Strain</td>
<td></td>
</tr>
<tr>
<td>Angle</td>
<td>degree</td>
</tr>
<tr>
<td>Length</td>
<td>mm</td>
</tr>
</tbody>
</table>

Catalogs 57 Customize the profile catalog
<table>
<thead>
<tr>
<th>Type</th>
<th>Unit (if blank, no unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deformation</td>
<td>mm</td>
</tr>
<tr>
<td>Dimension</td>
<td>mm</td>
</tr>
<tr>
<td>Radius of inertia</td>
<td>mm</td>
</tr>
<tr>
<td>Area</td>
<td>mm²</td>
</tr>
<tr>
<td>Reinforcement area</td>
<td>mm²</td>
</tr>
<tr>
<td>Transverse reinforcement area</td>
<td>mm²/m</td>
</tr>
<tr>
<td>Area/unit length</td>
<td>mm²/m</td>
</tr>
<tr>
<td>Volume</td>
<td>mm³</td>
</tr>
<tr>
<td>Section modulus</td>
<td>mm³</td>
</tr>
<tr>
<td>Moment of inertia</td>
<td>mm⁴</td>
</tr>
<tr>
<td>Torsion constant</td>
<td>mm⁴</td>
</tr>
<tr>
<td>Warping constant</td>
<td>mm⁶</td>
</tr>
<tr>
<td>Force</td>
<td>N</td>
</tr>
<tr>
<td>Weight</td>
<td>kg</td>
</tr>
<tr>
<td>Distributed load</td>
<td>N/m</td>
</tr>
<tr>
<td>Spring constant</td>
<td>N/m</td>
</tr>
<tr>
<td>Mass/length</td>
<td>kg/m</td>
</tr>
<tr>
<td>Surface load</td>
<td>N/m²</td>
</tr>
<tr>
<td>Strength</td>
<td>N/m²</td>
</tr>
<tr>
<td>Stress</td>
<td>N/m²</td>
</tr>
<tr>
<td>Modulus</td>
<td>N/m²</td>
</tr>
<tr>
<td>Density</td>
<td>kg/m³</td>
</tr>
<tr>
<td>Moment</td>
<td>Nm</td>
</tr>
<tr>
<td>Distributed moment</td>
<td>Nm/m</td>
</tr>
<tr>
<td>Rotation spring constant</td>
<td>Nm/rad</td>
</tr>
<tr>
<td>Temperature</td>
<td>K (°C)</td>
</tr>
<tr>
<td>Thermal dilation coefficient</td>
<td>1/K (1/°C)</td>
</tr>
<tr>
<td>Factor</td>
<td></td>
</tr>
</tbody>
</table>

**See also**

- Import profile catalog items (page 54)
- Import a material catalog (page 109)
- Export an entire profile catalog (page 55)
- Export an entire material catalog (page 109)
Import and export sketched profiles

To use a sketched profile in other Tekla Structures models, you have to export the profile to a file (*.uel), and then import the file into another Tekla Structures model.

We recommend that you use the profile catalog to import and export sketched profiles. You can also use the Applications & components catalog to import sketched profiles together with related custom components.

See also
Import sketched profiles (page 59)
Export sketched profiles (page 59)

Import sketched profiles
After you have exported sketched profiles to a file, you can import them to another Tekla Structures model.

1. Open the Tekla Structures model you want to import to.
2. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
3. Click Import.
4. In the Import Profile Catalog dialog box, select *.uel from the Filter list.
5. Select the file to import.
6. Click OK.
7. Click OK to close the Modify Profile Catalog dialog box.
8. Click OK in the Save confirmation dialog box to save the changes.

TIP To automatically import all *.uel files from a folder when creating a new model, use the advanced option XS_UEL_IMPORT_FOLDER.

See also
Export sketched profiles (page 59)

Export sketched profiles

1. Open the Tekla Structures model you want to export from.
2. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
3. Right-click the profile you want to export and select Export Profile.
4. In the Export Profile Catalog dialog box, enter a name for the export file in the Selection box.
5. If you want to save the export file to a specific location, browse for the folder.
   By default, Tekla Structures saves the export file in the current model folder.
6. Click OK.

See also
Import sketched profiles (page 59)

Create your own profiles
You can create your own profiles and save them in the profile catalog.
Use any of the following methods to create user-defined profiles in Tekla Structures:

<table>
<thead>
<tr>
<th>Profile type</th>
<th>Creation methods</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed profile</td>
<td>• Create a fixed profile (page 66)</td>
</tr>
<tr>
<td></td>
<td>• Create a fixed profile by copying (page 68)</td>
</tr>
<tr>
<td></td>
<td>• Create a fixed profile based on a parametric profile (page 69)</td>
</tr>
<tr>
<td>Parametric profile</td>
<td>• Create parametric profiles by sketching (page 70)</td>
</tr>
<tr>
<td>Parametric profile with variable cross sections</td>
<td>• Create parametric profiles with variable cross sections (page 93)</td>
</tr>
</tbody>
</table>

Create user-defined cross sections
User-defined cross sections can be used for creating fixed profiles. Define the needed cross sections before creating the profile.

Use any of the following methods to define a cross section:
• Define a cross section using polygon (page 61)
  Use this method to create a cross section with fixed dimensions.
• Define a cross section using a plate (page 62)
  Use this method if you have a contour plate in the model.
• Define a cross section using a DWG file (page 64)
  Use this method if you have a .dwg file of the profile you want to define.
Define a cross section using polygon
Define a cross section by picking the shape of the cross section.


2. Define a cross section without or with inner contours.
   - To create a cross section with no inner contours:
     a. Pick the corner points of the cross section to define the shape. Start at the bottom-right corner and pick the points counter clockwise.
     b. Pick the start point and click the middle mouse button to close the shape.
     c. Pick the center point of the cross section.

   ![Diagram of a cross section with corner points labeled 1 to 8.]

   **TIP** To make it easier to define the shape, insert a reference model of the cross section in the model, and use the reference model as a basis for picking the cross section shape.

   Alternatively, you can create a few construction lines or points in the model and use them to define the cross section shape.

   If you do not have any actual points to pick, picking the center point of the cross section becomes difficult. This is because the cross section shape disappears after you have clicked the middle mouse button to close the shape.
• To create a cross section with inner contours:
  a. Pick the corner points of the cross section to define the shape.
  b. Pick the start point to close the shape.
  c. Pick the corner points of the cross section inner contour.
  d. Pick the start point to close the shape
  e. Repeat until you have picked all inner contours.
  f. Click the middle mouse button.
  g. Pick the center point of the cross section.

3. When the User Profile Cross Section dialog box appears, enter a name for the cross section.
4. Click OK to close the User Profile Cross Section dialog box.
5. Click OK in the Save confirmation dialog box to save the changes.
   You can now use the cross section in the profile catalog to create a new profile. The Profile type will be User-defined, fixed.

See also
Create a fixed profile (page 66)
Modify a user-defined cross section (page 65)
Define a cross section using a plate (page 62)
Define a cross section using a DWG file (page 64)

Define a cross section using a plate
You can define a cross section using a contour plate.
1. Create a contour plate that includes all the chamfers.
2. On the **File** menu, click **Catalogs --> Define profiles --> Define cross section using plate**.
   The **Profile Cross-Section from Plate (10)** dialog box appears.

3. On the **Parameters** tab, enter a name in the **Section name** and **Profile name** boxes.
   Other properties are optional.

4. Click **OK**.

5. Select the contour plate.
   Tekla Structures creates the cross section with the shape of the contour plate.
   You can now use the cross section in the profile catalog to create a new profile. The **Profile type** will be **User-defined, fixed**.

**See also**

Create a fixed profile (page 66)
Properties: Profile cross-section from plate (10) (page 63)
Define a cross section using polygon (page 61)
Define a cross section using a DWG file (page 64)

*Properties: Profile cross-section from plate (10)*
Use the **Parameters** tab to define the profile properties in the **Profile cross-section from plate (10)** component.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Section name</strong></td>
<td>Name of the cross section shown in the <strong>Modify Profile Catalog</strong> dialog box. If you leave this box empty, no profile is created.</td>
</tr>
<tr>
<td><strong>Profile name</strong></td>
<td>Name of the profile shown in the <strong>Beam Properties</strong> dialog box, and in the <strong>Modify Profile Catalog</strong> dialog box. If you leave this box empty, no profile is created.</td>
</tr>
<tr>
<td><strong>Save to</strong></td>
<td>The location of the profile catalog. Select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Model directory</strong>: The current model folder.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Global directory</strong>: ..\ProgramData\Tekla Structures &lt;version&gt;\environments&lt;environment&gt;\profil</td>
</tr>
<tr>
<td></td>
<td>• <strong>Don’t save</strong>: Does not save the profile. This is useful for testing.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Min distance between points</td>
<td>The minimum distance between the corner points of the cross section. To create simpler drawings of complicated cross sections, increase this value.</td>
</tr>
<tr>
<td>Center point offset</td>
<td>The origin of the plate defines the location of the profile reference line. Enter an offset value to move the reference line, relative to the cross section.</td>
</tr>
</tbody>
</table>

See also

Define a cross section using a plate (page 62)

Define a cross section using a DWG file
If a cross section is available in DWG format, you can import the cross section and add it as a DWG profile to the profile catalog.

Tekla Structures supports DWG files that have been created using version ACAD2012 or earlier.

Before you start defining a cross section using a DWG file:

- Save the outline of the cross section as a DWG file. Ensure that the DWG file only contains the outline of the profile.
- Make sure that the cross section is created as a closed polyline.
- Make sure that the outline consists of only one closed polyline. You cannot, for example, define holes to your cross section with this method. If you need holes or openings, use the polygon or the plate creation method.
- Remove hatching and unnecessary lines from the DWG file. Tekla Structures imports all the lines it finds in the DWG file.
- If there are blocks in the DWG file, they must be exploded.

1. Open a model.
2. On the File menu, click Catalogs --&gt; Define profiles --&gt; Define cross section using DWG file.
   The DWG Profile to Library (6) dialog box appears.
3. Define the cross section properties and click OK.
4. In the model, pick the start and the end points of the cross section to be imported.
   Tekla Structures imports the cross section and places the profile reference line at the origin of the DWG file.
   You can now use the cross section in the profile catalog to create a new profile. The Profile type will be User-defined, fixed.
See also
Create a fixed profile (page 66)
Properties: DWG Profile to Library (6) (page 65)
Define a cross section using polygon (page 61)
Define a cross section using a plate (page 62)

Properties: DWG Profile to Library (6)
Use the Parameters tab to define the profile properties in the DWG profile to library (6) component.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input file</td>
<td>Browse for the DWG file to be imported.</td>
</tr>
<tr>
<td>Section name</td>
<td>Name of the cross section shown in the Modify Profile Catalog dialog box.</td>
</tr>
<tr>
<td>Profile name</td>
<td>Name of the profile shown in the Modify Profile Catalog dialog box.</td>
</tr>
<tr>
<td>Save to</td>
<td>The location of the profile catalog. Select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>• Model directory: The current model folder.</td>
</tr>
<tr>
<td></td>
<td>• Global directory: ..\ProgramData\Tekla Structures &lt;version&gt;\environments&lt;environment&gt;\profil</td>
</tr>
<tr>
<td></td>
<td>• Don't save: Does not save the profile. This is useful for testing.</td>
</tr>
<tr>
<td>Min distance between points</td>
<td>The minimum distance between the corner points of the cross section. To create simpler drawings of complicated cross sections, increase this value.</td>
</tr>
<tr>
<td>Center point offset</td>
<td>The origin of the plate defines the location of the profile reference line. Enter an offset value to move the reference line, relative to the cross section.</td>
</tr>
</tbody>
</table>

See also
Define a cross section using a DWG file (page 64)

Modify a user-defined cross section
You can modify cross sections that have been defined using a polygon, a plate, or a DWG file.
1. Go to Quick Launch, start typing edit polygon cross section, and select the Edit Polygon Cross Section command from the list that appears. The Modify Cross Section dialog box appears.

2. Select the cross section you want to modify.

3. Modify the cross section point properties.
   - **Number** refers to each point picked when the cross section was created, in numerical order. The first point picked is 1, the second 2, and so on.
   - **Chamfer** refers to the chamfer shape.
   - **x:** and **y:** apply to the chamfer type. For example, if you want the chamfer to be equal on both sides of the angle, only enter a value for **x:**.
     For an uneven chamfer, enter values for **x:** and **y:**.

4. Click **Update**.

5. Click **OK** to close the Modify Cross Section dialog box.

6. Click **OK** in the Save confirmation dialog box to save the changes.

**TIP** If you want to delete a cross section, select the cross section and click **Delete**.

**See also**
- Define a cross section using polygon (page 61)
- Define a cross section using a plate (page 62)
- Define a cross section using a DWG file (page 64)

**Create fixed profiles**
You can create new fixed profiles either from scratch or by copying an existing one. You can also convert a parametric profile into a fixed one.

Click the links below to find out more:

- Create a fixed profile (page 66)
- Create a fixed profile by copying (page 68)
- Create a fixed profile based on a parametric profile (page 69)
- Modify a fixed profile (page 69)

**Create a fixed profile**
You can create fixed profiles with a single cross section or with multiple cross sections. Note that cross sections affect the total weight of the profile.
WARNING If you create a profile with multiple cross sections, create the cross sections with the same number of corner points and in the same order.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
2. Right-click anywhere in the profile tree and select Add Profile.
   A new fixed profile with the name PROFILE1 is created.
3. Change the profile name by entering a new name in the Profile name box.
   The profile name must be in upper case letters, with no spaces. Tekla Structures automatically converts lower case letters to upper case letters.
4. In the Profile type list, select User-defined, fixed.
5. In the Profile subtype list, select the cross section you want to use.
   If you have created your own user-defined cross sections, you can use one of them.
6. Under Equivalent type, select a profile type that matches the new cross section as closely as possible. This is important because some connections only work for certain types of profiles.
   The equivalent type and the profile dimensions, such as height and width, affect which connections can be applied to the profile. An unsuitable equivalent type or missing dimension values may result in problems with connections.
7. Click Update.
8. Modify the dimension values.
   Always enter values for the dimensions Height h and Width b, as these values affect how Tekla Structures displays the profiles. If the values are 0, the part is drawn as a line.
9. Under Cross section, define a relative location for each cross section:
   a. In the Number list, select the number of the cross section.
   b. In the Relative location box, enter the location of the cross section.
      This value indicates the location of the cross section along the axis: 0.0 for the start end and 1.0 for the second end. If you only have a single cross section, select 1 for Number and enter 0.000 for Relative location.
   c. Click Update after defining each cross section.
10. Click Add to add more cross sections, if needed.
11. If you want to use a different cross section in the profile, select a new one from the Profile subtype list.
12. If you want to remove a cross section, select the cross section from the **Number** list and click **Remove**.

13. Click **OK** to close the **Modify Profile Catalog** dialog box.

14. Click **OK** in the **Save confirmation** dialog box to save the changes.

**Example**

For a pitched profile, you need two cross sections with the same center point height. The **Relative location** value is 0.0 for the first cross section, 0.5 for the second cross section, and 1.0 for the third cross section.

![Diagram of cross sections and relative locations](image)

---

**See also**

- Create a fixed profile by copying (page 68)
- Modify a fixed profile (page 69)
- Delete a profile from the profile catalog (page 52)
- Create user-defined cross sections (page 60)

**Create a fixed profile by copying**

You can create new fixed profiles by modifying a copy of an existing, similar profile.

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.

2. Select a fixed profile that is similar to the one you wish to create.

3. Right-click and select **Copy Profile**.

   A new profile with the name `<existing_profile_name COPY>` is created.
4. Change the profile name by entering a new name in the **Profile name** box.

The profile name must be in upper case letters, with no spaces. Tekla Structures automatically converts lower case letters to upper case letters.

5. Modify the profile properties on the **General**, **Analysis**, and **User attributes** tabs.

**WARNING** Under **Equivalent type**, select a profile type that matches the new cross section as closely as possible. This is important because some connections only work for certain types of profiles.

Always enter values for the dimensions **Height h** and **Width b**, as these values affect how Tekla Structures displays the profiles. If the values are 0, the part is drawn as a line.

The equivalent type and the profile dimensions, such as height and width, affect which connections can be applied to the profile. An unsuitable equivalent type or missing dimension values may result in problems with connections.

6. Click **Update**.

7. Click **OK** to close the **Modify Profile Catalog** dialog box.

8. Click **OK** in the **Save confirmation** dialog box to save the changes.

**See also**

* Create a fixed profile (page 66)
* Modify a fixed profile (page 69)

Create a fixed profile based on a parametric profile

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.

2. Select a parametric profile from the list.

3. Right-click and select **Add Profile**.

   A new standard fixed profile is created, and it has the profile values of the parametric profile.

**See also**

* Create fixed profiles (page 66)
Modify a fixed profile
If necessary, you can modify existing fixed profiles using the profile catalog. Note that the fixed profiles conform to industry standards, and you should not modify them unless you are an administrator.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.

2. Select a fixed profile in the tree and modify its properties.
   - The General tab contains information on profile types and dimensions.
   - The Analysis tab contains information on the properties used in structural analysis. The structure can be analyzed with different analysis software.
   - The User attributes tab is for viewing or entering user attributes for profiles.

3. When you have finished modifying the profile, click Update.

4. Click OK to close the Modify Profile Catalog dialog box.

5. Click OK in the Save confirmation dialog box to save the changes.

See also
Create a fixed profile (page 66)
Create a fixed profile by copying (page 68)

Create parametric profiles by sketching
This section explains how to create parametric user-defined profiles by sketching. You can change the dimensions of parametric profiles each time you use them in a model.

Click the links below to find out more:

Open the sketch editor (page 71)
Sketch the outline of a profile (page 73)
Refine the shape of a sketched profile (page 75)
Add dimensions to a sketched profile (page 80)
Define positioning planes for a sketched profile (page 84)
Check a sketched profile (page 89)
Save a sketched profile (page 89)
Modify a sketched cross section (page 90)
Use sketched profiles in a model (page 93)

Open the sketch editor
Use the sketch editor to create and modify sketched profiles.

1. Open a Tekla Structures model.
2. On the File menu, click Editors --> Define cross section in sketch editor.

Tekla Structures opens the sketch editor, the Sketch Browser, and the Variables dialog box.

When you first open the sketch editor, the view is empty. The grid coordinates and labels that you see in the sketch editor depend on the grid properties of your actual Tekla Structures model.

See also
Sketch Browser (page 72)
**Variables in sketched profiles** (page 73)

**Sketch Browser**

The **Sketch Browser** shows the objects (lines, arcs, circles, constraints, dimensions, and chamfers) of a sketched profile in a hierarchical, tree-like structure. The **Sketch Browser** automatically opens when you open the sketch editor.

When you click an object in the sketch editor, Tekla Structures highlights the object in the **Sketch Browser**, and vice versa.

The **Sketch Browser** displays the following information about a sketched profile:

- Extrusion type (0, 1, or 2) and thickness of the sketched profile
- Lines, arcs, and circles
- Constraints
- Distances and dimensions and their values
- Chamfers and their type (0=**None**, 1=**Line** ... 7=**Line and arc**) and dimensions.

**See also**

Open the sketch editor (page 71)
Variables in sketched profiles

Use the Variables dialog box to define the properties of a sketched profile. Variables can define fixed properties, or they can include formulas, so that Tekla Structures calculates the property value each time you use the profile in a model.

The Variables dialog box automatically opens when you open the sketch editor.

NOTE  The Variables dialog box functions the same way as the corresponding dialog box in the custom component editor. For more information on how to use variables, see Add variables to a custom component (page 172).

See also

Open the sketch editor (page 71)

Sketch the outline of a profile

When you create a new sketched profile, start by sketching the outline and the holes of the profile using lines, arcs, and circles.

Ensure that you create a closed shape, unless you are creating a profile of a consistent thickness, such as a cold-rolled profile.

See also

Sketch a polyline (page 74)
Sketch an arc (page 74)
Sketch a circle (page 75)
**Sketch a polyline**
You can create line segments in the sketch editor by picking points. Tekla Structures automatically creates coincident constraints between the line segments and displays a chamfer symbol where line segments meet.

1. Open the sketch editor.
2. Click the **Sketch polyline** button: 📊. 
3. Pick points to create each line segment.
4. Click the middle mouse button to create the polyline.

![Image of sketch polyline](image)

**See also**
*Sketch the outline of a profile (page 73)*

**Sketch an arc**
You can create an arc in the sketch editor by picking three points.

1. Open the sketch editor.
2. Click the **Sketch arc** button: 📊. 
3. Pick three points to define the arc.

![Image of sketch arc](image)
**TIP** You can use the advanced option XS_CS_CHAMFER_DIVIDE_ANGLE to define the smoothness of the arc.

See also

*Sketch the outline of a profile (page 73)*

*Sketch a circle*

You can create a circle in the sketch editor by picking two points.

1. Open the sketch editor.

2. Click the **Sketch circle** button.

3. Pick a point to indicate the center of the circle (1).

4. Pick a point to indicate the radius of the circle (2).

See also

*Sketch the outline of a profile (page 73)*

*Refine the shape of a sketched profile*

After you have sketched the outline of a profile, use *constraints* to refine your sketch and lock the shape. For example, you can straighten lines, create 90 degree angles, force lines to meet, close the shape, and add chamfers in corners.

To straighten the entire profile, use horizontal and vertical constraints in conjunction with other constraints. Although the shape is locked, you can still rotate the profile in the model.

See also

*Add a parallel constraint (page 76)*

*Add a perpendicular constraint (page 76)*
Add a coincident constraint (page 77)
Add a fixed constraint (page 78)
Add a horizontal constraint (page 78)
Add a vertical constraint (page 79)
Delete a constraint (page 79)

Add a parallel constraint
You can force two lines in a sketched profile to be parallel to each other. Before you start, sketch the outline of the profile in the sketch editor.

1. Click the **Parallel constraint** button:  
2. Select a line in the sketch (1).  
3. Select another line in the sketch (2).

See also
Refine the shape of a sketched profile (page 75)

Add a perpendicular constraint
You can force a line in a sketched profile to be at a 90 degree angle to another line you select. The lines do not have to intersect. Before you start, sketch the outline of the profile in the sketch editor.

1. Click the **Perpendicular constraint** button:  
2. Select a line in the sketch (1).  
3. Select another line in the sketch (2).
See also
Refine the shape of a sketched profile (page 75)

Add a coincident constraint
You can force two lines in a sketched profile to start or end at the same point, by extending or shortening one or both lines. The lines do not have to intersect.

NOTE  Tekla Structures automatically creates coincident constraints:
• Where two lines meet.
• Between line segments when you draw them with the Sketch polyline tool.
• Between the start of the first line segment and the end of the last line segment in a shape, if they are within a certain distance of each other.

Before you start, sketch the outline of the profile in the sketch editor.

1. Ensure that the Snap to end points snap switch is active.
2. Click the Coincident constraint button.
3. Pick the end of the first line (1).
4. Pick the end of the second line. (2)
See also

Refine the shape of a sketched profile (page 75)

Add a fixed constraint
You can lock the position and angle of a line in a sketched profile so that other constraints do not affect it.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Fixed constraint button:
2. Select a line in the sketch.

See also

Refine the shape of a sketched profile (page 75)

Add a horizontal constraint
Use horizontal constraints to force a line in a sketched profile to be parallel to the local x axis. Tekla Structures automatically creates horizontal constraints when you create lines that are nearly horizontal.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Horizontal constraint button:
2. Select the lines you want to straighten (1, 2).
See also
Refine the shape of a sketched profile (page 75)

Add a vertical constraint
Use vertical constraints to force a line in a sketched profile to be parallel to the local y axis. Tekla Structures automatically creates vertical constraints when you create lines that are nearly vertical.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the **Vertical constraint** button:
2. Select the lines you want to straighten (1, 2).

See also
Refine the shape of a sketched profile (page 75)

Delete a constraint
You can delete constraints from sketched profiles.

1. Click to open the **Sketch Browser**.
2. Select the constraint you want to delete.
3. Right-click and select **Delete**.
4. Click **Refresh**.

**See also**

Refine the shape of a sketched profile (page 75)

**Add dimensions to a sketched profile**

After you have sketched a profile, use dimensions to make different distances in the profile parametric. You can use these dimensions to define the size of the profile when you use it in a model.

Tekla Structures also adds the dimensions you create to the list of variables that you can use in calculations.

**NOTE**  Do not create too many dimensions in a sketch, or the dimensions will not be able to adjust when the values are changed.

In the following example, if you create the dimension marked in red, the dimension b1 will no longer work:

![Diagram showing a sketched profile with dimensions b1, b2, and b3.](image)

**See also**

Add a radial dimension to a sketch (page 80)
Add an angle dimension to a sketch (page 81)
Add a dimension between two points in a sketch (page 82)
Add a horizontal dimension to a sketch (page 82)
Add a vertical dimension to a sketch (page 83)
Delete a dimension from a sketch (page 83)
Add a radial dimension to a sketch
You can create a radial dimension for an arc or a circle in a sketched profile. Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch radial dimension button:
2. Select the arc or circle.

See also
Add dimensions to a sketched profile (page 80)

Add an angle dimension to a sketch
You can create an angle dimension between two lines in a sketched profile. The angle is calculated counter clockwise from the first line you select. Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch angle dimension button:
2. Select the first line (1).
3. Select the second line (2).

TIP If you are unable to see the angle symbol, scroll with the mouse wheel to zoom in.
See also
Add dimensions to a sketched profile (page 80)

Add a dimension between two points in a sketch
You can add a dimension to a sketched profile, between two points you pick. Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch free dimension button:
2. Pick a point to indicate the start point of the dimension (1).
3. Pick a point to indicate the end point of the dimension (2).
4. Pick a point to indicate the location of the dimension lines and text.

See also
Add dimensions to a sketched profile (page 80)

Add a horizontal dimension to a sketch
You can add a horizontal dimension to a sketched profile, between two points you pick. Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch horizontal dimension button:
2. Pick a point to indicate the start point of the dimension (1).
3. Pick a point to indicate the end point of the dimension (2).
4. Pick a point to indicate the location of the dimension lines and text.
You can add a vertical dimension to a sketched profile, between two points you pick.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch vertical dimension button:
2. Pick a point to indicate the start point of the dimension (1).
3. Pick a point to indicate the end point of the dimension (2).
4. Pick a point to indicate the location of the dimension lines and text.

See also
Add dimensions to a sketched profile (page 80)

Delete a dimension from a sketch
When you want to delete a dimension from a sketch, you can do it in the sketch editor view, in the Variables dialog box, or in the Sketch browser.

1. Select the dimension you want to delete.

See also
Add dimensions to a sketched profile (page 80)
2. Do one of the following:
   - In the sketch editor view or in the Sketch browser, right-click and select Delete.
   - In the Variables dialog box, click the Delete button.

See also
Add dimensions to a sketched profile (page 80)

Define positioning planes for a sketched profile
When you sketch a profile, you can define positioning planes for it. With positioning planes you can determine the planes Tekla Structures will use for positioning parts and components.

See also
Part positioning planes (page 84)
Connection positioning planes (page 85)
Show and hide positioning planes (page 86)
Move positioning planes (page 87)
Revert to default positioning planes (page 88)

Part positioning planes
With part positioning planes you can determine how Tekla Structures positions parts that have a sketched profile. These planes are used for the On plane and At depth settings for parts, and also when placing custom components that are bound to boundary planes.

The part positioning planes are displayed in blue:

The On plane options Left and Right are set according to the vertical blue planes, and the Middle option is halfway between them.
The same principle applies to the **At depth** setting: the **Front** and **Behind** options are set according to the horizontal blue planes, and the **Middle** option is halfway between them.

<table>
<thead>
<tr>
<th>Position</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>On plane:</td>
<td><strong>Middle</strong></td>
<td><strong>0.00</strong></td>
</tr>
<tr>
<td>Rotator:</td>
<td><strong>Top</strong></td>
<td><strong>-0.00000</strong></td>
</tr>
<tr>
<td>At depth:</td>
<td><strong>Middle</strong></td>
<td><strong>-0.00</strong></td>
</tr>
</tbody>
</table>

**Example**

You can define part positioning planes so that an asymmetric profile will be positioned according to its web only. In the following example, the **Middle** option is illustrated in gray dotted lines:

![Diagram showing part positioning planes](image)

**Middle** option

**See also**

*Define positioning planes for a sketched profile* (page 84)

*Connection positioning planes*

With *connection positioning planes* you can determine how Tekla Structures positions components in relation to the component main part that has a sketched profile.
The connection positioning planes are displayed in green:

**Example**

The following image shows the default connection positioning planes of a double tee slab that was created as a sketched profile. The green line illustrates the default connection positioning planes.

To place connections according to the location of the stems of the double tee, move the connection positioning planes as shown below.

**See also**

*Define positioning planes for a sketched profile (page 84)*

*Show and hide positioning planes*

To show or hide the positioning planes, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or hide <em>part</em> positioning planes</td>
<td>Click 📚.</td>
</tr>
<tr>
<td>Show or hide <em>connection</em> positioning planes</td>
<td>Click 📚.</td>
</tr>
</tbody>
</table>
See also
Define positioning planes for a sketched profile (page 84)

Move positioning planes
You can move the positioning planes by moving their handles. Note that if you move the handles away from the outmost corners of the sketched profile, you must bind them by adding a dimension to each handle. Otherwise the positioning will not function correctly in the model.

1. Click the positioning plane to display the handles.
   The handles are displayed in pink. By default, the handles are at the outmost corners of the sketched profile. For example:

![Diagram showing positioning planes](image)

2. Click a handle to select it.
   
   **NOTE** The same handle controls both the vertical and horizontal plane, so you can move them both at the same time.

3. Move the handle like any other object in Tekla Structures.
   For example, right-click and select **Move**.

4. If the handle is not at the outmost corner of the profile, add a dimension between the handle and the corner.

Example
In the following examples, the left handle of the positioning plane has been bound by using a horizontal dimension (b1):
See also

Define positioning planes for a sketched profile (page 84)
Show and hide positioning planes (page 86)

Revert to default positioning planes
You can revert back to the default positioning planes of a sketched profile if you have moved the planes.

To revert to the default positioning planes, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revert to the default <strong>part</strong></td>
<td>1. Click to show the part positioning planes.</td>
</tr>
<tr>
<td>positioning planes</td>
<td>2. Select the part positioning planes.</td>
</tr>
<tr>
<td></td>
<td>3. Right-click and select <strong>Delete</strong>.</td>
</tr>
<tr>
<td></td>
<td>4. Click again to check that the planes have reverted back to the default.</td>
</tr>
<tr>
<td>Revert to the default <strong>connection</strong> positioning planes</td>
<td>1. Click to show the connection positioning planes.</td>
</tr>
<tr>
<td></td>
<td>2. Select the connection positioning planes.</td>
</tr>
<tr>
<td></td>
<td>3. Right-click and select <strong>Delete</strong>.</td>
</tr>
<tr>
<td></td>
<td>4. Click again to check that the planes have reverted back to the default.</td>
</tr>
</tbody>
</table>
See also
Define positioning planes for a sketched profile (page 84)

Check a sketched profile
You can check that the constraints and dimensions in a sketched profile work correctly.
1. Double-click a dimension line to open the Distance Properties dialog box.
2. Change the Value box.
3. Click Modify.
   Tekla Structures updates the profile in the sketch editor.
4. Check that the shape of the profile does not change and that the dimensions adjust correctly.
5. Click Cancel to close the Distance Properties dialog box.

See also
Use sketched profiles in a model (page 93)

Save a sketched profile
Tekla Structures saves the sketched profiles in the current model folder, in the xslib.db1 file, which is a library file containing custom components and sketches. Sketched profiles are available in the Others section in the profile catalog.

NOTE Note the following limitations when naming sketched profiles:
• You cannot use the name of a fixed profile.
• You cannot include numbers, special characters, or blank spaces in the profile name.
• Lower case letters are automatically converted into upper case letters.

To save a sketched profile, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save a new profile</td>
<td>1. Click <strong>Save sketch</strong></td>
</tr>
<tr>
<td></td>
<td>2. Enter a name in the Prefix box, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td>Update an existing profile</td>
<td>1. Click <strong>Save sketch</strong></td>
</tr>
</tbody>
</table>
To | Do this
---|---
2. Click Yes when prompted to update the existing cross section.

Save a copy of the profile under a different name | 1. Click Save sketch as.
2. Enter a new name in the Prefix box, and then click OK.

See also
Import and export sketched profiles (page 59)

Modify a sketched cross section
You can modify existing sketched profiles, for example, by modifying chamfers or dimensions. You can also move corners or holes by moving the handles. The chamfers are moved automatically when you move the handles.

NOTE • You cannot change dimensions that have been calculated using formulas in the Variables dialog box.
• Constraints may also prevent you from changing dimensions.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
2. Open the Others branch at the end of the profile tree.
3. Right-click a sketched profile, and then select Edit profile to open the profile in the sketch editor.
4. Double-click a sketch object to modify its properties.
   The sketch objects you can modify appear in yellow.
5. Modify the properties and then click Modify.
6. Close the sketch object properties dialog box.
7. Click the Save sketch as icon to save the changes.

See also
Modify chamfers in a sketch (page 90)
Set the sketch thickness (page 91)

Modify chamfers in a sketch
You can change the shape and dimensions of chamfers in a sketched profile. For example, you can create rounded profile corners.

1. Double-click a chamfer symbol in the sketch editor.
2. In the **Chamfer Properties** dialog box, change the shape and dimensions of the chamfer.

3. Click **Modify**.

4. Click **OK** to close the dialog box.

5. Click the **Save sketch as** icon to save the changes.

**See also**

*Modify a sketched cross section (page 90)*

*Set the sketch thickness*

If you have sketched an open shape, such as a cold-rolled section, you must define the extrusion type and thickness of the sketch in the **Sketch Browser**. The thickness can be either fixed or parametric.

1. In the sketch editor, sketch an open polyline.

2. Do one of the following:
   - To set a fixed thickness:
     a. In the **Sketch Browser**, right-click **Thickness** and select **Add Equation**.
     b. Enter the value of the thickness after =.
   - To define a parametric thickness:
     a. In the **Variables** dialog box, add a new parameter variable for **Length** (for example, P1).
     b. In the **Formula** column, define the default value for the parameter variable.
     c. In the **Sketch Browser**, right-click **Thickness** and select **Add Equation**.
     d. Enter the name of the parameter variable (for example, P1) after =.
3. To define the extrusion type:
   a. In the Sketch Browser, right-click Extrusion Type and select Add Equation.
   b. Enter the extrusion type number (0, 1, or 2) after =.

4. Click the Save sketch as icon to save the changes.

See also
Modify a sketched cross section (page 90)
Extrusion types (page 92)

Extrusion types
The extrusion type defines how a sketched profile of a consistent thickness is extruded. When you change the thickness, the profile grows inwards, outwards, or symmetrically in both directions, depending on the extrusion type. You must define the extrusion type for sketches that consist of an open polyline.

The extrusion types are:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>The sketch is extruded symmetrically to the outside and inside of the polyline. (Default)</td>
<td><img src="image1.jpg" alt="Image" /></td>
</tr>
<tr>
<td>1</td>
<td>The sketch is extruded to the outside of the polyline.</td>
<td><img src="image2.jpg" alt="Image" /></td>
</tr>
<tr>
<td>2</td>
<td>The sketch is extruded to the inside of the polyline.</td>
<td><img src="image3.jpg" alt="Image" /></td>
</tr>
</tbody>
</table>
See also
Set the sketch thickness (page 91)

Use sketched profiles in a model
Once you have created a sketched profile and saved it, you are ready to use it in the model. If you have applied constraints correctly, the shape of the profile will be maintained when you change its dimensions.

To use a sketched profile for a new part in a model:
1. Open the part properties dialog box.
   For example, to open the beam properties dialog box, on the Steel tab, hold down Shift and click .
2. Click Select next to the Profile box.
   The Select Profile dialog box appears.
3. Open the Others branch at the end of the profile tree.
4. Select a sketched profile.
5. If the profile is parametric, you can define its dimensions in the Value column on the General tab.
6. Click OK to close the Select Profile dialog box.
7. Click Apply to use the selected profile in the model.
8. Pick points to place the part in the model.

See also
Create an image of a profile (page 97)

Create parametric profiles with variable cross sections
You can create parametric user-defined profiles with variable cross sections using the Profile Editor. You can use a profile with variable cross sections like any other parametric profile.

You can:
• Use a cross section with different dimensions at different locations in a profile.
• Modify the variables of the cross sections and the profile.
• Save the profile and use it as a parametric profile through the profile catalog.
• Import and export variable cross section profiles.

NOTE When you use this method, only the dimensions of a variable cross section can vary, not the actual shape of the cross section. If you want to use several different cross section shapes in the profile, create a fixed profile with multiple cross sections instead.

See also
Create a profile with variable cross sections (page 94)
Modify a profile with variable cross sections (page 96)
Create a fixed profile (page 66)

Create a profile with variable cross sections

Before you start:
• Create a sketched profile using the sketch editor.
• In the Variables dialog box in the sketch editor, set Visibility to Show for the dimensions that you want to change when using the profile in a model.

1. Go to Quick Launch, start typing define profile with variable cross section, and select the Define Profile with Variable Cross Section command from the list that appears.

   The Define Profile with Variable Cross Section dialog box opens.

2. Select the sketch you want to use as the start and end cross section of the profile.
3. Click **OK**.

The **Profile Editor** and the **Profile preview** view appear.

4. Under **Cross sections of the profile**, add cross sections or remove selected cross sections by clicking **Add** or **Remove**.

   When you click **Add**, Tekla Structures adds a new cross section at the end of the profile, at the location 1.0., and moves the existing cross sections towards the start of the profile. By default, cross sections are located at 0.1 intervals in the profile.

5. Under **Cross section variables**, define the following:

   • The relative location of each cross section in the profile.
     Use the **.*.Location** variables. For example, start=0.00, middle=0.5, end=1.00.

   • How the cross sections are aligned in the horizontal and vertical direction.
     Use the **.*.HorPos** and **.*.VerPos** variables.

   • How much the cross sections are offset from the alignment.
     Use the **.*.HorOffset** and **.*.VerOffset** variables.
6. If you have added new cross sections, check that they do not overlap any existing cross sections.

7. Set **Visibility** to **Show** for the dimensions that you want to change when using the profile in a model.

8. If you want to use parameter variables and equations to define the cross section dimension, click **Add variable** and define the variable values.

9. Save the profile.
   a. Click **Save**.
   b. In the **Save profile as** dialog box, enter a unique name for the profile.

   You cannot include numbers in the profile name, or use the name of a standard profile.
   c. Click **OK**.

   Tekla Structures saves the profile in the current model folder.

**See also**

*Create parametric profiles with variable cross sections (page 93)*

*Modify a profile with variable cross sections (page 96)*

*Create parametric profiles by sketching (page 70)*

**Modify a profile with variable cross sections**

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.

2. Open the **Others** branch at the end of the profile tree.

3. Right-click a profile with variable cross sections, and then select **Edit profile** to open the profile in the **Profile Editor**.
4. Modify the profile properties.
5. Click Save.

See also
Create a profile with variable cross sections (page 94)

Define standardized values for parametric profiles
You can define standardized values for the dimensions of parametric profiles. The standardized values are visible in the profile catalog where you can select suitable dimension values for the profiles.

1. Go to the ..\ProgramData\Tekla Structures\<version>\environments\<environment>\system folder.
2. Open the industry_standard_profiles.inp file using any standard text editor, for example, Microsoft Notepad.
3. Modify the file.
   The file has the following format:
   • profile and profile subtype
   • parameters separated by spaces
   • units for each parameter
   • standardized values for each parameter.
      Each dimension combination has its own row.
4. Save the file.

Example
For example, the standardized combinations of dimension values for a C profile are as follows:

<table>
<thead>
<tr>
<th>C</th>
<th>h</th>
<th>b</th>
<th>t</th>
</tr>
</thead>
<tbody>
<tr>
<td>mm</td>
<td>mm</td>
<td>mm</td>
<td>mm</td>
</tr>
<tr>
<td>75</td>
<td>35</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>75</td>
<td>35</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>75</td>
<td>35</td>
<td>7</td>
<td></td>
</tr>
<tr>
<td>100</td>
<td>40</td>
<td>7</td>
<td></td>
</tr>
<tr>
<td>100</td>
<td>40</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>100</td>
<td>40</td>
<td>9</td>
<td></td>
</tr>
</tbody>
</table>
Create an image of a profile

To illustrate the shape and dimensions of a profile you have created, you can create an image of it. Tekla Structures displays the image when you browse for profiles in the profile catalog. The image must be in Windows bitmap (.bmp) format and can be created with any bitmap editor, for example Microsoft Paint.

1. Take a screenshot of the profile you have drawn or sketched.
   For example, press the Print Screen (Prt Scr) key to take a screenshot of your entire desktop. To take a screenshot of an active window, press Alt + Print Screen. The screenshot is placed on the clipboard.

2. Open the screenshot in any bitmap editor (for example, Microsoft Paint) and modify the image if necessary.

3. Save the image in .bmp format in the ..\ProgramData\Tekla Structures<version>\Bitmaps folder.
   The file name must match the actual profile name. For example, if the profile name is mysketch, the image must be named mysketch.bmp.

4. Restart Tekla Structures.
   The image is now shown in the profile catalog.
5.2 Customize the shape catalog

The Shape Catalog dialog box contains information on shapes. It is used for viewing shape properties, and for importing and exporting shapes.

The shapes you download from Tekla Warehouse are also displayed in the Shape Catalog dialog box.

The catalog includes two default shapes: Default and Concrete Default. Shapes are used in defining items. In Tekla Structures, items are similar to other parts, such as beams and columns. The main difference between items and other types of parts is that a 3D shape defines the geometry of an item, whereas a part has a 2D profile that is extruded to create the length of the part.

The shapes you import to the shape catalog are stored in the current model folder. There are two .xml files for each shape: one stored in the \Shapes folder and one in the \ShapeGeometries folder.

If you have shapes that you would like to have available in the Shape Catalog dialog box for all new models that are created in your project or company, copy the corresponding .xml files to the correct subfolders (\Shapes and \ShapeGeometries) in the \profif folder under your project or firm folder.

See also
Import a shape (page 99)
Export a shape (page 100)
Delete a shape (page 101)

Import a shape

You can import the following types of shape files: dgn, tsc, skp, dxf, dwg, ifc, ifcZIP, ifcXML, igs, iges, stp, and step.

When using other modeling software to model shapes that you want to import into Tekla Structures, we recommend that you center parts around the origin and direct the parts along the x axis.

1. On the File menu, click Catalogs --> Shape catalog.
   The Shape Catalog dialog box opens.
2. Click Import.
3. Select the shape file to import.
   To select multiple shape files, hold down Ctrl or Shift.
4. Click OK.
   Importing a large file can take several minutes.
Shape import has three possible results:

- Tekla Structures imports the shape as a watertight solid shape. All solid operations are available.

- Tekla Structures imports the shape as a non-solid shape. A non-solid shape means that the object may not be watertight. For example, it has holes, or is missing a face or an edge.

- Import fails. This can happen, for example, if the shape is very complex or has no volume. There may also be a tolerance difference between Tekla Structures and the original software that was used to create the shape. To find out why the import failed, check the session history log by clicking File menu --> Logs --> Session history log.

When you import a shape into the Shape Catalog, Tekla Structures creates two .xml files: one for shape attributes, such as name and GUID, and one for geometric properties, such as coordinates. The files are saved in the current model folder under the \Shapes and \ShapeGeometries subfolders.

TIP You can also download shapes from Tekla Warehouse.

See also
Example: Import a shape from SketchUp Pro (page 101)
Export a shape (page 100)
Delete a shape (page 101)
Customize the shape catalog (page 98)

Export a shape

1. On the File menu, click Catalogs --> Shape catalog.
   The Shape Catalog dialog box opens.
2. Select the shape to export.
   To select multiple shapes, hold down Ctrl or Shift.
3. Click Export.
4. If you are exporting only one shape, select the folder where you want to export the shape, and enter a name for the export file in the Selection box.
5. If you are exporting multiple shapes, select the folder where you want to export the shapes.
   Tekla Structures will create a separate export file for each shape using the shape name as the file name.
6. Click OK.
The shapes are saved in the destination folder as .tsc files.

**TIP** You can also upload shapes to Tekla Warehouse.

**See also**
Import a shape (page 99)
Delete a shape (page 101)
Customize the shape catalog (page 98)

### Delete a shape

Before you start, ensure that the shape you want to delete is not used in your Tekla Structures model. When you delete a shape from the Shape Catalog, the shape is no longer available anywhere in the model. If a model includes a deleted shape, it is only shown as a straight line between its original reference points.

1. On the **File** menu, click **Catalogs --> Shape catalog**.
   The **Shape Catalog** dialog box opens.
2. Right-click the name of the shape.
3. Click **Delete**.
   Tekla Structures deletes the shape.

**See also**
Import a shape (page 99)
Export a shape (page 100)
Customize the shape catalog (page 98)

### Example: Import a shape from SketchUp Pro

In this example, you import a solid 3D shape from Trimble SketchUp Pro to a Tekla Structures model.

1. Create an empty model in SketchUp Pro.
   Delete any extra entities, such as the default person on the drawing area.
2. Create a group of entities.
Although Tekla Structures supports importing separate individual entities, we recommend you create a group of entities or a component in SketchUp.

All SketchUp groups and components should form watertight solids. Select the group or component and open Entity Info to check that the selection is a solid. SketchUp solids have a volume. If there is no volume listed, the selection is not a solid.

3. Select the group and click **Solid Tools --> Union** to make the group of entities into a union of solids. Your group becomes a single solid volume: a solid.

4. Place the solid in SketchUp so that it lies along the positive x axis (red), and halfway on both y (green) and z axes (blue). In Tekla Structures, the yellow and magenta part handles will align with the x axis used in SketchUp.

The location and rotation of the solid in SketchUp are important, since they determine how an item is inserted and positioned in Tekla Structures. Different positioning in SketchUp causes an offset in Tekla Structures.

5. Save the SketchUp file.

6. In your Tekla Structures model, open the **Shape Catalog** and click **Import**.

7. Select the SketchUp file.

8. Click **OK**.

Tekla Structures imports the shape to the **Shape Catalog** and you can use it to define the shape of an item or a concrete item.

**See also**

- Customize the shape catalog (page 98)
- Import a shape (page 99)
5.3 Customize the material catalog

The material catalog contains information on material grades. Materials are displayed in a hierarchical tree grouped according to material types, for example, steel and concrete. Material grades are located under each material type in the tree.

By default, the material catalog contains standard, environment-specific materials. You can add, modify, and delete material grades.

Tekla Structures stores the material information in the `matdb.bin` file.

See also

- Important buttons in the material catalog (page 103)
- Add a material grade (page 104)
- Copy a material grade (page 104)
- Modify a material grade (page 105)
- Delete a material grade (page 106)
- Add user attributes to material grades (page 106)
- Create user-defined material definitions (page 107)
- Import and export material grades (page 108)

Important buttons in the material catalog

When you work with the material grades, note the usage of the following buttons in the **Modify Material Catalog** dialog box:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="update.png" alt="Update" /></td>
<td>Saves the changes of a single edited material grade to the computer’s memory until you click <strong>OK</strong>.</td>
</tr>
<tr>
<td><img src="ok.png" alt="OK" /></td>
<td>Saves the changes in the model folder. Tekla Structures saves the modified catalog on the hard disk when you click <strong>OK</strong> to close the dialog box and then click <strong>OK</strong> in the <strong>Save confirmation</strong> dialog box.</td>
</tr>
<tr>
<td><img src="cancel.png" alt="Cancel" /></td>
<td>Closes the <strong>Modify Material Catalog</strong> dialog box without saving the changes. Note that all changes made to the catalog will be lost even if you have clicked <strong>Update</strong>, because the changes have not been saved on the hard disk. The changes made to the catalog are visible during one session, because the catalog is using the computer’s memory. When you start Tekla Structures the next time, the previous data is restored from the hard disk.</td>
</tr>
</tbody>
</table>
Tekla Structures stores the material information in the matdb.bin file. When you first open a model, Tekla Structures reads the data from the hard disk and stores it in the computer's memory.

When you select a material, Tekla Structures reads the data from the computer's memory and displays it in the Modify Material Catalog dialog box. This is faster than accessing the data from the hard disk.

**See also**

Customize the material catalog (page 102)

### Add a material grade

1. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.
2. Select a material type, for example, steel.
3. Right-click and select **Add Grade**.
   
   A new material grade is added under to the material type you selected.
4. Change the material grade name by clicking the grade and entering a new name for it.
5. Enter the material grade properties.
6. Click **OK** to save the material grade and close the **Modify Material Catalog** dialog box.
7. Click **OK** in the **Save confirmation** dialog box to save the changes.

**See also**

Copy a material grade (page 104)
Modify a material grade (page 105)
Delete a material grade (page 106)
Import and export material grades (page 108)

### Copy a material grade

You can add new material grades by modifying a copy of an existing, similar material grade.

1. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.
2. Select a material grade that is similar to the one you wish to create.
3. Right-click and select **Copy Grade**.
   
   A copy of the material grade with the name **COPY** is added to the material tree.

4. Change the material grade name by clicking the grade and entering a new name for it.

5. Modify the material grade properties.

6. Click **OK** to save the material grade and close the **Modify Material Catalog** dialog box.

7. Click **OK** in the **Save confirmation** dialog box to save the changes.

**See also**

- Add a material grade (page 104)
- Modify a material grade (page 105)
- Delete a material grade (page 106)

### Modify a material grade

You can modify existing material grades using the material catalog.

1. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.

2. Select a material grade in the tree and modify its properties.
   
   - Use the **General** tab for entering three alternative names for the material. The names are usually the material names used in different countries or standards. The tab also contains the profile and plate density values.
   
   - Use the **Analysis** tab for entering information on the properties used in structural analysis.
   
   - Use the **Design** tab for entering information on the design-specific properties, such as strengths and partial safety factors.
   
   - Use the **User attributes** tab for creating your own attributes for material grades.
     
     For example, you can define a paint layer thickness, or the maximum grain size of concrete using a user-defined attribute.

3. When you have finished modifying the material grade, click **Update**.

4. Click **OK** to close the **Modify Material Catalog** dialog box.

   Tekla Structures asks if you want to save the changes to the model folder.
5. Click **OK** in the **Save confirmation** dialog box to save the changes.

The modified material catalog is saved in the current model folder and is available only for that model. To make the modified catalog available for all the other models, use export and import.

**See also**

- Add a material grade (page 104)
- Copy a material grade (page 104)
- Delete a material grade (page 106)

**Delete a material grade**

1. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.
2. Select the material grade that you want to delete.
3. Right-click and select **Delete Grade**.
4. Click **OK** to close the **Modify Material Catalog** dialog box.
5. Click **OK** in the **Save confirmation** dialog box to save the changes.

**See also**

- Add a material grade (page 104)
- Copy a material grade (page 104)
- Modify a material grade (page 105)

**Add user attributes to material grades**

You can add user attributes and their values to the material grades. The user attributes can then be used, for example, in filtering.

1. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.
2. On the **User attributes** tab, click **Definitions** to open the **Modify Material Properties** dialog box.
3. Click **Add** to add a new row.
4. To define a user attribute, click each item on a row.
   a. In the **Category** list, select a material category to which the user attribute is applied.
   b. In the **Design code** list, select a design code to which the attribute is added.
c. In the Material type list, select a material type for the attribute.

d. In the Quantity type list, select the type of information that the user attribute contains, for example, weight, area, ratio, or string.

e. In the Order column, define the order in which the user attributes are shown in the dialog box. Smaller values are shown first.

f. In the Property name column, define a name for the property. The name is saved in the catalog and can be used in reports and templates. When Property name is used in a template, MATERIAL.PROPERTY_NAME indicates where the property name appears.

g. In the Label column, define a label for the attribute.

5. Click Update.

6. Click OK to close the Modify Material Properties dialog box.

See also

Modify a material grade (page 105)

Create user-defined material definitions

You can replace the existing material definitions with your own definitions and use them, for example, in drawing part marks. Material definitions can contain text, numbers and symbols.

1. Save the symbol file user_material_symbols.sym in the symbol folder (usually the folder ..\ProgramData\Tekla Structures\<version>\environments\common\symbols\).

2. Create a text file that contains your material definitions.

   Create the file using a text editor, for example Microsoft Notepad.

   Each row in the file defines a material. Use the following syntax:

   material_name symbol_file_name@n, where

   • material_name is the name of the material used in the material catalog
   • symbol_file_name is the symbol file name to be used
   • n is the number of the symbol.

   For example:

   S235JR61 user_material_symbols@1 B
   S235JR62 user_material_symbols@2 C
   S235JR user_material_symbols@0 A
   S275JR user_material_symbols@3 D
   S355JR user_material_symbols@4 E

Catalogs 107 Customize the material catalog
The order of material names in the definition file is relevant to the conversion. Materials with more specific names need to be listed before the ones with similar, but simpler names, for example, S235JRG1 must be listed before S235JR. Otherwise they both get the same symbol.

3. Save the file for example with the name user_material_definitions.txt. All the named materials in the material catalog will be replaced with the ones defined in this file.

4. Set the name of the file as a value for the advanced option $\text{XS\_MATERIAL\_SYMBOL\_REPRESENTATION\_FILE}$ in File menu → Settings → Advanced options → Drawing Properties as follows:

   set $\text{XS\_MATERIAL\_SYMBOL\_REPRESENTATION\_FILE}=$user\_material\_definitions.txt

   You can also enter a full path to the material definition file. Without the path Tekla Structures searches for the file in the model, firm, project, and system folders.

See also

Customize the material catalog (page 102)

Import and export material grades

Use importing and exporting for merging material catalogs. Material catalogs are imported and exported as .lis files.

Importing and exporting is useful when you:

• upgrade to a newer version of Tekla Structures and want to use a customized material catalog from a previous version
• want to combine material catalogs that are stored in different locations
• want to share material catalog information with other users
• want to combine material catalogs across different environments.

TIP You can also download or share material grades using Tekla Warehouse.

See also

Import a material catalog (page 109)
Export an entire material catalog (page 109)
Export a part of the material catalog (page 110)
Import a material catalog

Material catalogs are imported to Tekla Structures models as .lis files. You can move an exported .lis file to any model folder and import it to an existing material catalog.

1. Open the model to which you want to import a material catalog.
2. On the File menu, click Catalogs --> Material catalog to open the Modify Material Catalog dialog box.
3. Click Import.
4. Browse for the folder that contains the import file, and select the file.
5. Click OK.

If a material with a same name as the material being imported already exists, the Import confirmation dialog box appears and you have three options:

- **Replace**: The existing material is replaced with the imported material.
- **Merge**: Material properties that are different in the import file are added to the existing material. All the other properties remain unchanged.
  
  Use this option to import only certain elements of the material catalog, such as user attributes.
- **Leave**: The existing material is not replaced and the material definitions in the import file are ignored.

If you select the Apply for all check box, Tekla Structures uses the same option (Replace, Merge, or Leave) for all the existing materials that have the same name as the one being imported.

If a user attribute with a different definition already exists, you are prompted to Replace or Leave the existing attribute.

6. Click OK to close the Modify Material Catalog dialog box.
7. Click OK in the Save confirmation dialog box to save the changes.

See also

- Export an entire material catalog (page 109)
- Export a part of the material catalog (page 110)
- Units used in import and export (page 57)
**Export an entire material catalog**
Exporting and importing are used to merge material catalogs. Material catalogs are exported from Tekla Structures models as .lis files. Note that the Export command exports the entire catalog.

1. On the File menu, click Catalogs --> Material catalog to open the Modify Material Catalog dialog box.
2. Click Export.
   By default, the file is saved to the current model folder.
4. Enter a name for the file and click OK.
5. Click OK to close the Modify Material Catalog dialog box.
6. Click OK in the Save confirmation dialog box to save the changes.

See also
Import a material catalog (page 109)
Units used in import and export (page 57)

**Export a part of the material catalog**
If you do not want to export the whole material catalog, you can export a branch of the material tree, meaning all the material grades grouped under one material type, or a single material grade. Material catalogs are exported from Tekla Structures models as .lis files.

1. On the File menu, click Catalogs --> Material catalog to open the Modify Material Catalog dialog box.
2. Select material grades to be exported.
   • To export a branch of the material tree, right-click the branch and select Export Grades.
   • To export a single material grade, right-click the material grade and select Export Grade.
3. Browse for the folder where you want to save the export files.
   By default, the file is saved to the current model folder.
4. Enter a name for the file and click OK.
5. Click OK to close the Modify Material Catalog dialog box.
6. Click OK in the Save confirmation dialog box to save the changes.

See also
Export an entire material catalog (page 109)
Import a material catalog (page 109)
5.4 Customize the bolt catalog

The individual *bolt assembly elements*, such as bolts of different sizes and lengths, nuts and washers, are listed in the bolt catalog. Each *bolt assembly* then consists of these bolt assembly elements. You cannot use a bolt if it does not belong to a bolt assembly. The bolt assemblies are listed in the bolt assembly catalog.

Tekla Structures stores the bolt catalog information in the `screwdb.db` file and the bolt assembly catalog information in the `assdb.db` file.

**See also**

- How the bolt catalog and bolt assembly catalogs work together (page 111)
- Manage bolts and bolt assemblies (page 113)
- Import and export bolts and bolt assemblies (page 117)
- Bolt length calculation (page 122)
How the bolt catalog and bolt assembly catalogs work together

1. The **Bolt standard** options are read from the bolt assembly catalog.
2. The bolt assembly catalog defines which bolt standard is used in the bolt assembly.
3. The bolt catalog contains the different bolt diameters, lengths, and other properties used in the bolt standard.
4. The **Bolt size** options are read from the bolt catalog depending on the selected **Bolt standard** option.

**See also**

- Customize the bolt catalog (page 111)
- Bolt catalog properties (page 126)
- Bolt assembly catalog properties (page 127)
Manage bolts and bolt assemblies

This section describes how to manage bolts and bolt assemblies using the bolt catalog and the bolt assembly catalog. You can add, modify, and delete bolts and bolt assemblies.

Click the links below to find out more:

- Add a bolt to the catalog (page 113)
- Add a stud bolt to the catalog (page 114)
- Modify bolt information in the catalog (page 115)
- Delete a bolt from the catalog (page 116)
- Add a bolt assembly to the catalog (page 116)
- Modify bolt assembly information in the catalog (page 117)
- Delete a bolt assembly from the catalog (page 117)

**Add a bolt to the catalog**

You need to add individual bolt elements, such as bolts, nuts, and washers, to the bolt catalog before you can define bolt assemblies and use them in a model.

The following steps are for adding bolts, but they also apply to adding nuts and washers.

1. On the **File** menu, click **Catalogs** --> **Bolt catalog** to open the Bolt Catalog dialog box.
2. Enter the name of the bolt in the following box:

   ![Bolt Catalog Dialog Box]

   You can enter a maximum of 40 characters in the name box.

3. In the **Type** list, select an option to define the bolt element type.
4. Define the other properties of the new bolt.

   You can enter a maximum of 25 characters in the **Standard** box.

   Use different names for bolt, nut, washer, and stud standards to distinguish bolt element types from each other when defining bolt assemblies.

5. Click **Add** to add the bolt to the bolt catalog.

   You cannot use a bolt if it does not belong to a bolt assembly. Therefore, we recommend checking that the catalog also includes nuts and washers that work with the new bolt so that you can create a bolt assembly. If the
catalog does not include suitable nuts and washers, add them the same way as you added the new bolt.

6. Click **OK**.

   The **Save confirmation** dialog box appears.

7. Select **Save changes to model folder** to save the changes in the `screwdb.db` file in the current model folder, and then click **OK**.

   **TIP** You can also add bolts by importing them to the bolt catalog.

---

**See also**

- Import bolts to the catalog (page 118)
- Add a stud bolt to the catalog (page 114)
- Modify bolt information in the catalog (page 115)
- Delete a bolt from the catalog (page 116)
- Bolt length calculation (page 122)
- Bolt catalog properties (page 126)
- Add a bolt assembly to the catalog (page 116)

---

**Add a stud bolt to the catalog**

A stud is special type of bolt that is welded to steel parts to transfer loads between steel and concrete. You cannot use studs unless you have defined a stud assembly that contains the assembly's name and material.

1. On the **File** menu, click **Catalogs --> Bolt catalog** to open the **Bolt Catalog** dialog box.

2. Enter values for the following properties:
   - **Name**: Name for the stud bolt.
   - **Type**:  
     - **Standard**: This name is needed when creating a bolt assembly for the stud.
   - **Diameter**: Shank diameter.
   - **Length**: Stud length.
   - **Weight**: Stud weight.
   - **top thick**: Head thickness.
• top diameter: Head diameter.

The units depend on the settings in File menu -> Settings -> Options -> Units and decimals.

3. On the File menu, click Catalogs -> Bolt assembly catalog to open the Bolt Assembly Catalog dialog box.

4. Select the standard for the stud bolt.

5. Set all the other bolt assembly elements to None.

6. To create studs in the model, create bolts and select the stud assembly standard.

See also
Bolt catalog properties (page 126)

Modify bolt information in the catalog

1. On the File menu, click Catalogs -> Bolt catalog to open the Bolt Catalog dialog box.

2. Select a bolt from the list.

3. Modify the properties.

4. Click Update.

5. Click OK.

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the screwdb.db file in the current model folder, and then click OK.

See also
Add a bolt to the catalog (page 113)
Delete a bolt from the catalog (page 116)
Bolt catalog properties (page 126)
**Delete a bolt from the catalog**

1. On the **File** menu, click **Catalogs --> Bolt catalog** to open the **Bolt Catalog** dialog box.
2. Select a bolt from the list.
   Use the **Shift** and **Ctrl** keys to select multiple bolts.
3. Click **Delete**.
4. Click **OK**.
   The **Save confirmation** dialog box appears.
5. Select **Save changes to model folder** to save the changes in the `screwdb.db` file in the current model folder, and then click **OK**.

**See also**

- Add a bolt to the catalog (page 113)
- Modify bolt information in the catalog (page 115)

**Add a bolt assembly to the catalog**

You can add new bolt assemblies to the bolt assembly catalog. Note that the bolt assembly can contain only bolts or studs, not both of them.

1. On the **File** menu, click **Catalogs --> Bolt assembly catalog** to open the **Bolt Assembly Catalog** dialog box.
2. Enter the name of the bolt assembly in the following box:
   ![Image](image)
3. Define the other properties of the new bolt assembly.
   You can enter a maximum of 30 characters in the **Standard** box. For all the other properties, you can enter a maximum of 25 characters.
4. Click **Add** to add the bolt assembly to the catalog.
5. Click **OK**.
   The **Save confirmation** dialog box appears.
6. Select **Save changes to model folder** to save the changes in the `assdb.db` file in the current model folder, and then click **OK**.

**See also**

- Import bolt assemblies to the catalog (page 119)
- Modify bolt assembly information in the catalog (page 117)
Modify bolt assembly information in the catalog
1. On the File menu, click Catalogs --> Bolt assembly catalog to open the Bolt Assembly Catalog dialog box.
2. Select a bolt assembly from the list.
3. Modify the properties.
4. Click Update.
5. Click OK.
   The Save confirmation dialog box appears.
6. Select Save changes to model folder to save the changes in the assdb.db file in the current model folder, and then click OK.

See also
Add a bolt assembly to the catalog (page 116)
Delete a bolt assembly from the catalog (page 117)

Delete a bolt assembly from the catalog
1. On the File menu, click Catalogs --> Bolt assembly catalog to open the Bolt Assembly Catalog dialog box.
2. Select a bolt assembly from the list.
3. Click Delete.
4. Click OK.
   The Save confirmation dialog box appears.
5. Select Save changes to model folder to save the changes in the assdb.db file in the current model folder, and then click OK.

See also
Add a bolt assembly to the catalog (page 116)
Modify bolt assembly information in the catalog (page 117)

Import and export bolts and bolt assemblies
Use importing and exporting for merging bolts and bolt assemblies across catalogs. Bolts are imported and exported as .bolts files, bolt assemblies as .bass files, and bolt catalogs as .lis files.
When you export single bolts or bolt assemblies, you can select the bolts or bolt assemblies you want to include in the `.bolts` or `.bass` file. When you import and export bolt assemblies, also the related bolts are included in the `.bass` file.

You can import and export an entire bolt catalog. You can also import a part of an exported bolt catalog.

Importing and exporting bolt catalogs is useful, when you:

- Upgrade to newer version of Tekla Structures and you want to use a customized bolt catalog from a previous version.
- Want to combine bolt catalogs that are stored in different locations.
- Want to share bolt catalog information with other users.

**TIP**  You can also download or share bolt assemblies using Tekla Warehouse.

**See also**

- Import bolts to the catalog (page 118)
- Export bolts from the catalog (page 119)
- Import bolt assemblies to the catalog (page 119)
- Export bolt assemblies from the catalog (page 120)
- Import a bolt catalog (page 120)
- Import a part of the bolt catalog (page 121)
- Export an entire bolt catalog (page 122)

**Import bolts to the catalog**

Bolts are imported and exported as `.bolts` files. A `.bolts` file can include one bolt or several bolts.

1. On the **File** menu, click **Catalogs** --> **Bolt catalog** to open the **Bolt Catalog** dialog box.
2. Right-click in the **Bolts** list and select **Import**.
3. Select the import file.
4. Click **OK**.
   The bolts are displayed on the **Bolts** list by their original names.
5. Click **OK**.
   The **Save confirmation** dialog box appears.
6. Select **Save changes to model folder** to save the changes in the `screwdb.db` file in the current model folder, and then click **OK**.
Bolts are imported and exported as .bolts files. A .bolts file can include one bolt or several bolts.

1. On the **File** menu, click **Catalogs --> Bolt catalog** to open the **Bolt Catalog** dialog box.
2. Select bolts from the **Bolts** list.
   - Use the **Shift** and **Ctrl** keys to select multiple bolts.
3. Right-click in the **Bolts** list and select **Export**.
4. Browse for the folder where you want to save the export file.
5. Enter a name for the file in the **Selection** box.
6. Click **OK**.

**Export bolt assemblies from the catalog**

Bolt assemblies are imported and exported as .bass files. A .bass file can include one bolt assembly or several bolt assemblies.

1. On the **File** menu, click **Catalogs --> Bolt assembly catalog** to open the **Bolt Assembly Catalog** dialog box.
2. Right-click in the **Bolt assemblies** list and select **Import**.
3. Select the import file.
4. Click **OK**.
   - The bolt assemblies are displayed on the **Bolt assemblies** list by their original names.
5. Click **OK**.
   
   The **Save confirmation** dialog box appears.

6. Select **Save changes to model folder** to save the changes in the
   assdb.db file in the current model folder, and then click **OK**.

**See also**

Add a bolt assembly to the catalog (page 116)
Import a bolt catalog (page 120)
Import bolts to the catalog (page 118)
Export bolt assemblies from the catalog (page 120)

**Export bolt assemblies from the catalog**

Bolt assemblies are imported and exported as .bass files. A .bass file can include one bolt assembly or several bolt assemblies.

1. On the **File** menu, click **Catalogs --> Bolt assembly catalog** to open the
   **Bolt Assembly Catalog** dialog box.
2. Select bolt assemblies from the **Bolt assemblies** list.
   
   Use the **Shift** and **Ctrl** keys to select multiple bolt assemblies.
3. Right-click in the **Bolt assemblies** list and select **Export**.
4. Browse for the folder where you want to save the export file.
5. Enter a name for the file in the **Selection** box.
6. Click **OK**.

**See also**

Export an entire bolt catalog (page 122)
Export bolts from the catalog (page 119)
Import bolt assemblies to the catalog (page 119)

**Import a bolt catalog**

Bolt catalogs are imported to Tekla Structures models as .lis files.

1. Open the model to which you want to import a bolt catalog.
2. Copy the screwdb.lis file that you want to import to the current model folder.
3. To import the bolt catalog file `screwdb.lis` from the current model folder, go to Quick Launch, start typing `import bolt catalog`, and select the Import Bolt Catalog command from the list that appears.

Tekla Structures does not replace the entries that have the same names as the entries in the import file.

4. Check the status bar for error messages.

To view errors, go to the File menu and click Logs --> Session history log.

See also
Import a part of the bolt catalog (page 121)
Export an entire bolt catalog (page 122)

**Import a part of the bolt catalog**
If you do not want to import the entire bolt catalog, you can select the parts to be imported.

**TIP** If you only want to import a few bolts or bolt assemblies, use the import and export commands of the corresponding catalogs.

1. Open the model that contains the bolt catalog you want to use.
2. Go to Quick Launch, start typing `export bolt catalog`, and select the Export Bolt Catalog command from the list that appears.

The bolt catalog is saved as the `screwdb.lis` file in the current model folder.

3. Open the `screwdb.lis` file using a text editor, for example, Microsoft Notepad.

Each entry is listed on a separate row.

4. Delete the unwanted rows from the file.

**WARNING** Do not delete the STARTLIST and ENDLIST rows.

5. Save the file with the name `screwdb.lis`.
6. Open the model to which you want to import the bolt catalog.
7. Copy the `screwdb.lis` file that you want to import to the current model folder.
8. To import the bolt catalog file `screwdb.lis` from the current model folder, go to Quick Launch, start typing `import bolt catalog`, and select the Import Bolt Catalog command from the list that appears.
**See also**
Import bolts to the catalog (page 118)
Import bolt assemblies to the catalog (page 119)
Import a bolt catalog (page 120)
Export an entire bolt catalog (page 122)

**Export an entire bolt catalog**
Bolt catalogs are exported from Tekla Structures models as .lis files.

1. Open the model that contains the bolt catalog you want to export.
2. Go to **Quick Launch**, start typing `export bolt catalog`, and select the **Export Bolt Catalog** command from the list that appears.

   The exported bolt catalog is the `screwdb.lis` file in the current model folder.

   **TIP** The **Export Bolt Catalog** command exports the entire bolt catalog. To export only part of the bolt catalog, modify the export file to contain only the required elements. You can also export bolts from the **Bolt Catalog** dialog box or bolt assemblies from the **Bolt Assembly Catalog** dialog box.

**See also**
Export bolt assemblies from the catalog (page 120)
Export bolts from the catalog (page 119)
Import a bolt catalog (page 120)
Import a part of the bolt catalog (page 121)

**Bolt length calculation**
Tekla Structures uses values from the bolt catalog and the bolt assembly catalog when calculating the bolt length. If the bolt catalog does not contain long enough bolts for your purposes, you need to add them to the bolt catalog.
The following settings in the **Bolt Properties** dialog box affect the bolt length calculation process. If the check box is selected, the part is used in the bolt assembly.

![Diagram showing parts with slotted holes and include in bolt assembly]

1. Washer (1)
2. Washer (2)
3. Washer (3)
4. Nut (1)
5. Nut (2)
6. If the check box is clear, only a hole is created

The chart and the detailed steps below explain the process of bolt length calculation.
1. Tekla Structures calculates the minimum possible length of the bolt as follows:
   - washer (1) thickness (if the check box is selected) +
   - material thickness +
   - washer (2) thickness (if the check box is selected) +
   - washer (3) thickness (if the check box is selected) +
   - nut (1) thickness +
   - nut (2) thickness +
   - extra length

2. Tekla Structures searches for the closest match in the bolt catalog.

3. Tekla Structures calculates the number of washers required (must not exceed 10) so that the length of the shaft is less than:
   - nut (1) thickness +
   - material thickness +
   - nut (2) thickness +
   - washer (1) thickness +
   - washer (2) thickness +
   - (number of washers*washer (3) thickness)

4. Tekla Structures checks that the bolt found in step 2 is longer than:
   - extra length +
   - nut (1) thickness +
material thickness +
nut (2) thickness +
add. dist (from the bolt catalog) +
washer (1) thickness +
washer (2) thickness +
(number of fitting washers * washer (3) thickness)

5. If the selected bolt does not fulfill the criteria in step 4, Tekla Structures returns to step 2, otherwise it continues on to step 6.

6. Tekla Structures checks that the selected bolt fulfills all the following conditions:
   • Can the thread be inside the material to be connected? Even if this is not allowed, the calculation always allows 3 or 4 mm of thread to be inside the material, depending on the bolt diameter. If the bolt diameter is ≥ 24 mm, it allows 4 mm, otherwise it allows 3 mm.
   • Shaft length must be more than:
     material thickness +
     extra length +
     washer (1) thickness (if checked) -
     maximum thread in material allowed (if thread in material = no) = 3 mm or 4 mm
   • Shaft length is calculated as:
     Screw length - screw thread length - thread end.
   • Thread end is the part of the bolt between the shaft and the thread. It is calculated as follows:

<table>
<thead>
<tr>
<th>Diameter of bolt (mm)</th>
<th>Thread end (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;33.0</td>
<td>10.0</td>
</tr>
<tr>
<td>&gt;27.0</td>
<td>8.0</td>
</tr>
<tr>
<td>&gt;22.0</td>
<td>7.0</td>
</tr>
<tr>
<td>&gt;16.0</td>
<td>6.0</td>
</tr>
<tr>
<td>&gt;12.0</td>
<td>5.0</td>
</tr>
<tr>
<td>&gt;7.0</td>
<td>4.0</td>
</tr>
<tr>
<td>&gt;4.0</td>
<td>2.5</td>
</tr>
<tr>
<td>≤4</td>
<td>1.5</td>
</tr>
</tbody>
</table>

7. If the selected bolt does not fulfill all the above conditions, Tekla Structures returns to step 2 and tries the next longest bolt.
8. If the advanced option `XS_BOLT_LENGTH_EPSILON` is set, the epsilon thickness is added to, or subtracted from, the material thickness to avoid inaccurate bolt length calculation. 

For example, if this value is not taken into account, and the calculated length is 38.001 mm, a 39 mm bolt might be selected.

**See also**

How the bolt catalog and bolt assembly catalogs work together (page 111)
Add a bolt to the catalog (page 113)

---

**Bolt catalog properties**

Use the **Bolt Catalog** dialog box to view and modify the properties of individual bolt elements, such as bolts, washers, and nuts. The units depend on the settings in **File menu --> Settings --> Options --> Units and decimals**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>The type of the bolt element. The options are:</td>
</tr>
<tr>
<td><img src="image" alt="Bolt" /></td>
<td>(Stud)</td>
</tr>
<tr>
<td><img src="image" alt="Washer" /></td>
<td>(Washer)</td>
</tr>
<tr>
<td><img src="image" alt="Nut" /></td>
<td>(Nut)</td>
</tr>
<tr>
<td><strong>Standard</strong></td>
<td>The name of the bolt element standard.</td>
</tr>
<tr>
<td></td>
<td>Used in the <strong>Bolt Assembly Catalog</strong> dialog box for defining bolt elements in a bolt assembly.</td>
</tr>
<tr>
<td></td>
<td>Use different names for bolt, nut, washer, and stud standards to distinguish bolt element types from each other.</td>
</tr>
<tr>
<td><strong>Diameter</strong></td>
<td>The diameter of the bolt element.</td>
</tr>
<tr>
<td><strong>Length</strong></td>
<td>The length of the bolt element.</td>
</tr>
<tr>
<td><strong>Weight</strong></td>
<td>The weight of the bolt element.</td>
</tr>
</tbody>
</table>
### Option Table

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>add. dist</td>
<td>The length of the part of the bolt that protrudes from the nut.</td>
</tr>
<tr>
<td></td>
<td>The value is used in bolt length calculation.</td>
</tr>
<tr>
<td>top thick</td>
<td>The thickness of the bolt head.</td>
</tr>
<tr>
<td>thread len</td>
<td>The length of the threaded part of the bolt shaft.</td>
</tr>
<tr>
<td></td>
<td>The value is not used in bolt length calculation (value is 0) if the bolt is fully-threaded.</td>
</tr>
<tr>
<td>washer tol</td>
<td>The tolerance between the washer inner diameter and the bolt diameter.</td>
</tr>
<tr>
<td></td>
<td>The value is used when searching for the correct-sized washer for the bolt. Not used in bolt length calculation.</td>
</tr>
<tr>
<td>span size</td>
<td>The size of the wrench needed.</td>
</tr>
<tr>
<td>calc thick</td>
<td>The calculation thickness of a nut or a washer.</td>
</tr>
<tr>
<td></td>
<td>This value is used in bolt length calculation.</td>
</tr>
<tr>
<td>real thick</td>
<td>The true thickness of a nut or a washer.</td>
</tr>
<tr>
<td></td>
<td>This is for information only.</td>
</tr>
<tr>
<td>inner diam</td>
<td>The inner diameter of a nut or a washer.</td>
</tr>
<tr>
<td></td>
<td>This is for information only.</td>
</tr>
<tr>
<td>outer diam</td>
<td>The outer diameter of a nut or a washer.</td>
</tr>
<tr>
<td></td>
<td>This is for information only.</td>
</tr>
<tr>
<td>top diam</td>
<td>The diameter of the hexagon.</td>
</tr>
<tr>
<td></td>
<td>This is for information only.</td>
</tr>
</tbody>
</table>

### See also

*Add a bolt to the catalog (page 113)*

*How the bolt catalog and bolt assembly catalogs work together (page 111)*

### Bolt assembly catalog properties

Use the **Bolt Assembly Catalog** dialog box to view and modify the properties of bolt assemblies. The units depend on the settings in **File menu --> Settings --> Options --> Units and decimals.**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Short name</td>
<td>This name is used in drawings and reports. It is usually the commercial name for a specific bolt.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Standard</td>
<td>This name is the full name which is shown in the bolt assemblies list in the <strong>Bolt Assembly Catalog</strong> dialog box, and in the <strong>Bolt standard</strong> list in the <strong>Bolt Properties</strong> dialog box. The value is used in bolt length calculation.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the bolt assembly.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of the finish.</td>
</tr>
<tr>
<td>Grade</td>
<td>The grade of the bolt assembly.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>The tolerances of the bolt assembly.</td>
</tr>
</tbody>
</table>

### Additional length for bolt calculation

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add. dist...</td>
<td>The <strong>Additional Distance</strong> option controls how much of the bolt protrudes from the nut. <strong>Additional Distance</strong> updates the <strong>Additional Distance</strong> values of all bolts that use the selected bolt standard and have the selected diameter. The value is used in bolt length calculation.</td>
</tr>
</tbody>
</table>

![Additional Distance](image_url)

1. Select whether the value of the additional length affects all or individual diameters of one bolt assembly.
2. Enter the additional length value.
3. Select whether the value is absolute or relative to the diameter.
See also

Add a bolt assembly to the catalog (page 116)
6.1 Customize a default setup for Organizer

You can customize Organizer by creating a setup that opens the same templates and categories in all new models. A customized setup is useful if you have templates and categories you want to use in all models. Then you do not need to create or import the templates and categories for each model separately. The customized setup is used when you open Organizer in a model for the first time.

To make the customized property templates and categories available in all models, store the templates in the \ProjectOrganizerData\PropertyTemplates folder and the categories in the \ProjectOrganizerData\DefaultCategoryTrees folder. The templates and categories are stored as in the xml format. Property template files have the .propertytemplate file extension and categories have the .category file extension.

**NOTE** The defined location categories are automatically imported but they behave like manually created categories. Automatic categories need to be defined in each model separately.

You can have the folders under any or all of the following folders:
- Current model folder
- Project folder, defined in the XS_PROJECT advanced option
- Firm folder, defined in the XS_FIRM advanced option
- System folder, defined in the XS_SYSTEM advanced option

Example of the \system folder:
All templates and categories in these folders are loaded to Organizer when you open it for the first time in a model. If there are many files with the same file name in several different folders, the first file found is loaded and the other files with the same file name are ignored. The search order is always: model, project, firm, system. The roles.ini does not affect this order.

For example, if you have `rebar.category`, `category.category` and `material.category` in the `\system\ProjectOrganizerData\DefaultCategoryTrees` folder, these files will all be loaded automatically to the categories. If you also have a `rebar.category` file in the `\PROJECT\ProjectOrganizerData\DefaultCategoryTrees` folder and in the `\model\ProjectOrganizerData\DefaultCategoryTrees` folder, only the first `rebar.category` file found is used. In this case, the file under the model folder would be the first one found.

**NOTE** You can use the roles.ini files to control multiple setups. For example, create a `\Concrete\ProjectOrganizerData` folder and a `\Steel\ProjectOrganizerData` folder under the firm folder. Then define in the roles.ini file which of these folders is read and/or in which order the folders are read. This way you can read only the `\Concrete` folder files, or read the `\Concrete` folder first. In this case, the files with the same name in the steel folder are ignored.

The loaded templates and categories are saved in the ProjOrg.db in the \ProjectOrganizer folder under the model folder. When you open Organizer for the first time, the ProjOrg.db is created and the files are read in from the model, project, firm and system folders. The ProjOrg.db database stores all template and category information used in the model. When you make changes to the templates and categories in the folders, they are not automatically updated in ProjOrg.db. The database will not read in the template and category xml files again, so updates to the files will not be automatically applied.

If you want to apply the changed templates and categories to the ProjOrg database, you have two options:

- Delete the old templates and categories in Organizer and import the changed templates and categories. We recommend that you use this option.

- Export from Organizer all the templates and categories that you want to keep and close the model. Delete the ProjOrg.db database from the \ProjectOrganizer folder under the model folder, and re-open the model. Import the exported templates and categories back to Organizer.

**NOTE** The second option will reset Organizer completely. All data will be lost if not exported.
Excluding object types from Organizer

Some object types can be excluded from Organizer. These object types are listed in the ExcludedTypesFromOrganizer.xaml file that is by default located in the \system\ProjectOrganizerData folder in the Common environment. The location may vary depending on your environment. Excluded object types are not displayed in Object Browser and they are not included in categories, even if you select in the category rules to include a model and all its objects to a category. For example, loads, cuts and fittings are listed in the ExcludedTypesFromOrganizer.xaml file and excluded from Organizer.

You can modify the ExcludedTypesFromOrganizer.xaml file to either include or exclude the object types. Before you modify the file, we recommend that you copy it to the \ProjectOrganizerData folder that is under the model folder. You may need to create the \ProjectOrganizerData folder as it does not by default exist in the model folder.

For example, to exclude fittings, change the value as follows:

<Fitting>true</Fitting> to <Fitting>false</Fitting>

To include fittings again, change the value false back to true.

To apply the changes, click in Categories to fully synchronize Organizer with the model.

**NOTE** Do not add or remove any lines from the ExcludedTypesFromOrganizer.xaml file, otherwise Organizer will not be able to use the file.
7 System

7.1 Create project and firm folders

Use project and firm folders for customized files that you want to use in more than one project. These can be custom ribbons, drawing styles, profile and material catalogs, or any other settings you want to store for future use. You can use the same files in each project, without having to redefine the values each time you start a new model or install a new version of Tekla Structures. This also means you can easily revert back to the default settings, because you have not overwritten any of the system files. Place the project and firm folders in a shared directory on a network drive, so that everyone concerned can access them.

Use the **project folder** for customized files that are only used in a particular project. For example, a project may consist of several models done by separate teams, all spread out in different locations. You can save project-specific files and settings in the project folder, so that everyone in the project can use them.

Use the **firm folder** to store customized files for the entire organization or company. These settings and files are meant to be used in all projects within the company.

For example, let's say you regularly work for a company that has specific drawing layout standards it expects you to use. Customize the drawing templates once for the company and save them in a sub-folder located under the firm folder. You can then use the customized drawing templates for all future projects for that company.

**Create a project or firm folder**

1. Create an empty folder in a shared location, for example on a network drive.
2. Name the folder appropriately.
   For example, **Project** or **Firm**, depending on which folder you are creating.
3. Open the user.ini file in a text editor.
   The file is located in the ..\Users<user>\AppData\Local\Tekla Structures<version>\UserSettings folder.

4. Define the path to the project or firm folder you created in step 1.
   Modify either of the following lines in the user.ini file:
   
   ```
   set XS_FIRM=..firm folder path
   set XS_PROJECT=..project folder path
   ```
   Make sure you have included the name of the actual project or firm folder in the path. For example, set XS_FIRM=Z:\Firm. Also make sure you have removed "rem" from the beginning of the line. Only the lines beginning with "set" are active and therefore used by Tekla Structures.

5. Save the user.ini file.

6. Restart Tekla Structures for the change to take effect.

7.2 Customize message files
You can customize the messages that Tekla Structures displays in the user interface.

1. Do one of the following:
   • To modify an .ail message file, go to the ..\Tekla Structures <version>\messages folder.
   • To modify an .xml message file, go to the ..\Tekla Structures <version>\messages\DotAppsStrings folder.

2. Open the message file you want to customize using a standard text editor.

3. Modify the message as required.

4. Save the message file.

**Example: customize a message file**

In this example, you will modify a message that Tekla Structures uses for near side plates in drawings. You want Tekla Structures to display (NS) instead of (N/S).

1. Go to the ..\Tekla Structures<version>\messages folder.

2. Open by_number.ail using a standard text editor.
   The by_number.ail file contains both prompts and default texts that Tekla Structures uses in drawings.

3. Browse to the following section:
7.3 Create startup shortcuts with customized initializations

You can use shortcuts to start teklastructures.exe with customized initializations. You can use this functionality to create shortcuts for different purposes, for example, to have customized setup files depending on the client you are working for in a project. The Tekla Structures installation automatically creates shortcuts for the selected environments.

NOTE We recommend that only administrators create the customization and the necessary shortcuts. Otherwise, your settings may differ from the settings defined for your firm, or for the particular project you are working for.

Create a startup shortcut with customized initialization

1. Open the user.ini file using any standard text editor.
2. Save the file with a new name, for example, customer.ini or project.ini.
3. Modify the file by adding the required settings.
4. Save the modified initialization file.
5. Open the Windows Start menu and select All Programs --&gt; Tekla Structures <version>.
6. Right-click Tekla Structures <version> and select Copy.
7. Paste the shortcut to your desktop.
8. Select the shortcut, right-click and select Properties.
9. Modify the Target of the shortcut by adding the required project initialization information to it.
First enter the path to the current `teklastructures.exe`, then the desired parameters.

Use the quotation marks ("") in the path to avoid possible problems if the path contains spaces. If you have installed Tekla Structures to a path that does **not** contain spaces, there will be no problems even if you remove the quotations marks, for example, `C:\TeklaStructures\`. If you have installed Tekla Structures to a path that contains spaces, the quotation marks are needed, for example, `C:\Program Files\Tekla Structures\`.

The maximum length of a shortcut is 256 characters. If you have problems with the length, you can call all other necessary initialization files from your customized initialization file instead of adding them to the shortcut.

10. To override the settings defined in the shortcuts, use the parameter `-i <initialization_file>` in the `user.ini` and `option.ini` files.

### Available parameters in shortcuts

You can use the following parameters in shortcuts:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| `-I <ini_file_path>` | The given `.ini` file is **loaded before** the environment `.ini` files. This parameter can be specified multiple times. This parameter could be used to bypass the **Choose Setup** dialog (the login dialog). Example:  
```
"C:\Program Files\Tekla Structures\2016\nt\bin
``` |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-i &lt;ini_file_path&gt;</td>
<td>The given .ini file is loaded after the role .ini files. This parameter can be specified multiple times. Example:</td>
</tr>
<tr>
<td></td>
<td>&quot;C:\Program Files\Tekla Structures\2016\nt\bin\TeklaStructures.exe&quot; -i</td>
</tr>
<tr>
<td></td>
<td>&quot;C:\TeklaStructures\MySettings.ini&quot;</td>
</tr>
<tr>
<td>&lt;model_path&gt;</td>
<td>The given model is opened after startup. Example:</td>
</tr>
<tr>
<td></td>
<td>&quot;C:\Program Files\Tekla Structures\2016\nt\bin\TeklaStructures.exe&quot;</td>
</tr>
<tr>
<td></td>
<td>&quot;C:\TeklaStructuresModels\New Engineering model&quot;</td>
</tr>
<tr>
<td>-m &lt;macro_file_path&gt;</td>
<td>The given macro is executed during startup. Example:</td>
</tr>
<tr>
<td></td>
<td>&quot;C:\Program Files\Tekla Structures\2016\nt\bin\TeklaStructures.exe&quot;</td>
</tr>
<tr>
<td></td>
<td>&quot;c:\ProgramData\Tekla Structures\2016\Environments\usimp\macros\modeling\Directory Browser.cs&quot;</td>
</tr>
</tbody>
</table>

These parameters can be used in combination, and they automatically bypass the **Tekla Structures - Choose setup** dialog box, open a model and run a macro, for example.

"C:\Program Files\Tekla Structures\2016\nt\bin\TeklaStructures.exe" -I
"C:\ProgramData\Tekla Structures\2016\Environments\usimp\us_roles\engineering\EngBypass.ini"
"D:\Models\TS2016\New Engineering model" -m "c:\ProgramData\Tekla Structures\2016\Environments\usimp\macros\modeling\Directory Browser.cs"

**Example of an initialization file**
Below is an example of a customized project initialization file that calls other initialization files.
MyProject.ini

// The project is based on the default US imperial settings
call c:\ProgramData\Tekla Structures\18.0\environments\usimp\env_usimp.ini
// ...but our company policy requires these changes
call c:\Company\Settings\OurPolicy.ini
// ...and the fabricator requires something

call c:\Fabricator\Fabricator1.ini
// ...and then we let users to make some changes (bg color etc.)
call c:\Users\user\USERNAME4.ini

The project shortcut for this initialization file:

C:\Program Files\Tekla Structures\21.0\nt\bin
\TeklaStructures.exe -i \MyServer\MyProject\MyProject.ini \MyServer\MyProject\MyModel\MyModel.db1

7.4 Define and update user-defined attributes (UDAs)

Many dialog boxes contain user-defined attributes (UDAs) for various objects, including beams, columns, bolts and drawings. Tekla Structures displays these fields when you click **User-defined attributes** in a dialog box. For example, comment, locked, and erection status are user-defined attributes.

**When you define new user-defined attributes**

The user-defined attributes are managed in the objects.inp file. To define new user-defined attributes, create your own objects.inp file in the model, project or firm folder. After adding your own user-defined attributes, you need to run the **Diagnose and change attribute definitions** command to **update the definitions** (page 139) in the model.

When you **define new user-defined attribute** (page 140), make the definition of the user-defined attribute unique. This is because a user-defined attribute cannot have different definitions for different object types, such as beams and columns.

The object.inp files are merged so that if there are user-defined attributes in any of the files, they are displayed in the user interface. Tekla Structures merges the files in a way that eliminates duplicate attributes. If Tekla Structures encounters the same attribute name in different objects.inp files, the attribute from the first read objects.inp file will be used.

**WARNING**  Do not copy the objects.inp file in the ..\environments\common\inp\ folder. Copying the file creates unnecessary duplicates and later objects.inp updates by Tekla Structures can be lost.
Tekla Structures reads the objects.inp files from the following folders in the following order:
1. model folder
2. project folder
3. firm folder
4. system folder
5. inp folder

See also
Environment database file (page 139)

Update definitions of user-defined attributes (UDAs) in a model
When you have changed definitions of a user-defined attribute by modifying the objects.inp file, you need to update the definitions in the model.
1. Open the model.
2. On the File menu, click Diagnose & repair and in the Utilities area, click Diagnose and change attribute definitions.
   The Diagnose & Change Attribute Definitions dialog box opens.
3. Select an attribute from the list on left side to see the comparison of current definitions and objects.inp definitions.
4. Select the definitions you want to update in the Object classes with Objects.inp differences compared to current settings list.
5. Click Change current settings to selected Objects.inp settings.

See also
Define and update user-defined attributes (UDAs) (page 138)
Environment database file (page 139)
Example: Create and update a user-defined attribute (UDA) (page 140)

Environment database file
To guarantee consistent model behavior when a model is used with different roles, the environment database file (environment.db) contains the definitions of the user-defined attributes (UDAs) used in the model.

When you create a new model, Tekla Structures merges the definitions from your objects.inp files to the environment.db file. Later, when you add new...
user-defined attributes in the objects.inp file, the definitions are saved in environment.db as you open the model.

You can modify your user-defined attributes (page 138) in an objects.inp file but the changed definitions do not come into effect automatically. If there are conflicts, the definitions in environment.db win. You need to run the Diagnose and change attribute definitions command to see the conflicts between environment.db and objects.inp, and select the attribute definitions that you want to update.

See also
Update definitions of user-defined attributes (UDAs) in a model (page 139)
Example: Create and update a user-defined attribute (UDA) (page 140)

Example: Create and update a user-defined attribute (UDA)
This example shows how to create your own user-defined attribute (UDA) and update the model to use the changed attribute definition.

Create a user-defined attribute
1. Create a new model and save it.

   The user-defined attributes in the model are merged from objects.inp (page 138) files and Tekla Structures saves the attribute definitions in the environment.db (page 139) file in the model folder.

2. Close the model.

3. Create an input file called objects.inp in the model folder by using a standard text editor.

4. Enter the following information in objects.inp. For details about the properties in the attribute string, see objects.inp (page 138).

   /*********************************************************/
   /* Part attributes */
   /*********************************************************/
   part(0,"Part")
   {
   /* User defined tab page */
   tab_page("My UDA tab")
   {
/* User defined attribute */
attribute("MY UDA", "My UDA", string,"%s", no, none, "0,0", "0,0")
{
  value("", 0)
}

tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
}/

*********************************************************
******************
/* Column attributes */
*********************************************************
******************
column(0,"j_column")
{
  /* Reference to the user defined tab page that is defined above in */
  /* the part() section: */
  tab_page("My UDA tab", "My UDA tab", 19)
  modify (1)
}

To see the example text file, click objects.inp - example 1.

NOTE  If you want to create a user-defined attribute that also affects numbering, set the special_flag property of the attribute to yes (it is no in the example above). Also, just like in the example above, the definition of the tab_page must be in the part section, and the column (beam, etc.) section must have only a reference to it.

5. Save objects.inp.

Test the user-defined attribute
1. Open the model.
2. Create a steel column.
3. Double-click the steel column to open its properties dialog box.
4. Click **User-defined attributes**.
5. Go to **My UDA tab**.

<table>
<thead>
<tr>
<th>My UDA tab</th>
<th>General Design</th>
<th>Tekla Structural Designer</th>
</tr>
</thead>
<tbody>
<tr>
<td>My UDA</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

6. Enter a value in the **My UDA** box.
7. Click **Modify**.
8. Copy the steel column.
9. Check the **My UDA** box of the new steel column.
   The attribute value was also copied.
10. Close the model.

**Modify the user-defined attribute to make it unique**
1. Open the `objects.inp` file in the model folder by using a standard text editor.
2. Enter `unique_` before the user-defined attribute.

```plaintext
/* User-defined attributes */
part(0,"Part")
{
    /* Common tab pages for part attributes */
    tab_page("My UDA tab")
    {
        unique_attribute("MY UDA", "My UDA", string,"%s", no, none, "0,0", "0,0")
        {
            value("", 0)
        }
    }
    tab_page("My UDA tab", "My UDA tab", 19)
    modify (1)
}
```

**System 142**
**Define and update user-defined attributes (UDAs)**
This makes the user-defined attribute unique, meaning that the value of the user-defined attribute will not be copied to another part.

3. **Save** `objects.inp`.

To see the example text file, click `objects.inp - example 2`.

**Test the unique user-defined attribute**

1. Open the model.
2. Enter a value in the **My UDA** box for a steel column and click **Modify**.
3. Copy the steel column.
4. Check the **My UDA** box of the new column.
5. The value was copied, so the user-defined attribute in the model is not unique. There is a conflict between the `environment.db` and `objects.inp` definitions.

**Update the definitions of user-defined attributes**

1. On the **File** menu, click **Diagnose & repair** and in the **Utilities** area, click **Diagnose and change attribute definitions**.
   
   The **Diagnose & Change Attribute Definitions** dialog box opens.
2. Select **My UDA** in the **Attribute** area on the left.
   
   You can see that **My UDA** is not unique in the current setting, but it is set to unique in `objects.inp`.

3. Select the definition in the area on the right.
4. Click **Change current settings to selected Objects.inp settings**.
   Now the definition of the user-defined attribute is updated in the model.
   If you now copy a steel column that has a value for **My UDA**, the value is not copied to the new column.

**See also**

- Update definitions of user-defined attributes (UDAs) in a model (page 139)
- Define and update user-defined attributes (UDAs) (page 138)

## 7.5 Customize using Tekla Open API

Tekla Open API is a specialized Application Programming Interface (API) developed by Tekla that enables you to develop applications and additional functionality on the Tekla modeling platform and integrate it into your own environment. Tekla Open API is implemented using Microsoft .NET technology.

Applications that are developed with Tekla Open API to work in conjunction with Tekla Structures are called *extensions*.

With Tekla Open API you can:

- **Record and run user interface actions**
  By recording and running user interface actions you can automate routine tasks, such as creating daily reports.

- **Create automation tools**
  You can create automation tools for frequently needed objects. With automation tools you can, for example, create basic structures or add typical details to drawings.

- **Integrate Tekla Structures to other software**
  You can utilize the Tekla Open API and .NET in transferring information between Tekla Structures and other software, such as Analysis & Design software.

- **Create new functionality**
  With Tekla Open API, you can create tools that add new functionality to Tekla Structures.

For more information on Tekla Open API and extensions, see:

- TeklaOpenAPI_Reference.chm help in the ..\ProgramData\Tekla Structures\<version>\help folder
- Tekla Open API Startup Package in Tekla Warehouse product download service.
- Extensions in Tekla Warehouse.
• **Extensions** in Tekla User Assistance.
• Tekla Structures Open API Forums in **Tekla Discussion Forum**
8 Custom components

8.1 What is a custom component

You can create customized connections, parts, seams, and details for your project. These are called custom components. You can use custom components in the same way as any Tekla Structures system component. You can even create intelligent custom components that automatically adjust to changes in the model.

When to use

Create a custom component if you cannot find a predefined system component that meets all your needs. Especially if you need to create a large number of complex model objects and copy them across several projects.

Benefits

Once you store a custom component in the Applications & components catalog, you can easily access it from the catalog and use it in another location in the same model. If you must modify the custom component, you only need to make the changes once. When you save the changes, they will be automatically applied to all copies of that custom component in the model. You can also import and export custom components as .uel files between models and share the custom components with your colleagues.

Custom component types

You can create four types of custom components:
<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom part (page 148)</td>
<td>Creates a group of objects that may contain connections and details.</td>
<td><img src="image" alt="Custom part example" /></td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Unlike other custom components, custom parts are <strong>not</strong> marked with a component symbol in the model. Custom parts have the same position properties as beams have.</td>
<td></td>
</tr>
<tr>
<td>Custom connection (page 150)</td>
<td>Creates connection objects and connects the secondary parts to the main part. The main part may be continuous at the connection point.</td>
<td><img src="image" alt="Custom connection example" /></td>
</tr>
<tr>
<td>Type</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>-----</td>
<td>-----------------------------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Custom detail (page 152)</td>
<td>Creates detail objects and connects them to a single part at the location you picked.</td>
<td><img src="image" alt="Custom detail example" /></td>
</tr>
<tr>
<td>Custom seam (page 154)</td>
<td>Creates seam objects and connects the parts along a line that you create by picking with two points. The parts are usually parallel.</td>
<td><img src="image" alt="Custom seam example" /></td>
</tr>
</tbody>
</table>

**Custom parts**

Custom parts may consist of a single part or a group of parts, and they often have a complex composition. The following images show some examples of custom parts:
<table>
<thead>
<tr>
<th>Steel</th>
<th>Company standard bracing plates</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image1.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Castellated beam and cell beam</td>
<td><img src="image2.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Built-up beams/columns</td>
<td><img src="image3.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Built-up beams</td>
<td><img src="image4.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Standard glazing fixings</td>
<td><img src="image5.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Precast concrete</td>
<td>Sandwich panel</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Lifters</td>
<td><img src="image1.png" alt="Diagram of lifters" /></td>
</tr>
<tr>
<td>Standard embeds/inserts</td>
<td><img src="image2.png" alt="Diagram of standard embeds/inserts" /></td>
</tr>
<tr>
<td>Standard beams</td>
<td><img src="image3.png" alt="Diagram of standard beams" /></td>
</tr>
</tbody>
</table>

See also
- Custom connections (page 150)
- Custom details (page 152)
- Custom seams (page 154)

**Custom connections**
Custom connections can be used to connect a main part to up to 30 secondary parts. The connection is made between the main part and the ends of the

Custom components 150 What is a custom component
secondary parts. The following images show some examples of custom connections:

<table>
<thead>
<tr>
<th>Material</th>
<th>Connection Type</th>
<th>Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>Steel</td>
<td>Built-up plate seat</td>
<td><img src="image1.png" alt="Image" /></td>
</tr>
<tr>
<td>Shear plate</td>
<td></td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
<tr>
<td>Typical japanese post connections</td>
<td></td>
<td><img src="image3.png" alt="Image" /></td>
</tr>
<tr>
<td>Precast concrete</td>
<td>Base detail</td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
<tr>
<td></td>
<td>Double tee to L profile</td>
<td><img src="image5.png" alt="Image" /></td>
</tr>
</tbody>
</table>

What is a custom component?
See also

Custom parts (page 148)
Custom details (page 152)
Custom seams (page 154)

Custom details
Custom details can be used to add more information to a single part, such as extra plates or cut-outs. The following images show some examples of custom details:
<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cast base</td>
<td></td>
</tr>
<tr>
<td>Timber base</td>
<td></td>
</tr>
<tr>
<td>Out rigger (stiffeners) and</td>
<td></td>
</tr>
<tr>
<td>out rigger plate (stiffeners)</td>
<td></td>
</tr>
<tr>
<td>Precast concrete</td>
<td></td>
</tr>
<tr>
<td>Door and window</td>
<td></td>
</tr>
<tr>
<td>Column patterns</td>
<td></td>
</tr>
</tbody>
</table>

**What is a custom component**

153
<table>
<thead>
<tr>
<th>Hollow core end details</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Hollow core end details" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lifting details</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Lifting details" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Mock joint/reveal</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Mock joint/reveal" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Side pocket</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Side pocket" /></td>
</tr>
</tbody>
</table>

**See also**
- Custom parts (page 148)
- Custom connections (page 150)
- Custom seams (page 154)

**Custom seams**
Custom seams can be used to connect a main part to up to 30 secondary parts. They can also be used on one main part only. The seam is made along the length of the part. The following images show some examples of custom seams:
<table>
<thead>
<tr>
<th>Steel</th>
<th>Steel stair step</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turnbuckles</td>
<td><img src="image1.jpg" alt="Turnbuckles Diagram" /></td>
</tr>
</tbody>
</table>

**What is a custom component**

**Custom components**

155  What is a custom component
| Precast concrete | Double tee connection |
| Panel to panel grout tube connection |

**See also**
- Custom parts (page 148)
- Custom connections (page 150)
- Custom details (page 152)
8.2 Create a custom component

You can create customized components that have all the details you need. Start by creating a simple custom component which you can modify later. In the following example, we will create a simple custom connection.

1. In the model, create a sample component that contains all the necessary component objects, such as parts, cuts, fittings, and bolts. To do this quickly, explode and modify (page 160) a similar existing component.

2. Click the Applications & components button in the side pane to open the Applications & components catalog.

3. Click the Access advanced features button and select Define custom component. The Custom Component Wizard dialog box opens.

4. In the Type list, select the component type (page 146): connection, detail, seam, or part.

5. In the Name box, enter a unique name for the component.

6. Modify the other properties (page 266) on the Type/Notes tab, Position tab, and Advanced tab, and then click Next.

7. In the model, select the objects you want to include in the custom component.
You can use area selection to select multiple objects simultaneously. The main and secondary parts and the grids are ignored when you select objects for the custom component.

**NOTE** If you cannot select desired objects in the model, check the selection switches and the selection filter settings.

8. Click **Next**.

9. Select the main part for the component.

10. Click **Next**.

11. Select the secondary parts for the component.
To select multiple secondary parts, hold down **Shift** when you select them. The maximum number of secondary parts in a custom component is 30.

**NOTE** Pay attention to the order in which you select secondary parts. Tekla Structures will use the same picking order when you use the custom component in a model.

12. Define any other properties required for this custom component, such as detail or seam position. The properties depend on the component type that you selected in step 4.

13. If you want to adjust any of the settings at this stage, click **Back** to return to the previous page of the **Custom Component Wizard**.

14. When you are happy with the settings, click **Finish** to create the custom component.

The custom component is added in the model and in the **Applications & components** catalog.

15. If you want to change these settings afterwards:
   a. On the **custom component editor toolbar** (page 170), click the
      **Modify custom component settings** button.
   b. Change the settings.
   c. Click **OK**.

**See also**

*Create a nested custom component* (page 160)
Explode a component
Exploding means that you ungroup the objects of an existing component. This can be useful when you want to create custom components more quickly. Once the objects are detached, you can modify them to suit your needs and then create new custom components using these objects.

1. Select the component you want to explode.
2. Right-click and select **Explode Component**.

    Tekla Structures separates the component objects. You can modify the objects and use them to create new custom components (page 157).

Create a nested custom component
You can create more complex custom components by joining two or more components together as a nested component. The original components become sub-components in the nested component.

1. In the model, create the components and other model objects that you want to include in the nested component.
2. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.
3. Click the **Access advanced features** button and select **Define custom component**.

    The **Custom Component Wizard** dialog box opens.
4. In the **Type** list, select the type of the nested custom component.
5. In the **Name** box, enter a unique name for the nested component.
6. Modify the other properties on the **Type/Notes** tab, **Position** tab, and **Advanced** tab, and then click **Next**.
7. Select the components and any other objects you want to include in the nested component, and then click **Next**.
8. Follow the instructions in the **Custom Component Wizard** to continue.

    You will be asked to select the main and secondary parts for the nested component. Depending on the component type that you selected in step 3, you may also have to define other properties, such as detail or seam position.
9. When you are happy with the settings, click **Finish** to create the nested component.

The component is added in the model and in the **Applications & components** catalog. The sub-components are shown in the ([page 170](#)), together with the other component objects:

![Model objects with nested component](image)

10. If you want to change the settings afterwards:
   a. **In the custom component editor ([page 170](#)),** click the **Modify custom component settings** button.
   b. Change the settings.
   c. Click **OK**.

**WARNING** If you use a component of the type plug-in as a sub-component of a nested component, and change the sub-component's properties in the custom component editor, note that those changes may be lost when you save the nested component and use it in a model.

To prevent losing any properties, link a variable to each plug-in property that you want to keep. You can also use component...
attribute files to do this. For more information, see Examples of parametric variables and variable formulas (page 206).

Create a thumbnail image of a custom component

Create a thumbnail image for each custom component to make it easier to find a suitable component when modeling.

1. In the model, select the custom component.
2. Right-click and select Edit Custom Component.
3. Adjust the view and hide unnecessary objects to have a clear view of the custom component.
4. Take a screenshot of the custom component.
   a. On the View tab, click Screenshot --> Screenshot to open the Screenshot dialog box.
   b. Click Pick view and select the view you want to take a screenshot of.
   c. Click Options to open the Screenshot Options dialog box.
   d. Select Print to file.
   e. Select White background and click OK.
   f. In the Screenshot dialog box, click Capture.
   g. Click Close to close the dialog box.
   h. On the File menu, click Open the model folder.
   i. Browse to the \screenshots folder under the model folder.
   j. Open the screenshot file in a graphics editor.
   k. Crop the image, if needed.
5. Save the thumbnail image in the \screenshots folder under the model folder.

6. Click the Applications & components button in the side pane to open the Applications & components catalog.
7. Right-click the custom component and select Thumbnails.
   The Thumbnails dialog box opens.
8. Click Add thumbnail.
9. Browse to the \screenshots folder under the model folder.
10. Select the thumbnail image and click Open.
11. In the **Thumbnails** dialog box, select the check box next to the image you want to use and clear the other check boxes.

12. Click **Close**.

   Tekla Structures shows the thumbnail image in the **Applications & components** catalog:

   ![End plate with haunches](image)

**Example: Create a custom end plate component**

In this example, you will create a simple custom component based on an existing end plate component.

1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.

2. Click the **Access advanced features** button and select **Explode component**.

3. Select the end plate component in the model.

   ![Tekla Structures separates the objects in the component](image)
4. Click the **Access advanced features** button and select **Define custom component**.

5. In the **Type** list, select **Connection**.

6. In the **Name** box, enter a unique name for the custom component.

7. Click **Next**.

8. Select the objects you want to use in the custom component, and then click **Next**.
You can use area selection (left to right) to select the objects. Tekla Structures ignores the main part and secondary parts and the grids when you are selecting objects to include in the custom component.

9. Select the column as the main part, and then click **Next**.

The main part supports the secondary part.

10. Select the beam as the secondary part.

The secondary part is supported by the main part.

**NOTE** When you select multiple secondary parts, pay attention to the order of selection. The custom component will use the same selection order when you add the component in a model. The maximum number of secondary parts in a custom component is 30.

11. Click **Finish**.
Tekla Structures displays a component symbol for the new component.

You have now defined a simple custom component, which you can use in locations similar to where it was originally created. This component is not intelligent and Tekla Structures does not adjust dimensions to suit any changes in the model. To make the custom component intelligent, you need to modify (page 170) it in the custom component editor.

**Example: Create a nested connection with stiffeners**

In this example, you will create a nested custom connection that consists of an end plate, a bolt group, welds, and two **Stiffeners (1003)** components. The stiffeners are optional, which means that you can choose whether or not to create them when using the component in a model.

1. Add an **End plate (144)** component.

2. **Explode (page 160)** the end plate component.
3. Add two Stiffeners (1003) components.

4. Create a nested custom component that contains the stiffeners and the end plate objects.
   
   a. Click the Applications & components button in the side pane to open the Applications & components catalog.
   
   b. Click the Access advanced features button and select Define custom component.
   
   c. In the Type list, select Connection.
   
   d. In the Name box, enter End plate with stiffeners.
   
   e. Click Next.
   
   f. Make an area selection (from right to left) to include the following objects in the nested component: the column, the beam, the stiffener
components, and all the end plate objects.

g. Click **Next**.

h. Choose the column as the main part of the nested component, and then click **Next**.

i. Choose the beam as the secondary part of the nested component, and then click **Finish**. Tekla Structures creates the nested component.

5. Select the nested component you just created.

6. Right-click and select **Edit Custom Component**.

7. In the custom component editor, click the **Display variables** button. The **Variables** dialog box opens.
8. Create the following parametric variables:
   a. Click **Add** to create a new parametric variable P1.
   b. In the **Value type** list, select **Yes/No**.
   c. In the **Label in dialog box** box, enter Create Stiffener 1.
   d. Click **Add** to create a new parametric variable P2.
   e. In the **Value type** list, select **Yes/No**.
   f. In the **Label in dialog box** box, enter Create Stiffener 2.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
<th>Label in dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1</td>
<td>0</td>
<td>0</td>
<td>Yes/No</td>
<td>Parameter</td>
<td>Show</td>
<td>Create Stiffener 1</td>
</tr>
<tr>
<td>P2</td>
<td>0</td>
<td>0</td>
<td>Yes/No</td>
<td>Parameter</td>
<td>Show</td>
<td>Create Stiffener 2</td>
</tr>
</tbody>
</table>

9. Link the variables to the **Creation** property of the two stiffeners:
   a. In the **Custom component browser**, browse for the uppermost **Connection**.
   b. Right-click **Creation** and select **Add Equation**.
   c. Enter P1 after the equal sign, and then press **Enter**.
   d. Browse for the second **Connection**.
   e. Right-click **Creation** and select **Add Equation**.
   f. Enter P2 after the equal sign, and then press **Enter**.

10. **Save and close (page 225)** the nested component.
You now have the following options in the nested component's dialog box:

8.3 Modify a custom component
Use the custom component editor to fine-tune existing custom components. When you modify a custom component, Tekla Structures updates all instances of that component throughout the model with the changes you have made.

1. In the model, select the custom component by clicking the green component symbol.

   **NOTE** Custom parts do not have a component symbol in the model. To select custom parts, ensure that the Select components selection switch is active.

2. Right-click and select **Edit Custom Component**.

   The custom component editor opens. It consists of the following parts:

   - **The Custom component browser**

   - **The Custom component editor toolbar**
• Four different **views** of the custom component

![View 1, View 2, View 3, View 4](images)

3. Modify the custom component in one of the four custom component views. You can, for example:

   • **Add or remove component objects**
     
     For example, add extra bolts or stiffeners to the component. Only component objects, not the main or secondary parts, can be modified in the custom component editor.

   • **Bind component objects to a plane** (page 173)

   • **Add a distance between component objects** (page 183)

   • **Set object properties using parametric variables** (page 186)

4. **Save the custom component** (page 225). Click **Yes** when prompted to replace all occurrences of the custom component in the model. All instances of the custom component are now updated with the changes you made.

**See also**

Protect a custom component with a password (page 171)

**Protect a custom component with a password**

You can set a password to prevent others from modifying a custom component. Password-protected custom components can still be added to models as usual.

1. In the model, select a custom component.
2. Right-click the custom component symbol and select **Edit Custom Component**.

3. In the custom component editor, click the **Display variables** button. The **Variables** dialog box opens.

4. Click **Add** to create a new variable.

5. In the **Name** box, enter **Password**.

6. In the **Formula** box, enter the desired password.

7. Save the custom component. (page 225)

The next time someone tries to edit this custom component, they will be asked for the password.

### 8.4 Add variables to a custom component

**Variables** are the properties of a custom component. You can create variables in the custom component editor and use them to adapt custom components to changes in the model. Some of the variables appear in the custom component's dialog box, while others are hidden and are only used in calculations.

#### Variable types

There are two types of variables:

- **Distance variable**: The distance between two planes, or between a point and a plane. A distance variable binds parts together, or works as a reference distance.

- **Parametric variable**: Controls all the other properties in a custom component, such as name, material grade, and bolt size. Parametric variables are also used in calculations.

#### Distance variables

Use distance variables to bind custom component objects to a plane, so that the component objects stay at a fixed distance even if the surrounding objects change. You can create distance variables manually or automatically.

You can bind the following objects to a plane:

- construction planes
- reference points of parts (only custom component objects)
- reference points of bolt groups
- chamfers
- part and polygon cut handles

---

Custom components 172 Add variables to a custom component
- line cuts
- reference points of reinforcing bars
- reference points of reinforcement meshes and strands
- fittings

You can decide which distance variables are shown in the custom component's dialog box. Show the variables if you want to edit their values in the dialog box. Hide the variables if you only use them to bind objects to a plane.

**Parametric variables**

Use parametric variables to set properties for any object the custom component creates (page 186). After creating the variable, you will be able to change the value directly in the custom component's dialog box.

You can also create formulas to calculate values. For example, you can calculate the position of a stiffener relative to the beam length.

You can decide which parametric variables are shown in the custom component's dialog box. Show the variables if you want to edit their values in the dialog box. Hide the variables if you only use them in calculations.

**Bind component objects to a plane**

Use *distance variables* to bind component objects to a plane. Binding keeps the custom component at a fixed distance from the plane even if the surrounding objects change. Distance variables automatically get the prefix \( D \) (distance), which is shown in the Variables dialog box.

**Bind objects automatically**

You can bind objects automatically to the main and secondary parts of a connection or detail. The selected objects, or their handles, are bound to existing planes if the objects (or handles) are located exactly on the plane.

**NOTE** You cannot bind custom parts (page 148) automatically, because they do not have a main part.

1. In the custom component editor, click the Create distances variables automatically button.
2. Select an object that has handles.
3. Click the middle mouse button to bind the object.

Tekla Structures binds the object from a maximum of three directions to the existing planes.

Tekla Structures displays a distance symbol for each binding. Select the object to see the bindings.
The corresponding distance variables are shown in the (page 277) dialog box:

![Variables dialog box](image)

**Bind objects manually**
Create the bindings manually if you want to bind a custom component from specific handles only. You can bind an object to a maximum of three planes.

1. Ensure that **Direct modification** is switched off.
   The selection of handles is easier when **Direct Modification** is off.
2. Ensure that you are using a model view that shows object faces.
   On the **View** tab, click **Rendering**, and use one of the following options:
   • **Parts grayscale** (Ctrl+3)
   • **Parts rendered** (Ctrl+4)
3. In a custom component view, select the custom component to see its handles.
4. Select the handle that you want to bind to a plane.

5. In the custom component editor, click the **Add fixed distance** button. You can also right-click and select **Bind to Plane**.

6. Move the mouse pointer in a custom component view to highlight the plane that you want to bind with the handles.
For example:

**NOTE** If you cannot highlight the correct plane, change the plane type (page 274) on the **Custom component editor** toolbar. Boundary and component planes work for most profile types, so try to use them whenever you can.

7. Click the plane to create the binding.
Tekla Structures displays a distance symbol for the binding.

The corresponding distance variable is shown in the **Variables** dialog box:
**Test a binding**
Test all bindings to see that they work correctly.

1. Double-click the binding symbol in a custom component view.
   
   The **Distance Properties** dialog box opens.

2. In the **Value** box, enter a new value.
3. Click **Modify**.
   
   You should see the binding change in the model.

   **TIP** Alternatively, you can test the binding in the (page 277) dialog box:
   
   a. Enter a new value in the **Formula** box.
   
   b. Press **Enter**.
      
   You should see the binding change in the model.

**Delete a binding**

Bindings cannot be modified, but you can delete the existing bindings and then create new ones to rebind the objects.

1. Select the binding in a custom component view.

2. Press **Delete**.
   
   You can also select the binding in the (page 277) dialog box and then click the **Delete** button.
Example: Bind an end plate to a plane
In this example, you will bind the end plate top to the upper side of the beam.

1. Ensure that Direct modification is switched off. The selection of end plate handles is easier when Direct Modification is off.
2. In a custom component view, select the end plate to see the end plate handles.

3. Select the top handle of the end plate.
4. Right-click the top handle and select Bind to Plane.
5. Move the pointer over the upper side of the beam flange to highlight it.
Here we are using the boundary plane type. If the part profile changes, the boundary plane is always found.

**NOTE** If you cannot highlight the desired plane, change the plane type (page 274) on the **Custom component editor** toolbar.

6. Click the upper side of the beam flange.
   A distance symbol appears in the custom component views.

7. Give a descriptive name for the binding you created:
   a. In the custom component editor, click the **Display variables** button.
      
      The **Variables** dialog box opens.
   b. In the **Label in dialog box** box, enter Plate Top to Flange Top as the name of the new binding.
Bind component objects using magnetic construction planes or lines
Instead of binding each component object handle to a plane separately, you can use magnetic construction planes and lines. The objects that are directly on a magnetic construction plane (or line) will move with the plane (or line), which means you only need to create one distance variable instead of 8, for example.

Bind handles using a magnetic construction plane

1. In the custom component editor, click \textit{Add construction plane}.
2. Pick four points to define the shape of the construction plane.
   For example, create a plane that goes through all the handles and chamfers of the custom component.
3. Click the middle mouse button.
   Tekla Structures creates a construction plane. For example:

   ![Construction Plane Example](image)

5. Enter a name for the plane.
6. Select the \textit{Magnetic} check box.
7. Click \textit{Modify}. 
Now when you move the construction plane, all handles that are on the plane are moved as well:

![Diagram of construction plane and handles]

8. Bind the construction plane to a part face:
   a. Select the construction plane, right-click and select **Bind to plane**.
   b. Select a suitable part face.
      For example, the inner flange of the column:
      ![Diagram with inner flange selected]

Tekla Structures displays a distance symbol for the binding. Now if you move the part face, the handles on the magnetic construction plane will follow.

**NOTE** Only the objects whose reference points are directly on the magnetic construction plane are affected. By default, the magnetic distance is 0.2 mm. To change this setting, use the advanced option XS_MAGNETIC_PLANE_OFFSET.
**Bind handles using a magnetic construction line**

1. In the custom component editor, click **Add construction line**.
2. Pick the starting point of the construction line.
3. Pick the end point of the construction line.
   Tekla Structures creates a construction line.
4. Double-click the line. The **Construction Line Properties** dialog box opens.
5. Enter a name for the line.
6. Select the **Magnetic** check box.
7. Click **Modify**.
   Now when you move the construction line, all handles that are on the line are moved as well.
8. Bind the construction line to a part face:
   a. Select the construction line, right-click and select **Bind to plane**.
   b. Select a suitable part face.
      Tekla Structures displays a distance symbol for the binding. Now if you move the part face, the handles on the magnetic construction line will follow.

**Add a distance between component objects**

Use **reference distance variables** to add a distance between two points or a point and a plane. The reference distance changes as you move the objects it refers to. You can use reference distances in calculations, for example, to determine the spacing of rungs on a ladder. Reference distance variables automatically get the prefix D (distance), which is shown in the **Variables** dialog box.

1. In a custom component view, select a handle.
This is the starting point for your measurement.

2. In the custom component editor, click the **Add reference distance** button.

3. Move the mouse pointer in the view to highlight a plane.
   This will be the end point for your measurement. If you cannot highlight the correct plane, change the plane type (page 274) on the **Custom component editor** toolbar.

4. Click the plane to select it.
Tekla Structures displays the distance.

The corresponding reference distance variable is shown in the Variables dialog box:

Note that the Add reference distance command remains active. You can click more planes if you want to measure other distances.

5. To stop measuring, press Esc.
6. To check that the reference distance works correctly, move the handle.
The distance changes accordingly. For example:

Set object properties using parametric variables

Use parametric variables to set basic properties (such as name, material, profile, position number, and so on) for any object the custom component creates. Parametric variables automatically get the prefix P (parameter), which is shown in the Variables dialog box.

In the following example, we will create a variable that sets all welds in a custom component to a given size. After creating the variable, we will be able to change the weld size directly in the custom component's dialog box.

1. In the custom component editor, click the Display variables button. The Variables dialog box opens.
2. Click Add to create a new parametric variable.
3. In the Name box, enter a name for the variable. You can also use the default name, such as P1. In our example, we will enter Weldsize as the name of the variable.
4. In the Value type list, select a suitable value type (page 277). The type determines what kind of values can be used with this variable. In our example, we will select Length, which is suitable for lengths and distances.
5. In the Formula box, enter a value or variable formula. In our example, we will leave this box empty.
6. In the **Label in dialog box** box, enter a descriptive name for the parametric variable.
   This label will be shown in the custom component's dialog box. In our example, we will enter *Weld size* as the label.

7. In the **Visibility** list, define whether the variable will be visible in the custom component's dialog box.
   Hide the variable if you only use it in calculations. Show the variable if you want to be able to edit the value in the custom component's dialog box. In our example, we will select *Show*.

8. Click **Close**.
   In our example, we have now created a parametric variable with the following settings:

9. In the **Custom component browser**, link the variable to the desired object property.
   a. Select the property.
      In our example, we will select the *Size above line* property of the uppermost weld.

   ![Diagram of component objects]

   b. Right-click the property and select **Add Equation**.
c. After the equal sign, enter the name of the parametric variable. In our example, we will enter `Weldsize` here.

```
Component objects
  Part
  Contour plate
  Contour plate
  Fitting
  Weld
    General properties
      Creation
      Root face thickness above line
      Size above line
        Size above line = Weldsize
      Size below line
      Effective throat above line
```

You can now modify the **Size above line** property by using the **Weld size** box in the custom component's dialog box.

10. Repeat step 9 for any other property of the same type, if needed.
In our example, we will repeat the procedure for the other welds as well, so that they will all be linked to the **Weld size** box in the custom component's dialog box.

11. **Save the custom component. (page 225)**

The variable is now displayed in the custom component's dialog box, unless you set the visibility of the variable to **Hide** in step 7.

If we change the weld size value now, the size of all welds within the custom component will change accordingly.

**See also**

*Copy properties and property references from another object (page 189)*

**Copy properties and property references from another object**

You can copy properties, such as names and values, from other objects and use them to determine the properties of a custom component. You can also
copy property references. The link is dynamic, so when the property changes, the reference reflects the change. For example, you can use a beam length reference in variable formulas. Even if the length changes, the correct value is always used in calculations.

1. In the Custom component browser, browse for the object property you want to copy.
   
   To find the required component object more easily, select it in a custom component view. Tekla Structures highlights the selected object in the Custom component browser.

2. Right-click the property and select one of the following:
   
   • Copy Name
     
     Copies the name of the object. For example, Material.
   
   • Copy Value
     
     Copies the value the object currently has. For example, S235JR.
   
   • Copy Reference
     
     Copies the link to the property. For example, fP(Material,"ID57720EEE-0000000E-3134-363730393237").
3. Right-click where you want to insert the object property, and then select Paste.

For example, you can paste a reference to the Formula box in the dialog box to use it in a calculation.

See also

Examples of parametric variables and variable formulas (page 206)

Create a variable formula

Use variable formulas to add more intelligence to your custom components. Variable formulas always begin with the equal sign (\(=\)). At its simplest, a formula can be a simple dependency between two variables, stating that \(P_2\) equals half of \(P_1\) (\(P_2=\frac{P_1}{2}\)), for example. To create more complex calculations, you can use functions and operators inside the formula. For example, you can
add mathematical expressions, **if** statements, references to object properties, and so on.

In the following example, we will create a formula that sets the weld size to half the thickness of the secondary part flange. When the component is used in a model, Tekla Structures will use the thickness of the secondary part flange to calculate the size of the weld.

1. In the custom component editor, click the **Display variables** button. The **Variables** dialog box opens.
2. Click **Add** to create a new parametric variable.
3. In the **Name** box, enter a name for the variable. In our example, we will enter `w` as the name of the variable.
4. In the **Custom component browser**, go to **Input objects --> Secondary parts --> Part --> Profile properties**.
5. Right-click **Flange thickness 1** and select **Copy reference**.

![Image of custom component browser and Variables dialog box]

6. In the **Formula** box, type `=`, right-click, and select **Paste**. Tekla Structures pastes the reference to flange thickness from the clipboard.
7. After the flange thickness formula, enter `*0.5`.
   The formula should now read:
   
   `=fP(Flange thickness 1,"GUID")*0.5`

8. Set the other values as follows:
   a. In the **Value type** list, select **Length**.
b. In the **Visibility** list, select **Hide**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
</tr>
</thead>
<tbody>
<tr>
<td>w</td>
<td>=PT({range thickness 1,&quot;ID648CB39-24EC-442B-9363-AA20EAE0E8AA&quot;})/0.5</td>
<td>4.00</td>
<td>Length</td>
<td>Parameter</td>
<td>Hide</td>
</tr>
</tbody>
</table>

9. In the **Custom component browser**, go to **Component objects --> Weld** --> **General properties**.

10. Right-click **Size above line**, select **Add equation** and type \( w \).

functions in variable formulas

You can use functions to calculate values for parametric variables. Variable formulas always begin with the equal sign (=).

For more information, see Set object properties using parametric variables (page 186).

**Arithmetic operators**

Use arithmetic operators to combine expressions that return numeric values. You can use the following arithmetic operators:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>addition</td>
<td>Use also to create strings of parameters.</td>
</tr>
<tr>
<td>–</td>
<td>subtraction</td>
<td></td>
</tr>
<tr>
<td>*</td>
<td>multiplication</td>
<td>Multiplication is faster than division.</td>
</tr>
<tr>
<td>/</td>
<td>division</td>
<td></td>
</tr>
</tbody>
</table>

=\( D1 \times 0.5 \) is faster than \( =D1/2 \)

**Logical and comparison operators**

Use logical and comparison operators inside if statements. You can use if-then-else statements to test a condition and to set the value according to the result.

Custom components 193 Add variables to a custom component
For example:

```plaintext
=if (D1>200) then 20 else 10 endif
```

You can use the following operators inside if statements:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>==</td>
<td>both sides are equal</td>
<td>=if (D1==200 &amp;&amp; D2&lt;40) then 6 else 0 endif</td>
</tr>
<tr>
<td>!=</td>
<td>sides are not equal</td>
<td></td>
</tr>
<tr>
<td>&lt;</td>
<td>left side is smaller</td>
<td>If D1 is 200 and D2 smaller than 40, the result is 6, otherwise 0.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>left side is smaller or equal</td>
<td></td>
</tr>
<tr>
<td>&gt;</td>
<td>right side is smaller</td>
<td></td>
</tr>
<tr>
<td>&gt;=</td>
<td>right side is smaller or equal</td>
<td></td>
</tr>
<tr>
<td>&amp;&amp;</td>
<td>logical AND both conditions must be true</td>
<td>If D1 is 200 or D2 is smaller than 40, the result is 6, otherwise 0.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Reference functions**

Use reference functions to refer to the property of another object, such as the plate thickness of a secondary part. Tekla Structures refers to the object on the system level, so if the object property changes, so does the reference function value.

You can use the following reference functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>fTpl(&quot;template attribute&quot;, &quot;object GUID&quot;)</td>
<td>Returns the template attribute value of an object that has a given object GUID.</td>
<td>=fTpl(&quot;WEIGHT&quot;,&quot;ID50B8559A-0000-010B-3133-353432373038&quot;) returns the weight of an object whose GUID is ID50B8559A-0000-010B-3133-353432373038.</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>---------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>fP(&quot;user-defined attribute&quot;, &quot;object GUID&quot;)</td>
<td>Returns the user-defined attribute value of an object that has a given object GUID.</td>
<td>=fP(&quot;comment&quot;, &quot;ID50B8559A-0000-010B-3133-353432373038&quot;) returns the user-defined attribute comment of an object whose GUID is ID50B8559A-0000-010B-3133-353432373038.</td>
</tr>
<tr>
<td>fValueOf(&quot;parameter&quot;)</td>
<td>Returns the value of the parameter.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If the equation is =P2+&quot;<em>&quot;+P3, the result is P2</em>P3.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>With =fValueOf(&quot;P2&quot;) +&quot;<em>&quot;+fValueOf(&quot;P3&quot;), where P2=780 and P3=480, the result is 780</em>480.</td>
<td></td>
</tr>
<tr>
<td>fRebarCatalogValue(BarGrade, BarSize, Usage, FieldName)</td>
<td>Returns the reinforcing bar catalog value of an object.</td>
<td>fRebarCatalogValue(&quot;A500HW&quot;, &quot;10&quot;, 1, 2) returns the size, usage, and weight of an object whose reinforcing bar grade is A500HW.</td>
</tr>
<tr>
<td></td>
<td>Usage can be either 2 (&quot;Tie&quot;) or 1 (&quot;Main&quot;).</td>
<td></td>
</tr>
<tr>
<td></td>
<td>FieldName must be one of the following:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 0 NominalDiameter</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 1 ActualDiameter</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 2 Weight</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 3 MinRadius</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 4 Hook1Radius</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 5 Hook1Angle</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 6 Hook1Length</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 7 HookRadius</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 8 Hook2Angle</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 9 Hook2Length</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td>---------</td>
</tr>
<tr>
<td>10</td>
<td>Hook3Radius</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Hook3Angl</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Hook3Length</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Area</td>
<td></td>
</tr>
</tbody>
</table>

**ASCII file as a reference function**

You can refer to ASCII files to get data. Tekla Structures searches for the files in the following order:

1. model
2. ..\TeklaStructuresModels\<model>\CustomComponentDialogFiles\n3. project (set with advanced option XS_PROJECT)
4. firm (set with advanced option XS_FIRM)
5. system (set with advanced option XS_SYSTEM)

The format for reading files is the following:

\[ fVF("filename", "key_value_of_row", column_number) \]

- Key value of row is a unique text value.
- Column number is an index starting from 1.

**NOTE** Enter a space at the end of each row in the ASCII file. Otherwise the information is not read correctly.

![Cell.dat - Notepad](image)

**Example**

The \( fVF("Overlap.dat", "MET-202Z25", 5) \) function is in the **Formula** box in the **Variables** dialog box. The function gets the value 16.0 for the profile **MET-202Z25**, from the Overlap.dat file.
1. Key value of the row (MET-202Z25)
2. Column number (5)

**Mathematical functions**

Use mathematical functions to create more complex mathematical expressions. You can use the following functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>fabs(parameter)</td>
<td>Returns the absolute value of the parameter</td>
<td>=fabs(D1) returns 15 if D1 = -15</td>
</tr>
<tr>
<td>exp(power)</td>
<td>Returns $e$ raised to the power $e$ is Euler's number.</td>
<td>=exp(D1) returns 7.39 if D1 = 2</td>
</tr>
<tr>
<td>ln(parameter)</td>
<td>Returns the natural logarithm of the parameter (base number $e$)</td>
<td>=ln(P2) returns 2.71 if P2 = 15</td>
</tr>
<tr>
<td>log(parameter)</td>
<td>Returns the logarithm of the parameter (base number 10)</td>
<td>=log(D1) returns 2 if D1=100</td>
</tr>
<tr>
<td>sqrt(parameter)</td>
<td>Returns the square root of the parameter</td>
<td>=sqrt(D1) returns 4 if D1 = 16</td>
</tr>
<tr>
<td>mod(dividend, divider)</td>
<td>Returns the modulo of the division</td>
<td>=mod(D1, 5) returns 1 if D1 = 16</td>
</tr>
<tr>
<td>pow(base number, power)</td>
<td>Returns the base number raised to the specified power</td>
<td>=pow(D1, D2) returns 9 if D1 = 3 and D2 = 2</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td>---------</td>
</tr>
<tr>
<td>hypot(side1, side2)</td>
<td>Returns the hypotenuse</td>
<td>=hypot(D1, D2) returns 5 if D1 = 3 and D2 = 4</td>
</tr>
<tr>
<td>n!(parameter)</td>
<td>Returns the factorial of the parameter</td>
<td>=n!(P2) returns 24 if P2 = 4 (1<em>2</em>3*4)</td>
</tr>
<tr>
<td>round(parameter, accuracy)</td>
<td>Returns the parameter rounded off to the given accuracy</td>
<td>=round(P1, 0.1) returns 10.600 if P1 = 10.567</td>
</tr>
<tr>
<td>PI</td>
<td>Returns the value of pi to 31 decimal places</td>
<td>=PI returns 3.1415926535897932384626433832795</td>
</tr>
</tbody>
</table>

**Statistical functions**
Use statistical functions to calculate sums and averages, and to round values. You can use the following statistical functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example (P1 = 1.4 P2 = 2.3)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ceil()</td>
<td>Returns the smallest whole number greater than or equal to the parameter</td>
<td>=ceil(P1) returns 2</td>
</tr>
<tr>
<td>floor()</td>
<td>Returns the largest whole number less than or equal to the parameter</td>
<td>=floor(P1) returns 1</td>
</tr>
<tr>
<td>min()</td>
<td>Returns the smallest parameter</td>
<td>=min(P1, P2) returns 1.4</td>
</tr>
<tr>
<td>max()</td>
<td>Returns the largest parameter</td>
<td>=max(P1, P2) returns 2.3</td>
</tr>
<tr>
<td>sum()</td>
<td>Sum of the parameters</td>
<td>=sum(P1, P2) returns 3.7</td>
</tr>
<tr>
<td>sqsum()</td>
<td>Sum of the squared parameters: ((\text{parameter1})^2 + (\text{parameter2})^2)</td>
<td>=sqsum(P1, P2) returns 7.25</td>
</tr>
<tr>
<td>ave()</td>
<td>Average of the parameters</td>
<td>=ave(P1, P2) returns 1.85</td>
</tr>
</tbody>
</table>
Function | Description | Example (P1 = 1.4 P2 = 2.3)
--- | --- | ---
sqave() | Average of the squared parameters | \(=\text{sqave}(P_1, P_2)\) returns 3.625

**Example: Ceil and floor statistical functions**

In this example, you have the following parametric variables:

- Beam length: \(P_1 = 3500\)
- Post spacing: \(P_2 = 450\)

\(P_1 / P_2 = 7.7778\)

You can use the `ceil` and `floor` statistical functions to round the value and then use the rounded value as the number of beam posts:

- \(=\text{ceil}(P_1/P_2)\) returns 8
- \(=\text{floor}(P_1/P_2)\) returns 7

**Data type conversion functions**

Use data type conversion functions to convert values into another data type. You can use the following data type conversion functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>int()</td>
<td>Converts data to integer</td>
<td>Useful especially for calculating profile dimensions: (=\text{int}(100.0132222000)) returns 100, if decimals are set to 0 in the <strong>Options</strong> dialog box</td>
</tr>
<tr>
<td>double()</td>
<td>Converts data to a double</td>
<td></td>
</tr>
<tr>
<td>string()</td>
<td>Converts data to string</td>
<td></td>
</tr>
<tr>
<td>imp()</td>
<td>Converts imperial units Use this function in calculations instead of imperial units. You cannot use imperial units directly in calculations.</td>
<td>For the following examples, length unit is set to mm and decimals are set to 2 in the <strong>Options</strong> dialog box. (=\text{imp}(1,1,1,2)) meaning 1 foot 1 1/2 inch returns 342.90 mm (=\text{imp}(1,1,2)) meaning 1 1/2 inches returns 38.10 mm (=\text{imp}(1,2)) meaning 1/2 inches returns 12.70 mm (=\text{imp}(1)) meaning 1 inch returns 25.40 mm (=3'/3&quot;) is not possible, but (=\text{imp}(36)/\text{imp}(3)) is ok</td>
</tr>
</tbody>
</table>
**Function** | **Description** | **Example**
---|---|---
vwu(value, unit) | Converts the length values and angle values. The available units are: • "ft" ("feet", "foot") • "in" ("inch", "inches") • "m" • "cm" • "mm" • "rad" • "deg" | =vwu(4.0,"in") returns 101.60 mm, if length unit is set to mm and decimals are set to 2 in the **Options** dialog box

=vwu(2.0,"rad") returns 114.59 degrees, if angle is set to degrees and decimals are set to 2 in the **Options** dialog box

**NOTE** The units depend on the settings in File menu --> Settings --> Options --> Units and decimals.

---

**String operations**

Use string operations to manipulate character strings. Strings must be inside quotation marks in variable formulas.

You can use the following string operations:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
<th>Example (P1 = &quot;PL100*10&quot;)</th>
</tr>
</thead>
</table>
| match(parameter1, parameter2) | Returns 1 if parameters are equal and 0 if different. You can also use wildcards *, ?, and [ ] with the match function. | =match(P1, "PL100*10") returns 1

Accept all profiles starting with PFC: =match(P4, "PFC*"

Accept profiles starting with PFC, and height starts with 2,3,4 or 5: =match(P4, "PFC[2345]*")

Accept profiles starting with PFC, heights are 200,300,400 or 500 and width starts with 7: =match(P4, "PFC[2345]00?7")

<p>| length(parameter) | Returns the number of characters in the parameter. | =length(P1) returns 8 |
| find(parameter, string) | Returns the order number (starting at zero) of the specified string and -1 if the specified string is not | =find(P1, &quot;*&quot;) returns 5 |</p>
<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
<th>Example (P1 = &quot;PL100*10&quot;)</th>
</tr>
</thead>
<tbody>
<tr>
<td>getat(paramater, n)</td>
<td>Returns the n:th (starting at zero) character from the parameter.</td>
<td>=getat(P1, 1) returns &quot;L&quot;</td>
</tr>
<tr>
<td>setat(parameter, n, character)</td>
<td>Sets the n:th (starting at zero) character to the specified character in the parameter.</td>
<td>=setat(P1, 0, &quot;B&quot;) returns &quot;BL100*10&quot;</td>
</tr>
<tr>
<td>mid(string, n, x)</td>
<td>Returns x characters from the string starting from n:th (starting at zero) character. If you leave out the last argument (x), returns the last part of the string.</td>
<td>=mid(P1,2,3) returns &quot;100&quot;</td>
</tr>
<tr>
<td>reverse(string)</td>
<td>Reverses the given string.</td>
<td>=reverse(P1) returns &quot;01*001LP&quot;</td>
</tr>
</tbody>
</table>

**Example 1**

To define profile size PL100*10 with two variables P2 = 100 and P3 = 10, enter the formula as follows:

"PL"+P2+"*"+P3

**Example 2**

Tekla Structures handles bolt spacings as strings. To define bolt spacing, set Value type to Distance list and enter the formula as follows:

"P"+" "+P2

This results in 100 200, if P1 = 100 (length) and P2 = 200 (length).

**Trigonometric functions**

Use trigonometric functions to calculate angles. You can use the following trigonometric functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>sin()</td>
<td>Returns the sine value</td>
<td>=sin(d45) returns 0.71</td>
</tr>
<tr>
<td>cos()</td>
<td>Returns the cosine value</td>
<td>=cos(d45) returns 0.71</td>
</tr>
<tr>
<td>tan()</td>
<td>Returns the tangent value</td>
<td>=tan(d45) returns 1.00</td>
</tr>
<tr>
<td>asin()</td>
<td>Inverse function of sin(), return value in radians</td>
<td>=asin(1) returns 1.571 rad</td>
</tr>
<tr>
<td>acos()</td>
<td>Inverse function of cos(), return value in radians</td>
<td>=acos(1) returns 0 rad</td>
</tr>
</tbody>
</table>

Custom components 201 Add variables to a custom component
<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>atan()</td>
<td>Inverse function of tan(), return value in radians</td>
<td>=atan(1) returns 0.785 rad</td>
</tr>
<tr>
<td>sinh()</td>
<td>Returns the hyperbolical sine value</td>
<td>=sinh(d45) returns 0.87</td>
</tr>
<tr>
<td>cosh()</td>
<td>Returns the hyperbolical cosine value</td>
<td>=cosh(d45) returns 1.32</td>
</tr>
<tr>
<td>tanh()</td>
<td>Returns the hyperbolical tangent value</td>
<td>=tanh(d45) returns 0.66</td>
</tr>
<tr>
<td>atan2()</td>
<td>Returns the angle whose tangent is the quotient of the two numbers. Return value in radians</td>
<td>=atan2(1,3) returns 0.32</td>
</tr>
</tbody>
</table>

**NOTE** When you use trigonometric functions in variable formulas, you need to include a prefix to define the unit. If you do not include a prefix, Tekla Structures uses radians as the default unit.

- d is degree. For example, sin(d180)
- r is radians (default). For example, sin(r3.14) or sin(3.14)

### Market size function
Use the market size function in a custom component to select a suitable plate dimension (usually plate thickness) from the available market sizes. For example, a plate's thickness should match the web of a beam.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>fMarketSize(...)</td>
<td>Returns the next available market size for the material from the marketsize.dat file, based on the thickness you specify. The file must be in the .. \environments \your_environment \profil folder or the system folder. For extrastep enter a number to define the increment to the next size (default is 0).</td>
<td>=fMarketSize(&quot;S235JR&quot;, 10, 0)</td>
</tr>
</tbody>
</table>
Example
In this example, you have the following data in `marketsize.dat`:

```
S235JR,6,9,12,16,19,22
SS400,1.6,2.3,3.2,4.5,6,9,12,16,19,22,25,28,32,38
DEFAULT,6,9,12,16,19,22,25,28,32,38
```

The first item in a row is a material grade followed by available plate thicknesses in millimeters. The DEFAULT line lists the thicknesses available in all other material grades.

With the above data, the function `=fMarketSize("S235JR",10,0)` would return 12, and `=fMarketSize("S235JR",10,1)` would return 16 (one size up).

Framing condition functions
Use the framing condition functions to return the skew, slope, and cant angle of the secondary beam relative to the main part (column or beam). You can use the following framing condition functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>fAD(&quot;skew&quot;,&quot;GUID&quot;)</code></td>
<td>Returns the skewed angle of the secondary part whose GUID is given.</td>
<td><code>=fAD(&quot;skew&quot;,&quot;ID50B8559A-0000-010B-3133-353432373038&quot;)</code> returns 45 ID50B8559A-0000-010B-3133-353432373038 is the GUID of the secondary part, which is at a 45 degree angle to the main part.</td>
</tr>
<tr>
<td><code>fAD(&quot;slope&quot;,&quot;GUID&quot;)</code></td>
<td>Returns the sloped angle of the secondary part whose GUID is given.</td>
<td><code>=fAD(&quot;slope&quot;,&quot;ID50B8559A-0000-010B-3133-353432373038&quot;)</code></td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>fAD(&quot;cant&quot;, GUID)</td>
<td>Returns the cant angle of rotated secondary part whose GUID is given.</td>
<td>=fAD(&quot;cant&quot;,&quot;ID50B8559A-0000-010B-3133-353432373038&quot;)</td>
</tr>
</tbody>
</table>

**NOTE**

- These functions do not return positive and negative slope and skew values. It is not possible to determine up or down slope and left or right skew with these functions.
- The maximum skew angle to return is 45 degrees.
- Tekla Structures calculates the angles in 2D so that slope and skew are isolated from each other. For example, the skew angle is not taken into consideration when calculating the slope angle, which means that the slope angle value stays the same regardless of the secondary part's rotation around the primary part.

To find out the true 3D slope with the skew included, you can use the following mathematical formula:

\[
\text{TRUE}_\text{SLOPE} = \tan^{-1}(\tan(\text{SLOPE}) \times \cos(\text{SKEW}))
\]

**Example 1**

The slope and skew are relative to a beam framing into a column.

1. Column
2. Beam
3. **Slope**
4. **Skew**

**Example 2**

With two beams, the **slope** is actually the horizontal skew of the beam framing into the other beam, and the vertical slope of the beam relative to the main is actually the **skew** angle.

**Side view**

**Top view**

1. **Skew**
2. **Slope**

**How to avoid cyclic dependencies in formulas**

Be careful not to create cyclic dependencies between variables, or else the custom component will not work correctly. A cyclic dependency chain contains formulas that make a variable eventually dependent on itself.

In the following example, variable P1 becomes dependent on itself, through variables P2 and P3:

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1</td>
<td>=P2</td>
</tr>
<tr>
<td>P2</td>
<td>=P3/4</td>
</tr>
<tr>
<td>P3</td>
<td>=P1*2</td>
</tr>
</tbody>
</table>

Cyclic dependencies may also occur when binding handles to other objects or when using magnetic construction planes. When you create new formulas, bindings, or magnetic construction planes, Tekla Structures checks if they create cyclic dependency chains in a custom component. If that happens, a warning message “Caution. Operation created cycle.” is displayed.
Tekla Structures also writes the message "Cycle detected in parametric solver" into the session history log file and lists the objects involved in the cyclic dependency, to help you find and remove the cyclic dependency. If you do not remove it, the custom component will not work correctly.

**Examples of parametric variables and variable formulas**

Here you will find some examples that demonstrate how to use parametric variables and variable formulas to create intelligent custom components that adapt to changes in the model.

The examples are independent from each other.

- **Example: Set the end plate material (page 207)**
  In this example, you will link a parametric variable to the end plate material of a component object.

- **Example: Create new component objects (page 208)**
  In this example, you will create a parametric variable that adds bolts to the custom component.

- **Example: Replace sub-components (page 209)**
  In this example, you will create a parametric variable that replaces sub-components with other sub-components.

- **Example: Modify a sub-component by using a component attribute file (page 211)**
  In this example, you will create a parametric variable that modifies a sub-component on the basis of a component attribute file.

- **Example: Define the stiffener position using construction planes (page 212)**
  In this example, you will use construction planes for determining the position of the stiffeners. You will position the stiffeners so that they divide the beam into three equally long sections.
- **Example: Determine the bolt size and bolt standard (page 215)**
  In this example, you will create two parametric variables that determine the bolt size and bolt standard.

- **Example: Calculate the bolt group distance (page 216)**
  In this example, you will create a variable formula that calculates the bolt group distance from the beam flange.

- **Example: Calculate the number of bolt rows (page 218)**
  In this example, you will create a variable formula that calculates the number of bolt rows based on the beam height. You will use if statements in the calculations.

- **Example: Link variables to user-defined attributes (page 220)**
  In this example, you will link parametric variables to the user-defined attributes of panels. You can then use the user-defined attributes in view filters to show or hide the panels.

- **Example: Calculate the number of handrail posts using a template attribute (page 222)**
  In this example, you will create a variable formula that calculates the number of handrail posts based on the length template attribute of the beam. The handrail posts were created at both ends of the beam and one of them was copied with the **Array of objects (29)** component.

- **Example: Link an Excel spreadsheet to a custom component (page 224)**
  In this example, you will link a parametric variable to an Excel spreadsheet. For example, you can use Excel spreadsheets to check connections.

### Example: Set the end plate material
In this example, you will link a parametric variable to the end plate material of a component object.

1. In the custom component editor, click the **Display variables** button 🔄. The **Variables** dialog box opens.
2. Click the **Add** button.
   A new parametric variable appears.
3. In the **Value type** list, change the variable's value type to **Material**.
4. In the **Label in dialog box** box, enter **End Plate Material**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
<th>Label in dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1</td>
<td>0.00</td>
<td>0.00</td>
<td><strong>Material</strong></td>
<td>Parameter</td>
<td>Show</td>
<td><strong>End Plate Material</strong></td>
</tr>
</tbody>
</table>

5. In the **Custom component browser**, browse for the end plate material.
6. Right-click Material and select Add Equation.
7. Enter P1 after the equal sign, and then press Enter.
8. Save the custom component.
9. Close the custom component editor.

You can now change the end plate material in the custom component's dialog box.

**Example: Create new component objects**
In this example, you will create a parametric variable that adds bolts to the custom component.

1. In the custom component editor, click the Display variables button. The Variables dialog box opens.
2. Click Add to create a new parametric variable.
3. Modify the variable as follows:
a. In the **Value type** list, select **Yes/No**.

b. In the **Label in dialog box** box, enter **Create bolts**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
<th>Label in dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1</td>
<td>0</td>
<td>0</td>
<td>Yes/No</td>
<td>Parameter</td>
<td>Show</td>
<td>Create bolts</td>
</tr>
</tbody>
</table>

4. Select the bolt group in a custom component view to highlight it in the **Custom component browser**.

5. In the **Custom component browser**, browse for **Bolt**.

6. Right-click **Creation** and select **Add Equation**.

7. Enter **P1** after the equal sign, and then press **Enter**.

8. Save the custom component.

9. Close the custom component editor.

You now have the following option in the custom component's dialog box:

```
Parameters 1  General  Analysis

Create bolts

No
Yes
No
```

**Example: Replace sub-components**

In this example, you will create a parametric variable that replaces sub-components with other sub-components.
1. In the custom component editor, click the **Display variables** button. The **Variables** dialog box opens.

2. Click **Add** to create a new parametric variable.

3. Modify the variable as follows:
   a. In the **Value type** list, select **Component name**. Tekla Structures automatically adds the suffix `_name` in the variable name. Do not delete the suffix.
   b. In the **Formula** box, enter the name of the sub-component.
   c. In the **Label in dialog box** box, enter **Cast-in plate**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
<th>Label in dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1_name</td>
<td>castnl1</td>
<td>castn1</td>
<td>Component name</td>
<td>Parameter</td>
<td>Show</td>
<td>Cast-in plate</td>
</tr>
</tbody>
</table>

4. Link the variable to the **Name** property of both sub-components:
   a. In the **Custom component browser**, browse for the **Name** attribute of the first sub-component.
   b. Right-click **Name** and select **Add Equation**.
   c. Enter `P1_name` after the equals sign.
   d. Repeat steps 4b–4c for the other sub-component.
5. Save the custom component.
6. Close the custom component editor.

You can now change the sub-components by using the Cast-in-plate option in the custom component's dialog box.

**Example: Modify a sub-component by using a component attribute file**

In this example, you will create a parametric variable that modifies a sub-component on the basis of a component attribute file.

1. In the custom component editor, click the Display variables button. The Variables dialog box opens.
2. Click Add to create a new parametric variable.
3. In the Value type list, select Component attribute file. Tekla Structures automatically adds the suffix _attrfile in the variable name. Do not delete the suffix.
4. In the Formula box, enter the name of the component attribute file.
5. In the Name box, ensure that the variable has the same prefix as the variable that is linked to the component name. In this example, the prefix is P1.

**NOTE** The component name and the component attribute file variables must always have the same prefix, otherwise they do not work.

6. In the Label in dialog box box, enter Properties file.
7. In the **Custom component browser**, browse for the component attribute file property of the sub-component.

8. Right-click **Attribute file** and select **Add Equation**.

9. Enter `P1_attrfile` after the equal sign, and then press **Enter**.

10. Save the custom component.

11. Close the custom component editor.

You can now modify the sub-component by using the **Properties file** option in the custom component's dialog box.

**Example: Define the stiffener position using construction planes**

In this example, you will use construction planes for determining the position of the stiffeners. You will position the stiffeners so that they divide the beam into three equally long sections.

1. Ensure that **Direct Modification** is switched off. The selection of handles is easier when **Direct Modification** is off.
2. In the custom component editor, click the **Display variables** button. The **Variables** dialog box opens.
3. Click **Add** to create a new parametric variable.
4. Get the GUID of the beam.
   a. On the ribbon, click **Inquire objects**.
   b. Select the beam.
   c. In the **Inquire Object** dialog box, check the GUID of the beam.
5. Modify the variable as follows:
   a. In the **Formula** box, enter
      $$=fTp1(\text{"LENGTH"}, \text{"ID4C8B5E24-0000-017D-3132-383432313432"})$$
      
      **ID4C8B5E24-0000-017D-3132-383432313432** is the GUID of the beam.
      
      The value of the variable is now the same as the beam length. If you change the beam length, also the value changes.
   b. In the **Label in dialog box** box, enter **Beam Length**.
6. Click **Add** to create another parametric variable.
7. Modify the new variable as follows:
   a. In the **Formula** box, enter $$=P1/3$$
   b. In the **Label in dialog box** box, enter **3rd Points**.
8. Create a construction plane:
   a. In the custom component editor, click the **Add construction plane** button.
   b. Pick the required points and then click the middle mouse button to create a construction plane in the center of a stiffener at one end.
9. Bind the stiffener to the construction plane:
   a. Select the stiffener.
   b. Hold down Alt and use area selection (from left to right) to select all stiffener handles.
   c. Right-click and select Bind to plane.
   d. Bind the stiffener handles to the construction plane.

10. Bind the construction plane to the beam end:
    a. Select the construction plane.
    b. Right-click and select Bind to plane.
    c. Bind the construction plane to the beam end.
11. Repeat steps 9–11 for the stiffener at the other end.
12. In the Formula box, enter =$P2$ for the two distance variables that bind the construction planes to the beam ends.
13. Save the custom component.
14. Close the custom component editor.

If you now change the beam length, the position of the stiffeners changes so that the stiffeners divide the beam into three equally long sections.

**Example: Determine the bolt size and bolt standard**

In this example, you will create two parametric variables that determine the bolt size and bolt standard.

1. In the custom component editor, click the Display variables button.
   The Variables dialog box opens.
2. Click Add twice to create two new parametric variables.
3. Modify the first variable as follows:
   • In the Value type list, select Bolt size.
     Tekla Structures automatically adds the suffix _diameter to the name of the variables. Do not delete the suffix.
   • In the Label in dialog box box, enter Bolt Size.
4. Modify the second variable as follows:
   a. In the Value type list, select Bolt standard.
      Tekla Structures automatically adds the suffix _screwdin to the name of the variable. Do not delete the suffix.
   b. In the Name box, change the prefix of the second variable so that the prefixes for the two variables are the same.
In this example, the prefix is P1.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1_diameter</td>
<td>0.00</td>
<td>0.00</td>
<td>Bolt size</td>
<td>Parameter</td>
<td>Show</td>
</tr>
<tr>
<td>P1_screwdin</td>
<td>0.00</td>
<td>0.00</td>
<td>Bolt standard</td>
<td>Parameter</td>
<td>Show</td>
</tr>
</tbody>
</table>

**NOTE** The bolt size and bolt standard variables must always have the same prefix, otherwise they do not work.

c. In the **Label in dialog box** box, enter **Bolt Standard**.

5. Link the parametric variables to the bolt group properties:
   a. In the **Custom component browser**, browse for the size property of the component object.
   b. Right-click **Size** and select **Add Equation**.
   c. Enter **P1_diameter** after the equal sign, and then press **Enter**.
   d. Right-click **Bolt standard** and select **Add Equation**.
   e. Enter **P1_screwdin** after the equal sign, and then press **Enter**.

6. Save the custom component.
7. Close the custom component editor.

You can now determine the bolt size and bolt standard for the custom component in the custom component's dialog box.

**Example: Calculate the bolt group distance**

In this example, you will create a variable formula that calculates the bolt group distance from the beam flange.
1. Modify the bolt group properties as follows:
   a. In the custom component editor, double-click the bolt group.
      The **Bolt Properties** dialog box opens.
   b. Clear all values that are under the **Offset from** area.
   c. Click **Modify**.
      The bolt group moves to the same level with the start point handle of
      the bolt group.

2. Bind the bolt group to the beam flange:
   a. In the custom component editor, select the bolt group.
   b. Select the yellow top handle.
   c. Right-click the handle and select **Bind to plane**.
   d. Select the top flange of the beam.
A new distance variable appears in the Variables dialog box.

3. In the custom component editor, click the Display variables button. The Variables dialog box opens.
4. Click Add to create a new parametric variable.
5. Modify the variable as follows:
   a. In the Formula box, enter a distance value.
   b. In the Label in dialog box box, enter Vertical distance to bolt.
6. In the Formula box, enter \(-P1\) for the distance variable.

7. Save the custom component.
8. Close the custom component editor.

You can now determine the bolt group distance from the beam flange by changing the Vertical distance to bolt value in the custom component's dialog box.

**Example: Calculate the number of bolt rows**

In this example, you will create a variable formula that calculates the number of bolt rows based on the beam height. You will use if statements in the calculations.
1. In the custom component editor, click the **Display variables** button. The **Variables** dialog box opens.

2. Click **Add** to create a new parametric variable.

3. In the **Value type** list, select **Number**.

4. In the **Custom component browser**, browse for height property of the beam.

5. Right-click **Height** and select **Copy Reference**.

6. In the **Formula** box, enter the following \( \text{if} \) statement for the parametric variable:

\[
=\text{if} \ (\text{fP(Height, "ID50B8559A-0000-00FD-3133-353432363133") < 301}) \ \text{then} \ 2 \\
\text{else (if} \ (\text{fP(Height, "ID50B8559A-0000-00FD-3133-353432363133") > 501}) \ \text{then} \ 4 \\
\text{else 3 endif}) \ \text{endif}
\]

In the formula, \( \text{fP(Height, "ID50B8559A-0000-00FD-3133-353432363133")} \) is the beam height reference copied from the **Custom component browser**. The variable gets its value in the following way:

- If the beam height is under 301 mm, the value is 2.
- If the beam height is over 501 mm, the value is 4.
- If the beam height is between 300 and 500 mm, the value is 3.

7. Click **Add** to create another parametric variable.

8. In the **Value type** list, select **Distance list** for the new variable.

9. In the **Formula** box, enter \( =\text{P1}^\prime * 100 \) for the new variable.
In the formula, 100 is the bolt spacing and the P1 value is the number of bolt rows.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1</td>
<td>=if (fP(Height,&quot;ID50B8550A-0000 ...</td>
<td>2</td>
<td>Number</td>
</tr>
<tr>
<td>P2</td>
<td>=P1^&quot;x&quot;+100</td>
<td>2*100.00</td>
<td>Distance list</td>
</tr>
</tbody>
</table>

10. In the Custom component browser, browse for Bolt group distance x.
11. Right-click Bolt group distance x and select Add Equation.
12. Enter P2 after the equal sign, and then press Enter.
13. Save the custom component.
14. Close the custom component editor.

When you now change the beam height, the number of bolt rows changes as well.

**Example: Link variables to user-defined attributes**

In this example, you will link parametric variables to the user-defined attributes of panels. You can then use the user-defined attributes in view filters to show or hide the panels in the model.

1. In the custom component editor, click the Display variables button.
   The Variables dialog box opens.
2. Click Add to create a new parametric variable.
3. Modify the variable as follows:
   a. In the Value type list, select Text.
b. In the **Formula** box, enter `Type1`.
c. In the **Label in dialog box** box, enter `Panel1`.

4. In the **Custom component browser**, browse for the user-defined attributes of the first panel.

You will link the `P1` variable to the `USER_FIELD_1` attribute. However, the attribute is not visible in the **Custom component browser**.

5. Make the user-defined attribute visible in the **Custom component browser**:
   a. Double-click the first panel.
      The panel properties dialog box opens.
   b. Click **User-defined attributes**.
      The dialog box for user-defined attributes opens.
   c. Go to the **Parameters** tab.
   d. Enter text in the **User field** box.
   e. Click **Modify**.

6. In the **Custom component browser**, click **Refresh**.

   `USER_FIELD_1` appears under **User-defined attributes** in the **Custom component browser**.

7. Link `P1` to `USER_FIELD_1`.
   a. Right-click `USER_FIELD_1` and select **Add Equation**.
   b. Enter `P1` after the equal sign, and then press **Enter**.

8. Create two new parametric variables and link them to the user-defined attributes of the other two panels.

9. Save the custom component.

10. Close the custom component editor.

You can now create a view filter in the model to hide or show panels using the `User field 1` attribute and the **Formula** values you entered for the parametric variables in the filter.
**Example: Calculate the number of handrail posts using a template attribute**

In this example, you will create a variable formula that calculates the number of handrail posts based on the length template attribute of the beam. The handrail posts were created at both ends of the beam and one of them was copied with the *Array of objects (29)* component.

1. In the custom component editor, click the **Display variables** button. The **Variables** dialog box opens.
2. Create three new parametric variables by clicking **Add**.
3. Modify the variable **P1** as follows:
   - In the **Formula** box, enter 250.
   - In the **Label in dialog box** box, enter **End Distance**.
4. Modify the variable **P2** as follows:
   - In the **Formula** box, enter 900.
   - In the **Label in dialog box** box, enter **Spacing**.
5. Modify the variable **P3** as follows:
   - In the **Value type** box, select **Number**.
   - In the **Label in dialog box** box, enter **Number of Posts**.
6. Inquire the GUID of the beam:
   a. On the ribbon, click **Inquire objects**.
   b. Select the beam.
   c. Check the GUID of the beam in the **Inquire Object** dialog box.
7. In the **Formula** box of the **P3** variable, enter
   \[(fTp1("LENGTH","ID50B8559A-0000-010B-3133-353432373038") - (P1*2))/P2\].
   
   \(fTp1("LENGTH","ID50B8559A-0000-010B-3133-353432373038")\) is the length template attribute of the beam and
   \(ID50B8559A-0000-010B-3133-353432373038\) is the GUID of the beam.

   The number of the posts is calculated as follows: First the end distances are subtracted from the beam length, and then the result is divided by the post spacing.

8. In the **Custom component browser**, link the variables **P2** and **P3** to the properties of **Array of objects (29)**.
   a. Right-click **dist_betweenElem** and select **Add Equation**.
   b. Enter **P2** after the equal sign, and then press **Enter**.
   c. Right-click **number_of_arrays** and select **Add Equation**.
   d. Enter **P3** after the equal sign, and then press **Enter**.

   ![Component](image)

   ![General properties](image)

   ![dist_between_elem = P2](image)

   ![number_of_arrays = P3](image)

9. Bind the first post to the beam end.
   a. Select the post in the custom component view.
   b. Hold down **Alt** and use area selection (from left to right) to select the post handles.
   c. Right-click and select **Bind to Plane**.
10. Bind the last post to the other beam end by following the instructions in step 9.

11. Modify the distance variables as follows:
   a. In the **Formula** box, enter \( P1 \).
   b. In the **Visibility** list, select **Hide**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
<th>Label in dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1</td>
<td>=P1</td>
<td>250.00</td>
<td>Length</td>
<td>Parameter</td>
<td>Show</td>
<td>End Distance</td>
</tr>
<tr>
<td>P2</td>
<td>=P1</td>
<td>900.00</td>
<td>Length</td>
<td>Parameter</td>
<td>Show</td>
<td>Spacing</td>
</tr>
<tr>
<td>P3</td>
<td>=(P1+...)(4)</td>
<td>250.00</td>
<td>Number</td>
<td>Parameter</td>
<td>Show</td>
<td>Number of Posts</td>
</tr>
<tr>
<td>D1</td>
<td>=P1</td>
<td>250.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D1.COLUMN.BEAM</td>
</tr>
<tr>
<td>D2</td>
<td>=P1</td>
<td>250.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D2.COLUMN.BEAM</td>
</tr>
<tr>
<td>D3</td>
<td>=P1</td>
<td>250.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D3.COLUMN.BEAM</td>
</tr>
<tr>
<td>D4</td>
<td>=P1</td>
<td>250.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D4.COLUMN.BEAM</td>
</tr>
</tbody>
</table>

12. Save the custom component.
13. Close the custom component editor.

You can now change the spacing and the end distance of the handrail posts in the custom component dialog box. Tekla Structures calculates the number of posts based on the spacing, end distance, and length of the beam.

**Example: Link an Excel spreadsheet to a custom component**

In this example, you will link a parametric variable to an Excel spreadsheet. For example, you can use Excel spreadsheets to check connections.
1. Create an Excel spreadsheet.
   The name of the spreadsheet file must be
   `component_"component_name".xls`. For example,
   `component_stiffener.xls` for a custom component whose name is
   stiffener.

2. Save the Excel spreadsheet in the model folder: `..<\model>\exceldesign\`. Alternatively, you can save the spreadsheet in the folder defined with the `XS_EXTERNAL_EXCEL DESIGN_PATH` advanced option.

3. In the custom component editor, click the **Display variables** button.
   The **Variables** dialog box opens.

4. Click **Add** to create a new parametric variable.

5. Modify the variable as follows:
   a. In the **Value type** list, select **Yes/No**.
   b. In the **Name** box, enter `use_externaldesign`.
   c. In the **Label in dialog box** box, enter `Use external design`.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
<th>Label in dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>use_external</td>
<td>0</td>
<td>0</td>
<td>Yes/No</td>
<td>Parameter</td>
<td>Show</td>
<td>Use external design</td>
</tr>
</tbody>
</table>

6. Save the custom component.
7. Close the custom component editor.
   The custom component dialog box now contains the **Use external design** option.

8.5 **Save a custom component**

After modifying a custom component, save the changes.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save changes to all copies of the custom component</td>
<td>1. In the custom component editor, click the <strong>Save component</strong> button.</td>
</tr>
<tr>
<td>To</td>
<td>Do this</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>2. In the <strong>Save confirmation</strong> dialog box, click <strong>Yes</strong>. Tekla Structures saves the changes and applies them to all copies of the custom component in the model.</td>
<td></td>
</tr>
</tbody>
</table>
| **Save the component with a new name** | 1. In the custom component editor, click the **Save with new name** button.  
2. Enter a new name for the component.                                                                                           |
| **Save and close the component**   | 1. In the custom component editor, click the **Close** button.  
2. In the **Close custom component editor** message, click **Yes**. If you click **No**, the custom component editor closes without saving the changes. |

**See also**

Tips for sharing custom components (page 283)

### 8.6 Modify the dialog box of a custom component

Tekla Structures automatically creates a dialog box for each custom component you define. You can customize the dialog box by using the **Custom Component Dialog Editor** tool.
To open the dialog editor, select a custom component in the model, right-click, and select **Edit Custom Component Dialog Box**.

![Custom Component Dialog Editor](image)

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| View and edit object properties | 1. Select a dialog box element. For example, a text box.  
2. Click **Modify --> Properties**.  
Now you can view and edit the current properties of the dialog box element. For example, you can check that you have the correct text box under each label in the dialog box.  
Alternatively, you can double-click the dialog box element. If the dialog box element will not open for viewing and editing, try double-clicking the space right underneath the check box: |

Add a dialog box element | Click **Insert** and select a suitable element from the list. The options are:  
- **Tab Page**: add a new tab  
- **Label**: add a label for a text box or list |
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Add an image | 1. Click **Insert --> Picture** to show the contents of the **Image Folder** set in **Tools --> Options**.  
2. Select an image.  
The image must be in the bitmap (.bmp) format.  
3. Click **Open**.  
4. Drag the image to the desired location. |
| Add a tab | 1. Click **Insert --> Tab Page**.  
2. Double-click the new tab.  
3. Enter a new name, and then press **Enter**.  
**NOTE** Each tab may contain up to 25 fields. If you have more than 25 fields visible, Tekla Structures automatically creates another tab. |
| Show or hide the pixel grid | Click ![Pixel Grid](image).  
Tekla Structures displays a pixel grid that makes it easier to align elements in the dialog box. |
| Move a dialog box element | Drag the dialog box element to a new location.  
You can also use the keyboard shortcuts **Ctrl+X** (cut), **Ctrl+C** (copy), and **Ctrl+V** (paste). For example, to move a dialog box element to another tab: select the dialog box element, |
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select multiple dialog box elements</td>
<td>Hold down the <strong>Ctrl</strong> key and click the dialog box elements, or use area selection.</td>
</tr>
</tbody>
</table>
| Rename a tab or text box label          | 1. Double-click the tab or text box label.  
  2. Type a new name.  
  3. Press **Enter**. |
| Remove a dialog box element             | 1. Select the dialog box element you want to remove.  
  2. Press **Delete**. |
| Remove a tab                            | 1. Select the tab.  
  2. Right-click and select **Delete**. |
| Add images to a list                    | 1. Select the list element.  
  2. Click **Modify --> Properties**.  
  3. Click **Edit Values**.  
  4. Click **Browse Add**.  
  5. Select the image you want to use and click **Open**.  
  6. Repeat steps 4–5 for any other images you want to use.  
  7. Click **OK** to save the changes. |
| Save the changes                        | Click **File --> Save**. |

**See also**
- Dialog editor settings (page 259)
- Modify custom component input files manually (page 230)
- Example: Modify the dialog box of a stiffener detail (page 237)

**Custom component input files**

Each custom component has an input file that defines the contents of the custom component's dialog box.

When you create a new custom component, Tekla Structures automatically creates an input file for the component. The input file is located in the `\CustomComponentDialogFiles` folder under the model folder. The input
file has the same name as the custom component, and the file name extension is `.inp`.

When you modify a custom component (page 170), you will lose any changes you have made to the input file. However, when you modify the custom component, Tekla Structures automatically creates a backup copy of the input file. The backup copy has the file name extension `.inp_bak`, and it is located in the \CustomComponentDialogFiles folder under the model folder. Tekla Structures displays a notification when the backup file is created.

See also

Lock or unlock the custom component input file (page 233)

Modify custom component input files manually

If you are an advanced user, you can modify the dialog box input (.inp) files manually in a text editor. Be careful when modifying an input file, as errors may cause the dialog box to disappear.

Note that the General tab is reserved for predefined general properties. You cannot rename the General tab or add more parameters to it.

Add new tabs

1. Open the `.inp` file in a text editor.
2. Add a new tab definition, as shown below:

   ```
   { 
   tab_page("", "Parameters 1", 1) 
   { 
   parameter("Parameter1","F1", integer, number 1) 
   parameter("Parameter2","F2", integer, number 2) 
   parameter("Parameter3","F3", integer, number 3) 
   } 
   tab_page("", "Parameters 2", 2) 
   { 
   parameter("Parameter4","F4", integer, number 1) 
   parameter("Parameter5","F5", integer, number 2) 
   parameter("Parameter6","F6", integer, number 3) 
   } 
   } 
   ```

3. Save the `.inp` file.
NOTE The fourth tab is reserved for the General properties, so you cannot add your own parameters to it.

**Add text boxes**
1. Open the .inp file in a text editor.
2. Add parameter elements and enclose them in curly brackets, as shown below:

```plaintext
{ tab_page(""," Parameters 1 ",1)
  { parameter("Parameter1","P1", integer, number 1)
    parameter("Parameter2","P2", integer, number 2)
    parameter("Parameter3","P3", integer, number 3)
  }
  tab_page(""," Parameters 2 ",2)
  { parameter("Parameter4","P4", integer, number 1)
    parameter("Parameter5","P5", integer, number 2)
    parameter("Parameter6","P6", integer, number 3)
  }
}
```
3. Save the .inp file.

**Add images**
1. Create an image and save it in bitmap (.bmp) format in the ..\Tekla Structures\<version>\nt\bitmaps folder.
2. Open the .inp file in a text editor.
3. Add an image definition, as shown below:
(1) $y = 100$
(2) $x = 50$
(3) $\text{height} = 75$
(4) $\text{width} = 100$

4. Save the .inp file.

Change the order of boxes

1. Open the .inp file in a text editor.
2. Change the last number in the parameter definition.
   The boxes are listed from top to bottom, as shown below:

3. Save the .inp file.

Custom components 232 Modify the dialog box of a custom component
**Change the location of boxes**

You can define an exact location for each text box.

1. Open the `.inp` file in a text editor.
2. Define the exact location of the box using three values: the x coordinate, y coordinate, and width of the box.

   For example:

   ```
   { 
     tab_page("", "Parameters 1", 1)
     { 
       parameter("Parameter1", "P1", integer, number, 374, 0, 100) 
       parameter("Parameter2", "P2", integer, number, 374, 25, 100) 
       parameter("Parameter3", "P3", integer, number, 374, 50, 100) 
     } 
   }
   ``

   **(1)** x = 374  
   **(2)** y = 25  
   **(3)** width = 160
3. Save the `.inp` file.

**Lock or unlock the custom component input file**

You can lock the custom component's input file to prevent accidental modifications. If the file is unlocked, and someone else updates the custom component in the custom component editor, all your modifications to the dialog box will be lost.

1. In the model, select the custom component whose input file you want to lock or unlock.
2. Right-click and select **Edit Custom Component Dialog Box**.
3. In the dialog editor, click the **Lock/Unlock** button.

If someone modifies the custom component in the custom component editor when the `.inp` file is locked, the `.inp` file will not be updated. You can still modify the dialog box in the **Custom Component Dialog Editor** even if the `.inp` file is locked.
Example: Create a toggle group
Create a toggle group if you want to add a group of check boxes without labels.

In this example, we will add a check box for each bolt group in a custom component. When the component is used in a model, the user can select which bolts to create by selecting the desired check boxes.

1. Create a custom component that contains bolts.
   For example, we created a custom tee connection that creates one bolt group and three single bolts:

![Image of a custom tee connection with bolts](image)

2. Create parametric variables that control the creation of bolts.
   With toggle groups, the **Value type** of these variables must be **Yes/No**.
   For example, we created three variables P1, P2, and P3, one for each single bolt in the custom tee connection.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
<th>Label in dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1</td>
<td>0</td>
<td>0</td>
<td>Yes/No</td>
<td>Parameter</td>
<td>Show</td>
<td>Parameter1</td>
</tr>
<tr>
<td>P2</td>
<td>0</td>
<td>0</td>
<td>Yes/No</td>
<td>Parameter</td>
<td>Show</td>
<td>Parameter2</td>
</tr>
<tr>
<td>P3</td>
<td>0</td>
<td>0</td>
<td>Yes/No</td>
<td>Parameter</td>
<td>Show</td>
<td>Parameter3</td>
</tr>
</tbody>
</table>

3. Link the variables (page 186) to the **Creation** property of the bolts.
For example, link the variable P1 to the **Creation** property of the first bolt, the variable P2 to the **Creation** property of the second bolt, and so on.

4. Save the custom component.

5. In the model, click **File --> Open the model folder** to open the current model folder.

6. Go to the \CustomComponentDialogFiles folder.

7. Open the .inp file in a text editor.

8. **Add an image definition (page 231).**

   For example:

   ```
   page("TeklaStructures","")
   {
     detail(1, "Tee")
     {
       tab_page("", " Parameters 1 ", 1)
       {
         picture("CustomTee",100,100,200,100) /*Bolts*/
       }
     }
   }
   
   If you use a custom image, save it in bitmap (.bmp) format in the .. \TeklaStructures\<version>\Bitmaps folder.

9. **Add a toggle_group element to define the toggle group origin, that is, the position of the toggle group in the custom component dialog box.**
Use the x and y coordinate values to define the position. For example:

```
page("TeklaStructures",""
{
  detail(1, "tee"
  {
    tab_page("", " Parameters 1 ", 1)
    {
      picture("CustomTee",100,100,200,100) /*Bolts*/
      toggle_group(200,320,
      "P1", 160, -165, "0",
      "P2", 160, -135, "C",
      "P3", 160, -105, "C")
    }
  }
}
```

(1) x = 200
(2) y = 320

10. Within the `toggle_group` element, add a line for each check box you want to add.

Use the same parametric variables that you created in step 2.

```csharp
page("TeklaStructures",""
{
  detail(1, "tee"
  {
    tab_page("", " Parameters 1 ", 1)
    {
      picture("CustomTee",100,100,200,100) /*Bolts*/
      toggle_group(200,320,
      "P1", 160, -165, "0",
      "P2", 160, -135, "C",
      "P3", 160, -105, "C")
    }
  }
}
```

The two numeric values after the variable name are offsets from the toggle group origin. For example, the first definition "P1", 160, -165, "0" means that the check box for the variable P1 is located 160 steps right and 165 steps up from the toggle group origin.

<table>
<thead>
<tr>
<th>Direction</th>
<th>Negative values</th>
<th>Positive values</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>left</td>
<td>right</td>
</tr>
<tr>
<td>Y</td>
<td>up</td>
<td>down</td>
</tr>
</tbody>
</table>

Custom components 236 Modify the dialog box of a custom component
11. Save the .inp file.
12. Close and reopen the model for the change to take effect.

Now when you select and clear check boxes in the dialog box, the number of bolts changes accordingly in the model. For example:

NOTE  Tekla Structures automatically adds the Effect in modify label and check box for each toggle group you create.
Example: Modify the dialog box of a stiffener detail
In this example, we will edit the dialog box of a custom stiffener detail to make it easier to adjust the settings later on.

When we begin, the dialog box looks like the following:

![Example dialog box image]

Do this
1. Create a custom stiffener detail with all the needed variables that control the creation of stiffener plates.
2. Add a list with images.
3. Arrange text boxes and labels.
4. Dim unavailable options.

Example: Create a custom stiffener detail with variables
In this example, we will create a stiffener detail with variables that control the shape and position of the stiffeners.

Create a basic stiffener detail
In this example, we will create a basic stiffener detail.
1. Create a beam with two stiffeners.
TIP  To create the stiffeners, you can use the Stiffeners (1003) component and then explode the component.

2. Click the Applications & components button in the side pane to open the Applications & components catalog.

3. Click the Access advanced features button and select Define custom component.

   The Custom Component Wizard dialog box opens.

4. In the Type list, select Detail.

5. In the Name box, type Stiffeners.

6. Click Next.

7. Select the stiffeners and the beam as the objects that form the custom component.
8. Click **Next**.
9. Select the beam as the main part.
10. Click **Next**.
11. Select the middle point of the beam as the reference point.

**TIP** Switch to the plane view to select the middle point more easily.

12. Click **Finish** to finish creating the stiffener detail.
Tekla Structures displays a component symbol for the new custom component and adds the stiffener detail to the component catalog.

Create bindings to control the stiffener shape
In this example, we will bind custom component handles to a plane to control the shape of the stiffeners.

1. Open the stiffener detail in the custom component editor.
   a. Right-click the custom component in the model.
   b. Select Edit Custom Component.

      The custom component editor opens showing the custom component editor toolbar, the component browser, and four views of the custom component.

2. On the View tab, click Rendering --> Parts rendered.

      Part surfaces and available planes can be selected only when they are rendered.

3. On the custom component editor toolbar, select Outline planes from the list.

4. In the custom component editor, select the stiffener on the right.

5. Bind the two inside handles of the stiffener to the beam web.
   a. Select the two handles next to the beam web.
b. Right-click and select **Bind to Plane**.

c. Move the pointer over the face of the web to highlight it.

d. Click the web to bind the handles.

6. Bind the two outside handles of the stiffener to the face of the top flange. Use the same method as in step 5.

7. Bind the two bottom handles of the stiffener to the inside face of the bottom flange.
8. Bind the two top handles of the stiffener to the inside face of the top flange.
   Use the same method as in step 5.

9. Repeat steps 4–11 for the stiffener on the left.

10. In the custom component editor, click the Display variables button. The Variables dialog box opens.
11. Click Add to create a new parametric variable P1.
12. Modify the variable P1 as follows:
   a. In the Formula box, enter 10.
   b. In the Label in dialog box box, enter Stiffener set back.
13. In the Formula box, enter =P1 for all variables that got values during the binding of the handles.
For example:

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
</tr>
</thead>
<tbody>
<tr>
<td>D1</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
</tr>
<tr>
<td>D2</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
</tr>
<tr>
<td>D3</td>
<td>10.00</td>
<td>10.00</td>
<td>Length</td>
</tr>
<tr>
<td>D4</td>
<td>10.00</td>
<td>10.00</td>
<td>Length</td>
</tr>
</tbody>
</table>

The variable P1 now controls the distances of these variables.

14. In the **Visibility** list, set the variable P1 to **Show** and the other variables to **Hide**.

We have now created distance variables that control the stiffener shape.

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
<th>Label in dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>D1</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D1.PLATE.Web right plane</td>
</tr>
<tr>
<td>D2</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D2.PLATE.Web right plane</td>
</tr>
<tr>
<td>D3</td>
<td>=P1</td>
<td>10.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D3.PLATE.Upper flange right plane</td>
</tr>
<tr>
<td>D4</td>
<td>=P1</td>
<td>10.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D4.PLATE.Upper flange right plane</td>
</tr>
<tr>
<td>D5</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D5.PLATE.Lower flange top right plane</td>
</tr>
<tr>
<td>D6</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D6.PLATE.Lower flange top right plane</td>
</tr>
<tr>
<td>D7</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D7.PLATE.Upper flange bottom right plane</td>
</tr>
<tr>
<td>D8</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D8.PLATE.Upper flange bottom right plane</td>
</tr>
<tr>
<td>D9</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D9.PLATE.Web left plane</td>
</tr>
<tr>
<td>D10</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D10.PLATE.Web left plane</td>
</tr>
<tr>
<td>D11</td>
<td>=P1</td>
<td>10.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D11.PLATE.Upper flange left plane</td>
</tr>
<tr>
<td>D12</td>
<td>=P1</td>
<td>10.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D12.PLATE.Upper flange left plane</td>
</tr>
<tr>
<td>D13</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D13.PLATE.Lower flange top left plane</td>
</tr>
<tr>
<td>D14</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D14.PLATE.Lower flange top left plane</td>
</tr>
<tr>
<td>D15</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D15.PLATE.Upper flange bottom left plane</td>
</tr>
<tr>
<td>D16</td>
<td>0.00</td>
<td>0.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>D16.PLATE.Upper flange bottom left plane</td>
</tr>
<tr>
<td>P1</td>
<td>10.00</td>
<td>10.00</td>
<td>Length</td>
<td>Parameter</td>
<td>Show</td>
<td>Stiffener set back</td>
</tr>
</tbody>
</table>

**Create bindings to control the stiffener position**

In this example, we will bind custom component handles to a plane to control the position of the stiffeners.

1. Open the stiffener detail in the custom component editor.
   a. Right-click the custom component in the model.
   b. Select **Edit Custom Component**.
      
      The custom component editor opens showing the custom component editor toolbar, the component browser, and four views of the custom component.

2. On the custom component editor toolbar, select **Component planes** from the list.
3. Select all the handles of both stiffeners.

4. Right-click and select **Bind to Plane**.

5. Bind the handles to the vertical component plane.

We have now created distance variables that control the position of the stiffeners.

**Create variables to control the stiffener thickness**

In this example, we will control the stiffener thickness so that it is one and a half times the web thickness rounded up to the nearest available plate thickness. The available thickness values are 10, 12, and 16 mm.

1. Open the stiffener detail in the custom component editor.
   a. Right-click the custom component in the model.
b. Select **Edit Custom Component**.

The custom component editor opens showing the custom component editor toolbar, the component browser, and four views of the custom component.

2. In the custom component editor, click the **Display variables** button. The **Variables** dialog box opens.

3. Click **Add** to create a new parametric variable P2.

4. Modify the variable P2 as follows:
   a. In the **Formula** box, enter \( =1.5^* \).
   b. In the **Visibility** list, select **Hide**.
   c. In the **Label in dialog box** box, enter **Plate calculation**.

5. Select the beam in the custom component editor to highlight the beam (primary part) in the custom component browser.

6. In the **Custom component browser**, select **Web thickness** of the primary part.

7. Right-click and select **Copy Reference**.

8. Paste the reference value to **Formula** after \( =1.5^* \).

\[
P2 = 1.5 * \text{Web thickness, 'ID130f6981-f56c-4619-88ff-7d30f42abf2e'}
\]
9. Click **Add** to create a new parametric variable P3.

10. Modify the variable P3 as follows:
   a. In the **Value type** list, select **Number**.
   b. In the **Formula** box, enter:

   ```plaintext
   =if (P2 < 12 && P2 > 10) then 12 
   else if (P2 > 12) then 16 else 10 endif endif
   ```

   This means that if P2 is less than 12 and greater than 10, the thickness is 12. If P2 is greater than 12, the thickness is 16. If none of these conditions are met, the thickness is 10.

11. In the **Custom component browser**, link the variable P3 to the **Profile** property of the first contour plate.

12. Repeat step 11 for the second contour plate.

We have now created and linked all required variables that control the stiffener thickness according to the web thickness.

**Create variables to control the creation of stiffener plates**

In this example, we will create five variables to control which stiffener plates are created and what is the class of the plates.

1. Open the stiffener detail in the custom component editor.
   a. Right-click the custom component in the model.
b. Select **Edit Custom Component**.

The custom component editor opens showing the custom component editor toolbar, the component browser, and four views of the custom component.

2. In the custom component editor, click the **Display variables** button.

The **Variables** dialog box opens.

3. Click **Add** to create a new parametric variable P4.

4. Modify the variable P4 as follows:
   a. In the **Formula** box, enter `2`.
   b. In the **Value type** list, select **Number**.
   c. In the **Visibility** list, select **Show**.
   d. In the **Label in dialog box** box, enter *Plates created*.

5. Click **Add** to create a new parametric variable P5.

6. Modify the variable P5 as follows:
   a. In the **Formula** box, enter `if P4==0 then 0 else 1 endif`.
   b. In the **Value type** list, select **Yes/No**.
   c. In the **Visibility** list, select **Hide**.
   d. In the **Label in dialog box** box, enter *Do not create right*.

7. Click **Add** to create a new parametric variable P6.

8. Modify the variable P6 as follows:
   a. In the **Formula** box, enter `if P4==1 then 0 else 1 endif`.
   b. In the **Value type** list, select **Yes/No**.
   c. In the **Visibility** list, select **Hide**.
   d. In the **Label in dialog box** box, enter *Do not create left*.

9. Click **Add** to create a new parametric variable P7.

10. Modify the variable P7 as follows:
    a. Rename P7 as *LeftC*.
    b. In the **Formula** box, enter `4`.
    c. In the **Value type** list, select **Number**.
    d. In the **Visibility** list, select **Show**.
    e. In the **Label in dialog box** box, enter *Left plate class*.

11. Click **Add** to create a new parametric variable P8.

12. Modify the variable P8 as follows:
a. Rename P8 as RightC.
b. In the Formula box, enter 5.
c. In the Value type list, select Number.
d. In the Visibility list, select Show.
e. In the Label in dialog box box, enter Right plate class.

13. In the Custom component browser, link the variables P5 and RightC to the right stiffener plate.

14. Link the variables P6 and LeftC to the left stiffener plate.

Example: Add a list with images

In this example, we will add an illustrative list in the stiffener dialog box. You can do this either in the custom component dialog editor or by editing the input (.inp) file manually.

When we begin, the dialog box has the text box shown below, and the user needs to know the values (0 is left, 1 is right, and 2 is both plates) that control the creation of stiffener plates.

```
Plates created: [ ]
```

We will replace the text box with a list that is easier to use:
Add a list by using the dialog editor

1. Create a custom stiffener detail (page 238) with all the needed variables that control which stiffener plates are created.
   In our example, the variable is called **Plates created**.

2. Open the stiffener dialog box for editing.
   a. In the model, select the custom stiffener detail.
   b. Right-click and select **Edit Custom Component Dialog Box**.

3. Check the name of the parametric variable that controls the plate creation.
   a. In the dialog editor, double-click the **Plates created** box.
      The **Object Properties** dialog box opens.
   b. Check the name of the parametric variable.
In our example, the name is P4.

4. Select the **Plates created** text box and press **Delete**.
5. Click **Insert** --> **Attribute** to add a new attribute list.
6. Drag the attribute list to a suitable location, next to the **Plates created** label.
7. Select the attribute list and then click **Modify** --> **Properties** to edit its properties.
8. Enter P4 as the **Name** of the attribute.
   Now the attribute list is linked to the parametric variable that controls the plate creation.
9. Click **Edit Values** to add the list items.
10. In the **Edit Attribute Values** dialog box, add an image for the left plate.
    a. Click **Browse Add**.
    b. Browse for a suitable image.
       If you make new images, make sure they are in the bitmap (.bmp) format. Save the images in the ..\ProgramData\Tekla Structures\<version>\Bitmaps folder.
    c. Click **Open**.
11. Repeat step 9 to add an image for the right plate, and then for both plates.
12. In the **Edit Attribute Values** dialog box, select the image of both plates and then click **Default** to make the attribute the default value.

![Edit Attribute Values dialog box]

13. Click **OK**.

14. Click **Apply** in the **Object Properties** dialog box, and then click **Cancel** to close the dialog box.

15. In the dialog editor, click **File --> Save** to save the changes.

16. Close and reopen the model for the change to take effect.

**Add a list by editing the .inp file**

1. Create a custom stiffener detail (page 238) with all the needed variables that control which stiffener plates are created.
   
   In our example, the variable is called **Plates created**.

2. In the model, click **File --> Open the model folder** to open the current model folder.

3. Go to the \CustomComponentDialogFiles folder.

4. Open the .inp file in a text editor.
5. Remove the following line:

   parameter("Plates created", "P4", integer, number, 2)

6. Add a new **Plates created** attribute with the following settings:

   ```
   attribute("Plates created", label, "%s", none, none, "0", "0", 334, 118)
   ```

7. Add a new **P4** attribute with the following settings:

   ```
   attribute("P4", "", option, "%s", none, none, "0.0", "0.0", 360, 151, 90)
   ```

The list now contains three options, and **Both** is the default value. The list options are linked to the variable P4 that controls the creation of the stiffener plates.
8. Edit the line numbers so that there are no empty rows between the variables in the dialog box.

```plaintext
page("TeklaStructures",""")
{
detail(1, "Stiffeners")
{
tab_page("", " Parameters 1 ", 1)
{
    parameter("Stiffener set back", "Pl", distance, number, 1)
    parameter("Left plate class", "LeftC", integer, number, 1)
    parameter("Right plate class", "RightC", integer, number, 1)
    attribute("", "Plates created", label, "%s", none, none, "0", "0", 134, 118)
    attribute("P4", ",", option, "%s", none, none, "0.0", "0.0", 360, 151, 90)
{
    value ("Left", 0)
    value ("Right", 0)
    value ("Both", 1)
}
}
}
```

9. Browse for the images you want to use in the dialog box.

   If you make new images, make sure they are in the bitmap (.bmp) format.
   Save the images in the ..\ProgramData\Tekla Structures \<version>\Bitmaps folder.

10. Replace the option texts with the actual filenames of the images, but with the filename extension .xbm.

```plaintext
page("TeklaStructures",""")
{
detail(1, "Stiffeners")
{
tab_page("", " Parameters 1 ", 1)
{
    parameter("Stiffener set back", "Pl", distance, number, 1)
    parameter("Left plate class", "LeftC", integer, number, 1)
    parameter("Right plate class", "RightC", integer, number, 1)
    attribute("", "Plates created", label, "%s", none, none, "0", "0", 134, 118)
    attribute("P4", ",", option, "%s", none, none, "0.0", "0.0", 360, 151, 90)
{
    value ("CC_Left.xbm", 0)
    value ("CC_Right.xbm", 0)
    value ("CC_Both.xbm", 1)
}
}
}
```

11. Save the .inp file.

12. Close and reopen the model for the change to take effect.

**Example: Arrange text boxes and labels**

In this example, we will arrange the text boxes and labels around a list in the dialog box. You can do this either in the custom component dialog editor or by editing the input (.inp) file manually.
When we begin, the dialog box looks like the following:

```
Stiffener set back
Left plate class
Right plate class
Plates created

[10.00]

[4]

[5]
```

We will arrange the dialog box elements more nicely, in the following manner:

```
<table>
<thead>
<tr>
<th>Left plate class</th>
<th>Plates created</th>
<th>Right plate class</th>
</tr>
</thead>
<tbody>
<tr>
<td>[4]</td>
<td></td>
<td>[5]</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Stiffener set back</th>
</tr>
</thead>
<tbody>
<tr>
<td>[10.00]</td>
</tr>
</tbody>
</table>
```

**Arrange the elements by using the dialog editor**

1. Create a custom stiffener detail (page 238) with all the needed variables that control the creation of stiffener plates.

2. Open the stiffener dialog box for editing.
   a. In the model, select the custom stiffener detail.
   b. Right-click and select **Edit Custom Component Dialog Box**.

3. Drag the **Plates created** label above the list with images.

4. Drag the **Left plate class** label and the corresponding text box to the left side of the list.

5. Drag the **Right plate class** label and the corresponding text box to the right side of the list.

6. Drag the **Stiffener set back** label and the corresponding text box underneath the list.

7. In the dialog editor, click **File --> Save** to save the changes.

8. Close and reopen the model for the change to take effect.

**Arrange the elements by editing the .inp file**

1. Create a custom stiffener detail (page 238) with all the needed parametric variables that control the creation of stiffener plates.
2. In the model, click **File --> Open the model folder** to open the current model folder.

3. Go to the \CustomComponentDialogFiles folder.

4. Open the *.inp* file in a text editor.

5. Edit the file as follows:

   ```
   page("TeklaStructures", "")
   { 
     detail(1, "Stiffeners")
     { 
       tab_page("", " Parameters 1 ", 1)
       { 
         attribute("", "Plates created", label, "\%s", none, none, "0", "0", 334, 118)
         attribute("", "option", "\%s", none, none, "0.0", "0.0", 300, 151, 90)
           { 
             value("CC_Left.xbm", 0)
             value("CC_Right.xbm", 0)
             value("CC_Both.xbm", 1)
           }
         attribute("", "Left plate class", label, "\%s", none, none, "0", "0", 125, 157)
         attribute("", "Right plate class", label, "\%s", none, none, "0", "0", 497, 160)
         parameter("", "LeftC", integer, number, 146, 192, 160)
         parameter("", "RightC", integer, number, 522, 354, 160)
         parameter("", "P1", distance, number, 357, 289, 160)
         attribute("", "Stiffener set back", label, "\%s", none, none, "0", "0", 330, 255)
       }
     }
   }
   ```


7. Close and reopen the model for the change to take effect.

**Example: Dim unavailable options**

In this example, we will dim the unavailable options in the stiffener dialog box based on conditions. You can do this either in the custom component dialog editor or by editing the input (*.inp*) file manually.

When we begin, all the options are available:

We will define that the **Left plate class** text box is unavailable if only the right plate is created, and vice versa.
Dim unavailable options by using the dialog editor

1. Create a custom stiffener detail (page 238) with all the needed parametric variables that control the creation of stiffener plates.

2. Open the stiffener dialog box for editing.
   a. In the model, select the custom stiffener detail.
   b. Right-click and select **Edit Custom Component Dialog Box**.

3. Define that the **Left plate class** text box must be dimmed if only the right stiffener plate is created.
   a. In the **Plates created** list, select the image for the right plate class. Note that a blue selection border must be displayed for the image:

   ![Plates created](image)

   b. Hold down the **Ctrl** key and click the **Left plate class** text box.

   ![Left plate class](image)

   c. Click the **Toggle visibility** button. The **Left plate class** text box is now dimmed:

   ![Left plate class dimmed](image)
4. Unselect the Left plate class text box by clicking the Right plate class text box.

5. Define that the Right plate class text box must be dimmed if only the left stiffener plate is created.
   a. In the Plates created list, select the image for the left plate class. Note that a blue selection border must be displayed for the image:

   ![Plates created image]

   b. Hold down the Ctrl key and select the Right plate class text box.

   ![Plate created image]

   c. Click the Toggle visibility button. The Right plate class text box is now dimmed:

   ![Plate created dimmed image]

6. In the dialog editor, click File --> Save to save the changes.
7. Close and reopen the model for the change to take effect.

Dim unavailable options by editing the .inp file

1. Create a custom stiffener detail (page 238) with all the needed parametric variables that control the creation of stiffener plates.

2. In the model, click File --> Open the model folder to open the current model folder.

3. Go to the \CustomComponentDialogFiles folder.

4. Open the .inp file in a text editor.

5. Add the following line to the end of the attribute P4 line:
The logic is the following:
Selecting the image \textbf{CC\_left} returns 0, \textbf{CC\_right} returns 1, and \textbf{CC\_both} returns 2.

\begin{itemize}
  \item \textbf{toggle\_field:RightC=1} \\
  When 0 (left) is selected, \textbf{RightC} is dimmed.
  \item \textbf{toggle\_field:LeftC=0} \\
  When 1 (right) is selected, \textbf{LeftC} is dimmed.
\end{itemize}

6. Save the .inp file.
7. Close and reopen the model for the change to take effect.

\textbf{TIP} If you want to hide unavailable options instead of dimming them in the stiffener dialog box, add an exclamation mark in the conditions:

\begin{quote} "\texttt{toggle\_field:!LeftC=0;!RightC=1}" \end{quote}

The option is now completely hidden when unavailable:

\begin{center}
\includegraphics[width=0.5\textwidth]{dialog.png}
\end{center}

\textbf{Dialog editor settings}
Click \texttt{Tools \rightarrow Options} in the \textbf{Custom Component Dialog Editor} to view and modify basic settings in the dialog editor. Click \texttt{Tools \rightarrow Change Language} to change the language of the dialog editor.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image folder</td>
<td>The location of the image folder. To restore the default folder setting, click <strong>Default</strong>.</td>
</tr>
<tr>
<td>Project folder</td>
<td>The location of the project folder. When you create a completely new input file by clicking <strong>File --&gt; New</strong> and then save it, the file is saved in the project folder. Note that existing input files are saved under the model folder.</td>
</tr>
<tr>
<td>Parameter width</td>
<td>The default width for text boxes.</td>
</tr>
<tr>
<td>Attribute width</td>
<td>The default width for lists.</td>
</tr>
<tr>
<td>Grid spacing X</td>
<td>The spacing of the pixel grid (page 226) in the X and Y directions. The default value is 5.</td>
</tr>
<tr>
<td>Grid spacing Y</td>
<td></td>
</tr>
<tr>
<td>Snap to grid</td>
<td>Select to show or hide the pixel grid.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Language</td>
<td>Select a language from the list. Close and reopen the dialog editor for the change to take effect. You have the following options:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Auto</strong>: the dialog editor follows the language of the Tekla Structures user interface</td>
</tr>
<tr>
<td></td>
<td>• <strong>English</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Dutch</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>French</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>German</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Italian</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Spanish</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Japanese</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Chinese Simplified</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Chinese Traditional</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Czech</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Portuguese Brazilian</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Hungarian</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Polish</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Russian</strong></td>
</tr>
</tbody>
</table>
8.7 Add a custom component to a model

Use the Applications & components catalog to add your custom component to a model.

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. To search for a component, browse the catalog or enter a search term in the search box. Custom components have the following symbols in the catalog:

<table>
<thead>
<tr>
<th>Type</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom part</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Custom connection or seam</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Custom detail</td>
<td>![Symbol]</td>
</tr>
</tbody>
</table>

3. Select the custom component you want to add.
4. Follow the instructions on the status bar to add the custom component in the model.
5. To modify the properties, double-click the custom component in the model.

Example: Add a custom connection to a model

In this example, you will add a previously created custom end plate connection to a model. Because you have not modified the custom component to adapt to different situations in the model, you need to add it to a similar location where it was created. Otherwise the custom component may not work as required.

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. In the catalog, select the custom end plate connection you want to add. Tekla Structures displays instructions on the status bar.
3. Select the column as the main part.
4. Select the beam as the secondary part.

   Tekla Structures adds the end plate connection to the model.

See also

Add or move a custom part in the model (page 262)

8.8 Add or move a custom part in the model

Use the direct modification handles and dimensions when you add or move custom parts. If you are unable to select custom parts in the model, ensure that the Select components selection switch is active.

NOTE

This method cannot be used when adding custom parts to surfaces that have cuts or edge chamfers. You need to hide the cutting parts and edge chamfer objects from the view before you add custom parts on cut or chamfered surfaces using direct modification.

We do not recommend using this method with custom parts that are parametric, and in which the input points define the dimensions of the custom part. The preview is simplified, based on the default custom part dimensions, and snapping has a different focus than usually.

1. Ensure that Direct modification is switched on.

2. Click the Applications & components button in the side pane to open the Applications & components catalog.

3. In the catalog, select the custom part you want to add.

4. Move the mouse pointer over part faces and edges in the model, and see how the custom part turns over and adjusts to the part faces.

   If you are adding the custom part to another part, Tekla Structures shows location dimensions from the first input point of the custom part to the nearest part faces.

   If you are adding a custom part that has only one input point, press Tab to rotate it in 90-degree steps around the work plane Y axis.

5. Depending on the number of custom part input points, pick one or two points to place the custom part in the model.

   Tekla Structures shows the coordinate axes, rotation handles, and location dimensions that you can use to fine-tune the location and rotation of the
custom part. The handles are red, green, and blue, according to the local coordinate system of the custom part.

6. Click the middle mouse button to confirm the location and rotation. Tekla Structures adds the custom part to the model.

7. To move the custom part along any of its coordinate axes, drag the relevant axis handle to a new location.

8. To rotate the custom part around any of its coordinate axes, drag the relevant rotation handle to a new location.
Press **Tab** to rotate the custom part in 90-degree steps in the direction of the selected rotation handle.

9. To move or rotate the custom part by specifying a distance or angle:
   a. Select an axis handle, a rotation handle, or a dimension arrowhead.
   b. Type the value by which you want the dimension to change.
      When you start typing, Tekla Structures displays the **Enter a Numeric Location** dialog box.
   c. Click **OK** to confirm the new dimension.

10. To stop modifying, press **Esc**.

### 8.9 Import and export custom components

You can import and export custom components as `.ueI` files between models.

**TIP** You can share your custom components in Tekla Warehouse, and also download custom components made by other users.

**Export custom components**

You can export custom components in a `.ueI` file.

1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.
2. In the catalog, select the custom components you want to export.
3. Right-click the selection, and then select **Publish**.
5. Enter a name for the export file.
   The file name extension is .uel. Do not change the file name after
   exporting the custom component. If the file name differs from the name
   in the Applications & components catalog, it may be difficult to find the
   right component later on.
6. Click Save to export the custom components.

   **TIP** If you want to export custom components as separate files, select
   the custom components in the Applications & components
   catalog, right-click, and then select Publish separately.

**Import custom components**
You can import previously made custom components to another model.

1. Click the Applications & components button in the side pane to
   open the Applications & components catalog.
2. Click the Access advanced features button, and then select Import.
   The location depends on where you saved the file when you exported the
   custom component.
4. Select the export file.
5. Click Open to import the custom components.

   **TIP** You can import custom components to a new model automatically
   by using the XS_UEL_IMPORT_FOLDER advanced option. Export all
   custom components to certain folders and enter these folders as
   the value for the XS_UEL_IMPORT_FOLDER advanced option to
   easily import the custom components to new models.

**8.10 Custom component settings**
Here you will find more information about the various custom component
properties and plane types.
• **Custom component properties (page 266)**
  You must define these properties when you create new custom components. You can change some of these properties when you modify an existing custom component.

• **Default properties of a custom component (page 269)**
  Each custom component has a dialog box that you can modify. By default, the dialog box has a **Position** tab for custom parts and a **General** tab for custom connections, details, and seams.

• **Plane types (page 274)**
  When you create distance variables for a custom component, you must select a plane type. The plane type defines what planes you can select.

• **Variable properties (page 277)**
  Use the **Variables** dialog box to define properties for distance and parametric variables.

---

### Custom component properties

You must define these properties when you create new custom components with the **Custom Component Wizard**. You can change some of these properties when you modify an existing custom component.

For more information, see Create a custom component (page 157) and Modify a custom component (page 170).

---

### Type/Notes tab properties

On the **Type/Notes** tab, you have the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Type**       | Select the type of the custom component.  
Type affects how you insert the custom component in the model. Type also defines if the custom component connects to existing parts. |
| **Name**       | Enter a unique name for the custom component.                               |
| **Description**| Enter a short description for the custom component. Tekla Structures shows the description in the **Applications & components** catalog. |
| **Component identifier** | Enter an additional name or reference for the component, for example a design code reference. |
This can be shown in general arrangement and assembly drawings, and in lists. To show this in drawings, include **Code** in the **Connection Mark Properties** dialog box.

**Position tab properties**

On the **Position** tab, you have the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Up direction</strong></td>
<td>Sets the default up direction.</td>
<td>Not available for parts.</td>
</tr>
<tr>
<td><strong>Position type</strong></td>
<td>The position (or origin) of the component, relative to the main part.</td>
<td>Not available for details and parts.</td>
</tr>
</tbody>
</table>

You can define the position for custom connections and seams. You have the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Middle</strong></td>
<td>Where the center lines of the main and secondary parts intersect.</td>
<td><img src="middle.png" alt="Diagram" /></td>
</tr>
<tr>
<td><strong>Box plane</strong></td>
<td>Where the main part bounding box and the center line of the secondary part intersect.</td>
<td><img src="box-plane.png" alt="Diagram" /></td>
</tr>
<tr>
<td><strong>Collision plane</strong></td>
<td>Where the main part and the center line of the secondary part intersect.</td>
<td><img src="collision-plane.png" alt="Diagram" /></td>
</tr>
<tr>
<td><strong>End plane</strong></td>
<td>Where the center line of the secondary part hits the end of the main part.</td>
<td><img src="end-plane.png" alt="Diagram" /></td>
</tr>
</tbody>
</table>
**Option** | **Description** | **Example**
---|---|---
Gusset plane | Where the center lines of the main part and the first secondary part intersect. The x direction is perpendicular to the center line of the main part. | ![Gusset plane example](image)

**Advanced tab properties**
On the **Advanced** tab, you have the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Detail type</strong></td>
<td>Determines on which side of the main part the component is located. The options are:</td>
<td>Only available for details and seams</td>
</tr>
<tr>
<td>• Intermediate detail</td>
<td>Tekla Structures creates all components on the same side of the main part</td>
<td></td>
</tr>
<tr>
<td>• End detail</td>
<td>Tekla Structures creates all components on the side of the main part closest to the details</td>
<td>Only affects asymmetric components.</td>
</tr>
<tr>
<td><strong>Definition point position in relation to primary part</strong></td>
<td>Determines the position you pick to create the detail, relative to the main part.</td>
<td>Only available for details</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Note</td>
</tr>
<tr>
<td>----------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Definition point position in relation to secondary part</strong></td>
<td>Determines where the component is created, relative to the secondary part.</td>
<td>Only available for connections and seams</td>
</tr>
<tr>
<td><strong>Allow multiple instances of connection between same parts</strong></td>
<td>Select this option to create many components to the same main part, in different locations.</td>
<td>Only available for connections and seams</td>
</tr>
<tr>
<td><strong>Exact positions</strong></td>
<td>Select this option to position the seam based on the positions that you pick in the model. Clear the check box to let Tekla Structures use automatic seam recognition to position the seam. This is useful especially with warped seams.</td>
<td>Only available for seams</td>
</tr>
<tr>
<td><strong>Use the center of the bounding box in positioning</strong></td>
<td>Select to position the custom part based on the center of its bounding box (the box that surrounds the actual part profile).</td>
<td>Only available for parts</td>
</tr>
</tbody>
</table>

**Default properties of a custom component**

Each custom component has a dialog box that you can modify. By default, the dialog box has a **Position** tab for custom parts and a **General** tab for custom connections, details, and seams.

For more information, see [Modify the dialog box of a custom component](page 226).

To view the current properties, double-click the custom component in the model.

**Default properties of custom parts**

By default, the dialog box of a custom part has the following options:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>On plane</strong></td>
<td>Changes part location on the work plane.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="image" alt="Middle" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="image" alt="Right" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="image" alt="Left" /></td>
</tr>
<tr>
<td><strong>Rotation</strong></td>
<td>Rotates the part in steps of 90 degrees.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="image" alt="Top" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="image" alt="Below" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="image" alt="Front" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="image" alt="Back" /></td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>--------------</td>
<td>------------------------------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td><strong>At depth</strong></td>
<td>Changes part location perpendicular to the work plane.</td>
<td>Middle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Front</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Behind</td>
</tr>
</tbody>
</table>
| **Show third handle** | Sets the third handle of a nested custom part visible in the desired direction.  
You can bind the third handle in the desired direction and thus force the part to follow the rotation of another part. | None    |
**Default properties of custom connections, details, and seams**

By default, the dialog box of a custom connection, detail, or seam has the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up direction</td>
<td>Indicates how the component is rotated around the secondary part, relative to the current work plane. If there are no secondary parts, Tekla Structures rotates the connection around the main part.</td>
<td></td>
</tr>
<tr>
<td>Position in relation to primary part</td>
<td>The creation point of the component, relative to the main part.</td>
<td>Only available for details.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Note</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Position in relation to secondary part</td>
<td>Tekla Structures automatically places the component according to the selected option.</td>
<td>By default, only available for seams. If you want to use this property in connections, select the <strong>Allow multiple instances of connection between same parts</strong> check box on the <strong>Advanced</strong> tab when you create the component.</td>
</tr>
<tr>
<td>Place to picked positions</td>
<td>Select this option to place the seam at the points you pick.</td>
<td>Only available for seams.</td>
</tr>
<tr>
<td>Detail type</td>
<td>Determines on which side of the main part the component is located. The options are:</td>
<td>Only available for details.</td>
</tr>
</tbody>
</table>
|                                      | • **Intermediate detail**  
  Tekla Structures creates all components on the same side of the main part.                                                                                                                                |                                                                      |
|                                      | • **End detail**  
  Tekla Structures creates all components on the side that is closest to the details.                                                                                                                 | Only affects asymmetric components.                                  |
<p>| Locked                               | Select Yes to prevent other users from modifying the properties.                                                                                                                                              |                                                                      |
| Class                                | The class of the parts that the custom component creates.                                                                                                                                                     |                                                                      |
| Connection code                      | Identifies the component. You can display this connection code in connection marks in drawings.                                                                                                               |                                                                      |
| AutoDefaults rule group              | The rule group used for setting the connection properties.                                                                                                                                                    |                                                                      |</p>
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>AutoConnection rule</td>
<td>The rule group Tekla Structures uses to select the connection.</td>
<td></td>
</tr>
<tr>
<td>group</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Plane types**

When you add distance variables to a custom component, you must select a plane type. The plane type defines what planes you can select.

You have the following options:

<table>
<thead>
<tr>
<th>Plane type</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary planes</td>
<td>You can select the edges of a bounding box that surrounds the profile.</td>
<td><img src="example1.png" alt="Example" /></td>
</tr>
<tr>
<td>Center planes</td>
<td>You can select the center planes of a profile.</td>
<td><img src="example2.png" alt="Example" /></td>
</tr>
</tbody>
</table>

Custom components 274 Custom component settings
<table>
<thead>
<tr>
<th>Plane type</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outline planes</td>
<td>You can select the outer and inner surfaces of a profile.</td>
<td><img src="image" alt="Outline planes Example" /></td>
</tr>
<tr>
<td>Cut planes</td>
<td>If the part contains line, part, or polygon cuts, this option enables you to select cut surfaces. Fittings cannot be selected.</td>
<td><img src="image" alt="Cut planes Example" /></td>
</tr>
<tr>
<td>Component planes</td>
<td>What you can select depends on the component type and the Position type of the custom component.</td>
<td><img src="image" alt="Component planes Example" /></td>
</tr>
</tbody>
</table>

**Examples of component planes**

See below for examples of possible component planes. What you can select depends on the component type and the Position type of the custom component.

**Part component planes**

![Part component planes Example](image)
Connection component planes

Custom components 276 Custom component settings
Variable properties

Use the **Variables** dialog box to view, modify, and create parametric variables, and to view fixed and reference distance variables.

Tekla Structures uses variables with custom components (page 172), sketched cross sections (page 71), and parametric modeling. The examples below are
given for custom components, but the same principles apply also to sketched cross sections and parametric modeling.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>A unique name of a variable. Use this name to refer to the variable in the custom component editor. The maximum length is 19 characters.</td>
</tr>
<tr>
<td>Formula</td>
<td>Use this box to enter a value or a formula (page 191). Formulas begin with =.</td>
</tr>
<tr>
<td>Value</td>
<td>Shows the current value of Formula.</td>
</tr>
<tr>
<td>Value type</td>
<td>Select a value type from the list. The type determines what kind of value you can enter for the variable.</td>
</tr>
<tr>
<td>Variable type</td>
<td>This property can be either Distance or Parametric.</td>
</tr>
<tr>
<td>Visibility</td>
<td>Use this setting to control the visibility of a variable. Set to Show to display the variable in the custom component dialog box.</td>
</tr>
<tr>
<td>Label in dialog box</td>
<td>The name of the variable that Tekla Structures displays in the custom component dialog box. The maximum length is 30 characters.</td>
</tr>
</tbody>
</table>

**Value types**

You have the following options for the value type:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number</td>
<td>A whole (integer) number. Use for quantity and multiplier.</td>
</tr>
<tr>
<td>Length</td>
<td>A decimal (floating point) number. Use for lengths and distances. Length numbers have unit (mm, inch, etc.) and they are rounded to two decimal places.</td>
</tr>
<tr>
<td>Text</td>
<td>A text (ASCII) string.</td>
</tr>
<tr>
<td>Factor</td>
<td>A decimal value without a unit. You can set the number of decimals for the value type in File menu --&gt; Settings --&gt; Options --&gt; Units and decimals.</td>
</tr>
<tr>
<td>Angle</td>
<td>A decimal number type for storing angles, stored to one decimal place, in radians.</td>
</tr>
<tr>
<td>Material</td>
<td>A data type associated with the material catalog. Use to select a material from the standard material dialog.</td>
</tr>
<tr>
<td>Profile</td>
<td>A data type associated with the profile catalog. Use to select a profile from the standard profile dialog.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Bolt size</strong></td>
<td>Data types linked to the bolt catalog. <strong>Bolt size</strong> works with <strong>Bolt standard</strong>. They have a fixed naming format: Px_diameter and Px_screwdin. Do not change the fixed name. To show values for these in the component’s dialog box, x must be the same for both, for example, P1_diameter and P1_screwdin.</td>
</tr>
<tr>
<td><strong>Bolt standard</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Bolt type</strong></td>
<td>For determining the bolt type (site/workshop) in the custom component dialog box. Linked to the <strong>Bolt type</strong> property of bolts in the Custom component browser.</td>
</tr>
<tr>
<td><strong>Stud size</strong></td>
<td>Data types linked to the bolt catalog. <strong>Stud size, Stud standard</strong> and <strong>Stud length</strong> work together. They have a fixed naming format: Px_size, Px_standard and Px_length. Do not change the fixed names. To show values for these in the component’s dialog box, x must be the same for all of them. For example, P9_size, P9_standard, and P9_length.</td>
</tr>
<tr>
<td><strong>Stud standard</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Stud length</strong></td>
<td></td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Distance list</td>
<td>Use with options that have several length values, such as bolt spacings. Use space as a separator between the distances.</td>
</tr>
<tr>
<td>Weld type</td>
<td>A data type for selecting the weld type.</td>
</tr>
<tr>
<td>Chamfer type</td>
<td>A data type for determining the shape of a chamfer. For more information, see Corner chamfer types and dimensions.</td>
</tr>
<tr>
<td>Welding site</td>
<td>A data type for determining the welding place: workshop or building site.</td>
</tr>
<tr>
<td>Rebar grade</td>
<td>Data types linked to reinforcement catalog. <strong>Rebar grade</strong>, <strong>Rebar size</strong>, and <strong>Rebar bending radius</strong> work together. They have a fixed naming format: $P_x$ grade, $P_x$ size, and $P_x$ radius. Do not change the fixed name.</td>
</tr>
<tr>
<td>Rebar size</td>
<td></td>
</tr>
<tr>
<td>Rebar bending radius</td>
<td>To show values for these in the component's dialog box, $x$ must be the same for all, for example, $P_1$ grade, $P_1$ size, and $P_1$ radius.</td>
</tr>
<tr>
<td>Rebar hook type</td>
<td>Used for rebar set end detail modifiers, to specify the hook type.</td>
</tr>
<tr>
<td>Rebars to split</td>
<td>Used for rebar set splitters, to specify how the bars are to be split (1/1, 1/2, and so on).</td>
</tr>
<tr>
<td>Rebar stagger type</td>
<td>Used for rebar set splitters, to specify the stagger type (left/right/middle).</td>
</tr>
<tr>
<td>Rebar lap side</td>
<td>Used for rebar set splitters, to specify the side of the overlap (left/right/middle).</td>
</tr>
<tr>
<td>Rebar lap placement</td>
<td>Used for rebar set splitters, to determine whether the lapping bars are parallel to each other or on top of each other.</td>
</tr>
<tr>
<td>Rebar lap type</td>
<td>Used for rebar set splitters, to determine whether the reinforcing bars are kept straight at lap splices by offsetting entire bars, or placed slanted by offsetting bar ends.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Reinforcement mesh</td>
<td>For determining meshes in custom components. Linked to the <strong>Catalog name</strong> property of reinforcement meshes in the <strong>Custom component browser</strong>.</td>
</tr>
<tr>
<td>Cross bar location</td>
<td>Used for rebar meshes, to determine whether the crossing bars are located above or below the longitudinal bars.</td>
</tr>
<tr>
<td>Component name</td>
<td>Use <strong>Component name</strong> for replacing a sub-component inside a custom component with another sub-component. Linked to the <strong>Name</strong> property of objects in the <strong>Custom component browser</strong>.</td>
</tr>
<tr>
<td>Component attribute file</td>
<td>Use <strong>Component attribute file</strong> for setting the properties of a sub-component inside a custom component.</td>
</tr>
<tr>
<td></td>
<td><strong>Component name</strong> and <strong>Component attribute file</strong> work together. They have a fixed naming format: Px_name and Px_attrfile. Do not change the fixed name.</td>
</tr>
<tr>
<td></td>
<td>To show values for these in the component's dialog box, x must be the same for both, for example, P2_name and P2_attrfile.</td>
</tr>
<tr>
<td>Yes/No</td>
<td>For determining whether or not Tekla Structures creates an object in a custom component. Linked to the <strong>Creation</strong> property of objects in the <strong>Custom component browser</strong>.</td>
</tr>
<tr>
<td>Bitmask</td>
<td>For defining bolt assembly (nuts and washers) and parts with slotted holes. Linked to the <strong>Bolt structure</strong> and <strong>Parts with slotted holes</strong> properties of bolts in the <strong>Custom component browser</strong>.</td>
</tr>
<tr>
<td></td>
<td>The value is a five-digit series of ones and zeros. This relates to the check boxes in the <strong>Bolt Properties</strong> dialog box. 1 means that a check box is selected, 0 means that a check box is clear.</td>
</tr>
<tr>
<td></td>
<td>In the example below, the value of 10010 means that a bolt with a washer and a nut is created in the bolt assembly.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
</tbody>
</table>

### 8.11 Hints and tips for using custom components

Here you will find some useful tips on how to create and use custom components more efficiently.

- **Tips for creating custom components (page 282)**
  Follow these guidelines when creating new custom components.

- **Tips for sharing custom components (page 283)**
  Follow these guidelines when sharing custom components with colleagues.

- **Tips for updating custom components to a new version (page 283)**
  When you start using a new version of Tekla Structures, always check that custom components created in older versions work correctly in the new version.

#### Tips for creating custom components

Follow these guidelines when creating new custom components.

- **Enter short, logical names for custom components.**
  Use the description field to describe the component and to explain what it does.

- **Create simple components for specific situations.**
  Simple components are easier and faster to model, and also much easier to use. Avoid creating a single, complex component which you will use for every possible purpose.
• **Consider creating a separate component model.**
  Use that model when you create and test custom components.

• **Use the simplest part you can.**
  For example, if all you need is a rectangular shape, use a rectangular plate, not a contour plate. Rectangular plates only have two handles, so you only need to create a few bindings to manipulate them. Contour plates require more bindings because they have four handles.

1. Rectangular plate
2. Contour plate

• **Model parts only as accurately as you need.**
  If the only part information required is a part mark in a general arrangement drawing, plus a quantity on a materials list, create a simple bar or plate. If you need to include the part in a detailed view later on, simply re-model the part more accurately at that point.

• **Model embeds as custom parts and include them in components.**

**Tips for sharing custom components**
Follow these guidelines when sharing custom components with colleagues.

• **Use Tekla Warehouse to share and store custom components.**

• **Provide essential information.**
  If you distribute your component to other users, remember to list the profiles it works with.

• **Use fixed profiles whenever possible.**

• **If your custom component contains user-defined profile cross sections, remember to include them when you copy the custom component to a new location.**
Tips for updating custom components to a new version
When you start using a new version of Tekla Structures, always check that custom components created in older versions work correctly in the new version.

When you edit custom components created with an older version of Tekla Structures, and the new version contains improvements that require an update, Tekla Structures asks whether you want to update the component. If you do not update the component, it works in the same manner as in the version where it was originally created, but you do not gain the benefits of the new improvements.

If you choose to update the component, you need to check and sometimes recreate dimensions depending on the improvements. When you delete a dimension and create a new one (even with the same name), the equations that contain the dimension also need to be modified, because the dependency created by the equation is lost when a dimension is deleted. You can recreate dimensions and modify equations in the custom component editor.
Disclaimer

© 2017 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced Software. Use of the Software, and use of this Software Manual are governed by a License Agreement. Among other provisions, the License Agreement sets certain warranties for the Software and this Manual, disclaims other warranties, limits recoverable damages, defines permitted uses of the Software, and determines whether you are an authorized user of the Software. All information set forth in this manual is provided with the warranty set forth in the License Agreement. Please refer to the License Agreement for important obligations and applicable limitations and restrictions on your rights. Trimble does not guarantee that the text is free of technical inaccuracies or typographical errors. Trimble reserves the right to make changes and additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by international treaties. Unauthorized reproduction, display, modification, or distribution of this Manual, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve, Fastrak and Orion are either registered trademarks or trademarks of Trimble Solutions Corporation in the European Union, the United States, and/or other countries. More about Trimble Solutions trademarks: http://www.tekla.com/tekla-trademarks. Trimble is a registered trademark or trademark of Trimble Inc. in the European Union, in the United States and/or other countries. More about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product and company names mentioned in this Manual are or may be trademarks of their respective owners. By referring to a third-party product or brand, Trimble does not intend to suggest an affiliation with or endorsement by such third party and disclaims any such affiliation or endorsement, except where otherwise expressly stated.

Portions of this software:

D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved.
EPM toolkit © 1995-2006 Jotne EPM Technology a.s., Oslo, Norway. All rights reserved.

Open Cascade Express Mesh © 2015 OPEN CASCADE S.A.S. All rights reserved.

PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

Teigha © 2002-2016 Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

FlexNet Publisher © 2014 Flexera Software LLC. All rights reserved.

This product contains proprietary and confidential technology, information and creative works owned by Flexera Software LLC and its licensors, if any. Any use, copying, publication, distribution, display, modification, or transmission of such technology in whole or in part in any form or by any means without the prior express written permission of Flexera Software LLC is strictly prohibited. Except where expressly provided by Flexera Software LLC in writing, possession of this technology shall not be construed to confer any license or rights under any Flexera Software LLC intellectual property rights, whether by estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures, click File menu —> Help —> About Tekla Structures and then click the 3rd party licenses option.

The elements of the software described in this Manual are protected by several patents and possibly pending patent applications in the United States and/or other countries. For more information go to page http://www.tekla.com/tekla-patents.
Custom Inquiry tool attributes.............. 30
keyboard shortcuts.................................... 26
message files.......................................... 134
ribbons.................................................. 8
user-defined attributes.......................... 138
custom
ribbons.................................................. 20
tabs...................................................... 22
cut planes.............................................. 274
cyclic dependencies............................... 205
defining
cross sections........................................... 61,62,64
weld cross sections................................. 31
deleting
bolt assemblies........................................ 117
bolts from catalog..................................... 116
material grades....................................... 106
profiles.................................................. 52
shapes.................................................. 101
dependencies
in variable formulas.............................. 205
details
custom details.......................................... 146,152
dialog boxes
modifying................................................. 226
dialog editor............................................. 226
dimensions
horizontal............................................... 82
in sketching............................................. 80,81,82,83
vertical................................................... 83
distance variables.................................... 172,173
distance
reference distance.................................... 183
distributing
custom ribbons.......................................... 20
custom tabs.............................................. 22
DWG profile to library (6)......................... 64
properties.............................................. 65

e
editing
custom components................................. 170
editors
Custom component dialog editor............... 226
environment.db......................................... 139
environment
database file.......................................... 139
tables
e
adding option to create object in custom component.............................. 208
adding user attributes to profiles........... 49
component planes..................................... 275
creating custom connection...................... 163
creating parametric variable.................... 207
creating user-defined attribute................ 140
determining bolt group distance from beam flange................................. 216
determining bolt size and bolt standard.................................................... 215
determining number of bolt rows in custom component............................ 218
exploding components.............................. 163
modifying custom component dialog box.................................................. 237
modifying dialog box of stiffener detail................................................. 237
nested components.................................... 166
profile export file..................................... 56
replacing sub-components in custom component....................................... 209
sub-components....................................... 166
updating user-defined attribute................ 140
using construction planes in custom component....................................... 212
using Excel spreadsheets with custom components................................. 224
using properties file in custom component............................................. 211
using template attributes in custom components.................................... 211
using user-defined attributes in custom components.............................. 220
Excel
using with custom components.................. 224
exploding components............................. 160
exporting
bolt assemblies........................................ 120
bolts...................................................... 117,119,122
custom components................................. 264
keyboard shortcuts.................................. 26
modifying
  bolt assembly information................... 117
  bolt information................................ 115
  cross sections.................................. 65
  custom components............................ 157,170
  material grades.................................. 105
  profile with variable cross sections....... 96
  profiles............................................. 69
  rules................................................ 47
  sketched profiles.............................. 90
move
  command buttons................................. 8

N
  nested
    components..................................... 160,166
  non-solid.......................................... 99

O
  operators.......................................... 191
  Organizer
    customize......................................... 130
  outline planes.................................... 274

P
  parallel constraints............................ 76
  parametric profiles............................. 69,97
    creating.......................................... 70
  parametric variables............................ 172
    creating.......................................... 186
    linking........................................... 186
  parts
    custom parts..................................... 146,148
    defining the material of profile types... 51
  passwords
    protecting custom components............... 171
  perpendicular constraints..................... 76
  phases............................................... 31
  plane types........................................ 274
  polylines.......................................... 74
  positioning planes.............................. 84,85,86
    moving............................................. 87
    reverting to default............................ 88
  profile catalog, see profiles................. 45
  Profile cross section from plate (10)....... 62
  properties.......................................... 63
  profiles
    adding rules...................................... 47
    adding user attributes......................... 48
    adding user attributes to profiles.......... 49
    associating with certain material.......... 51
    converting........................................ 69
    copying........................................... 68
    creating.......................................... 60,66,70
    creating image of profile..................... 97
    defining cross sections. 60,61,62,63,64,65
    deleting.......................................... 52
    exporting.......................................... 53,55
    fixed............................................... 66,68,69
    grouping.......................................... 46,47
    importing.......................................... 53,54
    importing and exporting....................... 57
    modifying.......................................... 69
    profile catalog.................................. 45
    Profile Editor.................................... 94
    profile export file.............................. 56
    rules................................................ 46
    saving changes................................... 45
    sketching......................................... 70
    user-defined...................................... 60
    with variable cross sections............... 93,94,96
  properties
    bolt assembly catalog......................... 127
    bolt catalog...................................... 126
    Custom Component Wizard..................... 266
    custom components............................. 269
    DWG profile to library (6).................... 65
    Profile cross section from plate (10)..... 63
    variable properties................................ 277
  radial dimensions................................ 80
  reference distance variables................ 172,183
remove
  weld cross sections............................ 31
resizes
  command buttons.................................. 8
revert
  to default positioning planes................ 88
ribbons
backing up.................................................. 8
customizing...........................................8,20
restoring..................................................... 8
rules
in profile catalog............................................. 46,47
profile catalog rules........................................ 47

S

saving
custom component...............................225
profiles......................................................45
sketched profiles......................................... 89
seams
custom seams............................................ 146,154
settings
bolt assembly catalog properties.................127
bolt catalog properties..................................126
custom components........................................ 265
dialog editor settings.....................................259
shape catalog.............................................98,99,100,101
shapes
deleting.....................................................101
exporting...................................................100
importing....................................................99
shape catalog.............................................98
shortcuts, see keyboard shortcuts..................26
shortcuts
creating....................................................135
showing
positioning planes........................................ 86

sketch editor............................................... 71
sketched profiles..........................................70
addings constraints.............................. 75,76,77,78,79
adding dimensions............................ 80,81,82,83
arcs.............................................................74
chamfers.................................................... 90
checking.......................................................89
circles.........................................................74
deleting constraints................................. 79
deleting dimensions................................. 83
exporting.....................................................59
extrusion types........................................... 92
importing.....................................................59
modifying....................................................90
polylines......................................................74
positioning planes................................. 84,85,86,87,88
refining the shape........................................ 75
saving........................................................89
setting the thickness...................................91
Sketch Browser............................................ 72
sketch editor............................................... 71
sketching the outline................................... 73
using in model.............................................93
variables.....................................................73
sketching, see sketched profiles.....................70
solid...........................................................99
standardized values
for parametric profiles.................................97
studs..........................................................114
sub-components...........................................160
examples...................................................166

T

tabs...............................................................8
importing custom tabs...................................22
Tekla Open API............................................ 144
testing
sketched profiles......................................... 89
thickness
sketch thickness.......................................... 91
thumbnail image
of custom component.....................................162
tips
creating custom components......................282
custom components in new Tekla
Structures version.........................................283
sharing custom components.......................283
toggle_group................................................ 233

U

units
in importing and exporting......................... 57
updating
user-defined attributes in model.............. 139
updating
material catalog........................................103
profile catalog........................................... 45
user attributes
adding to material grades...........................106
to profiles.................................................. 48
user-defined attributes
customizing.............................................138
environment.db.....................................139
example..................................................140
updating in model.....................................139
user-defined material symbols
  creating...............................................107
user-defined profiles................................60
user-defined weld cross sections.................31
user-defined
  commands...............................................8

V
value types.............................................277
variable cross sections..............................93
variable formulas......................................191
variables
  creating dependencies.............................186
  dependencies.........................................205
  distance variables..................................173
  in custom components..............................172
  in sketching..........................................73
  parametric variables...............................186
  value types...........................................277
  variable properties................................277
vertical
  constraints..........................................79
  dimensions..........................................83

W
weld cross sections
  defining..............................................31
  removing.............................................31
welds
  defining cross sections...........................31
  removing cross sections............................31
  user-defined cross sections.......................31