Tekla Structures 2016
Basics of Tekla Structures

April 2016

©2016 Trimble Solutions Corporation
## Contents

1. **Start Tekla Structures** ........................................................................................................ 9  
  1.1 What is a blank project........................................................................................................... 11  
  1.2 Check or change your Tekla Structures setup ........................................................................ 12  

2. **Open and create 3D models** .................................................................................................. 13  
  2.1 Open a model....................................................................................................................... 14  
  2.2 Create a new model ............................................................................................................. 15  
  2.3 Create a thumbnail image of a model..................................................................................... 16  
  2.4 Edit project properties........................................................................................................... 16  
  2.5 Save a model ....................................................................................................................... 18  
  2.6 Save the current model ........................................................................................................ 19  
  2.7 Save as a copy with different name or location ................................................................... 19  
  2.8 Save as a model template .................................................................................................... 19  
  2.9 Define autosave settings...................................................................................................... 19  
  2.10 Create model templates .................................................................................................... 20  
  2.11 Create a new model template ............................................................................................ 20  
  2.12 Modify an existing model template ..................................................................................... 21  
  2.13 Download model templates ............................................................................................... 21  
  2.14 Model template options ..................................................................................................... 22  

3. **Get familiar with the user interface** .................................................................................... 23  
  3.1 How to use commands.......................................................................................................... 24  
  3.2 Zoom and rotate the model.................................................................................................... 25  
  3.3 Zoom in and out.................................................................................................................... 25  
  3.4 Rotate the model.................................................................................................................... 26  
  3.5 Pan the model....................................................................................................................... 26  
  3.6 Find commands and dialog boxes....................................................................................... 27  
  3.7 How to use the side pane...................................................................................................... 28  
  3.8 Get instructions..................................................................................................................... 29  
  3.9 Learn the common buttons.................................................................................................... 30  
  3.10 Change the appearance of the ribbon................................................................................... 31  
  3.11 Change the language............................................................................................................ 32  
  3.12 Customize keyboard shortcuts............................................................................................ 33  
  3.13 Default keyboard shortcuts.................................................................................................. 34  
  3.14 Common commands............................................................................................................. 34
<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.15</td>
<td>Rendering options</td>
<td>34</td>
</tr>
<tr>
<td>3.16</td>
<td>Selecting objects</td>
<td>35</td>
</tr>
<tr>
<td>3.17</td>
<td>Snapping</td>
<td>35</td>
</tr>
<tr>
<td>3.18</td>
<td>Copying and moving objects</td>
<td>35</td>
</tr>
<tr>
<td>3.19</td>
<td>Viewing the model</td>
<td>36</td>
</tr>
<tr>
<td>3.20</td>
<td>Checking the model</td>
<td>36</td>
</tr>
<tr>
<td>3.21</td>
<td>Drawings</td>
<td>37</td>
</tr>
<tr>
<td>4</td>
<td>Set up the workspace</td>
<td>39</td>
</tr>
<tr>
<td>4.1</td>
<td>Change units and decimals</td>
<td>39</td>
</tr>
<tr>
<td>4.2</td>
<td>Create grids and grid lines</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td>Create a grid</td>
<td>41</td>
</tr>
<tr>
<td></td>
<td>Modify a grid</td>
<td>42</td>
</tr>
<tr>
<td></td>
<td>Delete a grid</td>
<td>43</td>
</tr>
<tr>
<td></td>
<td>Change the grid color</td>
<td>43</td>
</tr>
<tr>
<td></td>
<td>Add a single grid line</td>
<td>43</td>
</tr>
<tr>
<td></td>
<td>Add a grid line between existing grid lines</td>
<td>43</td>
</tr>
<tr>
<td></td>
<td>Add a grid line between two points</td>
<td>44</td>
</tr>
<tr>
<td></td>
<td>Modify a single grid line</td>
<td>44</td>
</tr>
<tr>
<td></td>
<td>Modify grid line properties</td>
<td>44</td>
</tr>
<tr>
<td></td>
<td>Move a grid line</td>
<td>44</td>
</tr>
<tr>
<td></td>
<td>Stretch, shrink, or incline a grid line</td>
<td>45</td>
</tr>
<tr>
<td></td>
<td>Change a grid line label</td>
<td>45</td>
</tr>
<tr>
<td></td>
<td>Turn grid line stretching off</td>
<td>45</td>
</tr>
<tr>
<td></td>
<td>Deleting a single grid line</td>
<td>46</td>
</tr>
<tr>
<td></td>
<td>Delete a grid line using direct modification</td>
<td>46</td>
</tr>
<tr>
<td></td>
<td>Delete a grid line (alternative method)</td>
<td>46</td>
</tr>
<tr>
<td>4.3</td>
<td>Create model views</td>
<td>46</td>
</tr>
<tr>
<td></td>
<td>Create views</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>Create a basic view of the model</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>Create a view using two points</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>Create a view using three points</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td>Create a view of the work plane</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td>Create grid views</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td>Create a view on a part plane</td>
<td>52</td>
</tr>
<tr>
<td></td>
<td>Create a 3D view of a part</td>
<td>52</td>
</tr>
<tr>
<td></td>
<td>Create default part views</td>
<td>53</td>
</tr>
<tr>
<td></td>
<td>Create an undeformed part view</td>
<td>53</td>
</tr>
<tr>
<td></td>
<td>Create a 3D view of a component</td>
<td>53</td>
</tr>
<tr>
<td></td>
<td>Create default component views</td>
<td>54</td>
</tr>
<tr>
<td></td>
<td>Create a surface view</td>
<td>54</td>
</tr>
<tr>
<td></td>
<td>Create a surface view along selected edge</td>
<td>55</td>
</tr>
<tr>
<td></td>
<td>Open a view</td>
<td>57</td>
</tr>
<tr>
<td></td>
<td>Save a view</td>
<td>57</td>
</tr>
<tr>
<td></td>
<td>Modify a view</td>
<td>58</td>
</tr>
<tr>
<td></td>
<td>Delete a view</td>
<td>58</td>
</tr>
<tr>
<td></td>
<td>Switch between views</td>
<td>58</td>
</tr>
<tr>
<td></td>
<td>Switch between open views</td>
<td>59</td>
</tr>
<tr>
<td></td>
<td>Switch between 3D and plane view</td>
<td>59</td>
</tr>
<tr>
<td></td>
<td>Update and refresh views</td>
<td>59</td>
</tr>
</tbody>
</table>
6.10 Override the current snap switch................................................................. 86
6.11 Example: Place a drawing object at a specified distance....................... 87
6.12 Example: Tracking along a line towards a snap point.................................89

7 Snap to a line............................................................................................92
8 Snap to extension lines..............................................................................93
9 Snap to orthogonal points...........................................................................95
10 Snap relative to previously picked points.................................................96
11 Create a temporary reference point..........................................................98
12 Lock X, Y or Z coordinate.........................................................................100
13 Select objects............................................................................................101
13.1 Select assemblies and cast units..............................................................101
13.2 Select nested objects................................................................................101
13.3 Select reference models, reference model objects and assemblies...........102
13.4 Select an entire reference model..............................................................102
13.5 Select a reference model object...............................................................103
13.6 Select a reference model assembly.........................................................103
13.7 If you cannot select objects......................................................................103
14 Select single objects................................................................................104
15 Select multiple objects...............................................................................105
16 Select all objects........................................................................................107
17 Select handles............................................................................................108
18 Modify the selection..................................................................................109
19 Copy and move objects..............................................................................110
19.1 Copy objects...........................................................................................111
Copy objects using linear array tool..............................................................111
How to use Linear array tool.........................................................................111
How to define the settings.............................................................................112
Copy objects using radial array tool..............................................................113
How to use Radial array tool.........................................................................114
How to define the settings.............................................................................115
Copy objects using Array of objects (29) component....................................116
19.2 Copy by picking two points......................................................................117
19.3 Copy linearly............................................................................................119
19.4 Copy by specifying a distance from origin ................................................. 119
19.5 Copy using drag-and-drop ............................................................................ 120
19.6 Copy objects to another object ................................................................... 120
19.7 Copy all content to another object ............................................................. 120
19.8 Copy to another plane .................................................................................. 121
19.9 Copy from another model ........................................................................... 122
19.10 Move objects .................................................................................................. 122
19.11 Move by picking two points ......................................................................... 122
19.12 Move linearly ................................................................................................. 123
19.13 Move by specifying a distance from origin ................................................. 124
19.14 Move using drag-and-drop ........................................................................... 124
19.15 Move to another plane .................................................................................. 125
19.16 Move objects to another object ................................................................... 125
19.17 Rotate objects ................................................................................................ 126
19.18 Rotate around a line ..................................................................................... 126
19.19 Rotate around the z axis .............................................................................. 127
19.20 Rotate drawing objects ................................................................................ 129
19.21 Mirror objects ................................................................................................ 130
19.22 Mirror model objects .................................................................................... 130
19.23 Mirror drawing objects ................................................................................ 130
20 Filter objects ................................................................................................. 132
20.1 Use existing filters .......................................................................................... 132
20.2 How to use a view filter ................................................................................ 132
20.3 How to use a selection filter .......................................................................... 133
20.4 Create new filters ........................................................................................... 133
20.5 Create a view filter .......................................................................................... 133
20.6 Create a selection filter ................................................................................... 134
20.7 Create a drawing filter ..................................................................................... 135
20.8 Create a drawing view filter .......................................................................... 136
20.9 Possible values in filtering ............................................................................. 137
20.10 Examples of filters ....................................................................................... 138
20.11 Filter beams and columns ........................................................................... 138
20.12 Filter parts in specific phases ..................................................................... 138
20.13 Filter out parts that have a certain profile ............................................... 139
20.14 Filter assemblies and cast units .................................................................. 139
20.15 Filter sub-assemblies .................................................................................... 140
20.16 Filter out reference models ......................................................................... 140
20.17 Filter reference model object properties .................................................. 141
20.18 Copy a filter to another model .................................................................... 141
20.19 Delete a filter ................................................................................................ 142
21 Take screenshots.................................................................................. 143
22 Take a screenshot of a model................................................................. 144
23 Take a screenshot of a drawing.............................................................. 145
24 Save a screenshot in bitmap format..................................................... 146
25 Tips for basic tasks.............................................................................. 147
25.1 Switch rollover highlight on or off .................................................... 148
25.2 Select values from the model............................................................. 149
25.3 Interrupt object selection................................................................... 149
25.4 Select on right-click.......................................................................... 150
25.5 Copy and move efficiently................................................................. 150
25.6 Change a property in several parts at the same time......................... 150
25.7 How to restore missing toolbars....................................................... 151
25.8 Show or hide "Do not show this message again"................................. 151
25.9 Wildcards ......................................................................................... 152
26 Disclaimer........................................................................................... 153
When you start Tekla Structures, you are asked to choose your Tekla Structures setup. The setup consists of an environment, role, and configuration.

- **Environment** means region-specific settings and information. It defines which profiles, material grades, default values, connections, wizards, variables, reports, and templates you have available.

- **Role** is a user group profile that limits the availability of files and settings in an environment. The user interface has been customized for each role.

- **Configuration** consists of a set of features that the user is entitled to based on the license agreement. Each configuration is meant for a specific user group, to suit the various players in the construction industry.

1. Start Tekla Structures by selecting it from the Windows Start menu or by double-clicking the desktop icon.
The **Choose your Tekla Structures setup** dialog box appears.

2. Select an environment.
   
   If you cannot find the desired environment from the list, see Adding an environment to Tekla Structures.
   
   You can also select **Blank project (page 11)** to create a model that contains generic content, such as parametric profiles.

3. Select a role.
   
   The availability of roles depends on your environment, but typically the following roles are available:
   
   • All (a combination of all roles)
   • Concrete Contractor
   • Construction Management
   • Engineer
   • Precast Concrete Detailer
   • Rebar Detailer
   • Steel Detailer

4. Select a configuration.
   
   The configuration you are using may not contain all the features described in the Tekla Structures product guides. For more information on
the features available in each configuration, see Tekla Structures configurations.

5. Click **OK**.

The **Welcome** page appears.

6. Select what you want to do:
   - On the **Recent** tab, you can open a recently used model.
   - On the **Open** tab, you can open any existing model (page 14).
   - On the **New** tab, you can create a new model (page 15).

See also

Check or change your Tekla Structures setup (page 12)

1.1 **What is a blank project**

Blank project is a Tekla Structures environment that includes only generic content, such as parametric profiles and undefined materials. It can be used for gathering region-, company-, or project-specific settings, tools, and information. The blank project is always included in the Tekla Structures installation.
Download and install content

You can use Tekla Warehouse to download and install content to the blank project. For example, you can download profiles, material grades, bolts, reinforcement, components, applications, and templates from Tekla Warehouse across all environment- and manufacturer-specific collections, and make combinations that suit your needs.

You can download and install content from Tekla Warehouse both before and during a project. Before starting a project, you can install content to your project and firm folders. During a project, you can install content to the model folder.

1.2 Check or change your Tekla Structures setup

You can check your current Tekla Structures setup (environment, role, and configuration) at any time without having to close the model.

1. In the File menu, click Settings and scroll down to the License area.
   
   You current setup is displayed.

2. Change the setup if needed.
   
   You may be required to restart Tekla Structures after the changes.
Open and create 3D models

With Tekla Structures, you can create a 3D real-life model of any structure. The model contains all the information that is needed to manufacture and construct the structure: part geometry and dimensions, profiles, materials, connection types, and so on.

- Open a model (page 14)
- Create a new model (page 15)
- Create model templates (page 20)

Model output

The 3D model is also the single source of information for drawings and other outputs, such as reports and NC data files. This ensures that the information in drawings and reports is always up to date, as they react to modifications in the model.

Collaboration

You can use the multi-user mode or Tekla Model Sharing to work collaboratively within a model.
2.1 Open a model

You can have one model open at a time. If you open a model and already have one open, Tekla Structures prompts you to save the first model.

1. On the File menu, click Open.
2. Select the model you want to open.
   - To search for models in another folder, click Browse.
   - To open a recently used model folder, click the Open model from folder list.
   - To sort models by name, date, or type, click the column titles.
   - When the models are sorted alphabetically by their names, you can use the keyboard to select a model. For example, when you type N, Tekla Structures selects the first model starting with an N.
3. Click **Open**.

   If no views (page 46) are visible in the model, Tekla Structures prompts you to select one.

**See also**

Create a new model (page 15)
Create a thumbnail image of a model (page 15)

---

### 2.2 Create a new model

Create a separate model for each Tekla Structures project. Each model is stored in its own folder under the **TeklaStructuresModels** folder.

1. On the **File** menu, click **New**.
2. In the **Name** box, enter a name for the new model.

   Do not use special characters (/ \ ; : | ). We recommend that you try to decide on a permanent name at this point. The name of the model can be changed afterwards, but it involves changing several file names.

3. Define where to save the new model.

   By default, the model is saved in the **TeklaStructuresModels** folder that was created during installation. You can change the default folder by clicking **Browse**. You can also select a recently used folder from the **Save in** list.

4. If you want to use a **model template (page 20)**, select one.

5. Under **Type**, define whether to run Tekla Structures in single-user or multi-user mode.

   - Single-user: the model will be used by one person at a time.
   - Multi-user: the model is stored on a server and may be used by several people simultaneously. Enter the name of the server in the **Server** box.

6. Click **Create**.

   Tekla Structures creates the model and opens the default **model view (page 57)**. The contents of the model view may differ based on the model template you chose in step 4.

**See also**

Create a thumbnail image of a model (page 15)
Edit project properties (page 16)
2.3 Create a thumbnail image of a model

You can add a thumbnail image to make it easier to recognize your project even when you do not remember the exact name of the model. The thumbnail image is displayed when you browse for existing models.

1. On the View tab, click Screenshot --> Project thumbnail.
2. Pick a view.
   Tekla Structures creates the image and saves it in the model folder with the name thumbnail.png.
3. To check the thumbnail, go to the File menu, click Open, and select the model you created the thumbnail for.
   The image is now displayed next to the model name. For example:

   ![Thumbnail Image]

   1st steps europe
   Environment default
   Version 2016
   Modified 15.1.2016 14:48:42
   Language en

4. If you are unhappy with the thumbnail image, you can repeat steps 1–2 as many times as you need.
   For example, you can zoom the model (page 25) in and out to adjust what is shown in the thumbnail image. When you create a new thumbnail, Tekla Structures overrides the existing thumbnail image with the new one.

**TIP** Alternatively, if you want to use a custom image, you can add the image directly to the model folder with the name thumbnail.png. The preferred size of the image is 120 x 74 pixels.

2.4 Edit project properties

You will need project information, such as project number and name, many times during a project. Update the project properties at the beginning of each
project to make reports and drawings display the correct information automatically. All of the fields are optional.

1. On the File menu, click Project properties.
2. Click Edit.
3. In the Description box, enter a description that helps you identify the model when you next need to open it.
   The description appears in the Open dialog box when you open a model.
4. Edit the other project properties.
5. To define project-specific user-defined attributes, click User-defined attributes.
   By default, you can define:
   • Project comment
   • User fields
   • Execution class
   • IFC export attributes
   • GEO coordinates
   • Status attributes
   • Unitechnic factory location
   The availability of user-defined attributes depends on your environment (page 9).
6. Click Apply to save your changes.
Now you will get updated project properties in drawings and reports.
7. If you want to save these properties as the default properties for this project:
   a. Go to Quick Launch (page 27).
   b. Start typing save defaults.
   c. Select the Save Defaults command from the list.
   For more information on saving default properties, see Standard files.

Displaying project information in templates and reports
The fields in the image below refer to template attributes, which you can use when designing your own reports and templates. To display project information, add the corresponding template attributes in the templates and reports.
2.5 **Save a model**

You should save your model regularly to avoid losing any work. Tekla Structures also automatically saves your work at regular intervals.

---

- **Open and create 3D models**
- **Save a model**
2.6 Save the current model
Do one of the following:

- On the top left corner of the screen, click Save.
- On the File menu, click Save -> Save.
- Press Ctrl+S.

2.7 Save as a copy with different name or location
You can create a copy of the model with a different name or in a different folder. The original version of the model remains intact.

**NOTE** When you save the model with a different name, all the GUID object identifiers of the saved model will change and be different than in the original model. This means that the saved model has no relation to the original model, and the saved model cannot be used as backup.

1. On the File menu, click Save -> Save as.
2. In the Model name box, enter a new name.
3. To save in a different location, click Browse and define where you want to save the model.
4. Click OK.

Tekla Structures creates a new copy with a different name, but the original version of the model remains intact.

2.8 Save as a model template
See Create model templates (page 20).

2.9 Define autosave settings
Use Autosave to automatically back up and save your work at set intervals. You can set the autosave interval separately for the model and drawings. Autosave files have the extension .db1_<user>.

1. On the File menu, click Settings --> Options, and go to the General settings.
2. Under Autosave, set the autosave interval.
a. In the first box, define how often Tekla Structures saves the model or drawing.
   This number represents the number of commands you will have to run before Tekla Structures saves the model or drawing. For example, if you create many beams without interrupting the Create beam command, it only counts as one command.

b. In the second box, enter the number of drawings after which Tekla Structures saves your work.

   **NOTE** If you set the interval values to less than 2, autosave is disabled.

3. Click **OK**.

4. Define where to store the **Autosave** files.
   By default, Tekla Structures stores the autosave files in the ..\TeklaStructuresModels\autosave folder. To change the folder, use the advanced option XS_AUTOSAVE_DIRECTORY.

5. Define whether to keep old autosave files.
   By default, Tekla Structures deletes the autosave files when you close a model, to save disk space. To keep autosave files even if you exit Tekla Structures without saving the model, use the advanced option XS_KEEP_AUTOSAVE_FILES_ON_EXIT_WHEN_NOT_SAVING.

### 2.10 Create model templates

Model templates allow you to start a model with predefined company templates and settings. This can be especially useful for sub-contractors.

Only single-user models can be created with model templates. If you wish to create a multi-user model using a model template, create the model in single-user mode and then switch to multi-user mode.

By default, the model template folder is saved in your environment folder. Use the advanced option XS_MODEL_TEMPLATE_DIRECTORY to define a different location.

### 2.11 Create a new model template

You can create your own model templates and use them for creating new models. You can select which catalogs, custom components, model subfolders, drawing templates, and report templates from the model are included in the model template.
1. **Create a new model (page 15).**

   Always start by creating a new empty model. This is because old models that have been used in live projects cannot be completely cleaned. They may contain excess information that increases the size of the model even if you delete all objects and drawings from the model.

2. **Add the desired part properties, drawing properties, profiles, materials, custom components, sketches, and so on, in the model.**

   You can copy the needed attribute files from another model, for example.

3. **On the File menu, click Save --> Save as model template.**

4. **Enter a name for the model template.**

5. **Select which catalogs, drawing templates, report templates, and model subfolders to include in the model template.**

   For more information, see the section **Model template options** on this help page.

   You can only select files and folders that are available in the model folder. Catalogs are typically located in the Environment folder and they are included in the model folder only if they have been modified.

6. **If you want to open the destination folder after creating the model template, select the check box.**

7. **Click OK.**

   You can now use the model template for creating new models.

---

**2.12 Modify an existing model template**

To modify an existing template, save the model as a new template. Alternatively, you can modify the template by copying new or updated files directly to the model template folder.

1. **Create a model using the existing model template.**

2. **Make the needed changes.**

3. **Save it as a new model template.**

---

**2.13 Download model templates**

You can download, share, and store model templates using Tekla Warehouse.
### 2.14 Model template options

Use the **Save as Model Template** dialog box to define which files and folders are included in the model template.

<table>
<thead>
<tr>
<th>Option</th>
<th>Files and folders included</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profiles</td>
<td>profdb.bin</td>
</tr>
<tr>
<td></td>
<td>profitab.inp</td>
</tr>
<tr>
<td>Materials</td>
<td>matdb.bin</td>
</tr>
<tr>
<td>Components and sketches</td>
<td>ComponentCatalog.txt</td>
</tr>
<tr>
<td></td>
<td>ComponentCatalogTreeView.txt</td>
</tr>
<tr>
<td></td>
<td>Xslib.db1</td>
</tr>
<tr>
<td></td>
<td>thumbnail_bitmap.arc</td>
</tr>
<tr>
<td></td>
<td>*.dat files</td>
</tr>
<tr>
<td></td>
<td>CustomComponentDialogFiles folder</td>
</tr>
<tr>
<td>Attribute definitions</td>
<td>Includes all attribute definitions of the current model.</td>
</tr>
<tr>
<td>Bolts and bolt assemblies</td>
<td>screwdb.db</td>
</tr>
<tr>
<td></td>
<td>assd.db</td>
</tr>
<tr>
<td>Reinforcement</td>
<td>rebar_database.inp</td>
</tr>
<tr>
<td></td>
<td>RebarShapeRules.xml</td>
</tr>
<tr>
<td></td>
<td>rebardatabase_config.inp</td>
</tr>
<tr>
<td></td>
<td>rebardatabase_schedule_config.inp</td>
</tr>
<tr>
<td>Meshes</td>
<td>mesh_database.inp</td>
</tr>
<tr>
<td>Options</td>
<td>Includes all options of the current model.</td>
</tr>
<tr>
<td>Drawing templates</td>
<td>*.tpl files</td>
</tr>
<tr>
<td>Report templates</td>
<td>*.rpt files</td>
</tr>
<tr>
<td>Include model subfolders</td>
<td>Lists all subfolders found in the model folder. The selected</td>
</tr>
<tr>
<td></td>
<td>folders are included in the model template. The <strong>attributes</strong></td>
</tr>
<tr>
<td></td>
<td>folder, which contains part and drawing properties, is included</td>
</tr>
<tr>
<td></td>
<td>by default.</td>
</tr>
</tbody>
</table>
1. This is your Tekla Structures model. If you are starting a completely new project, you will only see the default model view (page 46) and an empty grid (page 40) at this point.

2. The box around the grid represents the work area. In a view, you can only see the parts that are within this area. Objects that are outside the work area exist in the model, but they are not visible. You can shrink and expand the work area (page 61) to suit your needs. You can also hide the work area box (page 61).
3. The coordinate symbol with the three axes x, y, and z represents the local coordinate system (page 63). It also indicates the direction of the model.

4. The green cube symbol represents the global coordinate system (page 63) and it lies at the global origin (x=0, y=0, z=0).

5. The ribbon contains all the commands (page 24) and other functions you will use when building your model. You can hide some tabs (page 31) if you do not need them in your current project.

6. If you cannot find the command you are looking for, search with Quick Launch (page 27).

7. When you create objects (page 24), the status bar (page 29) will tell you how to proceed and when to pick points.

8. The File menu is where you manage your models. You can save models (page 18), print drawings, and import and export models, among other things.

9. The selection switches (page 73) control which objects you can select.

10. The snap switches (page 80) control which positions you can pick when creating objects.

11. Use the side pane (page 28) on the right-hand side of the screen to add reference models and components.

### 3.1 How to use commands

Learn the basic method of running and ending commands. All commands throughout Tekla Structures work in the same manner.

1. To find commands, slide the ribbon right or left with your mouse.
   
   Some commands have more options under them. Click the shaded area to see the rest of the options:

   ![Command Ribbon](image)

2. If you are unsure which command you need for your current task, rest the mouse pointer on a command.
A small window called tooltip appears. Tooltips provide more information about commands and also give examples, hints, and tips. For example:

```
Measure distance (F)
Measure the distance between any two points. Use this command to measure inclined or aligned distances. By default, the results contain the distance and the coordinates. Follow the instructions on the status bar.
```

When a tooltip is open, you can press **Ctrl+F1** for more help on the subject.

3. When you find the command you need, click once to use it.

The command runs until you end it or use another command.

**NOTE** If you want to check or change the object properties before running the command, hold down the **Shift** key when you click the command. This brings up the properties dialog box. If you modify the properties, remember to save the changes (page 30).

4. To end a command, right-click and select **Interrupt**.

You can also press **Esc**.

5. To re-activate the last command, press **Enter**.

**See also**

Create and modify objects (page 69)

### 3.2 Zoom and rotate the model

The commands on the **View** tab allow you to focus on a particular area, or pull out for a wider view. You can use a mouse, command, keyboard shortcut, or a combination of these.

### 3.3 Zoom in and out

You can use a variety of tools to zoom in and out in the model. By default, the mouse pointer position determines the center point of zooming.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Scroll forward with the mouse wheel.</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Scroll backward with the mouse wheel.</td>
</tr>
<tr>
<td>Zoom to selected objects</td>
<td>1. Select the objects.</td>
</tr>
</tbody>
</table>

Get familiar with the user interface  
25  
Zoom and rotate the model
To | Do this
---|---

2. On the **View** tab, click **Zoom** --> **Zoom selected**.

**Zoom with menu commands**

On the **View** tab, click **Zoom** and select one of the zoom commands.

**Keep the center point of zooming in the middle of the view**

On the **File** menu, click **Settings** and select **Centered zooms**.

**Define the zoom ratio**

Use these advanced options:
- **XS_ZOOM_STEP_RATIO**
- **XS_ZOOM_STEP_RATIO_IN_MOUSEWHEEL_MODE**
- **XS_ZOOM_STEP_RATIO_IN_SCROLL_MODE**

---

### 3.4 Rotate the model

You can use either the middle or left mouse button to rotate the model in a view.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| **Rotate using the middle mouse button** | 1. To set the view point, press `v`, and then pick a position in the view. Tekla Structures rotates the model around this view point.  
2. Hold down the **Ctrl** key, and then click and drag the model with the middle mouse button. |
| **Rotate using the left mouse button** | 1. On the **View** tab, click **Navigate** --> **Rotate with mouse**.  
2. Pick a position in the view. Tekla Structures rotates the model around this view point.  
3. Click and drag the model with the left mouse button. |

---

### 3.5 Pan the model

You can use either the middle or left mouse button to pan the model in a view.
To | Move the model using the middle mouse button
---|---
**Do this** | 1. To activate the middle button pan, go to the File menu, click Settings, and select the Middle button pan check box.  
2. Hold down the middle mouse button and drag the model anywhere within the view.

| Move the model using the left mouse button | **Do this** | 1. On the View tab, click Navigate --> Pan to activate dynamic panning.  
The mouse pointer changes to a hand.  
2. Hold down the left mouse button and drag the mouse anywhere within the view.  
3. To stop panning, press Esc.

3.6 Find commands and dialog boxes

Use the Quick Launch box in the upper-right corner of the Tekla Structures main window to find commands, dialog boxes, and other functions. The shortcut key for Quick Launch is Ctrl+Q.

![](Quick Launch.png)

1. In the Quick Launch box, enter a search term. For example, type bolt if you are looking for bolt commands.

2. Wait for a list of search results to appear. For example:

![](Search Results.png)

Tekla Structures highlights the commands on the ribbon, to help you locate them. For example:
3. To run a command, click its name on the search results list. Or press Enter to instantly run the first command on the list.

**TIP** If the list of search results is no longer visible, press Ctrl+Space to reactivate it.

### 3.7 How to use the side pane

Use the side pane on the right-hand side of the screen to add reference models and components.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show the side pane contents</td>
<td>Click a side pane button. For example, click <img src="image" alt="Applications &amp; components" /> to show the Applications &amp; components catalog.</td>
</tr>
<tr>
<td>Move a side pane window</td>
<td>Click the grab bar <img src="image" alt="Grab bar" /> and drag the side pane window to a new location.</td>
</tr>
</tbody>
</table>
| Keep multiple side pane windows open at the same time | 1. Right-click a side pane button and select Open below.  
2. Repeat for each side pane button. The side pane windows are now stacked on top of each other.  
3. To change the order of side pane windows, drag them around. |
<p>| Adjust the size of a side pane window  | Click and drag the <img src="image" alt="Size adjuster" /> button.                                                                                           |</p>
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dock a floating side pane</td>
<td>Right-click the side pane button and select <strong>Attach to panel</strong>.</td>
</tr>
<tr>
<td></td>
<td>Alternatively, you can drag the side pane back to the docking area, which is marked with yellow color.</td>
</tr>
<tr>
<td>Hide the side pane</td>
<td>Click the &gt; button.</td>
</tr>
<tr>
<td>Hide the side pane</td>
<td><strong>&gt;</strong> button.</td>
</tr>
<tr>
<td>Show the side pane</td>
<td>Click the &lt; button.</td>
</tr>
<tr>
<td>Close the side pane</td>
<td>Click the X button.</td>
</tr>
</tbody>
</table>

### 3.8 Get instructions

*Status bar* is the area located at the bottom of the Tekla Structures main window. Follow the instructions on the status bar when you use commands. For example, when you are creating a part, the status bar will tell you how to proceed and when to pick points.

1. Instructions and error messages
2. The status of **Smart select (S)** and **Drag and drop (D)**
3. The level in assembly or component hierarchy (0–9)
4. The middle mouse button mode (**Pan** or **Scroll**)

---

Get familiar with the user interface 29 Get instructions
5. The current phase
6. The number of selected objects and handles

**Status bar message history**

To view the status bar message history, go to **Quick Launch**, type **Message Panel**, and select the **Message Panel** command from the list that appears. A message panel appears at the bottom of the Tekla Structures window.

![Message Panel](image)

### 3.9 Learn the common buttons

The following table lists some common buttons that can be found in most of the Tekla Structures dialog boxes.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="OK" /></td>
<td>Saves the properties and closes the dialog box. Tekla Structures uses these properties the next time you create an object of this type.</td>
</tr>
<tr>
<td><img src="image" alt="Apply" /></td>
<td>Saves the properties without closing the dialog box. Tekla Structures uses these properties the next time you create an object of this type.</td>
</tr>
<tr>
<td><img src="image" alt="Modify" /></td>
<td>Modifies the selected objects using the current properties of the dialog box.</td>
</tr>
<tr>
<td><img src="image" alt="Get" /></td>
<td>Fills the dialog box with the properties of the selected object. If several objects are being selected, Tekla Structures takes the properties randomly from one of them.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Switches all check boxes in the dialog box on and off.</td>
</tr>
<tr>
<td><img src="image" alt="Cancel" /></td>
<td>Closes the dialog box without saving the properties or modifying objects.</td>
</tr>
<tr>
<td><img src="image" alt="Save" /></td>
<td>Saves the properties in the file shown in the list.</td>
</tr>
<tr>
<td><img src="image" alt="Load" /></td>
<td>Loads the previously saved properties to the dialog box. Tekla Structures also loads the properties of sub-dialogs.</td>
</tr>
<tr>
<td>Button</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| Save as | Saves the properties with the name given in the box. The **Save as** button also updates the **Load** list. This is important if you add or delete files manually.  
Tekla Structures stores the properties files in the model folder, also including the properties of sub-dialog boxes.  
For more information, see **Save and load dialog box properties** (page 78). |

### 3.10 Change the appearance of the ribbon

You can change the order of ribbon tabs, choose how they are aligned, and even hide some parts of the ribbon if you do not need them in your current project. For example, if you are only modeling steel parts, you can temporarily hide the **Concrete** tab. You can also minimize the ribbon to save space on your screen.

1. To change the order of tabs on the ribbon, drag and drop the tab titles.
2. To change how the tabs are aligned, right-click on the top bar of the ribbon, select **Navigation mode**, and then select one of the options.
   - **Scroll visible**: the ribbon movement is minimal when you switch between the tabs
   - **Align to left**: the icons start from the left side of the ribbon
   - **Align to tab**: the icons start from the left side of the current tab
3. To hide the tabs that you do not need in your current project:
   a. Rest the mouse pointer on a tab title.
      A small eye symbol appears next to the tab title:
      ![View](view.png)  
   b. Click the eye symbol  
      The eye symbol changes and the tab title becomes gray:
      ![View](view_2.png)
      The **View** tab is now hidden from the ribbon. If you slide the ribbon, hidden tabs appear as:
c. To re-display the hidden tab, click the eye symbol again.

4. To minimize the ribbon, right-click on the top bar of the ribbon, and then select **Minimize**. The ribbon is now automatically hidden to save space on the screen. When you move the mouse pointer on top of the tab titles, the ribbon reappears.

### 3.11 Change the language

You can change the language of the Tekla Structures user interface at any time.

1. On the **File** menu, click **Settings --> Change language**.
2. Select a language from the list.

You have the following options. The three-letter language codes that are given in parentheses are used in some language-dependent file and folder names.

- Chinese – simplified (chs)
- Chinese – traditional (cht)
- Czech (csy)
- Dutch (nld)
- English (enu)
- French (fra)
- German (deu)
- Hungarian (hun)
- Italian (ita)
- Japanese (jpn)
- Korean (kor)
- Polish (plk)
- Portuguese (ptg)
- Portuguese – Brazilian (ptb)
- Russian (rus)
- Spanish (esp)

3. Click **OK**.
4. Restart Tekla Structures for the change to take effect.

3.12 Customize keyboard shortcuts

You can assign customized keyboard shortcuts to any command, macro, or component. You can also change the default keyboard shortcuts, if needed.

**NOTE** If you are assigning keyboard shortcuts to drawing commands, open a drawing first, to activate the drawing mode.

1. On the **File** menu, click **Settings --> Keyboard shortcuts**.
   The **Keyboard shortcuts** dialog box opens.
2. In the **Group** list, select the shortcut group you want to modify.
   A list of commands and shortcuts appears.
3. If you want to search for a particular command or keyboard shortcut, enter some text in the **Filter** box.
   For example, type **grid** to only see the commands whose name contains the word "grid". Type "+" to get a list of shortcuts that consist of two parts (such as **Ctrl+S**).
4. Select a command from the list.
5. Click **Enter shortcut**.
6. On the keyboard, enter the combination of keys you would like to use as the shortcut.
7. Check the **Conflicts** box to see if the keyboard shortcut is already assigned to another command.
   If the shortcut is already in use, enter a different combination of keys.

**NOTE** If you reassign a keyboard shortcut that is already used, it will no longer be associated with the command it was originally assigned to.

8. Click **Assign** to save the keyboard shortcut.
9. To remove a keyboard shortcut, select the command from the list and click **Clear**.
10. To reset all the keyboard shortcuts to the defaults, click the **Restore** button.
3.13 Default keyboard shortcuts
Tekla Structures contains a large number of keyboard shortcuts that you can use to speed up your work. You can create custom shortcuts and change the default keyboard shortcuts.
For more information, see Customize keyboard shortcuts (page 33).

3.14 Common commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>F1</td>
</tr>
<tr>
<td>Create new model</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Open model</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Save model</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Properties</td>
<td>Alt+Enter</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Interrupt</td>
<td>Esc</td>
</tr>
<tr>
<td>Repeat last command</td>
<td>Enter</td>
</tr>
<tr>
<td>Quick Launch</td>
<td>Ctrl+Q</td>
</tr>
</tbody>
</table>

3.15 Rendering options

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parts wireframe</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>Parts rendered wireframe</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>Parts grayscale</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>Parts rendered</td>
<td>Ctrl+4</td>
</tr>
<tr>
<td>Show only selected part</td>
<td>Ctrl+5</td>
</tr>
<tr>
<td>Components wireframe</td>
<td>Shift+1</td>
</tr>
<tr>
<td>Components rendered wireframe</td>
<td>Shift+2</td>
</tr>
<tr>
<td>Components grayscale</td>
<td>Shift+3</td>
</tr>
<tr>
<td>Components rendered</td>
<td>Shift+4</td>
</tr>
<tr>
<td>Show only selected component</td>
<td>Shift+5</td>
</tr>
</tbody>
</table>
### 3.16 Selecting objects

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollover highlight</td>
<td>H</td>
</tr>
<tr>
<td>Select all selection switch</td>
<td>F2</td>
</tr>
<tr>
<td>Select parts selection switch</td>
<td>F3</td>
</tr>
<tr>
<td>Add to selection</td>
<td>Shift</td>
</tr>
<tr>
<td>Toggle selection</td>
<td>Ctrl</td>
</tr>
<tr>
<td>Select all</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select assembly</td>
<td>Alt+object</td>
</tr>
<tr>
<td>Hide object</td>
<td>Shift+H</td>
</tr>
<tr>
<td>Lock X, Y or Z coordinates</td>
<td>X, Y or Z</td>
</tr>
<tr>
<td>Selection filter</td>
<td>Ctrl+G</td>
</tr>
</tbody>
</table>

### 3.17 Snapping

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snap to reference lines/points</td>
<td>F4</td>
</tr>
<tr>
<td>Snap to geometry lines/points</td>
<td>F5</td>
</tr>
<tr>
<td>Snap to nearest points</td>
<td>F6</td>
</tr>
<tr>
<td>Snap to any position</td>
<td>F7</td>
</tr>
<tr>
<td>Ortho</td>
<td>O</td>
</tr>
<tr>
<td>Relative coordinate input</td>
<td>R</td>
</tr>
<tr>
<td>Absolute coordinate input</td>
<td>A</td>
</tr>
<tr>
<td>Global coordinate input</td>
<td>G</td>
</tr>
<tr>
<td>Snap to next position</td>
<td>Tab</td>
</tr>
<tr>
<td>Snap to previous position</td>
<td>Shift+Tab</td>
</tr>
</tbody>
</table>

### 3.18 Copying and moving objects

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Move</td>
<td>Ctrl+M</td>
</tr>
</tbody>
</table>
### 3.19 Viewing the model

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom original</td>
<td>Home</td>
</tr>
<tr>
<td>Zoom previous</td>
<td>End</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Page Up</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Page Down</td>
</tr>
<tr>
<td>Rotate using mouse</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Rotate using keyboard</td>
<td>Ctrl+arrow keys</td>
</tr>
<tr>
<td></td>
<td>Shift+arrow keys</td>
</tr>
<tr>
<td>Disable view rotation</td>
<td>F8</td>
</tr>
<tr>
<td>Set view rotation point</td>
<td>V</td>
</tr>
<tr>
<td>Auto rotate</td>
<td>Shift+R</td>
</tr>
<tr>
<td></td>
<td>Shift+T</td>
</tr>
<tr>
<td>Pan</td>
<td>P</td>
</tr>
<tr>
<td>Middle button pan</td>
<td>Shift+M</td>
</tr>
<tr>
<td>Move right</td>
<td>arrow keys</td>
</tr>
<tr>
<td>Move left</td>
<td></td>
</tr>
<tr>
<td>Move down</td>
<td></td>
</tr>
<tr>
<td>Move up</td>
<td></td>
</tr>
<tr>
<td>3D/Plane view</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Fly</td>
<td>Shift+F</td>
</tr>
<tr>
<td>Create clip plane</td>
<td>Shift+X</td>
</tr>
<tr>
<td>Center by cursor</td>
<td>Ins</td>
</tr>
</tbody>
</table>

### 3.20 Checking the model

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inquire object</td>
<td>Shift+I</td>
</tr>
<tr>
<td>Command</td>
<td>Keyboard shortcut</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Free measure</td>
<td>F</td>
</tr>
<tr>
<td>Create report</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Open the Views list</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Open the <strong>Drawing List</strong></td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Print drawings</td>
<td>Shift+P</td>
</tr>
<tr>
<td>Open component catalog</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Create AutoConnections</td>
<td>Ctrl+J</td>
</tr>
<tr>
<td>Advanced options</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Phase manager</td>
<td>Ctrl+H</td>
</tr>
</tbody>
</table>

### 3.21 Drawings

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open <strong>Drawing list</strong> when a drawing is open</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Open <strong>Drawing list</strong> in model mode</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Open previous drawing</td>
<td>Ctrl+Page Up</td>
</tr>
<tr>
<td>Open next drawing</td>
<td>Ctrl+Page Down</td>
</tr>
<tr>
<td>Open any drawing after creating the drawing</td>
<td>Ctrl+Shift</td>
</tr>
<tr>
<td>Associativity symbol</td>
<td>Shift+A</td>
</tr>
<tr>
<td>Set next drawing color mode</td>
<td>B</td>
</tr>
<tr>
<td>Ghost outline</td>
<td>Shift+G</td>
</tr>
<tr>
<td>Add an orthogonal dimension</td>
<td>G</td>
</tr>
<tr>
<td>Add free dimension</td>
<td>F</td>
</tr>
<tr>
<td><strong>In Drawing list</strong>: Open user-defined attributes</td>
<td>Alt+U</td>
</tr>
<tr>
<td><strong>In Drawing list</strong>: Add to Master Drawing Catalog</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td><strong>In Drawing list</strong>: Revision</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td><strong>In Master Drawing Catalog</strong>: Select all</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td><strong>In Master Drawing Catalog</strong>: Create drawings for all parts</td>
<td>Alt+A</td>
</tr>
<tr>
<td>Command</td>
<td>Keyboard shortcut</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>In <strong>Master Drawing Catalog</strong>: Create drawings</td>
<td>Alt+C</td>
</tr>
<tr>
<td>Set UCS origin</td>
<td>U</td>
</tr>
<tr>
<td>Set UCS by two points</td>
<td>Shift+U</td>
</tr>
<tr>
<td>Toggle orientation</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Reset current</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>Reset all</td>
<td>Ctrl+0</td>
</tr>
</tbody>
</table>
Set up the workspace

Before starting to model, check that your Tekla Structures workspace is set up correctly.

1. Define the units and decimals you will use. (page 39)
2. Modify the grid to suit your needs. (page 40) Create a modular grid if needed.
3. Create some views (page 46) to examine the model from different angles and elevations.
4. Resize the work area to suit your project. (page 61)
5. Get familiar with the coordinate system (page 63). If you are modeling sloped structures, shift the work plane accordingly. (page 64)

4.1 Change units and decimals

You can define which units and decimals Tekla Structures uses. The settings are model-specific. Note that these settings do not have any effect on drawings or reports, or on the Inquire and Measure tools.

1. On the File menu, click Settings --> Options, and go to the Units and decimals settings.
2. Modify the units and decimals to suit your needs.

   The number located to the right of each option indicates the number of decimals. The number of decimals affects the input and storage accuracy. Always use a sufficient number of decimals.

   • The settings on the Modeling tab affect the data that is used when you are modeling, for example copying, moving, creating grids, creating points, and so on.

   • The settings on the Catalogs tab affect the data stored in the profile and material catalogs.

   • The settings on the Analysis results tab affect the output data.
3. Click **OK** to save the changes.

### 4.2 Create grids and grid lines

A grid represents a three-dimensional complex of horizontal and vertical planes. The grid is shown on the view plane using dash-and-dot lines. Use grids as an aid in locating objects in a model. You can make grids and grid lines act magnetically so that the objects on the grid lines follow if you move the grid line.

- Create a grid (page 41)
- Modify a grid (page 42)
- Add a single grid line (page 43)

**Grid terminology**

1. Grid origin is the point where the zero points of each coordinate axis intersect
2. Grid line extensions define how far the grid lines extend in each direction
3. Grid labels are the names of the grid lines shown in views

**Modular grid**

You can have more than one grid in a model. We strongly advise that you create a modular grid, so that you can easily place objects in your model. You can create a large-scale grid for the entire structure, and smaller grids for some detailed sections.
**Single grid lines**

You can create single grid lines and attach them to an existing grid.

Single grid lines have handles. If the **Select grid line** selection switch is active and you select a grid line, the handles appear in magenta. If you move the handles to make a skewed grid, you can do this only on the local **XY plane** (page 46) of the grid.

![Diagram of grid lines with handles]

**Create a grid**

When you create a new model, Tekla Structures automatically creates a grid and a view according to the saved standard properties. Here we will show how to create grids manually.

1. On the **Edit** tab, click:

   ![Grid button]

2. Pick a point to indicate the origin of the grid.

   The coordinates of the picked point appear in the **Grid** dialog box as **X0**, **Y0**, and **Z0**. If you do not pick a point, Tekla Structures positions the origin according to the existing values.

3. Enter the x and y coordinates (page 63).
You can either define the coordinates individually, or you can define several grid lines with equal spacing. Both of the following coordinate entries create three grid lines with the spacing of 4000:

0 4000 4000
0 2*4000

4. Enter the z coordinates.
5. Enter the grid labels.
6. Modify the other grid properties if needed.
7. If you want objects to follow if you move the grid line, select the Magnetic grid plane check box.
8. Click Create.

**NOTE** When working with very large grids, always having the grid labels visible might slow down Tekla Structures. To hide the grid labels when you zoom in, use the advanced option.

See also
Modify a grid (page 42)
Change the grid color (page 43)

**Modify a grid**
Double-click an existing grid to modify it.

1. Ensure that the Select grid selection switch is active.
2. Double-click a grid line.
3. Modify the grid properties.
4. If you have attached additional grid lines to the grid and you want to preserve them, clear the check boxes next to the Coordinate boxes. Otherwise Tekla Structures deletes all single grid lines (page 40) attached to the grid.
5. Click Modify to save the changes.

See also
Change the grid color (page 43)
**Delete a grid**

When you delete an entire grid, ensure that you do not have any other objects selected. Otherwise Tekla Structures only deletes the objects, not the grid.

1. Ensure that **only** the **Select grid** selection switch is active.
2. Select the grid.
3. Right-click and select **Delete** from the pop-up menu.
4. Confirm that you want to delete the grid.

**Change the grid color**

You can change the color of the grid using the advanced option XS_GRID_COLOR.

1. On the **File** menu, click **Settings --> Advanced options**, and go to the **Model View** category.
2. Modify the advanced option XS_GRID_COLOR.
   Define the color using RGB values on a scale of 0 to 1. For example, to change the color to red, set the value to 1.0 0.0 0.0.
3. Click **OK**.
4. Close and reopen the view for the change to take effect.

**Add a single grid line**

You can add new grid lines either between existing grid lines or between two freely chosen points that you define in the model.

**Add a grid line between existing grid lines**

You can add new grid lines between existing grid lines.

1. Ensure that the **Direct modification** switch is active.
2. Ensure that the **Select grid** selection switch is active.
3. Select an existing grid to attach the grid line to.
4. Click the + symbol between two existing grid lines or outside the grid.
   Tekla Structures creates the grid line and gives it a label using the labels of the adjacent grid lines. For example, a new grid line between the grid lines 1 and 2 receives the label 12*.
Add a grid line between two points
You can add new grid lines between two picked points.
1. On the Edit tab, click Grid and select Add grid line.
2. Select an existing grid to attach the grid line to.
3. Pick the start point of the grid line.
4. Pick the end point of the grid line.

Modify a single grid line
You can move, stretch, shrink, and incline single grid lines. You can also change grid line labels.

Modify grid line properties
You can edit the properties of a single grid line.
1. Ensure that the Select grid line selection switch is active.
2. Double-click a grid line.
3. Modify the grid line properties.
4. Click Modify to save the changes.

Move a grid line
Use direct modification to move single grid lines.
1. Ensure that the Direct modification switch is active.
2. Ensure that the Select grid selection switch is active.
3. Select the grid.
4. Select the grid line you want to move.
5. Drag the grid line to a new location.
   You can also use the keyboard to enter a numeric location (page 83).
   To start with the negative sign (-), use the numeric keypad. To enter an absolute coordinate, first enter $, then the value. Press Enter to confirm.
Stretch, shrink, or incline a grid line
Use direct modification to stretch, shrink, or incline single grid lines.

1. Ensure that the **Direct modification** switch is active.
2. Ensure that the **Select grid** selection switch is active.
3. Select the grid.
4. Select the grid line.
5. Drag a grid line handle to a new location.

Change a grid line label
Use the contextual toolbar to change the label of a single grid line.

1. Ensure that the **Direct modification** switch is active.
2. Ensure that the **Select grid line** selection switch is active.
3. Select a grid line.
4. On the contextual toolbar, enter a new label.

Turn grid line stretching off
If you move the outermost grid lines using the line handles, Tekla Structures stretches or shrinks the perpendicular, crossing grid lines accordingly by default. You can switch this off temporarily.

1. Ensure that the **Direct modification** switch is active.
2. Ensure that the **Select grid** selection switch is active.
3. Select the grid line.
4. On the contextual toolbar, click the **Turn grid line stretching off** button.
Deleting a single grid line
You can delete grid lines in two different ways. The easiest way is by using direct modification.

Delete a grid line using direct modification
Use direct modification to quickly delete single grid lines.

1. Ensure that the Direct modification switch is active.
2. Select the grid line you want to delete.
3. Press Delete.

Delete a grid line (alternative method)
This is the alternative way of deleting single grid lines.

1. Ensure that the Select grid line selection switch is active.
2. Select the grid line you want to delete.
3. Ensure that you do not have any other objects selected.
   If you also have other objects selected, Tekla Structures only deletes the objects, not the grid line.
4. Right-click and select Delete from the pop-up menu.
5. Confirm that you want to delete the grid line.

4.3 Create model views
A view is a representation of a model from a specific location. Each view is represented in its own window within Tekla Structures. Selecting a part in a view highlights the part in all open views.

- Create views (page 48)
- Open a view (page 57)
- Switch between views (page 58)
- Change the background color (page 60)

View plane
Each view has a view plane on which the grids (page 40) are visible and points are represented as yellow crosses. Points that are located outside the view plane are red. You can move the view plane (page 48) like any other object.
**Basic views**

Basic views are those parallel to the global basic planes (xy, xz, and zy). In basic views, two axes always define the view plane and the axes appear in the plane name. The third axis is perpendicular to the view plane. It does not appear in the plane name. In the basic plane view, the model is shown from the direction of the third axis.

When you create basic views, you must define the view plane's distance (the view plane coordinate) from the global origin in the direction of the third axis.

Examples of basic views:

<table>
<thead>
<tr>
<th>Plane</th>
<th>3D view</th>
<th>Plane view</th>
</tr>
</thead>
<tbody>
<tr>
<td>XY</td>
<td><img src="image1.png" alt="3D view" /></td>
<td><img src="image2.png" alt="Plane view" /></td>
</tr>
<tr>
<td>XZ</td>
<td><img src="image3.png" alt="3D view" /></td>
<td><img src="image4.png" alt="Plane view" /></td>
</tr>
<tr>
<td>ZY</td>
<td><img src="image5.png" alt="3D view" /></td>
<td><img src="image6.png" alt="Plane view" /></td>
</tr>
</tbody>
</table>

**Other views**

For other view types, you either define the view plane and coordinate by picking points, or the points are defined automatically, depending on the creation method.
Move the view plane
You can move the view plane like any other object. When you move it, Tekla Structures only uses the vector that is perpendicular to the view plane.
1. Click the view.
2. Right-click and select Move --> Linear.
3. Pick the start point of the translation vector, or enter its coordinates.
4. Pick the end point of the translation vector, or enter its coordinates.
5. Click Move to move the view plane.

Create views
You can create views of parts, components, and the entire model.

Create a basic view of the model
You can create a basic view along two coordinate axes. Use this view for the overall viewing of the model.

1. On the View tab, click New view --> Basic view.
2. Select a view plane from the Plane list.
3. In the Coordinate box, enter the view level.
   This value defines the distance from the global origin.
4. Click Create.

Create a view using two points
You can create a view using two points you pick: the origin and a point in the horizontal direction.

1. On the View tab, click New view --> Using two points.
2. Pick a point to indicate the origin of the view plane.
3. Pick a second point to indicate the direction of the x axis.
   The y axis is perpendicular to the view plane on which you picked the first point.
Create a view using three points
You can create a view using three points you pick: the origin, a point in the horizontal direction, and a point in the vertical direction.

1. On the View tab, click New view --> Using three points.
2. Pick a point to indicate the origin of the view plane.
3. Pick a second point to indicate the direction of the x axis.
4. Pick a third point to indicate the direction of the y axis.

Create a view of the work plane
You can create a view of the work plane using the current view properties.

• On the View tab, click New view --> On work plane.

Create grid views
You can create views along the grid lines you select.

Before you start, create a view that contains a grid, and check the grid properties. If the grid properties are incorrect in some way, Tekla Structures may cut the views at the wrong elevations or they may be named incorrectly. If you change the grid labels or the elevation or grids later on, the views will not be automatically renamed.

1. Select the grid.

2. On the View tab, click New view --> Along grid lines.

3. Modify the grid view properties if needed.
   a. In the Number of views list, select how many views you want to create.
   b. In the View name prefix box, enter a prefix.
   c. In the View properties list, define which view properties (applied or saved) you want to use.

4. Click Create.
   The Views dialog box opens.
5. Click the arrow buttons to move views from the **Named views** list to the **Visible views** list.

The views will not be visible until you move them to the **Visible views** list.

**Example**

In this example, we will create vertical views of the grid lines 1–7 on the following model:

![Diagram of model with grid lines](image)

In the **Creation of Views Along Grid Lines** dialog box, we select **All** for the view plane XZ and **None** for the view planes XY and ZY. We use the default settings for the view name prefix and the view properties.

<table>
<thead>
<tr>
<th>View plane</th>
<th>Number of views</th>
<th>View name prefix</th>
<th>View properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>XY</td>
<td>None</td>
<td>PLAN</td>
<td>Grid-Plan</td>
</tr>
<tr>
<td>ZY</td>
<td>None</td>
<td>GRID</td>
<td>Grid-Elevation</td>
</tr>
<tr>
<td>XZ</td>
<td>All</td>
<td>GRID</td>
<td>Grid-Elevation</td>
</tr>
</tbody>
</table>

After creating the grid views, we move the view named **Grid 2** to the **Visible views** list:
The grid view is displayed as a plane view in a new window:

We can rotate the view to see it in 3D:
Create a view on a part plane
You can create a view on the front, top, back, or bottom plane of a part.

1. On the View tab, click New view and select one of the following:
   • On part front plane
   • On part top plane
   • On part back plane
   • On part bottom plane
2. Select the part.

Create a 3D view of a part
When you need to see a specific part clearly, create a 3D view of the part. The part is placed in the center of the view.

1. On the View tab, click New view → 3D view of part.
2. Select the part.

Tekla Structures creates the view. The view plane y axis is the global z axis of the model. The x axis is the projection of the part's local x axis onto the global xy plane.

Create default part views

You can create four basic views of a part: front, top, end and perspective view. Tekla Structures creates these views all at once with the same command. By default, the perspective view is a 3D view, and the front, top, and end views are plane views.

1. On the View tab, click **New view --> Default views of part**.
2. Select the part.

Tekla Structures creates the four default views all at once.

Create an undeformed part view

You can create a view that shows a deformed part in undeformed form. This only works for beams and columns.

1. On the View tab, click **New view --> Undeformed view of part**.
2. Select the part.

For example, select a warped beam. Tekla Structures displays the beam in a separate view in undeformed form.

Create a 3D view of a component

When you need to see a specific component clearly, create a 3D view of the component. The component is placed in the center of the view.

1. On the View tab, click **New view --> 3D view of component**.
2. Select the component.

Tekla Structures creates the view. The view plane y axis is the global z axis of the model. The x axis is the projection of the first secondary part local x axis onto the global xy plane. Work area depth is 1 m in all directions.
Create default component views
You can create four basic views of a component: front, top, end and perspective view. Tekla Structures creates these views all at once with the same command. By default, the perspective view is a 3D view, and the front, top, and end views are plane views.

1. On the View tab, click New view --> Default views of component.
2. Select the component.
   Tekla Structures creates the four default views all at once.

Create a surface view
Use the CreateSurfaceView macro to create an automatically aligned surface view. This can be useful when modeling bolt groups, stiffener plates, and hole penetrations on complex geometry.

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. Click the arrow next to Applications to open the applications list.
3. Double-click CreateSurfaceView to start the macro.
4. Select the surface of the part.

Tekla Structures creates a new temporary view and moves the work plane typically along the longest edge of the part face. You can model in the
surface view and see your modeling work being done in your original 3D view at the same time.

5. Press Esc to stop the macro.
6. To return the work plane back to the origin:
   a. Repeat steps 1–2 to open the Applications list.
   b. Double-click the WorkPlaneGlobal macro.

Create a surface view along selected edge
Use the CreateSurfaceView_wEdge macro to create a surface view and align the work plane along the edge you select. This can be useful when modeling bolt groups, stiffener plates, and hole penetrations on complex geometry.

1. Ensure that the Snap to geometry lines/points selection switch is active.
   This allows you to pick along an edge to define the direction.

2. Click the Applications & components button in the side pane to open the Applications & components catalog.
3. Click the arrow next to Applications to open the applications list.
4. Double-click CreateSurfaceView_wEdge to start the macro.
5. Select the surface of the part.
   When you hover the mouse pointer over the part edges, a yellow arrow symbol is displayed to indicate the possible edges you can align the view
to. The head of the arrow represents the positive direction of the x axis. The view will be rotated in this direction to form the flat horizontal edge of the view. The origin of the view and work plane will be at the start of the arrow snap line.

6. Pick the desired edge.
Tekla Structures creates a new temporary view, and the selected edge forms the x axis of the view. You can model in the surface view and see your modeling work being done in your original 3D view at the same time.

7. Press Esc to stop the macro.
8. To return the work plane back to the origin:
   a. Repeat steps 2–3 to open the Applications list.
   b. Double-click the WorkPlaneGlobal macro.

Open a view
You can have up to nine views on the screen at the same time. If you are unable to open a view, check how many views you already have open - you may need to close some of them first.

1. On the View tab, click View list to open the Views dialog box.
   Tekla Structures lists all invisible named views on the left, and all visible views on the right.
2. Select a view from the Named views list and click the right arrow to move it to the Visible views list.
   You can also double-click a view to open it. If the view does not appear, check how many views you already have open.
3. To open multiple views, use the Shift and Ctrl keys when you select views from the list.

See also
Save a view (page 57)

Save a view
If you need to re-open views later on, give each view a unique name. When you exit the model, Tekla Structures only saves the named views. Temporary views disappear when you close them.

Before you start, create one or more views (page 48) in the model.
1. Double-click the view to open the View Properties dialog box.
2. Enter a unique name in the Name box.
   Temporary views have a default name in parentheses. Do not use parentheses when naming a view, or the view will not be saved for later use.

   NOTE In multi-user mode, it is very important to give views unique names. If several users have different views with the same name,
the view settings of one user may accidentally override the settings of another user.

3. Click **Modify**.
   
   Tekla Structures will automatically save all named views when you close the model.

**Modify a view**

You can modify a view simply by double-clicking it.

1. Double-click the view to open the **View Properties** dialog box.
2. Modify the view properties.
3. Click **Modify**.

**See also**

*Move the view plane (page 48)*

**Delete a view**

You can permanently delete named views.

1. On the **View** tab, click **View list** to open the **Views** dialog box.
2. Select the view you want to delete.
3. Click **Delete**.

4. To delete multiple views, use **Shift** or **Ctrl** when you select views from the list.

**Switch between views**

You can easily switch between all open views while modeling. You can also switch between the 3D mode and Plane mode, to examine the current view from different perspectives.
Switch between open views
To switch between open views, do one of the following:

• Use the keyboard shortcut **Ctrl+Tab**.

• Click **Window** and select a view from the list.

• Right-click a view, then select **Next Window** from the pop-up menu.
  The next open view becomes active.

Switch between 3D and plane view
Use the **Switch to 3D or plane** command to examine the current view from different perspectives.

• On the **View** tab, click **Switch to 3D or plane**.
  You can also press **Ctrl+P**.

Update and refresh views
Use the **Redraw** command to refresh a view. You can also update views. Updating is faster than redrawing, because updating only removes temporary graphics (such as measured distances) from the views. It does not, for example, show hidden objects.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redraw the contents of all</td>
<td>On the <strong>View</strong> tab, click <strong>Redraw</strong>.</td>
</tr>
<tr>
<td>the views</td>
<td></td>
</tr>
<tr>
<td>Redraw the contents of the</td>
<td>Right-click the view and select <strong>Redraw View</strong>.</td>
</tr>
<tr>
<td>active view</td>
<td></td>
</tr>
<tr>
<td>Update the contents of all</td>
<td>On the <strong>View</strong> tab, click <strong>Redraw --&gt; Erase temporary graphics</strong>.</td>
</tr>
<tr>
<td>the views</td>
<td></td>
</tr>
<tr>
<td>Update the contents of the</td>
<td>Right-click the view and select <strong>Update Window</strong>.</td>
</tr>
<tr>
<td>active view</td>
<td></td>
</tr>
</tbody>
</table>
Change the background color
You can define the background color of model views using RGB values. You can control the color of each corner of the background separately.

1. On the File menu, click Settings --> Advanced options, and go to the Model View category.

2. Modify the background color using the following advanced options:
   - XS_BACKGROUND_COLOR1
   - XS_BACKGROUND_COLOR2
   - XS_BACKGROUND_COLOR3
   - XS_BACKGROUND_COLOR4
   
   To use a single-colored background, set the same value for all four corners of the background. To use the default background color, leave the boxes empty.

3. Click OK to save the changes.

4. Close and reopen the view for the change to take effect.

Examples
Below are some examples of possible background colors that you can define. The first RGB value refers to the advanced option XS_BACKGROUND_COLOR1, the second value to the advanced option XS_BACKGROUND_COLOR2, and so on.

<table>
<thead>
<tr>
<th>RGB values</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
</tbody>
</table>
4.4 Define the work area

Tekla Structures indicates the work area of a view using dashed lines. Objects outside the work area exist, but they are not visible. You can shrink and expand the work area to suit particular situations, for example to concentrate on a particular area of the model. You can temporarily hide the work area box.

4.5 Fit work area to entire model

You can resize the work area to include all model objects, either in all views or in selected views only.
1. On the View tab, click Work area and select one of the following:

   - **To entire model in all views**
     Fits the work area to include all model objects in all visible views.
   - **To entire model in selected views**
     Fits the work area to include all model objects in the selected views.

### 4.6 Fit work area to selected parts

You can resize the work area to include only selected parts, either in all views or in selected views only.

1. Select the objects you want to include.

2. On the View tab, click Work area and select one of the following:

   - **To selected parts in all views**
     Fits the work area to include the selected model objects in all views.
   - **To selected parts in selected views**
     Fits the work area to include the selected model objects in the selected views.

### 4.7 Fit work area using two points

You can resize the work area based on two corner points you pick on the view plane. The depth of the work area is the same as the view depth.

1. On the View tab, click Work area and select **Using two points**.
2. Pick the first point.
3. Pick the second point.

### 4.8 Hide the work area box

You can temporarily hide the work area box in a view. This can be useful, for example, when creating screenshots for presentations.
1. Hold down the Ctrl and Shift keys simultaneously.
2. On the View tab, click Redraw --> Redraw all.

3. To make the box visible again, click Redraw --> Redraw all again.

TIP Alternatively, use the advanced option XS_HIDE_WORKAREA.

4.9 Coordinate system
Tekla Structures uses two coordinate systems: the global and the local coordinate system. The local coordinate system is also known as the work plane.

Global coordinate system
The green cube symbol represents the global coordinate system and lies at the global point of origin (x=0, y=0, z=0). Do not place the model far away from the origin. If you create model objects far away from the origin, snapping to points (page 80) in the model views may become inaccurate. The further away from the origin you model, the less precise all computations become.

Local coordinate system (Work plane)
The work plane represents the local coordinate system. The work plane has its own grid, which can be used for positioning parts. Most of the commands that are dependent on the coordinate system use work plane coordinates. For example creating points, part positioning, and copying always comply with the work plane coordinate system. The coordinate symbol, which is located in the lower right corner of the model view, follows the work plane.
The work plane is model specific, so it is the same in all views. The red work plane arrow symbol shows the xy plane. The z direction follows the right-hand rule.

See also
Show or hide the work plane grid (page 64)
Change the color of the work plane grid (page 67)

Show or hide the work plane grid
The work plane grid is hidden by default. Use the options on the Snapping toolbar to show or hide the work plane grid.

1. To show the grid, select **Work plane** from the second list.

2. To hide the grid, select **View plane** from the same list.

Shift the work plane
You can set the work plane to any position by picking points or by selecting a plane. This makes it easier to place parts accurately when modeling sloped parts.
For example, you can shift the work plane to the slope of the roof to make it easier to model horizontal bracing and purlins in a sloped roof.

Set work plane to any part plane
Use the Workplane tool command to set the work plane to any part plane.
1. On the View tab, click Workplane --> Workplane tool.
   
   ![Workplane]

2. Pick a point.

Set work plane parallel to xyz plane
You can set the work plane parallel to the xy, xz, or zy plane.
1. On the View tab, click Workplane and select Parallel to XY(Z) plane.
   
   ![Workplane]

2. In the Plane list box, select the plane parallel to the work plane.
3. Enter the depth coordinate.
   The depth coordinate defines the distance of the work plane from the global origin along a line perpendicular to the plane parallel to the third axis.
4. Click Change.
Set work plane using one point
You can set the work plane using one picked point. The work plane stays parallel to the current work plane, but moves it to a new position. The x and y directions are unchanged.
1. On the View tab, click Workplane and select Using one point.

2. Pick the new position of the work plane.

Set work plane using two points
You can set the work plane using two picked points. The first point you pick is the origin, the second defines the x direction of the work plane. The y direction remains the same as the previous work plane.
1. On the View tab, click Workplane and select Using two points.

2. Pick the origin of the work plane.
3. Pick a point in the work plane, in the positive x direction.

Set work plane using three points
You can set the work plane using three picked points. The first point you pick is the origin, the second defines the x direction, and the third defines the y direction of the work plane. Tekla Structures fixes the z direction according to the right-hand rule.
1. On the View tab, click Workplane and select Using three points.

2. Pick the origin for the work plane.
3. Pick a point in the positive x direction.
4. Pick a point in the positive y direction.
**Set work plane parallel to view plane**
You can set the work plane to be the same as the view plane of a selected view.
1. On the **View** tab, click **Workplane** and select **Parallel to view plane**.
2. Select the view.

**Restore the default work plane**
Remember to change back to the default work plane when you have finished modeling sloped structures.
1. On the **View** tab, click **Workplane** --> **Parallel to XY(Z) plane**.
2. In the **Plane** list, select **XY**.
3. In the **Depth coordinate** box, enter **0**.
4. Click **Change**.

**Change the color of the work plane grid**
Tekla Structures displays the work plane grid in dark red. You can change the color of the grid using the advanced option `XS_GRID_COLOR_FOR_WORK_PLANE`.
1. On the **File** menu, click **Settings** --> **Advanced options** and go to the **Model View** category.
2. Modify the advanced option.
   Define the color using RGB values on a scale of 0 to 1. For example, to change the color to red, set the value to `1.0 0.0 0.0`.
3. Click **OK**.
4. Close and reopen the view for the change to take effect.
See also

Show or hide the work plane grid (page 64)
There are several ways to create, modify, and delete objects in Tekla Structures. Here we will introduce the way that is most useful for a first-time user.

1. Run a command that creates an object.

   For example, click to create a steel beam.

2. Pick points (page 80) to place the object in the model.

   Tekla Structures creates the object using the current properties of the object type.

3. Follow the status bar messages (page 29) to get instructions on how to proceed.

4. To create more objects with the same properties, pick more points.

   The command runs until you end it (page 24) or use another command.

5. Double-click the object to modify it.

   The object properties dialog box opens.

6. Change the properties as desired.

7. To indicate which properties you want to change, select or clear the desired check boxes.

   For example, if you only want to change the object's material, select the Material check box and clear all the others.

   **TIP** Click to switch all check boxes on or off.

8. Click Modify.

   Tekla Structures changes the properties whose check boxes you selected in step 7.

9. To delete an object, select it and press Delete.
5.1 Change properties using contextual toolbar

A contextual toolbar appears next to the mouse pointer when you click an object in a model or drawing. Use the contextual toolbar to quickly view and change some basic properties of an object, view, grid, and so on.

If multiple objects are being selected, the contextual toolbar displays the text "Varies" for any properties that differ.

5.2 How to use contextual toolbar

The changes that you make in the contextual toolbar are immediately applied to the model or drawing.

1. Click an object in a model or drawing.
   The contextual toolbar appears next to the mouse pointer.
2. Change the object properties in the contextual toolbar.
   The changes are applied immediately.

5.3 Show or hide contextual toolbar

You can define whether the contextual toolbar is visible in Tekla Structures.

1. On the File menu, click Settings.
2. Under Switches, select or clear the Contextual Toolbar check box.

5.4 Define contextual toolbar’s position

You can define the position of the contextual toolbar, relative to an object's reference point.

1. Select an object.
2. Hold down the **Ctrl** key and click the contextual toolbar with the left mouse button.
   A dashed line appears between the contextual toolbar and the object.

3. Drag the contextual toolbar to a new position. For example, you can position the contextual toolbar on the left side of the selected object.
4. Release the left mouse button. The contextual toolbar now appears in the position you defined, for example on the left side of any object you select.

### 5.5 Pin contextual toolbar in place
You can pin the contextual toolbar to a specific location on the screen, so that the position is locked. For example, you could have it appear at the upper left corner of the screen. In the locked state, the position of the contextual toolbar is independent of the individual part's location.

1. Move the mouse pointer on the gray bar on the left-hand side of the contextual toolbar. The mouse pointer changes into a cross with four arrows.
2. Drag the contextual toolbar to a new location.
3. Click to pin the contextual toolbar to the new location.
   The pin icon changes when the position is locked.
4. To unlock the position, click.

### 5.6 Minimize contextual toolbar
You can minimize the contextual toolbar so that it takes less space on your screen.

1. On the contextual toolbar, click **Minimize**. The contextual toolbar now has the symbol.
2. To restore the contextual toolbar to its original size, click the **Minimize** button again.
5.7 Customize contextual toolbar

You can customize the contextual toolbar by selecting which toolbar elements are visible. You can also adjust the width of the elements, and add icons and additional titles to the elements.

1. On the contextual toolbar, click Customize.

2. By selecting and clearing check boxes, define which toolbar elements you wish to show or hide.
   The Preview area shows what the toolbar will look like.

3. To modify the toolbar elements:
   a. Click the toolbar element.
   b. Use the slider to adjust the width of the toolbar element.
   c. To add a title text, click the text box and enter an additional title.
   d. To add a title icon, click and select an icon from the list.
   e. To remove the title or icon, click the Reset button.

4. Click Ok to save the changes.

5.8 Create user profiles for contextual toolbars

You can create multiple profiles for contextual toolbars. Each profile contains the same contextual toolbars, but with different settings.

1. On the contextual toolbar, click Customize.

2. Click Set profiles.

3. Select New profile from the list.

4. Enter a name for the profile.

5. Click Save.

6. Customize the contextual toolbar.
   For example, remove some elements from the contextual toolbar.

7. Click OK to save the changes.
   The user profile is now active with the settings you defined.

8. To switch to another profile:
a. Click **Set profiles**.

b. Select another profile from the list.

c. Modify the settings.

d. Click **OK**.

This user profile is now active.

### 5.9 Selection switches

The *selection switches* are special commands that control which objects and object types you can select. For example, if you select the entire model area but only the **Select parts** switch is active, only the parts become selected.

Click the selection switches on the **Selecting** toolbar to switch them on or off.

#### Main selection switches

The main selection switches control whether you can select components and assemblies, or objects included in them. These switches have the highest priority.

<table>
<thead>
<tr>
<th>Switch</th>
<th>Selectable objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![icon]</td>
<td>Components</td>
<td>When you click any object belonging to a component, Tekla Structures selects the component symbol and highlights (but does not select) all component objects.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Component objects</td>
<td>Objects created automatically by a component can be selected.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Assemblies and cast units</td>
<td>When you click any object in an assembly or a cast unit, Tekla Structures selects the assembly or cast unit and highlights all objects in the same assembly or cast unit.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Objects in assemblies and cast units</td>
<td>You can select single objects in assemblies and cast units.</td>
</tr>
</tbody>
</table>

#### Other selection switches

The table below lists the remaining selection switches. Use these switches to control which object types you want to select.

<table>
<thead>
<tr>
<th>Switch</th>
<th>Selectable objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![icon]</td>
<td>Any objects</td>
<td>Turns all switches on. You can select all object types, except for single bolts.</td>
</tr>
</tbody>
</table>
### Switches

<table>
<thead>
<tr>
<th>Switch</th>
<th>Selectable objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Components</td>
<td>You can select component symbols.</td>
</tr>
<tr>
<td></td>
<td>Parts</td>
<td>You can select parts, such as columns, beams, or plates.</td>
</tr>
<tr>
<td></td>
<td>Surface treatments and surfaces</td>
<td>You can select surface treatments and surfaces.</td>
</tr>
<tr>
<td></td>
<td>Points</td>
<td>You can select points.</td>
</tr>
<tr>
<td></td>
<td>Construction lines and circles</td>
<td>You can select construction lines and circles.</td>
</tr>
<tr>
<td></td>
<td>Reference models</td>
<td>You can select entire reference models.</td>
</tr>
<tr>
<td></td>
<td>Grids</td>
<td>You can select entire grids by selecting one line in the grid.</td>
</tr>
<tr>
<td></td>
<td>Grid lines</td>
<td>You can select single grid lines.</td>
</tr>
<tr>
<td></td>
<td>Welds</td>
<td>You can select welds.</td>
</tr>
<tr>
<td></td>
<td>Cuts and added material</td>
<td>You can select line, part, and polygon cuts, fittings, and added material.</td>
</tr>
<tr>
<td></td>
<td>Views</td>
<td>You can select model views.</td>
</tr>
<tr>
<td></td>
<td>Bolt group</td>
<td>You can select entire bolt groups by selecting one bolt in the group.</td>
</tr>
<tr>
<td></td>
<td>Single bolts</td>
<td>You can select single bolts.</td>
</tr>
<tr>
<td></td>
<td>Reinforcing bars</td>
<td>You can select reinforcing bars and bar groups.</td>
</tr>
<tr>
<td></td>
<td>Pour breaks</td>
<td>You can select pour breaks.</td>
</tr>
<tr>
<td></td>
<td>Planes</td>
<td>You can select construction planes.</td>
</tr>
<tr>
<td></td>
<td>Distances</td>
<td>You can select distances.</td>
</tr>
<tr>
<td></td>
<td>Tasks</td>
<td>You can select Task Manager tasks.</td>
</tr>
</tbody>
</table>

### Analysis model switches

The following switches can be used to select objects in an analysis model:

<table>
<thead>
<tr>
<th>Switch</th>
<th>Selectable objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Loads</td>
<td>You can select point, line, area, uniform, and temperature loads.</td>
</tr>
<tr>
<td></td>
<td>Analysis parts</td>
<td>You can select analysis parts.</td>
</tr>
<tr>
<td></td>
<td>Nodes</td>
<td>You can select analysis nodes.</td>
</tr>
<tr>
<td></td>
<td>Rigid links</td>
<td>You can select analysis rigid links.</td>
</tr>
</tbody>
</table>
Selection switches in drawings

Similar selection switches are available in drawings:

<table>
<thead>
<tr>
<th>Switch</th>
<th>Selectable objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Any objects</td>
<td>Turns all switches on. You can select all object types, single dimensions of a dimension set, or single grid lines of a grid.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Lines</td>
<td>You can select drawing objects such as lines, arcs, circles, rectangles, polylines, polygons, and clouds.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Text</td>
<td>You can select any text in drawings.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Marks</td>
<td>You can select all kinds of marks in drawings.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Parts</td>
<td>You can select parts, such as columns, beams, and plates in drawings.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Section symbols</td>
<td>You can select section symbols in drawings.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Welds</td>
<td>You can select welds in drawings.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Views</td>
<td>You can select drawing views.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Dimensions</td>
<td>You can select drawing dimensions. You can select an entire group of dimensions by selecting one dimension in the group.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Single dimensions</td>
<td>You can select single drawing dimensions.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Grids</td>
<td>You can select grids in drawings.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Grid lines</td>
<td>You can select single grid lines in drawings.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Detail marks</td>
<td>You can select details marks in drawings.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Plugins</td>
<td>You can select custom plugins in drawings.</td>
</tr>
</tbody>
</table>

See also

- If you cannot select objects (page 103)
- How to restore missing toolbars (page 151)

### 5.10 Move or reshape an object using direct modification

Use direct modification to modify model objects by simply dragging the handles. When you select an object in a model view, Tekla Structures displays handles and dimensions that are specific for that model object.

Direct modification can be used with the following object types:

- Parts
How to use direct modification

Use direct modification to modify model objects by dragging handles and dimensions.

1. Ensure that **Direct modification** is switched on.

   To switch direct modification on or off, click or press **Ctrl+D**.

2. Click the object to select it.

   Tekla Structures displays handles and dimensions that are specific for the model object. Note that not all object types can be modified using this method.

3. To modify the object, drag the handles.

4. To fine-tune a specific dimension, click the arrowhead and start typing a dimension.

   Tekla Structures displays the **Enter a Numeric Location** dialog box.

Direct modification handles

Direct modification handles are typically blue. However, the handles of custom parts are red, green, and blue, according to the local coordinate system of the custom part.

<table>
<thead>
<tr>
<th>Handle</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Reference point handle" /></td>
<td>Reference point handle</td>
</tr>
<tr>
<td><img src="image" alt="Midpoint handle" /></td>
<td>Midpoint handle</td>
</tr>
</tbody>
</table>
5.13 Direct modification dimensions

The colors of direct modification dimensions follow the colors of the work plane coordinate axes. The dimensions are red in the x direction of the work plane, green in the y direction, and blue in the z direction. The diagonal dimensions are magenta.
5.14 Save and load dialog box properties

You can save predefined sets of properties for model and drawing objects and load these properties later on when you create new objects. Tekla Structures stores the properties files in the model folder, also including the properties of sub-dialog boxes.

1. In the dialog box, enter the properties you want to save.
2. In the box next to the Save as button, enter a name for the new set of properties.
   For example, MyProperties.
3. Click Save as.
The set of properties has now been added to the list of saved properties:

4. When you want to load a set of properties, select the set from the list, and then click **Load**.

5. If you want to make changes to an existing set of properties:
   a. Load the set of properties you want to change.
   b. Change the properties.
   c. Click **Save**.
      
      Tekla Structures saves the changes in the file shown in the list, overwriting the old set of properties.

**See also**

*Learn the common buttons (page 30)*
Most commands ask you to pick points to place objects in the model or drawing. This is called snapping. When you move the mouse pointer over objects, Tekla Structures displays snap symbols for the available snap points. Tekla Structures also displays snap dimensions to help you create objects of a desired length.

You can use a variety of different methods when snapping to positions in a model or drawing. You can combine different methods to achieve the best results. Use the snap switches (page 80) to control which positions you can snap to.

### 6.1 Snap switches and symbols

Use the snap switches to control which positions you can pick in the model or drawing. By using snap switches, you can position objects precisely without having to know the coordinates. You can use snap switches whenever Tekla Structures prompts you to pick a point.

![Snap switches toolbar](image)

Click the snap switches on the Snapping toolbar to switch them on or off. If there is more than one point available to snap to, press the Tab key to cycle forward through the snap points, and Shift+Tab to cycle backwards through them. Click the left mouse button to select the appropriate point.

**Main snap switches**

The two main snap switches define whether you can snap to reference points or any other points on objects, for example part corners. These switches have the highest snap priority (page 82). If both these switches are off, you cannot snap to any positions, even if all the other switches are on.
<table>
<thead>
<tr>
<th>Switch</th>
<th>Snap positions</th>
<th>Description</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Reference lines and points" /></td>
<td>Reference lines and points</td>
<td>You can snap to object reference points (points that have handles).</td>
<td><img src="image2.png" alt="Symbol" /></td>
</tr>
<tr>
<td><img src="image3.png" alt="Geometry lines and points" /></td>
<td>Geometry lines and points</td>
<td>You can snap to any points on objects.</td>
<td><img src="image4.png" alt="Symbol" /></td>
</tr>
</tbody>
</table>

**Other snap switches**

The table below lists the remaining snap switches and their symbols in the model or drawing. The snap symbol is yellow for model objects and objects in drawings, and green for objects inside components.

Make sure that you do not have too many snap switches on when snapping. Having too many snap switches on may easily lead to inaccuracies and errors in snapping. Be particularly careful when you use the **Snap to any position** snap switch.

<table>
<thead>
<tr>
<th>Switch</th>
<th>Snap positions</th>
<th>Description</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image5.png" alt="Points" /></td>
<td>Points</td>
<td>Snaps to points and grid line intersections.</td>
<td><img src="image6.png" alt="Symbol" /></td>
</tr>
<tr>
<td><img src="image7.png" alt="End points" /></td>
<td>End points</td>
<td>Snaps to end points of lines, polyline segments, and arcs.</td>
<td><img src="image8.png" alt="Symbol" /></td>
</tr>
<tr>
<td><img src="image9.png" alt="Centers" /></td>
<td>Centers</td>
<td>Snaps to centers of circles and arcs.</td>
<td><img src="image10.png" alt="Symbol" /></td>
</tr>
<tr>
<td><img src="image11.png" alt="Midpoints" /></td>
<td>Midpoints</td>
<td>Snaps to midpoints of lines, polyline segments, and arcs.</td>
<td><img src="image12.png" alt="Symbol" /></td>
</tr>
<tr>
<td><img src="image13.png" alt="Intersections" /></td>
<td>Intersections</td>
<td>Snaps to intersections of lines, polyline segments, arcs, and circles.</td>
<td><img src="image14.png" alt="Symbol" /></td>
</tr>
<tr>
<td><img src="image15.png" alt="Perpendicular" /></td>
<td>Perpendicular</td>
<td>Snaps to points on objects that form a perpendicular alignment with another object.</td>
<td><img src="image16.png" alt="Symbol" /></td>
</tr>
<tr>
<td>Switch</td>
<td>Snap positions</td>
<td>Description</td>
<td>Symbol</td>
</tr>
<tr>
<td>--------</td>
<td>----------------</td>
<td>-------------</td>
<td>--------</td>
</tr>
<tr>
<td>![image]</td>
<td>Line extensions</td>
<td>Snaps to the line extensions of nearby objects, and reference and geometry lines of drawing objects.</td>
<td>![image]</td>
</tr>
<tr>
<td>![image]</td>
<td>Any position</td>
<td>Snaps to any position.</td>
<td>![image]</td>
</tr>
<tr>
<td>![image]</td>
<td>Nearest point</td>
<td>Snaps to the nearest points on objects, e.g. any point on part edges or lines.</td>
<td>![image]</td>
</tr>
<tr>
<td>![image]</td>
<td>Lines</td>
<td>Snaps to grid lines, reference lines, and the edges of existing objects.</td>
<td>![image]</td>
</tr>
<tr>
<td>![image]</td>
<td>Dimensions and marks</td>
<td>Snaps to annotation geometries in drawings. Available only in drawings.</td>
<td>![image]</td>
</tr>
</tbody>
</table>

**See also**

Override the current snap switch (page 86)
How to restore missing toolbars (page 151)

### 6.2 Snap zone, depth, and priority

Snap zone, snap depth, and snap priority affect the picking of points. Snap priority is automatic, but the other two settings you can change.

**Snap zone**

Each object has a snap zone. It defines how close you need to pick to hit a position. When you pick within the snap zone of an object, Tekla Structures automatically snaps to the closest pickable point on that object.

You can set the snap zone using the advanced option.

**Snap depth**

The first list on the **Snap** toolbar defines the depth of each position you pick. You have the following options:
• **Plane**: You can snap to positions either on the view plane (page 46) or the work plane (page 63), depending on what you have selected in the second list on the Snapping toolbar.

• **3D**: You can snap to positions in the entire 3D space.

• **Auto**: In perspective views, this option works like the 3D option. In non-perspective views, it works like the Plane option.

**Snap priority**
Tekla Structures automatically snaps to the point with the highest snap priority, but you can also choose another point.

See also
Snap switches and symbols (page 80)

6.3 **Snap to a point using coordinates**
You can use coordinates when snapping to a position. Use the Enter a Numeric Location dialog box to specify the coordinates.

6.4 **Enter a numeric location**
You can use coordinates when snapping to a position. Use the Enter a Numeric Location dialog box to specify the coordinates.

1. Run a command that requires you to pick points.
   For example, start creating a beam.
2. Enter the coordinates using the keyboard.
   For example, type 1000. When you start typing, Tekla Structures displays the Enter a Numeric Location dialog box automatically.
3. After entering the coordinates, press Enter to snap to the position.

**TIP** To see an example of using coordinates, see Example: Tracking along a line towards a snap point (page 89).

6.5 **Options for coordinates**
The following below explains the types of information you can enter in the Enter a Numeric Location dialog box:
<table>
<thead>
<tr>
<th>You can enter</th>
<th>Description</th>
<th>Special character</th>
</tr>
</thead>
<tbody>
<tr>
<td>One coordinate</td>
<td>A distance to an indicated direction.</td>
<td></td>
</tr>
<tr>
<td>Two coordinates</td>
<td>If you omit the last coordinate (z) or angle, Tekla Structures assumes that the value is 0.</td>
<td></td>
</tr>
<tr>
<td>Three coordinates</td>
<td>In drawings, Tekla Structures ignores the third coordinate.</td>
<td></td>
</tr>
<tr>
<td>Cartesian coordinates</td>
<td>The x, y, and z coordinates of a position separated by commas. For example, 100,-50,-200.</td>
<td>, (comma)</td>
</tr>
<tr>
<td>Polar coordinates</td>
<td>A distance, an angle on the xy plane, and an angle from the xy plane separated by angle brackets. For example, 1000&lt;90&lt;45. Angles increase in the counterclockwise direction.</td>
<td>&lt;</td>
</tr>
<tr>
<td>Relative coordinates</td>
<td>The coordinates relative to the last position picked. For example, @1000,500 or @500&lt;30. Defined by XS_KEYIN_RELATIVE_PREFIX. The default is @.</td>
<td></td>
</tr>
<tr>
<td>Absolute coordinates</td>
<td>The coordinates based on the origin of the work plane. For example, $0,0,1000 Defined by XS_KEYIN_ABSOLUTE_PREFIX. The default is $.</td>
<td></td>
</tr>
<tr>
<td>Global coordinates</td>
<td>The coordinates relative to the global origin and the global x and y directions. For example, !6000,12000,0. This is handy, for example, when you have set the work plane to a part plane and want to snap to a position defined in the global coordinate system without changing the work plane to global. Defined by XS_KEYIN_GLOBAL_PREFIX. The default is !.</td>
<td></td>
</tr>
</tbody>
</table>

### 6.6 Change the snapping mode

Tekla Structures has three snapping modes: relative, absolute, and global. Use the advanced option XS_KEYIN_DEFAULT_MODE to indicate the default snapping mode.

1. On the **File** menu, click **Settings** --> **Advanced options** and go to the **Modeling Properties** category.
2. Set the advanced option XS_KEYIN_DEFAULT_MODE to RELATIVE, ABSOLUTE, or GLOBAL.

   This is now the default snapping mode.

3. Click OK to save the changes.

4. If you want to temporarily override the default snapping mode, enter a special character in front of the coordinates when entering a numeric location.

   By default, the special characters are:
   • @ for relative coordinates
   • $ for absolute coordinates
   • ! for global coordinates

   **NOTE** If you want to change the special character for any of the three snapping modes, use the advanced options XS_KEYIN_RELATIVE_PREFIX, XS_KEYIN_ABSOLUTE_PREFIX, and XS_KEYIN_GLOBAL_PREFIX.

### 6.7 Align objects using a snap grid

A snap grid makes it easier to align objects in a model or drawing, because it allows you to snap to positions only at set intervals. Use a snap grid when you pick points using the **Snap to any position** snap switch.

### 6.8 Define a snap grid in a model

1. On the **File** menu, click **Settings --> Options** and go to the **Mouse settings**.

2. Define the grid spacing intervals in the **Spacing** boxes.

   For example, if the spacing of the x coordinate is 500, you are able to snap to positions at intervals of 500 units in the x direction.

3. If needed, define offsets for the snap grid origin in the **Origin** boxes.

4. To activate the snap grid, select the **Activate snap grid when free snap is on** check box.

   Now when you pick points using the **Snap to any position** snap switch, you can only snap to positions at set intervals. The snap grid itself is invisible in the model.
6.9 Define a snap grid in a drawing

You can easily align dimensions, mark and associative notes using a snap grid.

1. Open a drawing.
2. On the File menu, click Settings --> Snap settings to open the Snap dialog box.
3. If you want to see the snap grid symbol, select Symbol.
4. Define the grid spacing intervals in the Spacing boxes.
   For example, if the spacing of the x coordinate is 200, you are able to snap to positions at intervals of 200 units in the x direction.
5. If needed, define offsets for the snap grid origin in the Origin boxes.
6. Click Apply and OK.

Now when you pick points using the Snap to any position snap switch, you can only snap to positions at set intervals. The snap grid itself is invisible in the drawing.

6.10 Override the current snap switch

You can temporarily override the current snap switch settings.

1. Run a command that asks you to pick a point.
   For example, start creating a beam.
2. To override the current snap switches (page 80), do one of the following:
   • Right-click to bring up a list of snap options, and then select one of the options.
   • Go to Quick Launch (page 27), type snap override, and select the Snap Override command from the list that appears.
     A new toolbar appears. Click a button to override the current snap switch.
6.11 Example: Place a drawing object at a specified distance

This example shows how to place a drawing object at a specified distance in the indicated direction. We will use the **Enter a Numeric Location** dialog box to specify the distance coordinate.

1. On the **Drawing** tab, click **Draw line** to activate the line tool.

2. Hold down **Ctrl** and pick an origin.

3. Point to the direction where you want to place the start point of the line.
   Here, the bolt group needs to be moved 30 mm to the right and the line will indicate the new position for the group.
4. Start entering the distance, for example 30.

The **Enter a Numeric Location** dialog box is displayed.

5. When you have entered the distance, click **OK**. Tekla Structures indicates the start point of the line.

6. Pick an end point for the line.

7. To check that the distance is correct, create a dimension.
6.12 Example: Tracking along a line towards a snap point

This example shows how to pick a point at a specified distance along a line. We will use the Enter a Numeric Location dialog box to specify the distance from the last point picked.

Starting point

When you have snap switches on and you use a command that requires you to pick positions, the mouse pointer locks onto a snap point. Tekla Structures displays a green line between the snap point and the last point picked.
Tracking along a line
In the illustration below, we snapped to a grid line midpoint and tracked along the tentative line for 1000 units when creating a beam.

Tracking beyond the snap point
You can also track beyond the snap point, for example, 4000 units from the last point picked.

Tracking in the opposite direction
Track in the opposite direction by entering a negative value, for example, -1000.
Snap to a point or line
Example: Tracking along a line towards a snap point
Use the **Snap to line** snap switch when modeling objects that should be lined up with an existing object or a grid line.

1. Ensure that the **Snap to line** snap switch (page 80) is active.
2. Run a command that requires you to pick two or more points.
   For example, create a beam. Tekla Structures automatically picks both ends of the line. The yellow arrow symbol indicates the direction of the points.

3. To switch direction, move the mouse pointer closer to the opposite end of the line.
Snap to extension lines

You can snap to the extension lines of nearby objects. This can be useful, for example, when you want to align objects with one another.

1. Ensure that the correct snap switches (page 80) are active:
   - Switch on **Snap to extension lines**
   - Switch on either **Snap to intersection points** or **Snap to nearest points** if you are snapping to the intersection of an extension line and a grid line
   - Switch off **Snap to end points** if you are working in 3D

2. Run a command that requires you to pick points.
   For example, start creating a beam. Tekla Structures displays line extensions in blue color.

3. Move the mouse pointer close to the object to find the extension line.
   When the line is found, you can move the pointer further away while keeping the snap.

**Examples**

In a model:
In a drawing:

Example: Tracking along a line towards a snap point
Use the **Ortho** tool to snap to the closest orthogonal point on the plane (0, 45, 90, 135, 180 degrees, and so on). The mouse pointer automatically snaps to positions at even distances in the given direction. This can be useful, for example, if you need to place marks in a consistent manner in exact locations in a drawing.

1. On the **File** menu, click **Settings** and select the **Ortho** check box.
   
   Alternatively, you can press **O**.

2. Run a command that requires you to pick points.
   
   For example, start creating a beam. Tekla Structures displays an angle symbol to indicate the direction of snapping. The snapping precision depends on the current zoom level.
Snap relative to previously picked points

When you create objects that require you to pick more than two points, you can snap in orthogonal directions relative to the two previously picked points. This can be useful, for example, if you need to create a rectangular slab that is on the view plane but not along the x and y axes.

1. Run a command that requires you to pick multiple points. For example, start creating a polybeam.
2. Pick the first two points.
   Tekla Structures displays an angle symbol to indicate the direction of snapping.
3. Move the mouse pointer in the model to see the angle symbol.
   When the snap is orthogonal to the work plane, the color of the angle symbol is green:

   ![Angle Symbol Green](image)

   When the snap is orthogonal to the previous points, the color of the angle symbol changes to yellow:

   ![Angle Symbol Yellow](image)
Snap relative to previously picked points

Example: Tracking along a line towards a snap point
11 Create a temporary reference point

You can create a temporary reference point to use as a local origin when snapping in models and drawings.

1. Run a command that requires you to pick points.
   For example, start creating a beam.
2. Pick the start point.
3. Hold down the Ctrl key and pick a position.
   A green cross indicates that this position is now a temporary reference point.
4. Repeat step 3 to create as many reference points as needed.
5. Release the Ctrl key and pick the end point.
Tekla Structures creates the object between the start point and the end point.

Example: Tracking along a line towards a snap point
Lock X, Y or Z coordinate

You can lock the x, y, and z coordinates on a line. This is useful when you need to determine a point to pick and the needed point does not exist on the line. When a coordinate is locked, you can snap to points only in that direction.

1. Run a command that requires you to pick positions.
   For example, start creating a beam.

2. To lock the x coordinate, press X.
   You can snap to points only in the x direction.

3. To unlock the coordinate, press X again.
13 Select objects

You can make single selections and area selections. Tekla Structures highlights the selected objects. The number of selected objects and handles is displayed in the bottom right corner of the status bar. For example: **1 object(s) selected**

13.1 Select assemblies and cast units

Use the Select assemblies selection switch to select assemblies and cast units.

1. Ensure that the Select assemblies selection switch is active.
2. Select a part.
   
   Tekla Structures selects the entire cast unit or assembly that contains the selected part.

13.2 Select nested objects

You can select nested assemblies and components. The active selection switch defines on which level you start and toward which direction you move in the component or assembly hierarchy. The status bar shows the steps you take in the hierarchy.

1. Ensure that the correct selection switch is active.
   
   • ![Switch](image) to start from the assemblies on the highest level, move to their sub-assemblies, and finally select single parts, bolts, and so on
   
   • ![Switch](image) to start from single objects and move to bigger and bigger nested assemblies
   
   • ![Switch](image) to start from the components on the highest level, move to their sub-components, and finally select single parts, bolts, and so on
• to start from single objects and move to bigger and bigger nested components

2. Hold down the **Shift** key.
3. Scroll with the mouse wheel.

The orange highlighting indicates the assembly or component that you can select.

13.3 Select reference models, reference model objects and assemblies

You can select either entire reference models, or single objects and assemblies that are part of a reference model. The use of selection switches differs in each case.

13.4 Select an entire reference model

1. Activate the **Select reference models** selection switch.
2. Activate the **Select components** selection switch.
3. Select the reference model.
13.5  Select a reference model object

1. Activate the Select reference models selection switch.
2. Activate the Select objects in components selection switch.
3. Select the desired object in the reference model.

13.6  Select a reference model assembly

1. Activate the Select reference models selection switch.
2. Activate the Select assemblies selection switch.
3. Select the desired assembly in the reference model.

13.7  If you cannot select objects

If you cannot select desired objects in the model, check the selection switches and the filter settings.

1. Check that you have switched on all the needed selection switches (page 73).
2. If you still cannot select the objects, check the selection filter (page 133) settings.
   You can select a different filter or modify the current filter.
Select single objects

1. Ensure that the correct selection switches (page 73) are active.
2. Click an object to select it.
   Tekla Structures displays dimensions and dimension lines for the object.
3. If you want to hide the dimensions, use the advanced option.
You can select multiple objects using area selection. By default, the dragging direction affects the selection of objects.

1. Ensure that the correct selection switches (page 73) are active.

2. To select all objects that are completely within a rectangular area, hold down the left mouse button and drag the mouse from left to right.

3. To select all objects that are at least partly within a rectangular area, hold down the left mouse button and drag the mouse from right to left.

4. If you want to change how area selection works, click File menu --> Settings and select or clear the Crossing selection check box.

   By default, the option is switched off. When the option is off, the dragging direction affects the selection of objects. When the option is on, all objects that fall at least partially inside the rectangular area are selected, regardless of the dragging direction.
Select all objects

To select all objects at once, do one of the following:

• On the ribbon, click the down arrow next to the button, and then click **Select all objects**.

• Press **Ctrl+A**.
Select handles

Sometimes you need to select only the handles of a part, for example when moving the part. Before you start, make sure that **Crossing selection** is switched off.

1. On the **File** menu, click **Settings** and make sure that **Crossing selection** is switched off.
2. Ensure that the correct **selection switches (page 73)** are active.
3. Drag the mouse from left to right to select the part.

4. Hold down the **Alt** key and drag the mouse from left to right to select the part again.
You can add objects to the current selection, or remove objects from the selection.

1. To add objects to the current selection, press the **Shift** key and select more objects.

2. To switch the selection of an object on or off, press the **Ctrl** key during the selection. Tekla Structures deselects the objects that were already selected and selects those that were previously not selected.
Copy and move objects

The basic functionality of copying and moving objects is the same in models and drawings. You can copy and move objects linearly, with rotation, and with mirroring.

- Copy objects (page 111)
- Move objects (page 122)
- Rotate objects (page 125)
- Mirror objects (page 130)

Duplicate objects

Two objects are considered duplicates if they have the same size and orientation. Tekla Structures checks for duplicate objects when you copy and move objects or create new parts in the same location as an existing part. If duplicates are found, you can choose whether to keep or delete them.

Use the advanced option to define the maximum number of objects that can be counted as duplicates while copying or moving objects.

NOTE  Tekla Structures does not check for duplicates when you copy objects using a modeling tool, such as the Array of Objects (29) component.

Assemblies and cast units

If you copy or move objects from an assembly or cast unit, Tekla Structures copies the assembly structure if possible. For example, sub-assemblies are copied as sub-assemblies if a parent object is found.

Reinforcement and surface treatment

If you copy or move reinforcement or surface treatments, and want them to adapt to the part they are copied or moved to:

- The reinforcement handle or surface treatment handles must be in part corners.
- The parts between which you copy or move must have the same number of cross section corners.
• Circular parts must have the same cross section dimensions.

**Drawing objects**
You can copy and move drawing objects between drawing views that have different scales.

### 19.1 Copy objects

You can copy objects in a number of different ways. When you copy an object, Tekla Structures copies all objects connected to it, including the components.

**Copy objects using linear array tool**

Use **Linear array tool** to copy selected objects linearly along multiple directions at defined intervals or spacing. Tekla Structures does not check for duplicates when you copy objects using this method.

![Linear array tool diagram]

**How to use Linear array tool**

1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.
2. Search for **Linear array tool**, and then double-click to open it.
3. Select the **Copy method**. The options are:
   - **Selected objects only**
     - This is the default. Only the selected objects are copied.
   - **All associated objects**
     - Selected objects and all objects associated with them are copied. For example, cuts and fittings applied to a part.
• Advanced
   This option is similar to All associated objects, but works better with modifications. For example, when you have stairs that have handrails welded to the steps, and you modify the distance between steps.

4. Select the Copy origin. The options are:
   • Objects to be copied
      This is the default. Copies are relative to the input objects.
   • Origin point
      Copies are relative to the input origin point.

5. Define the settings.
6. Select the objects to copy.
7. Click OK to close the dialog box.
8. Click the middle mouse button.
10. Pick axis direction X.
11. Pick axis direction Y.

The selected objects are copied.

How to define the settings

1. Offset along the Y axis. The default value is 0 mm.
| 2 | Offset along the Z axis. The default value is 0 mm. |
| 3 | Number of copies. The default value is 0. |
| 4 | Space between copies. The default value is 0 mm.  
Use the space character to separate values. Enter a value for each space between copies.  
This option is not available if you select **Equal** as the spacing method. |
| 5 | Copy direction. The options are:  
• **Normal** (default)  
Spacing values are calculated from the origin in positive direction along the axis.  
• **Reverse**  
Spacing values are calculated from the origin in negative direction along the axis.  
• **Centered**  
Copies are centered on the origin.  
• **Mirror**  
Spacing values are calculated from the origin in both positive and negative direction. Mirrored copying doubles the number of copies. |
| 6 | Spacing method. The options are:  
• **Equal** (default)  
Copies are equally spaced based on the length of the X or Y axis.  
• **Specified**  
Copies are spaced according to the number and spacing values given. |

**Copy objects using radial array tool**  
Use **Radial array tool** to copy selected objects radially along multiple directions at defined intervals or spacing. Tekla Structures does not check for duplicates when you copy objects using this method.
How to use Radial array tool

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. Search for Radial array tool, and then double-click to open it.
3. Select the Copy method. The options are:
   - **Selected objects only**
     This is the default. Only the selected objects are copied.
   - **All associated objects**
     Selected objects and all objects associated with them are copied. For example, cuts, welds, and bolts.
   - **Advanced**
     This option is similar to All associated objects, but works better with modifications. For example, when you have stairs that have handrails welded to the steps, and you modify the distance between steps.
4. Select the Rotate copies option. The default is Yes.
5. Define the rotation axis.
   The default is X.
6. Define the settings.
7. Select the objects to copy.
8. Click OK to close the dialog box.
9. Click the middle mouse button.
10. Pick origin point.
11. Pick axis direction X.
12. Pick axis direction Y.
   The selected objects are copied.
## How to define the settings

1. **Distance between copies.** The default value is 0.

2. **Rotation.** The options are:
   - **Angle** (default)
     The copies are rotated by angle.
   - **Distance**
     The copies are rotated by distance.

3. **Number of angles or distances.** The default value is 0.

4. **Space between copies.**
   Use the space character to separate values. Enter a value for each space between copies.

5. **Copy direction.** The options are:
   - **Normal** (default)
     Spacing values are calculated from the origin in positive direction along the axis.
   - **Reverse**
     Spacing values are calculated from the origin in negative direction along the axis.
   - **Centered**
     Copies are centered on the origin.
<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mirror</strong></td>
<td>Spacing values are calculated from the origin in both positive and negative direction. Mirrored copying doubles the number of copies.</td>
</tr>
<tr>
<td>6</td>
<td>Radial distance.</td>
</tr>
<tr>
<td></td>
<td>The radial distance should be equivalent to the distance you picked when applying the component.</td>
</tr>
<tr>
<td></td>
<td>If the radial distance is smaller or greater than the picked distance, the spacing between the copied objects is not the same as given in the <em>Space between copies</em> box (4).</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures calculates the rotation angle according to the dialog box values (spacing and radial distance), and the rotation angle overrides the spacing given in the dialog box.</td>
</tr>
</tbody>
</table>

**Copy objects using Array of objects (29) component**

Use the *Array of objects (29)* component to copy model objects along a line. If you modify the original object, Tekla Structures also changes the copied objects.

1. Click the *Applications & components* button in the side pane to open the *Applications & components* catalog.
2. Search for the *Array of objects (29)* component, and then double-click to open it.
3. Define the settings:
   - **Number of copies**: Enter the number of copies you want to create.
   - **Spacing values**: Define the spacing of the objects.
   - **Copy to the opposite direction**: Select *Yes* if you want to copy in the direction opposite to the points you pick.
   - **Start point for copying**: Choose either the object to be copied or the first input point.
   - **Copy at equal distances**: Select *Yes* if you want to create the objects at equal distances. *Spacing value* will be ignored.
4. Click **OK** to save the settings.
5. Select the objects to copy.
6. Click the middle mouse button to finish selecting.
7. Pick a point to indicate the start of the line along which to arrange copied objects.
8. Pick a point to indicate the end of the line.
### Examples

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Example" /></td>
<td>An array of parts.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Example" /></td>
<td>An array of components.</td>
</tr>
</tbody>
</table>

#### 19.2 Copy by picking two points

The basic way to copy objects in a model or drawing is by defining the origin and one or more destination points.

1. Select the object you want to copy.
2. Run the **Copy** command:
   - In the model, on the **Edit** tab, click ![Copy](image3.png).
   - In the drawing, on the **Drawing** tab, click ![Copy](image4.png) --> ![Copy](image5.png).
3. Pick the origin for copying.
4. Pick one or more destination points.

The objects are copied immediately. The **Copy** command remains active.

5. If you want to undo the latest copy operation, click the **Undo** button on the top left corner of the Tekla Structures main window.

The **Copy** command still remains active.
6. To stop copying, press Esc.

19.3 Copy linearly
In the model, you can create multiple copies of an object in the same linear direction.
1. Select the objects you want to copy.
2. On the Edit tab, click Copy special --&gt; Linear. The Copy - Linear dialog box opens.
3. Pick two points, or enter the coordinates in the dX, dY, and dZ boxes. You can also use a formula to calculate the x, y, and z displacements. For example:

4. Enter the number of copies.
5. Click Copy.
6. To stop copying, press Esc.

TIP If the dialog box is open but the command is no longer active, click the Pick button to re-activate the command.

19.4 Copy by specifying a distance from origin
You can copy objects to a new position in the model or drawing by specifying a distance from the origin. Use the Enter a Numeric Location dialog box to specify the distance.
1. Select the objects you want to copy.
2. Run the Copy command:
   • In the model, on the Edit tab, click Copy.
   • In the drawing, on the Drawing tab, click Copy --&gt; Copy.
3. Pick the origin for copying.
4. Move the cursor in the direction you want to copy the objects, but do not pick the point.
5. Type the distance.
   When you start typing, Tekla Structures displays the Enter a Numeric Location dialog box automatically.

6. Click OK.

19.5 Copy using drag-and-drop
You can copy objects by dragging them to a new position.

1. On the File menu, click Settings and select the Drag & drop check box to activate the command.
2. Select the objects you want to copy.
3. Hold down the Ctrl key and the mouse button, and drag the objects to the new position.

**NOTE** To copy grid labels in a drawing, first select the grid label and then either activate the Select grid line selection switch or select the grid label handle.

19.6 Copy objects to another object
In the model, you can copy objects from an object to other similar objects. This is useful, for example, when you detail previously modeled parts. The objects that you can copy between can have different dimensions, length, and rotation.

1. Select the objects you want to copy.
2. On the Edit tab, click Copy special --> To another object.
3. Select the object to copy from (source object).
4. Select the objects to copy to (target object).

19.7 Copy all content to another object
In the model, you can copy objects from an assembly or cast unit to other similar assemblies or cast units without individually selecting each object to copy. This is useful, for example, when you have detailed an assembly and want to copy all details to another similar assembly.

1. Ensure that the Select assemblies selection switch is active.
2. Select the assembly or cast unit to copy from (source object).

3. On the **Edit** tab, click **Copy special --> All content to another object**.

4. Select the assemblies or cast units to copy to (target objects).

As a result, Tekla Structures copies the following objects:

- Secondary parts
- Reinforcement, bolts, and welds
- Cuts, fittings, and edge chamfers
- Sub-assemblies
- Components

**NOTE** Tekla Structures does not copy pour breaks, or secondary parts created by a component that has also created the assembly main part. If some of the objects to be copied already exist in the assembly or cast unit to copy to, Tekla Structures may create duplicate objects. Tekla Structures warns you about duplicate secondary parts, reinforcement, and sub-assemblies, but not about duplicate bolts, welds, cuts, or components.

### 19.8 Copy to another plane

In the model, you can copy objects from the first plane you specify to the second (and third, etc.) plane you specify. The position of the copied objects relative to the second (and third, etc.) plane remains the same as the position of the original objects relative to the first plane.

1. Select the objects you want to copy.

2. On the **Edit** tab, click **Copy special --> To another plane**.

3. Pick the point of origin of the first plane.

4. Pick a point on the first plane in the positive x direction.

5. Pick a point on the first plane in the positive y direction.

6. Repeat steps 3–5 for all destination planes.
19.9 Copy from another model
You can copy objects from another model. Tekla Structures only copies secondary parts from the model if they belong to the same phase as their main part. This applies to both model and component parts.

1. On the Edit menu, click Copy special --&gt; From another model. The Copy from Model dialog box opens.
2. In the Model directories list, select the model to copy from.
3. Enter the numbers of the phases from which to copy objects, separated by spaces. For example, 2 7.
4. Click Copy.
5. Close the dialog box.

19.10 Move objects
You can move objects in a number of different ways, especially in models. When you move an objects, Tekla Structures also copies all objects connected to it.

19.11 Move by picking two points
The basic way to move objects in a model or drawing is by defining the origin and one or more destination points.

1. Select the object you want to move.
2. Run the Move command:

   • In the model, on the Edit tab, click Move.
   • In the drawing, on the Drawing tab, click Move --&gt; Move
3. Pick the origin for moving.
4. Pick a destination point.

The object is moved immediately. The Move command does not remain active.

19.12 Move linearly
You can move objects linearly to a new position in the model.
1. Select the objects you want to move.

2. On the Edit tab, click Move special --> Linear.
The Move - Linear dialog box opens.
3. Pick two points in the model, or enter the coordinates in the dX, dY, and dZ boxes.
You can also use a formula to calculate the x, y, and z displacements. For example:

\[ \Delta V = 3.750 \]

4. Click **Move**.

**TIP** If the dialog box is open but the command is not active anymore, click the **Pick** button to re-activate the command.

## 19.13 Move by specifying a distance from origin

You can move objects to a new position in the model or drawing by specifying a distance from the origin. Use the **Enter a Numeric Location** dialog box to specify the distance.

1. Select the objects you want to move.
2. Run the **Move** command:
   - In the model, on the **Edit** tab, click **Move**.
   - In the drawing, on the **Drawing** tab, click **Move** --> **Move**.
3. Pick the origin for moving.
4. Move the cursor in the direction you want to move the objects, but do not pick the point.
5. Type the distance.
   - When you start typing, Tekla Structures displays the **Enter a Numeric Location** dialog box automatically.
6. Click **OK**.

## 19.14 Move using drag-and-drop

You can move objects by dragging them to a new position.

1. On the **File** menu, click **Settings** and select the **Drag & drop** check box to activate the command.
2. Select the objects you want to move.
3. To move the objects, hold down the mouse button and drag the objects to the new position.
4. To move the end of an object, select the handle, hold down the mouse button, and drag the handle to the new position.

   For some objects, you may need to switch on Smart select to drag from handles without selecting them first. To switch it on, click File menu --> Settings and select the Smart select check box.

   NOTE To move grid labels in a drawing, first select the grid label and then either activate the Select grid line selection switch or select the grid label handle.

19.15 Move to another plane

   In a model, you can move objects from the first plane you specify to another plane, which you specify by picking three points. The moved objects remain in the same position on the second plane as the original objects on the first plane.

   1. Select the objects you want to move.

   2. On the Edit tab, click Move special --> To another plane.

   3. Pick the point of origin of the first plane.

   4. Pick a point on the first plane in the positive x direction.

   5. Pick a point on the first plane in the positive y direction.

   6. Repeat steps 3–5 for the destination plane.

19.16 Move objects to another object

   In a model, you can move objects from an object to other, similar objects. This is useful, for example, when you detail previously modeled parts. The objects that you move between can have different dimensions, length, and rotation.

   1. Select the objects you want to move.

   2. On the Edit tab, click Move special --> To another object.

   3. Select the object to move from (source object).

   4. Select the objects to move to (target object).
19.17 Rotate objects
You can copy or move an object in a model by rotating it around any line you choose. In a drawing, you can copy or move an object by rotating it around a given line on the work plane.

NOTE Positive rotation is according to the right-hand rule (clockwise when looking from the start point of the rotation axis).

19.18 Rotate around a line
Use the line option in the Rotate dialog box when you want to copy and rotate, or move and rotate objects around any given line in the model.

1. Select the objects you want to copy or move.
2. Activate the rotation command.
   • To copy and rotate, go to the Edit tab and click Copy special --> Rotate.
     The Copy - Rotate dialog box opens.
   • To move and rotate, go to the Edit tab and click Move special --> Rotate.
     The Move - Rotate dialog box opens.
3. In the Around list, select line.
4. Pick the start point of the rotation axis, or enter its coordinates.
5. Pick the end point of the rotation axis, or enter its coordinates.
6. If you are copying, enter the number of copies.
7. If needed, enter the dZ value, which is the difference in position between the original and copied object in the z direction.
8. Enter the rotation angle.
9. Click Copy or Move.
   The objects are rotated accordingly.

Example
In this example, a fitting plate is copied and rotated around a construction line that is located at the following coordinates.
As a result, the copied fitting plates follow the curve of the concrete panel.

19.19 Rotate around the z axis

Use the Z option in the Rotate dialog box when you want to copy and rotate, or move and rotate objects around the z axis in the model.

1. Select the objects you want to copy or move. For example:
2. Activate the rotation command.

- To copy and rotate, go to the Edit tab and click \[Copy special --> \] Rotate . The Copy - Rotate dialog box opens.

- To move and rotate, go to the Edit tab and click \[Move special --> \] Rotate . The Move - Rotate dialog box opens.

3. Select Z in the Around list.

4. Pick a point to define the rotation axis, or enter its coordinates.

   In the example below, the red cross indicates the picked point.

5. If you are copying, enter the number of copies.

6. If needed, enter the dZ value, which is the difference in position between the original and copied object in the z direction.

7. Enter the rotation angle. For example:
8. Click **Copy** or **Move**.

The objects are rotated accordingly.

19.20 **Rotate drawing objects**

Use this option when you want to rotate drawing objects on the work plane.

1. Select the objects you want to copy or move.
2. Activate the rotation command.

- To copy and rotate, go to the Drawings tab and click **Copy** --> Rotate.

  The **Copy - Rotate** dialog box opens.

- To move and rotate, go to the Drawings tab and click **Move** --> Rotate.

  The **Move - Rotate** dialog box opens.

3. Pick a point, or enter its coordinates.
4. If you are copying, enter the number of copies.
5. Enter the rotation angle.
6. Click **Copy** or **Move**.

### 19.21 Mirror objects

When you copy or move objects, you can mirror them through a plane that is perpendicular to the work plane and passes through a line you specify.

Note that Tekla Structures cannot create mirrored copies of component properties. The **Copy special > Mirror** command does not fully mirror objects if they include components that contain, for example, asymmetrically positioned parts.

### 19.22 Mirror model objects

Use this method to copy and mirror, or move and mirror objects in a model.

1. Select the objects you want to copy or move.
2. Activate the mirroring command.

   - To copy and mirror, go to the **Edit** tab and click **Copy special --> Mirror**.  
     The **Copy - Mirror** dialog box opens.
   
   - To move and mirror, go to the **Edit** tab and click **Move special --> Mirror**.  
     The **Move - Mirror** dialog box opens.

3. Pick the start point of the mirroring plane, or enter its coordinates.
4. Pick the end point of the mirroring plane, or enter its coordinates.
5. Enter the angle.
6. Click **Copy** or **Move**.

### 19.23 Mirror drawing objects

Use this method to copy and mirror, or move and mirror objects in a drawing.

1. Select the objects you want to copy or move.
2. Activate the mirroring command.
• To copy and mirror, go to the Edit tab and click Copy special --> Mirror.
   The Copy - Mirror dialog box opens.

• To move and mirror, go to the Edit tab and click Move special --> Mirror.
   The Move - Mirror dialog box opens.

3. Pick the start point of the mirroring plane, or enter its coordinates.
4. Pick the end point of the mirroring plane, or enter its coordinates.
5. Enter the angle.
6. Click Copy or Move.
Filter objects

Use filters to restrict what can be selected or what is visible in a view. For example, you can create a selection filter that allows you to only select objects that have certain characteristics. This can be useful when you want to perform an operation on several objects at the same time.

You can create filters of your own, or you can use any of the standard filters available in Tekla Structures.

- Use existing filters (page 132)
- Create new filters (page 133)
- Examples of filters (page 138)

20.1 Use existing filters

Before you start creating your own custom filters, check out the standard filters available in Tekla Structures.

20.2 How to use a view filter

Use view filters to define which objects are displayed in a model view.

1. Double-click the view to open the View Properties dialog box.
2. Select a filter from the Visible object group list.
3. Click Modify.

Now only the objects defined by the filter are visible.

If you cannot see all desired objects, note that the work area, view depth, view setup, and object representation settings also affect the visibility of objects.
20.3 How to use a selection filter
Use selection filters to select objects in a model.
1. On the Selecting toolbar, select a filter from the list:

Now only the objects defined by the filter can be selected.
2. Select the desired objects in the model.
   Note that you can only select objects that are visible in the view. If you cannot select all objects defined by the selection filter, check that you have switched on all the needed selection switches (page 73).

20.4 Create new filters
You can create custom filters for viewing and selecting objects both in models and drawings.

20.5 Create a view filter
You can create your own custom view filters to define which objects are visible in a model.
1. Double-click the view to open the View Properties dialog box.
2. Click Object group to open the Object Group - View Filter dialog box.
3. Modify the filter settings.
   a. If you want to remove all existing filter rules, click New filter.
   b. Click Add row to add a new filter rule.
   c. Select options from the Category, Property, and Condition lists.
   d. In the Value list, enter a value or select one from the model.
   e. Add more filter rules, and use the And/Or options or parentheses to create more complex rules.
4. Select the check boxes next to all filter rules that you want to enable.
   The check boxes define which filter rules are enabled and effective.
5. Define the filter type.
   a. Click to display the advanced saving settings.
b. Select or clear the check boxes to define where the filter will be visible.

For example, you can create a filter that can be used both as a view filter and as a selection filter.

6. Enter a unique name in the box next to the **Save as** button.

**TIP** Do not use spaces in filter names. To have the filter appear at the top of the list, right after the standard filter, use capital letters in the filter name.

7. Click **Save as** to save the filter.

### 20.6 Create a selection filter

You can create your own custom filters to help you select objects in a model.

1. On the **Selecting** toolbar, click **Object Group - Selection Filter** dialog box.

2. Modify the filter settings.
   a. If you want to remove all existing filter rules, click **New filter**.
   b. Click **Add row** to add a new filter rule.
   c. Select options from the **Category, Property, and Condition** lists.
   d. In the **Value** list, enter a value or select one from the model or drawing.
   e. Add more filter rules, and use the **And/Or** options or parentheses to create more complex rules.

3. Select the check boxes next to all filter rules that you want to enable.
   The check boxes define which filter rules are enabled and effective.

4. Define the filter type.
   a. Click **>>** to display the advanced saving settings.
   b. Select or clear the check boxes to define where the filter will be visible.

For example, you can create a selection filter that can be used both in the model and in drawings.
5. Enter a unique name in the box next to the **Save as** button.  
Do not use spaces in filter names. To have the filter appear at the top of the list, right after the standard filter, use capital letters in the filter name.
6. Click **Save as** to save the filter.

20.7 **Create a drawing filter**

For general arrangement drawings, you can create drawing filters that affect the whole drawing, not just a specific view.

You can use drawing filters together with saved object property files when you create and apply object level settings in the whole drawing. For example, you might create a filter that selects all beams, then save an object property file that defines that the part color is blue, and then create and apply an object level settings file that changes all beams to blue in the whole drawing.

1. On the **Drawing** tab, click **Properties --> Drawing**.
2. Click **Filter**.
3. Modify the filter settings:
   - To remove all existing filter rules, click **New filter**.
   - Click **Add row** to add a new filter rule.
   - Select options from the **Category**, **Property**, and **Condition** list boxes.
     For example, to create a drawing filter for parts, select **Parts** as the **Category**, **Name** as the **Property**, **Equals** as the **Condition**.
   - In the **Value** box, enter a value or select the required object from the drawing.
     For example, select a part from the drawing.
   - You can add more rows, and use the **And/Or** options or parentheses to create more complex rules.
4. Select the check boxes next to all filter rows that you want to enable.
   The check boxes define which rows of the filter are enabled and effective.

5. Define the filter type.
   a. Click ➤ to display the advanced saving settings.
   b. Select or clear the check boxes to define where the filter will be visible.
      For example, you can create a filter that can be used for all drawing types or just for the current drawing type, or a filter that can be used in all drawings and in Organizer.

6. Enter a unique name in the box next to the **Save as** button.
7. Click **Save as** to save the filter.
8. Click **Cancel** to close the filter properties dialog box.

Now you can use the created drawing filter for example, for creating object level settings in the whole drawing.

### 20.8 Create a drawing view filter

You can create your own custom view filters to help you select a specific group of view objects in a drawing view. For example, you can use these filters for changing the appearance of a certain object group, or for selecting which objects are shown in a drawing view. You can also use them in creating detailed object level settings, which you can apply in the selected views.

You can use view filters together with saved object property files when you create and apply object level settings in the selected view. For example, you might create a view filter that selects all columns in a view, then save an object property file that defines that the part color is red, and then create and apply an object level settings file that changes all columns to red in the selected view.

1. Open a drawing.
2. Double-click the view frame.
3. Click **Filter**.
4. Modify the filter settings:
   - If you want to remove all existing filter rules, click **New filter**.
   - Click **Add row** to add a new filter rule.
   - Select options from the **Category**, **Property**, and **Condition** list boxes. For example, to create a view filter for parts, select **Parts** as the **Category**.
     - In the **Value** box, enter a value or select the object from the drawing.
   - You can add more rows, and use the **And/Or** options or parentheses to create more complex rules.
5. Select the check boxes next to all filter rules that you want to enable.
   The check boxes define which filter rules are enabled and effective.
6. Define the filter type.
   a. Click to display the advanced saving settings.
b. Select or clear the check boxes to define where the filter will be visible.

For example, you can create a filter that can be used for all drawing types or just for the current drawing type, or a filter that can be used in all drawings and in Organizer.

7. Enter a unique name in the box next to the Save as button.

**TIP** Do not use spaces in filter names. To have the filter appear at the top of the list, right after the standard filter, use capital letters in the filter name.

8. Click Save as to save the filter.

Now you can use the created view filter, for example, for creating object level settings in the selected view.

### 20.9 Possible values in filtering

You can create filters that contain several properties. You can also have multiple filtering values for each property. By using conditions, parentheses, and the And/Or option you can create filters that can be as complex as needed.

Empty values are matched to empty properties in filtering.

If you use multiple values, separate the strings with blank spaces (for example, 12 5). If a value consists of multiple strings, enclose the entire value in quotation marks (for example, "custom panel"), or use a question mark (for example, custom?panel) to replace the space.

**NOTE** When you create filter rules between objects whose Category settings differ, use the And option when possible to avoid potential problems with more complex rules.

#### Template attributes in filters

You can select objects according to template attributes. To do this, select Template from the Category list, and then select the desired template attribute from the Property list.

Use the following units when filtering template attributes, even when using the US Imperial environment:

- **mm** for length
- **mm**² for area
- **kg** for weight
- **degree** for angle

Filter objects 137 Possible values in filtering
TIP To check which unit Tekla Structures uses for a particular template attribute, use the Select from model option in the Value list.

See also
Wildcards (page 151)

20.10 Examples of filters
Here are some examples of filters that you can create. The same filtering techniques can be used both for view filters and selection filters.

20.11 Filter beams and columns
Create a filter based on object names.
1. Create an empty view or selection filter. (page 133)
2. Click Add row twice to add two new rows.
3. Fill in the part names, BEAM and COLUMN.
4. Select the Or option. The filter is now looking for an object that has the Name BEAM or COLUMN.
5. Enter a unique name in the box next to the Save as button.
6. Click Save as.

<table>
<thead>
<tr>
<th>Category</th>
<th>Property</th>
<th>Condition</th>
<th>Value</th>
<th>And/Or</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part</td>
<td>Name</td>
<td>Equals</td>
<td>BEAM</td>
<td>Cr</td>
</tr>
<tr>
<td>Part</td>
<td>Name</td>
<td>Equals</td>
<td>COLUMN</td>
<td></td>
</tr>
</tbody>
</table>

20.12 Filter parts in specific phases
Create a filter based on objects' phase numbers.
1. Create an empty view or selection filter. (page 133)
2. Click Add row.
3. Fill in the part phases, 1 and 2.
   Separate the strings with a blank space.
4. Enter a unique name in the box next to the Save as button.
5. Click Save as.
20.13 Filter out parts that have a certain profile

If you only want to select certain parts, filter out the remaining parts.

1. Create an empty view or selection filter. (page 133)
2. Click Add row.
3. Fill in the profile, \textit{BL200*20}.
4. Select \textit{Does not equal} from the Condition list.
5. Enter a unique name in the box next to the Save as button.
6. Click Save as.

<table>
<thead>
<tr>
<th>Category</th>
<th>Property</th>
<th>Condition</th>
<th>Value</th>
<th>And/Or</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part</td>
<td>Profile</td>
<td>Does not equal</td>
<td>BL200*20</td>
<td></td>
</tr>
</tbody>
</table>

20.14 Filter assemblies and cast units

Create a filter based on assembly types.

1. Create an empty view or selection filter. (page 133)
2. Click Add row.
3. In the Category list, select Assembly.
4. In the Property list, select Assembly type.
5. In the Value box, enter the number of the assembly type, or use the Select from model... option to select a value from the model.
6. Enter a unique name in the box next to the Save as button.
7. Click Save as.

<table>
<thead>
<tr>
<th>Value</th>
<th>Assembly type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>precast</td>
</tr>
<tr>
<td>1</td>
<td>cast in place</td>
</tr>
<tr>
<td>2</td>
<td>steel</td>
</tr>
<tr>
<td>3</td>
<td>timber</td>
</tr>
<tr>
<td>6</td>
<td>miscellaneous</td>
</tr>
</tbody>
</table>
20.15 **Filter sub-assemblies**
Create a filter to select or view parts that belong to a sub-assembly.

1. Create an empty view or selection filter. (page 133)
2. Click Add row.
3. In the Category list, select Template.
4. In the Property list, select ASSEMBLY.HIERARCHY_LEVEL.
5. In the Condition list, select Does not equal.
6. In the Value list, enter 0.
7. Enter a unique name in the box next to the Save as button.
8. Click Save as.

<table>
<thead>
<tr>
<th></th>
<th>Category</th>
<th>Property</th>
<th>Condition</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓</td>
<td>Assembly</td>
<td>Assembly type</td>
<td>Equals</td>
<td>0</td>
</tr>
</tbody>
</table>

20.16 **Filter out reference models**
If you only want to have certain reference models visible in the model, filter out the remaining reference models based on their ID numbers.

1. Create an empty view filter. (page 133)
2. Click Add row.
3. In the Category list, select Reference object.
4. In the Property list, select Id number.
5. In the Condition list, select Does not equal.
6. In the Value list, enter the ID numbers of the reference models you want to hide.
   To hide several reference models, separate their IDs with spaces.
7. Enter a unique name in the box next to the Save as button.
8. Click Save as.
20.17 Filter reference model object properties

Create a filter based on reference model object properties.

1. Create an empty view or selection filter. (page 133)
2. Click Add row.
3. In the Category list, select Template.
4. In the Property list, select the required template attribute, and enter the property value prefix EXTERNAL.
5. In the Condition list, select Equals.
6. In the Value list, select Select from model and select the required object in the model.
7. Enter a unique name in the box next to the Save as button.
8. Click Save as.

20.18 Copy a filter to another model

You can copy existing filters to a specific model or all models.

1. Select the filter you want to copy.

   The filters you have created are located in the attributes folder under the current model folder. View filters have the file name extension .VObjGrp, and selection filters have the file name extension .SObjGrp.

2. To make the filter available in another model, copy the file to the attributes folder of the destination model folder.

3. To make the filter available in all models, copy the file to the project or firm folder, defined by the advanced option or .

4. Restart Tekla Structures.
20.19 Delete a filter

You can delete filters from the model's attributes folder.

1. Delete the filter file located in the model's attributes folder.
   View filters have the file name extension *.VObjGrp, and selection filters have the file name extension *.SObjGrp.

2. Restart Tekla Structures.
A screenshot is an image of a model or drawing view. You can use screenshots in posters, brochures, or other material to show projects carried out using Tekla Structures.

By default, the screenshots are saved in the \screenshots folder under the current model folder with the name snap_xx.png.
Take a screenshot of a model

You can take screenshots of model views.

1. Open a model and adjust the model view according to your needs.
   For example, hide the work area box (page 61) if you do not want to show it.

2. On the View tab, click **Screenshot**.

3. If you have multiple views of the model, click **Pick view** and select the view to take the screenshot from.

4. To modify the settings, click **Options**.
   a. Define the width, height, and DPI of the screenshot.
   b. Click **OK** to save the changes.

5. Define a name and location for the screenshot.
   a. Select **Print to file** and enter a descriptive name for the screenshot in the **File name** box.
      You can also change the whole path. If you do not want to do this, you can keep the default values for the path and the file name.

6. Click **Show with associated viewer** to show the screenshot in an application that is by default associated with this file type.

7. Click **Capture**.
23 Take a screenshot of a drawing

A drawing screenshot is an image of an open drawing with or without borders.

1. Open a drawing and adjust the drawing view according to your needs.
   For example, delete unnecessary marks or dimensions, and hide unnecessary parts.

2. On the Views tab, click Screenshot.

3. Do one of the following:
   • Select View to take a screenshot of the open drawing with window borders
   • Select View without borders to take a screenshot of the open drawing without window borders.

4. Under the preselected Print to file option enter a descriptive name for the screenshot in the File name box.
   You can also change the whole path. If you do not want to do this, you can keep the default values for the path and the file name.

5. Click Show with associated viewer to show the screenshot in an application that is by default associated with this file type.

6. Click Capture.
Save a screenshot in bitmap format

By default, screenshots are created as Portable Network Graphics (.png) files. You can also save a screenshot in bitmap (.bmp) format to use it, for example, as a custom component thumbnail.

1. On the Views tab, click Screenshot --&gt; Screenshot.
2. Select Place on clipboard.
3. Click Capture.
4. Paste the screenshot in your graphics editor and save it in .bmp format.

**NOTE** The software that you use to open the screenshot may have a limit for the number of pixels.
Here we provide useful hints and tips that help you use the Tekla Structures user interface and its basic features more efficiently.

- **Switch rollover highlight on or off (page 148)**
  By default, Tekla Structures highlights the objects in yellow, so that you can easily see which objects you can select. You can switch the highlighting on or off.

- **Select values from the model (page 148)**
  You can select object properties and dates directly from the model. This can be useful when creating view filters, selection filters, and object groups.

- **Interrupt object selection (page 149)**
  You can have Tekla Structures interrupt the object selection process if the selection takes over a defined period of time. For example, if you are working on a large model and you accidentally select all or part of the model, you can interrupt the selection if it takes over 5000 milliseconds (5 seconds) to complete.

- **Select on right-click (page 150)**
  You can change the settings so that you can select objects also with the right mouse button.

- **Copy and move efficiently (page 150)**
  You can keep the Move and Copy dialog boxes open if you are going to use them often, for example when creating grids and levels in a new model.

- **Change a property in several parts at the same time (page 150)**
  You can quickly change a property in multiple parts simultaneously.

- **Show or hide "Do not show this message again" (page 151)**
  Sometimes when Tekla Structures displays warning messages, you have the option to hide future warnings of the same type. You can have Tekla Structures show these warnings again.
• **Wildcards (page 151)**

A wildcard is a symbol that stands for one or more characters. You can use wildcards to shorten strings, for example in filtering.

---

### 25.1 Switch rollover highlight on or off

By default, Tekla Structures highlights the objects in yellow, so that you can easily see which objects you can select. You can switch the highlighting on or off.

1. On the **File** menu, click **Settings** and select or clear the **Rollover highlight** check box. Alternatively, you can press **H**.

---

![Diagram showing the rollover highlight feature]
25.2 Select values from the model

You can select object properties and dates directly from the model. This can be useful when creating view filters, selection filters, and object groups.

Before you start, create an empty view or selection filter, or an object group.

1. Create an empty view or selection filter (page 133), or an object group.
2. Click Add row.
3. Select options from the Category and Property lists.
4. In the Value list, select one of the options.

The availability of options depends on your selection in the Property list. You can select dates from the model only if the property is a date.

a. To select an object property, click Select from model and then select an object.

b. To select a date, click Select date to open the Select date dialog box, and then select one of the options.

You can either select a date from the calendar, select the review date, or define the number of days before or after the review date. The review date is the same as Review date in the dialog box.

25.3 Interrupt object selection

You can have Tekla Structures interrupt the object selection process if the selection takes over a defined period of time. For example, if you are working on a large model and you accidentally select all or part of the model, you can interrupt the selection if it takes over 5000 milliseconds (5 seconds) to complete.

1. Define the time after which Tekla Structures asks if you want to interrupt object selection.
   a. On the File menu, click Settings --> Advanced options and go to the Modeling Properties category.
   b. Modify the advanced option XS_OBJECT_SELECTION_CONFIRMATION. The default value is 5000 milliseconds.
   c. Click OK.
2. Select (page 101) all or part of the model.
3. When Tekla Structures asks if you want to interrupt object selection, click Cancel.
25.4 Select on right-click
You can change the settings so that you can select objects also with the right mouse button.
1. On the File menu, click Settings and select the following check boxes:
   - Select on right click
   - Rollover highlight
2. Right-click an object to select it. Tekla Structures highlights the object and shows the related shortcut menu.

25.5 Copy and move efficiently
You can keep the Move and Copy dialog boxes open if you are going to use them often, for example when creating grids and levels in a new model.
1. Run the Copy or Move command.
2. To stop copying or moving objects, right-click and select Interrupt from the pop-up menu.
   The dialog box remains open on the screen.
3. To continue copying or moving objects:
   a. Click the dialog box to activate it.
   b. Select an object.
   c. Enter the values you want to use, and then click the Move or Copy button in the dialog box.

25.6 Change a property in several parts at the same time
You can quickly change a property in multiple parts simultaneously.
1. Double-click a part to open the properties dialog box.
2. Click \(\text{\ns} / \text{\ns}\) to clear all selections from the check boxes next to the properties.
3. Select the check box next to the property that you want to change, for example Class.
4. Change the value.
   Leave the dialog box open.
5. Select all parts whose value you want to change.
6. Click Modify in the part properties dialog box.
7. Click Cancel to close the dialog box.

See also
Create and modify objects (page 69)

25.7 How to restore missing toolbars
You can bring back the Selecting and Snapping toolbars, if you have accidentally removed them.
1. Go to (page 27).
2. Enter a search term:
   • Type selecting if you are looking for the Selecting toolbar.
   • Type snapping if you are looking for the Snapping toolbar.
3. Select the toolbar from the list that appears. The toolbar becomes visible.

25.8 Show or hide "Do not show this message again"
Sometimes when Tekla Structures displays warning messages, you have the option to hide future warnings of the same type. You can have Tekla Structures show these warnings again.

1. To hide future warnings of the same type, select the Do not show this message again check box.
2. To re-display the warnings, hold down the Shift key while running a command that should normally induce a warning message. For example, copy or move objects outside the work area. Tekla Structures displays the associated warning message.
25.9 Wildcards

A wildcard is a symbol that stands for one or more characters. You can use wildcards to shorten strings, for example in filtering.

<table>
<thead>
<tr>
<th>Wildcard</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>* (asterisk)</td>
<td>Matches any number of characters</td>
<td>HE* matches all parts with a profile name that begins with the characters &quot;HE&quot;. You can also use this symbol at the beginning of a word: <em>BRAC</em>.</td>
</tr>
<tr>
<td>? (question mark)</td>
<td>Matches a single character</td>
<td>HE?400 matches parts with profile names such as HEA400, HEB400, and HEC400</td>
</tr>
<tr>
<td>[] (square brackets)</td>
<td>Matches whatever is enclosed in the brackets</td>
<td>L[78]X4X1/2 matches parts with the profile names L7X4X1/2 and L8X4X1/2</td>
</tr>
</tbody>
</table>

**NOTE** The characters * and ? can also be used in object names. If the object name you want to filter contains * or ?, you need to enclose these characters in square brackets. For example, to find the profile P100*10, enter P100[*]10 in the filter field.

**See also**

Filter objects (page 132)
Disclaimer

© 2016 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced Software. Use of the Software, and use of this Software Manual are governed by a License Agreement. Among other provisions, the License Agreement sets certain warranties for the Software and this Manual, disclaims other warranties, limits recoverable damages, defines permitted uses of the Software, and determines whether you are an authorized user of the Software. All information set forth in this manual is provided with the warranty set forth in the License Agreement. Please refer to the License Agreement for important obligations and applicable limitations and restrictions on your rights. Trimble does not guarantee that the text is free of technical inaccuracies or typographical errors. Trimble reserves the right to make changes and additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by international treaties. Unauthorized reproduction, display, modification, or distribution of this Manual, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve, Fastrak and Orion are either registered trademarks or trademarks of Trimble Solutions Corporation in the European Union, the United States, and/or other countries. More about Trimble Solutions trademarks: http://www.tekla.com/tekla-trademarks. Trimble is a registered trademark or trademark of Trimble Navigation Limited in the European Union, in the United States and/or other countries. More about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product and company names mentioned in this Manual are or may be trademarks of their respective owners. By referring to a third-party product or brand, Trimble does not intend to suggest an affiliation with or endorsement by such third party and disclaims any such affiliation or endorsement, except where otherwise expressly stated.

Portions of this software:

D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved.
Disclaimer
starting
  Tekla Structures................................. 9

3
  3D models........................................ 13
  3D views............................................ 58

A
  adding
    grid lines....................................... 43
    align to left.................................. 31
    align to tab................................... 31
  Array of objects (29).......................... 116
  assemblies
    nested assemblies............................. 101
    selecting....................................... 101
  autosave......................................... 18

B
  background color
    changing........................................ 60
    examples....................................... 60
  basics............................................ 23
  basics of Tekla Structures
    tips............................................. 147
  blank project................................... 11
  buttons
    common buttons................................ 30

C
  cast units
    selecting....................................... 101
  colors
    changing the background color............... 60
    grid color..................................... 43,67
  commands
    ending.......................................... 24
    re-activating................................ 24
    searching...................................... 27
    using.......................................... 24
  components
    selecting...................................... 101
  configurations................................. 9,12
  contextual toolbar............................ 70
  coordinate system............................. 63
  coordinates.................................... 41
  copying
    filters......................................... 141
    hints and tips................................ 150
    objects......................................... 110,111
    Radial array tool............................ 113
    with Array of objects (29) component 116
  creating
    3D models..................................... 13
    grids.......................................... 41
    model templates.............................. 20
    models......................................... 15
    objects........................................ 69
    screenshots................................... 143
    view filters
      selection filters............................ 133
    views.......................................... 48
  customizing
    keyboard shortcuts........................... 33

D
  deleting
    objects......................................... 69
    views.......................................... 58
  dialog boxes
    common buttons............................... 30
    loading properties......................... 78
    saving properties......................... 78
    searching.................................... 27
direct modification
modifying................................................. 75
Do not show this message again.............. 151
drawing objects
moving....................................................122
rotating..................................................125

E
environments............................................. 9,12
test cases
background colors................................. 60
snapping...................................................89
snapping in drawings..............................86
tracking along a line...............................89

F
filtering
copying filters........................................ 141
deleting filters........................................142
objects.....................................................132
possible values...................................... 137
view filters
  selection filters......................................133
wildcards................................................ 151
filters
  selection................................................... 73

G
going to the start......................................... 23
global coordinate system.............................63
global point of origin.................................... 63
grid lines
  adding.......................................................43
  deleting......................................................45
  modifying.................................................... 44
grids
  coordinates............................................. 41
  creating.....................................................41
  deleting......................................................42
  grid color..................................................... 43,67
  labels..........................................................40,41
  line extensions............................................ 40
  modifying.................................................... 42
  origin.........................................................40
  grid work plane grid...............................64

H
hiding
dimensions............................................. 101
ribbon tabs............................................. 31
work area................................................. 61
highlighting
  objects..................................................... 148

I
if you cannot select objects.....................103
images
  thumbnail image of model.....................15
interrupting....................................................24
  object selection..............................................149

K
keyboard shortcuts..................................... 33
languages
  changing the language.............................32
  linear array tool........................................111
loading
  saved properties............................................78
local coordinate system............................63

M
message history......................................... 29
minimizing the ribbon..............................31
missing toolbars.........................................151
model templates
  creating.....................................................20
  modifying.................................................... 20
  options......................................................20
model views............................................. 46
models
about 3D models.....................................13
creating.....................................................15
moving...................................................... 25
rotating..................................................... 25
saving........................................................18
thumbnail image..................................... 15
zooming....................................................25
modifying
  model templates..................................... 20
  objects.....................................................69
  properties in many parts simultaneously.................................................................150
  using direct modification.........................75
moving
  drawing objects..................................... 122
  hints and tips...........................................150
  models in a view..................................... 25
  objects......................................... 110,111,122
  multi-user vs single-user.........................15

N
navigation mode........................................... 31
nested assemblies........................................... 101

O
objects
  copying............................................. 110,111
  creating............................................. 69
  deleting............................................. 69
  filtering............................................ 132
  modifying........................................... 69
  moving.............................................. 110,111,122
  rotating............................................. 125
  selecting........................................... 101
opening
  models................................................ 14
  origin.................................................. 63
  overriding snap switches......................... 86

P
panning...................................................... 25
parts
  modifying properties.............................. 150
tips..........................................................150
plane views.............................................. 58
project setup
  editing project properties........................ 16
  prompts............................................... 29
  properties
    project properties.................................16
Q
Quick Launch............................................. 27
R
radial array tool......................................... 113
redrawing views........................................... 59
refreshing views........................................... 59
restoring
  toolbars............................................... 151
ribbon
  changing the appearance........................ 31
  hiding............................................... 31
  minimizing.......................................... 31
right-click
  selecting............................................. 150
roles..................................................... 9,12
rollover highlight...................................... 148
rotating
  drawing objects................................... 125
  objects.............................................. 125
S
saving
  dialog box properties............................. 78
  models................................................ 18
  views.................................................. 57
screenshots
  creating............................................. 143
searching
  for commands and dialog boxes................ 27
selecting
  assemblies............................................ 101
  cast units...........................................101
  dates from model.................................. 148
  interrupting object selection................... 149
nested assemblies................................ 101
objects................................ 73,101,103,148
objects in components......................... 101
on right-click.......................................... 150
unable to select objects........................103
values from model................................ 148
selection filters................................. 73,133
selection switches.................................... 73
setting up Tekla Structures.................... 9,12
  blank project............................................ 11
setting up
  grid.................................................. 39
  views................................................ 39
  work area........................................... 39
  work plane......................................... 39
  workspace......................................... 39
settings
  model templates.................................. 20
  units and decimals............................... 39
shifting the work plane.........................64
shortcuts, see keyboard shortcuts............33
showing
  dimensions........................................ 101
  toolbars............................................. 86
  views................................................ 57
  work area.......................................... 61
side panes ........................................... 28
single-user vs multi-user.......................15
snap switches........................................ 80
overriding........................................... 86
snapping
  snap override..................................... 86
  snap priority..................................... 80
  snap zone......................................... 82
  using coordinates............................... 86
  using tracking.................................... 89
snapshots, see screenshots....................143
status bar........................................... 29
switching between
  views............................................. 58
tabs.................................................. 31
Tekla Structures
  user interface..................................... 23
templates
  model templates.................................. 20
thumbnail image..................................... 15
tips
  copying and moving efficiently............. 150
  selecting values from model................. 148
toolbars
  contextual toolbar............................. 70
  how to restore.................................. 151
  selection switches.............................. 73
tooltips.............................................. 24
tracking............................................... 89

U
units and decimals............................... 39
updating views...................................... 59
user interface....................................... 23
  languages......................................... 32

V
values
  selecting from model......................... 148
view filters.......................................... 133
view planes
  moving.............................................. 48
views................................................ 46
  creating.......................................... 48
  deleting.......................................... 58
  modifying......................................... 58
  naming............................................. 57
  opening............................................ 57
  refreshing......................................... 59
  saving............................................. 57
  switching between views..................... 58

W
warning messages................................. 151
wildcards.......................................... 151
work area.......................................... 61
  hiding............................................. 61
work plane
  shifting............................................ 64
  show or hide....................................... 64
Z
zooming in or out..............................................25