Contents

1 Start Tekla Structures.......................................................................................... 9
  1.1 What is a blank project...................................................................................11
  1.2 Check or change your Tekla Structures setup............................................. 12

2 Open, create, and save 3D models................................................................. 14
  2.1 Open a model...................................................................................................15
  2.2 Create a new model .......................................................................................16
  2.3 Create a thumbnail image of a model.......................................................... 17
  2.4 Edit project properties....................................................................................17
  2.5 Create model templates.................................................................................19
    Create a new model template................................................................................20
    Modify an existing model template.........................................................................20
    Download model templates......................................................................................21
    Model template options..........................................................................................21
  2.6 Save a model ...................................................................................................22
    Save the current model..........................................................................................22
    Save a copy with different name or location........................................................22
    Save a backup copy...............................................................................................23
    Save as a model template.......................................................................................23
    Define autosave settings......................................................................................23

3 Get familiar with the user interface......................................................... 25
  3.1 How to use commands...................................................................................26
  3.2 Zoom and rotate the model...........................................................................28
    Zoom in and out....................................................................................................28
    Rotate the model...................................................................................................28
    Pan the model.......................................................................................................29
  3.3 Find commands and dialog boxes.................................................................30
  3.4 Learn the common buttons...........................................................................31
  3.5 Change the appearance of the ribbon......................................................... 31
  3.6 Get instructions.............................................................................................32
  3.7 Minimize the ribbon.......................................................................................33
  3.8 How to use the contextual toolbar.............................................................. 34
    How to change object properties using contextual toolbar.................................34
    Show or hide contextual toolbar..........................................................................34
    Define contextual toolbar’s position......................................................................34
    Pin contextual toolbar in place.............................................................................35
    Minimize contextual toolbar...............................................................................35
    Customize contextual toolbar...............................................................................36
    Create user profiles for contextual toolbars.......................................................37
4.3 Create model views................................................................. 52
   Move the view plane........................................................................ 54
   Create views.................................................................................. 54
      Create a basic view of the model.................................................. 54
      Create a view using two points.................................................... 54
      Create a view using three points............................................... 55
      Create a view of the work plane................................................. 55
   Create grid views........................................................................ 55
   Create a view on a part plane......................................................... 58
   Create a 3D view of a part............................................................... 58
   Create default part views.............................................................. 59
   Create an undeformed part view................................................... 59
   Create a 3D view of a component.................................................. 59
   Create default component views................................................. 59
   Create a surface view................................................................... 60
      Create a surface view along selected edge................................ 61
   Open a view.................................................................................. 63
   Save a view.................................................................................. 64
   Modify a view............................................................................... 64
   Delete a view............................................................................... 64
   Switch between views.................................................................... 65
      Switch between open views....................................................... 65
      Switch between 3D and plane view......................................... 65
   Update and refresh views............................................................. 66
4.4 Define the work area.................................................................. 66
   Fit work area to entire model......................................................... 67
   Fit work area to selected parts....................................................... 67
   Fit work area using two points...................................................... 67
   Hide the work area box............................................................... 68
12.6 Viewing the model................................................................................................................. 190
12.7 Checking the model.............................................................................................................. 191
12.8 Drawings.................................................................................................................................. 191

13  Tips for basic tasks.................................................................................................................. 193
13.1 Switch rollover highlight on or off ......................................................................................... 194
13.2 Select values from the model................................................................................................. 195
13.3 Interrupt object selection......................................................................................................... 195
13.4 Select on right-click................................................................................................................. 196
13.5 Copy and move efficiently........................................................................................................ 196
13.6 Change a property in several parts at the same time.............................................................. 196
13.7 How to restore missing toolbars.............................................................................................. 197
13.8 Show or hide "Do not show this message again"...................................................................... 197

14  Disclaimer.................................................................................................................................. 199
When you start Tekla Structures, you are asked to choose your Tekla Structures setup. The setup consists of an environment, role, and configuration.

- **Environment** means region-specific settings and information. It defines which profiles, material grades, default values, connections, wizards, variables, reports, and templates you have available.

- **Role** is a user group profile that limits the availability of files and settings in an environment. The user interface has been customized for each role.

- **Configuration** consists of a set of features that the user is entitled to based on the license agreement. Each configuration is meant for a specific user group, to suit the various players in the construction industry.

1. Start Tekla Structures by selecting it from the Windows Start menu or by double-clicking the desktop icon.
The **Choose your Tekla Structures setup** dialog box appears.

2. Select an environment.
   
   If you cannot find the desired environment from the list, see Adding an environment to Tekla Structures.
   
   You can also select **Blank project (page 11)** to create a model that contains generic content, such as parametric profiles.

3. Select a role.
   
   The availability of roles depends on your environment, but typically the following roles are available:
   
   • All (a combination of all roles)
   • Concrete Contractor
   • Construction Management
   • Engineer
   • Precast Concrete Detailer
   • Rebar Detailer
   • Steel Detailer

4. Select a configuration.
   
   The configuration you are using may not contain all the features described in the Tekla Structures product guides. For more information on
the features available in each configuration, see Tekla Structures configurations.

5. Click **OK**. The **Welcome** page appears.

![Welcome page](image)

6. Select what you want to do:
   - On the **Recent** tab, you can open a recently used model.
   - On the **All models** tab, you can open any existing model (page 15).
   - On the **New** tab, you can create a new model (page 16).

**See also**

Check or change your Tekla Structures setup (page 12)

### 1.1 What is a blank project

Blank project is a Tekla Structures environment that includes only generic content, such as parametric profiles and undefined materials. It can be used for gathering region-, company-, or project-specific settings, tools, and information. The blank project is always included in the Tekla Structures installation.
Download and install content
You can use Tekla Warehouse to download and install content to the blank project. For example, you can download profiles, material grades, bolts, reinforcement, components, applications, and templates from Tekla Warehouse across all environment- and manufacturer-specific collections, and make combinations that suit your needs.
You can download and install content from Tekla Warehouse both before and during a project. Before starting a project, you can install content to your project and firm folders. During a project, you can install content to the model folder.

1.2 Check or change your Tekla Structures setup
You can check your current Tekla Structures setup (environment, role, and configuration) at any time without having to close the model.
1. On the File menu, click Settings and scroll down to the License area.
2. Change the setup if needed.
   You may be required to restart Tekla Structures after the changes.
Open, create, and save 3D models

With Tekla Structures, you can create a 3D real-life model of any structure. The model contains all the information that is needed to manufacture and construct the structure: part geometry and dimensions, profiles, materials, connection types, and so on.

- Open a model (page 15)
- Create a new model (page 16)
- Create model templates (page 19)
- Save a model (page 22)

Model output

The 3D model is also the single source of information for drawings and other outputs, such as reports and NC data files. This ensures that the information in drawings and reports is always up to date, as they react to modifications in the model.

Collaboration

You can use the multi-user mode or Tekla Model Sharing to work collaboratively within a model.
2.1 **Open a model**

You can have one model open at a time. If you open a model and already have one open, Tekla Structures prompts you to save the first model.

1. On the **File** menu, click **Open**.
2. Select the model you want to open.
   - To search for models in another folder, click **Browse**.
   - To open a recently used model folder, click the **Open model from folder** list.
   - To sort models by name, date, or type, click the column titles.
   - When the models are sorted alphabetically by their names, you can use the keyboard to select a model. For example, when you type N, Tekla Structures selects the first model starting with an N.
3. Click **Open**.
   If no views (page 52) are visible in the model, Tekla Structures prompts you to select one.

**See also**
- Create a new model (page 16)
- Create a thumbnail image of a model (page 16)

### 2.2 Create a new model

Create a separate model for each Tekla Structures project. Each model is stored in its own folder under the **TeklaStructuresModels** folder.

1. On the **File** menu, click **New**.
2. In the **Name** box, enter a name for the new model.
   Do not use special characters (/ \ ; : | ). We recommend that you try to decide on a permanent name at this point. The name of the model can be changed afterwards, but it involves changing several file names.
3. Define where to save the new model.
   By default, the model is saved in the **TeklaStructuresModels** folder that was created during installation. You can change the default folder by clicking **Browse**. You can also select a recently used folder from the **Save in** list.
4. If you want to use a **model template** (page 19), select one.
5. Under **Type**, define whether to run Tekla Structures in single-user or multi-user mode.
   - Single-user: the model will be used by one person at a time.
   - Multi-user: the model is stored on a server and may be used by several people simultaneously. Enter the name of the server in the **Server** box.
6. Click **Create**.
   Tekla Structures creates the model and opens the default model view (page 63). The contents of the model view may differ based on the model template you chose in step 4.

**See also**
- Create a thumbnail image of a model (page 16)
- Edit project properties (page 17)
2.3 Create a thumbnail image of a model

You can add a thumbnail image to make it easier to recognize your project even when you do not remember the exact name of the model. The thumbnail image is displayed when you browse for existing models.

1. On the View tab, click Screenshot --> Project thumbnail.
2. Select a view.

Tekla Structures creates the image and saves it in the model folder with the name thumbnail.png.
3. To check the thumbnail, go to the File menu, click Open, and select the model you created the thumbnail for.

The image is now displayed next to the model name. For example:

![Thumbnail Image](image)

1st steps europe

Environment: default
Version: 2016
Modified: 15.1.2016 14:49:42
Language: en

4. If you are unhappy with the thumbnail image, you can repeat steps 1–2 as many times as you need.

For example, you can zoom the model (page 28) in and out to adjust what is shown in the thumbnail image. When you create a new thumbnail, Tekla Structures overrides the existing thumbnail image with the new one.

TIP Alternatively, if you want to use a custom image, you can add the image directly to the model folder with the name thumbnail.png. The preferred size of the image is 120 x 74 pixels.

2.4 Edit project properties

You will need project information, such as project number and name, many times during a project. Update the project properties at the beginning of each
project to make reports and drawings display the correct information automatically. All of the fields are optional.

1. On the **File** menu, click **Project properties**.

2. Click ☞ **Edit**.

3. In the **Description** box, enter a description that helps you identify the model when you next need to open it.
   The description appears in the **Open** dialog box when you open a model.

4. Edit the other project properties.

5. To define project-specific user-defined attributes, click **User-defined attributes**.
   By default, you can define:
   • Project comment
   • User fields
   • Execution class
   • IFC export attributes
   • GEO coordinates
   • Status attributes
   • Unitechnic factory location
   The availability of user-defined attributes depends on your environment (page 9).

6. Click **Apply** to save your changes.
   Now you will get updated project properties in drawings and reports.

7. If you want to save these properties as the default properties for this project:
   a. Go to **Quick Launch** (page 30).
   b. Start typing **save defaults**.
   c. Select the **Save Defaults** command from the list.
   For more information on saving default properties, see Standard files.

**Displaying project information in templates and reports**
The fields in the image below refer to template attributes, which you can use when designing your own reports and templates. To display project information, add the corresponding template attributes in the templates and reports.
2.5  Create model templates

Model templates allow you to start a model with predefined company templates and settings. This can be especially useful for sub-contractors.
Only single-user models can be created with model templates. If you wish to create a multi-user model using a model template, create the model in single-user mode and then switch to multi-user mode.

By default, the model template folder is saved in your environment folder. Use the advanced option XS_MODEL_TEMPLATE_DIRECTORY to define a different location.

Create a new model template
You can create your own model templates and use them for creating new models. You can select which catalogs, custom components, model subfolders, drawing templates, and report templates from the model are included in the model template.

1. Create a new model (page 16).
   Always start by creating a new empty model. This is because old models that have been used in live projects cannot be completely cleaned. They may contain excess information that increases the size of the model even if you delete all objects and drawings from the model.

2. Add the desired part properties, drawing properties, profiles, materials, custom components, sketches, and so on, in the model.
   You can copy the needed attribute files from another model, for example.

3. On the File menu, click Save --> Save as model template.

4. Enter a name for the model template.

5. Select which catalogs, drawing templates, report templates, and model subfolders to include in the model template.
   For more information, see the section Model template options on this help page.
   You can only select files and folders that are available in the model folder. Catalogs are typically located in the Environment folder and they are included in the model folder only if they have been modified.

6. If you want to open the destination folder after creating the model template, select the check box.

7. Click OK.
   You can now use the model template for creating new models.

Modify an existing model template
To modify an existing template, save the model as a new template. Alternatively, you can modify the template by copying new or updated files directly to the model template folder.
1. Create a model using the existing model template.
2. Make the needed changes.
3. Save it as a new model template.

**Download model templates**
You can download, share, and store model templates using Tekla Warehouse.

**Model template options**
Use the **Save as Model Template** dialog box to define which files and folders are included in the model template.

<table>
<thead>
<tr>
<th>Option</th>
<th>Files and folders included</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profiles</td>
<td>profdb.bin</td>
</tr>
<tr>
<td></td>
<td>profitab.inp</td>
</tr>
<tr>
<td>Materials</td>
<td>matdb.bin</td>
</tr>
<tr>
<td>Components and sketches</td>
<td>ComponentCatalog.txt</td>
</tr>
<tr>
<td></td>
<td>ComponentCatalogTreeView.txt</td>
</tr>
<tr>
<td></td>
<td>Xslib.db1</td>
</tr>
<tr>
<td></td>
<td>thumbnail_bitmap.arc</td>
</tr>
<tr>
<td></td>
<td>*.dat files</td>
</tr>
<tr>
<td></td>
<td>CustomComponentDialogFiles folder</td>
</tr>
<tr>
<td>Attribute definitions</td>
<td>Includes all attribute definitions of the current model.</td>
</tr>
<tr>
<td>Bolts and bolt assemblies</td>
<td>screwdb.db</td>
</tr>
<tr>
<td></td>
<td>assdb.db</td>
</tr>
<tr>
<td>Reinforcement</td>
<td>rebar_database.inp</td>
</tr>
<tr>
<td></td>
<td>RebarShapeRules.xml</td>
</tr>
<tr>
<td></td>
<td>rebardatabase_config.inp</td>
</tr>
<tr>
<td></td>
<td>rebardatabase_schedule_config.inp</td>
</tr>
<tr>
<td>Meshes</td>
<td>mesh_database.inp</td>
</tr>
<tr>
<td>Options</td>
<td>Includes all options of the current model.</td>
</tr>
<tr>
<td>Drawing templates</td>
<td>*.tpl files</td>
</tr>
<tr>
<td>Report templates</td>
<td>*.rpt files</td>
</tr>
</tbody>
</table>
### 2.6 Save a model

You should save your model regularly to avoid losing any work. Tekla Structures also automatically saves your work at regular intervals.

#### Save the current model

To save changes to the current model file, do one of the following:

- On the top left corner of the screen, click **Save** 📝.
- On the **File** menu, click **Save** --> **Save**.
- Press **Ctrl+S**.

#### Save a copy with different name or location

You can create a copy of the model with a different name or in a different folder. The original version of the model remains intact.

**NOTE** When you save the model with a different name, all the GUIDs (globally unique identifiers) of the saved model will change and be different than in the original model. This means that the saved model has no relation to the original model, and the saved model cannot be used as backup.

1. On the **File** menu, click **Save as** --> **Save as**.
2. In the **Model name** box, enter a new name.
3. To save in a different location, click **Browse** and define where you want to save the model.
4. Click **OK**.

   Tekla Structures creates a new copy with a different name, but the original version of the model remains intact.
Save a backup copy
You can create a backup copy of the model with the same GUIDs (globally unique identifiers) as the original model.

1. On the File menu, click Save as --&gt; Save and create backup copy.
   Tekla Structures saves a copy of the model in the .\TeklaStructuresModels\backup\<model_name>\<date-time> folder.

2. If you need to take the backup copy into use in place of the current model, move the backup copy from the chosen date to your model folder.
   You can either replace all contents of the current model folder with the content of the chosen backup folder, or you can rename the backup folder (<date-time>) to match the original model name.

3. If you want to change the location of the backup folder, use the advanced option XS_MODEL_BACKUP_DIRECTORY.

   **NOTE** To save disk space, you can compress the XS_MODEL_BACKUP_DIRECTORY folder.

Save as a model template
See Create model templates (page 19).

Define autosave settings
Use Autosave to automatically back up and save your work at set intervals. You can set the autosave interval separately for the model and drawings. Autosave files have the extension .db1_<user>.

1. On the File menu, click Settings --&gt; Options, and go to the General settings.

2. Under Autosave, set the autosave interval.
   a. In the first box, define how often Tekla Structures saves the model or drawing.
      This number represents the number of commands you will have to run before Tekla Structures saves the model or drawing. For example, if you create many beams without interrupting the Create beam command, it only counts as one command.
   b. In the second box, enter the number of drawings after which Tekla Structures saves your work.

   **NOTE** If you set the interval values to less than 2, autosave is disabled.
3. Click OK.
4. Define where to store the **Autosave** files.
   
   By default, Tekla Structures stores the autosave files in the .. \TeklaStructuresModels\autosave folder. To change the folder, use the advanced option XS_AUTOSAVE_DIRECTORY.

5. Define whether to keep old autosave files.
   
   By default, Tekla Structures deletes the autosave files when you close a model, to save disk space. To keep autosave files even if you exit Tekla Structures without saving the model, use the advanced option XS_KEEP_AUTOSAVE_FILES_ON_EXIT_WHEN_NOT_SAVING.
3 Get familiar with the user interface

When you open a Tekla Structures model, a new window appears. By default, the user interface will look something like this:

1. This is your Tekla Structures model. If you are starting a completely new project, you will only see the default model view (page 52) and an empty grid (page 46) at this point.
2. The green cube symbol represents the global coordinate system (page 68) and it lies at the global origin (x=0, y=0, z=0).
3. The box around the grid represents the work area. In a view, you can only see the parts that are within this area. Objects that are outside the work area are invisible.
area exist in the model, but they are not visible. You can shrink and expand the work area (page 66) to suit your needs. You can also hide the work area box (page 66).

4. The coordinate symbol with the three axes x, y, and z represents the local coordinate system (page 68). It also indicates the direction of the model.

5. The File menu is where you manage your models. You can save models (page 22), print drawings, and import and export models, among other things.

6. The ribbon contains all the commands (page 26) and other functions you will use when building your model. You can customize the ribbon according to your needs.

7. By default, the Quick Access Toolbar contains the Save, Undo, and Redo buttons.

8. If you cannot find the command or dialog box you are looking for, search with Quick Launch (page 30).

9. Use the side pane (page 38) on the right-hand side of the screen to add reference models and components, or to view model object properties.

10. The selection switches (page 106) control which objects you can select.

11. The snap switches (page 93) control which positions you can pick when creating objects.

12. When you create objects (page 26), the status bar (page 32) will tell you how to proceed and when to pick points.

### 3.1 How to use commands

Learn the basic method of running and ending commands. All commands throughout Tekla Structures work in the same manner.

1. To find commands, slide the ribbon right or left with your mouse.

   ![Ribbon](image)

   Some commands have more options under them. The options become available when you click the command's name:
2. If you are unsure which command you need for your current task, rest the mouse pointer on a command.

A small window called tooltip appears. Tooltips provide more information about commands and also give examples, hints, and tips. For example:

![Measure distance (F)](image)

Measure distance (F)
Measure the distance between any two points. Use this command to measure inclined or aligned distances. By default, the results contain the distance and the coordinates. Follow the instructions on the status bar.

When a tooltip is open, you can press **Ctrl+F1** for more help on the subject.

**TIP** To switch the tooltips on or off, click File menu --> Settings --> Switches, and then select or clear the **Tooltips** check box.

3. When you find the command you need, click once to use it.

The command runs until you end it or use another command.

**NOTE** If you want to check or change the object properties before running the command, hold down the **Shift** key when you click the command. This brings up the properties dialog box. If you modify the properties, remember to save the changes (page 30).

4. To end a command, right-click and select **Interrupt**.

You can also press **Esc**.

5. To re-activate the last command, press **Enter**.

**See also**

Create, modify, and delete objects (page 76)
3.2 Zoom and rotate the model

The commands on the View tab allow you to focus on a particular area, or pull out for a wider view. You can use a mouse, command, keyboard shortcut, or a combination of these.

Zoom in and out
You can use a variety of tools to zoom in and out in the model. By default, the mouse pointer position determines the center point of zooming.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Scroll forward with the mouse wheel.</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Scroll backward with the mouse wheel.</td>
</tr>
<tr>
<td>Zoom to selected objects</td>
<td>1. Select the objects.</td>
</tr>
<tr>
<td></td>
<td>2. On the View tab, click Zoom --&gt; Zoom selected.</td>
</tr>
<tr>
<td>Zoom with menu commands</td>
<td>On the View tab, click Zoom and select one of the zoom commands.</td>
</tr>
<tr>
<td>Keep the center point of zooming in the middle of the view</td>
<td>On the File menu, click Settings and select Centered zooms.</td>
</tr>
<tr>
<td>Define the zoom ratio</td>
<td>Use these advanced options:</td>
</tr>
<tr>
<td></td>
<td>XS_ZOOM_STEP_RATIO</td>
</tr>
<tr>
<td></td>
<td>XS_ZOOM_STEP_RATIO_IN_MOUSEWHEEL_MODE</td>
</tr>
<tr>
<td></td>
<td>XS_ZOOM_STEP_RATIO_IN_SCROLL_MODE</td>
</tr>
</tbody>
</table>

Rotate the model
You can use either the middle or left mouse button to rotate the model in a view.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate using the middle mouse button</td>
<td>1. On the View tab, click Navigate --&gt; Set view point.</td>
</tr>
<tr>
<td></td>
<td>You can also press V.</td>
</tr>
<tr>
<td></td>
<td>2. To set the view point, pick a position in the view.</td>
</tr>
<tr>
<td></td>
<td>The following symbol appears in the model:</td>
</tr>
</tbody>
</table>
To | Do this
---|---
3. | Hold down the Ctrl key, and click and drag the model with the middle mouse button. Tekla Structures rotates the model around the view point you defined in step 2.

| Rotate using the left mouse button | 1. On the View tab, click Navigate --> Rotate with mouse. You can also press Ctrl+R.
2. To set the view point, pick a position in the view. The following symbol appears in the model:
3. Click and drag the model with the left mouse button. Tekla Structures rotates the model around the view point you defined in step 2.

---

Pan the model
You can use either the middle or left mouse button to pan the model in a view.

| To | Do this
---|---
Move the model using the middle mouse button | 1. On the File menu, click Settings and check that the Middle button pan check box is selected.
2. Hold down the middle mouse button and drag the model.

Move the model using the left mouse button | 1. To activate dynamic panning, go to the View tab and click Navigate --> Pan. You can also press P.
The mouse pointer changes to a hand:
2. Hold down the left mouse button and drag the model.
3. To stop panning, press Esc.
### 3.3 Find commands and dialog boxes

Use the **Quick Launch** box in the upper-right corner of the Tekla Structures main window to find commands, dialog boxes, and other functions. The shortcut key for **Quick Launch** is **Ctrl+Q**.

1. In the **Quick Launch** box, enter a search term. For example, type **bolt** if you are looking for bolt commands.
2. Wait for a list of search results to appear. For example:

   - **Ribbon**
     - Bolt (Steel)
     - Bolt points (Edit—Points)
     - Bolt spacing (Edit—Measure)
     - Bolted parts (Steel)
   - **Commands**
     - Bolt Assembly Catalog...
     - Bolt Catalog...
     - Bolt Points
     - Bolt Spacing
     - Bolt...

   Tekla Structures highlights the commands on the ribbon, to help you locate them. For example:

3. To run a command, click its name on the search results list. Or press **Enter** to instantly run the first command on the list.

**TIP** If the list of search results is no longer visible, press **Ctrl+Space** to reactivate it.
3.4 Learn the common buttons

The following table lists some common buttons that can be found in most of the Tekla Structures dialog boxes.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="OK" /></td>
<td>Saves the properties and closes the dialog box. Tekla Structures uses these properties the next time you create an object of this type.</td>
</tr>
<tr>
<td><img src="image" alt="Apply" /></td>
<td>Saves the properties without closing the dialog box. Tekla Structures uses these properties the next time you create an object of this type.</td>
</tr>
<tr>
<td><img src="image" alt="Modify" /></td>
<td>Modifies the selected objects using the current properties of the dialog box.</td>
</tr>
<tr>
<td><img src="image" alt="Get" /></td>
<td>Fills the dialog box with the properties of the selected object. If several objects are being selected, Tekla Structures takes the properties randomly from one of them.</td>
</tr>
<tr>
<td><img src="image" alt="Switch" /></td>
<td>Switches all check boxes in the dialog box on and off.</td>
</tr>
<tr>
<td><img src="image" alt="Cancel" /></td>
<td>Closes the dialog box without saving the properties or modifying objects.</td>
</tr>
<tr>
<td><img src="image" alt="Save" /></td>
<td>Saves the properties in the file shown in the list.</td>
</tr>
<tr>
<td><img src="image" alt="Load" /></td>
<td>Loads the previously saved properties to the dialog box. Tekla Structures also loads the properties of sub-dialog boxes, even if they are not open. Select the name of the properties file you want to use. For more information, see Save and load dialog box properties (page 83).</td>
</tr>
<tr>
<td><img src="image" alt="Save as" /></td>
<td>Saves the properties with the name given in the box. The Save as button also updates the Load list. This is important if you add or delete files manually. Tekla Structures stores the properties files in the model folder, also including the properties of sub-dialog boxes. For more information, see Save and load dialog box properties (page 83).</td>
</tr>
</tbody>
</table>

3.5 Change the appearance of the ribbon

You can change the order of ribbon tabs, choose how they are aligned, and even hide some parts of the ribbon if you do not need them in your current project. For example, if you are only modeling steel parts, you can temporarily hide the Concrete tab.
1. To change the order of tabs on the ribbon, drag and drop the tab titles.
2. To change how the tabs are aligned, right-click on the top bar of the ribbon, select Navigation mode, and then select one of the options.
   • Scroll visible: the ribbon movement is minimal when you switch between the tabs
   • Align to left: the icons start from the left side of the ribbon
   • Align to tab: the icons start from the left side of the current tab
3. To hide the tabs that you do not need in your current project:
   a. Rest the mouse pointer on a tab title.
      A small eye symbol appears next to the tab title:
      ![Eye symbol](image)
   b. Click the eye symbol.
      The eye symbol changes and the tab title becomes gray:
      ![Grayscale tab](image)
      The View tab is now hidden from the ribbon. If you slide the ribbon, hidden tabs appear as:
      ![Hidden tab](image)
   c. To re-display the hidden tab, click the eye symbol again.

3.6 Get instructions

Status bar is the area located at the bottom of the Tekla Structures main window. Follow the instructions on the status bar when you use commands. For example, when you are creating a part, the status bar will tell you how to proceed and when to pick points.

<table>
<thead>
<tr>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Instruction icons" /></td>
<td>Instructions and error messages</td>
<td>The status of Smart select (S), Drag and drop (D), and Ortho (O)</td>
<td>The level in assembly or component hierarchy (0–9)</td>
<td>The middle mouse button mode (Pan or Scroll)</td>
<td></td>
</tr>
</tbody>
</table>
5. The current phase
6. The number of selected objects and handles

**Status bar message history**

To view the status bar message history, go to **Quick Launch**, type **Message Panel**, and select the **Message Panel** command from the list that appears. A message panel appears at the bottom of the Tekla Structures window.

![Message Panel](image)

### 3.7 Minimize the ribbon

You can minimize the ribbon to save space on your screen. When the ribbon is minimized, the command buttons are hidden but the tabs are visible.

1. Right-click on the top bar of the ribbon, and select **Minimized**.

![Minimized ribbon](image)

   The ribbon is now minimized to save space on the screen:

   ![Minimized ribbon](image)

2. To access the commands when the ribbon is minimized, click a tab title. The ribbon becomes visible so that you can select a command.

3. To restore the ribbon, right-click on the top bar of the ribbon, and select **Minimized** again.
3.8 How to use the contextual toolbar
When you click an object in a model or drawing, a contextual toolbar appears next to the mouse pointer. Use the contextual toolbar to quickly view and change some basic properties of an object, view, grid, and so on.

If multiple objects are being selected, the contextual toolbar displays the text *Varies* for any properties that differ.

### How to change object properties using contextual toolbar
The changes that you make on the contextual toolbar are immediately applied to the model or drawing.

1. Click an object in a model or drawing.
   - A contextual toolbar appears next to the mouse pointer.
2. Change the object properties on the contextual toolbar.
   - The changes are applied immediately.

**TIP** Press the Tab key to move between the properties and command buttons on the contextual toolbar.

### Show or hide contextual toolbar
You can define whether the contextual toolbar is visible in Tekla Structures.

1. On the File menu, click Settings.
2. Under Switches, select or clear the Contextual Toolbar check box.

### Define contextual toolbar's position
You can define the position of the contextual toolbar, relative to an object's reference point.

1. Select an object.
2. Hold down the Ctrl key and click the contextual toolbar with the left mouse button.
A dashed line appears between the contextual toolbar and the object.

3. Drag the contextual toolbar to a new position. For example, you can position the contextual toolbar on the left side of the selected object.

4. Release the left mouse button. The contextual toolbar now appears in the position you defined, for example on the left side of any object you select.

**Pin contextual toolbar in place**

You can pin the contextual toolbar to a specific location on the screen, so that the position is locked. For example, you could have it appear at the upper left corner of the screen. In the locked state, the position of the contextual toolbar is independent of the individual part's location.

1. Move the mouse pointer on the gray bar on the left-hand side of the contextual toolbar.

   The mouse pointer changes into a cross with four arrows.

2. Drag the contextual toolbar to a new location.

3. Click to pin the contextual toolbar to the new location.

   The pin icon changes when the position is locked.

4. To unlock the position, click.

**Minimize contextual toolbar**

You can minimize the contextual toolbar so that it takes less space on your screen.

1. On the contextual toolbar, click. The contextual toolbar now has the symbol.

2. To restore the contextual toolbar to its original size, click again.
**Customize contextual toolbar**

You can customize the contextual toolbar by selecting which toolbar elements are visible. You can also adjust the width of the elements, and add icons and additional titles to the elements.

1. On the contextual toolbar, click ☰.

2. By selecting and clearing check boxes, define which toolbar elements you wish to show or hide.

   The **Preview** area shows what the toolbar will look like. For example:

   ![Customized toolbar preview]

3. To modify the toolbar elements:
   a. Click the toolbar element.
      
      If the element can be modified, the following box appears:
      
      ![Modifiable element box]

   b. Use the slider to adjust the width of the toolbar element.
   c. To add an additional title, click the text box and enter a title.
   d. To add an icon, click ☰ and select an icon from the list.
   e. To remove the icon or title, click ☯.

4. To add macros and user-defined attributes:
   a. Select the desired macro or user-defined attribute from the list.
   b. Click **Add**.
Tekla Structures adds the macro or user-defined attribute to the list of toolbar elements and to the Preview image. For example:

```
Name   Profile
Class   Phase
USER_FIELD_1
```

c. To hide the macro or user-defined attribute, clear the corresponding check box as described in step 2.

5. Click **OK** to save the changes.

### Create user profiles for contextual toolbars

You can create multiple profiles for contextual toolbars. Each profile contains the same contextual toolbars, but with different settings.

1. On the contextual toolbar, click ![Set profiles](image).
2. Click **Set profiles**.
3. Select **New profile** from the list.
4. Enter a name for the profile.
5. Click **Save**.
6. Customize the contextual toolbar.
   For example, remove some elements from the contextual toolbar.
7. Click **OK** to save the changes.
   The user profile is now active with the settings you defined.
8. To switch to another profile:
   a. Click **Set profiles**.
   b. Select another profile from the list.
   c. Modify the settings.
   d. Click **OK**.
      This user profile is now active.

### Back up and share contextual toolbars

We advice you to save a backup copy of your customized contextual toolbars. You can use the backup file to copy settings to another computer or to share the customizations with your co-workers.
1. Save the contextual toolbar under a user profile, with a name that you can easily recognize. For example, MyContextualToolbar.

2. Go to the ..\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\ContextualToolbar\Profiles folder.

3. Make a copy of your customized contextual toolbar and save it in the corresponding folder on another computer.

4. To open a customized contextual toolbar on another computer:
   a. On the contextual toolbar, click 🛠️.
   b. Click Set profiles.
   c. Select the correct profile from the list. For example, MyContextualToolbar, if that is the name you used in step 1.
   d. Click OK. The customizations are now active.

**NOTE** Alternatively, you can place the entire ContextualToolbar folder to your company’s project or firm folder.

### 3.9 How to use the side pane

Use the side pane on the right-hand side of the screen to add reference models and components, or to view model object properties.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show the side pane</td>
<td>Click a side pane button.</td>
</tr>
<tr>
<td>contents</td>
<td>- Click 🕵️ to view model object properties using <strong>Custom Inquiry</strong>.</td>
</tr>
<tr>
<td></td>
<td>- Click 🛠️ to show model object properties in the property pane.</td>
</tr>
<tr>
<td></td>
<td>- Click 📚 to show the <strong>Reference Models</strong> list.</td>
</tr>
<tr>
<td></td>
<td>- Click 🛠️ to show the <strong>Applications &amp; components</strong> catalog.</td>
</tr>
<tr>
<td>Move a side pane window</td>
<td>Click the grab bar 🖇️ and drag the side pane window to a new location.</td>
</tr>
<tr>
<td>To</td>
<td>Do this</td>
</tr>
<tr>
<td>----</td>
<td>---------</td>
</tr>
</tbody>
</table>
| Keep multiple side pane windows open at the same time | 1. Right-click a side pane button and select **Open below**.  
   ![Open below button](image1.png)  
   2. Repeat for each side pane button.  
   The side pane windows are now stacked on top of each other.  
   3. To change the order of side pane windows, drag them around.  |
| Adjust the size of a side pane window | Click and drag the **+** button.  
   ![Reference Models](image2.png)  |
| Dock a floating side pane | Right-click the side pane button and select **Attach to panel**.  
   ![Attach to Panel](image3.png)  
   Alternatively, you can drag the side pane back to the docking area, which is marked with yellow color.  |
| Close the side pane | Click the **x** button.  
   ![Close button](image4.png)  |
3.10 Change the language
You can change the language of the Tekla Structures user interface at any time.

1. On the File menu, click Settings --> Change language.
2. Select a language from the list.
   You have the following options. The three-letter language codes that are given in parentheses are used in some language-dependent file and folder names.
   • Chinese – simplified (chs)
   • Chinese – traditional (cht)
   • Czech (csy)
   • Dutch (nld)
   • English (enu)
   • French (fra)
   • German (deu)
   • Hungarian (hun)
   • Italian (ita)
   • Japanese (jpn)
   • Korean (kor)
   • Polish (plk)
   • Portuguese (ptg)
   • Portuguese – Brazilian (ptb)
   • Russian (rus)
   • Spanish (esp)
3. Click OK.
4. Restart Tekla Structures for the change to take effect.

3.11 Basic settings in the File menu
Use the switches in File menu --> Settings --> Switches to control some basic modeling and drawing settings.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Smart select</strong></td>
<td>Change how drag-and-drop works for object handles.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>on</strong>, you can drag from object handles without selecting them first.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>off</strong>, you must select the handles before dragging.</td>
</tr>
<tr>
<td><strong>Drag &amp; drop</strong></td>
<td>Activate or inactivate the drag-and-drop command.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>on</strong>, you can use drag-and-drop when copying or moving (page 113) objects.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>off</strong>, drag-and-drop cannot be used.</td>
</tr>
<tr>
<td><strong>Middle button pan</strong></td>
<td>Change the panning (page 28) mode.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>on</strong>, you can move the model using the middle mouse button.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>off</strong>, you can move the model using the left mouse button.</td>
</tr>
<tr>
<td><strong>Centered zooms</strong></td>
<td>Change the zooming (page 28) mode.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>on</strong>, the center point of zooming is kept in the middle of the view, regardless of the mouse pointer position.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>off</strong>, the mouse pointer position determines the center point of zooming.</td>
</tr>
<tr>
<td><strong>Basic view auto rotation</strong></td>
<td>Activate or inactivate the auto rotation of part and component 3D views.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>on</strong>, Tekla Structures rotates the view once whenever you create a new 3D view of a part or component.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>off</strong>, Tekla Structures does not rotate the view.</td>
</tr>
<tr>
<td><strong>Crossing selection</strong></td>
<td>Change how area selection works.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>on</strong>, all objects that fall at least partially inside the</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Rollover highlight</td>
<td>Switch the highlighting (page 194) of objects on or off. When the option is <strong>on</strong>, Tekla Structures highlights selectable objects in yellow when you move the mouse pointer on them. When the option is <strong>off</strong>, selectable objects are not highlighted.</td>
</tr>
<tr>
<td>Select on right-click</td>
<td>Change how objects can be selected (page 196). When the option is <strong>on</strong>, you can select objects also with the right mouse button. Also the related shortcut menu is displayed immediately. When the option is <strong>off</strong>, you can select objects with the left mouse button.</td>
</tr>
<tr>
<td>Automatic rotation center</td>
<td>Define how the view point (page 28) is set. When the option is <strong>on</strong>, the view point changes whenever you click the middle mouse button. When the option is <strong>off</strong>, the view point stays in a set position.</td>
</tr>
<tr>
<td>Ortho</td>
<td>Activate or inactivate orthogonal snapping. When the option is <strong>on</strong>, Tekla Structures snaps to the closest orthogonal point on the plane (0, 45, 90, 135, 180 degrees, and so on). The mouse pointer automatically snaps to positions at even distances in the given direction. When the option is <strong>off</strong>, orthogonal snapping is not used.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>DirectX rendering</td>
<td>Switch between OpenGL rendering and DirectX rendering. When the option is on, DirectX rendering is used. When the option is off, OpenGL rendering is used.</td>
</tr>
<tr>
<td>Contextual toolbar</td>
<td>Show or hide the contextual toolbar (page 33). When the option is on, the contextual toolbar appears when you select objects. When the option is off, the contextual toolbar does not appear.</td>
</tr>
<tr>
<td>Large icons</td>
<td>Change the size of toolbar icons on the Snapping and Selecting toolbars. When the option is on, large icons are used. When the option is off, small icons are used.</td>
</tr>
<tr>
<td>Tooltips</td>
<td>Show or hide the tooltips (page 26). When the option is on, a small window with examples, hints, and tips appears when you rest the mouse pointer on a command. When the option is off, no tooltips appear.</td>
</tr>
</tbody>
</table>

The following settings are available only in drawings:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printer line widths</td>
<td>Show the lines in color drawings with defined thickness on the screen. When the option is on, the lines in color drawings are shown with defined thickness. When the option is off, the lines in color drawings are shown with default thickness.</td>
</tr>
<tr>
<td>Ghost outline</td>
<td>Show hidden objects in drawings as ghost outlines in color drawings. In grayscale and black and white</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>drawings, hidden objects are not shown even if <strong>Ghost outline</strong> is selected.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>on</strong>, hidden lines are shown as ghost outlines.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>off</strong>, hidden lines are not shown.</td>
</tr>
<tr>
<td><strong>Associativity symbol</strong></td>
<td>Shows which drawing objects are associative and automatically updated. Associativity symbols are shown only when you select a drawing object, for example a dimension.</td>
</tr>
<tr>
<td></td>
<td>Objects that do not have valid association get a ghost associativity symbol and a question mark.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>on</strong>, associativity symbols are shown.</td>
</tr>
<tr>
<td></td>
<td>When the option is <strong>off</strong>, associativity symbols are not shown.</td>
</tr>
</tbody>
</table>
4 Set up the workspace

Before starting to model, check that your Tekla Structures workspace is set up correctly.

1. Define the units and decimals you will use. (page 45)
2. Modify the grid to suit your needs. (page 46) Create a modular grid if needed.
3. Create some views (page 52) to examine the model from different angles and elevations.
4. Resize the work area to suit your project. (page 66)
5. Get familiar with the coordinate system (page 68). If you are modeling sloped structures, shift the work plane accordingly. (page 69)

4.1 Change units and decimals

You can define which units and how many decimals Tekla Structures uses. The settings are model-specific. Note that these settings do not have any effect on drawings or reports, or on the Inquire and Measure tools.

1. On the File menu, click Settings --> Options, and go to the Units and decimals settings.
2. Modify the units and decimals to suit your needs.

The number located to the right of each option indicates the number of decimals. The number of decimals affects the input and storage accuracy. Always use a sufficient number of decimals.

- The settings on the Modeling tab affect the data that is used when you are modeling, for example copying, moving, creating grids, creating points, and so on.
- The settings on the Catalogs tab affect the data stored in the profile and material catalogs.
- The settings on the Analysis results tab affect the output data.
3. Click **OK** to save the changes.

### 4.2 Create grids and grid lines

A grid represents a three-dimensional complex of horizontal and vertical planes. The grid is shown on the view plane using dash-and-dot lines. Use grids as an aid in locating objects in a model. You can make grids and grid lines act magnetically so that the objects on the grid lines follow if you move the grid line.

- Create a grid (page 47)
- Modify a grid (page 48)
- Add a single grid line (page 49)

**Grid terminology**

1. Grid origin is the point where the zero points of each coordinate axis intersect
2. Grid line extensions define how far the grid lines extend in each direction
3. Grid labels are the names of the grid lines shown in views

**Modular grid**

You can have more than one grid in a model. We strongly advise that you create a modular grid, so that you can easily place objects in your model. For example:
Single grid lines
You can create single grid lines and attach them to an existing grid.

Single grid lines have handles. If the Select grid line selection switch (page 106) is active and you select a grid line, the handles appear in magenta. If you move the handles to make a skewed grid, you can do this only on the local XY plane (page 52) of the grid.

Create a grid
When you create a new model, Tekla Structures automatically creates a grid and a view according to the saved standard properties. Here we will show how to create grids manually.

1. On the Edit tab, click:
2. Pick a point to indicate the origin of the grid.
   The coordinates of the picked point appear in the Grid dialog box as \(X0\), \(Y0\), and \(Z0\). If you do not pick a point, Tekla Structures positions the origin according to the existing values.

3. Enter the \(x\) and \(y\) coordinates (page 68).
   You can either define the coordinates individually, or you can define several grid lines with equal spacing. Both of the following coordinate entries create three grid lines with the spacing of 4000:
   
   \[
   0 \ 4000 \ 4000 \\
   0 \ 2*4000
   \]

4. Enter the \(z\) coordinates.

5. Enter the grid labels.

6. Modify the other grid properties if needed.

7. If you want objects to follow if you move the grid line, select the Magnetic grid plane check box.

8. Click Create.

**NOTE** When working with very large grids, always having the grid labels visible might slow down Tekla Structures. To hide the grid labels when you zoom in, use the advanced option.

---

**See also**

Modify a grid (page 48)
Change the color settings (page 72)

---

**Modify a grid**

Double-click an existing grid to modify it.

1. Ensure that the Select grid selection switch (page 106) is active.
2. Double-click a grid line.
3. Modify the grid properties.
4. If you have attached additional grid lines to the grid and you want to preserve them, clear the check boxes next to the Coordinate boxes. Otherwise Tekla Structures deletes all single grid lines (page 46) attached to the grid.

5. Click Modify to save the changes.

See also
Change the color settings (page 72)
Modify a single grid line (page 50)

Delete a grid
When you delete an entire grid, ensure that you do not have any other objects selected. Otherwise Tekla Structures only deletes the objects, not the grid.

1. Ensure that only the Select grid selection switch (page 106) is active.
2. Select the grid.
3. Right-click and select Delete from the pop-up menu.
4. Confirm that you want to delete the grid.

See also
Deleting a single grid line (page 52)

Add a single grid line
You can add new grid lines either between existing grid lines or between two freely chosen points that you define in the model.

Add a grid line between existing grid lines
You can add new grid lines between existing grid lines.

1. Ensure that the Direct modification switch is active.
2. Ensure that the Select grid selection switch (page 106) is active.
3. Select an existing grid to attach the grid line to.
4. Click the symbol between two existing grid lines or outside the grid. Tekla Structures creates the grid line and gives it a label using the labels of the adjacent grid lines. For example, a new grid line between the grid lines 1 and 2 receives the label 12*.

**Add a grid line between two points**
You can add new grid lines between two picked points.

1. On the Edit tab, click Grid and select Add grid line.
2. Select an existing grid to attach the grid line to.
3. Pick the start point of the grid line.
4. Pick the end point of the grid line.

**Modify a single grid line**
You can move, stretch, shrink, and incline single grid lines. You can also change grid line labels.

**Modify grid line properties**
You can edit the properties of a single grid line.

1. Ensure that the Select grid line selection switch (page 106) is active.
2. Double-click a grid line.
3. Modify the grid line properties.
4. Click Modify to save the changes.

**Move a grid line**
Use direct modification to move single grid lines.

1. Ensure that the Direct modification switch is active.
2. Ensure that the Select grid selection switch (page 106) is active.
3. Select the grid.
4. Select the grid line you want to move.
5. Drag the grid line to a new location.
You can also use the keyboard to enter a numeric location.
To start with the negative sign (-), use the numeric keypad. To enter an absolute coordinate, first enter $, then the value. Press Enter to confirm.

**Stretch, shrink, or incline a grid line**
Use direct modification to stretch, shrink, or incline single grid lines.

1. Ensure that the [Direct modification] switch is active.
2. Ensure that the [Select grid] selection switch (page 106) is active.
3. Select the grid.
4. Select the grid line.
5. Drag a grid line handle to a new location.

**Change a grid line label**
Use the contextual toolbar to change the label of a single grid line.

1. Ensure that the [Direct modification] switch is active.
2. Ensure that the [Select grid line] selection switch (page 106) is active.
3. Select a grid line.
4. On the contextual toolbar, enter a new label.

**Turn grid line stretching off**
If you move the outermost grid lines using the line handles, Tekla Structures stretches or shrinks the perpendicular, crossing grid lines accordingly by default. You can switch this off temporarily.

1. Ensure that the [Direct modification] switch is active.
2. Ensure that the [Select grid] selection switch (page 106) is active.
3. Select the grid line.
4. On the contextual toolbar, click the [Turn grid line stretching off] button.
Deleting a single grid line
You can delete grid lines in two different ways. The easiest way is by using direct modification.

Delete a grid line using direct modification
Use direct modification to quickly delete single grid lines.

1. Ensure that the Direct modification switch is active.
2. Select the grid line you want to delete.
3. Press Delete.

Delete a grid line (alternative method)
This is the alternative way of deleting single grid lines.

1. Ensure that the Select grid line selection switch (page 106) is active.
2. Select the grid line you want to delete.
3. Ensure that you do not have any other objects selected.
   If you also have other objects selected, Tekla Structures only deletes the objects, not the grid line.
4. Right-click and select Delete from the pop-up menu.
5. Confirm that you want to delete the grid line.

4.3 Create model views
A view is a representation of a model from a specific location. Each view is represented in its own window within Tekla Structures. Selecting a part in a view highlights the part in all open views.

- Create views (page 54)
- Open a view (page 63)
- Switch between views (page 65)
- Change the color settings (page 72)

View plane
Each view has a view plane on which the grids (page 46) are visible and points are represented as yellow crosses. Points that are located outside the view plane are red. You can move the view plane (page 54) like any other object.
**Basic views**

Basic views are those parallel to the global basic planes (xy, xz, and zy). In basic views, two axes always define the view plane and the axes appear in the plane name. The third axis is perpendicular to the view plane. It does not appear in the plane name. In the basic plane view, the model is shown from the direction of the third axis.

When you create basic views, you must define the view plane's distance (the view plane coordinate) from the global origin in the direction of the third axis.

Examples of basic views:

<table>
<thead>
<tr>
<th>Plane</th>
<th>3D view</th>
<th>Plane view</th>
</tr>
</thead>
<tbody>
<tr>
<td>XY</td>
<td><img src="image" alt="3D view" /></td>
<td><img src="image" alt="Plane view" /></td>
</tr>
<tr>
<td>XZ</td>
<td><img src="image" alt="3D view" /></td>
<td><img src="image" alt="Plane view" /></td>
</tr>
<tr>
<td>ZY</td>
<td><img src="image" alt="3D view" /></td>
<td><img src="image" alt="Plane view" /></td>
</tr>
</tbody>
</table>

**Other views**

For other view types, you either define the view plane and coordinate by picking points, or the points are defined automatically, depending on the creation method.
Move the view plane
You can move the view plane like any other object. When you move it, Tekla Structures only uses the vector that is perpendicular to the view plane.
1. Click the view.
2. Right-click and select **Move --> Linear**.
3. Pick the start point of the translation vector, or enter its coordinates.
4. Pick the end point of the translation vector, or enter its coordinates.
5. Click **Move** to move the view plane.

Create views
You can create views of parts, components, and the entire model.

Create a basic view of the model
You can create a basic view along two coordinate axes. Use this view for the overall viewing of the model.

1. On the **View** tab, click **New view --> Basic view**.
2. Select a view plane from the **Plane** list.
3. In the **Coordinate** box, enter the view level.
   This value defines the distance from the global origin.
4. Click **Create**.

Create a view using two points
You can create a view using two points you pick: the origin and a point in the horizontal direction.

1. On the **View** tab, click **New view --> Using two points**.
2. Pick a point to indicate the origin of the view plane.
3. Pick a second point to indicate the direction of the x axis.
   The y axis is perpendicular to the view plane on which you picked the first point.
Create a view using three points
You can create a view using three points you pick: the origin, a point in the horizontal direction, and a point in the vertical direction.

1. On the View tab, click New view --> Using three points.
2. Pick a point to indicate the origin of the view plane.
3. Pick a second point to indicate the direction of the x axis.
4. Pick a third point to indicate the direction of the y axis.

Create a view of the work plane
You can create a view of the work plane using the current view properties.

* On the View tab, click New view --> On work plane.

Create grid views
You can create views along the grid lines you select.

Before you start, create a view that contains a grid, and check the grid properties. If the grid properties are incorrect in some way, Tekla Structures may cut the views at the wrong elevations or they may be named incorrectly. If you change the grid labels or the elevation or grids later on, the views will not be automatically renamed.

1. Select the grid.
2. On the View tab, click New view --> Along grid lines.
3. Modify the grid view properties if needed.
   a. In the Number of views list, select how many views you want to create.
   b. In the View name prefix box, enter a prefix.
   c. In the View properties list, define which view properties (applied or saved) you want to use.
4. Click Create.
   The Views dialog box opens.
5. Click the arrow buttons to move views from the Named views list to the Visible views list.
   The views will not be visible until you move them to the Visible views list.
Example

In this example, we will create vertical views of the grid lines 1–7 on the following model:

In the Creation of Views Along Grid Lines dialog box, we select All for the view plane XZ and None for the view planes XY and ZY. We use the default settings for the view name prefix and the view properties.

After creating the grid views, we move the view named Grid 2 to the Visible views list:
The grid view is displayed as a plane view in a new window:

We can rotate the view to see it in 3D:
Create a view on a part plane
You can create a view on the front, top, back, or bottom plane of a part.

1. On the View tab, click **New view** and select one of the following:
   - On part front plane
   - On part top plane
   - On part back plane
   - On part bottom plane
2. Select the part.

Create a 3D view of a part
When you need to see a specific part clearly, create a 3D view of the part. The part is placed in the center of the view.

1. On the View tab, click **New view --> 3D view of part**.
2. Select the part.
   Tekla Structures creates the view. The view plane y axis is the global z axis of the model. The x axis is the projection of the part's local x axis onto the global xy plane.

**Create default part views**
You can create four basic views of a part: front, top, end and perspective view. Tekla Structures creates these views all at once with the same command. By default, the perspective view is a 3D view, and the front, top, and end views are plane views.

1. On the **View** tab, click **New view --> Default views of part**.
2. Select the part.
   Tekla Structures creates the four default views all at once.

**Create an undeformed part view**
You can create a view that shows a deformed part in undeformed form. This only works for beams and columns.

1. On the **View** tab, click **New view --> Undeformed view of part**.
2. Select the part.
   For example, select a warped beam. Tekla Structures displays the beam in a separate view in undeformed form.

**Create a 3D view of a component**
When you need to see a specific component clearly, create a 3D view of the component. The component is placed in the center of the view.

1. On the **View** tab, click **New view --> 3D view of component**.
2. Select the component.
   Tekla Structures creates the view. The view plane y axis is the global z axis of the model. The x axis is the projection of the first secondary part local x axis onto the global xy plane. Work area depth is 1 m in all directions.

**Create default component views**
You can create four basic views of a component: front, top, end and perspective view. Tekla Structures creates these views all at once with the
same command. By default, the perspective view is a 3D view, and the front, top, and end views are plane views.

1. On the View tab, click New view --> Default views of component.
2. Select the component.
   Tekla Structures creates the four default views all at once.

**Create a surface view**

Use the CreateSurfaceView macro to create an automatically aligned surface view. This can be useful when modeling bolt groups, stiffener plates, and hole penetrations on complex geometry.

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. Click the arrow next to Applications to open the applications list.
3. Double-click CreateSurfaceView to start the macro.
4. Select the surface of the part.

![Diagram of a surface view](image)

Tekla Structures creates a new temporary view and moves the work plane typically along the longest edge of the part face. You can model in the
surface view and see your modeling work being done in your original 3D view at the same time.

5. Press Esc to stop the macro.

6. To return the work plane back to the origin:
   a. Repeat steps 1–2 to open the Applications list.
   b. Double-click the WorkPlaneGlobal macro.

**Create a surface view along selected edge**

Use the CreateSurfaceView_wEdge macro to create a surface view and align the work plane along the edge you select. This can be useful when modeling bolt groups, stiffener plates, and hole penetrations on complex geometry.

1. Ensure that the Snap to geometry lines/points selection switch (page 106) is active.
   This allows you to pick along an edge to define the direction.

2. Click the Applications & components button in the side pane to open the Applications & components catalog.

3. Click the arrow next to Applications to open the applications list.

4. Double-click CreateSurfaceView_wEdge to start the macro.

5. Select the surface of the part.

   When you hover the mouse pointer over the part edges, a yellow arrow symbol is displayed to indicate the possible edges you can align the view to. The head of the arrow represents the positive direction of the x axis. The view will be rotated in this direction to form the flat horizontal edge of
the view. The origin of the view and work plane will be at the start of the arrow snap line.

6. Pick the desired edge.
Tekla Structures creates a new temporary view, and the selected edge forms the x axis of the view. You can model in the surface view and see your modeling work being done in your original 3D view at the same time.

7. Press Esc to stop the macro.
8. To return the work plane back to the origin:
   a. Repeat steps 2–3 to open the Applications list.
   b. Double-click the WorkPlaneGlobal macro.

Open a view
You can have up to nine views on the screen at the same time. If you are unable to open a view, check how many views you already have open - you may need to close some of them first.

1. On the View tab, click View list to open the Views dialog box.
   Tekla Structures lists all invisible named views on the left, and all visible views on the right.
2. Select a view from the Named views list and click the right arrow to move it to the Visible views list.
   You can also double-click a view to open it. If the view does not appear, check how many views you already have open.
3. To open multiple views, use the **Shift** and **Ctrl** keys when you select views from the list.

**See also**
- Save a view (page 64)
- Switch between views (page 65)

**Save a view**
If you need to re-open views later on, give each view a unique name. When you exit the model, Tekla Structures only saves the named views. Temporary views disappear when you close them.

Before you start, create one or more views (page 54) in the model.

1. Double-click the view to open the **View Properties** dialog box.
2. Enter a unique name in the **Name** box.
   Temporary views have a default name in parentheses. Do not use parentheses when naming a view, or the view will not be saved for later use.

   **NOTE** In multi-user mode, it is very important to give views unique names. If several users have different views with the same name, the view settings of one user may accidentally override the settings of another user.

3. Click **Modify**.
   Tekla Structures will automatically save all named views when you close the model.

**Modify a view**
You can modify a view simply by double-clicking it.

1. Double-click the view to open the **View Properties** dialog box.
2. Modify the view properties.
3. Click **Modify**.

**See also**
- Move the view plane (page 54)
Delete a view
You can permanently delete named views.

1. On the View tab, click View list to open the Views dialog box.
   Tekla Structures lists all invisible named views (page 52) on the left, and all visible views on the right.
2. Select the view you want to delete.
3. Click Delete.
   Tekla Structures deletes the view permanently. If the view was visible during the deletion, it will remain visible until you close it.
4. To delete multiple views, use Shift or Ctrl when you select views from the list.

Switch between views
You can easily switch between all open views while modeling. You can also switch between the 3D mode and Plane mode, to examine the current view from different perspectives.

Switch between open views
To switch between open views, do one of the following:

- Use the keyboard shortcut Ctrl+Tab.
- Click Window and select a view from the list.
- Right-click a view, then select Next Window from the pop-up menu. The next open view becomes active.

Switch between 3D and plane view
Use the Switch to 3D or plane command to examine the current view from different perspectives.

- On the View tab, click Switch to 3D or plane.
  You can also press Ctrl+P.
Update and refresh views
Use the **Update Window** and **Redraw** commands to refresh a single view or all views at once.

- **Update**: Removes temporary graphics (such as measured distances) but does not redraw the view. Faster than redrawing.
- **Redraw**: Redraws the view completely and shows all previously hidden objects.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update the current view</td>
<td>Right-click the view and select <strong>Update Window</strong>.</td>
</tr>
<tr>
<td>Update all of the views</td>
<td>On the <strong>View</strong> tab, click <strong>Redraw --&gt; Erase temporary graphics</strong>.</td>
</tr>
<tr>
<td>Redraw the current view</td>
<td>Right-click the view and select <strong>Redraw View</strong>.</td>
</tr>
<tr>
<td>Redraw all of the views</td>
<td>On the <strong>View</strong> tab, click <img src="image" alt="Redraw View icon" /></td>
</tr>
</tbody>
</table>

See also

*Switch between views (page 65)*

4.4 Define the work area
Tekla Structures indicates the work area of a view using dashed lines. Objects outside the work area exist, but they are not visible. You can shrink and expand the work area to suit particular situations, for example to concentrate on a particular area of the model. You can temporarily hide the work area box.
Fit work area to entire model
You can resize the work area to include all model objects, either in all views or in selected views only.

1. On the View tab, click Work area and select one of the following:

   • To entire model in all views
     Fits the work area to include all model objects in all visible views.
   • To entire model in selected views
     Fits the work area to include all model objects in the selected views.

Fit work area to selected parts
You can resize the work area to include only selected parts, either in all views or in selected views only.

1. Select the objects you want to include.

2. On the View tab, click Work area and select one of the following:

   • To selected parts in all views
     Fits the work area to include the selected model objects in all views.
   • To selected parts in selected views
     Fits the work area to include the selected model objects in the selected views.

Fit work area using two points
You can resize the work area based on two corner points you pick on the view plane. The depth of the work area is the same as the view depth.

1. On the View tab, click Work area and select Using two points.
2. Pick the first point.
3. Pick the second point.
**Hide the work area box**

You can temporarily hide the work area box in a view. This can be useful, for example, when creating screenshots for presentations.

1. Hold down the **Ctrl** and **Shift** keys simultaneously.
2. On the **View** tab, click **Redraw -- Redraw all**.

3. To make the box visible again, click **Redraw -- Redraw all** again.

**TIP** Alternatively, use the advanced option XS_HIDE_WORKAREA.

### 4.5 Coordinate system

Tekla Structures uses two coordinate systems: the global and the local coordinate system. The local coordinate system is also known as the work plane.

**Global coordinate system**

The green cube symbol represents the global coordinate system and lies at the global point of origin (x=0, y=0, z=0). Do not place the model far away from the origin. If you create model objects far away from the origin, snapping to points (page 85) in the model views may become inaccurate. The further away from the origin you model, the less precise all computations become.

**Local coordinate system (Work plane)**

The work plane represents the local coordinate system. The work plane has its own grid, which can be used for positioning parts. Most of the commands that are dependent on the coordinate system use work plane coordinates. For example creating points, part positioning, and copying always comply with the work plane coordinate system. The coordinate symbol, which is located in the lower right corner of the model view, follows the work plane.
The work plane is model specific, so it is the same in all views. The red work plane arrow symbol shows the xy plane. The z direction follows the right-hand rule.

See also
Show or hide the work plane grid (page 69)
Shift the work plane (page 69)
Change the color settings (page 72)

Show or hide the work plane grid
The work plane grid is hidden by default. Use the options on the Snapping toolbar to show or hide the work plane grid.

1. To show the grid, select **Work plane** from the second list.

2. To hide the grid, select **View plane** from the same list.

See also
Shift the work plane (page 69)
**Shift the work plane**
You can set the work plane to any position by picking points or by selecting a plane. This makes it easier to place parts accurately when modeling sloped parts.

For example, you can shift the work plane to the slope of the roof to make it easier to model horizontal bracing and purlins in a sloped roof.

**Set work plane to any part plane**
Use the [Workplane tool](#) command to set the work plane to any part plane.
1. On the **View** tab, click **Workplane** --&gt; **Workplane tool**.
2. Pick a point.

**Set work plane parallel to xyz plane**
You can set the work plane parallel to the xy, xz, or zy plane.
1. On the **View** tab, click **Workplane** and select **Parallel to XY(Z) plane**.
2. In the **Plane** list box, select the plane parallel to the work plane.
3. Enter the depth coordinate.
   The depth coordinate defines the distance of the work plane from the global origin along a line perpendicular to the plane parallel to the third axis.
4. Click **Change**.
**Set work plane using one point**
You can set the work plane using one picked point. The work plane stays parallel to the current work plane, but moves it to a new position. The x and y directions are unchanged.

1. On the **View** tab, click **Workplane** and select **Using one point**.

2. Pick the new position of the work plane.

**Set work plane using two points**
You can set the work plane using two picked points. The first point you pick is the origin, the second defines the x direction of the work plane. The y direction remains the same as the previous work plane.

1. On the **View** tab, click **Workplane** and select **Using two points**.

2. Pick the origin of the work plane.
3. Pick a point in the work plane, in the positive x direction.

**Set work plane using three points**
You can set the work plane using three picked points. The first point you pick is the origin, the second defines the x direction, and the third defines the y direction of the work plane. Tekla Structures fixes the z direction according to the right-hand rule.

1. On the **View** tab, click **Workplane** and select **Using three points**.

2. Pick the origin for the work plane.
3. Pick a point in the positive x direction.
4. Pick a point in the positive y direction.
**Set work plane parallel to view plane**
You can set the work plane to be the same as the view plane of a selected view.

1. On the **View** tab, click **Workplane** and select **Parallel to view plane**.

   ![Workplane](image1)

2. Select the view.

**Restore the default work plane**
Remember to change back to the default work plane when you have finished modeling sloped structures.

1. On the **View** tab, click **Workplane --> Parallel to XY(Z) plane**.

   ![Workplane](image2)

2. In the **Plane** list, select **XY**.
3. In the **Depth coordinate** box, enter **0**.
4. Click **Change**.

### 4.6 Change the color settings

You can define which color you want to use for dimensions, labels, background, and grid lines in the model. For example, if you set the background color to black, you may need to adjust the other color settings as well to ensure that the text and dimensions will be visible.

Change the color settings in the **Advanced Options** dialog box using RGB values: `<value for red> <value for green> <value for blue>`. 
Separate the values with spaces. Define the values on a scale of 0.0 to 1.0. For example, the RGB code for yellow is 1.0 1.0 0.0.

Find RGB values for colors
Use the Tekla Structures Background Color Selector tool to find a suitable color for the background, grids, part labels, and so on.
1. Go to Tekla Warehouse.
2. Download and install the Background Color Selector tool.

**TIP** Alternatively, you can use the Color picker for Tekla Structures tool, which is available in Tekla User Assistance.

**Examples**

<table>
<thead>
<tr>
<th>RGB color code</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0 1.0 1.0</td>
<td>White</td>
</tr>
<tr>
<td>1.0 0.0 0.0</td>
<td>Red</td>
</tr>
<tr>
<td>0.0 1.0 0.0</td>
<td>Green</td>
</tr>
<tr>
<td>0.0 0.0 1.0</td>
<td>Blue</td>
</tr>
<tr>
<td>1.0 1.0 0.0</td>
<td>Yellow</td>
</tr>
</tbody>
</table>
**Change the background color**
Set the background color using a combination of four different advanced options. You can control the color of each corner of the background separately.

1. On the **File** menu, click **Settings --> Advanced options**, and go to the **Model View** category.
2. Set the background color using the following advanced options:
   - XS_BACKGROUN5D_COLOR1
   - XS_BACKGROUN5D_COLOR2
   - XS_BACKGROUN5D_COLOR3
   - XS_BACKGROUN5D_COLOR4
   To use a single-colored background, set the same value for all four corners of the background. To use the default background color, leave the boxes empty.
3. Click **OK** to save the changes.
4. Close and reopen the view to see the changes.

**Examples**
Below are some examples of possible background colors that you can define. The first RGB value refers to the advanced option XS_BACKGROUN5D_COLOR1, the second value to the advanced option XS_BACKGROUN5D_COLOR2, and so on.

<table>
<thead>
<tr>
<th>RGB values</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
</tbody>
</table>
Change the color of dimensions, part labels, and grids

You can define which color you want to use for dimensions, part labels, and grid lines in the model.

1. On the **File** menu, click **Settings** --> **Advanced options**.
2. Search for the color setting you want to change.

<table>
<thead>
<tr>
<th>Color setting</th>
<th>Advanced option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grid</td>
<td>XS_GRID_COLOR</td>
</tr>
<tr>
<td>Work plane grid</td>
<td>XS_GRID_COLOR_FOR_WORK_PLANE</td>
</tr>
<tr>
<td>Dimension lines</td>
<td>XS_VIEW_DIM_LINE_COLOR</td>
</tr>
<tr>
<td>Dimension text</td>
<td>XS_VIEW_DIM_TEXT_COLOR</td>
</tr>
<tr>
<td>Part labels</td>
<td>XS_VIEW_PART_LABEL_COLOR</td>
</tr>
</tbody>
</table>

**TIP** To quickly find all color related advanced options, type **color** in the **Search** box and press **Enter**. Make sure the **In all categories** check box is selected.

3. Define the color using RGB values.
4. Click **OK** to save the changes. You may be required to restart Tekla Structures.
5. Close and reopen the view to see the changes.
Create, modify, and delete objects

There are several ways to create, modify, and delete objects in Tekla Structures. Here we will introduce the way that is most useful for a first-time user.

1. Run a command that creates an object.
   For example, click \( \text{Beam} \) to create a steel beam.

2. Pick points (page 85) to place the object in the model.
   Tekla Structures creates the object using the current properties of the object type.

3. Follow the status bar messages (page 32) to get instructions on how to proceed.

4. To create more objects with the same properties, pick more points.
   The command runs until you end it or start another command (page 26).

5. Double-click the object to modify it.
   The object properties dialog box opens.

6. Change the properties as desired.

7. To indicate which properties you want to change, select or clear the desired check boxes.
   For example, if you only want to change the object's material, select the Material check box and clear all the others.

   **TIP** Click \( \text{Switch All} \) to switch all check boxes on or off.

8. Click Modify.
   Tekla Structures changes the properties whose check boxes you selected in step 7.
9. To delete an object, select it and press **Delete**.

**See also**
- How to use the contextual toolbar (page 33)
- Resize and reshape an object (page 77)
- Save and load dialog box properties (page 83)

### 5.1 Resize and reshape an object

You can resize, reshape, and move model objects by using direct modification handles. When you select an object, Tekla Structures displays the handles and dimensions that are specific for that model object.

Direct modification can be used with the following object types:

- Parts
- Construction objects
- Grids and grid lines
- Line cuts
- Polygon cuts
- Reinforcement
- Rebar set guidelines and modifiers
- Pour breaks
- Custom parts
- Loads

1. Ensure that **Direct modification** is switched on.

   To switch direct modification on or off, click [ ] or press **Ctrl+D**.

2. Click the object to select it.
Tekla Structures displays the handles that you can use to modify the object.

Also the relevant dimensions are shown when you move the mouse pointer slowly over the object's edges. The dimension colors follow the colors of the work plane coordinate axes: red in the X direction, green in the Y direction, and blue in the Z direction. Diagonal dimensions are magenta.

3. To reshape the object, drag any of the handles.

Here are some examples of direct modification handles:

<table>
<thead>
<tr>
<th>Handle</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Reference point handle" /></td>
<td>Reference point handle</td>
</tr>
<tr>
<td><img src="image" alt="Midpoint handle" /></td>
<td>Midpoint handle</td>
</tr>
<tr>
<td><img src="image" alt="End point handle" /></td>
<td>End point handle (for reinforcing bars only)</td>
</tr>
<tr>
<td>Handle</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td><img src="Image" alt="Plane handle" /></td>
<td>Plane handle</td>
</tr>
<tr>
<td><img src="Image" alt="Line handle" /></td>
<td>Line handle</td>
</tr>
<tr>
<td><img src="Image" alt="Axis handle" /></td>
<td>Axis handle (for custom parts only)</td>
</tr>
<tr>
<td><img src="Image" alt="Rotation handle" /></td>
<td>Rotation handle (for custom parts only)</td>
</tr>
</tbody>
</table>

**TIP** You can use the snap switches (page 93) when dragging a handle. To temporarily disable the snap switches, hold down the **Shift** key when dragging a handle.

4. To change the overall dimensions of the object, move the dimension arrowheads.
   You can either drag an arrowhead to a new location, or you can type an exact distance or coordinates.
   a. Select the dimension arrowhead you want to move. For example:
To change a dimension at both ends, select both arrowheads.

b. Type the distance or coordinates.
When you start typing, Tekla Structures displays the **Enter a Numeric Location** dialog box. Click **OK** to confirm the dimension.

![Enter a Numeric Location dialog box](image)

5. To add a new object corner, drag a midpoint handle. For example:

![Add new object corner](image)

6. To display more modification options, select a handle.
A contextual toolbar appears with more options. The availability of the options depends on the object and handle you have selected.

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To do this</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Move handle" /></td>
<td>Move a handle to any location in the 3D space.</td>
<td><img src="image" alt="Move in 3D" /> Move in XY plane Move in Z direction</td>
</tr>
<tr>
<td><img src="image" alt="Move handle" /></td>
<td>Move a handle in the XY plane only.</td>
<td><img src="image" alt="Move in 3D" /> Move in XY plane Move in Z direction</td>
</tr>
</tbody>
</table>

Create, modify, and delete objects 80 Resize and reshape an object
<table>
<thead>
<tr>
<th>Click this button</th>
<th>To do this</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Arrow Up Icon" /></td>
<td>Move a handle in the Z direction only.</td>
<td><img src="image2" alt="Move in 3D" /> Move in parallel direction Move in perpendicular direction</td>
</tr>
<tr>
<td><img src="image3" alt="Arrow Right Icon" /></td>
<td>Move a handle in the parallel direction only.</td>
<td><img src="image2" alt="Move in 3D" /> Move in parallel direction Move in perpendicular direction</td>
</tr>
<tr>
<td><img src="image4" alt="Arrow Down Icon" /></td>
<td>Move a handle in the perpendicular direction only.</td>
<td><img src="image2" alt="Move in 3D" /> Move in parallel direction Move in perpendicular direction</td>
</tr>
<tr>
<td><img src="image5" alt="Backward Arrow" /></td>
<td>Move a handle in the selected part plane only. Select a plane and drag the handle to a new location. This option can be useful when working with a sloped roof, for example.</td>
<td><img src="image2" alt="Move in 3D" /> Move in parallel direction Move in perpendicular direction</td>
</tr>
<tr>
<td><img src="image6" alt="Eye Icon" /></td>
<td>Control the visibility of direct modification dimensions. Click the eye symbol to show or hide dimensions.</td>
<td><img src="image7" alt="X, Y, Z dimensions" /> Total dimensions</td>
</tr>
</tbody>
</table>

- **X, Y, Z dimensions:** All orthogonal dimensions in the work plane directions X, Y, and Z are displayed.
- **Total dimensions:**
<table>
<thead>
<tr>
<th><strong>Click this button</strong></th>
<th><strong>To do this</strong></th>
<th><strong>Location</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Only the total length is displayed.</td>
<td></td>
</tr>
<tr>
<td>![Arrow]</td>
<td>Show or hide midpoint handles.</td>
<td>![Image]</td>
</tr>
<tr>
<td>![Add Point]</td>
<td>Add a new point at the end of an object. Only available for objects that pass through multiple points, such as polybeams, panels, strip footings, and rebar set modifiers.</td>
<td>![Image]</td>
</tr>
</tbody>
</table>

**NOTE** Some of these options are located in an expandable section on the contextual toolbar. Click the small triangle symbol on the contextual toolbar to show or hide the options:

7. To delete a handle, select it and press **Delete**.

**See also**

*Modify a single grid line (page 50)*

### 5.2 Copy properties from another object

Use the ![Copy] **Copy properties** command on the contextual toolbar to copy properties from another object.

1. Select the object you want to copy properties from. A contextual toolbar (page 33) appears.

2. Click **Copy properties** on the contextual toolbar.
The mouse cursor changes into a paintbrush:

3. Click the object you want to copy properties to.
   When the properties have been copied, the cursor returns to normal.

4. To copy properties to multiple objects, double-click the Copy properties button.
   Now you can copy properties to multiple objects. The cursor remains in the paintbrush mode until you press Interrupt or start another command.

5.3 Save and load dialog box properties
You can save predefined sets of properties for model and drawing objects and load these properties later on when you create new objects. Tekla Structures stores the properties files in the model folder, also including the properties of sub-dialog boxes.
1. In the dialog box, enter the properties you want to save.
2. In the box next to the Save as button, enter a name for the new set of properties.
   For example, MyProperties.
3. Click Save as.
   The set of properties has now been added to the list of saved properties:
4. When you want to load a set of properties, select the set from the list, and then click Load.
5. If you want to make changes to an existing set of properties:
   a. Load the set of properties you want to change.
   b. Change the properties.
   c. Click Save.

   Tekla Structures saves the changes in the file shown in the list, overwriting the old set of properties.

**See also**

Learn the common buttons (page 30)
Most commands ask you to pick points to place objects in the model or drawing. This is called *snapping*. When you are creating a new object, Tekla Structures displays snap symbols for the available snap points and displays a green line between the snap point and the last point picked. Use the snap switches to control which positions you can snap to.

Tekla Structures displays snap dimensions to help you create objects of a desired length. Use the advanced option `XS_DISPLAY_DIMENSIONS_WHEN_CREATING_OBJECTS` to switch the snap dimensions on or off.

### 6.1 Snap to a line

Use the **Snap to line** snap switch when modeling objects that should be lined up with an existing object or a grid line.

1. Ensure that the ![Snap to line](snap_to_line_icon.png) *Snap to line* snap switch (page 93) is active.
2. Run a command that requires you to pick two or more points.
For example, start creating a beam. When you move the mouse pointer over a nearby object, Tekla Structures automatically picks both ends of the line. The yellow arrow symbol indicates the direction of the points.

3. To switch direction, move the mouse pointer closer to the opposite end of the line.
4. Click the left mouse button to confirm the snap position. Tekla Structures creates the object. For example:

6.2 Snap to extension lines
You can snap to the extension lines of nearby objects. This can be useful, for example, when you want to align objects with one another.

1. Ensure that the correct snap switches (page 93) are active:
   - Switch on \( \text{Snap to extension lines} \)
   - Switch on either \( \text{Snap to intersection points} \) or \( \text{Snap to nearest points} \) if you are snapping to the intersection of an extension line and a grid line
   - Switch off \( \text{Snap to end points} \) if you are working in 3D

Snap to a point or line  
86  
Snap to extension lines
2. Run a command that requires you to pick points.
   For example, start creating a plate or slab.

3. Move the mouse pointer close to nearby objects to see the extension lines.

When a line is found, you can move the pointer further away while keeping the snap.

4. Pick the rest of the points.
6.3 Snap to orthogonal points

Use the **Ortho** tool to snap to the closest orthogonal point on the plane (0, 45, 90, 135, 180 degrees, and so on). The mouse pointer automatically snaps to positions at even distances in the given direction. This can be useful, for example, if you need to place marks in a consistent manner in exact locations in a drawing.

1. On the **File** menu, click **Settings** and select the **Ortho** check box.
   Alternatively, you can press **O**.
2. Run a command that requires you to pick points.
For example, start creating a beam. Tekla Structures displays an angle symbol to indicate the direction of snapping. The snapping precision depends on the current zoom level.

3. Click the left mouse button to confirm the snap position.

Tekla Structures creates the object. For example:

6.4 Snap relative to previously picked points

When you create objects that require you to pick more than two points, you can snap in orthogonal directions relative to the two previously picked points. This can be useful, for example, if you need to create a rectangular slab that is on the view plane but not along the x and y axes.

1. Run a command that requires you to pick multiple points. For example, start creating a polybeam or a rectangular slab.

2. Pick the first two points.

Tekla Structures displays an angle symbol to indicate the direction of snapping.

3. Move the mouse pointer in the model to see the angle symbol.
When the snap is orthogonal to the work plane, the color of the angle symbol is green:

When the snap is orthogonal to the previous points, the color of the angle symbol changes to yellow:

4. Pick the rest of the points.

Tekla Structures creates the object. For example:

6.5 Create a temporary reference point

You can create a temporary reference point to use as a local origin when snapping in models and drawings.

1. Run a command that requires you to pick points.

For example, start creating a beam.
2. Pick the start point.

3. Hold down the Ctrl key and pick a position.
   A green cross indicates that this position is now a temporary reference point.

4. Repeat step 3 to create as many reference points as needed.

5. Release the Ctrl key and pick the end point.
   Tekla Structures creates the object between the start point and the end point. For example:
6.6 **Lock X, Y, or Z coordinate**

You can lock the x, y, and z coordinates on a line. This is useful when you need to determine a point to pick and the needed point does not exist on the line. When a coordinate is locked, you can only snap to points in that direction.

1. Run a command that requires you to pick positions.
   For example, start creating a beam.
2. Lock a coordinate:
   - To lock the x coordinate, press X.
   - To lock the y coordinate, press Y.
   - To lock the z coordinate, press Z.
   Now you can only snap to points in the chosen direction.
3. To unlock the coordinate, press the same letter (X, Y, or Z) again.

6.7 **Snapping toolbar**

Use the **Snapping** toolbar to activate snap switches and to access additional snapping options.

1. Use the snap switches to control which positions you can pick when placing objects.
2. Use the first list to define the snap depth. For more information, see the separate instructions further along on this page.
3. Use the second list to switch between the view plane and **work plane** (page 69).
4. Use the third list to set the plane type. The plane type defines what planes you can select in the model.

By default, the **Snapping** toolbar is located at the bottom of the Tekla Structures main window. If you are unable to find the toolbar, see How to restore missing toolbars (page 197).
Snap zone
Each object has a snap zone. It defines how close you need to pick to hit a position. When you pick within the snap zone of an object, Tekla Structures automatically snaps to the closest pickable point on that object.
You can set the snap zone using the advanced option XS_PIXEL_TOLERANCE.

Snap depth
The first list on the Snapping toolbar defines the depth of each position you pick. You have the following options:

- **Plane**: You can snap to positions either on the view plane (page 52) or the work plane (page 68), depending on what you have selected in the second list on the Snapping toolbar.
- **Auto**: In perspective views, this option works like the 3D option. In non-perspective views, it works like the Plane option.
- **3D**: You can snap to positions in the entire 3D space.

Snap priority
Tekla Structures automatically snaps to the point with the highest snap priority, but you can also choose another point.

Snapping in drawings
See Snapping in drawings.

6.8 Snap switches and symbols
Use the snap switches to control which positions you can pick in the model or drawing. By using snap switches, you can position objects precisely without having to know the coordinates. You can use snap switches whenever Tekla Structures prompts you to pick a point.

Click the snap switches on the Snapping toolbar to switch them on or off. If there is more than one point available to snap to, press the Tab key to cycle forward through the snap points, and Shift+Tab to cycle backwards through them. Click the left mouse button to select the appropriate point.

Main snap switches
The two main snap switches define whether you can snap to reference points or any other points on objects, for example part corners. These switches have
the highest snap priority (page 92). If both these switches are off, you cannot snap to any positions, even if all the other switches are on.

<table>
<thead>
<tr>
<th>Switch</th>
<th>Snap positions</th>
<th>Description</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Reference lines and points" /></td>
<td>Reference lines and points</td>
<td>You can snap to object reference points (points that have handles).</td>
<td><img src="image" alt="Large symbol" /></td>
</tr>
<tr>
<td><img src="image" alt="Geometry lines and points" /></td>
<td>Geometry lines and points</td>
<td>You can snap to any point on an object. In drawings, you can use this switch to snap to snapshot overlays.</td>
<td><img src="image" alt="Small symbol" /></td>
</tr>
</tbody>
</table>

**Other snap switches**

The table below lists the remaining snap switches and their symbols in the model and drawing.

Make sure that you do not have too many snap switches on when snapping, as it may easily lead to inaccuracies and errors in snapping. Be particularly careful when you use the Snap to any position snap switch.

<table>
<thead>
<tr>
<th>Switch</th>
<th>Snap positions</th>
<th>Description</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Points" /></td>
<td>Points</td>
<td>Snaps to points and grid line intersections.</td>
<td><img src="image" alt="Points symbol" /></td>
</tr>
<tr>
<td><img src="image" alt="End points" /></td>
<td>End points</td>
<td>Snaps to end points of lines, polyline segments, and arcs.</td>
<td><img src="image" alt="End points symbol" /></td>
</tr>
<tr>
<td><img src="image" alt="Centers" /></td>
<td>Centers</td>
<td>Snaps to centers of circles and arcs.</td>
<td><img src="image" alt="Centers symbol" /></td>
</tr>
<tr>
<td><img src="image" alt="Midpoints" /></td>
<td>Midpoints</td>
<td>Snaps to midpoints of lines, polyline segments, and arcs.</td>
<td><img src="image" alt="Midpoints symbol" /></td>
</tr>
</tbody>
</table>
### Switch

<table>
<thead>
<tr>
<th>Switch</th>
<th>Snap positions</th>
<th>Description</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>✕</td>
<td>Intersections</td>
<td>Snaps to intersections of lines, polyline segments, arcs, and circles.</td>
<td><img src="#" alt="Symbol" /></td>
</tr>
<tr>
<td></td>
<td>Perpendicular</td>
<td>Snaps to points on objects that form a perpendicular alignment with another object.</td>
<td><img src="#" alt="Symbol" /></td>
</tr>
<tr>
<td></td>
<td>Line extensions</td>
<td>Snaps to the line extensions of nearby objects, and reference and geometry lines of drawing objects.</td>
<td><img src="#" alt="Symbol" /></td>
</tr>
<tr>
<td></td>
<td>Any position</td>
<td>Snaps to any position.</td>
<td><img src="#" alt="Symbol" /></td>
</tr>
<tr>
<td></td>
<td>Nearest point</td>
<td>Snaps to the nearest points on objects, e.g. any point on part edges or lines.</td>
<td><img src="#" alt="Symbol" /></td>
</tr>
<tr>
<td></td>
<td>Lines</td>
<td>Snaps to grid lines, reference lines, and the edges of existing objects.</td>
<td><img src="#" alt="Symbol" /></td>
</tr>
<tr>
<td></td>
<td>Dimensions and mark lines, drawing layout items and drawing frames</td>
<td>Snaps to annotation geometries, drawing layout items and drawing frames. Available only in drawings.</td>
<td><img src="#" alt="Symbol" /></td>
</tr>
</tbody>
</table>

#### See also

- Snap settings (page 101)
- Override the current snap switch (page 98)
- Default keyboard shortcuts (page 188)

### 6.9 Snap to a point using exact distance or coordinates

You can enter exact distances and coordinates when snapping to a position.

#### Enter a distance or coordinates

Use the **Enter a Numeric Location** dialog box to specify the distance or coordinates to a position you want to snap to.

1. Run a command that requires you to pick points.  
   For example, start creating a beam.
2. Enter a distance or coordinates by using the keyboard.
   For example, type 1000 as the distance from the last point picked. When you start typing, Tekla Structures displays the Enter a Numeric Location dialog box automatically.

3. After entering the distance or coordinates, press Enter to snap to the position.

Options for coordinates
The table below explains the types of information you can enter in the Enter a Numeric Location dialog box:

<table>
<thead>
<tr>
<th>You can enter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>One coordinate</td>
<td>A distance to an indicated direction.</td>
</tr>
<tr>
<td>Two coordinates</td>
<td>If you omit the last coordinate (z) or angle, Tekla Structures assumes that the value is 0. In drawings, Tekla Structures ignores the third coordinate.</td>
</tr>
<tr>
<td>Three coordinates</td>
<td>The x, y, and z coordinates of a position separated by commas. For example, 100, -50, -200.</td>
</tr>
<tr>
<td>Cartesian coordinates</td>
<td>The x, y, and z coordinates of a position separated by commas. For example, 1000&lt;90&lt;45. Angles increase in the counterclockwise direction.</td>
</tr>
<tr>
<td>Polar coordinates</td>
<td>A distance, an angle on the xy plane, and an angle from the xy plane separated by angle brackets. For example, 1000&lt;90&lt;45. Angles increase in the counterclockwise direction.</td>
</tr>
<tr>
<td>Relative coordinates</td>
<td>The coordinates relative to the last position picked. For example, @1000, 500 or @500&lt;30.</td>
</tr>
<tr>
<td>Absolute coordinates</td>
<td>The coordinates based on the origin of the work plane. For example, $0,0,1000.</td>
</tr>
<tr>
<td>Global coordinates</td>
<td>The coordinates relative to the global origin and the global x and y directions. For example, !6000, 12000, 0. This is handy, for example, when you have set the work plane to a part plane and want to snap to a position defined in the global coordinate system without changing the work plane to global.</td>
</tr>
</tbody>
</table>
Change the snapping mode
Tekla Structures has three snapping modes: relative, absolute, and global. Use the advanced option XS_KEYIN_DEFAULT_MODE to indicate the default snapping mode.
1. On the **File** menu, click **Settings** --> **Advanced options** and go to the **Modeling Properties** category.
2. Set the advanced option XS_KEYIN_DEFAULT_MODE to RELATIVE, ABSOLUTE, or GLOBAL.
   This is now the default snapping mode.
3. Click **OK** to save the changes.
4. If you want to temporarily override the default snapping mode, enter a special character in front of the coordinates when entering a numeric location.
   By default, the special characters are:
   • @ for relative coordinates
   • $ for absolute coordinates
   • ! for global coordinates

   **NOTE** If you want to change the special character for any of the three snapping modes, use the advanced options XS_KEYIN_RELATIVE_PREFIX, XS_KEYIN_ABSOLUTE_PREFIX, and XS_KEYIN_GLOBAL_PREFIX.

6.10 Align objects using a snap grid
A snap grid makes it easier to align objects in a model, because it allows you to snap to positions only at set intervals. Use a snap grid when you pick points using the **Snap to any position** snap switch.
1. On the **File** menu, click **Settings** --> **Snap settings**.
2. Define the grid spacing intervals in the **Spacing** boxes.
   For example, if the spacing of the x coordinate is 500, you are able to snap to positions at intervals of 500 units in the x direction.
3. If needed, define offsets for the snap grid origin in the **Origin** boxes.
4. To activate the snap grid, select the **Active (when free snap is on)** check box.
5. Click **OK**.
Now when you pick points using the **Snap to a point or line**
Snap to any position snap switch (page 93), you can only snap to positions at set intervals. The snap grid itself is invisible in the model.

See also
Snap settings (page 101)

6.11 Override the current snap switch
You can temporarily override the current snap switch settings.

1. Run a command that asks you to pick a point.
   For example, start creating a beam.
2. To override the current snap switches (page 93), do one of the following:
   - Right-click to bring up a list of snap options, and then select one of the options.
   - Go to Quick Launch (page 30), type snap override, and select the Snap Override command from the list that appears.
     A new toolbar appears. Click a button to override the current snap switch.

6.12 Example: Track along a line towards a snap point
This example shows how to pick a point at a specified distance along a line. We will use the Enter a Numeric Location dialog box to specify the distance from the last point picked.

1. Create two beams and place them as shown below:
2. Activate the beam command, to create one more beam.
3. Pick the first point.

4. Move the mouse pointer over the grid line midpoint, so that it locks onto the snap point, but **do not** click the mouse button.

5. Type **1000**.
   When you start typing, Tekla Structures displays the **Enter a Numeric Location** dialog box.

6. Click **OK** to confirm the distance.
Tekla Structures creates a beam, which is 1000 units long and positioned between the points you defined:

**TIP** You can also:

- Track beyond the snap point, for example 4000 units from the first point:

![Enter a Numeric Location dialog box with Location set to 4000](image)

- Track in the opposite direction by entering a negative value, for example -1000:

![Enter a Numeric Location dialog box with Location set to -1000](image)

Snap to a point or line 100 Example: Track along a line towards a snap point
6.13 Snap settings

Use the Model snap settings dialog box to view and modify the snap settings in the model. The Drawing snap settings dialog box has the same options for drawings. These settings are user specific.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbol</td>
<td>Show or hide the snap symbols. Select the check box to show the snap symbols, and clear the check box to hide them.</td>
</tr>
<tr>
<td>Active (when free snap is on)</td>
<td>Select the check box to activate the snap grid (page 97).</td>
</tr>
<tr>
<td>Spacing</td>
<td>Define grid spacing intervals for the snap grid origin. For example, if the spacing of the x coordinate is 500, you are able to snap to positions at intervals of 500 units in the x direction.</td>
</tr>
<tr>
<td>Origin</td>
<td>Define offsets for the snap grid origin.</td>
</tr>
<tr>
<td>Angle interval</td>
<td>Set the angle interval for the Ortho tool. This setting is used when you snap to orthogonal points (page 85). For example, if you set the interval to 10, the Ortho tool will snap to angles at intervals of 10 degrees in the model or drawing.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Custom angles</td>
<td>Define custom angles for the Ortho tool. This setting is used when you snap to orthogonal points (page 85). Separate the values with empty spaces. For example, if you enter 12.5 60, the Ortho tool will snap to the angles 12.5 and 60 in the model or drawing.</td>
</tr>
</tbody>
</table>

**See also**

Align objects using a snap grid (page 97)
Select objects

You can make single selections and area selections. Tekla Structures highlights the selected objects. The number of selected objects and handles is displayed in the bottom right corner of the status bar. For example: 

7.1 Select single objects

1. Ensure that the correct selection switches (page 106) are active.
2. Click an object to select it.
   Tekla Structures displays dimensions and dimension lines for the object.
3. If you want to hide the dimensions, use the advanced option XS_DISPLAY_DIMENSIONS_WHEN_SELECTING_OBJECTS.
7.2 **Select multiple objects**

You can select multiple objects using area selection. By default, the dragging direction affects the selection of objects.

1. Ensure that the correct **selection switches (page 106)** are active.
2. To select all objects that are completely within a rectangular area, hold down the left mouse button and drag the mouse from **left to right**.

![Select multiple objects](image1)

3. To select all objects that are at least partly within a rectangular area, hold down the left mouse button and drag the mouse from **right to left**.

![Select multiple objects](image2)

4. If you want to change how area selection works, click **File menu --> Settings** and select or clear the **Crossing selection** check box.

   By default, the option is switched off. When the option is **off**, the dragging direction affects the selection of objects. When the option is **on**, all objects that fall at least partially inside the rectangular area are selected, regardless of the dragging direction.

7.3 **Select all objects**

To select all objects at once, do one of the following:

- On the ribbon, click the down arrow next to the **button, and then click Select all objects.**

7.4 Select handles

Sometimes you need to select only the handles of a part, for example when moving the part. Before you start, make sure that Crossing selection is switched off.

1. On the File menu, click Settings and make sure that Crossing selection is switched off.
2. Ensure that the correct selection switches (page 106) are active.
3. Hold down the left mouse button and drag the mouse from left to right to include the entire part.

The part becomes selected:

4. Hold down the Alt key and drag the mouse from left to right again.
Now only the part handles are selected:

### 7.5 Modify the selection

You can add objects to the current selection, or remove objects from the selection.

1. To add objects to the current selection, press the **Shift** key and select more objects.
2. To switch the selection of an object on or off, press the **Ctrl** key during the selection. Tekla Structures deselects the objects that were already selected and selects those that were previously not selected.
3. To clear the selection of all objects and handles, click somewhere else. For example, click on the empty background of the current view.

### 7.6 Selection switches

The *selection switches* are special commands that control which objects and object types you can select. For example, if you select the entire model area but only the **Select parts** switch is active, only the parts become selected.
Click the selection switches on the **Selecting** toolbar to switch them on or off.

[Image of the Selecting toolbar]

By default, the **Selecting** toolbar is located at the bottom of the Tekla Structures main window. If you are unable to find the toolbar, see How to restore missing toolbars (page 197).

**Main selection switches**

The main selection switches control whether you can select components and assemblies, or objects included in them. These switches have the highest priority.

<table>
<thead>
<tr>
<th>Switch</th>
<th>Selectable objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Components icon]</td>
<td>Components</td>
<td>When you click any object belonging to a component, Tekla Structures selects the component symbol and highlights (but does not select) all component objects.</td>
</tr>
<tr>
<td>![Component objects icon]</td>
<td>Component objects</td>
<td>Objects created automatically by a component can be selected.</td>
</tr>
<tr>
<td>![Assemblies and cast units icon]</td>
<td>Assemblies and cast units</td>
<td>When you click any object in an assembly or a cast unit, Tekla Structures selects the assembly or cast unit and highlights all objects in the same assembly or cast unit.</td>
</tr>
<tr>
<td>![Objects in assemblies and cast units icon]</td>
<td>Objects in assemblies and cast units</td>
<td>You can select single objects in assemblies and cast units.</td>
</tr>
</tbody>
</table>

**Other selection switches**

The table below lists the remaining selection switches. Use these switches to control which object types you want to select.

<table>
<thead>
<tr>
<th>Switch</th>
<th>Selectable objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Any objects icon]</td>
<td>Any objects</td>
<td>Turns all switches on. You can select all object types, except for single bolts.</td>
</tr>
<tr>
<td>![Components icon]</td>
<td>Components</td>
<td>You can select component symbols.</td>
</tr>
<tr>
<td>![Parts icon]</td>
<td>Parts</td>
<td>You can select parts, such as columns, beams, or plates.</td>
</tr>
<tr>
<td>![Surface treatments and surfaces icon]</td>
<td>Surface treatments and surfaces</td>
<td>You can select surface treatments and surfaces.</td>
</tr>
<tr>
<td>![Points icon]</td>
<td>Points</td>
<td>You can select points.</td>
</tr>
<tr>
<td>![Construction lines and circles icon]</td>
<td>Construction lines and circles</td>
<td>You can select construction lines and circles.</td>
</tr>
<tr>
<td>Switch</td>
<td>Selectable objects</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>--------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>![Image]</td>
<td>Reference models</td>
<td>You can select entire reference models. This selection switch may affect the speed of zooming and rotating in the model. For more information, see Tips for large models.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Grids</td>
<td>You can select entire grids by selecting one line in the grid.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Grid lines</td>
<td>You can select single grid lines.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Welds</td>
<td>You can select welds.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Cuts and added material</td>
<td>You can select line, part, and polygon cuts, fittings, and added material.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Views</td>
<td>You can select model views.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Bolt group</td>
<td>You can select entire bolt groups by selecting one bolt in the group.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Single bolts</td>
<td>You can select single bolts.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Reinforcing bars</td>
<td>You can select reinforcing bars and bar groups.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Pour breaks</td>
<td>You can select pour breaks.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Planes</td>
<td>You can select construction planes.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Distances</td>
<td>You can select distances.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Tasks</td>
<td>You can select Task Manager tasks.</td>
</tr>
</tbody>
</table>

**Analysis model switches**

The following switches can be used to select objects in an analysis model:

<table>
<thead>
<tr>
<th>Switch</th>
<th>Selectable objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Image]</td>
<td>Loads</td>
<td>You can select point, line, area, uniform, and temperature loads.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Analysis parts</td>
<td>You can select analysis parts.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Nodes</td>
<td>You can select analysis nodes.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Rigid links</td>
<td>You can select analysis rigid links.</td>
</tr>
</tbody>
</table>
Selection switches in drawings

Similar selection switches are available in drawings:

<table>
<thead>
<tr>
<th>Switch</th>
<th>Selectable objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Switch" /></td>
<td>Any objects</td>
<td>Turns all switches on. You can select all object types, single dimensions of a dimension set, or single grid lines of a grid.</td>
</tr>
<tr>
<td><img src="image2" alt="Switch" /></td>
<td>Lines</td>
<td>You can select drawing objects such as lines, arcs, circles, rectangles, polylines, polygons, and clouds.</td>
</tr>
<tr>
<td><img src="image3" alt="Switch" /></td>
<td>Text</td>
<td>You can select any text in drawings.</td>
</tr>
<tr>
<td><img src="image4" alt="Switch" /></td>
<td>Marks</td>
<td>You can select all kinds of marks in drawings.</td>
</tr>
<tr>
<td><img src="image5" alt="Switch" /></td>
<td>Parts</td>
<td>You can select parts, such as columns, beams, and plates in drawings.</td>
</tr>
<tr>
<td><img src="image6" alt="Switch" /></td>
<td>Section symbols</td>
<td>You can select section symbols in drawings.</td>
</tr>
<tr>
<td><img src="image7" alt="Switch" /></td>
<td>Welds</td>
<td>You can select welds in drawings.</td>
</tr>
<tr>
<td><img src="image8" alt="Switch" /></td>
<td>Views</td>
<td>You can select drawing views.</td>
</tr>
<tr>
<td><img src="image9" alt="Switch" /></td>
<td>Dimensions</td>
<td>You can select drawing dimensions. You can select an entire group of dimensions by selecting one dimension in the group.</td>
</tr>
<tr>
<td><img src="image10" alt="Switch" /></td>
<td>Single dimensions</td>
<td>You can select single drawing dimensions.</td>
</tr>
<tr>
<td><img src="image11" alt="Switch" /></td>
<td>Grids</td>
<td>You can select grids in drawings.</td>
</tr>
<tr>
<td><img src="image12" alt="Switch" /></td>
<td>Grid lines</td>
<td>You can select single grid lines in drawings.</td>
</tr>
<tr>
<td><img src="image13" alt="Switch" /></td>
<td>Detail marks</td>
<td>You can select details marks in drawings.</td>
</tr>
<tr>
<td><img src="image14" alt="Switch" /></td>
<td>Plugins</td>
<td>You can select custom plugins in drawings.</td>
</tr>
</tbody>
</table>

See also

If you cannot select objects (page 112)
7.7 Select assemblies and cast units

Use the Select assemblies selection switch to select assemblies and cast units.

1. Ensure that the Select assemblies selection switch (page 106) is active.
2. Select a part.
   Tekla Structures selects the entire cast unit or assembly that contains the selected part.

7.8 Select nested objects

You can select nested assemblies and components. The active selection switch defines on which level you start and toward which direction you move in the component or assembly hierarchy. The status bar shows the steps you take in the hierarchy.

1. Ensure that the correct selection switch (page 106) is active.
   - : to start from the assemblies on the highest level, move to their sub-assemblies, and finally select single parts, bolts, and so on
   - : to start from single objects and move to bigger and bigger nested assemblies
   - : to start from the components on the highest level, move to their sub-components, and finally select single parts, bolts, and so on
   - : to start from single objects and move to bigger and bigger nested components
2. Hold down the Shift key.
3. Scroll with the mouse wheel.
7.9 Select reference models, reference model objects and assemblies

You can select either entire reference models, or single objects and assemblies that are part of a reference model. The use of selection switches differs in each case.

**Select an entire reference model**

1. Activate the ![Select reference models](image) selection switch.
2. Activate the ![Select components](image) selection switch.
3. Select the reference model.

**Select a reference model object**

1. Activate the ![Select reference models](image) selection switch.
2. Activate the **Select objects in components** selection switch.
3. Select the desired object in the reference model.

### Select a reference model assembly

1. Activate the **Select reference models** selection switch.
2. Activate the **Select assemblies** selection switch.
3. Select the desired assembly in the reference model.

#### 7.10 If you cannot select objects

If you cannot select desired objects in the model, check the selection switches and the filter settings.

1. Check that you have switched on all the needed selection switches (page 106).
2. If you still cannot select the objects, check the selection filter settings. You can select a different filter or modify the current filter.
Copy and move objects

The basic functionality of copying and moving objects is the same in models and drawings. You can copy and move objects linearly, with rotation, and with mirroring.

- Copy objects (page 114)
- Move objects (page 125)
- Rotate objects (page 131)
- Mirror objects (page 135)

Duplicate objects

Two objects are considered duplicates if they have the same size and orientation. Tekla Structures checks for duplicate objects when you copy and move objects or create new parts in the same location as an existing part. If duplicates are found, you can choose whether to keep or delete them.

Use the advanced option to define the maximum number of objects that can be counted as duplicates while copying or moving objects.

NOTE  Tekla Structures does not check for duplicates when you copy objects using a modeling tool, such as the Array of Objects (29) component.

Assemblies and cast units

If you copy or move objects from an assembly or cast unit, Tekla Structures copies the assembly structure if possible. For example, sub-assemblies are copied as sub-assemblies if a parent object is found.

Reinforcement and surface treatment

If you copy or move reinforcement or surface treatments, and want them to adapt to the part they are copied or moved to:

- The reinforcement handle or surface treatment handles must be in part corners.
- The parts between which you copy or move must have the same number of cross section corners.
- Circular parts must have the same cross section dimensions.

**Drawing objects**

You can copy and move drawing objects between drawing views that have different scales.

### 8.1 Copy objects

You can copy objects in a number of different ways. When you copy an object, 
Tekla Structures copies all objects connected to it, including the components.

**Copy by picking two points**

The basic way to copy objects in a model or drawing is by defining the origin and one or more destination points.

1. Select the object you want to copy.
2. Run the **Copy** command:
   - In the model, on the **Edit** tab, click **Copy**.
   - In the drawing, on the **Drawing** tab, click **Copy** --> **Copy**.
3. Pick the origin for copying.
4. Pick one or more destination points.
The objects are copied immediately. The **Copy** command remains active.

5. If you want to undo the latest copy operation, click the **Undo** button on the top left corner of the Tekla Structures main window.

   The **Copy** command still remains active.

6. To stop copying, press **Esc**.

**Copy linearly**

In the model, you can create multiple copies of an object in the same linear direction.

1. Select the objects you want to copy.

2. On the **Edit** tab, click **Copy special --> Linear**.

   The **Copy - Linear** dialog box opens.
3. Pick two points, or enter the coordinates in the $dX$, $dY$, and $dZ$ boxes. You can also use a formula to calculate the x, y, and z displacements. For example:

\[ dY = 3 \times 1250 \]

4. Enter the number of copies.
5. Click **Copy**.
6. To stop copying, press **Esc**.

**TIP** If the dialog box is open but the command is no longer active, click the **Pick** button to re-activate the command.

---

**Copy by specifying a distance from origin**

You can copy objects to a new position in the model or drawing by specifying a distance from the origin. Use the **Enter a Numeric Location** dialog box to specify the distance.

1. Select the objects you want to copy.
2. Run the **Copy** command:
   - In the model, on the **Edit** tab, click **Copy**.
   - In the drawing, on the **Drawing** tab, click **Copy**.
3. Pick the origin for copying.
4. Move the cursor in the direction you want to copy the objects, but do not pick the point.
5. Type the distance.
   When you start typing, Tekla Structures displays the **Enter a Numeric Location** dialog box automatically.
6. Click **OK**.

**Copy using drag-and-drop**

You can copy objects by using drag-and-drop.

1. On the **File** menu, click **Settings** and select the **Drag & drop** check box to activate the command.
2. Select the objects you want to copy.
3. Hold down the **Ctrl** key and drag the objects to a new location. The point you start dragging from (center, corner, or middle point) affects the object's alignment in the new location.

Tekla Structures copies the objects:

---

**NOTE** To copy grid labels in a drawing, first select the grid label and then either activate the **Select grid line** selection switch (page 106) or select the grid label handle.
Copy objects to another object
In the model, you can copy objects from an object to other similar objects. This is useful, for example, when you detail previously modeled parts. The objects that you can copy between can have different dimensions, length, and rotation.

1. Select the objects you want to copy.
2. On the Edit tab, click **Copy special --> To another object**.
3. Select the object to copy from (source object).
4. Select the objects to copy to (target object).

Copy all content to another object
In the model, you can copy objects from an assembly or cast unit to other similar assemblies or cast units without individually selecting each object to copy. This is useful, for example, when you have detailed an assembly and want to copy all details to another similar assembly.

1. Ensure that the **Select assemblies** selection switch (page 106) is active.
2. Select the assembly or cast unit to copy from (source object).
3. On the Edit tab, click **Copy special --> All content to another object**.
4. Select the assemblies or cast units to copy to (target objects).

As a result, Tekla Structures copies the following objects:

- Secondary parts
- Reinforcement, bolts, and welds
- Cuts, fittings, and edge chamfers
- Sub-assemblies
- Components

**NOTE** Tekla Structures does not copy pour breaks, or secondary parts created by a component that has also created the assembly main part. If some of the objects to be copied already exist in the assembly or cast unit to copy to, Tekla Structures may create duplicate objects. Tekla Structures warns you about duplicate secondary parts, reinforcement, and sub-assemblies, but not about duplicate bolts, welds, cuts, or components.
Copy to another plane
In the model, you can copy objects from the first plane you specify to the second (and third, etc.) plane you specify. The position of the copied objects relative to the second (and third, etc.) plane remains the same as the position of the original objects relative to the first plane.

1. Select the objects you want to copy.
2. On the **Edit** tab, click **Copy special --> To another plane**.
3. Pick the point of origin of the first plane.
4. Pick a point on the first plane in the positive x direction.
5. Pick a point on the first plane in the positive y direction.
6. Repeat steps 3–5 for all destination planes.

Copy from another model
You can copy objects from another model based on phase numbers. Note that Tekla Structures copies secondary parts from the model only if they belong to the same phase as their main part. This also applies to component objects.

1. On the **Edit** menu, click **Copy special --> From another model**.
   The **Copy from Model** dialog box opens.
2. In the **Model directories** list, select the model to copy from.
   This is the source model. Note that the target model must have been created using the same or newer version of Tekla Structures as the source model. You cannot copy from a newer version to an older version.
3. In the **Phase numbers** box, enter the numbers of the phases from which to copy objects, separated by spaces.
   For example, 2 7.
4. Click **Copy**.
5. Close the dialog box.

Copy objects using linear array tool
Use **Linear array tool** to copy selected objects linearly along multiple directions at defined intervals or spacing. Tekla Structures does not check for duplicates when you copy objects using this method.
How to use Linear array tool

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. Search for Linear array tool, and then double-click to open it.
3. Select the Copy method. The options are:
   • Selected objects only
     This is the default. Only the selected objects are copied.
   • All associated objects
     Selected objects and all objects associated with them are copied. For example, cuts and fittings applied to a part.
   • Advanced
     This option is similar to All associated objects, but works better with modifications. For example, when you have stairs that have handrails welded to the steps, and you modify the distance between steps.
4. Select the Copy origin. The options are:
   • Objects to be copied
     This is the default. Copies are relative to the input objects.
   • Origin point
     Copies are relative to the input origin point.
5. Define the settings.
6. Select the objects to copy.
7. Click OK to close the dialog box.
8. Click the middle mouse button.
10. Pick axis direction X.
11. Pick axis direction Y.
    The selected objects are copied.
**How to define the settings**

1. Offset along the Y axis. The default value is 0 mm.
2. Offset along the Z axis. The default value is 0 mm.
3. Number of copies. The default value is 0.
4. Space between copies. The default value is 0 mm.
   - Use the space character to separate values. Enter a value for each space between copies.
   - This option is not available if you select Equal as the spacing method.
5. Copy direction. The options are:
   - **Normal** (default)
     - Spacing values are calculated from the origin in positive direction along the axis.
   - **Reverse**
     - Spacing values are calculated from the origin in negative direction along the axis.
   - **Centered**
     - Copies are centered on the origin.
   - **Mirror**
     - Spacing values are calculated from the origin in both positive and negative direction. Mirrored copying doubles the number of copies.
Spacing method. The options are:

• **Equal** (default)
  Copies are equally spaced based on the length of the X or Y axis.

• **Specified**
  Copies are spaced according to the number and spacing values given.

Copy objects using radial array tool
Use **Radial array tool** to copy selected objects radially along multiple directions at defined intervals or spacing. Tekla Structures does not check for duplicates when you copy objects using this method.

![Radial array tool diagram](image)

**How to use Radial array tool**

1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.
2. Search for **Radial array tool**, and then double-click to open it.
3. Select the **Copy method**. The options are:
   - **Selected objects only**
     This is the default. Only the selected objects are copied.
   - **All associated objects**
     Selected objects and all objects associated with them are copied. For example, cuts, welds, and bolts.
   - **Advanced**
     This option is similar to **All associated objects**, but works better with modifications. For example, when you have stairs that have handrails welded to the steps, and you modify the distance between steps.
4. Select the **Rotate copies** option.
   The default is **Yes**.
5. Define the rotation axis.
   The default is **X**.
6. Define the settings.
7. Select the objects to copy.
8. Click **OK** to close the dialog box.
9. Click the middle mouse button.
10. Pick origin point.
11. Pick axis direction X.
12. Pick axis direction Y.
   The selected objects are copied.

### How to define the settings

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Distance between copies. The default value is 0.</td>
</tr>
<tr>
<td>2</td>
<td>Rotation. The options are:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Angle</strong> (default)</td>
</tr>
<tr>
<td></td>
<td>The copies are rotated by angle.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Distance</strong></td>
</tr>
<tr>
<td></td>
<td>The copies are rotated by distance.</td>
</tr>
<tr>
<td>3</td>
<td>Number of angles or distances. The default value is 0.</td>
</tr>
<tr>
<td>4</td>
<td>Space between copies.</td>
</tr>
<tr>
<td></td>
<td>Use the space character to separate values. Enter a value for each space</td>
</tr>
<tr>
<td></td>
<td>between copies.</td>
</tr>
</tbody>
</table>

Copy and move objects 123 Copy objects
Copy direction. The options are:

- **Normal** (default)
  Spacing values are calculated from the origin in positive direction along the axis.

- **Reverse**
  Spacing values are calculated from the origin in negative direction along the axis.

- **Centered**
  Copies are centered on the origin.

- **Mirror**
  Spacing values are calculated from the origin in both positive and negative direction. Mirrored copying doubles the number of copies.

Radial distance.
The radial distance should be equivalent to the distance you picked when applying the component.

If the radial distance is smaller or greater than the picked distance, the spacing between the copied objects is not the same as given in the **Space between copies** box (4).

Tekla Structures calculates the rotation angle according to the dialog box values (spacing and radial distance), and the rotation angle overrides the spacing given in the dialog box.

**Copy objects using Array of objects (29) component**

Use the **Array of objects (29)** component to copy model objects along a line. If you modify the original object, Tekla Structures also changes the copied objects.

1. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.

2. Search for the **Array of objects (29)** component, and then double-click to open it.

3. Define the settings:
   - **Number of copies**: Enter the number of copies you want to create.
   - **Spacing values**: Define the spacing of the objects.
   - **Copy to the opposite direction**: Select **Yes** if you want to copy in the direction opposite to the points you pick.
• **Start point for copying**: Choose either the object to be copied or the first input point.

• **Copy at equal distances**: Select Yes if you want to create the objects at equal distances. **Spacing value** will be ignored.

4. Click **OK** to save the settings.

5. Select the objects to copy.

6. Click the middle mouse button to finish selecting.

7. Pick a point to indicate the start of the line along which to arrange copied objects.

8. Pick a point to indicate the end of the line.

**Examples**

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Array of steel objects" /></td>
<td>An array of steel objects.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Array of concrete objects" /></td>
<td>An array of concrete objects.</td>
</tr>
</tbody>
</table>
8.2 Move objects

You can move objects in a number of different ways, especially in models. When you move an object, Tekla Structures also copies all objects connected to it.

Move by picking two points

The basic way to move objects in a model or drawing is by defining the origin and one or more destination points.

1. Select the object you want to move.

2. Run the Move command:

   - In the model, on the Edit tab, click Move.
   - In the drawing, on the Drawing tab, click Move --> Move

3. Pick the origin for moving.

4. Pick the destination point.
The object is moved immediately. The **Move** command does not remain active.

**Move linearly**
You can move objects linearly to a new position in the model.

1. Select the objects you want to move.

2. On the **Edit** tab, click **Move special --> Linear**.
   The **Move - Linear** dialog box opens.

3. Pick two points in the model, or enter the coordinates in the **dX**, **dY**, and **dZ** boxes.
   You can also use a formula to calculate the x, y, and z displacements. For example:
   
   
   \[
   dY = 3\times1.250
   \]

4. Click **Move**.
TIP If the dialog box is open but the command is not active anymore, click the Pick button to re-activate the command.

Move by specifying a distance from origin

You can move objects to a new position in the model or drawing by specifying a distance from the origin. Use the **Enter a Numeric Location** dialog box to specify the distance.

1. Select the objects you want to move.
2. Run the **Move** command:
   - In the model, on the **Edit** tab, click **Move**.
   - In the drawing, on the **Drawing** tab, click **Move --> Move**.
3. Pick the origin for moving.
4. Move the cursor in the direction you want to move the objects, but do not pick the point.
5. Type the distance.
   - When you start typing, Tekla Structures displays the **Enter a Numeric Location** dialog box automatically.
6. Click **OK**.

Move using drag-and-drop

You can move objects by dragging them to a new location.

1. On the **File** menu, click **Settings** and select the **Drag & drop** check box to activate the command.
2. Select the objects you want to move.
3. Drag the objects to a new location.
   The point you start dragging from (center, corner, or middle point) affects the object's alignment in the new location.

The objects are moved immediately.

4. To move an end point using drag-and-drop:
   a. Select the handle.
   b. Hold down the left mouse button, and drag the handle to a new location.

The end point is moved accordingly:
NOTE For some objects, you may need to switch on Smart select to drag from handles without selecting them first. To switch it on, click File menu --> Settings and select the Smart select check box.

NOTE To move grid labels in a drawing, first select the grid label and then either activate the Select grid line selection switch (page 106) or select the grid label handle.

**Move to another plane**

In a model, you can move objects from the first plane you specify to another plane, which you specify by picking three points. The moved objects remain in the same position on the second plane as the original objects on the first plane.

1. Select the objects you want to move.

2. On the Edit tab, click Move special --> To another plane.

3. Pick the point of origin of the first plane.

4. Pick a point on the first plane in the positive x direction.

5. Pick a point on the first plane in the positive y direction.

6. Repeat steps 3–5 for the destination plane.

**Move objects to another object**

In a model, you can move objects from an object to other, similar objects. This is useful, for example, when you detail previously modeled parts. The objects that you move between can have different dimensions, length, and rotation.

1. Select the objects you want to move.
2. On the **Edit** tab, click **Move special --&gt; To another object**.

3. Select the object to move from (source object).

4. Select the objects to move to (target object).

### 8.3 Rotate objects

You can copy or move an object in a model by rotating it around any line you choose. In a drawing, you can copy or move an object by rotating it around a given line on the work plane.

**NOTE** Positive rotation is according to the right-hand rule (clockwise when looking from the start point of the rotation axis).

---

#### Rotate around a line

Use the **line** option in the **Rotate** dialog box when you want to copy and rotate, or move and rotate objects around any given line in the model.

1. Select the objects you want to copy or move.

2. Activate the rotation command.

   - To copy and rotate, go to the **Edit** tab and click **Copy special --&gt; Rotate**.
     
     The **Copy - Rotate** dialog box opens.
     
     - To move and rotate, go to the **Edit** tab and click **Move special --&gt; Rotate**.
       
     The **Move - Rotate** dialog box opens.

3. In the **Around** list, select **line**.

4. Pick the start point of the rotation axis, or enter its coordinates.

5. Pick the end point of the rotation axis, or enter its coordinates.

6. If you are copying, enter the number of copies.

7. If needed, enter the **dZ** value, which is the difference in position between the original and copied object in the z direction.

8. Enter the rotation angle.

9. Click **Copy** or **Move**.

   The objects are rotated accordingly.
Example
In this example, a fitting plate is copied and rotated around a construction line that is located at the following coordinates.

<table>
<thead>
<tr>
<th>Origin</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>10000.00</td>
</tr>
<tr>
<td>Y0</td>
<td>23047.50</td>
</tr>
<tr>
<td>Z0</td>
<td>-900.00</td>
</tr>
<tr>
<td>X1</td>
<td>19000.00</td>
</tr>
<tr>
<td>Y1</td>
<td>24000.00</td>
</tr>
<tr>
<td>Z1</td>
<td>-900.00</td>
</tr>
</tbody>
</table>

As a result, the copied fitting plates follow the curve of the concrete panel.

Rotate around the z axis
Use the Z option in the Rotate dialog box when you want to copy and rotate, or move and rotate objects around the z axis in the model.

1. Select the objects you want to copy or move. For example:
2. Activate the rotation command.

- To copy and rotate, go to the Edit tab and click Copy special --> Rotate .
  The Copy - Rotate dialog box opens.

- To move and rotate, go to the Edit tab and click Move special --> Rotate .
  The Move - Rotate dialog box opens.

3. Select Z in the Around list.

4. Pick a point to define the rotation axis, or enter its coordinates.
   In the example below, the red cross indicates the picked point.

5. If you are copying, enter the number of copies.

6. If needed, enter the dZ value, which is the difference in position between the original and copied object in the z direction.

7. Enter the rotation angle. For example:
8. Click **Copy** or **Move**.

The objects are rotated accordingly.

---

**Rotate drawing objects**

Use this option when you want to rotate drawing objects on the work plane.

1. Select the objects you want to copy or move.
2. Activate the rotation command.
   
   - To copy and rotate, go to the **Drawings** tab and click **Copy --&gt; Rotate**.
     
     The **Copy - Rotate** dialog box opens.
   
   - To move and rotate, go to the **Drawings** tab and click **Move --&gt; Rotate**.
     
     The **Move - Rotate** dialog box opens.

3. Pick a point, or enter its coordinates.
4. If you are copying, enter the number of copies.
5. Enter the rotation angle.
6. Click **Copy** or **Move**.
8.4 Mirror objects

When you copy or move objects, you can mirror them through a plane that is perpendicular to the work plane and passes through a line you specify.

Note that Tekla Structures cannot create mirrored copies of component properties. The Copy special > Mirror command does not fully mirror objects if they include components that contain, for example, asymmetrically positioned parts.

Mirror model objects

Use this method to copy and mirror, or move and mirror objects in a model.

1. Select the objects you want to copy or move.
2. Activate the mirroring command.

   • To copy and mirror, go to the Edit tab and click Copy special --> Mirror.
     The Copy - Mirror dialog box opens.

   • To move and mirror, go to the Edit tab and click Move special --> Mirror.
     The Move - Mirror dialog box opens.

3. Pick the start point of the mirroring plane, or enter its coordinates.
4. Pick the end point of the mirroring plane, or enter its coordinates.
5. Enter the angle.
6. Click Copy or Move.

Mirror drawing objects

Use this method to copy and mirror, or move and mirror objects in a drawing.

1. Select the objects you want to copy or move.
2. Activate the mirroring command.

   • To copy and mirror, go to the Edit tab and click Copy special --> Mirror.
     The Copy - Mirror dialog box opens.
• To move and mirror, go to the Edit tab and click \textit{Move special} --\textgreater \textit{Mirror}.

The \textit{Move - Mirror} dialog box opens.

3. Pick the start point of the mirroring plane, or enter its coordinates.
4. Pick the end point of the mirroring plane, or enter its coordinates.
5. Enter the angle.
6. Click \textit{Copy} or \textit{Move}.
Filter objects

Use filters to restrict what can be selected or what is visible in a view. You can create filters of your own, or you can use any of the standard filters available in Tekla Structures.

Here are some examples of what filters can be used for:

• **To select a large number of objects**
  Use selection filters when you need to change a specific object property that is common for many objects. The rest of the objects will not be affected, even if you try to include them in the selection.

• **To check the model**
  Use view filters to ensure that beams are called beams, columns are called columns, and so on. You can highlight several groups of objects, one at a time, to check that all required objects are included in a given group.

• **To hide objects**
  Use view filters to temporarily hide the columns in a view so that it easier to select all the beams, for example.

• **To find objects**
  You can create a selection filter to find all locations where $\frac{1}{2}$” reinforcing bars are in the model, for example. Once the filter is active, you can make an area selection that includes the entire model. All specified reinforcing bars become selected, but the other objects will not be affected.

**See also**

- Use existing filters (page 137)
- Create new filters (page 140)
- Filtering techniques (page 144)
- Examples of filters (page 162)
9.1 Use existing filters
Before creating new custom filters, check out the existing view and selection filters available in Tekla Structures.

How to use a view filter
Use view filters to define which objects are displayed in a model view.
1. Double-click the view to open the View Properties dialog box.
2. Select a filter from the Visible object group list.
   For example, select purlins.

![Visible object group dialog box]

3. Click Modify.
   Now only the objects defined by the filter are visible. For example, the purlins:

![Diagram showing purlins]

4. To stop using the filter:
   a. Double-click the view to open the View Properties dialog box.
   b. In the Visible object group list, select the standard filter.
   c. Click Modify.
All objects are visible again:

NOTE If you cannot see all desired objects, note that the work area, view depth, view setup, and object representation settings also affect the visibility of objects.

How to use a selection filter
Use selection filters to define which objects can be selected in the model. Note that an object must be visible in the model to be selectable.

1. On the Selecting toolbar, select a filter from the list.

   The list is by default located at the bottom of the Tekla Structures main window.

   For example, select the Name - Footing filter.

2. Select the desired objects in the model.

   You can select multiple objects or even the entire model at once. Now that the filter is active, only objects defined by the filter become selected. For
example, if the **Name - Footing** filter is active, only footings are selectable and the rest of the objects stay intact:

3. If you cannot select all objects defined by the selection filter, check your view filter settings and ensure that you have switched on all the needed selection switches (page 106).

4. To stop using the filter, go to the **Selecting** toolbar and select the **standard** filter.
   All objects are selectable again.

### 9.2 Create new filters

You can create custom filters to define which objects are visible and selectable in the model and drawings. Add new filter rules, one on each row, to define which objects should be included or excluded.

**Create a view filter**

You can create your own custom filters to define which objects are visible in a model.

1. Double-click the view to open the **View Properties** dialog box.
2. Click **Object group**.
   
   The **Object Group - View Filter** dialog box opens, showing the currently active filter.
3. Click **New filter** to create a new filter from scratch.
4. Click **Add row** to add a new filter rule.
5. In the **Category** list, select an object category. You have the following options:

- Part
- Component
- Bolt
- Weld
- Reinforcing bar
- Surface
- Assembly
- Load
- Template
- Reference assembly
- Reference object
- Location breakdown structure
- Task
- Object

6. In the **Property** list, select a suitable *object property* (page 147). The options vary depending on the object category you chose in step 5.

7. In the **Condition** list, select a suitable *condition* (page 144).

8. In the **Value** list, type a value. Alternatively, to use the current value of an existing object, click **Select from model** and select the desired object from the model. For date values, also the **Select date** option is available.

Filter values can be complete strings, such as the profile name **UC310*97**. You can also use incomplete strings together with **wildcards (page 162)**. For example, the value **UC*** will match with all parts whose profile name begins with the characters **UC**. Empty values are matched to empty object properties.

If you use multiple values, separate the strings with blank spaces (for example, **12 5**). If a value consists of multiple strings, enclose the entire
value in quotation marks (for example, "custom panel"), or use a question mark (for example, custom?panel) to replace the space.

9. Repeat steps 4–8 to create as many filter rules as needed.
   You can apply several filter rules at the same time.

10. Use the **And/Or** options and brackets (page 144) to define how the filter rules work together.

11. Select the check boxes next to all filter rules that you want to enable.
    If the check box is selected, the filter rule is enabled and effective. For example:

```
- {   Category     Property
  - Object       Object type
  - Part         Phase
```

   By default, each new rule is disabled.

12. Define the filter type.
   a. Click to display more settings.
   b. Select or clear the check boxes to define where the filter will be used.
      For example, the same filter may be used both as a view filter and as a selection filter.

13. Enter a unique name in the box next to the **Save as** button.

   **NOTE**
   - Filters are case sensitive.
   - Do not use spaces in filter names.
   - We recommend that you use _ (underscores) in your naming convention.
   - To have the filter appear at the top of the list, right after the standard filter, use capital letters in the filter name.

14. Click **Save as** to save the filter.

15. To apply the filter to the current view, click **Modify**.

**Create a selection filter**
You can create your own custom filters to help you select objects in a model.

1. On the **Selecting** toolbar, click to open the **Object Group - Selection Filter** dialog box.
2. Follow the instructions above on how to create a view filter. The same instructions apply to selection filters.

**Create a drawing filter**

For general arrangement drawings, you can create drawing filters that affect the whole drawing, not just a specific view. Drawing filters select objects in the whole drawing.

You can use drawing filters together with saved object property files when you create and apply object level settings in the whole drawing. For example, you might create a filter that selects all beams, then save an object property file that defines that the part color is blue, and then create and apply an object level settings file that changes all beams to blue in the whole drawing.

1. On the **Drawing** tab, click **Properties --> Drawing**.
2. Click **Filter**.
3. Follow the instructions above on how to create a view filter. The same instructions apply to drawing filters.
4. When you are done, click **Cancel** to close the filter properties dialog box.

**Create a drawing view filter**

You can create your own custom view filters to help you select a specific group of view objects in a drawing view.

You can use drawing view filters for changing the appearance of a certain object group, or for selecting which objects are hidden in a drawing view.

You can also use drawing view filters together with saved object property files when you create and apply object level settings in the selected view. For example, you might create a view filter that selects all columns in a view, then save an object property file that defines that the part color is red, and then create and apply an object level settings file that changes all columns to red in the selected view.

1. Open a drawing.
2. Double-click the view frame.
3. Click **Filter**.
4. Follow the instructions above on how to create a view filter. The same instructions apply to drawing view filters.
5. When you are done, click **Cancel** to close the filter properties dialog box.
Create a drawing selection filter

You can create your own custom filters to help you select objects in a drawing. You can use selection filters in drawings if you want to hide certain parts from drawings or drawing views, or change the part color or representation for certain parts.

Also, if you have some different looking part marks for different types of parts, you can select the specific parts using a selection filter and then only modify part marks for those parts.

1. In an open drawing, on the Selecting toolbar, click \( \text{Ctrl+G} \).
   The Selection Filter dialog box opens.
2. Follow the instructions above on how to create a view filter.
   The same instructions apply to drawing selection filters.
3. Click Apply or OK to select the parts according to the filter.

9.3 Filtering techniques

By using conditions, brackets, and the And/Or options you can create filters that can be as complex as needed.

Conditions

Use conditions to define how filter criteria relate to one another. Note that when you create filters, you are always defining what should be shown (or be selectable) in the model or drawing. Therefore, if you enter "Component name does not contain gusset", you are telling Tekla Structures to show all components whose name does not contain the word "gusset". Tekla Structures then hides all components which have the word "gusset" in their name.

<table>
<thead>
<tr>
<th>Condition</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Equals</strong></td>
<td>Use this condition when the filter value must be matched exactly. For example, &quot;Part name equals BEAM.&quot;</td>
</tr>
<tr>
<td><strong>Does not equal</strong></td>
<td>Filters out objects that contain the value you enter. For example, &quot;Part profile does not equal BL200<em>20&quot; means that Tekla Structures will hide (or not select) the objects whose profile is BL200</em>20. The rest of the objects will be shown (or selected).</td>
</tr>
<tr>
<td><strong>Begins with</strong></td>
<td>Finds all objects that start with the value you enter. For example,</td>
</tr>
<tr>
<td>Condition</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>&quot;Component name begins with purlin.&quot;</td>
<td>Filters out objects that start with the value you enter. For example, &quot;Component name does not begin with shear&quot; means that Tekla Structures will hide (or not select) the objects whose name begins with the word &quot;shear&quot;. The rest of the objects will be shown (or selected).</td>
</tr>
<tr>
<td>Does not begin with</td>
<td></td>
</tr>
<tr>
<td>Ends with</td>
<td>Filters out objects that end with the value you enter. For example, &quot;Component name does not end with angle&quot; means that Tekla Structures will hide (or not select) the objects whose name ends with the word &quot;angle&quot;. The rest of the objects will be shown or selected.</td>
</tr>
<tr>
<td>Does not end with</td>
<td></td>
</tr>
<tr>
<td>Contains</td>
<td>Filters out objects that include the value you enter. For example, &quot;Component name contains plate&quot; would find base plate and shear plate simple.</td>
</tr>
<tr>
<td>Does not contain</td>
<td>Filters out objects that include the value you enter. For example, &quot;Component name does not contain gusset&quot; means that Tekla Structures will hide (or not select) the objects whose name contains the word &quot;gusset&quot;. The rest of the objects will be shown or selected.</td>
</tr>
<tr>
<td>Greater than</td>
<td>Filters out objects that exceed the value you enter. For example, &quot;Template attribute LENGTH is greater than 5000.&quot; This property can only be used with numerical data, such as the part start number, class, phase, or LENGTH.</td>
</tr>
<tr>
<td>Condition</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Greater than or equal</td>
<td>Finds all objects that match or exceed the value you enter.</td>
</tr>
<tr>
<td></td>
<td>This property can only be used with numerical data, such as the part start number, class, phase, or LENGTH.</td>
</tr>
<tr>
<td>Less than</td>
<td>Finds all objects that are less than the value you enter.</td>
</tr>
<tr>
<td></td>
<td>This property can only be used with numerical data, such as the part start number, class, phase, or LENGTH.</td>
</tr>
<tr>
<td>Less or equal</td>
<td>Finds all objects that match or are less than the value you enter.</td>
</tr>
<tr>
<td></td>
<td>This property can only be used with numerical data, such as the part start number, class, phase, or LENGTH.</td>
</tr>
<tr>
<td>Later than</td>
<td>Available for dates only. The date must be later than the one you have defined. For example, &quot;Object's approval date later than 4/10/2017.&quot;</td>
</tr>
<tr>
<td>Later than or equal</td>
<td>Available for dates only. The date must be later than or equal to the one you have defined.</td>
</tr>
<tr>
<td>Earlier than</td>
<td>Available for dates only. The date must be earlier than the one you have defined. For example, &quot;Object's approval date earlier than 2/18/2017.&quot;</td>
</tr>
<tr>
<td>Earlier than or equal</td>
<td>Available for dates only. The date must be earlier than or equal to the one you have defined.</td>
</tr>
</tbody>
</table>

**And/Or options**

Use the **And/Or** options when you create filter rules that consist of several rows.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>And</td>
<td>Use to find objects that match both values.</td>
</tr>
<tr>
<td></td>
<td>When you create filter rules between objects whose <strong>Category</strong> settings differ, use the <strong>And</strong> option when possible to avoid potential problems with more complex rules.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------------------------------------</td>
</tr>
<tr>
<td>Or</td>
<td>Use to find objects that match either value.</td>
</tr>
<tr>
<td>empty (= And)</td>
<td>Empty means the same as And.</td>
</tr>
</tbody>
</table>

**Brackets**

You can use single, double, and triple brackets to create more complex filter rules.

**Example 1.** Use the format "A and (B or C)" to find objects that match the first filter rule and **either** of the last two rules.

```
- ( Part Name  Equals  BRACING  -  And
  ( Part Phase Equals  1       -  Or
  - Part Phase Equals  3       )  Or
```

**Example 2.** Use the format "(A and B) or C" to find objects that match both of the first two rules **or** the third.

```
- ( Part Name  Equals  COLUMN  -  And
  - Part Profile Equals  IPE300  )  Or
  - Part Material Equals  S235JR  -  Or
```

### 9.4 Object properties in filtering

You can select from a wide variety of object properties when creating new filters. In the tables below, the properties are listed according to their object category. In addition to these, almost all categories contain user-defined attributes and template attributes that can also be used in filtering.

**Category: Part**

Use the **Part** category to filter parts based on their common properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>To filter objects based on their name. For example, &quot;Part name equals SLAB.&quot;</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Profile</td>
<td>To filter objects based on their profile. For example, &quot;Part profile does not equal L20*2.&quot;</td>
</tr>
<tr>
<td>Material</td>
<td>To filter objects based on their material grade. For example, &quot;Part material equals C25/30.&quot;</td>
</tr>
<tr>
<td>Finish</td>
<td>To filter objects based on how the part surface has been treated. For example, &quot;Part finish equals &quot;FP – Fire proofing&quot;.&quot;</td>
</tr>
<tr>
<td>Prefix</td>
<td>To filter objects based on their numbering prefix. For example, &quot;Part prefix equals P.&quot;</td>
</tr>
<tr>
<td>Start number</td>
<td>To filter objects based on their start number. For example, &quot;Part start number greater than 100.&quot;</td>
</tr>
<tr>
<td>Numbering series</td>
<td>To filter objects based on their numbering series information. For example, &quot;Part numbering series equals TP/1.&quot;</td>
</tr>
<tr>
<td></td>
<td>Note that position number separator can be a dot (.), comma (,), slash (/), or hyphen (-), depending on what you have defined in File menu --&gt;</td>
</tr>
<tr>
<td></td>
<td>Settings --&gt; Options --&gt; Numbering.</td>
</tr>
<tr>
<td>Position number</td>
<td>To filter objects based on their position number. For example, &quot;Part position number does not equal P/5.&quot;</td>
</tr>
<tr>
<td></td>
<td>Note that position number separator can be a dot (.), comma (,), slash (/), or hyphen (-), depending on what you have defined in File menu --&gt;</td>
</tr>
<tr>
<td></td>
<td>Settings --&gt; Options --&gt; Numbering.</td>
</tr>
<tr>
<td>Class</td>
<td>To filter objects based on their class number. For example, &quot;Part class equals 210.&quot;</td>
</tr>
<tr>
<td>Phase</td>
<td>To filter objects based on their phase number. For example, &quot;Part phase equals 1 2.&quot;</td>
</tr>
<tr>
<td>Lot</td>
<td>To filter objects based on their lot number. For example, &quot;Part lot greater than 1.&quot;</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Primary part</td>
<td>To filter objects based on whether they are main or secondary parts in an assembly or cast unit. (1 = ) primary part, (0 = ) secondary part. For example, &quot;Part primary part equals 1.&quot;</td>
</tr>
</tbody>
</table>

**Category: Component**  
Use the **Component** category to filter components based on their common properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>To filter components based on their name. For example, &quot;Component name equals &quot;shear plate simple&quot;.&quot;</td>
</tr>
<tr>
<td>Connection code</td>
<td>To filter components based on their connection code, which can be either a text string or a number. For example, &quot;Component connection code equals 200_2.&quot;</td>
</tr>
<tr>
<td>Running number</td>
<td>To filter components based on their unique running number. For example, &quot;Component running number less than 150.&quot;</td>
</tr>
<tr>
<td>Phase</td>
<td>To filter components based on their phase number. For example, &quot;Component phase equals 2.&quot;</td>
</tr>
<tr>
<td>Is conceptual</td>
<td>To filter components based on their type. Components can be either detailed or conceptual. (Yes = ) conceptual, (No = ) detailed. For example, &quot;Component is conceptual equals Yes.&quot;</td>
</tr>
</tbody>
</table>

**Category: Bolt**  
Use the **Bolt** category to filter bolts based on their common properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>To filter bolts based on their diameter. For example, &quot;Bolt size less than 20.00.&quot;</td>
</tr>
<tr>
<td>Standard</td>
<td>To filter bolts based on their bolt assembly standard/grade. For</td>
</tr>
</tbody>
</table>

Filter objects 149 Object properties in filtering
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>example, &quot;Bolt standard equals 7990.&quot;</td>
</tr>
<tr>
<td>Site/Workshop</td>
<td>To filter bolts based on their assembly type. Site = 0, Workshop = 1. For</td>
</tr>
<tr>
<td></td>
<td>example, &quot;Bolt Site/Workshop equals 1.&quot;</td>
</tr>
<tr>
<td>Phase</td>
<td>To filter bolts based on their phase number. For example, &quot;Bolt phase</td>
</tr>
<tr>
<td></td>
<td>equals 3 4.&quot;</td>
</tr>
<tr>
<td>Length</td>
<td>To filter bolts based on their length. For example, &quot;Bolt length greater</td>
</tr>
<tr>
<td></td>
<td>than 50.00.&quot;</td>
</tr>
</tbody>
</table>

**Category: Weld**

Use the **Weld** property to filter welds based on their common properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size above line</td>
<td>To filter welds based on their size. For example, &quot;Weld size above line</td>
</tr>
<tr>
<td></td>
<td>equals 5.00.&quot;</td>
</tr>
<tr>
<td>Size below line</td>
<td></td>
</tr>
<tr>
<td>Reference text</td>
<td>To filter welds based on their reference text, which is a user-definable</td>
</tr>
<tr>
<td></td>
<td>value in the <strong>Weld Properties</strong> dialog box. For example, &quot;Weld reference</td>
</tr>
<tr>
<td></td>
<td>text contains 12345.&quot;</td>
</tr>
<tr>
<td>Phase</td>
<td>To filter welds based on their phase number. For example, &quot;Weld phase</td>
</tr>
<tr>
<td></td>
<td>equals 3.&quot;</td>
</tr>
<tr>
<td>Type above line</td>
<td>To filter welds based on their weld type. Select the type from the <strong>Value</strong></td>
</tr>
<tr>
<td>Type below line</td>
<td>list.</td>
</tr>
<tr>
<td>Length above line</td>
<td>To filter welds based on their length value. For example, &quot;Weld length</td>
</tr>
<tr>
<td></td>
<td>greater than 0.00.&quot;</td>
</tr>
<tr>
<td>Length below line</td>
<td></td>
</tr>
<tr>
<td>Welding site</td>
<td>To filter welds based on where they should be made. The options are <strong>Site</strong></td>
</tr>
<tr>
<td></td>
<td>and <strong>Workshop</strong>.</td>
</tr>
<tr>
<td>Position number</td>
<td>To filter welds based on their unique position number. For example, &quot;Weld</td>
</tr>
<tr>
<td></td>
<td>position number is greater than 100.&quot;</td>
</tr>
<tr>
<td>Angle above line</td>
<td>To filter welds based on the angle of weld preparation, bevels, or groove.</td>
</tr>
<tr>
<td>Angle below line</td>
<td></td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Contour above line</td>
<td>To filter welds based on their fill type contour. The options are <strong>None</strong>, <strong>Flush</strong>, <strong>Convex</strong>, and <strong>Concave</strong>. For example, &quot;Weld contour above line does not equal None.&quot;</td>
</tr>
<tr>
<td>Contour below line</td>
<td></td>
</tr>
<tr>
<td>Effective throat above line</td>
<td>To filter welds based on their weld size used in weld strength calculation. For example, &quot;Weld effective throat above line equals 0.500.&quot;</td>
</tr>
<tr>
<td>Effective throat below line</td>
<td></td>
</tr>
<tr>
<td>Finish above line</td>
<td>To filter welds based on how they have been treated. The options are <strong>None</strong>, <strong>Grind</strong>, <strong>Machine</strong>, <strong>Chip</strong>, <strong>Finished weld</strong>, and <strong>Smooth transition</strong>.</td>
</tr>
<tr>
<td>Finish below line</td>
<td></td>
</tr>
<tr>
<td>Increment amount above line</td>
<td>To filter welds based on their amount of increments. For example, &quot;Weld increment amount above line greater than 0.&quot;</td>
</tr>
<tr>
<td>Increment amount below line</td>
<td></td>
</tr>
<tr>
<td>Intermittent type</td>
<td>To filter welds based on their shape. The options are <strong>Continuous</strong>, <strong>Intermittent</strong>, and <strong>Staggered intermittent</strong>.</td>
</tr>
<tr>
<td>Pitch above line</td>
<td>To filter welds based on their spacing of weld increments.</td>
</tr>
<tr>
<td>Pitch below line</td>
<td></td>
</tr>
<tr>
<td>Root face thickness above line</td>
<td>To filter welds based on their root face thickness, in other words, the height of the narrowest part inside the root opening.</td>
</tr>
<tr>
<td>Root face thickness below line</td>
<td></td>
</tr>
<tr>
<td>Root opening above line</td>
<td>To filter welds based on the space found between the welded parts.</td>
</tr>
<tr>
<td>Root opening below line</td>
<td></td>
</tr>
<tr>
<td>Size prefix above line</td>
<td>To filter welds based on their weld size prefix. For example, &quot;Weld size prefix above line equals a.&quot;</td>
</tr>
<tr>
<td>Size prefix below line</td>
<td>The standard ISO 2553 prefixes are <strong>a</strong> (Design throat thickness), <strong>s</strong> (Penetration throat thickness), and <strong>z</strong> (Leg length).</td>
</tr>
<tr>
<td>User-defined cross-section</td>
<td>To filter welds based on whether or not they contain user-defined cross-sections. The options are <strong>Yes</strong> and <strong>No</strong>.</td>
</tr>
</tbody>
</table>
## Property Description

**Electrode classification**  
To filter welds based on their weld electrode classification. The options are (empty), 35, 52, 50, E60XX, E70XX, E80XX, and E90XX.

**Electrode strength**  
To filter welds based on their electrode strength. For example, "Weld electrode strength greater than 0.000."

**Process type**  
To filter welds based on their welding process type. The options are SMAW, SAW, GMAW, FCAW, ESW, and EGW.

**NDT inspection**  
To filter welds based on their non-destructive testing and inspection level. The options are A, B, C, D, and E.

**Is around weld**  
To filter welds based on whether only one edge or the entire perimeter of a face is welded. **Edge = No, Around = Yes.**

### Category: Reinforcing bar

Use the **Reinforcing bar** category to filter reinforcing bars based on their common properties.

## Property Description

**Name**  
To filter reinforcing bars based on their name. For example, "Reinforcing bar name equals "STIRRUP"."

**Class**  
To filter reinforcing bars based on their class number. For example, "Reinforcing bar class equals 3."

**Size**  
To filter reinforcing bars based on their size. The size property depends on the environment and may contain letters and special characters. For example, in the US imperial environment, "Reinforcing bar size equals #18."

**Diameter**  
To filter reinforcing bars based on their diameter. Diameter is the nominal diameter of the bar, not actual. For example, "Reinforcing bar diameter less than 12."
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Length</td>
<td>To filter reinforcing bars based on their total length. For example, &quot;Reinforcing bar length greater than 5000.00.&quot;</td>
</tr>
<tr>
<td>Material</td>
<td>To filter reinforcing bars based on their material grade. For example, &quot;Reinforcing bar material does not equal Undefined.&quot;</td>
</tr>
<tr>
<td>Prefix</td>
<td>To filter reinforcing bars based on their numbering prefix. For example, &quot;Reinforcing bar prefix equals R.&quot;</td>
</tr>
<tr>
<td>Start number</td>
<td>To filter reinforcing bars based on their start number. For example, &quot;Reinforcing bar start number greater than 1.&quot;</td>
</tr>
<tr>
<td>Numbering series</td>
<td>To filter reinforcing bars based on their numbering series information. For example, &quot;Reinforcing bar numbering series equals R/1.&quot;</td>
</tr>
<tr>
<td>Position number</td>
<td>To filter reinforcing bars based on their position number. For example, &quot;Reinforcing bar position number equals R/3.&quot;</td>
</tr>
<tr>
<td>Phase</td>
<td>To filter reinforcing bars based on their phase number. For example, &quot;Reinforcing bar phase equals 2.&quot;</td>
</tr>
<tr>
<td>Shape</td>
<td>To filter reinforcing bars based on their bending shape. For example, &quot;Reinforcing bar shape does not equal 2_1.&quot;</td>
</tr>
</tbody>
</table>

**Category: Surface**

Use the **Surface** category to filter surfaces based on their common properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>To filter surfaces based on their name. For example, &quot;Surface name equals SURFACE.&quot;</td>
</tr>
<tr>
<td>Type</td>
<td>To filter surfaces based on their type. The options are <strong>Formwork</strong> and <strong>Concrete finish</strong>.</td>
</tr>
</tbody>
</table>
**Property** | **Description**  
---|---  
**Class** | To filter surfaces based on their class number. For example, "Surface class does not equal 13."  
**Phase** | To filter surfaces based on their phase number. For example, "Surface phase equals 3 4."  

**Category: Assembly**  
Use the **Assembly** category to filter assemblies and cast units based on their common properties.  

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>To filter assemblies and cast units based on their name. For example, &quot;Assembly name does not contain RAFTER.&quot;</td>
</tr>
</tbody>
</table>
| **Id number** | To filter assemblies and cast units based on their ID number. For example, "Assembly ID number greater than 25000."  
Use this property only in temporary filters, because the ID number may change when you reopen the model. Use the GUID property available in the **Object** category for more permanent filters. |
| **Prefix** | To filter assemblies and cast units based on their numbering prefix. For example, "Assembly prefix equals A." |
| **Start number** | To filter assemblies and cast units based on their start number. For example, "Assembly start number greater than 1." |
| **Position number** | To filter assemblies and cast units based on their position number. For example, "Assembly position number equals A/13." |
| **Phase** | To filter assemblies and cast units based on their phase number. For example, "Assembly phase does not equal 1." |
| **Assembly level** | To filter assemblies and cast units based on their position in the assembly hierarchy. The larger the
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
</table>
| Assembly type      | To filter assemblies and cast units based on their type.  
• 0 = precast  
• 1 = cast in place  
• 2 = steel  
• 3 = timber  
• 6 = miscellaneous |
| Assembly series    | To filter assemblies and cast units based on their numbering series information. For example, "Assembly series equals C/1." |

**Category: Load**

Use the **Load** category to filter loads based on their common properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load group</td>
<td>To filter loads based on which load group they belong to. For example, &quot;Load group does not equal DefaultGroup.&quot;</td>
</tr>
<tr>
<td>Load type</td>
<td>To filter loads based on their type. The options are <strong>line</strong>, <strong>point</strong>, <strong>area</strong>, <strong>uniform</strong>, and <strong>temperature</strong>. Note that wind loads are handled as area loads in filtering. Use the <strong>Select components</strong> and <strong>Select objects as components</strong> selection switches to select wind loads.</td>
</tr>
<tr>
<td>Phase</td>
<td>To filter loads based on their phase number. For example, &quot;Load phase does not equal 1.&quot;</td>
</tr>
</tbody>
</table>
**Category: Template**

Use the **Template** category to filter parts and other objects by using template attributes.

With this category, you can type the name of any template attribute or user-defined attribute directly in the **Property** box, even if it is not on the list. Use the **ASSEMBLY.** or **CAST_UNIT.** prefix in front of the property name to access assembly-level attributes, and the **USERDEFINED.** prefix to access user-defined attributes.

For example, to access the cast-unit level user-defined attribute **User field 1,** type **CAST_UNIT.USERDEFINED.USER_FIELD_1** in the **Property** box.

**Category: Reference assembly**

Use the **Reference assembly** category to filter reference model assemblies based on their common properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id number</td>
<td>To filter reference model assemblies based on their ID numbers. For example, &quot;Reference assembly ID number greater than 55.&quot; Use this property only in temporary filters, because the ID number may change when you reopen the model. Use the GUID property available in the <strong>Object</strong> category for more permanent filters.</td>
</tr>
<tr>
<td>Phase</td>
<td>To filter reference model assemblies based on their phase number. For example, &quot;Reference assembly phase equals 2.&quot;</td>
</tr>
<tr>
<td>Lot</td>
<td>To filter reference model assemblies based on their lot number. For example, &quot;Reference assembly lot greater than 1.&quot;</td>
</tr>
<tr>
<td>Description</td>
<td>To filter reference model assemblies based on their description, which is a user-definable value in the reference model properties. For example, &quot;Reference assembly description contains &quot;architect model&quot;.&quot;</td>
</tr>
<tr>
<td>Info text</td>
<td>To filter reference model assemblies based on their info text, which is a user-definable value in the <strong>Reference object</strong> dialog box. For example,</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Locked</td>
<td>To filter reference model assemblies based on whether or not they are locked. 0 = No, 1 = Yes, 2 = Organization.</td>
</tr>
<tr>
<td>Logical name</td>
<td>To filter reference model assemblies based on their logical name, which is a user-definable value in the Reference object dialog box. For example, &quot;Reference assembly logical name equals &quot;MEP heating system&quot;.&quot;</td>
</tr>
</tbody>
</table>

**Category: Reference object**

Use the **Reference object** category to filter reference model objects based on their common properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
</table>
| Id number  | To filter reference model objects based on their ID numbers. For example, "Reference object ID number greater than 12."
Use this property only in temporary filters, because the ID number may change when you reopen the model. Use the GUID property available in the **Object** category for more permanent filters. |
<p>| Phase      | To filter reference model objects based on their phase number. For example, &quot;Reference object phase does not equal 1.&quot;                          |
| Lot        | To filter reference model objects based on their lot number. For example, &quot;Reference object lot equals 1.&quot;                                     |
| Description| To filter reference model objects based on their description, which is a user-definable value in the Reference object dialog box. For example, &quot;Reference object description contains &quot;architect model&quot;.&quot; |</p>
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Info text</td>
<td>To filter reference model objects based on their info text, which is a user-definable value in the <strong>Reference object</strong> dialog box. For example, &quot;Reference object info text contains revised.&quot;</td>
</tr>
<tr>
<td>Locked</td>
<td>To filter reference model objects based on whether or not they are locked. <strong>0</strong> = No, <strong>1</strong> = Yes, <strong>2</strong> = Organization.</td>
</tr>
<tr>
<td>Logical name</td>
<td>To filter reference model objects based on their logical name, which is a user-definable value in the <strong>Reference object</strong> dialog box. For example, &quot;Reference object logical name contains &quot;3rd floor&quot;.&quot;</td>
</tr>
</tbody>
</table>

**TIP** You can filter reference model object attributes using the **Template** category and the **EXTERNAL** prefix in the **Property** box. For example, "Reference object **EXTERNAL.Material equals A572**."  

**Category: Location breakdown structure**

Use the **Location breakdown structure** category to filter objects based on their location categories, which can be defined in **Organizer**.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site</td>
<td>To filter objects based on which site category they belong to. For example, &quot;Location breakdown structure site equals &quot;Site 2&quot;.&quot;</td>
</tr>
<tr>
<td>Building</td>
<td>To filter objects based on which building category they belong to. For example, &quot;Location breakdown structure building does not equal &quot;Building A&quot;.&quot;</td>
</tr>
<tr>
<td>Section</td>
<td>To filter objects based on which section category they belong to. For example, &quot;Location breakdown structure section equals Ramp.&quot;</td>
</tr>
<tr>
<td>Floor</td>
<td>To filter objects based on which floor they are located on. For example, &quot;Location breakdown structure floor equals &quot;Floor 4&quot;.&quot;</td>
</tr>
</tbody>
</table>
Category: Task

Use the Task category to filter scheduled tasks based on their common properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>To filter scheduled tasks based on their name. For example, &quot;Task name contains floors.&quot;</td>
</tr>
<tr>
<td>Planned start date</td>
<td>To filter scheduled tasks based on their planned start date. For example, &quot;Task planned start date earlier than Review date.&quot;</td>
</tr>
<tr>
<td>Planned end date</td>
<td>To filter scheduled tasks based on their planned start date. For example, &quot;Task planned end date later than or equal to 10/13/2017.&quot;</td>
</tr>
<tr>
<td>Actual start date</td>
<td>To filter scheduled tasks based on their actual start date.</td>
</tr>
<tr>
<td>Actual end date</td>
<td>To filter scheduled tasks based on their actual end date.</td>
</tr>
<tr>
<td>Completeness</td>
<td>To filter scheduled tasks based on their completeness. The value is a percentage. For example, &quot;Task completeness is 75.&quot;</td>
</tr>
<tr>
<td>Critical</td>
<td>To filter scheduled tasks based on how critical they are. A task can be critical only if it has been imported from external software. 1 = Critical, 0 = Not critical. Note that this property is not visible in Task Manager.</td>
</tr>
<tr>
<td>Local</td>
<td>To filter scheduled tasks based on whether they were created in Task Manager or imported from external software. 1 = Created in Task Manager, 0 = Imported.</td>
</tr>
<tr>
<td>Contractor</td>
<td>To filter scheduled tasks based on the contractor. For example, &quot;Task contractor equals &quot;Contractor A&quot;.&quot;</td>
</tr>
<tr>
<td>Scenario</td>
<td>To filter scheduled tasks based on the scenario they belong to. For example, &quot;Task scenario equals &quot;Scenario 1&quot;.&quot;</td>
</tr>
</tbody>
</table>
### Property | Description
--- | ---
**Task Type** | To filter scheduled tasks based on their type. For example, "Task type does not equal "A - Floor tiling"."

### Category: Object

Use the **Object** category to filter objects based on their object level properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Guid</strong></td>
<td>To filter objects based on their globally unique identifier (GUID). For example, &quot;Object GUID begins with ID7554C9EB-C8B4.&quot;</td>
</tr>
<tr>
<td><strong>Phase</strong></td>
<td>To filter objects based on their phase number. For example, &quot;Object phase does not equal 3.&quot;</td>
</tr>
<tr>
<td><strong>Id number</strong></td>
<td>To filter objects based on their identification number. For example, &quot;Object ID number equals 413822.&quot; Use this property only in temporary filters, because the ID number may change when you reopen the model. Use the GUID property for more permanent filters.</td>
</tr>
</tbody>
</table>
| **Object type** | To filter objects based on their type. Select an object type from the Value list, or use the Select from model option. We recommend that you include one filter rule for the Object type property in each filter you create. The filtering outcome will be different if you leave the object type out. The following object types can be selected from the list:  
  - Assembly  
  - Bolt group  
  - Connection  
  - Part  
  - Pour break  
  - Pour object |
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Reference object</td>
<td></td>
</tr>
<tr>
<td>• Reinforcing bar</td>
<td></td>
</tr>
<tr>
<td>• Surface</td>
<td></td>
</tr>
<tr>
<td>• Surface treatment</td>
<td></td>
</tr>
<tr>
<td>• Weld</td>
<td></td>
</tr>
<tr>
<td>The following object types are shown as numeric values only:</td>
<td></td>
</tr>
<tr>
<td>• 1 = point</td>
<td></td>
</tr>
<tr>
<td>• 9 = fitting</td>
<td></td>
</tr>
<tr>
<td>• 11 = polygon cut</td>
<td></td>
</tr>
<tr>
<td>• 12 = line cut</td>
<td></td>
</tr>
<tr>
<td>• 24 = construction line</td>
<td></td>
</tr>
<tr>
<td>• 30 = construction plane</td>
<td></td>
</tr>
<tr>
<td>• 38 = added material</td>
<td></td>
</tr>
<tr>
<td>• 42 = construction circle</td>
<td></td>
</tr>
<tr>
<td>• 48 = reference model</td>
<td></td>
</tr>
<tr>
<td>• 70 = edge chamfer</td>
<td></td>
</tr>
<tr>
<td>• 76 = analysis part</td>
<td></td>
</tr>
</tbody>
</table>

**Is component**

- To filter objects based on whether or not they are components. The options are **Yes** and **No**. For example, "Object is component equals Yes."

### 9.5 Template attributes in filtering

Use the following units when filtering template attributes, even when using the US Imperial environment:

- **mm** for length
- **mm2** for area
- **kg** for weight
- **degree** for angle

**TIP** To check which unit Tekla Structures uses for a particular template attribute, use the **Select from model** option in the **Value** list in the filtering dialog box.
9.6 Wildcards

A wildcard is a symbol that stands for one or more characters. You can use wildcards to shorten strings, for example in filtering.

<table>
<thead>
<tr>
<th>Wildcard</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>* (asterisk)</td>
<td>Matches any number of characters</td>
<td>HE* matches all parts with a profile name that begins with the characters &quot;HE&quot;. You can also this symbol at the beginning of a word: <em>BRAC</em>.</td>
</tr>
<tr>
<td>? (question mark)</td>
<td>Matches a single character</td>
<td>HE?400 matches parts with profile names such as HEA400, HEB400, and HEC400.</td>
</tr>
<tr>
<td>[ ] (square brackets)</td>
<td>Matches whatever is enclosed in the brackets</td>
<td>L[78]X4X1/2 matches parts with the profile names L7X4X1/2 and L8X4X1/2.</td>
</tr>
</tbody>
</table>

**NOTE** The characters * and ? may also be used in object names in Tekla Structures. If the object name you want to filter contains * or ?, you need to enclose these characters in square brackets. For example, to find the profile P100*10, enter P100[*]10 in the filter field.

See also

Filter objects (page 137)

9.7 Examples of filters

Here are some examples of filters that you can create. The same filtering techniques can be used for view, selection, and drawing filters.

**Filter parts based on their name**

Create a filter that only shows parts with a certain name.

1. Create a new view filter. (page 140)
2. Click Add row three times to add three filter rules.
3. In the first filter rule, define that the object type must be part:
   a. In the Category list, select Object.
b. In the **Property** list, select **Object type**.
c. In the **Condition** list, select **Equals**.
d. In the **Value** list, select **Part**.
e. In the **And/Or** list, select **And**.

4. In the second and third filter rules, define that the part name must be BEAM or COLUMN:
   a. In the **Category** list, select **Part**.
   b. In the **Property** list, select **Name**.
   c. In the **Condition** list, select **Equals**.
   d. In the **Value** box, enter the part names, BEAM and COLUMN.
   e. In the **And/Or** list, select **Or**.

5. Include the second and third filter rule in brackets. The filter is now looking for parts that are named either BEAM or COLUMN.

6. Enter a unique name in the box next to the **Save as** button.

7. Click **Save as**.

<table>
<thead>
<tr>
<th>Category</th>
<th>Property</th>
<th>Condition</th>
<th>Value</th>
<th>And/Or</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object</td>
<td>Object type</td>
<td>Equals</td>
<td>Part</td>
<td>And</td>
</tr>
<tr>
<td>Part</td>
<td>Name</td>
<td>Equals</td>
<td>COLUMN</td>
<td>Or</td>
</tr>
<tr>
<td>Part</td>
<td>Name</td>
<td>Equals</td>
<td>BEAM</td>
<td></td>
</tr>
</tbody>
</table>

**Filter main parts**
Create a filter that selects the main parts only.

1. **Create a new selection filter.** (page 140)
2. Click **Add row** twice to add two filter rules.
3. In the first filter rule, define that the object type must be part:
   a. In the **Category** list, select **Object**.
   b. In the **Property** list, select **Object type**.
   c. In the **Condition** list, select **Equals**.
   d. In the **Value** list, select **Part**.
   e. In the **And/Or** list, select **And**.
4. In the second filter rule, define that you only want to include main parts:
   a. In the **Category** list, select **Part**.
   b. In the **Property** list, select **Primary part**.
c. In the **Condition** list, select **Equals**.
d. In the **Value** box, enter 1.
   
   In this context, 1 means the main parts, and 0 would mean the secondary parts.

5. Enter a unique name in the box next to the **Save as** button.

6. Click **Save as**.

<table>
<thead>
<tr>
<th></th>
<th>(</th>
<th>Category</th>
<th>Property</th>
<th>Condition</th>
<th>Value</th>
<th></th>
<th>And/Or</th>
</tr>
</thead>
<tbody>
<tr>
<td>![checkmark]</td>
<td>-</td>
<td>Object</td>
<td>Object type</td>
<td>Equals</td>
<td>Part</td>
<td>-</td>
<td>And</td>
</tr>
<tr>
<td>![checkmark]</td>
<td>-</td>
<td>Part</td>
<td>Primary part</td>
<td>Equals</td>
<td>1</td>
<td>-</td>
<td>And</td>
</tr>
</tbody>
</table>

**Filter bolts based on their size**
Create a filter that only shows bolts of certain sizes.

1. **Create a new view filter. (page 140)**
2. Click **Add row** twice to add two filter rules.
3. In the first filter rule, define that the object type must be bolt:
   a. In the **Category** list, select **Object**.
   b. In the **Property** list, select **Object type**.
   c. In the **Condition** list, select **Equals**.
   d. In the **Value** list, select **Bolt group**.
   e. In the **And/Or** list, select **And**.
4. In the second filter rule, define that the bolt size must be 12.00 or 16.00:
   a. In the **Category** list, select **Bolt**.
   b. In the **Property** list, select **Size**.
   c. In the **Condition** list, select **Equals**.
   d. In the **Value** box, enter the bolt sizes, 12.00 and 16.00.
      Separate the strings with a blank space.
5. Enter a unique name in the box next to the **Save as** button.
6. Click **Save as**.
Filter parts based on their assembly type
Create a filter based on assembly types. For example, you can create a filter that only shows cast-in-place and precast columns. Steel columns and any other columns or parts are hidden. The same filtering technique can be used for steel, concrete, timber, and miscellaneous parts.

1. Create a new filter. (page 140)
2. Click Add row four times to add four filter rules.
3. In the first filter rule, define that the object type must be part:
   a. In the Category list, select Object.
   b. In the Property list, select Object type.
   c. In the Condition list, select Equals.
   d. In the Value list, select Part.
   e. In the And/Or list, select And.
4. In the second filter rule, define that the part name must be COLUMN:
   a. In the Category list, select Part.
   b. In the Property list, select Name.
   c. In the Condition list, select Equals.
   d. In the Value box, enter the part name, COLUMN.
   e. In the And/Or list, select And.
5. Include the first and second filter rule in brackets.
6. In the third and fourth filter rules, define that the assembly type must be precast or cast in place:
   a. In the Category list, select Assembly.
   b. In the Property list, select Assembly type.
   c. In the Value box, enter the assembly types, 0 and 1.

<table>
<thead>
<tr>
<th>Value</th>
<th>Assembly type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>precast</td>
</tr>
<tr>
<td>1</td>
<td>cast in place</td>
</tr>
<tr>
<td>2</td>
<td>steel</td>
</tr>
</tbody>
</table>

Examples of filters
<table>
<thead>
<tr>
<th>Value</th>
<th>Assembly type</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>timber</td>
</tr>
<tr>
<td>6</td>
<td>miscellaneous</td>
</tr>
</tbody>
</table>

d. In the **And/Or** list, select **Or**.

7. Include the third and fourth filter rule in brackets. The filter is now looking for concrete parts that are named COLUMN.

8. Enter a unique name in the box next to the **Save as** button.

9. Click **Save as**.

Filter sub-assemblies
Create a filter that only selects parts that belong to a sub-assembly.

1. **Create a selection filter.** 

2. Click **Add row** to add a new filter rule.

3. In the **Category** list, select **Template**.

4. In the **Property** list, select **ASSEMBLY.HIERARCHY_LEVEL**.

5. In the **Condition** list, select **Does not equal**.

6. In the **Value** box, enter **0**.

   In this context, **0** means that the part does not belong to any sub-assembly, and **1** would mean that the part does. The filter will show only those parts whose value is **not** **0**.

7. Enter a unique name in the box next to the **Save as** button.

8. Click **Save as**.

Filter reference model objects
Create a filter based on reference model object properties.
1. Create an empty view or selection filter. (page 140)
2. Click Add row to add a new filter rule.
3. In the Category list, select Template.
4. In the Property list, select the desired template attribute or enter one of your own (page 147).

TIP To find the attribute name used by the reference model, select a reference model object, right-click and select one of the Inquire commands. Find the property name in the Inquire Object dialog box and copy it.

5. Add the prefix EXTERNAL in front of the template attribute name.
6. In the Condition list, select Equals.
7. In the Value box, enter the desired value or click Select from model to select the object in the model.
8. Enter a unique name in the box next to the Save as button.
9. Click Save as.

Filter parts within component
Create a filter that selects all parts within a component.

1. Create an empty selection filter. (page 140)
2. Click Add row twice to add two filter rules.
3. In the first filter rule, define that the object must be a component:
   a. In the Category list, select Object.
   b. In the Property list, select Is component.
   c. In the Condition list, select Equals.
   d. In the Value list, select Yes.
4. In the And/Or list, select And.
5. In the second filter rule, define that the object type must be part:
   a. In the Category list, select Object.
   b. In the Property list, select Object type.
   c. In the Condition list, select Equals.
   d. In the Value list, select Part.
6. Enter a unique name in the box next to the Save as button.
7. Click Save as.

9.8 Copy and remove filters
You can copy custom filters to another model by manually copying filter files to the attributes folder under the desired model folder. You can also manually remove unneeded filters from the same folder. If you want to make a filter available in all models, copy the file to your company's project or firm folder.

Copy a filter to another model
1. Select the filter you want to copy.

The filters you have created are located in the attributes folder under the current model folder. You can recognize different filter types based on their file name extension:

<table>
<thead>
<tr>
<th>File name extension</th>
<th>Filter type</th>
</tr>
</thead>
<tbody>
<tr>
<td>.VObjGrp</td>
<td>Model view filter</td>
</tr>
<tr>
<td>.SObjGrp</td>
<td>Model selection filter</td>
</tr>
<tr>
<td>.PObjGrp</td>
<td>Object group filter</td>
</tr>
<tr>
<td>.vf</td>
<td>Drawing view filter</td>
</tr>
<tr>
<td>.vnf</td>
<td>Drawing view level neighbor part filter</td>
</tr>
<tr>
<td>.wdf</td>
<td>Single-part drawing filter</td>
</tr>
<tr>
<td>.wdnf</td>
<td>Single-part drawing neighbor part filter</td>
</tr>
<tr>
<td>.adf</td>
<td>Assembly drawing filter</td>
</tr>
<tr>
<td>.adnf</td>
<td>Assembly drawing neighbor part filter</td>
</tr>
<tr>
<td>.cuf</td>
<td>Cast unit drawing filter</td>
</tr>
<tr>
<td>.cunf</td>
<td>Cast unit drawing neighbor part filter</td>
</tr>
<tr>
<td>.gdf</td>
<td>General arrangement drawing filter</td>
</tr>
<tr>
<td>.gdnf</td>
<td>General arrangement drawing neighbor part filter</td>
</tr>
<tr>
<td>.dsf</td>
<td>Drawing selection filter</td>
</tr>
</tbody>
</table>
2. To make the filter available in another model, copy the file to the attributes folder of the destination model folder.

3. To make the filter available in all models, copy the file to your company's project or firm folder.

4. Restart Tekla Structures.

Remove a filter

1. Remove the filter file from the model's attributes folder.

2. Restart Tekla Structures.
A screenshot is an image of a model or drawing view. You can use screenshots in posters, brochures, or other material to show projects carried out using Tekla Structures.

By default, the screenshots are saved in the \screenshots folder under the current model folder with the name snap_xx.png.

10.1 Take a screenshot of a model
You can take screenshots of model views.

1. Open a model and adjust the model view according to your needs.
   For example, hide the work area box (page 66) if you do not want to show it.

2. On the View tab, click \( \text{Screenshot} \)\( \rightarrow \text{Screenshot} \).

3. If you have multiple views of the model, click Pick view and select the view to take the screenshot from.

4. To modify the settings, click Options.
   a. Define the width, height, and DPI of the screenshot.
   b. Click OK to save the changes.

5. Define a name and location for the screenshot.
   a. Select Print to file and enter a descriptive name for the screenshot in the File name box.
      You can also change the whole path. If you do not want to do this, you can keep the default values for the path and the file name.

6. Click Show with associated viewer to show the screenshot in an application that is by default associated with this file type.

7. Click Capture.
10.2 Take a screenshot of a drawing

A drawing screenshot is an image of an open drawing with or without borders.

1. Open a drawing and adjust the drawing view according to your needs.
   
   For example, delete unnecessary marks or dimensions, and hide unnecessary parts.

2. On the Views tab, click \( \text{Screenshot} \rightarrow \text{Screenshot} \).

3. Do one of the following:

   • Select View to take a screenshot of the open drawing with window borders.
   
   • Select View without borders to take a screenshot of the open drawing without window borders.

4. Under the preselected Print to file option enter a descriptive name for the screenshot in the File name box.
   
   You can also change the whole path. If you do not want to do this, you can keep the default values for the path and the file name.

5. Click Show with associated viewer to show the screenshot in an application that is by default associated with this file type.

6. Click Capture.

10.3 Save a screenshot in bitmap format

By default, screenshots are created as Portable Network Graphics (.png) files. You can also save a screenshot in bitmap (.bmp) format to use it, for example, as a custom component thumbnail.

1. On the Views tab, click \( \text{Screenshot} \rightarrow \text{Screenshot} \).

2. Select Place on clipboard.

3. Click Capture.

4. Paste the screenshot in your graphics editor and save it in .bmp format.

**NOTE** The software that you use to open the screenshot may have a limit for the number of pixels.
11 Customize Tekla Structures

Use customizations to personalize Tekla Structures. For example, you can define which commands are available on the ribbon. You can also define your own keyboard shortcuts for commands.

- Customize the ribbon (page 172)
- Customize keyboard shortcuts (page 184)

11.1 Customize the ribbon

You can customize the ribbon according to your needs. You can change the size and shape of any command button, for example. You can add custom buttons and assign commands to them. You can also bring your favorite components and extensions to the ribbon for an easy access.

To open the customization tool, click **File menu --> Settings --> Customize --> Ribbon**.

The tool includes two editing modes:

- **Simple mode:** Add, move, and resize command buttons; add, hide, and edit tabs; remove command buttons and tabs from the ribbon.

- **Design mode:** Choose which name and icon is used for each command button; add new buttons and assign commands to them; add vertical and horizontal separator bars.
Add a command button
You can add command buttons simply by dragging commands to the ribbon or to the Quick Access Toolbar.

1. Ensure that Simple mode is switched on.
2. In the Select ribbon list, select which ribbon you want to customize.
   For example:

```
Select ribbon:
Full Modeling
```

You can only customize ribbons that are available in your configuration.

3. Search for the command you want to add.
   You can also add components, macros, and extensions. Browse through the lists or use the Search box to filter content. For example, type mesh to
find the **Create reinforcing mesh** command and other mesh related components:

![Drag and drop commands to the ribbon](image)

• **User-defined**: commands that you have created on the **User-defined commands** tab

• **Tekla Structures**: all the Tekla Structures commands available in this configuration and mode

• **Applications & components**: components, macros, plugins, and extensions

4. Drag and drop the command to the ribbon.
   The blue color indicates the place where the command button will be inserted. For example:

![Rebar](image)

**NOTE** If you hover over a down arrow, a list will open and you can drag commands to the list. The list will remain open until you click the down arrow again.

You can also drag commands to the Quick Access Toolbar, which is located above the ribbon, or to the fixed container on the left side of the ribbon:
5. To remove a command button, select it and press **Delete**.

**Move a command button**
You can rearrange command buttons on the ribbon. Note that you cannot move drop-down buttons underneath each other.

1. Select the command button you want to move.
   The command button becomes highlighted:

2. Drag and drop the command button to a new location.
   The blue color indicates the place where the command button will be inserted. For example:

**Resize a command button**
You can change the size of existing command buttons.

1. Select the command button you want to resize:
2. Move the mouse pointer over any side or corner of the command button to display a white arrow symbol:

3. Drag with the arrow to define a new size:

   The size of the command button changes accordingly. The other command buttons are automatically moved forward on the ribbon, if needed.

4. Double-click the command button to expand it.

   The command button now fully occupies the empty space around it:

---

**Change the appearance of a command button**

You can change the appearance of any command button in the [Design mode](#).

1. Ensure that **Design mode** is switched on.
2. Select the command button you want to modify.
The current properties of the command button are displayed.

3. To change the name, select one of the options:
   - **None**: no name is used for the command button
   - **Short name**: the default short version of the name is used
   - **Full name**: the default full version of the name is used
   - **Custom**: enter a custom name for the command button

4. To change the icon, select one of the options:
   a. **None**: no icon is used for the command button
   b. **Large icon**: the default large icon (32x32) is used
   c. **Small icon**: the default small icon (16x16) is used
   d. **Gallery**: select an icon from the Tekla Structures icon gallery
   e. **Custom**: define a custom icon by selecting a suitable image file. The recommended size is 32x32 pixels for large buttons and 16x16 pixels for small buttons. If you have problems with your custom image not appearing the right size, check the DPI setting of the image file. A DPI of 96 is recommended.

   **TIP** When you modify a command button which is on a drop-down list, the options may become hidden behind the drop-down list. Slide the ribbon right or left to make the options visible.

---

**Create a user-defined command**

You can create user-defined commands and link them to any file or URL.

1. Go to the **User-defined commands** tab.
2. Click **Add**.
3. Enter a unique ID for the command, and then click **Create**.
For example, let's assume you are creating a link to the Tekla Discussion Forum. Enter OpenTeklaDiscussionForum as the ID of the command. A new page with more properties appears.

4. Click **Action** and define a file or URL. For example, enter https://forum.tekla.com.

5. Click **Name** and enter a name for the command. This name will be visible in the Tekla Structures user interface. You can define two alternative names: a full name and a short version. For example, enter Tekla Discussion Forum as the full name of the command, and Forum as the short version.

6. Click **Icon** and select a suitable icon from the Tekla Structures icon gallery. You can define two alternative icons: a large one and a small one.

7. Click **Tooltip** and enter a tooltip for the command. For example, enter Go to the Tekla discussion forum.

8. Click **Apply** to save the new command.

9. Go to the **Edit ribbons** tab.

The command you created is available in the User-defined list, on the left-hand side of the dialog box:

10. Drag and drop the command to the ribbon:
11. To modify a user-defined command, switch to the Design mode and edit the command properties just like for any other command.

**Add a custom button and assign a command to it**

You can add new buttons, split buttons, toggle buttons, and drop-down buttons to the ribbon. These are all empty placeholders for commands. After creating a new button, you can assign a command to it.

1. Ensure that Design mode is switched on.
2. On the Edit ribbons tab, click the desired button type to select it:

   • **Basic**: Add a button for a single command.
   
   • **Toggle**: Add a toggle button that switches a particular command on or off. Use this to add any switch from the File menu --> Settings --> Switches to the ribbon, for example.
   
   • **Drop-down**: Add a drop-down button with a group of commands underneath it. You can define a name and a custom tooltip for the button.
   
   • **Split**: Add a button for a single command, plus a drop-down button with a group of commands underneath it.

3. Using the mouse, draw a rectangular area for the new button.

4. To assign a command to the button:
   a. Ensure that the new button is selected.
b. On the **Command** tab, search for the command you want to add. Browse through the lists or use the **Search** box to filter content. For example:

![Search for command](image1)

For example:

- \( \text{Component 3D cut (10)} \)
- \( \text{Component Angle cut (1057)} \)
- \( \text{Component Stringer cut (1023)} \)
- \( \text{Keyboard shortcuts} \)

![Assign command to button](image2)

c. Click **Assign this command**. The command is now assigned to the button.

d. On the **Appearance** tab, modify the command's name and icon, if needed.

5. To add commands to a drop-down button:
   a. Return to the **Simple mode**.
   b. Search for commands.
   c. Drag and drop commands to the drop-down button.

   If you hover over a down arrow, a list will open and you can drag commands to the list. The list will remain open until you click the down arrow again.

![Drop-down button](image3)
Add a separator bar
You can add vertical and horizontal separator bars to divide command buttons into smaller groups on the ribbon.
1. Ensure that **Design mode** is switched on.
2. Click **Separator** to select it.
3. Using the mouse, draw a rectangular area in the vertical direction.

A vertical bar appears in the location you defined.
4. Ensure that the bar is selected.
5. Modify the orientation and line thickness of the bar, if needed.

Add, hide, and edit tabs
You can add, move and rename ribbon tabs, choose how they are aligned, and hide some tabs if you do not need them in your current project. For example, if you are only modeling steel parts, you can temporarily hide the **Concrete** tab.
1. Ensure that **Simple mode** is switched on.
2. To add a new tab, click the plus sign at the end of the tab row.
3. To rename a tab:
   a. Right-click a tab title and select **Rename**.
   b. Type a new name.
   c. Press **Enter** to save the new name.
4. To change the order of tabs on the ribbon, drag and drop the tab titles.
5. To change how the tabs are aligned, click and then select one of the options:
   - **Scroll visible**: the ribbon movement is minimal when you switch between the tabs
• **Align to left**: the icons start from the left side of the ribbon
• **Align to tab**: the icons start from the left side of the current tab

6. To hide the tabs that you do not need in your current project:
   a. Rest the mouse pointer on a tab title.
      A small eye symbol appears next to the tab title:
      ![View](image)
   b. Click the eye symbol.
      The eye symbol changes and the tab title becomes gray:
      ![View](image)
      The View tab is now hidden from the ribbon. If you slide the ribbon, hidden tabs appear as:
      ![View](image)
   c. To re-display the hidden tab, click the eye symbol again.

7. To remove a tab, select it and press **Delete**.

**Save the ribbon**
When you are happy with the changes, save the customized ribbon.

1. On the **Edit ribbons** tab, click the **Save** button.
   ![Edit ribbons](image)

2. When you return to Tekla Structures and the program asks if you wish to load the new ribbon, click **Yes**. The ribbon becomes updated with the changes you made.

**Check the changes**
You can compare the original ribbon with the changes you have made. You can check what has been added and removed, and what has been moved to different tabs.

1. Save the customized ribbon, if you have not already done so.
2. Click **Compare**.

3. In the **Compare ribbons** dialog box, check the changes you have made. For example:

   - **First list:** these commands have been removed
   - **Second list:** these commands have been moved to a new place
   - **Third list:** these commands have been added

   **NOTE** **Original ribbon** refers to the ribbon file that came with the Tekla Structures installation for your current configuration.

4. If you have removed a command that you would like to get back, drag it from the **Compare ribbons** dialog box to the ribbon.

5. When you are finished, click **Close**.

### Back up and restore ribbons

You can restore the default Tekla Structures ribbons at any time. Before restoring the default settings, make sure to save a backup copy of your customized ribbon, because the customizations will be permanently deleted. You can use the backup file to take your customized ribbon back into use, to copy the ribbon settings to another computer, or to share the customized ribbon with your co-workers.

1. To save a backup copy of the customized ribbon:
   a. On the **Edit ribbons** tab, click the **Save** button 📋.
b. Go to the ..\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\UI\Ribbons folder.

c. Make a copy of the desired ribbon file and save it in another folder. The ribbons are named according to the Tekla Structures configurations. For example, in the Full configuration, the name of the Modeling ribbon file is albl_up_Full--main_menu.xml.

2. To restore the default Tekla Structures ribbons:
   a. In the Select ribbon list, select which ribbon you want to restore. For example:

   ![Select ribbon list]

   b. Click Reset to defaults. The default Tekla Structures ribbons are now in use.

3. To take the customized ribbon back into use:
   a. Copy the backup file back to the ..\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\UI\Ribbons folder.
   b. When you return to Tekla Structures and the program asks if you wish to load the new ribbon, click Yes. The ribbon becomes updated with the changes you made.

11.2 Customize keyboard shortcuts

In the Keyboard shortcuts dialog box, you can view a list of all shortcuts available in Tekla Structures. You can define new keyboard shortcuts and remove existing ones. After customization, you can export the keyboard shortcuts and share them with your co-workers.

Define new keyboard shortcuts

You can assign keyboard shortcuts to any command, macro, or component. You can even change the default keyboard shortcuts, if needed.

1. On the File menu, click Settings --> Keyboard shortcuts.
2. In the **Group** list, select the shortcut group you want to modify. A list of commands and shortcuts appears.

3. If you want to search for a particular command or keyboard shortcut, enter some text in the **Filter** box.

   For example:
   - Type **grid** to only see the commands whose name contains the word "grid".
   - Type "+" to get a list of shortcuts that consist of two parts (such as **Ctrl +S**).
• Type ", " to get a list of shortcuts that consist of two consecutive keys (such as M, N).

4. Select a command from the list.
5. Click Enter shortcut.
6. On the keyboard, enter the combination of keys you would like to use as the shortcut.
7. Check the Conflicts box to see if the keyboard shortcut is already assigned to another command.
   If the shortcut is already in use, enter a different combination of keys.

   **NOTE** If you reassign a keyboard shortcut that is already used, it will no longer be associated with the command it was originally assigned to.

8. Click Assign to save the keyboard shortcut.

### Clear and reset shortcuts
You can remove any existing shortcut. You can also reset all shortcuts back to the defaults.

1. On the **File** menu, click **Settings --> Keyboard shortcuts**.
2. To remove a keyboard shortcut, select the command from the list and click **Clear**.
3. To reset all the keyboard shortcuts to the defaults, click the **Restore** button.

### Export keyboard shortcuts
You can export your customized keyboard shortcuts and share them with your co-workers.

1. On the **File** menu, click **Settings --> Keyboard shortcuts**.
2. Click **Export**.
3. Enter a file name and location.
4. Click **Save** to export the keyboard shortcuts.
5. To share your keyboard shortcuts with other users, send them the exported file.
**Import keyboard shortcuts**
You can import keyboard shortcuts from a file. Use this method to import keyboard shortcuts from Tekla Structures 2016 or newer.

1. On the **File** menu, click **Settings --> Keyboard shortcuts**.
2. Click **Import**.
3. Browse for the shortcuts file you want to import. For example, `\Users <user>\AppData\Local\Trimble\TeklaStructures 2016\Settings\KeyboardShortcuts_4.xml`.
4. Click **Open** to import the keyboard shortcuts.
Tekla Structures contains a large number of keyboard shortcuts that you can use to speed up your work.

If you want to change the default shortcuts, see Customize keyboard shortcuts (page 184).

### 12.1 Common commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>F1</td>
</tr>
<tr>
<td>Help: when tooltip is open</td>
<td>CTRL + F1</td>
</tr>
<tr>
<td>Open model</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Create new model</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Save model</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Properties</td>
<td>Alt+Enter</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Interrupt</td>
<td>Esc</td>
</tr>
<tr>
<td>Repeat last command</td>
<td>Enter</td>
</tr>
<tr>
<td>Show/hide contextual toolbar</td>
<td>CTRL + K</td>
</tr>
<tr>
<td>Switch direct modification on/off</td>
<td>CTRL + D</td>
</tr>
<tr>
<td>Quick Launch</td>
<td>CTRL + Q</td>
</tr>
<tr>
<td>Advanced options</td>
<td>CTRL + E</td>
</tr>
<tr>
<td>Applications &amp; components catalog</td>
<td>CTRL + F</td>
</tr>
</tbody>
</table>
12.2 Rendering options

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parts wireframe</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>Parts rendered wireframe</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>Parts grayscale</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>Parts rendered</td>
<td>Ctrl+4</td>
</tr>
<tr>
<td>Show only selected part</td>
<td>Ctrl+5</td>
</tr>
<tr>
<td>Components wireframe</td>
<td>Shift+1</td>
</tr>
<tr>
<td>Components rendered wireframe</td>
<td>Shift+2</td>
</tr>
<tr>
<td>Components grayscale</td>
<td>Shift+3</td>
</tr>
<tr>
<td>Components rendered</td>
<td>Shift+4</td>
</tr>
<tr>
<td>Show only selected component</td>
<td>Shift+5</td>
</tr>
</tbody>
</table>

12.3 Selecting objects

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollover highlight on/off</td>
<td>H</td>
</tr>
<tr>
<td>Select all selection switch</td>
<td>F2</td>
</tr>
<tr>
<td>Select parts selection switch</td>
<td>F3</td>
</tr>
<tr>
<td>Select all</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select assembly</td>
<td>Alt+object</td>
</tr>
<tr>
<td>Add to selection</td>
<td>Shift</td>
</tr>
<tr>
<td>Toggle selection</td>
<td>Ctrl</td>
</tr>
<tr>
<td>Selection filters</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Hide object</td>
<td>Shift+H</td>
</tr>
</tbody>
</table>

12.4 Snapping

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snap to reference lines/points</td>
<td>F4</td>
</tr>
<tr>
<td>Snap to geometry lines/points</td>
<td>F5</td>
</tr>
<tr>
<td>Snap to nearest points</td>
<td>F6</td>
</tr>
<tr>
<td>Snap to any position</td>
<td>F7</td>
</tr>
<tr>
<td>Command</td>
<td>Keyboard shortcut</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Ortho</td>
<td>O</td>
</tr>
<tr>
<td>Relative coordinate input</td>
<td>R</td>
</tr>
<tr>
<td>Absolute coordinate input</td>
<td>A</td>
</tr>
<tr>
<td>Global coordinate input</td>
<td>G</td>
</tr>
<tr>
<td>Snap to next position</td>
<td>Tab</td>
</tr>
<tr>
<td>Snap to previous position</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Lock X, Y or Z coordinates</td>
<td>X, Y or Z</td>
</tr>
</tbody>
</table>

### 12.5 Copying and moving objects

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Move</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td>Drag and drop</td>
<td>D</td>
</tr>
<tr>
<td>Smart Select</td>
<td>S</td>
</tr>
</tbody>
</table>

### 12.6 Viewing the model

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the view list</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>3D/Plane view</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Switch between views</td>
<td>Ctrl+Tab</td>
</tr>
<tr>
<td>Updated window</td>
<td>Ctrl + U</td>
</tr>
<tr>
<td>Zoom original</td>
<td>Home</td>
</tr>
<tr>
<td>Zoom previous</td>
<td>End</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Page Up</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Page Down</td>
</tr>
<tr>
<td>Rotate using mouse</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Rotate using keyboard</td>
<td>Ctrl+arrow keys</td>
</tr>
<tr>
<td></td>
<td>Shift+arrow keys</td>
</tr>
<tr>
<td>Set view rotation point</td>
<td>V</td>
</tr>
<tr>
<td>Auto rotate</td>
<td>Shift+R</td>
</tr>
<tr>
<td></td>
<td>Shift+T</td>
</tr>
<tr>
<td>Pan</td>
<td>P</td>
</tr>
<tr>
<td>Command</td>
<td>Keyboard shortcut</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Middle button pan</td>
<td>Shift+M</td>
</tr>
<tr>
<td>Move right</td>
<td></td>
</tr>
<tr>
<td>Move left</td>
<td></td>
</tr>
<tr>
<td>Move down</td>
<td></td>
</tr>
<tr>
<td>Move up</td>
<td></td>
</tr>
<tr>
<td>Fly</td>
<td>Shift+F</td>
</tr>
<tr>
<td>Create clip plane</td>
<td>Shift+X</td>
</tr>
</tbody>
</table>

### 12.7 Checking the model

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inquire object</td>
<td>Shift+I</td>
</tr>
<tr>
<td>Measure distance</td>
<td>F</td>
</tr>
<tr>
<td>Create report</td>
<td>Ctrl+B</td>
</tr>
</tbody>
</table>

### 12.8 Drawings

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Drawing list in model</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Open Drawing list in drawing mode</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Print drawings</td>
<td>Shift+P</td>
</tr>
<tr>
<td>Open next drawing</td>
<td>Ctrl+Page Down</td>
</tr>
<tr>
<td>Open previous drawing</td>
<td>Ctrl+Page Up</td>
</tr>
<tr>
<td>Associativity symbol</td>
<td>Shift+A</td>
</tr>
<tr>
<td>Set next drawing color mode</td>
<td>B</td>
</tr>
<tr>
<td>Ghost outline</td>
<td>Shift+G</td>
</tr>
<tr>
<td>Add orthogonal dimension</td>
<td>G</td>
</tr>
<tr>
<td>Add free dimension</td>
<td>F</td>
</tr>
<tr>
<td>Open any drawing after creating the drawing</td>
<td>Ctrl+Shift</td>
</tr>
<tr>
<td>In Drawing list: Open user-defined attributes</td>
<td>Alt+U</td>
</tr>
<tr>
<td>In Drawing list: Add to Master Drawing Catalog</td>
<td>Ctrl+M</td>
</tr>
</tbody>
</table>

Default keyboard shortcuts 191 Checking the model
<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Drawing list: Revision handling</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>In Master Drawing Catalog: Select all</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>In Master Drawing Catalog:</td>
<td></td>
</tr>
<tr>
<td>Create drawings for all parts</td>
<td>Alt+A</td>
</tr>
<tr>
<td>In Master Drawing Catalog: Create</td>
<td></td>
</tr>
<tr>
<td>drawings</td>
<td>Alt+C</td>
</tr>
<tr>
<td>Set UCS origin</td>
<td>U</td>
</tr>
<tr>
<td>Set UCS by two points</td>
<td>Shift+U</td>
</tr>
<tr>
<td>Toggle orientation</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Reset current</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>Reset all</td>
<td>Ctrl+0</td>
</tr>
</tbody>
</table>
Tips for basic tasks

Here we provide useful hints and tips that help you use the Tekla Structures user interface and its basic features more efficiently.

• **Switch rollover highlight on or off (page 194)**
  By default, Tekla Structures highlights the objects in yellow, so that you can easily see which objects you can select. You can switch the highlighting on or off.

• **Select values from the model (page 194)**
  You can select object properties and dates directly from the model. This can be useful when creating view filters, selection filters, and object groups.

• **Interrupt object selection (page 195)**
  You can have Tekla Structures interrupt the object selection process if the selection takes over a defined period of time. For example, if you are working on a large model and you accidentally select all or part of the model, you can interrupt the selection if it takes over 5000 milliseconds (5 seconds) to complete.

• **Select on right-click (page 196)**
  You can change the settings so that you can select objects also with the right mouse button.

• **Copy and move efficiently (page 196)**
  You can keep the Move and Copy dialog boxes open if you are going to use them often, for example when creating grids and levels in a new model.

• **Change a property in several parts at the same time (page 196)**
  You can quickly change a property in multiple parts simultaneously.

• **Show or hide "Do not show this message again" (page 197)**
  Sometimes when Tekla Structures displays warning messages, you have the option to hide future warnings of the same type. You can have Tekla Structures show these warnings again.
Wildcards (page 162)
A wildcard is a symbol that stands for one or more characters. You can use wildcards to shorten strings, for example in filtering.

13.1 Switch rollover highlight on or off
By default, Tekla Structures highlights the objects in yellow, so that you can easily see which objects you can select. You can switch the highlighting on or off.

1. On the File menu, click Settings and select or clear the Rollover highlight check box. Alternatively, you can press H.

See also
Select objects (page 103)
13.2 Select values from the model

You can select object properties and dates directly from the model. This can be useful when creating view filters, selection filters, and object groups.

Before you start, create an empty view or selection filter, or an object group.

1. Create an empty view or selection filter (page 140), or an object group.
2. Click Add row.
3. Select options from the Category and Property lists.
4. In the Value list, select one of the options.

   a. To select an object property, click Select from model and then select an object.
   b. To select a date, click Select date to open the Select date dialog box, and then select one of the options.

   You can either select a date from the calendar, select the review date, or define the number of days before or after the review date. The review date is the same as Review date in the dialog box.

13.3 Interrupt object selection

You can have Tekla Structures interrupt the object selection process if the selection takes over a defined period of time. For example, if you are working on a large model and you accidentally select all or part of the model, you can interrupt the selection if it takes over 5000 milliseconds (5 seconds) to complete.

1. Define the time after which Tekla Structures asks if you want to interrupt object selection.
   a. On the File menu, click Settings --> Advanced options and go to the Modeling Properties category.
   b. Modify the advanced option XS_OBJECT_SELECTION_CONFIRMATION.
      The default value is 5000 milliseconds.
   c. Click OK.
2. Select (page 103) all or part of the model.
3. When Tekla Structures asks if you want to interrupt object selection, click Cancel.
13.4 Select on right-click
You can change the settings so that you can select objects also with the right mouse button.
1. On the File menu, click Settings and select the following check boxes:
   • Select on right click
   • Rollover highlight
2. Right-click an object to select it. Tekla Structures highlights the object and shows the related shortcut menu.

See also
Select objects (page 103)

13.5 Copy and move efficiently
You can keep the Move and Copy dialog boxes open if you are going to use them often, for example when creating grids and levels in a new model.
1. Run the Copy or Move command.
2. To stop copying or moving objects, right-click and select Interrupt from the pop-up menu.
   The dialog box remains open on the screen.
3. To continue copying or moving objects:
   a. Click the dialog box to activate it.
   b. Select an object.
   c. Enter the values you want to use, and then click the Move or Copy button in the dialog box.

See also
Copy objects (page 114)
Move objects (page 125)

13.6 Change a property in several parts at the same time
You can quickly change a property in multiple parts simultaneously.
1. Double-click a part to open the properties dialog box.
2. Click to clear all selections from the check boxes next to the properties.

3. Select the check box next to the property that you want to change, for example Class.

4. Change the value.
   Leave the dialog box open.

5. Select all parts whose value you want to change.

6. Click Modify in the part properties dialog box.

7. Click Cancel to close the dialog box.

See also
Create, modify, and delete objects (page 76)

13.7 How to restore missing toolbars
You can bring back the Selecting and Snapping toolbars, if you have accidentally removed them.
1. Go to (page 30).
2. Enter a search term:
   • Type selecting if you are looking for the Selecting toolbar.
   • Type snapping if you are looking for the Snapping toolbar.
3. Select the toolbar from the list that appears. The toolbar becomes visible.

13.8 Show or hide "Do not show this message again"
Sometimes when Tekla Structures displays warning messages, you have the option to hide future warnings of the same type. You can have Tekla Structures show these warnings again.

1. To hide future warnings of the same type, select the Do not show this message again check box.
2. To re-display the warnings, hold down the **Shift** key while running a command that should normally induce a warning message. For example, copy or move objects outside the work area. Tekla Structures displays the associated warning message.
14 Disclaimer

© 2017 Trimble Solutions Corporation and its licensors. All rights reserved.
This Software Manual has been developed for use with the referenced Software. Use of the Software, and use of this Software Manual are governed by a License Agreement. Among other provisions, the License Agreement sets certain warranties for the Software and this Manual, disclaims other warranties, limits recoverable damages, defines permitted uses of the Software, and determines whether you are an authorized user of the Software. All information set forth in this manual is provided with the warranty set forth in the License Agreement. Please refer to the License Agreement for important obligations and applicable limitations and restrictions on your rights. Trimble does not guarantee that the text is free of technical inaccuracies or typographical errors. Trimble reserves the right to make changes and additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by international treaties. Unauthorized reproduction, display, modification, or distribution of this Manual, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve, Fastrak and Orion are either registered trademarks or trademarks of Trimble Solutions Corporation in the European Union, the United States, and/or other countries. More about Trimble Solutions trademarks: http://www.tekla.com/tekla-trademarks. Trimble is a registered trademark or trademark of Trimble Inc. in the European Union, in the United States and/or other countries. More about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product and company names mentioned in this Manual are or may be trademarks of their respective owners. By referring to a third-party product or brand, Trimble does not intend to suggest an affiliation with or endorsement by such third party and disclaims any such affiliation or endorsement, except where otherwise expressly stated.

Portions of this software:
D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved.
Index

starting
Tekla Structures......................................... 9
switches
File menu switches..................................40

* character................................................... 162

3
3D models......................................................14
3D in snapping...............................................92
views......................................................... 65

? character................................................... 162

A
adding
command buttons.................................... 172
grid lines.................................................. 49
align to left............................................. 31
align to tab............................................. 31
aligning
objects................................................... 97
Array of objects (29).................................. 124
assemblies
nested assemblies................................... 110
selecting............................................... 109,110
assigning
commands........................................... 172
associativity symbol.............................. 40
asterisk.................................................. 162
Auto
in snapping............................................. 92
automatic rotation center............................... 40
autosave.................................................. 22

B
background color
changing.................................................. 72
examples.................................................. 72
backing up
models.................................................. 22
ribbons............................................... 172
basic view auto rotation............................. 40
basics.................................................... 25
basics of Tekla Structures
tips.................................................... 193
blank project.......................................... 11
brackets............................................... 162
buttons
common buttons..................................... 30

C
cast units
selecting.................................................. 109
categories
in filtering.................................. 147
centered zooms........................................ 40
colors
changing color settings........................... 72
changing the background color.................. 72
finding RGB values.................................. 72
commands
assigning............................................. 172
customizing........................................... 172
ending.................................................. 26
re-activating......................................... 26
searching.............................................. 30
user-defined.......................................... 172
using.................................................... 26
comparing
ribbons................................................... 172
components
  selecting............................................. 110
configurations........................................ 9,12
contextual toolbar....................................33
coordinate system..................................... 68
coordinates............................................... 47
copying
  filters.................................................. 168
  hints and tips....................................... 196
  models.................................................. 22
  objects.................................................. 113,114
properties............................................... 82
Radial array tool.................................... 122
with Array of objects (29) component 124
creating
  3D models............................................. 14
  grids..................................................... 47
  model templates.....................................19
  models..................................................... 16
  objects..................................................... 76
  screenshots............................................ 170
view filters
  selection filters..................................... 140
views....................................................... 54
crossing selection...................................... 40
customizing
  commands.............................................. 172
  keyboard shortcuts................................... 184
  ribbons.................................................. 172

deleing
  objects.................................................. 76
  views...................................................... 64
dialog boxes
  common buttons........................................ 30
  loading properties.................................... 83
  saving properties..................................... 83
searching................................................ 30
direct modification
  modifying............................................... 77
DirectX rendering.................................... 40
Do not show this message again.................... 197
drag & drop............................................... 40
drawing objects
  moving................................................... 125

rotating................................................... 131

E
environments............................................. 9,12
examples
  background colors.................................... 72
drawing filters......................................... 162
  snapping in model.................................... 98
  view and selection filters.......................... 162
exporting
  keyboard shortcuts................................... 184

F
File menu
  switches............................................... 40
filtering
  And/Or.................................................... 144
categories............................................... 147
  conditions............................................. 144
  copying filters...................................... 168
  object properties................................... 147
  objects..................................................... 137
parentheses............................................ 144
removing filters....................................... 168
template attributes.................................... 144,161
use for.................................................... 137
view filters
  selection filters..................................... 140
wildcards................................................ 162
filters
  examples............................................... 162
  selection............................................... 106
font color
  changing............................................... 72

G
getting started........................................ 25
ghost outline.......................................... 40
global coordinate system............................. 68
global point of origin.................................. 68
grid color............................................... 72
grid lines
  adding.................................................. 49
deleting.....................................................52
modifying..................................................50

grids
cordinates............................................47
creating...............................................47
deleting...............................................49
labels....................................................46,47
line extensions.......................................46
modifying...............................................48
origin......................................................46
grid
work plane grid........................................69

H
hiding
dimensions.............................................103
ribbon.....................................................33
ribbon tabs.............................................31
work area.............................................66
highlighting
objects..................................................194

I
if you cannot select objects.....................112
images
thumbnail image of model......................16
importing
keyboard shortcuts.............................184
interrupting..........................................26
object selection....................................195

K
keyboard shortcuts..............................184,188

L
languages
changing the language..........................39
large icons..........................................40
linear array tool....................................119
loading
saved properties..................................83
local coordinate system......................68

M
message history......................................32
middle button pan.................................40
minimizing the ribbon..........................31,33
missing toolbars....................................197
model templates
creating...............................................19
modifying...............................................19
options................................................19
model views..........................................52
models
about 3D models.................................14
backing up..........................................22
creating...............................................16
moving..................................................28
rotating...............................................28
saving..................................................22
thumbnail image....................................16
zooming...............................................28
modifying
model templates....................................19
objects..............................................76,77
properties in many parts simultaneously
.................................................196
moving
command buttons................................172
drawing objects....................................125
hints and tips.......................................196
models in a view.....................................28
objects..............................................77,113,114,125
multi-user vs single-user......................16

N
navigation mode...................................31
nested assemblies.................................110

O
object properties
in filtering............................................147
objects
copying..............................................113,114
creating..............................................76
deleting..............................................76
filtering..............................................137
modifying................................................. 76
moving..................................... 113,114,125
rotating...................................................131
selecting................................................. 103
opening
models...................................................... 15
origin...............................................................68
ortho............................................................... 40
overriding snap switches......................... 98

P
paintbrush icon............................................. 82
panning.......................................................... 28
parts
modifying part shape..............................77
modifying properties............................ 196
tips.......................................................... 196
plane views.................................................... 65
Plane
in snapping...........................................92
printer line widths.........................................40
profiles
profile names.............................................162
project setup
editing project properties.......................17
prompts..........................................................32
properties
copying..................................................... 82
project properties...........................................17

Q
question mark............................................. 162
Quick Launch................................................. 30

R
radial array tool...........................................122
redrawing views............................................. 65
refreshing views............................................. 65
removing
filters..........................................................168
reshaping
objects...................................................... 77
resizing
command buttons...........................................172
restoring
toolbars......................................................... 197
RGB values........................................................ 72
ribbon
changing the appearance............................ 31
hiding........................................................ 31
minimizing................................................. 31,33
ribbons
backing up.................................................. 172
customizing................................................. 172
restoring...................................................... 172
right-click
selecting................................................... 196
roles............................................................. 9,12
rollover highlight........................................ 40,194
rotating
drawing objects............................................ 131
objects...................................................... 131

S
saving
dialog box properties............................ 83
models...................................................... 22
views.......................................................... 64
screeshots
creating...................................................... 170
searching
for commands and dialog boxes................ 30
select on right-click........................................... 40
selecting
assemblies................................................... 109
cast units................................................... 109
dates from model........................................... 194
interrupting object selection...................... 195
nested assemblies........................................... 110
objects...................................................... 103,106,112,194
objects in components............................... 110
on right-click.............................................. 196
unable to select objects............................ 112
values from model........................................... 194
selection filters............................................ 106,140
selection switches........................................... 106
setting up Tekla Structures............................ 9,12
blank project............................................... 11
setting up
grid.......................................................... 45
views......................................................... 45
work area.................................................. 45
work plane.................................................. 45
workspace.................................................. 45
settings
model templates.....................................19
snapping.................................................101
units and decimals............................... 45
shape
modifying part shape..............................77
shifting the work plane.................................69
shortcuts, see keyboard shortcuts... 184,188
showing
dimensions............................................ 103
toolbars.................................................... 98
views......................................................... 63
work area................................................. 66
side panes...................................................... 38
single-user vs multi-user..............................16
smart select.................................................... 40
snap grid........................................................ 97
snap settings............................................. 101
snap switches........................................... 93
  overriding................................................. 98
snapping
  example.................................................... 98
  using coordinates....................................... 98
snapping toolbar..................................... 92
snapping
  priority...................................................... 92
  settings..................................................... 101
  snap depth................................................. 92
  snap override........................................... 98
  snap zone.................................................. 92
snapshots, see screenshots.......................170
special characters....................................... 162
status bar...................................................... 32
switching between
  views......................................................... 65

T

tabs..........................................................31,172
Tekla Structures
  user interface...........................................25
template attributes
  in filtering.............................................161
templates
  model templates...........................................19
tip
  copying and moving efficiently..............196
  finding RGB values for colors..................72
  selecting values from model....................194
toolbars
  contextual toolbar.................................33
  how to restore...........................................197
  selection switches.................................106
  snapping toolbar....................................92
tooltips.....................................................26
tracking
  along line................................................ 98

U

units and decimals........................................45
updatings views.........................................65
user interface...........................................25
  languages................................................. 39
  user-defined
    commands............................................. 172

V

values
  selecting from model..............................194
view filters.............................................140
view plane............................................... 69
view planes
  moving..................................................... 54
  creating.................................................... 54
deleting................................................. 64
modifying............................................... 64
naming..................................................... 64
opening..................................................... 63
refreshing............................................... 65
saving..................................................... 64
switching between views.......................... 65

W

warning messages........................................197
wildcards............................................... 162
work area....................................................... 66
hiding........................................................ 66
work plane
  shifting.................................................. 69
  show or hide........................................... 69

Z
zooming in or out........................................... 28