## Contents

1. **Creating 3D models**
   - What is a 3D model ................................................. 11
   - Creating a new model ............................................. 12
   - Opening a model .................................................. 13
   - Saving a model ...................................................... 14
     - Saving a model with a different name or location ... 14
   - Model templates
     - Creating a model template .................................... 15
     - Modifying a model template .................................. 17

2. **Setting up the workspace**
   - Screen layout ...................................................... 18
     - Changing the background color ......................... 20
     - Background color examples ................................. 20
   - Work area ............................................................ 22
     - Defining the work area ........................................ 23
     - Hiding the work area .......................................... 23
   - Work plane .......................................................... 24
     - Shifting the work plane ....................................... 25
     - Restoring the default work plane .......................... 25
     - Changing the color of the work plane grid .......... 26
   - Coordinate system ................................................. 26
   - Grids
     - Creating a grid ................................................. 27
     - Modifying a grid ............................................... 28
     - Deleting a grid .................................................. 28
     - Changing the grid color ...................................... 29
     - Single grid lines
       - Creating a single grid line .................................. 30
       - Modifying a single grid line ............................... 31
       - Deleting a single grid line ................................. 33
   - Views
     - View planes ...................................................... 33
       - Moving a view plane ........................................ 36
       - Adjusting the view properties ............................ 36
     - Creating views
       - Creating a basic view of the model ..................... 37
       - Creating a view using two points ....................... 37
       - Creating a view using three points ..................... 38
       - Creating a view of the work plane ...................... 38
       - Creating grid views ......................................... 38
       - Creating a view on a part plane ......................... 41
Creating a 3D view of a part................................................................................................................ 41
Creating default part views.................................................................................................................... 41
Creating an undeformed part view........................................................................................................ 42
Creating a 3D view of a component........................................................................................................ 42
Creating default component views........................................................................................................ 42
Creating a surface view......................................................................................................................... 43
Creating a surface view along selected edge.......................................................................................... 44
Saving a view.......................................................................................................................................... 46
Opening a view........................................................................................................................................ 46
Modifying a view..................................................................................................................................... 47
Deleting a view........................................................................................................................................ 47
Switching between open views................................................................................................................ 47
Switching between 3D and plane view.................................................................................................... 48
Refreshing views..................................................................................................................................... 48
Arranging views...................................................................................................................................... 49
2.7 Construction objects............................................................................................................ 49
Creating a construction plane.................................................................................................................. 50
Creating a construction line.................................................................................................................... 50
Creating a construction circle using center point and radius................................................................. 51
Creating a construction circle using three points................................................................................... 52
Modifying a construction object.............................................................................................................. 53
2.8 Points............................................................................................................................................... 54
Creating points along the extension line of two points......................................................................... 55
Creating points parallel to two points..................................................................................................... 56
Creating points on a line.......................................................................................................................... 57
Creating points on a plane....................................................................................................................... 58
Creating projected points on a line......................................................................................................... 58
Creating points along an arc using center and arc points..................................................................... 59
Creating points along an arc using three arc points............................................................................... 60
Creating points tangent to a circle........................................................................................................... 60
Creating points at the intersection of two lines...................................................................................... 61
Creating points at the intersection of a plane and a line....................................................................... 62
Creating points at the intersection of a part and a line.......................................................................... 62
Creating points at the intersection of a circle and a line....................................................................... 62
Creating points at the intersection of two part axes............................................................................. 63
Creating points at any position............................................................................................................... 63
Importing points...................................................................................................................................... 64
3 Defining project information ............................................................................................................ 66
4 Creating parts.................................................................................................................................... 69
4.1 About parts....................................................................................................................................... 69
Part handles............................................................................................................................................... 70
Part labels.................................................................................................................................................. 71
Showing part labels in a view................................................................................................................... 72
4.2 About items....................................................................................................................................... 73
Limitations to items.................................................................................................................................. 73
4.3 Creating steel parts................................................................................................................. 74
Creating a steel column............................................................................................................................ 74
Creating a steel beam.................................................................................................................................. 75
Creating a steel polybeam......................................................................................................................... 76
Creating a curved beam............................................................................................................................. 77
Creating a contour plate............................................................................................................................ 78
5.6 Changing the material of a part ................................................................. 111
5.7 Changing the shape of an item................................................................. 111
5.8 Splitting parts .......................................................................................... 112
  Splitting a straight or curved part or polybeam ......................................... 112
  Splitting a plate or slab ............................................................................. 112
5.9 Combining parts ....................................................................................... 113
5.10 Attaching parts ....................................................................................... 114
  Attaching a part to another part .............................................................. 115
  Detaching an attached part ...................................................................... 115
  Exploding attached parts ........................................................................ 115
5.11 Warping concrete parts ......................................................................... 116
  Warping a concrete beam using deformation angles .............................. 116
  Warping a concrete slab by moving chamfers ........................................ 117
  Warping a Floor Bay (66) slab ................................................................. 117
5.12 Cambering parts .................................................................................... 118
6 Detailing parts ............................................................................................ 120
  6.1 Creating bolts ....................................................................................... 120
  Creating a bolt group ............................................................................... 121
  Creating a single bolt .............................................................................. 121
  Creating bolts using the auto bolt tool .................................................. 122
  Changing or adding bolted parts ............................................................ 125
  6.2 Creating holes ....................................................................................... 125
  Creating round holes ............................................................................... 126
  Creating oversized holes ......................................................................... 127
  Creating slotted holes .............................................................................. 127
  6.3 Welding parts ....................................................................................... 129
  Setting the visibility and appearance of welds ....................................... 129
  Creating a weld between parts .............................................................. 130
  Creating a polygon weld ......................................................................... 131
  Creating a weld to a part ........................................................................ 131
  Weld preparation .................................................................................... 132
  Preparing a part for welding with a polygon ......................................... 132
  Preparing a part for welding with another part ..................................... 133
  Changing a weld to a polygon weld ....................................................... 134
  User-defined weld cross sections .......................................................... 134
    Defining a user-defined cross section for a weld ................................... 135
    Removing a user-defined cross section from a weld ......................... 135
  6.4 Fitting parts ......................................................................................... 135
  6.5 Cutting parts ....................................................................................... 136
  Cutting parts with a line .......................................................................... 136
  Cutting parts with a polygon .................................................................. 137
  Cutting parts with another part ............................................................ 138
  6.6 Chamfering parts ............................................................................... 139
  Chamfering part corners ....................................................................... 140
  Status of polybeam chamfers ............................................................... 141
  Chamfering part edges ......................................................................... 142
  6.7 Adding surface treatment ................................................................. 142
  Modifying surface treatment properties .............................................. 143
  Adding surface treatment to parts ....................................................... 144
7 Showing and hiding parts.................................................................156
7.1 Setting the visibility and appearance of parts.................................................................156
7.2 Changing the representation of parts and components..............................................158
7.3 Hiding a part.................................................................................................161
7.4 Hiding unselected parts......................................................................................162
7.5 Showing and hiding assemblies........................................................................163
7.6 Showing and hiding components......................................................................163
8 Grouping parts.........................................................................................165
8.1 Creating an object group......................................................................................165
8.2 Copying an object group to another model...........................................................166
8.3 Deleting an object group......................................................................................166
9 Changing the color and transparency of parts..................................................167
9.1 Changing the color of a part..................................................................................168
9.2 Changing the color of an object group.................................................................168
9.3 Defining color and transparency settings.............................................................170
9.4 Copying color and transparency settings.............................................................171
9.5 Removing color and transparency settings........................................................172
10 Viewing the model.........................................................................................173
10.1 Zooming..........................................................................................................173
10.2 Rotating the model............................................................................................174
10.3 Moving the model..............................................................................................176
10.4 Flying through the model..................................................................................176
10.5 Creating a clip plane...........................................................................................177
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.6</td>
<td>Taking a screenshot</td>
<td>178</td>
</tr>
<tr>
<td></td>
<td>Saving a screenshot in bitmap format</td>
<td>179</td>
</tr>
<tr>
<td>10.7</td>
<td>Keyboard shortcuts for viewing the model</td>
<td>179</td>
</tr>
<tr>
<td>11</td>
<td>Checking the model</td>
<td>181</td>
</tr>
<tr>
<td>11.1</td>
<td>Inquiring object properties</td>
<td>181</td>
</tr>
<tr>
<td></td>
<td>Object property report templates</td>
<td>182</td>
</tr>
<tr>
<td></td>
<td>Using the Custom Inquiry tool</td>
<td>182</td>
</tr>
<tr>
<td></td>
<td>Defining which attributes are displayed by Custom Inquiry tool</td>
<td>183</td>
</tr>
<tr>
<td></td>
<td>Adding attributes to Custom Inquiry tool</td>
<td>183</td>
</tr>
<tr>
<td>11.2</td>
<td>Measuring objects</td>
<td>184</td>
</tr>
<tr>
<td></td>
<td>Measuring distances</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td>Measuring angles</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td>Measuring arcs</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td>Measuring bolt spacing</td>
<td>186</td>
</tr>
<tr>
<td>11.3</td>
<td>Detecting clashes</td>
<td>187</td>
</tr>
<tr>
<td></td>
<td>Finding clashes</td>
<td>188</td>
</tr>
<tr>
<td></td>
<td>Managing clash check results</td>
<td>189</td>
</tr>
<tr>
<td></td>
<td>Symbols used in clash checking</td>
<td>189</td>
</tr>
<tr>
<td></td>
<td>About clash types</td>
<td>190</td>
</tr>
<tr>
<td></td>
<td>Managing the list of clashes</td>
<td>192</td>
</tr>
<tr>
<td></td>
<td>Searching for clashes</td>
<td>193</td>
</tr>
<tr>
<td></td>
<td>Changing the status of clashes</td>
<td>193</td>
</tr>
<tr>
<td></td>
<td>Changing the priority of clashes</td>
<td>194</td>
</tr>
<tr>
<td></td>
<td>Grouping clashes</td>
<td>194</td>
</tr>
<tr>
<td></td>
<td>Ungrouping clashes</td>
<td>194</td>
</tr>
<tr>
<td></td>
<td>Viewing the details of a clash</td>
<td>195</td>
</tr>
<tr>
<td></td>
<td>Adding comments to a clash</td>
<td>195</td>
</tr>
<tr>
<td></td>
<td>Modifying a clash comment</td>
<td>195</td>
</tr>
<tr>
<td></td>
<td>Removing a clash comment</td>
<td>196</td>
</tr>
<tr>
<td></td>
<td>Viewing the history of a clash</td>
<td>196</td>
</tr>
<tr>
<td></td>
<td>Printing a list of clashes</td>
<td>197</td>
</tr>
<tr>
<td></td>
<td>Previewing a list of clashes before printing</td>
<td>197</td>
</tr>
<tr>
<td></td>
<td>Setting the paper size, margins and page orientation</td>
<td>197</td>
</tr>
<tr>
<td></td>
<td>Opening and saving clash check sessions</td>
<td>198</td>
</tr>
<tr>
<td></td>
<td>Defining a clash check clearance area for bolts</td>
<td>199</td>
</tr>
<tr>
<td>11.4</td>
<td>Diagnosing and repairing the model</td>
<td>200</td>
</tr>
<tr>
<td></td>
<td>Diagnose and repair model results</td>
<td>200</td>
</tr>
<tr>
<td>11.5</td>
<td>Comparing parts or assemblies</td>
<td>201</td>
</tr>
<tr>
<td>11.6</td>
<td>Finding distant objects</td>
<td>201</td>
</tr>
<tr>
<td>11.7</td>
<td>Keyboard shortcuts for checking the model</td>
<td>202</td>
</tr>
<tr>
<td>12</td>
<td>Numbering the model</td>
<td>203</td>
</tr>
<tr>
<td>12.1</td>
<td>What is numbering and how to plan it</td>
<td>203</td>
</tr>
<tr>
<td></td>
<td>Identical parts</td>
<td>204</td>
</tr>
<tr>
<td></td>
<td>Identical reinforcement</td>
<td>205</td>
</tr>
<tr>
<td></td>
<td>What affects numbering</td>
<td>205</td>
</tr>
<tr>
<td></td>
<td>User-defined attributes in numbering</td>
<td>206</td>
</tr>
<tr>
<td></td>
<td>Numbering series</td>
<td>206</td>
</tr>
<tr>
<td></td>
<td>Planning your numbering series</td>
<td>207</td>
</tr>
<tr>
<td></td>
<td>Assigning a numbering series to a part</td>
<td>208</td>
</tr>
</tbody>
</table>
12.12 Adjusting the numbering settings ................................................................................. 210
12.3 Numbering parts .............................................................................................................. 211
  Numbering a series of parts .............................................................................................. 211
  Numbering assemblies and cast units ............................................................................. 212
  Numbering reinforcements .............................................................................................. 213
  Numbering welds ............................................................................................................. 213
  Saving preliminary numbers ........................................................................................... 213
12.4 Changing existing numbers ............................................................................................ 214
12.5 Clearing existing numbers ............................................................................................... 215
12.6 Checking the numbering .................................................................................................. 215
12.7 Viewing the numbering history ....................................................................................... 217
12.8 Repairing numbering errors ........................................................................................... 218
12.9 Renumbering the model .................................................................................................. 219
12.10 Control numbers ............................................................................................................ 219
  Assigning control numbers to parts ................................................................................. 220
  Control number order ...................................................................................................... 220
  Displaying control numbers in the model ...................................................................... 221
  Removing control numbers ............................................................................................. 222
  Locking and unlocking control numbers ...................................................................... 223
  Example: Using control numbers to indicate the erection order .................................... 224
12.11 Numbering parts by design group (Design Group Numbering) ................................... 226
12.12 Numbering examples .................................................................................................... 228
  Example: Numbering identical beams ............................................................................ 228
  Example: Using family numbers ...................................................................................... 229
  Example: Numbering selected part types ........................................................................ 230
  Example: Numbering parts in selected phases .............................................................. 231
13 Modeling settings .............................................................................................................. 233
  General settings .............................................................................................................. 233
    Grid properties ............................................................................................................. 233
    Grid line properties .................................................................................................... 234
    Point properties .......................................................................................................... 235
    Rotation settings ......................................................................................................... 235
    Screenshot settings ...................................................................................................... 236
13.2 View and representation settings .................................................................................... 236
  View properties .............................................................................................................. 237
  Grid view properties ..................................................................................................... 238
  Display settings ............................................................................................................. 238
  Color settings for parts .................................................................................................. 240
  Color settings for object groups ...................................................................................... 240
  Transparency settings for object groups ........................................................................ 241
13.3 Part properties ................................................................................................................ 241
  Steel column properties .................................................................................................. 242
  Steel beam properties .................................................................................................... 243
  Contour plate properties ............................................................................................... 243
Creating 3D models

This section explains how to open, create, and save models in Tekla Structures.

Click the links below to find out more:

- What is a 3D model on page 11
- Creating a new model on page 12
- Opening a model on page 13
- Saving a model on page 14
- Model templates on page 15

1.1 What is a 3D model

Using Tekla Structures, you can create a real-life model of any structure. The 3D model contains all the information that is needed to manufacture and construct the structure, including:

- Geometry and dimensions
- Profiles and cross sections
- Connection types
- Materials

The 3D model is the single source of information for drawings and other outputs, such as reports and NC data files. This ensures that the information in drawings and reports is always up to date, as they react to modifications in the model.
1.2 Creating a new model

You need to create a model for each Tekla Structures project. This model contains all the information about the project. Each model is stored in its own folder in the TeklaStructuresModels folder.

To create a new model:

1. Click File > New... or .

   You can only have one model open at a time. If you already have a model open, Tekla Structures prompts you to save that model.

2. Define where to save the new model.

   • To select a folder, click Browse.
   • To save the model in a recently used model folder, use the Save in list.
• To define the location manually, enter the path in the Save in box, followed by the \ character. Do not enter the model name in this box.

3. Enter a unique name in the Model name box.
   Do not use special characters (/ \ ; : | ).

4. If you want to use a predefined model template, select the template in the Model template list.

5. In the Model type list, define whether the model may be used by one person or shared by many.
   • Single-user: model will be used by one person.
   • Multi-user: model is stored on a server and may be used by several people. Also enter the name of the server in the Server box.

6. Click OK.
   Tekla Structures creates the model and opens the default model view.

See also  Model templates on page 15
Multi-user mode

1.3 Opening a model

To open a Tekla Structures model:

1. Click File --> Open... or 📖.
   You can only have one model open at a time. If you already have a model open, Tekla Structures prompts you to save that model.

2. In the Open dialog box, select the model.
   • To open a recently used model, use the Model name list.
   • To open a recently used model folder, use the Look in list.
   • To search for models in another folder, click Browse...

3. Click OK to open the model.
   If no views are visible after you have opened a model, Tekla Structures prompts you to select one.
You can sort models by clicking the column titles. When the models are sorted alphabetically by their names, you can use the keyboard to select models. For example, when you type ‘N’, Tekla Structures selects the first model starting with an ‘N’.

**See also**  Creating a new model on page 12

### 1.4 Saving a model

You should save your model regularly to avoid losing any work. Tekla Structures also automatically saves your work at regular intervals.

To save a model, do one of the following:

- Click ![File](/file.png).
- Click File > Save.

The **Autosave** tool automatically saves your model and drawings at set intervals. To set the autosave interval, click Tools --> Options --> Options... --> General. If you set the interval to less than 2, autosave is disabled.

**See also**  Saving a model with a different name or location on page 14

### Saving a model with a different name or location

To save a copy of a model under a different name or in a different location:

1. Click File --> Save As...
2. In the Save as dialog box, browse to the folder where you want to save the model.
3. In the Model name box, enter a new name.
4. Click OK.
Tekla Structures creates a new copy with a different name, but the original version of the model remains intact.

When you save the model with a different name, all the GUID object identifiers of the saved model will change and be different than in the original model.

See also  Saving a model on page 14

1.5  Model templates

You can save your model as a model template and use the desired model settings when creating new models. You can select which catalogs, custom components, model subfolders, drawing templates and report templates from the model are included in the model template. Note that only the items in the model folder can be included in the model template.

By default, the model template folder is saved in your environment folder. For example, if your environments are stored in `C:\ProgramData`, the model template folder for the default environment is in `C:\ProgramData\Tekla Structures\<version>\environments\default\model_templates`. You can define a different location using the advanced option XS_MODEL_TEMPLATE_DIRECTORY. For example, you can set this advanced option to point to the same location as XS_FIRM.

Only single-user models can be created with model templates. If you wish to create a multi-user model using a model template, create the model in single-user mode and then switch to multi-user mode.

You can download, share, and store model templates using Tekla Warehouse.

See also  Creating a model template on page 15  
Modifying a model template on page 17

Creating a model template

When you create a model template, always start by creating a new empty model. This is because old models that have been used in live projects cannot be completely cleaned. They may contain excess information that increases the size of the model even if you delete all objects and drawings from the model.
You can copy the needed attribute files into the new model folder, for example, from an earlier project.

To create a model template:

1. Create a new model and give it a unique name.
   
   For example, Steel framework.

2. Add the desired part attributes, drawing attributes, profiles, materials, custom components, sketches, and so on, in the model.

3. Save the model.

4. Click **File --> Save as Model Template**.

5. Enter a name for the model template and include the desired catalogs, drawing templates, report templates, and model subfolders.

   If there are no catalogs and templates in the model folder, the options are not available. Catalogs are typically located in the **Environment** folder. They are included in the model folder only when they have been modified.

<table>
<thead>
<tr>
<th>Option in Save as Model Template dialog box</th>
<th>File(s)/folder(s) included into model template folder when the option is selected</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profiles</td>
<td>profdb.bin, profitab.inp</td>
</tr>
<tr>
<td>Materials</td>
<td>matdb.bin</td>
</tr>
<tr>
<td>Components and sketches</td>
<td>componentcatalog.txt, ComponentCatalogTreeView.txt, Xslib.db1, thumbnail_bitmap.arc, *.dat files, and CustomComponentDialogFiles folder</td>
</tr>
<tr>
<td>Bolts and bolt assemblies</td>
<td>screwdb.db, assdb.db</td>
</tr>
<tr>
<td>Reinforcement</td>
<td>rebar_database.inp, RebarShapeRules.xml, rebar_config.inp, rebar_schedule_config.inp</td>
</tr>
<tr>
<td>Meshes</td>
<td>mesh_database.inp</td>
</tr>
<tr>
<td>Drawing templates</td>
<td>*.tpl files</td>
</tr>
<tr>
<td>Report templates</td>
<td>*.rpt files</td>
</tr>
</tbody>
</table>

6. If you want to open the destination folder after creating the model template, select the check box.

7. Click **OK**.

   You can now create a new model by selecting the model template from the model template list in the **New** dialog box.
Modifying a model template

To modify an existing model template, do one of the following:

- Copy the new or updated files directly to the model template folder.
- Create a new model using the existing model template and save the model as a new model template after you have made the needed changes.
2 Setting up the workspace

This section explains how to set up the workspace so that you can start modeling. It also presents some basic Tekla Structures vocabulary and concepts that are needed when working with 3D models.

Click the links below to find out more:

- Screen layout on page 18
- Work area on page 22
- Work plane on page 24
- Coordinate system on page 26
- Grids on page 26
- Views on page 33
- Construction objects on page 49
- Points on page 54

2.1 Screen layout

When you start Tekla Structures, a new window appears on the screen. Initially, most of the menu options and all the buttons appear dimmed, which indicates that they are unavailable. When you open or create a model, they become available.

The following image identifies the various areas of the modeling interface:
Menus
Toolbars
Selection switches
Snap switches
Status bar

See also Changing the background color on page 19
Changing the background color

You can define the background color of model views using RGB values. You can control the color of each corner of the background separately.

To change the background color in rendered views:

1. Click **Tools --> Options --> Advanced Options... --> Model View**.
2. Modify the background color using the following advanced options:
   - 
   - 
   - 
   - 

   To use a single-colored background, set the same value for all four corners of the background. To use the default background color, leave the advanced option boxes empty.

3. Close and reopen the view for the change to take effect.

See also
- Finding RGB values for colors on page 283
- Background color examples on page 20

Background color examples

Below are some examples of possible background colors that you can define. The first RGB value refers to the advanced option , the second value to the advanced option , and so on.

<table>
<thead>
<tr>
<th>RGB values</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td></td>
</tr>
<tr>
<td>RGB values</td>
<td>Result</td>
</tr>
<tr>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>0.0 0.4 0.2</td>
<td><img src="image1" alt="Diagram 1" /></td>
</tr>
<tr>
<td>0.0 0.4 0.2</td>
<td><img src="image1" alt="Diagram 1" /></td>
</tr>
<tr>
<td>0.0 0.0 0.0</td>
<td><img src="image1" alt="Diagram 1" /></td>
</tr>
<tr>
<td>0.0 0.0 0.0</td>
<td><img src="image1" alt="Diagram 1" /></td>
</tr>
<tr>
<td>0.3 0.0 0.6</td>
<td><img src="image2" alt="Diagram 2" /></td>
</tr>
<tr>
<td>0.3 0.0 0.6</td>
<td><img src="image2" alt="Diagram 2" /></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td><img src="image2" alt="Diagram 2" /></td>
</tr>
<tr>
<td>1.0 1.0 1.0</td>
<td><img src="image2" alt="Diagram 2" /></td>
</tr>
</tbody>
</table>
### RGB values

<table>
<thead>
<tr>
<th>RGB values</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.0 0.2 0.7</td>
<td><img src="image1.png" alt="Image" /></td>
</tr>
<tr>
<td>0.0 0.8 0.7</td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
<tr>
<td>0.0 0.2 0.7</td>
<td><img src="image3.png" alt="Image" /></td>
</tr>
<tr>
<td>0.0 0.8 0.7</td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
</tbody>
</table>

### See also
- Changing the background color on page 19
- Finding RGB values for colors on page 283

#### 2.2 Work area

Tekla Structures indicates the work area of a view using green, dashed lines.

You can define the work area to suit particular situations, for example, to concentrate on a particular area of the model. Defining the work area makes it faster and easier to work with the model. Objects outside the work area still exist, but they are not visible.

### See also
- Defining the work area on page 23
- Hiding the work area on page 23
Defining the work area

You can shrink and expand the work area by picking the corner points of the new work area, or size the work area to include selected parts, or all model objects. You can define the work area in a selected view, or in all visible views.

To define the work area:

1. Click **View** ---&gt; **Fit Work Area** and select one of the following commands:

   - **Using Two Points**
     Sets the work area based on two corner points you pick on the view plane. The depth of the work area is the same as the view depth.

   - **To Entire Model in All Views**
     Fits the work area to include all model objects in all visible views.

   - **To Entire Model in Selected Views**
     Fits the work area to include all model objects in the selected views.

   - **To Selected Parts in All Views**
     Fits the work area to include the selected model objects in all views. You must select the objects before running this command.

   - **To Selected Parts in Selected Views**
     Fits the work area to include the selected model objects in the selected views. You must select the objects before running this command.

2. If you selected the **Using Two Points** command, continue by following the instructions on the status bar.

See also  Work area on page 22

Hiding the work area

If you want, you can hide the green work area box. This can be useful, for example, when creating screenshots for presentations.

1. Click **Tools** ---&gt; **Options** ---&gt; **Advanced Options...** ---&gt; **Model View**.
2. Set the **XS_HIDE_WORKAREA** advanced option to **TRUE**.
3. Click **OK** or **Apply**.
4. Click **View** ---&gt; **Redraw All**. Tekla Structures hides the work area.
5. To make the work area visible again, set the advanced option to **FALSE**.
Alternatively, hold down Ctrl and Shift when clicking View > Redraw All to hide the green work area box. To make the box visible again, click View > Redraw All again.

See also  Work area on page 22

2.3 Work plane

The red coordinate arrow symbol indicates the work plane, which is the local coordinate system of the model. The work plane also has its own grid, which can be used for positioning parts. Tekla Structures displays the work plane grid in dark red.

To display the work plane grid, select Work plane from the second list on the Snapping toolbar.

![Work Plane Diagram]

The red arrow symbol shows the xy plane. The z direction follows the right-hand rule.

Most of the commands that are dependent on the coordinate system use work plane coordinates. For example creating points, part positioning, and copying always comply with the work plane coordinate system. The current work plane is model-specific, so it is the same in all views.

To set the work plane to any part plane, go to View --> Set Work Plane --> Using the Workplane Tool.

See also  Shifting the work plane on page 25
        Restoring the default work plane on page 25
        Changing the color of the work plane grid on page 25
        Right-hand rule on page 283
Shifting the work plane

You can shift the work plane to any position by picking points, parallel to one of the global basic planes, or on a part or view plane. When modeling sloped parts, shifting the work plane helps you to place parts accurately. For example, to model horizontal bracing and purlins in a sloped roof, you need to shift the work plane to the slope of the roof.

To shift the work plane:

1. Click View > Set Work Plane and select one of the commands.
   For more information on each command, see the corresponding menu tooltip.
2. Shift the work plane by following the instructions on the status bar.
3. If you want to display the work plane grid, select Work plane from the second list on the Snapping toolbar.

See also Work plane on page 24

Restoring the default work plane

Remember to change back to the default work plane when you have finished modeling sloped structures.

To restore the default work plane:

1. Click View --> Set Work Plane --> Parallel to XY(Z) Plane...
2. Set Plane to XY.
3. Set Depth coordinate to 0.
4. Click Change.

See also Work plane on page 24
**Changing the color of the work plane grid**

To change the color of the work plane grid:

1. Click **Tools --> Options --> Advanced Options... --> Model View**.
2. Modify the advanced option.
   - Define the color using RGB values on a scale of 0 to 1. For example, to change the color to red, set the value to `1.0 0.0 0.0`.
3. Click **OK**.
4. Close and reopen the view for the change to take effect.

**See also**  
Work plane on page 24  
Finding RGB values for colors on page 283

---

### 2.4 Coordinate system

The symbol with three axes (x, y, and z) represents the local coordinate system and indicates the direction of the model. It is located in the lower right corner of the model view. The coordinate symbol follows the work plane.

![Coordinate system](image)

The green cube symbol represents the global coordinate system and lies at the global point of origin.

![Global coordinate system](image)

**See also**  
Work plane on page 24
2.5 Grids

Grids are used as an aid in locating objects in a Tekla Structures model. A grid represents a three-dimensional complex of horizontal and vertical planes. The grid is shown on the view plane using dash-and-dot lines.

Grid origin is the point where the zero points of each coordinate axis intersect

Grid line extensions define how far the grid lines extend in each direction

Grid labels are the names of the grid lines shown in views

You can make grids and grid lines act magnetically so that the objects on the grid lines follow if you move the grid line.

You can have more than one grid in a model. So that you can easily place objects in your model, we strongly advise that you create a modular grid. You can create a large-scale grid for the entire structure, and smaller grids for some detailed sections. You can also create single grid lines and attach them to an existing grid.

See also

Creating a grid on page 27
Modifying a grid on page 28
Deleting a grid on page 29
Changing the grid color on page 29
Single grid lines on page 30
Creating a grid

When you create a new model, Tekla Structures automatically creates a grid and a view according to the saved standard properties. You can also create grids manually.

To manually create a grid:

1. Click **Modeling --> Create Grid...** to open the **Grid** dialog box.
2. When prompted, you can pick a point to indicate the origin of the grid. The coordinates of the picked point appear in the **Grid** dialog box as \( X_0, Y_0, \) and \( Z_0 \). If you do not pick a point, Tekla Structures positions the origin according to the existing values.
3. Enter the x and y coordinates. You can either define the coordinates individually, or you can define several grid lines with equal spacing. Both of the following coordinate entries create three grid lines with the spacing of 4000:
   
   - 0 4000 4000
   - 0 2*4000
4. Enter the z coordinates.
5. Enter the grid labels.
6. Modify the other grid properties if needed.
7. If you want to bind objects to the grid lines, select the **Magnetic grid plane** check box.
8. Click **Create**.

When working with very large grids, always having the grid labels visible might slow down Tekla Structures. To hide the grid labels when you zoom in, use the advanced option .

See also
- Grids on page 26
- Coordinate system on page 26
- Grid properties on page 233

Modifying a grid

To modify a grid:

1. Ensure that the **Select grid** selection switch \( 
\) is selected.
2. Double-click a grid line. The **Grid** dialog box appears.
3. Modify the grid properties.

If you have attached additional grid lines to the grid and you want to preserve them, clear the check boxes next to the **Coordinate** boxes. Otherwise Tekla Structures deletes all single grid lines attached to the grid.

4. Click **Modify** to save the changes.

**See also** Grids on page 26
Grid properties on page 233

### Deleting a grid

To delete a grid:

1. Ensure that the **Select grid** selection switch is selected.
2. Select a grid line.
3. Ensure that you do not have any other objects selected.
   - If you have also other objects selected, Tekla Structures only deletes the objects, not the grid.
4. Right-click and select **Delete** from the pop-up menu.
5. Confirm that you want to delete the grid.

**See also** Grids on page 26

### Changing the grid color

To change the color of the grid in rendered views:

1. Click **Tools --> Options --> Advanced Options... --> Model View**.
2. Modify the advanced option.
   - Define the color using RGB values on a scale of 0 to 1. For example, to change the color to red, set the value to \(1.0 \ 0.0 \ 0.0\).
3. Click **OK**.
4. Close and reopen the view for the change to take effect.

**See also** Grids on page 26
Finding RGB values for colors on page 283
**Single grid lines**

You can attach single grid lines to an existing grid.

Single grid lines have handles. If the **Select grid line** selection switch is active and you select a grid line, the handles appear in magenta. You can use handles to move the grid lines.

If you want to move the grid lines using the handles to make a skewed grid, you can do this only on the local XY plane of the grid.

You can also use direct modification to create and modify grid lines.

**See also**  [Grids on page 26](#)
- Creating a single grid line on page 30
- Modifying a single grid line on page 31
- Deleting a single grid line on page 32

**Creating a single grid line**

To create a single grid line, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a grid line</td>
<td>1. Ensure that the <strong>Direct modification</strong> switch is active.</td>
</tr>
<tr>
<td></td>
<td>2. Ensure that the <strong>Select grid</strong> selection switch is active.</td>
</tr>
</tbody>
</table>
To | Do this
--- | ---
3. | Select an existing grid to attach the grid line to.
4. | Click the + symbol between two existing grid lines or outside the grid.
   Tekla Structures creates the grid line and gives it a label using the labels of the adjacent grid lines. For example, a new grid line between the grid lines 1 and 2 receives the label 12*.

Create a grid line between two points | 1. Click **Modeling --> Add Grid Line**.
2. | Select an existing grid to attach the grid line to.
3. | Pick the start point of the grid line.
4. | Pick the end point of the grid line.

See also  Single grid lines on page 30
Grid line properties on page 234

### Modifying a single grid line

To modify a single grid line, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| **Modify grid line properties** | 1. Ensure that the **Select grid line** selection switch is active.
2. Double-click a grid line. The **Grid Line Properties** dialog box appears.
3. Modify the grid line properties.
4. Click **Modify** to save the changes. |
| **Move a grid line** | 1. Ensure that the **Direct modification** switch is active.
2. Ensure that the **Select grid** selection switch is active.
3. Select the grid.
4. Select the grid line you want to move.
5. Do one of the following:
   - Drag the grid line to a new location. |
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| • Using the keyboard, enter the distance you want the grid line to move.  
To start with the negative sign (-), use the numeric keypad.  
To enter an absolute coordinate, first enter $, then the value.  
Press Enter, or click OK in the Enter a Numeric Location dialog box. |                                                                                                                                 |

**Stretch, shrink, or incline a grid line**

1. Ensure that the Direct modification switch is active.
2. Ensure that the Select grid selection switch is active.
3. Select the grid.
4. Select the grid line.
5. Drag a grid line handle to a new location.

**Change a grid line label**

1. Ensure that the Direct modification switch is active.
2. Ensure that the Select grid selection switch is active.
3. Select the grid.
4. Right-click the grid line.
5. Enter a new label in the box that appears:

   ![Label Box]

6. Press Enter.

If you move any of the outermost grid lines using its line handle, Tekla Structures stretches or shrinks the perpendicular, crossing grid lines accordingly by default. To temporarily prevent this, select the grid line to move, right-click and click , and then move the grid line.

**See also**

- Single grid lines on page 30
- Grid line properties on page 234
Deleting a single grid line

To delete a single grid line, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete a grid line using the <strong>Select grid</strong> switch</td>
<td>1. Ensure that the <strong>Direct modification</strong> switch is active.</td>
</tr>
<tr>
<td></td>
<td>2. Ensure that the <strong>Select grid</strong> selection switch is active.</td>
</tr>
<tr>
<td></td>
<td>3. Select the grid from which to delete the grid line.</td>
</tr>
<tr>
<td></td>
<td>4. Select the grid line you want to delete.</td>
</tr>
<tr>
<td></td>
<td>5. Press <strong>Delete</strong>.</td>
</tr>
</tbody>
</table>

| Delete a grid line using the **Select grid line** switch | 1. Ensure that the **Select grid line** selection switch is active.     |
|                                                        | 2. Select the grid line you want to delete.                             |
|                                                        | 3. Ensure that you do not have any other objects selected.              |
|                                                        | If you also have other objects selected, Tekla Structures only deletes the objects, not the grid line. |
|                                                        | 4. Right-click and select **Delete** from the pop-up menu.             |
|                                                        | 5. Confirm that you want to delete the grid line.                      |

See also Single grid lines on page 30

2.6 Views

A view is a representation of a model from a specific location. Each view is displayed in its own window inside the Tekla Structures window. Selecting a part in a view highlights the part in all open views.

There are several ways to create views in Tekla Structures. For example, you can create views:

- of the entire structure
- of selected parts and components
- of selected cast units and assemblies
- along the grid lines
See also  
Creating views on page 36  
Opening a view on page 46  
Modifying a view on page 47  
Deleting a view on page 47  
Switching between open views on page 47  
Switching between 3D and plane view on page 48  
Refreshing views on page 48  
Arranging views on page 48

**View planes**

Each view has a view plane on which the grids are visible and points are represented as yellow crosses. Points that are located outside the view plane are red.

**Basic views**  
Basic views are those parallel to the global basic planes (xy, xz, and yz). In basic views, two axes always define the view plane and the axes appear in the plane name. The third axis is perpendicular to the view plane. It does not appear in the plane name. In the basic plane view, the model is shown from the direction of the third axis.

The view plane options for basic views are:
For basic views, you also define the distance the view plane is from the global origin in the direction of the third axis. The view plane coordinate equals this distance.

**Other views**
For view types other than basic views, you either define the view plane and coordinate by picking points, or the points are defined automatically, depending on the creation method.

**See also**
Moving a view plane on page 35
Creating views on page 36
Moving a view plane

You can change the view plane by moving it like any other object. When you move a view plane, Tekla Structures only uses the vector that is perpendicular to the view plane.

To move the view plane:
1. Click the view.
2. Right-click and select Move Special > Linear... from the pop-up menu.
3. Pick the start point of the translation vector, or enter its coordinates.
4. Pick the end point of the translation vector, or enter its coordinates.
5. Click Move.

If the Move – Linear dialog box is open but the command is not active anymore, click the Pick button to re-activate the command.

See also  View planes on page 34

Adjusting the view properties

You can adjust the view properties to suit your needs. Tekla Structures uses the current view properties when you create new views.

To adjust the view properties:
1. Double-click the view to open the View Properties dialog box.
   The current view properties are displayed.
2. Modify the properties.
   You can modify the individual settings, or you can load a previously stored set of properties with the Load button.
3. Click Apply or OK to save the settings.

See also  View properties on page 237

Creating views

This section explains how to create views of parts, components, or the entire model.

Click the links below to find out more:
•  Creating a basic view of the model on page 37
•  Creating a view using two points on page 37
Creating a basic view of the model
You can create a basic view along two coordinate axes. Use this view for the overall viewing of the model.

To create a basic view:

1. Click View --> Create View of Model --> Basic View... to open the Create Basic View dialog box.
2. Select a view plane from the Plane list.
3. In the Coordinate box, enter the view level.
   This value defines the distance from the global origin.
4. Click Create.

See also Adjusting the view properties on page 36

Creating a view using two points
You can create a view using two points you pick: the origin and a point in the horizontal direction.

To create a view using two points:

1. Click View --> Create View of Model --> Using Two Points.
2. Pick a point to indicate the origin of the view plane.
3. Pick a second point to indicate the direction of the x axis.
   The y axis is perpendicular to the view plane on which you picked the first point.

See also Adjusting the view properties on page 36
Creating a view using three points
You can create a view using three points you pick: the origin, a point in the horizontal direction, and a point in the vertical direction.

To create a view using three points:
1. Click View --> Create View of Model --> Using Three Points.
2. Pick a point to indicate the origin of the view plane.
3. Pick a second point to indicate the direction of the x axis.
4. Pick a third point to indicate the direction of the y axis.

See also Adjusting the view properties on page 36

Creating a view of the work plane
You can create a view of the work plane using the current view properties.

To create a view of the work plane:
• Click View --> Create View of Model --> On Work Plane to create the view.

See also Adjusting the view properties on page 36

Creating grid views
You can create views along the grid lines you select.

Before you start, create a view that contains a grid, and check the grid properties. If the grid properties are incorrect in some way, Tekla Structures may cut the views at the wrong elevations or they may not be named correctly. If you change the grid labels or the elevation or grids later on, the views will not be automatically renamed.

To create grid views:
1. Select the grid.
2. Click View --> Create View of Model --> Along Grid Lines... to open the Creation of Views Along Grid Lines dialog box.
3. Modify the grid view properties if needed.
   a. In the Number of views list, select how many views you want to create.
   b. In the View name prefix box, enter a prefix.
   c. In the View properties list, define which view properties (applied or saved) you want to use.
4. Click Create.
   The Views dialog box opens.
5. Click the arrow buttons to move views from the **Named views** list to the **Visible views** list.

The views will not be visible until you move them to the **Visible views** list.

**Example**  
In this example, we will create vertical views of the grid lines 1–7 on the following model:

![Model with grid lines](image)

In the **Creation of Views Along Grid Lines** dialog box, we select **All** for the view plane XZ and **None** for the view planes XY and ZY. We use the default settings for the view name prefix and the view properties.

<table>
<thead>
<tr>
<th>View plane</th>
<th>Number of views</th>
<th>View name prefix</th>
<th>View properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>XY</td>
<td>None</td>
<td>PLAN</td>
<td>Grid-Plan</td>
</tr>
<tr>
<td>ZY</td>
<td>None</td>
<td>GRID</td>
<td>Grid-Elevation</td>
</tr>
<tr>
<td>XZ</td>
<td>All</td>
<td>GRID</td>
<td>Grid-Elevation</td>
</tr>
</tbody>
</table>

After creating the grid views, we move the view named **Grid 2** to the **Visible views** list:
The grid view is displayed as a plane view in a new window:

We can rotate the view to see it in 3D:

See also  Grid view properties on page 238
          Modifying a grid on page 28
Creating a view on a part plane
You can create a view on the front, top, back, or bottom plane of the selected part.

To create a view on a part plane:

1. Click View --> Create View of Model --> On Part Plane and then click one of the following:
   • Front
   • Top
   • Back
   • Bottom

2. Select the part of which you want to create the view.

See also Adjusting the view properties on page 36

Creating a 3D view of a part
When you need to see a specific part clearly, create a 3D view of the part. The part is placed in the center of the view.

To create a 3D view of a part:

1. Click View --> Create View of Part --> 3D View

2. Select the part of which you want to create the view.
   Tekla Structures creates the view. The view plane y axis is the global z axis of the model. The x axis is the projection of the part's local x axis onto the global xy plane.

See also Adjusting the view properties on page 36

Creating default part views
You can create four basic views of a part: front, top, end and perspective view. Tekla Structures creates these views all at once with the same command. By default, the perspective view is a 3D view, and the front, top, and end views are plane views.

To create four default views of a part:

1. Click View --> Create View of Part --> Default Views

2. Select the part of which you want to create the view.
   Tekla Structures creates the four default views all at once.

See also Adjusting the view properties on page 36
Creating an undeformed part view
You can create a view that shows a deformed part in undeformed form. This only works for beams and columns.

To create an undeformed view of a part:
1. Click View --> Create View of Part --> Undeformed View.
2. Select the part of which you want to create the view.
   For example, select a warped beam. Tekla Structures displays the beam in a separate view in undeformed form.

See also Adjusting the view properties on page 36

Creating a 3D view of a component
When you need to see a specific component clearly, create a 3D view of the component. The component is placed in the center of the view.

To create a 3D view of a component:
1. Click View --> Create View of Component --> 3D View.
2. Select the component of which you want to create the view.
   Tekla Structures creates the view. The view plane y axis is the global z axis of the model. The x axis is the projection of the first secondary part local x axis onto the global xy plane. Work area depth is 1 m in all directions.

See also Adjusting the view properties on page 36

Creating default component views
You can create four basic views of a component: front, top, end and perspective view. Tekla Structures creates these views all at once with the same command. By default, the perspective view is a 3D view, and the front, top, and end views are plane views.

To create four default views of a component:
1. Click View --> Create View of Component --> Default Views.
2. Select the component of which you want to create the view.
   Tekla Structures creates the four default views all at once.

See also Adjusting the view properties on page 36
Creating a surface view

Use the CreateSurfaceView macro to create an automatically aligned surface view. This can be useful when modeling bolt groups, stiffener plates, and hole penetrations on complex geometry.

To create an automatically aligned surface view:

1. Click Tools --> Macros and select CreateSurfaceView from the list of macros.
2. Click Run to start the macro.
3. Select the surface of the part.

Tekla Structures creates a new temporary view and moves the work plane typically along the longest edge of the part face. You can model in the surface view and see your modeling work being done in your original 3D view at the same time.
4. Press Esc to stop the macro.

5. To return the work plane back to the origin, click Tools --> Macros and run the WorkPlaneGlobal macro.

**See also** Creating a surface view along selected edge on page 44

**Creating a surface view along selected edge**

Use the CreateSurfaceView_wEdge macro to create a surface view and align the work plane along the edge you select. This can be useful when modeling bolt groups, stiffener plates, and hole penetrations on complex geometry.

To create a surface view and align it along the edge you select:

1. Ensure that the Snap to geometry lines/points selection switch is selected. This allows you to pick along an edge to define the direction.

2. Click Tools --> Macros and select CreateSurfaceView_wEdge from the list of macros.

3. Click Run to start the macro.

4. Select the surface of the part.

When you hover the mouse pointer over the part edges, a yellow arrow symbol is displayed to indicate the possible edges you can align the view to. The head of the arrow represents the positive direction of the x axis. The view will be rotated in this direction to
form the flat horizontal edge of the view. The origin of the view and work plane will be at the start of the arrow snap line.

5. Pick the desired edge.

Tekla Structures creates a new temporary view, and the selected edge forms the x axis of the view. You can model in the surface view and see your modeling work being done in your original 3D view at the same time.

6. Press Esc to stop the macro.

7. To return the work plane back to the origin, click **Tools --> Macros** and run the **WorkPlaneGlobal** macro.
Saving a view
If you need to re-open views later on, give each view a unique name. When you exit the model, Tekla Structures only saves the named views. Temporary views disappear when you close them.

Before you start, create one or more views in the model.

To save a view:
1. Double-click the view to open the View Properties dialog box.
2. Enter a unique name in the Name box.
   
   Temporary views have a default name in parentheses. Do not use parentheses when naming a view, or the view will not be saved for later use.

3. Click Modify.

   Tekla Structures will automatically save all named views when you close the model.

Opening a view
To view and open an existing view:
1. Click View --> View List... .

   The Views dialog box appears. Tekla Structures lists all invisible named views on the left, and all visible views on the right.

2. Select a view and use the arrows between the lists, or double-click a view to open it.

   You can have up to nine views on the screen at the same time. If you try to open more than nine views, Tekla Structures displays a warning. If the view does not appear, check how many views you have open.
To open multiple views, use the Shift and Ctrl keys when you select views from the list.

See also Views on page 33

**Modifying a view**

To modify an existing view:

1. Double-click the view to open the View Properties dialog box.
2. Modify the view properties.
3. Click Modify.

See also Views on page 33

View and representation settings on page 236

**Deleting a view**

To delete a named view:

1. Click View --> View List... .
   
   The Views dialog box appears. Tekla Structures lists all invisible named views on the left, and all visible views on the right.
2. Select the view you want to delete.
3. Click Delete.

See also Views on page 33

Switching between open views

To switch between open views, do one of the following:

- Use the keyboard shortcut Ctrl+Tab.
• On the **Window** menu, select a view from the list.
• Right-click a view, then select **Next Window** from the pop-up menu.

The next open view becomes active.

**See also**  
[Views on page 33](#)  
Switching between 3D and plane view on page 48

### Switching between 3D and plane view

To switch between the 3D and the plane view, do one of the following:

• Press **Ctrl+P**.

• Click **View --> Switch to 3D / Plane**.

• In the **View Properties** dialog box, select an option from the **Angle** list, and then click **Modify**.

**See also**  
[Views on page 33](#)  
Switching between open views on page 47

### Refreshing views

To refresh the screen display, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redraw the contents of the active view</td>
<td>Right-click the view and select <strong>Redraw View</strong> from the pop-up menu.</td>
</tr>
<tr>
<td>Redraw the contents of all the views</td>
<td>Click <strong>View --&gt; Redraw All</strong>.</td>
</tr>
<tr>
<td>Update the contents of the active view</td>
<td>Right-click the view and select <strong>Update Window</strong> from the pop-up menu.</td>
</tr>
<tr>
<td>Update the contents of all the views</td>
<td>Click <strong>View --&gt; Update All</strong>.</td>
</tr>
</tbody>
</table>

Updating views is faster than redrawing. Updating only removes temporary graphics, such as measured distances, from the views. It does not, for example, show hidden objects.

**See also**  
[Views on page 33](#)
Arranging views

You can arrange views manually by dragging and dropping each view within the Tekla Structures window, or have Tekla Structures automatically arrange views.

To arrange the views, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrange all open views in a stack</td>
<td>Click Windows --&gt; Cascade .</td>
</tr>
<tr>
<td>Arrange all open views horizontally</td>
<td>Click Windows --&gt; Tile Horizontally .</td>
</tr>
<tr>
<td>Arrange all open views vertically</td>
<td>Click Windows --&gt; Tile Vertically .</td>
</tr>
<tr>
<td>Close all the views</td>
<td>Click Windows --&gt; Close All .</td>
</tr>
</tbody>
</table>

You cannot use the Cascade, Tile Horizontally, and Tile Vertically commands for views that you can move outside the Tekla Structures window.

For more information on how to move part and component basic views and zoom windows across the entire Windows desktop, see , , and .

See also Views on page 33

2.7 Construction objects

Construction planes, lines, and circles help you place other objects. For example, you can easily pick the points at intersections of construction lines and circles. The snap priority of construction objects is the same as with the other lines.

Construction objects remain in the model when you update or redraw views and windows. They do not appear in drawings.

You can also create magnetic construction lines or planes to bind and move groups of objects. For example, rather than binding lots of handles and chamfers to faces, simply create a construction plane that goes through all the handles and chamfers. Then make this plane magnetic and bind the plane to the appropriate face. When you move the plane, the attached handles and chamfers move with it.

See also Creating a construction plane on page 50
Creating a construction line on page 50
Creating a construction circle using center point and radius on page 51
Creating a construction circle using three points on page 52
Modifying a construction object on page 53

Creating a construction plane

To create a construction plane:
1. Click **Modeling --> Add Construction Plane**.
2. Pick three points.
3. Click the middle mouse button. Tekla Structures draws the plane.
4. Double-click the plane in the model. The **Construction Plane Properties** dialog box appears.
5. Enter a name for the plane.
6. If you want to make the construction plane magnetic, select the **Magnetic** check box.
7. Click **Modify**.

Creating a construction line

To create a construction line:
1. Click **Modeling --> Add Construction Line**.
2. Pick the start point of the construction line.
3. Pick the end point of the construction line.
4. If needed, you can make the construction line magnetic.
   a. Double-click the line in the model.
   b. Select the **Magnetic** check box.
   c. Click **Modify**.

See also  Construction objects on page 49
         Modifying a construction object on page 53
Creating a construction circle using center point and radius

To create a construction circle:

1. Click **Modeling --> Add Construction Circle --> Using Center Point and Radius**.
2. Pick a point to define the center point of the circle.

3. Pick another point to define the radius.

Tekla Structures draws the construction circle.

See also  Construction objects on page 49
Modifying a construction object on page 53
Creating a construction circle using three points

Creating a construction circle using three points

To create a construction circle:

2. Pick three points along the arc of the circle.

   The picking order does not matter. For example:

   Tekla Structures draws the construction circle.
Modifying a construction object
You can modify construction points, lines, circles, and planes using direct modification.

Before you start:

- Ensure that the **Direct modification** switch is active.
- Select the construction object.

  Tekla Structures displays the handles and dimensions that you can use to modify the construction object. When you right-click a handle, Tekla Structures displays a toolbar with more modification options. The available options depend on the type of the construction object you are modifying.

When you drag a handle, hold down the **Shift** key to use the snap switches. By default, the snap switches are off to make it easier to drag the handle to any location.

To modify a construction object, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
<th>Available for</th>
</tr>
</thead>
</table>
| Set a reference point to move in one or two directions | 1. Right-click the handle in the reference point.  
  2. Click \( \rightarrow \) to define whether the handle can move only in one direction (z), or in two directions (x and y). You can also press **Tab** when you have the handle selected. | Construction points, lines, circle center points, planes |
| Move a point, a point on a line or circle, or a plane corner | Drag the handle in the reference point to a new location. | All construction objects |
| Move a circle | Drag the handle in the center point to a new location. | Construction circles |
| Move a line or a plane edge | Drag the line handle to a new location. | Construction lines, planes |
| Move a plane | Drag the plane to a new location. | Construction planes |
| Show or hide diagonal dimensions | 1. Right-click a handle.  
  2. Click \( \rightarrow \). | Construction lines, planes |
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
<th>Available for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change a dimension</td>
<td>Drag a dimension arrowhead to a new location, or:</td>
<td>Construction lines, circles, planes</td>
</tr>
<tr>
<td></td>
<td>1. Select the dimension arrowhead which you want to move.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To change the dimension at both ends, select both arrowheads.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To change the radius of a circle, select the outer arrowhead.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2. Using the keyboard, enter the value with which you want the dimension to change.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To start with the negative sign (-), use the numeric keypad.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To enter an absolute value for the dimension, first enter $, then the value.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3. Press Enter, or click OK in the Enter a Numeric Location dialog box.</td>
<td></td>
</tr>
</tbody>
</table>

**See also**  
Construction objects on page 49  
Points on page 54

### 2.8 Points

You can create points to make it easier to place objects at positions where no lines or objects intersect.

There are many ways to create points in Tekla Structures. Which method is the most convenient at each time depends on what you have already created in the model and which locations you can easily pick.

When you create points, Tekla Structures always places them according to the work plane coordinate system. Points located on the view plane are yellow and points outside the view plane are red.
Creating points along the extension line of two points

To create points along the extension line of two points:

1. Click **Modeling --> Add Points --> Along Extension of Two Points**.
   The **Point Input** dialog box opens.

2. Define the distances at which the points are created.
   Separate multiple values with spaces.
3. Click **OK**.
4. Pick the start point of the line (1).
5. Pick the end point of the line (2).

For example, if you enter `500 100 100` to the **Point Input** dialog box, the first point is created at 500 mm distance from the end point of the line, and the second and the third point are each created at 100 mm distance.

![Diagram showing points](image)

Enter a negative value to the **Point Input** dialog box to create a point between the start point and the end point.

**See also** Points on page 54

**Creating points parallel to two points**

You can create two offset points that are parallel to a line between two points you have picked.

To create points parallel to two points:
1. Click **Modeling --> Add Points --> Parallel to Two Points**.
   The **Point Input** dialog box appears.
2. Define the distances at which the points are created.
   Separate multiple values with spaces.
3. Click **OK**.
4. Pick the start point of the line (1).
5. Pick the end point of the line (2).
The picking order of the start point and the end point defines the offset direction of the new points.

When you look from the start point to the end point, Tekla Structures creates the new points to the left of the existing points. When you pick points, Tekla Structures uses arrows to indicate the offset direction.

For example, if you enter 500 to the Point Input dialog box, the new points are created parallel at 500 mm distance from the original points.

Enter a negative value to the Point Input dialog box to create a point between the start point and the end point.

See also Points on page 54

Creating points on a line
You can create points at equal intervals along a line that is defined by two points.

To create points on a line:
   The Divided Line Points dialog box appears.
2. Define the number of points to be created.
3. Click OK.
4. Pick the start point of the line (1).
5. Pick the end point of the line (2).
Creating points on a plane

You can create several equally spaced points in the desired area in the model. The points are created in relation to the picked origin position.

A point array consists of several points in a rectangular xy(z) pattern relative to the current work plane. The x, y, and z coordinates of the points define the array pattern. The x and y coordinates are relative distances between the points on the work plane. The z coordinates are absolute distances perpendicular to the work plane.

To create points on a plane:
1. Click Modeling --> Add Points --> On Plane...
   The Point Array dialog box appears.
2. Define the array point coordinates.
   Use positive or negative values to define the direction of the array.
   Use a zero at the beginning of the row to represent a point in the array origin. Separate multiple values with spaces.
3. Pick the origin of the array in the view.
   Alternatively, you can define the origin in the Point Array dialog box.
4. Click OK.

See also Points on page 54

Creating projected points on a line

You can project a point onto a selected line or its extension.

To create projected points on a line:
1. Click Modeling --> Add Points --> Projected Points on Line.
2. Pick the first point on the line (1).
3. Pick the second point on the line (2).
4. Pick the point to be projected (3).

See also Points on page 54

Creating points along an arc using center and arc points
You can create points along an arc.

To create points along an arc using center and arc points:
1. Click **Modeling --> Add Points --> Along Arc --> Using Center and Arc Points**.
   The **Arc Points** dialog box appears.
2. Select either **Angles** or **Distances** and enter the angles or distances between the points along the arc.
   Give the angle values in degrees.
   Separate multiple angle and distance values with spaces.
3. Click **OK**.
4. Pick the center point.
5. Pick the start point of the arc.
   Tekla Structures creates the arc points counterclockwise from the start point.

See also Points on page 54
Creating points along an arc using three arc points
You can create points as an extension of an arc.

To create points along an arc using three arc points:
1. Click **Modeling --> Add Points --> Along Arc --> Using Three Arc Points**.
   The **Arc Points** dialog box appears.
2. Select either **Angles** or **Distances** and enter the angles or distances between the points along the arc.
   Give the angle values in degrees.
   Separate multiple angle and distance values with spaces.
3. Click **OK**.
4. Pick three points along the arc (1-3).

See also  Points on page 54

Creating points tangent to a circle
To create points tangent to a circle:
1. Click **Modeling --> Add Points --> Tangent to Circle**.
2. Pick the center point of the circle (1).
3. Pick a point on the circle to define the radius (2).
4. Pick the end point of the tangent (3).
5. Pick a side to indicate the side on which Tekla Structures creates the tangent point (4).
Creating points at the intersection of two lines

To create points at the intersection of two lines:
1. Click **Modeling --> Add Points --> At Intersection --> Of Two Lines**.
2. Pick the start point of the first line (1).
3. Pick the end point of the first line (2).
4. Pick the start point of the second line (3).
5. Pick the end point of the second line (4).

See also Points on page 54
Creating points at the intersection of a plane and a line

To create points at the intersection of a plane and a line:
1. Click **Modeling --> Add Points --> At Intersection --> Of Plane and Line**.
2. Pick three points to define the plane.
3. Pick the first point of the line.
4. Pick the second point of the line.

See also Points on page 54

Creating points at the intersection of a part and a line

You can create points where a line intersects with the surface of a part.

To create points at the intersection of a part and a line:
1. Click **Modeling --> Add Points --> At Intersection --> Of Part and Line**.
2. Select the part.
3. Pick the first point of the line.
4. Pick the second point of the line.

See also Points on page 54

Creating points at the intersection of a circle and a line

To create points at the intersection of a circle and a line:
1. Click **Modeling --> Add Points --> At Intersection --> Of Circle and Line**.
2. Pick the center point of the circle (1).
3. Pick a point on the circle to define the radius (2).
4. Pick the first point on the line (3).
5. Pick the second point on the line (4).
Creating points at the intersection of two part axes

You can create points where the axes of two parts intersect, and project the points onto the view plane.

To create points at the intersection of a two part axes:

1. Click **Modeling --> Add Points --> At Intersection --> Of Two Part Axes**.
2. Select the first part (1).
3. Select the second part (2).

   Tekla Structures projects the point onto the view plane of where the parts you select are located.

Creating points at any position

Snap switches determine the positions you can pick.

You can also use temporary reference points and numeric snapping to create a point, for example, to a certain distance from an existing corner or a point.

To create points at any position:

1. Click **Modeling --> Add Points --> At Any Position**.
2. Pick the intersection of two part edges (1), or the corner of a part (2).

See also Points on page 54

**Importing points**

This section is for advanced users.

You can import points to specific locations in an open Tekla Structures model using the point creation import macro. You need to specify the point coordinates in a text file. In some cases this file is generated by another software package.

To import points from a file:

1. Create a point import file.
   a. Create a text file that consists of single lines for each point.
      Use commas or tabs as delimiters for the three point coordinates on a line. For example:
      - `100, 500, 1000`
      - `300, 700, 1500`
   b. Save the file.

   During the import process, Tekla Structures ignores all lines in the import file which do not consist of valid values delimited by tabs or commas.

2. Press **Ctrl + F** to open the Component Catalog.
3. Enter **point** in the **Search** box and click **Search**.
4. Double-click **Point Creation Import** (8).

5. Enter the ASCII file name.
   
   Include the full path and the file name extension. If you do not specify the path, Tekla Structures looks for the file in the current model folder.

6. Define the origin of the imported points by entering the coordinates.

7. Click **Create**.

**See also**  [Points on page 54](#)
You will need project information, such as the project number and name, many times during a project. Update the project information at the beginning of the project to make reports and drawings display the correct information automatically.

To define project information:

1. Click File --> Project Properties... .
   
   The Project Properties dialog box is displayed. It contains some sample entries, which you can overwrite.

2. Enter or update the project information. All information is optional.

3. In the Description box, enter a description that helps you identify the model when you next need to open it.
   
   The description appears in the Open dialog box when you open a model.

4. To define user-defined attributes, click User-defined attributes...:
   
   • Enter fabricator information.
   
   • Define project standards, such as finish, material and field connection.
   
   • Define what information appears in drawings.
   
   • Define your own fields to include in drawings and reports.
   
   • Preview title block and bill of material styles.

5. Click OK.

6. Click OK to save your changes.
   
   Now you will get updated project properties in drawings and reports.

7. To save the project properties as the default properties for this project, click Tools --> Defaults --> Save Defaults .
This will save `standard.prf` and `standard.prf.more` files (among many other standard files) into the `\attributes` folder under the model folder.

The project properties are loaded into the model by the `standard.prf` and `standard.prf.more` files from the environment files when you create a new model. The settings are saved in the model database.

To use the `standard.prf` files from your firm folder copy it there from the `\attributes` folder. It will then only be read by new models that do not use model templates.

The fields in the image below refer to template attributes, which you can use when designing your own reports and templates. To display in your reports and templates the information that you enter in this dialog box, add in the reports and templates the corresponding template attributes listed under the image.

![Project Properties dialog box](image)

1. PROJECT.NUMBER
2. PROJECT.NAME
<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>PROJECT.BUILDER</td>
</tr>
<tr>
<td>4</td>
<td>PROJECT.OBJECT</td>
</tr>
<tr>
<td>5</td>
<td>PROJECT.ADDRESS</td>
</tr>
<tr>
<td>6</td>
<td>PROJECT.DESIGNER</td>
</tr>
<tr>
<td>7</td>
<td>PROJECT.DATE_START</td>
</tr>
<tr>
<td>8</td>
<td>PROJECT.DATE_END</td>
</tr>
<tr>
<td>9</td>
<td>PROJECT.INFO1</td>
</tr>
<tr>
<td>10</td>
<td>PROJECT.INFO2</td>
</tr>
</tbody>
</table>

Defining project information 68 Points
This section explains how to create parts using different materials and profiles. It also explains how to join parts together into more complex structures.

Click the links below to find out more:

- About parts on page 69
- Creating steel parts on page 74
- Creating concrete parts on page 81
- Creating assemblies on page 88
- Creating cast units on page 97

### 4.1 About parts

In Tekla Structures, the term *part* refers to the basic building objects that can be modeled and detailed further. These are the building blocks of the physical model.

Every part has properties that define it, such as material, profile, and location. You can use part properties in view and selection filters. For example, you can select, modify, and hide parts based on their properties. You can also include part properties and user-defined attributes in drawing and report templates.

See also  
Part properties on page 241  
User-defined attributes on page 253
Part handles

Tekla Structures indicates the direction of a part with *handles*. When you select a part, Tekla Structures highlights the handles. The handle of the first end point is yellow, the rest are magenta.

If *Direct Modification* is on, Tekla Structures also displays direct modification handles for the reference points, corners, segments, and segment midpoints of the selected part. These handles are blue.
Part labels
You can display selected part properties, user-defined attributes, and template attributes in a model view by using part labels.
Part labels are textual descriptions that are displayed next to the part they represent. You can define what information to display in the labels, such as the name, profile, and position number of the part.

Example

See also  Showing part labels in a view on page 72

**Showing part labels in a view**

To show part labels in a view:

1. Double-click the view to open the **View Properties** dialog box.
2. Click **Display...**
3. In the **Display** dialog box, go to the **Advanced** tab.
4. Select the **Part label** check box.
5. Define which part properties to display in part labels.
   a. Select a property in the **Properties** list.
   b. Click **Add** to add the property to the **Part label** list.
6. If needed, define which user-defined attribute or template attribute to display in part labels.
   a. Select **User-defined attribute** in the **Properties** list.
   b. Click **Add**. The **Part label** dialog box appears.
c. Enter the attribute name and click OK.

7. Click Modify.

See also Part labels on page 71

4.2 About items

In Tekla Structures, the term item refers to the building objects that have a 3D shape. Shapes are created in an external modeling software, or in Tekla Structures, and they are available in the Tekla Structures shape catalog.

Items are similar to other parts, such as beams and columns. The main difference between items and other types of parts is that a 3D shape defines the geometry of an item, whereas a part has a 2D profile that is extruded to create the length of the part.

You can use items to model objects that would be difficult to model using basic Tekla Structures parts and commands, such as cutting. You can also use items to model objects that use shapes modeled in an external software or by a manufacturer.

Every item has properties that define it, such as shape, material, and location. If you want to use item properties in view and selection filters or in drawing and report templates, you need to use the template attributes of parts and profiles. If you want to separate items from parts, use the IS_ITEM template attribute.

See also

- Limitations to items on page 73
- Creating an item on page 80
- Creating a concrete item on page 87
- Item properties on page 246
- Concrete item properties on page 252
- Shapes

Limitations to items

- Items have a fixed geometry according to their shape, so items cannot be scaled, stretched, or fitted.
- Items cannot be mirrored.
- Items cannot be split or combined. Splitting an imported item creates a duplicate to the splitting position.
- Items can only be cut or attached to another part if they have a solid shape.
• The gross weight value of an imported item may be different from that of an identical Tekla Structures part modeled with cuts. This is because the cuts are not taken into account when calculating the gross weight of parts.
• The Mini Toolbar does not work for items.

See also About items on page 73

4.3 Creating steel parts

This section explains how to create steel parts.

Click the links below to find out more:
• Creating a steel column on page 74
• Creating a steel beam on page 75
• Creating a steel polybeam on page 76
• Creating a curved beam on page 77
• Creating a contour plate on page 77
• Creating an orthogonal beam on page 79
• Creating a twin profile on page 80
• Creating an item on page 80

Creating a steel column

To create a steel column:

1. Click or Modeling --> Create Steel Part --> Column.
2. Pick a point.
Tekla Structures creates the column at the level defined in the Column Properties dialog box.

3. If you want to change the part properties:
   a. Double-click the column to open the Column Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

Sometimes when you copy and mirror a column, its upper and lower levels may become incorrectly switched. Use the Orthogonal Beam Properties dialog box to correct the position of a column. Remember to change the part name to COLUMN.

See also  Steel column properties on page 242
Positioning columns, pad footings, and orthogonal beams on page 288

Creating a steel beam

To create a steel beam:

1. Click or Modeling --> Create Steel Part --> Beam.
2. Pick two points.
Tekla Structures creates the beam between the points you picked.

3. If you want to change the part properties:
   a. Double-click the beam to open the **Beam Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

See also  Steel beam properties on page 243

### Creating a steel polybeam
A polybeam can contain straight and curved segments. You can also create bent plates with this command.

To create a steel polybeam:

1. Click  or Modeling --&gt; Create Steel Part --&gt; Polybeam .
2. Pick the points you want the beam to go through.
3. Press the middle mouse button.
   Tekla Structures creates the polybeam between the points you picked.

4. If you want to change the part properties:
   a. Double-click the polybeam to open the **Beam Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

5. If you want to create curved segments, chamfer the corners of the polybeam.
Creating a curved beam

To create a curved steel beam:

1. Click or Modeling --> Create Steel Part --> Curved Beam.
2. Pick the start point (1).
3. Pick a point on the arc (2).
4. Pick the end point (3).

   Tekla Structures creates the beam between the points you picked.

5. If you want to change the part properties:
   a. Double-click the curved beam to open the Beam Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

See also Steel beam properties on page 243
Creating curved parts on page 285
Creating a contour plate
When you create a contour plate, the profile you use defines the thickness of the plate and
the picked points define the shape. The corners of the contour plate can be chamfered.

To create a contour plate:

1. Click or Modeling --> Create Steel Part --> Contour Plate.
2. Pick the corner points of the contour plate.
3. Press the middle mouse button.
   Tekla Structures creates the plate.

4. If you want to change the part properties:
   a. Double-click the plate to open the Contour Plate Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

See also Creating a round contour plate on page 78
Contour plate properties on page 243

Creating a round contour plate

To create a round contour plate:

1. Create a square contour plate with four equal sides.
2. Select the plate.
3. Select the handles of the plate.

   To select all the handles at once, hold down the Alt key and drag the mouse from left to right, covering all the handles.

4. Press Alt + Enter to display the Chamfer Properties dialog box.
5. Select the round chamfer symbol from the list.
6. Enter the chamfer radius in the box. The radius must be equal to half of the side of the square.

7. Click **Modify**.

![Diagram showing chamfering process]

**Create an orthogonal beam**

To create a steel beam that is orthogonal to the work plane:

1. Click **Modeling --> Create Steel Part --> Orthogonal Beam**.

2. Pick a point.

   Tekla Structures creates the beam at the position you picked.

3. If you want to change the part properties:
   a. Double-click the orthogonal beam to open the properties dialog box.
   b. Modify the properties.
   c. Click **Modify**.

---

**See also**
- Alternative way of creating a round plate or slab on page 287
- Creating a contour plate on page 77
- Contour plate properties on page 243
- Chamfering parts on page 139
Creating a twin profile
A twin profile consists of two identical beams. You define the positions of both beams by selecting the twin profile type and setting the clearance between the beams in two directions.

To create a twin steel profile:
1. Click **Modeling --> Create Steel Part --> Twin Profile**.
2. Pick two points.
   
   Tekla Structures creates the twin profile between the points you picked.

3. If you want to change the part properties:
   a. Double-click either of the beams to open the **Beam Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

See also Twin profile properties on page 245

Creating an item
To create an item:

1. Click **Create Steel Part --> Item**.
2. Pick two points.
Tekla Structures creates the item between the points you picked starting from the first point (yellow handle) towards the direction of the second point (magenta handle).

3. If you want to change the item properties:
   a. Double-click the item to open the Item Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

See also Item properties on page 246  
About items on page 73

4.4 Creating concrete parts

This section explains how to create concrete parts.

Click the links below to find out more:
• Creating a pad footing on page 81
• Creating a strip footing on page 82
• Creating a concrete column on page 83
• Creating a concrete beam on page 84
• Creating a concrete polybeam on page 84
• Creating a concrete slab on page 85
• Creating a concrete panel on page 86
• Creating a concrete item on page 87

Creating a pad footing

To create a pad footing:

1. Click or Modeling --> Create Concrete Part --> Pad Footing.
2. Pick a point.
Tekla Structures creates the footing at the position you picked.

3. If you want to change the part properties:
   a. Double-click the pad footing to open the Pad Footing properties dialog box.
   b. Modify the properties.
   c. Click Modify.

See also Pad footing properties on page 247

Creating a strip footing

To create a strip footing:

1. Click or Modeling --> Create Concrete Part --> Strip Footing.
2. Pick the points you want the footing to go through.
3. Press the middle mouse button.
   Tekla Structures creates the footing between the points you picked.

4. If you want to change the part properties:
   a. Double-click the strip footing to open the Strip Footing properties dialog box.
   b. Modify the properties.
   c. Click Modify.

5. If you want to create curved segments, chamfer the corners of the footing.
For example:

![Diagram showing a concrete column before and after modification]

See also  
Strip footing properties on page 248
Chamfering part corners on page 139

Creating a concrete column

To create a concrete column:

1. Click or Modeling --> Create Concrete Part --> Column .
2. Pick a point.
   Tekla Structures creates the column at the level defined in the Concrete Column Properties dialog box.

3. If you want to change the part properties:
   a. Double-click the column to open the Concrete Column Properties dialog box.
   b. Modify the properties.
   c. Click Modify.

See also  Concrete column properties on page 249
Creating a concrete beam

To create a concrete beam:

1. Click or \textbf{Modeling $\rightarrow$ Create Concrete Part $\rightarrow$ Beam}.
2. Pick two points.

3. If you want to change the part properties:
   a. Double-click the beam to open the \textbf{Concrete Beam Properties} dialog box.
   b. Modify the properties.
   c. Click \textbf{Modify}.

See also \textbf{Concrete beam properties on page 249}

Creating a concrete polybeam

A polybeam can contain straight and curved segments. You can also create concrete bent plates with this command.

To create a concrete polybeam:

1. Click or \textbf{Modeling $\rightarrow$ Create Concrete Part $\rightarrow$ Polybeam}.
2. Pick the points you want the beam to go through.
3. Press the middle mouse button.

Tekla Structures creates the beam between the points you picked.
4. If you want to change the part properties:
   a. Double-click the polybeam to open the **Concrete Beam Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.
5. If you want to create curved segments, chamfer the corners of the polybeam.
   For example:

   ![Concrete Beam Chamfer Example](image)

   **See also**  
   - Status of polybeam chamfers on page 140
   - Concrete beam properties on page 249

### Creating a concrete slab

When you create a concrete slab, the profile you use defines the thickness of the slab and the picked points define the shape. The corners of the slab can be chamfered.

To create a concrete slab:

1. Click **Modeling** --> **Create Concrete Part** --> **Slab**.
2. Pick the corner points of the slab.
3. Press the middle mouse button.
   
   Tekla Structures creates the slab.

4. If you want to change the part properties:
   a. Double-click the slab to open the **Concrete Slab Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.
Creating a round slab

To create a round slab:

1. Create a square slab with four equal sides.
2. Select the slab.
3. Select the handles of the slab.
   
   To select all the handles at once, hold down the Alt key and drag the mouse from left to right, covering all the handles.

4. Press Alt + Enter to display the Chamfer Properties dialog box.
5. Select the round chamfer symbol from the list.
6. Enter the chamfer radius in the x box. The radius must be equal to half of the side of the square.
7. Click Modify.

Creating a concrete panel

To create a concrete panel:

1. Click or Modeling --> Create Concrete Part --> Panel
2. Pick the points you want the panel to go through.
3. Press the middle mouse button.
   
   Tekla Structures creates the panel.

4. If you want to change the part properties:
   a. Double-click the panel to open the **Concrete Panel Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

5. If you want to create curved segments, chamfer the corners of the panel.
   
   For example:

See also  
**Concrete panel properties on page 251**
**Chamfering parts on page 139**

### Creating a concrete item

To create a concrete item:

1. Click ![Modeling icon] or **Modeling --> Create Concrete Part --> Item**.
2. Pick two points.
Tekla Structures creates the item between the points you picked starting from the first point (yellow handle) towards the direction of the second point (magenta handle).

3. If you want to change the item properties:
   a. Double-click the item to open the **Concrete Item Properties** dialog box.
   b. Modify the properties.
   c. Click **Modify**.

**See also**
Concrete item properties on page 252
About items on page 73

### 4.5 Creating assemblies

This section explains how to turn steel parts into assemblies.

Tekla Structures creates assemblies of steel parts when you use a workshop weld or bolt to join parts together. Assemblies and their main parts are automatically defined when you create single workshop welds or bolts, or when you apply automatic connections that create workshop welds or bolts.

Click the links below to find out more:

- Creating an assembly on page 88
- Adding objects to assemblies on page 91
- Changing the assembly main part on page 94
- Changing the main assembly on page 95
- Removing objects from an assembly on page 95
- Highlighting objects in an assembly on page 95
- Exploding an assembly on page 96
- Assembly examples on page 96
Creating an assembly

To create an assembly:
1. Ensure that the Select assemblies selection switch is active.
2. Select the parts and/or assemblies that you want to join together.
3. Right-click and select Assembly --> Make into Assembly from the pop-up menu.

Creating a sub-assembly

To create a sub-assembly of parts that are already in an assembly:
1. Ensure that the Select objects in assemblies selection switch is active.
2. Select the parts you want to include in the sub-assembly.
3. Right-click and select Make into Sub-Assembly from the pop-up menu.

Using bolts to create assemblies

You can use bolts to create and connect assemblies. You can create nested assemblies by connecting sub-assemblies to an existing assembly, or you can just connect more parts to assemblies using bolts.

To control how Tekla Structures creates assemblies, use the Connect part/assembly and Bolt type lists in the Bolt Properties dialog box. The order in which you select parts when creating the connection determines the main and secondary parts of the assembly or the assembly hierarchy.

<table>
<thead>
<tr>
<th>Connect part/assembly</th>
<th>Bolt type</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>As sub-assembly</td>
<td>Workshop or Site</td>
<td>Nested assembly with the assembly you are bolting as a sub-assembly.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The first part you pick determines the assembly to which you are bolting.</td>
</tr>
<tr>
<td>As secondary part</td>
<td>Workshop</td>
<td>Basic assembly with the part you are bolting as a secondary part.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The first part you pick usually becomes the main part in the assembly.</td>
</tr>
<tr>
<td>As secondary part</td>
<td>Site</td>
<td>No assembly created.</td>
</tr>
</tbody>
</table>
Creating assemblies on page 88
Bolting sub-assemblies to an existing assembly on page 90

**Bolting sub-assemblies to an existing assembly**

To bolt sub-assemblies to an existing assembly:

1. Click Detailing --> Properties --> Bolt... to open the Bolt Properties dialog box.
2. In the Connect part/assembly list, select As sub-assembly.
3. Click Apply or OK.
4. Select a part in the assembly to bolt to.
5. Select a part in the sub-assembly to be bolted.
6. Pick the bolt group origin.
7. Pick a point to indicate the bolt group x direction.

**Using welds to create assemblies**

Tekla Structures forms assemblies based on where the weld should be made. You can create workshop welds and site welds.

The order in which you select parts when creating the connection determines the main and secondary parts of the assembly or the assembly hierarchy. The first part you select becomes the main part of the assembly. Tekla Structures dimensions secondary parts relative to the main part in assembly drawings. The largest main part in the weld becomes the main part of the assembly.

When you connect assemblies, the first part you select determines the assembly to which you weld sub-assemblies.

To control how Tekla Structures creates assemblies, use the Connect part/assembly and Workshop/Site lists in the Weld Properties dialog box.

<table>
<thead>
<tr>
<th>Connect part/assembly</th>
<th>Workshop/Site</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>As sub-assembly</td>
<td>Workshop or Site</td>
<td>Nested assembly with the assembly you are welding as a sub-assembly. The first part you pick determines the assembly to which you are welding.</td>
</tr>
<tr>
<td>As secondary part</td>
<td>Workshop</td>
<td>Basic assembly with the part you are welding as a secondary part. The first part you pick usually becomes the main part in the assembly.</td>
</tr>
<tr>
<td>As secondary part</td>
<td>Site</td>
<td>No assembly created.</td>
</tr>
</tbody>
</table>

See also **Using bolts to create assemblies on page 89**
Welding sub-assemblies to an existing assembly

To weld sub-assemblies to an existing assembly:

1. Click Detailing --> Properties --> Weld... to open the Weld Properties dialog box.
2. In the Connect part/assembly list, select As sub-assembly.
3. Click Apply or OK.
4. Select a part in the assembly to weld to.
5. Select a part in the sub-assembly to be welded.
6. To check that the weld marks look correct, create a drawing.

Adding objects to assemblies

You can add objects to assemblies in the following ways:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a basic assembly</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Add parts to an existing assembly as secondary parts.</td>
</tr>
<tr>
<td></td>
<td>• Bolt or weld parts to an existing assembly as secondary parts.</td>
</tr>
<tr>
<td>Create a nested assembly</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Add parts to an existing assembly as secondary parts.</td>
</tr>
<tr>
<td></td>
<td>• Bolt or weld assemblies to an existing assembly as sub-assemblies.</td>
</tr>
<tr>
<td></td>
<td>• Add assemblies to an existing assembly as sub-assemblies.</td>
</tr>
<tr>
<td></td>
<td>• Join existing assemblies together without adding any loose parts.</td>
</tr>
</tbody>
</table>

Sub-assemblies in a nested assembly retain their own assembly information and main part. You can also define properties separately for the sub-assemblies and the nested assembly by using the part properties dialog box.

See also Creating assemblies on page 88
Assembly hierarchy on page 92
Adding parts to an assembly on page 93
Creating a nested assembly on page 94
Joining assemblies on page 94

Assembly hierarchy

You can work on any level of a nested assembly, from single parts and bolts, through the basic and sub-assemblies, up to the highest level of the nested assembly.

To work with nested assemblies, you need to know how to use the Shift key and mouse scrolling to select objects on different levels in the assembly hierarchy.
The assembly hierarchy in nested assemblies affects drawings and reports. You can create separate drawings and reports of the sub-assemblies and the nested assembly, and still produce dimensions, marks, fabrication information, etc. for all assembly levels.

See also Adding objects to assemblies on page 91

**Adding parts to an assembly**

To add secondary parts to a basic assembly or to any level of a nested assembly:

1. Ensure that the Select objects in assemblies selection switch is active.
2. Select the part you want to add.
3. Right-click and select Assembly > Add to Assembly from the pop-up menu.
4. Select the assembly to add to.

See also Adding objects to assemblies on page 91

Creating a nested assembly

To create a nested assembly:

1. Ensure that the Select assemblies selection switch is active.
2. Select the assemblies you want to add to another assembly. They will become sub-assemblies in the nested assembly.
3. Right-click and select Assembly > Add as sub-assembly from the pop-up menu.
4. Select the assembly to add to.

See also Adding objects to assemblies on page 91

Joining assemblies

To join existing assemblies without adding any loose parts:

1. Ensure that the Select assemblies selection switch is active.
2. Select the assemblies you want to join.
3. Right-click and select Assembly > Make into Assembly from the pop-up menu.
   The assembly with the largest volume becomes the main assembly.

See also Changing the main assembly on page 95
Adding objects to assemblies on page 91

Changing the assembly main part

The main part in a steel assembly has other parts welded or bolted to it. By default, the main part is not welded or bolted to any other parts. You can change the main part in an assembly.

To change the main part in an assembly:

1. Check what is currently the main part of the assembly.
   a. Ensure that the Select assemblies selection switch is active.
   b. Click Tools --> Inquire --> Assembly Objects.
   c. Select the assembly.
      Tekla Structures highlights the main part in orange and the secondary parts in yellow.
2. Ensure that the Select objects in assemblies selection switch is active.
3. Click **Modeling --> Assembly --> Set as New Main Object of Assembly**.
4. Select the new main part.

Tekla Structures changes the main part.

**See also** Adding objects to assemblies on page 91
Highlighting objects in an assembly on page 95

**Changing the main assembly**
When you join two or more assemblies together, the assembly with the largest volume becomes the main assembly. You can change the main assembly at any time.

To change the main assembly in a nested assembly:
1. Select the new main assembly.
2. Right-click and select **Assembly --> Set as New Main Sub-Assembly** from the pop-up menu.

**See also** Adding objects to assemblies on page 91

**Removing objects from an assembly**
To remove objects from an assembly:
1. Select the part or sub-assembly you want to remove.
2. Right-click and select **Assembly > Remove from Assembly** from the pop-up menu.

**See also** Creating assemblies on page 88

**Highlighting objects in an assembly**
Use the **Inquire** tool to check which objects belong to a particular assembly.

To highlight objects in an assembly:
1. Click **Tools --> Inquire --> Assembly Objects**.
2. Select a part that belongs to an assembly.

Tekla Structures highlights the other parts that belong to the same assembly. The following colors are used:

<table>
<thead>
<tr>
<th>Object type</th>
<th>Highlight color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete - main part</td>
<td>magenta</td>
</tr>
</tbody>
</table>
Exploding an assembly

When you explode a nested assembly, Tekla Structures breaks the assembly hierarchy level by level, always starting from the highest level. You need to use the **Explode** command several times to break a nested assembly back to single parts.

You can also explode sub-assemblies to single parts without breaking the entire assembly hierarchy.

To explode an assembly:

1. Select the assembly or sub-assembly you want to explode.
2. Do one of the following:
   - To explode the entire assembly, right-click and select **Assembly > Explode** from the pop-up menu.
   - To only explode the sub-assembly, right-click and select **Assembly > Explode Sub-Assembly** from the pop-up menu.

See also  Creating assemblies on page 88

Assembly examples

**Column corbel**

A column corbel is fabricated in one workshop, and then attached to the column in another workshop. Model the corbel as a sub-assembly of the column. Then create an assembly drawing for each workshop: one assembly drawing showing how the corbel is welded together, another assembly drawing showing how the corbel and the other part are welded to the column.
Model the halves of a complex truss as assemblies. Create assembly drawings for the workshop to fabricate the truss halves. Then create another assembly drawing showing how the halves should be joined on site.

In a frame of built-up columns and beams, each built-up profile can be a sub-assembly. You can create an assembly drawing showing the entire frame, and separate drawings showing how the columns and beams are constructed.

See also Creating assemblies on page 88
4.6 Creating cast units

This section explains how to create cast units.

By default, each concrete part is considered a separate cast unit. For construction purposes, you may need to merge several concrete parts into one cast unit. For example, a single cast unit could consist of a column with corbels.

Click the links below to find out more:

- Defining the cast unit type of a part on page 98
- Creating a cast unit on page 99
- Adding objects to a cast unit on page 99
- Changing the cast unit main part on page 99
- Removing objects from a cast unit on page 100
- Highlighting objects in a cast unit on page 100
- Exploding a cast unit on page 101
- Casting direction on page 101

Defining the cast unit type of a part

You must define the cast unit type of concrete parts. Tekla Structures checks the cast unit type of the main part each time you create or modify a cast unit. Precast and cast-in-place parts cannot be mixed within a cast unit.

To define the cast unit type of a concrete part:

1. Double-click a concrete part to open the part properties dialog box.
2. Go to the Cast unit tab.
3. In the Cast unit type list, select one of the following:
   - Cast in place
     Cast units that are constructed fully in their final location.
   - Precast
     Cast units that are built at another location and transported to their final location for placement in the full structure.
4. Click Modify to save the changes.

It is important to use the correct cast unit type, because some functionalities, for example numbering, are based on the cast unit type.

See also Creating cast units on page 97
Creating a cast unit

You need to specify which parts form the cast unit. Cast units can include reinforcement, as well as concrete parts.

To create a cast unit:
1. Click **Modeling** --> **Cast Unit** --> **Create**.
2. Select the objects you want to include in the cast unit.
3. Click the middle mouse button to create the cast unit.

See also  Creating cast units on page 97

Adding objects to a cast unit

You can use different methods to add objects to cast units. The available methods depend on the objects’ material and on the hierarchy you want to create in the cast unit.

To add an object to a cast unit, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
<th>Available for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add an object as a</td>
<td>1. Click <strong>Modeling</strong> --&gt; <strong>Cast Unit</strong> --&gt;</td>
<td>Concrete, timber, miscellaneous</td>
</tr>
<tr>
<td>secondary part</td>
<td><strong>Add to</strong>.</td>
<td>materials</td>
</tr>
<tr>
<td></td>
<td>2. Select the object you want to add.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3. Select an object in the cast unit.</td>
<td></td>
</tr>
<tr>
<td>Add an object as a</td>
<td>1. If you are adding a custom part, ensure</td>
<td>Steel, concrete, timber,</td>
</tr>
<tr>
<td>sub-assembly</td>
<td>that the <strong>Select components</strong> selection</td>
<td>miscellaneous materials</td>
</tr>
<tr>
<td></td>
<td>switch is active.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Modeling</strong> --&gt; <strong>Assembly</strong> --&gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Add as Sub-Assembly</strong>.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3. Select the object you want to add.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>4. Select the cast unit to which you want</td>
<td></td>
</tr>
<tr>
<td></td>
<td>to add the object.</td>
<td></td>
</tr>
</tbody>
</table>

See also  Creating cast units on page 97

Changing the cast unit main part

The *main part* in a concrete cast unit is the one with the largest volume of concrete. You can change the main part in a cast unit.

To change the main part in a cast unit:
1. Check what is currently the main part of the cast unit.
   a. Ensure that the **Select assemblies** selection switch is active.
   b. Click **Tools --> Inquire --> Assembly Objects**.
   c. Select the cast unit.

   Tekla Structures highlights the main and secondary parts in different colors.

2. Ensure that the **Select objects in assemblies** selection switch is active.

3. Select the new main part.

4. Right-click and select **Set as New Main Part of Assembly** from the pop-up menu.

**See also**  
Adding objects to a cast unit on page 99  
Highlighting objects in a cast unit on page 100  

---

**Removing objects from a cast unit**

To remove objects from a cast unit:

1. Click **Modeling --> Cast Unit --> Remove From**.

2. Select the objects you want to remove.

**See also**  
Creating cast units on page 97  

---

**Highlighting objects in a cast unit**

Use the **Inquire** tool to check which objects belong to a particular cast unit.

To highlight objects in a cast unit:

1. Click **Tools --> Inquire --> Assembly Objects**.

2. Select a part that belongs to a cast unit.

   Tekla Structures highlights the other parts that belong to the same cast unit. The following colors are used:

<table>
<thead>
<tr>
<th>Object type</th>
<th>Highlight color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete - main part</td>
<td>magenta</td>
</tr>
<tr>
<td>Concrete - secondary part</td>
<td>cyan</td>
</tr>
<tr>
<td>Reinforcement</td>
<td>blue</td>
</tr>
<tr>
<td>Steel part - main part</td>
<td>orange</td>
</tr>
<tr>
<td>Steel part - secondary part</td>
<td>yellow</td>
</tr>
</tbody>
</table>

**See also**  
Creating cast units on page 97
Exploding a cast unit

To explode a cast unit:

1. Click **Modeling --> Cast Unit --> Explode**.
2. Select an object in the cast unit you want to explode.

See also  Creating cast units on page 97

Casting direction

To indicate the casting direction of a concrete part, you can define which part face you want to have on top of the casting form. The top-in-form face is displayed in the front view of a drawing.

The casting direction affects the numbering of concrete parts. If you define the casting direction for parts that differ only by their modeling direction, they get different position numbers. This is because the modeling direction affects the top-in-form face of the parts. By default, the casting direction of the parts is undefined, which means the modeling direction does not affect numbering.

In drawings, use the **Fixed** coordinate system to show the top-in-form face in the front view.

Example

In the following example, each cast unit gets a different position number, because the top-in-form setting and the orientation of the panels is different. The red arrow indicates the modeling direction.
In the following example, the cast units get the same position number, because their top-in-form setting has not been defined. The red arrow indicates the modeling direction.

See also  
Creating cast units on page 97  
Defining the casting direction of a part on page 102  
Numbering the model on page 203

**Defining the casting direction of a part**

To define the casting direction of a concrete part:

1. Set the representation of parts to Rendered by doing one of the following:
   - Click View --> Representation --> Parts --> Rendered.
   - Press Ctrl + 4.
2. Select a concrete part.
3. Right-click and select Cast Unit --> Set Top in Form Face.
4. Select the part face that will face upwards in the form.

See also  Casting direction on page 101

**Showing the top-in-form face**

To display the top-in-form face of a concrete part:

1. Click Modeling --> Cast Unit --> Show Top in Form Face.
2. Click the concrete part whose top-in-form face you want to show.
Tekla Structures highlights the top-in-form face in red:

To hide the top-in-form face again, right-click the view and select **Update Window** from the pop-up menu.

**See also**  [Casting direction on page 101](#)
5  Modifying parts

This section explains how to modify different part properties, such as shape, position and length of a part. It also explains how to split and combine parts, and how to use the deforming options to warp and camber parts.

Click the links below to find out more:

• Modifying the part properties on page 104
• Modifying the position of a part on page 105
• Modifying the shape of a part on page 106
• Modifying the length of a part on page 108
• Changing the profile of a part on page 109
• Changing the material of a part on page 111
• Splitting parts on page 112
• Combining parts on page 113
• Attaching parts on page 114
• Warping concrete parts on page 116
• Cambering parts on page 118

5.1 Modifying the part properties

To modify the part properties:

1. Double-click a part to open the part properties dialog box.

2. To indicate which properties should be changed, select or clear the desired check boxes.
For example, if you want some steel parts to share the same name but do not want to change any of their other individual properties, ensure that only the Name check box is selected.

Click [✓/✗] to switch all check boxes on or off.

3. Modify the properties.
4. Select the parts you want to modify.
5. Click Modify.

See also Part properties on page 241

5.2 Modifying the position of a part

To modify the position of a part, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Modify part position in the part properties dialog box | 1. Double-click a part to open the part properties dialog box.  
2. On the Position tab, modify the desired position settings.  
   For example, you can define the part to be positioned 200 units above its handles.  
3. Click Modify.  |
| Modify part position using the Mini Toolbar   | 1. Click [ buttoon in the Mini Toolbar.  
2. Modify the settings. The object moves in the model accordingly.  
   • To change the overall position of the part, use the round selection dial. Click a sector in the dial to select a position.  
   • To change the rotation angle, click and drag the green rotation angle knob. |

Modifying the position of a part
To change the **Angle, Plane offset, or Depth offset**, enter a value in the corresponding box.

The rotation angle knob snaps to every 45 degrees. Hold down **Shift** to override this.

---

**See also**  
Part position settings on page 254  
Tips for creating and positioning parts on page 284

### 5.3 Modifying the shape of a part

You can modify the shape of a part by dragging the part corners, edges, and surfaces, and by changing the part dimensions.

To modify the shape of a part:

1. Ensure that the **Direct modification** switch is active.
2. Select the part.

   Tekla Structures displays the handles that you can use to modify the part. The relevant dimensions are shown when you move the mouse pointer slowly over the part edges.
3. Modify the shape by dragging any of the handles. For example:

When you drag a handle, hold down the Shift key to use the snap switches. By default, the snap switches are off to make it easier to drag the handle to any location.

4. To change a dimension, drag the relevant dimension arrowhead to a new location, or:
   a. Select the dimension arrowhead which you want to move.
      To change the dimension at both ends, select both arrowheads.
   b. Using the keyboard, enter the value with which you want the dimension to change.
      To start with the negative sign (-), use the numeric keypad.
      To enter an absolute value for the dimension, first enter $, then the value.
   c. Press the Enter key, or click OK in the Enter a Numeric Location dialog box.

5. To display more modification options, right-click one of the handles.

The handle toolbar appears:

Use it to add a new point at a polybeam end, show and hide diagonal dimensions and midpoint handles, and set a handle to move in one or two directions.

6. To delete a handle, select it and press the Delete key.

See also  Modifying parts on page 104

Modifying the shape of a polygon
You can modify the shape of the following polygonal parts: steel and concrete polybeams, contour plates, concrete slabs, concrete panels, and strip footings.

To modify the shape of a polygonal part:
1. Select the part you want to modify.
2. Click **Detailing --> Modify Polygon Shape**.
3. Pick an existing corner (1).
4. Pick new corners for the polygon (2, 3).
5. Pick another existing corner (4).
6. Pick the corner to remove (5).

Alternatively, move the handles using drag-and-drop or the **Move** command.

See also

*Part handles on page 69*

### 5.4 Modifying the length of a part

To modify the length of a part:

1. Select the part.
   
   Tekla Structures highlights the handles of the part.
2. Click one of the handles to select it.
3. Move the handle like any other object in Tekla Structures.
   
   For example, right-click and select **Move**.
Do not use cuts or fittings to change the length of a part, for the following reasons:

- Cuts may cause shop errors, because cuts do not always affect part length when you export information to NC files.
- Fittings may cause problems with connections and details.

See also  Part handles on page 69

### 5.5 Changing the profile of a part

When you create or modify a part, you can select the profile from a list that contains all the profiles available in the profile catalog.

To change the profile of a part:

1. Double-click a part to open the part properties dialog box.
2. Click **Select...** next to the **Profile** box.
   - The **Select Profile** dialog box appears.
   - By default, only the profile types that are relevant to the material of the part are shown.
3. If needed, define what profile information you want to see.
   - To display all the profiles of the profile catalog in the list, select the **Show all profiles** check box.
   - To see all the properties of profiles, select the **Show details** check box.
4. Select a profile from the list.
5. If the profile is parametric, define its dimensions on the **General** tab.
   - ![Property Table]
   - Click the **Value** box and replace the existing value with a new one.
6. Click **OK** to close the **Select Profile** dialog box.
7. Click **Modify**.

```markdown
<table>
<thead>
<tr>
<th>Property</th>
<th>Symbol</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Height</td>
<td>h</td>
<td>300.00</td>
<td>mm</td>
</tr>
<tr>
<td>Web thickness</td>
<td>s</td>
<td>15.00</td>
<td>mm</td>
</tr>
<tr>
<td>Flange thickness</td>
<td>t</td>
<td>20.00</td>
<td>mm</td>
</tr>
<tr>
<td>Width</td>
<td>b</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

---

Modifying parts 109 Changing the profile of a part
Alternatively, if you know the name of the profile, you can enter it directly in the appropriate box in the part properties dialog box.

See also Using standardized values for profile dimensions on page 110

Associating profile types with a certain material

Using standardized values for profile dimensions

You can use standardized values for the dimensions of parametric profiles.

To use standardized values for profile dimensions:

1. Double-click a part to open the part properties dialog box.

2. Click the Select... button to open the Select Profile dialog box.

3. Select a parametric profile.

   If standardized values have been defined for this profile, the Use industry standardized values only check box appears on the General tab under the profile properties:

4. Select the Use industry standardized values only check box.
5. Select the profile dimensions from a list in the Value column.

See also

5.6 Changing the material of a part

When you create or modify a part, you can select the material and grade from a list that contains all the materials available in the material catalog.

To change the material of a part:

1. Double-click a part to open the part properties dialog box.
2. Click Select... next to the Material box.
   The Select Material dialog box appears.
3. If needed, define what material information you want to see.
   • To include aliases for material grades in the list, select the Show aliases check box.
   • To see all the properties of materials, select the Show details check box.
4. Select a material from the list.
5. Click OK to close the Select Material dialog box.
6. Click Modify.

Alternatively, if you know the name of the material, you can enter it directly in the Material box in the part properties dialog box.

See also

5.7 Changing the shape of an item

When you create or modify an item, you can select the shape from the list that contains all the shapes available in the shape catalog.

Before you start, ensure that you have the required shape imported to the shape catalog.

To change the shape of an item:

1. Double-click an item to open the item properties dialog box.
2. Click Select next to the Shape box to open the Shape Catalog dialog box.
3. If needed, use the Filter box to search for a shape.
4. Select a shape from the list.
5. Click OK to close the Shape Catalog dialog box.
6. Click **Modify**.

**See also** Importing a shape

*About items on page 73*

### 5.8 Splitting parts

Use splitting to split a part into two. You can use splitting with straight parts, polybeams and curved beams without offsets, and normal and tapered reinforcing bar groups. You can also split plates and slabs by using a polygon.

Click the links below to find out more:

- [Splitting a straight or curved part or polybeam](#) on page 112
- [Splitting a plate or slab](#) on page 112

#### Splitting a straight or curved part or polybeam

To split a straight or curved part or polybeam:

1. Click **Edit --&gt; Split**.
2. Select the part you want to split.
3. Pick a point for the dividing line.
4. If you split a polybeam, check that the following are correct:
   - The position and orientation settings of the split polybeams
   - The components related to the split polybeams

**See also** [Splitting parts](#) on page 112

#### Splitting a plate or slab

To split a plate or slab by using a polygon:

1. Ensure that the Z axis is perpendicular to the plate or slab you want to split.
2. Click **Edit --&gt; Split**.
3. Select the part you want to split.
4. Pick positions to outline the polygon to be used for splitting.
5. Click the middle mouse button to close the polygon and to split the part.
When you pick the corner points of the polygon to be used for splitting, make sure the starting and end points are:

- outside of the part, and
- on the same side of the part.

If you split contour plates that have bolts, welds or surface treatments, check the result after splitting.

See also  [Splitting parts on page 112](#)

### 5.9 Combining parts

You can combine two parts into one. This can be useful when you want to model complex parts (such as folded plates) that are otherwise difficult to model, or when you want to model prefabricated parts that are delivered to the workshop already attached to profiles.

To combine two parts into one:

1. Click **Edit --> Combine**.
2. Select the first part.
   
   The properties of the first selected part will be used for the combined part.
3. Select the second part.
   
   The parts are combined into one.

   If the center lines of the parts are not in line with each other, Tekla Structures combines them by taking the largest distance between the start and end points from both parts.

   For example:
Limitations

- Combining does not work for contour plates, polybeams or slabs.
- When you combine parts, Tekla Structures retains the attached objects and connections. Tekla Structures does not recreate connections in the part that was selected first.

See also  Attaching parts on page 114

5.10 Attaching parts

When you attach parts, the attached parts do not need to touch the part they are attached to.

When you modify the properties of attached parts, note that some of the part properties are taken from the main part. These properties are not shown in the properties of the attached part. You can inquire the properties of the whole part and the properties of each attached part separately. The attached parts are taken into account when calculating area, volume, and weight:

- **Weight (Gross)** compares the weight with fittings and without fittings, and shows the biggest weight result without cuts and with attached parts.
- **Weight (Net)** shows the weight with cuts and attached parts based on the geometry volume of the modeled part.
- **Weight** shows the net weight.

You can use the Attach to Part command to have more than 100 corner points in a polygon plate. Each plate has a maximum number of corner points. When you attach plates, the corner points of all the plates are summed up, that is, the maximum number of points in the whole part is \( \text{number of plates} \times \text{maximum number of points} \).

Limitations

- Connections must be added to the part to which other parts have been attached. You cannot add connections to an attached part.
- All reinforcement components may not work correctly with parts that have been attached to each other using the Added Material commands. The geometry of the parts is not always kept suitable for adding a component. For example, the reference points of the attached part may be lost and therefore the orientation information needed for adding the reinforcement is not known anymore.

To ensure that the reinforcements work correctly, add them manually or use the Reinforcing Bar Shape Catalog to place them.

See also  Attaching a part to another part on page 114
Detaching an attached part on page 115
Exploding attached parts on page 115
Attaching a part to another part

To attach a part to another part:
1. Click **View** --> **View Properties**... --> **Display**... and ensure that the **Cuts and added material** option is selected in the display settings.
2. Click **Detailing** --> **Added Material** --> **Attach to Part**.
3. Select the part to attach to.
4. Select the part you want to attach.
   You can attach more than one part at a time. The parts that are attached do not need to touch the part to which they are attached.
5. Click the middle mouse button to attach the part.

See also  
**Attaching parts on page 114**
**Showing the attached parts on page 291**

Detaching an attached part

To detach an attached part:
1. Click **View** --> **View Properties**... --> **Display**... and ensure that the **Cuts and added material** option is selected in the display settings.
2. Click **Detailing** --> **Added Material** --> **Detach from Part**.
3. Select the attached part you want to detach.
   You can detach more than one part from several different parts at a time. Select the parts either by clicking them or by using area selection.
4. Click the middle mouse button to detach the part.
   The detached part keeps the color it had as an attached part.

See also  
**Attaching parts on page 114**
**Showing the attached parts on page 291**

Exploding attached parts

To explode a part that has attached parts:
1. Click **View** --> **View Properties**... --> **Display**... and ensure that the **Cuts and added material** option is selected in the display settings.
2. Click **Detailing** --> **Added Material** --> **Explode Part**.
3. Select the part you want to explode.
4. Click the middle mouse button to explode the part.

See also  Attaching parts on page 114
Showing the attached parts on page 291

5.11  Warping concrete parts

You can warp concrete beams and slabs. The warping functionality is available only in the Full, Precast Concrete Detailing, and Steel Detailing configurations.

Click the links below to find out more:
- Warping a concrete beam using deformation angles on page 116
- Warping a concrete slab by moving chamfers on page 117
- Warping a Floor Bay (66) slab on page 117

Warping a concrete beam using deformation angles

To warp a concrete beam:
1. Double-click a concrete beam to open the Concrete Beam Properties dialog box.
2. Go to the Deforming tab.
3. In the Start box, enter the angle of the beam at its start point, relative to the part handles.
4. In the End box, enter the angle of the beam at its end point, relative to the part handles.
   For example, to warp the beam 45 degrees at the end point, enter 0 in the Start angle box and 45 in the End angle box.
5. Click Modify to warp the beam.
6. Click OK to close the dialog box.
Warping a concrete slab by moving chamfers

Before you start, create a concrete slab by using the Create concrete slab command.

To warp a concrete slab by moving the chamfers:
1. Double-click a chamfer to open the Chamfer Properties dialog box.
2. Modify the chamfer properties.
   - To move the upper corner of the chamfer, use the $dz1$ box.
   - To move the lower corner of the chamfer, use the $dz2$ box.
3. Click Modify to warp the slab.
4. Click OK to close the dialog box.

See also Warping concrete parts on page 116

Warping a Floor Bay (66) slab

Before you start, create a concrete slab by using the component.

To warp a Floor Bay (66) slab by moving chamfers:
1. Ensure that the Select components selection switch is on.
2. Select the chamfer you want to move.
   For example, select the corner point of a slab component to warp that end of the slab:
3. Right-click and select **Move Special --> Linear** from the pop-up menu.

4. In the **Move – Linear** dialog box, enter a value in the appropriate direction box. For example, enter **100** in the **dZ** box to lift that corner up 100 mm.

5. Click **Move**.

   Tekla Structures moves the point in the direction you selected, which warps the slabs.

6. Right-click and select **Interrupt** from the pop-up menu to finish.

7. Ensure that the **Select objects in components** selection switch is on.

8. To see the warping angle of a single slab, double-click a slab to open the **Beam properties** dialog box, and go to the **Deforming** tab.
   - The **Start** box shows the warping angle at the start point of the part.
   - The **End** box shows the warping angle at the end point of the part.

**See also** *Warping concrete parts on page 116*

---

### 5.12 Cambering parts

You can use cambering to pre-camber parts, in other words, to curve long heavy sections that will settle on site and become flat. Use cambering to show the natural camber of a prestressed part in a model. Cambering affects the position of cuts, skews, and embeds in the model.

To camber a part:

1. Double-click a part to open the part properties dialog box.
2. Go to the **Deforming** tab.
3. In the **Cambering** box, define the degree of camber.
4. Click **Modify**.
Tekla Structures cambers the part in the local z direction.
This section explains how to create details using Tekla Structures. It also gives you some techniques for fine-tuning the part shape.

Click the links below to find out more:

- Creating bolts on page 120
- Creating holes on page 125
- Welding parts on page 128
- Fitting parts on page 135
- Cutting parts on page 136
- Chamfering parts on page 139
- Adding surface treatment on page 142

6.1 Creating bolts

To create bolts, you can either create a single bolt group or apply a component that automatically creates bolt groups.
You can create different part marks for holes and bolts in drawings.

Tekla Structures uses the same command for creating bolts and holes. Therefore you cannot use bolt elements (such as screws, washers, and nuts) while creating holes.

See also  
Creating a bolt group on page 121  
Creating a single bolt on page 121  
Creating bolts using the auto bolt tool on page 122  
Creating bolts by modifying an existing bolt group on page 291  
Changing or adding bolted parts on page 125

Creating a bolt group

To create a bolt group:

1. Click Detailing --> Bolts --> Create Bolts.
2. Select the main part, to which the secondary parts will be bolted.
3. Select the secondary parts.
4. Click the middle mouse button to finish selecting parts.
5. Pick a point to indicate the bolt group origin.
6. Pick a second point to indicate the bolt group direction on the x axis.

Tekla Structures determines the location of the bolt group using the following values: the bolt group x axis and the work plane. Dimensions are relative to the bolt group origin, which is the first point picked. Tekla Structures sets the x direction of the bolt group using the second point picked. It is important that the points you pick to create the bolt group are close enough to the parts you want to connect.

See also  
Bolt properties on page 262

Creating a single bolt

To create a single bolt:

1. Click Detailing --> Properties --> Bolt... to open the Bolt Properties dialog box.
2. Under Bolt group, select Array from the Shape list.
3. In the Bolt dist X and Bolt dist Y boxes, enter 0.
4. Click Apply to save the changes.
5. Create the bolt the same way you would create a bolt group:
a. Click Detailing --> Bolts --> Create Bolts.
b. Select the main part, to which the secondary parts will be bolted.
c. Select the secondary parts.
d. Click the middle mouse button to finish selecting parts.
e. Pick a point to indicate the bolt origin.
f. Pick a second point to indicate the direction on the x axis.

See also  Creating bolts on page 120
Bolt properties on page 262

Creating bolts using the auto bolt tool
Use the Auto bolt modeling tool to bolt parts and nearby parts, shim plates, splice plates, or other plates. Auto bolt follows the part rotation and finds the best rotation so that you do not need to set the work plane. With Auto bolt one bolt group can span many parts, for example, manage a splice as a single group.

To create bolts using Auto bolt:
1. Open the Auto bolt modeling tool from the Component Catalog.
2. Define the bolt properties.
3. If needed, use the Show cut length as temporary lines option to view where the bolts should be placed even if they are not created.
   • Select to not show the temporary lines.
   • Select to show the temporary lines.
   To delete the temporary lines, right-click the view and select Redraw View.
4. Click Apply.
5. Select the main part. Auto bolt uses this part to identify the best rotation. This part will be the main part of the assembly.
6. Select the secondary part.
7. Click the middle mouse button.
8. Pick the first and the second position to define the bolt group direction.
The bolt group is created automatically when you pick the second position. The bolts are automatically split into separate bolt groups.

Examples
Examples of parts bolted using the Auto bolt modeling tool are shown below. The main parts and the selected points are highlighted.
Detailing parts

Creating bolts
Changing or adding bolted parts

To change the parts a bolt group connects to:

1. Click **Detailing --> Bolts --> Edit Bolted Parts**.
2. Select the bolt group.
3. Reselect the main and secondary parts.

Tekla Structures automatically updates bolt length to suit these changes.

See also **Creating bolts on page 120**

### 6.2 Creating holes

You can create the following types of holes:

- Round
- Oversized
- Slotted
- Tapped

See also **Creating bolts on page 120**
Note that Tekla Structures uses the same command for creating bolts and holes. Before creating holes, you need to change some of the properties in the Bolt Properties dialog box. If you want to create only holes without any bolts, clear all the Include in bolt assembly check boxes:

Creating round holes

Tekla Structures calculates the diameter of a round hole as the sum of Bolt size and Tolerance.

To create a group of round holes:

1. Click Detailing --> Properties --> Bolt... to open the Bolt Properties dialog box.
2. If you do not want to create any bolts, clear all the Include in bolt assembly check boxes.
3. If needed, modify the hole properties.
4. Click Apply to save the changes.
5. Create the holes the same way you would create a bolt group:
   a. Click Detailing --> Bolts --> Create Bolts.
   b. Select the main part, to which the secondary parts will be bolted.
   c. Select the secondary parts.
   d. Click the middle mouse button to finish selecting parts.
   e. Pick a point to indicate the hole group origin.
   f. Pick a second point to indicate the hole group direction on the x axis.

See also  Creating round holes on page 126
Creating oversized holes on page 126
Creating slotted holes on page 127

See also  Creating holes on page 125
Creating oversized holes

To create a group of oversized holes:

1. Click Detailing --> Properties --> Bolt... to open the Bolt Properties dialog box.
2. Select the desired Parts with slotted holes check boxes to indicate which plies of the connection get oversized holes.
3. If you do not want to create any bolts, clear all the Include in bolt assembly check boxes.
4. In the Hole type list, select Oversized.
5. In the Oversize box, enter the allowance for the oversized hole.
   You can also use a negative value to create smaller (tapped) holes.
6. Click Apply to save the changes.
7. Create the holes the same way you would create a bolt group:
   a. Click Detailing --> Bolts --> Create Bolts.
   b. Select the main part, to which the secondary parts will be bolted.
   c. Select the secondary parts.
   d. Click the middle mouse button to finish selecting parts.
   e. Pick a point to indicate the hole group origin.
   f. Pick a second point to indicate the hole group direction on the x axis.

See also Creating holes on page 125

Creating slotted holes

To create a group of slotted holes:

1. Click Detailing --> Properties --> Bolt... to open the Bolt Properties dialog box.
2. To indicate which parts should be slotted, select the desired Parts with slotted holes check boxes.
   Tekla Structures counts the pieces of steel from the head of the bolt down. For example, if you select the second check box from the head of the bolt, Tekla Structures slots the second piece of steel from the head of the bolt.
3. If you do not want to create any bolts, clear all the Include in bolt assembly check boxes.
4. In the Hole type list, select Slotted.
5. Enter the allowance for the slotted hole in the x and y directions of the hole group using the Slotted hole X or Slotted hole Y boxes.
6. If you want to rotate alternate holes by 90 degrees, select Even or Odd in the Rotate slots list.

7. Click Apply to save the changes.

8. Create the holes the same way you would create a bolt group:
   a. Click Detailing --> Bolts --> Create Bolts.
   b. Select the main part, to which the secondary parts will be bolted.
   c. Select the secondary parts.
   d. Click the middle mouse button to finish selecting parts.
   e. Pick a point to indicate the hole group origin.
   f. Pick a second point to indicate the hole group direction on the x axis.

See also Creating holes on page 125
     Creating a bolt group on page 121
6.3 Welding parts

You can either create a weld manually, or use a component that automatically creates welds. By default, Tekla Structures places the welds above line according to the ISO standard. You can change this to below line to comply with the AISC standard with the advanced option.

See also
- Setting the visibility and appearance of welds on page 129
- Creating a weld between parts on page 130
- Creating a polygon weld on page 130
- Creating a weld to a part on page 131
- Weld preparation on page 132
- Changing a weld to a polygon weld on page 134
- Weld properties on page 266

Setting the visibility and appearance of welds

Modify the display settings to define how welds appear in the model.

To set the visibility and appearance of welds:

1. Double-click the view to open the View Properties dialog box.
2. Click Display... to open the Display dialog box.
3. Ensure that the Welds check box is selected.
4. Select a representation option for welds:
   - Fast
     Use this option to show the weld marks only.

   ![Fast weld representation](image1)

   - Exact
     Use this option to show welds as solid objects.

   ![Exact weld representation](image2)

5. Ensure that the view is being selected.
6. Click **Modify** to apply the changes.

If the representation option is **Exact** and you still cannot see the weld object in the model, check that the following properties have been defined for the weld in question:

- Size
- Type
- Angle
- Root opening

---

**Creating a weld between parts**

Weld two parts together using the weld position defined in the **Weld Properties** dialog box. The length of the weld depends on the length of the connection between the welded parts.

To weld parts together:

1. Click **Detailing --> Weld --> Create Weld between Parts**.

2. Select the part to weld to.
   
   If you are creating a workshop weld, this is the main part of the assembly.

3. Select the part to be welded.
   
   If you are creating a workshop weld, this is the secondary part of the assembly.

---

**See also**  
Weld properties on page 266

Using welds to create assemblies on page 90
Creating a polygon weld
Create polygon welds when you want to define the exact position of the weld by picking the points you want the weld to traverse.

To weld parts together using a polygon:
1. Click Detailing --> Weld --> Create Polygon Weld.
2. Select the part to weld to.
   If you are creating a workshop weld, this is the main part of the assembly.
3. Select the part to be welded.
   If you are creating a workshop weld, this is the secondary part of the assembly.
4. Pick the starting and end point, or alternatively, pick the points you want the weld to go through.
5. Click the middle mouse button to create the weld.

See also
- Weld properties on page 266
- Using welds to create assemblies on page 90

Creating a weld to a part
You can create a weld to a single part, without connecting any other parts.

To create a weld to a single part:
1. Click Detailing --> Weld --> Create Weld to Part.
2. Select the part that you want to weld.
3. Pick the starting and end point, or alternatively, pick the points you want the weld to go through.
4. Click the middle mouse button to create the weld.

Example
Use the Create Weld to Part command to weld seams in tubular sections:
To model tubular sections with visible seams, use the SPD profile.

See also  Weld properties on page 266

Weld preparation

When parts are prepared for welding, their edges can be beveled to produce a groove for the weld. You can define the angle of bevels and grooves.

You can either prepare a part for welding manually, or apply a component that does it automatically, or you can use the Preparation options in the Weld Properties dialog box or in the component weld properties.

See also  Welding parts on page 128
Prepar[ing a part for welding with a polygon on page 132
Preparing a part for welding with another part on page 133
Welded connections
Weld properties on page 266

Preparing a part for welding with a polygon

You can manually prepare a part for welding by cutting it with a polygonal shape.

Before you start, ensure that the work plane is on the plane you are cutting on.

To manually prepare a part to be welded:
1. Click Detailing --> Weld --> Prepare Part for Welding --> With Polygon .
2. Select the part that you want to cut.
3. Pick positions to outline the polygon to be used for cutting.
   Extend the polygon outside the part, so that it is clear that the part edge should be cut away.
4. Click the middle mouse button to close the polygon and to cut the part.
Before you start, create a cutting part and position it through the part you want to cut.

To manually prepare a part to be welded:

1. Click Detailing --> Weld --> Prepare Part for Welding --> With Another Part.
2. Select the part that you want to cut.
3. Select the cutting part.

See also
- Weld preparation on page 132
- Preparing a part for welding with another part on page 133

Preparing a part for welding with another part
You can manually prepare a part for welding by cutting it with another part. The cutting part will subsequently be deleted.

Cuts are displayed using dash-and-dot lines
Changing a weld to a polygon weld
You can change existing welds to polygon welds if the existing welds have been created by using the Create Weld between Parts command or by a component. The new polygon welds will traverse the same points as the original welds did.

To change a weld to a polygon weld:
1. Select the weld you want to change.
   To select multiple welds, hold down the Ctrl or Shift key.
2. Click Detailing --&gt; Weld --&gt; Convert to Polygon Weld.

See also Creating a weld between parts on page 130
Creating a polygon weld on page 130

User-defined weld cross sections
You can define special cross sections for welds. This is useful when you need weld cross sections that are not predefined in Tekla Structures.

For example, you can create bevel backing welds:

To find the welds in the model that have a user-defined cross section, set Category to Weld and Property to User-defined cross section in the selection or view filter, or in the color and transparency settings.

Limitations
• User-defined weld cross sections are reported using only the above-line properties.
• User-defined weld cross sections do not create automatic weld preparation.
Defining a user-defined cross section for a weld
You can define your own cross sections for model welds.

To define a cross section for a weld:
1. Select the weld you want to modify.
2. Right-click and select Define cross section from the pop-up menu.
3. In the weld cross section editor view:
   a. Pick points to indicate the weld cross section corners.
   b. Click the middle mouse button to finish picking.

Removing a user-defined cross section from a weld
You can remove user-defined cross sections from model welds and revert to the previous standard cross sections.

To remove a user-defined cross section from a weld:
1. Select a weld that has a user-defined cross section.
2. Right-click and select Remove cross section from the pop-up menu.
   Tekla Structures removes the user-defined cross section and uses the previous standard cross section and properties for the weld.

6.4 Fitting parts
You can fit the end of a part to a plane by creating a straight cutting line between two points you pick. You can use fittings to extend or shorten parts inside a component, which makes it easier to create connections, details, and so on. Do not use fittings to otherwise change the length of a part in the model.

To create a fitting:
1. Click Detailing --> Fit Part End.
2. Select the part you want to cut with a fitting.
3. Pick the first point of the cutting line.
4. Pick the second point of the cutting line.

Tekla Structures creates a fitting between the two points you picked. The fitting adjusts the end of a beam on a plane, perpendicular to the view plane.

Fitting symbol

Limitations
• Fittings cannot be used on contour plates.
• If you apply a second fitting on the same part end, Tekla Structures will ignore the first fitting.

See also  Modifying the length of a part on page 108

6.5 Cutting parts

You can use cuts to shape a part. Do not use cuts to otherwise change the length of a part in the model.

Click the links below to find out more:
• Cutting parts with a line on page 136
• Cutting parts with a polygon on page 137
• Cutting parts with another part on page 138

Cutting parts with a line

Use line cuts to shape the end of a beam or column. A line cut cuts the end of a beam on a plane that passes through the points you pick. Tekla Structures displays the cut line using dash-and-dot lines.

To cut a part with a line:
1. Click Detailing --> Cut Part --> With Line.
2. Select the part you want to cut.
3. Pick the first point of the cutting line.
4. Pick the second point of the cutting line.
5. Pick the side you want to remove.

Cuts are displayed using dash-and-dot lines
Cut lines can be hidden

See also  Cutting efficiently on page 282

Cutting parts with a polygon
A polygon cut cuts a part using a polygonal shape. Tekla Structures displays the cut using dash-and-dot lines.

To cut a part using a polygonal shape:
1. Press Ctrl+P to switch to the plane view.
2. Ensure that the work plane is on the plane you are cutting on.
   For example, if you are creating a polygonal cut on the yz plane, you should temporarily set your work plane to the yz plane as well.
3. Click Detailing --> Cut Part --> With Polygon .
4. Select the part you want to cut.
5. Pick positions to outline the polygon to be used for cutting.
   Define the polygon so that there is some tolerance between the edges. If the edge of a cutting polygon is in exactly the same position as the edge of the part to be cut, it can be unclear whether the edge should be cut away.
6. Click the middle mouse button to close the polygon and to cut the part.
You can cut a part using another part. Tekla Structures displays the cut using dash-and-dot lines. Note that you can cut parts that already have cuts. That can be useful, for example, when you want to create more sophisticated cut shapes.

To cut a part with another part:

1. Create a cutting part and position it through the part you want to cut.
2. Click Detailing --> Cut Part --> With Another Part.
3. Select the part you want to cut.

See also  Cutting efficiently on page 282
4. Select the cutting part.
   Tekla Structures cuts the selected main part. The part cut does not affect other parts.

5. Delete the cutting part.
   a. Ensure that the Select cuts and fittings selection switch is off.
   b. Select the cutting part and press Delete.

   ![](image1.png)
   ![image2.png]

   ① Cuts are displayed using dash-and-dot lines
   ② Cut lines can be hidden

**Limitations**
Do not create cuts with the same planes or vertices. Otherwise, it may be unclear what should be cut away.

**See also** Cutting efficiently on page 282

### 6.6 Chamfering parts

Chamfers are modeling details that can be used to refine the shape of parts for aesthetic, practical, and manufacturing reasons. In Tekla Structures, you can chamfer part corners and part edges.

**Limitations**
- Only the following parts have corner chamfers: contour plates, concrete slabs, strip footings, steel and concrete polybeams, and concrete panels.
- The end points of a part do not have corner chamfers. The handles that you select must be at corner points or between two segments of a part.

**See also**
- Chamfering part corners on page 139
- Status of polybeam chamfers on page 140
- Chamfering part edges on page 141
Chamfering part corners

When Tekla Structures creates a part, by default it has a rectangular chamfer at each corner, which does not change the geometry of the part. You can modify the default chamfers.

To modify a corner chamfer:
1. Select the part.
2. Double-click the handle of any part corner.
   The Chamfer Properties dialog box is displayed.
3. Modify the chamfer properties.
4. Select the handles of the part corners you want to modify.
5. Click Modify.

See also  Corner chamfer properties on page 272
Corner chamfer types and dimensions on page 272
Status of polybeam chamfers on page 140
Status of polybeam chamfers

Tekla Structures shows the status of polybeam chamfers using the following colors:

<table>
<thead>
<tr>
<th>Color</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
</table>
| Magenta| Correct chamfer                    | ![Magenta Example](image1)
| Yellow | Correct chamfer that cannot be unfolded | ![Yellow Example](image2) |
| Red    | Incorrect chamfer                  | ![Red Example](image3) |

To see the chamfer lines of polybeams, set the advanced option to **CHAMBERS**.

**See also** Chamfering part corners on page 139
Chamfering part edges

To chamfer the edge of a part:

1. Click Detailing --> Create Chamfer --> For Part Edge.
2. Select the part you want to chamfer.
3. Pick a point where you want the chamfer to start on the part edge.
4. Pick a second point where you want the chamfer to end on the part edge. Tekla Structures displays the chamfer in light blue.
5. If needed, you can modify the chamfer.
   a. Double-click the chamfer to open the Edge Chamfer Properties dialog box.
   b. Modify the chamfer properties.
   c. Click OK.
6. Right-click the view and select Redraw View. Tekla Structures removes the chamfered edge.

See also  Edge chamfer properties on page 273
Chamfering parts on page 139

6.7 Adding surface treatment

Use the surface treatment tools to add surface treatment to parts. Surface treatment for concrete parts include flat finishes, surface mixes, and tiles. Surface treatment for steel parts include fire-proofing and unpainted areas, for example. Surface treatments are visible only in rendered views.

When you modify the shape or size of a part, Tekla Structures automatically modifies the surface treatment to fit the part.
When you create overlapping surface treatments, the smaller surface treatment overrides the larger one. The overlapping area is recognized in reports: only the topmost (visible) surface treatment is calculated.

See also  
- Modifying surface treatment properties on page 143
- Adding surface treatment to parts on page 144
- Creating new surface treatment options on page 147
- Tiled surface treatment on page 148
- Creating an unpainted area using the no paint area tool on page 153

**Modifying surface treatment properties**

To define the properties of a surface treatment:

1. Click Detailing --> Properties --> Surface Treatment... to open the Surface Treatment Properties dialog box.
2. In the Type list, select the type of surface treatment to use.
3. In the Surface treatment name list, select the specific surface treatment.
4. Click the Select... to select a material from the catalog.
5. Enter the Thickness of the surface treatment.
6. Set the Color to use to display the surface treatment in rendered views.
7. In the At depth list, select the location of the surface treatment. The options are Middle, Front, and Behind.

8. If needed, define the properties of a tiled surface treatment:
   a. On the Attributes tab, select Tile surface from the Type list.
   b. On the Pattern tab, select the pattern from the Pattern type list.
   c. The Definition table lists the properties of the pattern type.

9. Click Apply or OK to save the surface treatment properties.

See also Adding surface treatment on page 142

Adding surface treatment to parts
This section explains how to add surface treatment to a part.

Click the links below to find out more:
- Adding surface treatment to a selected area on page 144
- Adding surface treatment to a part face on page 144
- Adding surface treatment to all faces of a part on page 145
- Adding surface treatment to cut faces on page 145
- Surface treatment on chamfered parts on page 146
- Surface treatment on parts with openings and recesses on page 146

Adding surface treatment to a selected area
To add surface treatment to a selected area on the face of a part:
1. Click Detailing --> Create Surface Treatment --> To Selected Area on Part Face.
3. Pick a point to indicate the direction of the surface treatment.
4. Select an area of the part face to apply the surface treatment to.
   a. Move the mouse pointer over a part. The part faces that you can select appear in blue.
   b. Select the part face.
   c. Pick three or more points on the part face to define a polygonal area.

See also Adding surface treatment to parts on page 144
    Modifying surface treatment properties on page 143
Adding surface treatment to a part face

To add surface treatment to the entire face of a part:
1. Click Detailing --> Create Surface Treatment --> To Part Face.
3. Pick a point to indicate the direction of the surface treatment.
4. Select the part to apply the surface treatment to.
   a. Move the mouse cursor over a part. The faces that you can select appear in blue.
   b. Select the part face.

See also  Adding surface treatment to parts on page 144
          Modifying surface treatment properties on page 143

Adding surface treatment to all faces of a part

To add surface treatment to all faces of a part:
1. Click Detailing --> Create Surface Treatment --> To All Faces of Part.
2. Select the part to apply the surface treatment to.

See also  Adding surface treatment to parts on page 144
          Modifying surface treatment properties on page 143

Adding surface treatment to cut faces

To add surface treatment to cut faces:
1. Click Detailing --> Create Surface Treatment, and then select either To Part Face or To Selected Area on Part Face.
3. Pick the direction.
4. Select the cut face to apply the surface treatment to:
5. If you are using the **To Selected Area on Part Face** command, pick the points to define the area of the surface treatment.

**See also**  
Adding surface treatment to parts on page 144  
Modifying surface treatment properties on page 143

**Surface treatment on chamfered parts**

Take these things into account when adding surface treatment to chamfered parts:

- Surface treatment does not work on sketched profiles with chamfers.
- Add surface treatment before chamfering the part. If surface treatment is applied to a chamfered part, the surface treatment chamfer cannot be modified later on.
- The chamfers for the main part and surface treatment are separate. Modifying the main part chamfer does not affect the surface treatment chamfer.
- The orientation of unsymmetric chamfers depends on the face where it was created (such as top, bottom, left, or right). To change the orientation of an unsymmetric chamfer, you must swap the chamfer's x and y values.

**See also**  
Adding surface treatment to parts on page 144
To force Tekla Structures to consider openings and recesses in parts when adding surface treatment, select the **Cut by father part cuts** check box in the **Surface Treatment Properties** dialog box.

The green surface treatment has the **Cut by father part cuts** check box selected.

The tiled surface treatment is not cut by the cut in the part: **Cut by father part cuts** is not selected.

If you use the **To All Faces of Part** command and select the **Cut by father part cuts** checkbox, Tekla Structures automatically adds surface treatment also to the cut faces.

**See also**  
Adding surface treatment to parts on page 144  
Modifying surface treatment properties on page 143

**Creating new surface treatment options**

This section is for advanced users.

You can add new options to the **Surface treatment name** list in the **Surface Treatment Properties** dialog box.

To create new surface treatment options:
1. Open the product_finishes.dat file using any text editor.

The file is located in the ..\.\ProgramData\Tekla Structures\<version>\environments\<environment>\system folder.

The first section of the file explains the available types of surface treatment. The surface treatment types are hard-coded, so do not modify this section:

```cpp
// Product finishes
// -------------------
//
// Type : Type of surfacing
// 1 = concrete finish
// 2 = special mix
// 3 = tile surface
// 4 = steel finish
```

2. Go to the sections that define the options for each type of surface treatment:

```cpp
// -------------------
// *** Concrete Finish
// -------------------
// WET FINISH

1    MF    "Magnesium Float"
1    SMF   "Smooth Magnesium Float"
1    WI    "Wet Trowel"
```

3. Add rows to define new options.
   a. Define the surface treatment type. For example, 1 for concrete finish.
   b. Define a code for the surface treatment option. For example, MF for Magnesium Float.
   c. Define the full name of the surface treatment option. For example, Magnesium Float. Remember to enclose the name in double quotes " ".

4. Save the file.

See also  Adding surface treatment on page 142

**Tiled surface treatment**

This section is for advanced users.
Tekla Structures includes complex tile and brick surface treatment options, such as basketweave and herringbone patterns. Tiled surface treatment options are based on repeating tile patterns that are stored in XML format.

See also  
Creating new tile patterns on page 149
Example pattern definition on page 149
Tile pattern definitions on page 152
Tile pattern elements on page 152

Creating new tile patterns

To create new tile patterns:

1. Open the TilePatternCatalog.xml file using any text editor.
   The file is located in the ..\ProgramData\Tekla Structures\<version>\environments\<environment>\system folder.

2. Add a new <TilePattern> element to the file.
   The <TilePattern> element must have <HOffset> and <VOffset> elements and at least one <Tile> element. Other elements are optional.
   
   ![Tip]
   You may find it easier to copy one of the existing elements, and then modify it to suit your needs.

3. Repeat adding <TilePattern> elements for all the patterns you want to define.

4. Save the TilePatternCatalog.xml file.

See also  
Tiled surface treatment on page 148
Example pattern definition on page 149
Tile pattern definitions on page 152
Tile pattern elements on page 152

Example pattern definition

This example explains how the Basketweave tile pattern is defined in the TilePatternCatalog.xml file.

The Basketweave pattern block is made up of eight tiles:
1. Tile width
2. Mortar width
3. VOffset
4. HOffset
5. Red marks indicate TileOrigin. Angle value for vertical tiles is 90
6. Tile height
7. Mortar height

The pattern is repeated in the x and y direction of the surface treatment, starting from the origin of the surface treatment. You can run the pattern in different x directions:

In the TilePatternCatalog.xml file, the pattern is defined as follows:
<TilePattern Name="Basketweave">
  <Parameter Name="W" DefaultValue="220">
    <Label> _Tile_Width </Label>
  </Parameter>
  <Parameter Name="H" DefaultValue="100">
    <Label> _Tile_Height </Label>
  </Parameter>
  <Parameter Name="TH" DefaultValue="100">
    <Label> _Tile_Thickness </Label>
  </Parameter>
  <Parameter Name="MH" DefaultValue="20">
    <Label> _Mortar_Height </Label>
  </Parameter>
  <Parameter Name="MW" DefaultValue="20">
    <Label> _Mortar_Width </Label>
  </Parameter>

  <HOffset>
    <Vector2D X="W-2*H-3*MW" Y="" />
  </HOffset>

  <VOffset>
    <Vector2D X="0" Y="W+2*H-3*MH" />
  </VOffset>

  <Tile Angle="0" Width="W" Height="H" Thickness="TH">
    <TileOrigin>
      <Vector2D X="0" Y="0" />
    </TileOrigin>
  </Tile>
</TilePattern>

1. The name of the pattern
2. The size of the pattern block in the x direction, after which the pattern repeats
3. The size of the pattern block in the y direction, after which the pattern repeats

The definition file uses the same symbols as the pattern definition table in the Surface Treatment Properties dialog box:
The predefined tile patterns that are available in the Surface Treatment Properties dialog box are stored in the following files:

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TilePatternCatalog.xml</td>
<td>Contains the tile pattern definitions.</td>
</tr>
<tr>
<td></td>
<td>Located in the ..\ProgramData\Tekla Structures&lt;version&gt;\environments &lt;environment&gt;\system folder.</td>
</tr>
<tr>
<td>TilePatternCatalog.dtd</td>
<td>Document Type Declaration (DTD) file that defines the elements allowed in the</td>
</tr>
<tr>
<td></td>
<td>TilePatternCatalog.xml file.</td>
</tr>
<tr>
<td></td>
<td>Located in the same folder as the</td>
</tr>
<tr>
<td></td>
<td>TilePatternCatalog.xml file.</td>
</tr>
<tr>
<td>Thumbnail images</td>
<td>The images that appear on the Pattern tab in the</td>
</tr>
<tr>
<td></td>
<td>Surface Treatment Properties dialog box.</td>
</tr>
<tr>
<td></td>
<td>Located in the ..\ProgramData\Tekla Structures&lt;version&gt;\Bitmaps folder.</td>
</tr>
<tr>
<td></td>
<td>Filenames identify the pattern types. For example,</td>
</tr>
<tr>
<td></td>
<td>herringbone.bmp illustrates the herringbone pattern type.</td>
</tr>
</tbody>
</table>

See also Tiled surface treatment on page 148
**Tile pattern elements**

The `TilePatternCatalog.xml` file can contain the following elements:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>TilePatternCatalog</code></td>
<td>The container for tile patterns. Required.</td>
</tr>
<tr>
<td><code>TilePattern</code></td>
<td>Tile pattern element. Required. This element can contain the following elements listed in this table.</td>
</tr>
<tr>
<td><code>HOffset</code></td>
<td>Horizontal offset of the tile pattern. Required.</td>
</tr>
<tr>
<td><code>VOffset</code></td>
<td>Vertical offset of the tile pattern. Required.</td>
</tr>
<tr>
<td><code>Tile</code></td>
<td>The individual tiles used in a tile pattern. At least one required.</td>
</tr>
<tr>
<td><code>Color</code></td>
<td>Color of the tile or mortar, defined by the RGB values (0–255). Optional.</td>
</tr>
<tr>
<td><code>Label</code></td>
<td>The label that identifies a parameter in the dialog box. Optional.</td>
</tr>
<tr>
<td><code>TileOrigin</code></td>
<td>The origin of an individual tile, defined from the origin of the pattern. Optional.</td>
</tr>
</tbody>
</table>

**Creating an unpainted area using the no paint area tool**

You can create an unpainted area between bolted steel parts using the **No paint area** modeling tool.

To create an unpainted area:

1. Open the **No paint area** modeling tool from the **Component Catalog**.
2. On the **General** tab:
   a. Click the **Load bolt standards** button to display the available bolt standards, and select the relevant standards.
   b. Select the clearance location from the **Create for** list.

See also **Tiled surface treatment on page 148**
• Define the hole tolerance.

• Define the contact area offset.

c. In the Allowable gap box, enter the maximum distance that can exist between two plates so that the surface treatment can be created.

3. On the Surfacing attributes tab:
   a. Select one of the following Surfacing attributes.
      • standard surface treatment property file
      • A custom surface treatment property file
         You can create your own property files using the Detailing --> Properties --> Surface Treatment... command. In the property file, the Type has to be Steel finish and the Surface treatment name has to be UP - Unpainted.
      • . . .
         Define the custom attributes and the position for the surface treatment.

4. Click OK.

5. Select the No paint area modeling tool in the Component Catalog.

6. Select a bolt group in the model.
The unpainted area is created between the bolted parts.

See also  Modifying surface treatment properties on page 143
This section explains how to control the visibility and representation of parts and other model objects.

Click the links below to find out more:

- Setting the visibility and appearance of parts on page 156
- Changing the representation of parts and components on page 158
- Hiding a part on page 161
- Hiding unselected parts on page 162
- Showing and hiding assemblies on page 163
- Showing and hiding components on page 163

7.1 Setting the visibility and appearance of parts

Modify the display settings to define how parts and other model objects appear in a model view.

To set the visibility and appearance of parts:

1. Double-click the view to open the View Properties dialog box.
2. Click Display to open the Display dialog box.
3. Select or clear check boxes to specify which objects are visible in the view.
4. Select a representation option for parts, bolts, holes, welds, construction planes and reinforcing bars.

You have the following options:

- Fast
- Exact
- Reference line (only for parts)
- Exact slotted holes (only for holes)
5. Ensure that the view is selected.

6. Click Modify to apply the changes.

See also  Display settings on page 238
Showing parts with exact lines on page 157
Showing parts with high accuracy on page 157

Showing parts with exact lines
Use the Show Part with Exact Lines command to temporarily display a part with exact lines even if you are using the Fast representation option for parts.

To display a part with exact lines:
1. Select the part.
2. Click View --> Representation --> Show Part with Exact Lines.
3. Click the view in which you want to display exact lines.
4. To clear the exact lines effect, click View --> Redraw All.

See also  Showing and hiding parts on page 156

Showing parts with high accuracy
You can temporarily display parts with the highest possible level of accuracy. This can be useful, for example, when checking a large model, because the entire model can still be displayed in the Fast or Exact representation mode but the individual part can be shown in more detail.

To display selected parts with high accuracy:
1. Select the parts.
2. Right-click, and then hold down the Shift key while selecting Show with Exact Lines from the pop-up menu.
   Tekla Structures displays the selected parts with the highest possible level of accuracy.
3. To clear the high accuracy effect, right-click and select Show with Exact Lines from the pop-up menu.
7.2 Changing the representation of parts and components

You can easily change the representation of parts and components in rendered views.

To change the representation of parts or components:

1. Click View --> Representation and then either Parts or Components.
2. Select one of the representation options:
   - Wireframe
   - Shaded Wireframe
   - Hidden Lines
   - Rendered
   - Show Only Selected
### Representation options

The following table lists the available representation options for parts and components:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wireframe</td>
<td>Part outlines are displayed, surfaces are not. Parts are transparent.</td>
<td><img src="image" alt="Wireframe Example" /> In this example, component objects are displayed as <strong>Rendered</strong>.</td>
</tr>
<tr>
<td>Shaded Wireframe</td>
<td>Part outlines are displayed. Parts are transparent, and their surfaces are shaded.</td>
<td><img src="image" alt="Shaded Wireframe Example" /> In this example, component objects are displayed as <strong>Rendered</strong>.</td>
</tr>
<tr>
<td>Hidden Lines</td>
<td>Parts are not transparent. Underlying parts are not visible.</td>
<td><img src="image" alt="Hidden Lines Example" /></td>
</tr>
</tbody>
</table>

See also  
- Representation options on page 159  
- Keyboard shortcuts for part representation options on page 160  
- Keyboard shortcuts for component representation options on page 160
### Option Description Example

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rendered</td>
<td>Part surfaces are displayed. Parts are not transparent.</td>
<td><img src="image" alt="Rendered Example" /></td>
</tr>
<tr>
<td>Show Only Selected</td>
<td>Selected parts are displayed. Other parts are almost completely transparent. This option is useful, for example, when viewing clash check results in a large model.</td>
<td><img src="image" alt="Show Only Selected Example" /></td>
</tr>
</tbody>
</table>

### Keyboard shortcuts for part representation options

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wireframe</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>Shaded Wireframe</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>Hidden Lines</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>Rendered</td>
<td>Ctrl+4</td>
</tr>
<tr>
<td>Show Only Selected</td>
<td>Ctrl+5</td>
</tr>
</tbody>
</table>

### Keyboard shortcuts for component representation options

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wireframe</td>
<td>Shift+1</td>
</tr>
</tbody>
</table>

### See also
- Changing the representation of parts and components on page 158
- Keyboard shortcuts for part representation options on page 160
- Keyboard shortcuts for component representation options on page 160
- Representation options on page 159
<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shaded Wireframe</td>
<td>Shift+2</td>
</tr>
<tr>
<td>Hidden Lines</td>
<td>Shift+3</td>
</tr>
<tr>
<td>Rendered</td>
<td>Shift+4</td>
</tr>
<tr>
<td>Show Only Selected</td>
<td>Shift+5</td>
</tr>
</tbody>
</table>

See also [Representation options on page 159](#)

### 7.3 Hiding a part

You can quickly hide selected parts in a view. This can be useful, for example, when you want to temporarily hide parts to see the parts behind them.

To hide a part:

1. Click **View --> Hide Part**.
2. Select the part (or parts) you want to hide.

The selected part becomes invisible.
3. To make the part visible again, click View --> Redraw All.

See also  Hiding unselected parts on page 162

7.4 Hiding unselected parts
As an alternative to hiding single parts, you can define which parts you want to keep visible. All of the other, unselected parts will be hidden.

To hide all unselected parts in a view:
1. Select the parts that you want to keep visible.
   
   ![Diagram](image1.png)

   2. Right-click and select Show Only Selected.
      The unselected parts become almost transparent.
      
      ![Diagram](image2.png)
To completely hide the unselected parts, hold down the Shift key when selecting the command.

To show the unselected parts as sticks, hold down the Ctrl key when selecting the command.

3. To make the parts visible again, click View --> Redraw All.

See also Hiding a part on page 161

### 7.5 Showing and hiding assemblies

Do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show the contents of an assembly</td>
<td>Right-click the assembly and select Assembly &gt; Show Assembly from the pop-up menu. Tekla Structures displays all parts, bolts, welds,</td>
</tr>
<tr>
<td></td>
<td>cuts, fittings, and other details belonging to the assembly, even if you had defined them as hidden in the view properties.</td>
</tr>
<tr>
<td>Hide an assembly</td>
<td>1. Select the assembly you want to hide. 2. Right-click and select Assembly &gt; Hide from the pop-up menu.</td>
</tr>
<tr>
<td>Make a hidden assembly visible again</td>
<td>Click View --&gt; Redraw All.</td>
</tr>
</tbody>
</table>

See also Refreshing views on page 48

### 7.6 Showing and hiding components

Do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show the contents of a component</td>
<td>Click View --&gt; Representation --&gt; Show Component Content and select a component. Tekla Structures displays all bolts, welds, and other</td>
</tr>
<tr>
<td></td>
<td>details belonging to the component, even if you had defined them as hidden in the view properties.</td>
</tr>
<tr>
<td>Hide a component</td>
<td>1. Select the component you want to hide.</td>
</tr>
<tr>
<td>To</td>
<td>Do this</td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Make a hidden component visible again</td>
<td>2. Right-click and select <strong>Hide</strong> from the pop-up menu.</td>
</tr>
<tr>
<td></td>
<td>Click <strong>View --&gt; Redraw All</strong>.</td>
</tr>
</tbody>
</table>

**See also**  
*Refreshing views on page 48*
You can group parts and other objects based on their properties. Use object groups to control the color and transparency of parts in the model. Object groups are also needed with the Project Status Visualization tool.

Click the links below to find out more:

- Creating an object group on page 165
- Copying an object group to another model on page 166
- Deleting an object group on page 166

### 8.1 Creating an object group

To create an object group:

1. Click **View --> Representation --> Object Representation...** to open the Object Representation dialog box.
2. Click **Object group...** to open the Object Group – Representation dialog box.
3. Modify the object group settings.
   a. Click **Add row**.
   b. Select options from the **Category**, **Property**, and **Condition** lists.
   c. In the **Value** list, enter a value or select one from the model.
   d. Add more rows, and use the **And/Or** options or parentheses to create more complex rules.
4. Select the check boxes next to all object group rules that you want to enable.
   The check boxes define which rules are enabled and effective.
5. Enter a unique name in the box next to the **Save as** button.
6. Click **Save as** to save the object group.

See also Changing the color of an object group on page 168
8.2 Copying an object group to another model

To copy an object group to another model:

1. Select the object group you want to copy.
   The object groups you have created are located in the model's attributes folder, and they have the file name extension .PObjGrp.

2. Select where you want to copy the object group.
   - To make an object group available in another model, copy the file to the attributes folder of the destination model.
   - To make an object group available in all models, copy the file to the project or firm folder, defined by the advanced option XS_PROJECT or XS_FIRM.

3. Restart Tekla Structures.

See also Grouping parts on page 165

8.3 Deleting an object group

To delete an object group:

1. Delete the object group file located in the model's attributes folder.
   Object groups have the file name extension *.PObjGrp.

2. Restart Tekla Structures.

See also Grouping parts on page 165
Changing the color and transparency of parts

You can modify the color and transparency of parts and create customized presentations of the model. The following images show the same model with different transparency settings:

1. Standard color and transparency settings
2. Only parts whose profile name starts with IPE* or HEA* are visible
3. Parts whose user-defined attribute Planned erection date is set to 01/05/2009 are displayed in blue, while all other parts are 90% transparent

See also  Changing the color of a part on page 168
Defining color and transparency settings on page 170
9.1 Changing the color of a part

You can change the color of individual parts in a model by modifying their class in the part properties dialog box. Alternatively, you can use the object representation settings to specify colors for entire object groups.

To change the color of a part:
1. Double-click a part to open the part properties dialog box.
2. In the Class box, enter a new value.
   The possible values range between 0 and 14.
3. Click Modify.

You can also use the Mini Toolbar for changing the color.

9.2 Changing the color of an object group

You can customize the color of model objects by selecting a specific color for each object group. You can use an unlimited number of colors. This option gives you more freedom in visualizing the different types of objects in the model.

To change the color of an object group:
1. Click View --> Representation --> Object Representation to open the Object Representation dialog box.
2. Select an object group from the Object group list.
3. In the Color list, select a color.
4. In the Transparency list, select the desired transparency option.
5. Click Save to save the changes.
6. Click Modify to change the color of objects in the model.
Defining your own colors for object groups

To define colors for object groups:

1. Click View --> Representation --> Object Representation to open the Object Representation dialog box.
2. Select an object group from the Object Group list.
3. In the Color list, select Choose color....
4. Do one of the following:
   - Click a color in the Basic colors palette.
   - Click Define Custom Colors and create a color of your own:
     1. Click a color in the color window.
     2. Define the color depth by using the color bar on the right, or enter the exact RGB values.
     3. Click Add to Custom Colors.
4. Click the color in the **Custom colors** palette to select it.

5. Click **OK**.

6. Click **Save** to save the changes.

When you open the **Object Representation** dialog box the next time, the **Color** list shows a maximum of 10 colors that you last defined. Customized colors are shown above the dashed line:

Information about the colors that you define for the object groups is stored in the **used_custom_colors.clr** file, which is located in the attributes folder under the model folder. Information about the colors that you add in the **Custom colors** palette is stored in the **xs_user.xxx** file in the model folder (**xxx** is your user name).

**See also**  Changing the color of an object group on page 168

---

### 9.3 Defining color and transparency settings

You can define color and transparency settings for parts and other model objects.

To define color and transparency settings:

1. Click **View --> Representation --> Object Representation...** to open the **Object Representation** dialog box.

2. Click **Add row**.

3. Select an object group from the **Object group** list.
4. Use the **Color** list to define the color of the objects.

5. Use the **Transparency** list to define the transparency of the objects.

6. Repeat steps 3–5 for each row you add.

7. Use the **Move up** and **Move down** buttons to change the order of the rows.

   If an object belongs to several object groups, the color and transparency setting defined on the top row is applied to that object.

8. Enter a unique name in the box next to the **Save as** button.

9. Click **Save as** to save the settings.

   If your setting does not contain the group **All**, Tekla Structures adds that row to the bottom of the list when you click **Modify**, **Apply** or **OK**.

---

**See also**

- Changing the color and transparency of parts on page 167
- Color settings for object groups on page 240
- Transparency settings for object groups on page 241
- Defining your own colors for object groups on page 169

---

**9.4 Copying color and transparency settings**

To copy color and transparency settings to another model:

1. Select the settings you want to copy.

   The settings you have created are located in the model’s `attributes` folder, and they have the file name extension `.rep`.

2. Select where you want to copy the settings.

   - To make the settings available in another model, copy them to the `attributes` folder of the destination model.
   - To make the settings available in all models, copy them to the project or firm folder, defined by the advanced option `XS_PROJECT` or `XS_FIRM`.

3. Restart Tekla Structures.

**See also**

- Changing the color and transparency of parts on page 167
9.5 Removing color and transparency settings

To delete color and representation settings:
1. Delete the .rep file located in the model's attributes folder.
2. Restart Tekla Structures.

See also Changing the color and transparency of parts on page 167
10 Viewing the model

This section describes a variety of tools you can use to move and rotate the model. It also describes how to create clip planes and take screenshots of the model.

Click the links below to find out more:

- Zooming on page 173
- Rotating the model on page 174
- Moving the model on page 176
- Flying through the model on page 176
- Creating a clip plane on page 177
- Taking a screenshot on page 178
- Keyboard shortcuts for viewing the model on page 179

10.1 Zooming

The commands on the View > Zoom menu allow you to focus in on a particular area, or pull out for a wider view. You can use a mouse, menu command, keyboard shortcut, or a combination of these. The zooming commands in the model are available also in drawings.

To zoom in the model or in the drawing, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Scroll forward with the mouse wheel.</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Scroll backward with the mouse wheel.</td>
</tr>
<tr>
<td>Zoom the active view so that selected objects are shown in the center of the view</td>
<td>1. Select the objects. 2. Click View --&gt; Zoom --&gt; Zoom Selected.</td>
</tr>
<tr>
<td>Zoom with menu commands</td>
<td>Use the commands on the View --&gt; Zoom menu.</td>
</tr>
<tr>
<td>Zoom with keyboard shortcuts</td>
<td>1. Place the mouse pointer over the model.</td>
</tr>
</tbody>
</table>
To

Do this

1. Select View --> Zoom --> Create Zoom Window
2. Click a starting corner for the zoom window, and then drag the pointer to size the window.
3. Click the Magnifier icon.

As you move the pointer in the general view, the zoom window displays the area around the pointer in detail.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Press Page Up to zoom in, or Page Down to zoom out.</td>
<td></td>
</tr>
<tr>
<td>Create a separate zoom window in a drawing and zoom using Magnifier</td>
<td>1. Select View --&gt; Zoom --&gt; Create Zoom Window</td>
</tr>
<tr>
<td></td>
<td>2. Click a starting corner for the zoom window, and then drag the pointer to size the window.</td>
</tr>
<tr>
<td></td>
<td>3. Click the Magnifier icon.</td>
</tr>
</tbody>
</table>

See also Modifying the zoom settings on page 174

Modifying the zoom settings

To modify zoom settings, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keep the center point of the view in the middle of the view window</td>
<td>Click Tools --&gt; Options --&gt; Centered Zooms . If this option is off, the mouse pointer position determines the center point of zooming.</td>
</tr>
<tr>
<td>Define the zoom ratio when using a 3-button mouse</td>
<td>Use the advanced option .</td>
</tr>
<tr>
<td>Define the zoom ratio when scrolling</td>
<td>Use the advanced option .</td>
</tr>
<tr>
<td>Define the zoom ratio when scrolling and holding down the wheel</td>
<td>Use the advanced option .</td>
</tr>
</tbody>
</table>

See also Zooming on page 173

10.2 Rotating the model

You can use the mouse, keyboard shortcuts, menu commands, or a combination of these techniques to rotate the model in rendered views.
To rotate the model, use any of the following methods:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate using the <strong>middle</strong> mouse button</td>
<td>1. Hold down Ctrl and click and drag with the middle mouse button to rotate the model.&lt;br&gt;2. To relocate the center of rotation, press v, and then pick a position in the view.&lt;br&gt;Tekla Structures rotates the model around this view point.</td>
</tr>
<tr>
<td>Rotate using the <strong>left</strong> mouse button</td>
<td>1. Press Ctrl+R.&lt;br&gt;2. Pick a position in the view.&lt;br&gt;Tekla Structures rotates the model around this view point.&lt;br&gt;3. Click and drag with the left mouse button to rotate the model.</td>
</tr>
<tr>
<td>Rotate using menu commands or keyboard shortcuts</td>
<td>• Click View --&gt; <strong>Rotate</strong> and select one of the commands.&lt;br&gt;The center of rotation is fixed in the center of the work area.&lt;br&gt;For more information on how to use each command, rest the mouse pointer on the command. The corresponding menu tooltip appears on the screen.</td>
</tr>
<tr>
<td>Automatically set the rotation center</td>
<td>1. Click Tools --&gt; <strong>Options</strong> --&gt; <strong>Automatic Rotation Center</strong> to switch on automatic rotation centering.&lt;br&gt;2. Hold down Ctrl and click and drag with the middle mouse button to rotate the model.&lt;br&gt;The rotation center is automatically set at the location you clicked.&lt;br&gt;Tip: When <strong>Automatic Rotation Center</strong> is switched off, you can temporarily activate it by holding down Ctrl +Shift while you click and drag with the middle mouse button.</td>
</tr>
<tr>
<td>Define a specific rotation angle</td>
<td>1. Double-click the view to open the <strong>View Properties</strong> dialog box.&lt;br&gt;2. Enter a rotation angle in the <strong>Rotation around Z</strong> or <strong>Rotation around X</strong> box.&lt;br&gt;3. Click <strong>Modify</strong>.</td>
</tr>
</tbody>
</table>

**See also**  
Rotation settings on page 235  
Viewing the model on page 173
10.3 Moving the model

To move the entire model, use any of the following methods:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Move the model using the middle mouse button  | 1. To activate the middle button pan, click **Tools --> Options --> Middle Button Pan**, or **Shift + M**. A checkmark appears next to the menu command if the middle button pan is already active.  
2. Hold down the **middle** mouse button and drag the model anywhere within the view. |
| Move the model using the **Pan** command      | 1. Press **P** or click **View --> Move --> Pan** to activate dynamic panning. The mouse pointer changes to a hand.  
2. Hold down the left mouse button and drag the mouse anywhere within the view.  
3. To stop panning, press **Esc**.               |
| Move the model using keyboard shortcuts or menu commands | Do one of the following:  
• Use the up, down, left and right arrows on the keyboard.  
• Click **View --> Move** and then select one of the commands. |

See also Viewing the model on page 173

10.4 Flying through the model

Using the **Fly** command, you can travel through a model, changing direction and varying the speed as you go. You can also adjust the field of view setting, which can be useful when flying in a tight space.

To fly through a model:

1. Set view projection to **Perspective**.  
   a. Double-click the view to open the **View Properties** dialog box.  
   b. In the **Projection** list, select **Perspective**.  
   c. Click **Modify**.  
2. If needed, adjust the field of view setting.  
   a. Click **Tools --> Options --> Advanced Options... --> Model View**.
b. Modify the advanced option.
c. Click OK.

3. Click View --> Fly.

4. Select a view. The mouse pointer changes into an arrow and a cross. The arrow indicates the current flying direction.

5. Drag the mouse to move around in the model.
   • To fly forward, move the mouse forward.
   • To change the flying direction, drag the mouse in the desired direction.
     The flying speed grows exponentially when you are approaching the model from a distance.
   • To move up or down, hold down Ctrl and drag the mouse forward or backward.
   • To change the camera angle, scroll with the mouse wheel.
   • To fly in the direction of the camera angle, hold down Shift and scroll forward or backward.

6. To stop flying, press Esc.

See also Viewing the model on page 173

10.5 Creating a clip plane

Clip planes enable you to focus in on the required detail in the model. You can create up to six clip planes in any rendered model view.

To create a clip plane:
1. Click View --> Create Clip Plane.
2. Select a plane. The clip plane symbol appears in the model:

3. Repeat step 2 to create as many clip planes as needed.
4. To finish creating clip planes, press Esc.
To move a clip plane, click the clip plane scissor symbol and drag it to a new location.

5. To delete a clip plane, click the clip plane symbol and press **Delete**.

**See also**  Viewing the model on page 173

### 10.6 Taking a screenshot

A screenshot is an image of a model or drawing view. You can use screenshots in posters, brochures, or other material to show projects carried out using Tekla Structures.

To take a screenshot of a rendered model view:

1. Ensure that the view type is set to **Rendered**.
2. Click **Tools** --> **Screenshot**.
3. To define which view to take the screenshot from, click **Pick view** and select a view.
4. Under **Capture**, select **Rendered view**.
5. Click **Options...** The **Screenshot Options** dialog box appears.
6. Set the desired properties and click **OK**.
7. Click **Capture**.

**See also**  Screenshot settings on page 236  

**Saving a screenshot in bitmap format on page 179**
Saving a screenshot in bitmap format

By default, screenshots are created as Portable Network Graphics (.png) files. You can also save a screenshot in bitmap (.bmp) format to use it, for example, as a custom component thumbnail.

To save a screenshot in bitmap format:

1. Click **Tools --> Screenshot**.
2. Select **Place on clipboard**.
3. Click **Capture**.
4. Paste the screenshot in your graphics editor and save it in .bmp format.

---

The software that you use to open the screenshot may have a limit for the number of pixels.

---

See also **Taking a screenshot on page 178**

---

### 10.7 Keyboard shortcuts for viewing the model

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom original</td>
<td>Home</td>
</tr>
<tr>
<td>Zoom previous</td>
<td>End</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Page Up</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Page Down</td>
</tr>
<tr>
<td>Rotate using mouse</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Rotate using keyboard</td>
<td>Ctrl+arrow keys</td>
</tr>
<tr>
<td></td>
<td>Shift+arrow keys</td>
</tr>
<tr>
<td>Disable view rotation</td>
<td>F8</td>
</tr>
<tr>
<td>Set view rotation point</td>
<td>V</td>
</tr>
<tr>
<td>Auto rotate</td>
<td>Shift+R</td>
</tr>
<tr>
<td></td>
<td>Shift+T</td>
</tr>
<tr>
<td>Pan</td>
<td>P</td>
</tr>
<tr>
<td>Middle button pan</td>
<td>Shift+M</td>
</tr>
<tr>
<td>Move right</td>
<td>arrow keys</td>
</tr>
<tr>
<td>Move left</td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Keyboard shortcut</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Move down</td>
<td></td>
</tr>
<tr>
<td>Move up</td>
<td></td>
</tr>
<tr>
<td>3D/Plane view</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Fly</td>
<td>Shift+F</td>
</tr>
<tr>
<td>Create clip plane</td>
<td>Shift+X</td>
</tr>
<tr>
<td>Center by cursor</td>
<td>Ins</td>
</tr>
</tbody>
</table>

See also  Viewing the model on page 173
This section describes a variety of tools you can use to ensure the model does not contain errors.

Click the links below to find out more:

- Inquiring object properties on page 181
- Measuring objects on page 184
- Detecting clashes on page 187
- Diagnosing and repairing the model on page 200
- Comparing parts or assemblies on page 201
- Finding distant objects on page 201
- Keyboard shortcuts for checking the model on page 202

11.1 Inquiring object properties

Use the Inquire object command to display the properties of a particular object, or a group of objects, within the model.

To inquire object properties:
1. Click Tools --> Inquire --> Object .
2. Select an object.

Tekla Structures displays the object properties in a separate window.

See also Object property report templates on page 181
Object property report templates

When you view object properties using the Inquire object command, Tekla Structures uses the following report templates, available in the folder \ProgramData\Tekla Structures\<version>\environments\common\system:

<table>
<thead>
<tr>
<th>Part type</th>
<th>Template</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assemblies</td>
<td>TS_Report_Inquire_Assembly.rpt</td>
</tr>
<tr>
<td>Bolts</td>
<td>TS_Report_Inquire_Bolt.rpt</td>
</tr>
<tr>
<td>Cast units</td>
<td>TS_Report_Inquire_Cast_Unit.rpt</td>
</tr>
<tr>
<td>Parts</td>
<td>TS_Report_Inquire_Part.rpt</td>
</tr>
<tr>
<td>Pour breaks</td>
<td>TS_Report_Inquire_Pour_Break.rpt</td>
</tr>
<tr>
<td>Pour objects</td>
<td>TS_Report_Inquire_Pour_Object.rpt</td>
</tr>
<tr>
<td>Reinforcement meshes</td>
<td>TS_Report_Inquire_Rebar_Mesh.rpt</td>
</tr>
<tr>
<td>Reinforcement strands</td>
<td>TS_Report_Inquire_Rebar_Strand.rpt</td>
</tr>
<tr>
<td>Reference models</td>
<td>TS_Report_Inquire_Reference.rpt</td>
</tr>
<tr>
<td>Reinforcement</td>
<td>TS_Report_Inquire_Reinforcement.rpt</td>
</tr>
<tr>
<td>Welds</td>
<td>TS_Report_Inquire_Welding.rpt</td>
</tr>
</tbody>
</table>

You can modify these templates according to your needs. For more information on how to use templates, see the Template Editor user documentation.

See also Inquiring object properties on page 181

Using the Custom Inquiry tool

Use the Custom Inquiry tool to display information of the selected model object in a separate window that you can drag and drop to any position on the screen. By default, the tool shows the total area, weight, and length of the selected model object.

To display object properties using the Custom Inquiry tool:

1. Click **Tools** --> **Inquire** --> **Custom Inquiry**... .
   The Custom Inquiry dialog box appears.

2. Select a part.
   Tekla Structures displays the part properties in the tool window.

See also Defining which attributes are displayed by Custom Inquiry tool on page 182

Adding attributes to Custom Inquiry tool on page 183
**Defining which attributes are displayed by Custom Inquiry tool**

You can define what information is displayed in the Custom Inquiry dialog box.

To define which attributes are displayed:

1. Click **Tools --> Inquire --> Custom Inquiry...**
   - The Custom Inquiry dialog box appears.

2. Click **Manage contents...**
   - The Manage Contents dialog box appears. The Attributes list contains all of the available attributes. The Contents of Custom Inquiry list contains the attributes that are displayed in the tool window.

3. If needed, define which attributes are shown in the Attributes list.
   - To modify the default attributes, edit the InquiryTool.config file in the .. \ProgramData\Tekla Structures\<version>\environments \common\macros\modeling\InquiryToolAttributes folder.
   - To create new calculated attributes, click Add.... You can use standard mathematical symbols (+, -, *, and /) to form equations.
   - To modify the calculated attributes, click Edit....

4. Define which attributes are shown in the tool window.
   - To add more attributes to the tool window, click an item in the Attributes list and then click the right arrow button.
   - To remove attributes from the tool window, click an item in the Contents of Custom Inquiry list and then click the left arrow button.
   - To change the order of the attributes, use the Up and Down buttons.
   - To change the formula of an attribute, click the down arrow and select a different formula (SUM, AVERAGE, MAX, or MIN) from the list.

**See also** Using the Custom Inquiry tool on page 182

Adding attributes to Custom Inquiry tool on page 183

**Adding attributes to Custom Inquiry tool**

This section is for advanced users.

Use the InquiryTool.config file to control which attributes are shown as default attributes in the Manage Contents dialog box in the Custom Inquiry tool. The file is located in the folder defined with the advanced option XS_MACRO_DIRECTORY, and under .. \modeling\InquiryToolAttributes in that folder path.
For example, if XS_MACRO_DIRECTORY is set to C:\ProgramData\Tekla Structures\<version>\environments\common\macros, the file InquiryTool.config is located in the folder C:\ProgramData\Tekla Structures\<version>\environments\common\macros\modeling\InquiryToolAttributes.

To add new attributes to the InquiryTool.config file:
1. Open the InquiryTool.config file in any standard text editor.
2. Copy the entire contents of [ATTR_CONTENT_??] to the end of the file.
3. Change the position number of the new attribute.
   For example, change [ATTR_CONTENT_??] to [ATTR_CONTENT_66].
4. Modify the NAME, DISPLAY_NAME, DATATYPE, UNIT, and DECIMAL values of the new attribute. Use the attribute names and definitions that are included in the contentattributes_global.lst file.
5. Change the TOTAL_ATTR_CONTENT value to reflect the total number of attributes in the file.
   For example, change TOTAL_ATTR_CONTENT=65 to TOTAL_ATTR_CONTENT=66.
6. Save the file.

See also Using the Custom Inquiry tool on page 182

11.2 Measuring objects

Use the commands on the Tools --> Measure menu to measure angles, arcs, the distance between two points and between bolts.

All measurements are temporary. The measurements appear in the rendered view window until you update or redraw the window.

The units depend on the settings in Tools --> Options --> Options --> Units and decimals.

See also Measuring distances on page 184
Measuring angles on page 185
Measuring arcs on page 185
Measuring bolt spacing on page 186
Measuring distances

To measure horizontal, vertical and user-defined distances:

1. Press Ctrl+P to switch to the plane view.
2. Click Tools --> Measure and select one of the following commands:
   - **Distance**
     This command measures the distance between any two points. Use this command to measure inclined or aligned distances on the current view plane. By default, the results contain the distance and the coordinates.
   - **Horizontal Distance**
     This command measures the horizontal distance between two points along the x axis.
   - **Vertical Distance**
     This command measures the vertical distance between two points along the y axis.
3. Pick the start point.
4. Pick the end point.
5. Pick a point to indicate on which side of the dimension line you want the measurement to appear.
   The measurement is displayed until the next window update or redraw.

See also  Measuring objects on page 184

Measuring angles

To measure angles:

1. Click or Tools --> Measure --> Angle.
2. Pick the center point.
3. Pick the start point.
4. Pick the end point.

See also  Measuring objects on page 184

Measuring arcs

To measure the radius and length of an arc:

1. Click or Tools --> Measure --> Arc.
2. Pick the start point.
3. Pick the middle point.
   This can be any point along the arc between the start and end points.
4. Pick the end point.

Measuring objects on page 184

See also Measuring objects on page 184

Measuring bolt spacing
You can measure distances between bolts in a bolt group. Tekla Structures also gives you the edge distances between the bolts and a selected part.

To measure bolt spacing:
1. Click or Tools --> Measure --> Bolt Spacing.
2. Select a bolt group.
3. Select a part.
11.3 Detecting clashes

Use the Clash Check Manager tool to find parts, bolts, reinforcement, or reference model objects that collide. Clashes of objects that only touch one another are not included in the clash check results.

See also Measuring objects on page 184
You can also use the sections and floors created in Organizer to run a controlled clash check. If you want to use another Tekla Structures model as a reference model, you must export it in IFC format to be able to use it in clash checking. The following reference model file types are supported in clash checking:

- IFC
- DWG
- DGN

See also Finding clashes on page 188

Finding clashes

To find clashes in a model:

1. Click Tools --> Clash Check Manager.
2. In the model, select the objects you want to include in the clash check.
3. Click to check the objects.
   
   You can continue working during the clash check. When the clash check is complete, the status bar message changes from Clash checking in progress to Ready.
4. To highlight a clash in the model, select a row in the list of clashes. The related model objects are selected.
5. To zoom the active view so that the selected objects are shown in the center of the view, double-click a row.

6. If you want to include more objects in the clash check, select the desired model objects and re-run the clash check.
   New clashes are appended to the end of the list.

7. After removing or modifying objects, re-run clash check to see if the clash still exists.
   a. Select the desired rows in the list of clashes.
   b. Click to re-run clash check.

For best results, run the clash check only for appropriate sections and floors, not for the entire model. Use Organizer to select the sections and floors for which you want to run the clash check. Right-click and select Select in the Model.

If you cannot find the clashes in the model, change the representation of objects to Show Only Selected (Ctrl+5) for better visibility.

See also Managing the list of clashes on page 192

Managing clash check results
This section describes how to interpret the symbols and clash types used in clash checking and how to change the status or priority of the clashes.

Click the links below to find out more:

Symbols used in clash checking on page 189
About clash types on page 190
Managing the list of clashes on page 192
Searching for clashes on page 193
Changing the status of clashes on page 193
Changing the priority of clashes on page 194

Symbols used in clash checking
Clash Check Manager uses the following flags to indicate the state of clashes:
<table>
<thead>
<tr>
<th>Flag</th>
<th>State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(none)</td>
<td>Active</td>
<td>The default state. The clash is not new, modified, resolved, or missing.</td>
</tr>
<tr>
<td>⚫</td>
<td>New</td>
<td>All clashes are marked as new when they are found for the first time.</td>
</tr>
<tr>
<td>⚠️</td>
<td>Modified</td>
<td>If the object has been modified (for example, if the profile has been changed), the state changes to modified when you re-run the clash check. Only certain object properties affect this flag. To see which properties have an effect, right-click one of the column headings. Both visible and hidden properties affect the flag.</td>
</tr>
<tr>
<td>✅</td>
<td>Resolved</td>
<td>If the objects no longer clash, the state changes to resolved when you re-run the clash check.</td>
</tr>
<tr>
<td>❌</td>
<td>Missing</td>
<td>If one or both of the clashing objects have been removed from the model, the state changes to missing when you re-run the clash check.</td>
</tr>
</tbody>
</table>

**See also**  Finding clashes on page 188

**About clash types**
Tekla Structures shows the type of each clash in the **Type** column in the **Clash Check Manager** dialog box.

The following clash types can occur:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clash</td>
<td>The object partly overlaps with another object.</td>
<td><img src="image" alt="Clash Example" /></td>
</tr>
<tr>
<td>Type</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td><strong>Exact match</strong></td>
<td>Two identical objects completely overlap.</td>
<td><img src="image" alt="Exact match Example" /></td>
</tr>
<tr>
<td><strong>Complex clash</strong></td>
<td>Objects intersect with each other in several locations.</td>
<td><img src="image" alt="Complex clash Example" /></td>
</tr>
<tr>
<td>Type</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Is inside</td>
<td>The object is inside another object.</td>
<td></td>
</tr>
<tr>
<td>Cut through</td>
<td>The object cuts through another object.</td>
<td></td>
</tr>
</tbody>
</table>

**See also**  
Finding clashes on page 188  
Managing clash check results on page 189

**Managing the list of clashes**

To manage the list of clashes in **Clash Check Manager**:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the sort order of clash results</td>
<td>Click the heading of the desired column to alternate between the ascending and descending sort order.</td>
</tr>
</tbody>
</table>
To do this

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select multiple rows in the list of clashes</td>
<td>Hold down Ctrl or Shift while selecting rows.</td>
</tr>
<tr>
<td>Show or hide a column</td>
<td>1. Right-click one of the column headings to open a pop-up menu.</td>
</tr>
<tr>
<td></td>
<td>2. Click any of the list items to show or hide them.</td>
</tr>
<tr>
<td></td>
<td>A check mark in front of the item indicates that it is visible.</td>
</tr>
</tbody>
</table>

See also Finding clashes on page 188

**Searching for clashes**

Use the Search box to find clashes based on search terms. The more search terms you enter, the more refined your search will be. For example, if you enter column 8112, only the clashes that match both of these terms are displayed.

To search for clashes:
1. Open the clash check session you want to find clashes from.
2. In the Search box, enter the words to search for.
   - The search results are displayed as you type.
3. To narrow your search, enter more characters.
4. To display all the clashes again, click next to the Search box.

See also Finding clashes on page 188

**Changing the status of clashes**

To change the status of clashes:
1. In Clash Check Manager, select the clashes whose status you want to change.
2. Right-click one of the selected rows to open a pop-up menu.
3. Select Status and then one of the status options:
   - Assign
   - Fix
   - Approve
   - Ignore
   - Reopen

See also Finding clashes on page 188
Changing the priority of clashes

To change the priority of clashes:

1. In Clash Check Manager, select the clashes whose priority you want to change.
2. Right-click one of the selected rows to open a pop-up menu.
3. Select Priority and then one of the status options:
   • High
   • Medium
   • Low

See also Finding clashes on page 188

Grouping clashes

You can combine several clashes into a group so that the clashes are treated as a single unit.

To group clashes:

1. In Clash Check Manager, select the clashes you want to group.
2. Right-click and select Group --> Group from the pop-up menu.
3. If you want to add clashes to an already existing group, select the clashes and the group, and then repeat step 2.

You cannot create nested groups of clashes.

See also Ungrouping clashes on page 194

Ungrouping clashes

To ungroup clashes:

1. In Clash Check Manager, select the clash group you want to ungroup.
2. Right-click and select Group --> Ungroup from the pop-up menu.

See also Grouping clashes on page 194
**Viewing the details of a clash**

Use the **Clash Information** dialog box to view more detailed information about a clash. For example, you can view the profile, material and class of the objects that collide. This can be useful especially when you view clash groups that contain more than two objects.

To view the details of a clash:

1. Select the clash or clash group whose details you want to view.
2. Right-click and select **Clash Information** from the pop-up menu.

   If more than one clash or clash group is being selected at the same time, the **Clash Information** option appears dimmed in the pop-up menu.

**See also**

- Adding comments to a clash on page 195
- Viewing the history of a clash on page 196

**Adding comments to a clash**

You can add comments to clashes and clash groups. For example, you might use comments as reminders to yourself and other users.

To add a comment:

1. Select the clash or clash group you want to comment on.
2. Right-click and select **Clash Information** from the pop-up menu.
3. Go to the **Comments** tab.
4. Click 🔒 to open the **Add comment** dialog box.
5. Enter your comment in the **Comment** box.
6. Modify the author name and the date if needed.
7. Click **OK**.

**See also**

- Modifying a clash comment on page 195
- Removing a clash comment on page 196

**Modifying a clash comment**

To modify a comment:

1. Select the clash or clash group whose comment you want to modify.
2. Right-click and select **Clash Information** from the pop-up menu.
3. Go to the Comments tab.
4. Select the comment you want to modify.
5. Click 📝 to open the Edit comment dialog box.
6. Modify the comment.
7. Click OK.

See also  Adding comments to a clash on page 195
Removing a clash comment on page 196

Removing a clash comment

To remove a comment from a clash:
1. Select the clash or clash group whose comment you want to remove.
2. Right-click and select Clash Information from the pop-up menu.
3. Go to the Comments tab.
4. Select the comment you want to remove.
5. Click 📝.

See also  Adding comments to a clash on page 195
Modifying a clash comment on page 195

Viewing the history of a clash

You can view the history of a particular clash. For example, you can see when and by whom the clash was detected.

To view the history of a clash:
1. Select a clash or a clash group.
2. Right-click and select Clash Information from the pop-up menu.
3. Go to the History tab.
   The history information of the clash is displayed.

See also  Viewing the details of a clash on page 194
Printing a list of clashes
You can print lists of clashes. You can control the print settings the same way as in any standard Windows application.

To print a list of clashes:
1. Open the clash check session you want to print.
2. Click Print...
3. If needed, modify the print settings.
4. Click Print.

See also Previewing a list of clashes before printing on page 197
Setting the paper size, margins and page orientation on page 197

Previewing a list of clashes before printing
Use the options in the Print preview dialog box to see what a list of clashes will look like when it is printed.

To preview a list of clashes:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the Print preview dialog box</td>
<td>In Clash Check Manager, click the arrow next to the button and select Print preview... from the pop-up menu.</td>
</tr>
<tr>
<td>Select how many pages to view at a time</td>
<td>Click one of the Page Layout buttons: <img src="image" alt="Page Layout buttons" /> If the list of clashes is very long, it might be spread out on several pages.</td>
</tr>
<tr>
<td>Zoom the page in or out</td>
<td>Click the arrow button next to the button and select an option from the pop-up menu.</td>
</tr>
<tr>
<td>Print the current page</td>
<td>Click <img src="image" alt="Print" /></td>
</tr>
<tr>
<td>Close the Print preview dialog box</td>
<td>Click <img src="image" alt="Close" /></td>
</tr>
</tbody>
</table>

See also Printing a list of clashes on page 196
Setting the paper size, margins and page orientation on page 197

Setting the paper size, margins and page orientation
Before printing a list of clashes, you can set the paper size, margins, and page orientation in the Page Setup dialog box.
The options for paper size and paper source are printer-dependent. To use different paper options, select another printer in the **Print** dialog box and click **Apply**.

To set up the page for printing:

1. Click the arrow next to the button and select **Page setup...** from the pop-up menu.
2. In the **Size** box, select the paper size you want to use.
3. In the **Source** box, select the correct paper source.
4. Under **Orientation**, select one of the page orientation options.
   - **Portrait**: vertical page orientation
   - **Landscape**: horizontal page orientation
5. Under **Margins**, enter values for the **Left**, **Right**, **Top**, and **Bottom** margins.
6. Click **OK** to save the changes.

**See also**  
* Printing a list of clashes on page 196  
* Previewing a list of clashes before printing on page 197

---

**Opening and saving clash check sessions**

Clash check sessions are saved as XML files in the ..\TeklaStructuresModels <model>\Clashes folder. Tekla Structures creates the folder automatically when you open **Clash Check Manager** for the first time.

To open or save sessions in **Clash Check Manager**, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Open a session      | 1. Click ![Open button](image)  
                      2. In the **Open** dialog box, select a session.  
                      3. Click **OK**.                                                                 |
| Start a new session | **Clash Check Manager** clears the list of clashes without running clash check.                                                           |
| Save the current session | Click ![Save button](image)  
                          **Clash Check Manager** clears the list of clashes without running clash check.                                                      |
Save the current session with a
another name or in another location

1. Click the arrow next to the button. A pop-up menu appears.
2. Click Save as.
3. In the Save As dialog box, browse to the folder where you want to save the session.
4. In the File name box, enter a new name.
5. Click Save.

Save only selected clashes

1. In the list of clashes, select the clashes you want to save.
2. Click the arrow next to the button. A pop-up menu appears.
3. Click Save selected.

Defining a clash check clearance area for bolts

To check if bolts collide with profiles and if there is enough space to fix the bolt, you can define a clash check clearance area for bolts.

To define a clearance area for bolts:
1. Click Tools --> Options --> Options...
2. In the Options dialog box, go to the Clash check page.
3. Modify the bolt clearance values.
   If the boxes are empty, Tekla Structures uses the default value 1.00.

See also Detecting clashes on page 187
1. \( d \) is the larger value of the bolt head or nut diameters

2. Clash check clearance area

4. Ensure that you have selected the check box in front of each box.

   If you clear the check boxes, the clearance will be zero.

5. Click **Apply** or **OK**.

If Tekla Structures cannot find the bolt head or nut diameter in the bolt catalog, it uses the shank diameter instead.

---

**See also**  Detecting clashes on page 187

---

### 11.4 Diagnosing and repairing the model

Use the **Diagnose & Repair Model** commands to check and to repair errors and inconsistencies in the structure of model objects and the library database (xslib). By diagnosing and repairing the model you can ensure, for example, that empty assemblies are removed and that unused points and attributes are deleted. Repairing the model also corrects invalid object relations and hierarchies. We recommend you to diagnose and to repair your model regularly to maintain the consistency and integrity of your model databases.

To diagnose or repair a model or a library database:

1. Click **Tools** --> **Diagnose & Repair Model**.

2. Select the appropriate **Diagnose** or **Repair** command.

   The errors and inconsistencies found in the model are listed in a report. Some of them are automatically corrected, some of them are warnings that you need to correct manually.

   If the model does not contain any errors or inconsistencies, a message is displayed on the status bar.

---

**See also**  Checking the model on page 181

Diagnose and repair model results on page 200

---

**Diagnose and repair model results**

The following table lists the most common errors and inconsistencies found when diagnosing and repairing the model.
### Diagnosis result

<table>
<thead>
<tr>
<th>Diagnosis result</th>
<th>Description</th>
<th>Action needed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Empty assembly</td>
<td>The assembly does not contain any objects.</td>
<td>Click <strong>Tools --&gt; Diagnose &amp; Repair Model --&gt; Repair Model</strong> to delete the assembly.</td>
</tr>
<tr>
<td>Missing assembly</td>
<td>A part is not included in any assembly.</td>
<td>Click <strong>Tools --&gt; Diagnose &amp; Repair Model --&gt; Repair Model</strong> to create an assembly and to move the part to it.</td>
</tr>
<tr>
<td>Illegal profile</td>
<td>An unknown profile has been found.</td>
<td>Change the profile to an allowed profile.</td>
</tr>
</tbody>
</table>

See also  
[Diagnosing and repairing the model on page 200](#)

### 11.5 Comparing parts or assemblies

To compare two parts or assemblies:

1. Select the objects you want to compare.
   - To compare parts, select two parts in the model.
   - To compare assemblies, select a part in each assembly.

2. Click **Tools --> Compare**, and then select either **Parts** or **Assemblies**.
   
   Tekla Structures displays the results on the status bar.

See also  
[Checking the model on page 181](#)

### 11.6 Finding distant objects

When the work area is huge, the model may contain some distant objects that are not easy to find. Use the **Find Distant Objects** command to find these objects.

To find distant objects:

1. Click **Tools --> Diagnose & Repair Model --> Find Distant Objects**.
Tekla Structures displays a list of object IDs. At the end of the list, Tekla Structures displays additional six objects that have the biggest and smallest x, y, or z coordinates.

```
Id: 13218
Id: 13217
Id: 13109
Id: 13108
Id: 13107
Id: 13106
Id: 13105
```

2. Select an object in the list.
3. Right-click and select a command from the pop-up menu.
   You can, for example, inquire or delete the object.

See also  Checking the model on page 181

### 11.7 Keyboard shortcuts for checking the model

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inquire object</td>
<td>Shift+I</td>
</tr>
<tr>
<td>Free measure</td>
<td>F</td>
</tr>
<tr>
<td>Create report</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Open the Views list</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Open the Drawing List</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Print drawings</td>
<td>Shift+P</td>
</tr>
<tr>
<td>Open component catalog</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Create AutoConnections</td>
<td>Ctrl+J</td>
</tr>
<tr>
<td>Advanced options</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Phase manager</td>
<td>Ctrl+H</td>
</tr>
</tbody>
</table>

See also  Checking the model on page 181
This section explains how to change numbering settings and apply numbering in Tekla Structures.

Click the links below to find out more:

- What is numbering and how to plan it on page 203
- Adjusting the numbering settings on page 210
- Numbering parts on page 211
- Changing existing numbers on page 214
- Clearing existing numbers on page 215
- Checking the numbering on page 215
- Viewing the numbering history on page 217
- Repairing numbering errors on page 218
- Renumbering the model on page 218
- Control numbers on page 219
- Numbering parts by design group (Design Group Numbering) on page 226
- Numbering examples on page 228

## 12.1 What is numbering and how to plan it

Before you can create drawings or accurate reports, you need to number all parts in the model. You do not need to number the model before you create general arrangement drawings.

*Numbering* is the key to the production output, for example, drawings, reports, and NC files. Numbers are also needed when you export models. Part numbers are vital in the fabrication, shipping, and erection stages of construction. Tekla Structures assigns a mark to each part and assembly/cast unit in a model. The mark includes part or assembly prefix and position number, and other elements, such as profile or material grade. It is useful to identify the
parts with numbers to see which parts are similar and which different. Identical parts have
the same number, which makes the planning of the production easier.

We recommend that you plan the numbering in an early phase of the project. If other users
are using the same model, it is even more important to make a numbering plan that
everybody in the project follows. You should have the numbering ready before you create the
first drawings and reports.

When planning the numbering, it can be useful to number the model in phases, for example
first floor of the building first, then the second, and so on.

Give start numbers in wide ranges so that you do not run out of numbers. For example, start
the first floor with the start number 1000 and the second with start number 2000.

If the numbering of a part or assembly is not up to date, a question mark (?) is displayed in
the part label and in the Inquire Object dialog box, for example.

<table>
<thead>
<tr>
<th>Assembly information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly Pos:</td>
</tr>
<tr>
<td>Main part profile:</td>
</tr>
</tbody>
</table>

See also  Identical parts on page 204
Inquiring object properties on page 181

Identical parts

Tekla Structures gives parts the same number if the parts are identical in the fabrication or
casting. If a part is deformed after fabrication or casting (for example if the part is cambered,
shortened, or warped), the final geometry on site and in the model may be different.

Tekla Structures treats parts as identical and gives them the same number if the following
basic part properties are the same:

- Part geometry
- Casting direction
- Numbering series
- Profile
- Material
- Finish

You can set the degree of tolerance for part geometry in the Numbering Setup dialog box. If
the geometry of parts differs within this degree of tolerance, Tekla Structures treats the parts
as identical for numbering purposes.

Class and phase do not affect numbering. Tekla Structures gives the same number to
identical parts that belong to different classes or phases.

See also  Part properties on page 241
**Identical reinforcement**

Tekla Structures treats reinforcing bars as identical, and gives them the same number, if the following properties are the same:

- Bar geometry
- Numbering series
- Size
- Grade
- Bending radius

Tekla Structures uses the values of the `rebar_config.inp` file located in the `..\ProgramData\Tekla Structures\<version>\environments\<environment>\system\` folder to round bar dimensions up or down. For example, if you set the rounding accuracy for bar dimensions to 5 and the rounding direction to up, Tekla Structures rounds all bar dimensions up to the nearest 5 mm. In that case, two bars with dimensions of 131 mm and 133 mm would both round up to 135 mm. This gives them identical bar geometry.

Class does not affect numbering. Tekla Structures gives the same number to identical reinforcing bars that belong to different classes.

**See also**

- Reinforcement creation
- Reinforcement settings for drawings

**What affects numbering**

Tekla Structures treats objects as different, and therefore numbers them differently, if the following properties differ:

- Beam orientation
- Column orientation
- Reinforcement
- Cast-in embeds
- Surface treatment (affects only assemblies)
- Welds (affect only assemblies)
- Pop marks
- Contour marking information
• Shortening
• User-defined attributes

To define which properties affect numbering in your model, modify the settings in the **Numbering Setup** dialog box. For example, if two otherwise identical parts have different names and you select the **Part name** check box, Tekla Structures gives the parts different numbers.

By default, a part retains its number, as long as only one part has that particular number, regardless of the settings in the **Numbering Setup** dialog box.

**See also**  
[What is numbering and how to plan it](#) on page 203  
[Identical parts](#) on page 204  
[Identical reinforcement](#) on page 205  
[User-defined attributes in numbering](#) on page 206

**User-defined attributes in numbering**

Tekla Structures treats parts and reinforcing bars as different, and therefore numbers them differently, if the values of a user-defined attribute differ.

**Parts**  
If a user-defined attribute has the variable `special_flag` set to `yes`, Tekla Structures takes this user-defined attribute into account when numbering parts.

**Reinforcements**  
If a user-defined attribute has the variable `consider_in_numbering` set to `yes`, Tekla Structures takes this user-defined attribute into account when numbering reinforcements.

**See also**  
[What affects numbering](#) on page 205  
[User-defined attributes](#) on page 253

**Numbering series**

You can use numbering series to divide steel parts, cast units, and assemblies into groups. For example, you can allocate a separate numbering series to different phases or part types.

The name of a numbering series consists of a `prefix` and a `start number`. You do not have to define a part prefix (for example, you may want to omit the part prefix for minor parts).

When you run numbering, Tekla Structures compares parts that belong to the same series with each other. All identical parts in the same numbering series are given the same part number.
Concrete parts are numbered according to the cast unit numbering settings. For example, if the cast unit prefix is C and the start number is 1, concrete parts will get the part prefix Concrete_C-1. This applies also to concrete components whose part position prefix is Concrete and start number is 1.

**Example**  For example, if you define a numbering series with the prefix P and start number 1001, Tekla Structures numbers that series P1001, P1002, P1003, ...

**See also**  Planning your numbering series on page 207  
Assigning a numbering series to a part on page 208  
Assigning a numbering series to an assembly on page 208  
Family numbers on page 208  
Overlapping numbering series on page 208

**Planning your numbering series**  
Before you start modeling, it is good idea to plan the numbering prefixes and start numbers you will use for the entire project. Careful planning prevents numbering conflicts.

To save time, include the numbering series in the default part properties for each type of part before you start modeling.

You may want to omit the part prefix for minor parts, such as plates. If you do this, ensure that you assign a Start number for that numbering series so that it will not overlap other parts.

**Example**  One way to plan the numbering series is to create a table:

<table>
<thead>
<tr>
<th>Part type</th>
<th>Part Prefix</th>
<th>Part Start number</th>
<th>Assembly Prefix</th>
<th>Assembly Start number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beam</td>
<td>PB</td>
<td>1</td>
<td>AB</td>
<td>1</td>
</tr>
<tr>
<td>Vertical brace</td>
<td>PVB</td>
<td>1</td>
<td>AVB</td>
<td>1</td>
</tr>
<tr>
<td>Horizontal brace</td>
<td>PHB</td>
<td>1</td>
<td>AHB</td>
<td>1</td>
</tr>
<tr>
<td>Rafter</td>
<td>PR</td>
<td>1</td>
<td>AR</td>
<td>1</td>
</tr>
<tr>
<td>Purlin</td>
<td>PP</td>
<td>1</td>
<td>AP</td>
<td>1</td>
</tr>
<tr>
<td>Column</td>
<td>PC</td>
<td>1</td>
<td>AC</td>
<td>1</td>
</tr>
<tr>
<td>Plate</td>
<td>1001</td>
<td></td>
<td>A</td>
<td>1</td>
</tr>
</tbody>
</table>

**See also**  Numbering series on page 206  
Overlapping numbering series on page 208
Assigning a numbering series to a part

To assign a numbering series to a part:

1. Double-click a part to open the part properties dialog box.
2. If you are modifying the properties of a concrete part, go to the Cast unit tab.
3. Under Numbering series, define a part prefix and a start number.
4. Click Modify.

See also  Assigning a numbering series to an assembly on page 208
        Numbering series on page 206

Assigning a numbering series to an assembly

To assign a numbering series to an assembly:

1. Ensure that the Select assemblies selection switch is active.
2. Double-click an assembly to open the assembly properties dialog box.
3. On the Assembly tab, define an assembly prefix and a start number.
4. Click Modify.

See also  Assigning a numbering series to a part on page 208
        Numbering series on page 206

Overlapping numbering series

When you plan numbering, ensure that you reserve enough numbers for each series. If a series overlaps another, Tekla Structures might allocate the same number to different parts.

Tekla Structures warns you about series overlaps. View the numbering history log to check which numbers overlap.

See also  Numbering series on page 206
        Viewing the numbering history on page 217
**Family numbers**

With family numbering you can group objects within the same numbering series into different "families". This can be used, for example, to find similar cast units that can be cast in the same bed.

When you use family numbering, the cast unit position numbers consist of a *family number* and a *qualifier*. For example:

```
TT/102-3
```

1. **Family number**
2. **Qualifier**

Assemblies and cast units that match the comparison criteria you define in the *Numbering Setup* dialog box get the same family number. However, if they have the same family number but different part geometry or materials, they get unique qualifier numbers.

See also  
- Numbering series on page 206  
- Assigning family numbers on page 209  
- Changing the family number of an object on page 210  
- Example: Using family numbers on page 228

**Assigning family numbers**

To assign family numbers to numbering series:

1. Click **Drawings & Reports --> Numbering --> Numbering Settings...** to open the *Numbering Setup* dialog box.
2. Go to the **Family numbering** tab.
3. Define which numbering series to assign family numbers to.
   a. Click **Add series** to open the *Add series* dialog box.

   Tekla Structures displays all the assembly and cast unit numbering series in the model.
   b. Select a numbering series from the list, and then click **Add**.

   The numbering series appears in the family numbering list.
4. Under **Compare**, select the properties that need to be identical for the members of the same family.
Define comparison criteria for each numbering series separately.

Select at least one check box, but not all of them. If you select all the check boxes, the family number will be the same as the normal assembly position, and the qualifier number will be 1 for all. If you do not select any check boxes, only one family number per series is assigned.

5. Click **Apply**.

Tekla Structures stores the settings in the numbering database file `<model_name>.db2` in the current model folder the next time you save the model.

6. If you are assigning family numbers to parts that have already been numbered, clear the existing numbers.

7. Update numbering in the model.

   Tekla Structures assigns a family number to all objects in the numbering series.

**See also**  
Family numbers on page 208

Clearing existing numbers on page 215

---

**Changing the family number of an object**

To change the family number and/or family qualifier of an object:

1. Select the objects whose family numbers you want to change.

2. Click **Drawings & Reports --&gt; Numbering --&gt; Change Number --&gt; Family Number...**

3. In the **Assign Family Number** dialog box, enter the desired values in the **Family number** and **Family qualifier** boxes.

4. Click **Assign**.

**See also**  
Family numbers on page 208

---

### 12.2 Adjusting the numbering settings

You can adjust the numbering settings to better suit your needs. This should be done early in the project, before creating any drawings or reports. Do not change your numbering conventions in the middle of a project.

To adjust the numbering settings:

1. Click **Drawings & Reports --&gt; Numbering --&gt; Numbering Settings...** to open the **Numbering Setup** dialog box.

2. Modify the settings if necessary.

   For example, you can define which part properties affect numbering in your model. Using the default settings is effective in most cases.
3. Click **Apply** or **OK**.

Always check and repair numbering after you have changed the numbering settings.

**See also**
- What affects numbering on page 205
- Numbering settings during a project on page 293
- Repairing numbering errors on page 218

### 12.3 Numbering parts

Use the **Number Modified Objects** command to number all parts that have been created or modified since the last numbering. If this is the first time you run numbering for this model, all parts in the model are new and will therefore be numbered.

To number new and modified parts:

- Click Drawings & Reports --> Numbering --> Number Modified Objects.

  Tekla Structures numbers the parts.

**See also**
- Numbering a series of parts on page 211
- Numbering assemblies and cast units on page 212
- Numbering reinforcements on page 213
- Numbering welds on page 213
- Saving preliminary numbers on page 213
- Numbering parts by design group (Design Group Numbering) on page 226

#### Numbering a series of parts

Use the **Number Series of Selected Objects** command to only number parts that have a certain prefix and start number. This enables you to limit the numbering to certain series of objects only, which can be useful in large models.

Before you start, we recommend that you plan the numbering series carefully, and split the model into smaller numbering series, for example by area or phase.

To number a series of parts:

1. Select the parts that have the desired prefix and start number.

   Only parts that have the same prefix and start number as the selected part will be numbered.
2. Click **Drawings & Reports --> Numbering --> Number Series of Selected Objects**. Tekla Structures numbers all parts in the specified numbering series.

**See also**  
Example: **Numbering selected part types on page 230**  
Example: **Numbering parts in selected phases on page 231**

**Numbering assemblies and cast units**  
To number assemblies and cast units, use the same numbering commands as for numbering parts. Before numbering, you can modify the sort order, which defines how assemblies and cast units are given their position numbers. Sorting does not affect part position.

To number assemblies and cast units:
1. If needed, modify the sort order of assemblies and cast units.
   a. Click **Drawings & Reports --> Numbering --> Numbering Settings...** to open the **Numbering Setup** dialog box.
   b. Modify the sort order by selecting items from the **Sort by** and **Then by** lists.

The default sort order is XYZ. You have the following options:

- The x, y or z coordinates of the main part of the assembly or cast unit
  The sorting is based on the center of gravity (COG) location of the assembly or cast unit. Tekla Structures finds the center of gravity for each assembly and cast unit and compares them in the order you defined.

- The user-defined attribute of an assembly or the main part
  If your sorting is based on user-defined attributes, Tekla Structures displays a list that includes all the available user-defined attributes.

   c. Click **Apply or OK** to save the changes.

2. If needed, modify the other numbering settings.

3. Click **Drawings & Reports --> Numbering --> Number Modified Objects** to number the model.
If you add new parts in the model, parts that have already been numbered are not
renumbered to suit the sorting order. In this case you should check and repair the
numbering of those parts.

See also Repairing numbering errors on page 218

**Numbering reinforcements**
To number reinforcements, use the same numbering commands as for numbering parts.

Note that reinforcements may affect the numbering of parts and cast units. To force Tekla
Structures to give otherwise identical concrete parts and cast units different numbers if they
have different reinforcements, select the **Reinforcing bars** check box in the **Numbering Setup** dialog box.

Part numbering and cast unit numbering do not affect the numbering of reinforcements.

See also Numbering parts on page 211

**Numbering welds**
Use the **Number Welds** command to assign numbers to welds. Weld numbers are displayed
in drawings and reports.

To number welds:

1. Click **Drawings & Reports --> Numbering --> Number Welds...** to open the **Weld Numbering** dialog box.
2. If needed, modify the weld numbering settings.
3. Click **Assign numbers** to start numbering welds.

See also Weld numbering settings on page 276
Numbering parts on page 211

**Saving preliminary numbers**
A preliminary mark is a user-defined attribute that defines the part position number. You can save the current part position numbers as preliminary marks for selected parts. The previous preliminary numbers are overridden.

To save part position numbers for preliminary marks:

1. Select the parts.
2. Click **Drawings & Reports --> Numbering --> Save Preliminary Numbers**.

See also [Numbering parts on page 211](#)

### 12.4 Changing existing numbers

Use the **Change Number** command to change the existing part, assembly, multi-position, or family numbers into something you have defined yourself. This command does not change the numbering series of parts. To prevent drawing, modeling, and fabrication errors, Tekla Structures does not allow you to use identical numbers for two different assemblies or parts.

To change existing numbers:

1. Click **Drawings & Reports --> Numbering --> Change Number** and select one of the following commands:

   ![Numbering Options](image)

   The corresponding dialog box appears.

2. Select a part in the model.

3. Click **Get** to view the current numbering properties of the part.

4. Enter the numbering properties you want to use for this part.

   Note that the position numbers you enter here are not absolute numbers. For example, if the start number of the series is 100, the position numbers refer to numbers in that series. Therefore, position number 1 is actually 100, position number 2 is 101, position number 3 is 102, and so on.

5. If you are changing the assembly number of selected parts, ensure that the **Assign to: Selected objects only** option is selected.

   Otherwise, all parts with the same original number will be renumbered.

6. Click **Assign** to change the number.

   If the number you specified is already in use, Tekla Structures displays a warning and keeps the original number.

   Tekla Structures also displays a warning if the position number is higher than the highest current number. This is for information only and the number is still changed.

See also [Numbering parts on page 211](#)
12.5 Clearing existing numbers

Use the Clear Numbers command to permanently remove the current position numbers of parts. Next time you run numbering, Tekla Structures assigns new numbers to these parts, irrespective of what their previous numbers were.

To clear existing numbers:

1. Select the parts whose numbers you want to clear.
2. Click Drawings & Reports --> Numbering --> Clear Numbers and select one of the following commands:

   - Part and Assembly Numbers
   - Part Numbers
   - Assembly Numbers
   - Reinforcing Bar Numbers

   Tekla Structures removes the position numbers of the selected parts.

See also Numbering parts on page 211

12.6 Checking the numbering

You can check the position numbers in many places:

- In the model, double-click the background to open the Display dialog box, then go to the Advanced tab and add Part position to the Part label. The part labels contain the position numbers.

- You can check the part number in the Drawing List.

[AP:1] STANDARD
[AR:1] STANDARD
[AV:1] STANDARD
• The drawing label shows the position number and the amount of identical parts.

<table>
<thead>
<tr>
<th>Mark</th>
<th>Profile</th>
<th>Material</th>
<th>No.</th>
<th>Length</th>
<th>Area</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC/5</td>
<td>HEA800</td>
<td>5355JR</td>
<td>1</td>
<td>18200</td>
<td>49.1</td>
<td>4086.1</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>49.1</td>
<td>4086.1</td>
</tr>
</tbody>
</table>

• You can use the Inquire commands on the Tools menu.
• You can create reports that list your assembly and part positions.

![Report](image.png)

See also Repairing numbering errors on page 218

### 12.7 Viewing the numbering history

To view the numbering history:

• Click **Tools --> Display Log File --> Numbering History...**

  Tekla Structures displays the numbering log file.

See also

Numbering the model  217  Viewing the numbering history
12.8 Repairing numbering errors

We recommend that you check and repair numbering in the model every now and then, especially before producing drawings or reports.

To check and repair numbering in a model:

1. Click Drawings & Reports --> Numbering --> Numbering Settings... to open the Numbering Setup dialog box.
2. Ensure that the option Compare to old is selected for New parts.
3. Ensure that one of the following options is selected for Modified parts:
   - Compare to old
   - Keep number if possible
4. Click OK to save the changes.
5. Unless you want to repair the entire model, select the objects whose numbering you want to repair.
6. Click Tools --> Diagnose & Repair Model and select one of the following commands:
   - Diagnose & Repair Numbering: All
     This command numbers all parts and assemblies, even the unmodified ones.
   - Diagnose & Repair Numbering: Series of Selected Objects
     This command numbers all parts and assemblies that have the same prefix and start number as the selected part.
     Note that Tekla Structures assigns the position number of the oldest part or assembly to all identical parts, even if a newer part or assembly has a smaller position number.

To manually assign a certain position number on a part or assembly, use the Change Number command after repairing numbering in the model.

See also Changing existing numbers on page 214
12.9 Renumbering the model

Use the Renumber all option when the numbering needs to be started over. This option permanently removes the existing position numbers and resets them with new ones. Any existing drawings will also be removed.

To renumber the entire model:

1. Click Drawings & Reports --> Numbering --> Numbering Settings... to open the Numbering Setup dialog box.
2. Select the Renumber all check box.
3. Click Apply or OK.
4. Click Drawings & Reports --> Numbering --> Number Modified Objects.
5. When you are asked to confirm the renumbering of the model, click Yes.

Tekla Structures renumbers the entire model.

See also Changing existing numbers on page 214
Clearing existing numbers on page 215

12.10 Control numbers

Control numbers are additional numbers that can be used to identify parts in a model. Use control numbers if you need to give additional, unique numbers to assemblies or cast units, regardless of their position numbers.

Control numbers can be useful, for example, when delivering a large number of similar wall elements to the site. To successfully pack and unpack the load, you need to plan the order of the wall elements already when the order is shipped. Although all of the wall elements may have the same cast unit position number, you can assign a unique control number to each individual wall element.

See also Assigning control numbers to parts on page 219
Control number order on page 220
Displaying control numbers in the model on page 221
Removing control numbers on page 222
Locking and unlocking control numbers on page 223
Example: Using control numbers to indicate the erection order on page 223
Assigning control numbers to parts

To assign control numbers to parts:

1. Click Drawings & Reports --> Numbering --> Assign Control Numbers... to open the Create control numbers dialog box.

2. Indicate which parts to assign control numbers to.
   - To number the entire model, do not select any parts.
   - To only number specific parts, select the parts you want to number.

3. If you want to assign control numbers only to parts in a specific numbering series:
   a. In the Numbering list, select By numbering serie.
   b. Enter the prefix and start number in the corresponding boxes.

4. Define the control numbers to be used.
   a. In the Start number of control numbers box, enter the first control number to be used.
   b. In the Step value box, define the control number interval.
      For example, to assign the control numbers 2, 5, 8, 11, and so on, enter 2 in the Start number of control numbers box and 3 in the Step value box.

5. Use the Renumber list to specify how to treat parts that already have control numbers.
   - Select No to keep the existing control numbers.
   - Select Yes to replace the existing control numbers with new ones.

6. Use the First direction, Second direction, and Third direction lists to define the order of control numbers.

7. Click Apply to save the changes.

8. Click Create to number the parts.

See also  Control number order on page 220
         Control number settings on page 276

Control number order

When you assign control numbers, you must define in what order to assign them. The order is based on the location of each part on the global coordinate system. The options are:

- None
- X
- Y
- Z
-X  
-Y  
-Z

With positive directions (X, Y, and Z), the parts with the lowest coordinate value are numbered first. With negative directions (-X, -Y, and -Z), the parts with the highest coordinate value are numbered first.

For example, if the first direction is X, the second direction is Y, and the third direction is Z, numbering starts from the parts that have the lowest x coordinate value. If multiple parts have the same x coordinate, also their y coordinates are compared. If multiple parts have the same x and y coordinates, also their z coordinates are compared.

Example  In the following example, the first direction is X and the second direction is Y. The numbers 1–8 indicate the control numbers.

Displaying control numbers in the model  
If the control numbers are not displayed in the model, you can set them visible using the display settings.

To display control numbers in the model:
1. Double-click the view to open the View Properties dialog box.
2. Click **Display...** and go to the **Advanced** tab.
3. Select the **Part label** check box.
4. In the **Properties** list, select **User-defined attributes**, and then click **Add**.
   The **Part label** dialog box is displayed.
5. Enter **acn** and click **OK**.
   The property is moved to the **Part label** list.
6. Click **Modify**.
   The control numbers are displayed in the model, right after the part position numbers.

**Example** In the following example, the numbers 1–8 indicate the control numbers.

![Diagram showing control numbers](image)

**See also**  [Control numbers on page 219](#)

**Removing control numbers**
If needed, you can remove existing control numbers from all or some of the parts. Do not remove control numbers unless you are absolutely sure that they are no longer needed.
Removing of control numbers is different than reassigning of control numbers. If you only want to reassign new control numbers to parts that already have control numbers, use the Renumber option in the Create control numbers dialog box.

To remove existing control numbers:
1. Double-click the part to open the part properties dialog box.
2. Click User-defined attributes...
   The current control number of the part is displayed on the Parameters tab, next to the Control Number box. For example:
   
   ![Control Number (Do not modify) 2]

3. Remove the existing control number from the box.
4. Click Modify to apply the change.

See also  Control numbers on page 219

Locking and unlocking control numbers
To prevent other users from changing the control numbers of some or all of the parts in the model, use the Lock/Unlock Control Numbers command. Later on, if the control numbers need to be changed, you can use the same command for unlocking the numbers.

To lock or unlock control numbers:
1. Click Drawings & Reports --> Numbering --> Lock/Unlock Control Numbers to open the Lock/Unlock control numbers dialog box.
2. Define which parts’ control numbers to lock or unlock.
   • To lock or unlock the control numbers of all parts, do not select any parts in the model.
   • To lock or unlock the control numbers of specific parts only, select the parts in the model.
3. In the Status list, select Lock or Unlock.
4. Click Apply to save the changes.
5. Click Create to lock or unlock the numbers.

See also  Control numbers on page 219
Example: Using control numbers to indicate the erection order

This example shows how to assign control numbers to six concrete walls. As four of these walls have the same cast unit position, you cannot make a clear distinction between the cast units based on their position number. That is why each wall will get a unique identifier that indicates their erection order at the site. The erection order also affects the order of shipping. For example, the wall number 1 needs to be shipped on top of the delivery, because it will be erected first on the site; the wall number 2 should be the second on the bundle, because it will be erected next; and so on.

The following image represents the desired end result.

![Diagram showing control numbers assigned to concrete walls](image)

To assign control numbers to the concrete walls:
1. Click Drawings & Reports --> Numbering --> Assign Control Numbers... to open the Create control numbers dialog box.

2. Select the six concrete walls.

3. Define that you want to assign control numbers only to parts in the numbering series S with the start number 1.
   a. In the Numbering list, select By numbering serie.
   b. In the Prefix box, enter S.
   c. In the Start number box, enter 1.

4. Define that you want to use the numbers 1–6 as the control numbers for these concrete walls.
   a. In the Start number of control numbers box, enter 1.
   b. In the Step value box, enter 1.

5. Define that you want to first number the walls with identical z coordinates in the order they appear in the positive x axis.
   a. In the First direction list, select Z.
   b. In the Second direction list, select X.

6. Click Apply to save the changes.

7. Click Create to number the concrete walls.

   Each concrete wall gets a unique control number, as shown in the following image.

If you cannot see the control numbers in the model, modify the display settings. For more information on the required settings, see Displaying control numbers in the model on page 221.
Numbering parts by design group (Design Group Numbering)

You can number parts by design groups so that you can differentiate the parts from each other in drawings and reports. The design group numbers can be used in engineering documents or as preliminary numbers.

Use the Design Group Numbering macro to assign prefixes and numbers to parts on the basis of design groups. The Design Group Numbering macro groups parts that match a selection filter into a design group, numbers them, and optionally compares the part lengths.

Before you start:
- Create the needed selection filters that define the design groups.
- In multi-user or Tekla Model Sharing models, make sure that only one of the users runs the Design Group Numbering macro.

To number parts by their design group:
1. In the model, click Tools --> Macros.
2. In the Macros dialog box:
   a. Select Design Group Numbering.
   b. Click Run to start the macro.
3. In the Design group numbering dialog box:
   a. Click Add group to create design group numbering settings for parts matching a selection filter.
- Select the filter in the **Group filter** column.
  The selection filters are read from specific folders in the standard folder search order.
- Enter the design group prefix and start number you want to use for the parts in this group.
- In the **Compare length** column, define whether the part lengths are compared or not.

b. Repeat step 3a for all part groups that you want to number by design group.

c. If needed, change the order of the groups by using the **Move up** and **Move down** buttons.

If a part belongs to several groups, the last group filter in the list overrides the previous ones.

d. If you want to compare part lengths, define the length tolerance.

For example, if you enter 0, parts must be exactly the same length to receive the same design group number. If you enter 2, part lengths can differ 2 mm from each other.

The default tolerance is 0.05 mm.

e. Enter a number separator that is used to separate the design group prefix and number in drawing marks and in reports. For example, enter `-`.

We recommend that you do not change the separator during the project.

f. In **Reimport all**, select whether to renumber all parts or not.

g. To reuse old, unneeded numbers, select the **Reuse old numbers** check box.

h. To number the parts by design group, click **Perform numbering**.

A design group number is saved as the user-defined attribute `DESIGN_GROUP_MARK` of each part.

By default, the user-defined attribute `DESIGN_GROUP_MARK` is available in the `objects.inp` file in the Engineering configuration in the default and US environments.

i. To create a report to show the numbering results, select whether to create a report of all or the selected parts, and then click **Create report**.

Tekla Structures shows the report in the **List** dialog box and also saves the report as `dgnReport.txt` in the `\Reports` folder under the current model folder.

When you select a row in the **List** dialog box, Tekla Structures highlights and selects the corresponding part in the model.

If the numbering of a part is not up to date, meaning that the part has been modified after numbering, a question mark (?) is added after the design group number.

4. To show the design group numbers in drawing marks or in reports, use the user-defined attribute `DESIGN_GROUP_MARK`. 
12.12 Numbering examples

This section gives some examples of numbering the model.

Click the links below to find out more:

- Example: Numbering identical beams on page 228
- Example: Using family numbers on page 228
- Example: Numbering selected part types on page 230
- Example: Numbering parts in selected phases on page 231

Example: Numbering identical beams

This example explains how different numbering settings result in different part numbers when you modify a part.

To number identical beams:

1. Create three identical beams with the numbering series prefix P and start number 1.
2. Number the model. All the beams have the part position number P1.
3. Modify one of the beams.
4. Number the model. You should now have two beams P1 and one P2.
5. Change beam P2 to be identical to the others.
6. Number the model.

Depending on the numbering settings in the Numbering Setup dialog box, Tekla Structures assigns one of the following part position numbers to the modified part:

- Compare to old: P1
- Keep number if possible: P2
- Take new number: P3

See also Numbering parts on page 211
Example: Using family numbers

In this example, the following four beams have the numbering series prefix B and the start number 1. The parts have the same main profile, and each pair has the same length, but the holes are different.

1. Assembly position: B/1
2. Assembly position: B/2
3. Assembly position: B/3
4. Assembly position: B/4

We use the following family numbering settings:

- Numbering series: B/1
- Compare: Main part profile and Overall length

With the given family numbering criteria, Tekla Structures divides the beams into two families. All beams have the same profile, but each pair has a different length. Within both families the beams get different qualifiers because they have different holes.

- The first beam gets the assembly position number B/1-1
- The second beam gets the assembly position number B/1-2
- The third beam gets the assembly position number B/2-1
- The fourth beam gets the assembly position number B/2-2

See also Family numbers on page 208
Example: Numbering selected part types
This example shows how different numbering settings can be used for different part types.
We will use one set of numbering settings for steel anchor rods, and another one for steel columns. Note that the Number Series of Selected Objects command numbers all parts that have the same assembly prefix.

To number anchor rods and columns:
1. Create steel columns.
2. Create anchor rods with the numbering series prefix AR and start number 1.
   Ensure that this numbering series is different to any other parts or assemblies in the model.
3. Click Drawings & Reports --> Numbering --> Numbering Settings... to open the Numbering Setup dialog box.
4. Ensure that the Column orientation check box is not selected, and then click Apply.
5. Select one of the anchor rods in the model.
6. Click Drawings & Reports --> Numbering --> Number Series of Selected Objects.
   All parts with the AR prefix and start number at 1 are numbered.
7. After the anchor rod numbering is complete, click Drawings & Reports --> Numbering --> Numbering Settings... to open the Numbering Setup dialog box.
8. Select the Column orientation check box, and then click Apply.
9. Select one of the steel columns in the model.
10. Click **Drawings & Reports -- Numbering -- Number Series of Selected Objects**.

All columns belonging to the same numbering series as the selected column are numbered.

**See also** Numbering a series of parts on page 211

**Example: Numbering parts in selected phases**
This example shows how to number a model that consists of multiple phases, each phase having a different detailing and submittal schedule. This enables you to release drawings for a particular phase at any time.

Before you start, divide the model into phases.

To number parts in selected phases:
1. Apply a specific numbering series prefix and start number for parts in each phase.
   
   For example:
   - The beams in phase 1 get the numbering series prefix B and start number 1000.
   - The beams in phase 2 get the numbering series prefix B and start number 2000.

---

1. Phase 1: green
2. Phase 2: magenta
2. Ensure that the numbering series are not overlapping.
   
   For example, to avoid numbering overlaps with the beams in phase 2, phase 1 should not contain more than 1000 position numbers.

3. Select the parts you want to number.

   Use selection filters to easily select parts belonging to a certain phase or parts with a specific start number series. You can also use selection filters to ignore specific phases that are already completed or phases that are not ready for numbering.

4. Click Drawings & Reports --> Numbering --> Numbering Settings... to open the Numbering Setup dialog box.

5. Modify the numbering settings, and then click Apply.

6. Select one of the parts you want to number.

7. Click Drawings & Reports --> Numbering --> Number Series of Selected Objects.
   
   All parts belonging to the same numbering series as the selected part are numbered.

See also  Numbering a series of parts on page 211

Numbering settings during a project on page 293
Modeling settings

This section provides more information about the various settings you can modify in Tekla Structures.

Click the links below to find out more:

- General settings on page 233
- View and representation settings on page 236
- Part properties on page 241
- Part position settings on page 254
- Detail properties on page 261
- Numbering settings on page 274

13.1 General settings

This section provides more information about some general modeling settings.

Click the links below to find out more:

- Grid properties on page 233
- Grid line properties on page 234
- Point properties on page 235
- Rotation settings on page 235
- Screenshot settings on page 236

Grid properties

Use the Grid dialog box to view and modify the grid properties. The units depend on the settings in Tools --> Options --> Options --> Units and decimals.
Option | Description
--- | ---
Coordinates | The coordinates of the grid in the x, y, and z directions.  
X: grid lines vertical to the work plane  
Y: grid lines horizontal to the work plane  
Z: elevations in the structure  
You can enter a maximum of 1024 characters. Use a zero at the start to represent a grid on the 0,0 coordinate and spaces as separators for coordinates.  
The x and y coordinates are relative, which means that the entries for x and y are always relative to the previous entry. The z coordinates are absolute, which means that entries for z are absolute distances from the work plane origin.

Labels | The names of the grid lines shown in views.  
The names in the X box are associated with the grid lines parallel to the y axis and vice versa. The Z box is for the names of levels parallel to the work plane.  
If you wish, you can leave the label boxes empty.

Line extensions | Define how far the grid lines extend in the directions Left/Below and Right/Above.

Origin | The coordinates of the grid origin in the x, y, and z directions. These values offset the grid from the work plane origin, not from the global model origin.

Magnetic grid plane | Select to bind objects to grid lines.

User-defined attributes... | Click to access the user-defined properties of the grid.

See also  [Grids on page 26](#)

**Grid line properties**

Use the Grid Line Properties dialog box to view and modify the properties of a single grid line. The units depend on the settings in Tools --> Options --> Options --> Units and decimals.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>The name of the grid line.</td>
</tr>
<tr>
<td>Depth in view plane</td>
<td>The height of the grid plane perpendicular to the view plane.</td>
</tr>
<tr>
<td>Extension Left/Below</td>
<td>Define how far the grid lines extend in the directions Left/Below and Right/Above.</td>
</tr>
<tr>
<td>Magnetic grid plane</td>
<td>Select to bind objects to the grid line.</td>
</tr>
<tr>
<td>User-defined attributes...</td>
<td>Click to access the user-defined properties of the grid.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Visible in drawings</td>
<td>Select to make the grid line visible in drawings.</td>
</tr>
<tr>
<td>Grid line automatic dimensioning</td>
<td>Select to use single grid lines in grid dimensioning.</td>
</tr>
</tbody>
</table>

See also  Single grid lines on page 30

**Point properties**

Use the **Point Information** dialog box to view the properties of a point.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase</td>
<td>The phase number. You can filter objects by their phase numbers.</td>
</tr>
<tr>
<td>Id</td>
<td>The ID number, which is used in log files. You can filter objects by their ID numbers.</td>
</tr>
<tr>
<td>Coordinates</td>
<td>The local (work plane) and global x, y, and z coordinates of a point.</td>
</tr>
<tr>
<td></td>
<td>Indicates the correct location of the point.</td>
</tr>
<tr>
<td></td>
<td>The units depend on the settings in Tools --&gt; Options --&gt; Options --&gt; Units and decimals.</td>
</tr>
</tbody>
</table>

See also  Points on page 54

**Rotation settings**

Use the **Copy - Rotate** and **Move - Rotate** dialog boxes to view and modify the settings that are used when you rotate objects in Tekla Structures. The units depend on the settings in Tools --&gt; Options --&gt; Options --&gt; Units and decimals.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>The x and y coordinates of the start point of the rotation axis.</td>
</tr>
<tr>
<td>Y0</td>
<td></td>
</tr>
<tr>
<td>Origin angle</td>
<td>The angle of the rotation axis when rotating around a line on the work plane.</td>
</tr>
<tr>
<td>Number of copies</td>
<td>Defines the number of copies created.</td>
</tr>
<tr>
<td>dZ</td>
<td>The difference in position between the original and copied object in the z direction.</td>
</tr>
<tr>
<td>Rotation angle</td>
<td>The rotation angle between the original and new position.</td>
</tr>
<tr>
<td>Around</td>
<td>Defines whether the rotation axis is a line on the work plane or in the z direction.</td>
</tr>
</tbody>
</table>
See also

Screenshot settings
Use the Screenshot dialog box to view and modify the screenshot settings.

The following options are available in modeling views and in drawings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View name</td>
<td>Shows the selected view name.</td>
</tr>
<tr>
<td>View</td>
<td>Includes the view content and window borders in the screenshot.</td>
</tr>
<tr>
<td>View without borders</td>
<td>Includes only the view content in the screenshot.</td>
</tr>
<tr>
<td>Rendered view</td>
<td>For high resolution screenshots from rendered views. The Options... button displays the Screenshot Options dialog box. Not available in drawings.</td>
</tr>
<tr>
<td>Place on clipboard</td>
<td>Places the screenshot on the clipboard. Not available in drawings.</td>
</tr>
<tr>
<td>Print to file</td>
<td>Saves the screenshot to a file.</td>
</tr>
</tbody>
</table>

The following screenshot options are only available in rendered views:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Final width</td>
<td>The width of the screenshot. The units depend on the settings in Tools --&gt; Options --&gt; Options --&gt; Units and decimals.</td>
</tr>
<tr>
<td>Final height</td>
<td>The height of the screenshot. The units depend on the settings in Tools --&gt; Options --&gt; Options --&gt; Units and decimals.</td>
</tr>
<tr>
<td>DPI</td>
<td>The pixel density (DPI) of the screenshot. There are limitations to pixel density. You can change the DPI using a graphics editor.</td>
</tr>
<tr>
<td>White background</td>
<td>Uses white background.</td>
</tr>
<tr>
<td>Smooth lines</td>
<td>Uses smooth lines to decrease jagged edges.</td>
</tr>
<tr>
<td>Line width</td>
<td>Sets the line width.</td>
</tr>
</tbody>
</table>

See also  Taking a screenshot on page 178

13.2 View and representation settings
This section provides more information about specific view and representation settings.
Click the links below to find out more:

- View properties on page 237
- Grid view properties on page 238
- Display settings on page 238
- Color settings for parts on page 240
- Color settings for object groups on page 240
- Transparency settings for object groups on page 241

## View properties

Use the View Properties dialog box to view and modify the view properties.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the view.</td>
</tr>
<tr>
<td>Angle</td>
<td>Whether the view angle is Plane or 3D.</td>
</tr>
<tr>
<td>Projection</td>
<td>The projection type of rendered views.</td>
</tr>
<tr>
<td></td>
<td><strong>Orthogonal:</strong> All objects are of equal size (no perspective). When you zoom, text and point size remains the same. In addition, the zoom remains on part surfaces.</td>
</tr>
<tr>
<td></td>
<td><strong>Perspective:</strong> Distant objects appear smaller than close ones, as do text and points. You can zoom, rotate the model, or fly through it.</td>
</tr>
<tr>
<td>Rotation</td>
<td>How the view is rotated around the z and x axes. Rotation is view-specific.</td>
</tr>
<tr>
<td></td>
<td>The units depend on the settings in <strong>Tools --&gt; Options --&gt; Options --&gt; Units and decimals</strong>.</td>
</tr>
<tr>
<td>Color and transparency in all views</td>
<td>The color and transparency setting that is used in all views (according to the status of the objects in the model).</td>
</tr>
<tr>
<td>Representation...</td>
<td>Opens the Object Representation dialog box for defining color and transparency settings.</td>
</tr>
<tr>
<td>View depth</td>
<td>The thickness of the displayed slice of model. You can define the depth separately upwards and downwards from the view plane. Only objects positioned within the view depth are visible in the model.</td>
</tr>
<tr>
<td></td>
<td>The units depend on the settings in <strong>Tools --&gt; Options --&gt; Options --&gt; Units and decimals</strong>.</td>
</tr>
<tr>
<td>Display...</td>
<td>Opens the Display dialog box for defining which objects are displayed in the view and how.</td>
</tr>
<tr>
<td>Visible object group</td>
<td>Which object group is displayed in the view.</td>
</tr>
<tr>
<td>Object group...</td>
<td>Opens the Object Group – View Filter dialog box for creating and modifying object groups.</td>
</tr>
</tbody>
</table>
Grid view properties
Use the **Creation of Views Along Grid Lines** dialog box to view and modify the properties of grid views.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View plane</strong></td>
<td>The plane of the view defined by two axes similarly to the default view.</td>
</tr>
<tr>
<td><strong>Number of views</strong></td>
<td>Defines which grid lines the views will be created of.</td>
</tr>
<tr>
<td>None</td>
<td>does not create any views.</td>
</tr>
<tr>
<td>One (First)</td>
<td>only creates the view closest to the grid origin.</td>
</tr>
<tr>
<td>One (Last)</td>
<td>only creates the view furthest from the grid origin.</td>
</tr>
<tr>
<td>All</td>
<td>creates all views in grid planes in the relevant direction.</td>
</tr>
<tr>
<td><strong>View name prefix</strong></td>
<td>The prefix to be used with the grid label in the view name. This name overrides the name in the view properties. View names consist of a prefix and a grid label, e.g. PLAN +3000. If the <strong>View name prefix</strong> box is left empty, no prefix is used. Tekla Structures adds a dash and a running number to the view name if view names are otherwise identical.</td>
</tr>
<tr>
<td><strong>View properties</strong></td>
<td>Defines which view properties (applied or saved) will be used. Each view plane has its own view properties. You can load the properties from the current view properties with the option <code>&lt;applied values&gt;</code> or from saved view properties. The <strong>Show...</strong> button displays the current view properties.</td>
</tr>
</tbody>
</table>

See also **Creating grid views on page 38**

Display settings
Use the **Display** dialog box to define which object types Tekla Structures displays and how they appear in the model. Some of these settings may affect system performance.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parts</strong></td>
<td>Defines how parts are displayed. Fast uses a rapid drawing technique that displays internal hidden edges, but skips cuts. The setting does not automatically affect already modeled parts. When you switch this setting on, the fast representation mode will be applied only to newly created parts and to parts that are displayed with the <strong>Show with Exact Lines</strong> command.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>Exact</td>
<td>displays the cuts, but hides the internal hidden lines of parts.</td>
</tr>
<tr>
<td>Reference line</td>
<td>shows parts as sticks. This option increases display speed significantly, when viewing the entire model, or large parts of it.</td>
</tr>
<tr>
<td>Bolts</td>
<td>Defines how bolts are displayed.</td>
</tr>
<tr>
<td>Fast</td>
<td>displays the axis and a cross to represent the bolt head. This is the recommended representation mode for bolts, because it increases display speed significantly and consumes less system memory.</td>
</tr>
<tr>
<td>Exact</td>
<td>shows bolts, washers, and nuts as solid objects.</td>
</tr>
<tr>
<td>Holes</td>
<td>Defines how holes are displayed.</td>
</tr>
<tr>
<td>Fast</td>
<td>only displays the circle in the first plane. When using this option, Tekla Structures always displays fast holes on the first part (counting from the head of the bolt). If there are slotted holes in any of the parts, a slotted hole is displayed on the first part, even if the hole in that part is not slotted. The new slotted hole has the same size and rotation as the first slotted hole (counting from the head of the bolt). Holes that are outside a part are always displayed as fast holes in rendered views. Exact shows holes as solid objects. Exact slotted holes only displays slotted holes in exact mode and ordinary holes in fast mode.</td>
</tr>
<tr>
<td>Welds</td>
<td>Defines how welds are displayed.</td>
</tr>
<tr>
<td>Fast</td>
<td>displays a symbol for welds.</td>
</tr>
<tr>
<td>Exact</td>
<td>shows welds as solid objects.</td>
</tr>
<tr>
<td>Construction planes</td>
<td>Defines how construction planes are displayed.</td>
</tr>
<tr>
<td>Reinforcing bars</td>
<td>Defines how reinforcement objects are displayed.</td>
</tr>
<tr>
<td>Fast</td>
<td>displays the shape of reinforcement meshes using an outline polygon and a diagonal line. Single reinforcing bars and bar groups are displayed as solid objects.</td>
</tr>
<tr>
<td>Exact</td>
<td>shows reinforcing bars, bar groups, and reinforcement meshes as solid objects.</td>
</tr>
<tr>
<td>Part label</td>
<td>See Showing part labels in a view on page 72.</td>
</tr>
<tr>
<td>Point size</td>
<td>Defines the size of points in views. You can also change the size of the part handle using this option.</td>
</tr>
<tr>
<td>In model</td>
<td>increases the point size on the screen when you zoom in.</td>
</tr>
<tr>
<td>In view</td>
<td>does not increase the point size.</td>
</tr>
</tbody>
</table>

See also  Setting the visibility and appearance of parts on page 156
Changing the representation of parts and components on page 158
Color settings for parts

Use the **Class** value to change the color of a part.

<table>
<thead>
<tr>
<th>Class</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>light gray</td>
</tr>
<tr>
<td>2 or 0</td>
<td>red</td>
</tr>
<tr>
<td>3</td>
<td>green</td>
</tr>
<tr>
<td>4</td>
<td>blue</td>
</tr>
<tr>
<td>5</td>
<td>turquoise</td>
</tr>
<tr>
<td>6</td>
<td>yellow</td>
</tr>
<tr>
<td>7</td>
<td>magenta</td>
</tr>
<tr>
<td>8</td>
<td>gray</td>
</tr>
<tr>
<td>9</td>
<td>rose</td>
</tr>
<tr>
<td>10</td>
<td>lime</td>
</tr>
<tr>
<td>11</td>
<td>aqua</td>
</tr>
<tr>
<td>12</td>
<td>pink</td>
</tr>
<tr>
<td>13</td>
<td>orange</td>
</tr>
<tr>
<td>14</td>
<td>light blue</td>
</tr>
</tbody>
</table>

See also Changing the color of a part on page 168

Color settings for object groups

Use the **Object Representation** dialog box to define the color of object groups.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>As is</td>
<td>The current color is used. If the object belongs to one of the object groups defined in the following rows, its color is defined by the settings that the object group in question has on that row.</td>
</tr>
<tr>
<td>Colors</td>
<td>Select color from the list.</td>
</tr>
<tr>
<td>Color by class</td>
<td>All parts are colored according to their <strong>Class</strong> property.</td>
</tr>
<tr>
<td>Color by lot</td>
<td>Parts belonging to different lots get different colors.</td>
</tr>
<tr>
<td>Color by phase</td>
<td>Parts belonging to different phases get different colors.</td>
</tr>
<tr>
<td>Color by analysis type</td>
<td>Displays parts according to the member analysis type.</td>
</tr>
<tr>
<td>Color by analysis utility check</td>
<td>Displays parts according to the utilization ratio in analysis.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Color by attribute</td>
<td>Displays parts in different colors according to the values of a user-defined attribute.</td>
</tr>
</tbody>
</table>

See also Changing the color and transparency of parts on page 167

**Transparency settings for object groups**

Use the Object Representation dialog box to define the transparency of object groups.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>As is</td>
<td>The current visibility. If the object belongs to any object group whose visibility and color settings have been defined, the settings will be read from that object group.</td>
</tr>
<tr>
<td>Visible</td>
<td>Object is shown in the views.</td>
</tr>
<tr>
<td>50% transparent</td>
<td>Object is transparent in rendered views.</td>
</tr>
<tr>
<td>70% transparent</td>
<td></td>
</tr>
<tr>
<td>90% transparent</td>
<td></td>
</tr>
<tr>
<td>Hidden</td>
<td>Object is not shown in the views.</td>
</tr>
</tbody>
</table>

See also Changing the color and transparency of parts on page 167

### 13.3 Part properties

This section provides more information about the properties of specific steel and concrete parts.

Click the links below to find out more:

- Steel column properties on page 242
- Steel beam properties on page 243
- Contour plate properties on page 243
- Orthogonal beam properties on page 244
- Twin profile properties on page 245
- Item properties on page 246
- Pad footing properties on page 247
- Strip footing properties on page 248
- Concrete column properties on page 249
Steel column properties

Use the Column Properties dialog box to view and modify the properties of a steel column. The file name extension of a column properties file is *.clm.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part prefix and start number</td>
<td>The part mark series of the column.</td>
</tr>
<tr>
<td>Assembly prefix and start number</td>
<td>The assembly mark series of the column.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of the column. Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the column.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the column.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group columns. For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td>Vertical</td>
<td>See Vertical position on page 258.</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation on page 255.</td>
</tr>
<tr>
<td>Horizontal</td>
<td>See Horizontal position on page 259.</td>
</tr>
<tr>
<td>Top</td>
<td>The position of the second end of the column in the global z direction.</td>
</tr>
<tr>
<td>Bottom</td>
<td>The position of the first end of the column in the global z direction.</td>
</tr>
<tr>
<td>Deforming tab</td>
<td>Warping, cambering, and shortening of the column.</td>
</tr>
</tbody>
</table>

See also Creating a steel column on page 74
Steel beam properties

Use the Beam Properties dialog box to view and modify the properties of a steel beam, steel polybeam, or curved beam. The file name extension of a beam properties file is *.prt.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part prefix and start number</td>
<td>The part mark series of a beam.</td>
</tr>
<tr>
<td>Assembly prefix and start number</td>
<td>The assembly mark series of the beam.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of a beam.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and</td>
</tr>
<tr>
<td></td>
<td>to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of a beam.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of a beam.</td>
</tr>
<tr>
<td>Finish</td>
<td>The finish type.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been</td>
</tr>
<tr>
<td></td>
<td>treated, e.g. with anti-corrosive paint, hot galvanized, fire</td>
</tr>
<tr>
<td></td>
<td>retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group beams.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different</td>
</tr>
<tr>
<td></td>
<td>colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td>On plane</td>
<td>See Position on the work plane on page 254.</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation on page 255.</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth on page 256.</td>
</tr>
<tr>
<td>End offset</td>
<td>See End offsets on page 260.</td>
</tr>
<tr>
<td>Radius</td>
<td>The plane of curvature and radius of a curved beam.</td>
</tr>
<tr>
<td>Number of segments</td>
<td>The number of segments Tekla Structures uses when drawing a curved beam.</td>
</tr>
<tr>
<td>Deforming tab</td>
<td>Warping, cambering, and shortening of the beam.</td>
</tr>
</tbody>
</table>

See also Creating a steel beam on page 75

Contour plate properties

Use the Contour Plate Properties dialog box to view and modify the properties of a contour plate. The file name extension of a contour plate properties file is *.cpl.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part prefix and start number</td>
<td>The part mark series of the contour plate.</td>
</tr>
<tr>
<td>Assembly prefix and start number</td>
<td>The assembly mark series of the contour plate.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of the contour plate.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and</td>
</tr>
<tr>
<td></td>
<td>to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the contour plate.</td>
</tr>
<tr>
<td></td>
<td>The format is PL+ thickness, for example PL20.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the contour plate.</td>
</tr>
<tr>
<td>Finish</td>
<td>The finish type.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been</td>
</tr>
<tr>
<td></td>
<td>treated, e.g. with anti-corrosive paint, hot galvanized, fire</td>
</tr>
<tr>
<td></td>
<td>retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group contour plates.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different</td>
</tr>
<tr>
<td></td>
<td>colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth on page 256.</td>
</tr>
</tbody>
</table>

See also  Creating a contour plate on page 77

### Orthogonal beam properties

Use the **Orthogonal Beam Properties** dialog box to view and modify the properties of an orthogonal steel beam. The file name extension of an orthogonal beam properties file is *.crs*.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part prefix and start number</td>
<td>The part mark series of the beam.</td>
</tr>
<tr>
<td>Assembly prefix and start number</td>
<td>The assembly mark series of the beam.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of the beam.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and</td>
</tr>
<tr>
<td></td>
<td>to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the beam.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the beam.</td>
</tr>
</tbody>
</table>
Option | Description
--- | ---
Finish | The finish type. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.
Class | Used to group beams. For example, you can display parts of different classes in different colors.
User-defined attributes | See User-defined attributes on page 253.
Vertical | See Vertical position on page 258.
Rotation | See Rotation on page 255.
Horizontal | See Horizontal position on page 259.
Top | The position of the second end of the beam in the z direction of the work plane.
Bottom | The position of the first end of the beam in the z direction of the work plane.

See also Creating an orthogonal beam on page 79

Twin profile properties
Use the Twin Profile Properties dialog box to view and modify the properties of a twin steel profile. The file name extension of a twin profile properties file is *.dia.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part prefix and start number</td>
<td>The part mark series of the twin profile.</td>
</tr>
<tr>
<td>Assembly prefix and start number</td>
<td>The assembly mark series of the twin profile.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of the twin profile. Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of both the beams in the twin profile.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the beams.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
</tbody>
</table>
## Option | Description
--- | ---
Class | Used to group twin profiles. For example, you can display parts of different classes in different colors.
User-defined attributes | See User-defined attributes on page 253.
On plane | See Position on the work plane on page 254.
Rotation | See Rotation on page 255.
At depth | See Position depth on page 256.
End offset | See End offsets on page 260.
Twin profile type | Defines how the profiles are combined.
Horizontal | The horizontal clearance between the profiles.
Vertical | The vertical clearance between the profiles.

See also  Creating a twin profile on page 80

### Item properties

Use the Item Properties dialog box to define, view, and modify the properties of an item. The file name extension of an item properties file is .ips.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part prefix</td>
<td>The part mark series of the item.</td>
</tr>
<tr>
<td>Part start number</td>
<td></td>
</tr>
<tr>
<td>Assembly prefix</td>
<td>The assembly mark series of the item.</td>
</tr>
<tr>
<td>Assembly start number</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>The user-definable name of the item. Tekla Structures uses item names in reports and drawing tables, and to identify items of the same type.</td>
</tr>
<tr>
<td>Shape</td>
<td>The shape of the item. To select a shape from the shape catalog, click Select. To show the item shape in reports and drawing tables, use the PROFILE template attribute.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the item.</td>
</tr>
<tr>
<td>Finish</td>
<td>The finish type. Finish is user-definable. It describes how the item surface has been treated.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Class</td>
<td>Used for grouping items. For example, you can display items of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td>On plane</td>
<td>See Position on the work plane on page 254.</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation on page 255.</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth on page 256.</td>
</tr>
<tr>
<td>End offset</td>
<td>See End offsets on page 260.</td>
</tr>
</tbody>
</table>

See also Creating an item on page 80

Shapes

### Pad footing properties

Use the Pad Footing Properties dialog box to view and modify the properties of a pad footing. The file name extension of a pad footing properties file is *.cpf*.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the pad footing. Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the pad footing.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the pad footing.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group pad footings. For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td>Vertical</td>
<td>See Vertical position on page 258.</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation on page 255.</td>
</tr>
<tr>
<td>Horizontal</td>
<td>See Horizontal position on page 259.</td>
</tr>
<tr>
<td>Top</td>
<td>The position of the top surface of the pad footing in the global z direction.</td>
</tr>
<tr>
<td>Bottom</td>
<td>The position of the bottom surface of the pad footing in the global z direction.</td>
</tr>
</tbody>
</table>
### Option  Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cast unit prefix and start number</td>
<td>Define the cast unit series of the pad footing.</td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the footing is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place parts. Used to separate pour objects from one another.</td>
</tr>
</tbody>
</table>

See also  Creating a pad footing on page 81

### Strip footing properties

Use the **Strip Footing Properties** dialog box to view and modify the properties of a strip footing. The file name extension of a strip footing properties file is *\.csf.*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The user-definable name of the strip footing.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td><strong>Profile</strong></td>
<td>The profile of the strip footing.</td>
</tr>
<tr>
<td><strong>Material</strong></td>
<td>The material of the strip footing.</td>
</tr>
<tr>
<td><strong>Finish</strong></td>
<td>The type of finish.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td><strong>Class</strong></td>
<td>Used to group strip footings.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td><strong>User-defined attributes</strong></td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td><strong>On plane</strong></td>
<td>See Position on the work plane on page 254.</td>
</tr>
<tr>
<td><strong>Rotation</strong></td>
<td>See Rotation on page 255.</td>
</tr>
<tr>
<td><strong>At depth</strong></td>
<td>See Position depth on page 256.</td>
</tr>
<tr>
<td><strong>End offset</strong></td>
<td>See End offsets on page 260.</td>
</tr>
<tr>
<td>Cast unit prefix and start number</td>
<td>Define the cast unit series of the strip footing.</td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the footing is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place parts. Used to separate pour objects from one another.</td>
</tr>
<tr>
<td><strong>Radius</strong></td>
<td>The plane of curvature and radius of the curved strip footing.</td>
</tr>
<tr>
<td><strong>Number of segments</strong></td>
<td>The number of segments required to draw a curved strip footing.</td>
</tr>
</tbody>
</table>
Concrete column properties

Use the Concrete Column Properties dialog box to view and modify the properties of a concrete column. The file name extension of a concrete column properties file is *.ccl.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the column. Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the column.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the column.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish. Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group columns. For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td>Vertical</td>
<td>See Vertical position on page 258.</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation on page 255.</td>
</tr>
<tr>
<td>Horizontal</td>
<td>See Horizontal position on page 259.</td>
</tr>
<tr>
<td>Top</td>
<td>The position of the second end of the column in the global z direction.</td>
</tr>
<tr>
<td>Bottom</td>
<td>The position of the first end of the column in the global z direction.</td>
</tr>
<tr>
<td>Cast unit prefix and start number</td>
<td>Define the cast unit series of the column.</td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the column is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place parts. Used to separate pour objects from one another.</td>
</tr>
<tr>
<td>Deforming tab</td>
<td>Warping, cambering and shortening of the column.</td>
</tr>
</tbody>
</table>

See also Creating a concrete column on page 83
Concrete beam properties

Use the **Concrete Beam Properties** dialog box to view and modify the properties of a concrete beam or polybeam. The file name extension of a concrete beam properties file is 

```
*.cbm
```

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the beam.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and</td>
</tr>
<tr>
<td></td>
<td>to identify parts of the same type.</td>
</tr>
<tr>
<td>Profile</td>
<td>The profile of the beam.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the beam.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of finish.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been</td>
</tr>
<tr>
<td></td>
<td>treated, e.g. with anti-corrosive paint, hot galvanized, fire</td>
</tr>
<tr>
<td></td>
<td>retardant coating, etc.</td>
</tr>
<tr>
<td>Class</td>
<td>Used to group beams.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different</td>
</tr>
<tr>
<td></td>
<td>colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See <a href="#">User-defined attributes on page 253</a>.</td>
</tr>
<tr>
<td>On plane</td>
<td>See <a href="#">Position on the work plane on page 254</a>.</td>
</tr>
<tr>
<td>Rotation</td>
<td>See <a href="#">Rotation on page 255</a>.</td>
</tr>
<tr>
<td>At depth</td>
<td>See <a href="#">Position depth on page 256</a>.</td>
</tr>
<tr>
<td>End offset</td>
<td>See <a href="#">End offsets on page 260</a>.</td>
</tr>
<tr>
<td>Radius</td>
<td>The plane of curvature and radius of the curved beam.</td>
</tr>
<tr>
<td>Number of segments</td>
<td>The number of segments required to draw a curved beam.</td>
</tr>
<tr>
<td>Cast unit prefix and start</td>
<td>Define the cast unit series of the beam.</td>
</tr>
<tr>
<td>number</td>
<td></td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the beam is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place parts. Used to separate pour</td>
</tr>
<tr>
<td></td>
<td>objects from one another.</td>
</tr>
<tr>
<td>Deforming tab</td>
<td>Warping, cambering and shortening of the beam.</td>
</tr>
</tbody>
</table>

See also  
**Creating a concrete beam on page 84**

Concrete slab properties

Use the **Concrete Slab Properties** dialog box to view and modify the properties of a concrete slab. The file name extension of a concrete slab properties file is 

```
*.csl
```
### Concrete slab properties

Use the Concrete Panel Properties dialog box to view and modify the properties of a concrete panel. The file name extension of a concrete panel properties file is *.cpn.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The user-definable name of the slab.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses part names in reports and drawing lists, and to identify parts of the same type.</td>
</tr>
<tr>
<td><strong>Thickness</strong></td>
<td>The thickness of the slab.</td>
</tr>
<tr>
<td><strong>Material</strong></td>
<td>The material of the slab.</td>
</tr>
<tr>
<td><strong>Finish</strong></td>
<td>The type of finish.</td>
</tr>
<tr>
<td></td>
<td>Finish is user-definable. It describes how the part surface has been treated, e.g. with anti-corrosive paint, hot galvanized, fire retardant coating, etc.</td>
</tr>
<tr>
<td><strong>Class</strong></td>
<td>Used to group slabs.</td>
</tr>
<tr>
<td></td>
<td>For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td><strong>User-defined attributes</strong></td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td><strong>At depth</strong></td>
<td>See Position depth on page 256.</td>
</tr>
<tr>
<td><strong>Cast unit prefix and start number</strong></td>
<td>Define the cast unit series of the slab.</td>
</tr>
<tr>
<td><strong>Cast unit type</strong></td>
<td>Indicates whether the slab is precast or cast in place.</td>
</tr>
<tr>
<td><strong>Pour phase</strong></td>
<td>The pour phase of cast-in-place parts. Used to separate pour objects from one another.</td>
</tr>
</tbody>
</table>

**See also** [Creating a concrete slab on page 85](#)
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Class</td>
<td>Used to group panels. For example, you can display parts of different classes in different colors.</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td>On plane</td>
<td>See Position on the work plane on page 254.</td>
</tr>
<tr>
<td>Rotation</td>
<td>See Rotation on page 255.</td>
</tr>
<tr>
<td>At depth</td>
<td>See Position depth on page 256.</td>
</tr>
<tr>
<td>End offset</td>
<td>See End offsets on page 260.</td>
</tr>
<tr>
<td>Cast unit prefix and start number</td>
<td>Define the cast unit series of the panel.</td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the panel is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place parts. Used to separate pour objects from one another.</td>
</tr>
<tr>
<td>Radius</td>
<td>The plane of curvature and radius of the curved panel.</td>
</tr>
<tr>
<td>Number of segments</td>
<td>The number of segments required to draw a curved panel.</td>
</tr>
</tbody>
</table>

See also Creating a concrete panel on page 86

Concrete item properties

Use the Concrete Item Properties dialog box to define, view, and modify the properties of a concrete item. The file name extension of a concrete item properties file is .ipc.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The user-definable name of the concrete item. Tekla Structures uses item names in reports and drawing tables, and to identify items of the same type.</td>
</tr>
<tr>
<td>Shape</td>
<td>The shape of the concrete item. To select a shape from the shape catalog, click Select. To show the item shape in reports and drawing tables, use the PROFILE template attribute.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the concrete item.</td>
</tr>
<tr>
<td>Finish</td>
<td>The finish type. Finish is user-definable. It describes how the item surface has been treated.</td>
</tr>
<tr>
<td>Class</td>
<td>Used for grouping items. For example, you can display items of different classes in different colors.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>User-defined attributes</td>
<td>See <a href="#">User-defined attributes on page 253.</a></td>
</tr>
<tr>
<td>On plane</td>
<td>See <a href="#">Position on the work plane on page 254.</a></td>
</tr>
<tr>
<td>Rotation</td>
<td>See <a href="#">Rotation on page 255.</a></td>
</tr>
<tr>
<td>At depth</td>
<td>See <a href="#">Position depth on page 256.</a></td>
</tr>
<tr>
<td>End offset</td>
<td>See <a href="#">End offsets on page 260.</a></td>
</tr>
<tr>
<td>Cast unit prefix</td>
<td>The cast unit series of the concrete item.</td>
</tr>
<tr>
<td>Cast unit start number</td>
<td></td>
</tr>
<tr>
<td>Cast unit type</td>
<td>Indicates whether the concrete item is precast or cast in place.</td>
</tr>
<tr>
<td>Pour phase</td>
<td>The pour phase of cast-in-place items. Used for separating pour objects from one another.</td>
</tr>
</tbody>
</table>

**See also**  
[Creating a concrete item on page 87](#)

**Shapes**

### User-defined attributes

User-defined attributes provide extra information about a part. Attributes can consist of numbers, text, or lists. The following table gives some examples of what you can use attributes for:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Can be used...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>In part and weld marks in Tekla Structures drawings, or in projects.</td>
</tr>
<tr>
<td>Shorten</td>
<td>When drawings of the parts are created, Tekla Structures decreases the true length of the part by this value. This is useful when creating assembly drawings of bracing bars that should always be under tension.</td>
</tr>
<tr>
<td>Camber</td>
<td>In part marks in Tekla Structures drawings.</td>
</tr>
<tr>
<td>Preliminary mark</td>
<td>To obtain preliminary marks for parts in reports.</td>
</tr>
<tr>
<td>Locked</td>
<td>To protect objects from being accidentally changed.</td>
</tr>
<tr>
<td>Shear, Tension, and Moment</td>
<td>To save reaction forces for AutoDefaults. You can enter forces separately for each end of a part.</td>
</tr>
<tr>
<td>User field 1...4</td>
<td>User-defined fields. You can change the names of these fields and add new user-defined fields.</td>
</tr>
<tr>
<td>Connection code</td>
<td>When importing information on connection types into Tekla Structures. You can then use the connection codes as rules in AutoConnection and AutoDefaults. Each end of a part can have a different connection code.</td>
</tr>
<tr>
<td>Moment connection</td>
<td>For selecting whether to show moment connection symbols in drawings or not.</td>
</tr>
</tbody>
</table>
13.4 Part position settings

This section provides more information about specific part position settings. These settings can be modified on the Position tab in the part properties dialog box, or by using the Mini Toolbar.

Click the links below to find out more:

- Position on the work plane on page 254
- Rotation on page 255
- Position depth on page 256
- Vertical position on page 258
- Horizontal position on page 259
- End offsets on page 260

Position on the work plane

Use the On plane option in the part properties dialog box to view and change the part's position on the work plane. The position is always relative to the part's handles.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle</td>
<td>The handles are in the middle of the part.</td>
<td>![Example of Middle Position]</td>
</tr>
<tr>
<td>Right</td>
<td>The part is positioned underneath its handles.</td>
<td>![Example of Right Position]</td>
</tr>
<tr>
<td>Left</td>
<td>The part is positioned above its handles.</td>
<td>![Example of Left Position]</td>
</tr>
</tbody>
</table>
Modification the position of a part on page 105

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle</td>
<td>The work plane is parallel to the part's front</td>
<td></td>
</tr>
<tr>
<td>Right</td>
<td>The work plane is parallel to the part's right</td>
<td></td>
</tr>
<tr>
<td>Left</td>
<td>The work plane is parallel to the part's left</td>
<td></td>
</tr>
</tbody>
</table>

See also Modeling settings 255 Part position settings

Rotation

Use the Rotation option in the part properties dialog box to view and change the rotation of a part around its axis on the work plane.

You can also define the angle of rotation. Tekla Structures measures positive values clockwise around the local x axis.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>The work plane is parallel to the top plane of the part.</td>
<td><img src="image1.png" alt="Top Option Example" /></td>
</tr>
<tr>
<td>Back</td>
<td>The work plane is parallel to the back plane of the part.</td>
<td><img src="image2.png" alt="Back Option Example" /></td>
</tr>
<tr>
<td>Below</td>
<td>The work plane is parallel to the bottom plane of the part.</td>
<td><img src="image3.png" alt="Below Option Example" /></td>
</tr>
</tbody>
</table>

See also [Modifying the position of a part on page 105](#)

### Position depth
Use the **At depth** option in the part properties dialog box to view and change the position depth of the part. The position is always perpendicular to the work plane.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle</td>
<td>The part is positioned in the middle of the work plane.</td>
<td><img src="image4.png" alt="Middle Option Example" /></td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
<td>---------</td>
</tr>
<tr>
<td><strong>Front</strong></td>
<td>The part is positioned above the work plane.</td>
<td><img src="image1" alt="Diagram" /></td>
</tr>
<tr>
<td><strong>Behind</strong></td>
<td>The part is positioned underneath the work plane.</td>
<td><img src="image2" alt="Diagram" /></td>
</tr>
</tbody>
</table>

### Examples

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Middle 400</strong></td>
<td><img src="image3" alt="Diagram" /></td>
</tr>
<tr>
<td><strong>Front 400</strong></td>
<td><img src="image4" alt="Diagram" /></td>
</tr>
<tr>
<td><strong>Behind 400</strong></td>
<td><img src="image5" alt="Diagram" /></td>
</tr>
</tbody>
</table>

**See also**  
[Modifying the position of a part on page 105](#)
**Vertical position**

Use the **Vertical** option in the part properties dialog box to view and change the vertical position of the part. The position is always relative to the part's handles.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Middle</strong></td>
<td>The handle is in the middle of the part.</td>
<td><img src="image1.png" alt="Example Middle" /></td>
</tr>
<tr>
<td><strong>Down</strong></td>
<td>The part is positioned underneath its handle.</td>
<td><img src="image2.png" alt="Example Down" /></td>
</tr>
<tr>
<td><strong>Up</strong></td>
<td>The part is positioned above its handle.</td>
<td><img src="image3.png" alt="Example Up" /></td>
</tr>
</tbody>
</table>

**Examples**

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Middle 200</strong></td>
<td><img src="image4.png" alt="Example Middle 200" /></td>
</tr>
</tbody>
</table>
### Modifying the position of a part on page 105

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Down 200</td>
<td><img src="image1" alt="Down Example" /></td>
</tr>
<tr>
<td>Up 200</td>
<td><img src="image2" alt="Up Example" /></td>
</tr>
</tbody>
</table>

**See also** Modifying the position of a part on page 105

### Horizontal position

Use the **Horizontal** option in the part properties dialog box to view and change the horizontal position of the part. The position is always relative to the part’s handle.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle</td>
<td>The handle is in the middle of the part.</td>
<td><img src="image3" alt="Middle Example" /></td>
</tr>
<tr>
<td>Left</td>
<td>The part is positioned on the left side of its handle.</td>
<td><img src="image4" alt="Left Example" /></td>
</tr>
</tbody>
</table>

**See also** Modeling settings 259 Part position settings
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right</td>
<td>The part is positioned on the right side of its handle.</td>
<td>[Diagram]</td>
</tr>
</tbody>
</table>

### Examples

#### Position

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Middle 150</td>
<td><img src="Middle_150.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Left 150</td>
<td><img src="Left_150.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Right 150</td>
<td><img src="Right_150.png" alt="Diagram" /></td>
</tr>
</tbody>
</table>

**See also**  
Modifying the position of a part on page 105

**End offsets**

Use the Dx, Dy and Dz options in the part properties dialog box to move the ends of a part, relative to its handles. You can enter positive and negative values.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dx</td>
<td>Changes the length of the part by moving the part end point along the line formed by the part handles.</td>
</tr>
<tr>
<td>Dy</td>
<td>Moves the part end perpendicular to the part handles.</td>
</tr>
<tr>
<td>Dz</td>
<td>Moves the part end in the z direction of the work plane.</td>
</tr>
</tbody>
</table>

### Examples

<table>
<thead>
<tr>
<th>Position</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dx</td>
<td><img src="image1" alt="Example 1" /></td>
</tr>
<tr>
<td>End point: 200</td>
<td><img src="image2" alt="Example 1" /></td>
</tr>
<tr>
<td>Dx</td>
<td><img src="image3" alt="Example 2" /></td>
</tr>
<tr>
<td>End point: -200</td>
<td><img src="image4" alt="Example 2" /></td>
</tr>
<tr>
<td>Dy</td>
<td><img src="image5" alt="Example 3" /></td>
</tr>
<tr>
<td>End point: 300</td>
<td><img src="image6" alt="Example 3" /></td>
</tr>
<tr>
<td>Dy</td>
<td><img src="image7" alt="Example 4" /></td>
</tr>
<tr>
<td>End point: -300</td>
<td><img src="image8" alt="Example 4" /></td>
</tr>
<tr>
<td>Dz</td>
<td><img src="image9" alt="Example 5" /></td>
</tr>
<tr>
<td>End point: 400</td>
<td><img src="image10" alt="Example 5" /></td>
</tr>
<tr>
<td>Dz</td>
<td><img src="image11" alt="Example 6" /></td>
</tr>
<tr>
<td>End point: -400</td>
<td><img src="image12" alt="Example 6" /></td>
</tr>
</tbody>
</table>

See also  Modifying the position of a part on page 105
13.5 **Detail properties**

This section provides more information about the properties of specific modeling details. Click the links below to find out more:

- Bolt properties on page 262
- Weld properties on page 266
- List of weld types on page 270
- Corner chamfer properties on page 272
- Edge chamfer properties on page 273

**Bolt properties**

Use the Bolt Properties dialog box to view or modify the properties of a bolt group. The units depend on the settings in Tools --> Options --> Options --> Units and decimals.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bolt size</td>
<td>Bolt diameter.</td>
</tr>
<tr>
<td>Bolt standard</td>
<td>Bolt assembly standard/grade.</td>
</tr>
<tr>
<td>Bolt type</td>
<td>Defines whether the bolts are assembled on-site or in the shop.</td>
</tr>
<tr>
<td>Connect part/assembly</td>
<td>Indicates whether you are bolting a secondary part or a sub-assembly.</td>
</tr>
<tr>
<td>Thread in material</td>
<td>Indicates if the thread of the bolt can be inside the bolted parts. Tekla Structures does not use this value when calculating the length of full-threaded bolts.</td>
</tr>
<tr>
<td>Cut length</td>
<td>Indicates which parts the bolt connects. The value defines the area Tekla Structures should search for parts that belong to the bolt group. Using cut length you can determine whether the bolt will go through one flange or two. Tekla Structures searches for parts using half the cut length value, in both directions from the bolt group plane. In the illustration below, A is the cut length and B is the bolt origin. Tekla Structures calculates the search area as A/2 in both directions from point B.</td>
</tr>
</tbody>
</table>
Tekla Structures warns you if the cut length is too small (i.e. the bolt group contains no parts) and makes the bolt length 100 mm.

If there are large gaps between the connected parts, the gap is added to the length of the bolt. Tekla Structures calculates bolt length using the total distance between the first and last surfaces.

If you want to force a bolt to be a certain length, enter a negative value for cut length (e.g. -150).

**Extra length**

Additional bolt length.

Increases the material thickness that Tekla Structures uses when calculating bolt length. For example, you might need extra bolt length to allow for painting. You can also build additional lengths into bolt assemblies.

**Shape**

Bolt group shape. You have the following options:
- **Array** for rectangular
- **Circle** for circular
- **xy list** for any shape

**Bolt dist X**

See [Bolt group shape on page 265](#).

**Bolt dist Y**

See [Bolt group shape on page 265](#).

**Tolerance**

Tolerance = Hole diameter - Bolt diameter

**Hole type**

Oversized or slotted. This option becomes active when you select the **Parts with slotted holes** check boxes.

**Slotted hole X**

x allowance of a slotted hole. Zero for a round hole.

**Slotted hole Y**

y allowance of a slotted hole. Zero for a round hole.

**Rotate Slots**

If the bolt connects several parts, you may want to rotate alternate holes by 90 degrees. This allows the bolt to move in different directions.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Show cut length as temporary lines** | This option is available in the Auto Bolt modeling tool. Shows were the bolts should be placed even if they are not created.  
• Select to not show the temporary lines.  
• Select to show the temporary lines. |
| **On plane**                    | Moves the bolt group perpendicular to the bolt group x axis.                                                                                                                                                 |
| **Rotation**                    | Defines how far the bolt group is rotated around the x axis, relative to the current work plane.  
For example, you can use this box to indicate on which side of the connected parts you want the bolt head to be. |
| **At depth**                    | Moves the bolt group perpendicular to the current work plane.                                                                                                                                                 |
| **Dx, Dy, Dz**                  | Offsets that move the bolt group by moving the bolt group x axis. Use to change the position of the bolt group.  
The start point values Dx, Dy and Dz move the first end of the bolt group, relative to the bolt group x axis. The end point values move the second end of the bolt group.  
• A positive Dx value moves the start point towards the end point.  
• Dy moves the end point perpendicular to the bolt group x axis on the current work plane.  
• Dz moves the end point perpendicular to the current work plane.  
An example bolt group with the Dx start point set to 75: |
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating bolts on page 120</td>
<td></td>
</tr>
<tr>
<td>User-defined attributes on page 253</td>
<td></td>
</tr>
</tbody>
</table>

---

Bolt group shape

Tekla Structures uses the values of the **Bolt dist X** and **Bolt dist Y** boxes to determine how many bolts the bolt group contains, as shown in the table below:

<table>
<thead>
<tr>
<th>Shape</th>
<th>Bolt dist X</th>
<th>Bolt dist Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>Array</td>
<td>Spacing between bolts, in the x direction of the bolt group.</td>
<td>Spacing between bolts, in the y direction of the bolt group.</td>
</tr>
<tr>
<td>Circle</td>
<td>Number of bolts.</td>
<td>Diameter of the bolt group.</td>
</tr>
<tr>
<td>xy list</td>
<td>x coordinate of each bolt, from the bolt group point of origin.</td>
<td>y coordinate of each bolt, from the bolt group point of origin.</td>
</tr>
</tbody>
</table>

---

Examples

<table>
<thead>
<tr>
<th>Bolt group shape</th>
<th>Dimensions</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Array</td>
<td>Bolt dist X: 150</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bolt dist Y: 100</td>
<td></td>
</tr>
</tbody>
</table>
### Bolt group shape

<table>
<thead>
<tr>
<th>Bolt group shape</th>
<th>Dimensions</th>
<th>Result</th>
</tr>
</thead>
</table>
| Circle          | Number of bolts: 6  
                   Diameter: 100 | ![Diagram](image1.png) |
| xy list         | Bolt dist X: 75 175 250  
                   Bolt dist Y: 75 -50 0 | ![Diagram](image2.png) |

---

**See also**  Creating a bolt group on page 121

---

**Weld properties**

Use the Weld Properties dialog box to view or modify the properties of a weld. The units depend on the settings in Tools --> Options --> Options --> Units and decimals.

Some of the properties are only displayed in reports, not in drawings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Prefix | The weld size prefix. Shown in drawings, but only if the weld size is also defined.  

The standard ISO 2553 prefixes are:  
- a – Design throat thickness  
- s – Penetration throat thickness  
- z – Leg length |
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="option.png" alt="Diagram" /></td>
<td>Note that if the last character of the prefix is ( s ), Tekla Structures creates the solid weld object according to the right-hand image so that ( a ) equals weld size.</td>
</tr>
<tr>
<td><strong>Size</strong></td>
<td>The size of the weld. If you enter a zero or negative weld size, Tekla Structures creates the weld, but does not display it in drawings.</td>
</tr>
<tr>
<td><strong>Type</strong></td>
<td>See List of weld types on page 270.</td>
</tr>
<tr>
<td><strong>Angle</strong></td>
<td>The angle of weld preparation, bevels, or groove. Enter a positive value for bevel and groove welds. Tekla Structures displays the angle between the weld type symbol and the fill type contour symbol.</td>
</tr>
<tr>
<td><strong>Contour</strong></td>
<td>The fill type contour of a weld can be:</td>
</tr>
<tr>
<td></td>
<td>• None</td>
</tr>
<tr>
<td></td>
<td>• Flush</td>
</tr>
<tr>
<td></td>
<td>• Convex</td>
</tr>
<tr>
<td></td>
<td>• Concave</td>
</tr>
<tr>
<td></td>
<td>This setting does not affect solid weld objects.</td>
</tr>
<tr>
<td><strong>Finish</strong></td>
<td>Tekla Structures displays the finish symbol above the weld type symbol in drawings. The options are:</td>
</tr>
<tr>
<td></td>
<td>• G (Grind)</td>
</tr>
<tr>
<td></td>
<td>• M (Machine)</td>
</tr>
<tr>
<td></td>
<td>• C (Chip)</td>
</tr>
<tr>
<td></td>
<td>• ☐ (Flush finished weld)</td>
</tr>
<tr>
<td></td>
<td>• ⬛ (Smooth blended weld face)</td>
</tr>
<tr>
<td></td>
<td>This setting does not affect solid weld objects.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Root face</td>
<td>Root face thickness is the height of the narrowest part inside the root opening. Root face values do not appear in drawings, but you can use the WELD_ROOT_FACE_THICKNESS template attribute in reports to show the root face dimension in the weld list.</td>
</tr>
<tr>
<td>Effective throat</td>
<td>The weld size used in weld strength calculation.</td>
</tr>
<tr>
<td>Root opening</td>
<td>The space between the welded parts. Enter a positive value for square-groove welds.</td>
</tr>
<tr>
<td>Edge/Around</td>
<td>Indicates whether only one edge or the entire perimeter of a face should be welded.</td>
</tr>
<tr>
<td>Workshop/Site</td>
<td>Indicates where the weld should be made. This setting affects assemblies and drawings.</td>
</tr>
<tr>
<td>Position</td>
<td>Defines the position of a weld relative to the work plane. The type and position of the parts to be welded affect the position of the weld. The options for weld position are:</td>
</tr>
<tr>
<td></td>
<td>• + x</td>
</tr>
<tr>
<td></td>
<td>• − x</td>
</tr>
<tr>
<td></td>
<td>• + y</td>
</tr>
<tr>
<td></td>
<td>• − y</td>
</tr>
<tr>
<td></td>
<td>• + z</td>
</tr>
<tr>
<td></td>
<td>• − z</td>
</tr>
<tr>
<td></td>
<td>In most cases, Tekla Structures creates the weld on the face or side of the part that faces in the selected direction (x, y, or z). Also the following factors may affect the position of the weld:</td>
</tr>
<tr>
<td></td>
<td>• perpendicularity of the part edge towards the selected direction (x, y or z)</td>
</tr>
<tr>
<td></td>
<td>• length of the part edge</td>
</tr>
<tr>
<td></td>
<td>• distance of the part edge in the selected direction (x, y or z)</td>
</tr>
<tr>
<td></td>
<td>The following image shows welds in different positions:</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Connect part/assembly</td>
<td>See Using welds to create assemblies on page 90.</td>
</tr>
<tr>
<td>Placement</td>
<td>Defines how the weld is placed in relation to the assembly parts. The options are:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Auto</strong></td>
</tr>
<tr>
<td></td>
<td>The weld placement adapts to the typical situation of the weld type. Square-, V-, and U-groove welds are located in the middle of the main and secondary parts. Single-bevel and J-groove welds are located on the secondary part side. This is the default option.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Main part</strong></td>
</tr>
<tr>
<td></td>
<td>The weld is located fully on the main part side. Does not affect V- or U-groove welds.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Secondary part</strong></td>
</tr>
<tr>
<td></td>
<td>The weld is located fully on the secondary part side. Does not affect V- or U-groove welds.</td>
</tr>
<tr>
<td>Preparation</td>
<td>Defines which assembly parts, if any, are automatically prepared for welding. The options are:</td>
</tr>
<tr>
<td></td>
<td>- <strong>None</strong></td>
</tr>
<tr>
<td></td>
<td>Parts are not prepared for welding. This is the default option.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Auto</strong></td>
</tr>
<tr>
<td></td>
<td>Parts are prepared for welding according to the weld type.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>• <strong>Main part</strong></td>
<td>The main part is prepared for welding.</td>
</tr>
<tr>
<td>• <strong>Secondary part</strong></td>
<td>The secondary part is prepared for welding.</td>
</tr>
<tr>
<td>User-defined attributes...</td>
<td>See User-defined attributes on page 253.</td>
</tr>
<tr>
<td><strong>Shape</strong></td>
<td>The shape of the weld can be:</td>
</tr>
<tr>
<td>•</td>
<td>(Regular, continuous weld)</td>
</tr>
<tr>
<td>•</td>
<td>(Intermittent weld)</td>
</tr>
<tr>
<td>•</td>
<td>(Staggered, intermittent weld)</td>
</tr>
<tr>
<td><strong># of incr.</strong></td>
<td>The amount of increments in an intermittent weld.</td>
</tr>
<tr>
<td></td>
<td>Only use with the ISO standard.</td>
</tr>
<tr>
<td><strong>Length</strong></td>
<td>Defines the length value that is shown in the weld mark.</td>
</tr>
<tr>
<td></td>
<td>For intermittent welds, defines the length of an increment.</td>
</tr>
<tr>
<td></td>
<td>Does not affect continuous solid weld objects.</td>
</tr>
<tr>
<td><strong>Pitch</strong></td>
<td>If the advanced option XS_AISC_WELD_MARK is set to TRUE, the center-to-center spacing of weld increments in an intermittent weld.</td>
</tr>
<tr>
<td></td>
<td>If the advanced option XS_AISC_WELD_MARK is set to FALSE, the space between the weld increments in an intermittent weld.</td>
</tr>
<tr>
<td></td>
<td>Tekla Structures uses the – character by default to separate weld length and pitch, for example 50–100. To change the separator to @, for example, set the advanced option XS_WELD_LENGTH_CC_SEPARATOR_CHAR to @.</td>
</tr>
<tr>
<td><strong>NDT inspection level</strong></td>
<td>Defines the non-destructive testing and inspection level.</td>
</tr>
<tr>
<td><strong>Electrode classification</strong></td>
<td>Defines the weld electrode classification.</td>
</tr>
<tr>
<td><strong>Electrode strength</strong></td>
<td>Defines the electrode strength.</td>
</tr>
<tr>
<td><strong>Electrode coefficient</strong></td>
<td>Defines the electrode strength coefficient.</td>
</tr>
<tr>
<td><strong>Welding process type</strong></td>
<td>Defines the process type.</td>
</tr>
<tr>
<td><strong>Reference text</strong></td>
<td>Additional information to appear in the weld symbol. For example, information about the weld specification or process.</td>
</tr>
</tbody>
</table>

See also  Welding parts on page 128

XS_AISC_WELD_MARK
List of weld types

Use the Weld Properties dialog box to define the weld type. Some weld types also automatically prepare the parts to be welded. The following table shows the available weld types:

<table>
<thead>
<tr>
<th>Number</th>
<th>Type</th>
<th>Name</th>
<th>Optional automatic weld preparation</th>
<th>Solid weld object</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>None</td>
<td>None</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>10</td>
<td>▽</td>
<td>Fillet weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>3</td>
<td>V</td>
<td>Bevel-groove (single-V butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>4</td>
<td>V</td>
<td>Bevel-groove (single-bevel butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>2</td>
<td>II</td>
<td>Square-groove (square butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>5</td>
<td>Y</td>
<td>Single-V butt weld with broad root face</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>6</td>
<td>V</td>
<td>Single-bevel butt weld with broad root face</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>7</td>
<td>Y</td>
<td>U-groove weld (single-U butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>8</td>
<td>V</td>
<td>J-groove weld (single-J butt weld)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>16</td>
<td>V</td>
<td>Flare V-groove weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>15</td>
<td>V</td>
<td>Flare-bevel-groove weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>1</td>
<td>J</td>
<td>Edge-flange weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>17</td>
<td>I</td>
<td>Corner-flange weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>11</td>
<td>◄</td>
<td>Plug weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>9</td>
<td>◄</td>
<td>Bevel backing weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>12</td>
<td>O</td>
<td>Spot weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>13</td>
<td>◆</td>
<td>Seam weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>14</td>
<td>□</td>
<td>Slot weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>18</td>
<td>V + △</td>
<td>Partial penetration weld (single-bevel butt + fillet)</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>19</td>
<td>□ + △</td>
<td>Partial penetration weld (square groove + fillet)</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>20</td>
<td>□</td>
<td>Melt-through weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>21</td>
<td>▼</td>
<td>Steep-flanked single-V butt weld</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Number</td>
<td>Type</td>
<td>Name</td>
<td>Optional automatic weld preparation</td>
<td>Solid weld object</td>
</tr>
<tr>
<td>--------</td>
<td>------</td>
<td>-------------------------------------------</td>
<td>--------------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>22</td>
<td>I</td>
<td>Steep-flanked single-bevel butt weld</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>23</td>
<td>III</td>
<td>Edge weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24</td>
<td>~</td>
<td>Surfacing weld</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>25</td>
<td>@</td>
<td>Fold joint</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>26</td>
<td>//</td>
<td>Inclined joint</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

**Corner chamfer properties**

Use the Chamfer Properties dialog box to view and modify the properties of a corner chamfer. The units depend on the settings in Tools --> Options --> Options --> Units and decimals.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>The shape of the chamfer.</td>
</tr>
<tr>
<td>x</td>
<td>The dimensions of the chamfer. The dimension depends on the chamfer type.</td>
</tr>
<tr>
<td>y</td>
<td>dz1</td>
</tr>
<tr>
<td>dz2</td>
<td>Moves the top or bottom surface of the part corner in the part's local z direction. Use these options, for example, to give plates varying thicknesses.</td>
</tr>
</tbody>
</table>

See also Chamfering part corners on page 139

**Corner chamfer types and dimensions**

The table below describes the available corner chamfer types and dimensions. Straight chamfers can have different dimensions in two directions. Curved chamfers only use one dimension.

<table>
<thead>
<tr>
<th>Type</th>
<th>Symbol</th>
<th>Dimensions</th>
</tr>
</thead>
</table>
| None   | ![image] | x: not used  
y: not used |
| Line   | ![image] | x: the distance in the x coordinate direction from the corner  
y: the distance in the y coordinate direction from the corner |
<table>
<thead>
<tr>
<th>Type</th>
<th>Symbol</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Rounding</strong></td>
<td>![Symbol]</td>
<td>x: the radius</td>
</tr>
<tr>
<td></td>
<td></td>
<td>y: not used</td>
</tr>
<tr>
<td><strong>Arc</strong></td>
<td>![Symbol]</td>
<td>x: the radius</td>
</tr>
<tr>
<td></td>
<td></td>
<td>y: not used</td>
</tr>
<tr>
<td><strong>Arc point</strong></td>
<td>![Symbol]</td>
<td>x: not used</td>
</tr>
<tr>
<td></td>
<td></td>
<td>y: not used</td>
</tr>
<tr>
<td><strong>Square</strong></td>
<td>![Symbol]</td>
<td>The chamfer is perpendicular to the edges.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>x: the distance in the x coordinate direction from the corner</td>
</tr>
<tr>
<td></td>
<td></td>
<td>y: the distance in the y coordinate direction from the corner</td>
</tr>
<tr>
<td><strong>Square parallel</strong></td>
<td>![Symbol]</td>
<td>The chamfer is parallel to the opposite edge.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>x: the distance in the x coordinate direction from the corner</td>
</tr>
<tr>
<td></td>
<td></td>
<td>y: the distance in the y coordinate direction from the corner</td>
</tr>
<tr>
<td><strong>Line and arc</strong></td>
<td>![Symbol]</td>
<td>x (if smaller than y): the arc radius</td>
</tr>
<tr>
<td></td>
<td></td>
<td>x (if bigger than y): the distance in the x coordinate direction from the corner</td>
</tr>
<tr>
<td></td>
<td></td>
<td>y (if smaller than x): the arc radius</td>
</tr>
<tr>
<td></td>
<td></td>
<td>y (if bigger than x): the distance in the y coordinate direction from the corner</td>
</tr>
</tbody>
</table>

See also [Chamfering part corners on page 139](#)

## Edge chamfer properties

Use the **Edge Chamfer Properties** dialog box to view and modify the properties of an edge chamfer. The units depend on the settings in **Tools --> Options --> Options --> Units and decimals**.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>More information</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>The shape of the chamfer.</td>
<td></td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>The name of the chamfer.</td>
<td></td>
</tr>
<tr>
<td><strong>Cutting distance in X direction</strong></td>
<td>Defines how far away from the chamfered edge the chamfer will end in the x direction.</td>
<td></td>
</tr>
<tr>
<td><strong>Cutting distance in Y direction</strong></td>
<td>Defines how far away from the chamfered edge the chamfer will end in the y direction.</td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
<td>More information</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>First end type</td>
<td>The shape and position of the first end point.</td>
<td>The options are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Full</strong>: The end point is positioned at the end of the part (moving along the nearest edge), and the shape is straight.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Straight</strong>: The end point is positioned at the point you pick, and the shape is straight.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Bevelled</strong>: The end point is positioned at the point you pick, and the shape is angled.</td>
</tr>
<tr>
<td>Second end type</td>
<td>The shape and position of the second end point.</td>
<td></td>
</tr>
<tr>
<td>Dimension</td>
<td>The distance between the (picked) end point and the bevelled points.</td>
<td></td>
</tr>
</tbody>
</table>

See also  [Chamfering part edges on page 141](#)

### 13.6 Numbering settings

This section provides more information about specific numbering settings.

Click the links below to find out more:

- [General numbering settings on page 274](#)
- [Weld numbering settings on page 276](#)
- [Control number settings on page 276](#)

#### General numbering settings

Use the **Numbering Setup** dialog box to view and modify some general numbering settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Renumber all</td>
<td>All parts get a new number. All information on previous numbers is lost.</td>
</tr>
<tr>
<td>Re-use old numbers</td>
<td>Tekla Structures reuses the numbers of parts that have been deleted. These numbers may be used to number new or modified parts.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Check for standard parts</td>
<td>If a separate standard-part model has been set up, Tekla Structures compares the parts in the current model to those in the standard-part model. If the part to be numbered is identical to a part in the standard-part model, Tekla Structures uses the same part number as in the standard-part model.</td>
</tr>
<tr>
<td>Compare to old</td>
<td>The part gets the same number as a previously numbered similar part.</td>
</tr>
<tr>
<td>Take new number</td>
<td>The part gets a new number even if a similar numbered part already exists.</td>
</tr>
<tr>
<td>Keep number if possible</td>
<td>Modified parts maintain their previous numbers if possible. Even if a part or assembly becomes identical with another part or assembly, the original position number is maintained. For example, you might have two different assemblies, B/1 and B/2, in the model. Later on you modify B/2 so that it becomes identical with B/1. If the Keep number if possible option is used, B/2 will maintain its original position number when you renumber the model.</td>
</tr>
<tr>
<td>Synchronize with master model model</td>
<td>Use this setting when working in multi-user mode. Tekla Structures locks the master model and performs a save, numbering, and save sequence, so that all other users can continue working during the operation.</td>
</tr>
<tr>
<td>Automatic cloning</td>
<td>If the main part of a drawing is modified and therefore gets a new assembly position, the existing drawing is automatically assigned to another part of the position. If the modified part moves to an assembly position that does not have a drawing, the original drawing is automatically cloned to reflect the changes in the modified part.</td>
</tr>
<tr>
<td>Holes</td>
<td>The location, size, and number of holes affects numbering.</td>
</tr>
<tr>
<td>Part name</td>
<td>The part name affects numbering.</td>
</tr>
<tr>
<td>Beam orientation</td>
<td>The orientation of beams affects numbering of assemblies.</td>
</tr>
<tr>
<td>Column orientation</td>
<td>The orientation of columns affects numbering of assemblies.</td>
</tr>
<tr>
<td>Reinforcing bars</td>
<td>Reinforcing bars affect numbering.</td>
</tr>
<tr>
<td>Embedded objects</td>
<td>Embedded objects affect numbering.</td>
</tr>
<tr>
<td>Surface treatment</td>
<td>Surface treatments affect the numbering of assemblies.</td>
</tr>
<tr>
<td>Welds</td>
<td>Welds affect the numbering of assemblies.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>Parts get the same number if their dimensions differ less than the value entered in this box.</td>
</tr>
<tr>
<td>Assembly position sort order</td>
<td>See Numbering assemblies and cast units on page 212.</td>
</tr>
</tbody>
</table>
Weld numbering settings

Use the Weld Numbering dialog box to view and modify the weld numbering settings. The weld number is displayed in drawings and weld reports.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start number</td>
<td>The number from which the numbering starts. Tekla Structures automatically suggests the following free number as the start number.</td>
</tr>
<tr>
<td>Apply for</td>
<td>Defines which objects are affected by the change.</td>
</tr>
<tr>
<td>All welds</td>
<td>changes the number of all welds in the model.</td>
</tr>
<tr>
<td>Selected welds</td>
<td>changes the number of the selected welds without affecting others.</td>
</tr>
<tr>
<td>Renumber also welds that have a number</td>
<td>Tekla Structures replaces existing weld numbers.</td>
</tr>
<tr>
<td>Re-use numbers of deleted welds</td>
<td>If some welds have been removed, Tekla Structures uses their numbers when numbering other welds.</td>
</tr>
</tbody>
</table>

Control number settings

Use the Create control numbers (S9) dialog box to view and modify the control number settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numbering</td>
<td>Defines which parts get control numbers.</td>
</tr>
<tr>
<td>All</td>
<td>creates consecutive numbers for all parts.</td>
</tr>
<tr>
<td>By numbering series</td>
<td>creates control numbers for parts in a specific numbering series.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Assembly/Cast unit numbering series</td>
<td>Defines the prefix and start number of the numbering series for which to create control numbers. Needed only with the <strong>By numbering series</strong> option.</td>
</tr>
<tr>
<td>Start number of control numbers</td>
<td>The number from which the numbering starts.</td>
</tr>
<tr>
<td>Step value</td>
<td>Defines the interval between two control numbers.</td>
</tr>
<tr>
<td>Renumber</td>
<td>Defines how to treat parts that already have control numbers.</td>
</tr>
<tr>
<td></td>
<td><strong>Yes</strong> replaces the existing control numbers.</td>
</tr>
<tr>
<td></td>
<td><strong>No</strong> keeps the existing control numbers.</td>
</tr>
<tr>
<td>First direction</td>
<td>Defines in what order to assign control numbers.</td>
</tr>
<tr>
<td>Second direction</td>
<td></td>
</tr>
<tr>
<td>Third direction</td>
<td></td>
</tr>
</tbody>
</table>

**See also**  Control numbers on page 219
This section provides useful hints and tips that help you to model structures more quickly and accurately, and avoid potential problems with templates and drawings.

Click the links below to find out more:

- General modeling tips on page 278
- Tips for creating and positioning parts on page 284
- Tips for numbering on page 292

14.1 General modeling tips

These tips will help you to use some basic modeling functionalities more efficiently.

Click the links below to find out more:

- Creating a radial grid on page 278
- If you cannot see all objects on page 280
- Should I model in a 3D or plane view? on page 281
- Activating an overlapping view on page 281
- Hiding cut lines in a view on page 281
- Showing part reference lines in model views on page 282
- Cutting efficiently on page 282
- Right-hand rule on page 283
- Finding RGB values for colors on page 283
- Using an autosaved model on page 284
Creating a radial grid

You can create a radial grid using a modeling tool called Radial Grid (1). You can preview the grid before creating it.

To create a radial grid:

1. Press Ctrl+F to open the Component Catalog.
2. Select Plugins from the list.
3. Double-click RadialGrid to open the properties dialog box.
4. Modify the grid properties.

In the coordinate properties

- **X** defines the location of the arched grid lines and the distance between the grid lines.
  The first value is the radius of the innermost arc.

- **Y (degrees)** defines the location of the straight grid lines and the distance between the grid lines in degrees.
  The first value defines how the grid is rotated. The grid is rotated counter-clockwise from the x axis in the current work plane.

5. Click OK.
6. Pick a point to indicate the origin of the grid.
The grid is created automatically.

Limitations  You cannot modify the radial grid using the general grid properties dialog box.

See also  Grid properties on page 233

If you cannot see all objects
The visibility of objects in a view depends on a number of different settings. If you cannot see all the desired objects in a model view, check the following settings:

- work area
- view depth
- view filter
- view and representation settings
- color and transparency settings

Note that work area and view depth are like two virtual boxes. Objects that have their handles partially or totally inside both boxes are visible. Newly created objects are also visible outside the view depth but never outside the work area. When you redraw a view, only the objects inside the view depth are displayed.
Should I model in a 3D or plane view?

3D, plane, and elevation views provide different types of information, which is useful for different tasks.

One common technique is to open several views:

- A 3D view to see a real-life version of the model
- A plane view, where you can add and connect parts
- An elevation view to check the level

If you are working with two screens, maximize your work area by putting the elevation and 3D views on one screen and the plane view on the other.

Activating an overlapping view

When you want to pick positions from two views that partly overlap, you can use the Xmouse option. With Xmouse active, simply moving the mouse pointer over a view activates the view.

To activate a view using Xmouse:

1. Click **Tools** --> **Options** --> **Xmouse** to switch on Xmouse.
   
   A check mark appears next to the menu option if Xmouse is already switched on.

2. To activate a view, do one of the following:
   
   - Move the mouse pointer over the view.
   - Use the Page Up, Page Down and arrow keys.

Hiding cut lines in a view

To hide all cut lines in a view:

1. Double-click the view to open the View Properties dialog box.

2. Click **Display** to open the Display dialog box.
3. Clear the **Cuts** check box.

4. Click **Modify**.

**See also**  
Cutting parts on page 136

---

**Showing part reference lines in model views**

The part reference line is formed between the part handles. By default, the part reference line is invisible in the model. It may be useful to display it when snapping to the middle points of parts, for example.

To show the part reference lines in the model:

1. Click **View --> View Properties...**
2. Click **Display...** to open the **Display** dialog box.
3. On the **Advanced** tab, select the **Part reference line** check box.
4. Click **Modify** and **OK**.

The part reference lines are displayed.

**See also**  
Part handles on page 69

---

**Cutting efficiently**

Follow these guidelines when cutting objects in the model:

- **Avoid part faces**

  Avoid creating cuts that are exactly on the part planes or go through vertices. Try to position the cut at least 0.3 mm outside of the part planes.
• **Use polygon cuts**
  Whenever possible, use polygon cuts. The **Cut part with polygon** command automatically extends the cut slightly outside of the part face. Note that after creating the polygon, you may have to adjust the position of the handles manually.

• **Use edge chamfers**
  Whenever possible, use edge chamfers instead of small cuts, especially in components.

• **Tips for flange cuts**
  When cutting a flange, if the cutting part cuts very slightly the web as well (at least 0.3 mm), the cut is more likely to succeed. For example, if you are cutting a beam that has roundings, it may be useful to cut even further onto the web than just the flange thickness.

• **Tips for round tube cuts**
  Use the **Round tube (23)** component for round tube cuts. The component automatically rotates the cutting part until a successful cut position is found. If the component fails, rotate the cutting part slightly until you find a successful cut position.

If a cut fails, Tekla Structures displays the cutting part using dash-and-dot lines. An error notification is printed in the session history log stating which part and which cut caused the failure.

To locate the failure in the model, click a row that contains an ID number in the session history log. Tekla Structures selects the corresponding part and cut in the model.

---

**See also**  [Cutting parts on page 136](#)

---

**Right-hand rule**
Right-hand rule indicates the direction of the coordinate axes. When you hold the thumb, index finger, and middle finger of your right hand so that they form three right angles, then the thumb symbolizes the x axis, the index finger the y axis, and the middle finger the z axis.
Finding RGB values for colors

Use the Tekla Structures Background Color Selector tool to find a suitable background color for your model.

To find RGB values for colors:
1. Go to Selecting background color for model editor.
2. Download and install the application.

Alternatively, you can use the Color picker tool available at Color picker for Tekla Structures.

Using an autosaved model

You can select to use an autosaved model if there are errors when trying to open a model.

When you open a model, Tekla Structures automatically checks if the previous session ended normally. If it did not, Tekla Structures asks whether you want to continue by using the autosaved model or the original model.

If Tekla Structures displays the warning Fatal: Model memory corrupted by read, it means that hardware problems have damaged the model database. Your hard disk may be damaged. Use autosave or system backup files to restore the model.

See also Opening a model on page 13

14.2 Tips for creating and positioning parts

These tips will help you to efficiently create and position parts in a model view.

Click the links below to find out more:
- Defining default part properties on page 285
- Creating curved parts on page 285
- Creating horizontal parts on page 287
- Creating beams close to each other on page 287
- Alternative way of creating a round plate or slab on page 287
- Positioning columns, pad footings, and orthogonal beams on page 288
- Positioning objects in a radial or circular pattern on page 289
- Optional ways of placing objects in a model on page 289
- Displaying objects connected to a part on page 290
- Showing the attached parts on page 291
- Modeling identical areas on page 291
- Creating bolts by modifying an existing bolt group on page 291

**Defining default part properties**

Save time by saving a default set of properties for each part you plan to create before you start modeling.

To define default sets of part properties for a project:

1. Double-click a part to open the part properties dialog box.
2. Enter the part properties you want to use as defaults.
3. In the box next to the **Save as** button, enter a name for the set of properties. For example, enter **BEAM**.
4. Click **Save as** to save the set of properties.
5. Click **OK** to close the part properties dialog box.
6. Continue to save sets of properties for each type of part you intend to create.
7. To make the sets of part properties you have defined the default sets for this project, click **Tools** --> **Defaults** --> **Save Defaults**.

---

To use a default set of part properties, open the part properties dialog box and select an option from the list next to the **Load** button. Click **Load** to load the properties.
Creating curved parts
You can create curved parts by defining a radius and the number of segments for a part. The number of segments determines how realistic the curved part looks: the more segments, the less angular the part appears.

To create a curved part:
1. Create a part that can be bent: a beam, panel, or strip footing.
2. Double-click the part to open the part properties dialog box.
3. Go to the Curved beam settings area.
   These settings can be found either on the Position tab or on the Bending tab, depending on the part type.
4. In the Radius box, enter the radius.
5. In the Number of segments box, enter the number of segments you want to use.
6. If needed, define the plane of curvature, which is relative to the current work plane.
7. Click Modify to bend the part.

Examples

<table>
<thead>
<tr>
<th>Number of segments: 2</th>
<th>![Example 1]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of segments: 5</td>
<td>![Example 2]</td>
</tr>
</tbody>
</table>
Creating horizontal parts

When creating horizontal parts, such as beams, always pick points in the same direction. For example, pick positions from left to right, and from bottom to top (in positive x, y directions). This ensures that Tekla Structures places and dimensions the parts in the same way in drawings, and that part marks automatically appear at the same part end.

To ensure that beam rotation is correct in drawings, set part Rotation to Top in the part properties dialog box.

Creating beams close to each other

When you create beams so that they are located very close to each other Tekla Structures may consider them as a twin profile. To prevent this from happening, use the user attribute MAX_TWIN_SEARCH_DIST in the profile catalog.

To create beams close to each other:

1. Click Modeling --> Profiles --> Profile Catalog... to open the profile catalog.
2. Select the desired profile in the profile tree.
3. Go to the User attributes tab and set the property Twin profile detection distance to a larger value than 0, for example to 0.1.
4. Click OK.
5. Create the beams using the profile.

See also Creating a steel beam on page 75
Creating a twin profile on page 80
Alternative way of creating a round plate or slab

This example shows an alternative method for creating round plates and slabs.

To create a round plate or slab:
1. Create a diamond-shaped plate or slab with four equal sides.
2. To round the corners, use the arc point chamfer type.

See also
- Creating a round contour plate on page 78
- Creating a round slab on page 86

Positioning columns, pad footings, and orthogonal beams

For parts that you create by picking only one point (such as columns), you can define the top and bottom level of the part in the global z direction. The part is created at the defined level, not at the level you picked in the model. This can be useful when creating multi-story structures, as you can define exact levels for each part you create.

To define the top and bottom levels of a part:
1. Create a part that requires you to pick only one point.
   For example, a column.
2. Double-click the part to open the part properties dialog box.
3. Go to the Position tab.
4. Modify the top and bottom levels of the part.
   - Top: Use to define the top level of the part.
   - Bottom: Use to define the bottom level of the part.
5. Click Modify.

Example In this example, the concrete columns form a two-story structure. To position the upper columns correctly, you must modify their bottom level position.
Positioning objects in a radial or circular pattern

To position objects in a radial or circular pattern, do one of the following:
• Create a grid line and use the Copy Special --- Rotate command to copy it.
• Use construction lines and circles to position the objects.

Optional ways of placing objects in a model

When you want to place an object to a position where no lines or objects intersect, you have the following options:
• Use the snapping commands.
• Use construction planes, lines and circles.
• Create points.

See also
Construction objects on page 49
Points on page 54

See also
Modifying the position of a part on page 105

See also
Creating a single grid line on page 30

See also
Construction objects on page 49
Displaying objects connected to a part

In some cases it is useful to see all the objects that are connected to a part, such as components, welds and fittings. You can then examine, for example, whether parts are welded correctly.

To display the objects connected to a part:

1. Select the part.

2. Delete the part.

3. ClickEdit --> Undo, or click.

The part and the accompanying objects are displayed.

See also Showing and hiding parts on page 156
Showing the attached parts
You can show the attached parts of any single part even if the Cuts and added material option is not selected in the Display dialog box.

To show the attached parts:
1. Click Tools --> Customize...
2. Add the Show added material command to a user-specific toolbar.
   a. On the Toolbars tab, click New...
      A new toolbar with the name UserToolbar 1 appears in the toolbar tree.
   b. Select the Show added material command from the list on the left, and then click the right arrow button.
   c. Click Close.
3. To show the attached parts, click the Show added material button and select a part in the model.

See also   Attaching a part to another part on page 114

 Modeling identical areas
Most structures contain identical areas, from simple frames to entire floors. Save time by modeling these areas once, then copying them throughout the model. For example, create a column with a base plate and cap plate, then copy the column to all the locations where it occurs in the model.

You can use this technique to create and reproduce any identical area. Depending on the project, you may even be able to add connections before copying the area of the building.

For a project that has several identical floors, try modeling an entire floor, then copying it to several levels.

See also
Creating bolts by modifying an existing bolt group

An alternative way to create bolts is to apply a component that includes bolt groups.

To create new bolts by modifying an existing bolt group:

1. Apply a component that includes bolt groups.
   
   For example, connect two beams, or a beam to a column, using a bolted end plate. For more information, see Steel component example: Creating an end plate using the End plate (144) connection.

2. Explode the component.
   
   a. Click **Detailing** --&gt; **Component** --&gt; **Explode component** .
   
   b. Select the component to explode.

   Tekla Structures separates the objects in the component.

3. Modify the bolt group.
   
   a. Select the bolt group and double-click it to open the properties dialog box.
   
   b. Modify the properties.
   
   c. Click **Modify**.

See also Creating a bolt group on page 121

14.3 Tips for numbering

These tips will help you to efficiently number your model.

Click the links below to find out more:

- General numbering tips on page 292
- Numbering settings during a project on page 293
- Creating a standard-part model on page 293

General numbering tips

- It is a good idea to have some kind of a routine in numbering. For example, number the model when you start your working day or when you finish for the day.

- To save time, include the numbering series in the default part properties for each type of part before you start modeling.

- Numbering is not just another way of classifying parts. To classify, use Organizer, user-defined attributes, or colors.
• If you have overlapping position numbers, Tekla Structures will warn you about it.

You can have a closer look at the overlapping position numbers in the numbering history log. To display the log, select Tools --> Display Log Files --> Numbering History.

See also  Numbering settings during a project on page 293
Numbering examples on page 228

Numbering settings during a project
You can use different numbering settings at different times in a project. For example:

• Before releasing a phase of the project for fabrication, you might use the Re-use old numbers option for numbering the entire model.

• If a phase has already been released for fabrication in a project, you might use the Take new number option for new and modified parts.

• If you are numbering other phases of the project at earlier stages of detailing, you might use the Compare to old option and try to combine as many position numbers as possible.

See also  Example: Numbering parts in selected phases on page 231
General numbering settings on page 274

Creating a standard-part model
A standard-part model contains only standard parts with specific part prefixes. You can use these prefixes when numbering parts in another model. The prefixes that you define will be used as actual part position numbers in the other model.

This functionality only applies to steel parts. Assemblies are not affected.

To create a standard-part model:
1. Create a new model and give it a descriptive name.
   For example, StandardParts.
2. Create the objects you want to use as standard parts.
3. Explode all components.
   You can explode the components if you plan to delete the unnecessary parts such as duplicate angles and main parts.
4. Delete all unnecessary items.
5. Give the objects part prefixes that are not used elsewhere (for example, STD1, STD2, and so on).

Ensure that the standard-part model does not contain duplicate part prefixes. You do not need to define the assembly prefix and the start numbers.

6. Save the standard-part model.

7. Open a project model that you wish to number.

8. Click Tools --> Options --> Advanced Options... --> Numbering.

9. Check that the advanced option points to the correct standard-part model.

For example:

   XS_STD_PART_MODEL=C:\TeklaStructuresModels\StandardParts

10. Click Drawings & Reports --> Numbering --> Numbering Settings... to display the Numbering Setup dialog box.

11. If you have selected the Part name check box, ensure that the project model has the same part names as the standard-part model.

12. Select the Check for standard parts check box.

13. Click Apply to save the changes.

14. Click Drawings & Reports --> Numbering --> Number Modified Objects to number the model.

As the parts are being numbered, Tekla Structures compares all parts in the project model to the standard-part model. Any part position numbers found in the standard-part model are applied to all identical parts found in the project model.

See also  Numbering parts on page 211
Disclaimer

© 2015 Tekla Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced Software. Use of the Software, and use of this Software Manual are governed by a License Agreement. Among other provisions, the License Agreement sets certain warranties for the Software and this Manual, disclaims other warranties, limits recoverable damages, defines permitted uses of the Software, and determines whether you are an authorized user of the Software. All information set forth in this manual is provided with the warranty set forth in the License Agreement. Please refer to the License Agreement for important obligations and applicable limitations and restrictions on your rights. Tekla does not guarantee that the text is free of technical inaccuracies or typographical errors. Tekla reserves the right to make changes and additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by international treaties. Unauthorized reproduction, display, modification, or distribution of this Manual, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tedds, Solve, Fastrak and Orion are either registered trademarks or trademarks of Tekla Corporation in the European Union, the United States, and/or other countries. More about Tekla trademarks: http://www.tekla.com/tekla-trademarks. Trimble is a registered trademark or trademark of Trimble Navigation Limited in the European Union, in the United States and/or other countries. More about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product and company names mentioned in this Manual are or may be trademarks of their respective owners. By referring to a third-party product or brand, Tekla does not intend to suggest an affiliation with or endorsement by such third party and disclaims any such affiliation or endorsement, except where otherwise expressly stated.

Portions of this software:

D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved.
EPM toolkit © 1995–2004 EPM Technology a.s., Oslo, Norway. All rights reserved.
Open CASCADE Technology © 2001–2014 Open CASCADE SA. All rights reserved.
FLY SDK – CAD SDK © 2012 VisualIntegrity™. All rights reserved.
Teigha © 2003–2014 Open Design Alliance. All rights reserved.
PolyBoolean C++ Library © 2001–2012 Complex A5 Co. Ltd. All rights reserved.
FlexNet Copyright © 2014 Flexera Software LLC. All Rights Reserved.

This product contains proprietary and confidential technology, information and creative works owned by Flexera Software LLC and its licensors, if any. Any use, copying, publication, distribution, display, modification, or transmission of such technology in whole or in part in any form or by any means without the prior express written permission of Flexera Software LLC is strictly prohibited. Except where expressly provided by Flexera Software LLC in writing, possession of this technology shall not be construed to confer any license or rights under any Flexera Software LLC intellectual property rights, whether by estoppel, implication, or otherwise.

To see the third party licenses, go to Tekla Structures, click Help --> About and click the Third party licenses button.

The elements of the software described in this Manual are protected by several patents and possibly pending patent applications in the European Union and/or other countries. For more information go to page http://www.tekla.com/tekla-patents.
Index

3
3D view ................................................. 41,42
3D models .............................................. 11
views .................................................... 48

A
accuracy, see high accuracy .................. 157
accuracy in modeling .................................. 157
of parts ................................................. 157
angles ..................................................... 185
arcs
measuring ............................................. 185
assemblies ............................................ 88
adding objects ...................................... 91,93
changing the main assembly .................. 95
changing the main part ......................... 94
comparing ............................................ 201
creating ............................................. 88
examples ............................................. 96
exploding ............................................ 96
highlighting ......................................... 95
joining .................................................. 94
nested assemblies .................................. 92,94
numbering .......................................... 208,212
removing objects .................................. 95
showing and hiding ............................... 163
sub-assemblies ..................................... 89
using bolts to create assemblies ............ 89
using welds to create assemblies ............ 90
attached parts
showing .............................................. 291
attaching parts .................................... 114
auto bolt
creating bolts ....................................... 122
autosave
error ............................................... 284

opening model ..................................... 284

B
background color
changing ............................................. 19
examples ............................................. 20
basic view ........................................... 37
beams
cambering ......................................... 118
cement beams ...................................... 84,249
cement polybeams ................................ 84
curved beams ....................................... 77
orthogonal beams ................................ 79
steel beams ........................................ 75,243
steel polybeams ................................... 76
warping .............................................. 116
bending ............................................. 285
bolts ................................................... 89,120,262
bolt group shape ................................... 265
bolt spacing ....................................... 186
bolting sub-assemblies ......................... 90
clash checking ..................................... 199
creating ............................................ 121,291
modifying ......................................... 125

C
cambering parts ................................... 118
cast units ........................................... 97
adding objects ..................................... 99
cast unit type ....................................... 98
casting direction .................................. 101,102
changing the main part ......................... 99
creating ............................................ 99
exploding .......................................... 101
highlighting ....................................... 100
numbering ........................................ 212
removing objects ................................ 100
top-in-form face .................................. 102
example.................................................................228
 modifying..........................................................210
 finding distant objects..........................................201
 finding
 clashes..................................................................188
 fittings...................................................................135
 flying through model............................................176
 footings..................................................................81,82,247,248

G
 global coordinate system........................................26
 grid lines...............................................................30
 creating.................................................................30
 deleting.................................................................32
 modifying..............................................................31
 properties.............................................................234
 grid views
 creating.................................................................38
 properties.............................................................238
 grids
 coordinates...........................................................27
 creating.................................................................27
 deleting.................................................................29
 grid color..............................................................25,29
 labels.....................................................................26,27
 line extensions.......................................................26
 modifying..............................................................28
 origin....................................................................26
 properties.............................................................233
 work plane grid......................................................24
 grouping
 clashes....................................................................194

H
 handles.....................................................................69
 hiding
 assemblies............................................................163
 components..........................................................163
 cut lines..................................................................281
 part labels..............................................................72
 reference lines.......................................................282
 selected parts.........................................................161
 top-in-form face......................................................102
 unselected parts......................................................162
 work area...............................................................23
 high accuracy.........................................................157
 highlighting
 assemblies............................................................95
 cast units...............................................................100
 hints and tips, see tips.............................................278
 history
 of clashes............................................................196
 holes.......................................................................125,126,127
 horizontal position...............................................259

I
 identical
 areas.......................................................................291
 parts.......................................................................204
 reinforcement.........................................................205
 importing
 points.....................................................................64
 inquiring
 object properties.................................................181,182
 items.....................................................................73,80,87,246,252
 changing the shape...............................................111
 limitations.............................................................73

J
 joining assemblies.....................................................94

K
 keyboard shortcuts
 for checking the model.............................................202
 for component representation options.................160
 for part representation options.............................160
 for viewing the model.............................................179

L
 labels
 part labels..............................................................71
 length
 modifying part length...........................................108
 levels....................................................................288
 limitations
 to items....................................................................73
 line cuts.................................................................136
lines
  exact......................................................... 157
local coordinate system................................. 26

M
  main entry
    subentry.................................................. 194
  measuring objects...................................... 184
    angles..................................................... 185
    arcs...................................................... 185
    bolt spacing............................................ 186
    distances................................................ 184
  Mini Toolbar
    modifying part position............................. 105
  model template
    creating................................................. 15
    modifying................................................ 17
  Modeling of floor bay (66)............................ 117
  modeling views
    surface views.......................................... 42
  modeling
    hints and tips.......................................... 278
    identical areas......................................... 291
    more accurately........................................ 157
    rendered or plan view?............................... 281
    screen layout........................................... 18
  models
    about 3D models....................................... 11
    checking for errors................................... 181
    creating................................................. 12
    flying through model.................................. 176
    moving.................................................... 176
    numbering................................................ 203
    rotating................................................. 174
    saving.................................................... 14
    viewing................................................... 173
    zooming.................................................. 173
  modifying model template............................. 17
  modifying
    construction objects.................................. 53
    parts...................................................... 104
  moving
    models in a view....................................... 176
    multi-story structures.................................. 288

N
  nested assemblies....................................... 92,94
  no paint area........................................... 153
  numbering............................................... 203,211
    about numbering...................................... 203
    assemblies............................................... 212
    cast units.............................................. 212
    checking and repairing............................... 218
    clearing................................................ 215
    control numbers.......................... 219,220,221,222,223
    examples................................................. 228,230,231
    family numbers.............................. 208,209,210,228
    history.................................................. 217
    identical parts........................................ 204
    manually................................................ 214
    modifying.............................................. 214
    numbering series....................................... 208
    parts..................................................... 211,218
    preliminary numbers................................. 213
    reinforcement.......................................... 205,213
    renumbering........................................... 218
    series.................................................... 206,207,208
    settings................................................. 210,274,276,293
    standard-part model................................. 293
    user-defined attributes............................. 206
    welds.................................................... 213
    what affects........................................... 205
  numbering
    design group numbering.............................. 226
    numbering settings.................................... 274

O
  object groups........................................... 165
  changing the color..................................... 168,169
  color settings......................................... 240
  copying to another model............................ 166
  creating............................................... 165
  deleting............................................... 166
  transparency settings.................................. 241
  object property report templates.................. 181
  object representation settings..................... 167,170,171
  objects
    clash checking......................................... 187
    connected to a part................................... 290
    defining visibility.................................... 156
    finding distant objects.............................. 201
inquiring properties........................................ 181,182
measuring......................................................... 184
numbering......................................................... 211
placing objects in model............................... 289
positioning......................................................... 289
showing and hiding........................................ 280
offsets............................................................. 260
opening a model
autosave......................................................... 284
derror............................................................... 284
opening models................................................. 13
orthogonal beams........................................... 244
positioning......................................................... 288
overlapping
numbering series.......................................... 208
views.............................................................. 281
oversized holes................................................. 126

P

pad footings..................................................... 81,247
positioning......................................................... 288
page margins..................................................... 197
page orientation................................................. 197
panels............................................................... 86
panning............................................................ 176
paper size......................................................... 197
part add, see attaching parts.......................... 114
part labels......................................................... 71
    showing and hiding....................................... 72
part plane
    creating a view.............................................. 40
part properties................................................ 241
part reference lines........................................ 282
parts
    adding to assembly.................................... 93
    assemblies.................................................. 88
    attaching................................................... 114
    bending..................................................... 285
    cambering.................................................. 118
    changing the color....................................... 168
    changing the material.................................. 111
    changing the profile.................................... 109
    colors......................................................... 240
    combining................................................... 113
    comparing.................................................. 201
    concrete parts.............................................. 81
curved parts.................................................. 285
cutting with another part............................ 138
default properties.......................................... 285
handles......................................................... 69
hiding........................................................... 161
horizontal parts.......................................... 287
identical parts................................................. 204
items............................................................ 73
keyboard shortcuts........................................ 160
labels............................................................ 71,72
modifying......................................................... 104
modifying part length...................................... 108
modifying part shape....................................... 106
numbering...................................................... 208,211,218
position.......................................................... 69,105
position settings............................................. 254
properties......................................................... 69
showing and hiding........................................ 156
showing only selected parts........................... 162
showing with exact lines.................................. 157
showing with high accuracy............................ 157
splitting.......................................................... 112
steel parts....................................................... 74
user-defined attributes.................................... 253
warping........................................................... 116
phases
    in numbering............................................... 231
plane of curvature.......................................... 285
plane views..................................................... 48
points............................................................ 54
    along arc using center and arc points............. 59
    along arc using three arc points................... 60
    along extension of two points....................... 55
    at any position............................................. 63
    at the intersection of a circle and a line......... 62
    at the intersection of a part and a line.......... 62
    at the intersection of a plane and a line.......... 61
    at the intersection of two lines...................... 61
    at the intersection of two part axes................. 63
    importing..................................................... 64
    on line....................................................... 57
    on plane....................................................... 58
    parallel to two points................................... 56
    projected points on line.............................. 58
    properties.................................................... 235
tangent to circle........................................... 60
polybeams.................................................... 76,84
chamfers....................................................... 140
polygon cuts.............................................................137
polygon shapes..........................................................107
polygon welds............................................................130
  converting..............................................................134
position
  depth.......................................................................256
  end offsets................................................................260
  horizontal................................................................259
  on the work plane...................................................254
part position settings................................................254
rotation......................................................................255
  vertical....................................................................258
preliminary numbers................................................213
preparing parts for welding......................................132,133
previewing
  lists of clashes.......................................................197
printing
  lists of clashes.......................................................196
priority
  in clash checking...................................................194
profiles.......................................................................109
  standardized values...............................................110
  twin profiles..........................................................80
project setup
  updating project information..................................66
properties
  default.......................................................................285
  project properties..................................................66
Radial Grid (1)............................................................278
radius..........................................................................285
redrawing views.........................................................48
reference lines..........................................................282
reference models
  clash checking........................................................187
refreshing views........................................................48
reinforcement
  identical...................................................................205
  numbering..................................................................205,213
removing
  weld cross sections................................................135
rendered views
  representation options..........................................158,159
renumbering..............................................................218
repairing model........................................................200
repairing.....................................................................200
numbering errors.......................................................218
report templates
  for inquiring object properties...............................181
representation
  of parts and components.........................................158
restoring default work plane.....................................25
RGB values...............................................................283
right-hand rule..........................................................283
rotating
  models.....................................................................174
  parts.........................................................................255
  rotation settings.....................................................235
rotation angle settings.............................................105
round
  holes.........................................................................126
  plates..........................................................................78,287
  slabs..........................................................................86,287
saving
  clashes.................................................................198
  models.................................................................14
  views.........................................................................46
screen layout
  in modeling...........................................................18
screenshots
  creating....................................................................178
  saving in bitmap format...........................................179
  settings.....................................................................236
searching
  clashes.....................................................................193
selection dial............................................................105
settings
  bolt properties........................................................262
  color settings........................................................170,171,240
  concrete beam properties........................................249
  concrete column properties.....................................249
  concrete item properties..........................................252
  concrete panel properties........................................251
  concrete slab properties..........................................250
  contour plate properties..........................................243
  corner chamfer properties......................................272
detail properties.......................................................261
display settings........................................................238
edge chamfer properties.........................................273
general modeling settings......................................233
grid line properties........................................234
grid properties...........................................233
grid view properties....................................238
numbering...................................................293
numbering settings.....................................210,274,276
orthogonal beam properties........................244
pad footing properties..................................247
part position settings...................................254
part properties...............................................241
point properties..........................................235
rotation settings..........................................235
screen shot settings.....................................236
steel beam properties....................................243
steel column properties.................................242
steel item properties......................................246
strip footing properties................................248
transparency settings...................................170,171,241
twin profile properties..................................245
view properties.............................................36,237
view settings...............................................236
weld properties..........................................266
shape
modifying part shape....................................106
shapes
of items......................................................111
shifting the work plane.................................25
showing and hiding
parts............................................................156
showing
assemblies...................................................163
attached parts.............................................291
components................................................163
cut lines......................................................281
parts labels..................................................72
parts with exact lines....................................157
parts with high accuracy..............................157
reference lines...........................................282
top-in-form face..........................................102
views..........................................................46
welds..........................................................129
work area...................................................23
single bolts...............................................121
single grid lines.........................................30
single-part welds........................................131
slabs..........................................................85,86
warping.......................................................117
slotted holes...............................................127
snapping

snapshots, see screenshots............................178
splitting
parts..........................................................112
plates and slabs..........................................112
standard-part models...................................293
standardized values for parametric profiles........110
status
in clash checking.........................................193,194
steel items...................................................73,80,246
steel parts....................................................74
assemblies...................................................88
beams........................................................75,243
columns......................................................74,242
contour plates............................................77,78,243
curved beams.............................................77
items...........................................................80,246
orthogonal beams........................................79,244
polybeams...................................................76
twin profiles...............................................80,245
stories
creating multi-story structures.......................288
strip footings...............................................82,248
sub-assemblies............................................89
bolting to existing assembly.........................90
welding to existing assembly.........................91
surface treatment.........................................142
adding........................................................144
creating new surface treatments....................147
modifying....................................................143
on all faces of part........................................145
on chamfered parts......................................146
on cut faces...............................................145
on part face...............................................144
on parts with openings and recesses...............146
on selected areas........................................144
tiled surface treatment.................................143,148
surface views..............................................42,44
switching between
views........................................................47,48

T

tiled surface treatment....................................148
creating new tile patterns.............................149
pattern definition example............................149
pattern definitions.......................................152
pattern elements........................................152
weld preparation.............................................132,133
weld types................................................................. 270
welding sub-assemblies...........................................91
work area.................................................................... 22,280
  defining........................................................................ 23
  hiding............................................................................23
work plane...........................................................................24
  creating a view...........................................................38
  restoring.......................................................................25
  shifting......................................................................... 25
workspace
  in Model Editor...........................................................18

Z
zooming in or out...........................................................173
zooming
  zoom settings...........................................................174