Hello!

Did you know that logged in users can see a lot more content?

Support articles

How to get the old drawing export dialog box?

Question: We are getting different drawing export dialog box in Tekla Structures version 2018. How to get the old drawing export dialog? Answer: New drawing export option introduced in Tekla structures (TS) 2017i onwards. We introduced new advanced option (ini file) XS_USE_OLD_DRAWING_EXPORT also from the same version. Set this advanced option to TRUE to use old drawing export option.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • old drawing export
  • drawing export
  • export to DWG
  • DWG
  • Export drawing
  • dwg export
  • new drawing export
  • XS_USE_OLD_DRAWING_EXPORT
  • advanced option

How to hide dimension change symbols in all the drawings in one go?

Question: Is there any way to hide dimension change symbols temporarily in all the drawings in one go? I want to keep the mark change symbols in all drawings and want to show the dimension change symbols later. Answer: Yes, it is possible. Change the advanced option XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES to FALSE.XS_HIGHLIGHT_MARK_CONTENT_CHANGES to TRUE. Then reopen the drawings, all dimension change symbols disappeared from all drawings. All mark change symbols remain appeared in the drawings. You can reset the "XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES" advanced option to TRUE if you
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_HIGHLIGHT_MARK_CONTENT_CHANGES
  • XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES
  • mark
  • mark change
  • dimension change
  • highlight
  • associative
  • associative dimension
  • show
  • hide
  • remove
  • show marks
  • hide marks
  • remove marks

How to hide mark change symbols in all the drawings in one go?

Question: Is there any way to hide mark change symbols temporarily in all the drawings in one go? I want to keep the dimension change symbols in all drawings and want to show the mark change symbols later. Answer: Yes, it is possible. Keep the advanced options XS_HIGHLIGHT_MARK_CONTENT_CHANGES to FALSE andXS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES to TRUE. Then reopen the drawings, all mark change symbols disappeared from all drawings. All dimension change symbols remain appeared in the drawings. You can reset the "XS_HIGHLIGHT_MARK_CONTENT_CHANGES" advanced option to TRUE if you want to get
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_HIGHLIGHT_MARK_CONTENT_CHANGES
  • XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES
  • mark
  • mark change
  • dimension change
  • highlight
  • associative
  • associative dimension
  • show
  • hide
  • remove
  • shoe marks
  • hide marks
  • remove marks

Error message when perform numbering

Question: The below message is appearing whenever I am trying to perform numbering, what it means? Answer: This message will appear when you perform numbering and if you set the advanced optionXS_USE_REPAIR_NUMBERING_INSTEAD_OF_NUMBERING to TRUE If this advanced option is set to TRUE, Tekla Structures automatically repairs numbering instead of only running numbering. You can set this advanced option to FALSE if you don’t want to repair numbering when you perform numbering.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_USE_REPAIR_NUMBERING_INSTEAD_OF_NUMBERING
  • repair numbering
  • numbering
  • error
  • error message
  • perform numbering
  • numbering issue

Rotate a part to the required view

Question: Is there any way to rotate a part to the selected (required) view angle in the model (not creating a view by "View > New view option") , for an example , I would like to work in top, back, right, bottom, front, or left view of the part frequently? Answer: Yes, it is possible to create 6 views of part in the model as per your requirement (top, back, right, bottom, front, or left view) from Tekla Structures (TS) 2018i onwards, this option is called Show parts in a selected view angle The same option is available from TS 2018i onwards.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • 6 views of part
  • views of part
  • Show parts in a selected view angle
  • View angle
  • create view
  • part view
  • top
  • back
  • right
  • bottom
  • front
  • left
  • VIEW

Was BIMSight removed from 2019?

Question -  Was BIMSight removed from Version 2019? It is no longer in the Export options under File > Export.  Answer -  Yes, BIMSight was removed in 2019 as it is being phased out and replaced with Trimble Connect Desktop. You can still use BIMSight by exporting an IFC directly from Tekla (File > Export > IFC) if you need but we recommend transitioning to Trimble Connect for Desktop in the near future.  You can get Trimble Connect for Desktop from the Trimble Connect App Store found here Please note, you must create a Trimble Identity in order to access this site. You can create
Requires Tekla Maintenance
by Tekla Support US
0
  • Trimble Connect for Desktop
  • BIMsight
  • where did bimsight go
  • has bimsight been removed

Rotate template (tpl)

Question: How can we rotate a graphical template (tpl.)? Answer: You can rotate the graphical template (*.tpl) with the help of new “Layout editor” option from where the layout of a drawing can be edited directly on a drawing. Layout editor is available from Tekla structures 2017 Service pack 3 onwards. A) You can open the layout editor from any one of the following methods Method 1: 1) Select the table (Template) 2) Double click on the table 3) The below message box will appear 4) Click “edit drawing layout”Method 2: Inside the drawing, File menu, click Editors > Layout editor.Method 3: 1
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Rotate templates
  • Rotate template
  • Rotate layout
  • layout
  • drawing layout
  • New drawing layout
  • layout table

Different line type for different construction lines & circles in a same model

Question: Is it possible to create construction lines with different line types within a same model? Answer: Yes, It is possible to create construction lines & construction circles with different line types within a same model from Tekla Structures 2019 (TS2019) version onwards. Additional info: Construction object line type properties have been moved from advanced options to object properties.  These advanced option (XS_CONSTRUCTION_CIRCLE_LINE_TYPE and XS_CONSTRUCTION_LINE_LINE_TYPE) removed in TS2019 version
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Different line type for different construction lines
  • Different line type for different construction circles
  • circle
  • Line
  • construction objects
  • XS_CONSTRUCTION_CIRCLE_LINE_TYPE
  • XS_CONSTRUCTION_LINE_LINE_TYPE
  • line type

Different color for different grids in a same model

Question: Is it possible to create different color grids in a same model? Answer: Yes, It is possible to create a different color grids in a same model from Tekla Structures 2019 (TS2019) version onwards. Now the properties of rectangular grids, radial grids, and single grid lines are accessed through the property pane. You can find the options to change the Grid colour, Label font size and Label font colour in the bottom side of the Grid property dialog box (New property pane) as shown below. Additional info: Previously, these were available in advanced options. These advanced options (
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Grid color
  • Grid Colour
  • colour
  • grid
  • different colour
  • Different color
  • XS_GRID_COLOR
  • XS_DEFAULT_FONT_SIZE_GRID
  • change the grid color

XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SIZE (Example)

Question: Is there any example to understand about the advanced option XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SIZE? Answer: Yes, Please follow the below steps to understand about this advanced option. 1)  Create a beam which is 2000 mm length 2)  Create a GA drawing (Plan), It will be look like as below, then close this drawing. 3)  Modify this beam’s length to 1000 mm length 4)  Open the GA drawing , dimension change symbol will be appear as below The default value is 7. 5) Go to advanced option , then change the value in XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SIZE=14 6) Reopen the drawing, you will get
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SIZE
  • XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL
  • advanced option
  • associative symbol
  • associative
  • symbol
  • highlight
  • change symbol
  • Symbol size

XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL (Example)

Question: Is there any example to understand about the advanced option XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL? Answer: Yes, Please follow the below steps to understand about this advanced option. 1)  Create a beam which is 2000 mm length 2)  Create a GA drawing (Plan), it will be look like as below, then close this drawing. 3)  Modify this beam’s length to 1000 mm length 4)  Open the GA drawing , dimension change symbol will be appear as below The default value is AssociativityAnchor@1 (a cloud). 5) Go to advanced option , then change the XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL=xsteel@0 6)
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL
  • advanced option
  • associative symbol
  • associative
  • symbol
  • highlight
  • change symbol

BVBS export uses actual rebar diameter if XS_USE_ONLY_NOMINAL_REBAR_DIAMETER=FALSE

Tekla Structures 2018 SP5 and 2019 contain an unintentional change, which might lead to using wrong size reinforcement in concrete objects exported with BVBS export. If the advanced option XS_USE_ONLY_NOMINAL_REBAR_DIAMETER is set to FALSE, it also affects the BVBS export and forces it to use actual diameter instead of nominal diameter. The BVBS export should always use nominal diameter for reinforcing bars, no matter what the setting for the advanced option is. We recommend that you do not use Tekla Structures 2019 or 2018 SP4 for your projects where you need to use BVBS export until we fix
Requires Tekla Maintenance
by Tekla Global Support

How to make basic HTML-based excel reports

To export reports to Microsoft Excel in a certain layout, for example, including merged cells, border lines,  font types & sizes, you can use HTML in Template editortool in Tekla Structures that is used for creating and modifying templates to be used in drawings and reports. This replaces the CSV file import in spreadsheets. By using the extension type .xls.rpt  in the name, the Excel report will automatically open in Excel when Show report is set to With associated viewer. To begin export to Excel To create an Excel template you can use the following steps. There is a template
Requires Tekla Maintenance
by Tekla Global Support
5

Using Array of objects (29) in custom components

The use of Array of objects (29) component in custom components has 2 limitations:There is always 1 extra array of the original objects. When you modify the original object, the arrays do not change. There is a workaround for both of these limitations. Show only 1 object without an array The Array of objects (29) component always creates 1 array. If you want to show only 1 object in your custom componentcomponent that the user creates and uses for creating model objects whose composition the user can modify as a group, you can use this workaround. Add a new parameter and create an If-
Requires Tekla Maintenance
by Tekla Global Support
0

Visualizer for Tekla Structures

What is it? Visualizer makes Tekla Structures models look amazing to everyone, technical and non-technical people alike. Visualizer helps Tekla Structures customers to build compelling sales and project presentations to add to reports and form part of e.g. a PowerPoint presentation. The Visualizer enhances presentations  with compelling, descriptive content that demonstrate design and build options and clearly communicate the structural strategy for feedback from the widest stakeholder audience to drive productivity and project quality gains. Visualizer is a Tekla Structures Extension found
Requires Tekla Maintenance
by David Lash
2.5
  • Visualizer Render

FLEXnet Licensing Help

What are you doing? I am a new customer ready to activate my new license I am updating to the latest version of Tekla Structures I am moving my license to a new machine Replacing licenses Borrowing Help Frequently Asked Questions                                                                                                              I am a new customer ready to activate my new license This guide provides you with information on installing the FLEXnet licensing system and starting Tekla Structures with the licensing system. FLEXnet is an activation-based licensing system provided by a
by Tekla Support US
4.5
  • flexnet help
  • setup license
  • activate license
  • how to activate my tekla license
  • tekla license
  • license setup
  • how to start using tekla
  • License
  • FLEXNET

Numbering Identical Objects in Different Phases

Sometimes, we may have identical objects within a model that must be released at different times, and therefore their numbering must be different. You can tell Tekla to number identical objects differently by assigning each object or set of objects to a separate section (phase), and then using the Phase numbering option in the General numbering settings. The advanced option XS_ ENABLE_ PHASE_ OPTION_ IN_ NUMBERING is available in Tekla 2018 and newer. It will activate the Phase numbering option within the Numbering Setup dialog box. The option will number all the objects in separate phases
Requires Tekla Maintenance
by Tekla Support US
5
  • Phase Manager
  • General numbering settings
  • Number parts
  • XS_​ENABLE_​PHASE_​OPTION_​IN_​NUMBERING
  • TTSD-28014

Tekla Model Sharing Overview

Tekla Model Sharing enables teams to collaborate on the same Tekla Structures project regardless of their location or time zone. Tekla Model Sharing adapts to any Internet connection speed, and you can even work offline. No additional hardware or software is required apart from Tekla Structures. On this page, you can browse the topics in the product guide, view the video tutorial, check out troubleshooting articles and find other content related to Tekla Model Sharing.
by Tekla User Assistance
0
  • Tekla Model Sharing overview

Changing the color of a PDF Reference File

PDF Reference files are often imported in a color that does not contrast well with the model's background color, thus making the reference file difficult to see. While you can Change the Color Settings of the model's background for better contrast, the color of the PDF reference file can also be changed by following these steps: Original PDF Reference Add an Object Group Double-click on the background of your current 3D view to pull out the View Properties, and click on the Representation tab under the Representation section. Click on the Object group... tab located at the bottom of the 
Requires Tekla Maintenance
by Tekla Support US
5
  • PDF Reference model
  • Reference object color
  • Reference Object

Tekla Structures 2019 US environments Release Notes

Table of Contents Folder Structure Reorganization Common to all US Roles Steel Detailing Role Partner Developer Notes Administrator Release Notes 1. Folder Structure Reorganization 1.1 Environment folders We have modified the environment to now contain both US Imperial and US Metric within one environment. See image below for reference, the environments have now been combined into one environment called USA. Within the USA environment, we have 3 main folders, one which contains shared files between both US Imperial and US Metric called “Common” and then specific folders for settings that
by Tekla Support US
5

Pages