Hello!

Did you know that logged in users can see a lot more content?

Support articles

How to turn a Tekla member into "Existing"

Question - How do I make a current part in Tekla an existing part? Answer - You can access a part's User-defined attributes (UDAs) by highlighting and clicking on the member to view its properties. In the Property Pane click on the More tab, and in the UDA dialog go to the Parameters tab and choose the Existing option from the drop-down menu next to the Existing Member section. Hit Modify. The existing part will change colors if using Standard Object Representation settings.  Note that this will only change the representation of parts in the model and, if needed, it can be shown on marks or
Requires Tekla Maintenance
by Tekla Support US
0
  • existing member
  • Make part Existing
  • Existing Part Numbering
  • existing
  • User-defined attributes (UDAs) for parts

Add Embed To Cast Unit

When you have your cast unit in your model, change your selection tool to Select Assemblies. With 'Select Assemblies' activated, choose your desired embed and place it in the Cast Unit.   With 'Select Assemblies' still activated, select the embed and then right click on the embed.  From the right click menu, navigate down to the assembly option and choose Add as Sub-Assembly. Note the status bar on the bottom left: It wants you to select the assembly that you want to add the sub-assembly to. The embed will now be part of the overall cast unit.  To double check this, choose 'Select
Requires Tekla Maintenance
by Tekla Support US
0
  • Add to Cast Unit
  • Adding to Cast Unit
  • Add Embed to Cast Unit

Create Deleted 3D view

Question: I lost my 3d view, how do i get it back?  Answer: If you happen to delete your 3d view you can easily create a new one. Just navigate to the view tab > new view and then basic view. Once basic view is selected a dialog box will appear, here you will need to place the coordinates for your floor level. If you modeled at 0 (zero) you can just hit "Create" otherwise enter the floor level (example 100') and hit create.  Once you do that, your new 3D view is created
Requires Tekla Maintenance
by Tekla Support US
0
  • create 3d view
  • three d
  • 3D
  • 3D view
  • lost 3d view
  • recreate 3d view

Convert SDS Model in Tekla

Question: I need to take an SDS model and convert it to a native Tekla model, how can i do this? Answer: You will need to request an IFC from the SDS detailer. This IFC needs to be export as a Type EM11(IFC2X3) in order to prevent issues in the conversion process in Tekla.  Take the IFC received from the SDS detailer and add it as a reference model in Tekla. Then, use the Convert IFC Objects tool found under the Manage tab on the ribbon and convert the objects. For more information on this process see here - https://teklastructures.support.tekla.com/2018/en/int_conversion_management
Requires Tekla Maintenance
by Tekla Support US
0
  • SDS
  • convert sds model
  • import sds
  • sds model

Cannot create Part Chamfers at once on two or more handles

In Tekla Structures, you can chamfer part corners and part edges by selecting a handle and double clicking on it. Tekla also gives you the ability to select several handles at the same time and therefore chamfer more than one corner at once. However, in versions 2018 through 2019, with the appearance of the Property pane you can no longer chamfer corners at the same time from the Property Pane. This is currently a defect, TTSD-20502 The workaround to add several chamfers simultaneously is to select all handles and then press Alt+Enter to open the old chamfer properties dialog and do it from
Requires Tekla Maintenance
by Tekla Support US
0
  • Create part Chamfers
  • Selecting several handles at once
  • Select handles with ALT-key down
  • property pane
  • Part Chamfers

Model search toolbar

Question: What is the use of Model search toolbar which is available in File menu > Settings > Toolbars list? Answer:  You can use this tool bar to search by using name, profile, material, position number of model objects. It is available in Tekla Structures 2019.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Model search toolbar
  • search toolbar
  • toolbar
  • tool bar
  • Model search tool bar
  • search tool bar

How to get old drawing list ?

Question: We are getting different drawing list dialog box (Ctrl+L) in Tekla Structures version 2018i. It shows as "Document manager" instead of Drawing list. How to get the old drawing list dialog? Answer: Document manager is enabled by default instead of drawing list from Tekla Strutures (TS) 2018i. We introduced new advanced option XS_USE_OLD_DRAWING_LIST_DIALOG from the same version. Set this advanced option to TRUE to use old drawing list dialog.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_USE_OLD_DRAWING_LIST_DIALOG
  • drawing list
  • old drawing list
  • new drawing list
  • document manager

How to get the old drawing export dialog box?

Question: We are getting different drawing export dialog box in Tekla Structures version 2018. How to get the old drawing export dialog? Answer: New drawing export option introduced in Tekla structures (TS) 2017i onwards. We introduced new advanced option (ini file) XS_USE_OLD_DRAWING_EXPORT also from the same version. Set this advanced option to TRUE to use old drawing export option.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • old drawing export
  • drawing export
  • export to DWG
  • DWG
  • Export drawing
  • dwg export
  • new drawing export
  • XS_USE_OLD_DRAWING_EXPORT
  • advanced option

How to hide dimension change symbols in all the drawings in one go?

Question: Is there any way to hide dimension change symbols temporarily in all the drawings in one go? I want to keep the mark change symbols in all drawings and want to show the dimension change symbols later. Answer: Yes, it is possible. Change the advanced option XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES to FALSE.XS_HIGHLIGHT_MARK_CONTENT_CHANGES to TRUE. Then reopen the drawings, all dimension change symbols disappeared from all drawings. All mark change symbols remain appeared in the drawings. You can reset the "XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES" advanced option to TRUE if you
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_HIGHLIGHT_MARK_CONTENT_CHANGES
  • XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES
  • mark
  • mark change
  • dimension change
  • highlight
  • associative
  • associative dimension
  • show
  • hide
  • remove
  • show marks
  • hide marks
  • remove marks

How to hide mark change symbols in all the drawings in one go?

Question: Is there any way to hide mark change symbols temporarily in all the drawings in one go? I want to keep the dimension change symbols in all drawings and want to show the mark change symbols later. Answer: Yes, it is possible. Keep the advanced options XS_HIGHLIGHT_MARK_CONTENT_CHANGES to FALSE andXS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES to TRUE. Then reopen the drawings, all mark change symbols disappeared from all drawings. All dimension change symbols remain appeared in the drawings. You can reset the "XS_HIGHLIGHT_MARK_CONTENT_CHANGES" advanced option to TRUE if you want to get
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_HIGHLIGHT_MARK_CONTENT_CHANGES
  • XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES
  • mark
  • mark change
  • dimension change
  • highlight
  • associative
  • associative dimension
  • show
  • hide
  • remove
  • shoe marks
  • hide marks
  • remove marks

Error message when perform numbering

Question: The below message is appearing whenever I am trying to perform numbering, what it means? Answer: This message will appear when you perform numbering and if you set the advanced optionXS_USE_REPAIR_NUMBERING_INSTEAD_OF_NUMBERING to TRUE If this advanced option is set to TRUE, Tekla Structures automatically repairs numbering instead of only running numbering. You can set this advanced option to FALSE if you don’t want to repair numbering when you perform numbering.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_USE_REPAIR_NUMBERING_INSTEAD_OF_NUMBERING
  • repair numbering
  • numbering
  • error
  • error message
  • perform numbering
  • numbering issue

Rotate a part to the required view

Question: Is there any way to rotate a part to the selected (required) view angle in the model (not creating a view by "View > New view option") , for an example , I would like to work in top, back, right, bottom, front, or left view of the part frequently? Answer: Yes, it is possible to create 6 views of part in the model as per your requirement (top, back, right, bottom, front, or left view) from Tekla Structures (TS) 2018i onwards, this option is called Show parts in a selected view angle The same option is available from TS 2018i onwards.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • 6 views of part
  • views of part
  • Show parts in a selected view angle
  • View angle
  • create view
  • part view
  • top
  • back
  • right
  • bottom
  • front
  • left
  • VIEW

Was BIMSight removed from 2019?

Question -  Was BIMSight removed from Version 2019? It is no longer in the Export options under File > Export.  Answer -  Yes, BIMSight was removed in 2019 as it is being phased out and replaced with Trimble Connect Desktop. You can still use BIMSight by exporting an IFC directly from Tekla (File > Export > IFC) if you need but we recommend transitioning to Trimble Connect for Desktop in the near future.  You can get Trimble Connect for Desktop from the Trimble Connect App Store found here Please note, you must create a Trimble Identity in order to access this site. You can create
Requires Tekla Maintenance
by Tekla Support US
0
  • Trimble Connect for Desktop
  • BIMsight
  • where did bimsight go
  • has bimsight been removed

Rotate template (tpl)

Question: How can we rotate a graphical template (tpl.)? Answer: You can rotate the graphical template (*.tpl) with the help of new “Layout editor” option from where the layout of a drawing can be edited directly on a drawing. Layout editor is available from Tekla structures 2017 Service pack 3 onwards. A) You can open the layout editor from any one of the following methods Method 1: 1) Select the table (Template) 2) Double click on the table 3) The below message box will appear 4) Click “edit drawing layout”Method 2: Inside the drawing, File menu, click Editors > Layout editor.Method 3: 1
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Rotate templates
  • Rotate template
  • Rotate layout
  • layout
  • drawing layout
  • New drawing layout
  • layout table

Different line type for different construction lines & circles in a same model

Question: Is it possible to create construction lines with different line types within a same model? Answer: Yes, It is possible to create construction lines & construction circles with different line types within a same model from Tekla Structures 2019 (TS2019) version onwards. Additional info: Construction object line type properties have been moved from advanced options to object properties.  These advanced option (XS_CONSTRUCTION_CIRCLE_LINE_TYPE and XS_CONSTRUCTION_LINE_LINE_TYPE) removed in TS2019 version
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Different line type for different construction lines
  • Different line type for different construction circles
  • circle
  • Line
  • construction objects
  • XS_CONSTRUCTION_CIRCLE_LINE_TYPE
  • XS_CONSTRUCTION_LINE_LINE_TYPE
  • line type

Different color for different grids in a same model

Question: Is it possible to create different color grids in a same model? Answer: Yes, It is possible to create a different color grids in a same model from Tekla Structures 2019 (TS2019) version onwards. Now the properties of rectangular grids, radial grids, and single grid lines are accessed through the property pane. You can find the options to change the Grid colour, Label font size and Label font colour in the bottom side of the Grid property dialog box (New property pane) as shown below. Additional info: Previously, these were available in advanced options. These advanced options (
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Grid color
  • Grid Colour
  • colour
  • grid
  • different colour
  • Different color
  • XS_GRID_COLOR
  • XS_DEFAULT_FONT_SIZE_GRID
  • change the grid color

XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SIZE (Example)

Question: Is there any example to understand about the advanced option XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SIZE? Answer: Yes, Please follow the below steps to understand about this advanced option. 1)  Create a beam which is 2000 mm length 2)  Create a GA drawing (Plan), It will be look like as below, then close this drawing. 3)  Modify this beam’s length to 1000 mm length 4)  Open the GA drawing , dimension change symbol will be appear as below The default value is 7. 5) Go to advanced option , then change the value in XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SIZE=14 6) Reopen the drawing, you will get
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SIZE
  • XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL
  • advanced option
  • associative symbol
  • associative
  • symbol
  • highlight
  • change symbol
  • Symbol size

XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL (Example)

Question: Is there any example to understand about the advanced option XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL? Answer: Yes, Please follow the below steps to understand about this advanced option. 1)  Create a beam which is 2000 mm length 2)  Create a GA drawing (Plan), it will be look like as below, then close this drawing. 3)  Modify this beam’s length to 1000 mm length 4)  Open the GA drawing , dimension change symbol will be appear as below The default value is AssociativityAnchor@1 (a cloud). 5) Go to advanced option , then change the XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL=xsteel@0 6)
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_ASSOCIATIVE_CHANGE_HIGHLIGHT_SYMBOL
  • advanced option
  • associative symbol
  • associative
  • symbol
  • highlight
  • change symbol

BVBS export uses actual rebar diameter if XS_USE_ONLY_NOMINAL_REBAR_DIAMETER=FALSE

Tekla Structures 2018 SP5 and 2019 contain an unintentional change, which might lead to using wrong size reinforcement in concrete objects exported with BVBS export. If the advanced option XS_USE_ONLY_NOMINAL_REBAR_DIAMETER is set to FALSE, it also affects the BVBS export and forces it to use actual diameter instead of nominal diameter. The BVBS export should always use nominal diameter for reinforcing bars, no matter what the setting for the advanced option is. We recommend that you do not use Tekla Structures 2019 or 2018 SP4 for your projects where you need to use BVBS export until we fix
Requires Tekla Maintenance
by Tekla Global Support

How to make basic HTML-based excel reports

To export reports to Microsoft Excel in a certain layout, for example, including merged cells, border lines,  font types & sizes, you can use HTML in Template editortool in Tekla Structures that is used for creating and modifying templates to be used in drawings and reports. This replaces the CSV file import in spreadsheets. By using the extension type .xls.rpt  in the name, the Excel report will automatically open in Excel when Show report is set to With associated viewer. To begin export to Excel To create an Excel template you can use the following steps. There is a template
Requires Tekla Maintenance
by Tekla Global Support
5

Pages