Support articles

Copying fully detailed elements

Question: I have modelled and detailed a concrete beam. I'd like to copy the detailed elements across to another beam but it is at a different elevation and plane, is this possible? Answer: Yes, you could use the Copy special > To another object command. You don't need to know the distance or level you are copying to, as it copies object to object. However, you have to select all the elements you want to copy seperately. An easier approach would be to completely detail the element and once you are happy with it, use the Select assemblies switch in conjunction with the Copy special >
Requires Tekla Maintenance
by Trimble Solutions UK
0
  • all content to another object
  • copy to another object
  • cuts

Inserting logo into Drawing Template

Question: How do I insert a logo into a Drawing Template in Tekla Structures 2019? Answer: The file structure has changed considerably in Tekla Structures 2019 compared to older versions. The following article explains how to set up your drawing template with your company logo in this version.  Solution Save your logo Save your company logo into the following location: C:\TeklaStructures\2019\Environments\UK\General\symbols  Edit the file location  Double click on any template in any drawing Click on Edit template in Template Editortool in Tekla Structures that is used for creating and
Requires Tekla Maintenance
by Trimble Solutions UK
5
  • logo
  • company logo
  • drawing template
  • file structure
  • file locations
  • symbols
  • pictures
  • preferences

Rotating a wall panel with openings

Question: When I rotate my wallplate that represents a structure such as a wall or roof panelIn Tekla Structures, a panel is created by picking two or more points.In cast-in-place concrete the term wall refers to a concept similar to panel. layout the openings I have in place for the windows disappear, what am I doing wrong? Answer: It sounds as though all the points that define the openings weren't selected before rotating the wall layout. There are two ways in which we can rotate the wall and its openings, in the first example we will directly modify the wall layout using the line handle,
Requires Tekla Maintenance
by Trimble Solutions UK
0
  • wall layout
  • rotating parts
  • Direct Modification
  • line handle

Using external or own organization Model Sharing license

Question: How does Model Sharing decide, which model sharing license will be selected, when user signs in and if he is having model sharing license in two organizations: in his own organization as an employee and in another organization as an external user? Answer: Currently you cannot see which company's license is in use. But if user is an external user, then external company licenses are used first, and when they run out, then own organization licenses are used. For example it doesn’t matter which company owns the model. See alsoAdmin guideline to purchasing and managing Tekla Model
Requires Tekla Maintenance
by Tekla Global Support
4

Manage a point cloud on a facade

1. Insert the point cloud From the side panel, Link the point cloud  with the option Location by: on Model origin Note: point clouds move through the base point. It is not possible to move them like the reference models. It is sometimes necessary to use the automatically created Base Point option and readjust this Base Point by making a new connection, but not in this case. 2.  Modify the grid on direct modification 3. Create views Use dynamic modification to adjust mesh queues on mullions and facade offsets. Next, create elevation and facade views. 4. Model a concrete wall  Model a panel
Requires Tekla Maintenance
by Trimble Solutions France
0
  • Scan
  • nuage de point
  • trimble
  • Realworks

How to turn a Tekla member into "Existing"

Question - How do I make a current part in Tekla an existing part? Answer - You can access a part's User-defined attributes (UDAs) by highlighting and clicking on the member to view its properties. In the Property Pane click on the More tab, and in the UDA dialog go to the Parameters tab and choose the Existing option from the drop-down menu next to the Existing Member section. Click Modify. The existing part will change colors if using Standard Object Representation settings.  Note that this will only change the representation of parts in the model. If needed, the modification can be shown
Requires Tekla Maintenance
by Tekla Support US
0
  • existing member
  • Make part Existing
  • Existing Part Numbering
  • existing
  • User-defined attributes (UDAs) for parts

Add Embed To Cast Unit

When you have your cast unit in your model, change your selection tool to Select Assemblies. With Select Assemblies activated, choose your desired embed and place it in the Cast Unit.   With Select Assemblies still activated, select the embed and then right click on the embed.  From the right click menu, navigate down to the assembly option and choose Add as Sub-Assembly. You to select the assembly that you want to add the sub-assembly to from the status bar on the bottom left. The embed will now be part of the overall cast unit.  To double check this, choose Select Components as your
Requires Tekla Maintenance
by Tekla Support US
0
  • Add to Cast Unit
  • Adding to Cast Unit
  • Add Embed to Cast Unit

Create Deleted 3D view

Question: I lost my 3d view, how do I get it back?  Answer: If you happen to delete your 3d view you can easily create a new one. First, navigate to the View tab > New view and, while holding Shift, click on Basic view. You will now see two dialog boxes: View Properties and Create Basic View. On the View Properties dialog box, Load the 3D View presets/ properties and hit Apply.  On the Create Basic View dialog, you must place the coordinates for your floor level: If you modeled at the default Coordinate 0 (zero) simply click Create. Otherwise, enter the floor level (example 100') and
Requires Tekla Maintenance
by Tekla Support US
5
  • create 3d view
  • three d
  • 3D
  • 3D view
  • lost 3d view
  • recreate 3d view

Convert SDS Model in Tekla

Question: I need to take an SDS model and convert it to a native Tekla model, how can i do this? Answer: You will need to request an IFC from the SDS detailer. This IFC needs to be export as a Type EM11(IFC2X3, Coordination View 2.0) in order to prevent issues in the conversion process in Tekla.  Take the IFC received from the SDS detailer and add it as a reference model in Tekla. Then, use the Convert IFC Objects tool found under the Manage tab on the ribbon and convert the objects. For more information on this process see here.
Requires Tekla Maintenance
by Tekla Support US
0
  • SDS
  • convert sds model
  • import sds
  • sds model

Cannot create Part Chamfers at once on two or more handles

In Tekla Structures, you can chamfer part corners and part edges by selecting a handle and double-clicking on it. Tekla also gives you the ability to select several handles at the same time and therefore chamfer more than one corner at once. However, since version 2018 with the appearance of the Property pane, you could not chamfer corners at the same time from the Property Pane. This was a defect, TTSD-15866, and it is now fixed in 2019 SP1 and newer.  If updating is not an option, the workaround to add several chamfers simultaneously is to select all handles and then press Alt+Enter to open
Requires Tekla Maintenance
by Tekla Support US
0
  • Create part Chamfers
  • Selecting several handles at once
  • Select handles with ALT-key down
  • property pane
  • Part Chamfers

Model search toolbar

Question: What is the use of Model search toolbar which is available in File menu > Settings > Toolbars list? Answer:  You can use this tool bar to search by using name, profile, material, position number of model objects. It is available in Tekla Structures 2019.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Model search toolbar
  • search toolbar
  • toolbar
  • tool bar
  • Model search tool bar
  • search tool bar

How to get old drawing list ?

Question: We are getting different drawing list dialog box (Ctrl+L) in Tekla Structures version 2018i. It shows as "Document manager" instead of Drawing list. How to get the old drawing list dialog? Answer: Document manager is enabled by default instead of drawing list from Tekla Strutures (TS) 2018i. We introduced new advanced option XS_USE_OLD_DRAWING_LIST_DIALOG from the same version. Set this advanced option to TRUE to use old drawing list dialog.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_USE_OLD_DRAWING_LIST_DIALOG
  • drawing list
  • old drawing list
  • new drawing list
  • document manager

How to get the old drawing export dialog box?

Question: We are getting different drawing export dialog box in Tekla Structures version 2018. How to get the old drawing export dialog? Answer: New drawing export option introduced in Tekla structures (TS) 2017i onwards. We introduced new advanced option (ini file) XS_USE_OLD_DRAWING_EXPORT also from the same version. Set this advanced option to TRUE to use old drawing export option.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • old drawing export
  • drawing export
  • export to DWG
  • DWG
  • Export drawing
  • dwg export
  • new drawing export
  • XS_USE_OLD_DRAWING_EXPORT
  • advanced option

How to hide dimension change symbols in all the drawings in one go?

Question: Is there any way to hide dimension change symbols temporarily in all the drawings in one go? I want to keep the mark change symbols in all drawings and want to show the dimension change symbols later. Answer: Yes, it is possible. Go to File > Settings > Advanced options > XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES . Set it to FALSE. Then, search for advanced option XS_HIGHLIGHT_MARK_CONTENT_CHANGES and set it to TRUE. Next, reopen the drawings. All dimension change symbols should have disappeared but mark change symbols should remain visible in the drawings. If you want to
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_HIGHLIGHT_MARK_CONTENT_CHANGES
  • XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES
  • mark
  • mark change
  • dimension change
  • highlight
  • associative
  • associative dimension
  • show
  • hide
  • remove
  • show marks
  • hide marks
  • remove marks

How to hide mark change symbols in all the drawings in one go?

Question: Is there any way to hide mark change symbols temporarily in all the drawings in one go? I want to keep the dimension change symbols in all drawings and want to show the mark change symbols later. Answer: Yes, it is possible. Go to File > Settings > Advanced options > XS_HIGHLIGHT_MARK_CONTENT_CHANGES and set it to FALSE if it is set to true. Next, search for Advanced options > XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES and change it to TRUE. Then, reopen the drawings. All mark change symbols have disappeared and dimension change symbols remain visible in the drawings.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_HIGHLIGHT_MARK_CONTENT_CHANGES
  • XS_HIGHLIGHT_ASSOCIATIVE_DIMENSION_CHANGES
  • mark
  • mark change
  • dimension change
  • highlight
  • associative
  • associative dimension
  • show
  • hide
  • remove
  • shoe marks
  • hide marks
  • remove marks

Error message when perform numbering

Question: The below message is appearing whenever I am trying to perform numbering, what it means? Answer: This message will appear when you perform numbering and the  advanced optionXS_USE_REPAIR_NUMBERING_INSTEAD_OF_NUMBERING is set to TRUE. Whn this option is set to TRUE, Tekla Structures automatically repairs numbering. You can set this advanced option to FALSE if you don’t want to repair numbering by going to File > Settings > Advanced options > XS_USE_REPAIR_NUMBERING_INSTEAD_OF_NUMBERING and setting it to FALSE.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • XS_USE_REPAIR_NUMBERING_INSTEAD_OF_NUMBERING
  • repair numbering
  • numbering
  • error
  • error message
  • perform numbering
  • numbering issue

Rotate a part to the required view

Question: Is there any way to rotate a part to the selected (required) view angle in the model (not creating a view by "View > New view option") , for an example , I would like to work in top, back, right, bottom, front, or left view of the part frequently? Answer: Yes, it is possible to create 6 views of part in the model as per your requirement (top, back, right, bottom, front, or left view) from Tekla Structures (TS) 2018i onwards, this option is called Show parts in a selected view angle The same option is available from TS 2018i onwards.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • 6 views of part
  • views of part
  • Show parts in a selected view angle
  • View angle
  • create view
  • part view
  • top
  • back
  • right
  • bottom
  • front
  • left
  • VIEW

Was BIMSight removed from 2019?

Question -  Was BIMSight removed from Version 2019? It is no longer in the Export options under File > Export.  Answer -  Yes, BIMSight was removed in 2019 as it is being phased out and replaced with Trimble Connect Desktop. You can still use BIMSight by exporting an IFC directly from Tekla (File > Export > IFC) if you need but we recommend transitioning to Trimble Connect for Desktop in the near future.  You can get Trimble Connect for Desktop from the Trimble Connect App Store found here Please note, you must create a Trimble Identity in order to access this site. You can create
Requires Tekla Maintenance
by Tekla Support US
0
  • Trimble Connect for Desktop
  • BIMsight
  • where did bimsight go
  • has bimsight been removed

Rotate template (tpl)

Question: How can we rotate a graphical template (tpl.)? Answer: You can rotate the graphical template (*.tpl) with the help of new Layout editor option which allows you to edit the layout of a drawing directly on a drawing. Layout editor is available from Tekla structures 2017 Service pack 3 onwards. You can open the layout editor with any one of the following methods: Method 1: 1) Select the table (Template) 2) Double click on the table 3) The dialog box shown below appears 4) Click Edit drawing layout. Method 2: When you have the drawing open, go to File > Editors > Layout editor.
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Rotate templates
  • Rotate template
  • Rotate layout
  • layout
  • drawing layout
  • New drawing layout
  • layout table

Different line type for different construction lines & circles in a same model

Question: Is it possible to create construction lines with different line types within a same model? Answer: Yes, It is possible to create construction lines & construction circles with different line types within a same model from Tekla Structures 2019 (TS2019) version onwards. Additional info: Construction object line type properties have been moved from advanced options to object properties.  These advanced option (XS_CONSTRUCTION_CIRCLE_LINE_TYPE and XS_CONSTRUCTION_LINE_LINE_TYPE) removed in TS2019 version
Requires Tekla Maintenance
by Trimble Solutions India
0
  • Different line type for different construction lines
  • Different line type for different construction circles
  • circle
  • Line
  • construction objects
  • XS_CONSTRUCTION_CIRCLE_LINE_TYPE
  • XS_CONSTRUCTION_LINE_LINE_TYPE
  • line type

Pages