Здравствуйте!

Вы знаете, что после входа пользователям становится доступно намного больше содержимого?

2019i Table of Contents

Создание видов модели

Добавлено September 30, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Версия программы: 
2019i

Создание видов модели

Создание видов модели

Создавать виды модели в Tekla Structures можно несколькими способами.

Например, можно создавать виды

Каждый вид имеет свойства, которые определяют его внешний вид. Внешний вид вида можно изменить после его создания. Для просмотра и изменения свойств каждого вида дважды щелкните в любом месте на фоне модели, чтобы открыть диалоговое окно Свойства вида.

При создании видов по линиям сетки можно просмотреть и изменить свойства с помощью диалогового окна Создание видов по линиям сетки.

Создание основного вида модели

Основной вид создается по двум координатным осям. Такие виды используются для получения общего представления о модели.

  1. На вкладке Вид выберите Новый вид > Основной вид.
  2. Выберите плоскость вида в списке Плоскость.

    Плоскость вида определяется двумя осями.

  3. В поле Координата введите уровень вида.

    Это значение определяет расстояние до плоскости вида от глобального начала координат перпендикулярно плоскости вида.

  4. Нажмите кнопку Создать.

Создание вида по двум точкам

Можно создать вид по двум указанным точкам: началу координат и точке в направлении оси X.

  1. На вкладке Вид выберите Новый вид > По двум точкам.
  2. Укажите точку, чтобы задать начало координат плоскости вида.
  3. Укажите вторую точку, чтобы задать направление оси X.

    Ось Y будет перпендикулярна плоскости вида, на которой была указана первая точка.

Создание вида по трем точкам

Можно создать вид по трем указанным точкам: началу координат, точке в направлении оси X и третьей точке в направлении оси Y.

  1. На вкладке Вид выберите Новый вид > По трем точкам.
  2. Укажите точку, чтобы задать начало координат плоскости вида.
  3. Укажите вторую точку, чтобы задать направление оси X.
  4. Укажите третью точку, чтобы задать направление оси Y.

Создание вида рабочей плоскости

Можно создать вид рабочей плоскости, используя текущие свойства вида.

На вкладке Вид выберите Новый вид > На рабочей плоскости.

Создание видов сетки

Можно создавать виды по выбранным линиям сетки.

Прежде чем приступить, создайте вид, содержащий сетку, и проверьте свойства сетки. Обратите внимание, что при использовании радиальной сетки виды по сетке можно создавать только на прямых линиях сетки, но не на дуговых линиях сетки.

Если свойства сетки в чем-то неверны, Tekla Structures может обрезать виды на неправильной высоте или неправильно их именовать. Если впоследствии изменить метки сетки, отметки высоты или сами сетки, виды не будут переименованы автоматически.

  1. Выберите сетку.
  2. На вкладке Вид выберите Новый вид > По линиям сетки.
  3. При необходимости измените свойства сетки.
    1. В списке Количество видов выберите, сколько видов требуется создать.
    2. В поле Префикс имени вида введите префикс.
    3. В списке Свойства вида укажите, какие свойства вида (примененные или сохраненные) требуется использовать.
  4. Нажмите кнопку Создать.

    Откроется диалоговое окно Виды.

  5. Нажимая кнопки со стрелками, перенесите виды из списка Все виды в список Активные виды.

    Виды не будет видны, пока вы не перенесете их в список Активные виды.

Пример

В этом примере показано, как создать вертикальные виды по линиям 1–7 сетки в следующей модели:

В диалоговом окне Создание видов по линиям сетки выберите Все для плоскости вида XZ и Ничего для плоскостей вида XY и ZY. В качестве префикса имени вида и свойств вида оставьте значения по умолчанию.

После создания видов по сетке перенесите вид с именем Grid 2 в список Активные виды

Вид сетки открывается в новом окне как плоскостной:

Поверните вид, чтобы увидеть его в 3D:

Создание вида на плоскости

Можно создать вид на рабочей плоскости или практически на любой плоскости существующей детали.

  1. На вкладке Вид выберите Новый вид > На плоскости.

    При наведении указателя мыши на объекты модели Tekla Structures выделяет доступные плоскости светло-синим цветом.

  2. Выберите требуемую плоскость.
Tip:

Кроме того, для создания вида на передней, верхней, задней или нижней плоскости детали можно также использовать следующие команды на вкладке Вид :

  • На передней плоскости детали

  • На верхней плоскости детали

  • На задней плоскости детали

  • На нижней плоскости детали

Для использования этих команд сначала выберите команду, а затем деталь.

Создание 3D-вида детали

Чтобы рассмотреть деталь во всех подробностях, можно создать 3D-вид этой детали. Деталь при этом помещается в центр вида.

  1. На вкладке Вид выберите Новый вид > 3D-вид детали.
  2. Выберите деталь.

    Tekla Structures создает вид, используя свойства, определенные в файле свойств part_basic_view. Ось Y плоскости вида соответствует глобальной оси Z модели. Ось X является проекцией локальной оси X детали на глобальную плоскость XY.

    Tekla Structures определяет размер рабочей области в соответствии с выбранной деталью.

    Если вы хотите, чтобы всегда, когда вы создаете в Tekla Structures новый 3D-вид, это вид один раз поворачивался, установите флажок Автоматическое вращение основного вида в меню Файл.

Создание видов детали, предусмотренных по умолчанию

Для детали можно создать четыре вида: спереди, сверху, сбоку и 3D. Tekla Structures создает эти виды одновременно, с помощью одной команды. Виды спереди, сверху и сбоку по умолчанию представляют собой плоскостные виды.

  1. На вкладке Вид выберите Новый вид > Виды детали по умолчанию.
  2. Выберите деталь.

    Tekla Structures создает четыре вида по умолчанию (все сразу), используя свойства, определенные в файлах свойств part_front_view , part_top_view , part_end_view и part_persp_view.

Создание недеформированного вида детали

Можно создать вид, на котором деформированная деталь будет показана в ее недеформированном состоянии. Это возможно только для балок и колонн.

  1. На вкладке Вид выберите Новый вид > Недеформированный вид детали.
  2. Выберите деталь.

    Например, выберите искривленную балку. Tekla Structures отобразит балку на отдельном виде в недеформированном состоянии.

Создание 3D-вида компонента

Чтобы рассмотреть компонент во всех подробностях, можно создать 3D-вид этого компонента. Компонент при этом помещается в центр вида.

  1. На вкладке Вид выберите Новый вид > 3D-вид компонента.
  2. Выберите компонент.

    Tekla Structures создает вид, используя свойства, определенные в файле свойств component_basic_view. Ось Y плоскости вида соответствует глобальной оси Z модели. Ось X является проекцией локальной оси X первой второстепенной детали на глобальную плоскость XY. Глубина рабочей области составляет 1 м во всех направлениях.

    Рабочая область автоматически определяется выбранным компонентом.

    Если вы хотите, чтобы всегда, когда вы создаете в Tekla Structures новый 3D-вид, это вид один раз поворачивался, установите флажок Автоматическое вращение основного вида в меню Файл.

Создание видов компонента, предусмотренных по умолчанию

Для компонента можно создать четыре вида: спереди, сверху, сбоку и 3D. Tekla Structures создает эти виды одновременно, с помощью одной команды. Виды спереди, сверху и сбоку по умолчанию представляют собой плоскостные виды.

  1. На вкладке Вид выберите Новый вид > Виды компонента по умолчанию.
  2. Выберите компонент.

    Tekla Structures создает четыре вида по умолчанию (все сразу), используя свойства, определенные в файлах свойств component_front_view , component_top_view , component_end_view и component_persp_view.

Создание вида поверхности

Макрос Create surface view служит для создания автоматически ориентированного вида поверхности. Это удобно делать при моделировании групп болтов, элементов жесткости и проникающих отверстий в сложной геометрии.

Чтобы иметь возможность выбрать поверхность детали, убедитесь, что вы работаете на виде модели, на котором видны грани деталей. На вкладке Вид выберите Визуализация , а затем выберите либо Детали - в оттенках серого , либо Детали - визуализированные.

  1. Нажмите кнопку Приложения и компоненты в боковой панели, чтобы открыть каталог Приложения и компоненты.
  2. Нажмите стрелку рядом с Приложения , чтобы открыть список приложений.
  3. Дважды щелкните Create surface view , чтобы запустить макрос.
  4. Выберите поверхность детали.

    Tekla Structures создает новый временный вид и переносит рабочую плоскость — как правило, так, чтобы она располагалась вдоль самого длинного ребра грани детали. Работая во временном виде поверхности, можно одновременно видеть моделируемые объекты в исходном 3D-виде.

  5. Нажмите клавишу Esc , чтобы остановить макрокоманду.
  6. Чтобы вернуть рабочую плоскость обратно в начало координат:
    1. Повторите шаги 1–2, чтобы открыть список Приложения.
    2. Дважды щелкните макрос Work plane global.

      Рабочая плоскость вернется обратно в начало координат и будет соответствовать глобальным осям X, Y и Z модели.

Создание вида поверхности вдоль выбранного ребра

Макрос Create surface view wEdge служит для создания вида поверхности и выравнивания рабочей плоскости по выбранному ребру. Это удобно делать при моделировании групп болтов, элементов жесткости и проникающих отверстий в сложной геометрии.

Чтобы иметь возможность выбрать поверхность детали, убедитесь, что вы работаете на виде модели, на котором видны грани деталей. На вкладке Вид выберите Визуализация , а затем выберите либо Детали - в оттенках серого , либо Детали - визуализированные.

  1. Убедитесь, что переключатель привязки Привязать к линиям/точкам геометрии активен.

    Это позволит указать точку на ребре для задания направления.

  2. Нажмите кнопку Приложения и компоненты в боковой панели, чтобы открыть каталог Приложения и компоненты.
  3. Нажмите стрелку рядом с Приложения , чтобы открыть список приложений.
  4. Дважды щелкните Create surface view wEdge , чтобы запустить макрос.
  5. Выберите поверхность детали.

    При наведении указателя мыши на грани детали появляется желтая стрелка, указывающая ребра, по которым можно выровнять вид. Наконечник стрелки показывает положительное направление оси X. Вид будет повернут так, что ось X будет соответствовать ровному горизонтальному ребру на виде. Начало координат вида и рабочей плоскости будет находиться в начале линии привязки со стрелкой.

  6. Укажите требуемое ребро.

    Tekla Structures создает новый временный вид, и выбранное ребро образует ось X этого вида. Работая во временном виде поверхности, можно одновременно видеть моделируемые объекты в исходном 3D-виде.

  7. Нажмите клавишу Esc , чтобы остановить макрокоманду.
  8. Чтобы вернуть рабочую плоскость обратно в начало координат:
    1. Повторите шаги 2–3, чтобы открыть список Приложения.
    2. Дважды щелкните макрос Work plane global.

      Рабочая плоскость вернется обратно в начало координат и будет соответствовать глобальным осям X, Y и Z модели.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Рейтинг: 
Голосов еще нет