Здравствуйте!

Вы знаете, что после входа пользователям становится доступно намного больше содержимого?

2019 Table of Contents

Журнал модели в многопользовательском режиме

Добавлено April 3, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Версия программы: 
2019

Журнал модели в многопользовательском режиме

Журнал модели в многопользовательском режиме

Tekla Structures ведет журнал модели , записывая действия, выполняемые над многопользовательской моделью различными пользователями.

В истории модели указывается, когда была изменена модель, каким образом она была изменена и кто внес изменения, а также содержатся комментарии к редакции модели.

Ведение журнала модели в многопользовательском режиме

  1. В меню Файл выберите Настройки > Расширенные параметры .
  2. Перейдите на вкладку Скорость и точность.
  3. Установите расширенный параметр XS_​COLLECT_​MODEL_​HISTORY в значение TRUE.
  4. Установите XS_​CLEAR_​MODEL_​HISTORY в значение FALSE.
  5. (Необязательно.) Перейдите на вкладку Многопользовательский режим.

    Установите расширенный параметр XS_​SAVE_​WITH_​COMMENT в значение TRUE.

    Это позволяет сохранять комментарии к редакциям модели.

Просмотр журнала модели в многопользовательском режиме

Чтобы просмотреть журнал модели, выполните одно из следующих действий.

  • На ленте щелкнитеи выберите объект в модели.

    История модели открывается в диалоговом окне Запросить объект.

  • Создайте отчет по журналу модели.

    1. На вкладке Чертежи и отчеты выберите Отчеты.

    2. Выберите в списке шаблон отчета, предназначенный для вывода журнала модели. В разных средах этот шаблон отчета может называться по-разному.

      В среде Default он называется Q_Model_History_Report.

    3. Нажмите кнопку Создать из всех , чтобы создать отчет по всем объектам в модели, или выберите один или несколько объектов в модели и нажмите кнопку Создать из выбранного , чтобы создать отчет по выбранным объектам.

Сохранение комментариев к редакции модели в многопользовательском режиме

При работе с многопользовательскими моделями можно сохранять комментарии к изменениям, вносимым в модель. Это означает, что все объекты, которые были изменены во время последнего интервала сохранения, содержат в себе информацию о редакции. Эту информацию можно использовать для фильтрации и в отчетах. Ее можно также можно использовать для определения того, кто из пользователей вносил изменения в объекты.

  • Владелец – это пользователь, который добавил объект в модель.

  • В разделе Журнал указывается, когда была изменена модель, каким образом она была изменена, кто внес изменения и комментарии к редакции модели.

Прежде чем сохранять комментарии к редакции модели, проверьте следующее:

  • Установите расширенный параметр XS_​SAVE_​WITH_​COMMENT в значение TRUE (меню Файл > Настройки > Расширенные параметры > Многопользовательский режим ).

  • Установите расширенный параметр XS_​COLLECT_​MODEL_​HISTORY в значение TRUE (меню Файл > Настройки > Расширенные параметры > Скорость и точность ).

  1. После установки указанных выше расширенных параметров в значение TRUE при сохранении модели Tekla Structures будет выводить диалоговое окно Комментарий к редакции модели. Введите комментарий и код редакции в полях Комментарий к редакции модели и Код редакции модели.
  2. Нажмите ОК.

Tekla Structures применяет значения, введенные в этом диалоговом окне, к деталям, которые были изменены с момента последнего сохранения. При запросе объектов сведения о редакции модели отображаются в диалоговом окне Запросить объект. Эти сведения также можно использовать в фильтрах выбора и вида.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Рейтинг: 
Голосов еще нет