Здравствуйте!

Вы знаете, что после входа пользователям становится доступно намного больше содержимого?

2019 Table of Contents

Создание шаблона PDF-отчета

Добавлено April 3, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Версия программы: 
2019

Создание шаблона PDF-отчета

Создание шаблона PDF-отчета

Можно создавать графические шаблоны и использовать их для отчетов в формате .pdf.

  1. В меню Файл выберите Редакторы > Редактор шаблонов .
  2. Выберите Файл > Создать > Таблицы .
  3. Выберите Правка > Свойства .
  4. В диалоговом окне Свойства страницы шаблона задайте размеры страницы в соответствии с требуемым форматом страницы (например, А4):

    Размеры должны соответствовать одному из форматов, определенных в файле конфигурации PaperSizesForDrawings.dat.

  5. Добавьте строки и поля значений для получения необходимых данных из базы данных Tekla Structures. Дополнительные сведения о добавлении строк и полей значений см. в разделе Создание шаблона.
  6. Выберите Файл > Сохранить как и сохраните отчет с расширением .pdf.rpt.
  7. Скопируйте новый шаблон в папку шаблонов, например в папке модели или настроек компании ( XS_FIRM ).

    Теперь вы можете создавать отчеты в формате .pdf , используя новый шаблон отчета .pdf. Дополнительные сведения о создании отчетов см. в разделе Создание отчета.

Пример PDF-отчета

В этом примере отчета используются следующие размеры страницы:

Ниже приведен пример отчета, созданного с использованием этого шаблона. Чтобы открыть отчет в браузере, щелкните здесь.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Рейтинг: 
Голосов еще нет