Здравствуйте!

Вы знаете, что после входа пользователям становится доступно намного больше содержимого?

2017i Table of Contents

Настройка ленты

Добавлено September 21, 2017 by Tekla User Assistance tekla.documentation@trimble.com

Версия программы: 
2017i

Настройка ленты

Настройка ленты

Вы можете настроить ленту в соответствии со своими потребностями. Можно, например, изменить размер и форму любой командной кнопки. Можно добавить пользовательские кнопки и назначить им команды. Кроме того, вы можете поместить не ленту часто используемые компоненты и расширения, чтобы вам было удобнее к ним обращаться.

Чтобы открыть средство настройки, перейдите в меню Файл > Настройки > Настроить > Лента .

В этом средстве предусмотрено два режима редактирования:

  • Упрощенный режим : позволяет добавлять, перемещать командные кнопки и изменять их размер; добавлять, скрывать и редактировать вкладки; удалять командные кнопки и вкладки с ленты.
  • Режим проектирования : позволяет выбирать, какое имя и значок используются для каждой командной кнопки; добавлять новые кнопки и назначать им команды; добавлять вертикальные и горизонтальные разделители.

Добавление командной кнопки

Добавлять командные кнопки можно просто путем перетаскивания команд на ленту или на панель инструментов быстрого доступа.

  1. Убедитесь, что Упрощенный режим включен.
  2. В списке Выберите ленту выберите ленту, которую вы хотите настроить.

    Например:

    Настраивать можно только ленты, доступные в используемой конфигурации.

  3. Найдите команду, которую вы хотите добавить.

    Также можно добавлять компоненты, макросы и расширения. Содержимое списков можно фильтровать с помощью поля Поиск. Например, введите сетк , чтобы найти команду Создать арматурную сетку и другие компоненты, связанные с сетками:

    • Пользовательские : команды, созданные на вкладке Пользовательские команды.
    • Tekla Structures : все команды Tekla Structures , доступные в этой конфигурации и в этом режиме.
    • Приложения и компоненты : компоненты, макросы, плагины и расширения.
  4. Перетащите команду на ленту.

    Голубым цветом показано место, где будет вставлена командная кнопка. Например:

    Note:

    Если навести указатель мыши на стрелку вниз, откроется список, куда можно перетащить команды. Список будет оставаться открытым, пока вы снова не щелкнете стрелку вниз.

    Также можно перетаскивать команды на Панель инструментов быстрого доступа , которая находится над лентой, или в фиксированный контейнер слева от ленты:

Удаление командной кнопки

  1. Выберите командную кнопку.
  2. Нажмите клавишу DELETE.

Перемещение командной кнопки

Командные кнопки можно переносить в другие места на ленте. Обратите внимание, что кнопки с раскрывающимися меню нельзя размещать друг под другом.

  1. Выберите командную кнопку, которую требуется переместить.

    Командная кнопка будет выделена:

  2. Перетащите командную кнопку в новое место.

    Голубым цветом показано место, где будет вставлена командная кнопка. Например:

Изменение размеров командной кнопки

Размер существующих командных кнопок можно изменять.

  1. Выберите командную кнопку, размер которой требуется изменить:

  2. Наведите указатель мыши на любую сторону или угол командной кнопки, чтобы появилась белая стрелка:

  3. Перетащите стрелку, чтобы определить новый размер:

    Размер командной кнопки изменится соответствующим образом. Остальные командные кнопки на ленте автоматически подвигаются, если необходимо.

  4. Дважды щелкните командную кнопку, чтобы ее развернуть.

    Теперь командная кнопка полностью заполняет пустое пространство вокруг нее:

Изменение внешнего вида командной кнопки

Режим проектирования позволяет изменить внешний вид любой командной кнопки.

  1. Убедитесь, что Режим проектирования включен.
  2. Выберите командную кнопку, которую требуется изменить.

    Отображаются текущие свойства командной кнопки.

  3. Чтобы изменить имя, выберите один из вариантов:
    • Без значка : командная кнопка не имеет имени.
    • Краткое имя : используется предусмотренная по умолчанию короткая версия имени.
    • Полное имя : используется предусмотренная по умолчанию полная версия имени.
    • Пользовательский : позволяет ввести пользовательское имя для командной кнопки.
  4. Чтобы изменить значок, выберите один из вариантов:
    1. Без значка : командная кнопка не имеет значка.
    2. Большой значок : используется предусмотренный по умолчанию большой значок (32x32).
    3. Маленький значок : используется предусмотренный по умолчанию маленький значок (16x16).
    4. Галерея : позволяет выбрать значок из галереи значков Tekla Structures.
    5. Пользовательский : позволяет задать пользовательский значок путем выбора подходящего файла изображения. Рекомендуемый размер — 32x32 пикселя для больших кнопок и 16x16 пикселей для маленьких кнопок. Если изображение отображается с неверным размером, проверьте разрешение файла изображения. Рекомендуемое разрешение — 96 DPI.
Tip:

При изменении командной кнопки с раскрывающимся меню параметры кнопки могут быть скрыты за этим меню. Прокрутите ленту вправо или влево, чтобы увидеть параметры.

Создание определенной пользователем команды

Вы можете создавать определенные пользователем команды и связывать их с любыми файлами или URL-адресами.

  1. Перейдите на вкладку Пользовательские команды.
  2. Нажмите кнопку Добавить.
  3. Введите уникальный идентификатор для команды и нажмите кнопку Создать.

    Например, предположим, что вы создаете ссылку на Tekla Discussion Forum. Введите в качестве идентификатора команды OpenTeklaDiscussionForum.

    Появится новая страница с дополнительными свойствами.

  4. Щелкните Действие и задайте файл или URL-адрес. Например, введите https://forum.tekla.com.
  5. Щелкните имя и введите имя для команды. Это имя будет отображаться в пользовательском интерфейсе Tekla Structures. Можно задать два имени: полное имя и короткую версию. Например, введите Tekla Discussion Forum в качестве полного имени команды и Форум в качестве короткой версии.
  6. Щелкните Значок и выберите подходящий значок из галереи значков Tekla Structures. Можно задать два значка: большой и маленький.
  7. Щелкните Всплывающая подсказка и введите всплывающую подсказку для команды. Например, введите Переход на Tekla Discussion Forum.
  8. Нажмите кнопку Применить , чтобы сохранить новую команду.
  9. Перейдите на вкладку Редактирование лент.

    Созданная вами команда присутствует в списке Пользовательские в левой части диалогового окна:

  10. Перетащите команду на ленту:

  11. Чтобы изменить пользовательскую команду, перейдите в Режим проектирования и отредактируйте свойства команды точно так же, как для любой другой команды.

Добавление пользовательской кнопки и назначение ей команды

На ленту можно добавлять новые кнопки, кнопки с разделителями, кнопки-переключатели и кнопки с раскрывающимися меню. Все эти кнопки представляют собой пустые заполнители для команд. После создания новой кнопки вы сможете назначить ей команду.

  1. Убедитесь, что Режим проектирования включен.
  2. На вкладке Редактирование лент щелкните требуемый тип кнопки, чтобы выбрать его:

    • Базовая : позволяет добавить кнопку для одной команды.
    • Переключатель : позволяет добавить кнопку, которая включает или выключает какой-либо режим. С помощью этого варианта можно добавить на ленту любой переключатель из меню Файл > Настройки > Переключатели .
    • Раскрывающееся меню : позволяет добавить кнопку с раскрывающимся меню, т. е. с группой команд под кнопкой. Для кнопки можно задать имя и пользовательскую всплывающую подсказку.
    • Разбить : позволяет добавить кнопку для одной команды плюс кнопку с раскрывающимся меню, т. е. с группой команд под кнопкой.
  3. С помощью мыши нарисуйте прямоугольную область для новой кнопки.

  4. Чтобы назначить кнопке команду:
    1. Убедитесь, что новая кнопка выбрана.
    2. На вкладке Команда найдите команду, которую вы хотите добавить.

      Содержимое списков можно фильтровать с помощью поля Поиск. Например:

    3. Нажмите кнопку Назначить эту команду. Команда будет назначена кнопке.
    4. На вкладке Внешний вид измените имя и значок команды, если необходимо.
  5. Чтобы добавить команды для кнопки с раскрывающимся меню:
    1. Вернитесь в Упрощенный режим.
    2. Найдите нужные команды.
    3. Перетащите команды на кнопку с раскрывающимся меню.

      Если навести указатель мыши на стрелку вниз, откроется список, куда можно перетащить команды. Список будет оставаться открытым, пока вы снова не щелкнете стрелку вниз.

Добавление разделителя

Можно добавлять вертикальные и горизонтальные разделители, чтобы разделить командные кнопки на ленте на группы.

  1. Убедитесь, что Режим проектирования включен.
  2. Нажмите кнопку Разделитель.

  3. С помощью мыши нарисуйте вертикально ориентированную прямоугольную область.

    В указанном вами месте появится вертикальный разделитель.

  4. Убедитесь, что разделитель выбран.
  5. При необходимости измените ориентацию и толщину разделителя.

Добавление, скрытие и редактирование вкладок

Вы можете добавлять, перемещать и переименовывать вкладки ленты, выбирать способ их выравнивания, а также скрывать вкладки, если они не нужны в вашем текущем проекте. Например, если вы моделируете только стальные детали, можно временно скрыть вкладку Бетон.

  1. Убедитесь, что Упрощенный режим включен.
  2. Чтобы добавить новую вкладку, щелкните знак плюсав конце ряда вкладок.
  3. Чтобы переименовать вкладку:
    1. Щелкните заголовок вкладки правой кнопкой мыши и выберите Переименовать....
    2. Введите новое имя.
    3. Нажмите Enter , чтобы сохранить новое имя.
  4. Чтобы изменить порядок вкладок на ленте, перетаскивайте заголовки вкладок.
  5. Чтобы изменить способ выравнивания вкладок, нажмите кнопкуи выберите один из вариантов:
    • Не скрывать полосу прокрутки : движение ленты при переключении между вкладками минимальное.
    • По левому краю : значки начинаются с левой стороны ленты.
    • По табуляции : значки начинаются с левой стороны текущей вкладки.
  6. Чтобы скрыть вкладки, которые в текущем проекте не нужны:
    1. Задержите указатель мыши на заголовке вкладки.

      Рядом с заголовком вкладки появится небольшой значок глаза:

    2. Нажмите значок глаза.

      Значок глаза меняет вид, а заголовок вкладки становится серым:

      Вкладка Вид теперь скрыта из ленты. При прокручивании ленты скрытые вкладки выглядят следующим образом:

    3. Чтобы снова отобразить скрытую вкладку, нажмите значок глаза еще раз.
  7. Чтобы удалить вкладку, выберите ее и нажмите Delete.

Сохранение ленты

После внесения всех необходимых изменений сохраните настроенную ленту.

  1. На вкладке Редактирование лент нажмите Сохранить кнопку.

  2. После возврата в Tekla Structures программа спросит, хотите ли вы загрузить новую ленту. Нажмите Да. Лента будет обновлена в соответствии с внесенными изменениями.

Проверка изменений

Можно сравнить первоначальную ленту с изменениями, которые вы внесли. Вы можете проверить, что вы добавили и что удалили, а также что перенесли на другие вкладки.

  1. Сохраните настроенную ленту, если вы еще этого не сделали.
  2. Нажмите кнопку Сравнить.
  3. В диалоговом окне Сравнить ленты проверьте внесенные изменения.

    Например:

    • Первый список : эти команды были удалены.
    • Второй список : эти команды были перенесены в новое место.
    • Третий список : эти команды были добавлены.
    Note:

    Под первоначальной лентой понимается файл ленты из комплекта установки Tekla Structures для текущей конфигурации.

  4. Если вы удалили команду и хотели бы вернуть ее обратно, перетащите ее из диалогового окна Сравнить ленты на ленту.
  5. Закончив, нажмите кнопку Закрыть.

Резервное копирование и восстановление лент

Вы можете в любой момент восстановить стандартные ленты Tekla Structures. Прежде чем восстанавливать стандартные ленты, обязательно сохраните резервную копию настроенной ленты, потому что настройки будут удалены без возможности восстановления. Резервный файл можно использовать для возврата к настроенной ленте, чтобы скопировать настройки ленты на другой компьютер или чтобы поделиться настроенной лентой с коллегами.

  1. Чтобы сохранить резервную копию настроенной ленты:
    1. На вкладке Редактирование лент нажмите Сохранить кнопку.

    2. Перейдите к папке ..\Users\<пользователь>\AppData\Local\Trimble\TeklaStructures\<версия>\UI\Ribbons.
    3. Сделайте копию требуемого файла ленты и сохраните ее в другой папке.

      Имена лент соответствуют конфигурациям Tekla Structures. Например, в конфигурации полностью файл ленты Моделирование называется albl_up_Full--main_menu.xml.

  2. Чтобы восстановить стандартные ленты Tekla Structures :
    1. В списке Выберите ленту выберите ленту, которую вы хотите восстановить.

      Например:

    2. Нажмите кнопку Восстановить значения по умолчанию. После этого будут использоваться стандартные ленты Tekla Structures.
  3. Чтобы снова перейти к настроенной ленте:
    1. Скопируйте файл резервной копии обратно в папку ..\Users\<пользователь>\AppData\Local\Trimble\TeklaStructures\<версия>\UI\Ribbons.
    2. После возврата в Tekla Structures программа спросит, хотите ли вы загрузить новую ленту. Нажмите Да. Лента будет обновлена в соответствии с внесенными изменениями.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Рейтинг: 
Average page rating: 5 (1 оценка)
Refresh page after voting to show updated result.