Здравствуйте!

Вы знаете, что после входа пользователям становится доступно намного больше содержимого?

2017i Table of Contents

Копирование объектов

Добавлено September 21, 2017 by Tekla User Assistance tekla.documentation@trimble.com

Версия программы: 
2017i

Копирование объектов

Копирование объектов

Для копирования объектов предусмотрен ряд различных способов. При копировании объекта Tekla Structures копирует все объекты, соединенные с ним, в том числе компоненты.

Копирование путем указания двух точек

Самый простой способ скопировать объекты в модели или на чертеже — указать исходную точку и одну или несколько конечных точек.

  1. Выберите объект, который требуется скопировать.
  2. Вызовите команду Копировать :
    • В модели на вкладке Правка выберитеКопировать.

    • На чертеже на вкладке Чертеж выберите Копировать > Копировать .

  3. Укажите исходную точку для копирования.

  4. Укажите одну или несколько целевых точек.

    Объекты копируются. Команда Копировать остается активной.

  5. Если вы хотите отменить последнюю операцию копирования, нажмите кнопкуОтменить в левом верхнем углу главного окна Tekla Structures.

    Команда Копировать по-прежнему остается активной.

  6. Чтобы остановить копирование, нажмите клавишу Esc.

Линейное копирование

В модели можно создать несколько копий объекта в одном и том же линейном направлении.

  1. Выберите объекты, которые требуется скопировать.
  2. На вкладке Правка выберите Специальное копирование > Линейно .

    Откроется диалоговое окно Копировать - линейно.

  3. Укажите две точки или введите координаты в полях dx , dy и dZ.

    Также использовать формулу для вычисления смещений по осям X, Y и Z. Например:

  4. Введите число копий.
  5. Нажмите кнопку Копировать.
  6. Чтобы остановить копирование, нажмите клавишу ESC
    Tip:

    Если диалоговое окно открыто, но команда уже неактивна, для ее активации нажмите кнопку Выбрать....

Копирование на заданное расстояние от исходной точки

Объекты можно копировать в новое место в модели или на чертеже путем указания расстояния от исходной точки. Для задания расстояния используется диалоговое окно Ввод местоположения в виде числа.

  1. Выберите объекты, которые требуется скопировать.
  2. Вызовите команду Копировать :
    • В модели на вкладке Правка выберитеКопировать.

    • На чертеже на вкладке Чертеж выберите Копировать > Копировать .

  3. Укажите исходную точку для копирования.
  4. Переместите курсор в направлении копирования объектов, однако не указывайте точку.
  5. Введите расстояние.

    Когда вы начинаете вводить значение, Tekla Structures автоматически отображает диалоговое окно Ввод местоположения в виде числа.

  6. Нажмите кнопку ОК.

Копирование путем перетаскивания

Перемещать и копировать объекты можно с помощью перетаскивания.

  1. В меню Файл выберите Настройки и установите флажок Перетаскивание , чтобы активировать команду.
  2. Выберите объекты, которые требуется скопировать.

  3. Удерживая нажатой клавишу Ctrl , перетащите объекты в новое место.

    Точка начала перетаскивании (центр, угол или средняя точка) влияет на выравнивание объекта в новом местоположении.

    Tekla Structures копирует объекты:

Note:

Чтобы скопировать метки сетки на чертеже, сначала выберите метку сетки, а затем либо активируйте переключатель выбора Выбрать линию сетки , либо выберите ручку метки сетки.

Копирование объектов в другой объект

В модели можно копировать объекты из одного объекта в другие подобные объекты. Это удобно делать, например, при деталировке ранее смоделированных деталей. Объекты, между которыми выполняется копирование, могут иметь разные размеры, длину и поворот.

  1. Выберите объекты, которые требуется скопировать.
  2. На вкладке Правка выберите Специальное копирование > В другой объект .
  3. Выберите объект, объекты из которого требуется скопировать (исходный объект).
  4. Выберите объект, куда будут скопированы объекты (целевой объект).

Копирование всего содержимого в другой объект

В модели можно скопировать объекты из сборки или отлитого элемента в другие подобные сборки или отлитые элементы, не выбирая отдельно каждый копируемый объект. Этим удобно пользоваться, например, когда после деталировки сборки требуется скопировать все узлы в другую подобную сборку.

  1. Убедитесь, что переключатель выбора Выбрать сборки активен.
  2. Выберите сборку или отлитый элемент, содержимое которых требуется скопировать (исходный объект).
  3. На вкладке Правка выберите Специальное копирование > Все содержимое в другой объект .
  4. Выберите сборки или отлитые элементы, куда будет скопировано содержимое (целевые объекты).

В результате Tekla Structures копирует следующие объекты:

  • Второстепенные детали
  • Армирование, болты и сварные швы
  • Срезы/вырезы, подгонки и фаски кромок
  • Сборочные узлы
  • Компоненты
Note:

Tekla Structures не копирует разделители заливки или второстепенные детали, созданные компонентом, которым также была создана главная деталь сборки. Если некоторые из копируемых объектов уже присутствуют в сборке или ЖБ элементе, копирование в которые производится, Tekla Structures может создать дубликаты объектов. Tekla Structures предупреждает о дубликатах второстепенных деталей, армирования и сборочных узлов, но не о дубликатах болтов, сварных швов, срезов/вырезов или компонентов.

Копирование на другую плоскость

В модели можно скопировать объекты с первой указанной плоскости на вторую (третью и т. д.) указанную плоскость. Положение скопированных объектов относительно второй (третьей и т. д.) плоскости остается таким же, как и положение исходных объектов относительно первой плоскости.

  1. Выберите объекты, которые требуется скопировать.
  2. На вкладке Правка выберите Специальное копирование > На другую плоскость .
  3. Укажите точку начала координат первой плоскости.
  4. Укажите точку на первой плоскости в направлении положительной полуоси X.
  5. Укажите точку на первой плоскости в направлении положительной полуоси Y.
  6. Повторите шаги 3–5 для всех конечных плоскостей.

Копирование из другой модели

Объекты можно копировать из другой модели по номерам стадий. Обратите внимание, что Tekla Structures копирует второстепенные детали из модели, только если они принадлежат к той же стадии, что и их главная деталь. Это также относится к объектам компонентов.

  1. На вкладке Правка выберите Специальное копирование > Из другой модели .

    Откроется диалоговое окно Копировать из модели.

  2. В списке Каталоги моделей выберите модель, из которой будут копироваться объекты.

    Это исходная модель. Обратите внимание, что целевая модель должна быть создана с использованием той же или более новой версии Tekla Structures , что и исходная модель. Нельзя копировать из новой версии в предыдущую версию.

  3. В поле Номера стадий введите номера стадий, объекты на которых будут копироваться, разделяя их пробелами.

    Например: 2 7.

  4. Нажмите кнопку Копировать.
  5. Закройте диалоговое окно.
Note:

При копировании разделителей заливки из другой модели скопированные разделители автоматически адаптируются к целевой модели. Всегда проверяйте, что скопированные разделители заливки адаптировались к целевой модели правильно.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Рейтинг: 
Голосов еще нет