Здравствуйте!

Вы знаете, что после входа пользователям становится доступно намного больше содержимого?

Инструмент для работы с комментариями

Последнее обновление May 16, 2018 by Tekla Extensions - General Design tekla.extensions-generaldesign@trimble.com

Версия программы: 
19.0
Среда: 
Not environment-specific

Инструмент для работы с комментариями

Содержание

  1. Назначение и описание
  2. Системные требования
  3. Установка и запуск
  4. Основы работы
  5. Обмен комментариями
  6. Создание комментариев в многопользовательском режиме
  7. Обмен комментариями между Tekla BIMsight и Tekla Structures
  8. Создание комментариев в двух моделях — оригинальной модели Tekla Structures и опорной модели IFC
  9. Примеры рабочих процессов
  10. Дополнительная информация

1.         Назначение и описание

Инструмент для работы с комментариям позволяет пользователям передавать друг другу информацию по проекту, изменения, вопросы и даже рабочие задания через модель Tekla Structures. Комментарии могут включать в себя снимки модели, местоположения камеры на виде, документы, веб-сайты и связанные с ними объекты оригинальной модели Tekla Structures или опорной модели IFC.

Комментарии автоматически сохраняются в папке модели. Затем комментарии можно открыть для доступа других пользователей из инструмента для работы с комментариями путем задания папки, которая будет использоваться для записи и чтения комментариев с общим доступом. Такой папкой может быть, например:

  • папка многопользовательской модели на сервере компании;
  • отдельная папка комментариев на сервере компании;
  • локальная папка, автоматически синхронизируемая на всех компьютерах и во всех компаниях с помощью файлообменных приложений, таких как Dropbox (http://www.dropbox.com).

Кроме того, комментарии можно получать и отправлять по электронной почте или через FTP-сайт.

Это дает пользователям возможность добавлять/получать комментарии в реальном времени в пределах одной организации, между организациями, не имеющими общих серверов, или просто иметь комментарии и заметки для себя в своих проектах.

Файлы, создаваемые и считываемые инструментом для работы с комментариями, имеют формат BIM Collaboration Format (BCF), определение которого разработано всемирной организацией buildingSMART. Это значит, что комментариями, в том числе связанными деталями модели и положениями видов, легко можно обмениваться с Tekla BIMsight или другими BIM-приложениями и средствами управления проектами, поддерживающими формат BCF.

 

2.         Системные требования

Конфигурация Tekla Structures:          любая (включая «Средство просмотра»)

Среда:                                    любая

3.         Установка и запуск

Чтобы установить и запустить расширение, выполните следующие действия.

  1. Загрузите и установите соответствующую версию инструмента для работы с комментариями (32-разрядную или 64-разрядную, x64). Программа установки автоматически определит используемую среду и установит панели инструментов, а также файлы в соответствующим папки.
  2. Перезапустите Tekla Structures. В пользовательском интерфейсе должна появиться новая панель инструментов со значком.

    Примечание. Панель инструментов связана с конкретным пользователем (т. е. учетной записью Windows); это значит, что пользователь, устанавливающий расширение, будет видеть ее в Tekla Structures, тогда как другие пользователи не будут.

    Чтобы вручную добавить расширение на пользовательскую панель инструментов в Tekla Structures, выполните следующие действия.

    1. Выберите «Инструменты» > «Настройка», чтобы открыть диалоговое окно «Настроить».
    2. На вкладке «Панели инструментов» нажмите кнопку «Создать...». В дереве панелей инструментов появится новая панель инструментов с именем «UserToolbar 1». Можно ввести для панели инструментов свое имя.
    3. Найдите расширение в списке слева, щелкните его и нажмите кнопку со стрелкой вправо, чтобы добавить его на панель инструментов.
    4. Нажмите кнопку «Закрыть».

4.         Основы работы

Откройте модель в Tekla Structures и щелкните значок на панели инструментов, чтобы запустить инструмент для работы с комментариями. Другой вариант — выбрать «Инструменты» > «Макрокоманды», затем выбрать «Инструмент для работы с комментариями» и нажать кнопку «Выполнить». Должен появиться интерфейс инструмента для работы с комментариями.

4.1.   Добавление нового комментария

Увеличьте масштаб изображения фрагмента модели, к которому требуется добавить комментарий. Находясь в требуемом месте в модели, нажмите кнопку «Создать» в верхнем левом углу инструмента для работы с комментариями. Инструмент для работы с комментариями запомнит текущее местоположение и угол камеры.

Примечание. Если добавить комментарий в перспективном виде, а затем перейти в ортогональный (или наоборот), выбранное местоположение отображено не будет. Поэтому желательно согласовать использование одного режима проекции для всех комментариев.

Новый комментарий появится в списке. Чтобы изменить значения в полях «Заголовок», «Назначено» или «Состояние», просто щелкните в поле (ячейке), которое требуется отредактировать. Появится всплывающее окно, в котором можно ввести новое значение.

4.2.   Написание текста комментария и добавление информации

Следующий шаг — написать сам комментарий. Просто щелкните поле комментария под списком комментариев и введите текст.

Над текстом комментария отображается ваше имя. Если вы хотите его изменить, щелкните его и отредактируйте.

С комментарием можно связать выбранные объекты модели. Это значит, что при выборе комментария в списке инструмента для работы с комментариями в модели не только будет показано местоположение, где был создан комментарий, но также будут выделены/выбраны детали модели, связанные с комментарием. Выберите детали в модели и нажмите кнопку «Связать объекты». Количество связанных объектов отображается на кнопке «Объект(ы)»; при нажатии кнопки они выделяются.

Далее можно связать с комментарием документ или URL-адрес. Введите адрес или путь непосредственно в поле «Связь» или нажмите кнопку «...» рядом с полем, чтобы найти документ на своем компьютере или в папке на сервере. Путь к файлу будет вставлен в комментарий и сохранен вместе с ним. При нажатии кнопки «Открыть» связанный документ открывается в приложении, сопоставленном по умолчанию его типу файла/расширению. Веб-ссылки (URL-адреса) открываются в Internet Explorer.

Совет. Если в качестве первого символа пути ввести точку (.), он будет указывать на папку текущей модели. Если предоставить к комментарию общий доступ (см. раздел «Обмен комментариями»), при открытии комментария другим пользователем путь будет указывать на его папку модели. Этим удобно пользоваться для совместно используемых моделей и заметок. При выборе файла в папке текущей модели точка вставляется автоматически.

Наконец, к комментарию можно добавить снимок. Просто щелкните в поле с изображением камеры. Появится прозрачное окно камеры. Наведите окно на область в модели, снимок которой требуется сделать, и соответствующим образом измените его размеры. Нажмите кнопку «Захват» или дважды щелкните внутри прозрачного окна, чтобы сделать снимок. Полученное изображение будет связано с комментарием.

   

Совет. На снимок можно добавить графические пометки, нажав кнопку «Изменить». Изображение откроется в приложении, сопоставленном по умолчанию PNG-файлам. Закончив редактировать изображение, сохраните его и закройте приложение-редактор. Изображение в инструменте для работы с комментариями обновится.

Закончив работу над текстом комментария и связав с ним всю необходимую информацию, можно нажать кнопку «Сохранить», чтобы сохранить комментарий.

4.3.   Ответ на комментарий

После сохранения комментария на него можно добавить ответ. Просто щелкните внутри поля комментария, отображаемого после вашего последнего комментария, и введите ответ. Закончив, нажмите кнопку «Сохранить». Комментарий будет добавлен в качестве ответа в текущую ветку.

Примечание. Добавить в ответ снимок или ссылку невозможно. Если требуется сделать новый снимок, необходимо добавить новый комментарий.

4.4.   Фильтрация комментариев

Для поиска нужного комментария введите текстовую строку в поле фильтра на панели инструментов. Комментарии будут фильтроваться по ходу ввода.

В результате в списке комментариев будут присутствовать только комментарии, содержащие какую-либо часть введенной текстовой строки. Поиск производится в заголовках и основном тексте комментариев, а также в полях «Состояние» и «Назначено».

Чтобы снять фильтр, просто очистите поле фильтра.

4.5.   Настройки

При щелчке по значку «Настройки» открывается меню с параметрами, позволяющими постоянно отображать диалоговое окно поверх остальных окон, показывать при открытии комментария связанные с ним объекты (а не восстанавливать сохраненный вид камеры), изменить ориентацию диалогового окна инструмента для работы с комментариями, а также мгновенно обновлять список комментариев при обнаружении новых комментариев в общей папке.

 

5.         Обмен комментариями

Все созданные комментарии будут сначала храниться без общего доступа в папке модели (в папке с именем PrivateComments). Вы можете решить, к каким из комментариев предоставить доступ другим пользователям. Для предоставления общего доступа к комментарием используется формат bcfzip; это значит, что обмениваться заметками можно как с другими пользователями инструмента для работы с комментариями, так и с пользователями Tekla BIMsight.

Существует два варианта предоставить другим пользователям доступ к комментарию.

5.1.   Обмен с помощью общей папки

Для обмена комментариями их можно поместить в любую папку на вашем компьютере или в сети. Если у других пользователей инструмента для работы с комментариями есть доступ к выбранной вами папке, они могут настроить его на использование той же папки, и при предоставлении вами общего доступа к своим комментарием все автоматически будут их получать. Для организации общего доступа к комментариям очень удобно пользоваться файлообменной службой/службой синхронизации файлов, такой как Dropbox. Просто укажите в инструменте для работы с комментариями папку, настроенную на автоматическую синхронизацию между компьютерами и компаниями (о том, как синхронизировать папку с другими пользователями, см. в документации к конкретной файлообменной службе).

Чтобы указать папку с общим доступом, раскройте меню общего доступа и выберите «Задать общую папку». Текущая общая папка будет отображаться внизу меню общего доступа. Пункт «Открыть общую папку» позволяет открыть содержимое папки в Проводнике Windows.

Выберите один или несколько комментариев, к которым требуется предоставить общий доступ, и выберите «Предоставить общий доступ к выбранному». Выбранные комментарии упаковываются и копируются в общую папку.

При предоставлении общего доступа сразу к нескольким комментариям создается один BCFZIP-файл. Этот файл удобно импортировать в Tekla BIMsight или вкладывать в сообщения электронной почты. При многократном предоставлении общего доступа к комментарию будет создано несколько версий BCFZIP-файла, каждая со своей меткой времени.

Примечание. Общая папка очищается при каждом запуске инструмента для работы с комментариям. Подробнее см. ниже в этом документе.

При написании нового комментария или ответе на комментарий можно нажать кнопку «Сохранить и предоставить общий доступ» под полем комментария. Комментарий или ответ при этом сохраняется и сразу же помещается (вместе со всей веткой комментария) в общую папку.

5.2.   Обмен по электронной почте

Для обмена комментариями по электронной почте сначала выберите комментарии, доступ к которым требуется предоставить другим пользователям, затем в меню общего доступа выберите «Копировать выбранное в буфер обмена». Затем создайте новое сообщение электронной почты в Outlook, щелкните правой кнопкой мыши в теле сообщения и выберите «Вставить». В результате комментарии будут добавлены в сообщение в виде вложения.

Совет. Скопированные комментарии помещаются в виде файлов в буфер обмена Windows, поэтому их можно вставить в любой клиент электронной почты или приложение, поддерживающее вставку файлов из буфера обмена. Если в вашем клиенте это сделать не удается, просто поместите комментарии в общую папку («Предоставить общий доступ к выбранному») и вложите BCFZIP-файл оттуда.

5.3.   Получение комментариев от других пользователей

Новые комментарии считываются инструментом для работы с комментариями непосредственно из общей папки. Поэтому при совместной работе нескольких пользователей инструмента все они должны размещать комментарии в одной и той же сетевой папке или же пользоваться папкой, автоматически синхронизируемой с другими компьютерами (такой как папка Dropbox). Тогда каждый раз, когда кто-то предоставляет общий доступ к комментарию, этот комментарий сразу же становится доступным всем остальным пользователям.

При щелчке по значку «Обновить» справа от меню общего доступа инструмент для работы с комментариями считывает все комментарии и обновления, которые он найдет в общей папке. Новые комментарии отображаются зеленым цветом, а существующие комментарии, имеющие обновления или новые ответы — синим цветом. 

Если кто-либо из пользователей использует для комментирования другое приложение (такое как Tekla BIMsight), эти пользователи могут экспортировать комментарии из этого приложения в ту же общую папку. При обновлении эти комментарии будут считываться инструментом для работы с комментариями.

При получении комментариев по электронной почте их можно открыть, просто перетащив на список комментариев в инструменте. Но, конечно, можно также скопировать полученные комментарии в общую папку и щелкнуть значок «Обновить», как описано выше.

Совет. Если в меню настроек установлен флажок «Постоянное обновление», инструмент для работы с комментариями будет автоматически считывать новые и обновленные комментарии сразу же после их добавления в общую папку.

5.4.   Как работает предоставление общего доступа

Иногда на один и тот же комментарий могут ответить несколько пользователей, и вы получите эти файлы из разных источников и в разное время, зачастую даже не в том порядке, в котором они были созданы.

При обновлении списка комментариев из общей папки инструмент для работы с комментариями сравнивает содержимое всех найденных файлов комментариев. При наличии нескольких файлов, содержащих разные ответы на один и тот же исходный комментарий, они объединяются и отображаются как единый комментарий с ответами, отсортированными по метке времени.

При каждом запуске инструмента для работы с комментариями комментарии сравниваются и объединяются так, как описано выше. Кроме того, инструмент для работы с комментариями создает один BCFZIP-файл для каждого комментария. Исходные файлы затем удаляются, однако общая папка будет по-прежнему содержать всю ту же информацию. Это позволяет избежать нагромождения файлов комментариев в папке.

Все заметки всегда сохраняются также локально (в папке PrivateComments внутри папки модели). Поэтому при удалении комментариев из общей папки они сохраняются в виде локальной копии, доступной из инструмента для работы с комментариями. Если написать ответ на удаленный комментарий и предоставить к нему общий доступ вся ветка будет снова помещена в общую папку.

 

6.         Создание комментариев в многопользовательском режиме

Общую папку можно использовать для предоставления общего доступа к комментариям в многопользовательском режиме. В качестве общей папки можно установить папку внутри папки основной модели на сервере. Это значит, что все работающие с моделью пользователи будут иметь мгновенный доступ к любым из общих комментариев.

Изменить местоположение папки общий комментариев можно с помощью пункта «Задать общую папку» в меню общего доступа. Также можно открыть папку комментариев в Проводнике Windows с помощью пункта «Открыть общую папку».

Примечание. Перед предоставление общего доступа комментарии будут храниться отдельно у каждого пользователя в локальной папке внутри папки модели, которая называется PrivateComments. Эту папку не следует синхронизировать при совместном использовании модели. Исключить ее из синхронизации можно в меню Tekla Structures, выбрав «Файл» > «Совместное использование моделей» > «Настройки...» > «Настройки».

Общая папка позволяет всем пользователям, работающим в многопользовательском режиме над проектом, одновременно просматривать, добавлять и редактировать комментарии в пределах этого проекта. При добавлении комментариев в многопользовательской модели не требуется, чтобы все работающие над ней пользователи сохраняли модель, прежде чем увидеть комментарии, потому что сами комментарии не сохраняются в базе данных модели; они представляют собой внешние файлы, только связанные с моделью. Это очень удобно, особенно при наличии двух копий одной и той же модели, загруженной на двух разных компьютерах, например, в разных офисах в разных регионах страны или мира: в качестве папки комментариев в этом случае можно установить одну общую сетевую папку, к которой могут обращаться оба офиса. Файлы комментариев очень малы по сравнению с моделью; это значит, что обмениваться комментариями при больших расстояниях между пользователями можно в реальном времени через папку на сервере без обмена самими моделями.

Попробуйте попользоваться инструментом для работы с комментариями в многопользовательском режиме вместе с кем-либо из коллег. Если установить флажок «Постоянное обновление» в меню настроек, вы увидите, что, когда инструмент для работы с комментариями открыт на вашем компьютере и компьютере коллеги и вы начинаете добавлять комментарии и предоставлять к ним общий доступ, ваши комментарии будут автоматически отображаться на экране у коллеги и наоборот. Новые комментарии будут отображаться зеленым цветом, а измененные — синим.

Пусть затем один человек закроет свой сеанс инструмента для работы с комментариями, а другой продолжит добавлять комментарии и отвечать на них. После того, как ваш коллега добавит и изменит несколько комментариев, снова откройте инструмент. Обратите внимание, что при открытии инструмента некоторые комментарии будут отображаться вверху списка и зеленым цветом, а некоторые — синим цветом. Инструмент для работы с комментариями запоминает комментарии из вашего предыдущего сеанса, определяет, что с тех пор изменилось, и сообщает вам об изменениях. Комментарии в списке располагаются в порядке от самых новых к самым старым.

Еще один совет: при работе с большими проектами, где проект приходится разбивать на несколько моделей и требуется координировать изменения или вопросы, связанные с линиями совмещения двух моделей, можно использовать инструмент для работы с комментариями в двух разных моделях Tekla Structures, чтобы делать снимки и сохранять местоположения камеры в модели A, а затем показывать их пользователю в модели Б. Для этого главное, чтобы линия совмещения стальных конструкций, заканчивающаяся в модели А, находилась точно в том же физическом местоположении, где начинается линия совмещения стальных конструкций в модели Б.

 

7.         Обмен комментариями между Tekla BIMsight и Tekla Structures

При наличии установленной программы Tekla BIMsight ( http://www.teklabimsight.com) можно легко организовать обмен комментариями между Tekla Structures и Tekla BIMsight.

Чтобы проверить, как работает обмен, сначала опубликуйте модель в Tekla BIMsight (в меню Tekla Structures выберите «Файл» > «Публикация в Tekla BIMsight»). Откройте модель в Tekla BIMsight.

Выберите несколько заметок в инструменте для работы с комментариями, после чего выберите «Предоставить общий доступ к выбранному». Затем перейдите в Tekla BIMsight и выберите «Notes» > «Sharing» > «Import Notes».

Перейдите к общей папке и выберите заметки, к которым вы только что предоставили общий доступ из инструмента для работы с комментариями (если вы не уверены, какие именно это комментарии, ориентируйтесь по времени создания). В результате комментарии будут добавлены в список заметок.

Дважды щелкните заметку, чтобы открыть ее; вы увидите, что в ней присутствуют комментарий, ответы, снимки и связанные объекты. Щелкните снимок, чтобы перейти к тому месту в модели, где изначально была создана заметка.

 

Один и тот же комментарий, открытый в инструменте для работы с комментариями и Tekla BIMsight
 

Теперь можно добавить ответ на комментарий в Tekla BIMsight и создать несколько новых заметок. Затем выберите все заметки в списке заметок и выберите «Sharing» > «Save to File». Сохраните файл в общую папку инструмента для работы с комментариями.

Затем перейдите в инструмент для работы с комментариями и щелкните значок «Обновить». Новые комментарии появятся в списке комментариев, а к существующим комментариям будут добавлены новые ответы. При щелчке по каждому из новых комментариев должно отображаться то же место в модели, которое было указано при создании комментария в Tekla BIMsight, при условии, что модель в Tekla Structures находится в том же режиме проекции (перспективном/ортогональном), что и в Tekla BIMsight.

Совет. Точно так же можно обмениваться комментариями по электронной почте — из Tekla BIMsight, выбрав «Send as E-mail», или из инструмента для работы с комментариями, как описано в разделе «Обмен комментариями». Получив комментарии в сообщении электронной почты, вы можете перетащить вложенные файлы непосредственно на список комментариев либо в Tekla BIMsight, либо в инструменте для работы с комментариями, чтобы просмотреть комментарии.

 

8.         Создание комментариев в двух моделях — оригинальной модели Tekla Structures и опорной модели IFC

Следующий шаг в проверке работы инструмента — продемонстрировать, как создавать комментарии к объектам модели IFC после ее разделения. В этом предлагаемом тестовом рабочем процессе необходимо сначала экспортировать IFC-файл текущей модели («Файл» > «Экспорт» > «IFC»). Затем необходимо создать новую модель Tekla Structures и вставить этот IFC-файл как опорную модель в новую пустую модель Tekla Structures («Файл» > «Вставить опорную модель»). При вставке опорной модели следите за тем, чтобы модель была вставлена в той же ориентации и в то же начало координат, что и оригинальная модель Tekla Structures. После вставки IFC-модели обязательно выберите модель в Tekla Structures и нажмите кнопку Разделить в диалоговом окне «Вставить опорную модель». Это необходимо для того, чтобы инструмент для работы с комментариями мог считывать GUID-идентификаторы IFC из объектов модели.

После этого снова откройте инструмент для работы с комментариями и измените расположение папки общих комментариев в этой новой модели на папку комментариев ранее использовавшейся оригинальной модели Tekla Structures. При этом в папке появятся комментарии из той модели. Убедитесь, что в свойствах 3D-вида модели установлен тот же режим (перспективный/ортогональный), который использовался при добавлении комментариев. Щелкая по комментариям в списке, вы увидите, что отображаются те же места, которые были определены в первоначальной модели, а также что выделяются объекты модели IFC, представляющие те оригинальные объекты, с которыми были связаны комментарии в ранее использовавшейся модели.

   

Если вы инженер и у вас есть какие-либо IFC-файлы, полученные от архитектора, или если вы генеральный подрядчик и у вас есть какие-либо файлы с инженерными сетями и оборудованием или другие IFC-файлы, вставьте их в модель и также разделите на объекты. Эти объекты также можно связывать с комментариями в инструменте для работы с комментариями. Просто, прежде чем выбирать опорные объекты IFC для связывания с комментариями, убедитесь, что на панели инструментов выбора активирован переключатель «Выбрать объекты в компонентах».

Один из предлагаемых здесь рабочих процессов состоит в том, что при работе с проектной группой конструкторов, пользующихся другим набором способных экспортировать IFC-модели BIM-приложений, деталировщики могут, тем не менее, использовать эти модели в Tekla Structures для согласования со своей деталировочной моделью. Так, например, деталировщик металлоконструкций может вставить IFC-модель инженерных систем, архитектурную IFC-модель и IFC-модель строительных конструкций в копию своей деталировочной модели либо вставить их в новую пустую модель Tekla Structures, а затем вставить туда же копию своей деталировочной модели, опубликованную в формате модели IFC. При этом все модели сохраняются в виде единой модели Tekla Structures, которую деталировщик может отправить генеральному подрядчику или конструкторской группе. Последним будет достаточно даже лицензии «Средство просмотра» для навигации по объединенным моделям, запроса свойств, измерений и, самое главное, добавления/просмотра комментариев в объединенной модели. Таким образом, конструкторская группа и группа деталировщиков легко могут отправлять друг другую комментариями, т. е. обмениваться информацией внутри защищенной среды опорных IFC-моделей — с короткой кривой внедрения и минимумом затрат и рисков. Платформа Tekla Structures рассчитана на работы с большими объемами информации и большим количеством моделей, чем другое программное обеспечение BIM, поэтому для проверки и обмена информацией другие участники проекта также могут пользоваться Tekla Structures в целях ускорения и повышения эффективности процесса.

Иногда подобный процесс выходит за рамки одной компании с общей папкой на сервере, однако в этом случае все равно можно попробовать настроить сеанс обмена комментариями в реальном времени. Это делается с помощью файлообменной службы/службы синхронизации файлов, такую как Dropbox (www.dropbox.com). Корпорация Tekla не дает никаких гарантий и не принимает на себя никаких обязательств в отношении использования службы Dropbox, однако при тестировании инструмента для работы с комментариями нам удалось быстро, легко и бесплатно настроить систему комментирования в реальном времени с участием нескольких компаний на основе базовой функциональности синхронизации файлов, обеспечиваемой Dropbox. Схема рабочего процесса в этом случае может выглядеть так, как показано ниже.

 

9.         Примеры рабочих процессов

Ниже приведено 5 начальных примеров возможного использования инструмента для работы с комментариями:

1.             При работе над многопользовательской моделью в реальном времени для обмена комментариями о проверке, рабочими заданиями на день или вопросами даже до сохранения модели.

2.             Для отслеживания запросов информации, заявок на изменение или проблемных областей. В этом случае комментарии — это что-то вроде стикеров, на которых вы делаете заметки по работе с моделью.

3.             Комментарии, сделанные в Tekla BIMsight, могут извлекаться инструментом для работы с комментариями, если экспортировать их в общую папку (или экспортировать иным образом, а затем перетащить на список комментариев). Это значит, что инженеры, архитекторы, подрядчики, монтажники, проектные менеджеры и изготовители конструкций, у которых на компьютерах может не быть Tekla Structures, все равно могут делать комментарии к модели с помощью Tekla BIMsight, а у пользователей Tekla Structures те же помеченные комментариями области модели будут открываться непосредственно в Tekla Structures.

4.             Деталировщик, работающий в Tekla Structures, может опубликовать IFC-модель своего проекта. Инженер или изготовитель, работающие в Tekla Structures, могут открыть новую модель Tekla Structures и вставить нее полученную от деталировщика IFC-модель с разделением на объекты. При этом инженер или изготовитель не могут изменять созданную деталировщиком геометрию и могут не беспокоиться о каталогах профилей, настройках нумерации и т. п.: они просто добавляют комментарии в модель и связывают их с объектами опорной IFC-модели, сформированными деталировщиком. Затем файлы комментариев отправляются обратно деталировщику. Он загружает эти комментарии в свой оригинальный деталировочный проект Tekla Structures, после чего комментарии, созданные в опорной IFC-модели и связанные с ее объектами, появляются в проекте, причем теперь они связаны с оригинальными объектами Tekla Structures, созданными деталировщиком. Это возможно благодаря тому, что комментарии «запоминают» — посредством GUID-идентификатора IFC-объекта — связь между IFC-объектами и оригинальными объектами Tekla, из которых они были сформированы. В результате получается более безопасная и простая схема совместной работы над опубликованным проектом.

5.             Находясь на строительной площадке, монтажник делает фотографию, иллюстрирующую какое-либо полевое условие или область площадки. Используя даже лицензию «Средство просмотра» на Tekla Structures и инструмент для работы с комментариями, он может перетащить файл фотографии полевого условия и связать его с соответствующей областью и деталями в модели. Все это затем легко можно упаковать и отправить обратно в офис на рассмотрение менеджером проекта.

10.     Дополнительная информация

На странице инструмента для работы с комментариями в Extranet ( https://extranet.tekla.com/BC/tekla-structures-en/product/extensions/comment-tool/Pages/Default.aspx ) есть несколько видеороликов, демонстрирующих варианты использования инструмента. Обратите внимание, что это ролики были сняты с предыдущей версией инструмента для работы с комментариями, поэтому в них могут некоторые несоответствия. Сами по себе рабочие процессы, однако, остаются такими же.

 

Эта страница написана для старой версии Tekla Structures

Комментарии к документации и отзывы о ней закрыты, потому что эта страница больше не будет обновляться.

Рейтинг: 
Голосов еще нет