Hello!

Did you know that logged in users can see a lot more content?

Detail Manager

Last updated November 10, 2016 by Tekla Structures Extensions USA solutions.us@tekla.com

Software version: 
Not version-specific
Environment: 
United States (Imperial)
United States (Metric)

Detail Manager


Purpose and description

This tool allows users to create section and detail views on General Arrangement (GA) drawings quickly and easily through a simple interface. It circumvents the need to identify, cut sections and define blowup details by utilizing component marks and associative notes on plan and elevation drawings.

System requirements

Environments:   Default
Languages:   English

Installing Detail Manager

To install the application:

  1. Close Tekla Structures (if running)
  2. Download the appropriate MSI Installer from Tekla Warehouse.
  3. Install MSI Installer…
  4. Start Tekla Structures
  5. Before version 2016:A new toolbar icon which will launch the tool should now be visible. 2016 version and newer: a new thumbnail under Ungrouped items in the Applications and components side pane will appear.

Using Detail Manager

Introduction

The tool is designed to fit with several workflows

  1. Steel Detailers creating sections and details for the review or approval process and for site instructions.
  2. Engineers creating connection design sketches of each similar connection for validation.
  3. Concrete detailers producing shop fabrication and site installation details.

This extension contains features defined specifically for these processes but can be used in other methods too.

Getting Started

  1. Start the tool by clicking the icon on the toolbar or by going to Tools > Macros > Global within Tekla Structures, select Detail Manager in the list, and press the Run button.
  2. As the interface opens it will detect any GA type drawings previously created by this tool and show them in the list. You can have the interface show all GA type drawings as well (see Options section below).
  3. The interface is icon driven and tool tips will appear as the mouse is hovered over each icon.

From Left to Right

  1. Refresh: This is only required when the model or details are altered while the interface dialog is open and will update all the drawings and details.
  2. Create Drawings:
    1. Create New Blank: Creates a new blank GA drawingdrawing that is created from one or more model views and that shows information needed to understand the general arrangement of structural elements on a project

      General arrangement drawings show how parts, assemblies, cast units, or pour objects are located in a building.

      conforming to the Drawing Settingssettings that control what the drawing looks like and what it includes

      Drawing settings can be defined in the modeling mode when creating a drawing, and they can be modified in the drawing mode.

      The range of the objects and elements that drawing settings affect may vary.

      defined in the Program Defaults.
    2. Create New from Model: Creates a new GA drawing with views based on the selected System Components, Custom Components, ModelViews, or ReferenceViews in the model.
    3. Create New from File(s): Creates a new GA drawing with a selection of 2D details in either DWG, DXF or DDF format. These details will not be located on plan or elevation drawings unless you add a Reference View in the model.
  3. Create Views:
    1. Create New Reference View: This function allows linking of a 2D Reference Filefile that contains information that can be used in a model or a drawing

      A reference file can contain a reference model or a reference drawing, for example.

      by first defining a location in the model where that Reference View exists. The location will appear on Plan or Elevation drawings, denoting which detail sheet the reference file is shown upon.
    2. Create New Model Viewview that is represented in the modeling mode

      Model view is available also in the drawing mode and it is represented in its own window.

      : For locations where multiple components exist or where no components exist, a ModelView can be created. The users is prompted to input 2 points defining the extrema for the drawing viewview that includes selected model objects or an area in the model, that is represented in a drawing

      A drawing view is a container for model and drawing objects.

      A drawing can include several drawing views, which usually are two-dimensional views, plane views, to the model.

      Examples of drawing views in Tekla Structures include main views, section views, single-part views, and 3D views.

      .
  4. Options:
    1. Component Settings: This is where you can define different view settings to be used for specific components in the model. See section 10 below for more information.
    2. Program Defaults: This is where you define the settings to be used for the GA drawings. See section 9 below for more information.
  5. Select Mode:
    1. Select Only: This will select the component in the model when you click on a detail viewdrawing view that is created from an existing drawing view and that shows a selected area of that view in the same viewing direction

      Detail view is usually in a larger scale than the source view.

      The view plane of the detail view is the same as the view plane of the source view.

      in the list.
    2. Select and Zoom: This will select the component in the model and zoom to it in the selected model view when you click on a detail view in the list.
    3. Find from Model: Select a component in the model and then pick this option to highlight the associated view in the list.
  6. Always On Top: Select this option to keep the Detail manager dialog box on top of all other windows or allow it to be covered by other active windows if left unchecked.
  7. Help:
    1. About: This contains the important build information about the version of the tool that you have installed.
    2. Documentation: Opens this Help file.
    3. Log File: Opens the log file in your default text editor. This file may be needed by support if you have any issues with the tool. 

Component Settings

Every system and custom componentcomponent that the user creates and uses for creating model objects whose composition the user can modify as a group

has a Connection Code field on the General tab of the properties. The Detail Manager uses these connections codes to determine whether or not to create a detail view based on the applied settings.
This applies for Model Views and Reference Views created with the Detail Manager as well.

 
To have the Detail Manager only create one view (or set of views) per Connection Code, go to Options > Program Defaults and check the box next to Limit new views by unique component code?. (This is the default setting)
If this box is unchecked, the Detail Manager will create views for all components in the model, regardless of their Connection Code.

Creating Model Views

  1. Activate the command by clicking the Create Views icon and select Create Model View.

  1. Select two points in the model that define the limits of the extrema.

  1. Double click on the component to open the Model View properties dialog box. Define the View Namename of an individual view

    , Connection Code, as well as the Width and Height of the DrawingBlockCube if needed. Model View settings get saved in the “attributes” folder in the model folderfolder that is used for storing files associated with a model

    Tekla Structures stores all files associated with a model in a folder it creates with the same name as the model database (.db1).

    In multi-user mode all users access the same model folder.

    with a file extension of <>.DetailManagerLogic.DrawingBlockPlugins.ModelView.UI.MainForm.xml. These files can be copied to your Project and Firm Folders.
  2. This creates two parts in the model:
    1. DrawingBlockCube: Sets the view extrema on the detail drawing. All parts contained inside the DrawingBlockCube will be added to the detail.
    2. BlockMarkCube: 3/8”x3/8”x3/8” cube that is used to create the marks on Plan and Elevation GA drawings (see section 15 below).

Creating Reference Views

  1. Activate the command by clicking the Create Views icon and select Create New Reference View.

  1. Select a point in the model where you want the detail markuser-created symbol that includes a set of mark elements, identifies the point of creation of the detail view, and is displayed in the source view

    to be called out on the drawings.

  1. Double click on the component to open the Reference View properties dialog box.
    1. Saved File: Browse to a 2D file that will be the detail view. Files can be .dwg, .dxf, or .ddf (Tekla Symbol Manager) format.
    2. Define the View Name and Connection Code.
    3. Define the Dwg/dxf settings to be used. This uses saved attributes from the View > Add DWG\DXF File… command in the drawing editor.

  1. Reference View settings get saved in the “attributes” folder in the model folder with a file extension of  <>.DetailManagerLogic.DrawingBlockPlugins.ReferenceView.UI.MainForm.xml. These files can be copied to your Project and Firm Folders.
  1. This creates two parts in the model:
    1. DrawingDetailCube: Used to visualize the location of the detail in the Tekla model.
    2. BlockMarkCube: 3/8”x3/8”x3/8” cube that is used to create the marks on Plan and Elevation GA drawings (see section 15 below).

Drawing Settings

Before creating the Detail Drawings, go to Options > Program Defaults to establish how the drawings and detail views will get created. 

  1. Drawing Prefix: Defines the prefix for the Name of the GA drawing(s) that the Detail Manager will create with the detail views.
  2. Drawing Start No: Defines what number to start at to complete the Name of the GA drawing(s) created. The Detail Manger will create drawing in sequential order base off the prefix and start numberfirst number of a numbering series

    . If you define a prefix that is already in use, the Detail Manager will take the next available number higher than the start number you define.
  3. Views per Drawing: Defines how many views to add to each GA drawing before creating the next drawing.
  4. Drawing Settings: Defines the GA drawing attribute to use when creating the drawings.
  5. File View Settings: Defines the View attribute to use when creating details for Reference Views.
  6. Create new drawing for each component in model?: Use this setting if you only want one view (or set of views) per drawing (i.e. 8”1/2 x 11” calculation sheets)
  7. Limit new views by unique component code: Determines whether to create one view (or sets of views) for each unique connection code, or create views (or sets of views) for all components in the model regardless of the connection codes (see section 6 above).
  8. Read in all GA type drawings?: Use this setting if you want the Detail Manager to show all GA drawings that exist in the model. Leave this box unchecked if you only want the UI to show the drawings that were created by the Detail Manager (this is the default setting).
  9. Drawing Leading Zeros: Use this setting to define the number of digits in the numerical part of the drawing name (i.e. value of 3 = D001, D002, …D009, D010)

View Settings

Before creating the Detail Drawings, go to Options > Component Settings to establish the view settings to be used when creating the individual details on the detail drawings. You can search by component number and that component will show or you can add multiple components to one line by separating the component numbers by commas.

  1. Component Specific View Settings: This is where you can create saved settingsmaster drawing where the drawing settings are saved in a drawing property file and used when creating a new drawing of a specific drawing type

    to be used for various components or model views. All components views will be created using the “standard” setting unless specified otherwise in the Component Settings.
    1. Front, Top, Start End, Isometric, Back Bottom, Finish End: Check one or more options to determine which views of the component will get created.
    2. Rotation Around X and Z: Use these settings when the Isometric view is selected. These work the same way as the rotation in model views.
    3. View Settings: Use this setting to define which pre saved view attribute you want to use to create the detail views.
    4. Slope to Follow: Use these settings for skewed or sloped connections that may be unclear with a normal orthogonaldisplaying objects in right-angles projection

      In model view the size of the objects is the same despite of their distance to the viewing point and the zoom remains on part faces.

      view.
    5. Naming Style: Controls what information from the component will be added to the << View name >> attribute in the drawing editor.

Creating Detail Drawings

After applying the drawing and view settings, you can create the detail drawings by using one of the 3 methods in the Create Drawings button.

Organizing Drawings

In the main interface, you can add or remove headers to display drawing information, search for detail views, and create folders to make it easier to organize the detail drawings.

  1. Add header columns: Right click in the header area and click Show Column Chooser. Click and drag the desired columns to the desired header area.
  2. Remove header columns: Click and drag the column title outside of the Detail manager window.
  3. Search for details:
    1. Right click in the header are and click Show Search Panel. A search field will be displayed where you can enter text to search within any of the visible field.
    2. For a more detailed search, right click in the header and select Filter Editor. Here you can build a conditional statement by clicking on each of the fields. Click Apply or OK to filter the list.
  4. Create a new folder: Right click in the blank space below the column headers and select Create new folder. You can also create sub folders by right clicking on a folder and selecting Create new sub folder. Click and drag a drawing to place it in a folder.

Adding Views to Existing Drawings

With a component selected in the model, right click on a GA drawing in the Detail Manager list and select either Create View From Model or Create View From File.

Deleting Views from Existing Drawings

Right click on a detail view in the Detail Manager list and select Delete View. Always delete the details views using this method to ensure that the marks on the drawings are correct.

Mapping of Details

Each detail can be identified and located on the General Arrangement Drawings using localized settings that show labels for each detail created. These marks can be automated through Drawing or View Connection Marks, Drawing or View Object Level Settingsdrawing settings that affect the representation of selected drawing objects

Object level settings can be defined when creating a new drawing or when modifying an open drawing.

Object level settings can be use in a drawing or in a drawing view in order to change the representation of the chosen drawing objects.

, or added manually with an Associative Noteassociative annotation object that can include any additional information about the building object it is attached to

One building object can have several associative notes.

.

  1. Connection Markmark that includes a set of selected property elements related to a connection

    : Use the installed DetailManager_ConnMark connection mark attribute to add marks to all components on a plan drawing. This mark will indicate the detail number and the drawing that it is located.
  2. Object Level Settings: Use the installed DetailManager_OLS attribute to see which conditions to add to your existing Object Level Settings in order to remove the Connection Marks from any components that do not have a detail created as well as adding Part Marks for any of the Block Mark Cubes (see section 7 and 8 above) that were manually created in the model.

NOTE: For detail views, it is better to select the drawing cubes and manually hide them in lieu of filtering them out in the view properties.

  1. Associative Note: Use the installed DetailManager_ConnMark attribute to add an associative note to any part and display the detail number and drawing that the component detail is located on. If the part selected is not an object in a component, or if the component does not have a detail generated from the Detail Manager, then no associative mark will be created. This attribute uses the installed DetailManager_View.tpl mark template.

Reports

You can create a report of all components and Block Mark Cubes in the model that have details created by running the DetailManager_ComponentList report.

Copying Settings to XS_PROJECT or XS_FIRM

In order to copy all of your custom settings to your Firm or Project folders, open your model folder and copy the entire DetailManager folder from the model folder to your Firm or Project folders.

Installed Files

Objects.inp

  1. objects_DetailManager.inp: This file is installed to the <environment>\inp folder and contains the Custom Type attributes that used to create the filters. In order to make these UDA’s visible, copy this file into the model folder and rename it to objects.inp.

Filters:

View Filters, Selection Filters, Object Representationrepresentation of a model object or an object group in a model view, such a representation being based on the color and transparency settings applied to the model object or the object group

Filters, All Drawing Level Filters, and Drawing Selection Filters that are saved to the <environment>\system folderfolder that is used for storing files that define default settings

.

  1. DetailManager_BlockMarkCube: Isolates the Block Mark Cube (see sections 7 and 8 above). (14 files total)
  2. DetailManager_DrawingBlock: Isolates the Drawing Block Cube and Drawing Detail Cube (see sections 7 and 8 above). (14 files total)
  3. DetailManager_DrawingBlockCube: Isolates the Drawing Block Cube (see section 7 above). (14 files total)
  4. DetailManager_DrawingDetailCube: Isolates the Drawing Detail Cube (see section 8 above). (14 files total)
Model View:
  1. DetailManager_standard.rep: Object Representationthe way that the information included in a model is represented visually

    file that controls the colorization of model views. This file is installed to each <environment>\us_roles\<role>\system folder and is a copy of the out of the box standard.rep file with 3 lines added to control the DrawingBlockCube, DrawingDetailCube, and BlockMarkCube, which are created by the Detail Manager. You can make these the default settings by renaming the file to “standard”.
    1. Steel Role:

  1. All Other Roles:

Drawing Attributes:

  1. DetailManager_ConnMark.gjm: GA Drawing Connection Mark attribute saved in the <environment>\system folder.
    1. Engineering Role: A copy of this file with 1/8” font in lieu of 3/32” font is installed to the <environment>\us_roles\engineering\system folder.
  2. DetailManager_ConnMark.note: Associative Note attribute saved in the <environment>\system folder.
  3. DetailManager_ConnMark.vjm: Drawing View Connection Mark attribute saved in the <environment>\system folder.
    1. Engineering Role: A copy of this file with 1/8” font in lieu of 3/32” font is installed to the <environment>\us_roles\engineering\system folder.
  4. DetailManager_NoDetail.gdf: GA Drawing filter used in Object Level settings. Saved in the <environment>\system folder.
  5. DetailManager_NoDetail.vf: Drawing View filterfilter used for defining which objects are displayed in a model view or drawing view

    View filter chooses objects according to object properties. The user can filter objects according to their profile or material, for example.

    used in Object Level settings. Saved in the <environment>\system folder.
  6. DetailManager_NoMark.gjm: GA Drawing Connection Mark attribute used in Object Level settings. Saved in the <environment>\system folder.
  7. DetailManager_NoMark.vjm: Drawing View Connection Mark attribute used in Object Level settings. Saved in the <environment>\system folder.
  8. DetailManager_NotVisible.gdp: GA Drawing Part attribute used in Object Level settings. Saved in the <environment>\system folder.
  9. DetailManager_NotVisible.gdp.more: GA Drawing Part attribute used in Object Level settings. Saved in the <environment>\system folder.
  10. DetailManager_NotVisible.vp: Drawing View Part attribute used in Object Level settings. Saved in the <environment>\system folder.
  11. DetailManager_OLS.gclassif: GA Drawing Objectobject that is represented in a drawing

    Level Setting attribute saved in the <environment>\system folder.
  12. DetailManager_OLS.gclassif.copt: GA Drawing Object Level Setting attribute saved in the <environment>\system folder.
  13. DetailManager_OLS.vclassif: Drawing View Object Level Setting attribute saved in the <environment>\system folder.
  14. DetailManager_OLS.vclassif.copt: Drawing View Object Level Setting attribute saved in the <environment>\system folder.
  15. DetailManager_PartMark.gpm: GA Drawing Part Markmark that includes a set of selected property elements related to a part

    Part marks are made use of, for example, when identifying constructions, when giving information about welding, when giving information about assemblies to a workshop, when giving information about how parts should be connected to each other, and when creating bills of quantities.

    In the US, the term piece mark is used to refer to position number.

    attribute used in Object Level Settings. Saved in the <environment>\system folder.
    1. Engineering Role: A copy of this file with 1/8” font in lieu of 3/32” font is installed to the <environment>\us_roles\engineering\system folder.
  16. DetailManager_PartMark.vpm: Drawing View Part Mark attribute used in Object Level Settings. Saved in the <environment>\system folder.
    1. Engineering Role: A copy of this file with 1/8” font in lieu of 3/32” font is installed to the <environment>\us_roles\engineering\system folder.
  17. DetailManager_ReferenceView.vi: Default Drawing View attribute used for inserting file views. Saved in the <environment>\system folder.
  18. DetailManager_ReferenceView.vi.filter: Default Drawing View attribute used for inserting file views. Saved in the <environment>\system folder.

Templates and Reports:

  1. DetailManager_ComponentList.rpt: Report templatetemplate that is used for creating a report

    saved in the <environment>\system folder.
  2. DetailManager_View.tpl: Mark template used in Associative Note attribute. Saved in the <environment>\us_roles\<role>\system\mark folder.

Detail Manager Files:

  1. standard.DetailManagerLogic.DrawingBlockPlugins.ModelView.UI.MainForm.xml: Standard fileproperty file that Tekla Structures uses by default

    Standard files are used, for example, for loading frequently used values into the property pane or a dialog box.

    Standard file name is standard.* where the symbol * is the file name extension. For example, standard.clm file is used for column properties.

    used to create Model Views.
  2. standard.DetailManagerLogic.DrawingBlockPlugins.ReferenceView.UI.MainForm.xml: Standard file used to create Reference Views.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our documentation.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet