Hello!

Did you know that logged in users can see a lot more content?

Comment Tool

Last updated October 29, 2015 by Tekla Extensions - General Design tekla.extensions-generaldesign@trimble.com

Software version: 
Not version-specific
Environment: 
Not environment-specific

Comment Tool

Contents

  1. Purpose and description
  2. System requirements
  3. Installation and launch
  4. Basic Usage
  5. Sharing Comments
  6. Create Comments in Multi User Mode
  7. Sharing comments between Tekla BIMsight and Tekla Structures
  8. Create Comments in two Tekla Structures Models, one Native, one IFC Reference
  9. Summary of example workflows
  10. Additional information

1.         Purpose and description

Comment Tool allows users to communicate project issues, changes, questions, and even work assignments through Tekla Structures model. The comments can include model snapshots, a camera view location, documents, websites, and either Tekla Structures native or IFCfile format commonly used in BIM that facilitates software interoperability

IFC is an open specification developed by the IAI (International Alliance for Interoperability).

Model can be exported into an IFC file.

reference modelmodel which the designer can use as an aid when building another model

A reference model is created in Tekla Structures or in other software and can be inserted to Tekla Structures. The reference model appears together with the model but it is not modified by Tekla Structures. The user can snap to reference model points.

For example, an architectural model, a plant design model, or a heating, ventilating, and air-conditioning (HVAC) model can be a reference model.

objects linked to them.

The comments are automatically stored in the model folderfolder that is used for storing files associated with a model

Tekla Structures stores all files associated with a model in a folder it creates with the same name as the model database (.db1).

In multi-user mode all users access the same model folder.

. The comments can then be shared with others from the comment tool by specifying a folder that the tool uses to write and read shared comments. This folder can be, for example,

  • a model folder of a multi-user modelmodel that is used for collaboration and that is opened in multi-user mode

    on a company server
  • a stand-alone comment folder on a company server
  • a local folder automatically synchronized across computers and companies by file share applications such as Dropbox ( http://www.dropbox.com ).

In addition, comments can be sent and received using e-mail or via an FTP site.

This gives users the choice to add or share comments live within a single organization, across organizations that do nt share servers, or just have comments and notes for themselves on their projects.

The files created and read by the comment tool use the BIMprocess of modeling and communicating the structure of a building in detail to benefit the entire construction life cycle

BIM facilitates the exchange and use of building information in a digital format.

Collaboration Format (BCF, version 2.0) which is being defined by the global buildingSMART  organization. This means that comments, including linked model parts and view positions, can easily be exchanged with Tekla BIMsight or other BIM software and project management tools that support BCF.

2.         System requirements

Tekla Structures configurationTekla Structures software set-up for a specific user group

Tekla Structures license is a permission to activate and use certain Tekla Structures configurations. A Tekla Structures configuration consists of a set of features that the user is entitled to based on the license agreement, and is the commercial part of Tekla Structures.

There are several Tekla Structures configurations, for example, Steel Detailing, Precast Concrete Detailing, and Engineering.

:          Any (including Viewer)

Environments:                                    Any

3.         Installation and launch

To install and launch the extension:

  1. Download and install the appropriate 32bit or 64bit (x64) Comment Tool version. The installer will automatically detect your environment and install toolbars and files to the appropriate folders.
  2. Restart Tekla Structures. A new toolbar with an icon appears in the user interface.

    Note: The toolbar is user (ie, Windows user account) specific; which means that the user installing the extension would get the user toolbar in Tekla Structures and another user would not.

    To manually add the extension to a user toolbar in Tekla Structures:

    1. Click Tools > Customize to open the Customize dialog box.
    2. On the Toolbars tab, click “New....”. A new toolbar with the name “User Toolbar 1” appears in the toolbar tree. You can enter a new name for the toolbar.
    3. Search for the extension on the list on the left, click on it and then click the right arrow to add it to the toolbar.
    4. Click Close.

4.         Basic usage

Open a model in Tekla Structures and click the toolbar icon to start the comment tool. Alternatively, you can go to the Tools > Macros menu, select ‘Comment Tool’ and click ‘Run’. The comment tool interface appears.

4.1.   Add a new comment

Zoom into a specific location in the model that you want to comment on. Once you are in the preferred location, click the ‘New’ button in the top left corner of the comment tool.
The comment tool creates a new comment with a snapshot of the current view. In addition to an image, the snapshot contains the current location, camera angle, clip planes and selected objects.

Note: If you are adding a comment in ‘Perspective’ view and then switch to ‘Orthogonal’ view later on (or vice versa), the location won’t be shown. Agree on a single projection mode to use for all the comments.

The new comment appears in the comment list. To change the Title, Assigned or Status fields click in the field you want to edit. A popup appears and you can enter a new value.

4.2.   Write the comment text and add information

The next step is to write the comment itself. Click the comment box next to the comments list and enter your comment.

Above the comment box you can add a free text status. The most recent status will be shown in the status column in the comment list as well.

You can link selected model objects to the comment. This means that every time the comment is selected in the Comment Tool list, it will highlight or select the parts linked with the comment in the model (and zoom to them if that option is used). The objects that were selected when you created the new comment are already linked. Change the linked objects by selecting any parts in the model and click the ‘Link Objects’ button. The number of linked objects is visible in the ‘Object(s)’ button, and the objects can be highlighted by clicking the button.

Next you can link a document or a web url to the comment. Click ‘Add Link’ and enter an address or path directly in the ‘Link’ field that appears, or click the ‘...’ button next to the field to browse for a document on your computer or in a server folder. The file path will be inserted and stored with the comment. Clicking the ‘Open’ button opens the linked document with the default associated application for that file type or extension. Web links open in Internet Explorer.

Tip: If you use a dot (.) as the first character of the path, it will refer to the current modelmodel that is active in Tekla Structures

The current model can be a single-user model, a shared model or a working model.

folder. If you share the comment (see Sharing) and another user then opens the comment, the url will now refer to their model folder. This can be useful for shared models and notes. The dot will be inserted automatically if you browse to a file in the current model folder.

Finally you can add additional snapshots to the comment. When you create a new comment, a snapshot of the current view will be included. Update this snapshot by hovering over it and clicking ‘Update’. You can add more snapshots by navigating to the preferred view in the model, selecting objects and then clicking ‘Add Current View’.

Additionally, you can take a snapshot manually by clicking the drop-down button next to ‘Add Current View’ and selecting ‘Capture’. A transparent camera window appears. Move or resize the window over the area you want to take a snapshot of in the model, or even take a snapshot of another application. Click ‘Capture’ or double-click inside the transparent window to take the snapshot. The image will be associated with the comment.

   

Tip: You can add redlines to a snapshot by hovering over it and clicking ‘Edit’. The image opens in the application that is associated by default to open *.png files. After you have finished editing, save the image and close the editing application. The image will be updated in the comment tool.

Note: If you share a comment, the receiving application must support BCF 2.0 in order to view more than the first snapshot.

When you are happy with your comment text and information, click ‘Save’ to save the comment.

4.3.   Reply to a comment

After you have saved the comment, you can add a reply to it. Click inside the comment box that appears after your last comment and start writing your reply, and click ‘Save’. The comment will be added as a reply to the current thread.

Tip: You can add new snapshots or update the status in each new reply.

Note: If you share comments, the receiving application must support BCF 2.0 in order to view more than the first snapshot of the whole topic. You can create a new comment if you need to share additional snapshots with BCF 1.0 applications.

4.4.   Viewing comments

When you select a comment in the list it shows up in the comment pane with replies and snapshots. You can switch to the views that were stored with the comment by clicking the snapshot thumbnails.

Tip: When you select a comment (or several) in the list, any linked parts will get selected in the model. After selecting a comment, right-click the model viewview that is represented in the modeling mode

Model view is available also in the drawing mode and it is represented in its own window.

in Tekla Structures and click ‘Show Only Selected’ to quickly isolate the linked parts.

4.5.   Identifying parts with comments

All (native) parts with associated comments are indicated with a label in the model. If you select one or several parts that belong to a comment, the associated comments are highlighted in the comment list.

4.6.   Filtering comments

To search for a comment, enter a string in the filter text box in the toolbar and the comments will be filtered as you type.

When you do this your comment list will only show comments that contain any portion of the string of text. The tool will search in comment titles and bodies as well as in the status and assigned fields.

To remove the filter, empty the filter text box.

4.7.   Settings

Under ‘Settings’ there are options for always keeping the dialog box on top of other windows, zoom in on associated objects when you open a comment (as opposed to restore the saved camera view), changing the orientation of how the comment tool dialog box is displayed and for instant refresh of the comment list when there are new comments detected in the shared folder.

 

5.         Sharing comments

All comments are first stored privately in the model folder (in a folder called ‘PrivateComments’). You can then decide which comments you wish to share with others. The bcfzip format (version 2.0) is used for sharing, which means you can share notes with Tekla BIMsight as easily as with other comment tool users.

Note: If you share a comment, the receiving application must support BCF 2.0 in order to view more than the first snapshot.

To share a comment with someone else you have two options.

5.1.   Sharing using the Share Folder

You can share comments to any folder in your system or in your network. If other Comment Tool users have access to the folder you select they can then set up their tool to use the same folder, and everyone will automatically receive your comments when you share them. A very convenient way to share comments is to use a file sharing or synchronizing service, such as Dropbox. Just point your comment tool to a folder that is set up to automatically synchronize across computers and companies (see the specific sharing service documentation on how to share/synchronize a folder with others).

To specify the share folder, drop down the share menu and click ‘Set Share Folder’. You can then see the current share folder at the bottom of the sharing menu. The ‘Open Share Folder’ button will show the folder content in Windows Explorer.

 

If you select a Tekla BIMsight project folderfolder that is used for storing Tekla Structures-related files customized for a particular project

, you can activate live communication with Tekla BIMsight. See section 5.5 for details.

Now select one or several comments that you want to share and click ‘Share Selected’. T he selected comments will be packed and copied to the shared folder.

Sharing multiple comments at once will create a single bcfzip file. This file is easy to import to Tekla BIMsight or attach to e-mails. Sharing a comment multiple times will create multiple versions of the bcfzip file, each with a unique timestamp.

Note : The shared folder will be cleaned up every time you launch the comment tool. See details further down this document.

When you are writing a new comment or making a reply to a comment, you have the option to click ‘Save and Share’ under the comment box. This saves the comment or reply and then immediately shares the comment or the reply (along with the whole comment thread) to the share folder.

5.2.   Sharing via e-mail

To share via e-mail, first select the comments you want to share and then go to the sharing menu and click ‘Copy Selected to Clipboard’. Now create a new e-mail in Outlook and just right click and select ‘Paste’ in the message body. This will add the comments in an attachment to the e-mail.

Tip: The copied comments are placed as files on Windows clipboard, so you should be able to paste comments into any e-mail client or application that supports pasting files from clipboard. If this doesn’t work for your client, just share the comments to the share folder (‘Share Selected’) and attach the bcfzip file from there.

5.3.   Getting comments from others

New comments are read in to the comment tool directly from the share folder. If there are several comment tool users collaborating they should all share comments to the same network folder, or alternatively use a folder that is automatically synchronized with others, such as a Dropbox folder. Then every time somebody shares a comment it will immediately be available to all the other users.

When you click the ‘Refresh’ icon, the comment tool will read in all the comments and updates it finds in the shared folder. New comments will show up in green, and existing comments that have updates or new replies will show up in blue. 

If somebody uses another application for commenting (such as Tekla BIMsight, however see section 5.5 for a more efficient way in this case), they can export the comments from that application to this same shared folder. Comments will then be read in to your comment tool by refreshing.

If you receive comments via e-mail you can just drag and drop them onto the comment list in the comment tool to open them. You can also copy the received comments to the shared folder and click the ‘Refresh’ icon like previously described.

Tip: If you enable ‘Live Refresh’ on the settings menu, the comment tool will automatically read in new and updated comments as soon as they are added to the shared folder.

5.4.   Details on how bcfzip sharing works

Sometimes several users might reply to the same comment independently, and you can receive these files from different sources and at different times, often not even in the same order that they were created in.

When refreshing from the shared folder, the comment tool will compare the content of all comment files it finds. If there are several files containing different replies to the same original comment, they will be merged and shown as a single comment with replies sorted by their timestamp.

On each launch of the comment tool, the comments will be compared and merged as described earlier. In addition, the comment tool creates a single bcfzip file per comment. The original files are then deleted, but the share folder still contains the same information. This is to avoid having comment files piling up in the folder.

All notes are always stored also locally (in the model folder, under ‘PrivateComments’). If comments are deleted from the shared folder they still remain as a local copy in your comment tool. If you then write a reply to a deleted comment and share it, the whole thread is again available in the share folder.

5.5. Live sharing with Tekla BIMsight

If you set the shared folder to a shared Tekla BIMsight project folder, the ‘Share as Tekla BIMsight notes’ menu item is selected. This means that you have joined the shared Tekla BIMsight project and any comments you share will immediately show up in Tekla BIMsight. If you have ‘Live Update’ enabled you receive any comments made in Tekla BIMsight immediately.

Note: In Tekla BIMsight, it is possible to save several views with a note similar to how you can add multiple snapshots to a comment in Comment Tool. However, Tekla BIMsight cannot import more than one snapshot from a bcfzip file. By using the ‘Share as Tekla BIMsight notes’ option all the snapshots will be visible in both applications.

5.6. Offsetting comments

If you export models and collaborate in coordinates that are different from model coordinates in Tekla Structures, you might find that viewpoints in BCF comments are shown in the wrong location. The offset featurepart of Tekla Structures functionality that is maintained and owned by Trimble Solutions and that is included in the Tekla Structures installation

can help you deal with this problem by modifying comments to match the project coordinates.

To offset a comment means that all viewpoints and clip planes of that comment will be translated and rotated. The offset settings and commands are available under ‘Settings’ > ‘Offset from project base point’.

First, click ‘Set Offset…’ to set up offset coordinates and angle to match the project base pointpoint in a model that is used to define a point and north direction (y axis) in another coordinate system

A project can have several base points but only one of them can be the project base point that sets the model origin.

Base points allow the use of another coordinate system needed for interoperability and collaboration. Base points can also be used in drawings, and in reports and templates.

. Then, if you use the ‘Apply offset automatically’ option, any new comments and replies that are made will automatically be offset to project coordinates and thus they show up correctly in the collaboration tool.

Additionally, with the ‘Apply offset automatically’ option enabled, comments viewed with Comment Tool are assumed to be in project coordinates and are temporarily offset to current model coordinates for correct viewing.

If you do not want to apply the offset automatically you can manually move comments between the different coordinate systems with the ‘Offset selected comments’ and ‘Revert offset for selected comments’ commands. These commands are also useful if you want to offset old comments.

 

6.         Create comments in multi-user mode

You can use the share folder to share comments in multi-user modemode in which several users can work on the same model using their own working models

. The share folder can be set to a folder in the master modelmulti-user model from and to which information is fetched and saved in multi-user mode, and into which Tekla Structures merges changes that individual users make in the working models

It is not possible to work on the master model.

folder on the server, which means that everyone working on the model will have instant access to any shared comments.

You can change the shared comment folder location by clicking the ‘Set Share Folder’ button in the Share menu. You can also browse for the comments folder using Windows Explorer by clicking the ‘Open Share Folder’ button.

Note: Before sharing, the comments are stored privately for everyone in the local model folder, in a folder called ‘PrivateComments’ . This folder should not be synchronized when using model sharing. You can set it to be excluded in the Tekla Structures menu, under File > Model Sharing > Settings... > Settings.

The share folder makes it possible for users in multi-user mode to see, add and edit comments within the same project at the same time. Comments being added in a multi-user model do not require all the members in the model to save the model before seeing the comments because the comments themselves are not stored in the model databasedatabase file that contains a model

Model database file has the extension .db1. In addition, other files, such as the corresponding numbering database .db2, are needed in order to obtain the functionality of the model database.

, they are external files only linked with the model. This is useful especially if you have two copies of the same model loaded up on two different computers, for example, in different offices across the country or world, and yet you can set your comments directory to a shared network folder that both offices can access. Comment files are very small compared to the model, and this means that you can share comments live across long distances through a server folder without having to exchange the models themselves

Try using the comment tool in a multi-user model with a colleague. If you click ‘Live Refresh’ on the Settings menu, you will notice that when you both have the comment tool open and you start to add and share comments, the comments appear automatically on the other person’s screen. New comments will show up in green, and existing comments that have updates or new replies are bolded.

Next try the following where one person closes the comment tool session, and then the other person continues to add and reply to comments. After a few additions and changes, reopen the comment tool. Notice that when you reopen the comment tool some comments will appear at the top in green and some blue. The comment tool remembers the comments from your previous session compared to what has changed and notifies you of the differences. Comments appear in the list from most recent to least recent.

In large projects where you have to split the project into multiple models you may need to coordinate changes or issues related to the match line areas between the two models. You can use the comment tool in two different Tekla Structures models and take pictures and store camera locations from Model A and make them visible to the user in model B. The key to this is that the Match line steel ending in Model A is in exactly the same physical location as where the Match line steel in Model B begins.

 

7.         Sharing comments between Tekla BIMsight and Tekla Structures via bcfzip format

If you have installed the Tekla BIMsight ( http://www.teklabimsight.com ), you can easily share comments between Tekla Structures and Tekla BIMsight.

To test this, first publish the model to Tekla BIMsight (Tekla Structures menu: File > Publish to Tekla BIMsight). Open the model in Tekla BIMsight.

Next, select some notes in the comment tool and click ‘Share Selected’. Then go to Tekla BIMsight and click Notes > Sharing > Import Notes.

Navigate to the share folder and select the note(s) you just shared from Comment Tool (look at the time of creation if you are unsure about which ones). This will add the comments to the notes list.

Double-click a note to open it and you will see that the comment, replies, snapshot (only the first one) and linked objects are all there. Click the snapshot to go to the place in the model that you originally created the note in.

 

The same comment opened in Comment Tool and Tekla BIMsight
 

Now you can add a reply to the comment in Tekla BIMsight and create a new notes. Then select all notes in the notes list and click Sharing > Save to File. Save the file to the comment tool shared folder.

Then go to Comment Tool and click ‘Refresh’. New comments will show up in the comments list and new replies will be loaded to the existing comments. When you click on each of the new comments it zooms you into the same location as you specified when creating the comments in Tekla BIMsight, as long as your model in Tekla Structures is in the same view mode (perspectivedisplaying objects in a model view from a particular standpoint so that distant objects appear smaller than close ones, as do text and points

The user can zoom, rotate, pan, or fly through the model objects.

/orthogonaldisplaying objects in right-angles projection

In model view the size of the objects is the same despite of their distance to the viewing point and the zoom remains on part faces.

) as Tekla BIMsight.

Tip: You can just as well share the comments via e-mail, from Tekla BIMsight by choosing ‘Send as E-mail’ or from Comment Tool as described in the Sharing section. When you receive comments in an e-mail you can drag and drop the attached files directly to the comments list in either Tekla BIMsight or Comment Tool to view the comments.

 

8.         Create comments in two Tekla Structures models, one native, one IFC reference

The next step in your testing is demonstrating how you can create comments on IFC model objects after the IFC model has been subdivided. In this suggested test workflow export an IFC file of the current model you were using before (File>Export>IFC). Then create a new Tekla Structures model and insert that IFC file as a reference model into the new empty Tekla Structures model (File>Insert Reference Model). Ensure that when inserting the reference model you insert the model in the same orientation and at the same origin as your native Tekla Structures model. After inserting the IFC model, select the model in Tekla Structures and then click the ‘Subdivide’ button which appears on the ‘Insert Reference Model’ dialog box. This is needed for the comment tool to be able to read the IFC GUID from the model objects.

Next re-open the comment tool and change the shared comment folder location in this new model to be the same comments folder that is in your previous Tekla Structures native model. When you do this you will see the comments from your other model appear here. Make sure your 3D Model view properties are set to the same mode (Perspective/Orthogonal) that was used when adding the comments . Click on the comments in the list, and notice you are zoomed into the same locations as defined in your original model, and that the IFC model objects are highlighted that represent the same native objects you linked to comments in your previous model.

   

If you are an Engineer and have some IFC files from an Architect, or if you are a General Contractor and have some mechanical or other IFC files, insert those into the model and subdivide as well. You can link those objects to comments in  Comment Tool too. Make sure you have ‘Select Objects in Components’ chosen on your selection toolbar before selecting IFC reference objects to link with your comments.

One suggested workflow is that even detailers who are working with a project team of designers using a different set of BIM applications that can produce IFC models can use those models in Tekla Structures for coordination with their Structural Detailing model. Fox example, a steel detailer can insert MEP, Architectural, and Structural Engineering IFC models into a copy of his structural detailing model or a new empty Tekla Structures model where he also inserts a copy of his Structural modelmodel that represents a structure to be constructed

published in IFC model format. Now all of the models are saved into one single Tekla Structures model, and the detailer can send this to a General Contractor, or Design Team that can even be at a minimum using a Viewer license to navigate the joined models, inquire on properties, measure in the model, and most importantly can add or review comments in the joined model. Those comments can easily be sent back and forth between the Design and Detailing team making it easy to communicate in a protected IFC reference model environment for little implementation curve, cost, and risk. The Tekla Structures platform is designed to handle a large amount of detail and models compared to some other BIM software, so for review and communication purposes Tekla Structures can be used by other parties to review the project more efficiently and effectively.

Even if you are not in the same company with a shared server folder, you still want to try and setup a live commenting session. This can be done with a file sharing and synchronizing service such as Dropbox ( www.dropbox.com ). Tekla does not endorse or hold any liability for use of Dropbox, but in testing with the Comment Tool, it has been easy, free and quick to setup a live multi company commenting system using the basic file folder synchronizing functionality Dropbox provides. So a workflow picture might look like below.

 

9.         Summary of example workflows

Here are 5 examples of where the comment tool can be used:

1.            In a live multi-user model environment for exchanging checking comments, daily work assignments or questions even before saving the model.

2.            Keeping track of RFI’s, Change Orders, or problem areas. Essentially, your own post-it notes for your work in the model.

3.            Comments made in Tekla BIMsight can be extracted by the comment tool if they are exported to the shared folder, or alternatively exported and then dragged to the comment list. This means engineers, architects, contractors, erectors, project managers, fabricators that may not have Tekla Structures on their computres can make comments on the model with Tekla BIMsight and then the Tekla Structures user can be easily zoomed in those same comment areas directly within Tekla Structures.

4.            A Tekla Structures detailer could publish an IFC model of his connected project. A Tekla Structures Engineer or Fabricator could open a new Tekla Structures model with that IFC model referenced and subdivided into it. The Engineer or Fabricator can’t modify the detailer’s geometry, doesn’t need to worry about profile catalogs, numberingprocess of assigning position numbers to parts, cast units, assemblies, or reinforcement

In Tekla Structures, the position numbers assigned in the numbering are shown in marks and templates, for example.

settings, etc. They just start adding comments into the model and linking them with IFC reference model objects generated by the detailer. The comment files are sent back to the detailer. He loads those comments into his local native Tekla Structures detailing project and the comments generated and linked to the IFC reference model objects are now visible and associated with the detailer’s native Tekla Structures objects. This is possible because the comments remember via the IFC guid the link between the IFC and Tekla native objects they were generated from. This offers a safer and easier form of published project collaboration.

5.            An erector is on the site and he takes a photo of a field condition or area. Using even a Viewer license of Tekla Structures and the comment tool, he can drag a photo image file he took of the field condition and link it to the same corresponding area and parts in the model. This can then be easily zipped and emailed back to the office for the project manager to review.

 

 

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our documentation.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet