Bridge Creator

Last updated March 12, 2020 by Bridge_Team HQ tekla-bridge-design-support-ug@trimble.com

Software version: 
Not version-specific
Environment: 
Not environment-specific

Bridge Creator


Purpose and description

Bridge Creator is a new extension for Tekla Structures 2018 and later versions. This tool reads the alignment in LandXML format that can be created by any road or rail design software or by selecting any Tekla construction lineconstruction object that represents a line between two points

. When defining the key section, points can be constrained to the road alignment for creating complex shapes, such as bridge decks with varying superelevation. By defining the skew angle, adding start and end chainage for the deck and defining key sections at certain chainages/stations, the bridge designer can create even the more complex double curved concrete decks. Bridge Creator is available in Tekla Warehouseservice for collaboration and for storing and sharing Tekla Structures content

In Tekla Warehouse the content items are stored in collections. Tekla Warehouse includes the Tekla Warehouse Service and the Tekla Warehouse web site.

Tekla Warehouse is one of the Tekla Online services.

.

System requirements

Tekla Structures version: 2018 or later
Environments: All

Installing Bridge Creator

First time installation

  1. Download the Bridge Creator file package from Tekla Warehouse. The file package contains the installer file (.tsep) and an example model, including LandXML demo files.
  2. Extract the file package.
  3. Save the example model for later use.
  4. Double-click the installation .tsep file and select which Tekla Structures versions are to be installed.
More information on how to import Tekla Structures extensions to the Tekla Structures extensions manager here

Installing an new version of Bridge Creator

Before installing a new version of Bridge Creator, you need to uninstall the current version by selecting "Applications & Components" / "Manage Extensions" / "Extensions Manager", search for the extension and click Remove. The extension will be removed when Tekla Structures restarts. More information here

         
 

Before you start

Understanding LandXML files

For a general overview click here

A LandXML file is a non-proprietary file format, which contains civil and survey information. 
LandXML files can be exported in .xml format from applications like Trimble Novapoint, Tekla Civil, Trimble Quadri, Bentley InRoads, Autodesk Civil, and Trimble Business Center.
LandXML files can be imported to Tekla Structures as reference models. The supported contents of LandXML files are terrain models, line alignments of roads and railways, and rain water systems. The LandXML format extends the capabilities of Tekla Structures by showing merged models, including the infra models. Tekla Structures supports the LandXML 1.2 schema and single-precision floating-point format.

The Bridge Creator extension reads alignments (reference lineline between two reference points

For example, if the user picks two points to position a beam, these points form the reference line, and handles appear at the line ends.

Reference lines can be used in snapping in a snap switch.

and road surface edge lines) from the LandXML file. Supports IrregularLine, Line and Curve elements for the horizontal projection of the imported lines and ProfAlign and CircCurve elements for the vertical projection.
When exporting, the LandXML file can contain information that is not necessary for Bridge Creator.
This extension only reads the information found in the <CoordGeom> and <Profile> elements.

If necessary, edit your LandXML file to match the following structure:

<?xml version="1.0"?>
<Units>XXX</Units>
<Project name="XXX"></Project>
<Applicationpart of Tekla Structures functionality that is developed in order to extend the capability of Tekla Structures but that is not included in the Tekla Structures installation

name="XXX"></Application>
<Alignments name="Main Name">
   <Alignment name="Line_1" staStart="0.000000" length="92.063034">
      <CoordGeom> Alignment Information here </CoordGeom>
      <Profile staStart="0.013621">
         <ProfAlign name="Line_1"> Profile Information here</ProfAlign>
      </Profile>
   </Alignment>
   <Alignment name="Line_2" staStart="0.000000" length="192.063034">
      <CoordGeom> Alignment Information here </CoordGeom>
      <Profile staStart="0.000">
      <ProfAlign name="Line_2"> Profile Information here</ProfAlign>
      </Profile>
   </Alignment>
</Alignments>
</LandXML>

 

Exporting Alignments as LandXML from Tekla Civil

  1. Create LandXML file containing alignments using Inframodel export (Inframodel is Finnish extension for LandXML)
  2. Select alignments in map view

 

  1. Select File -> Export file -> Export to Inframodel file…
  2. Selected alignments will show up in Inframodel export window

 

  1. Give name for the file to be exported and hit OK

 

Exporting Alignments as LandXML from Trimble Novapoint

  1. Choose Export to File from the Output tab.

 

  1. Choose the template: StakeOutLines_RoadSurface.

 

  1. Select the alignment and the connected road model to export.

 

  1. Select the features LinearElement and StakeOutStringTopLevel.

 

  1. On the Location tab in the Dynamic Query dialog: Double click on the Alignment object to open the chainage value control and click on the Pencil tool-button to edit the from- and to chainage values specifying the interval you want to export.

 

  1. Select the check box for Stakeout, select the LandXML format and click on the Settings button.

 

  1. In the Settings dialog, choose the LandXML 1.2 format.

 

  1. Open the conversion rule editor and select the conversion rule: Irregular lines.

 

  1. Click on the Finish button and select a directory and file name for the LandXML-file you are about to export.

 

Exporting Alignments as LandXML from Autodesk Civil 3D Corridor

  1. Open a Corridor file.

 
  1. Go to Alignments / Create Alignment from Corridor

 

  1. Select first line. A dialog box opens. Avoid long names. Featurepart of Tekla Structures functionality that is maintained and owned by Trimble Solutions and that is included in the Tekla Structures installation

    Line X will be enough to identify the line. Remember in this method the lines order is the selecting order. Try to keep consistency. For example pick lines from left to right. Click OK.

 

  1. A second dialog box may appear. Click OK.

 

  1. The alignment data appears immediatly. Proceed picking the other lines and repeating the previous points. The command stays active, there is no need in calling command create alignment from a corridor for every line.

 

  1. This is the result after creating alignments for all the required lines.

 

  1. Go to Model Viewview that is represented in the modeling mode

    Model view is available also in the drawing mode and it is represented in its own window.

    . Select Alignments, right click and click Export LandXML.

 

  1. A dialog box appears. Make sure that only the information needed is exported. In this case Alignments and Profiles. Do not export Superelevation, unclick Superelevation Views. All existing Alignments will be exported with the newly created Offset Alignments. Click OK and save the file.

 

Accessing Bridge Creator extension

  1. Install Tekla Structures to use the Bridge Designer role. The role is available for all English language-based environments. The Bridges ribbon tab that contains the Bridge Creator extension will be available in Tekla Structures.

  2. If you have downloaded the extension from Tekla Warehouse, the extension will be available in the Applications & components cataloguser interface for displaying or modifying information in categorized lists

    For example, profile catalog and shape catalog are catalogs.

    . Use the search box to find Bridge Creator.

  3. Use the Quick Launchtool that is used for quickly finding commands, dialog boxes, and other functions in Tekla Structures

    For example, local content in Tekla Warehouse can be found using quick launch.

    box in the top-right corner of the Tekla Structures screen to find the extension.

  4. Go to File menu > Settings > Customize > Ribbon and create a button for Bridge Creator.

Project base point and units

  1. Create a project base pointbase point that sets the point of origin for a project if the model has several base points

    A project can have only one project base point.

    before you start. More information here
  1. Bridge Creator is imperial and metric systems ready. Check the model units in File menu > Settings > Options > Units and decimals:


Metric unit system

 


Imperial unit system

 

Using Bridge Creator

 

  1. Insert the LandXML file as a reference. Remember to select the base pointpoint in a model that is used to define a starting point in surveying and that is used as an anchor point in coordinate and height transformations

    A Tekla Structures project can have several base points but only one of them can be the project base point.

    Base points allow the use of another coordinate system needed for interoperability and collaboration. Base points can also be used in drawings, and in reports and templates. Model origin is the default base point in Tekla Structures.

    Base points are also called control points.

    in Location by. It is a good practice to save the LandXML files under the <model>\ReferenceModels folder.

 

  1. Open Bridge Creator.

The main interface of this extension consists of six parts:

Header: Preset load, Save and Help buttons. XML files containing Bridge Creator presets are saved under the <model>\Attributes folder.
Alignment: road alignment input that is a LandXML file or by selecting any Tekla construction line (opens a new dialog box).
Key sections: key sections definition, add and edit (opens a new dialog box), copy, save and delete.
Section Preview: preview of a section at a specific chainage/station.
Creation: Object name, start and end chainage/station, interval for triangulation, polygon count and creation of construction lines.
Footer: OK, Create and Cancel buttons. Use the OK button to create the object and close the interface. The Create button creates the object and keeps the dialog box open for further editing. The Cancel button cancels all actions and closes the application.


 

  1. In the Read Alignments dialog box:

Browse to the LandXML file that contains the road alignment.

The table shows all available lines, but only Active lines will be made available for creation of key sections. Only one Reference line can be selected. You can preview lines by selecting the Preview box. Remember to select the base point in Location by.

Note that Bridge Creator is reading the LandXML file directly not the reference modelmodel which the designer can use as an aid when building another model

A reference model is created in Tekla Structures or in other software and can be inserted to Tekla Structures. The reference model appears together with the model but it is not modified by Tekla Structures. The user can snap to reference model points.

For example, an architectural model, a plant design model, or a heating, ventilating, and air-conditioning (HVAC) model can be a reference model.

shown in Tekla Structures. It is a good practice to keep the LandXML files saved under the Model\ReferenceModels folder. This will help with change management if objects need to be updated due to road line changes.

Other lines can be made active for later use during cross sectiongeometrical form of a part sectioned perpendicular to its axis

definition. It is a good practice to only make Active the lines that will be necessary for defining the cross section. The Reference line and all active lines will be made available during the creation of the cross section.
Offset, Scale and Rotation can be used in cases when project base point is not defined.
 

  1. Save the settings.

Make the needed changes, name the settings and save them for later use. Access the Help menu for support page.
It is good practice for the settings file to have the same name as the object that will be created. For example the object that will be created with settings file "deck" will be named "deck" as well. 
Write the name of the settings file and click Save.
 

  1. Click the add button in the Key sections area to open the Manage Cross-Section Library dialog box. 

There is one empty section and two presaved cross sections as default, the image above shows the Sample (1 ref) template.
You can add, copy or load a profile from Tekla Structures profile catalogcatalog that displays profiles and information on the profiles

In addition to the available profiles in the respective Tekla Structures environment, the user can add fixed or parametric user-defined profiles to the profile catalog. It is also possible to import profiles to the profile catalog.

. The delete and preview window are in the main area of the dialog box.
 

The image above shows the Langset (4 refs) template.
You can edit the cross section in this area by clicking the edit button at the side of the preview window. However, it is good practice to edit the section in the Key sections area of the main dialog box of the extension instead.
At the footer, click OK to accept the selection, or Cancel to exit without saving.

* Showing section from Tekla Profile Catalog:

Select a profile from the Tekla Structures profile catalog and click OK.
Note that all points will be constrained to the same origin point. Use this method only if the section is static and dimensions do not need to be changed. Otherwise it is better to create the section in Bridge Creator and start building a Bridge Creator Library.

* Saving a bridge Creator Library:

The profile will be available in the Bridge Creator Section Library.
 

Enter a name for the settings file and click Save, then click OK. In this example, "DEMO-SECTIONS" library was created and contains three cross sections including the section imported from Tekla catalog.

 

  1. Editing the key sections:

There above image shows a key section added to the key sections table. The table for the key section has Chainage/Station for the specific key section, Name of the section, Orientation of the section, Skew, or Cut.
Add the start chainage/station for the section. Usually, this is the start chainage of the deck or object.
Select between Vertical or Perpendicular orientation. To define if the object is going to be cut vertically to the world plane or perpendicularly to the road alignment in elevation.
Define the skew of the object. The value is in degrees.
Select the Cut box if the section is a cut section. In this example, the section is a key section, not a cut section.
 

Here the deck will be cut perpendicularly to the road profile.
 

After adding the chainage/station value, the section can be previewed both in the Section Preview window and in the model.
Type the chainage/station value in the Chainage/Station box and the Step increment for the preview in the model. Use the spinner to navigate through the chainages/stations while previewing the section both in the model and in the section preview window. Select Keep preview to keep the temporary sections (cyan) in the model. Select and snap to these lines is not possible.
 

Here the Keep preview box has been selected.
 

In the Creation area, enter a unique name in Shape name. This will be the name of the object, it is good practice to give logical names to the objects. Remember to match the settings name with the object name and names need to be unique.
Define the Chainage/Station for the start and end of the deck, and the interval used for the triangulation. The minimum is 0.20m or 7''. This is a value considered during the creation of the object. For objects in curve use 0.20m or 7'' value. In case the bridge is at a straight path, use value 1.00m or 3ft to increase the speed of object creation by reducing the number of polygons.
When you select the Construction lines box, construction lines will be created along the deck for future use. The interval of these support lines is taken from the Step value. If the Step value is set to 1.00m, the construction lines will be created every meter along the deck. These lines can be selected and snapped to, and usually used as support. Keep this box unselected during creation to avoid accumulation of construction lines. Use this feature when needed at the end of the creation process.

 

  1. Editing Cross Section. Select the key section to be edited at the key section table and click edit on the right-hand side of the table. The Edit Cross-Section dialog box will open.

The Edit Cross-Section area consists of the Cross Section table on the top left side. The section preview underneath and New/Edit point area on the right side.
There are four different point types, these are explained below.
 

Alignment Proxy points are the road alignment points that were made available at Point 3. 
Select Alignment Proxy from the Category list. Then in the Alignment line name list, select the line to be made available at the Cross-Section table. The line name can be kept the same or wildcards can be used for better reading of the points. For example: line "20100_L" is the centre line of the road, therefore CL can be used as a wildcard. Click the add button on the right side of the Cross-Section table. The alignment point will be made available at the table. This type of points are not geometry points.   
 

Outer Face points are geometry points. They can be added by selecting the add button on the right side of the Cross-Section table and are constrained to other points. More about this type of points below. A group of outer face points creates a section. There can be only one group of outer face points per section. The number of outer face points needs to be the same when having more than one key section to define an object. For example, if the start key section of the deck is defined with 10 points, any other key sections (mid and end span) need to be defined with 10 points. If the number of outer face points is not the same an alert message is shown after clicking the Create button. 
 

Virtual points are support points that can be used to constrain any other point type to define the key section. These are not geometry points and will not appear in the model or in drawings.
 

Inner Face points are used to create openings or voids inside the cross section. There can be more than one group of inner face points, grouped by Internal Face. For example: Name the internal face "Face-A" and add 3 or more inner points to that Face, then create another internal face named "Face-B" and add 3 or more inner points to that new internal face. 
 

 

Outer Face and Inner Face points can have a Radius value. Define an Outer Face point, and add constrains as explained below. This point location will be fixed. Change from Point to Radius to add a radius to the point.
There are two types of radiuses: Arc Chamfer or...
 

...Tangent Arc Chamfer.
 

There are three ways to define the Offset Direction of points:
Parallel with local cross-section coordinate axis. See diagram.
 

Defined by point pairs. See diagram.
 

Defined by rotation angles. See diagram.
 

Each of the above offset direction types have five types of Point Type. These will permit the creation of any cross-section.
Type 1
 

Type 2+2
 

Type 3+3
 

Type 2+3
 

Type 4
 

The Cross-Section has information about the category of point, Id, Type, Du, Dv, R, X and Y values.
Select a point in the table to change any values or the order of the point in the table.
The preview box can help during the creation of the section.
Zoom by scrolling the mouse wheel, pan by pressing, hold and drag the middle mouse button, reset by pressing the right mouse button.
Note that the alignment point names are always visible in the preview box. Any other point will be identified in the preview area after selecting the point in the table.    
 

In this case, the point number 14 has been selected. It shows that is an Outer Face point, Parallel with local cross-section coordinate axis, point type Type 1, constrained to -2.1* Alignment Proxy point with zero changes in U/X plane and -100mm V/Y constrained.
This means that point 14 point is always 100mm below -2.1* Alignment Proxy point. 
 

In this example, Outer Face point 10 is still a Parallel with local cross-section coordinate axis but a Point type Type 4. It is constrained to Outer Point 10 and 9. Placed always in the middle (0.5=50%) distance for U/X plane and -100 for V/Y plane. 
 

Outer Face point 6 is a Parallel with local cross-section coordinate axis and Point type Type 2+2. V/Y constrained to Outer point 1 and U/X constrained to Outer Point 5. 
 

Point 9 is an Outer Face point Parallel with local cross-section coordinate axis where Radius was applied. Is still a Point type Type 4 constrained -800mm to Alignment Proxy point 2.1*, however by choosing radius 500mm and Tangent Arc Chamfer both lines (7+8 and 10+11) were extended and connected with a radius value of 500mm. 
 

This image shows radius applied into the kerb and underneath of the deck on the start of the cantilever.
 

Outer Face point 3 has been created to apply circular chamfer into that corner of the kerb. It is a Type 2+2 with V/Y constrain to point 4 and U/X constrain to point 2 and with a radius of 75mm for the Arc Chamfer value.

 

  1. Add Key sections as cuts

You can add as many key sections as necessary. The Chainage/Station value of the key section will have exactly the required cross-section values and between the key sections, Bridge Creator will interpolate the values.

 

  1. Add as many key sections as necessary

For a smooth longitudinal variation, add as many key sections as necessary. Create the first key section, then copy it and change the Chainage/Station value and edit the key section. Repeat the process as many times as necessary.

 

  1. Add cuts to objects along other than main reference line

Use the section Cut option by copying an existing section and selecting the Cut box when an object follows an alignment not parallel in the horizontal plane with the reference line (main line/centre line). The skew value is related with the main reference line while the wing wallplate that represents a structure such as a wall or roof panel

In Tekla Structures, a panel is created by picking two or more points.

In cast-in-place concrete the term wall refers to a concept similar to panel.

follows a line that moves away from that line. Therefore, a 90-degree skew will not cut the object the way expected. Find the 90-degree angle between the along the wingwall and take the angle from that line to the main reference line. Then apply the cut with the value. In this case, for a 90-degree cut of the wingwall in the back of the abutment, a 98-degree skew value was added to the cut key section on the table.

 

  1. The objects created with Bridge Creator are boundary representationthe way that the information included in a model is represented visually

    solids, known as B-rep or items for Tekla Structures

You can access the list of items in Tekla Structures in File menu > Catalogs > Shape catalogcatalog that displays information of item shapes

The shapes are downloaded from Tekla Warehouse, are created using existing geometry and parts in the model, or are modeled using software other than Tekla Structures, for example SketchUp.

. Use caution when deleting items that are not needed. If any object is deleted from this catalog, all the attached reinforcement and associated drawings will be lost. When updating an item using Bridge Creator as described above, the item retains the GUID number, meaning that reinforcement and drawings will still be associated with that item.

What is New for Bridge Creator Version 1.1

  • Added empty section in the default library.
  • Changed behavior of cuts such that empty sections may or may not define a cut.

Before, empty sections were automatically assumed to be cuts. Empty sections can now be added and edited as normal key sections. Empty sections will not be considered when creating the shape. Name of empty sections and cuts can be edited. An error is shown when clicking create while shape has inconsistent number of points.

  • Fixed an issue where the location of alignment proxies was not updated when editing sections through the Section Library.

The fix is to use the active alignments similarly to editing the sections from the Main Window.
It is now also possible to change the key section chainage from the Editor Window. This will update alignment proxies when changed and makes it easier to test the key section.

  • Added default interval of 0.2m or 3 ft.
  • Fixed an issue where start chainage, end chainage and interval did not have default value or units.
  • Fixed an issue where the section preview wasn’t 100% accurate.
  • Fixed an issue where the alignment failed to find plane at start and end of alignment.

Now it is possible to create sections at zero and last chainage.

  • Fixed the rest of the issue where the font, lines and circles are too large when zoomed in.

Change for section editor, as for the preview. Sizes has been modified for usability.

  • Added section point ID in section preview for all points.

The IDs are now always visible.

  • The selected point is shown in red. Linked points are shown in green. Alignment proxies do not show duplicate names anymore.
  • It is now also possible to select section point by clicking the point or the text in the preview.
  • Fixed an issue where the inactive selected row was shown too faint.

Uses same color as Document Managertool that is used for listing and managing drawings and other types of documents

With the document manager the user can, for example, reorganize, update, freeze, lock, and delete drawings.

The user can also organize file documents, such as PDF, NC, and DWG files, and drawings, in document categories, and search documents and open drawings.

Document manager is replacing drawing list from the version 2018i onwards.

.

  • Fixed an issue where section points became slow when having “deep” dependencies.

Improved section calculation by only calculating location of section points when they change. Last text used 60 chained points and performance wasn’t affected.

  • Implemented live polygon count.

Based on key sections, chainages and interval.

  • Increased the zoom range of the section preview.

The section preview for editing has been updated to auto-resize like other preview windows.
When panning or zooming, auto-resize is disabled. Auto-resize is enabled when resetting by right clicking the preview.

  • Added Caltrans library.

The library xml file is available at warehouse. User needs to save it under model attributes folder.

  • Added section point ID in section preview for chamfered points.

The point ID is shown along the curve instead of at the chamfer point location (which may be far away).

  • Fixed an issue where the location in model was not considered when converting plane from base point and with rotation added to the Project base Point.
  • Added a warning when closing the editor if points are clashing.

Tolerance for clash is 1mm.

  • Added "Work planeplane that the user has chosen in a model and that is currently active for working on in a model view

    Newly created, copied, or moved model objects comply with the work plane. For example, shifting the work plane to follow a sloped plane makes it easier to model sloped structures.

    " text after Offset directions in editor.
  • Changed imperial units.

Stations/chainages are always shown as decimal feet with 3 decimals.
Editor is shown with the current units in Tekla.

  • Fixed an issue where list of section points to be referenced did not add new inner faces.
  • Added chamfer capability. Similar with Tekla chamfers and circles using 2 points.

Without and with Rounding Chamfer (300 mm)
Type of chamfers:
Added Y coordinate of the line chamfer, square chamfer, and square parallel chamfer.

  • It is now possible to define a circle using two points and two radius of type Arc Chamfer.
  • Added possibility for adding circle for a face with a single point when it is of type Rounding Chamfer.

This can be used for both outer face, and inner faces.

  • Implemented possibility to convert LandXML to native alignment objects and then read them.

Each active alignment in the LandXML is written to separate objects which are represented by an item. The item contains information about name, start chainage, end chainage, and geometry. The alignment object can then be read back into Bridge Creator and used like a regular alignment.

  • Convert and pick alignment
  • Convert imported alignments to “native” alignments
  • Select alignments by picking native alignments

Limitation: The picked alignments are not saved in preset files and must be picked each time.
Note: Alignments are moved to model originglobal coordinate system point of origin used for the model

Model origin is the default project base point.

using the current base point when converting.

Pick native alignments by selecting in the model view.

  • Implemented possibility to pick any Tekla Structures construction line (line, arc or polycurve) and use it a reference for extrusion.

Convert the construction line to a Bridge Creator Item and save it into a specific phase for future changes.

  • Implemented support for removing multiple key sections.

Also implemented support for selecting multiple points in section editor.
Note that section point properties cannot be edited while more than one point is selected.

  • Fixed an issue where LandXML failed to read if alignment element contained unknown attributes.

LandXML files with “desc” attribute on the alignment-tag should no longer be an issue. Now the user can export the entire road project as LandXML, including surfaces that Bridge Creator will only read the information for plan and profile.

Other fixes:

  • Only allows one instance of the program

  • Added help link

  • Application crash when inserting a radius as the only point in a face

  • Application crash when inserting second radius in group of four

  • Fixed an issue where the user had to remove the degree sign to enter a new angle
  • Fixed an issue where the application crashed when saving an attribute file without name

What is New for Bridge Creator Version 1.2

  • Faster creation of bridge items.

  • Items are now calculated and inserted more than 2x as fast as before.

  • Changed item insertion point. Changed insertion point from model origin to first chainage on the main alignment. The second point, indicates the horizontal direction but is not necessarily at the second chainage. Local insertion point improves graphics performance and part cutcut that is defined by a cutting part

    calculations.

  • Segmented alignment lines can now utilize specified chainage values. When calculating chainages using segments, the calculation can utilize specified chainages per segment to improve accuracy. This enables fully utilizing the information from Quadri Taskin the task manager, a representation of a piece of work that needs to be carried out in order to complete a project

    Connector.

  • Implemented reading txt, csv, xlsx files.

Other fixes:

  • Fixed an issue where the start and end chainage for creation were reseted.
  • Selecting a different reference alignment would reset the start and end chainage to the values from the reference alignment.
  • Now the values are changed only if they are unset.
  • Changed browse for alignment to start in model folderfolder that is used for storing files associated with a model

    Tekla Structures stores all files associated with a model in a folder it creates with the same name as the model database (.db1).

    In multi-user mode all users access the same model folder.

What is New for Bridge Creator Version 1.3

  • Changed “Read Alignments” dialog. Browse to import LandXML, TXT, CSV or XLS files with alignment or pick any Bridge Creator feature lines. Note “Convert” button moved to new “Manage Alignments” dialog.
  • New button “More” to access new “Manage Alignments” dialog.
  • New “Manage Alignments” dialog.
  • “Import” tab:
    • Import LandXML, TXT, CSV or XLS files with alignment or pick any Tekla construction line.
    • Convert any of the imported lines into Bridge Creator feature lines.
    • This dialog replaces the “Convert” button in the “Read Alignment” dialog.
    • Added possibility to change name of the alignment line before conversion.
  • Manage” tab:
    • Use the “Pick” button to select one or more Bridge Creator feature lines previously converted.
    • Get all Bridge Creator feature lines available in the model by selecting “Get all”.
    • Extracting and visualizing data with features available at “Tools” area.
    • Select “Draw chainage on alignment” button to get a visualization of the chainages along the selected alignment line. Chainages are found along whole alignment. Intervals are 1m, 5m and 10m or 5ft, 25ft and 50ft.
    • Select “Get chainage from point” by clicking the at any point or intersection of any object with the feature line to get a Layout Pointpoint that can be exported to a layout device

      Layout point can be a reference point.

      . The chainage value will be saved under attribute “Description” of the Layout Point. This and X,Y,Z values can be inquired in the model or tagged in the drawing. The value will be meters or feet depending on Tekla Structures unit settings.
    • Select “Get point from chainage” to place any Layout Point at a given chainage. The chainage value will be saved under attribute “Description” of the Layout Point. This and X,Y,Z values can be inquired in the model or tagged in the drawing. The value will be meters or feet depending on Tekla Structures unit settings.
    • The “Result” area will display information related with the Layout Points, possibility to zoom into the created object and chose from available types of Layout Points.
  • Added the length of each edge along the alignment as UDAobject property created by the user in order to widen the range of predefined object properties

    User-defined attributes are used when the predefined object properties are not sufficient but more properties are needed. For example, comment, locked, and erection status are user-defined attributes.

    • The UDAs can be used to get the actual length of the shape.
    • The UDA gets a name based on whether the point is inner or outer point.
    • The lengths are calculated based on the segments along the shape and always given in millimetres.
    • Lengths of the inner and outer section points shown as UDAs when inquire the object.

Other fixes:

  • Changed start and end reference points to span the entire shape. Changed the direction and length of the insertion points that intersects the last chainage to improve visualization at drawing level.
  • Changed start and end chainages to show only valid values. Some alignments are not defined consistently and not being read by Bridge Creator.
  • Fixed an issue where reading file failed if different number of attributes that was preventing the alignments from being read.
  • Implemented choice to insert new item when shape already existing in the shape catalog.
  • Fixed an issue where inner faces with different number of points were causing invalid geometries.
  • Changed default browse folder to model folder.

Image showing Layout Point UI information and visualization of alignment chainages/stations
 

Picture showing bridge Creator dialogs, model and inquire result with lengths along object edges.

Image showing curve in Rhinoceros, Grasshopper plugincomponent that is developed using Tekla Open API

Plugin is a .dll file and loaded inside Tekla Structures process.

Plugins can be started from the applications and components catalog.

code and Bridge Creator extrusion along the imported curve.

 

 

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
Average page rating: 4 (4 votes)
Refresh page after voting to show updated result.

Comments

by Redentor Soriano

Does the Bridge Creator incorporate vertical curve?

by Gabriel Neves

Redentor. This very first version of Bridge Creator has no vertical curve capability when triangulating between two key sections. However If the road is in a curve any constrained object will follow that curve. For the curve underneath the deck more key sections are needed to make a smooth triangulation. Another alternative is to create the curve in any road design software and export it along with the road lines to LandXML and use it with Bridge Creator.

by DVStratek

How to edit a point in cross section imported from Tekla Structures profile catalog so it could change to an alignment proxy point?

by Gabriel Neves

Stratek, alignment proxy points come from LandXML file. Those points have x,y,z information along the alignment path while the other type of points have information just related to the specific cross section, therefore other points such as Outer, Inner or Virtual cannot be transformed to alignment proxy points.

by Gabriel Neves

Hello all,
Just to clarify the how to achieve super-elevation when there is just the center line of the road and a known value.
If the LandXML file has the center line of the alignment and the left and right lines of the road the super-elevation is already taken into account.
For the cases where there is just one center line from the LandXML file or using Tekla construction line then Bridge Creator can apply super-elevation by defining a plane by rotation angle during the creation of the object. For that the value of the super-elevation needs to be converted from percentage to degrees using a formula or this calculator: https://www.calcunation.com/calculator/slope-percent-conversion.php
The formula for finding the angle in degrees from a percentage is:
Tan-1(Super-elevation Percentage divided by 100).
Example for 2.5% super-elevation: Tan-1(2.5/100) = 1.432096
Hope this helps.