Hallo!

Wist u dat ingelogde gebruikers veel meer inhoud kunnen zien?

Het lint aanpassen

Toegevoegd April 2, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Softwareversie: 
2019

Het lint aanpassen

Het lint aanpassen

U kunt het lint met Linteditor naar behoefte aanpassen. U kunt bijvoorbeeld de grootte en de vorm van een willekeurige knop wijzigen. U kunt door de gebruiker gedefinieerde commando's maken en voor een eenvoudige toegang uw favoriete componenten en extensies naar het lint brengen.

Als u de Linteditor wilt openen, klikt u in het menu Bestand > Instellingen > Aanpassen > Lint.

Met Linteditor kunt u:

  • nieuwe knoppen aan het lint toevoegen
  • bestaande knoppen op de lint verplaatsen
  • de grootte van de knoppen op de lint wijzigen
  • de pictogrammen en tekst van de knoppen wijzigen
  • knoppen verwijderen die u niet nodig hebt
  • nieuwe commando's maken en knoppen hiervoor toevoegen
  • scheidingsbalken aan het lint toevoegen
  • nieuwe tabbladen toevoegen
Opmerking:

Als u het modelleerlint wilt aanpassen, opent u de Linteditor in de Model Editor.

Als u het tekeninglint wilt aanpassen, opent u de Linteditor in de Tekening Editor.

U kunt alleen de linten aanpassen die in uw configuratie beschikbaar zijn.

De aangepaste linten worden opgeslagen in de map ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons. Als u de map niet kunt vinden, moet u ervoor zorgen dat u de verborgen bestanden en mappen op uw computer kunt bekijken.

Bedrijfsbeheerders kunnen de aangepaste linten of tabbladen naar de hele organisatie distribueren, op dezelfde manier als aangepaste opmaak van het eigenschappenvenster.

Een knop aan het lint toevoegen

U kunt knoppen eenvoudig toevoegen door een knoptype en het uiterlijk te selecteren en vervolgens het commando naar het lint of naar de Werkbalk Snelle toegang te slepen.

Taak Actie
Een knop voor één enkel commando toevoegen
  1. Selecteer Lintitem toevoegen in de lijst Eenvoudige knop.
  2. In de lijst Commando selecteert u het commando dat u aan het lint wilt toevoegen.

    U kunt ook componenten, macro's en extensies toevoegen. Blader door de lijst of gebruik het vak Zoeken om inhoud te filteren. Voer bijvoorbeeld net in om het commando Wapeningsnet maken en andere aan een net gerelateerde componenten te zoeken:

  3. In de lijst Uiterlijk doet u het volgende:
    • Selecteer of de knop een pictogram heeft. Selecteer de grootte van het pictogram, of u een schaalbaar pictogram wilt gebruiken, of blader naar de pictogramafbeelding.
    • Selecteer of de knop een tekst heeft.

  4. Voorbeeld geeft weer hoe de knop eruitziet. Wijzig indien nodig het uiterlijk van de knop.
  5. Sleep de knop naar het lint.

    De blauwe kleur geeft de plaats aan waar de knop wordt ingevoegd.

Een in-/uitschakelknop toevoegen die een bepaald commando in- of uitschakelt

Hiermee kunt u bijvoorbeeld een knop van het menu Bestand > Instellingen > Knoppen aan het lint toevoegen. U kunt ook enkelvoudige snapknoppen en selectieknoppen aan het lint toevoegen.

  1. Selecteer Lintitem toevoegen in de lijst Knop controleren.
  2. In de lijst Commando selecteert u een commando dat in- of uitgeschakeld kan worden.

    Commando's die kunnen worden in- of uitgeschakeld, hebben een selectievakje ernaast.

  3. In de lijst Uiterlijk doet u het volgende:
    • Selecteer of de knop een pictogram heeft. Selecteer de grootte van het pictogram, of u een schaalbaar pictogram wilt gebruiken, of blader naar de pictogramafbeelding.
    • Selecteer of de knop een tekst heeft.
  4. Voorbeeld geeft weer hoe de knop eruitziet. Wijzig indien nodig het uiterlijk van de knop.
  5. Sleep de knop naar het lint.

    De blauwe kleur geeft de plaats aan waar de knop wordt ingevoegd.

Een vervolgkeuzeknop toevoegen met een groep commando's eronder
  1. Selecteer Lintitem toevoegen in de lijst Vervolgkeuzeknop.
  2. In de lijst Uiterlijk doet u het volgende:
    • Selecteer of de knop een pictogram heeft. Blader naar de pictogramafbeelding.
    • Selecteer of de knop een tekst heeft.
  3. Voorbeeld geeft weer hoe de knop eruitziet. Wijzig indien nodig het uiterlijk van de knop.
  4. Sleep de knop naar het lint.

    De knop is nu een lege tijdelijke aanduiding voor enkelvoudige commando's. U moet commando's aan de vervolgkeuzeknop toevoegen om het te laten werken.

    1. Selecteer Lintitem toevoegen in de lijst Eenvoudige knop.
    2. In de lijst Commando selecteert u het commando dat u aan de vervolgkeuzelijst wilt toevoegen.
    3. In de lijst Uiterlijk stelt u het uiterlijk van de knop in.
    4. Sleep de knop naar de vervolgkeuzelijst.

      De blauwe kleur geeft de plaats aan waar de knop wordt ingevoegd. Als u de muisaanwijzer over een pijl omlaag beweegt, wordt een lijst geopend en kunt u commando's naar de lijst slepen. De lijst blijft open totdat u opnieuw op de pijl omlaag klikt.

    5. Voeg zoveel commando's als nodig toe aan de vervolgkeuzeknop.
Een knop toevoegen voor één enkel commando plus een vervolgkeuzeknop met een groep commando's eronder
  1. Selecteer Lintitem toevoegen in de lijst Splitsknop.
  2. In de lijst Commando selecteert u het commando dat u als de belangrijkste knop voor de hele splitsknop aan het lint wilt toevoegen.
  3. In de lijst Uiterlijk doet u het volgende:
    • Selecteer of de knop een pictogram heeft. Selecteer de grootte van het pictogram, of u een schaalbaar pictogram wilt gebruiken, of blader naar de pictogramafbeelding.
    • Selecteer of de knop een tekst heeft.
  4. Voorbeeld geeft weer hoe de knop eruitziet. Wijzig indien nodig het uiterlijk van de knop.
  5. Sleep de knop naar het lint.

    De knop heeft nu één enkel commando. U moet commando's aan de vervolgkeuzelijst toevoegen.

    1. Selecteer Lintitem toevoegen in de lijst Eenvoudige knop.
    2. In de lijst Commando selecteert u het commando dat u aan de vervolgkeuzelijst wilt toevoegen.
    3. In de lijst Uiterlijk stelt u het uiterlijk van de knop in.
    4. Sleep de knop naar de vervolgkeuzelijst.

      De blauwe kleur geeft de plaats aan waar de knop wordt ingevoegd. Als u de muisaanwijzer over een pijl omlaag beweegt, wordt een lijst geopend en kunt u commando's naar de lijst slepen. De lijst blijft open totdat u opnieuw op de pijl omlaag klikt.

    5. Voeg zoveel commando's als nodig toe aan de vervolgkeuzeknop.

U kunt ook commando's naar de Werkbalk Snelle toegang slepen die zich boven het lint bevindt of naar de vaste container aan de linkerzijde van het lint:

Een knop verplaatsen

U kunt knoppen op het lint opnieuw rangschikken. U kunt geen vervolgkeuzelijstknoppen onder elkaar verplaatsen.

  1. Selecteer het knop die u wilt verplaatsen.

    De knop wordt gemarkeerd.

  2. Sleep de knop naar een nieuwe locatie.

    De blauwe kleur geeft de plaats aan waar de knop wordt ingevoegd. Bijvoorbeeld:

De grootte van een knop wijzigen

U kunt de grootte van bestaande knoppen wijzigen.

  1. Selecteer de knop waarvan u de grootte wilt wijzigen.

  2. Beweeg de muisaanwijzer over een zijde of hoek van de knop om een wit pijlsymbool weer te geven:

  3. Sleep met de pijl om een nieuwe grootte te definiëren:

    De grootte van de knop wijzigt overeenkomstig. De andere knoppen worden indien nodig automatisch op het lint naar voren verplaatst.

  4. Dubbelklik op de knop om deze te verlengen.

    De knop bezet de lege ruimte eromheen nu volledig:

Het uiterlijk van een knop wijzigen

U kunt het uiterlijk van elke knop wijzigen.

  1. Selecteer de knop die u wilt wijzigen.
    • Als u een nieuwe knop toevoegt: selecteert u het commando in de lijst Commando.

      De huidige eigenschappen van de knop worden in de lijst Uiterlijk weergegeven.

    • Als de knop al op het lint bestaat: klikt u met de rechtermuisknop op de geselecteerde knop op het lint.

  2. Als u het pictogram wilt wijzigen, selecteert u een van de opties:
    1. Geen : er wordt geen pictogram voor de knop gebruikt
    2. Commando: Groot pictogram : het standaard grote pictogram (32x32) wordt gebruikt
    3. Commando: Klein pictogram : het standaard kleine pictogram (16x16) wordt gebruikt
    4. Commando: Schaalbaar pictogram : het schaalbare vectorpictogram wordt gebruikt
    5. Galerie (bitmap) : selecteer een groot of klein bitmappictogram uit de pictogramgalerie van Tekla Structures
    6. Galerie (schaalbaar) : selecteer een schaalbaar pictogram uit de pictogramgalerie van Tekla Structures
    7. Gebruiker : definieer een aangepast pictogram door een geschikt afbeeldingsbestand te selecteren. De aanbevolen grootte is 32x32 pixels voor grote knoppen en 16x16 pixels voor kleine knoppen. Als u problemen met uw aangepaste afbeelding zodat deze niet de juiste grootte verschijnt, controleert u de DPI-instelling van het afbeeldingsbestand. Een DPI van 96 wordt aanbevolen.
  3. Als u de naam wilt wijzigen, selecteert u een van de opties:
    • Geen : er wordt geen naam voor de knop gebruikt
    • Commando: Volledige tekst : de standaard volledige versie van de naam wordt gebruikt
    • Commando: Korte tekst : de standaard korte versie van de naam wordt gebruikt
    • Gebruiker : voer een aangepaste naam voor de knop in

Een gebruikerscommando met de Commando-editor maken

U kunt door de gebruiker gedefinieerde commando's maken en deze aan een bestand of URL koppelen. Maak de gebruikerscommando's met Commando-editor.

  1. Klik in het menu op Bestand > Instellingen > Aanpassen > Door gebruiker gedefinieerde commando's om de Commando-editor te openen.
  2. Klik op Nieuw.
  3. Voer een unieke ID voor het commando in en klik vervolgens op OK.

    Maakt bijvoorbeeld een koppeling naar het Tekla Discussion Forum. Voer OpenTeklaDiscussionForum als de ID van het commando in.

    Er verschijnt een nieuwe kolom met meer eigenschappen.

  4. Voer in de vakken Volledige naam en Korte naam een naam voor het commando in.

    Deze naam is zichtbaar in de gebruikersinterface van Tekla Structures. U kunt twee alternatieve namen definiëren: een volledige naam en een korte versie. Voer bijvoorbeeld Tekla Discussion Forum als volledige naam van het commando en Forum als korte versie in.

  5. In de instellingen Groot pictogram , Klein pictogram en Schaalbaar pictogram selecteert u een pictogram voor het commando.

    U kunt drie alternatieve pictogrammen definiëren: een groot en een klein of een schaalbaar vectorpictogram.

    U kunt uw eigen pictogram gebruiken of een geschikt pictogram uit de pictogramgalerie van Tekla Structures selecteren.

  6. Voer in het vak Knopinfo een tooltip voor het commando in.

    Voer bijvoorbeeld Ga naar het Tekla discussion forum in.

  7. Definieer in het vak Actie een bestand of een URL.

    Voer bijvoorbeeld in: https://forum.tekla.com.

  8. Selecteer in Beschikbaarheid de modus waarin het commando beschikbaar is.
  9. Klik op Opslaan om het nieuwe commando op te slaan.
  10. Ga naar Linteditor.
  11. Selecteer het knoptype.
  12. In de lijst Commando zoekt u naar het nieuwe commando dat u hebt gemaakt.
  13. In de lijst Uiterlijk wijzigt u indien nodig het uiterlijk van de knop.
  14. Sleep de nieuwe knop naar het lint.

  15. Als u een gebruikerscommando wilt wijzigen, klikt u met de rechtermuisknop op het commando op het lint en bewerkt u de commando-eigenschappen net als voor elk andere commando.

Een scheidingsbalk toevoegen

U kunt verticale en horizontale scheidingsbalken toevoegen om knoppen in kleinere groepen op het lint te verdelen.

  1. Selecteer Lintitem toevoegen in de lijst Scheidingsteken.
  2. In de lijst Uiterlijk selecteert u of een horizontale of verticale balk moet worden toegevoegd en de dikte van de balk.

    Voorbeeld geeft weer hoe de scheidingsbalk eruitziet.

  3. Sleep het voorbeelditem naar het lint.
  4. Als u de oriëntatie of de lijndikte van de balk wilt wijzigen, klikt u met de rechtermuisknop op de balk op het tabblad en selecteert u Oriëntatie of Dikte.
  5. Als u de balk wilt verwijderen, selecteert u de balk op het lint en drukt u op Delete op uw toetsenbord.

    U kunt ook met de rechtermuisknop op de balk op het lint klikken en Verwijderen selecteren.

Een knop verwijderen

  1. Selecteer de knop op het lint.
  2. Druk op uw toetsenbord op Delete.

    U kunt ook met de rechtermuisknop op de knop op het lint klikken en Verwijderen selecteren.

Tabbladen toevoegen, verbergen en bewerken

U kunt linttabbladen toevoegen, verplaatsen en de naam ervan wijzigen, kiezen hoe ze worden uitgelijnd en enkele tabbladen verbergen als u deze niet in uw huidige project nodig hebt. Als u bijvoorbeeld alleen stalen onderdelen modelleert, kunt u het tabblad Beton tijdelijk verbergen.

Taak Actie
Een nieuw tabblad toevoegen
  1. Selecteer Lintitem toevoegen in de lijst Tabblad.
  2. Voer in het vak Text een naam voor het tabblad in.
  3. Klik op Tabblad toevoegen om het aan het lint toe te voegen.
De volgorde van tabbladen op het lint wijzigen Versleep de tabbladtitels.
Selecteren hoe de tabbladen worden uitgelijnd Klik met de rechtermuisknop in het lintgebied en selecteer een van de opties Navigatiemodus :
  • Zichtbaar scrollen : de lintbeweging is minimaal wanneer u tussen tabbladen schakelt
  • Naar links uitlijnen : de pictogrammen beginnen vanaf de linkerzijde van het lint
  • Naar tabblad uitlijnen : de pictogrammen beginnen vanaf de linkerzijde van het huidige tabblad
De tabbladen verbergen die u in uw huidige project niet nodig hebt
  1. Laat de muisaanwijzer op een tabbladtitel rusten.

    Een klein oogsymbool verschijnt naast de tabbladtitel:

  2. Klik op het oogsymbool.

    Het oogsymbool wijzigt en de tabbladtitel wordt grijs:

Het tabblad Venster wordt nu verborgen in het lint. Als u het lint verschuift, verschijnen verborgen tabbladen als:

Als u het verborgen tabblad weer wilt weergeven, klikt u opnieuw op het oogsymbool.

De naam van een tabblad wijzigen Klik met de rechtermuisknop op het tabblad en selecteer Naam wijzigen. Voer een nieuwe naam voor het tabblad in.
Een tabblad verwijderen

Selecteer het tabblad en druk op Delete.

U kunt ook met de rechtermuisknop op het tabblad klikken en Verwijderen selecteren.

Het lint opslaan

Wanneer u tevreden bent over de wijzigingen, slaat u het aangepaste lint op.

  1. Klik in Linteditor op de knop Opslaan.
  2. Wanneer u naar Tekla Structures teruggaat en het programma u vraagt of u het nieuwe lint wilt laden, klikt u op Ja. Het lint wordt bijgewerkt met de wijzigingen die u hebt aangebracht.

De wijzigingen controleren

U kunt het oorspronkelijke lint vergelijken met de wijzigingen die u hebt gemaakt. U kunt controleren wat er is toegevoegd en verwijderd, en wat er naar andere tabbladen is verplaatst.

  1. Sla het aangepaste lint op als u dat al niet hebt gedaan.
  2. Klik op de knop Vergelijken.
  3. Controleer in het dialoogvenster Linten vergelijken de wijzigingen die u hebt aangebracht.

    Bijvoorbeeld:

    • Niet aanwezig : deze commando's zijn verwijderd
    • Verplaatst : deze commando's zijn verplaatst naar een nieuwe plaats
    • Gebruikerstoevoegingen : deze commando's zijn toegevoegd
    Note:

    Oorspronkelijk lint verwijst naar het lintbestand dat bij de installatie van Tekla Structures voor uw huidige configuratie is geleverd.

  4. Als u een commando hebt verwijderd dat u terug wilt hebben, sleept u het vanuit het dialoogvenster Linten vergelijken naar het lint.
  5. Wanneer u klaar bent, klikt u op Sluiten.

Een back-up van het lint maken en dit herstellen

U kunt het standaardlint van Tekla Structures op elk moment herstellen. Voordat u de standaardinstellingen gaat herstellen, moet u ervoor zorgen dat u een back-up van uw aangepaste lint hebt opgeslagen, omdat de aanpassingen permanent worden verwijderd. U kunt het back-upbestand gebruiken om uw aangepaste lint weer in gebruik te nemen, de lintinstellingen naar een andere computer te kopiëren of het aangepaste lint met uw collega’s te delen.

  1. U maakt als volgt een back-up van het aangepaste lint:
    1. Klik in Linteditor op de knop Opslaan.
    2. Ga naar de map ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons.
    3. Maak een kopie van het gewenste lintbestand en sla dit in een andere map op.

      De linten krijgen een naam volgens de Tekla Structures -configuraties. In de configuratie Volledig is de naam van het lintbestand Modelleren bijvoorbeeld albl_up_Full--main_menu.xml.

  2. Klik op de knop Herstellen om het standaard modelleringslint of tekeninglint Tekla Structures te herstellen.
  3. U neemt als volgt het aangepaste lint weer in gebruik:
    1. Kopieer het back-upbestand naar de map ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons.
    2. Wanneer u naar Tekla Structures teruggaat en het programma u vraagt of u het nieuwe lint wilt laden, klikt u op Ja. Het lint wordt bijgewerkt met de wijzigingen die u hebt aangebracht.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Inhoudswaardering: 
Nog geen stemmen