안녕하세요!

로그인하면 더 많은 내용을 볼 수 있다는 사실을 알고 계십니까?

관리자를 위한 환경, 회사 및 프로젝트 설정

Added April 2, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2019

관리자를 위한 환경, 회사 및 프로젝트 설정

관리자를 위한 환경, 회사 및 프로젝트 설정

환경 설정

공통 설정

모든 환경에서 동일한 설정 및 파일은 모두 \Tekla Structures\<version>\Environments\common 폴더 안에 있습니다. 한 환경에 특정한 파일 및 설정은 개별적인 환경 폴더 안에 있습니다.

env_global_default.ini 파일도 \common 폴더에 있습니다. 이 파일은 표준 설정을 결정하며 첫 번째로 읽어 오는 파일입니다. 이 파일 이후에 다른 초기화 파일 을 읽어 오고 이러한 다른 파일에 동일한 설정이 포함되어 있는 경우 이전 설정에 우선합니다.

국가별 설정

국가별 설정은 환경 폴더에 있으며 현지 Trimble 사무실/리셀러가 현지화합니다. 환경의 폴더 구조 는 다를 수 있지만 동일한 종류의 설정이 존재합니다. 예를 들어 현지화된 설정에는 프로파일 데이터베이스, 재질 데이터베이스, 레포트, 선택 필터, 뷰 필터, 컴포넌트 및 사용자 컴포넌트, 매크로, 사용자 정의 속성 및 도면 설정이 포함됩니다.

회사 설정

회사 레벨 설정은 주로 모든 프로젝트에 대해 회사 전체에서 사용되는 설정입니다. 이러한 설정은 XS_SYSTEMXS_FIRM 을 사용하여 설정됩니다.

자회사가 있는 대기업의 경우 다음과 같은 설정을 사용할 수 있습니다.

  • XS_SYSTEM 에는 다수의 경로가 포함되어 있으며 회사 내부의 일반 설정을 나타냅니다. 예를 들어 회사 로고, 레포트, 프린터 설정, 도면 설정, 템플릿이 될 수 있습니다. 이러한 설정은 거의 변경되지 않으며 모든 사용자가 사용할 수 있는 서버에 저장됩니다. 예를 들어 회사 로고를 업데이트하는 경우에 해당 로고는 한 곳의 위치에서만 교체되어야 합니다.
  • XS_FIRM 은 회사 또는 자회사가 설정하는 회사 지정 폴더를 나타냅니다. 특정 사무실에서 사용되는 모든 회사 설정이 포함되어 있습니다. 예를 들어 로고, 레포트 또는 프린터 설정, 도면 설정, 템플릿이 될 수 있습니다.
  • XS_PROJECT 는 프로젝트 폴더를 나타냅니다. 해당 폴더에는 도급업자 및 제조업자 로고 또는 도면 설정과 같은 프로젝트 설정이 포함되어 있습니다.

폴더 검색 순서에 대한 자세한 정보는 폴더 검색 순서 를 참조하십시오.

또한 온라인 또는 오프라인으로 자체 네트워크에서 Tekla Warehouse 회사별 모음을 사용할 수도 있습니다. Trimble Identity 를 사용하여 온라인 모음을 통해 다운로드 또는 설치하십시오. Tekla Online services에 대한 내용은 Trimble Identity 도 참조하십시오.

오프라인 모음에 대한 접근은 네트워크의 폴더 권한을 통해 각 사용자 컴퓨터에 있는 collections.json 파일의 모음 레벨로 관리됩니다.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

collections.json 파일은 C:\Users\Public\Documents\Tekla\Tekla Warehouse\ 폴더에 복사하여 선택한 사람들과 공유할 수 있습니다.

모델 템플릿

원하는 설정을 모델에 저장하고 새 모델을 만들 때 모델을 템플릿 으로 사용할 수 있습니다. 회사에 주차장, 사무실 건물, 교량 및 산업 시설 같은 다양한 종류의 프로젝트가 있는 경우에 매우 유용할 수 있습니다.

모델 템플릿을 생성할 때 항상 빈 모델을 새로 만들어서 시작해야 합니다. 이는 라이브 프로젝트에서 사용된 기존 모델을 완전히 정리할 수 없기 때문입니다. 기존 모델에는 너무 많은 정보가 포함되어 있어 모델에서 객체와 도면을 모두 삭제하더라도 모델 크기가 증가할 수 있습니다.

새 모델 템플릿을 생성하려면 다음을 수행합니다.

  1. 새 모델을 생성하여 고유 이름을 지정합니다.
  2. 모델에 원하는 프로파일, 사용자 컴포넌트 및 기타 필요한 항목을 추가합니다.
  3. 파일 메뉴에서 다른 이름으로 저장 > Save 을 클릭합니다.

    xslib.db1 파일에 사용자 컴포넌트를 포함하려면 모델을 저장해야 합니다. 모델을 저장하지 않으면 사용자 컴포넌트는 모델 템플릿에 포함되지 않습니다.

  4. 파일 메뉴에서 다른 이름으로 저장 > 모델 템플릿으로 저장 을 클릭합니다.
  5. 모델 템플릿에 이름을 입력하고 모델 템플릿에 포함하려는 카탈로그, 도면 템플릿, 레포트 템플릿 및 모델 하위 폴더를 선택합니다.
  6. 확인 를 클릭합니다.

    기본적으로 모델 템플릿 폴더는 ..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\ 아래에 있는 환경 폴더에 저장됩니다. 정확한 폴더 위치는 사용자의 환경 및 역할에 따라 다를 수 있습니다. 고급 옵션 XS_​MODEL_​TEMPLATE_​DIRECTORY 을 사용해 다른 위치를 정의할 수 있습니다.

Tekla Warehouse 에서 모델 템플릿을 다운로드, 공유 및 저장할 수 있습니다. 아래 이미지는 Tekla Warehouse 에 있는 모델 템플릿의 예입니다.

Tekla WarehouseInsert into model 버튼을 사용하면 XS_MODEL_TEMPLATE_DIRECTORY 가 가리키는 폴더에 모델 템플릿을 직접 설치합니다. 새 모델을 생성할 때 즉시 템플릿을 사용할 수 있습니다.

Tekla Structures 버전 업데이트의 모델 템플릿

Tekla Structures 업그레이드 버전에서 모델 템플릿을 업데이트하는 것이 좋습니다.

모델 템플릿을 업데이트하려면 다음을 수행합니다.

  1. 기존 모델 템플릿을 사용하여 새 모델을 생성합니다.
  2. 모델 이름을 이전 Tekla Structures 버전과 동일하게 사용합니다.
  3. 3D 뷰를 엽니다.
  4. 파일 메뉴에서 Diagnose and repair > Diagnose model 을 클릭합니다.
  5. View 탭에서 Screenshot > Project thumbnail 를 클릭하여 프로젝트 미리 보기를 생성하거나 모델 폴더에 thumbnail.png 로 명명된 사용자 지정 이미지를 추가합니다.

    이미지의 기본 설정 크기는 120 x 74 픽셀입니다.

  6. 파일 메뉴에서 다른 이름으로 저장 > Save 을 클릭합니다.

    안 그러면 이전 버전으로 생성된 모델에 관한 경고 메시지가 표시될 수 있습니다.

  7. 파일 메뉴에서 다른 이름으로 저장 > 모델 템플릿으로 저장 을 클릭합니다.
  8. 모델 템플릿에 포함하려는 카탈로그, 도면 템플릿, 레포트 템플릿 및 모델 하위 폴더를 선택합니다.
  9. 확인 를 클릭합니다.
  10. 모델 폴더에서 모든 *.db 파일(환경 데이터베이스, 옵션 데이터베이스 파일)을 수동으로 제거합니다.

    *.bak , *.logxs_user 파일이 모델 폴더에서 자동으로 제거됩니다.

    .idrm 파일( db.idrmxslib.idrm )은 모델의 일부이므로 제거하지 마십시오.

    모델 템플릿은 XS_MODEL_TEMPLATE_DIRECTORY 가 나타내는 위치에 저장됩니다.

    이제 모델 템플릿의 샘플 이미지가 생겼습니다. 이제 응용 프로그램 및 컴포넌트 카탈로그도 정리되어 간편하게 사용할 수 있습니다.

레포트 및 도면 사용자 지정

회사에 이미 DXF, DWG 또는 DGN 형식이 있는 경우 이러한 템플릿을 Tekla Structures 템플릿으로 변환할 수 있습니다. 이러한 방법에 대한 자세한 지침은 템플릿 편집기 도움말에서 AutoCAD 및 Microstation 파일 정보를 참조하십시오.

사용자 고유의 템플릿 및 레포트를 생성하는 방법에 대한 정보는 템플릿 편집기 도움말, 레포트템플릿 을 참조하십시오.

도면용 복제 템플릿

다음과 같은 경우 도면 복제를 고려해야 합니다.

  • 모델에는 여러 가지의 비슷한 부재, 어셈블리 또는 콘크리트 부재가 있습니다.
  • 비슷한 부재, 어셈블리 또는 콘크리트 부재의 단일 부재 도면, 어셈블리 도면 또는 콘크리트 부재도면을 생성해야 합니다.
  • 도면에는 수많은 수동 편집이 필요합니다.

예를 들어 하나의 트러스에 대한 도면을 생성하고 도면을 편집한 다음 유사한 트러스에 대해 복제할 수 있습니다. 그 다음에 해야 할 일은 복제된 도면에서 트러스의 다른 점을 수정하는 것뿐입니다.

복제된 도면에는 원본 도면보다 더 많은 부재가 포함될 수 있습니다. 부재 속성, 마크, 연결 메모, 관련 텍스트 객체는 원본 도면의 유사한 부재에서 복제됩니다.

마스터 도면 카탈로그에서 템플릿 복제

마스터 도면 카탈로그 템플릿을 사용하여 도면을 복제할 수 있습니다. 마스터 도면 카탈로그 의 복제 템플릿은 다른 모델에도 사용될 수 있습니다. 동일한 종류의 도면이 있는 프로젝트에서 사용할 수 있습니다.

복제 템플릿을 생성하려면 다음을 수행합니다.

  1. Select a drawing in 문서 관리자 에서 도면을 선택합니다.
  2. 마스터 도면 카탈로그에 추가 를 마우스 오른쪽 버튼으로 클릭하고 선택한 다음 필요한 속성을 입력합니다.

복제 템플릿은 마스터 도면 카탈로그복제 템플릿 에서 찾을 수 있습니다. 다른 모델에서 복제 템플릿을 사용하려면 모델의 마스터 도면 카탈로그 를 열고 도구 모음에서 버튼을 클릭하고 템플릿이 저장된 모델을 추가합니다.

마스터 도면 카탈로그 및 복제 템플릿에 관한 자세한 정보는 마스터 도면 카탈로그에서 도면 생성 을 참조하십시오.

프로젝트 설정

자체 컴포넌트 폴더 생성

일반적으로 프로젝트에는 서로 다른 접합부 및 컴포넌트 몇 개만 사용됩니다. 프로젝트의 모든 사람이 동일한 컴포넌트를 사용하고 이를 더 빠르게 찾으려면 자체 컴포넌트 폴더를 만드는 것이 좋습니다.

  1. 측면 패널에서 응용 프로그램 및 컴포넌트 버튼 을 클릭하여 응용 프로그램 및 컴포넌트 카탈로그를 엽니다.
  2. 다음과 같이 프로젝트에 대한 새 그룹을 만듭니다. 카탈로그를 마우스 오른쪽 버튼으로 클릭하고 새 그룹 을 선택합니다.
  3. 그룹에 컴포넌트 추가: 카탈로그에서 컴포넌트를 선택한 후 마우스 오른쪽 단추로 클릭하여 그룹에 추가 를 선택합니다. 그런 다음 컴포넌트를 추가할 그룹을 선택합니다. 선택한 컴포넌트를 다른 그룹으로 드래그할 수도 있습니다.
  4. 필요하지 않은 그룹 숨기기: 그룹을 선택하고 숨기기/숨기기 취소 를 마우스 오른쪽 버튼으로 클릭하여 선택합니다.
Tip:

응용 프로그램 및 컴포넌트 카탈로그에서 고급 기능 접근 > 카탈로그 관리 명령을 사용하여 카탈로그 정의를 수정합니다. 자세한 내용은 응용 프로그램 및 컴포넌트 카탈로그 사용자 지정XS_​COMPONENT_​CATALOG_​ALLOW_​SYSTEM_​EDIT 을 참조하십시오.

응용 프로그램 및 컴포넌트 카탈로그에 대한 자세한 정보는 응용 프로그램 및 컴포넌트 카탈로그의 사용 방법 을 참조하십시오.

프로젝트 속성 정의

프로젝트가 진행되는 동안 프로젝트 정보 가 많이 필요합니다. 레포트와 도면 디스플레이에 정확한 정보가 자동으로 표시되도록 프로젝트가 시작할 때 프로젝트 정보를 정의합니다. 프로젝트가 진행되는 동안 프로젝트 속성도 업데이트할 수 있습니다.

  1. 파일 메뉴에서 프로젝트 속성 을 클릭합니다.
  2. 프로젝트 속성을 편집합니다.

    속성을 편집하면 Tekla Structures 가 수정된 속성을 노란색으로 강조 표시합니다.

  3. 수정할 준비가 되었으면 수정 을 클릭하고 변경 내용을 적용합니다.

템플릿 및 레포트를 생성하고 수정합니다.

템플릿 편집기를 사용하여 기존 레포트 및 템플릿을 수정하거나 자체 템플릿 을 생성할 수 있습니다. 템플릿 편집기를 열려면 파일 > 편집기 > 템플릿 편집기 를 클릭하거나 열린 도면에서 기존 테이블을 두 번 클릭하여 도구를 엽니다. 자세한 내용은 Template Editor User's Guide 를 참조하십시오.

템플릿이 보호되는 폴더에 있는 경우, 그 템플릿은 읽기 전용이므로 수정된 템플릿을 보호되는 폴더에 저장할 수 없다는 점에 유의하십시오. 이 경우, 관리자 자격으로 Tekla Structures 를 실행합니다.

프린터 설정

Tekla Structures 는 Windows 드라이버를 사용하여 인쇄 데이터를 Windows 인쇄 장치 인터페이스에 직접 작성합니다. PDF 파일로 도면을 인쇄 하거나, 프린터/플로터로 인쇄하기 위해 플롯 파일( .plt )로 저장하거나, 선택한 프린터로 인쇄할 수 있습니다. 여러 용지 크기로 인쇄하려면 drawingsizes.dat 파일을 수정해야 합니다. 자세한 정보는 인쇄에 사용되는 구성 파일 을 참조하십시오. 인쇄 도면의 선 두께를 변경할 수도 있습니다. 자세한 정보는 .pdf 파일, 플롯 파일(.plt) 또는 프린터로 인쇄도면의 선 두께 를 참조하십시오.

특정 도면 유형별 고급 옵션을 사용하여 Tekla Structures 가 자동으로 .pdf 파일의 이름을 지정하는 방식에 영향을 줄 수 있습니다. 자세한 정보는 인쇄 파일 이름 사용자 지정 를 참조하십시오.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet