こんにちは

ログインすると、より多くのコンテンツを表示できることをご存知ですか?

RC断面リスト図ツール

最終更新 May 13, 2020 by Tekla サポート tekla.support.jp@trimble.com

ソフトウェアのバージョン: 
Not version-specific
環境: 
Japan

RC断面リスト図ツール

はじめに

本ツールでは、モデル上に作成されたコンクリート部材及びコンクリート部材に対して適用された配筋コンポーネントのパラメータ情報から、RC断面リスト図を作成する拡張ツールです。

本ツールでは、モデル上のRC部材について、大梁、柱、基礎梁、小梁に関してそれぞれの断面リスト図をTekla Structures上の一般図上で作画機能を利用してRC断面リスト図を作成します。

基本的な操作方法

本ツールは、モデルの編集時に、アプリケーションとコンポーネントカタログから起動することができます。

起動直後に現在開いているモデル内のコンクリート部材の情報やその部材に適用されている配筋コンポーネント、基準線等の情報を取得します。RC断面リスト図は、ダイアログ上の[大梁]、[柱]、[基礎梁]、[小梁]の各ボタンで部材タイプ毎に図面を作成します。

作成されるRC断面リスト図の詳細は、[図面設定]ボタンで表示されるダイアログ上で設定することができます。

【注意事項】
本ツールは、起動時にモデル上の基準線や部材、鉄筋コンポーネント等の情報を取得しますので、モデルの編集を行った際には、ツールの再起動が必要となります。

基本的な機能について

本ツールは部材種別毎に設けられたボタンで、図面の作成を、[図面設定]ボタンで、作成される図面の設定を行うことができる他、メニューバー上の機能を使からも操作することができます。

[ファイル]メニュー > [終了]

本ツールを終了します。タイトルバー右端の[X]ボタンでも終了できます。

[ウィンドウ]メニュー > [最前面に表示]

このダイアログを最前面に表示します。

[ウィンドウ]メニュー > [作成図面を開く]

Tekla Structures上で図面を開いた状態で、断面リスト図の作成を行います。

[大梁]、[柱]、[基礎梁]、[小梁]ボタン

それぞれの部材に対する断面リスト図の作成を実行します。本ツールでは作図対象の部材は、部材のユーザー定義情報の部材種別を参照しています。

また、部材に含まれる鉄筋詳細の情報については、配筋コンポーネントのパラメータを参照しております。

[図面設定]ダイアログ

[図面設定]ボタンを選択すると、作成される断面リスト図に関する設定ダイアログが表示されます。
[保存]ボタンで設定内容を保存することができ、 [閉じる]ボタンでダイアログを閉じることができます。

[共通]タブ

作成される全ての図面に対する共通設定を指示します。

[図面設定]グループ

断面接尾辞や図面のタイトル、縮尺及び図面余白に関して設定します。

[断面接尾辞]
本ツールでは、モデル上で同じ断面符号が定義されているが部材サイズや配筋の仕様が異なる場合、断面符号に接尾辞を付加し、異なる断面として図面が作成されます。本オプションでは、自動的に付加される接尾辞(1文字)を指定します。

【デフォルト値 = 1】

[名前]、[タイトル1]~[タイトル3]
一般図として作成される断面リスト図の名前、タイトル1~3フィールドに出力する情報をオプションリストから選択設定します。

  • (ブランク):何も出力されません。
  • %TEXT%:右側のテキストボックスに入力した文字列が出力されます。
  • %APPLICATION_NAME%:本ツールの製品名(JP_SectionListDrawingTool)が出力されます。
  • %PART_TYPE%:部材タイプ名が出力されます。
  • %DRG_WITH_PART_TYPE%:部材タイプ名につづけて文字列(部材リスト図)が結合されて出力されます。
  • %DRG_NUM%:部材種別毎に作成される断面リスト図の連番情報(番号情報)を出力します。

【デフォルト値】
名前=%TEXT%,断面リスト図
タイトル1=%PART_TYPE%
タイトル2=(ブランク)
タイトル3=%APPLICATION_NAME%

[基準スケール]
断面リスト図内に表記される部材断面の縮尺値(候補)を、半角スペースを区切り文字として指定します。設定されたスケール値の数で、処理形式が切り替わります。<\\/p>

  • スケール値を一つ定義した場合指定されたスケール値で、断面図を作成します。
    断面図枠の高さは、指定されたスケール値での作図ができない場合、作画可能なサイズに調整されます。
  • 複数のスケール値を定義した場合
    部材毎に最初に設定された値から、順番に確認し、断面リスト図に収まるスケールを検索し、適用します。

【デフォルト値 = 20】

[余白]
断面リスト図の上下左右の余白(mm)を指定します。
指定された余白を確保できなくなった時点で、新規図面を作成し、新規図面上に続きを出力します。

【デフォルト値 = 34(上), 100(下), 50(左), 50(右)】

[文字フォント]
図面内の文字フォントとサイズを指定します。文字サイズはリスト図内の文字及び特記文字のサイズを指定することができます。

【デフォルト値 = MSゴシック 、サイズ = 3、特記サイズ = 4】

[共通]グループ
図面上に出力される情報を設定します。

[材質省略]
本オプションが有効な場合、 [鉄筋材質表記]タブ上の”材質表記の省略”オプションが設定されている材質について、材質情報が自動的に省略されます。

(注意) 本オプションの設定を切り替えた際には、自動的に[特記表記]のオプションも更新されます。

【デフォルト値 = OFF】

[特記表記]
図面の右上に出力される特記表記の出力と出力内容を指定します。テキストボックス内に%METERIAL%と指定してある場合、材質省略オプションが設定された材質名が挿入されます。

 

【デフォルト値 = OFF / 特記なき限り主筋鉄筋の材質は%MATERIAL%とする。】

[符号の並替順]
本オプションが有効な場合、テキストボックスで指定した断面符号の順序で並び替えを実施します。

モデル上の部材情報を取得した際に、各部材の符号を接頭辞と連番、接尾辞に展開されます。
[符号の並替順]では、接頭辞の並び替え順序を指定することができます。システムが自動的に展開した接頭辞の情報は、モデルフォルダ内のファイル”JP_SectionListDrawingTool_Prefix.txt”に保存されます。
(例)

符号名 接頭辞 連番 接尾辞
1G1 1G  
G1A

【デフォルト値 = OFF】

部材の材質表記(大梁/柱/基礎梁に有効)
階単位で、出力される大梁、柱、基礎梁に有効なオプションで、各階の表題欄に材質情報の出力を指定することができます。

【デフォルト値 = ON】

SRC鉄骨部材の表記
本ツールでの処理実行時に、図化対象となるコンクリート材の内部にSRC鉄骨材が確認された場合に、SRC鉄骨部材を描画することができます。
SRC鉄骨材はコンクリート材と同じ位置に始終点の参照点がある以下のコンポーネント等で作成されている必要があります。

JP_SRC_Column、JP_SRC_Column_Taper、JpBuildBox、GBeamまたはプロファイルタイプとして”I(H鋼)"または"M(角鋼管)"の部材

【デフォルト値 = OFF】

図内に主筋本数の表記
断面図内に主筋の本数を表記することができます。

【デフォルト値 = はい】

鉄筋の断面表記
主筋、軸筋、腹筋筋など図面上で鉄筋断面を表記する際に、○印または鉄筋径に応じたシンボル表記を選択することができます。
シンボル表記を選択した場合は、シンボルフォルダまたはモデルフォルダに保存された、シンボルファイルjapansymbols.sym内で定義された径毎のシンボルで断面が表記されます。
表記される鉄筋シンボルについては、シンボルファイル”japansymbols.sym”をシンボルエディタで編集します。


【デフォルト値 = ○印表記】

(共通)材質表記
材質の表記方法を指定します。


材質文字を指定した場合、[鉄筋材質表記]タブ上で指定した材質文字を使って材質情報を出力します。

【デフォルト値 = 材質名】

(共通)部材サイズ表記
部材サイズの表記方法を指定します。


「断面図寸法表記」を選択した場合には、断面図内に寸法が表記され、「欄表記(BxD)」の場合には、サイズ欄が追加されます。

【デフォルト値 = 断面図寸法表記】

[鉄筋材質表記]タブ

[共通タブ]上の、[材質省略]オプションや、[材質表記]オプションで”材質文字”が選択されている場合、材質名や表記を省略する材質を指定します。

材質情報を更新後、 ボタンを選択した場合、更新された情報は、モデルフォルダ上の”JP_SectionListDrawingTool_MateMap.xml"ファイルに保存されます。

 [大梁/小梁/基礎梁表記]タブ

大梁、小梁、基礎梁の断面リスト図内の「主筋」、「帯筋」及び「あばら筋」欄の表記方法に関する設定を行います。
主筋本数の表記設定で「段毎本数(結合子)」を選択した場合には、段毎の結合子を指定することができます。

 

 【デフォルト値】
主筋本数 = 総本数
あばら筋表記 = 呼び 本数 @ ピッチ(材質名)
腹筋表記 = 本数 - 呼び(材質名)
図内に主筋本数を表示 = はい

[柱表記]タブ

柱断面リスト図内の「主筋」、「帯筋」、「軸筋」欄の表記方法に関する設定を行います。

【デフォルト値】
主筋本数 = 総本数 – 呼び(材質)
帯筋表記 = 呼び @ ピッチ(材質名)
軸筋表記 = 総本数 - 呼び(材質名)

断面リスト図として作成される部材

本ツールでは、各部材の部材種別情報と、その部材に適用されているコンポーネントとそのパラメータの条件が、次の条件を満たす場合に、大梁、柱、基礎梁、小梁の各断面リスト図上に情報が出力されます。






 

部材リスト図について

本ツールで作成される部材リスト図は、一般図のパラメータ設定”Standard”を使用して、Tekla Structruesの一般図として部材リスト図を作成します。
作成される断面リスト図の図面サイズや図枠等を変更する場合には、予めモデル上の一般図プロパティのStandardの設定を更新し、[上書き保存]してから、図面作成を実施します。
 

作成される図面について

断面リスト図は、Tekla Structuresの一般図を用いて作成されます。
作成された図面では、部材の断面図や鉄筋及び文字列が、補助線やテキスト等のグラフィックオブジェクトにて作成されます。
また、本ツールが作成する部材リスト図は、モデル上の部材情報とコンポーネントの実行時に設定したパラメータ情報を参照して作成されます。
したがって、作成された図面には以下の点について注意する必要があります。

  • モデル上の部材等と関連付けされていませんので、図面の作成後、モデルを編集した場合に、図面の内容は更新されません。
  • 部材のサイズや形状、鉄筋のサイズは、本ツールの固有スケールで記載され、モデル上でのサイズや位置等は参照されていません。
  • コンポーネントを適用後、コンポーネントを分解した場合には、その部材は図面作成の対象から除外されます。
  • コンポーネントを適用後、手動にて鉄筋の位置やサイズ形状等を編集した場合には、その内容は反映されません。
     

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
コンテンツの評価: 
まだ投票はありません