Hello!

Did you know that logged in users can see a lot more content?

First steps with Tekla Structures 2016 user interface

Last updated January 13, 2017 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2016

First steps with Tekla Structures 2016 user interface

Elements of the new user interface

Ribbon - scrollable, minimizable, configuration-specific 

  • All the essential commands are now available on the ribbon and grouped according to their use

Modeling ribbon

  • Steel tab contains commands for steel modeling
  • Concrete tab contains CIP, precast and rebars related commands
  • Edit tab contains commands for editing model objects and construction geometry
  • View tab contains commands for views, clip planes, work planes, rendering and navigation
  • Drawings & reports tab contains commands for drawings, numbering, and reports
  • Manage tab contains commands for Organizer, clash check and other construction management related tools
  • Analysis & design tab contains all calculation related commands, for example, loads
  • Custom tab: Add your own components, frequently used commands, and links to important tools outside Tekla Structures. The custom tab has been replaced by full ribbon customization in Tekla Structures 2016i.

Drawings ribbon

  • Drawing tab contains commands for editing and creating marks, symbols, associative notes, text, lines, etc.
  • Dimensioning tab contains commands for adding and editing dimensions
  • Views tab contains commands for adding and managing views in the drawing
  • Custom tab: Add your own components, frequently used commands, and links to important tools outside Tekla Structures

Some helpful rules about icons

Quick launch (Ctrl+Q)

  • Find all commands

File menu on the left - Manage your model and settings 

  • Save, print, export, share models, etc.
  • Catalogs
  • Options and advanced options, logs, editors, diagnose and repair, etc.
  • Customize the ribbon in Settings > Customize Ribbon

Side pane 

Modeling side pane

  • Reference models
  • Applications & components (custom components and macro recordings)

Drawings side pane

  • Drawing 2D Library
  • Applications & components

Contextual toolbar

  • Make quick changes to modeling and drawing objects. Contextual toolbar replaces the Mini Toolbar.

Keyboard shortcuts

  • Add keyboard shortcuts in File menuSettings.

Custom components

  • Import your custom components by following these instructions. Imported custom components go to Ungrouped items in the Applications & components catalog.
  • Create your own groups: Right-click on the groups in the Applications & components catalog -> select New group -> Drag your custom components to the groups where you want them (or right-click a component, click Add to group and select the target group)
  • Read more about working with the Applications & components catalog.

Quick feedback

Your feedback on the documentation. The feedback you give here is not visible to other users. Please use the "contact us" form instead if you have a query and you wish to receive a reply.
We use this to prevent automated spam submissions.
Content rating: 
Average page rating: 3.2 (13 votes)
Refresh page after voting to show updated result.

Comments

by Tero Laine

Should it say here that component toolbars can't be used anymore?

by Gaétan Nicole

I hate ribbons. Too many space used by ribbons on screens. Please let the user choose his way. I prefer icon toolbar where i can find command at the same place anytime in each job.
Moving...sliding...and find command.....we will lose a lot of time to do only as usual
Why a quick launch ? Is it because commands are not easy to find ???

by Adrian Arin

This new user interface is heading in the wrong direction. I understand Tekla has to look more like Trimble now but everything takes longer to do. It is not optimized for speed of use but only to look 'pretty'. A command that previously was one click away, now take 3-4. The flat look, one color icons are hard to distinguish, the component toolbar which made it so quick to find macros is gone, and there are many other negative points.
Please rethink the interface and optimize it for speed of use like it was before. Think of improving connection macros, drawing dimensioning, rework drawing list into a easier to manage folder structure like interface, would be a good start.

by Paul LaFrenier

I'm with you Adrian, This is not an improvement as far as I am concerned. I have been using Tekla since it was called X-Steel, Tekla was smart in keeping the toolbars consistent in layout and improving the engine itself. This "upgrade" is nothing short of throwing on some new rims and a paint job. I lost all of my drawing layouts, my custom toolbar. I tried to use the custom ribbon but it is so hard to distinguish one from the next. The text overruns each button and there are no icons to help visually pick one quickly. Please give us an option to use the old layout. Sorry guys, I was your biggest fan until this release. Autodesk Advance Steel understands productivity and pretty much emulated the old Tekla toolbars and steered away from the ribbon layout. I don't understand how 2 to 3 clicks is more productive than one click. As if carpel tunnel wasn't enough of a problem. Sorry Trimble, Huge fumble on this one. I will just stick to using Version 21 until they get it right. I'm pretty sure no one requested ribbon toolbars as a sought after upgrade.

by Tommi Hautalahti

Thank you everyone for you comments. However, the comments here are monitored only by people responsible for the documentation for the purpose of improving the content.

The discussion forum is the right place to discuss and give your feedback on the product, and there you will have a better chance of reaching people responsible for the product features. There are already some forum discussion threads about the user interface changes.

I am closing commenting on this page. If you wish to leave feedback on the content, please use the "Quick feedback" below.