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1 Tekla Structures configurations

Tekla Structures is available in different configurations that provide specialized
sets of functionalities to suit the needs of the construction industry. Tekla
Structures can be used to cover the entire building process from conceptual
design to fabrication, erection and construction management.

Special student and developer configurations of Tekla Structures are available.
Visit the main Tekla website for more information on student configurations
for home and classroom use. Visit the Tekla Developer Center for more
information on the Tekla Partners program.

The help covers the content of the Full configuration. Note that the
configuration that you are using may not contain all the described features.
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2 Install and license Tekla
Structures

To use Tekla Structures, you need to have a license, and Tekla Structures
installed on your computer. In most cases, you will also install a standard
localized environment or your organization's own customized Tekla Structures
environment. Each environment includes many important localized settings
and tools, such as profiles, templates and components.

About Tekla Structures licenses

Tekla Structures cannot be used without a valid license.

• You license most full commercial configurations of Tekla Structures by
activating an entitlement certificate on your license server (on-premises
licensing). The entitlement certificate is sent in an email to the contact
person your organization has named when purchasing the license.

• Online licensing is used with the EPM Modeler and Partner configurations
and with the free learning license (Tekla Campus).

• The Tekla Structures Partner and EPM Modeler configurations have
an online license that is connected to your Trimble Identity. The license
is delivered directly to the Tekla Online Admin tool, where your
organization's administrator(s) can assign the online licenses to
individual users.

• For a free learning license for Tekla Structures, visit the Tekla Campus
site, where you can activate an online license that is connected to your
Trimble Identity. Note that you are not allowed to use this configuration
for commercial work.

• You can see the license type of licenses in the About Tekla Structures
dialog box. It is either Domestic or Enterprise. For the Partner edition, the
value is Partner and for the Tekla Campus edition the value is
Educational.
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If you manage your own installation of Tekla Structures

License entitlement via email3

Trimble identity and 
Tekla Downloads service

Tekla Structures
Localized environment

License server 
License administration tool

2

1

The general process you must complete:

1. Download installers.

2. Install the software.

3. Activate your license.

In detail (follow the links for step-by-step instructions):

• Create your Trimble Identity (page 8) to access all Tekla online services.

• Download the installation package for Tekla Structures, the license server
and at least one of the Tekla Structures environments from Tekla
Downloads.

• Install the Tekla Structures software and at least one of the Tekla Structures
environments on your computer:

Tekla Structures installation (page 9)

• If you have a standard on-premises license, install the license server
software on your computer and activate your license.

1. Install Tekla license server (page 18)

2. Activate Tekla Structures licenses (page 19)

3. Save your Tekla Structures license entitlement certificate (page 18)

4. Connect Tekla Structures to the license server (page 20)

• If you have an online license, you can start Tekla Structures and select the
Use your Tekla online license licensing option. Online licenses are
available for specific configurations as listed in the previous section above.

If someone manages Tekla Structures for you

If your organization has a Tekla Structures administrator (IT administrator or
main user), you should follow their instructions for installation and licensing.
You may still need to consider the following points:
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• You need an account to access Tekla online services. If your administrator
has not invited you to your organization, ask to join so that you have access
to all Tekla online services:

Create your Trimble Identity (page 8)

• In most cases, your Tekla Structures administrator will prepare a
customized installation package for you or install the software for you. Ask
your administrator for further instructions.

• To be able to use Tekla Structures outside the office, you may need to know
how to borrow a license for offline use:

Borrowing Tekla Structures licenses for offline use

If you manage Tekla Structures for other users

The general workflow for a new Tekla Structures deployment can go for
example like this:

• Install the Tekla license server.

• Install Tekla Structures for your own use and start customizing it for your
organization.

• Add users to your organization group in the Tekla Online Admin tool to give
them full access to Tekla online services and any online licenses that your
organization may have.

• Deploy Tekla Structures to the users in your organization.

• Continue developing your organization's customizations and redeploy as
needed.

Start your journey in Tekla Structures installation for administrators, which
introduces you to all of the topics listed above.

2.1 Create your Trimble Identity
You need a Trimble Identity to download Tekla Structures.

Some Tekla Online services require that your account is connected to an
organization that has a valid maintenance contract with Trimble. If you are the
named contact at your organization, Trimble automatically creates an account
for you or connects your existing Trimble Identity to your organization. The
named contact has administrator status and must add other users into the
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organization to enable their access to content and services that require a valid
maintenance contract.

NOTE Membership in an organization can also affect your access to your
organization's cloud-stored data, such as Tekla Model Sharing models.
Make sure you do not switch between organizations unnecessarily.

If you are the named contact, Trimble sends you an email with an invitation to
accept membership in the organization group and complete the profile
information if you did not have an existing Trimble Identity. You are then
responsible for managing the organization group together with other
administrators that you assign. See Managing Trimble Identities and Tekla
Model Sharing licenses for more information.

If you are not the named contact, you receive an email invitation to join the
organization group when an administrator from your own organization invites
you. You can also create a new Trimble Identity here.

If you are having problems using your Trimble Identity in Tekla Online services,
see the troubleshooting information on this page.

2.2 Tekla Structures installation
Tekla Structures installation packages are available for download in Tekla
Downloads. In addition to installing Tekla Structures, you need to install and
set up a Tekla license server and activate your Tekla Structures license.

Tekla Structures software and environments are available as separate
installation packages. The software installation package always contains a
blank project (page 26) environment that includes generic content. Other
Tekla Structures environments are available as separate installation files.
Environments are region or company-specific settings and information that
are predefined in Tekla Structures, or that are defined by the user.

You can install the Tekla license server on the same computer as the Tekla
Structures software and environments. The license server can also be installed
on a separate server computer if there are many Tekla Structures users and
many Tekla Structures licenses in the company. The licenses you can use and
their activation IDs are listed in an entitlement certificate you receive via e-
mail.

Tekla Structures uses the FlexNet Publisher License Management (FlexNet)
licensing system. The FlexNet licensing system is not used with Tekla
Structures Educational (Tekla Campus), and FlexNet licensing instructions do
not apply.

Centralized installation

Tekla Structures can be installed across the company network using
centralized installation. Installing Tekla Structures centrally across the

Install and license Tekla Structures 9 Tekla Structures installation

https://download.tekla.com/
https://download.tekla.com/
https://campus.tekla.com/


company network saves time in a large company as the installation is done
silently in the background for each user.

Using Tekla Structures with application and desktop virtualization

Tekla Structures can be used with the Citrix application and desktop
virtualization. Tekla Structures is installed on a server or on a virtual machine
running on the server. Using Tekla Structures from the server ensures that all
users in a project are using the same project environment set-up.

Version updates: Service packs

Service packs are version updates that can contain new features, and
improvements and fixes to existing features.

Service packs are available in Tekla Downloads for all customers with a valid
maintenance agreement. We recommend that all users install the latest
service pack.

Borrowing licenses with Tekla License Borrow Tool

If you want to work offline and do not have the Tekla license server on your
computer, you can borrow an activated license from the license server
(page 21) using the Tekla License Borrow Tool. The borrowed license is
transferred from the license server to your computer. It is not available for
other users during the borrowing. The installer for Tekla License Borrow Tool is
available in Tekla Downloads.

Collaboration within a Tekla Structures model

Tekla Model Sharing allows several users to access the same model
simultaneously. With Tekla Model Sharing a global team can work efficiently
within one model regardless of the team location and time zone. The model
data is shared and synchronized over the Internet, and stored to a cloud-
based Tekla Model Sharing service. It is also possible to work offline. Tekla
Model Sharing requires a license.

Multi-user mode also allows several users to access the same model
simultaneously. Multi-user mode is suitable for local teams with projects
where the team members do not necessarily have an Internet connection. In
the multi-user mode a server computer runs the multi-user server, a file server
computer contains the multi-user master model and client computers run
Tekla Structures. The Tekla Structures multi-user server installer is available in
Tekla Downloads.

Using the multi-user server requires your company to have more than one
Tekla Structures license.
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Extensions

Extensions are applications that have been made using the Tekla Open API or
custom components. Extensions are not part of the Tekla Structures product
release. Extensions for Tekla Structures are available in Tekla Warehouse.

You can import the Tekla Structures extensions that have the .tsep (Tekla
Structures Extension Package) file extension to the Applications &
components catalog in Tekla Structures. The extensions are installed when
you restart Tekla Structures. Tekla Structures extensions that have the .msi
file extension have to be installed separately by running the installation file.

Tekla User Assistance

Tekla User Assistance collects all help and support material to one place. By
default, all help content is online. You can access Tekla Structures help
material in Tekla User Assistance by pressing the F1 button in Tekla Structures.
You can also use the help offline. Offline help installation packages are
available in Tekla Downloads.

See also

Tekla Structures installation prerequisites (page 11)

Tekla Structures installation folders (page 12)

Install Tekla Structures (page 16)

Tekla Structures installation prerequisites
Installing Tekla Structures requires one of the following operating systems:
Windows 10, Windows 8.1, or Windows 7 SP1.

The Tekla Structures installer is available as a 64-bit version.

Tekla Structures needs the following redistributable packages that are
automatically installed during the Tekla Structures software installation if they,
or newer versions of the packages, do not exist on your computer:

• Microsoft .NET Framework 4.7.2

• Microsoft Visual C++ 2010 Redistributable (x64) 10.0.40219

• Microsoft Visual C++ 2010 Redistributable (x86) 10.0.40219

• Microsoft Visual C++ 2013 Redistributable (x64) 12.0.40649

• Microsoft Visual C++ 2013 Redistributable (x86) 12.0.40649

• Microsoft Visual C++ 2015 Redistributable (x64) 14.0.23026

• Microsoft Visual C++ 2015 Redistributable (x86) 14.0.23026

In addition, the following installers are automatically installed during the Tekla
Structures software installation:

• Tsep File Dispatcher Launcher
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• Tekla Warehouse Service

These installers are needed to get Tekla Warehouse to work properly.

Tekla Warehouse offline content is available online. To find this content in
Tekla Warehouse, search for Catalogs and under Show, select Collections.

Recommended hardware is described in Tekla Structures 2019 Hardware
Recommendations.

See also

Install Tekla Structures (page 16)

Tekla Structures installation folders
You can select the Tekla Structures software installation folder in the software
installation wizard. By default, the software is installed to a folder under ..
\Program Files\Tekla Structures\<version>.

When you install a new Tekla Structures version, for example 2019, make sure
that the installation folder does not contain any files from other Tekla
Structures versions. This is to ensure that you get all the files that are included
in the installation package.

Note that when you are installing a service pack and you already have the
related Tekla Structures version or a previous service pack installed, you
cannot select the installation folder. The service pack will be installed to the
same folder as the related Tekla Structures version or the service pack that
you are updating. The installation folder will contain files from the related
Tekla Structures version or the previous service pack. Installing the new service
pack will automatically remove the old files before copying the new files. Note
that if you have your own files in the installation folder, these files will remain
unchanged in the folder.

The location of the environment installation folder depends on where you
have installed the software. You cannot select the installation folder for the
environments in the installation wizard. For example, when the software is
installed under \Program Files, the environments are installed in ..
\ProgramData\Trimble\Tekla Structures\<version>\Environments.

When you have installed the software and the environments, you can check
the installation paths in Windows Control Panel.

The image below shows the default installation folder structure under
\Program Files and \ProgramData. User settings are stored under
\Users.
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The image below shows the installation folder structure under C:\. If you
install Tekla Structures software under C:\, the environments are also
installed and the user settings stored under C:\.
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NOTE If you need to install Tekla Structures to a folder that has a non-Unicode folder
name, for example, in Chinese, Japanese, Korean, or Russian, change the
language in XS_STD_LOCALE and the Windows system locale in Windows
Control Panel to that same language so that Tekla Structures can work
normally.

The image below shows the installation folder structure of Tekla Warehouse
Content installation under C:\ProgramData\Tekla\Tekla Warehouse.
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See also

Install Tekla Structures (page 16)
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Install Tekla Structures
To use Tekla Structures, install the Tekla Structures software and the Tekla
Structures environments that you want to use.

You also need to have the Tekla license server installed, either on your own
computer or on another computer, and you need to activate your Tekla
Structures license.

NOTE You need to be logged in with administrator rights to install the Tekla
Structures software on your computer.

1. Install the Tekla Structures software.

a. Download the installation file from Tekla Downloads to your
computer.

b. Double-click the installation file to run the installation.

c. Follow the steps in the installation wizard to complete the installation.

You can select the installation folder (page 12) and the model folder.

2. Install the Tekla Structures environments. 

Note that the location of the environment installation folder depends on
where you have installed the software. You cannot select the environment
installation folder in the installation wizard.

a. Download the environment installation files from Tekla Downloads to
your computer. 

Note that you can also later install as many environments as you
want to a Tekla Structures version that you are using.

b. Double-click the installation file to run the installation.

c. Follow the steps in the installation wizard to complete the installation.

The environment setting files are installed to the environment folder
when you start Tekla Structures after the installation. Tekla Structures
opens a dialog box that shows the installation progress.

See also

Tekla Structures installation prerequisites (page 11)

Tekla Structures installation folders (page 12)

Tekla Structures settings in Windows registry (page 16)
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Tekla Structures settings in Windows registry
Windows registry is a hierarchical database that stores configuration settings
and options in Microsoft Windows operating systems. Registry settings are
used during a Tekla Structures session and during a Tekla Structures
installation.

WARNING Do not change the registry settings. Changing the settings can
cause the operating system to fail. It is possible to view the
registry settings using the Registry Editor.

User settings

Some of the Tekla Structures user settings, for example, general options, and
dialog box locations and sizes are stored in the registry. The settings are saved
in a registry key named after the Tekla Structures version number in the
registry branch HKEY_CURRENT_USER\Software\Trimble\Tekla
Structures\<VERSION>.

Tekla Structures uses the hardcoded default settings when opened for the first
time after the installation. If you change a setting during a Tekla Structures
session, Tekla Structures saves the change during the session, or when you
exit Tekla Structures. When you open the same version of Tekla Structures
again, the changed setting is used.

When upgrading to a newer Tekla Structures version, you can use the
Migration Wizard tool to copy the settings you have changed.

Installation settings

The Tekla Structures installation saves information to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Trimble\Tekla Structures
\<VERSION> registry key.

See also

Tekla Structures installation (page 9)

2.3 Taking Tekla Structures licenses into use
To take your Tekla license server into use, follow the workflow below:

1. Install Tekla license server (page 18)

2. Save your Tekla Structures license entitlement certificate (page 18)

3. Activate Tekla Structures licenses (page 19)

4. Connect Tekla Structures to the license server (page 20)
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NOTE When you set up the Tekla licensing system, you may also need to configure
the firewall settings to be able to connect Tekla Structures to the license
server. For more information about configuring the firewall, see Allowing Tekla
Structures license server to operate through Windows Firewall....

If you have problems, see Troubleshoot Tekla Structures licensing for more
information.

Install Tekla license server

Install the Tekla license server. This is phase 1 in the workflow Taking Tekla
Structures licenses into use (page 17).

If you are using other FlexNet licensing services, you need to stop them before
you install the Tekla license server. When you have completed installing the
Tekla license server, you can restart the other licensing services.

To install the license server:

1. Go to Tekla Downloads and download the latest Tekla license server
installation. To check the license server version to use, see Which license
server version to use.

2. For standard setup, select the options Automatic and complete the
installation. 

Tekla license server is installed.

In automatic license server installation, the license server host name is
automatically set to 27007@your_host_name, where 27007 is the port
and your_host_name is your computer name.

Automatic installation is recommended. Use the Manual installation only
if you are an advanced user of FlexNet or Flexlm licensing, and you need
to change something in the default installation, for example, the TCP/IP
port. For more information, see Installing Tekla Structures license service -
manual installation

Save your Tekla Structures license entitlement certificate

Save your license entitlement certificate. This is phase 2 in the workflow Taking
Tekla Structures licenses into use (page 17).

As a preliminary action for transferring license rights from Trimble Solutions
license activation server to your license server, you need to save the
entitlement certificate, which is sent in an e-mail to the person in your
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organization who has made the license purchase, or to someone named as
the contact person.

To save the license entitlement certificate:

1. In your e-mail application, open the e-mail containing the entitlement
certificate.

2. Download the entitlement certificate file
EntitlementCertificate.html to the ..\Tekla\License\Server
folder.

The entitlement certificate states the configurations, quantities and activation
IDs of your Tekla Structures licenses. The entitlement certificates are not
computer-specific. This means that you can activate licenses from several
entitlements on one license server and you can activate licenses from one
entitlement (containing several licenses) on several license servers.

Activate Tekla Structures licenses

Activate your Tekla Structures licenses. This is phase 3 in the workflow Taking
Tekla Structures licenses into use (page 17).

You need to activate the licenses on the license server to use Tekla Structures.
When you activate the licenses and notify the server, the license rights are
transferred from the activation server at Trimble Solutions to the license
server. Use Tekla License Administration Tool for activating licenses.

NOTE Do no use the automatic license server notification functionality if you
are using some other FlexNet license and license server
administration tool, such as FlexNet Manager. To use manual
notification, see Activating Tekla Structures licensing using manual
server notification.

To activate your licenses and notify the license server about license changes:

1. Go to Tekla Licensing --> Tekla License Administration Tool through
the Start menu or Start screen, depending on your Windows operating
system.

2. Enable the automatic license server notification functionality by clicking
the Notify Server button.

3. You saved your entitlement certificate in the ..\Tekla\License\Server
folder, and the licenses should now be listed in the Entitled Licenses
area. If they are not listed, click Open, select
EntitlementCertificate.html, and click Open again.

4. Select the number of licenses to activate.
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5. Click the Activate button. 

Your license server contacts the activation server at Trimble Solutions. The
activated licenses are displayed under the Activated Licenses area.

Next, you need to connect Tekla Structures to the license server when you
start Tekla Structures for the first time.

Connect Tekla Structures to the license server

Connect Tekla Structures to the license server. This is phase 4 in the workflow
Taking Tekla Structures licenses into use (page 17).

To connect Tekla Structures to the license server when you start Tekla
Structures for the first time:

1. Start Tekla Structures.

2. To connect Tekla Structures to the license server, enter the 
port@hostname information in the licensing dialog box, for example 
27007@HOST_NAME.

The host name and port must correspond with the host name and port
found in the tekla.lic file on the server computer located at ..\Tekla
\License\Server. The license server administrator informs users about
the license server name and port number.

1. host
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2. port

If there is more than one license server available with activated licenses,
you can define a primary and a secondary server in the licensing dialog
box by separating the servers with a semicolon as follows: 
27007@HOST_NAME_1;27007@HOST_NAME_2

3. Click OK to start Tekla Structures.

2.4 Borrowing licenses for using Tekla Structures offline
You can borrow an activated license from the license server when you work
offline and no license server is installed on your computer. The borrowed
license is transferred from the license server to your computer, so it is not
available for other users during the borrowing period.

To borrow licenses, follow the workflow below:

1. Install and set up Tekla License Borrow Tool for license borrowing
(page 21)

2. Borrow a Tekla license (page 22)

3. Return a borrowed Tekla license (page 23)

Install and set up Tekla License Borrow Tool for license
borrowing

Set up Tekla License Borrow Tool: install Tekla License Borrow Tool, connect
Tekla Structures to the license server, and open the product ID file containing
all Tekla Structures configurations and their product IDs. You may use the
default product ID file (standard.tpi) or ask your administrator to send you
a new and customized product ID file that contains only the configurations
that you are allowed to use. This is phase 1 of the workflow Borrowing licenses
for using Tekla Structures offline (page 21).

To install and set up Tekla License Borrow Tool:

1. Download and install the latest Tekla License Borrow Tool from Tekla
Downloads.

2. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.
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3. In the Setup dialog box, enter the port number and the hostname
(computer name) of the license server in the Server box in the format 
port@hostname, for example, 27007@server_hostname. 

You need to use exactly the same port and host name as in the licensing
dialog box when starting Tekla Structures.

4. Still in the Setup dialog box, click Browse and select the product ID file.

5. Click OK. 

The Products area in the Tekla License Borrow Tool is updated. Now you
can borrow licenses.

Borrow a Tekla license

Borrow a license from the Tekla license server. This is phase 2 of the workflow
Borrowing licenses for using Tekla Structures offline (page 21).

To borrow a license from the license server:

1. In Tekla License Borrow Tool, in the Products area, click the Borrow Until
box and select the expiration date for the borrowing period from the
calendar. 
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The maximum borrowing period is one month.

2. Click the Borrow button. 

The borrowing progress is displayed. After successful borrowing the
Borrowed Licenses area shows the borrowed license.

3. Disconnect your computer from the license server and start Tekla
Structures with the borrowed license to ensure that the borrowing
succeeded.

Return a borrowed Tekla license

Return the borrowed license when you do not need to use it anymore. This is
phase 3 of the workflow Borrowing licenses for using Tekla Structures offline
(page 21).

A borrowed license is automatically available on the license server one day
after the expiration date. However, you need to return the expired license to
the license server to update the Borrowed Licenses area in Tekla License
Borrow Tool. You can return a borrowed license any time.

To return a borrowed license:

1. Connect your computer to the network where you can connect to the
license server.

2. Close Tekla Structures.

3. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

4. Select the Return check box in the Borrowed Licenses area to select the
license to return.

5. Click the Return button at the top.

After successful returning, the Borrowed Licenses area is updated.
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3 Start Tekla Structures

When you start Tekla Structures, you are asked to choose your Tekla Structures
setup. The setup consists of an environment, role, and configuration.

• Environment means region-specific settings and information. It defines, for
example, which profiles, material grades, default values, drawing settings,
component settings, reports, and templates are available and used for the
specific region.

• Role is a user group profile that limits the availability of files and settings in
an environment. The user interface has been customized for each role,
meaning that some of the settings that are not relevant for the specific role
are hidden to make the user interface clearer and easier to use.

• Configuration consists of a set of features that the user is entitled to based
on the license agreement. Each configuration is meant for a specific user
group, to suit the various players in the construction industry.

If you are a company administrator, see Overview of environments, roles and
licenses.

3.1 Choose your Tekla Structures setup
1. Start Tekla Structures by selecting it from the Windows Start menu or by

double-clicking the desktop icon. 
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A dialog box where you choose your Tekla Structures setup appears.

2. Select an environment that fits the region where your project is done. 

If you cannot find the desired environment from the list, see Install Tekla
Structures (page 16).

You can also select blank project and use it as a basis for a customized
environment.

3. Select a role. 

The availability of roles depends on your environment, but typically the
following roles are available:

• Concrete Contractor

• Engineer

• General Contractor

• Precast Concrete Detailer

• Production Planner - Concrete

• Rebar Detailer

• Steel Detailer

4. Select a configuration. 

The configuration you are using may not contain all the features described
in the Tekla Structures product guides. For more information on the
features available in each configuration, see Tekla Structures
configurations (page 5).

5. Click OK. 
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Tekla Structures start screen appears.

6. Select what you want to do: 

• On the Recent tab, you can open a recently used model (page 30).

If the Recent tab is empty, then the All models tab is shown.

• On the All models tab, you can open any existing model (page 31).

If the All models tab is empty, then the New tab is shown.

On the Recent and All models tabs, you can sort each of the columns.
Additionally, you can change the order and size of the columns by
dragging them.

You can search models by name just by starting to type the name of
the model. For example, when you type N, Tekla Structures selects the
first model starting with the letter N.

To open the selected model, double-click the selected model, or select
the model and click the Open button.

• On the Shared models tab, you can open a model that has been
shared by using Tekla Model Sharing. Note that you need to be logged
in with your Trimble Identity to be able to work with Tekla Model
Sharing models.

• On the New tab, you can create a new model (page 31).

3.2 Create your own environment: blank project
Blank project is a Tekla Structures environment that includes only generic
content, such as parametric profiles, undefined bolt, material and rebar
grades, and basic drawing layouts. It can be used for gathering region-,
company-, or project-specific settings, tools, and information. The blank
project is always included in the Tekla Structures installation.

Start Tekla Structures 26 Create your own environment: blank project



Download and install content to the blank project

You can use Tekla Warehouse to download and install content to the blank
project. For example, you can download profiles, material grades, bolts,
reinforcement, components, applications, and templates from Tekla
Warehouse across all environment- and manufacturer-specific collections, and
make combinations that suit your needs.

You can download and install content from Tekla Warehouse both before and
during a project. Before starting a project, you can install content to your
project and firm folders. During a project, you can install content to the model
folder.

3.3 Check or change your Tekla Structures setup
You can check your current Tekla Structures setup (environment, role, and
configuration) at any time without having to close the model.

1. On the File menu, click Settings and scroll down to the License area. 

You current setup is displayed.

2. Change the setup if needed. 

You may be required to restart Tekla Structures after the changes.

3.4 Join or leave the Automatic User Feedback program
Join the Automatic User Feedback program to help improve Tekla Structures.
This is an easy way to influence the future development of Tekla Structures,
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because the program collects anonymous information on how you use the
software.

The program collects usage patterns and trends of how you use the
commands and tools in the software. The program collects this information
automatically while you use Tekla Structures. You can view the log file to check
the collected data. Your privacy is always a priority - the information we collect
cannot be used to identify you, and your data is combined with other people's
data to make statistical analysis.

1. On the Tekla Structures menu, click Settings and scroll down to the
Automatic User Feedback area.

2. Select one of the options: 

• Yes, I want to participate in the program: you accept the collecting
of anonymous information

• No, I would not like to participate: you do not accept the collecting
of information

3. To check the data that has been collected, click the review the collected
data link. 

Tekla Structures displays the UserFeedbackLog.txt file.

4. To send feedback or questions about the program, send e-mail to the
address tekla.usability@trimble.com.
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4 Work with 3D models

With Tekla Structures, you can create information-rich 3D models of all
structures and materials. The model contains all the information that is
needed to manufacture and construct the structure: part geometry and
dimensions, profiles, materials, and so on.

• Open a model (page 30)

• Create a new model (page 31)

• Save a model (page 36)

Model output

The 3D model is also the single source of information for drawings and other
outputs, such as reports and NC data files. This ensures that the information in
drawings and reports is always up to date, as they react to modifications in the
model.

Collaboration

You can use the multi-user mode or Tekla Model Sharing to work
collaboratively within a model.
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4.1 Open a model
You can have one model open at a time. If you open a model and already have
one open, Tekla Structures prompts you to save the first model.

Open a recently used model
1. On the File menu, click Open.

2. Click Recent.

3. Select a model in the list. 

Tekla Structures shows the thumbnail image (page 32) of the model, if
you have added a one, and some basic creation information of the model.
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4. To open the selected model, click Open or double-click the model. 

If no views are visible in the model, Tekla Structures prompts you to select
one.

NOTE If you want to remove a model from the Recent models list, right-click
a model and select one of the options.

• Delete the selected item: delete the selected model from the list

• Clear all: remove all the models from the list

• Clear invalid entries: remove all invalid models from the list, such
as deleted models that cannot be opened anymore

Open any existing model
1. On the File menu, click Open.

2. Click All models. 

If you want to search for models in another folder, click Browse....

If you want to sort the models based on name or the modification date,
use the Order by sorting.

3. Select a model in the list. 

Tekla Structures shows the thumbnail image (page 32) of the model, if
you have added a one, and some basic creation information of the model.

4. To open the selected model, click Open or double-click the model. 

If no views are visible in the model, Tekla Structures prompts you to select
one.

Open a shared model
If you want to open a model that has been shared by using Tekla Model
Sharing, you need to be logged in with your Trimble Identity.

1. On the File menu, click Open.

2. Click Browse shared models. 

Tekla Structures prompts you to log in with your Trimble Identity, if not
already done so.

3. Select the shared model in the Shared models dialog box.
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4.2 Create a new model
Create a separate model for each Tekla Structures project. Each model is
stored in its own folder under the TeklaStructuresModels folder.

1. On the File menu, click New.

2. In the Name box, enter a name for the new model. 

Do not use special characters (/ \ ; : |). We recommend that you try
to decide on a permanent name at this point. The name of the model can
be changed afterward, but it involves changing several file names.

3. Define where to save the new model. 

By default, the model is saved in the TeklaStructuresModels folder
that was created during installation. You can change the default folder by
clicking Browse. You can also select a recently used folder in the Place in
list.

4. Select whether to run Tekla Structures in single-user or multi-user mode. 

• Single-user: the model will be used by one person at a time.

• Multi-user: the model is stored on a server and may be used by several
people simultaneously. Enter the name of the server in the Server box.

5. If you want to use a model template, select one. 

You can mark the important model templates as favorites, or hide the
templates that you do not need.

a. Select a model template in the list.

b. Right-click and select Favorite or Hidden. 

If you marked a template as Favorite, it is placed on top of the
template list. Alternatively, use the star icon on the template to mark
it as Favorite, or to remove the marking.

If you marked a template as Hidden, it is removed from the template
list. Select the Show hidden items check box to show it again.

6. Click Create. 

Tekla Structures creates the model and opens the default model view. The
contents of the model view may differ based on the model template you
chose in step 5.

See also

Create a thumbnail image of a model (page 32)

Edit project properties (page 33)
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4.3 Create a thumbnail image of a model
You can add a thumbnail image to make it easier to recognize your project
even when you do not remember the exact name of the model. The thumbnail
image is displayed when you browse for existing models.

1. On the View tab, click  Screenshot --> Project thumbnail.

2. Select a view. 

Tekla Structures creates the image and saves it in the model folder with
the name thumbnail.png.

3. To check the thumbnail, go to the File menu, click Open, and select the
model you created the thumbnail for in the Recent or in the All models
list. 

The image is now displayed with other model information. For example:

4. If you are unhappy with the thumbnail image, you can repeat steps 1–2 as
many times as you need. 

For example, you can zoom the model in and out to adjust what is shown
in the thumbnail image. When you create a new thumbnail, Tekla
Structures overrides the existing thumbnail image with the new one.

TIP Alternatively, if you want to use a custom image, you can add the image directly
to the model folder with the name thumbnail.png. The preferred size of the
image is 120 x 74 pixels.

4.4 Edit project properties
You will need project information, such as project number and name, many
times during a project. Update the project properties at the beginning of each
project to make reports and drawings display the correct information
automatically. All of the fields are optional.
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1. On the File menu, click Project properties.

2. Edit the general project properties, and enter a description that helps you
identify the model when you next need to open it. 

The description is listed with the other model information when you select
a model in the Recent or in the All models list.

The limit for the length of the description is 78 characters.

When you edit the properties, Tekla Structures highlights the modified
properties in yellow. When you are ready with the modifications, click
Modify to apply the changes.

3. If you want to use another coordinate system for interoperability and
collaboration, click Base points to define a new base point. 

Once a base point has been defined, you can select it from the Location
by list.

4. To define project-specific user-defined attributes, click User-defined
attributes. 

By default, you can define:

• Project comment

• User fields

• Execution class

• Classification system

• IFC export attributes

• GEO coordinates

• Status attributes

• Unitechnik factory location

The availability of the various user-defined attributes depends on your
environment (page 24), role and configuration (page 5).

Once you are finished with editing the project properties, as a result, you will
get updated project properties in drawings and reports.

Displaying project information in templates and reports

The fields in the image below refer to template attributes, which you can use
when designing your own reports and templates. To display project
information, add the corresponding template attributes in the templates and
reports.
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(1) NUMBER#2

(2) NAME

(3) BUILDER
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(4) OBJECT

(5) DESIGNER

(6) LOCATION

(7) ADDRESS

(8) POSTAL_BOX

(9) TOWN

(10) REGION

(11) POSTAL_CODE

(12) COUNTRY

(13) DATE_START

(14) DATE_END

(15) INFO1, INFO2

(16) DESCRIPTION

4.5 Save a model
You should save your model regularly to avoid losing any work. Tekla
Structures also automatically saves your work at regular intervals.

NOTE Tekla Structures versions are not backwards compatible. When you save a
model, you cannot open it in older versions of Tekla Structures due to
database differences.

Save the current model
To save changes to the current model file, do one of the following:

• On the top left corner of the screen, click Save .

• On the File menu, click Save as --> Save.

• Press Ctrl+S.

Save a copy with different name or location
You can create a copy of the model with a different name or in a different
folder. The original version of the model remains intact.
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NOTE When you save the model with a different name, all the GUIDs
(globally unique identifiers) of the saved model will change and be
different than in the original model. This means that the saved model
has no relation to the original model, and the saved model cannot be
used as backup.

1. On the File menu, click Save as --> Save as.

2. In the Model name box, enter a new name.

3. To save in a different location, click Browse and define where you want to
save the model.

4. Click OK. 

Tekla Structures creates a new copy with a different name, but the original
version of the model remains intact.

Save a backup copy
You can create a backup copy of the model with the same GUIDs (globally
unique identifiers) as the original model.

1. On the File menu, click Save as --> Save and create backup copy. 

Tekla Structures saves a copy of the model in the ..
\TeklaStructuresModels\backup\<model_name>\<date-time>
folder.

2. If you need to take the backup copy into use in place of the current model,
move the backup copy from the chosen date to your model folder. 

You can either replace all contents of the current model folder with the
content of the chosen backup folder, or you can rename the backup
folder (<date-time>) to match the original model name.

3. If you want to change the location of the backup folder, use the advanced
option XS_MODEL_BACKUP_DIRECTORY.

NOTE To save disk space, you can compress the 
XS_MODEL_BACKUP_DIRECTORY folder.

Save as a model template
See Create model templates.
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Define autosave settings
Use Autosave to automatically back up and save your work at set intervals.
You can set the autosave interval separately for the model and drawings.
Autosave files have the extension .db1_<user>.

You can use the autosaved model if there are errors when trying to open a
model (page 30). When you open a model, Tekla Structures automatically
checks if the previous session ended normally. If it did not, Tekla Structures
asks whether you want to continue by using the autosaved model or the
original model.

If Tekla Structures displays the warning Fatal: Model memory corrupted by
read, it means that hardware problems have damaged the model database.
Your hard disk may be damaged. Use autosave or system backup files to
restore the model.

1. On the File menu, click Settings --> Options, and go to the General
settings.

2. Under Autosave, set the autosave interval.

a. In the first box, define how often Tekla Structures saves the model or
drawing. 

This number represents the number of commands you will have to
run before Tekla Structures saves the model or drawing. For example,
if you create many steel beams without interrupting the Create steel
beam command, it only counts as one command.

b. In the second box, enter the number of drawings after which Tekla
Structures saves your work.

NOTE The smallest accepted value for the autosave interval is 2, both
for modeling and for drawings.

If you try to enter a value smaller than 2, Tekla Structures
automatically changes the value to 2.

3. Click OK.

4. Define where to store the Autosave files. 

By default, Tekla Structures stores the autosave files in the ..
\TeklaStructuresModels\autosave folder. To change the folder, use
the advanced option XS_AUTOSAVE_DIRECTORY.

5. Define whether to keep old autosave files. 

By default, Tekla Structures deletes the autosave files when you close a
model, to save disk space. To keep autosave files even if you exit Tekla
Structures without saving the model, use the advanced option
XS_KEEP_AUTOSAVE_FILES_ON_EXIT_WHEN_NOT_SAVING.
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5 Get familiar with the user
interface

When you open a Tekla Structures model, a new window appears. By default,
the user interface will look something like this:

(1) This is your Tekla Structures model. If you are starting a completely new
project, you will only see the default model view and an empty grid at this
point.

(2) The green cube symbol represents the global coordinate system and it lies
at the global origin (x=0, y=0, z=0).

(3) The box around the grid represents the work area. In a view, you can only
see the parts that are within this area. Objects that are outside the work area
exist in the model, but they are not visible. You can shrink and expand the
work area to suit your needs. You can also hide the work area box.
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(4) The coordinate symbol with the three axes x, y, and z represents the local
coordinate system. It also indicates the direction of the model.

(5) The File menu is where you manage your models. You can save models
(page 36), print drawings, and import and export models, among other things.

(6) The ribbon contains all the commands and other functions you will use
when building your model. You can customize the ribbon according to your
needs.

(7) By default, the Quick Access Toolbar (page 54) contains the Save, Undo,
Redo, and Undo history shortcuts icons.

(8) If you cannot find the command or dialog box you are looking for, search
with Quick Launch (page 43).

(9) Use the side pane (page 45) on the right side of the screen to view model
objects properties, add reference models and components, attach point
clouds, use custom inquiry, or to find direct access to Tekla Online services.

(10) The work plane handler toolbar controls which work plane you currently
have in use in the model.

(11) The selection switches control which objects you can select.

(12) The snap switches control which positions you can pick when creating
objects.

(13) When you create objects, the status bar (page 49) will tell you how to
proceed and when to pick points.

5.1 How to use the ribbon and the commands on the
ribbon
All the essential commands in Tekla Structures are available on the ribbon. The
commands are grouped according to their use. You can modify the
appearance of the ribbon, and customize the content of the ribbon, if needed.
All commands throughout Tekla Structures work in the same manner.

How to use commands on the ribbon

To Do this
Find commands Slide the ribbon right or left with your

mouse, or scroll with your mouse
wheel.
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To Do this
Some commands have more options
under them. The options become
available when you click the
command's name:

Activate the command you want to
use

On the ribbon, click the command.

The command runs until you end it or
use another command.

Check which command you need for
your current task, if you are unsure

Rest the mouse pointer on a
command.

A small window called tooltip
appears. Tooltips provide more
information about commands and
also give examples, hints, and tips.
For example:

Find more help on the command Press Ctrl+F1 when a tooltip is open.

To switch the tooltips on or off, click
File menu --> Settings --> Switches,
and then select or clear the Tooltips
check box.

End command Right-click and select Interrupt.

You can also press Esc.
Re-activate the last command Press Enter.
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Change the appearance of the ribbon
You can change the order of ribbon tabs, choose how they are aligned, and
even hide some parts of the ribbon if you do not need them in your current
project. For example, if you are only modeling steel parts, you can temporarily
hide the Concrete tab.

To Do this
Change the order of tabs on the
ribbon

Drag and drop the tab titles.

Change how the tabs are aligned Right-click on the top bar of the
ribbon, select Navigation mode, and
then select one of the options.

• Scroll visible: the ribbon
movement is minimal when you
switch between the tabs

• Align to left: the icons start from
the left side of the ribbon

• Align to tab: the icons start from
the left side of the current tab

Hide the tabs that you do not need in
your current project

1. Rest the mouse pointer on a tab
title.

A small eye symbol appears next
to the tab title:

2. Click the eye symbol .

The eye symbol changes and the
tab title becomes gray:

The View tab is now hidden from
the ribbon. If you slide the
ribbon, hidden tabs appear as:

3. To re-display the hidden tab, click
the eye symbol again.
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Minimize the ribbon
You can minimize the ribbon to save space on your screen. When the ribbon is
minimized, the command buttons are hidden but the tabs are visible.

1. Right-click on the top bar of the ribbon, and select Minimized. 

The ribbon is now minimized to save space on the screen:

2. To access the commands when the ribbon is minimized, click a tab title.
The ribbon becomes visible so that you can select a command.

3. To restore the ribbon, right-click on the top bar of the ribbon, and select
Minimized again.

5.2 How to use Quick Launch to find commands, dialog
boxes, and toolbars
Use the Quick Launch box in the upper-right corner of the screen to find
commands, dialog boxes, toolbars, and other functions. The shortcut key for
Quick Launch is Ctrl+Q.

1. In the Quick Launch box, enter a search term. For example, type bolt if
you are looking for bolt commands.

2. Wait for a list of search results to appear. For example: 
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The search results show the location of the command. You can navigate in
the list by clicking the Recent, Ribbon, Menu, and All commands tabs.
The Recent tab list the 10 most recently started commands from the
search results.

Alternatively, you can navigate in the search results by using the up and
down arrow keys on the keyboard. Start the selected command by clicking
Enter.

Tekla Structures highlights the commands on the ribbon or on the File
menu, to help you locate them. For example:

If the command you have search is in the side pane, Tekla Structures
opens the side pane window.

3. To run a command, click its name on the search results list. 

Or press the Enter key to instantly run the first command on the list.

4. For some basic settings (page 50) and toolbars a check box appears in
front them in the search results list. Click the command to activate the
setting, or to have the toolbar visible. 

Get familiar with the user interface 44 How to use Quick Launch to find commands,
dialog boxes, and toolbars



5. If you want to open the search list results again, click the Quick Launch
box and the list opens automatically. 

To clear the Quick Launch box, click the  button or press the Esc key.

See also

How to use the ribbon and the commands on the ribbon (page 40)

How to use the side pane (page 45)

5.3 How to use the side pane
Use the side pane on the right side of the screen, for example, to view model
object properties, and to add reference models and components.

To Do this
Open a side pane window Click a side pane button to open a side pane

window.

•
Click  to view model object properties
using Custom inquiry.

•
Click  to find shortcut access to the
different Tekla Online services.

•
Click  to attach point clouds to a model.

•
Click  to show the properties of model
objects.

•
Click  to show the reference models list.

•
Click  to show the Applications &
components catalog.

When you click a side pane button, the side pane
window opens and becomes active. Active side

pane windows have blue buttons .
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To Do this
Keep multiple side pane
windows open at the same
time

Tekla Structures opens only one side pane
window at a time by default. You can keep
multiple side pane windows open at the same
time if needed.

• Right-click a side pane button and select
Single pane or Stacked panes.

Single pane: Tekla Structures opens a new
side pane window and closes all the other
open side pane windows.

Stacked panes: Tekla Structures opens a new
side pane window and keeps the other open
side pane windows stacked on top of each
other.

• Click Ctrl+side pane button to open the side
pane windows stacked on top of each other.

You can resize the side pane windows and
change their order by dragging them.

Close a side pane window You can close one active side pane window at a
time, or several windows at one go if you have
stacked them on top of each other.

• Click another side pane button to close the
active side pane window and to open a new
window.

•
Click the  button in the upper right corner
of each side pane window.

•
Click the arrow  in the side pane.

Move a side pane window When you position the mouse pointer on the
upper part of the side pane window, the upper
part is shown in light blue.

Grab the upper part of the side pane window
and drag the window to a new location.

Float and dock a side pane
window

You can float or dock the side pane windows.

• To float a side pane window: right-click a side
pane button and select Float.

• To dock a side pane window: right-click the
side pane button of a floating window and
select Attach to side pane.
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To Do this
Alternatively, you can drag the side pane
window back to the docking area on the right
or at the bottom of the screen. The docking
area is marked with blue color.

If you float a side pane window and close Tekla
Structures, the side pane window will be opened
in its floating position when you start Tekla
Structures the next time.

Adjust the size of a side
pane window

Resize a floating side pane window by dragging
its borders.

Find more help on the
content of a side pane
window

Click the  button.

TIP Sometimes a side pane window opens on a second display that is not
connected to your computer at the moment. To return the side pane
window to the main display, right-click the side pane button and select
Attach to side pane.

See also

Get familiar with the user interface (page 39)

5.4 How to use the contextual toolbar
When you click an object in a model or drawing, a contextual toolbar symbol

 appears next to the mouse pointer. Click the symbol to open the
contextual toolbar. Use the contextual toolbar to quickly view and change
some basic properties of an object, view, grid, and so on.
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If multiple objects are being selected, the contextual toolbar displays the text
Varies for any properties that differ.

How to change object properties using contextual toolbar
The changes that you make on the contextual toolbar are immediately applied
to the model or drawing.

1. Click an object in a model or drawing. 

A contextual toolbar appears next to the mouse pointer.

2. Change the object properties on the contextual toolbar. 

The changes are applied immediately.

TIP Press the Tab key to move between the properties and command buttons on the
contextual toolbar.

Show or hide contextual toolbar
You can define whether the contextual toolbar is visible in Tekla Structures.

1. On the File menu, click Settings.

2. Under Toolbars, select or clear the Contextual toolbar check box. 

Alternatively, use the keyboard shortcut Ctrl+K to show or hide the
contextual toolbar.

Define contextual toolbar's position
You can define the position of the contextual toolbar, relative to an object's
reference point.

1. Select an object.

2. Hold down the Ctrl key and click the contextual toolbar with the left
mouse button. 
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A dashed line appears between the contextual toolbar and the object.

3. Drag the contextual toolbar to a new position. For example, you can
position the contextual toolbar on the left side of the selected object.

4. Release the left mouse button. The contextual toolbar now appears in the
position you defined, for example on the left side of any object you select.

Pin contextual toolbar in place
You can pin the contextual toolbar to a specific location on the screen, so that
the position is locked. For example, you could have it appear at the upper left
corner of the screen. In the locked state, the position of the contextual toolbar
is independent of the individual part’s location.

1. Drag the contextual toolbar to a new location.

2. Click  to pin the contextual toolbar to the new location. 

The pin icon changes when the position is locked.

3. To unlock the position, click .

Minimize contextual toolbar
You can minimize the contextual toolbar so that it takes less space on your
screen.

1. On the contextual toolbar, click . The contextual toolbar now has the

symbol .

2. To restore the contextual toolbar to its original size, click  again.

5.5 View status bar messages
Status bar is the area located at the bottom of the Tekla Structures main
window. Follow the instructions on the status bar when you use commands.
For example, when you are creating a part, the status bar will tell you how to
proceed and when to pick points.
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1. Instructions and error messages

2. The status of Smart select (S), Drag & drop (D), and Ortho (O)

3. The level in assembly or component hierarchy (0–9)

4. The middle mouse button mode (Pan or Scroll)

5. The current phase

6. The number of selected objects and handles

5.6 Basic settings in the File menu
Use the toolbar settings and the switches in File menu --> Settings to control
some basic modeling and drawing settings.

User interface

• Toolbars: Use the slider to adjust the size of the icons on the toolbars and
at the same time the toolbar size.

• Font size (Ribbon): Use the slider to adjust the ribbon font size. The
default font size is 11p.

Switches

Option Description
Smart select Change how drag-and-drop works for

object handles.

When the option is on, you can drag
from object handles without selecting
them first.

When the option is off, you must
select the handles before dragging.

Drag & drop Activate or inactivate the drag-and-
drop command.

When the option is on, you can use
drag-and-drop when copying or
moving objects.

When the option is off, drag-and-drop
cannot be used.
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Option Description
Middle button pan Change the panning mode.

When the option is on, you can move
the model using the middle mouse
button.

When the option is off, you can move
the model using the left mouse
button.

Centered zooms Change the zooming mode.

When the option is on, the center
point of zooming is kept in the middle
of the view, regardless of the mouse
pointer position.

When the option is off, the mouse
pointer position determines the
center point of zooming.

Basic view auto rotation Activate or inactivate the auto
rotation of part and component 3D
views.

When the option is on, Tekla
Structures rotates the view once
whenever you create a new 3D view
of a part or component.

When the option is off, Tekla
Structures does not rotate the view.

Crossing selection Change how area selection works.

When the option is on, all objects that
fall at least partially inside the
rectangular area are selected,
regardless of the dragging direction.

When the option is off, the dragging
direction affects the selection of
objects.

Rollover highlight Switch the highlighting of objects on
or off.

Depending on the rendering engine
you are using, OpenGL or DirectX,
Tekla Structures highlights the objects
differently when rollover highlight is
on.

When the option is on, Tekla
Structures highlights selectable
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Option Description
objects when you move the mouse
pointer on them.

When the option is off, selectable
objects are not highlighted.

Select on right-click Change how objects can be selected.

When the option is on, you can select
objects also with the right mouse
button. Also the related shortcut
menu is displayed immediately.

When the option is off, you can select
objects with the left mouse button.

Automatic rotation center Define how the view point is set.

When the option is on, the view point
changes whenever you click the
middle mouse button.

When the option is off, the view point
stays in a set position.

Ortho Activate or inactivate orthogonal
snapping.

When the option is on, Tekla
Structures snaps to the closest
orthogonal point on the plane (0, 45,
90, 135, 180 degrees, and so on). The
mouse pointer automatically snaps to
positions at even distances in the
given direction.

When the option is off, orthogonal
snapping is not used.

DirectX rendering Switch between OpenGL rendering
and DirectX rendering.

When the option is on, DirectX
rendering is used.

When the option is off, OpenGL
rendering is used.

Tooltips Show or hide the tooltips (page 40).

When the option is on, a small
window with examples, hints, and tips
appears when you rest the mouse
pointer on a command.

When the option is off, no tooltips
appear.

Get familiar with the user interface 52 Basic settings in the File menu



The following settings are available only in drawings:

Option Description
Printer line widths Show the lines in color drawings with

defined thickness on the screen.

When the option is on, the lines in
color drawings are shown with
defined thickness.

When the option is off, the lines in
color drawings are shown with default
thickness.

Printer line colors Show line colors in the drawing.
Ghost outline Show hidden objects in drawings as

ghost outlines in color drawings. In
grayscale and black and white
drawings, hidden objects are not
shown even if Ghost outline is
selected.

When the option is on, hidden lines
are shown as ghost outlines.

When the option is off, hidden lines
are not shown.

Associativity symbol Shows which drawing objects are
associative and automatically
updated. Associativity symbols are
shown only when you select a
drawing object, for example a
dimension.

Objects that do not have valid
association get a ghost associativity
symbol and a question mark.

When the option is on, associativity
symbols are shown.

When the option is off, associativity
symbols are not shown.

Drawing drag & drop Activate or inactivate the drag-and-
drop command in drawings.

When the option is on, you can use
drag-and-drop when moving objects
such as annotations, sketch objects
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Option Description
and grid lines without selecting the
objects or handles first.

When the option is off, drag-and-drop
cannot be used.

Toolbars

Use the toolbar switches to control the visibility of toolbars. Switch the
selected toolbars on and off.

Alternatively, you can use Quick Launch (page 43) to control the toolbars and
the switches. Start typing the name of the toolbar or the switch, for example,
smart, in the Quick Launch box and select the toolbar or the switch on the
search results list to activate the setting.

5.7 How to control the visibility toolbars
You can control the visibility of toolbars in the modeling and in the drawing
mode, and bring back the toolbars if you have accidentally removed them.

You can switch the following toolbars on and off:

• Selecting toolbar

• Snapping toolbar

• Snap override toolbar

• Work plane handler toolbar

• Contextual toolbar (page 47)

1. To select which toolbars are visible, click File --> Settings.

2. In the Toolbars list, ensure that the needed toolbars are selected.

Alternatively, you can use Quick Launch (page 43) to control the visibility of the
toolbars. Type toolbar in the Quick Launch box and select the needed
toolbar from the search results list.

See also

Basic settings in the File menu (page 50)

5.8 Icons on the Quick Access Toolbar
Quick Access Toolbar provides shortcut icons to the commonly used
commands. The toolbar is located on top left corner of the screen.
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If needed, you can customize the Quick Access Toolbar and add the
commands of your choice to it.

Icon Description
Save (page 36) changes to the current model file.

Undo the last action.

Redo the actions previously undone.

Open the Undo history dialog box. The dialog box lists
the commands you have run and the modifications
you have done. Use the list to undo or redo several
commands or modifications at one go.
This icon is visible if you use Tekla Model Sharing.

Read in other users' model changes from the sharing
service. Only the changed data is read in.
This icon is visible if you use Tekla Model Sharing.

Write out your model changes to the sharing service.
Only new or changed data is written out.
The icon is visible if you use Tekla Model Sharing.

Show read in changes. After you have read in, a list of
model changes is displayed.

See also

Get familiar with the user interface (page 39)

5.9 Default keyboard shortcuts
Tekla Structures contains a large number of keyboard shortcuts that you can
use to speed up your work.

If you want to change the default shortcuts, see Customize the keyboard
shortcuts.

Common commands

Command Keyboard shortcut
Help F1
Help: when tooltip is open Ctrl+F1
Open model Ctrl+O
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Command Keyboard shortcut
Create new model Ctrl+N
Save model Ctrl+S
Delete Del
Properties Alt+Enter
Undo Ctrl+Z
Redo Ctrl+Y
Interrupt Esc
Repeat last command Enter
Show/hide contextual toolbar Ctrl+K
Switch direct modification on/off D
Quick Launch Ctrl+Q
Advanced options Ctrl+E
Applications & components catalog Ctrl+F

Rendering options

Command Keyboard shortcut
Parts wireframe Ctrl+1
Parts shaded wireframe Ctrl+2
Parts grayscale Ctrl+3
Parts rendered Ctrl+4
Show only selected part Ctrl+5
Components wireframe Shift+1
Components shaded wireframe Shift+2
Components grayscale Shift+3
Components rendered Shift+4
Show only selected component Shift+5

Selecting objects

Command Keyboard shortcut
Rollover highlight on/off H
Select all selection switch F2
Select parts selection switch F3
Select all Ctrl+A
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Command Keyboard shortcut
Select previous objects Alt+P
Select assembly Alt+object
Add to selection Shift
Toggle selection Ctrl
Selection filters Ctrl+G
Hide object Shift+H

Snapping

Command Keyboard shortcut
Snap to reference lines/points F4
Snap to geometry lines/points F5
Snap to nearest points F6
Snap to any position F7
Ortho O
Relative coordinate input R
Absolute coordinate input A
Global coordinate input G
Snap to next position Tab
Snap to previous position Shift+Tab
Lock X, Y or Z coordinates X, Y or Z

Copying and moving objects

Command Keyboard shortcut
Copy Ctrl+C
Move Ctrl+M
Smart Select S

Viewing the model

Command Keyboard shortcut
Open the view list Ctrl+I
3D/Plane view Ctrl+P
Switch between views Ctrl+Tab
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Command Keyboard shortcut
Updated window Ctrl+U
Zoom original Home
Zoom previous End
Zoom in Page Up
Zoom out Page Down
Rotate using mouse Ctrl+R
Rotate using keyboard Ctrl+arrow keys

Shift+arrow keys
Set view rotation point V
Rotate once

Rotate continuously

Shift+R

Shift+T
Pan P
Middle button pan Shift+M
Move right

Move left

Move down

Move up

arrow keys

Fly Shift+F
Create clip plane Shift+X

Checking the model

Command Keyboard shortcut
Inquire object Shift+I
Measure distance F
Create report Ctrl+B

Drawings

Command Keyboard shortcut
Open Document manager in model Ctrl+L
Open Document manager in
drawing mode

Ctrl+O

Print drawings Shift+P
Open next drawing Ctrl+Page Down
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Command Keyboard shortcut
Open previous drawing Ctrl+Page Up
Associativity symbol Shift+A
Set next drawing color mode B
Ghost outline Shift+G
Add orthogonal dimension G
Add free dimension F
Open any drawing after creating the
drawing

Ctrl+Shift

In Document manager: Open user-
defined attributes

Alt+U

InDocument manager: Add to
Master Drawing Catalog

Ctrl+M

In Document manager: Revision
handling

Ctrl+R

In Master Drawing Catalog: Select all Ctrl+A
In Master Drawing Catalog: Create
drawings for all parts

Alt+A

In Master Drawing Catalog: Create
drawings

Alt+C

Set UCS origin U
Set UCS by two points Shift+U
Toggle orientation Ctrl+T
Reset current Ctrl+1
Reset all Ctrl+0

5.10 How to use dialog boxes
You can use dialog boxes to view and modify the properties of various objects
in Tekla Structures. Typically dialog boxes open when you double-click an
object in the model or in the drawing.

NOTE Model object properties, such as part properties, are modified with property
pane, not with dialog boxes.

Learn the common dialog box buttons

The following table lists some common buttons that can be found in the Tekla
Structures dialog boxes.
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Button Description
Saves the properties and closes the dialog box. Tekla
Structures uses these properties the next time you create an
object of this type.
Saves the properties without closing the dialog box. Tekla
Structures uses these properties the next time you create an
object of this type.
Modifies the selected objects using the current properties of
the dialog box.
Fills the dialog box with the properties of the selected object.
If several objects are being selected, Tekla Structures takes
the properties randomly from one of them.
Switches all check boxes in the dialog box on and off.

Closes the dialog box without saving the properties or
modifying objects.
Saves the properties in the file shown in the list.

Loads the previously saved properties to the dialog box.
Tekla Structures also loads the properties of sub-dialog
boxes, even if they are not open. Select the name of the
properties file you want to use.

For more information, see Save and load properties.
Saves the properties with the name given in the box. The
Save as button also updates the Load list. This is important
if you add or delete files manually.

Tekla Structures stores the properties files in the model
folder, also including the properties of sub-dialog boxes.

For more information, see Save and load properties.

Modify object properties using dialog boxes

1. Double-click an object to open the properties dialog box.

2. To indicate which properties should be changed, select or clear the
desired check boxes.

For example, if you want some part marks to share the same name but do
not want to change any of their other individual properties, ensure that
only the Name check box is selected.

TIP Click  to switch all check boxes on or off.

3. Modify the properties as needed.

4. Select the objects you want to modify.

Get familiar with the user interface 60 How to use dialog boxes



5. Click Modify.

Tekla Structures changes the properties whose check boxes you selected.

5.11 Change the language
You can change the language of the Tekla Structures user interface at any
time.

1. On the File menu, click Settings --> Change language.

2. Select a language from the list. 

You have the following options. The three-letter language codes that are
given in parentheses are used in some language-dependent file and folder
names.

• Chinese – simplified (chs)

• Chinese – traditional (cht)

• Czech (csy)

• Dutch (nld)

• English (enu)

• French (fra)

• German (deu)

• Hungarian (hun)

• Italian (ita)

• Japanese (jpn)

• Korean (kor)

• Polish (plk)

• Portuguese (ptg)

• Portuguese – Brazilian (ptb)

• Russian (rus)

• Spanish (esp)

3. Click OK.

4. Restart Tekla Structures for the change to take effect.
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5.12 Take screenshots
A screenshot is an image of a model or drawing view. You can use screenshots
in posters, brochures, or other material to show projects carried out using
Tekla Structures.

By default, the screenshots are saved in the \screenshots folder under the
current model folder with the name snap_xx.png.

Take a screenshot of a model
You can take screenshots of model views.

1. Open a model and adjust the model view according to your needs. 

For example, hide the work area box if you do not want to show it.

2. On the View tab, click  Screenshot --> Screenshot.

3. If you have multiple views of the model, click Pick view and select the
view to take the screenshot from.

4. To modify the settings, click Options.

a. Define the width, height, and DPI of the screenshot.

b. Click OK to save the changes.

5. Define a name and location for the screenshot.

a. Select Print to file and enter a descriptive name for the screenshot in
the File name box. 

You can also change the whole path. If you do not want to do this, you
can keep the default values for the path and the file name.

6. Click Show with associated viewer to show the screenshot in an
application that is by default associated with this file type.

7. Click Capture.

Take a screenshot of a drawing
A drawing screenshot is an image of an open drawing with or without borders.

1. Open a drawing and adjust the drawing view according to your needs. 

For example, delete unnecessary marks or dimensions, and hide
unnecessary parts.

2. On the Views tab, click  Screenshot --> Screenshot.

3. Do one of the following: 
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• Select View to take a screenshot of the open drawing with window
borders

• Select View without borders to take a screenshot of the open drawing
without window borders.

4. Under the preselected Print to file option enter a descriptive name for
the screenshot in the File name box. 

You can also change the whole path. If you do not want to do this, you can
keep the default values for the path and the file name.

5. Click Show with associated viewer to show the screenshot in an
application that is by default associated with this file type.

6. Click Capture.

Save a screenshot in bitmap format
By default, screenshots are created as Portable Network Graphics (.png) files.
You can also save a screenshot in bitmap (.bmp) format to use it, for example,
as a custom component thumbnail. Note that the bitmap file size is much
larger than when saving as PNG.

1. On the Views tab, click  Screenshot --> Screenshot.

2. Select Place on clipboard.

3. Click Capture.

4. Paste the screenshot in your graphics editor and save it in .bmp format.

NOTE The software that you use to open the screenshot may have a limit for the
number of pixels.

Screenshot settings
Use the Screenshot dialog box to view and modify the screenshot settings.

The following options are available in model views and in drawings.

Option Description
View name Shows the selected view name.
View Includes the view content and window

borders in the screenshot.

Not available in model views.
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Option Description
View without borders Includes only the view content in the

screenshot.

Not available in model views.
Rendered view For high resolution screenshots from

model views. The Options button
displays the Screenshot Options
dialog box.

Not available in drawings.
Place on clipboard Places the screenshot on the

clipboard.

Not available in drawings.
Print to file Saves the screenshot to a file.

The following screenshot options are only available in model views:

Option Description
Final width The width of the screenshot.

The units depend on the settings in
File menu --> Settings --> Options --
> Units and decimals .

Final height The height of the screenshot.

The units depend on the settings in
File menu --> Settings --> Options --
> Units and decimals .

DPI The pixel density (DPI) of the
screenshot.

There are limitations to pixel density.
You can change the DPI using a
graphics editor.

White background Uses white background.
Smooth lines Uses smooth lines to decrease jagged

edges.
Line width Sets the line width.
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6 Contact Tekla Structures
support (Support tool)

The Support tool allows you to contact Tekla Structures support directly. With
this tool you can collect the model, related files, and other necessary
information in one support request, and safely upload your request to Tekla
Structures support.

The Support tool:

• Automatically identifies the open model and includes all files or selected
files according to your selection from the model folder as attachments to
your request. Some logs and files in other folders are also attached, such
as the user feedback log, Tekla Structures logs and user-defined attribute
files.

• Automatically gathers application and system information.

• Uploads the problem description, attached model, attached files, and all
other gathered information to Tekla Structures support.

NOTE Confidentiality information

All files you upload are treated as confidential. Only the recipient can access
the files.

6.1 Create a support request
1. On the File menu, click Help --> Contact Tekla support . 

If you are having problems in opening Tekla Structures, you can use the
Start menu/Start screen to start the Support tool. The command to use
is Support tool.

2. Log in using your Trimble Identity. 

The Support tool opens and automatically fills in user, application and
Tekla Structures version information. Support tool reads your name, email
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address, company name and support email address from your Trimble
Identity profile.

You can switch to another account by clicking Switch user.

3. Select a category from the list of predefined categories, or select Other
and enter the category.

4. Enter the problem description.

5. Click Next.

6. Select what you want to attach. The file name, file group, file size, and file
location are mentioned for each file. 

• Select the All check box, or select specific files from the Select the
files list.

• If you want to send some other attachments than shown in the Select
the files list, click the Add extra files button and browse for the files.

• To add crash dumps, click Add crash dumps.

7. Click Next. 

The Support tool creates the package and shows the total attachment
size. You can also check application information and operating system
information before finalizing the support case creation.

8. Click Create case to upload your case to Tekla Structures support.

While you create the support case, the navigating back button in the upper-left
corner is disabled for a moment so that you cannot accidentally interrupt the
upload.

When the upload is complete, you will receive a notification at your email
address. After a successful upload, an automatic confirmation message will be
sent to you, and then Tekla Structures support will start solving your case.
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7 Disclaimer

© 2019 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced
Software. Use of the Software, and use of this Software Manual are governed
by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other
warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the Software.
All information set forth in this manual is provided with the warranty set forth
in the License Agreement. Please refer to the License Agreement for important
obligations and applicable limitations and restrictions on your rights. Trimble
does not guarantee that the text is free of technical inaccuracies or
typographical errors. Trimble reserves the right to make changes and
additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by
international treaties. Unauthorized reproduction, display, modification, or
distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve,
Fastrak and Orion are either registered trademarks or trademarks of Trimble
Solutions Corporation in the European Union, the United States, and/or other
countries. More about Trimble Solutions trademarks: http://www.tekla.com/
tekla-trademarks. Trimble is a registered trademark or trademark of Trimble
Inc. in the European Union, in the United States and/or other countries. More
about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other
product and company names mentioned in this Manual are or may be
trademarks of their respective owners. By referring to a third-party product or
brand, Trimble does not intend to suggest an affiliation with or endorsement
by such third party and disclaims any such affiliation or endorsement, except
where otherwise expressly stated.

Portions of this software:

D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights
reserved.
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EPM toolkit © 1995-2006 Jotne EPM Technology a.s., Oslo, Norway. All rights
reserved.

Open Cascade Express Mesh © 2015 OPEN CASCADE S.A.S. All rights reserved.

PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

Teigha © 2002-2016 Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

FlexNet Publisher © 2014 Flexera Software LLC. All rights reserved.

This product contains proprietary and confidential technology, information
and creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission of
such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited.
Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or
rights under any Flexera Software LLC intellectual property rights, whether by
estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures,
click File menu --> Help --> About Tekla Structures and then click the 3rd
party licenses option.

The elements of the software described in this Manual are protected by
several patents and possibly pending patent applications in the United States
and/or other countries. For more information go to page http://
www.tekla.com/tekla-patents.
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