Hallo!

Wussten Sie, dass angemeldete Benutzer viel mehr Inhalte sehen können?

Umgebungs-, Firmen- und Projekteinstellungen für Administratoren

Hinzugefügt April 2, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Softwareversion: 
2019

Umgebungs-, Firmen- und Projekteinstellungen für Administratoren

Umgebungs-, Firmen- und Projekteinstellungen für Administratoren

Umgebungseinstellungen

Allgemeine Einstellungen

Alle Einstellungen und Dateien, die in allen Umgebungen gleich sind, befinden sich im Ordner \Tekla Structures\<Version>\Environments\common. Dateien und Einstellungen, die für eine bestimmte Umgebung gedacht sind, befinden sich in separaten Umgebungsordnern.

Die Datei env_global_default.ini befindet sich auch im Ordner \common. Die Datei bestimmt die Standardeinstellungen, und sie ist die erste Datei, die gelesen wird. Weitere Initialisierungsdateien werden nach dieser Datei gelesen, und wenn die anderen Dateien dieselben Einstellungen enthalten, sind die Einstellungen letzterer Dateien untergeordnet.

Landesspezifische Einstellungen

Die landesspezifischen Einstellungen befinden sich in den Umgebungsordnern und werden von Ihrem lokalen Trimble Büro/Händler vor Ort lokalisiert. Die Ordnerstruktur der Umgebungen kann variieren, jedoch liegen Einstellungen derselben Art vor. Zum Beispiel umfassen die Einstellungen, die geladen werden, die Profildatenbank, die Materialdatenbank, Listen, Selektionsfilter, Ansichtsfilter, Komponenten und benutzerdefinierte Komponenten, Makros, benutzerdefinierte Attribute und Zeichnungseinstellungen.

Firmeneinstellungen

Einstellungen auf Firmenebene sind hauptsächlich Einstellungen, die in der Firma für alle Projekte verwendet werden. Diese Einstellungen werden mit XS_SYSTEM und XS_FIRM festgelegt.

Für eine größere Firma mit Niederlassungen könnten die Einstellungen wie folgt verwendet werden:

  • XS_SYSTEM könnte mehrere Pfade enthalten und auf die allgemeinen Einstellungen innerhalb der Firma verweisen. Diese können beispielsweise ein Firmenlogo, Listen, Druckereinstellungen, Zeichnungseinstellungen oder Vorlagen sein. Dies sind Einstellungen, die sehr selten geändert werden, und auf einem Server für alle Benutzer zugänglich sind. Wenn beispielsweise das Firmenlogo aktualisiert wird, muss es nur an einem Ort ersetzt werden.
  • XS_FIRM verweist auf den Firmen Ordner, der von der Firma oder einer Niederlassung eingerichtet wurde. Der Ordner enthält alle Firmeneinstellungen, die im entsprechenden Büro verwendet werden. Diese können beispielsweise Logos, Zeichnungseinstellungen, Vorlagen oder Druckereinstellungen sein.
  • XS_PROJECT verweist auf den Projekt Ordner. Der Ordner enthält Projekteinstellungen, wie beispielsweise Logos für Auftraggeber und Hersteller oder Zeichnungseinstellungen.

Weitere Informationen zur Ordnersuchreihenfolge finden Sie unter Ordnersuchreihenfolge.

Sie können die firmenspezifischen Sammlungen in Tekla Warehouse auch online oder offline in Ihrem eigenen Netzwerk verwenden. Verwenden Sie Trimble Identity für das Herunterladen oder Installieren aus den Online-Sammlungen. Siehe auch Trimble Identity für Tekla Online services.

Der Zugriff auf die Online-Sammlung wird mit Ordnerrechten in Ihrem Netzwerk verwaltet, und auf der Sammlungsebene in der Datei collections.json auf dem Computer jedes Benutzers.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

Die Datei collections.json kann mit ausgewählten Personen geteilt werden, indem sie in den Ordner C:\Users\Public\Documents\Tekla\Tekla Warehouse\ kopiert wird.

Modellvorlagen

Sie können ein Modell mit den gewünschten Einstellungen speichern und das Modell als Vorlage beim Anlegen neuer Modelle verwenden. Dies kann sehr nützlich sein, wenn Ihr Unternehmen verschiedene Arten von Projekten durchführt, wie beispielsweise Parkhäuser, Bürogebäude, Brücken und industrielle Einrichtungen.

Wenn Sie eine Modellvorlage erstellen, beginnen Sie stets, indem Sie ein neues leeres Modell erstellen. Der Grund dafür ist, dass alte Modelle, die in echten Projekten verwendet wurden, nicht vollständig bereinigt werden können. Sie enthalten möglicherweise überschüssige Daten, die das Modell vergrößern – selbst, wenn Sie alle Objekte und Zeichnungen im Modell löschen.

Eine neue Modellvorlage erstellen:

  1. Erstellen Sie ein neues Modell und geben Sie diesem einen eindeutigen Namen.
  2. Fügen Sie im Modell die gewünschten Profile, benutzerdefinierte Komponenten und andere erforderliche Elemente hinzu.
  3. Klicken Sie im Menü Datei auf Speichern unter > Save .

    Sie müssen das Modell speichern, um benutzerdefinierte Komponenten in die Datei xslib.db1 einzubeziehen. Wenn Sie das Modell nicht speichern, werden benutzerdefinierte Komponenten nicht in die Modellvorlage einbezogen.

  4. Klicken Sie im Menü Datei auf Speichern unter > Als Modellvorlage speichern .
  5. Geben Sie einen Namen für die Modellvorlage ein, und legen Sie fest, welche Kataloge, Zeichnungsvorlagen, Listenvorlagen und Modellunterordner die Modellvorlage enthalten soll.
  6. Klicken Sie auf OK.

    Der Modellvorlagenordner ist standardmäßig ein Unterordner des Umgebungsordners ..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\. Der genaue Speicherort variiert möglicherweise abhängig von Ihrer Umgebung und Rolle. Mit der erweiterten Option XS_​MODEL_​TEMPLATE_​DIRECTORY können Sie einen anderen Speicherort festlegen.

Sie können Modellvorlagen über Tekla Warehouse herunterladen, freigeben und speichern. Die folgende Abbildung zeigt ein Beispiel für eine Modellvorlage in Tekla Warehouse.

Die Schaltfläche In Modell einfügen in Tekla Warehouse installiert die Modellvorlage direkt in dem Ordner, auf den durch XS_MODEL_TEMPLATE_DIRECTORY verwiesen wird. Sie können die Vorlage sofort verwenden, wenn Sie ein neues Modell erstellen.

Modellvorlagen in der Tekla Structures-Versionsaktualisierung

Es wird dringend empfohlen, dass Sie Ihre Modellvorlagen im Tekla Structures -Versionsupgrade aktualisieren.

So aktualisieren Sie Modellvorlagen:

  1. Erstellen Sie ein neues Modell mithilfe einer vorhandenen Modellvorlage.
  2. Geben Sie dem Modell den gleichen Namen wie in der vorherigen Version von Tekla Structures.
  3. Öffnen Sie eine 3D-Ansicht.
  4. Klicken Sie im Menü Datei auf Diagnose and repair > Diagnose model .
  5. Klicken Sie auf der Registerkarte View auf Screenshot > Project thumbnail , um eine Projekt-Miniaturansicht zu erstellen, oder fügen Sie ein benutzerdefiniertes Bild namens thumbnail.png zum Modellordner hinzu.

    Die bevorzugte Größe des Bilds beträgt 120 x 74 Pixel.

  6. Klicken Sie im Menü Datei auf Speichern unter > Save .

    Wenn Sie dies nicht tun, wird eventuell eine Meldung angezeigt, die davor warnt, dass das Modell mit einer Vorgängerversion erstellt wird.

  7. Klicken Sie im Menü Datei auf Speichern unter > Als Modellvorlage speichern .
  8. Wählen Sie die Kataloge, Zeichnungsvorlagen, Listenvorlagen und Modellunterordner aus, die in die Modellvorlage einbezogen werden sollen.
  9. Klicken Sie auf OK.
  10. Entfernen Sie von Hand alle *.db -Dateien (Umgebungsdatenbank, Optionsdatenbankdateien) aus dem Modellordner.

    Die *.bak -, *.log - und xs_user -Dateien werden automatisch aus dem Modellordner entfernt.

    Die .idrm -Dateien ( db.idrm und xslib.idrm ) dürfen NICHT entfernt werden; sie sind Teil des Modells.

    Der Speicherort für die Modellvorlage wird über XS_MODEL_TEMPLATE_DIRECTORY definiert.

    Sie haben jetzt ein Beispielbild für die Modellvorlage. Der Katalog Anwendungen und Komponenten sollte nun ebenfalls einwandfrei funktionieren und einfach zu nutzen sein.

Listen und Zeichnungen anpassen

Wenn Ihre Firma bereits grafische Vorlagen im DXF-, DWG- oder DGN-Format besitzt, können Sie diese Vorlagen zu Tekla Structures Vorlagen konvertieren. Detaillierte Anweisungen hierzu finden Sie in den Informationen über AutoCAD und Microstation Dateien in der Hilfe des Vorlagen-Editors.

Weitere Informationen dazu, wie Sie eigene Vorlagen und Berichte erstellen, finden Sie in der Hilfe des Vorlagen-Editors und Berichte sowie Vorlagen.

Klonvorlagen für Zeichnungen

Sie sollten in Erwägung ziehen, Zeichnungen zu klonen, wenn:

  • es mehrere gleiche Teile, Baugruppen oder Bauteile im Modell gibt.
  • Sie müssen Einzelteil-, Zusammenbau- oder Bauteilzeichnungen von ähnlichen Teilen, Baugruppen oder Bauteilen erzeugen.
  • Die Zeichnungen erfordern einen großen Aufwand an manueller Bearbeitung.

Zum Beispiel können Sie eine Zeichnung für eine Fachwerkkonstruktion erzeugen, die Zeichnung ändern und für andere ähnliche Fachwerkkonstruktionen klonen. Anschließend brauchen Sie nur die geklonten Zeichnungen an den Stellen zu ändern, an denen die Fachwerkkonstruktionen Unterschiede aufweisen.

Die geklonte Zeichnung enthält möglicherweise mehr Teile als die Originalzeichnung. Teileigenschaften, Bezeichnungen, assoziative Texte und verknüpfte Textobjekte werden von einem ähnlichen Teil in der Originalzeichnung geklont.

Klonvorlagen im Master-Zeichnungskatalog

Sie können Zeichnungen klonen, indem Sie die Vorlagen im Master-Zeichnungskatalog verwenden. Eine Klonvorlage im Master-Zeichnungskatalog kann auch in anderen Modellen verwendet werden. Sie können in Projekten verwendet werden, die die gleichen Zeichnungsarten enthalten.

So erstellen Sie Klonvorlagen:

  1. Wählen Sie eine Zeichnung im Dokument-Manager aus.
  2. Rechtsklicken Sie auf Zu Master-Zeichnungskatalog hinzufügen , und geben Sie anschließend die erforderlichen Eigenschaften an.

Die Klonvorlage kann unter Klonvorlagen im Master-Zeichnungskatalog gefunden werden. Um Klonvorlagen anderer Modelle zu verwenden, öffnen Sie den Master-Zeichnungskatalog im Modell, klicken Sie auf die Schaltfläche auf der Werkzeugleiste und fügen Sie das Modell ein, in dem die Vorlagen gespeichert sind.

Weitere Informationen über den Master-Zeichnungskatalog und Klonvorlagen finden Sie unter Zeichnungen im Master-Zeichnungskatalog erstellen.

Projekteinstellungen

Erstellen Sie Ihren eigenen Komponentenordner

In der Regel werden nur wenige verschiedene Verbindungen und Komponenten in einem Projekt verwendet. Um zu gewährleisten, dass jeder im Projekt dieselben Komponenten verwendet und die Komponenten schneller findet, empfehlen wir, einen eigenen Komponentenordner zu erstellen.

  1. Klicken Sie auf die Schaltfläche Anwendungen und Komponenten im Seitenbereich, um den Katalog Anwendungen und Komponenten zu öffnen.
  2. Erstellen Sie eine neue Gruppe für das Projekt: Rechtsklicken Sie in den Katalog und wählen Sie Neue Gruppe aus.
  3. Hinzufügen von Komponenten zur Gruppe: Wählen Sie die Komponenten im Katalog aus, klicken Sie mit der rechten Maustaste und wählen Sie Zu Gruppe hinzufügen aus. Wählen Sie die Gruppe aus, zu der die Komponenten hinzugefügt werden sollen. Sie können die ausgewählten Komponenten auch in eine andere Gruppe ziehen.
  4. Nicht benötigte Gruppen ausblenden: Wählen Sie die Gruppe aus, klicken Sie mit der rechten Maustaste und wählen Sie Ein/Ausblenden aus.
Tip:

Verwenden Sie im Katalog Anwendungen und Komponenten die Befehle unter Auf erweiterte Funktionen zugreifen > Katalogmanagement , um Katalogdefinitionen zu ändern. Weitere Informationen finden Sie unter Anpassen des Katalogs Anwendungen und Komponenten und XS_​COMPONENT_​CATALOG_​ALLOW_​SYSTEM_​EDIT.

Weitere Informationen zum Katalog Anwendungen und Komponenten finden Sie unter Verwendung des Katalogs Anwendungen und Komponenten.

Definieren Sie Auftragsdaten

Projekt-Informationen wird mehrfach während eines Projekts benötigt. Definieren Sie die Auftragsdaten zu Beginn eines Auftrags, damit in Listen und Zeichnungen automatisch die richtigen Informationen angezeigt werden. Sie können die Auftragsdaten auch während des Projekts aktualisieren.

  1. Klicken Sie im Menü Datei auf Projekteigenschaften.
  2. Bearbeiten Sie die Auftragsdaten.

    Beim Bearbeiten der Eigenschaften hebt Tekla Structures die geänderten Eigenschaften gelb hervor.

  3. Sobald Sie bereit sind, klicken Sie zum Anwenden der Änderungen auf Ändern.

Erstellen und ändern Sie Vorlagen und Listen

Sie können vorhandene Listen und Vorlagen ändern oder Ihre eigenen Vorlagen erstellen, indem Sie den Vorlagen-Editor verwenden. Um den Vorlagen-Editor zu öffnen, klicken Sie auf Datei > Editoren > Vorlagen-Editor , oder doppelklicken Sie auf eine bestehende Tabelle in einer geöffneten Zeichnung, um das Werkzeug zu öffnen. Weitere Informationen finden Sie unter Template Editor User's Guide.

Falls die Vorlagen in einem geschützten Ordner abgelegt sind, sind die Vorlagen schreibgeschützt, und es kann keine geänderte Vorlage in einem geschützten Ordner gespeichert werden. Führen Sie Tekla Structures in diesem Fall als Administrator aus.

Drucker einrichten

Tekla Structures verwendet Windows-Treiber, um die Druckdaten direkt zur Windows-Druckerschnittstelle zu senden. Sie können eine PDF-Version von Zeichnungen drucken , sie als Plotdateien ( .plt ) für das Drucken über einen Drucker/Plotter speichern oder sie über einen ausgewählten Drucker ausdrucken. Um auf verschiedenen Papiergrößen zu drucken, müssen Sie die Datei drawingsizes.dat ändern. Näheres erfahren Sie unter Konfigurationsdateien für die Druckausgabe. Sie können auch die Linienstärke der gedruckten Zeichnungen ändern. Näheres erfahren Sie unter Druckausgabe in eine .pdf-Datei, eine Plotdatei (.plt) oder auf einen Drucker vornehmen und Linienstärke in Zeichnungen.

Mit bestimmten, zeichnungsspezifischen erweiterten Optionen können Sie beeinflussen, wie Tekla Structures .pdf -Dateien und Plotdateien automatisch benennt. Näheres erfahren Sie unter Druckausgabedateinamen anpassen.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Inhaltsbewertung: 
Noch keine Bewertungen vorhanden