Hallo!

Wussten Sie, dass angemeldete Benutzer viel mehr Inhalte sehen können?

Exportieren einer Zeichnung in eine 2D-DWG- oder -DXF-Datei

Hinzugefügt April 2, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Softwareversion: 
2019

Exportieren einer Zeichnung in eine 2D-DWG- oder -DXF-Datei

Exportieren einer Zeichnung in eine 2D-DWG- oder -DXF-Datei

Sie können Zeichnungen aus Tekla Structures in die Formate 2D-DWG und 2D-DXF exportieren. Sie können mehrere Zeichnungen gleichzeitig exportieren.

Der DWG/DXF-Export arbeitet auf Objektbasis. Wenn Sie beispielsweise ein rechteckiges Teil exportieren, das mithilfe von verdeckten Linien gezeichnet ist, ist das Ergebnis ein rechteckiges Objekt, das mit einer gestrichelten Linie gezeichnet wird. Im alten linienbasierten DWG-Export besteht das Ergebnis aus mehreren kurzen Geraden. Schraffuren werden als Schraffurobjekte in CAD exportiert, nicht als separate Linien.

Im DWG/DXF-Zeichnungsexport haben Sie folgende Möglichkeiten:

  • z. B. Einrichten von Layern für verschiedene Objekte und Trennen der Bezeichnungsrahmen von dem Bezeichnungstext und den Führungslinien
  • Trennen verschiedener Teile voneinander mithilfe von Filtern
  • Verwenden von Layern, die mithilfe von Standard-CAD-Layer-Einstellungen vordefiniert wurden
  • Verwenden von Basispunkten und Modellkoordinaten
  • Einbetten von Bildern in die Exportdatei, sodass die Bilder nicht mehr als Links exportiert werden

Starten des DWG/DXF-Exports

  1. Starten Sie den Export auf eine der folgenden Arten:

    • Klicken Sie im Menü Datei auf Exportieren > Zeichnungen , und wählen Sie die Zeichnungen aus dem angezeigten Dokument-Manager aus.
    • Klicken Sie auf Zeichnungen & Listen > Dokument-Manager , wählen Sie die zu exportierenden Zeichnungen im Dokument-Manager aus, und klicken Sie dann im Menü Datei auf Exportieren > Zeichnungen .
    • Klicken Sie auf Zeichnungen & Listen > Dokument-Manager , wählen Sie die zu exportierenden Zeichnungen im Dokument-Manager aus, und wählen Sie im Kontextmenü (Rechtsklick) Exportieren aus. Beachten Sie, dass dieser Befehl nicht verfügbar ist, wenn Sie den Dokument-Manager im Zeichnungsmodus öffnen.
    • Klicken Sie in einer geöffneten Zeichnung im Menü Datei auf Zeichnungen exportieren.

  2. Klicken Sie auf Vorschau öffnen , um das Vorschaufenster anzuzeigen, in dem Sie die Zeichnung auch ändern können, wenn Sie viele Zeichnungen für den Export ausgewählt haben. Um die Vorschau zum ersten Mal anzuzeigen, klicken Sie auf Vorschau aktualisieren. Sie können die Vorschau erneut aktualisieren, indem Sie auf Vorschau aktualisieren klicken. Die Vorschau wird nicht automatisch aktualisiert, da dies eine längere Zeit dauern kann.

Definieren von Exporteinstellungen für und Exportieren von DWG/DXF-Dateien

  1. In der Liste Speichern können Sie zuvor gespeicherte oder vordefinierte Exporteinstellungen laden. Wenn Sie geänderten Einstellungen für die zukünftige Verwendung unter einem anderen Namen speichern möchten, geben Sie einen Namen für die neue Einstellungsdatei ein, und klicken Sie auf Speichern.
  2. Definieren Sie in Dateipfad den Speicherort für die exportierten DWG-Dateien. Standardmäßig werden die Dateien in den Unterordner \PlotFiles des aktuellen Modellordners exportiert. Ordner nach Abschluss öffnen öffnet den Exportordner nach dem Exportieren. Sie können den relativen Dateipfad mithilfe von .\ vor dem Ausgabeordnernamen verwenden. Der angegebene Ausgabeordner wird in den Einstellungen gespeichert.
  3. Wählen Sie aus der Liste Dateityp einen der Einträge DWG oder DXF aus.
  4. Wählen Sie die für den Export zu verwendende DWG-Version aus. Es werden mehrere AutoCAD- oder DXF-Formate angeboten. Der Standardwert lautet 2010.
  5. Definieren Sie ggf. weitere Einstellungen auf der Registerkarte Optionen :

    Modellraumkoordinaten

    Wählen Sie eine der folgenden Optionen:

    • Lokal : Exportiert die Zeichnung in den Punkt 0 im CAD-Koordinatensystem. Diese Option verwendet die linke untere Ecke des ersten Ansichtsrahmens, um die lokalen Koordinaten festzulegen. Wenn der Rahmen erweitert wird, bewegt sich auch die Position.
    • Modell : Verschiebt den Nullpunkt in Tekla Structures auf den CAD-Nullpunkt und dreht das CAD-Koordinatensystem in X- und Y-Koordinaten entsprechend. Z-Koordinaten werden nicht unterstützt.
    • Basispunkt : <Name_des_Basispunkts> : Verschiebt den ausgewählten Basispunkt auf den CAD-Nullpunkt und dreht das CAD-Koordinatensystem entsprechend. Die Basispunkte werden im Tekla Structures-Modell mittels Datei > Projekteigenschaften > Basispunkte definiert.

      Z-Koordinaten werden nicht unterstützt.

    Dateipräfix

    Dateisuffix

    Geben Sie ein bestimmtes Präfix oder Suffix für den Dateinamen an. Die Vorschau des Dateinamens ändert sich entsprechend.

    Der DWG-Export unterstützt die folgenden zeichnungsspezifischen erweiterten Optionen, die Sie verwenden können, um den Namen der exportierten Datei zu ändern:

    XS_DRAWING_PLOT_FILE_NAME_A

    XS_DRAWING_PLOT_FILE_NAME_C

    XS_DRAWING_PLOT_FILE_NAME_G

    XS_DRAWING_PLOT_FILE_NAME_M

    XS_DRAWING_PLOT_FILE_NAME_W

    Weitere Informationen über die Werte, die Sie für diesen Optionen angeben können, finden Sie unter Druckausgabedateinamen anpassen.

    Bilder in Datei einbetten

    Bettet alle Bilder in die Exportdatei ein. Es werden keine zusätzlichen Bilddateien beim Export erstellt.

    Zeichnung als Schnappschuss an CAD-Modellraum

    Exportiert alle eingeschlossenen Objekte in den Modell- und Papierbereich einer CAD-Datei. Modell- und globale Koordinaten sowie der Papierbereichsschalter in den Layer-Einstellungen werden ignoriert.

    Hinweis: Wenn die Zeichnung verknüpfte oder kopierte Ansichten enthält und Zeichnung als Schnappschuss an CAD-Modellraum nicht ausgewählt ist, werden Zeichnungsansichten eventuell übereinander platziert und die Ansichtsgrenzwerte in der resultierenden DWG-Datei sind möglicherweise nicht genau. Dies liegt daran, dass Zeichnungsansichten konzeptionell nicht identisch mit den Ansichten im Papierbereich im DWG-Format sind.

    Wenn Sie geraffte Ansichten in der Zeichnung nutzen und die Objekte im Maßstab 1:1 platziert werden, werden die Enden gestreckt, um zur tatsächlichen Größe des Teils zu passen. Mit Zeichnung als Schnappschuss an CAD-Modellraum vermeiden Sie das Strecken der gerafften Ansicht im CAD-Modellraum. Der Zeichnungsraum in einem CAD-Programm behält die Ansichtsraffung stets bei.

    Maßstab

    Legen Sie den Maßstab für die exportierte DWG fest. Diese Option steht nur zur Verfügung, wenn das Kontrollkästchen Zeichnung als Schnappschuss an CAD-Modellraum aktiviert ist.

    Wenn die Zeichnung zum Beispiel zwischen den Koordinaten 0,0 und 800 liegt, und Sie einen Maßstabswert von 5 festlegen, ist die resultierende DWG-Zeichnung fünfmal größer, sodass sie zwischen den Koordinaten 0,0 und 4000 liegt.

    Und wenn Sie den Maßstab der Zeichnungsansicht in Tekla Structures auf 1:50 eingestellt haben, und die Zeichnung im Maßstab 1:1 exportieren möchten, führt ein Maßstabswert von 50 für den Export zum gewünschten Ergebnis.

    Wenn Sie die erweiterte Option XS_EXPORT_DRAWING_TRY_TO_KEEP_LOCATION auf TRUE einstellen, versucht Tekla Structures , den DWG-Ursprung in derselben Position wie den Ursprung der Zeichnungsansicht beizubehalten. Das ist nur für Planansichten und Höhenansichten möglich. Wenn die Zeichnung mehr als eine Plan- oder Höhenansicht enthält, platziert Tekla Structures den DWG-Ursprung in der linken unteren Ecke des Zeichnungsrahmens.

    Gruppierung von Objekten in Blöcken aufheben

    Exportiert grafische Objekte als einzelne Objekte; Objekte werden keinen Blöcken hinzugefügt. Beispielsweise werden aus einer Linie, einer Schraffur und einem Rechteck auch eine Linie, Schraffur und ein Rechteck als DWG-Objekt – kein Block. Wenn diese Option aktiviert ist, wird die Option Nur Linien in Tekla Structures aktualisieren deaktiviert.

    Nur Linien in Tekla Structures aktualisieren

    Aktualisiert den Inhalt der Tekla Structures -Zeichnung und behält andere Inhalte in derselben Datei, die in einer CAD-Software erstellt worden sind, bei. Die Blöcke (Gruppen), die von Tekla Structures erzeugt wurden, werden aktualisiert.

    Diese Einstellung wird nur angezeigt, wenn die erweiterte Option XS_DWG_EXPORT_UPDATE_TS_LINEWORK_OPTION auf TRUE eingestellt ist (in der Kategorie Exportieren im Dialogfeld Erweiterte Optionen ).

    Hinweis: Dieselbe Zeichnung muss bereits zuvor exportiert worden sein und Layer-Einrichtung sowie Layer-Vorlage müssen dem vorherigen Export exakt entsprechen. Alle CAD-Linien, die zuvor hinzugefügt wurden, verbleiben in der Datei; nur Inhalte aus Tekla Structures werden aktualisiert, es sei denn, es wurden Bearbeitungen im CAD-Blockeditor vorgenommen.

    Wichtig: Wenn Sie den Inhalt eines Blocks (CAD-Objekt) bearbeiten und anschließend die Option Nur Linien in Tekla Structures aktualisieren auswählen, wird der gesamte Block neu geschrieben; im CAD vorgenommene Änderungen werden nicht beibehalten. Um die Änderungen im CAD beizubehalten, müssen Sie einen Block auflösen, bevor Sie ihn bearbeiten.

    Sie können diese Einstellung zum Beispiel verwenden, wenn Sie in der CAD-Datei Zeichnungstitelblöcke hinzugefügt haben, nachdem Sie die Zeichnung erstmals aus Tekla Structures exportiert hatten, und diese Titelblöcke in ihrer jetzigen Form beibehalten möchten, während nur die Objekte aktualisiert werden, die Sie aus Tekla Structures exportiert haben.

  6. Auf der Registerkarte Layer Regeln können Sie explizit die Layer definieren, in die verschiedene Modell- und Zeichnungsobjekte oder Teile von Objekten exportiert werden. Beispielsweise können Sie den Umriss von Füllungen und Schraffur separieren.

    Sie können hier auch festlegen, ob die Linienfarbe, der Stil und die Strichstärke aus den Tekla Structures -Einstellungen oder aus den Angaben zu den Ziellayer-Einstellungen einer DWG- oder DXF-Datei übernommen werden. Hinweis: Linienstärke, -stil und -farben aus Tekla Structures bleiben wie in der Tekla Structures -Zeichnung dargestellt erhalten; es gibt keine Möglichkeit, diese nur für den DWG-Export zu ändern.

  7. Verwenden Sie die Liste Ziellayer aus DWG , um nach einer DWG-Vorlagendatei zu suchen und diese zu verwenden. Eine angegebene Vorlage wird für die Layer-Definition verwendet. Die DWG-Vorlage darf keine CAD-Objekte enthalten, sondern nur Layer-Einstellungen – es sei denn, sie enthält Objekte, die in den mit dieser Vorlage exportierten Zeichnungen enthalten sein sollen. Beispielsweise könnten Sie hierfür die DWG-Standarddatei mit allen vordefinierten Layern verwenden.

    Geben Sie .\ gefolgt vom Dateinamen ein, damit Tekla Structures die Datei zunächst in den Modell-, Projekt- und Firmenordnern sucht; anschließend werden die Ordner aus der erweiterten Option XS_DRIVER , dann der Systemordner und abschließend der Ordner mit Benutzereinstellungen durchsucht.

    Der Text DWG-Datei nicht gefunden wird neben der Schaltfläche Durchsuchen... angezeigt, bis eine DWG- oder DXF-Datei gefunden und geladen wird.

    Die Felder für Ziellayer werden kurz gelb eingefärbt, wenn eine neue DWG-Datei aus der Liste Ziellayer aus DWG geladen wird. Wenn die DWG-Datei keine Layer enthält, werden die Felder rot eingefärbt.

  8. Fügen Sie die Regeln hinzu:
    • Sie können eine neue Regel erstellen, indem Sie auf die Schaltfläche Hinzufügen rechts klicken, oder die ausgewählte Regel kopieren, indem Sie auf die Schaltfläche Kopieren klicken. Sie können mehrere Regeln auswählen.
    • Sie können die Regeln durch Anklicken der Schaltflächen Nach oben und Nach unten im Satz verschieben. Sie können mehrere Regeln auswählen.
    • Wenn Sie eine Regel löschen möchten, wählen Sie sie aus, und klicken Sie auf Löschen. Sie können mehrere Regeln gleichzeitig löschen.
  9. Definieren Sie die Regelinhalte:

    Objekte

    Wählen Sie die Objekte aus, die Sie exportieren möchten.

    Beachten Sie, dass einige Objekte wie Nachbarteilbezeichnungen derzeit zu den Bezeichnungen gehören und nicht separat aufgelistet werden. Um diese im Export zu separieren, müssen Sie Objektfilter verwenden und unterschiedliche Bezeichnungsregeln für Teile und Nachbarteile erstellen.

    Um alle in der Liste Objekte fehlenden Elemente einzuschließen, fügen Sie eine Objektregel Alles am Ende der Regelliste hinzu, da Regeln in der angeführten Reihenfolge gelesen werden.

    Zum Exportieren von Betoniereinheiten müssen diese im Modell aktiviert sein; siehe XS_​ENABLE_​POUR_​MANAGEMENT.

    Präsentationsfilter

    Legen Sie fest, welches Teil der Objekte die Regel befolgen soll. Sie können auch Alles auswählen.

    Die Präsentationsfilter -Optionen sind für verschiedene Objekttypen unterschiedlich.

    Sie können nur einen Filter für jede Regel hinzufügen. Um zum Beispiel die Bezeichnungsrahmen vom Bezeichnungstext zu separieren, müssen Sie zwei Regeln für Bezeichnungen erstellen: In der ersten stellen Sie Präsentationsfilter auf Text ein, in der zweiten auf Rahmen. Im Abschnitt Layer-Regel-Beispiel unten finden Sie ein Beispiel.

    Objektfilter

    Liest die Selektionsfilter-Attributdateien, die im aktuellen Modell definiert wurden.

    Beachten Sie, dass diese Dateien nur aus dem aktuellen Modellordner gelesen werden, nicht aus den Firmen- oder Projektordnern.

    Ziellayer

    Wenn Sie keine DWG-Vorlagen haben oder eigene Layer erstellen möchten, geben Sie eine neue Layerbezeichnung im Feld Ziellayer an, oder wählen Sie einen zuvor verwendeten Layer aus der Liste aus.

    Beachten Sie, dass die Layer einer DWG-Vorlage nach dem Hinzufügen dieser Vorlage in der Liste Ziellayer angezeigt werden.

    Die Felder für Ziellayer werden kurz gelb eingefärbt, wenn eine neue DWG-Datei aus der Liste Ziellayer aus DWG geladen wird. Wenn die DWG-Datei keine Layer enthält, werden die Felder rot eingefärbt.

    Farbe

    Linienstil

    Linienstärke

    Definieren Sie, ob Linien aus den Tekla Structures -Einstellungen oder der DWG-Vorlage übernommen werden.

    Papierbereich

    Um Zeichnungsobjekte im Papierbereich einer DWG-Datei korrekt zu zeichnen (und nicht durch das Ansichtsportal), aktivieren Sie das Kontrollkästchen Papierbereich.

    Wenn das Kontrollkästchen nicht aktiviert ist, gibt es nur ein Portal aus dem Modellbereich in den Papierbereich.

    Hinweis: Es wird empfohlen, Zeichnungsanmerkungen wie Bezeichnungen, Bemaßungen und Texte nur im Papierbereich einzufügen. So werden sie korrekt dargestellt, beispielsweise wenn ein Teil in einer Tekla Structures -Zeichnungsansicht geschnitten wird.

    Einschließen

    Um eine Regel in die endgültige DWG einzubinden, aktivieren Sie das Kontrollkästchen Einschließen neben der Regel. Wenn Sie bestimmte Objekte nicht exportieren möchten, deaktivieren Sie das Kontrollkästchen Einschließen.

  10. Öffnen Sie die Vorschau, und klicken Sie auf Vorschau aktualisieren , um vor dem Exportieren eine Ergebnisvorschau anzuzeigen.
  11. Klicken Sie auf Exportieren.

    Die Zeichnungen werden anhand der definierten Einstellungen und Regeln exportiert. Die Regeln werden in der aufgeführten Reihenfolge gelesen. Falls Sie Ordner nach Abschluss öffnen aktiviert haben, wird der Exportordner geöffnet.

    Die Fehlermeldung Zeichnung kann nicht gelesen werden wird angezeigt, wenn die exportierte Zeichnung fehlt, nicht auf dem neuesten Stand ist oder ähnliche Probleme aufweist.

    Wenn Sie auf die Schaltfläche Exportieren klicken, prüft Tekla Structures vor dem Exportvorgang zunächst, ob in die Dateien geschrieben werden kann, und fordert Sie auf, die erforderlichen Anwendungen zu schließen. Es prüft auch, ob die Dateien bereits vorhanden sind, und fragt, ob Sie die vorhandenen Dateien überschreiben möchten.

Layer-Regel-Beispiel

Im folgenden Beispiel wurden drei verschiedene Bezeichnungsregeln erstellt, die in die Layer 1, 2 und 3 exportiert werden. Linien werden in den Layer 1 exportiert, Texte in den Layer 2 und Rahmen in den Layer 3.

Nach dem Exportieren können Sie die Bezeichnungen im CAD-Modell abhängig von den im CAD-Viewer gezeigten Layern auf drei Arten einblenden:

Alle Layer sind sichtbar:

Layer 1 mit den Linien ist ausgeblendet:

Layer 2 mit den Texten ist ausgeblendet:

Layer 3 mit den Rahmen ist ausgeblendet:

Tipps

  • Wenn Sie eine DWG-Datei mit Version der Ausgabedatei 2013 exportieren, wird aufgrund von CAD-Beschränkungen ein Deckrahmen auf der Layoutseite im CAD-Modell angezeigt (siehe unten):

    Um dies zu vermeiden, müssen Sie eine in AutoCAD erstellte DWG-Datei-Layervorlage verwenden oder für den Export die Version 2010 (Standard) oder früher wählen.

  • Ein weiterer Grund für den sichtbaren Deckrahmen ist, dass Sie eine DWG-Vorlage verwenden, in der Deckrahmen auf als sichtbar festgelegt worden sind. Blenden Sie die Deckrahmen in der CAD-Vorlage aus.

Verwenden der alten DWG/DXF-Exportfunktion

Wenn Sie den alten DWG/DXF-Export verwenden möchten, stellen Sie die erweiterte Option XS_USE_OLD_DRAWING_EXPORT auf TRUE ein (in einer .ini -Datei). Diese erweiterte Option ist standardmäßig eingestellt auf FALSE. Anleitungen zur Verwendung der alten Exportfunktion finden Sie unter Exportieren einer Zeichnung in eine 2D-DWG- oder DXF-Datei (alter Export).

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Inhaltsbewertung: 
Noch keine Bewertungen vorhanden