Hallo!

Wussten Sie, dass angemeldete Benutzer viel mehr Inhalte sehen können?

Menüband anpassen

Hinzugefügt April 2, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Softwareversion: 
2019

Menüband anpassen

Menüband anpassen

Sie können das Menüband im Menüband-Editor an Ihre Anforderungen anpassen. Sie können z. B. die Größe und Form von Schaltflächen ändern. Sie können benutzerdefinierte Befehle erstellen oder Ihre Lieblingskomponenten und Erweiterungen zum Menüband hinzufügen, damit sie schnell verfügbar sind.

Um den Menüband-Editor zu öffnen, klicken Sie auf Menü Datei > Einstellungen > Anpassen > Menüband .

Im Menüband-Editor können Sie …

  • neue Schaltflächen zum Menüband hinzufügen
  • vorhandene Schaltflächen auf dem Menüband verschieben
  • die Größe von Schaltflächen auf dem Menüband ändern
  • die Symbole und die Beschriftungen von Schaltflächen ändern
  • nicht benötigte Schaltflächen entfernen
  • neue Befehle erstellen und Schaltflächen dafür hinzufügen
  • Trennlinien zum Menüband hinzufügen
  • neue Registerkarten hinzufügen
Anmerkung:

Im Modellierungsmodus können Sie das Modellierungsmenüband anpassen, indem Sie den Menüband-Editor öffnen.

Im Zeichnungsmodus können Sie das Zeichnungsmenüband anpassen, indem Sie den Menüband-Editor öffnen.

Sie können nur die Menübänder anpassen, die in Ihrer Konfiguration verfügbar sind.

Die benutzerdefinierten Menübänder werden im Ordner ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons gespeichert. Wenn Sie den Ordner nicht finden können, stellen Sie sicher, dass versteckte Dateien und Ordner auf Ihrem Computer angezeigt werden.

Unternehmensadministratoren können benutzerdefinierte Menübänder oder Registerkarten im gesamten Unternehmen verteilen. Das Verfahren entspricht dem für benutzerdefinierte Eigenschaftenbereich-Layouts.

Hinzufügen von Schaltflächen zu Menübändern

Sie können Schaltflächen einfach hinzufügen, indem Sie Schaltflächentyp und Aussehen festlegen und den Befehl anschließend auf das Menüband oder die Symbolleiste für den Schnellzugriff ziehen.

Aktion Methode
Schaltfläche für einen einzelnen Befehl hinzufügen
  1. Wählen Sie aus der Liste Menübandelement hinzufügen den Eintrag Einfache Schaltfläche aus.
  2. Wählen Sie aus der Liste Befehl den Befehl aus, den Sie zum Menüband hinzufügen möchten.

    Sie können auch Komponenten, Makros und Erweiterungen hinzufügen. Scrollen Sie durch die Liste, oder verwenden Sie das Feld Suchen , um den angezeigten Inhalt zu filtern. Geben Sie z. B. Matte ein, um den Befehl Bewehrungsmatte erstellen und andere Komponenten für Matten zu suchen:

  3. In der Liste Aussehen :
    • Wählen Sie aus, ob die Schaltfläche ein Symbol aufweist. Legen Sie die Größe des Symbols fest, oder geben Sie an, dass Sie ein skalierbares Symbol verwenden möchten, oder suchen Sie nach dem Symbolbild.
    • Geben Sie an, ob die Schaltfläche Text enthält.

  4. Prüfen Sie die Schaltfläche in der Vorschau. Ändern Sie ggf. ihr Aussehen.
  5. Ziehen Sie die Schaltfläche auf das Menüband.

    Die blaue Farbe zeigt an, wo die Schaltfläche eingefügt wird.

Umschaltfläche hinzufügen, die einen bestimmten Befehl ein- bzw. ausschaltet

Damit können Sie z. B. beliebige Schalter aus dem Menü Datei > Einstellungen > Schalter zum Menüband hinzufügen. Sie können auch einzelne Fangschalter und Selektionsschalter zum Menüband hinzufügen.

  1. Wählen Sie aus der Liste Menübandelement hinzufügen den Eintrag Optionsschaltfläche aus.
  2. Wählen Sie aus der Liste Befehl einen Befehl aus, der umgeschaltet werden kann.

    Befehle, die umgeschaltet werden können, verfügen über ein Kontrollkästchen.

  3. In der Liste Aussehen :
    • Wählen Sie aus, ob die Schaltfläche ein Symbol aufweist. Legen Sie die Größe des Symbols fest, oder geben Sie an, dass Sie ein skalierbares Symbol verwenden möchten, oder suchen Sie nach dem Symbolbild.
    • Geben Sie an, ob die Schaltfläche Text enthält.
  4. Prüfen Sie die Schaltfläche in der Vorschau. Ändern Sie ggf. ihr Aussehen.
  5. Ziehen Sie die Schaltfläche auf das Menüband.

    Die blaue Farbe zeigt an, wo die Schaltfläche eingefügt wird.

Dropdown-Schaltfläche mit einer Gruppe von Befehlen darunter hinzufügen
  1. Wählen Sie aus der Liste Menübandelement hinzufügen den Eintrag Dropdown-Schaltfläche aus.
  2. In der Liste Aussehen :
    • Wählen Sie aus, ob die Schaltfläche ein Symbol aufweist. Suchen Sie das Symbolbild.
    • Geben Sie an, ob die Schaltfläche Text enthält.
  3. Prüfen Sie die Schaltfläche in der Vorschau. Ändern Sie ggf. ihr Aussehen.
  4. Ziehen Sie die Schaltfläche auf das Menüband.

    Die Schaltfläche ist momentan ein leerer Platzhalter für einzelne Befehle. Sie müssen Befehle zur Dropdown-Schaltfläche hinzufügen, damit diese funktioniert.

    1. Wählen Sie aus der Liste Menübandelement hinzufügen den Eintrag Einfache Schaltfläche aus.
    2. Wählen Sie aus der Liste Befehl den Befehl aus, den Sie zur Dropdown-Liste hinzufügen möchten.
    3. Legen Sie in der Liste Aussehen das Aussehen der Schaltfläche fest.
    4. Ziehen Sie die Schaltfläche auf die Dropdown-Liste.

      Die blaue Farbe zeigt an, wo die Schaltfläche eingefügt wird. Wenn Sie auf einen Abwärtspfeil zeigen, wird eine Liste geöffnet, in der Sie Befehle ablegen können. Die Liste bleibt geöffnet, bis Sie erneut auf den Abwärtspfeil klicken.

    5. Fügen Sie beliebig viele Befehle zur Dropdown-Schaltfläche hinzu.
Schaltfläche für einen einzelnen Befehl und eine Dropdown-Schaltfläche mit einer Gruppe von Befehlen darunter hinzufügen
  1. Wählen Sie aus der Liste Menübandelement hinzufügen den Eintrag Trennschaltfläche aus.
  2. Wählen Sie aus der Liste Befehl den Befehl aus, den Sie als primäre Schaltfläche für die gesamte Trennschaltfläche zum Menüband hinzufügen möchten.
  3. In der Liste Aussehen :
    • Wählen Sie aus, ob die Schaltfläche ein Symbol aufweist. Legen Sie die Größe des Symbols fest, oder geben Sie an, dass Sie ein skalierbares Symbol verwenden möchten, oder suchen Sie nach dem Symbolbild.
    • Geben Sie an, ob die Schaltfläche Text enthält.
  4. Prüfen Sie die Schaltfläche in der Vorschau. Ändern Sie ggf. ihr Aussehen.
  5. Ziehen Sie die Schaltfläche auf das Menüband.

    Die Schaltfläche weist nun einen einzelnen Befehl auf. Sie müssen Befehle zur Dropdown-Liste hinzufügen.

    1. Wählen Sie aus der Liste Menübandelement hinzufügen den Eintrag Einfache Schaltfläche aus.
    2. Wählen Sie aus der Liste Befehl den Befehl aus, den Sie zur Dropdown-Liste hinzufügen möchten.
    3. Legen Sie in der Liste Aussehen das Aussehen der Schaltfläche fest.
    4. Ziehen Sie die Schaltfläche auf die Dropdown-Liste.

      Die blaue Farbe zeigt an, wo die Schaltfläche eingefügt wird. Wenn Sie auf einen Abwärtspfeil zeigen, wird eine Liste geöffnet, in der Sie Befehle ablegen können. Die Liste bleibt geöffnet, bis Sie erneut auf den Abwärtspfeil klicken.

    5. Fügen Sie beliebig viele Befehle zur Dropdown-Schaltfläche hinzu.

Sie können Befehle auch auf der Symbolleiste für den Schnellzugriff ablegen; diese befindet sich über dem Menüband. Auch der unbewegliche Bereich links neben dem Menüband kann als Ablageziel dienen:

Verschieben von Schaltflächen

Sie können Schaltflächen auf dem Menüband neu anordnen. Beachten Sie, dass Dropdown-Schaltflächen nicht untereinander angeordnet werden können.

  1. Wählen Sie die zu verschiebende Schaltfläche aus.

    Die Schaltfläche wird hervorgehoben:

  2. Ziehen Sie die Schaltfläche an eine neue Position.

    Die blaue Farbe zeigt an, wo die Schaltfläche eingefügt wird. Zum Beispiel:

Ändern der Größe von Schaltflächen

Sie können die Größe von vorhandenen Schaltflächen ändern.

  1. Wählen Sie die zu ändernde Schaltfläche aus:

  2. Bewegen Sie den Mauszeiger auf eine Kante oder Ecke der Schaltfläche; ein weißes Pfeilsymbol erscheint:

  3. Ziehen Sie den Pfeil, um eine neue Größe festzulegen:

    Die Größe der Schaltfläche ändert sich entsprechend. Die anderen Schaltflächen werden bei Bedarf automatisch auf dem Menüband nach vorn verschoben.

  4. Doppelklicken Sie auf die Schaltfläche, um sie zu erweitern.

    Die Schaltfläche nutzt nun den umgebenden Leerraum vollständig:

Ändern des Aussehens von Schaltflächen

Sie können das Aussehen jeder Schaltfläche ändern.

  1. Wählen Sie die zu ändernde Schaltfläche aus.
    • Wenn Sie eine neue Schaltfläche hinzufügen: Wählen Sie den Befehl aus der Liste Befehl aus.

      Die aktuellen Eigenschaften der Schaltfläche werden in der Liste Aussehen angezeigt.

    • Wenn die Schaltfläche im Menüband bereits vorhanden ist: Klicken Sie mit der rechten Maustaste auf die Schaltfläche im Menüband.

  2. Diese Optionen dienen zum Ändern des Symbols:
    1. Kein : für die Schaltfläche wird kein Symbol verwendet
    2. Befehl: Großes Symbol : das große Standardsymbol (32×32) wird verwendet
    3. Befehl: Kleines Symbol : das kleine Standardsymbol (16×16) wird verwendet
    4. Befehl: Skalierbares Symbol : Das skalierbare Vektor Symbol wird verwendet.
    5. Galerie (Bitmap) : Wählen Sie ein großes oder kleines Bitmap-Symbol aus der Tekla Structures -Symbolgalerie aus.
    6. Galerie (skalierbar) : Wählen Sie ein skalierbares Symbol aus der Tekla Structures -Symbolgalerie aus.
    7. Benutzerdefiniert : Definieren Sie ein benutzerdefiniertes Symbol, indem Sie eine geeignete Bilddatei auswählen. Die empfohlene Größe beträgt 32×32 Pixel für große Schaltflächen und 16×16 Pixel für kleine Schaltflächen. Wenn das benutzerdefinierte Bild nicht in der erwarteten Größe angezeigt wird, überprüfen Sie die DPI-Einstellung der Bilddatei. Ein DPI-Wert von 96 wird empfohlen.
  3. Diese Optionen dienen zum Ändern des Namens:
    • Kein : für die Schaltfläche wird kein Name verwendet
    • Befehl: Ganzer Text : die Standardvollversion des Namens wird verwendet
    • Befehl: Kurzer Text : die Standardkurzversion des Namens wird verwendet
    • Benutzerdefiniert : für die Schaltfläche muss ein Name angegeben werden

Erstellen von benutzerdefinierten Befehlen im Befehlseditor

Sie können benutzerdefinierte Befehle erstellen und mit beliebigen Dateien oder URLs verknüpfen. Erstellen Sie benutzerdefinierte Befehle mit dem Befehlseditor.

  1. Klicken Sie auf das Menü Datei > Einstellungen > Anpassen > Benutzerdefinierte Befehle , um den Befehlseditor zu öffnen.
  2. Klicken Sie auf Neu.
  3. Geben Sie eine eindeutige ID für den Befehl ein, und klicken Sie auf OK.

    Erstellen Sie zum Beispiel eine Verknüpfung zum Tekla Discussion Forum. Geben Sie als ID des Befehls TeklaDiscussionForumöffnen ein.

    Eine neue Spalte mit weiteren Eigenschaften wird geöffnet.

  4. Geben Sie in den Feldern Komplette Bezeichnung und Kurzbezeichnung einen Namen für den Befehl ein.

    Dieser Name wird in der Benutzeroberfläche von Tekla Structures angezeigt. Sie können zwei Namensalternativen definieren: einen vollen Namen und eine Kurzversion. Geben Sie zum Beispiel als vollen Namen für den Befehl Tekla Discussion Forum ein und als Kurzversion Forum.

  5. Wählen Sie in den Einstellungen Großes Symbol , Kleines Symbol und Skalierbares Symbol ein Symbol für den Befehl aus.

    Sie können drei Symbolalternativen definieren: ein großes und ein kleines oder ein skalierbares Vektorsymbol.

    Sie können ein eigenes Symbol verwenden oder ein geeignetes Symbol aus der Tekla Structures -Symbolgalerie auswählen.

  6. Geben Sie einen Tooltip für den Befehl im Feld Tooltip an.

    Geben Sie zum Beispiel Tekla discussion forum aufrufen ein.

  7. Definieren Sie im Feld Aktion eine Datei oder eine URL.

    Geben Sie zum Beispiel Folgendes ein: https://forum.tekla.com.

  8. Wählen Sie unter Verfügbarkeit den Modus aus, in dem der Befehl verfügbar ist.
  9. Klicken Sie auf Speichern , um den neuen Befehl zu speichern.
  10. Wechseln Sie zum Menüband-Editor.
  11. Wählen Sie den Schaltflächentyp aus.
  12. Suchen Sie in der Liste Befehl den neu erstellten Befehl.
  13. Ändern Sie in der Liste Aussehen ggf. das Aussehen der Schaltfläche.
  14. Ziehen Sie die neue Schaltfläche auf das Menüband.

  15. Um einen benutzerdefinierten Befehl zu ändern, klicken Sie mit der rechten Maustaste auf den Befehl auf dem Menüband, und bearbeiten Sie die Befehlseigenschaften wie für alle anderen Befehle auch.

Trennlinie hinzufügen

Sie können vertikale und horizontale Trennlinien hinzufügen, um Schaltflächen auf dem Menüband in kleinere Gruppen zu unterteilen.

  1. Wählen Sie aus der Liste Menübandelement hinzufügen den Eintrag Trennlinie aus.
  2. Geben Sie in der Liste Aussehen an, ob es sich um eine horizontale oder eine vertikale Trennlinie handeln soll, und legen Sie ihre Stärke fest.

    Prüfen Sie die Trennlinie in der Vorschau.

  3. Ziehen Sie das Vorschauelement auf das Menüband.
  4. Um die Ausrichtung oder die Linienstärke der Linie zu ändern, klicken Sie die Linie auf der Registerkarte mit der rechten Maustaste an, und wählen Sie Ausrichtung oder Dicke aus.
  5. Um die Linie zu löschen, wählen Sie die Linie auf dem Menüband aus und drücken die Taste Entf.

    Sie können die Linie auf dem Menüband auch mit der rechten Maustaste anklicken und Löschen auswählen.

Entfernen von Schaltflächen

  1. Wählen Sie die Schaltfläche auf dem Menüband aus.
  2. Drücken Sie die Taste Entf auf Ihrer Tastatur.

    Sie können die Schaltfläche auf dem Menüband auch mit der rechten Maustaste anklicken und Löschen auswählen.

Registerkarten hinzufügen, ausblenden und bearbeiten

Sie können Registerkarten auf dem Menüband hinzufügen, verschieben und umbenennen, ihre Ausrichtung festlegen und sogar im aktuellen Projekt nicht benötigte Registerkarten ausblenden. Wenn Sie zum Beispiel nur Stahlteile modellieren, können Sie die Registerkarte Beton vorübergehend ausblenden.

Aktion Methode
Neue Registerkarte hinzufügen
  1. Wählen Sie aus der Liste Menübandelement hinzufügen den Eintrag Registerkarte aus.
  2. Geben Sie einen Namen für die Registerkarte im Feld Text an.
  3. Klicken Sie auf Registerkarte hinzufügen , um sie dem Menüband hinzuzufügen.
Reihenfolge der Registerkarten auf dem Menüband ändern Ändern Sie die Reihenfolge per Ziehen und Ablegen (Drag-and-Drop).
Ausrichtung der Registerkarten festlegen Klicken Sie im Menübandbereich mit der rechten Maustaste, und wählen Sie eine der Optionen für den Navigationsmodus aus:
  • Sichtbar scrollen : Die Bewegung des Menübands ist minimal, wenn Sie zwischen den Registerkarten wechseln
  • Links ausrichten : Die Symbole beginnen an der linken Seite des Menübandes
  • An Registerkarte ausrichten : Die Symbole beginnen an der linken Seite der aktuellen Registerkarte
Im aktuellen Projekt nicht benötigte Registerkarten ausblenden
  1. Zeigen Sie mit dem Mauszeiger auf einen Registerkartentitel.

    Ein kleines Augensymbol erscheint neben dem Registerkartentitel:

  2. Klicken Sie auf das Augensymbol.

    Das Augensymbol ändert sich und der Registerkartentitel wird ausgegraut:

Die Registerkarte Ansicht ist nun im Menüband ausgeblendet. Wenn Sie das Menüband schieben, werden ausgeblendete Registerkarten wie folgt dargestellt:

Um die ausgeblendete Registerkarte wieder einzublenden, klicken Sie erneut auf das Augensymbol.

Registerkarte umbenennen Klicken Sie mit der rechten Maustaste auf die Registerkarte, und wählen Sie Umbenennen aus. Geben Sie einen neuen Namen für die Registerkarte ein.
Registerkarte löschen

Wählen Sie die Registerkarte aus, und drücken Sie Entf.

Sie können auch mit der rechten Maustaste auf die Registerkarte klicken und Löschen auswählen.

Menüband speichern

Wenn Sie mit den Änderungen zufrieden sind, speichern Sie das benutzerdefinierte Menüband.

  1. Klicken Sie im Menüband-Editor auf die Schaltfläche Speichern.
  2. Wenn Sie zu Tekla Structures zurückkehren und gefragt werden, ob Sie das neue Menüband laden möchten, klicken Sie auf Ja. Das Menüband wird mit den vorgenommenen Änderungen aktualisiert.

Änderungen prüfen

Sie können das ursprüngliche Menüband mit den vorgenommenen Änderungen vergleichen. Sie können prüfen, welche Elemente hinzugefügt und entfernt wurden, und welche auf unterschiedliche Registerkarten verschoben wurden.

  1. Speichern Sie das benutzerdefinierte Menüband, falls noch nicht geschehen.
  2. Klicken Sie auf die Schaltfläche Vergleichen.
  3. Prüfen Sie die vorgenommenen Änderungen im Dialogfeld Menübänder vergleichen.

    Zum Beispiel:

    • Nicht vorhanden : Diese Befehle wurden entfernt
    • Verschoben : Diese Befehle wurden an eine andere Position verschoben
    • Benutzerdefinierte Ergänzungen : Diese Befehle wurden hinzugefügt
    Note:

    Ursprüngliches Menüband bezieht sich auf die Menübanddatei, die in der Tekla Structures -Installation Ihrer aktuellen Konfiguration enthalten war.

  4. Wenn Sie einen entfernten Befehl wieder hinzufügen möchten, ziehen Sie diesen aus dem Dialogfeld Menübänder vergleichen in das Menüband.
  5. Klicken Sie abschließend auf Schließen.

Menübänder sichern und wiederherstellen

Sie können die Standard-Menübänder in Tekla Structures jederzeit wiederherstellen. Bevor Sie die Standardeinstellungen wiederherstellen, sollten Sie eine Sicherungskopie Ihres benutzerdefinierten Menübandes anlegen, da die Anpassungen unwiderruflich gelöscht werden. Sie können die Sicherungsdatei verwenden, um Ihr benutzerdefiniertes Menüband erneut zu laden, die Menübandeinstellungen zu einem anderen Computer zu kopieren oder das benutzerdefinierte Menüband mit Kollegen zu teilen.

  1. So erstellen Sie eine Sicherungskopie des benutzerdefinierten Menübandes:
    1. Klicken Sie im Menüband-Editor auf die Schaltfläche Speichern.
    2. Wechseln Sie in den Ordner ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons.
    3. Erstellen Sie eine Kopie der gewünschten Menübanddatei, und speichern Sie sie in einem anderen Ordner.

      Die Menübänder werden gemäß den Konfigurationen in Tekla Structures benannt. Ein Beispiel: In der Konfiguration Vollständig lautet der Name der Menübanddatei Modellierung albl_up_Full--main_menu.xml.

  2. Klicken Sie auf die Schaltfläche Wiederherstellen , um den Tekla Structures -Standard für das Modellierungs- oder -Zeichnungsmenüband wiederherzustellen.
  3. So aktivieren Sie das benutzerdefinierte Menüband erneut:
    1. Kopieren Sie die Sicherungsdatei wieder in den Ordner ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons.
    2. Wenn Sie zu Tekla Structures zurückkehren und gefragt werden, ob Sie das neue Menüband laden möchten, klicken Sie auf Ja. Das Menüband wird mit den vorgenommenen Änderungen aktualisiert.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Inhaltsbewertung: 
Noch keine Bewertungen vorhanden