Move objects

Added May 4, 2021 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2021

Move objects

Move objects

You can move objects in a number of different ways, especially in models. When you move an object, Tekla Structures also copies all objects connected to it, including the components.

Move by picking two points

The basic way to move objects in a model or drawing is by defining the origin and one or more destination points.

  1. Select the objects you want to move.

  2. Run the Move command:
    • In the model, on the Edit tab, click Move.

    • In the drawing, on the Drawing tab, click Move > Move

  3. Pick the origin for moving.

    In the model, Tekla Structures displays a rubber band line between the first picked point and the cursor position. This is a preview of the position where the objects will be moved. Move the cursor to see how the preview changes.

    Note that Tekla Structures always displays the preview in the position where the objects will be moved, not in the position where the cursor is when you pick the destination point.

  4. Pick the destination point.

    The objects are moved immediately. The Move command does not remain active.

Note:

If you want to limit the number of objects shown in the preview, use the advanced option XS_PREVIEW_LIMIT. The default value is 1000. When the value is 0, the preview is off.

Move linearly

You can move objects linearly to a new position in the model.

  1. Select the objects you want to move.
  2. On the Edit tab, click Move special > Linear.

    The Move - Linear dialog box opens.

  3. Pick two points in the model, or enter the coordinates in the dX, dY, and dZ boxes.

    You can also use a formularule stated in a mathematical language

    Formula is part of an equation.

    to calculate the x, y, and z displacements. For example:

  4. Click Move.
Tip:

If the dialog box is open but the command is not active anymore, click the Pick... button to re-activate the command.

Move by specifying a distance from origin

You can move objects to a new position in the model or drawing by specifying a distance from the origin. Use the Enter a Numeric Location dialog box to specify the distance.

  1. Select the objects you want to move.
  2. Run the Move command:
    • In the model, on the Edit tab, click Move.

    • In the drawing, on the Drawing tab, click Move > Move.

  3. Pick the origin for moving.
  4. Move the cursor in the direction you want to move the objects, but do not pick the point.
  5. Type the distance.

    When you start typing, Tekla Structures displays the Enter a Numeric Location dialog box automatically.

  6. Click OK.

Move using drag-and-drop

You can move objects by dragging them to a new location.

  1. On the File menu, click Settings and select the Drag & drop check box to activate the command.
  2. Select the objects you want to move.

  3. Drag the objects to a new location.

    The point you start dragging from (center, corner, or middle point) affects the object's alignment in the new location.

    The objects are moved immediately.

  4. To move an end point using drag-and-drop:
    1. Select the handle.
    2. Hold down the left mouse button, and drag the handle to a new location.

      The end point is moved accordingly:

      Note that for some objects you may need to switch on Smart select to drag from handles without selecting them first. To switch it on, click File > Settings and select the Smart select check box.

    Note:

    To move gridmodeling aid that represents a three-dimensional complex of intersecting grid planes or intersecting grid planes and curved grid surfaces

    The grid is defined by coordinates in 3D space. It is shown two-dimensionally on the view plane by dash-and-dot lines. A grid can be rectangular or radial.

    It is possible to have more than one grid in a model. For example, a large-scale grid for the entire structure, and smaller grids for some detailed sections.

    It is also possible to show grids and grid line labels in drawings, and to modify how they are shown in the drawings.

    labels in a drawing, first select the grid labelname of a grid line

    and then either activate the Select grid line selection switch or select the grid label handle.

Move to another plane

In the model, you can move objects from the first plane you specify to the second, third, and so on, plane you specify. The moved objects remain in the same position in the second plane, third, and so on, plane as the original objects in the first plane.

  1. Select the objects you want to move.
  2. On the Edit tab, click Move special > To another plane.
  3. Pick the point of origincenter of the coordinate system where the axes intersect and form a fixed point of reference for the geometry of the surrounding space

    of the first plane.
  4. Pick a point on the first plane in the positive x direction.
  5. Pick a point on the first plane in the positive y direction.
  6. Repeat steps 3–5 for the destination planes.

Move objects to another object

In a model, you can move objects from an object to other, similar objects. This is useful, for example, when you detail previously modeled parts. The objects that you move between can have different dimensions, length, and rotation.

If you move reinforcement or surface treatments and want them to adapt to the part they are moved to, note the limitations:

  • The reinforcement or surface treatmentbuilding object that represents finishing of a part

    The term surface treatment is used in concrete detailing. For concrete parts surface treatment includes surface mixes, tiles, and flat finishes, such as troweling and sandblasting.

    The term surface finish is used in steel detailing. For steel parts surface finishes include fire-proofing and unpainted areas.

    handles must be in part corners.

  • The parts between which you move must have the same number of cross sectiongeometrical form of a part sectioned perpendicular to its axis

    corners.

  • Circular parts must have the same cross section dimensions.

  1. Select the objects you want to move.
  2. On the Edit tab, click Move special > To another object.
  3. Select the object to move from (source object).
  4. Select the objects to move to (target object).

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet