2020 Table of Contents

Changes in numeric snapping and other modeling improvements

Last updated March 26, 2020 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2020

Changes in numeric snapping and other modeling improvements

Changes in numeric snapping and other modeling improvements

In Tekla Structures 2020, many modeling features have been improved, such as numeric snapping with direct modificationfunction that activates the mode where the model objects can be modified by using handles

Direct modification enables additional handles and modification options.

, and solid error reporting. There are also changes in the Automatic User Feedback program.

 

Improvements in numeric snapping

Starting from Tekla Structures 2020, you can enter coordinate axis prefixes x, y, and z in the Enter a Numeric Location dialog box when you position or modify an object by using direct modification. Numeric snapping and axis prefixes are very useful when you modify the geometry of items, for example.

By using the axis prefixes, you can specify the directions that are available for snapping. The axis prefixes can be used with relative and absolute (work planeplane that the user has chosen in a model and that is currently active for working on in a model view

Newly created, copied, or moved model objects comply with the work plane. For example, shifting the work plane to follow a sloped plane makes it easier to model sloped structures.

) coordinates, but not with global coordinates. For example:

  • @z500 only allows snapping in the z direction and relative to the current location. The x and y coordinates stay the same.

  • $y6000,z-500 only allows snapping in the y and z directions of the work plane, starting from the origin of the work plane. The x coordinate stays the same.

  • Z500,X100 only allows snapping in the x and z directions in the default snapping mode. The y coordinate stays the same.

The axis prefixes are not case-sensitive, and the prefixed values can be entered in any order.

If any of the entered coordinate values has an axis prefix, the other values need to have prefixes, too.

Diagnose and list solid errors

The solid errors found in the currently open model are now shown in the report that opens when you use the Diagnose & repair > Diagnose model command on the File menu.

Using this report makes it easier to focus on the solid errors in the currently open model only and to check that the errors get fixed. The report is updated every time you rerun the Diagnose model command, so the fixed errors are not listed anymore. The report also lists the solid errors that are not visible in any model viewview that is represented in the modeling mode

Model view is available also in the drawing mode and it is represented in its own window.

.

As previously, solid errors are also listed in the session history log (TeklaStructures_<user>.log), but the session history log shows solid errors of all models that you open until you restart Tekla Structures.

The solid errors that occur in drawings are only listed in the session history log.

Changes in construction circles

You can again create construction circles on the view planeplane in a space that defines the view

In Tekla Structures, the grids are projected onto the view plane and the grid lines can be visible on it.

View depth is defined starting from the view plane.

by picking two points: the center point and a point to define the radius of the circle. This is the default option on the contextual toolbarfloating toolbar that contains commands for modifying the most common object properties

The user can customize the contextual toolbar.

that appears when you start the Edit > Construction object > Circle command:

More options for the date and time in Task manager

In Task manager, you can now select from 13 predefined options how the date and time are displayed in a taskin the task manager, a representation of a piece of work that needs to be carried out in order to complete a project

.

To set the date and time format, click > Date and time format, and select the format that you want to use.

Adjustments in toolbar size and toolbar icon size

You can now adjust the toolbar size and at the same time the icon size on the toolbars by using option buttons in the File menu > Settings > Toolbars.

Previously, the size of the toolbar was adjusted by using a slider.

New handle dragging option on the contextual toolbar

You can now drag the end point handles of beams and polybeams along the reference lineline between two reference points

For example, if the user picks two points to position a beam, these points form the reference line, and handles appear at the line ends.

Reference lines can be used in snapping in a snap switch.

.

Previously, only moving in 3D, in XY plane, and in Z direction were possible.

Small improvements in the side pane window docking

Now the side pane windows stay docked or floated when you restart Tekla Structures.

In addition, clicking the header area of a side pane window does not immediately float the window anymore. To detach the side pane window, you need to slightly drag it.

Small improvements in the customization of the contextual toolbars

 

  • The Customize toolbars dialog box's minimum width is now wider to make the Preview view of the toolbar more accurate.

  • In the Customize toolbars dialog box, the list of contextual toolbars that can be customized now shows only the toolbars that are available in the current mode, meaning in the modeling modemode that is used for creating and analyzing a model, and initiating the creation of a drawing and a report

    Custom component editor and sketch editor can be accessed in modeling mode.

    or in the drawing modemode that is used for editing the appearance and content of drawings

    Tekla Structures switches to the drawing mode when the user opens any drawing.

    .

  • On the contextual toolbar, the tooltip for now reads Minimize or maximize.

Changes in Automatic User Feedback program

The Automatic User Feedback program is now called Usage statistics in File > Settings.

Collecting the usage data is now on by default. Previously, the data collection was not on by default, and you had to separately accept the collecting of data. The collected data is anonymous information on how you use Tekla Structures and it is used to improve the software.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet