Hello!

Did you know that logged in users can see a lot more content?

Export a drawing to a 2D DWG or DXF file

Last updated September 10, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2019i

Export a drawing to a 2D DWG or DXF file

Export a drawing to a 2D DWG or DXF file

You can export Tekla Structures drawings to 2D DWG and DXF format. You can export several drawings at a time.

The DWG/DXF export is object based. For example, if you export a rectangular part that is drawn using hidden line types, the result is a rectangular object drawn with a dashed line. In the old line-based DWG export, the result would be many separate short straight lines. Hatches are also exported as hatch objects in CAD and not separate lines.

In the DWG/DXF drawing export you can:

  • easily set layers for different objects, and separate mark frames from mark text and leader lines, for example
  • separate different parts from another by using filters
  • use layers that have been predefined by standard CAD layer settings
  • use base points and model coordinates
  • embedbuilding object that represents an object that is to be cast into a concrete structure and that is used to connect structures or as an aid when constructing a structure

    For example, a cast-in socket is an embed that is placed in concrete structures to allow parts to be bolted together on site. In Tekla Structures, embeds are modeled as steel sub-assemblies that are inside a concrete nested assembly.

    images in the export file so that the images are no longer exported as links

Start DWG/DXF export

  1. Start the export in any of the following ways:

    • On the File menu, click Export > Drawings , and select the drawings from the displayed Document manager.
    • Click Drawings & reports > Document manager , select the drawings that you want to export from Document manager , and then on the File menu, click Export > Drawings.
    • Click Drawings & reports > Document manager , select the drawings that you want to export from Document manager , right-click and select Export. Note that this command is not available when you open the Document manager in the drawing modemode that is used for editing the appearance and content of drawings

      Tekla Structures switches to the drawing mode when the user opens any drawing.

      .
    • In an open a drawing, on the File menu, click Export drawings.

  2. Click Open preview to show the preview window, where you can also change the drawing if you have selected many drawings for export. To get the preview visible for the first time, click Refresh preview. You can refresh the preview again by clicking Refresh preview. The preview does not get refreshed automatically, because this could take a long time.

Define export settings and export to DWG/DXF

  1. In the Save list, load previously saved or predefined export settings. If you want to save modified settings for future use with another name, enter a name for a new settings file and click Save.
  2. In File location , define the location for the exported DWG files.

    The default location for DWG/DXF files is the current modelmodel that is active in Tekla Structures

    The current model can be a single-user model, a shared model or a working model.

    folder. The default folder for the generated DWG/DXF files can also be controlled by the XS_DRAWING_PLOT_FILE_DIRECTORY advanced option. You can use relative file location by using .\ in front of the output folder name. The specified output folder is saved in the settings. Open folder when finished opens the export folder after the export.

  3. In the File type list, select DWG or DXF.
  4. Select the DWG version to be used in export. There are several versions of AutoCAD or DXF formats available. 2010 is the default.
  5. Define other settings on the Options tab as necessary:

    Model space coordinates

    Select one of the following options:

    • Local : Exports the drawing to the 0 point in the CAD coordinate system. This option uses the left bottom corner of the 1st view frame to set the local coordinates. If frame is expanded, the local will move.
    • Model : Matches Tekla Structures 0 point with CAD 0 point and rotates the CAD coordinate system accordingly in X and Y coordinates. Note that Z coordinates are not supported.
    • Base point : <name_of_base_point> : Matches the selected base point with CAD 0 point, and rotates the CAD coordinate system accordingly. The base points are defined in the Tekla Structures model through File > Project properties > Base points.

      Note that Z coordinates are not supported.

    File prefix

    File suffix

    Enter a specific prefix or suffix to be used in the file name. The preview of the file name will change accordingly.

    The DWG export supports the following drawing-specific advanced options, which you can use to modify the name of the exported file:

    XS_DRAWING_PLOT_FILE_NAME_A

    XS_DRAWING_PLOT_FILE_NAME_C

    XS_DRAWING_PLOT_FILE_NAME_G

    XS_DRAWING_PLOT_FILE_NAME_M

    XS_DRAWING_PLOT_FILE_NAME_W

    For more information about the values that you can give to these options, see Customize print output file names.

    Embed images inside the file

    Embed all images inside the export file. No extra image files are created in the export.

    Drawing as snapshot to CAD model space

    Export all included objects to the model space and paper space of a CAD file. Model and global coordinates and paper space switch in the layer settings will be ignored.

    Note that if the drawing has linked or copied views, and you have not selected Drawing as snapshot to CAD model space , the drawing views may be placed on top of each other, and the view limits may not be accurate in the resulting DWG file. This is because drawing views are not conceptually the same as paper space viewports in the DWG format.

    Also note that if you have shortened views in the drawing, and the objects are placed in 1:1 scale, the ends will be stretched to match the actual size of the part. Select Drawing as snapshot to CAD model space to avoid stretching of the shortened view in a CAD model space. The drawing space in a CAD software will keep the view shortening.

    Scale

    Define the scale for the exported DWG. This option is only available if you have selected the Drawing as snapshot to CAD model space check box.

    For example, if you have a drawing between the coordinates 0,0 and 800, and you define a scale value 5, the resulting DWG is 5 times bigger, and the DWG is located between the coordinates 0,0 and 4000.

    In another example, if you have set the drawing view scale in Tekla Structures to 1:50 and wish to export the drawing in 1:1 scale, using export option scale value 50 will produce the desired result.

    If you set the advanced option XS_EXPORT_DRAWING_TRY_TO_KEEP_LOCATION to TRUE , Tekla Structures tries to keep the DWG origin in the same position as the drawing view origin. This can only be done in plan views and elevation views. If the drawing has more than one plan view or elevation view, Tekla Structures places the DWG origin in the bottom-left corner of the drawing frame.

    Ungroup objects in blocks

    Exports graphical objects as individual objects, does not add the objects to blocks. For example, a line, hatch and rectangle will be a DWG object line, hatch and rectangle, rather than blocks. When this option is selected, the option Update Tekla Structures linework only is disabled.

    Update Tekla Structures linework only

    Updates the Tekla Structures drawing content and keeps other content that is created in a CAD software intact in the same file. Blocks (groups), created by Tekla Structures will be updated.

    This setting is only shown if you have set the advanced option XS_DWG_EXPORT_UPDATE_TS_LINEWORK_OPTION to TRUE in the Export category in the Advanced Options dialog box.

    Note that you need to have the same drawing exported already, and the layer setup and the layer template must be the same as during the previous export. All CAD lines that were added previously will stay in the file and only Tekla Structures content will get updated, unless editing was done in CAD blocks editor.

    Also note that if you edit the content of a block (CAD object), and then select the Update Tekla Structures linework only option, the whole block will be re-written, and the changes made in CAD will not be kept. To keep the changes in CAD, you need to explode a block before editing it.

    For example, you may want to use this setting if you have added drawing title blocks in the CAD file after the first export of the drawing from Tekla Structures , and want to keep these title blocks as they are, and update only the objects that exported from Tekla Structures.

  6. On the Layer rules tab, you can define explicitly the layers where different model and drawing objects, or parts of objects are exported to. For example, you can separate outline from fills and hatches.

    You can also define here whether the line color, style and weight will be used from Tekla Structures settings or from the target layer settings specified in a DWG or DXF file. Note that Tekla Structures line weight, style and colors stay as you see them in the Tekla Structures drawing, and there is no functionality to modify them just for the DWG export.

  7. To use a DWG template, use the Target layers from DWG list to browse for the template file. If specified, the template is used for layer definition. The DWG template should not contain any CAD objects, just layer settings, unless it contains objects that are intended to appear on drawings exported using this template. For example, here you could use your standard DWG file with all the predefined layers.

    You can enter .\ and then the file name, in which case Tekla Structures searches for the file first in the model, project and firm folders, then in the folder indicated by the advanced option XS_DRIVER , then in the system folderfolder that is used for storing files that define default settings

    , and finally in the user settings folder.

    The DWG file not found text is displayed next to the Browse... button until a DWG or a DXF file is found and loaded.

    The target layer boxes are briefly colored in yellow when a new DWG file is loaded from the Target layers from DWG list. When there are no layers available in the DWG file, the boxes are colored in red.

  8. Add the rules:
    • You can create a new rule by clicking the Add button on the right, or by copying the selected rule by clicking the Copy button. You can select multiple rules.
    • You can move the rules upwards or downwards in the set by clicking the Move up and Move down buttons. You can select multiple rules.
    • If you wish to delete a rule, select it and click Delete. You can delete multiple rules at a time.
  9. Define the rule contents:

    Objects

    Select the objects that you want to export.

    Note that some objects, like neighbor part marks, are currently under marks and not listed separately. To have them separated in the export, you need to use Object filtering , and create several mark rules for parts and neighbor parts.

    To include everything else that is missing from the Objects list, add an All object rule at the end of the rules list, because rules are read in the order they are listed.

    To export pours, you need to have the pours enabled in the model, see XS_​ENABLE_​POUR_​MANAGEMENT.

    Presentation filtering

    Define which part of the objects should follow the rule. You can also select All.

    The Presentation filtering options are different for different object types.

    You cannot add more than one filter per rule. For example, to have mark frames separated from mark text, you need to create two rules for marks, and in the first one, set the Presentation filtering to Text , and in the other one to Frames. See the section Layer rule example below for an example.

    Object filtering

    Reads the selection filter attribute files that have been defined in the current model.

    Note that these files are only read from the current model folder, not from firm or project folders.

    Target layer

    If you have no DWG templates, or want to create layers of your own, type a new layer name in the Target layer box, or select a previously used layer from the list.

    Note that after you have added a DWG template, its layers will appear in the Target layer list.

    The target layer boxes are briefly colored in yellow when a new DWG file is loaded from the Target layers from DWG list. When there are no layers available in the DWG file, the boxes are colored in red.

    Color

    Line style

    Line weight

    Define whether the linework is taken from Tekla Structures settings or from the DWG template.

    Paper space

    To draw drawing objects correctly in the paper space in a DWG file (and not through the view portal), select the Paper space check box.

    If the check box is not selected, there will only be a portal from the model space in the paper space.

    Note that it is recommended to put drawing annotations, such as marks, dimensions, and texts to the paper space only. That way they will appear correctly, for example, when a part is cut in a Tekla Structures drawing view.

    Include

    To include a rule in the final DWG, select the Include check box next to the rule. If you do not want to export some objects, just clear the Include check box.

  10. Open the preview and click Refresh preview to preview the result before exporting.
  11. Click Export.

    The drawings are exported on the basis of the defined settings and rules. The rules are read in the order that they are listed. If you have selected Open folder when finished , the export folder will open.

    The error message Drawing cannot be read is displayed if the exported drawing is missing, not up to date or has similar problems.

    When you click the Export button, Tekla Structures first checks if the files can be written to before the export starts, and asks you to close the necessary applications. It also checks if the files already exist and asks if you want to overwrite the existing files.

Layer rule example

In the example below, three separate mark rules have been created that will be exported on layers 1, 2, and 3. Lines are exported on the layer 1, texts on the layer 2, and frames on the layer 3.

After exporting, you can show the marks in the CAD model in the following three ways depending on the layers displayed in the CAD viewer:

All layers are shown:

Layer 1 containing the lines is hidden:

Layer 2 containing the texts is hidden:

Layer 3 containing the frames is hidden:

Tips

  • If you export a DWG file to the Output file version 2013, a wipeout frame will be visible on the layout side in the CAD model due to the limitations in CAD, see below:

    To avoid this, either use a DWG file layer template created in AutoCAD, or export to version 2010 (default) or earlier.

  • Another reason for the visible wipeout frame is that you are using a DWG template where wipeout frames have been set to visible. Hide the wipeout frames in the CAD template.

To use old DWG/DXF export

If you want to use the old DWG/DXF export, set the advanced option XS_USE_OLD_DRAWING_EXPORT to TRUE in an .ini file. This advanced option is by default set to FALSE. For instructions on using the old export, see Export a drawing to 2D DWG or DXF (old export).

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet