Hello!

Did you know that logged in users can see a lot more content?

NC files

The help version you are viewing is a first draft for an upcoming release. The content is still being updated and does not fully correspond to final product features.

Added June 28, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2019i

NC files

NC files

Tekla Structures produces NC files in DSTV format. You can select the information to be included in NC files and NC filefile that contains information gathered from a model and exported to computer numerical controlled fabrication machinery

Tekla Structures produces NC files in several formats, for example, DSTV.

headers, and define the desired pop-mark and contour mark settings. You can also produce MIS (Manufacturing Information System) list files according to the DSTV standard.

NC (Numerical Control) refers to a method where machine tool operations are controlled with a computer. The NC data controls the motion of CNCoperation of a machine tool with a computer controlling the manufacturing process

During the computer numerical control manufacturing process, a machine tool or machining center drills, cuts, or shapes the piece of material.

The terms numerical control and NC refer to the method used prior to computer numerical control. However, the abbreviation NC is often used in the term NC file.

(computer numerical controloperation of a machine tool with a computer controlling the manufacturing process

During the computer numerical control manufacturing process, a machine tool or machining center drills, cuts, or shapes the piece of material.

The terms numerical control and NC refer to the method used prior to computer numerical control. However, the abbreviation NC is often used in the term NC file.

) machine tools. During the manufacturing process a machine tool or machining center drills, cuts, punches or shapes the piecebuilding object that is a basic element of a model and that can be modeled and detailed further

The main concrete parts are: column, beam, polybeam, spiral beam, panel, slab, pad footing, strip footing, and item.

The main steel parts are: column, beam, polybeam, curved beam, twin profile, orthogonal beam, spiral beam, contour plate, bent plate, and item.

The term piece is sometimes used to refer to part.

of material.

After you have finished detailing a Tekla Structures model, you can export the NC data as NC files from Tekla Structures to be used by CNC machine tools. Tekla Structures transforms the part length, holesmall hollow open throughout a part or assembly that is usually used for fastening parts with bolts or other such objects

Hole is created in the same way as bolts and hole properties are defined in the bolt properties.

positions, bevels, notches, and cuts into sets of coordinates that the machine tools can use to create the part in a shop. In addition to the CNC machine tools, the NC files can also be used by MIS and ERP software solutions.

The data for the NC files comes from the Tekla Structures model. We recommend that you complete detailing and create drawings before producing the NC files.

Tekla Structures produces NC files in DSTV format (Deutscher Stahlbau-Verband) in the current modelmodel that is active in Tekla Structures

The current model can be a single-user model, a shared model or a working model.

folder. In most cases each part has its own NC file. You can also produce NC files in DXF format by converting DSTV files to DXF files.

DSTV is a standard interface for geometrical description of steel structure pieces for the post-processors with numerical control. The essential aim of this interface is to be neutral, which means that with only one standard description you can manage several different NC machines. The interface standardizes the link between a CAD-program or a graphical system via a CAM file for the NC machines. The geometry of the piece is introduced completely neutrally, and after knowing the parameters of the NC machine, the post-processor is able to translate this neutral language to the NC machine language. For more information, visit http://www.deutscherstahlbau.de/dstv/der-verband.

Notes and limitations:

  • Duplicate bolts on a part (bolts in the same location as another bolt) are by default ignored in NC DSTV export. The tolerated distance for bolts to be considered duplicates can be adjusted with the XS_BOLT_DUPLICATE_TOLERANCE advanced option.

  • The DSTV standard does not support curved beams, and therefore Tekla Structures does not create NC files for curved beams. Use polybeams instead of curved beams.

Create NC files in DSTV format

  1. On the File menu, click Export > NC files .
  2. If you have some predefined settings that you want to use, select the settings from the settings file list at the top and click Load.
  3. In the NC Files dialog box, select the check box in the Create column next to DSTV for plates and/or DSTV for profiles.
  4. To modify the NC file settings, select an NC file settings row, and click Edit.

    In the NC File Settings dialog box, modify the settings on the Files and part selection , Holes and cuts , Hard stamp and Advanced Options tabs. Click OK to save your NC file settings and to close the NC File Settings dialog box.

    Hard stamps can be created for both the main part(1) part that exists in a building object and that determines the position number for the assembly or cast unit and the direction of assembly or cast unit drawings

    (1) Main part can be an assembly main part or a cast unit main part.

    (2) input part that the user selects first when creating a component

    (2) Connections and details always have a component main part.

    and the secondary parts. By default, Tekla Structures creates hard stamps only for the main part. Set the advanced option XS_​SECONDARY_​PART_​HARDSTAMP to TRUE to also create hard stamps for secondary parts.

    You can select to create only DSTV files, MIS files, both, or DSTV files embedded in MIS files.

    If you want to add new NC file settings, click Add. This will add a new row in the NC file settings list, and the NC File Settings dialog box is displayed, where you can give the settings a new name.

    You can enter a unique name for the settings using Save as. Tekla Structures saves the settings in the ..\attributes folder under the current model folderfolder that is used for storing files associated with a model

    Tekla Structures stores all files associated with a model in a folder it creates with the same name as the model database (.db1).

    In multi-user mode all users access the same model folder.

    .

    For more information about the NC file settings, see the "NC file settings" section below.

  5. You can customize the order in which information is displayed in an NC file, and add additional information on individual parts in the NC file header. To select the information to be included in the NC file header, click Header , modify the information, and click OK :
    • In the NC File Header Information dialog box, include in the Selected elements list the header information options that you want, and arrange the options in the desired order by selecting the option and using the Move up and Move down buttons.
    • If needed, add additional information on individual parts.

      You can enter text in the Text info on piece 1 - 4 boxes, and enter desired template attributes in double angle brackets, for example <<WEIGHT>> to display the weight of the part

    • If you want to restore the default file header information, click the Default button in the NC File Header Information dialog box.

  6. To create pop-marks and modify the pop-mark settings, click Pop-marks.

    For more information about creating pop-marks and about the pop-mark settings, see the section "Create pop-marks in NC files" below.

  7. To create contour marks, and modify contour mark settings, click Contour marking.

    For more information about creating contour markinginformation written in an NC file that passes information to the NC machine on the layout and the parts that are welded or bolted together

    Tekla Structures contour marking does not work on polybeams.

    and about the contour marking settings, see the section "Create contour marking in NC files" below.

    For more information on contour marking, see the support article How to create contour marking for steel beams.

  8. To save the settings that you have modified with another name for later use, click enter a new name next to Save as and click Save as.
  9. In the NC Files dialog box, use the All parts or Selected parts options to select whether to create the NC files for all parts or only for the selected parts.

    If you use the Selected parts option, you need to select the parts in the model.

  10. Click Create.

    Tekla Structures creates .nc1 files for the parts using the defined NC file settings. By default, the NC files are created in the current model folder. The filename consists of a position numberidentifier that is assigned to all similar parts, assemblies, cast units, or reinforcement

    Position number consists of a prefix, separator, and running number. The prefix is part of the position number, identifying a numbering series. The running number is part of the position number, and is the assigned number in the numbering series, based on the start number. The separator is an optional character, such as a slash, that separates the prefix and the running number.

    In Tekla Structures, the position numbers assigned in the numbering are shown in marks and templates, for example.

    In the US, the term piece mark or ship mark is used to refer to a position number.

    and the extension .nc1.

  11. Click Show NC log to create and show the log file dstv_nc.log that lists the exported parts and the parts that were not exported.

    If all expected parts are not exported, check that the parts which were not exported pass all the profile type, size, hole and other limits set in the NC file settings.

NC file settings

Files and part selection tab

Setting Description

File format

DSTV is the only available value.

File location

The default folder is \DSTV_Profiles or DSTV_Plates under the current model folder.

You can define another destination folder for NC files in one of the following ways:

  • You can enter the folder path in the File location box. You can also browse for the path.

    For example, enter C:\NC.

  • If you leave the field empty, the NC files will be created in the current model folder.
  • To create the NC file in a specific folder under the current model folder, enter .\<folder_name>.

    For example, enter .\MyNCFiles.

  • You can use the model-specific advanced option XS_​MIS_​FILE_​DIRECTORY to define the destination folder for NC and MIS files. Go to the CNC category in the Advanced Options dialog box, and enter the desired folder path for the advanced option XS_MIS_FILE_DIRECTORY. The NC files will be created in the specified folder under a folder that has the name of the current model.

    For example, if you define C:\NC , and the name of the current model is MyModel , the NC files will be created in the folder C:\NC\MyModel.

File extension

.nc1 is the default value.

Include revision mark to file name

Add a revision mark to the NC file name.

The file name then includes a number indicating the revision of the file, P176.nc1 becomes P176_1.nc1 , for example.

Create what

Select the type of files to create:

NC files creates only DSTV files.

Part list creates only a MIS list file ( .xsr ).

If you create an MIS list file, enter a name for the list in the Part list file name box. Also, you need to click the Browse button next to the Part list file location box and browse for the location where you want to save the list .

NC files and part list creates both the DSTV files and an MIS list file.

Combined NC files and part list embedds DSTV files in an MIS list file ( .xsr ).

Maximum size

The options define the maximum length, width, and height of the parts the machine tool can handle. Larger parts are sent to other machines.

Profile type

All profiles that are set to Yes in the Profile type list can be handled by the machine tool. Profile types are named according to the DSTV standard.

I : I profiles

U : U and C profiles

L : L profiles

M : Rectangular tubes

R : Round bars and tubes

B : Plate profiles

CC : CC profiles

T : T profiles

SO : Z profiles and all the other types of profiles

By default, Tekla Structures unwraps round tubes as plate profiles and uses the plate profile type B in the NC file header data. To change this, use the advanced option XS_​TUBE_​UNWRAP_​USE_​PLATE_​PROFILE_​TYPE_​IN_​NC.

Maximum size of holes

The Maximum size of holes options define how large holes the machine tool is able to drill. The NC file is not created if a part contains larger holes or its material is thicker than the specified values. The hole size is connected to material thickness or plate thickness.

Each row contains the maximum hole diameter and the material thickness. Both conditions have to be met for the NC file to be created. For example, a row with the values 60 45 means that when the material thickness is 45 mm or smaller, and the hole diameter is 60 mm or smaller, the NC file is created. You can add as many rows as needed.

The following example shows how the Maximum size of holes can be defined. In this example, we have the following situation:

  • Three plates of different thickness.

  • Two bolt groups with equal sizes, and one bolt group with a larger size.

Maximum size of holes are defined as follows:

Test1 creates a folder under the model folder for the plates that meet the following criteria:

  • Hole diameter : 22

  • Plate thickness : 10

Test2 creates a folder under the model folder for the plates that meet the following criteria:

  • Hole diameter : 22

  • Plate thickness : 20

When you create NC files for the plates, the folder Test1 includes the plate PL350*10 and the folder Test2 includes the plate PL350*20. The plate PL350*15 is not included in any folder, because the hole size criterion is not met.

The order in which you enter the criteria is important: enter the most exclusive criteria first. If you define the criteria in a different order, the results will also be different.

Holes and cuts tab

See also XS_​DSTV_​CREATE_​NOTCH_​ONLY_​ON_​BEAM_​CORNERS.

Setting Description

Inner corners shape

The Inner corners shape option defines the shape of, for example, web notches or flange cuts at the beam end.

The Inner corner shape option also affects cuts on the flange:

The Inner corner shape option does not apply to rectangular openings that are located in the middle of a part:

The Inner corner shape option does not apply to those inner contours that are already rounded in the model. The model values remain intact.

The examples in the below show how the different inner corner shape options affect the part in the NC file. The original part in the model has flanges cut entirely and the web is notched.

Option 0 : Radius

The inner corners are shaped like holes with a given radius. A separate BO block is not written to the NC file.

Option 1 : Tangential

The inner corner is rounded according to the value in the Radius box.

Option 2 : Square

The corner is as it is in the model.

Option 3 : Drilled hole

A drilled hole is added to the inner corner. The hole radius is the same as the value in the Radius box. Holes are written as a separate BO block to the NC file.

Option 4 : Tangential drilled hole

A drilled hole is added tangentially to the inner corner. The hole radius is the same as the value in the Radius box. Holes are written as a separate BO block to the NC file.

Distance from flange within which web is not cut

The Distance from flange within which web is not cut option defines the height of the flange clearance area. The clearance check only affects the I , U , C , and L DSTV profile types.

If a cut in a part is located closer to the flange than the clearance in the model, the cut points inside that clearance are moved to the border of the clearance area when the NC file is written.

The part how it is modeled. The cut goes closer to the top flange than the defined flange clearance in the NC file settings:

The part how it is written in the NC files. The dimension shows the clearance. The top of the original cut is moved so that the clearance area is left free. The bottom of the cut is not moved.

Machine slots as

The Machine slot as option defines how slotted holes are created:

Ignore slots : Slotted holes are not created in the NC file.

A single hole in the center of the slot : Drills a single hole in the center of the slotted hole.

Four small holes, one at each corner : Drills four smaller holes, one at each corner.

Internal contours : Flame-cuts the slots as internal contours.

Slots : Leaves slots as they are.

Maximum diameter for holes to be drilled

The Maximum diameter for holes to be drilled option defines the maximum hole diameter. Holes and slotted holes that are larger than the maximum hole diameter are manufactured as internal contours.

Maximum diameter for circular cuts to be drilled

Maximum diameter for circular cuts to be drilled defines the maximum circular part cuts. They are written as holes if the diameter of the cut is less than the value defined for the setting. Smaller internal circular cuts are converted to holes.

Hard stamp tab

Setting Description

Create hard stamp

When selected, creates hard stamps.

Hard stamp content

The Elements list defines which elements are included in hard stamps and the order in which the elements appear in the hard stamp. You can also define the Text height and Case.

Project number : Adds the project number to the hard stamp.

Lot number : Adds the lot number to the hard stamp.

Phase : Adds the phase number to the hard stamp.

Part position : Prefix and position number of the part.

Assembly position : Prefix and position number of the assembly.

Material : The material of the part.

Finish : The type of finish.

User-defined attribute : Adds a user-defined attribute (user fields 1-4) to the mark.

Text : Opens a dialog box where you can add user-defined text to the hard stamp.

Including part position and/or assembly position in the hard stamp affects the NC filename:

  • Part position: P1.nc1 , P2.nc1

  • Assembly position: A1.nc1 , A2.nc1

  • Assembly and part position: A1-P1.nc1 , A2-P2.nc1

The following example shows a hard stamp that contains the elements Phase , Part position , Material , and Text.

Hard stamp placing

If you set the option By orientation mark to Yes , the default face is changed from bottom ( u ) to top ( o ) for L profiles, rectangular tubes and round bars.

The Side option defines the side of the part on which the hard stamp is placed.

The Position along the part and Position in depth of part options define the position of hard stamps on parts.

These options move the hard stamp on the same face it is created, but they cannot move the stamp to a different face. If the face is, for example, the bottom flange, you can move the stamp to a different place on bottom flange, but not to the top flange.

Default faces for different profiles:

I profile: Bottom flange ( u )

U and C profiles: Back side of web ( h )

L profiles: Back (h) or Bottom ( u )

Rectangular tubes: Bottom flange ( u )

Round bars: Bottom flange ( u )

Circular tubes: Front ( v )

T profiles: Back side of web ( h )

Plate profiles: Front ( v )

See also XS_​SECONDARY_​PART_​HARDSTAMP.

Advanced Options tab

Setting Description

Number of decimals

Define the number of decimals shown in NC files.
Change external contour (AK block) radius sign Change the AK block curve radius signs on top (o) and back (h) faces. This change only affects on top (o) and back (h) faces.

Below is an example, where the Change external contour (AK block) radius sign on top (o) and back (h) faces is not selected.

Below is an example, where the Change external contour (AK block) radius sign on top (o) and back (h) faces is selected.

Change internal contour (IK block) radius sign

Change the IK block curve radius signs for top (o) and back (h) faces. This change only affects top (o) and back (h) faces.

Curve detection

Chord tolerance

Curve detection controls whether three points should be read as a curve instead of two straight lines. When Curve detection is set to Yes , Tekla Structures checks the edges of a solid against a virtual curve described by the edges to see if the edges are curved or straight based on the Chord tolerance value. Enter the Chord tolerance value in millimeters. Curve detection is on by default.

The image below describes the chord tolerance.

Convert I profile to T profile when flange is missing

Select whether to convert I profiles to T profiles when a flange is missing. You can select either Yes or No.

Skip unnecessary points

Select whether to keep or skip the points that are almost collinear.

If the creation points of a contour plate differ less than 0.3 mm from a straight line, they are skipped in the NC file when this setting is selected. When the setting is not selected, every creation point of a plate is written to the NC file.

Skip unnecessary points not selected:

Skip unnecessary points selected:

Create KA block for

Select the following options to show bent line information for bent plates and polybeam plates in the NC file KA block: Unfolded bent plates and Unfolded polybeam plates.

See also XS_​DSTV_​DO_​NOT_​UNFOLD_​POLYBEAM_​PLATES.

Create pop-marks in NC files

Pop-marks are small holes that help the shop assemble individual parts to form an assembly. Tekla Structures is able to write the pop-mark information in NC files to help position parts that will be manually welded to the assembly main partmain part that exists in an assembly

The assembly main part in a steel assembly may have other parts welded or bolted to it. By default, the assembly main part is not welded or bolted to any other parts.

The user can change the assembly main part.

. Pop-marks are usually made using a drilling machine that drills a small hole in the surface of the material.

Limitation:Tekla Structures pop-marking does not work with polybeams.

Tekla Structures only creates pop-marks for parts for which you have defined pop-mark settings. You can save the pop-mark settings in a .ncp file, which Tekla Structures saves by default in the ..\attributes folder under the current model folder.

Note:

Pop-marking affects numberingprocess of assigning position numbers to parts, cast units, assemblies, or reinforcement

In Tekla Structures, the position numbers assigned in the numbering are shown in marks and templates, for example.

. For example, if two parts have different pop-marks, or one part has pop-marks and the other one does not, Tekla Structures gives the parts different numbers.

  1. In the NC Files dialog box, select the parts for which you want to create the pop-marks by selecting the corresponding check boxes in the Pop-marks column.
  2. Click the Pop-marks button.
  3. In the Pop-Mark Settings , click Add to add a new row.
  4. To define which parts are pop-marked and where the pop-marks are created, enter or select information for each item on a row.

    The order of the rows in the Pop-Mark Settings dialog box is important. Enter the most limiting definition first, and the most generic one last.

    First define the pop-mark settings on the Parts to pop-mark tab:

    Option Description
    Main part profile type Select the main part profile type that is pop-marked. The list contains profiles according to the DSTV standard.
    Main part name Enter the names of the main part profiles. You can enter several part names separated by commas, for example, COLUMN, BEAM.

    You can use wildcards (* ? [ ] ). For example, HE* matches all parts with a profile name that begins with the characters "HE".

    Part name can contain more names separated by comma.

    Sec part profile type Select the secondary part profile type.
    Secondary part name Enter the names of the secondary part profiles. You can enter several part names separated by commas.

    You can use wildcards (* ? [ ] ).

    Part name can contain more names separated by comma

    Pop-mark location Select how the secondary part is projected onto the main part.
    • Left side : The left side of the secondary part is marked on the main part. The left side is the side of the secondary part that is closest to the start point of the main part.

    • Right side : The right side of the secondary part is marked on the main part.

    • Both sides : Combines Left side and Right side.

    • Center : Center of the secondary part.

    • Left side holes : Marks the main part with the position of holes in the secondary part, on the left side of the secondary part.

    • Right side holes : Marks the main part with the position of holes in the secondary part, on the right side of the secondary part.

    • Both side holes : Combines Left side holes and Right side holes.

    • Middle line : Marks two points on the middle line of the secondary part x axis.

    Move to flange Select to which part of the main part flange the pop-marks are moved. The options are None , Both flanges , Top flange , and Bottom flange.
    Edge distance Enter the minimum distance from a pop-mark to the edge of the main part. Tekla Structures does not create pop-marks inside this distance.

    If a pop-mark is inside the defined edge distance, Tekla Structures moves it, unless you have set Pop-mark location to Center.

    Secondary pop-marks Select whether pop-marks are created to the secondary parts.

    Add pop marks to parts welded on site

    Select whether pop-marks are created for parts that are welded on site.

    Then define the pop-mark settings on the Pop-marking options tab:

    Option Description
    Rotate part if pop-marks or other items only on the back First select the Pop-marks on the back check box and then one of the options.

    Also set the Hole diameter.

    Rotate part and drill through pop-marks on the back if items or more pop-marks only on the back
    Drill through pop-marks on the back if no other items on the back
    No pop-marks on overlapping holes Select if you do not want to have pop-marks on overlapping holes.
    Add pop-marks to centers of studs Select to have pop-marks in the stud centers.
    Show pop-marks in the model Select to show pop-marks in the model.
    Consider zero diameter holes as pop-marks Write zero diameter bolt holes as a pop-marks.
  5. Click OK.
  6. Select the parts in the model and create the NC files.

Pop-marks are written in the BO block in the DSTV file as 0 mm diameter holes.

If needed, pop-marks can also be displayed in drawings. In drawings, select the on/off check box in the part properties to display the pop-marks.

Tekla Structures displays thick red lines for each pop-mark pair in the model viewview that is represented in the modeling mode

Model view is available also in the drawing mode and it is represented in its own window.

which was last updated.

Examples

Tekla Structures marks the center point of all round secondary profiles on a main part, and does not create pop-marks closer than 10 mm to the main part edge.

Tekla Structures projects the hole location in the secondary plates onto a main part.

Create contour marking in NC files

Tekla Structures is able to generate contour marking in NC files. This means that information on the layout and the parts that are welded or bolted together can be added to the NC files and passed on to the machine tool.

Limitation:Tekla Structures contour marking on polybeams does not work in all cases. The visual placement of contour marking on polybeams has been improved.

Tekla Structures only creates contour markings for parts for which you have defined contour marking settings. You can save the contour marking settings in a .ncs file, which Tekla Structures saves by default in the ..\attributes folder under the current model folder.

You can add contour marking to both the main and the secondary parts.

Note:

Contour marking affects numbering. For example, if two parts have different contour markings, or one part has contour markings and the other one does not, Tekla Structures gives the parts different numbers.

  1. In the NC Files dialog box, select the parts for which you want to create the contour marks by selecting the corresponding check boxes in the Contour marking column.
  2. Click the Contour marking button in the NC Files dialog box.
  3. In the Contour marking settings dialog box, click Add to add a new row.
  4. To define which parts are contour marked and how they are contour marked, enter or select information for each item on a row:
    Option Description
    Main part profile type Select the main part profile type that is contour marked. The list contains profiles according to the DSTV standard.
    Main part name Enter the name for the main part profiles. You can enter several part names separated by commas, for example, COLUMN, BEAM.

    You can use wildcards (* ? [ ] ). For example, HE* matches all parts with a profile name that begins with the characters "HE".

    Part name can contain more names separated by comma.

    Sec part profile type Select the secondary part profile type. The list contains profiles according to the DSTV standard.
    Sec part name Enter the name for the secondary part profiles. You can enter several part names separated by commas.

    You can use wildcards (* ? [ ] ).

    Part name can contain more names separated by comma.

    Secondary contour marking Select whether the secondary parts are contour marked.
    Punch or powder In the list, select how the part is contour marked:
    • Punch : The part is punched.

    • Powder : The part is marked with powder.

    • Both : Both techniques are used.

    Hard stamp Select whether hard stamps are created.
    Mark parts welded on site Select whether you want to mark parts that are welded on site.
    Edge distance Define the minimum distance from a contour mark to the edge of the main part. Tekla Structures not create contour marks inside this distance.
  5. Click OK and create the NC files.

Contour marking is written in the PU and KO blocks in the DSTV file.

Tekla Structures displays contour marking as thick magenta lines in the model view.

Fittings and line cuts in NC files

When creating NC files in DSTV format, the method you use to cut the end of the beam affects the beam length in the NC file.

  • Fittings affect the length of the beam in the NC file.

  • Line cuts do not affect the length of the beam in the NC file.

When you cut the beam end, use the fittingadjustment of a part end

method to make sure that the beam length is correct in the NC file.

The overall length of a beam will be the fitted net length of the beam. This means that Tekla Structures always takes the fitting into account when calculating the beam length.

For lines, polygons, or part cuts, the cut does not affect beam length, but the overall length in the NC file will be the gross (initially modeled) length of the beam.

  1. Fitting

  2. Line cutcut that is defined by a cutting line

  3. Polygon or line cut

  4. Fitting

Shortest length

If you want to use the shortest possible length in an NC file, use the advanced option XS_​DSTV_​NET_​LENGTH.

Net and gross length

If you want to include both net and gross length into NC file header data, use the advanced option XS_​DSTV_​PRINT_​NET_​AND_​GROSS_​LENGTH.

DSTV file description

Tekla Structures produces NC files in DSTV format. DSTV format is an industrial standard defined by the German Steel Construction Association (Deutsche Stahlbau-Verband). A DSTV file is a text file in ASCII format. In most cases each part has its own DSTV file.

To learn more about the DTSV syntax, see Standard Description for Steel Structure Pieces for the Numerical Controls.

Blocks

The DSTV file is divided into blocks that describe the content of the file.

DSTV block

Description

ST

Start of the file

EN

End of the file

BO

Hole

SI

Hardstamp

AK

External contour

IK

Internal contour

PU

Powder

KO

Mark

KA

Bending

Profile types

Profile types are named according to the DSTV standard.

DSTV profile type

Description

I

I profiles

U

U and C profiles

L

L profiles

M

Rectangular tubes

RO

Round bars

RU

Round tubes

B

Plate profiles

CC

CC profiles

T

T profiles

SO

Z profiles and all the other types of profile

Part faces

Single letters in the DSTV file describe the part faces.

Letter

Part face

v

front

o

top

u

bottom

h

behind

Create NC files in DXF format using Convert DSTV files to DXF macro

You can convert the created NC files in DXF format by using the Convert DSTV files to DXF macrosaved series of actions that includes instructions for a program

Macros are located in the applications and components catalog. They are recorded or created manually and stored as .cs file in a folder defined with the advanced option XS_MACRO_DIRECTORY.

Macros can, for example, be used for creating drawings or reports.

Macros are sometimes used to run an application.

Limitation: The macro has been designed for simple plates. Therefore it may not give correct conversion results for beams, columns and bent polybeams.

  1. Create the NC files in the DSTV format.
  2. Click the Applications & components button in the side pane to open the Applications & components cataloguser interface for displaying or modifying information in categorized lists

    For example, profile catalog and shape catalog are catalogs.

    .

  3. Click the arrow next to Applications to open the applications list.
  4. If Convert DSTV files to DXF is not visible in the Applications list, select the Show hidden items check box at the bottom of the Applications & components catalog.
  5. Double-click Convert DSTV files to DXF to open the Convert DSTV files to DXF dialog box.
  6. Browse for the folder that contains the NC files you want to convert to DXF files.
  7. Select the NC files and click Open.

    Tekla Structures automatically creates an NC_dxf folder in the model folder and the DXF files are created there.

Create NC files in DXF format using tekla_dstv2dxf.exe

You can use a separate Tekla Structures program tekla_dstv2dxf.exe to convert the DSTV files to DXF format. Only one side of a part (front, top, back or bottom) is written to the file, and therefore this export format is most suited to plates.

The program is located in the ..\Tekla Structures\<version>\nt\dstv2dxf folder.

  1. Create a folder for the NC files, for example c:\dstv2dxf.

    Do not use spaces is the folder path. You should not save the files, for example, in the Tekla Structures folder under the \Program Files folder, because the folder path contains spaces.

  2. Copy all files from C:\Program Files\Tekla Structures\<version>\nt\dstv2dxf to the folder you created ( C:\dstv2dxf ).
  3. Create DSTV files and save the files in the in the folder you created ( C:\dstv2dxf ).
  4. Double-click a suitable dstv2dxf_conversion.bat file.

    The program converts the files to DXF format in the same folder.

    If you need to adjust the conversion settings, modify the settings in an appropriate tekla_dstv2dxf_<env>.def file and restart the conversion. For more information, see the tekla_dstv2dxf_<env>.def file description below.

    The conversion file description pdf files can be found in the same folder as the tekla_dstv2dxf.exe program.

tekla_dstv2dxf_<env>.def file description

The tekla_dstv2dxf_<env>.def file is used when converting from the DSTV to the DXF format using the tekla_dstv2dxf.exe. It contains all the necessary conversion settings. The .def file is located in the ..\Tekla Structures\<version>\nt\dstv2dxf folder.

The DSTV to DXF conversion settings are described below.

Environment settings [ENVIRONMENT]

INCLUDE_SHOP_DATA_SECTION=FALSE

Specify whether to include a special data section in the DXF file to allow the DXF file to be better imported into CNC software written by Shop Data Systems. Including this special data section in the DXF file makes the DXF file unreadable by AutoCAD.

Options: TRUE, FALSE

NO_INFILE_EXT_IN_OUTFILE=TRUE

Use to add the input fileInput files are used for different purposes, for example, for defining the content and structure of a dialog box and for defining certain reinforcement-related settings.

Input files have the extension .inp, for example rebar_config.inp.

extension to the output file.

Options:

TRUE : p1001.dxf

FALSE : p1001.nc1.dxf

DRAW_CROSSHAIRS=HOLES

Draw crosshair for holes and slotted holes.

Options: HOLES , LONG_HOLES , BOTH , NONE

HOLES :

LONG_HOLES :

BOTH :

NONE :

SIDE_TO_CONVERT=FRONT

Define which side of the member to convert.

Options: FRONT , TOP , BACK , BELOW

Defines which part face is shown in the DXF file. This setting is originally designed for plates.

FRONT is the most typical option. Sometimes you may need another rotation for a plate(1) part that represents a flat structure

(1) In some contexts, for example in analysis, the term plate object may be used to refer to plates.

(2) plate that represents a steel structure

(2) Plate is mainly used as a connection piece or as a floor plate.

, and then you can try if changing this setting to BACK would help. In addition to the SIDE_TO_CONVERT setting, it requires that the NC files are created with the advanced option XS_DSTV_WRITE_BEHIND_FACE_FOR_PLATE set to TRUE , which will include the back side data of a plate in the NC file.

OUTPUT_CONTOURS_AS=POLYLINES

Convert contours as polylines or lines and arcs.

Options: POLYLINES , LINES_ARCS

Note:

If you set OUTPUT_CONTOURS_AS =LINES_ARCS :

  • Slotted holes may sometimes have a gapany space between two objects

    The term gap is used in its general sense in Tekla Structures.

    /offset between a straight line and an arc.
  • Sometimes a 3D DXF is produced instead of a 2D DXF.

If you set OUTPUT_CONTOURS_AS=POLYLINES , the DXF file may not be correct if the NC is created with the Inner corner=0 setting.

CONTOUR_DIRECTION=REVERSE

Define the contour direction. This option changes the coordinates of the vertices, and the order they are written. You can see the difference if you open the DXF file in a text editor: "reverse" is clockwise and "forward" is counter-clockwise.

Options: REVERSE , FORWARD

CONTOUR_DIRECTION only works if you have set OUTPUT_CONTOURS_AS=POLYLINES. If you have set it to use LINES_ARCS , the output is always FORWARD (counter-clockwise).

CONVERT_HOLES_TO_POLYLINES=TRUE

Convert holes to polylines.

Options: TRUE , FALSE

MAX_HOLE_DIAMETER_TO_POINTS=10.0

Convert small holes to points in the DXF file.

When you set MAX_HOLE_DIAMETER_TO_POINTS to a value, the holes with a diameter smaller than this value will follow the HOLE_POINT_SIZE and HOLE_POINT_STYLE settings. With this kind of point visualization, the hole symbols will no longer show if a hole is bigger or smaller than the other one, but they will all have the same size.

HOLE_POINT_STYLE=33 and HOLE_POINT_SIZE=5

Point style and size for holes.

1 is a circle, but this setting is not in use

2 is +

3 is X

4 is short line

33 is circle

34 is a circle with +

35 is a circle with X

36 is a circle with short line

SCALE_DSTV_BY=0.03937

Use 0.03937 to scale to imperial units.

Use 1.0 to scale to metric units.

ADD_OUTER_CONTOUR_ROUNDINGS=FALSE

Add holes to roundings. This only affects the roundings that are created using the Inner corner shape = 1 setting in the NC File Settings dialog box on the Holes and Cuts tab. The hole size information is coming to the DSTV file from the Radius value in the NC File Settings dialog box, and you cannot adjust the hole size in the dstv2dxf converter.

Options: TRUE , FALSE

ADD_OUTER_CONTOUR_ROUNDINGS=FALSE :

ADD_OUTER_CONTOUR_ROUNDINGS=TRUE :

MIN_MATL_BETWEEN_HOLES=2.0

Define how close the holes can be to each other in slotted hole conversion.

INPUT_FILE_DIR= and OUTPUT_FILE_DIR=

Folders for input and output files.

DEBUG=FALSE

Show data processing in the DOS window.

Options: TRUE or FALSE

Text specifications [TEXT_SPECS]

TEXT_OPTIONS=PQDG

Define the text options that you want to use in the DXF file:

S adds a side mark (Side: v)

P adds a part markmark that includes a set of selected property elements related to a part

Part marks are made use of, for example, when identifying constructions, when giving information about welding, when giving information about assemblies to a workshop, when giving information about how parts should be connected to each other, and when creating bills of quantities.

In the US, the term piece mark is used to refer to position number.

(Part: P/1)

B adds a part mark and side mark (Part: P/1 Side: v)

Q adds the quantity (Quantity: 5)

G adds the steel grade (Material: A36)

T adds the thickness (Thickness: 3)

D adds the profile description (Desc: FL5/8X7)

TEXT_POSITION_X=30.0 and TEXT_POSITION_Y=30.0

The X/Y location of lower-left corner of first line of text from the origin point <0,0> of the DXF file.

TEXT_HEIGHT=0.0

TEXT_HEIGHT is not used, the text height is always 10.0, also in text layers.

Text item prefixes

You can define several different prefixes for text items. The prefix is only written in the file if the option CONCATENATE_TEXT is set to 0.

You can use the following prefix definitions:

PART_MARK_PREFIX=Part:

SIDE_MARK_PREFIX=Side:

STEEL_QUALITY_PREFIX=Material:

QUANTITY_PREFIX=Quantity:

THICKNESS_PREFIX=Thickness:

DESCRIPTION_PREFIX=Desc:

CONCATENATE_TEXT=1

Combine text items (part mark, quantity, profile, grade) into one or two lines.

Options:

0: Text lines are not combined. Prefixes work only with this option.

1: Part mark text on one line, other texts combined on another line.

2: All text on one line.

CONCATENATE_CHAR=+

Define a separator of max 19 characters for the text items.

Examples of different text specifications

The following settings are used the example below:

TEXT_OPTIONS=PQDG

TEXT_POSITION_X=30.0

TEXT_POSITION_Y=30.0

TEXT_HEIGHT=0.0

PART_MARK_PREFIX=Part:

SIDE_MARK_PREFIX=Side:

STEEL_QUALITY_PREFIX=Material:

QUANTITY_PREFIX=Quantity:

THICKNESS_PREFIX=Thickness:

DESCRIPTION_PREFIX=Desc:

CONCATENATE_TEXT=1

CONCATENATE_CHAR=+

The following settings are used for the example below: TEXT_OPTIONS=B, CONCATENATE_TEXT=0 :

Miscellaneous layers [MISC_LAYERS]

Entity Layer Name Color Text Height Output as
TEXT TEXT 7 Not used, always the same as the general text height definition 10.0.  
OUTER_CONTOUR CUT 7    
INNER_CONTOUR CUTOUT 4    
PART_MARK SCRIBE 3 Do not set a value for this option. If you set one, the DXF file will not be created.  
PHANTOM LAYOUT 4    
NS_POP_PMARK NS_POP_MARK 5   POP_CIRCLE 2.0 ( POP_CIRCLE or POP_POINT followed by size)
FS_POP_PMARK FS_POP_MARK 6 1.0

This ‘1.0’ is the diameter of the hole used for far side pop marks. It must match the value in the “drill thru” option in the machinex.ini file

POP_CIRCLE 2.0 ( POP_CIRCLE or POP_POINT followed by size)

Color table

1 = red

2 = yellow

3 = green

4 = cyan

5 = blue

6 = magenta

7 = white

8 = dark grey

9 = light grey

Hole layers [HOLE_LAYERS]

Layer Name Min Diam Max Diam Color
P1 8.0 10.31 7
P2 10.32 11.90 7
P3 11.91 14.0 7

Slot layers [SLOT_LAYERS]

The type and color affect the symbol, but the color of the slot outline or arrow (phantom) is defined by the PHANTOM layer definition in the MISC_LAYERS definition.

Layer Name Min Diam Max Diam Min ‘b’ Max ‘b’ Min ‘h’ Max ‘h’ Type Color Phantom
13_16x1 20.62 20.65 4.75 4.78 0.0 0.02 3 3 PHANTOM_OUTLINE
13_16x1-7_8 20.62 20.65 26.97 26.99 0.0 0.02 3 3 PHANTOM_OUTLINE

Below there are three examples with different phantom types. The other settings used are Slot type=1 , HOLE_POINT_STYLE=33 and HOLE_POINT_SIZE=1

PHANTOM_ARROW :

PHANTOM_BOTH :

PHANTOM_OUTLINE :

PHANTOM_NONE :

For an explanation of the “b” and “h” dimensions, see the image below:

Examples of slot types

These example use different slot types, but the other setting are the same:

  • Slot layer color is 3 (green).
  • Hole layer color is 6 (magenta).
  • Phantom layer color is 1 (red).
  • Slot layer phantom type: PHANTOM_OUTLINE
  • Hole point settings: HOLE_POINT_STYLE=35 , HOLE_POINT_SIZE=10
Slot type Description
SLOT_TYPE_1

One hole symbol to the center of slot. The hole symbol follows the HOLE_POINT_STYLE and HOLE_POINT_SIZE settings. The slot symbol is created according to the selected phantom setting ( PHANTOM_OUTLINE in this example). The circle color follows the slot layer color, and the slot color follows the phantom layer color.

SLOT_TYPE_2

Two hole symbols to the slot. The hole symbol follows the HOLE_POINT_STYLE and HOLE_POINT_SIZE settings. The slot symbol is created according to the selected phantom setting ( PHANTOM_OUTLINE in this example). The hole symbol color follows the hole layer color, and the slot color follows the phantom layer color.

SLOT_TYPE_3

One circle to the center of slot. The size of the circle corresponds to the real hole size. The circle color follows the slot layer color, and the slot color follows the phantom layer color. The slot symbol is created according to the selected phantom setting ( PHANTOM_OUTLINE in this example).

SLOT_TYPE_4

Two circles to the slot. The size of the circle corresponds to the real hole size. If the circles would be touching each other, only one circle in the middle of slot is created. The slot symbol is created according to the selected phantom setting ( PHANTOM_OUTLINE in this example). The circle color follows the hole layer color, and the slot color follows the phantom layer color.

SLOT_TYPE_5

Hole symbol to the first slot center point. The hole symbol follows the HOLE_POINT_STYLE and HOLE_POINT_SIZE settings. The slot symbol is created according to the selected phantom setting ( PHANTOM_OUTLINE in this example). The hole symbol color follows the hole layer color, and the slot symbol color follows the phantom layer.

SLOT_TYPE_6

One circle to the first slot center point. The slot symbol is created according to the selected phantom setting ( PHANTOM_OUTLINE in this example). The circle color follows the hole layer color, and the slot symbol color follows the phantom layer color.

SLOT_TYPE_7

No hole symbol is created. The slot symbol is created according to the selected phantom setting ( PHANTOM_OUTLINE in this example). The slot color follows the slot layer color.

Create tube NC files

You can create NC files for tubular hollow sections. You first need to use specific tube components to create the connections.

Create the following tube-to-tube and tube-to-plate connections:

After using the components, you can create an NC file for data export. The tube NC file creation results into an XML file which includes the model data.

Limitations:

To get the correct tube NC export results, note the following limitations:

  • Line cuts and fittings created manually or by other components will be exported as simple chamfers.

  • Holes created by bolts are not supported, and they will not be exported.

  • Curved beams are not supported.

  1. On the File menu, click Export > Tube NC files.
  2. In the Tube NC Files dialog box, enter a name for the export file, and browse for the location where you want to save the file. By default, the file is saved in the model folder.
  3. Select whether you want to create the file for selected parts or for all parts.
  4. Click Create.

    Tekla Structures creates an XML file and a log file in the location you defined.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet