Hello!

Did you know that logged in users can see a lot more content?

Copy objects

Last updated September 10, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2019i

Copy objects

Copy objects

You can copy objects in a number of different ways. When you copy an object, Tekla Structures copies all objects connected to it, including the components.

Copy by picking two points

The basic way to copy objects in a model or drawing is by defining the origin and one or more destination points.

  1. Select the object you want to copy.
  2. Run the Copy command:
    • In the model, on the Edit tab, clickCopy.

    • In the drawing, on the Drawing tab, clickCopy > Copy.

  3. Pick the origin for copying.

  4. Pick one or more destination points.

    The objects are copied immediately. The Copy command remains active.

  5. If you want to undo the latest copy operation, click theUndo button on the top left corner of the Tekla Structures main window.

    The Copy command still remains active.

  6. To stop copying, press Esc.

Copy linearly

In the model, you can create multiple copies of an object in the same linear direction.

  1. Select the objects you want to copy.
  2. On the Edit tab, click Copy special > Linear.

    The Copy - Linear dialog box opens.

  3. Pick two points, or enter the coordinates in the dX , dY , and dZ boxes.

    You can also use a formularule stated in a mathematical language

    Formula is part of an equation.

    to calculate the x, y, and z displacements. For example:

  4. Enter the number of copies.
  5. Click Copy.
  6. To stop copying, press Esc
    Tip:

    If the dialog box is open but the command is no longer active, click the Pick... button to re-activate the command.

Copy by specifying a distance from origin

You can copy objects to a new position in the model or drawing by specifying a distance from the origin. Use the Enter a Numeric Location dialog box to specify the distance.

  1. Select the objects you want to copy.
  2. Run the Copy command:
    • In the model, on the Edit tab, clickCopy.

    • In the drawing, on the Drawing tab, clickCopy > Copy.

  3. Pick the origin for copying.
  4. Move the cursor in the direction you want to copy the objects, but do not pick the point.
  5. Type the distance.

    When you start typing, Tekla Structures displays the Enter a Numeric Location dialog box automatically.

  6. Click OK.

Copy using drag-and-drop

You can copy objects by using drag-and-drop.

  1. On the File menu, click Settings and select the Drag & drop check box to activate the command.
  2. Select the objects you want to copy.

  3. Hold down the Ctrl key and drag the objects to a new location.

    The point you start dragging from (center, corner, or middle point) affects the object's alignment in the new location.

    Tekla Structures copies the objects:

Note:

To copy gridmodeling aid that represents a three-dimensional complex of horizontal and vertical planes

In Tekla Structures, grids are used as an aid in locating objects in a model. The grid is shown on the view plane by dash-and-dot lines. It is also possible to show grids and grid line labels in drawings, and to modify grid properties in the drawings.

It is possible to have more than one grid in a model. For example, a large-scale grid for the entire structure, and smaller grids for some detailed sections.

labels in a drawing, first select the grid labelname of a grid line

and then either activate theSelect grid line selection switch or select the grid label handle.

Copy objects to another object

In the model, you can copy objects from an object to other similar objects. This is useful, for example, when you detail previously modeled parts. The objects that you can copy between can have different dimensions, length, and rotation.

  1. Select the objects you want to copy.
  2. On the Edit tab, clickCopy special > To another object.
  3. Select the object to copy from (source object).
  4. Select the objects to copy to (target object).

Copy all content to another object

In the model, you can copy objects from an assembly or cast unit to other similar assemblies or cast units without individually selecting each object to copy. This is useful, for example, when you have detailed an assembly and want to copy all details to another similar assembly.

  1. Ensure that theSelect assemblies selection switch is active.
  2. Select the assembly or cast unit to copy from (source object).
  3. On the Edit tab, click Copy special > All content to another object.
  4. Select the assemblies or cast units to copy to (target objects).

As a result, Tekla Structures copies the following objects:

  • Secondary parts
  • Reinforcement, bolts, and welds
  • Cuts, fittings, and edge chamfers
  • Sub-assemblies
  • Components
Note:

Tekla Structures does not copy pour breaks, or secondary parts created by a component that has also created the assembly main partmain part that exists in an assembly

The assembly main part in a steel assembly may have other parts welded or bolted to it. By default, the assembly main part is not welded or bolted to any other parts.

The user can change the assembly main part.

. If some of the objects to be copied already exist in the assembly or cast unit to copy to, Tekla Structures may create duplicate objects. Tekla Structures warns you about duplicate secondary parts, reinforcement, and sub-assemblies, but not about duplicate bolts, welds, cuts, or components.

Copy to another plane

In the model, you can copy objects from the first plane you specify to the second (and third, etc.) plane you specify. The position of the copied objects relative to the second (and third, etc.) plane remains the same as the position of the original objects relative to the first plane.

  1. Select the objects you want to copy.
  2. On the Edit tab, click Copy special > To another plane.
  3. Pick the point of origincenter of the coordinate system where the axes intersect and form a fixed point of reference for the geometry of the surrounding space

    of the first plane.
  4. Pick a point on the first plane in the positive x direction.
  5. Pick a point on the first plane in the positive y direction.
  6. Repeat steps 3–5 for all destination planes.

Copy from another model

You can copy objects from another model based on phase numbers. Note that Tekla Structures copies secondary parts from the model only if they belong to the same phase as their main part(1) part that exists in a building object and that determines the position number for the assembly or cast unit and the direction of assembly or cast unit drawings

(1) Main part can be an assembly main part or a cast unit main part.

(2) input part that the user selects first when creating a component

(2) Connections and details always have a component main part.

. This also applies to component objects.

  1. On the Edit tab, click Copy special > From another model.

    The Copy from Model dialog box opens.

  2. In the Model directories list, select the model to copy from.

    This is the source model. Note that the target model must have been created using the same or newer version of Tekla Structures as the source model. You cannot copy from a newer version to an older version.

  3. In the Phase numbers box, enter the numbers of the phases from which to copy objects, separated by spaces.

    For example, 2 7.

  4. Click Copy.
  5. Close the dialog box.
Note:

If you copy pour breaks from another model, the copied pour breaks automatically adapt to the target model. Always check that the copied pour breaks have adapted correctly.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet