Hello!

Did you know that logged in users can see a lot more content?

Environment, company, and project settings for administrators

Last updated March 12, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2019

Environment, company, and project settings for administrators

Environment, company, and project settings for administrators

Environment settings

Common settings

All settings and files that are the same in all environments are located in the \Tekla Structures\<version>\Environments\common folder. Files and settings that are specific to an environment are located in separate environment folders.

The env_global_default.ini file is also located in the \common folder. The file determines the standard settings, and it is the first file that is read. Other initialization files are read after this file, and if the other files contain the same settings, they will override the previous settings.

Country-specific settings

The country-specific settings are located in the environments folders, and they are localized by your local Trimble office/reseller. The folder structure of the environments can vary, but the same kind of settings exist. For example, the settings that are localized include profile database, material database, reports, selection filters, view filters, components and custom components, macros, user-defined attributes, and drawings settings.

Company settings

Company-level settings are mainly settings that are used throughout the company for all projects. These settings are set using XS_SYSTEM and XS_FIRM.

For a larger company with subsidiaries, the settings could be used as follows:

  • XS_SYSTEM may contain multiple paths, and it points to general settingssettings that are used to control the general functions of the software

    For example, autosave interval and mouse settings are general settings in Tekla Structures. General settings can be saved for each model or as a standard file.

    In Tekla Structures, general settings are defined in the Options dialog box.

    inside the company. These can be company logo, reports, printer settings, drawing settingssettings that control what the drawing looks like and what it includes

    Drawing settings can be defined in the modeling mode when creating a drawing, and they can be modified in the drawing mode.

    The range of the objects and elements that drawing settings affect may vary.

    , templates, for example. These are settings that very seldom change, and are stored on a server available for all. For example, if the company logo is updated, it only has to be replaced in one place.
  • XS_FIRM points to the firm folderfolder that is used for storing Tekla Structures-related files customized for a particular organization

    A Tekla Structures user can, for example, customize a company’s cloning templates and save them in a sub-folder located under the firm folder. After this, the customized cloning templates can be used in all projects carried out for the company.

    set up by the company, or a subsidiary. The folder contains all the company settings used at the particular office. These can be logos, drawing settings, templates, reports, or printer settings, for example.
  • XS_PROJECT points to the project folderfolder that is used for storing Tekla Structures-related files customized for a particular project

    . The folder contains project settings, such as logos for contractors and fabricators, or drawing settings, for example.

For more information on the folder search order, see Folder search order.

You can also use Tekla Warehouseservice for collaboration and for storing and sharing Tekla Structures content

In Tekla Warehouse the content items are stored in collections. Tekla Warehouse includes the Tekla Warehouse Service and the Tekla Warehouse web site.

Tekla Warehouse is one of the Tekla online services.

company-specific collections online or offline, in your own network. Use Trimble Identityuser account to Tekla online services and other Trimble services

For a Tekla Structures user, Trimble Identity is a single sign-on account which enables the user’s online identity management. The organization that the user’s Trimble Identity belongs to, determines the user’s access rights. Trimble Identity is needed, for example, for Tekla Campus and Tekla Warehouse, and to log in to Tekla User Assistance.

for downloading or installing from the online collections. See also Trimble Identity for Tekla Online services.

The offline collection access is managed with folder rights in your network, and on the collection level in the collections.json file on each user's computer.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

The collections.json file can be shared to selected persons by copying it to the C:\Users\Public\Documents\Tekla\Tekla Warehouse\ folder.

Model templates

You can save a model with the desired settings and use the model as a template when you create new models. This can be very useful if your company has different kinds of projects, such as, parking garages, office buildings, bridges, and industrial.

When you create a model templatemodel which is used as a basis for creating new models

The user can save a model including all its elements, such as object properties, certain settings, parts, and components, in a model template.

, always start by creating a new empty model. This is because old models that have been used in live projects cannot be completely cleaned. They may contain excess information that increases the size of the model even if you delete all objects and drawings from the model.

To create a model template:

  1. Create a new model and give it a unique name.
  2. Add in the model the desired profiles, custom components, and other necessary items.
  3. On the File menu, click Save as > Save.

    You need to save the model to include custom components in the xslib.db1 file. If you do not save the model, custom components will not be included in the model template.

  4. On the File menu, click Save as > Save as model template.
  5. Enter a name for the model template, and select which catalogs, drawing templates, report templates, and model subfolders you want to include in the model template.
  6. Click OK.

    By default, the model template folder is saved in your environment folder, under ..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\. The exact folder location may vary depending on your environment and role. Use the advanced option XS_​MODEL_​TEMPLATE_​DIRECTORY to define a different location.

You can download, share, and store model templates in Tekla Warehouse. The image below shows an example of a model template in Tekla Warehouse.

The Insert into model button in Tekla Warehouse installs the model template directly in the folder pointed by XS_MODEL_TEMPLATE_DIRECTORY. You can immediately use the template when creating a new model.

Model templates in Tekla Structures version update

We strongly recommend that you update your model templates in Tekla Structures version upgrade.

To update a model template:

  1. Create a new model using an existing model template.
  2. Give the model the same name as in the previous Tekla Structures version.
  3. Open a 3D viewview that displays objects three-dimensionally

    3D view is one of the default views.

    .
  4. On the File menu, click Diagnose and repair > Diagnose model.
  5. On the View tab, click Screenshot > Project thumbnail to create a project thumbnail, or add a custom image named thumbnail.png in the model folderfolder that is used for storing files associated with a model

    Tekla Structures stores all files associated with a model in a folder it creates with the same name as the model database (.db1).

    In multi-user mode all users access the same model folder.

    .

    The preferred size of the image is 120 x 74 pixels.

  6. On the File menu, click Save as > Save.

    If you do not do this, a message may appear warning about the model being created with a previous version.

  7. On the File menu, click Save as > Save as model template.
  8. Select which catalogs, drawing templates, report templates, and model subfolders you want to include in the model template.
  9. Click OK.
  10. Remove manually all *.db files (environment databasedatabase file that contains the definitions of user-defined attributes used in a model

    The file name of the environment database is environment.db.

    , options databasedatabase file that contains the settings of model-specific general settings and advanced options

    There are two options databases, the model options database (options_model.db) and the drawing options database (options_drawings.db).

    files) from the model folder.

    The *.bak , *.log and xs_user files are automatically removed from the model folder.

    Do not remove the .idrm files ( db.idrm and xslib.idrm ) as they are part of the model.

    The model template is saved in a location pointed by XS_MODEL_TEMPLATE_DIRECTORY.

    You now have a sample image for your model template. The Applications & components cataloguser interface for displaying or modifying information in categorized lists

    For example, profile catalog and shape catalog are catalogs.

    is now also in order and easy to use.

Customizing reports and drawings

If your company already has graphical templates in the DXF, DWG, or DGN format, you can convert these templates to Tekla Structures templates. For detailed instructions on how to do this, see the information on AutoCAD and Microstation files in the Template Editortool in Tekla Structures that is used for creating and modifying templates to be used in drawings and reports

Help.

For information on how to create your own templates and reports, see the Template Editor Help, and Reports and Templates.

Cloning templates for drawings

You should consider cloning drawings when:

  • There are several similar parts, assemblies, or cast units in the model.
  • You need to produce single-part, assembly, or cast-unit drawings of similar parts, assemblies, or cast units.
  • The drawings need a lot of manual editing.

For example, you can create a drawing for one truss, edit the drawing, and then clone(performed by Tekla Structures) to create a new drawing by using a cloning template

Cloning aims at using the drawing properties, view properties, and object properties from the cloning template in a new drawing.

Drawings can be cloned from the current model or another model.

Cloned drawings need some manual checking.

it for similar trusses. Then you only need to modify the cloned drawings where the trusses differ.

The cloned drawing may contain more parts than the original drawing. Part properties, marks, associative notes and related text objects are cloned from a similar part in the original drawing.

Clone templates in Master Drawing Catalogcatalog that is used for creating drawings by using master drawings

Master drawing catalog can be used for searching for master drawings usually in the current model and saving the search results.

You can clone drawings by using the Master Drawing Catalog templates. A cloning templatemaster drawing where an existing drawing is used to copy the drawing settings for a new drawing

The new drawing has the same drawing settings as the original drawing.

The user creates a cloning template of a drawing typically after extensive manual modifications have been made in the drawing, in order to achieve the same appearance and contents in new drawings.

In the master drawing catalog, it is possible to create single-part, assembly, and cast unit drawings using cloning templates. It is also possible to add new cloning templates to the master drawing catalog from the document manager.

in the Master Drawing Catalog can also be used in other models. They can be used in projects that have the same kind of drawings.

To create cloning templates:

  1. Select a drawing in Document manager.
  2. Right-click and select Add to Master Drawing Catalog , and then fill in the required properties.

The cloning template can be found under Cloning templates in the Master Drawing Catalog. To use cloning templates in other models, open the Master Drawing Catalog in the model, click the button on the toolbar, and add the model where the templates are saved.

For more information on the Master Drawing Catalog and cloning templates, see Create drawings in Master Drawing Catalog.

Project settings

Create your own component folder

Usually, only a few different connections and components are used in a project. To ensure that everyone in the project uses the same components and finds the components faster, we recommend that you create a component folder of your own.

  1. Click the Applications & components button in the side pane to open the Applications & components catalog.
  2. Create a new group for the project: Right-click in the catalog and select New group.
  3. Add components to the group: Select the components in the catalog, right-click and select Add to group. Then select the group to which the components are added. You can also drag the selected components to another group.
  4. Hide the groups that you do not need: Select the group, right-click and select Hide/Unhide.
Tip:

In the Applications & components catalog, use the commands in Access advanced features > Catalog management to modify catalog definitions. For more information, see Customize the Applications & components catalog and XS_​COMPONENT_​CATALOG_​ALLOW_​SYSTEM_​EDIT.

For more information on the Applications & components catalog, see How to use the Applications & components catalog.

Define project properties

Project information is needed many times during a project. Define the project information at the beginning of a project to make reports and drawings display the correct information automatically. You can also update the project properties during the project.

  1. On the File menu, click Project properties.
  2. Edit the project properties.

    When you edit the properties, Tekla Structures highlights the modified properties in yellow.

  3. When you are ready with the modifications, click Modify to apply the changes.

Create and modify templates and reports

You can modify existing reports and templates, or create your own templates by using Template Editor. To open Template Editor, click File > Editors > Template editor , or double-click an existing table in an open drawing to open the tool. For more information, see Template Editor User's Guide.

Note that if your templates are located in a protected folder, the templates are read-only, and you cannot save a modified template in a protected folder. In this case, run Tekla Structures as an administrator.

Set up printers

Tekla Structures uses Windows drivers to write the print data directly to the Windows print device interface. You can print drawings as PDF files, save them as plot files ( .plt ) for printing with printer/plotter, or print them on a selected printer. To print to several paper sizes, you need to modify the drawingsizes.dat file, see more in Configuration files used in printing. You can also change the line width of the printed drawings, see more in Print to a .pdf file, plot file (.plt) or printer and Line thickness in drawings.

You can affect the way Tekla Structures automatically names the .pdf files and plot files by using certain drawing-type-specific advanced optionssettings used to customize Tekla Structures for specific companies, standards, users, or user groups

In Tekla Structures, advanced options are settings that are used, for example, in a specific project or geographical area, or by a specific company.

In Tekla Structures, advanced options usually begin with the initials XS and are followed by the name of the function, for example XS_BACKGROUND_COLOR.

, see more in Customize print output file names.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
Average page rating: 5 (1 vote)
Refresh page after voting to show updated result.