Hello!

Did you know that logged in users can see a lot more content?

Create a .pdf report template

Last updated March 12, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2019

Create a .pdf report template

Create a .pdf report template

You can create graphical templates to be used for .pdf reports.

  1. On the File menu, select Editors > Template editor.
  2. Select File > New > Graphical template.
  3. Click Edit > Properties.
  4. In Template page properties dialog box, set the page size to match the target page size (for example A4):

    The size must match a size defined in the PaperSizesForDrawings.dat configuration file.

  5. Add new rows and value fields to get the required data from your Tekla Structures database. For more information about adding new rows and value fields, see Create a template.
  6. Click File > Save as , and save the report with the filename extension .pdf.rpt.
  7. Copy the new template to your template folder, such as model or your company settings folder ( XS_FIRM ).

    Now you can create a .pdf report using the new .pdf report templatetemplate that is used for creating a report

    . For more information about creating a report, see Create a report.

Example .pdf report

In this report example, the following page size is used:

Below is an example of a report that has been created using this particular report template. To open the report in a browser, click here.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet