Hello!

Did you know that logged in users can see a lot more content?

Customize the ribbon

Last updated March 12, 2019 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2019

Customize the ribbon

Customize the ribbon

With Ribbon editor you can customize the ribbon according to your needs. You can change the size and shape of any button, for example. You can create user-defined commands, and bring your favorite components and extensions to the ribbon for an easy access.

To open Ribbon editor , click File menu > Settings > Customize > Ribbon .

With Ribbon editor , you can

  • add new buttons to the ribbon
  • move existing buttons on the ribbon
  • resize the buttons on the ribbon
  • change the icons and texts of the buttons
  • remove buttons you do not need
  • create new commands and add buttons for them
  • add separator bars to the ribbon
  • add new tabs
Note:

If you want to customize the modeling ribbon, open Ribbon editor in the modeling modemode that is used for creating and analyzing a model, and initiating the creation of a drawing and a report

Custom component editor and sketch editor can be accessed in modeling mode.

.

If you want to customize the drawing ribbon, open Ribbon editor in the drawing modemode that is used for editing the appearance and content of drawings

Tekla Structures switches to the drawing mode when the user opens any drawing.

.

You can only customize the ribbons that are available in your configuration.

The customized ribbons are saved to ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons folder. If you cannot find the folder, ensure that you are able to view the hidden files and folders on your computer.

Company administrators can distribute the customized ribbons or tabs to the whole organization, in the same way as customized property panecontrol element in Tekla Structures user interface in the form of a side pane window

The property pane can be used to show and modify the properties of model objects.

layouts.

Add a button to the ribbon

You can add buttons simply by selecting a button type and its appearance and then dragging the command to the ribbon or to the Quick Access Toolbar.

To Do this
Add a button for a single command
  1. In the Add ribbon item list, select Simple button.
  2. In the Command list, select the command you want to add to the ribbon.

    You can also add components, macros, and extensions. Browse through the list or use the Search box to filter content. For example, type mesh to find the Create reinforcement mesh command and other mesh related components:

  3. In the Appearance list:
    • Select whether the button has an icon. Select the size of the icon, or whether you want to use a scalable icon, or browse for the icon image.
    • Select whether the button has any text.

  4. Preview shows what the button looks like. Modify the button appearance, if needed.
  5. Drag the button to the ribbon.

    The blue color indicates the place where the button will be inserted.

Add a toggle button that switches a particular command on or off

Use this to add any switch from the File menu > Settings > Switches to the ribbon, for example. You can also add single snap switches and select switches to the ribbon.

  1. In the Add ribbon item list, select Check button.
  2. In the Command list, select a command that can be switched on or off.

    Commands that can be switched on or off have a check box next to them.

  3. In the Appearance list:
    • Select whether the button has an icon. Select the size of the icon, or whether you want to use a scalable icon, or browse for the icon image.
    • Select whether the button has any text.
  4. Preview shows what the button looks like. Modify the button appearance, if needed.
  5. Drag the button to the ribbon.

    The blue color indicates the place where the button will be inserted.

Add a drop-down button with a group of commands underneath it
  1. In the Add ribbon item list, select Drop-down button.
  2. In the Appearance list:
    • Select whether the button has an icon. Browse for the icon image.
    • Select whether the button has any text.
  3. Preview shows what the button looks like. Modify the button appearance, if needed.
  4. Drag the button to the ribbon.

    The button is now an empty placeholder for single commands. You need to add commands to the drop-down button to make it work.

    1. In the Add ribbon item list, select Simple button.
    2. In the Command list, select the command you want to add to the drop-down list.
    3. In the Appearance list, set the appearance of the button.
    4. Drag the button to the drop-down list.

      The blue color indicates the place where the button will be inserted. If you hover over a down arrow, a list will open and you can drag commands to the list. The list will remain open until you click the down arrow again.

    5. Add as many commands as needed to the drop-down button.
Add a button for a single command, plus a drop-down button with a group of commands underneath it
  1. In the Add ribbon item list, select Split button.
  2. In the Command list, select the command you want to add to the ribbon as the main button for the whole split button.
  3. In the Appearance list:
    • Select whether the button has an icon. Select the size of the icon, or whether you want to use a scalable icon, or browse for the icon image.
    • Select whether the button has any text.
  4. Preview shows what the button looks like. Modify the button appearance, if needed.
  5. Drag the button to the ribbon.

    The button now has a single command. You need to add commands to the drop-down list.

    1. In the Add ribbon item list, select Simple button.
    2. In the Command list, select the command you want to add to the drop-down list.
    3. In the Appearance list, set the appearance of the button.
    4. Drag the button to the drop-down list.

      The blue color indicates the place where the button will be inserted. If you hover over a down arrow, a list will open and you can drag commands to the list. The list will remain open until you click the down arrow again.

    5. Add as many commands as needed to the drop-down button.

You can also drag commands to the Quick Access Toolbar , which is located above the ribbon, or to the fixed container on the left side of the ribbon:

Move a button

You can rearrange buttons on the ribbon. Note that you cannot move drop-down buttons underneath each other.

  1. Select the button you want to move.

    The button becomes highlighted:

  2. Drag the button to a new location.

    The blue color indicates the place where the button will be inserted. For example:

Resize a button

You can change the size of existing buttons.

  1. Select the button you want to resize:

  2. Move the mouse pointer over any side or corner of the button to display a white arrow symbol:

  3. Drag with the arrow to define a new size:

    The size of the button changes accordingly. The other buttons are automatically moved forward on the ribbon, if needed.

  4. Double-click the button to expand it.

    The button now fully occupies the empty space around it:

Change the appearance of a button

You can change the appearance of any button.

  1. Select the button you want to modify.
    • If you are adding a new button: select the command in the Command list.

      The current propertiesproperties related to an object type and applied to new objects of this type

      In Tekla Structures, properties related to an object type are activated in the property pane or the dialog box.

      of the button are shown in the Appearance list.

    • If the button already exists on the ribbon: right-click the selected button on the ribbon.

  2. To change the icon, select one of the options:
    1. None : no icon is used for the button
    2. Command: Large icon : the default large icon (32x32) is used
    3. Command: Small icon : the default small icon (16x16) is used
    4. Command: Scalable icon : the scalable vector icon is used
    5. Gallery (bitmap) : select a large or small bitmap icon from the Tekla Structures icon gallery
    6. Gallery (scalable) : select a scalable icon from the Tekla Structures icon gallery
    7. Custom : define a custom icon by selecting a suitable image file. The recommended size is 32x32 pixels for large buttons and 16x16 pixels for small buttons. If you have problems with your custom image not appearing the right size, check the DPI setting of the image file. A DPI of 96 is recommended.
  3. To change the name, select one of the options:
    • None : no name is used for the button
    • Command: Full text : the default full version of the name is used
    • Command: Short text : the default short version of the name is used
    • Custom : enter a custom name for the button

Create a user-defined command with Command editor

You can create user-defined commands and link them to any file or URL. Create the user-defined commands with Command editor.

  1. Click File menu > Settings > Customize > User-defined commands to open Command editor.
  2. Click New.
  3. Enter a unique ID for the command, and then click OK.

    For example, create a link to the Tekla Discussion Forumsite where the users can have discussions and ask questions

    Tekla Discussion Forum has a wish list for sending ideas and wishes.

    Tekla Discussion Forum is one of the Tekla online services.

    . Enter OpenTeklaDiscussionForum as the ID of the command.

    A new column with more properties appears.

  4. In the Full name and Short name boxes, enter a name for the command.

    This name will be visible in the Tekla Structures user interface. You can define two alternative names: a full name and a short version. For example, enter Tekla Discussion Forum as the full name of the command, and Forum as the short version.

  5. In the Large icon , Small icon , and Scalable icon settings, select an icon for the command.

    You can define three alternative icons: a large one and a small one, or a scalable vector icon.

    You can use your own icon or select a suitable icon from the Tekla Structures icon gallery.

  6. In the Tooltip box enter a tooltip for the command.

    For example, enter Go to the Tekla discussion forum.

  7. In the Action box define a file or URL.

    For example, enter https://forum.tekla.com.

  8. In Availability , select the mode where the command will be available.
  9. Click Save to save the new command.
  10. Go to Ribbon editor.
  11. Select the button type.
  12. In the Command list, search for the new command you created.
  13. In the Appearance list, modify the appearance of the button, if needed.
  14. Drag the new button to the ribbon.

  15. To modify a user-defined command, right-click the command on the ribbon and edit the command properties just like for any other command.

Add a separator bar

You can add vertical and horizontal separator bars to divide buttons into smaller groups on the ribbon.

  1. In the Add ribbon item list, select Separator.
  2. In the Appearance list, select whether to add a horizontal or a vertical bar, and the thickness of the bar.

    Preview shows what the separator bar looks like.

  3. Drag the preview item to the ribbon.
  4. To modify the orientation or the line thickness of the bar, right-click the bar on the tab and select Orientation or Thickness.
  5. To delete the bar, select the bar on the ribbon and press Delete on your keyboard.

    Alternatively, right-click the bar on the ribbon and select Delete.

Remove a button

  1. Select the button on the ribbon.
  2. Press Delete on your keyboard.

    Alternatively, right-click the button on the ribbon and select Delete.

Add, hide, and edit tabs

You can add, move and rename ribbon tabs, choose how they are aligned, and hide some tabs if you do not need them in your current project. For example, if you are only modeling steel parts, you can temporarily hide the Concrete tab.

To Do this
Add a new tab
  1. In the Add ribbon item list, select Tab.
  2. Enter a name for the tab in the Text box.
  3. Click Add tab to add it to the ribbon.
Change the order of tabs on the ribbon Drag and drop the tab titles.
Select how the tabs are aligned Right-click in the ribbon area and select one of the Navigation mode options:
  • Scroll visible : the ribbon movement is minimal when you switch between the tabs
  • Align to left : the icons start from the left side of the ribbon
  • Align to tab : the icons start from the left side of the current tab
Hide the tabs that you do not need in your current project
  1. Rest the mouse pointer on a tab title.

    A small eye symbol appears next to the tab title:

  2. Click the eye symbol.

    The eye symbol changes and the tab title becomes gray:

The View tab is now hidden from the ribbon. If you slide the ribbon, hidden tabs appear as:

To re-display the hidden tab, click the eye symbol again.

Rename a tab Right-click the tab and select Rename. Enter a new name for the tab.
Remove a tab

Select the tab and press Delete.

Alternatively, right-click the tab and select Delete.

Save the ribbon

When you are happy with the changes, save the customized ribbon.

  1. In Ribbon editor , click the Save button.
  2. When you return to Tekla Structures and the program asks if you wish to load the new ribbon, click Yes. The ribbon becomes updated with the changes you made.

Check the changes

You can compare the original ribbon with the changes you have made. You can check what has been added and removed, and what has been moved to different tabs.

  1. Save the customized ribbon, if you have not already done so.
  2. Click the Compare button.
  3. In the Compare ribbons dialog box, check the changes you have made.

    For example:

    • Not present : these commands have been removed
    • Moved : these commands have been moved to a new place
    • Customized additions : these commands have been added
    Note:

    Original ribbon refers to the ribbon file that came with the Tekla Structures installation for your current configuration.

  4. If you have removed a command that you would like to get back, drag it from the Compare ribbons dialog box to the ribbon.
  5. When you are finished, click Close.

Back up and restore ribbons

You can restore the default Tekla Structures ribbons at any time. Before restoring the default settings, make sure to save a backup copy of your customized ribbon, because the customizations will be permanently deleted. You can use the backup file to take your customized ribbon back into use, to copy the ribbon settings to another computer, or to share the customized ribbon with your co-workers.

  1. To save a backup copy of the customized ribbon:
    1. In Ribbon editor , click the Save button.
    2. Go to the ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons folder.
    3. Make a copy of the desired ribbon file and save it in another folder.

      The ribbons are named according to the Tekla Structures configurations. For example, in the Full configuration, the name of the Modeling ribbon file is albl_up_Full--main_menu.xml.

  2. Click the Restore button to restore the default Tekla Structures modeling or drawing ribbon.
  3. To take the customized ribbon back into use:
    1. Copy the backup file back to the ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons folder.
    2. When you return to Tekla Structures and the program asks if you wish to load the new ribbon, click Yes. The ribbon becomes updated with the changes you made.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet