Hello!

Did you know that logged in users can see a lot more content?

Take screenshots

Last updated September 10, 2018 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2018i

Take screenshots

Take screenshots

A screenshot is an image of a model or drawing viewview that includes selected model objects or an area in the model, that is represented in a drawing

A drawing view is a container for model and drawing objects.

A drawing can include several drawing views, which usually are two-dimensional views, plane views, to the model.

Examples of drawing views in Tekla Structures include main views, section views, single-part views, and 3D views.

. You can use screenshots in posters, brochures, or other material to show projects carried out using Tekla Structures.

By default, the screenshots are saved in the \screenshots folder under the current modelmodel that is active in Tekla Structures

The current model can be a single-user model, a shared model or a working model.

folder with the name snap_xx.png.

Take a screenshot of a model

You can take screenshots of model views.

  1. Open a model and adjust the model viewview that is represented in the modeling mode

    Model view is available also in the drawing mode and it is represented in its own window.

    according to your needs.

    For example, hide the work area box if you do not want to show it.

  2. On the View tab, click Screenshot > Screenshot.
  3. If you have multiple views of the model, click Pick view and select the view to take the screenshot from.
  4. To modify the settings, click Options.
    1. Define the width, height, and DPI of the screenshot.
    2. Click OK to save the changes.
  5. Define a name and location for the screenshot.
    1. Select Print to file and enter a descriptive name for the screenshot in the File name box.

      You can also change the whole path. If you do not want to do this, you can keep the default values for the path and the file name.

  6. Click Show with associated viewer to show the screenshot in an applicationpart of Tekla Structures functionality that is developed in order to extend the capability of Tekla Structures but that is not included in the Tekla Structures installation

    that is by default associated with this file type.
  7. Click Capture.

Take a screenshot of a drawing

A drawing screenshot is an image of an open drawing with or without borders.

  1. Open a drawing and adjust the drawing view according to your needs.

    For example, delete unnecessary marks or dimensions, and hide unnecessary parts.

  2. On the Views tab, clickScreenshot > Screenshot.
  3. Do one of the following:
    • Select View to take a screenshot of the open drawing with window borders

    • Select View without borders to take a screenshot of the open drawing without window borders.

  4. Under the preselected Print to file option enter a descriptive name for the screenshot in the File name box.

    You can also change the whole path. If you do not want to do this, you can keep the default values for the path and the file name.

  5. Click Show with associated viewer to show the screenshot in an application that is by default associated with this file type.
  6. Click Capture.

Save a screenshot in bitmap format

By default, screenshots are created as Portable Network Graphics ( .png ) files. You can also save a screenshot in bitmap ( .bmp ) format to use it, for example, as a custom componentcomponent that the user creates and uses for creating model objects whose composition the user can modify as a group

thumbnail. Note that the bitmap file size is much larger than when saving as PNG.

  1. On the Views tab, clickScreenshot > Screenshot.
  2. Select Place on clipboard.
  3. Click Capture.
  4. Paste the screenshot in your graphics editor and save it in .bmp format.
Note:

The software that you use to open the screenshot may have a limit for the number of pixels.

Screenshot settings

Use the Screenshot dialog box to view and modify the screenshot settings.

The following options are available in model views and in drawings.

Option

Description

View name

Shows the selected view name.

View

Includes the view content and window borders in the screenshot.

Not available in model views.

View without borders

Includes only the view content in the screenshot.

Not available in model views.

Rendered view

For high resolution screenshots from model views. The Options button displays the Screenshot Options dialog box.

Not available in drawings.

Place on clipboard

Places the screenshot on the clipboard.

Not available in drawings.

Print to file

Saves the screenshot to a file.

The following screenshot options are only available in model views:

Option

Description

Final width

The width of the screenshot.

The units depend on the settings in File menu > Settings > Options > Units and decimals .

Final height

The height of the screenshot.

The units depend on the settings in File menu > Settings > Options > Units and decimals .

DPI

The pixel density (DPI) of the screenshot.

There are limitations to pixel density. You can change the DPI using a graphics editor.

White background

Uses white background.

Smooth lines

Uses smooth lines to decrease jagged edges.

Line width

Sets the line width.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
Average page rating: 5 (1 vote)
Refresh page after voting to show updated result.