Hello!

Did you know that logged in users can see a lot more content?

Zoom and rotate the model

Last updated September 10, 2018 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2018i

Zoom and rotate the model

Zoom and rotate the model

The commands on the View tab allow you to focus on a particular area, or pull out for a wider view. You can use a mouse, command, keyboard shortcut, or a combination of these.

Zoom in and out

You can use a variety of tools to zoom in and out in the model. By default, the mouse pointer position determines the center point of zooming.

To

Do this

Zoom in

Scroll forward with the mouse wheel.

Alternatively, press Page Up.

Zoom out

Scroll backward with the mouse wheel.

Alternatively, press Page Down.

Zoom to selected objects

  1. Select the objects.

  2. On the View tab, clickZoom > Zoom selected.

Zoom with menu commands

On the View tab, clickZoom and select one of the zoom commands.

Keep the center point of zooming in the middle of the view

On the File menu, click Settings and select Centered zooms.

Define the zoom ratio

Use these advanced options:

XS_ZOOM_STEP_RATIO

XS_ZOOM_STEP_RATIO_IN_MOUSEWHEEL_MODE

XS_ZOOM_STEP_RATIO_IN_SCROLL_MODE

Rotate the model

You can use either the middle or left mouse button, or keyboard, to rotate the model in a view.

To

Do this

Rotate using the middle mouse button

  1. On the View tab, clickNavigate > Set view point.

    You can also press V.

  2. To set the view point, pick a position in the view.

    The following symbol appears in the model:

  3. Hold down the Ctrl key, and click and drag the model with the middle mouse button.

    Tekla Structures rotates the model around the view point you defined in step 2.

Rotate using the left mouse button

  1. On the View tab, clickNavigate > Rotate with mouse.

    You can also press Ctrl+R.

  2. To set the view point, pick a position in the view.

    The following symbol appears in the model:

  3. Click and drag the model with the left mouse button.

    Tekla Structures rotates the model around the view point you defined in step 2.

Rotate using keyboard

Use the keyboard shortcuts Ctrl+arrow keys and Shift+arrow keys.

Ctrl+arrow keys rotates the model in 15 degree increments.

Shift+arrow keys rotates the model in 5 degree increments.

Pan the model

You can use either the middle or left mouse button to pan the model in a view.

To

Do this

Move the model using the middle mouse button

  1. On the File menu, click Settings and check that the Middle button pan check box is selected.

  2. Hold down the middle mouse button and drag the model.

Move the model using the left mouse button

  1. To activate dynamic panning, go to the View tab and click Navigate > Pan.

    You can also press P.

    The mouse pointer changes to a hand:

  2. Hold down the left mouse button and drag the model.

  3. To stop panning, press Esc.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
Average page rating: 5 (1 vote)
Refresh page after voting to show updated result.