Hello!

Did you know that logged in users can see a lot more content?

New DWG/DXF drawing export

Last updated April 17, 2018 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2017i

New DWG/DXF drawing export

New DWG/DXF drawing export

You can now export Tekla Structures drawings to 2D DWG and DXF format using the new DWG export. You can export several drawings at a time.

The new DWG/DXF export is object based and not line based. In the new DWG export, if you export a rectangular part that is drawn using hidden line types, the result is a rectangular object drawn with a dashed line. In the old line-based DWG export, the result would be many separate short straight lines. Now hatches are also exported as hatch objects in CAD and not separate lines.

In the new DWG/DXF export you can:

  • easily set layers for different objects, and separate mark frames from mark text and leader lines, for example

  • separate different parts from another by using filters

  • use layers that have been predefined by standard CAD layer settings

  • use base points and model coordinates

  • embedbuilding object that represents an object that is to be cast into a concrete structure and that is used to connect structures or as an aid when constructing a structure

    For example, a cast-in socket is an embed that is placed in concrete structures to allow parts to be bolted together on site. In Tekla Structures, embeds are modeled as steel sub-assemblies that are inside a concrete nested assembly.

    images in the export file so that the images are no longer exported as links

You can start the export from:

  • the model File menu by clicking Export > Drawings , and selecting the drawings from the displayed Drawing List

  • the Drawing List by selecting the drawings that you want to export, right-clicking and selecting Export

  • the drawing File menu when a drawing is open by clicking Export drawings

Options tab:

 

  • You can pick another drawing from the list at the top. Click Refresh preview for the drawing preview.

  • You can export drawings to DWG and DXF, and define the DWG version to be used in the export.

  • By default, the files are exported to the \PlotFiles folder under the current modelmodel that is active in Tekla Structures

    The current model can be a single-user model, a shared model or a working model.

    folder, but you can change the file location.

  • You can define a specific prefix or suffix to be used in the file name.

  • The DWG export supports the following drawing-specific advanced optionssettings used to customize Tekla Structures for specific companies, standards, users, or user groups

    In Tekla Structures, advanced options are settings that are used, for example, in a specific project or geographical area, or by a specific company.

    In Tekla Structures, advanced options usually begin with the initials XS and are followed by the name of the function, for example XS_BACKGROUND_COLOR.

    , which you can use to modify the name of the exported file:

    XS_DRAWING_PLOT_FILE_NAME_A

    XS_DRAWING_PLOT_FILE_NAME_C

    XS_DRAWING_PLOT_FILE_NAME_G

    XS_DRAWING_PLOT_FILE_NAME_M

    XS_DRAWING_PLOT_FILE_NAME_W

    For more information about the values that you can give to these options, see Customize print output file names.

  • Embed images inside the file embeds all images inside the export file. No extra image files are created in the export.

  • Drawing as snapshot to CAD model space exports all included objects to the model space and paper space of a CAD file. Model and global coordinates and paper space switch in the layer settings will be ignored.

  • Define the scale for the exported DWG in the Scale box, which is only available if you have selected the Drawing as snapshot to CAD model space check box.

    For example, if you have a drawing between the coordinates 0,0 and 800, and you define a scale value 5, the resulting DWG is 5 times bigger, and the DWG is located between the coordinates 0,0 and 4000.

    In another example, if you have set the drawing viewview that includes selected model objects or an area in the model, that is represented in a drawing

    A drawing view is a container for model and drawing objects.

    A drawing can include several drawing views, which usually are two-dimensional views, plane views, to the model.

    Examples of drawing views in Tekla Structures include main views, section views, single-part views, and 3D views.

    scale in Tekla Structures to 1:50 and wish to export the drawing in 1:1 scale, using export option scale value 50 will produce the desired result.

    If you set the advanced option XS_EXPORT_DRAWING_TRY_TO_KEEP_LOCATION to TRUE , Tekla Structures tries to keep the DWG origin in the same position as the drawing view origin. This can only be done in plan views and elevation views. If the drawing has more than one plan view or elevation view, Tekla Structures places the DWG origin in the bottom-left corner of the drawing frame.

  • If you select Ungroup objects in blocks , graphical objects are exported as individual objects, not added to blocks. For example, a line, hatch and rectangle will be a DWG object line, hatch and rectangle, rather than a block. When this option is selected, the option Update Tekla Structures linework only is disabled.

  • In Model space coordinates , select one of the following:

    • Local : export to the 0 point in the CAD coordinate system
    • Model : align Tekla Structures the 0 point with CAD 0 point and rotate the CAD coordinate system accordingly in X and Y coordinates
    • Base point : match the selected base points with CAD 0 point, and rotate the CAD coordinate system accordingly
  • Update Tekla Structures linework only updates the Tekla Structures drawing content and keeps other content that is created in a CAD software intact in the same file. Blocks (groups), created by Tekla Structures will be updated.

    This setting is shown if you have set the advanced option XS_DWG_EXPORT_UPDATE_TS_LINEWORK_OPTION to TRUE in the Export category in the Advanced Options dialog box.

  • For more information and details about DWG export settings on the Options tab, see Export a drawing to a 2D DWG or DXF file.

Layer rules tab:

  • On the Layer rules tab, you can define explicitly the layers where different model and drawing objects, or parts of objects are exported to. For example, you can separate outline from fills and hatches.

    You can also define here whether the line color, style and weight will be used from Tekla Structures settings or from the specified DWG template layer settings. Note that Tekla Structures line weight, style and colors stay as you see them in the Tekla Structures drawing, and there is no functionality to modify them just for the DWG export.

  • For more information and details about layer rules and options on the Layer rules tab, see Export a drawing to a 2D DWG or DXF file.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our documentation.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet

Comments

by Piotr Puchała

I've got a problem while exporting to dwg. In dwg views are placed in such a way that they clash with each other. Is there any way to solve this issue?

by Päivi from Tekla User Assistance

Hi,
Sorry to hear that you are having problems. Please contact your local Tekla Structures support for assistance. They need to know the version you are working with and may need to have your model as well.
Hope that your problem will be solved as soon as possible.

Best regards,
Päivi from User Assistance