2017 Table of Contents

Edit tables in Template Editor

Last updated March 6, 2017 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2017

Edit tables in Template Editor

Edit tables in Template Editor

If you need to edit a table in a drawing layoutplan of a drawing that includes the table layout and definitions of the sheet size

Tekla Structures includes several predefined drawing layouts, which are drawing-type specific. The user can also create new drawing layouts.

, you can open it in Template Editortool in Tekla Structures that is used for creating and modifying templates to be used in drawings and reports

(TplEdtool in Tekla Structures that is used for creating and modifying templates to be used in drawings and reports

). In Template Editor, drawing layout tables are called templates.

You can only open tables with templates created or saved in Template Editor version 3.2. or later.

If your templates are located in a protected folder, the templates are read-only, because you cannot save a modified template in a protected folder if you are not an administrator. In this case, run Tekla Structures as administrator.

  1. In a drawing, double-click the table you want to modify.
  2. Tekla Structures shows the following message:

    You are about to edit this template.

    To apply the changes in this drawing, save the template after editing and reopen the drawing.

    Please note that this change will be applied in all drawings that have this template in the drawing layout definition.

    Do you want to edit this template in Template Editor?

  3. Click Yes. Tekla Structures starts the Template Editor, and the selected template is displayed.
  4. Modify the template and save the changes by selecting File > Save , or Save as to use another folder, for example model folderfolder that is used for storing files associated with a model

    Tekla Structures stores all files associated with a model in a folder it creates with the same name as the model database (.db1).

    In multi-user mode all users access the same model folder.

    .

For more information about the Template Editor, see Template Editor User's Guide.

The example below illustrates how a table looks in a drawing and in Template Editor. In this example, there is a revision table and a title block. The revision table is located above the title block and bound to the title block in the layout.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet