Hello!

Did you know that logged in users can see a lot more content?

Move objects

Added August 31, 2016 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2016i

Move objects

Move objects

You can move objects in a number of different ways, especially in models. When you move an objects, Tekla Structures also copies all objects connected to it.

Move by picking two points

The basic way to move objects in a model or drawing is by defining the origin and one or more destination points.

  1. Select the object you want to move.

  2. Run the Move command:
    • In the model, on the Edit tab, clickMove.

    • In the drawing, on the Drawing tab, clickMove > Move

  3. Pick the origin for moving.

  4. Pick the destination point.

    The object is moved immediately. The Move command does not remain active.

Move linearly

You can move objects linearly to a new position in the model.

  1. Select the objects you want to move.
  2. On the Edit tab, clickMove special > Linear.

    The Move - Linear dialog box opens.

  3. Pick two points in the model, or enter the coordinates in the dX , dY , and dZ boxes.

    You can also use a formularule stated in a mathematical language

    Formula is part of an equation.

    to calculate the x, y, and z displacements. For example:

  4. Click Move.
Tip:

If the dialog box is open but the command is not active anymore, click the Pick button to re-activate the command.

Move by specifying a distance from origin

You can move objects to a new position in the model or drawing by specifying a distance from the origin. Use the Enter a Numeric Location dialog box to specify the distance.

  1. Select the objects you want to move.
  2. Run the Move command:
    • In the model, on the Edit tab, clickMove.

    • In the drawing, on the Drawing tab, clickMove > Move.

  3. Pick the origin for moving.
  4. Move the cursor in the direction you want to move the objects, but do not pick the point.
  5. Type the distance.

    When you start typing, Tekla Structures displays the Enter a Numeric Location dialog box automatically.

  6. Click OK.

Move using drag-and-drop

You can move objects by dragging them to a new location.

  1. On the File menu, click Settings and select the Drag & drop check box to activate the command.
  2. Select the objects you want to move.

  3. Drag the objects to a new location.

    The point you start dragging from (center, corner, or middle point) affects the object's alignment in the new location.

    The objects are moved immediately.

  4. To move an end point using drag-and-drop:
    1. Select the handle.
    2. Hold down the left mouse button, and drag the handle to a new location.

      The end point is moved accordingly:

    Note:

    For some objects, you may need to switch on Smart select to drag from handles without selecting them first. To switch it on, click File menu > Settings and select the Smart select check box.

    Note:

    To move gridmodeling aid that represents a three-dimensional complex of horizontal and vertical planes

    In Tekla Structures, grids are used as an aid in locating objects in a model. The grid is shown on the view plane by dash-and-dot lines. It is also possible to show grids and grid line labels in drawings, and to modify grid properties in the drawings.

    It is possible to have more than one grid in a model. For example, a large-scale grid for the entire structure, and smaller grids for some detailed sections.

    labels in a drawing, first select the grid labelname of a grid line

    and then either activate the Select grid line selection switchswitch used for controlling which object types can be selected

    or select the grid label handle.

Move to another plane

In a model, you can move objects from the first plane you specify to another plane, which you specify by picking three points. The moved objects remain in the same position on the second plane as the original objects on the first plane.

  1. Select the objects you want to move.
  2. On the Edit tab, click Move special > To another plane .
  3. Pick the point of origincenter of the coordinate system where the axes intersect and form a fixed point of reference for the geometry of the surrounding space

    of the first plane.
  4. Pick a point on the first plane in the positive x direction.
  5. Pick a point on the first plane in the positive y direction.
  6. Repeat steps 3–5 for the destination plane.

Move objects to another object

In a model, you can move objects from an object to other, similar objects. This is useful, for example, when you detail previously modeled parts. The objects that you move between can have different dimensions, length, and rotation.

  1. Select the objects you want to move.
  2. On the Edit tab, clickMove special > To another object.
  3. Select the object to move from (source object).
  4. Select the objects to move to (target object).

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
No votes yet