Hello!

Did you know that logged in users can see a lot more content?

Customize the ribbon

Last updated December 23, 2016 by Tekla User Assistance tekla.documentation@trimble.com

Software version: 
2016i

Customize the ribbon

Customize the ribbon

In Tekla Structures 2016i, you can customize the ribbon according to your needs. You can change the size and shape of any command button, for example. You can add custom buttons and assign commands to them. You can also bring your favorite components and extensions to the ribbon for an easy access.

To open the customization tool, click File menu > Settings > Customize > Ribbon.

The tool includes two editing modes:

  • Simple mode: Add, move, and resize command buttons; add, hide, and edit tabs; remove command buttons and tabs from the ribbon.
  • Design mode: Choose which name and icon is used for each command button; add new buttons and assign commands to them; add vertical and horizontal separator bars.

Add a command button

You can add command buttons simply by dragging commands to the ribbon or to the Quick Access Toolbar.

  1. Ensure that Simple mode is switched on.
  2. In the Select ribbon list, select which ribbon you want to customize.

    For example:

    You can only customize ribbons that are available in your configuration.

  3. Search for the command you want to add.

    You can also add components, macros, and extensions. Browse through the lists or use the Search box to filter content. For example, type meshreinforcement that represents a mesh of steel bars in two perpendicular directions

    In Tekla Structures, the reinforcement mesh bars in one direction are called main bars and reinforcement mesh bars perpendicular to them are called crossing bars.

    to find the Create reinforcing mesh command and other mesh related components:

    • User-defined: commands that you have created on the User-defined commands tab
    • Tekla Structures: all the Tekla Structures commands available in this configuration and mode
    • Applications & components: components, macros, plugins, and extensions
  4. Drag and drop the command to the ribbon.

    The blue color indicates the place where the command button will be inserted. For example:

    Note:

    If you hover over a down arrow, a list will open and you can drag commands to the list. The list will remain open until you click the down arrow again.

    You can also drag commands to the Quick Access Toolbar, which is located above the ribbon, or to the fixed container on the left side of the ribbon:

  5. To remove a command button, select it and press Delete.

Move a command button

You can rearrange command buttons on the ribbon. Note that you cannot move drop-down buttons underneath each other.

  1. Select the command button you want to move.

    The command button becomes highlighted:

  2. Drag and drop the command button to a new location.

    The blue color indicates the place where the command button will be inserted. For example:

Resize a command button

You can change the size of existing command buttons.

  1. Select the command button you want to resize:

  2. Move the mouse pointer over any side or corner of the command button to display a white arrow symbol:

  3. Drag with the arrow to define a new size:

    The size of the command button changes accordingly. The other command buttons are automatically moved forward on the ribbon, if needed.

  4. Double-click the command button to expand it.

    The command button now fully occupies the empty space around it:

Change the appearance of a command button

You can change the appearance of any command button in the Design mode.

  1. Ensure that Design mode is switched on.
  2. Select the command button you want to modify.

    The current propertiesproperties related to an object type and applied to new objects of this type

    In Tekla Structures, properties related to an object type are activated in the property pane or the dialog box.

    of the command button are displayed.

  3. To change the name, select one of the options:
    • None: no name is used for the command button
    • Short name: the default short version of the name is used
    • Full name: the default full version of the name is used
    • Custom: enter a custom name for the command button
  4. To change the icon, select one of the options:
    1. None: no icon is used for the command button
    2. Large icon: the default large icon (32x32) is used
    3. Small icon: the default small icon (16x16) is used
    4. Gallery: select an icon from the Tekla Structures icon gallery
    5. Custom: define a custom icon by selecting a suitable image file. The recommended size is 32x32 pixels for large buttons and 16x16 pixels for small buttons.
Tip:

When you modify a command button which is on a drop-down list, the options may become hidden behind the drop-down list. Slide the ribbon right or left to make the options visible.

Create a user-defined command

You can create user-defined commands and link them to any file or URL.

  1. Go to the User-defined commands tab.
  2. Click Add.
  3. Enter a unique ID for the command, and then click Create.

    For example, let's assume you are creating a link to the Tekla Discussion Forumsite where the users can have discussions and ask questions

    Tekla Discussion Forum has a wish list for sending ideas and wishes.

    Tekla Discussion Forum is one of the Tekla online services.

    . Enter OpenTeklaDiscussionForum as the ID of the command.

    A new page with more properties appears.

  4. Click Action and define a file or URL. For example, enter https://forum.tekla.com.
  5. Click Name and enter a name for the command. This name will be visible in the Tekla Structures user interface. You can define two alternative names: a full name and a short version. For example, enter Tekla Discussion Forum as the full name of the command, and Forum as the short version.
  6. Click Icon and select a suitable icon from the Tekla Structures image gallery. You can define two alternative icons: a large one and a small one.
  7. Click Tooltip and enter a tooltip for the command. For example, enter Go to the Tekla discussion forum.
  8. Click Apply to save the new command.
  9. Go to the Edit ribbons tab.

    The command you created is available in the User-defined list, on the left-hand side of the dialog box:

  10. Drag and drop the command to the ribbon:

  11. To modify a user-defined command, switch to the Design mode and edit the command properties just like for any other command.

Add a custom button and assign a command to it

You can add new buttons, split buttons, toggle buttons, and drop-down buttons to the ribbon. These are all empty placeholders for commands. After creating a new button, you can assign a command to it.

  1. Ensure that Design mode is switched on.
  2. On the Edit ribbons tab, click the desired button type to select it:

    • Basic: Add a button for a single command.
    • Toggle: Add a toggle button that switches a particular command on or off. Use this to add any switch from the File menu > Settings > Switches to the ribbon, for example.
    • Drop-down: Add a drop-down button with a group of commands underneath it. You can define a name and a custom tooltip for the button.
    • Split: Add a button for a single command, plus a drop-down button with a group of commands underneath it.
  3. Using the mouse, draw a rectangular area for the new button.

  4. To assign a command to the button:
    1. Ensure that the new button is selected.
    2. On the Command tab, search for the command you want to add.

      Browse through the lists or use the Search box to filter content. For example:

    3. Click Assign this command. The command is now assigned to the button.
    4. On the Appearance tab, modify the command's name and icon, if needed.
  5. To add commands to a drop-down button:
    1. Return to the Simple mode.
    2. Search for commands.
    3. Drag and drop commands to the drop-down button.

      If you hover over a down arrow, a list will open and you can drag commands to the list. The list will remain open until you click the down arrow again.

Add a separator bar

You can add vertical and horizontal separator bars to divide command buttons into smaller groups on the ribbon.

  1. Ensure that Design mode is switched on.
  2. Click Separator to select it.

  3. Using the mouse, draw a rectangular area in the vertical direction.

    A vertical bar appears in the location you defined.

  4. Ensure that the bar is selected.
  5. Modify the orientation and line thickness of the bar, if needed.

Add, hide, and edit tabs

You can add, move and rename ribbon tabs, choose how they are aligned, and hide some tabs if you do not need them in your current project. For example, if you are only modeling steel parts, you can temporarily hide the Concrete tab.

  1. Ensure that Simple mode is switched on.
  2. To add a new tab, click the plus signat the end of the tab row.
  3. To rename a tab:
    1. Right-click a tab title and select Rename.
    2. Type a new name.
    3. Press Enter to save the new name.
  4. To change the order of tabs on the ribbon, drag and drop the tab titles.
  5. To change how the tabs are aligned, clickand then select one of the options:
    • Scroll visible : the ribbon movement is minimal when you switch between the tabs
    • Align to left : the icons start from the left side of the ribbon
    • Align to tab : the icons start from the left side of the current tab
  6. To hide the tabs that you do not need in your current project:
    1. Rest the mouse pointer on a tab title.

      A small eye symbol appears next to the tab title:

    2. Click the eye symbol.

      The eye symbol changes and the tab title becomes gray:

      The View tab is now hidden from the ribbon. If you slide the ribbon, hidden tabs appear as:

    3. To re-display the hidden tab, click the eye symbol again.
  7. To remove a tab, select it and press Delete.

Save the ribbon

When you are happy with the changes, save the customized ribbon.

  1. On the Edit ribbons tab, click the Save button.

  2. When you return to Tekla Structures and the program asks if you wish to load the new ribbon, click Yes. The ribbon becomes updated with the changes you made.

Check the changes

You can compare the original ribbon with the changes you have made. You can check what has been added and removed, and what has been moved to different tabs.

  1. Save the customized ribbon, if you have not already done so.
  2. Click Compare.
  3. In the Compare ribbons dialog box, check the changes you have made.

    For example:

    • First list: these commands have been removed
    • Second list: these commands have been moved to a new place
    • Third list: these commands have been added
    Note:

    Original ribbon refers to the ribbon file that came with the Tekla Structures installation for your current configuration.

  4. If you have removed a command that you would like to get back, drag it from the Compare ribbons dialog box to the ribbon.
  5. When you are finished, click Close.

Back up and restore ribbons

You can restore the default Tekla Structures ribbons at any time. Before restoring the default settings, make sure to save a backup copy of your customized ribbon, because the customizations will be permanently deleted. You can use the backup file to take your customized ribbon back into use, to copy the ribbon settings to another computer, or to share the customized ribbon with your co-workers.

  1. To save a backup copy of the customized ribbon:
    1. On the Edit ribbons tab, click the Save button.

    2. Go to the ..\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\UI\Ribbons folder.
    3. Make a copy of the desired ribbon file and save it in another folder.

      The ribbons are named according to the Tekla Structures configurations. For example, in the Full configuration, the name of the Modeling ribbon file is albl_up_Full--main_menu.xml.

  2. To restore the default Tekla Structures ribbons:
    1. In the Select ribbon list, select which ribbon you want to restore.

      For example:

    2. Click Reset to defaults. The default Tekla Structures ribbons are now in use.
  3. To take the customized ribbon back into use:
    1. Copy the backup file back to the ..\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\UI\Ribbons folder.
    2. When you return to Tekla Structures and the program asks if you wish to load the new ribbon, click Yes. The ribbon becomes updated with the changes you made.

Quick feedback

The feedback you give here is not visible to other users. We use your comments to improve our content.
We use this to prevent automated spam submissions.
Content rating: 
Average page rating: 1.5 (19 votes)
Refresh page after voting to show updated result.

Comments

by Patrick Helldén

Hi, As an administrator for Tekla in COWI ( approx 80 licenses ) I see a big problem on having the XML file for the "COWI-ribbon" placed in the user branch on C:. A scenario is that I would like to have a "firm" ribbon place. I´d like to be able to place my part of the ribbon under XS_FIRM as an complement to the user placement on c:\users\....
That way I can make company/project changes to our installation or alter the ribbon in the meanwhile.

To place the ribbon under C:\users means that the user can alter the ribbon but me as an Admin has no chance at all to make any company specific alternations.

So keep the user ribbon alternativ and ADD an Admin atlernativ via XS_FIRM and XS_PROJECT.

PAtrick Helldén

by Liisa Kause

Thank you for bringing this case out clearly, a very valid use case. To be sure I understood correctly, would adding one or more custom tabs from firm folder to users' ribbon be what you are after?

by Josh Luker

I agree with the original comment. It would be beneficial to be able to maintain a separate XML ribbon file that contains company-specific buttons and commands, and placing that file(s) in FIRM would automatically load and merge it into the main Tekla ribbon. That would be the only way to efficiently manage my customizations and easily make them available across our company.

I think the Ribbon Customization UI would need an export option of some sort that would create the XML files for only selected Tabs and associated Commands in order to filter what goes into the definition xml

by Liisa Kause

Hello, thank you for elaborating on this idea. Let's continue the discussion in the Tekla Discussion Forum. I will check if there is an item about it in the Feature wish list. I do know that it has been commented in the general discussion.

by Daniel D'hondt

Hi, I've added a custom component to the ribbon. But what doesn't work is opening the properties dialog box when holding down shift and clicking the command. It seems to work for Tekla components/macro's, but not for custom components.
Is there a way to make it work?

by Päivi from Tekla User Assistance

Hi,
Thank you for your question. We will have a look at this, and get back to you.

Best regards,
Päivi

by Anna from User Assistance

Hi Daniel,

I apologise for the delay in responding. Unfortunately, this functionality does not work quite the same way for custom component dialog boxes. You can contact your local Tekla Structures support for any further assistance and to make a feature request regarding this.

Best regards,
Anna

by Robin Vondrak

I am able to see some macros that we have created inside of the applications and components area but i'm unable to find them in my customize ribbon area, any idea why?

Thanks,
Robin

by Anna from User Assistance

Thank you for your question. We'll investigate this and get back to you as soon as possible.

Best regards,
Anna

by Anna from User Assistance

Hi Robin,

Here are some tips on how to troubleshoot the issue:

Tekla Structures passes a snapshot list of the available macros to the ribbon customizer when launched. Is it possible that you refreshed the macro list while the ribbon customizer was still open (and thus it has an outdated list of the macros)? Please also notice that it matters whether Tekla Structures is in the modeling or drawing mode when you launch the ribbon customizer; the list of macros is dynamic and it kind of changes every time you switch from modeling to drawing (and vice versa), so you should re-launch the ribbon customizer if you change the mode in Tekla Structures. In general, the ribbon customizer should see the same list of macros that you can find using the Quick Launch search. Please check whether the macro you're looking for is found in Quick Launch.

Best regards,
Anna